Intersoft WebDesktop

Intersoft WebDesktop Documentation
Intersoft WebDesktop
Send Feedback

Glossary Item Box

IntersoftWebDesktop is the first comprehensive desktop user interface design suite that streamlines development so far, that even a sole developer can deliver rich, line-of-business web applications in a timely, cost effective manner. It delivers pure desktop experiences to the web with stunning UI controls.

Introducing the new WebDesktop, it's redesigned from the ground up to support the latest web standards such as HTML5 and CSS3. WebDesktop 4 includes over 20+ indispensable user interface components for building highly interactive web applications, from a fluid layout manager, toolbar, menubar, splitter, callout, navigation pane to stunning desktop and window controls.

In This Section

Getting Started

What's New in WebDesktop

Walkthrough topics

FAQ and How-to topics

Overview

Overview by Technology

Essential Concepts

WebCallOut

WebDragDropExtender

WebDesktopManager

WebToolBar

WebPaneManager

WebStyleManager

WebTab

WebNavPane

WebMenu

WebSplitter

WebDialogBox

WebFlyPostBackManager

WebExplorerPane

WebNotification

WebButton

Working with Component Editor

Common Tasks

Server-side References

Client-side References

Troubleshooting

Product Support

Licensing

© 2012 Intersoft Solutions Corp. All Rights Reserved.

© 2012 Intersoft Solutions Corp. All Rights Reserved.


Getting Started

Getting Started
See Also Send Feedback
Intersoft WebDesktop > Getting Started

Glossary Item Box

This section is designated to help you quickly getting started with WebDesktop.NET. You can use all links below to become familiar with WebDesktop.

Installation

The following topics will guide you how to install WebDesktop.NET and what the system requirements you need to have in order to run WebDesktop.NET in your PC.

  • Installation Guide
  • System Requirements
  • Use Toolbox Utility Tool to add Intersoft Products to Visual Studio toolbox

Deployment

This section will help you to configure and set the application in deploying the project to server. It also provides information on how to use Deployment Manager which contains the essential things you need to manage before proceeding to deployment.

  • Deployment Guide
  • Application Wide Configurations

Upgrading

This following topics will give you the information about the breaking changes in WebDesktop 2.5 and upgrading assembly reference from previous version of WebDesktop.

  • Breaking Changes in WebDesktop.NET 2.5
  • Upgrading from previous version

See Also

Other Resources
{What's New in 2.5}
{What's New in 2.0}


Installation

Installation
See Also Send Feedback
Intersoft WebDesktop > Getting Started > Installation

Glossary Item Box

This section contains information on installing WebDesktop.NET and specifying the system requirements needed by the component.

In This Section

Installation Guide
Information about installing WebDesktop.NET on your PC.

System Requirements
Read about the Windows version, Visual Studio application, WebUI.NET Framework and other software requirements for installing WebDesktop.NET.

Use Toolbox Utility Tool to add Intersoft Products to Visual Studio toolbox
Information about installing WebDesktop control to Visual Studio toolbox using Toolbox Utility tool.

See Also

Other Resources
{Deployment}
{Upgrading}


Installation Guide

Installation Guide
See Also Send Feedback
Intersoft WebDesktop > Getting Started > Installation > Installation Guide

Glossary Item Box

Installation Requirement

For system requirement, please see the System Requirements section.

Installing WebDesktop 3

Intersoft has released the new setup installer which includes WebUI Framework 3, WebGrid Enterprise 7, WebCombo 4, WebInput 4, WebDesktop 3, WebTreeView, ISDataSource, WebScheduler 3, WebAqua 2, WebTextEditor, WebEssentials and ClientUI components.

Here are the step-by-step instructions to install WebDesktop 3:

  1. Double click on the "intersoft webui studio 2010 r1.exe" icon to start the installation process. Read the instructions, and click next.

  2. Please read the license agreement. You must accept the terms in the license agreement in order to install WebDesktop 3.

  3. Fill in your details such as User Name and Organization. Click Next to proceed.

  4. You can select the product edition and setup type that you would like to install and perform.

    The product contains three editions such as WebUI Studio for ASP.NET, WebUI Studio for Silverlight and WebUI Studio for WPF.

  5. You can select the target environment for the samples, either Microsoft Visual Studio 2008 or Microsoft Visual Studio 2010.

  6. You can also customize the Start Menu group and choose to create shortcuts for all users or just for yourself.

  7. Click Next to proceed with the installation process.

  8. The wizard is installing WebUI Studio 2010 R1.

  9. A window showing the installation progress appears. It will list the status of components that are being installed.

  10. After the installation process has been finished, you will see a confirmation window. Click Finish to close the window. At this rate, you have successfully installed the Intersoft WebUI Studio 2010 R1.

  11. To install the full version of WebDesktop 3, proceed by using License Manager that can be triggered from Start menu >> All Programs >> Intersoft WebUI Studio 2010 R1 >> License Manager.

  12. Intersoft License Manager window will appear. Click "Add License" to proceed to the next step.

  13. Now, Select a product from the combo box. In this case, select WebDesktop Version 3.0.7200 and enter the license according to the component.

  14. Click Add and it will automatically check the license with the server through internet connection. If it is correct, then you have successfully installed the full version of WebDesktop 3.

See Also

Other Resources
{System Requirements}
Use Toolbox Utility Tool to add Intersoft Products to Visual Studio toolbox


System Requirements

System Requirements
See Also Send Feedback
Intersoft WebDesktop > Getting Started > Installation > System Requirements

Glossary Item Box

Development Machine Requirements

  • Microsoft Windows Vista
  • Microsoft Windows 2000/2003/2008 Server family
  • Microsoft Windows XP Professional or Home Edition
  • Microsoft .NET Framework v2.0 or higher
  • Microsoft Visual Studio 2005 Professional/Team Studio/Express Edition
  • Microsoft Visual Studio 2008
  • Intersoft WebUI.NET Framework v3.0 or higher

Server Machine Requirements

  • Windows Server 2003 Enterprise
  • Windows Server 2003 Web Edition
  • Windows Server 2008
  • Internet Information Services 6.0 or later
  • Microsoft .NET Framework Version 2.0 or later
  • Intersoft WebUI.NET Framework v3.0 or higher

Client Machine Requirements

  • Microsoft Internet Explorer 5.5 or higher
  • Mozilla V1.7 +for Windows/Mac/Linux/Solaris
  • Firefox V1.0+ for Windows/Mac/Linux/Solaris
  • Netscape V7.0+ for Windows/Mac/Linux/Solaris
  • Opera 9.5+ for Windows/Mac/Linux/Solaris/FreeBSD/BeOS/QNX
  • Apple Safari 3+ for Windows/Mac

See Also

Other Resources
{Installation Guide}
Use Toolbox Utility Tool to add Intersoft Products to Visual Studio toolbox


Use Toolbox Utility Tool to add Intersoft Products to Visual Studio toolbox

Use Toolbox Utility Tool to add Intersoft Products to Visual Studio toolbox
Send Feedback
Intersoft WebDesktop > Getting Started > Installation > Use Toolbox Utility Tool to add Intersoft Products to Visual Studio toolbox

Glossary Item Box

This topic provides a step-by-step instruction on how to manually add Intersoft products to Visual Studio Toolbox using Toolbox Utility tool.

To add Intersoft products to Visual Studio Toolbox

  1. Run Intersoft ToolBox Utility for Visual Studio from Start Menu >> All Programs >> Intersoft WebUI Studio 2010 R1 >> Intersoft ToolBox Utility for Visual Studio or you can access ToolBoxUtility.exe from [Installation Folder]\Intersoft Solutions\Intersoft WebUI Studio 2010 R1\ToolBoxUtility
  2. Select on the Visual Studio platform you want Intersoft products to be installed. By default, it will automatically select all Visual Studio versions installed on your PC.

  3. Click Register to run the tool and wait until the process is finished.

  4. Finally, open your project and you will notice that Intersoft products has been installed successfully into Visual Studio Toolbox.


Deployment

Deployment
See Also Send Feedback
Intersoft WebDesktop > Getting Started > Deployment

Glossary Item Box

This section contains information on configuring the application and guiding user with a step-by-step checklist instructions for deployment purposes.

In This Section

Deployment Guide
Information about Deployment Checklist that will list all the important tasks you need to do before deploying the project.

Application Wide Configurations
Read about the WebCombo's ability to configure deployment-related properties via web.config, such as ScriptDirectory and many others.

See Also

Other Resources
{Installation}
{Upgrading}


Deployment Guide

Deployment Guide
Send Feedback
Intersoft WebDesktop > Getting Started > Deployment > Deployment Guide

Glossary Item Box

This section continues to guide you on how to deploy the project by using Deployment Manager and SmartWebResources™.

In This Section

Using Deployment Manager
Learn how to use deployment manager to set the web.config.

Deploying project that uses SmartWebResources™
Information about deploying project using SmartWebResources™.

Deploying project that does not use SmartWebResources™
Information about deploying project without using SmartWebResources™. In other words, you need to copy CommonLibrary, project's directory and assemblies.


Using Deployment Manager
See Also Send Feedback
Intersoft WebDesktop > Getting Started > Deployment > Deployment Guide > Using Deployment Manager

Glossary Item Box

Intersoft comes up with a new hassle-free Deployment Manager that is designated to help developers to easily manage configurations during deployment phase.

Now, you can quickly configure the common settings required in deployment such as entering runtime license keys, view state configurations and others through user-friendly Windows GUI application.

Using Deployment Manager

Here are the step-by-step instructions to use Deployment Manager:

  1. Open Deployment Manager from Start menu >> All Programs >> Intersoft WebUI Studio.NET 2007 R2 >> WebUI.NET Framework 3.0 >> Deployment Manager.
  2. Click Browse and select the project's directory of your web application to be configured. Click Next afterwards.

  3. Tick WebDesktop.NET 2.5.2007 and put the Runtime License key according to the component. Click Next to proceed to the next step.

  4. In this step, there are many settings you can configure such as View State Storage, Optimization, Client Resources and Advanced sections.

    View State Storage Section

    View State Storage section lets you configure how ViewState is stored, specify how ViewState items are going to be saved in ViewState and determine the priority and duration of items stored in Cache object.

    Optimization Section

    Optimization section lets you choose whether to enable CSS Optimization and XML compression.

    Client Resources Section

    This section contains information on how to enable WebResources and set its mode.

    If you have applied SmartWebResources™ in your project, this option will be automatically selected with its default mode set to Auto.

    Advanced Section

    Advances section allows you to add necessary keys such as SharedScriptDirectory, ImagesDirectory or custom keys.

    In this section, you will learn how to assign the keys and values needed when you deploy the project.
    - In Advances section, click the ">" sign to move the available keys to the applied keys.
    - In Applied Keys table, Set the values like following:

    Key | Value
    ScriptDirectory | ~/CommonLibrary/WebDesktop/V2_5_2007/
    SharedScriptDirectory | ~/CommonLibrary/Shared/
    ImagesDirectory | ~/CommonLibrary/Images/WebDesktop/

    This section is very critical to be applied when you copy the CommonLibrary folder to the project's directory in development machine. However, if you have enabled SmartWebResources™, you no longer need to configure the directory settings.

  5. Click Next or Apply to save the configuration. Finally, the web.config has been updated successfully. Click Close to apply the settings.

See Also

Other Resources
{Deploying project that uses SmartWebResources™}
Deploying project that does not use SmartWebResources�?�
{Application Wide Configurations}

WebUI.NET Framework Reference
New SmartWebResources Framework


Deploying project that uses SmartWebResources™
See Also Send Feedback
Intersoft WebDesktop > Getting Started > Deployment > Deployment Guide > Deploying project that uses SmartWebResources™

Glossary Item Box

Intersoft Solutions constantly conduct extensive research and development to deliver new innovations that help developers become more productive by reducing the efforts and overwhelming complexity in both development and deployment stage.

SmartWebResources™ Framework is one of the great technology offered by Intersoft, which is used to eliminate the external physical resources such as scripts, images, etc.

WebDesktop.NET Deployment Checklist

  1. RuntimeLicenseKey
    This is a key required in order to license the components for deployment purpose in production environment.

    Runtime license key is different with design-time license key that you get during purchase. Please obtain each licensed component's RuntimeLicenseKey from Intersoft Developer Network under My Component section. You only need to obtain once and reuse it in multiple projects. The login detail is provided in your purchase receipt. If you purchased from our resellers, it may take 24-48 hours for the verification and account creation process.
  2. Resources Assembly
    Ensure that you have copied the resources assemblies to your project's bin folder. The resources assembly can be found in C:\Program Files\Intersoft Solutions\WebDesktop.NET 2.5\Bin. The resource assembly is:
    * ISNet.WebUI.WebDesktop.Resources.dll
  3. Framework Assemblies
    You are required to copy framework assemblies to your project's bin folder. The framework assemblies can be found in C:\Program Files\Intersoft Solutions\WebUI.NET Framework 3.0\Bin (Default installation directory). The framework assemblies are:
    * ISNet.dll
    * ISNet.WebUI.dll
  4. Component Assembly
    Component assembly is required to be copied to your project's bin folder. The component assembly can be found in C:\Program Files\Intersoft Solutions\WebDesktop.NET 2.5\Bin. The component assembly is:
    * ISNet.WebUI.WebDesktop.dll

Deploying project that uses SmartWebResources™

Here are step-by-step instructions to deploy the project using SmartWebResources™:

  1. Before deploying the project, you have to configure SmartWebResources after you created a new web application. Click here for guidance.
  2. Next, you need to use Deployment Manager in order to set the web.config of your web application, such as defining Runtime License key. Please read Using Deployment Manager for more information.
  3. Finally, you simply need to XCopy all required web application files along with the bin folder (i.e. your project's directory) to a destination folder in your web server.

See Also

Other Resources
{Using Deployment Manager}
{Deploying project that does not use SmartWebResources™ }
{Application Wide Configurations}

WebUI.NET Framework Reference
New SmartWebResources Framework


Deploying project that does not use SmartWebResources�?�

Deploying project that does not use SmartWebResources�?�
See Also Send Feedback
Intersoft WebDesktop > Getting Started > Deployment > Deployment Guide > Deploying project that does not use SmartWebResources�?�

Glossary Item Box

General

WebDesktop.NET 2.0 is built on the top of WebUI.NET Framework. It includes the common concept, functionalities and features implemented in the framework level.

WebDesktop.NET Deployment Checklist

  1. RuntimeLicenseKey.
    This is a key required in order to license the components for deployment purpose in production environment.

    Runtime license key is different with design-time license key that you get during purchase.

    Use Deployment Manager to set the project's Web.config. There are 2 important things you need to notice:

    - If you set CommonLibrary folder as IIS Virtual Directory in development machine, you may refer to Using Deployment Manager topic for guidance.

    - If you copy the CommonLibrary folder to the project's directory in development machine, you may refer to Using Deployment Manager topic under Advanced section for guidance.

    Please obtain each licensed component's RuntimeLicenseKey from Intersoft Developer Network under My Component section. You only need to obtain once and reuse it in multiple projects. The login detail is provided in your purchase receipt. If you purchased from our resellers, it may take 24-48 hours for the verification and account creation process.
  2. CommonLibrary
    All subfolders and files inside CommonLibrary folder is required.
  3. Framework Assemblies.
    You are required to copy framework assemblies to your project's bin folder. The framework assemblies can be found in C:\Program Files\Intersoft Solutions\WebUI.NET Framework 3.0\Bin (Default installation directory). The framework assemblies are as following:
    * ISNet.dll
    * ISNet.WebUI.dll
  4. Component Assembly
    Component assembly is required to be copied to your project's bin folder. The component assembly can be found in C:\Program Files\Intersoft Solutions\WebDesktop.NET 2.5\Bin. The component assembly is as following:
    * ISNet.WebUI.WebDesktop.dll

WebDesktop.NET Deployment Guide

  1. If you set CommonLibrary folder as IIS Virtual Directory in development machine
    - XCopy all your required web application files along with the bin folder (i.e. your project's directory) to a destination folder in your web server.
    - XCopy the CommonLibrary folder to your web server. It is recommended to place it under wwwroot folder (usually c:\inetpub\wwwroot). You need to map the destination folder to IIS Virtual Directory with name "CommonLibrary".
  2. If you copy the CommonLibrary folder to the project's directory in development machine
    - XCopy all your required web application files along with the bin and CommonLibrary folders (i.e. your project's directory) to a destination folder in your web server.

    Creating CommonLibrary as IIS Virtual Directory is not required in this case.

See Also

Other Resources
{Using Deployment Manager}
{Deploying project that uses SmartWebResources™}

WebUI.NET Framework Reference
New SmartWebResources Framework


Application Wide Configurations

Application Wide Configurations
See Also Send Feedback
Intersoft WebDesktop > Getting Started > Deployment > Application Wide Configurations

Glossary Item Box

One of the unique features introduced since the earlier products is the ability to configure specific deployment-related properties via web.config. WebDesktop.NET V2.5 further enhanced this capability by adding more properties configurable through web.config. Now it also supports relative application path by using ~ character. The application-wide Configurations feature allows centralized configuration for common deployment properties such as ScriptDirectory etc, which dramatically increasing effective and efficient maintenance.

Following are the list of properties that are configurable through web.config.

  • SharedScriptDirectory
  • ScriptDirectory
  • ImagesDirectory
  • ViewStateStorage
  • RuntimeLicenseKey
  • PageCachePriority
  • PageCacheDuration

There are numerous base properties that you can configure as well. For more information on base properties, please see the Framework's Application Wide Configurations.

The settings specified in web.config will only be applied to instances' properties that have Default value (unchanged).

The format of the key used for the configuration is AssemblyFullName.vProductVersion.Properties.

Examples:

The sample configuration in web.config below will change the property value of ScriptDirectory, ImagesDirectory, SharedScriptDirectory to all WebDesktop V2_5_2007 instances in the application.

<configuration>

<appSettings>

<add key="ISNet.WebUI.WebDesktop.V2_5_2007.ScriptDirectory" value="~/CommonLibrary/WebDesktop/V2_5_2007/" />

<add key="ISNet.WebUI.WebDesktop.V2_5_2007.ImagesDirectory" value="~/CommonLibrary/Images/" />

<add key="ISNet.WebUI.WebDesktop.V2_5_2007.SharedScriptDirectory" value="~/CommonLibrary/Shared/" />

</appSettings>

... other settings

</configuration>

Additional application-wide configurations may be available specifically per product. Please refer to the Application-wide Configurations topic in the product's help file.

See Also

Other Resources
{Deployment Guide}


What's new in v1.5

What's new in v1.5
Send Feedback

Glossary Item Box

Enhancements and New Features

WebDesktop.NET 1.5 includes significant enhancements and new features to existing components such as listed in the following.

General

  • Supports for Microsoft "Atlas" framework. Inherited from WebUI.NET Framework. Intersoft's components can now be used side-by-side with Atlas components in the same WebForm page.
  • Improved server side serialization architecture for faster performance. Inherited from WebUI.NET Framework.

WebDesktopManager

  • New Feature: Cinematic visual experiences. Now includes 8 visual transition effects for window display.
  • New Feature: Desktop preloader for scripts and images with completely customizable Style.
  • New Feature: Custom loader progress rendering for Desktop preloader.
  • New Feature: Preloader API for loading custom images.
  • New Feature: Ability to set a window as busy or idle programmatically at client side. When set as busy, the mouse cursor will be changed to HourGlass when moved over the window surface. This prevents users to interact with the content such as during saving process.
  • New Feature: Related to set window as busy, you can customize the BusyText at window level or at global level (TextSettings).
  • Enhancements: Major performance improvements. Expected 60% faster and more responsive during user interactions such as when switching windows, closing window that host complex page, minimizing, maximizing and more.
  • Enhancements: Added ScrollBarStyle to WindowSettings.
  • Enhancements: Added CssClass to ScrollBarStyle for custom scrollbar style class name.
  • Enhancements: Added DimWindowWhenBusy property which work in conjunction with SetBusy API.

WebNavPane

  • Enhancements: Major performance improvements. This is implemented to loading mechanism and migrated codes to use intelligent event handling mechanism.
  • Enhancements: Better Mozilla browsers support.

WebToolBar and WebMenuBar

  • New Feature: Images can now looks as "greyed" when the command is disabled.
  • New Feature: LazyLoad for dropdown menus. This feature is very useful when you have lot of commands which Type is DropdownButton or SplitButton, so that the menu items of these commands will be loaded on demand and thus increasing first load performance.
  • Enhancements: Refactored client side Bar engine for better reusability and extensibility.
  • Enhancements: Major performance improvements. Expected 50% faster performance during loading and user interactions.

WebStyleManager

  • New Feature: Custom stylesheet inclusion. This feature allows designers to include their own styles extension per theme level.
  • New Feature: Automatic style partition. This feature enables the theme architecture to selectively include only required styles which at the end dramatically improves performances.

Learn more

WebButton

  • New Feature: ASP.NET 2.0 native validation supports.
  • New Feature: Added ValidationGroup property for ASP.NET 2.0's ValidationGroup feature.
  • New Feature: Added CauseValidation property to support ASP.NET validation mechanism.

WebSplitter

  • Enhancements: Better layout persistence during postback.
  • Enhancements: Better support for Mozilla browsers.

WebTab

  • New Feature: Added AutoPostBack property to allow the control to perform full postback when the active tab is changed.

WebMenu

  • Enhancements: Better menu positioning depend on OffsetAlignment property in Mozilla browsers.

New Components

WebDesktop.NET 1.5 welcomes three new components to join the product family such as listed in the following.

WebFlyPostBackManager

  • The E-AJAX (Enhanced AJAX) architecture which is built on the top of FlyPostback�?�.
  • Offer two options for communication with server side, through WebService (ASMX) or WebForm (ASPX).
  • Elegant object model and API to invoke server methods from client side.
  • Automatic metadata collection and event wiring.
  • Support simple data types and complex data types, including ADO.NET objects.
  • Learn more about WebFlyPostBackManager: WebFlyPostBack, Features, Understanding Concepts

WebNotification

  • Built on the top of WebFlyPostBackManager.
  • Enables you to professionally create pull-model notifications.
  • Tightly integrated with WebDesktopManager as universal shell.
  • Supports various animations and control styles.
  • Learn more about WebNotifications: WebNotification, Features, Understanding Concepts

WebExplorerPane

          • The exact replica of Windows XP® Explorer Pane control in behaviors, styles and user interactions.
          • Provides height animation with fading effect while collapsing or expanding.
          • Support TrueShape technology for round corner without the need to use images.
          • Support pixel-perfect borders between header and content as well as ability to use custom images.
          • Learn more about WebExplorerPane: WebExplorerPane, Features, Understanding Concepts


Upgrading

Upgrading
Send Feedback
Intersoft WebDesktop > Getting Started > Upgrading

Glossary Item Box

This section contains information on the breaking changes in WebDesktop 2.0 and upgrading assembly reference from its previous version.

In This Section

Breaking Changes in WebDesktop.NET 2.5
Information about breaking changes in WebDesktop 2.5 such as object model, user interface and others.

Upgrading from previous version
Read about the latest upgrade in WebDesktop 2.5.


Breaking Changes in WebDesktop.NET 2.5

Breaking Changes in WebDesktop.NET 2.5
See Also Send Feedback
Intersoft WebDesktop > Getting Started > Upgrading > Breaking Changes in WebDesktop.NET 2.5

Glossary Item Box

There is no breaking changes in WebDesktop.NET 2.5. All existing object model, features and behaviors remain the same.

See Also

Other Resources
{Upgrading from previous version}
What's New in WebDesktop


Upgrading from previous version

Upgrading from previous version
See Also Send Feedback
Intersoft WebDesktop > Getting Started > Upgrading > Upgrading from previous version

Glossary Item Box

This section contains information on the upgrading areas from WebDesktop's previous version.

In This Section

Upgrading Overview
Read about the most significant major upgrade in WebDesktop 2.5.

Assembly References
Learn how to migrate your existing web application to WebDesktop 2.5.

See Also

Other Resources
What's New in WebDesktop


Upgrading Overview

Upgrading Overview
See Also Send Feedback
Intersoft WebDesktop > Getting Started > Upgrading > Upgrading from previous version > Upgrading Overview

Glossary Item Box

WebDesktop.NET® 2.5 includes major enhancements in user interface, styles, AJAX improvements, wider scenario support for WebFlyPostBackManager and WebNotification, and rich designer experience.

If you are planning to upgrade your existing web application to use WebDesktop.NET 2.5, please take the following points into consideration:

  • Enable SmartWebResources™ for WebDesktop and take advantage of the hassles-free deployment approach. With this new feature, you can now develop web application using File System Project (FSP) and Web Application Project (WAP) which introduced in Visual Studio 2005 SP1. The SmartWebResources™ enables all client resources including images and background images in the theme to display properly in design-time environment.

    If you are a new web developer and would like to develop ASP.NET 2.0 web application using WebDesktop.NET 2.5, you may want to check out Microsoft's Visual Web Developer Express. Visual Web Developer Express is a lightweight version of Visual Studio 2005, and is provided for free by Microsoft. Since that WebDesktop.NET 2.0 is built on the top of Visual Studio 2005 architecture, Visual Web Developer Express is fully supported as well. To download Visual Web Developer Express, visit http://msdn.microsoft.com/vstudio/express/vwd/download/
  • If you are using a lot of WebMenuBar, WebToolBar and WebContextMenu component, consider to use the new Normal option for MenuWindowType. This new WindowType solves numerous display and positioning issues that occurred in Internet Explorer 7.0. Note that these issues are behavior by design in Internet Explorer 7.0 which limits the usage of "popup" object to prevent security issues.
  • We have added new styles to all of the User Interface components included in WebDesktop.NET. The new styles are mainly focused on Office 2007 and Vista style. Check them out and easily apply the new style to your existing web application.

See Also

Related Sections
{Assembly References}

Other Resources
What's New in WebDesktop


Assembly References

Assembly References
See Also Send Feedback
Intersoft WebDesktop > Getting Started > Upgrading > Upgrading from previous version > Assembly References

Glossary Item Box

Our development team is working hard to ensure that you can upgrade your web application as smooth as possible in less efforts. You can easily migrate your existing web application to use version 2.5 by simply changing the assembly references to 2.5 assemblies.

To upgrade an existing ASP.NET 2.0 web application to use WebDesktop.NET 2.5, please do the following:

  • Open an existing web application in Visual Studio 2005/Express
  • Expand Bin folder
  • Remove ISNet.dll, ISNet.WebUI.dll and ISNet.WebUI.WebGrid.dll
  • Right click on the Project node then click Add Reference
  • Add ISNet.dll, ISNet.WebUI.dll from [Installation Folder]\WebUI.NET Framework 3.0\Bin [Note that the file version should be 3.0.5000.400+]
  • Add ISNet.WebUI.WebDesktop.dll from [Installation Folder]\WebDesktop.NET 2.5\Bin
  • Rebuild your web application and run in browser
If you are planning to use new SmartWebResources™ feature available in WebDesktop.NET 2.5 for simpler deployment, please refer to Hassle-free deployment through SmartWebResources™ technology.

See Also

Related Sections
Upgrading Overview

Other Resources
What's New in WebDesktop


What's New in WebDesktop 4

What's New in WebDesktop 4
See Also Send Feedback
Intersoft WebDesktop > What's New in WebDesktop 4

Glossary Item Box

Intersoft WebDesktop is the first comprehensive desktop user interface design suite that streamlines development so far, that even a sole developer can deliver rich, line-of-business web applications in a timely, cost effective manner. WebDesktop offers more than 15 advanced UI components to let you build true Web 2.0 business software.

In version 4, WebDesktop has been refined to fully support the latest web standards. This allows you to use many of the advanced WebDesktop features in your next-generation web applications and at the same time leveraging cutting-edge technologies such as HTML5 and CSS3.

Following are list details of the enhancements and new features introduced in WebDesktop 4.

  • Full compliance with HTML5 doc type.

    HTML5 doc type enables consistent results and pixel-perfect rendering across all modern browsers that support HTML5.

    The following features have been enhanced to support HTML5 doc type:

    • WebDesktopManager

      WebDesktopManager employs an object-based approach to give you granular control over every visual aspect of its elements.

      For more information, see What's New in WebDesktopManager.

    • WebPaneManager

      WebPaneManager puts you in control of the screen, providing all the tools you need to develop layouts that organize your applications content and give it a consistent, professional appearance.

      For more information, see What's New in WebPaneManager.

    • PlaceHolderManager

      A PlaceHolderManager represents four-edge partitioned table, where each side acts as a container for docking, and the middle area acts as the content placeholder.

      For more information, see What's New in PlaceHolderManager.

    • WebTab

      WebTab offers numerous customizations, such as flexible tab size, structure management, scroll enable, closure enable, and automatic resizing.

      For more information, see What's New in WebTab.

    • WebToolBar

      WebToolBar delivers a desktop toolbar experience equal to that of Microsoft Office 2007.

      For more information, see What's New in WebToolBar.

    • WebMenuBar

      WebMenu feature include: auto-adjust to browser size, unlimited submenus with intelligent positioning, automatic vertical item scrolling, sticky behavior, and mnemonic key support.

      For more information, see What's New in WebMenuBar.

    • WebDialogBox

      WebDialogBox provides you a powerful dialog box component from Intersoft that delivers a true desktop experience.

      For more information, see What's New in WebDialogBox.

    • WebNotification

      WebNotification enables interactive push message systems to your ASP.NET applications.

      For more information, see What's New in WebNotification.

    • WebExplorerPane

      WebExplorerPane give users a superior Microsoft Windows-style navigation and control pane in your web applications.

      For more information, see What's New in WebExplorerPane.

    • WebNavPane

      WebNavPane give users a superior Microsoft Windows-style navigation and control pane in your web applications.

      For more information, see What's New in WebNavPane.

    • WebCallOut

      Intersoft WebCallOut is a superior replacement for the standard tooltip.

      For more information, see What's New in WebCallOut.

To learn how to enable HTML5 rendering mode in WebDesktop, see How-To: Enable HTML5 RenderingMode

  • CSS3 support.

    When the WebDesktop control is hosted in pages that use HTML5 doc type, it will automatically enable CSS3 to deliver better visual effects and consistent results across all modern browsers. The CSS3 adoption also increases performance in overall due to the reduced HTML output. This is possible because certain markups are no longer required in the rendering which makes the WebDesktop output even more compact.
WebDesktop 4 continues to support backward compatibility with HTML4 and XHTML doc type. This means that you can upgrade your existing projects to WebDesktop 4 without any additional efforts.

For more information about WebDesktop, see WebDesktop OverView.

See Also

Getting Started
Getting Started
WebDesktop Overview


How-To: Enable HTML5 Rendering Mode

How-To: Enable HTML5 Rendering Mode
Send Feedback
Intersoft WebDesktop > What's New in WebDesktop 4 > How-To: Enable HTML5 Rendering Mode

Glossary Item Box

This topic explains how to configure WebDesktop to emit HTML5 compliance output.

Configure Doc Type

Each doctype declaration in HTML specification produces different results and behaviors, mostly in the layout and rendering aspects. WebDesktop supports most commonly used doctype and automatically adjust the behaviors and rendering results by detecting the doctype declaration of the HTML page.

In version 4, WebDesktop has been significantly enhanced to deliver consistent behaviors and layout in HTML5 pages. All features should work exactly as in other doctype.

To enable HTML5 support in WebDesktop, make sure you have configured the HTML pages to use the proper doctype. The standard doctype for HTML5 is <!DOCTYPE html>.

The following code example shows how to use WebDesktop in a simple WebForm using HTML5 doctype.

ASPX Copy Code
<%@ Page Language="C#" AutoEventWireup="true" CodeFile="Default.aspx.cs" Inherits="cs_WebGrid_Default" %>
<%@ Register Assembly="ISNet.WebUI.WebDesktop" Namespace="ISNet.WebUI.WebDesktop" TagPrefix="ISWebDesktop" %>

<!DOCTYPE html>
<html>
<head runat="server">
    <title></title>
</head>
<body>
    <form id="form1" runat="server">
    <div>
         <ISWebDesktop:WebDesktopManager ID="WebDesktopManager1" runat="server" Height="100%" Width="100%">
         </ISWebDesktop:WebDesktopManager>
    </div>
    </form>
</body>
</html>

Note that the xmlns attribute is no longer necessary to be defined in the <html> tag. If you upgraded your existing pages, make sure the xmlns attribute is removed from the <html> tag.

Also, to enable percentage height in HTML5, you must define its height in body and html element. Here's the example

ASPX Copy Code
<head runat="server">
    <title></title>
    <style type="text/css">
    html, body
    {
        height: 100%;
        width: 100%;
        margin: 0;
        padding: 0;
    }
    </style>
</head>

In HTML5, height of an element is refer to its parent's height so this is necessary to define its parent element.

Configure Rendering Mode

To provide the best HTML5 support, WebDesktop needs to adjust several features that are commonly processed in the server-side such as markup rendering and AJAX callback response. Unfortunately, the HTML5 doctype cannot be automatically detected by the server-side browser capability. As such, WebDesktop introduces a new property called RenderingMode which you must set explicitly in order to activate HTML5 compliance output.

You can set the rendering mode in a WebDesktop instance individually by setting the RenderingMode property to HTML5 value, such as shown in the example below.

ASPX Copy Code
<ISWebDesktop:WebDesktopManager ID="WebDesktopManager1" runat="server" Height="100%" Width="100%" RenderingMode="HTML5">
</ISWebDesktop:WebDesktopManager>

Alternatively, you can also apply the rendering mode globally through the application-wide configuration, see the following example.

Web.config Copy Code
<add key="ISNet.WebUI.WebDesktop.v4_0_7200.RenderingMode" value="HTML5"/>
If your project is exclusively targeting HTML5, it's recommended to use application-wide configuration to apply the rendering mode to all WebDesktop instances in the project.

For more information about application-wide settings in WebDesktop, see ........


How-To: Using Layout Manager

How-To: Using Layout Manager
Send Feedback

Glossary Item Box

Layout Manager

The Layout Manager feature has been introduced since previous version of WebDesktop. The feature was previously implemented in WebUI.NET Framework as part of Component Designer 1.0. Layout Manager is a powerful feature to let you easily apply from a predefined style as well as save your own style and reuse it later.

The Layout Manager in second generation of Component Designer has been much improved in many areas. It now has cleaner look and uncluttered user interface to bring you larger space for the preview.

You can easily preview a style before decide to apply it by simply clicking on Preview command. The preview is performed in real time and showing the exact visual appearances as in runtime.

Change layout in WebDesktop

To change the layout in WebDesktop, you can do the following / these steps:

  1. Open Component Designer by right clicking on the control or by clicking the smart tag on the upper right corner of the control.
  2. Open the Layout Manager Tab.
  3. You can expand the Predefined Layout in order to choose the layout that we provide for the control. Alternatively, if you have saved your own layout, you can choose expand Custom Layout. You can view the shape of the predefined layout on the right pane by clicking Preview button.
  4. After selecting the layout that you want, click Apply above the predefined layout of your Layout Manager.
  5. The layout will be applied to your component afterwards.


Walkthrough topics

Walkthrough topics
See Also Send Feedback
Intersoft WebDesktop > Walkthrough topics

Glossary Item Box

The following list of walkthrough topics demonstrates how to use all features in WebDesktop.

WebCallOut

The topic in this category provides an information about creating a simple application using WebCallOut.

  • Walkthrough: Getting started with WebCallOut

WebDragDropExtender - Predefined Cursor Effects

The topics in this category provide information about customizing cursor effect for drag control.

  • Walkthrough: Specifying cursor effect for all DragControls
  • Walkthrough: Specifying cursor effect for individual DragControl
  • Walkthrough: Changing cursor effect programmatically in client side

WebDragDropExtender - Vista™ Style Tooltip

The topic in this category provides information about setting tooltip text via client side.

  • Walkthrough: Setting tooltip text programmatically in client side based on drop target objects

WebDragDropExtender - Use Custom Object as Data

The topic in this category provides information about using GetDataPresent method to query object type.

  • Walkthrough: Using GetDataPresent method to query object type in OnDragOver event

WebDragDropExtender - Drag Data Validation

The topics in this category provide information about using drag data validation during DragDrop event.

  • Walkthrough: Restricting a drop control to accept only Number data type
  • Walkthrough: Ensuring validity of drag objects based on Effect

WebDragDropExtender - Cross IFRAME Support

The topics in this category provide information about performing drag-drop over IFRAMEs.

  • Wallthrough: Enabling a panel server control to be dragable across child IFRAMEs
  • Wallthrough: Enabling a panel server control to be dragable across sibling child IFRAMEs

    WebDragDropExtender - Integration with Intersoft Controls

    The topic in this category provides information about creating Outlook style drag and drop application.

    • Walkthrough: Creating Outlook style drag and drop application

    WebDragDropExtender - Client Side References Class

    The topic in this category provides information about using IsSubObject and SubObjectContext.

    • Walkthrough: Using IsSubObject and SubObjectContext to retrieve the target drop object of WebNavPane control

    WebDesktopManager

    The topics in this category provide information about implementing WebDesktopManager's features in various ways.

    • Creating Simple Desktop
    • Using IFrame from TaskBar
    • Hiding a Window from TaskBar
    • Enabling ShortcutIcons feature
    • Hiding a Window at initial load
    • Configuring Desktop to use VerticalTile WindowArrangement
    • Using Custom Template for Left and Right part of TaskBar
    • Using Window Options
    • Specifying Minimum and Maximum Size for a Window
    • Adding new Window at Client Side
    • Adding new Shortcut at Client Side
    • Obtaining Desktop Structure at Client Side
    • Configuring Window to use Complex Images

    WebToolBar

    The topics in this category provide information about implementing WebToolBar's features in various ways.

    • Creating Dockable Toolbar
    • Creating Standalone Toolbar
    • Changing Toolbar docking at design time
    • Using ToolCommand Types
    • Configuring Multiple Rows Docking
    • Configuring Multiple Bars in Same Row
    • Configuring Floating Mode
    • Using Templated Command
    • Configuring Toolbar Merging
    • Configuring ToolCommand Toolbar Merging
    • Changing Toolbar Styles
    • Using Images for Toolbar Appearance

    WebPaneManager

    The topics in this category provide information about implementing WebToolBar's features in various ways.

    • Creating Simple Layout
    • Creating Layout from Predefined Template
    • Creating Outlook 2003 Style Layout
    • Creating Complex Layout using Editor
    • Configuring Collapsible Pane
    • Disabling Resizing for specific Pane
    • Using CaptionMode Types
    • Using IFrame as ContentMode
    • Configuring Styles and Appearance

    WebStyleManager

    • Creating a New Project
    • Creating New Theme
    • Creating New Style
    • Configuring Styles for Web Application
    • Configuring Styles for Pages and Controls
    • Deploying Theme Project

    WebTab

    The topics in this category provide information about implementing WebTab's features in various ways.

    • Creating Simple Tab
    • Creating Overlapped Edges Tab
    • Changing Tab Position
    • Configuring Scrolling Tab mode
    • Configuring Closable Tab mode
    • Adding new TabItem at Client Side
    • Changing TabItem Caption at Client Side
    • Displaying confirmation box before TabItem is closed
    • Creating Visual Studio 2005 Style Tab
    • Saving and Loading Structure Programmatically
    • Configuring Justify Sizing mode
    • Enabling Focus border for Accessibility

    WebNavPane

    The topics in this category provide information about implementing WebNavPane's features in various ways.

    • Creating Simple NavPane
    • Creating NavPane with Images
    • Using BarItem for Content Navigation
    • Using Template and IFrame Content mode
    • Loading NavPane Structure Programmatically
    • Handling Client Side Events
    • Creating NavBar and NavBarItem at client side

    WebMenu

    The topics in this category provide information about implementing WebNavPane's features in various ways.

    • Walkthrough: Enabling complex images in WebContextMenu
    • Using MenuBar in PlaceHolderManager mode
    • Creating Standalone MenuBar
    • Working with MenuItem Types
    • Handling Command Client Side Events
    • Attaching ContextMenu to a Control
    • Showing ContextMenu Programmatically
    • Enabling and Disabling MenuItem
    • Add new MenuItem at Client Side

    WebSplitter

    The topics in this category provide information about implementing WebSplitter's features in various ways.

    • Using WebSplitter to split basic two cells
    • Using WebSplitter to split two rows
    • Configuring WebSplitter Interactive Styles
    • Using AllowCollapse feature

    WebDialogBox

    The topics in this category provide information about implementing WebDialogBox's features in various ways.

    • Creating Simple DialogBox
    • Designing custom DialogBox
    • Showing DialogBox at client side
    • Obtaining DialogResult at client side

    WebFlyPostBackManager

    The topics in this category provide information about implementing WebFlyPostBackManager's features in various ways.

    • Retrieving simple types using WebService
    • Retrieving simple types using WebForm service
    • Showing loading progress
    • Programmatically refresh server control
    • Converting standard controls to use callback
    • Selectively converting standard controls to use callback

    WebExplorerPane

    The topics in this category provide information about implementing WebExplorerPane's features in various ways.

    • Creating Simple ExplorerPane
    • Configuring Expand and Collapse ExplorerPane
    • Show and hide ExplorerBar items
    • Changing Inline content of ExplorerPane
    • Handling Client Side Events

    WebNotification

    The topics in this category provide information about implementing WebNotification's features in various ways.

    • Retrieving notifications from WebService
    • Retrieving notifications from WebForm Listener
    • Integrating into WebDesktopManager
    • Using action context menu
    • Passing custom properties

    WebButton

    The topics in this category provide information about implementing WebButton's features in various ways.

    • Configuring Interactive Style of WebButton
    • Enabling Automatic Postback when clicked
    • Executing server side codes in FlyPostBack mode
    • Using ClientAction engine during FlyPostBack execution

    • See Also

    Tasks
    {FAQ and How-to topics}


Walkthrough: Enabling WebTreeView to accept data items from WebGrid control

Walkthrough: Enabling WebTreeView to accept data items from WebGrid control
See Also Send Feedback

Glossary Item Box

See Also

Tasks
{How-to: Enable drag behavior in WebTreeView with ability to drop into Panel control using WebDragDropExtender}
{Walkthrough topics}
{FAQ and How-to topics}

Concepts
{Integration with WebDragDropExtender component}


FAQ and How-to topics

FAQ and How-to topics
See Also Send Feedback
Intersoft WebDesktop > FAQ and How-to topics

Glossary Item Box

The following list of How-to topics describes how to implement various features and enhancements in WebDesktop.

WebFlyPostBackManager

The topic in this category provides a direct instruction on how to enable automatic callback.

  • How-to: Enable automatic callback in FlyPostBackManager

SmartWebResources

The topic in this category provides a direct instruction on how to configure SmartWebResources in a web application.

  • FAQ: Does SmartWebResources feature automatically enabled in WebDesktop.NET 2.0?
  • FAQ: Briefly, what are the files included in WebDesktop SmartWebResources Assembly?
  • How-to: Configure SmartWebResources in a new web application

WebDesktopManager - Vista style animation

The topic in this category provides a direct instruction on how to use vista-style zoom animation in WebDesktopManager.

  • How-to: Enable Vista-style zoom animation in WebDesktopManager

WebDialogBox - Modeless Mode

The topic in this category provides a direct instruction on how to use modeless mode in WebDialogBox.

  • How-to: Set WebDialogBox to Modeless mode

WebDialogBox - Vista style animation

The topic in this category provides a direct instruction on how to use vista-style animation in WebDialogBox.

  • How-to: Enable Vista-style zoom animation in WebDialogBox

WebMenu - Quadratic Sliding Animation

The topic in this category provides a direct instruction on how to enable quadratic sliding animation.

  • How-to: Enable quadratic sliding animation

WebCallOut - Customizable DisplaySettings

The topic in this category provides a direct instruction on how to set several DisplaySettings from WebCallOut's Properties.

  • How-to: Customize DisplaySettings in WebCallOut

WebCallOut - ComplexImages

The topic in this category provides a direct instruction on how to use ComplexImages in WebCallOut.

  • How-to: Use ComplexImages in WebCallOut

WebCallOut - CloseBehaviors

The topic in this category provides a direct instruction on how to customize CloseBehaviors in WebCallOut.

  • How-to: Use CloseBehaviors in WebCallOut

WebCallOut - ShowBehaviors

The topic in this category provides a direct instruction on how to customize ShowBehaviors in WebCallOut.

  • How-to: Use ShowBehaviors in WebCallOut

WebCallOut - Customizable Pointing Position

The topic in this category provides a direct instruction on how to set pointing position in WebCallOut.

  • How-to: Customize pointing position in WebCallOut

WebCallOut - Preferred Position

The topic in this category provides a direct instruction on how to set preferred position in WebCallOut.

  • How-to: Use preferred position in WebCallOut

WebCallOut - InteractiveMoving

The topic in this category provides a direct instruction on how to set WebCallOut based on mouse cursor position of the control.

  • How-to: Move WebCallOut based on mouse cursor position of the control

WebCallOut - ContentMode

The topic in this category provides a direct instruction on how to set ContentMode in WebCallOut.

  • How-to: Set ContentMode in WebCallOut

WebCallOut - DisplayLatency

The topic in this category provides a direct instruction on how to set DisplayLatency in WebCallOut.

  • How-to: Set DisplayLatency in WebCallOut

WebCallOut - FlyPostBack

The topic in this category provides a direct instruction on how to set text and title via server side.

  • How-to: Set Text and Title on server side

  • How-to: Set Text and Title with template ContentMode on server side

WebDragDropExtender - AJAX DragDrop Server Side Event

The topic in this category provides a direct instruction on how to perform AJAX callback and server side task during drag and drop.

  • How-to: Enable AJAX callback and perform server side tasks upon drag and drop

WebDragDropExtender - Automatic Transparent Shadow

The topic in this category provides a direct instruction on how to use simple indicator as drag visual hint.

  • How-to: Use simple indicator as drag visual hint

WebDragDropExtender - Vista™ Style Tooltip

The topic in this category provides a direct instruction on how to specify tooltip text in a drag control.

  • How-to: Specify tooltip text to a drag control

WebDragDropExtender - Keyboard State

The topics in this category provide direct instructions on how to query the keyboard state during a drag operation.

  • How-to: Obtain key state during DragDrop event
  • How-to: Determine Effect programmatically based on current key state

WebDragDropExtender - Integration with Intersoft Controls

The topics in this category provide direct instructions on how to enable drag and drop integration for WebGrid and WebDesktopManager.

  • How-to: Enable special drag integration for WebGrid control
  • How-to: Enable special drop integration for WebDesktopManager control
  • How-to: Disable caching for movable drop objects

See Also

Tasks
{Walkthrough topics}


How-to: Set auto postback on drag drop operation

How-to: Set auto postback on drag drop operation
See Also Send Feedback

Glossary Item Box

See Also

Tasks
{How-to: Handle server side OnDragDrop event}
{Walkthrough topics}
{FAQ and How-to topics}

Concepts
{Auto Postback on DragDrop}


How-to: Handle server side OnDragDrop event

How-to: Handle server side OnDragDrop event
See Also Send Feedback

Glossary Item Box

See Also

Tasks
{How-to: Set auto postback on drag drop operation}
{Walkthrough topics}
{FAQ and How-to topics}

Concepts
{Auto Postback on DragDrop}


How-to: Enable drag behavior in WebTreeView with ability to drop into Panel control using WebDragDropExtender

How-to: Enable drag behavior in WebTreeView with ability to drop into Panel control using WebDragDropExtender
See Also Send Feedback

Glossary Item Box

See Also

Tasks
{Walkthrough: Enabling WebTreeView to accept data items from WebGrid control}
{Walkthrough topics}
{FAQ and How-to topics}

Concepts
{Integration with WebDragDropExtender component}


Release History

Release History
Send Feedback
Intersoft WebDesktop > Release History

Glossary Item Box

This section summarizes features and enhancements that have been added or modified in WebDesktop.NET.

In This Section

What's New in WebDesktop V2.5
Describes the latest features and enhancements in version 2.5.

What's New in WebDesktop V2.0
Describes the latest features and enhancements version 2.0.


Assembly Overview

ISNet.WebUI.WebDesktop Assembly
See Also Send Feedback

Glossary Item Box

Namespaces

Namespace | Description
ISNet.WebUI.WebDesktop |


Getting Started - Intersoft WebDesktop Documentation

Getting Started
Send Feedback

Glossary Item Box


Introduction - Intersoft WebDesktop Documentation

Introduction
Send Feedback

Glossary Item Box


V2.5

V2.5
Send Feedback
Intersoft WebDesktop > Release History > V2.5

Glossary Item Box

This section describes the new features and technologies added in WebDesktop.NET V2.5. Here are the following list of new features supported by WebDesktop.NET V2.5:

WebDesktopManager

WebDesktop.NET 2.5 introduces Shadow mode feature to be used when moving and resizing window. It offers a smooth interaction on the window and improves resizing stability.

  • For more information, see WebDesktopManager.

WebDialogBox

WebDesktop.NET 2.5 enhances its WebDialogBox to be able to access ContentTemplate from code behind, keep the dialog box visible in scrollable page and customize the background color of the shadow.

  • For more information, see WebDialogBox.

WebMenu

With its new feature, WebMenu is able to build a pixel-identical menu design that is similar to today's modern designs such as Vista Explorer or Office 2007.

  • For more information, see WebMenu.

WebButton

WebButton enhances its mouse state interactivity, complex images and DropDown menu support.

  • For more information, see WebButton.

Opera and Safari

WebDesktop.NET 2.5 implements extensive support for more widely used browsers such as Opera and Safari.

  • For more information, see Support for Opera 9.5 and Safari 3.0 browsers.


WebDesktopManager

WebDesktopManager
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.5 > WebDesktopManager

Glossary Item Box

This section contains information on the new added Shadow mode in WebDesktopManager 2.5 component.

In This Section

Shadow mode support for window moving and resizing
Read about moving and resizing windows in shadow mode.

Vista-style animation
Read about using vista-style zoom animation when open or close a WebDesktopWindow.

See Also

Other Resources
{What's New in 2.5}


Shadow mode support for window moving and resizing

Shadow mode support for window moving and resizing
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.5 > WebDesktopManager > Shadow mode support for window moving and resizing

Glossary Item Box

This new feature enables window moving and resizing operation to be performed in shadowing mode. That means the actual window will not be taken affect until the operation is done. During the interactive mode, only the shadow of the actual window will be displayed to indicate the current status of the interaction.

Unlike Physical interactivity mode which is the default value and the mode used in previous version, Shadow interactivity mode is significantly faster. It enables the window interaction such as moving and resizing to be performed in a very smooth and robust manner.

This new interactivity mode introduces several advantages:

  • Significantly faster performance while moving and resizing window. This is made possible because the heavy contents are not re-rendered during the interaction.
  • 100% smooth and robust interaction even with a lot of IFrame-kind of window content. This means, the window can still be smoothly moved and resized even though it is on the top of other IFrame windows. This was one limitation in previous "physical interaction" mode.
  • Avoided "resize bogus" and improved resizing stability in Mozilla. Most components today extensively using onresize event to handle the layout and rendering when a container is being resized. The "physical interaction" is surely a performance killer because the onresize events that attached to the resized window will be called massively and continuously. This problem is nothing to worry with the new interactivity mode.

The following is a sample screenshot when the "Stocks Application" window is resized downward:

To change the interactivity mode to Shadow, simply set the WindowInteractiveMode to Shadow in the WebDesktopManager instance.

There are two new properties related to this feature:

  1. ShadowModeAnimation
    The default value is false. This property allows you to add nice fading effect when the moving and resizing is performed in Shadow mode. However, the animation effect is not suitable for complex Web application as it could slow down the screen rendering while performing interaction.
  2. ShadowModeTransparency
    By default, the desktop manager screen would be 100% transparent when the moving and resizing is performed in Shadow mode. When this property is set to true, the background of desktop manager will be dimmed to 50% transparent to give user better focus on the interactive operation. The above screenshot shows the ShadowModeTransparency enabled.

See Also

Other Resources
{Vista-style animation}


Vista-style animation

Vista-style animation
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.5 > WebDesktopManager > Vista-style animation

Glossary Item Box

The new WebDesktopManager now includes visually-compelling Vista-like animation when you open or close a WebDesktopWindow. When this feature is enabled, the window will be zoomed in when open (or being shown). Likewise, the window will be zoomed out of view when closed (or being hidden).

Note that this feature may require better hardware specification at the end user side as it used system resources heavily. However, this feature still has a constant and good performance when used in Internet Explorer, Opera and Safari. In Firefox, this feature will cause significant performance issue especially when there are a lot of objects in the background.

See Also

Tasks
{How-to: Enable Vista-style zoom animation in WebDesktopManager}

Other Resources
{Shadow mode support for window moving and resizing}


How-to: Enable Vista-style zoom animation in WebDesktopManager

How-to: Enable Vista-style zoom animation in WebDesktopManager
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.5 > WebDesktopManager > Vista-style animation > How-to: Enable Vista-style zoom animation in WebDesktopManager

Glossary Item Box

WebDesktopManager introduces new animation style when opening or closing a WebDesktopWindow, it is called VistaStyleZoom.

This topic shows how to enable vista-style zoom animation from WebDesktopManager's Properties.

To enable vista-style zoom animation

  1. Right click on WebDesktopManager control and choose Properties.
  2. Set EnableAnimation to True.
  3. Set AnimationStyle to VistaStyleZoom.
  4. Vista-style zoom animation will be applied when you open or close the WebDesktopWindow.

See Also

Concepts
{Vista-style animation}


WebDialogBox

WebDialogBox
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.5 > WebDialogBox

Glossary Item Box

This section contains information on the new enhancements in WebDialogBox 2.5 component.

In This Section

Direct Control Access in Template
Read about this new enhancement that enables developer to use ContentTemplate from code behind directly.

Keep Visible on Scroll
Read about WebDialogBox's ability to keep visible in scrollable page.

Background Shadow Color and Opacity
Information on how to customize the background color's shadow and opacity to let end users easily focus on the dialog box.

Show Dialog with Animation
Read about the enhancement on ShowDialog() method to enable animation in WebDialogBox.

Modeless mode
Read about setting WebDialogBox to use Modeless mode, so the background object will no longer be blocked while you interact with web page.

Vista-style animation
Read about using vista-style zoom animation when a WebDialogBox is showing and closing.

See Also

Other Resources
{What's New in 2.5}


Direct Control Access in Template

Direct Control Access in Template
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.5 > WebDialogBox > Direct Control Access in Template

Glossary Item Box

This new enhancement enables developers to access the controls in the DialogBox's ContentTemplate directly in the code behind without have to use FindControl method. This enhancements increases code efficiency and reduce complexity. It also avoid the need to perform casting.

If you have developed Web form using the previous version of WebDialogBox, your Web form should be able to run properly without the need to perform upgrades. However, it is highly recommended that you take advantage of the benefits introduced with this new enhancement.
Previously, you will need the following codes to access a server control in ContentTemplate of a WebDialogBox:
C# Copy Image Copy Code
DropDownListdropdown = (DropDownList)dlgBox.FindControl("DropDownList1");

dropdown.Items.Add(new ListItem("Item 1", "Item 1"));

Now, you only need a single line of code:

C# Copy Code
this.DropDownList1.Items.Add(new ListItem("Item 1", "Item 1"));

See Also

Related Sections
Keep Visible On Scroll
Background Shadow Color and Opacity
Show Dialog with Animation
Modeless mode
Vista-style animation

Other Resources
V2.5


Keep Visible On Scroll

Keep Visible On Scroll
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.5 > WebDialogBox > Keep Visible On Scroll

Glossary Item Box

While WebDialogBox is best used in a Web page with no scrollbars, there are some scenarios where you will need to show dialog box in scrollable page. For instance, in a product information page or feature page.

With this new feature, you can keep WebDialogBox to stay visible when user is scrolling throughout the page. To enable this feature, simply set KeepVisibleOnScroll property to True. This property is set to False by default to preserve compatibility with existing applications.

See Also

Related Sections
Direct Control Access in Template
Background Shadow Color and Opacity
Show Dialog with Animation
{Modeless mode}
{Vista-style animation}

Other Resources
{What's New in 2.5}


Background Shadow Color and Opacity

Background Shadow Color and Opacity
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.5 > WebDialogBox > Background Shadow Color and Opacity

Glossary Item Box

By default, when a WebDialogBox is shown, the background of the parent window will be blocked in the way that it does not accept mouse clicks, which simulates desktop application. The background is set to Transparent by default, and is not customizable in the previous version.

In this new version, you can now customize the background color of the shadow, as well as the transparency opacity. These new additions allow you to dim out the background screen to let end users easily focus on the dialog box.
To set the background shadow color, set the ShadowColor property to a valid color. To change the transparency opacity, set the ShadowOpacity to a valid transparency level. The minimum is 0 which means opaque, and the maximum is 100 which means fully transparent. The default value for the opacity is 50.
The following illustration shows the comparison between fully transparent background and dimmed background.
Without Shadow Color (Fully Transparent) With Shadow Color set to Gray, and Opacity set to 50%

See Also

Related Sections
Direct Control Access in Template
Keep Visible On Scroll
Show Dialog with Animation
{Modeless mode}
{Vista-style animation}

Other Resources
{What's New in 2.5}


Show Dialog with Animation

Show Dialog with Animation
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.5 > WebDialogBox > Show Dialog with Animation

Glossary Item Box

The WebDialogBox now supports ExpandShrink type animation when showing a dialogbox from client codes. The animation is always a nice addition to give smooth and professional impression to your Web application.

The enhancement is made to the ShowDialog method of the WebDialogBox class. The method now introduces two new parameters: enableAnimation and fromElement.

Syntax:
[webDialogBoxInstance].ShowDialog(enableAnimation, fromElement);

enableAnimation is a boolean value indicating whether animation should be performed.

fromElement is a HTML element where the animation should start from.

Sample:

JavaScript Copy Image Copy Code
divEl = document.getElementById(�??div1�?�);
webDialogBox1.ShowDialog(true, divEl);

The EnableAnimation property of the WebDialogBox need to be set to True from the server side.

See Also

Related Sections
Direct Control Access in Template
Keep Visible On Scroll
Background Shadow Color and Opacity
{Modeless mode}
{Vista-style animation}

Other Resources
{What's New in 2.5}


Modeless mode

Modeless mode
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.5 > WebDialogBox > Modeless mode

Glossary Item Box

The WebDialogBox has been further improved with enhancements such as Modeless mode. In this new release, you can set the WebDialogBox to use Modeless mode, instead of Modal mode which is set by default.

When the WebDialogBox is using Modeless mode, the background objects will no longer be blocked. This allows you to interact with the Webpage while the WebDialogBox is active. Several examples of common scenarios that used this mode are such as using WebDialogBox as a tool window or using WebDialogBox as floating navigation bar, or moveable side bar.

See Also

Tasks
{How-to: Set WebDialogBox to Modeless mode}

Other Resources
{Direct Control Access in Template}
{Keep Visible On Scroll}
{Background Shadow Color and Opacity}
{Show Dialog with Animation}
{Vista-style animation}


How-to: Set WebDialogBox to Modeless mode

How-to: Set WebDialogBox to Modeless mode
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.5 > WebDialogBox > Modeless mode > How-to: Set WebDialogBox to Modeless mode

Glossary Item Box

WebDialogBox improves its feature to be able to use Modeless mode. With this feature enabled, you can interact with the background object.

This topic shows how to use WebDialogBox in modeless mode from its Properties.

To set WebDialogBox to Modeless mode

  1. Right click on WebDialogBox control and choose Properties.
  2. Set IsModal to False.
  3. Now, WebDialogBox is set to Modeless mode. When the WebDialogBox control is shown, you are able to interact with other objects in the background.

See Also

Concepts
{Modeless mode}


Vista-style animation

Vista-style animation
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.5 > WebDialogBox > Vista-style animation

Glossary Item Box

As in WebDesktopManager, the new WebDialogBox is also featuring Vista-style zoom animation when the WebDialogBox is showing and closing. This visually compelling animation allows end users to easily notice on the dialog box appearance, which dramatically enhances user experience.

Note that this feature may require better hardware specification at the end user side as it used system resources heavily. However, this feature still has a constant and good performance when used in Internet Explorer, Opera and Safari. In Firefox, this feature will cause significant performance issue especially when there are a lot of objects in the background.

See Also

Tasks
{How-to: Enable Vista-style zoom animation in WebDialogBox}

Concepts
{Vista-style animation}


How-to: Enable Vista-style zoom animation in WebDialogBox

How-to: Enable Vista-style zoom animation in WebDialogBox
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.5 > WebDialogBox > Vista-style animation > How-to: Enable Vista-style zoom animation in WebDialogBox

Glossary Item Box

WebDialogBox introduces new animation style when opening the dialog box, it is called VistaStyleZoom.

This topic shows how to enable vista-style zoom animation from WebDialogBox's Properties.

To enable vista-style zoom animation

  1. Right click on WebDialogBox control and choose Properties.
  2. Set EnableAnimation to True.
  3. Set AnimationStyle to VistaStyleZoom.
  4. Vista-style zoom animation will be applied when you open the WebDialogBox.

See Also

Concepts
{Vista-style animation}


WebMenu

WebMenu
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.5 > WebMenu

Glossary Item Box

This section contains information on the new features in WebMenu 2.5 component.

In This Section

Complex Images for Menu Item Style
Read about this new feature that enables you to use complex images in WebMenu.

Cosmetic Label Menu Item
Read about this new feature that provides ability to insert cosmetic and non selectable menu item.

Template Support for Menu Item
Read about its ability to use template inside Menu Item.

New Themes
Read about the new fluid and pixel-identical styles in WebMenu.

Quadratic Sliding Animation
Read about the latest added animation effect, that is Quadratic sliding animation.

See Also

Other Resources
{What's New in 2.5}


Complex Images for Menu Item Style

Complex Images for Menu Item Style
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.5 > WebMenu > Complex Images for Menu Item Style

Glossary Item Box

With this new feature, you can now build visually compelling design for your Web application's menu navigation. The complex images allow you to specify the images needed by the WebMenu to render the menu item. This enables you to build a pixel-identical menu design that is similar to today's modern designs such as Vista Explorer or Office 2007.

The complex images concept consists of three parts:

  • Left
  • Center
  • Right

All parts' image should have exactly the same dimension especially the height to deliver consistent and reliable design.

To enable complex images highlight, simply set HighlightMode property (inside MenuStyleSettings) to UseComplexImages.

The complex images can be specified in the ImagesSettings of the MenuStyleSettings object. MenuStyleSettings is available in all UI components that implement WebMenu interface, such as WebContextMenu, WebToolBar, WebMenuBar and WebNotification.
Sample ASPX declaration:
Component's Tags Copy Code
<ISWebDesktop:WebContextMenu ID="WebContextMenu1" runat="server" ControlId="Page">
   <MenuStyleSettings BackgroundStripColor2=""
           BackgroundStripImage="o7_menu_strip.gif"
           MenuAnimation="True" MenuDropShadow="True" MenuWindowType="Normal"
           BackgroundStripWidth="26"
           IconCellWidth="25" HighlightMode="UseComplexImages">
       ...<Other Styles Here>
       <ImagesSettings OverCenter="o7_menu_oc.gif" OverLeft="o7_menu_ol.gif"
           OverRight="o7_menu_or.gif"
           ActiveIconCell="o7_icon_active.gif" />
      </MenuStyleSettings>
      <Items>
             <ISWebDesktop:WebMenuItem Name="mnuCut" Text="Cut"
             ImageURL="images/cut.gif">
             </ISWebDesktop:WebMenuItem>
             ...
      </Items>
</ISWebDesktop:WebContextMenu>

Design concept illustration:

The layout, styling and rendering process is automatic based on the specified ImagesSettings. All you need is to provide the images needed by the complex images, and WebMenu will automatically arrange the layouting, margins, padding, repeating, edging, and other behaviors.

See Also

Tasks
{Walkthrough: Enabling complex images in WebContextMenu}
{Walkthrough topics}
{FAQ and How-to topics}

Related Sections
Cosmetic Label Menu Item
Template Support for Menu Item
New Themes
{Quadratic Sliding Animation}

Other Resources
{What's New in 2.5}


Walkthrough: Enabling complex images in WebContextMenu

Walkthrough: Enabling complex images in WebContextMenu
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.5 > WebMenu > Complex Images for Menu Item Style > Walkthrough: Enabling complex images in WebContextMenu

Glossary Item Box

This walkthrough shows you how to enable complex images in WebContextMenu.

During this walkthrough, you will learn how to do the following:

  • Use complex images in WebContextMenu.
  • Set images to the WebContextMenu.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Visual Studio 2005 Application.

Step-By-Step Instructions

To enable complex images in WebContextMenu.

  1. Launch Visual Studio.NET 2005.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. Create images to be set to WebContextMenu's ImageSettings as the ActiveIconCell's image, OverCenter's image, OverLeft's image and OverRight's image.
  8. Create an image to be set as WebContextMenu's BackgroundStripImage. In this walkthrough, you will use vista_icon_active.gif as ActiveIconCell's image, vista_menu_oc.gif as OverCenter's images, vista_menu_ol.gif as OverLeft's image, vista_menu_or.gif as OverRight's image and vista_menu_strip.gif as BackgroundStripImage.
  9. Copy the images that you have created to the application folder.
  10. Drag a TextBox to the WebForm (used for WebContextMenu's controlID).
  11. Drag a WebContextMenu control to the WebForm.
  12. Click the WebContextMenu's WebMenuBuilder to open the MenuBuilder window.

  13. Customize the menu like following:

  14. Go to WebContextMenu's properties >> MenuStyleSettings and set the following properties:

    Property Name | Value
    BackgroundStripColor | 240, 240, 240
    BackgroundStripImage | vista_menu_strip.gif
    HighlightDisableItem | True
    HighLightMode | UseComplexImages
    IconCellWidth | 27
    MenuAnimation | True
    MenuWindowType | Normal

  15. Go to WebContextMenu's properties >> MenuStyleSettings >> ImagesSettings and set the following images:

    Property Name | Value
    ActiveIconCell | vista_icon_active.gif
    OverCenter | vista_menu_oc.gif
    OverLeft | vista_menu_ol.gif
    OverRight | vista_menu_or.gif

  16. Run the application and you will have a TextBox's ContextMenu like the following

See Also

Tasks
{Walkthrough topics}
{FAQ and How-to topics}

Concepts
{Complex Images for Menu Item Style}


Cosmetic Label Menu Item

Cosmetic Label Menu Item
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.5 > WebMenu > Cosmetic Label Menu Item

Glossary Item Box

This new feature provides ability for developers to insert cosmetic, non selectable menu item. This label-like menu item is very useful and suitable to be used as a group header, or to provide a simple explanation about the menu items beneath it.

In Office 2007, oftentimes we find this kind of cosmetic menu item, such as shown in the following image.

To use label menu item type, simply set the Type of the menu item to Custom. You can also customize the style and appearance of the custom menu item by accessing the CustomStyle in MenuSettings object of the control instance.

See Also

Related Sections
Complex Images for Menu Item Style
Template Support for Menu Item
New Themes
Quadratic Sliding Animation

Other Resources
{What's New in 2.5}


Template Support for Menu Item

Template Support for Menu Item
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.5 > WebMenu > Template Support for Menu Item

Glossary Item Box

The ability to use template inside Menu Item has been added in this new release of WebMenu. With templating, you can put any html or server-side controls to the menu item's cell content. This allows you to create efficient and richer navigation concept for your Web application.

To use Template, set the Type of the menu item to Template. Next, in the Visual Studio 2005 designer, right click on the control instance and choose Edit Templates > Items. Finally you will see the region's surface where you can perform editing. See the following screenshot for more details.

See Also

Related Sections
Complex Images for Menu Item Style
Cosmetic Label Menu Item
New Themes
{Quadratic Sliding Animation}

Other Resources
{What's New in 2.5}


New Themes

New Themes
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.5 > WebMenu > New Themes

Glossary Item Box

With the new features such as complex images, template support and new client side APIs added in this new version, you can now deliver fluid and pixel-identical styles and designs. Fluid means that the appearance should be consistent and looking good regardless of the size of the text or width of the control.

Two new designs are now possible to be achieved:

  • Pixel-Perfect Fluid Vista Style

  • Pixel-Perfect Fluid Office 2007 Style

See Also

Related Sections
Complex Images for Menu Item Style
Cosmetic Label Menu Item
Template Support for Menu Item
{Quadratic Sliding Animation}

Other Resources
{What's New in 2.5}


Quadratic Sliding Animation

Quadratic Sliding Animation
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.5 > WebMenu > Quadratic Sliding Animation

Glossary Item Box

In the previous release, we introduced a nice Fading animation effect to WebMenu system component. As one of the initiative in 2008 release, we have added more animation effects and apply it consistently to applicable components and scenarios.

The improved WebMenu now features Quadratic sliding animation. This type of animation quickly adds elegant image to your Web application as the menu smoothly sliding from the left or bottom direction depend on the menu position. The sliding animation is using quadratic acceleration logic, which is an enhanced acceleration algorithm to achieve elegant and high-performance animation.

See Also

Tasks
{How-to: Enable quadratic sliding animation}

Other Resources
{Complex Images for Menu Item Style}
{Cosmetic Label Menu Item}
{Template Support for Menu Item}
{New Themes}


New SmartWebResources™ Framework

New SmartWebResources™ Framework
Send Feedback

Glossary Item Box

At Intersoft Solutions, we constantly conduct extensive research and development to deliver new innovations that help developers become more productive by reducing the efforts and overwhelming complexity in both development and deployment stage.

The brand-new SmartWebResources�?� Framework is one of the exciting technology that we had to offer in 2007 R1 platform. The key objective of SmartWebResources�?� is to eliminate the external physical resources �?? such as scripts, images, etc �?? which required by web components to function properly.

Problems introduced in traditional web components approach

Most web components require client resources such as scripts, images, stylesheets and other client files to gear up some advanced and powerful features. Normally these client resources are delivered through physical client files. In ASP.NET, these files may be located in aspnet_client folder or other common folder which needs to be mapped properly into IIS virtual path in order to function properly.

There are several issues with this traditional approach which causing inefficiency, such as:

  • Special IIS virtual directory is required to store the client resources. In several webhosting that does not support manual virtual directory setup, this can be a significant deployment problem.
  • Special attention and more efforts are required during deployment.
  • Versioning problems. This could cause overwhelming complexity while maintaining the versions of the client resources for specific components.
  • Complexity in maintaining control-specific�??s resources folder. For instance, some scripts are located in folder X, images in folder Y, and other scripts in folder Z.

The solution

The solution to the several issues mentioned above can be achieved by eliminating the requirements to use physical client resources. Thanks to the new SmartWebResources�?� Framework, the physical client resources can be completely eliminated.

The client resources are still required in our web components. It is just they are now stored in �??virtual location�?� which does not require the awareness of developers. They are fetched and delivered to client (browsers) in a new, different way.


How does SmartWebResources™ work

How does SmartWebResources™ work
Send Feedback

Glossary Item Box

Each product has their own resources such as scripts and images. For instance, previously these resources are stored in /CommonLibrary/Shared for core framework resources. WebGrid�??s resources are stored in /CommonLibrary/WebGrid/v4_0_6200.

With SmartWebResources, they are now embedded into .NET assembly. Unlike ASP.NET�??s built-in Web Resources which embeds client resources in main assembly, SmartWebResources stores each product�??s client resources in separate assembly. This enables flexible update (maintenance) to the client resources without has to rebuild the main server-side assembly.
SmartWebResources implements each product�??s client resources as separate resources assembly. Each product that supports SmartWebResources technology will have a companion resources assembly. The resources assembly commonly has this format: [ProductAssemblyFullName].Resources.dll.
For instance, the assembly hierarchy for WebCombo.NET 4.0 looks like in the following illustration:

The SmartWebResources works by intercepting the HTTP request through custom HTTP handler that extended in the Framework runtime. The SmartWebResources will then dispatch the request and automatically determining the correct resources assembly, then finally fetching the resource from the assembly and deliver it to the client.
The way it works can be seen in the following illustration:

With SmartWebResources enabled, you no longer need to aware what you should do to configure the client scripts virtual directory, or where to locate/store it. You simply ensure that the resources assemblies are in the Bin folder of your application. For more information, read How-to: Configure SmartWebResources in a new web application.


Features and benefits introduced by SmartWebResources™

Features and benefits introduced by SmartWebResources™
Send Feedback

Glossary Item Box

Here are lists of all features and benefits in SmartWebResources�?�:

  • Better throughput: IIS6 Kernel-level Caching
  • More secure: Does not use query string
  • Faster performance: Does not use Reflection. The SmartWebResources does not use WebResourceAttribute mechanism, so avoiding the needs to use Reflection.
  • Smaller output: Simpler path formatting and does not use long-encrypted string. For instance, the built-in ASP.NET 2.0�??s Web Resource commonly produced a web resource url such as /WebResource.axd?d=X3DBWN0WSNooBvJskjFXaHbLs_89EdATLyWdaCXXWBuO_EqnAFr_Di1ag4ubAsDdMu4h_k0tff_bX4YhT_csWQ2&t=632939437740000000. In SmartWebResources, the output url format is as simple as /ISRes.axd?C/WebCombo.js/4072001
  • Hassle-free Deployment: No more external client resources are required during deployment. Only one assembly is required to be copied into your app's bin folder.
  • Reduced Complexity: SmartWebResources includes automatic web resources configuration. When in auto mode, the client resources will be retrieved from Web Resources assembly whenever possible. Otherwise, it will automatically fallback the retrieval from traditional external resources which stored in IIS virtual directory (also known as CommonLibrary)
  • Easy to Configure: Easily configure the settings from application level. You can also customize the settings for individual control's instances for more precise control.
  • Flexibility: You can easily switch between SmartWebResources or external resources mode through EnableWebResources setting.
  • Seamless integration with VS 2005: The handlers and resources configuration can seamlessly added to your web application configuration.
  • FileSystem Project Support: For better design-time experience in FileSystem web project, the image resources are now properly displayed in the Visual Studio 2005 designer. Thanks to SmartWebResources Framework that provides automatic url conversion mechanism in design-time.


How-to: Enable quadratic sliding animation

How-to: Enable quadratic sliding animation
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.5 > WebMenu > Quadratic Sliding Animation > How-to: Enable quadratic sliding animation

Glossary Item Box

Previously, WebMenu has come up with its fading effect. Now, WebMenu adds a new quadratic sliding effect to give an elegant and high performance animation to your Web application.

This topic shows how to set quadratic sliding animation from WebMenu's Properties.

To enable quadratic sliding animation

  1. Right click on WebMenu control and choose Properties.
  2. Expand MenuStyleSettings.
  3. Set MenuAnimation to True, MenuAnimationMode to Sliding and MenuWindowType to Normal.

See Also

Concepts
{Quadratic Sliding Animation}


WebButton

WebButton
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.5 > WebButton

Glossary Item Box

WebButton has come up with its new features and enhancements, which are:

  • Enhanced mouse state interactivity
  • Complex Images
  • DropDown Menu Support

See Also

Other Resources
{What's New in 2.5}


What's New in WebDesktop

What's New in WebDesktop
See Also Send Feedback

Glossary Item Box

This section summarizes features and enhancements that have been added or modified in the latest versions of WebDesktop.NET.

In This Section

What's New in WebDesktop V2.5
Describes the latest features and enhancements in version 2.5.

What's New in WebDesktop V2.0
Describes the latest features and enhancements version 2.0.

See Also

Tasks
{Walkthrough topics}
{FAQ and How-to topics}

Other Resources
WebDesktop Overview


Features

Features
Send Feedback
Intersoft WebDesktop > Release History > V2.5 > Features

Glossary Item Box

WebSplitter is a member of the WebDesktop.NET which plays a significant role in the suite. WebSplitter control has a tight integration to WebPaneManager to bring a new standard in Web Layouting. The WebSplitter control is often used on table with contents have varying lengths of data to present, which needs more dynamic navigation to resize the panes.

Since most of the web-applications layout is based on HTML table-element to align the contents, WebSplitter control is built to add more dynamically feature to HTML table-element. It doesn't need to change the existing layout, simply add one additional cell between the two cells you want to split, then drag and drop the WebSplitter control inside that cell. That makes the WebSplitter control is easily to apply and configure.

Following are some key features of the control:

  • Vertical/Horizontal cell splitting.

WebSplitter supports two type of cell splitting, vertical and horizontal.

  • Colspan/Rowspan support.

WebSplitter offers automatic cell splitting scenario supporting rowspan and colspan.

  • Expand/Collapse with one click button.

WebSplitter offers expand and collapse feature to easily resize the pane to its minimum size and restore it back to its previous state by clicking on the grip button.

AllowCollapse feature related properties

Following is a brief descriptions of related properties to AllowCollapse feature:

  • AllowCollapse:

Specify whether the WebSplitter is able to collapse

  • CollapseDirection:

Specify the direction of collapse either to "panel1" or "panel2"

  • GripImageCollapse:

Specify the image for the grip. The image shown when the Panel is not collapse yet.

  • GripImageRestore:

Specify the image for the grip. The image shown when the Panel is already collapsed.

  • Panel1Min:

Specify the minimum size of panel I. (pixel size)
This property also determines the size of the panel I being collapsed (if the CollapseDirection is set to "panel1")

  • Panel2Min:

Specify the minimum size of panel II. (pixel size)
This property also determines the size of the panel II being collapsed (if the CollapseDirection is set to "panel2")

  • Intelligent resizing mechanism.

Enabling accurate unit measurement which returns the original unit type. for example, if the cell is in percentage (%) size, when it got resized, the unit measurement will still be in %. Thus the layout design still consistent if the browser window got resized.

As you can see in image A compares to image B, the Pane size proportionally resized as the window browser got resized. The image below illustrates it.

  • IFrame-support resizing.

WebSplitter works smoothly on the panel in which its content is iframe(s), as illustrated in image below.


Tutorials

Tutorials
Send Feedback
Intersoft WebDesktop > Release History > V2.5 > WebSplitter > Tutorials

Glossary Item Box

This section contains tutorial topics in WebSplitter.

In This Section

Using WebSplitter to split basic two cells

Using WebSplitter to split two rows

Configuring WebSplitter Interactive Styles

Using AllowCollapse feature

How-to: Split Cells


Using WebSplitter to split two rows

Using WebSplitter to split two rows
Send Feedback
Intersoft WebDesktop > Release History > V2.5 > WebSplitter > Tutorials > Using WebSplitter to split two rows

Glossary Item Box

Objectives:

Add Horizontal WebSplitter between 2 cells of row, simply by adding a cell between two rows and drag and drop the WebSplitter onto it.

  1. Presume there are already two cells in the row you want to split
  2. Add a new cell between the cells you want to split.

  3. Drag and drop the WebSplitter control into the cell you have just created
  4. Set the orientation property to horizontal, and other properties to set the control's behavior and design


Using WebSplitter to split basic two cells

Using WebSplitter to split basic two cells
Send Feedback
Intersoft WebDesktop > Release History > V2.5 > WebSplitter > Tutorials > Using WebSplitter to split basic two cells

Glossary Item Box

Splitting two simple cells

Objectives

Adding a Vertical WebSplitter between 2 cells, simply by adding a new cell between the cells you want to split and drag and drop the WebSplitter control into that cell.

  1. Presume there's already two cells of column you want to split

    Make sure the table's style attribute has: "table-layout: fixed".

    <TABLE id="Table1" style="TABLE-LAYOUT: fixed" height="300" cellSpacing="0" cellPadding="0" width="300" border="0">
    ...
    </TABLE>

  2. Add another cell between the cells you want to split.

    It does not need to specify any attributes because this cell only used as a placeholder of the WebSplitter control. Any settings are on the control itself.

  3. Drag and drop the WebSplitter from the toolbox control into the cell you have just created
  4. Since the orientation property's default value is set to vertical, there is no need to change it. Simply customize other properties to set the control's behavior and design.
  5. View in browser or run the page.

Splitting two columns with rowspan

Objectives

Demonstrate the WebSplitter feature of supporting colspan/rowspan by adding a Vertical WebSplitter between 2 columns using rowspan.

Use nested table to create a complicated layout of page instead of using colspan/rowspan
  1. Presume there's already a table using rowspan
    <TABLE id="Table1" style="TABLE-LAYOUT: fixed" height="300" cellSpacing="0" cellPadding="0" width="300" border="0">
    <TR>

    <TD rowspan="2" bgColor="#ccffcc">Panel I</TD>

    <TD bgColor="#ffffcc" width="30%">Panel IIa</TD>

    </TR>

    <TR><TD bgColor="#ffcc66">Panel IIb</TD></TR>
    </TABLE>

  2. Add another cell between the two columns, so the html code looks like this:

    <TABLE id="Table1" style="TABLE-LAYOUT: fixed" height="300" cellSpacing="0" cellPadding="0" width="300" border="0">
    <TR>

    <TD rowspan="2" bgColor="#ccffcc">Panel I</TD>

    <TD rowspan="2" style="Width: 40px"></TD>

    <TD bgColor="#ffffcc" width="30%">Panel IIa</TD>

    </TR>

    <TR><TD bgColor="#ffcc66">Panel IIb</TD></TR>
    </TABLE>

  3. Drag and drop the WebSplitter from the toolbox control onto the cell that you have just created, and customize the style as you like, illustrated in the below image:
    Cell of the WebSplitter (WebSplitter placeholder)
    Vertical WebSplitter

    You may resize the cell of the WebSplitter in design time as it will not be affecting the runtime layout. The size of the WebSplitter is set from the WebSplitter's property of Size
  4. View in browser or run the page.


Configuring WebSplitter Interactive Styles

Configuring WebSplitter Interactive Styles
Send Feedback
Intersoft WebDesktop > Release History > V2.5 > WebSplitter > Tutorials > Configuring WebSplitter Interactive Styles

Glossary Item Box

Objectives:

Adding and configuring Horizontal WebSplitter with interactive styles between two cells of row.

  1. Drag and drop the WebSplitter from the toolbox control onto the cell between two cells of row you want to split.
  2. Open the Property box window to configure the WebSplitter styles in SplitterStyle property. (shown in the image below)

SplitterStyle is a DynamicStyle property.

DynamicStyle is built around the WebStyle object, and consists of 3 states of interactivity: Normal, Over and Active.

  • Normal.

The default style of the WebSplitter.

  • Over.

The style of the WebSplitter being hovered.

  • Active.

The style when the WebSplitter is in the state of being dragged.

Each of the states in DynamicStyle is WebStyle object, as you can see in the below image there are some properties you can adjust. Following is a brief descriptions of commonly used properties:

  • BackColor : set the color of the WebSplitter.
  • BackColor2 : set the alternate color of the WebSplitter for gradient color, relates to GradientType property.
  • Cursor : the type of mouse pointer when the WebSplitter being hovered.
  • Overflow, OverflowX and OverflowY should be set to hidden for consistent layout especially not in IE browser.


Using AllowCollapse feature

Using AllowCollapse feature
Send Feedback
Intersoft WebDesktop > Release History > V2.5 > WebSplitter > Tutorials > Using AllowCollapse feature

Glossary Item Box

WebSplitter offers expand and collapse feature to easily resize the pane to its minimum size and restore it back to its previous state by clicking on the grip button.

This topic will show you how to use AllowCollapse feature.

To use AllowCollapse feature

  1. Create a table with two cells.
  2. Add another cell between the cells you want to split.
  3. Drag and drop the WebSplitter control into the cell that just created.
    <table style="table-layout: fixed; height: 300px; border-collapse: collapse;">
<tr>
   <td style="background-color: Yellow; width: 100px;">
       Panel 1
   </td>
   <td style="width: 100px">
      <ISWebDesktop:WebSplitter ID="WebSplitter1" runat="server" GripImageCollapse="../Images/dot_v.gif"
      GripImageRestore="../Images/dot_v.gif">
         <SplitterStyle>
            <Active BaseStyle="Normal" BackColor="Black">
            </Active>
            <Normal Overflow="Hidden" OverflowY="Hidden" OverflowX="Hidden" BackColor="Gray">
            </Normal>
            <Over BaseStyle="Normal">
            </Over>
         </SplitterStyle>
      </ISWebDesktop:WebSplitter>
   </td>
   <td style="background-color: Red; width: 100px;">
         Panel 2
   </td>
</tr>
  4. Set Orientation to Vertical and AllowCollapse to True. You can also set Orientation to Horizontal when you want to split rows using splitter.
  5. Set CollapseDirection to either Panel1 or Panel2. It depends on which panel you want to collapse.
  6. Set the GripImageCollapse and GripImageRestore for the grip images.
  7. You could set the minimum size of Panel 1 or Panel 2 when being collapsed in Panel1Min or Panel2Min property. (the default value is 1 pixel)


How-to: Split Cells

How-to: Split Cells
Send Feedback
Intersoft WebDesktop > Release History > V2.5 > WebSplitter > Tutorials > How-to: Split Cells

Glossary Item Box

WebSplitter supports two type of cell splitting, vertical and horizontal. It also supports rowspan and colspan.

This topic will show you how to split cells.

To split two cells

  1. Create a table with two cells.
  2. Add another cell between the cells you want to split.
  3. Drag and drop the WebSplitter control into the cell that just created.
    <table style="table-layout: fixed; height: 300px; border-collapse: collapse;">
<tr>
   <td style="background-color: Yellow; width: 100px;">
       Panel 1
   </td>
   <td style="width: 100px">
      <ISWebDesktop:WebSplitter ID="WebSplitter1" runat="server" GripImageCollapse="../Images/dot_v.gif"
      GripImageRestore="../Images/dot_v.gif">
         <SplitterStyle>
            <Active BaseStyle="Normal" BackColor="Black">
            </Active>
            <Normal Overflow="Hidden" OverflowY="Hidden" OverflowX="Hidden" BackColor="Gray">
            </Normal>
            <Over BaseStyle="Normal">
            </Over>
         </SplitterStyle>
      </ISWebDesktop:WebSplitter>
   </td>
   <td style="background-color: Red; width: 100px;">
         Panel 2
   </td>
</tr>
  4. Set Orientation to Vertical and AllowCollapse to True.
  5. Set CollapseDirection to either Panel1 or Panel2. It depends on which panel you want to collapse.
  6. Set the GripImageCollapse and GripImageRestore for the grip images.
  7. You could set the minimum size of Panel 1 or Panel 2 when being collapsed in Panel1Min or Panel2Min property. (the default value is 1 pixel)

To split two rows

  1. Create a table with two cells.
  2. Add another cell between the cells you want to split.
  3. Drag and drop the WebSplitter control into the cell that just created.

    <table style="table-layout: fixed; height: 200px; border-collapse: collapse;">
    <tr>
    <td style="background-color: Teal; width: 300px;">
    Panel 1
    </td>
    </tr>
    <tr>
    <td>
    <ISWebDesktop:WebSplitter ID="WebSplitter2" runat="server" Orientation="Horizontal"
    GripImageCollapse="../images/dot.gif" GripImageRestore="../images/dot.gif">
    <SplitterStyle>
    <Active BaseStyle="Normal" BackColor="Black">
    </Active>
    <Normal Overflow="Hidden" OverflowY="Hidden" OverflowX="Hidden" BackColor="Gray">
    </Normal>
    <Over BaseStyle="Normal">
    </Over>
    </SplitterStyle>
    </ISWebDesktop:WebSplitter>
    </td>
    </tr>
    <tr>
    <td style="background-color: Yellow; width: 300px;">
    Panel 2
    </td>
    </tr>
    </table>

  4. Set Orientation to Horizontal and AllowCollapse to True.
  5. Set CollapseDirection to either Panel1 or Panel2. It depends on which panel you want to collapse.
  6. Set the GripImageCollapse and GripImageRestore for the grip images.
  7. You could set the minimum size of Panel 1 or Panel 2 when being collapsed in Panel1Min or Panel2Min property. (the default value is 1 pixel)

To split cells with rowspan

  1. Create a table with two cells using rowspan.
  2. Add another cell between the cells you want to split.
  3. Drag and drop the WebSplitter control into the cell that just created.

    <table style="table-layout: fixed; height: 300px; border-collapse: collapse;">
    <tr>
    <td rowspan="3" style="background-color: Yellow; width: 100px;">
    Panel 1
    </td>
    <td rowspan="3" style="width: 100px">
    <ISWebDesktop:WebSplitter ID="WebSplitter1" runat="server" GripImageCollapse="../Images/dot_v.gif"
    GripImageRestore="../Images/dot_v.gif" CollapseDirection="Panel2">
    <SplitterStyle>
    <Active BaseStyle="Normal" BackColor="Black">
    </Active>
    <Normal Overflow="Hidden" OverflowY="Hidden" OverflowX="Hidden" BackColor="Gray">
    </Normal>
    <Over BaseStyle="Normal">
    </Over>
    </SplitterStyle>
    </ISWebDesktop:WebSplitter>
    </td>
    <td style="background-color: Red; width: 100px;">
    Panel 2
    </td>
    </tr>
    <tr>
    <td style="background-color: Lime; width: 100px;">
    Panel 3
    </td>
    </tr>
    </table>

  4. Set Orientation to Vertical and AllowCollapse to True.
  5. Set CollapseDirection to either Panel1 or Panel2. It depends on which panel you want to collapse.
  6. Set the GripImageCollapse and GripImageRestore for the grip images.
  7. You could set the minimum size of Panel 1 or Panel 2 when being collapsed in Panel1Min or Panel2Min property. (the default value is 1 pixel)


Support for Opera 9.5 and Safari 3.0 browsers

Support for Opera 9.5 and Safari 3.0 browsers
Send Feedback
Intersoft WebDesktop > Release History > V2.5 > Support for Opera 9.5 and Safari 3.0 browsers

Glossary Item Box

The new WebDesktop takes desktop user experience to the next level by implementing extensive support for more widely used browsers such as Opera and Safari. The advanced technologies of WebDesktop such as PixelPerfect™ rendering, Hybrid Menu, XmlCompressor, CssOptimizer etc have been significantly enhanced to support these new browsers.

The following screenshot demonstrates WebDesktopManager with Office2007 Blue Theme in action using Opera 9.5 browser.

The following screenshot demonstrates WebDesktopManager with Office2007 Blue Theme in action using Safari 3.0 for Windows.

The support for Opera and Safari have been fully implemented and extensively tested to the following members of WebDesktop.NET 2.5:

  • WebDesktopManager
  • WebDialogBox
  • WebPaneManager
  • WebNotification
  • WebFlyPostBackManager
  • WebTab
  • WebDragDropExtender
  • WebExplorerPane
  • WebNavPane
  • WebContextMenu
  • WebMenu
  • WebToolBar
  • WebMenuBar
  • WebCallout


V2.0

V2.0
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.0

Glossary Item Box

This section describes the new features and technologies added in WebDesktop V2.0. Here are the following list of new features supported by WebDesktop V2.0:

WebMenu Runtime Engine

To overcome the limitation of displaying popup window type's content out of the browser's window boundary and to introduce other possible new features, the MenuWindowType is now added in WebMenu 2.0 Component.

  • For more information, see WebMenu Runtime Engine.

WebFlyPostBackManager Component

In WebDesktop 2.0, WebFlyPostBackManager takes you a step further by adding support to perform partial rendering over Intersoft's own components such as WebGrid, WebCombo, WebInput or any UI components in the WebDesktop.

  • For more information, see WebFlyPostBackManager Component.

WebNotification Component

WebDesktop 2.0 enhances its WebNotification to be able to send notification from the WebForm page's code behind without the needs to create additional WebService or other proxy resource.

  • For more information, see WebNotification Component.

SmartWebResources

WebDesktop 2.0 introduces SmartWebResources™ which is able to simplify the deployment process. No more copying javascript, component images and runtime files. You can simply copy the assemblies to the bin folder.

  • For more information, see SmartWebResources.

Styles

WebDesktop.NET 2.0 is strongly focused on new visual styles and appearance that based on Microsoft's latest user interface breakthrough, such as in Windows® Vista and Office 2007®.

  • For more information, see Styles.

Master Page Support

All components in WebDesktop.NET 2.0 have been refined to fully support Master Page in ASP.NET 2.0..

  • For more information, see Master Page Support.

Component Designer 2.0

WebDesktop 2.0 introduces a new level of rich component designer to help developer easily configure the advanced settings in WebDesktop.

  • For more information, see Component Designer 2.0.

See Also

Other Resources
{Upgrading from previous version}


WebMenu Runtime Engine

WebMenu Runtime Engine
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.0 > WebMenu Runtime Engine

Glossary Item Box

This section contains information on the new added MenuWindowType in WebMenu 2.0 component.

In This Section

Menu Window Type
Read about the new added Menu Window Type.

Fading Animation
Information on how to add smooth fading animation effect to all components based on WebMenu.

DropShadow Effect
Read about WebDesktop's ability to show dropshadow effect when displayed.

See Also

Other Resources
{What's New in 2.0}


Menu Window Type

Menu Window Type
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.0 > WebMenu Runtime Engine > Menu Window Type

Glossary Item Box

In previous version, components that used WebMenu Engine such as WebContextMenu, WebMenuBar, WebToolBar, WebDesktopManager and WebNotification will have its window displayed in a special "popup" type when running in Internet Explorer browser. This behavior is by default and unchangeable in previous version.

The main advantage of the "popup" window type is its ability to display its content out of the browser's window boundary. However, Internet Explorer 7.0 has removed this function from "popup" object and introduced limited positioning by design.

To overcome this limitation and to introduce other possible new features, the MenuWindowType is now added WebMenu 2.0 Component.
The default value is set to Popup to preserve the behavior in previous version.

See Also

Related Sections
Fading Animation
{DropShadow Effect}

Other Resources
{WebMenu Runtime Engine}
{What's New in 2.0}


Fading Animation

Fading Animation
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.0 > WebMenu Runtime Engine > Fading Animation

Glossary Item Box

In previous version, animation effect is not possible because WebMenu used Internet Explorer's special popup object.

In this new version, you can now add smooth fading animation effect to all components that based on WebMenu. For instance, WebContextMenu, WebToolBar, WebMenuBar and other Intersoft's components that integrates WebMenu Runtime System.

Before you can enable animation, you will need to set MenuWindowType to Normal. The default value of MenuWindowType is set to Popup to preserve compatibility with previous version.
To enable animation, simply set MenuStyleSettings.MenuAnimation to True.

See Also

Related Sections
Menu Window Type
{DropShadow Effect}

Other Resources
{Menu Window Type}
{What's New in 2.0}


DropShadow Effect

DropShadow Effect
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.0 > WebMenu Runtime Engine > DropShadow Effect

Glossary Item Box

In addition to new animation capability in version 2.0, WebMenu also adds the ability to show dropshadow effect when displayed. All sub menu will be automatically applied as well.

Several notes regarding this feature:

  • Best used with animation effect to create smooth, visually appealing Menu.
  • This feature is not supported in Mozilla browsers since Mozilla has not provide such API.
  • As in animation feature, you also need to set the MenuWindowType to Normal in order to enable dropshadow effect.

See Also

Related Sections
{Menu Window Type}
{Fading Animation}

Other Resources
{WebMenu Runtime Engine}
{What's New in 2.0}


WebFlyPostBackManager Component

WebFlyPostBackManager Component
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.0 > WebFlyPostBackManager Component

Glossary Item Box

This section contains information on the enhanced WebFlyPostBackManager to perform partial rendering over Intersoft's own components such as WebGrid, WebCombo, WebInput or any UI components in the WebDesktop.

In This Section

AJAX over Intersoft's components
Read about the new enhancements added in WebFlyPostBackManager.

See Also

Other Resources
V2.0


AJAX over Intersoft's components

AJAX over Intersoft's components
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.0 > WebFlyPostBackManager Component > AJAX over Intersoft's components

Glossary Item Box

In previous version, WebFlyPostBackManager enables you to instantly convert standard .NET controls that perform page postback become AJAX callback, without changes to the codes. However, this function is not supported on complex component or other third party component.

In version 2.0, WebFlyPostBackManager takes you a step further by adding support to perform partial rendering over Intersoft's own components such as WebGrid, WebCombo, WebInput or any UI components in the WebDesktop. This means you can now write coding logic in the professional approach by using the server-side programming.
For instance, take a very basic scenario such as adding a GroupColumn to WebGrid and then present the new changes when the user clicks on a standard ASP.NET Button. See the following codes:
protected void Button1_Click(object sender, EventArgs e)
{
   WebGrid1.RootTable.TableHeaderVisible = true;
   WebGrid1.RootTable.GroupedColumns.Add(new WebGridGroup("ContactTitle"));
   WebGrid1.RequiresUIRefresh = true;
   WebGrid1.DataBind();
}

A new property called RequiresUIRefresh has been added to all Intersoft's components. As you noticed in above codes, the RequiresUIRefresh property of WebGrid1 instance is set to true. The property is required to be set to true to indicate its user interface needs to be updated by the FlyPostbackManager control.

While standard .NET controls can be automatically updated when they have changed, Intersoft controls do not use similar technique as our controls provide broad range of scenarios. For instance, there are scenarios where some of the data properties need to be changed, but the user interface does not need to be updated. With property control, developers will have more flexibility to control the behavior of the partial update.
To learn more about this new capability, launch Live Samples and see the sample at WebDesktop.NET > What's new in version 2.0 > WebFlyPostBackManager AJAX over Intersoft Control.

In This Section

How-to: Enable automatic callback in FlyPostBackManager

See Also

Other Resources
{What's New in 2.0}


How-to: Enable automatic callback in FlyPostBackManager

How-to: Enable automatic callback in FlyPostBackManager
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.0 > WebFlyPostBackManager Component > AJAX over Intersoft's components > How-to: Enable automatic callback in FlyPostBackManager

Glossary Item Box

By default, every postback in FlyPostBackManager is FullPostBack. However you can set every postback in FlyPostBackManager become a callback (FlyPostBack).

In this topic, you will learn how to enable automatic callback in FlyPostBackManager.

To enable automatic callback in FlyPostBackManager

  1. Focus on WebFlyPostBackManager and press F4 to open WebFlyPostBackManager's properties.
  2. Set EnableUIMode to True.

See Also

Concepts
{AJAX over Intersoft's components}


WebNotification Component

WebNotification Component
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.0 > WebNotification Component

Glossary Item Box

This section contains information on the new WebNotification 2.0 that is able to send notification from the WebForm page's code behind without the needs to create additional WebService or other proxy resource.

In This Section

Unbound Notify
Read about the new Notify method in WebNotification 2.0.

See Also

Other Resources
{What's New in 2.0}


Unbound Notify

Unbound Notify
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.0 > WebNotification Component > Unbound Notify

Glossary Item Box

In its initial concept, WebNotification is a control that acts as a timer which periodically interact with a server side resource, either it is WebForm or WebService. When the server side returns WebNotificationEvent object, the WebNotification control will display an Outlook-like or Messenger-like notification window. This means the WebNotification control should be assigned to a WebForm or WebService resource through its ServiceUrl property. This is called as Bound Mode Notification.

New in WebNotification 2.0 is the ability to send notification from the WebForm page's code behind without the needs to create additional WebService or other proxy resource.
Called as Unbound mode, this new feature enables basic scenarios that do not require periodic timer to be implemented easily and programmatically in code behind.
For instance, you want to display a one-time notification during first load of a web page to inform visitors that the site is currently under maintenance. You can easily add a WebNotification control to the web page and use Notify method in the web page's code behind. See sample codes in the following.
protected void Page_Load(object sender, EventArgs e)
{
   WebNotification1.Notify("Some of our website's features are disabled due to maintenance. We apologize for the inconvenience.",
"./Images/Warning-32.gif", "Maintenance");
}

The Notify method used in above sample takes 3 parameters, the description text, the image and the caption text. There are 4 overloads for the Notify method with various parameters for your convenience in coding.

See Also

Other Resources
{What's New in 2.0}


SmartWebResources

SmartWebResources
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.0 > SmartWebResources

Glossary Item Box

This section contains information on the SmartWebResource™ that is used to eliminate the external physical resources - such as scripts, images, etc - which required by web components to function properly.

In This Section

SmartWebResources Overview
Read about the overview of SmartWebResources™.

Benefits
Read about the benefits offered by SmartWebResources in WebDesktop 2.0.

FAQ: Does SmartWebResources feature automatically enabled in WebDesktop.NET 2.0?
Information about SmartWebResources feature in WebDestop.NET 2.0.

FAQ: Briefly, what are the files included in WebDesktop SmartWebResources Assembly?
Information about the files included in WebDesktop SmartWebResources assembly.

How-to: Configure SmartWebResources in a new web application
Learn how to set SmartWebResources in a web application.

See Also

Other Resources
{What's New in 2.0}


SmartWebResources Overview

SmartWebResources Overview
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.0 > SmartWebResources > SmartWebResources Overview

Glossary Item Box

Oftentimes, developers found it too complex in order to deploy their web application that used third party components. There are too much things that need to be recalled before a web application can be successfully deployed. For an instance, the javascript files, images and other runtime client files need to be copied in order for the component to run properly.

One of the goal in Intersoft's 2007 product platform is to simplify the deployment process required in Intersoft's controls. Our approach is by developing a new infrastructure that handles the storage and retrieval system of these client resources so that physical files can be totally eliminated. This new infrastructure is called SmartWebResources™.
WebDesktop.NET 2.0 fully supports SmartWebResources infrastructure. This enables WebGrid control to function perfectly right out-of-the-box after the simple XCOPY deployment.
Both developers and site administrators can now deploy Intersoft's components by simply copying the assemblies in the Bin folder of the project - and totally eliminates the need to copy javascript files, component-specific images and runtime files.
As best practice, it is highly recommended to enable SmartWebResources feature for all Intersoft's components especially WebGrid. Furthermore, WebGrid.NET Enterprise 5.0 exclusively requires WebDesktop's SmartWebResources Assembly in order to use some advanced User Interface features in WebGrid such as the new ContextMenu engine and runtime engines for dialog boxes and windowing system.
To learn how SmartWebResources works, please read How does SmartWebResources™ work.

See Also

Tasks
{FAQ: Does SmartWebResources feature automatically enabled in WebDesktop.NET 2.0?}
{FAQ: Briefly, what are the files included in WebDesktop SmartWebResources Assembly?}
{How-to: Configure SmartWebResources in a new web application}

Related Sections
{Benefits}


Benefits

Benefits
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.0 > SmartWebResources > Benefits

Glossary Item Box

The SmartWebResources feature offers more benefits to WebDesktop.NET components compared to other Intersoft's components since WebDesktop.NET components are mainly User Interface components that contain lot of images, styles and themes.

With SmartWebResources in WebDesktop.NET 2.0, you get the benefit such as:

  • Increasing Productivity - Quickly apply a sophisticated style from Layout Manager without has to copy the images to root directory of the web application. This is mostly applicable to non-HTTP projects such as File System Project (FSP) and Web Application Project (WAP).
  • Time Saving - Instantly deploy your web application without the need to configure the images that needed by the UI component.
To learn about the benefits introduced by SmartWebResources, read Features and benefits introduced by SmartWebResources™.

See Also

Tasks
FAQ: Does SmartWebResources feature automatically enabled in WebDesktop.NET 2.0?
{FAQ: Briefly, what are the files included in WebDesktop SmartWebResources Assembly?}
{How-to: Configure SmartWebResources in a new web application}

Related Sections
{Overview}


FAQ: Does SmartWebResources feature automatically enabled in WebDesktop.NET 2.0?

FAQ: Does SmartWebResources feature automatically enabled in WebDesktop.NET 2.0?
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.0 > SmartWebResources > FAQ: Does SmartWebResources feature automatically enabled in WebDesktop.NET 2.0?

Glossary Item Box

By default, Intersoft 2007 product platform have the SmartWebResources set to Automatic mode. This automatic mode ensures compatibility with existing web application when developers migrated to 2007 platform, while at the same time attempting to utilize SmartWebResources in new web application whenever possible.

When you created a new web application and started to use WebDesktop.NET 2.0, the SmartWebResources is not configured initially. With the automatic mode as default behavior, WebDesktop.NET 2.0will use physical resources since the SmartWebResources is not configured initially.

See Also

Tasks
{FAQ: Briefly, what are the files included in WebDesktop SmartWebResources Assembly?}
{How-to: Configure SmartWebResources in a new web application}

Related Sections
{Overview}
{Benefits}


FAQ: Briefly, what are the files included in WebDesktop SmartWebResources Assembly?

FAQ: Briefly, what are the files included in WebDesktop SmartWebResources Assembly?
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.0 > SmartWebResources > FAQ: Briefly, what are the files included in WebDesktop SmartWebResources Assembly?

Glossary Item Box

The single assembly of WebDesktop's SmartWebResources contains all required scripts and images that used by the control at runtime. It includes:

  • Core Scripts, such as WebDesktopManager.js, WebMenu.js, etc.
  • Core Images Set, such as tree lines, background images, command icons etc.
  • Theme Images Set, such as the Outlook 2007 or Vista style images contained in Predefined Style.
  • Stylesheets and other document files that will be automatically loaded when needed by the module in client side.

See Also

Tasks
FAQ: Does SmartWebResources feature automatically enabled in WebDesktop.NET 2.0?
{How-to: Configure SmartWebResources in a new web application}

Related Sections
{Overview}
{Benefits}


How-to: Configure SmartWebResources in a new web application

How-to: Configure SmartWebResources in a new web application
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.0 > SmartWebResources > How-to: Configure SmartWebResources in a new web application

Glossary Item Box

As the best practice in using Intersoft 2007's product lines, you are recommended to perform the following steps after you have created a new web application or migrated an existing web application.

  1. Right click on one of the Intersoft's control instance. For instance, WebDesktopManager1.
  2. Click Register SmartWebResources™ command in the context menu.

  3. In short time after you clicked the command, you should receive a message prompt similar to the following:
    "SmartWebResources has been successfully configured for this web application."

If you are receiving an error message, it is likely that you have not installed the product properly. Please note that you cannot enable this feature in older products (non 2007-platform products).

To learn more about SmartWebResources, please read Introducing SmartWebResources™.

See Also

Tasks
FAQ: Does SmartWebResources feature automatically enabled in WebDesktop.NET 2.0?
{FAQ: Briefly, what are the files included in WebDesktop SmartWebResources Assembly?}

Related Sections
{Overview}
{Benefits}


Styles

Styles
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.0 > Styles

Glossary Item Box

WebDesktop.NET 2.0 is strongly focused on new visual styles and appearance that based on Microsoft's latest user interface breakthrough, such as in Windows® Vista and Office 2007® - which have quickly become the new standards in user interface components industry.

To satisfy your end users with these breakthrough visual styles in your web application, WebDesktop.NET 2.0 has included Office 2007® visual style to most applicable components such as toolbar, menubar, navigation pane and menu system. These new visual styles can be easily applied with one button click from Layout Manager.

The following images are provided to give you quick reference to the new visual styles included in WebDesktop.NET 2.0.

You can also experience these new visual styles in Live Samples > WebDesktop.NET > What's new in version 2.0.

In This Section

WebDesktopManager Office 2007 Style

WebPaneManager Office 2007 Style

WebContextMenu/WebMenu Office 2007 Styles

WebToolBar Office 2007 Style

WebMenuBar Office 2007 Style

WebMenuBar Vista Style

PlaceHolderManager Office 2007 Style

WebNavPane Office 2007 Style

WebExplorerPane Vista Style

WebNotification Vista Style

WebTab Vista Style

WebTab Office 2007 Style

The complete WebUI Studio.NET®2007 components in the fashion of Office 207 Style

See Also

Other Resources
V2.0


WebDesktopManager Office 2007 Style

WebDesktopManager Office 2007 Style
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.0 > Styles > WebDesktopManager Office 2007 Style

Glossary Item Box

See Also

Related Sections
Styles

Other Resources
{What's New in 2.0}


WebPaneManager Office 2007 Style

WebPaneManager Office 2007 Style
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.0 > Styles > WebPaneManager Office 2007 Style

Glossary Item Box

See Also

Related Sections
Styles

Other Resources
{What's New in 2.0}


WebContextMenu/WebMenu Office 2007 Style

WebContextMenu/WebMenu Office 2007 Style
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.0 > Styles > WebContextMenu/WebMenu Office 2007 Style

Glossary Item Box

See Also

Related Sections
{Styles}

Other Resources
{What's New in 2.0}


WebToolBar Office 2007 Style

WebToolBar Office 2007 Style
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.0 > Styles > WebToolBar Office 2007 Style

Glossary Item Box

See Also

Related Sections
{Styles}

Other Resources
{What's New in 2.0}


WebToolBar Vista Style

WebToolBar Vista Style
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.0 > Styles > WebToolBar Vista Style

Glossary Item Box

See Also

Related Sections
{Styles}

Other Resources
{What's New in 2.0}


WebMenuBar Office 2007 Style

WebMenuBar Office 2007 Style
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.0 > Styles > WebMenuBar Office 2007 Style

Glossary Item Box

See Also

Related Sections
{Styles}

Other Resources
{What's New in 2.0}


WebMenuBar Vista Style

WebMenuBar Vista Style
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.0 > Styles > WebMenuBar Vista Style

Glossary Item Box

See Also

Related Sections
{Styles}

Other Resources
V2.0


PlaceHolderManager Office 2007 Style

PlaceHolderManager Office 2007 Style
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.0 > Styles > PlaceHolderManager Office 2007 Style

Glossary Item Box

See Also

Related Sections
{Styles}

Other Resources
{What's New in 2.0}


WebNavPane Office 2007 Style

WebNavPane Office 2007 Style
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.0 > Styles > WebNavPane Office 2007 Style

Glossary Item Box

See Also

Related Sections
{Styles}

Other Resources
{What's New in 2.0}


WebExplorerPane Vista Style

WebExplorerPane Vista Style
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.0 > Styles > WebExplorerPane Vista Style

Glossary Item Box

See Also

Related Sections
{Styles}

Other Resources
{What's New in 2.0}


WebNotification Vista Style

WebNotification Vista Style
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.0 > Styles > WebNotification Vista Style

Glossary Item Box

See Also

Related Sections
{Styles}

Other Resources
{What's New in 2.0}


WebTab Vista Style

WebTab Vista Style
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.0 > Styles > WebTab Vista Style

Glossary Item Box

See Also

Related Sections
{Styles}

Other Resources
{What's New in 2.0}


WebTab Office 2007 Style

WebTab Office 2007 Style
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.0 > Styles > WebTab Office 2007 Style

Glossary Item Box

See Also

Related Sections
{Styles}

Other Resources
{What's New in 2.0}


The complete WebUI Studio.NET® 2007 components in the fashion of Office 2007 Style

The complete WebUI Studio.NET® 2007 components in the fashion of Office 2007 Style
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.0 > Styles > The complete WebUI Studio.NET® 2007 components in the fashion of Office 2007 Style

Glossary Item Box

See Also

Related Sections
{Styles}

Other Resources
{What's New in 2.0}


Master Page Support

Master Page Support
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.0 > Master Page Support

Glossary Item Box

All components in WebDesktop.NET 2.0 have been refined to fully support Master Page in ASP.NET 2.0. You can use WebDesktop.NET components in either single or nested Master Page.

See Also

Other Resources
{What's New in 2.0}


Component Designer 2.0

Component Designer 2.0
See Also Send Feedback
Intersoft WebDesktop > Release History > V2.0 > Component Designer 2.0

Glossary Item Box

WebDesktop.NET 2.0 incorporates new Component Designer 2.0 as the main editor for all visual components in the collection. The new Component Designer sports consistent Vista style dialog and appearance to improve usability and developer's productivity.

The new Component Designer featuring:

  • Redesigned user experience for better layout management.
  • Improved Layout Manager for easier user interaction.
  • Improved Structure Manager, including the new ability to Preview Xml.

See Also

Other Resources
{What's New in 2.0}


WebDesktop Overview

WebDesktop Overview
See Also Send Feedback
Intersoft WebDesktop > WebDesktop Overview

Glossary Item Box

The Evolution of WebUI

World Wide Web, also known as the web today has improved dramatically since its invention back in 1983 and has also evolved several times over since the Internet took off back in 1995. The original objective of the web was to provide information in static, older tabular layout. Today, most Browsers ( which is the key to the web ) have been significantly improved so as to enable the capability to develop richer web pages that offer better user interactions, minimized postbacks and more.

Intersoft Solutions, with its latest offering in Web User Interface product line is proud to announce a new breakthrough product and a whole new perspective in User Interface development which redefines the WebUI and once again is leading the evolution of WebUI. The latest innovation in WebUI,

WebDesktop.NET, will enable you to build the future web applications of your dream today.

Introducing WebDesktop.NET® - The desktop on your browser

WebDesktop.NET® is the next generation in advanced UI controls designed to help you build future applications. WebDesktop includes everything you need to develop advanced ASP.NET applications which has the appearance and behavior of desktop applications and the desktop itself. That means, WebDesktop is not only offering the richness of desktop's controls, but also has high-level details of desktop implementation enabling you to create advanced Windowing system similar to Windows or MacOS. What's more, it even offers the capability to display shell-level notification similar to MSN Messenger or Outlook 2003 through its highly customizable WebNotification component which is built on the top of high performance OnTheFly-Postback architecture.

By incorporating WebDesktop.NET, end users will experience a much better navigation system similar to the operating system they have been familiar with for years and developers will be even more productive and get fresher ideas to implement Richer Internet Application which was not possible to do before.

WebDesktop.NET is the among the first WebUI product in the market which is specifically designed to run only on Visual Studio 2005 and takes advantage of powerful design-time features as well as native ASP.NET 2.0 feature.

WebDesktop.NET is a collection of 13 various advanced components listed in following table.

WebFlyPostBackManager

The unique generic callback component introduces pure callback functionalities, instead of only acting as a wrapper or as medium to render server control to client. Built on the top of Intersoft's renowned OnTheFly-PostBack architecture, FlyPostBackManager enables you to call the server-side method residing in a WebForm class or a WebService (ASMX) from client side without sacrificing your security. FlyPostBackManager is able to receive and parse any complex type of object returned from the server side, either it is a DataSet object or your own serializable custom object.
WebNotification

The first kind of its type, WebNotification is built on the top of FlyPostBackManager and closely integrated with WebDesktopManager to enable you to develop a shell-level notification system right into your web apps. WebNotification allows specific server code to be invoked asynchronously at specified interval and upon success condition, it will display the assigned data and actions available in the context. With it, you could develop extremely rich and responsive applications similar to Outlook 2003 or MSN Messenger, and the possibility to develop new kind of applications.
WebExplorerPane

Like no others, WebExplorerPane is the exact replica of Windows XP Explorer Pane enabling you to offer smooth user experience for navigation or commands functions. The WebExplorerPane has exactly the same behavior as the desktop version, from its animation style, animation speed with fading effects, gradient colors to images customization. WebExplorerPane also employs TrueShape for round corner "look and feel" without using images, ClickAndSelect and ClickAndEdit as in other members of WebDesktop.NET family.
WebDesktopManager

DesktopManager enables you to create high performance and powerful Desktop with built-in windowing navigation system and shortcut icons, extensive keyboard navigation support, customizable taskbar configurations, high performance window switching and resizing, configurable window state, ClickAndEdit™ designer experience and combinable 50+ advanced configurations.
WebToolBar

The first of its kind, WebToolBar introduce s several new breakthrough technologies such as TrueShape™ and TrueDock™. WebToolBar is able to behave exactly in the same manner as the desktop's ToolBar, such as multiple rows docking on four edges, hide more items when the width has exceed ed boundaries and customizes dialog box for extremely rich level of user personalization.
WebPaneManager

PaneManager allows you to easily create any kind of layout from simple horizontal layout to complex Outlook-like layout. This is done by using nested WebPane in hierarchical concept. The component comes with an advanced powerful Editor which enables you to apply a common layout from predefined template with only a mouse click away!
WebTab

Intersoft's innovative WebTab incorporates ClickAndEdit™ architecture enabling you to click on a TabItem and edit the content right away inside Visual Studio designer environment. No longer do you need to create separate views or multiple views or other traditional approach es which limits your productivity! WebTab is also the first product with TrueShape™ that renders round corners without images . You can now design any style with any color you wanted with unlimited possibilities!
WebStyleManager

Use StyleManager to free designers from having the needs to work with Visual Studio or development IDE! StyleManager enables designers to design the styles and themes of any product of Intersoft WebUI Studio.NET through standalone WinForm application and later seamlessly integrate the themes into the designated web application. StyleManager is built on the top of Theme Architecture and Serialization feature offered in WebUI.NET Framework.
WebMenu

Offers menu functionalities with capability to display perfectly on either vertical or horizontal positions. Unique features including feature to display the menu outside of browser boundary for Internet Explorer browsers, highly customizable styles and appearance as well as high performance client side rendering. The Menu can also be configured as ContextMenu to be assigned as context menu for other components.
WebSplitter

A versatile splitter component for your table layout. WebSplitter is a true splitter component which can be used independently and applied to your existing layout. WebSplitter offers automatic cell splitting scenario supporting rowspan and colspan, as well as intelligent resizing mechanism enabling accurate unit measurement which return the original unit type. WebSplitter automatically integrated in WebPaneManager component for resizing functionality.
WebDialogBox

Tightly integrated with WebDesktopManager, WebDialogBox enables you to easily create modal or normal dialog box on the top of DesktopManager. Developers can easily specify which buttons to appear and specify the DialogResult as in WinForm applications. The incorporated ClickAndEdit™ feature enables developers to easily design the dialog box at design time, or simply construct the DialogBox at client side programmatically.
WebNavPane

An advanced navigation pane component offering the richness of desktop navigation in every detail of styles and behaviors. You can use WebNavPane to create Outlook 2003 like navigation pane where end users can specify the visible navigation bars by dragging the splitters or though built-in context menu. You can choose to use built-in Items collection for the navigation item or use your own control through Custom Template.
WebButton

Unique Button component to complement the WebDesktop.NET a consistent look&feel and behaviors. WebButton is equipped with the easiness to invoke client side events or predefined client side actions such as closing window, calling a method in WebService through FlyPostBackManager, or to invoke your own codes in onclick event. WebButton has consistent dynamic styles enables style interactivity in entire applications.

See Also

{Benefits}
{New Technologies}
{System Requirements}


Benefits

Benefits
Send Feedback
Intersoft WebDesktop > WebDesktop Overview > Benefits

Glossary Item Box

Leverage the key benefits of employing WebDesktop.NET as your primary Web User Interface components:

The freedom to Design

WebDesktop.NET is the first ASP.NET component offering a clear separation between designing and the

developing process. WebDesktop allows an organization to develop better while working in a teamwork mode. WebDesktop is bundled with a standalone Style Manager which can be launched by User Interface designers separately. The designers would only need to have .NET Framework and WebDesktop installed, without the need to use Visual Studio or other IDE. That means designers can now work more independently and productively than ever before. Once the designers have completed the theme or style design for a web application, the xml-based theme file can be easily copied into deployment server and the designated web application will automatically use the deployed theme without additional changes to codes. At last, the freedom to design!

The freedom to Develop

By enabling designer s to work on their own independently, this means a big plus for developers! Now, developers would no longer have to deal with the styles or appearances of the components since these can now be done by designers independently . That means developers can spend their time focusing on business logics and jump into coding that is even faster and even more productive. Moreover, the new technologies offered in WebDesktop gives a unique development experience such as ClickAndEdit which allows developers to interact directly with the component during design time (in Visual Studio 2005 IDE). The ClickAndEdit and ClickAndSelect technologies are implemented

consistently throughout most components of the WebDesktop. Plus, the unified object model across all WebUI Studio.NET families enabl es developers to work with any new controls almost immediately. All of these give developers the freedom to develop web applications!

The freedom to Innovate

Innovation has a new name! WebDesktop.NET comes up with the latest innovation in Web Component history, introducing 6 new patent-pending technologies and 12 new advanced, powerful and unique products. WebDesktop allows you to develop any kind of rich applications which is able to simulate most of today's popular desktop functions. Be it Windows Vista or MacOS Tiger, you can build similar appearance s and behavior by utilizing WebDesktopManager which enables you to create rich user interactions with advanced, high performance Window navigation system, built-in TaskBar and Shortcut, creates new Window at runtime, tight integration with WebDialogBox, WebButton, WebNotification and more. There's almost nothing you can't do with it. It gives you the freedom to innovate for your next web apps!

The freedom to Personalize

Personalization is one of the most requested features today . WebDesktop introduce s a new level of personalization features for your end users such as TrueDock technology where users only need to drag a bar and drop it into one of four edges available in the screen. The docking system is so powerful that it not only allow s you perform drag and drop, it also supports dock to multiple bar or dock into single row similar to those found in Microsoft Office 2003. The AllowCustomize in WebToolBar is one of the high level personalizations where users are free to define their own items, moving the items around or even between bars, removing items, and even creating new toolbar at runtime! The entire WebDesktop products have their own personalization features and deliver the freedom to personalize for your users!

Summary

The overall concept and benefit of WebDesktop.NET -- as one of most significant product family of WebUI Studio.NET -- is obvious, to empower Rich Internet Applications through Unified Component System. WebDesktop.NET is the ultimate solution for rapid enterprise and rich internet application development available today, enabling clear separation between designing and developing process for better scalability in teamwork, offering the latest innovations and technologies to bring the best value for your end products and best satisfactions to your end users, offering highest level of personalization and user interaction as well as the most extensive accessibility support, enabling centralized deployment and administration, enabling one click product updates, and much more.

By incorporating WebDesktop.NET into your web applications, get ready to be the trendsetter today!


New Technologies

New Technologies
Send Feedback
Intersoft WebDesktop > WebDesktop Overview > New Technologies

Glossary Item Box

WebDesktop.NET does not only introduce new concepts and perspective in User Interface development. WebDesktop makes them into reality resulting in 10 new patent-pending technologies listed below.

TrueShape

TrueShape is an innovative rendering technology which enables round corner shape to be rendered without the need to use images. The name True Shape is appropriate for not only is it able to render round corners between four edges but it also has the ability to blend in perfectly into transparent background and filled gradient. With TrueShape, developers gain more productivity than ever before as they do not have to use photo editing software to create complex images. Instead, they can now configure everything with just a few mouse clicks right inside the Visual Studio IDE. With all these capabilities, you can create any kind of theme, for example, the blue Theme of Office Toolbar style or the silver theme, or any color blends you desire.

ClickAndEdit

ClickAndEdit technology is built on the top of Intersoft's new design time rendering architecture and Microsoft's Visual Studio 2005 webform architecture. This powerful technology introduces unique development experience for application developers as they no longer need to deal with separate template view or separate control for editing content and the master control (example, TabStrip and MultiView concept that was implemented in traditional components). ClickAndEdit removes this bottleneck by enabling developers to edit directly within the region of main control's content area. ClickAndEdit is one of the key technologies which has been implemented consistently in all WebDesktop products.

ClickAndSelect

ClickAndSelect is another technology to complement ClickAndEdit. ClickAndSelect is one of the key features allowing developers to interact with the object inside the main component region. This is a significant improvement to developers' productivity as functions are made interactively in Visual Studio IDE directly without the need toopen Collection Editor and so on. For instance, in WebTab, developer can click to select and activate another TabItem available in the collection the same way as it was in client side (end user) mode. When selected, the inactive TabItem will become the active TabItem and you can click on the content area and start editing. Developing and Editing has never been easier!

TrueFill

TrueFill is an advanced technology dealing with layouting component as introduced in WebPaneManager. It saves developers from "table layout nightmare", gone are the days where developers have to spend a day or more just to configure layout properly with each cell's width and height, between absolute and percentage dimensioning, and not to mention nested tables. TrueFill on the other hand automates everything and enables you to design even the most complex layout within minutes. Practically, TrueFill as implemented in WebPaneManager allows you to design and add as much Pane as you want. Every Pane will have Automatic Fill mode for the dimension and does not require you to specify the dimension manually. TrueFill will maintain the PaneManager to keep every Pane to fit into the master control automatically, and developers do not need to know or calculate the dimensions.

TrueDock

TrueDock is the only correct implementation today which allows end users to dock a Bar (either Toolbar or Menubar) into four edges of designated content area. It is a powerful docking technology recognizing its capabilities to intelligently dock into multiple bars or dock into the same row in any edges! It also enables a Bar to be floated when desired. TrueDock automatically maintain its configuration and adjust required settings when the docking changed from horizontal to vertical position. All of these capabilities offer a high level of user interactivity and personalization for your end users.

HighClarityDesktop

HighClarityDesktop is the main technology behind everything found in WebDesktop.NET. It is the technology with high end functions related to Windows management, such as minimize, maximize, resize, move and many others. It resembles many behaviors similar to today's desktop such as Windows XP, such as when WindowTaskBarButton is clicked, double clicked, mouse up & down and more, the shortcut, the desktop itself until the most detailed behavior of window events. With HighClarityDesktop, other components in the WebDesktop.NET fit perfectly into DesktopManager with the same architecture, such as WebDialogBox, WebNotification and WebButton which has built-in integration right into DesktopManager.

InteractiveDesigner

InteractiveDesigner is one of the technology powering WebPlaceHolderManager interface in IDE. WebToolBar and WebMenuBar use PlaceHolderManager as its main container to automatically dock its position right in the IDE. This is similar to WinForm development where one can easily set the Docking position of a Toolbar and the UI reflects it immediately. This interactive WinForm designer model was impossible to achieve before since the content area needs to be edited and has to be template while the Bar Docking was within our control level. Now, a new level of design experience has been introduced in InteractiveDesigner technology where developer can work with editing conveniently in a non-template mode and have the Bar placed according to the desired Docking position.

GenericPersistence

Persistence is needed to offer personalized functions on every component. The challenge lies on how to be consistent across all components. The traditional approach was through implementing separate codes into each component since they were not built on Framework. A better approach is found in GenericPersistence technology which built on top of WebUI.NET Framework, the base of all Intersoft's components. With GenericPersistence, all components which require personalization in WebDesktop can have consistent and similar ways to obtain the latest structure on client side as well as in server side. The structure can then be saved in server storage and loaded in the next request from server side method.

XmlCompression

Intersoft's main framework, the WebUI.NET Framework extensively utilizes XML as its main storage for client side settings. There are many advantages by using XML compared to traditional approaches which writes unstructured Array or lot of scripts for client side settings. For example, the state can be easily managed, accessed, changed and updated in consistent fashion and structure. There is one weakness however, a big price that has to be paid for all advantages because XML produces a bit larger output since its tag name and attributes are self describing. XmlCompression is born to solve this dilemma! Intersoft developed its own compression and decompression algorithm in order to compress the XML storage into 40-60% smaller size. This significantly improves the performance of page load in narrow bandwidth. This technology is also extensively used in FlyPostBack technology to reduce the posted data and improve overall response time up to 40%.

CssOptimizer

Even with all these new technologies and innovative products invented by Intersoft, there could be no release made without CssOptimizer. Since all components and architectures are dealing with Web technology, Intersoft has decided to develop its own technology in order to optimize the output of the component to a smaller output. This optimizing technology solves many scalability and performance issues found in today's web application. CssOptimizer enables all Intersoft's components to use abbreviated class name (optimizing up to 70%), and automatic CSS class grouping which remove repetitive styles and group them into as few selector as possible. For instance, a generated Style currently produces its name as "WebGrid1-LayoutSettings-FrameStyle" which is considered quite a long string. Now it can be as short as "W2703". The CSS optimization can be applied automatically without code changes to any member of WebUI Studio.NET family, whether it is WebGrid, or WebCombo, or WebDesktop -- since it is built on Framework level.


Overview by Technology

Overview by Technology
Send Feedback
Intersoft WebDesktop > Overview by Technology

Glossary Item Box

WebDesktop.NET is not just about DHTML-based user interface components. WebDesktop.NET is the next generation Web Presentation system which introduces new concepts and technologies to enhance productivity in four aspects of rapid web application development. This topic will list the new technologies grouped by the four aspects of web development.

Design Environment

One major breakthrough introduced in WebDesktop.NET is the innovative design environment through Standalone WebUI Style Manager. Designers can now build the application's user interface's styles and appearances independently from developers.

Development Environment

WebDesktop.NET offers numerous unique and powerful technologies that exclusively targetting Visual Studio 2005 which enables you to be more productive with the WYSIWYG fashion of development experience. The technologies are:

  • ClickAndEdit
  • ClickAndSelect
  • Visual PaneManager Designer
  • Visual Menu Builder
  • Uniform Component Designer
  • Interactive PlaceHolderManager Designer

Runtime Environment

This section lists the new technologies utilized during runtime environment. The runtime enviroment are mostly related to DHTML and browser technologies. All of them have been developed to support Internet Explorer and Gecko-based browsers such as Mozilla, Firefox and Netscape.

  • Hybrid Menu System
  • True Shape
  • High Clarity Desktop
  • Structure Manager
  • True Dock

Optimization Architectures

With all of the new technologies involved in three main aspects of enterprise web application development, the optimization architectures comes to complement the suite into perfection. The technologies above will certainly boost developer's productivity and maximize the value of your application by adding new significant features which increase end user productivity and experience. However, productivity and rich features will not scale properly and will even introduce performance issues without specific optimization architectures.

The following is the list of optimization architectures which enable you to build rich web application that extend and scale properly:

  • Xml Compressor
  • CSS Optimizer
  • Http Compressor

For the new technologies overview, see New Technologies.


Design Environment

Design Environment
Send Feedback
Intersoft WebDesktop > Overview by Technology > Design Environment

Glossary Item Box

This section contains information about standalone WebUIStyleManager

In This Section

Standalone WebUIStyleManager


Standalone WebUIStyleManager

Standalone WebUIStyleManager
Send Feedback
Intersoft WebDesktop > Overview by Technology > Design Environment > Standalone WebUIStyleManager

Glossary Item Box

Introduction

One of the most challenging tasks in developing scalable web application is providing rich visual style design in consistent fashion across the entire web forms in the application. Designing the style that is reusable and consistent in an application can oftenly become a painful task for developers because of the insufficient tools that has specific features to address this problem. Most of the times, developers need to spend a lot of time and efforts in only designing the style and appearances of the web form, while the design task should actually be done by other team in Design division. That had caused a major impact to developer's productivity and other efficiency areas.

Intersoft has provides several solutions in the previous version of the WebUI.NET Framework (v1.0 and 2.0) listed in the following:

  • Xml-based Layout Manager

    The Layout Manager is a feature implemented in most of Intersoft's component designer. It is only accessible through design time in Visual Studio IDE. By using Layout Manager, you can easily save a style configuration in a xml-based Layout File and later apply it to other control's instances. Although it provides many time-saving features for style reusability, it does not allow you to design the style outside of Visual Studio IDE.
  • Layout API

    Instead of applying a Layout on design-time using Layout Manager mentioned above, Intersoft has also provided comprehensive Layout API to allow developers to load and save a Layout dynamically at runtime. The Layout can be loaded from either a Stream object or a file path. The Layout API provides flexible and powerful way for developers to create extensible and personalized visual styles. However, it requires a lot of programming efforts in order to achieve consistent sitewide visual styles.

WebUI StyleManager

In this release of WebDesktop.NET, Intersoft offers a more solid tool for addressing this issue with the availability of WebUI StyleManager. The StyleManager lets design tasks to be done by proper division instead of having developers to do it. This provides a more robust and scalable teamwork while building enterprise application where designers can now work with developers in parallel manner.

With the clear separation between designing and developing tasks, it enables the application to be built with better organization which allows better maintenance in the future when enhancements or adjustments are required.

Concepts

The StyleManager is a standalone desktop (WinForm) application built on the top of WebUI.NET Framework 3.0 and .NET Framework 2.0 enabling a designer to add, edit or remove themes in a web application. It also provides the built-in capability for designers to visually create or edit the style of any supported Intersoft's components as well as previewing and deployment of the theme to production server easily.

The StyleManager can be installed independently on a computer without requiring Visual Studio development environment. It however requires following software to be installed:

  • Microsoft .NET Framework 2.0
  • IIS (for previewing purpose)
  • Intersoft WebUI.NET Framework 3.0
The "theme" referred above does not use ASP.NET 2.0's theming architecture. It used Intersoft's own Theme Architecture which enables better theming management architecture in the term of flexibility and features.

The following is a screenshot of WebStyleManager.

For more information about StyleManager and its features, see WebStyleManager Features.

For more information on how the StyleManager can be used in conjunction with Theme architecture and the Deployment concepts, see The Orchestration of Theme Architecture, StyleManager and Deployment.

Benefits

WebUI StyleManager introduced numerous benefits for both designers and developers. Some of the benefits are:

  • Improved developer's productivity by focusing on application development and leaving all design tasks to designers.
  • Better teamwork scalability and resources utilization with the clear separation between designing and developing tasks.
  • Reduced administration and maintenance complexity with the easy deployment mechanism.
  • Faster time of application implementation since designers can now work in parallel with developers.
  • Time saving with the easy to use application interface.


Development Environment

Development Environment
Send Feedback
Intersoft WebDesktop > Overview by Technology > Development Environment

Glossary Item Box

This section contains information on development environment.

In This Section

ClickAndEdit

ClickAndSelect

Visual PaneManager Designer

Visual Menu Builder

Uniform Component Designer

Interactive PlaceHolderManager Designer


ClickAndEdit

ClickAndEdit
Send Feedback
Intersoft WebDesktop > Overview by Technology > Development Environment > ClickAndEdit

Glossary Item Box

Introduction

ClickAndEdit is a productivity feature for Visual Studio 2005 Development Environment allowing you to easily perform editing in a container-type control, such as WebDesktopManager or WebTab.

With ClickAndEdit, you no longer required to use workaround or the need to interact with different instances of "readonly" and 'editable" instance of one container control. For instance, you typically require a TabHeader instance and another TabView instance which match up to the TabHeader. The things might become more complicated and difficult to maintain when you need to add more tab headers. The ClickAndEdit technology completely solves this problem by adding the capability to edit directly into the control's visual boundary and exposes new functions which are never possible before.

The following screenshot illustrates the main function of ClickAndEdit.

Supported Products

This section lists the components which implemented ClickAndEdit technology:

  • WebDesktopManager
  • WebTab
  • WebPaneManager
  • WebDialogBox
  • WebNavPane

Benefits

The following is a list of top benefits offered by ClickAndEdit:

  • Improved productivity by removing complexity and unnecessary actions while interacting with container control.
  • Enhanced development experience with the convenience of editing through one button click.
  • Easy to use and learn, minimizing the learning curve required to develop with the components.
  • Faster user interface implementation with better WYSIWYG visualization since no separate template view is needed.


ClickAndSelect

ClickAndSelect
Send Feedback
Intersoft WebDesktop > Overview by Technology > Development Environment > ClickAndSelect

Glossary Item Box

Introduction

ClickAndSelect is another technology to complement ClickAndEdit. ClickAndSelect is one of the key feature allowing developers to interact with the object inside the main component region. This is a significant improvement to developers' productivity as it enables many functions to be made interactively in Visual Studio IDE directly without has to open Collection Editor and so on. For instance, in WebTab, developer can click to select and activate another TabItem available in the collection the same way as it was in client side (end user) mode. When selected, the inactive TabItem will become the active TabItem and you can click on the content area and start editing.

Another ClickAndSelect implementation is customized actions or tasks based on the configured property. For example, you can select and specify the WebForm you want to assign for specific Content that used IFrame mode. Instead of requiring you to open Property Window and manually specify the path, you can click on the provided Button inside the control area and select the WebForm immediately.

The following screenshot illustrates the main function of ClickAndSelect.

Supported Products

This section lists the components which implemented ClickAndSelect technology:

  • WebDesktopManager
  • WebTab
  • WebPaneManager
  • WebDialogBox
  • WebNavPane

Benefits

The following is a list of top benefits offered by ClickAndSelect:

  • Improved productivity by removing complexity and unnecessary actions while interacting with container control.
  • Enhanced development experience with the convenience of selection through one button click.
  • Easy to use and learn, minimizing the learning curve required to develop with the components.
  • Reduced efforts for user interface development since no separate Collection Editor is required.


Visual PaneManager Designer
Send Feedback
Intersoft WebDesktop > Overview by Technology > Development Environment > Visual PaneManager Designer

Glossary Item Box

Visual PaneManager Designer

The intention to develop Visual PaneManager editor comes from the limitation of available editors. Developers usually create their own layout from scratch which is very troublesome especially when complex structure is involved. As table has been essential element in creating complex structure, to aid you in complex structure you will most probably need to have nested tables which is quite troublesome.

The other irritating problem is about the calculation of each TableRow and TableData's size (more well known as <TR> & <TD> in HTML) where they cannot conveniently set the dimension of each element. In WebPaneManager those sort of things are no longer a problem where different types of Dimension Unit are supported such as %, px, and even Fill.

By providing developer with Visual WebPane Designer, developer can now easily create complex structure without needing to deal with the HTML Codes directly. The Visual Designer encapsulates all the complexity which results in rapid development.

Supported Products

This section lists the components which implemented ClickAndSelect technology:

  • WebPaneManager

Benefits

The following are the list of top benefits offered by Visual PaneManager Designer:

  • Rich design time experience, enabling you to rapidly create even the most complex structures.
  • Unique design time experience by providing developer with a preview of the structure of your WebPane at run- time.
  • The ability to quickly apply predefined structure from our vast collection of predefined structure template.
  • Save and Load your WebPane structure and configurations for high reusability.


Visual Menu Builder

Visual Menu Builder
Send Feedback
Intersoft WebDesktop > Overview by Technology > Development Environment > Visual Menu Builder

Glossary Item Box

Introduction

The Visual Menu Builder was built to let you effortlessly create menu structures of WebContextMenu, WebMenuBar or WebToolBar for your Web application. The menu builder is designed with simplicity in mind and you will find its behaviors very similar to Visual Studio 2005's built-in WinForm menu editor, therefore eliminating learning curves.

The rich-designer feature of the WebMenu (WebContextMenu, WebMenuBar and WebToolBar) means that you can use Visual Menu Builder to build menu structures and add/insert/delete menu items to the menu structure at the same time. You can also modify the properties of the WebMenu object and the menu items it contains through the provided PropertyGrid.

Visual Menu Builder

Supported Products

Products supported by Visual Menu Builder:

  • WebContextMenu
  • WebMenuBar
  • WebToolBar

Features

Here are some of the benefits introduced by Visual Menu Builder designer:

  • Significant developer's productivity gains through rich and interactive designer.
  • Reduced lines of codes required to program the Page with the elegant architecture of the Visual Menu Builder.
  • Reduced learning curve with the ease-of-use since the Visual Menu Builder's usage is very similar to that found in WinForm's built-in menu editor.
  • Reduced overhead in Page's maintenance when required at future development phase.


Uniform Component Designer
Send Feedback
Intersoft WebDesktop > Overview by Technology > Development Environment > Uniform Component Designer

Glossary Item Box

Uniform Component Designer

Most components available in WebDesktop are now equipped with a Uniform Component Designer to complement the features which are not available simply by using standard PropertyGrid. The component designer will pop-up as an external window and any modification done in the component designer will immediately be applied on the DesignSurface of your Visual Studio.

Previously before Global (Uniform) Designer is developed, each component has its own designer. This results in longer component learning time and adaptation. Basically the whole intention behind Uniform Component Designer is the same "look and feel" for every Intersoft component.

Supported Products

This section lists the components which implemented ClickAndSelect technology:

  • WebDesktopManager
  • WebTab
  • WebPaneManager
  • WebToolBar
  • WebMenuBar
  • WebNavPane

Benefits

The following are the list of top benefits offered by Uniform Designer:

  • A new component property configuration experience by using our external fully customized component designer. Using component designer, you will experience convenient property grouping, layouting and a comfortable editing environment.
  • The ability to persist and apply the layouting you have done to the component such as color, style and other things related to the UI appearance of the component. You can later on apply the same appearance to other instance of the same component.
  • The ability to persist the structure of the component so you can save then loads the component structure later on when needed. This is very useful in cases where you have a complex structure so you can simply load the structure without needing to build the structure from scratch anymore.


Interactive PlaceHolderManager Designer

Interactive PlaceHolderManager Designer
Send Feedback
Intersoft WebDesktop > Overview by Technology > Development Environment > Interactive PlaceHolderManager Designer

Glossary Item Box

Introduction

Interactive PlaceHolderManager Designer is a new breakthrough feature for Visual Studio 2005 Development Environment allowing you to work with dockable bars in the designer surface, similar to WinForm-style development experience.

While the PlaceHolderManager designer architecture maintains the docking system of every IBar implemented components (in this release, WebMenuBar and WebToolBar), it still allows you to freely working on the content of the PlaceHolderManager. The content of the PlaceHolderManager is not the type of ITemplate, and therefore enables you to access the controls directly in the code behind without has to use FindControl.

More Details

A PlaceHolderManager is a container represented by a four-edge partitioned table which automatically maintained by the PlaceHolderManager system. The following image illustrates a PlaceHolderManager instance at design time.

When you drag a new PlaceHolderManager instance to a WebForm designer surface, the PlaceHolderManager Wizard will be launched automatically. It will help you to construct the PlaceHolderManager's table system with one button click as seen in following screenshot. The result of the container's table is similar to the above screenshot.

Advanced Features

In the above sections, we have discussed about the basic concepts of the PlaceHolderManager, such as how the PlaceHolderManager can be instantiated in the WebForm designer surface as well as how it looks like in the design time environment.

In this section, provided are several advanced features of the PlaceHolderManager for creating rich and interactive designer experience.

  • Automatic Bar Docking

This feature lets you drag any supported bars to anywhere in the designer surface. You don't need to worry where the bars should be inserted because the PlaceHolderManager system will automatically dock the new bar into available slot according to the specified MaxDockingRows and AllowDockBottom, AllowDockTop, AllowDockLeft and AllowDockRight property. By default, the MaxDockingRows property is set to 2 and all the AllowDockXXX properties are set to True.

With the default settings above, the first dropped Bar will be automatically docked to first row of Top edge. The second dropped Bar will be docked to second row of Top edge. The third dropped Bar will be docked to first row of Left edge. And so on.

For better understanding, the provided screenshots below demonstrate each action in step-by-step presentation.

Drag and drop first Bar to the designer's surface regardless of its insertion point.

The first dropped ToolBar automatically docked to first row of Top edge.

The second dropped ToolBar docked to second row of Top edge, and so on.

  • Customize Bar Docking Area

This innovative feature lets you easily change the docking of a Bar at design time. Oftenly developers would need to change the docking position of Bars in the webform, for instance, changing the second row of top's ToolBar to be docked at Left, or changing the left-docked ToolBar to Bottom, and so on.

In traditional approach, developers would have to manually drag and drop the Bars to the position they wanted. However, it can be troublesome to find the correct insertion point especially in a complex table system.

With this feature, you can quickly change a Bar's docking position by setting the DockingArea property. The PlaceHolderManager system will detect on the changes and automatically move the Bar to the designated position without affecting the content of the PlaceHolderManager or other bars.

The following screenshot shows a ToolBar which DockingArea changed from Top to Left position.

Benefits

The following is a list of top benefits introduced by PlaceHolderManager designer:

  • Significant developer's productivity gains through rich and interactive PlaceHolderManager.
  • Reduced lines of codes required to program the Page with the elegant architecture of PlaceHolderManager which used table system instead of Template.
  • Reduced learning curve with the ease-of-use since the interactive features are similar to WinForm development experience.
  • Reduced overhead in Page's maintenance when required at the future development phase.


Runtime Environment

Runtime Environment
Send Feedback
Intersoft WebDesktop > Overview by Technology > Runtime Environment

Glossary Item Box

This section contains information about runtime environment in WebDesktop.NET.

Hybrid Menu System

True Shape

High Clarity Desktop

Structure Manager

True Dock

Smart Keys


Hybrid Menu System

Hybrid Menu System
Send Feedback
Intersoft WebDesktop > Overview by Technology > Runtime Environment > Hybrid Menu System

Glossary Item Box

Introduction

The menu system incorporates hybrid architecture enabling server side WebContextMenu control and built-in menu system used in other WebDesktop members to use the same menu runtime system, which built upon WebUI.NET Framework and taking advantange of advanced Object concept such as encapsulation and inherittance allowing all Menu system to be running in one hybrid menu runtime system.

For instance, context menu in DesktopManager, menu system in Toolbar's SplitMenu and DropDownMenu, as well as in WebMenuBar and WebContextMenu are all using the same runtime engine. With this architecture, developers will find the same object model or API whenever they need to access or manipulate the context menu. This produces new, unique development experience with enhanced productivity and efficiency by reducing coding efforts.

More Details

The following illustration shows various components that support menu function. However, there is only one runtime menu system to support the menu function in these components; this approach is called hybrid menu system.

Benefits

  • Consistent object model and API for all "menu kind" needs.
  • Easy to use and implement in either client or server side since the object hierarchy and API in client side is exactly the same as in server side.
  • Reduces learning curve since only one set of API that needs to be leveraged.
  • Delivers high performance application with same code base of all "menu kind".
  • Offers greater integration and extensibility among components that support the menu system, such as integration of menu styles from WebContextMenu to DesktopManager and so on.


True Shape

True Shape
Send Feedback
Intersoft WebDesktop > Overview by Technology > Runtime Environment > True Shape

Glossary Item Box

Introduction

TrueShape is an innovative rendering technology which enables round corner shape to be rendered without the needs to use images. It is called TrueShape, because it does not only capable to render round corner between four edges, it also has the ability to blend perfectly into transparent background and filled gradient. With TrueShape, developers can gain more productivity than ever before since they don't have to use photo editing software to create complex images. Instead, they can now configure everything with just few mouse clicks right inside the Visual Studio IDE. With all these capabilities, you can create any kind of themes, for example, the blue Theme of Office Toolbar style or the silver theme, or any colors blending you liked. TrueShape technology is the beginning of new web applications model.

TrueShape features tight integration with other rendering architectures for rich visual styles:

  • Transparent edge
  • Gradient background color
  • Custom fore color
  • Custom border color
  • Grip objects

WebToolBar with TrueShape

In this section, provided are some illustrations of TrueShape implementation in WebToolBar component. Each style are presented in three color schemes which can be easily customized.

Office 2003

Office XP

Office 2000

IE

WebTab with TrueShape

The following shows some of modern visual styles of WebTab in different color schemes.

Benefits

  • Creates professional and great looking visual styles quickly and easily with few properties changes.
  • Achieves modern visual styles without the need of images.
  • Faster page loading since no images are needed.
  • Improved productivity with this time-saving feature, since you no longer need to use external photo editing software and spent time creating the background color, round corners and so on.


High Clarity Desktop

High Clarity Desktop
Send Feedback
Intersoft WebDesktop > Overview by Technology > Runtime Environment > High Clarity Desktop

Glossary Item Box

Introduction

HighClarityDesktop is the main technology behind everything found in WebDesktop.NET. It is the technology enabling high end functions related to Windows management, such as the capability to perform minimize, maximize, resize, move and many others. It resembles many behaviors similar to today's desktop such as Windows XP, including the behavior when WindowTaskBarButton is clicked, double clicked, mouse up & down and more, the behavior of the shortcut, the behavior of the desktop itself until the most detailed behavior of window events. With HighClarityDesktop, it then enable other components in the WebDesktop.NET to fit perfectly into DesktopManager with the same architecture, such as WebDialogBox, WebNotification and WebButton which has built-in integration right into DesktopManager.

Features

The HighClarityDesktop enables following capabilities to work in web browsers replicating almost 98% of desktop behaviors:

  • Window Movement through drag and drop operation on Title bar element.
  • Window Movement support in IFrame mode.
  • Window Minimize, Maximize and Restore through Window Options element.
  • Window Minimize, Maximize and Restore through Context Menu.
  • Window Minimize and Maximize through double click on Title bar element.
  • Window Minimize and Maximize through single click on TaskBar window element.
  • Window Close through Window Options element.
  • Window Close through Context Menu.
  • Window Close through Shortcut Key (Ctrl+Alt+C).
  • Window Close by double clicking on ControlBox.
  • Window Resizing on eight edges through drag and drop operation.
  • Window Resizing support in IFrame mode.
  • Window Navigation through Shortcut Key (Ctrl+1 and Ctrl+Shift+1).
  • Window Navigation through TaskBar element.
  • Window Activation through double clicking on Shortcut Icon.
  • Window Context Menu through ControlBox.
  • Window Context Menu through right click on Title bar element.
  • Window Minimize support without TaskBar.
  • Window Tiling (Cascading, Horizontal and Vertical) operation through Desktop context menu.
  • Window Animation support when minimize, maximize or restore operation is performed.
  • Shortcut Navigation through keyboard arrow keys and single mouse click.
  • Shortcut Movement through drag and drop operation.
  • Shortcut Automatic Arrangement.
  • Shortcut Open/Launch through keyboard key (Enter) and double click.
  • Desktop Context Menu through right click on Desktop.
  • TaskBar Context Menu.
  • TaskBar Click for Window activation.
  • Show Desktop operation through Desktop context menu.
  • Show/Hide Desktop Icons through Desktop context menu.
  • TaskBar Customization through TaskBarLeft and TaskBarRight template.
  • TaskBar Window's Automatic Resizing.
  • TaskBar Window's Automatic Tooltip when Caption's text is truncated.

All above capabilities can also be performed through client side API and object model.

More Details

The following screenshot illustrates a sample of DesktopManager with some open Windows, ContextMenu and Shorcut Icons.

For more information on DesktopManager concepts, click on following links:

  • Desktop
  • Shortcut
  • Window
  • TaskBar
  • ContextMenu

Benefits

  • Easy to use, similar with desktop application's styles and behaviors.
  • Enhanced user experience with richer Window-style navigation system.
  • Increased productivity with better, uncluttered workspaces.
  • Improved user interactions with dynamic, configurable Window state during runtime such as Move, Minimize, Maximize and more.
  • Richer user personalization options.


Structure Manager

Structure Manager
Send Feedback
Intersoft WebDesktop > Overview by Technology > Runtime Environment > Structure Manager

Glossary Item Box

Introduction

Structure Manager works in the conjunction with GenericPersistence technology which enables you to load or save the structure of a component programmatically at runtime.

With this architecture, you can have external configuration saved in either database or xml-format file to be loaded dynamically at runtime instead of hard-coding the items in designtime. The external configuration concept allows you to build more flexible and extensible applications which require fewer changes to User Interface or application's codes in the future.

More Details

Intersoft's components which have at least one Collection-type property implemented Structure Manager API for loading and saving the structure programmatically at runtime.

For instance, the following screenshot illustrates the API of DesktopManager for loading the Shortcuts and Windows configuration from a xml file which saved by the user in other event.

The Structure Manager API used the same GenericPersistence technology and works in harmony with Design-time Structure Manager.

Benefits

  • Provides greater scalability and extensibility architecture for your applications.
  • Offers better personalization options for end users.
  • Increased developer's productivity through reusable xml-based structures.
  • Faster implement with reduced learning time through consistent API and function in entire component suites.


True Dock

True Dock
Send Feedback
Intersoft WebDesktop > Overview by Technology > Runtime Environment > True Dock

Glossary Item Box

Introduction

TrueDock is the technology allowing end users to dock a Bar (either Toolbar or Menubar) into four edges of designated content area. It is a truly powerful docking technology recognizing its capabilities to intelligently dock into multiple bars or dock into the same row in any edges! It also enables a Bar to be floated when desired. TrueDock automatically maintain its configuration and adjust required settings when the docking changed from horizontal to vertical position. All of these capabilities enable you to offer a high level of user interactivity and personalization for your end users.

More Details

TrueDock works in conjunction with PlaceHolderManager component to partition a Page into several zones. By using the PlaceHolderManager, any bars can be docked within the PlaceHolderManager region in any of four supported edges.

TrueDock supports multiple PlaceHolderManager in one Page. The bars owned by its PlaceHolderManager will be managed by its own PlaceHolderManager and did not affect other zones in other PlaceHolderManager. See following illustration for more details.

In above illustration:

  • ToolBar1 or ToolBar2 can be moved to the available bottom or right edge of PlaceHolderManager1 zone.
  • ToolBar3 or ToolBar4 can be moved to the available left or bottom edge of PlaceHolderManager2 zone.
    ToolBar can be moved by dragging the Grip/Handle presented in the left edge of a ToolBar.

Multiple Rows Docking

The TrueDock technology is also capable to handle Multiple Rows configuration. MultipleRows is a feature in PlaceHolderManager indicating whether more than one Bar can be docked in same edge. For instance, docking two toolbars at top edge or docking three toolbars at right edge.
With this capability, end users can drag a Bar and move it to any available docking area including the unoccupied edges and available slot of occupied edges. Other complex docking scenarios such as same row docking and floating are also properly supportted by the TrueDock technology.
The following screenshot shows the runtime environment of Bars in MultipleRows configuration.

Benefits

  • Increased user experience with the capability to dock bars in any of four edges in the zone.
  • Added values to application with the advanced and powerful docking mechanism.
  • More end users personalization options.
  • Enhanced productivity with better screen real estate utilization provided by the docking mechanism.


Smart Keys

Smart Keys
Send Feedback
Intersoft WebDesktop > Overview by Technology > Runtime Environment > Smart Keys

Glossary Item Box

Introduction

One of the most essential requirements in today's Rich Internet Applications (RIA) and web applications is the extensive keyboard supports which allowing users to easily invoke commands and access to parts of User Interface element easily and quickly through keyboard. The key access support was previously available in desktop-applications only since popular desktop such as Windows(r) has provided comprehensive API and integrated runtime environment for this specific keyboard access features. Keyboard access is also one of the standards required in Graphical User Interface (GUI) applications.

WebDesktop.NET comes with a wide variety of keyboard access support, called SmartKeys technology. SmartKeys enables extensive keyboard access support to your web applications in the same way and manner as in desktop-based applications.

More Details

SmartKeys technology is tightly integrated with WebDesktop.NET runtime system such as WebDesktopManager, WebToolBar, WebMenuBar and WebContextMenu. SmartKeys consists of behaviors and functionalities in the following:

  • AccessKey invocation by pressing Alt, followed by the designated AccessKey. AccessKey is typically a character appearing in Underline style.
  • Override browser-level accelerator keys. For instance, you can configure a "File" MenuCommand and set its AccessKey to "f". At runtime when Alt+F is pressed, the File MenuCommand will be invoked instead of showing browser's File menu.
  • True focus behavior. The command access through accelerator key will not affect the current input's focus, so you can continue typing and editing after you cancel the operation of the invoked command (for instance, press Esc to cancel the displayed menu).
  • Cross frame. The keyboard access will work properly regardless of where the current focus is.
  • Tight integration with WebDesktopManager. When the controls with SmartKey-enabled are hosted in DesktopManager instance, the keyboard access will be scoped only to the current active window, without affecting AccessKey definition in other WebDesktopWindow.
  • ShowFocusBorder feature. This feature offers comprehensive accessibility support as defined in US Section 508, which enables users to navigate between items by pressing Tab or Shift+Tab.
  • When ShowFocusBorder is enabled, pressing Enter or Space will invoke the command of active index.
  • Item level AccessKey. For better flexibility and customization, you can define AccessKey of item level commands individually.
  • Built-in navigations for Menu system. When a Menu is shown, you can start navigating its items and submenu by using arrow keys, without requiring additional effort for focusing it.
  • Shortcut AccessKey. Regardless of where your current input is, you can easily access to a command by pressing the ShortcutKey associated to the command.

The following illustration represents a brief picture of the SmartKeys features.

Supported Products

This technology applies to following listed products:

  • WebToolBar
  • WebMenuBar
  • WebContextMenu
  • WebTab

Benefits

  • Increased application accessibility through industry-standard keyboard access supports.
  • Maximizing the value of your application by adding comprehensive accessibility supports defined in US Section 508.
  • Enhanced user experience by allowing entry users to easily and quickly access to commands using keyboard, in the same way and manner as in desktop GUI applications.
Some of keyboard access features in SmartKeys are not available in browsers other than Internet Explorer due to limitations of API and browser capabilities. For Mozilla-browsers, these features will be automatically supported in upcoming Mozilla 3.0 browsers. More information about Mozilla 3.0 keyboard supports, please see Accessible DHTML


Trouble Shooting

Trouble Shooting
Send Feedback

Glossary Item Box


Version 1.5

Version 1.5
See Also Send Feedback

Glossary Item Box

Final Release Notes

The following notes applied to final version of WebDesktop.NET 1.5.

  • WebDesktop.NET 1.5 requires WebUI.NET Framework 3.0 Build 31 or above.
  • If you have installed older version of WebUI.NET Framework 3.0, you can update to Build 31 by using Update Manager, or obtain latest WebUI.NET Framework Installer and reinstall. You can now download latest WebUI.NET Framework installation package in Developer Network 2.0 under My Components application.
  • The WebUI.NET Framework 3.0 Build 31 is fully backward compatible with following listed existing products. With the full compatibility design, you can safely replace the Framework scripts and assemblies with the new version from either Update Manager or full reinstallation.
    • WebDesktop.NET 1.0 for Visual Studio 2005
    • WebGrid.NET Enterprise 4.0
    • WebCombo.NET 3.0
    • WebInput.NET 2.0
  • C# Samples and C# Tutorials have been updated to demonstrate new features and new components available in WebDesktop.NET 1.5.
  • Products Documentation has been updated to use Visual Studio 2005 Style for consistency and more readability. All public classes and members are now documented.
  • WebDesktop.NET 1.5 can run side-by-side with previous version of WebDesktop.NET so you can work with different version of WebDesktop.NET in different web projects on a single development machine.

What's new in WebDesktop.NET 1.5

WebDesktop.NET 1.5 for Visual Studio 2005 is a significant major release of WebDesktop.NET product family. The new version contains major performance enhancements to existing components such as faster response in WebDesktopManager user interactions and optimized codes in Bar components for more compact size.

WebDesktop.NET 1.5 adds three new components under its umbrella. The new components are WebNotification, WebFlyPostBackManager and WebExplorerPane.

For more information on the enhancements, new features and new components in details, see What's new in V1.5

Behavior changes that may affect your projects

  • None. You should be able to apply WebDesktop.NET 1.5 to your projects, rebuild and run it without additional efforts in code changes.

Enhancements and bug fixes since initial version 1.0

  • WebGrid's Context Menu, WebCombo's Result Box, ToolBar's DropDown Box positions is incorrect when placed inside a WebPaneManager.
  • Display issue when using WebTab arrow button to scroll to the first WebTab.
  • Unable to use external CSS in WebTab.
  • WebSplitter issue on nested Iframe with Intersoft WebUI control(s) inside the iframe(s).
    Occurs only in Firefox Mozilla.
  • WebToolBar and WebMenuBar Separator command item is not hidden when Visible is set to false.
  • Incorrect behaviour when changing WebDesktopWindow's caption from client-side.
  • WebDesktopWindow can still be resized while AllowResize is set to No.
  • WebDialogBox doesn't disable other buttons (in background screen) when working in standalone mode.
  • Javascript error occurs when PaneManager is inside WebTab.
  • When a ToggleButton's Pushed = True, calling SetIsEnabled method reverts the style back to Normal while it should be Active.
  • Visible = false does not work for WebPane which parent GroupType is VerticalTile.
  • Enhanced SetVisible method to handle more scenarios in WebPaneManager.
  • Add SetWidthValue method to WebPane client side object, which can be used to set the Pane's width programmatically in client side.
  • ToolBar merging caused JavaScript error when the parent PlaceHolderManager has its BarVisible property set to False.
  • ToolBar merging now supports multiple child Tool Command merging.
  • Improved ToolBar merging mechanism (now more reliable and stable).
  • MoreItem in ToolBar shows all Items instead of only invisible Items.
  • WebTab now supports mouse over implementation for ComplexImages rendering mode.
  • Fixed style blinking when mouse over in WebTab and RenderMode is set to ComplexImages or Simple.
  • WebTab no longer displays gaps when RenderMode is set to ComplexImages and Enable/Disable client API is called.
  • Improved performance during window switching and moving in WebDesktopManager.
    Also applied to WebGrid Build 11
  • IFrame's content in WebPaneManager is not shown in the first page load.
    Occurs only in Mozilla
  • WebToolbar and WebMenubar caused infinite loop when used in HTA (HTML Application).
  • ControlBoxImage is not displayed properly when ControlBox is set to Yes in WebDialogBox component.
  • WebDesktopManager generates error when dropped to design surface in Visual Studio 2005 when using Swedish Language Settings.
    Requires WebUI.NET Framework 3 Build 19
  • TabPages displayes blank page when IFrameAutoLoadContent is set to True.
  • Error "Could not find file 'C:\WINDOWS\SYSTEM32\websplitter.isl'." Occured during full postback.
  • Javascript error occurs when using standalone WebToolBar with SplittButton/DropDown and IntegratedTo property is set to PlaceHolderManager.
  • WebButton can't be integrated to WebDesktop Manager when used in WebDesktopWindow with InlineContent mode.
  • Error "Access Denied" occurs when using External URL as WebDesktopWindow's ContentURL and WebDesktopShortcut's TargetURL.
  • JavaScript error "Expected ;" occurs when WebToolBar is placed inside PlaceHolderManager.
  • WebToolBar and WebMenuBar AutoPostBack feature do not trigger ASP.NET client side validation.
  • Collapse method of WebNavPane now supports collasping to right and down direction.
  • FontStyle color for Dropdown/SplitButton is incorrectly reflected when the toolcommand is active and mouse event is mouse up.
  • WebToolBar now supports CancelBubbling event before postback.
  • In WebNavPane Designer, bars collection vanished after previewing Layout then click OK.
  • WebToolBar could not be merged when adding a new Tab and setting one of the toolBar's display to false.
  • WebToolBar and WebMenuBar AutoPostBack feature do not trigger ASP.NET client side validation.
  • In WebTab, cycling through RenderMode property make Tab border disappear.
  • Improved mouse over mechanism when RenderMode is set to RoundCorner in WebTab.
  • In WebContextMenu, Relative URL in ImageURL of menu item under SubMenu is not properly translated.
  • In WebToolBar, unloading merged bar caused Java Script error and corrupted display.
  • Unable to set Visible property of WebToolBar and WebMenuBar programmatically.
  • When WebToolBar is merged, Separator ToolCommand is not displayed.
  • In WebToolBar, ToggleButton is not toggled on Initial Load.
  • OnCommandClick server side event is not executed when ToolBar is merged.
  • Bug in ToolBar docking when using PlaceHolderManager and WebToolBar.

See Also

Getting Started
{What's new in v1.5}


Running Samples

Running Samples
Send Feedback

Glossary Item Box

After you have successfully finished the WebDesktop.NET 1.5 Installation, you can directly launch the companion samples by choosing WebDesktop.NET 1.5 Samples from Start Menu > Programs > Intersoft WebUI Studio.NET > WebDesktop.NET 1.5 for Visual Studio 2005 program group. You can try the samples using Internet Explorer or Mozilla-based browsers.

In order to demonstrate real world scenarios in the companion samples, most of the samples require other Intersoft's products to be installed as well. Starting from v1.5, we are no longer including the products trial's assemblies into the installation package to reduce download size.

The following products are required for running the samples in your local machine:

  • WebGrid.NET Enterprise 4.0
  • WebCombo.NET 3.0
  • WebInput.NET 2.0

If you already purchased Suite or Subscription, you can download latest version of the above products and reference it to the samples then relaunch the samples in browser.

If you have not purchased products listed above, you can download the 30-days trial version of WebUI Studio.NET Suite. To download, visit Try WebUI Studio.NET page.

Additional Resources

Instead of running the samples locally, you may also want to:

  • Launch WebDesktop.NET 1.5 Online Live Demo
  • See screenshots in Images Gallery


Optimization Architectures

Optimization Architectures
Send Feedback
Intersoft WebDesktop > Overview by Technology > Optimization Architectures

Glossary Item Box

This section contains information on how to optimize WebDesktop.NET.

In This Section

XML Compressor

CSS Optimizer


XML Compressor

XML Compressor
Send Feedback
Intersoft WebDesktop > Overview by Technology > Optimization Architectures > XML Compressor

Glossary Item Box

Introduction

Intersoft's main framework, the WebUI.NET Framework extensively utilizes XML as its main storage for client side settings. There are many advantages by using XML compared to traditional approaches which writes unstructured Array or lot of scripts for client side settings. For instance, the state can be easily managed, accessed, changed and updated in consistent fashion and structured manner. There's one weakness though, a big price that has to be paid for all advantages, which is the xml produces a bit larger output since its tag name and attributes are self describing. XmlCompression is born to solve this dillema! Intersoft developed its own compression and decompression algorithm in order to compress the XML storage into 40-60% smaller size. This significantly improves the performance of page load in narrow bandwidth. This technology is also extensively used in FlyPostBack technology to reduce the posted string and overally improve response time to 40%.

Comparison

The following shows xml sample of a control's instance and compares the uncompressed and compressed output.

Uncompressed (Original) - 5 KB

<

xml id='WebDesktopManager1_x'>
<

WebDesktopManager FrameStyle="W5980" ShortcutIconsVisible="True" TaskBarStyle="W6262" EnableContextMenu="True" OptimizeCss="True" OptimizeCssName="True" GroupCssStyles="False" ServerUniqueID="WebDesktopManager1" xmlInputHiddenUniqueID="WebDesktopManager1$WebDesktopManager1_h">
<

Windows>
<

WebDesktopWindow Text="Disabled Samples" Name="wndDisabledSamples" ControlBoxImage="~/Images/X-16.gif" />
<

WebDesktopWindow Text="Welcome to WebDesktop.NET" Name="wndWelcome" />
</

Windows>
<

ShortcutIcons>
<

WebDesktopShortcut Name="scWelcome" Text="Welcome to WebDesktop.NET" Image="/WebDesktopSamples/Images/welcome-32.gif" WindowName="wndWelcome" ToolTip="Display Welcome screen." TargetControlBoxImage="/CommonLibrary/Images/WebDesktop/" />
<

WebDesktopShortcut Name="scWebPad" Text="WebPad" Image="/WebDesktopSamples/Images/webpad-32.gif" TargetURL="WebPad.aspx" WindowName="wndWebPad" ToolTip="The Web version of Notepad. Featuring Tabbed interface for text editing and Dockable Toolbar." TargetControlBoxImage="/WebDesktopSamples/Images/webpad-16.gif" />
<

WebDesktopShortcut Name="scWebOutlook" Text="WebOutlook" Image="/WebDesktopSamples/Images/outlook-32.gif" TargetURL="WebOutlook.aspx" WindowName="wndWebOutlook" ToolTip="The Web version of Outlook, demonstrating WebPaneManager.NET" TargetControlBoxImage="/WebDesktopSamples/Images/outlook-16.gif" />
<

WebDesktopShortcut Name="scNewEmail" Text="Write Email" Image="/WebDesktopSamples/Images/writemail-32.gif" TargetURL="NewEmail.aspx" WindowName="wndNewEmail" ToolTip="Demonstrate integration with WebCombo.NET" TargetControlBoxImage="/CommonLibrary/Images/WebDesktop/" />
<

WebDesktopShortcut Name="scExplorer" Text="WebExplorer" Image="/WebDesktopSamples/Images/webexplorer-32.gif" TargetURL="Explorer.aspx" WindowName="wndExplorer" Visible="False" ToolTip="The Web version of Windows Explorer, demonstrating WebGrid.NET Enterprise integration." TargetControlBoxImage="/CommonLibrary/Images/WebDesktop/" />
<

WebDesktopShortcut Name="scChangeStyle" Text="Change Desktop Style" Image="/WebDesktopSamples/Images/style-32.gif" TargetURL="ChangeStyle.aspx" WindowName="wndChangeStyle" ToolTip="Select theme for the Desktop" TargetControlBoxImage="/WebDesktopSamples/Images/style-16.gif" />
<

WebDesktopShortcut Name="scMyCust" Text="My Customers" Image="/WebDesktopSamples/Images/mycust-32.gif" TargetURL="MyCustomers.aspx" WindowName="wndMyCust" Enabled="False" ToolTip="A sample application using Northwind database. Demonstrating WebDialogBox, WebMenu, and the entire WebUI Studio.NET integration." TargetControlBoxImage="/CommonLibrary/Images/WebDesktop/" />
<

WebDesktopShortcut Name="scSampleByProducts" Text="Sample by Products" Image="/WebDesktopSamples/Images/sample-32.gif" WindowName="wndSampleByProducts" TargetControlBoxImage="/WebDesktopSamples/Images/sample-16.gif" />
</

ShortcutIcons>
<

TaskBarSettings />
<

ImagesSettings />
<

WindowSettings ScrollBarCssClass="" ContainerStyle="W9473" CommandButtonDisabledStyle="W11519">
<

WindowStyle Normal="W10016" Over="W9639" Active="W9992" />
<

CaptionStyle Normal="W10160" Over="W9783" Active="W10136" />
<

CaptionButtonStyle Normal="W11334" Over="W10957" Active="W11310" />
<

CommandButtonStyle Normal="W11257" Over="W10880" Active="W11233" />
</

WindowSettings>
<

ClientSideEvents OnWindowCreating="OnWindowCreating" />
<

TextSettings />
<

ShortcutSettings />
<

TaskBarButtonStyle Normal="W8515" Over="W8138" Active="W8491" />
<

ShortcutStyle Normal="W7790" Over="W7413" Active="W7766" />
<

MenuStyles>
<

System FrameStyle="W9064" SeparatorStyle="W9925" HasBackgroundStrip="False" BackgroundStripColor="FFFFFF" BackgroundStripColor2="C4C3AC">
<

ItemStyle Normal="W10001" Over="W9624" Active="W10036" />
<

DisabledItemStyle Normal="W11342" Over="W10965" Active="W11318" />
<

CheckedItemStyle Normal="W11114" Over="W10737" Active="W11149" />
</

System>
<

Application FrameStyle="W9915" SeparatorStyle="W10776" BackgroundStripColor="FFFFFF" BackgroundStripColor2="C4C3AC">
<

ItemStyle Normal="W10852" Over="W10475" Active="W10828" />
<

DisabledItemStyle Normal="W12193" Over="W11816" Active="W12169" />
<

CheckedItemStyle Normal="W11965" Over="W11588" Active="W11941" />
</

Application>
</

MenuStyles>
</

WebDesktopManager>
</

xml>

Compressed - 3.5 KB

<

CompressedXml>
<

WebDesktopManager a="W5980" ShortcutIconsVisible="b" TaskBarStyle="W6262" EnableContextMenu="b" OptimizeCss="b" OptimizeCssName="b" GroupCssStyles="d" ServerUniqueID="e" XmlCompressionEnabled="b" xmlInputHiddenUniqueID="e$WebDesktopManager1_h">
<

Windows>
<

C k="Disabled Samples" l="wndDisabledSamples" ControlBoxImage="~/k/X-m.n" />
<

C k="o p q.r" l="s" />
</

Windows>
<

ShortcutIcons>
<

E l="scWelcome" k="o p q.r" n="/u/k/welcome-w.n" o="s" p="Display o screen." q="/z/k/q/" />
<

E l="scWebPad" k="ab" n="/u/k/ac-w.n" r="ab.ad" o="wndWebPad" p="af ag ah ai Notepad. Featuring Tabbed interface an text editing aq Dockable Toolbar." q="/u/k/ac-m.n" />
<

E l="scWebOutlook" k="au" n="/u/k/av-w.n" r="au.ad" o="wndWebOutlook" p="af ag ah ai Outlook, ay WebPaneManager.r" q="/u/k/av-m.n" />
<

E l="scNewEmail" k="Write Email" n="/u/k/writemail-w.n" r="NewEmail.ad" o="wndNewEmail" p="Demonstrate bh with WebCombo.r" q="/z/k/q/" />
<

E l="scExplorer" k="WebExplorer" n="/u/k/webexplorer-w.n" r="Explorer.ad" o="wndExplorer" Visible="d" p="af ag ah ai Windows Explorer, ay WebGrid.r Enterprise bh." q="/z/k/q/" />
<

E l="scChangeStyle" k="Change bv Style" n="/u/k/bx-w.n" r="ChangeStyle.ad" o="wndChangeStyle" p="Select theme an cc bv" q="/u/k/bx-m.n" />
<

E l="scMyCust" k="My Customers" n="/u/k/mycust-w.n" r="MyCustomers.ad" o="wndMyCust" Enabled="d" p="A ck application using Northwind database. Demonstrating WebDialogBox, WebMenu, aq cc entire WebUI Studio.r bh." q="/z/k/q/" />
<

E l="scSampleByProducts" k="Sample by Products" n="/u/k/ck-w.n" o="wndSampleByProducts" q="/u/k/ck-m.n" />
</

ShortcutIcons>
<

TaskBarSettings />
<

ImagesSettings />
<

WindowSettings ScrollBarCssClass="" ContainerStyle="W9473" CommandButtonDisabledStyle="W11519">
<

WindowStyle x="W10016" y="W9639" z="W9992" />
<

CaptionStyle x="W10160" y="W9783" z="W10136" />
<

CaptionButtonStyle x="W11334" y="W10957" z="W11310" />
<

CommandButtonStyle x="W11257" y="W10880" z="W11233" />
</

WindowSettings>
<

ClientSideEvents OnWindowCreating="OnWindowCreating" />
<

TextSettings />
<

ShortcutSettings />
<

TaskBarButtonStyle x="W8515" y="W8138" z="W8491" />
<

ShortcutStyle x="W7790" y="W7413" z="W7766" />
<

MenuStyles>
<

System a="W9064" ab="W9925" HasBackgroundStrip="d" ad="dx" ae="dy">
<

T x="W10001" y="W9624" z="W10036" />
<

U x="W11342" y="W10965" z="W11318" />
<

V x="W11114" y="W10737" z="W11149" />
</

System>
<

Application a="W9915" ab="W10776" ad="dx" ae="dy">
<

T x="W10852" y="W10475" z="W10828" />
<

U x="W12193" y="W11816" z="W12169" />
<

V x="W11965" y="W11588" z="W11941" />
</

Application>
</

MenuStyles>
</

WebDesktopManager>
<

ISXMLMapping>
<

NodeKey>VUTEC</NodeKey>
<

NodeValue>CheckedItemStyleDisabledItemStyleItemStyleWebDesktopShortcutWebDesktopWindow</NodeValue>
<

AttrKey>zadaeanlxyabqrkpo</AttrKey>
<

AttrValue>ActiveBackgroundStripColorBackgroundStripColor2FrameStyleImageNameNormalOverSeparatorStyleTargetControlBoxImageTargetURLTextToolTipWindowName</AttrValue>
<

ValKey>mwaqaddyzaybvddxannkbhraiavckbxccafpbahagqeuauacabos</ValKey>
<

ValValue>1632andaspxC4C3ACCommonLibrarydemonstratingDesktopFalseFFFFFFforgifImagesintegrationNETofoutlooksamplestyletheThetoTrueversionWebWebDesktopWebDesktopManager1WebDesktopSamplesWebOutlookwebpadWebPadWelcomewndWelcome</ValValue>
</

ISXMLMapping>
</

CompressedXml>

The more redundant tags, attributes or values in the XML, the larger its saving percentage. The Xml Compressor works by checking redundant tags or attributes and map it with unique one character. Enabling Xml Compressor can also help you to prevent sensitive data to be seen by users (via View Source) since the Xml appears in kind of obfuscated form which makes it nearly impossible to be read.

How to enable XML Compressor

Xml Compressor can be enabled by using one of following techniques:

  • Individual control's configuration

All Intersoft's components that built upon WebUI.NET Framework 3.0 will automatically expose XmlCompressionEnabled property. This property is set to False by default. You can set it to True to enable xml compression for that specific instance.

  • Application wide configuration per product

You can also administer a certain product to have all its instances to use xml compression in the entire application. This can be done by adding following key under <appSettings> in web.config. Note that the following sample will only affect "WebDesktop V1.0.2006" component (also includes all components inside WebDesktop)

<add key="ISNet.WebUI.WebDesktop.v1_5_2006.XmlCompressionEnabled" value="true"></add>

Supported Products

This section lists the products which have been implemented to support Xml Compressor.

  • WebGrid.NET Enterprise 4.0 for Visual Studio 2005 (Build 4.0.6200.257+)
  • WebCombo.NET 3.0 for Visual Studio 2005 (Build 3.0.5000.257+)
  • WebInput.NET 2.0 for Visual Studio 2005 (Build 2.0.5000.2511+)
  • WebDesktop.NET 1.0 for Visual Studio 2005 (Build 1.0.2006.1+)

Benefits

The following lists some of the top benefits offered by XmlCompressor:

  • Faster page load performance with reduced output size.
  • Enables better scalability and extensibility as the application become richer in features.
  • Does not sacrifice the main function of Xml-based storage.
  • Faster response time when enabled in FlyPostback supported controls.


CSS Optimizer

CSS Optimizer
Send Feedback
Intersoft WebDesktop > Overview by Technology > Optimization Architectures > CSS Optimizer

Glossary Item Box

Introduction

Since all Intersoft's components and new architectures are dealing with Web technology, Intersoft has decided to develop its own technology in order to optimize the output of the component to produce smaller output size. This optimizing technology solves many scalability and performance issues found in today's web application. CSSOptimizer enables all Intersoft's components to use abbreviated class name (optimizing up to 70%), and automatic CSS class grouping which remove repetitive styles and group them into as few selector as possible. For instance, a generated Style currently produces its name as "WebGrid1-LayoutSettings-FrameStyle" which is considered quite a long string. Now it can be as short as "W2703". The CSS optimization can be applied automatically without code changes to any member of WebUI Studio.NET family, whether it is WebGrid, or WebCombo, or WebDesktop. This was made possible because the CSSOptimizer technology is built on the Framework level.

Comparison

The following shows a comparison between original generated css styles with optimized css styles.

Original css output

<style

 id="ISWebUI_Styles" type="text/css">
.WebDesktopManager1-FrameStyle

{background-color:WhiteSmoke;}
.WebDesktopManager1-WindowSettings-WindowStyle-Normal

{background-color:White; font-family:Tahoma; ...}
.WebDesktopManager1-WindowSettings-WindowStyle-Active

{background-color:White; font-family:Tahoma; ...}
.WebDesktopManager1-WindowSettings-CaptionStyle-Normal

{background-color:Gray; font-family:Tahoma; ...}
.WebDesktopManager1-WindowSettings-CaptionStyle-Active

{background-color:Navy; font-family:Tahoma; ...}
...
</style>

Optimized css output

<

style id="ISWebUI_Styles" type="text/css">

.W4615{background-color:WhiteSmoke;}
.W8710{background-color:White; font-family:Tahoma; ...}
.W8686{background-color:White; font-family:Tahoma; ...}
.W8795{background-color:White; font-family:Tahoma; ...}
.W8129{background-color:White; font-family:Tahoma; ...}

<style>

Notice that each automatic-generated style name will be shortened to use 5 unique digit characters when optimized. With this capability, you can put any number of instances regardless of the control's depth without has to worry the length of generated style name.

Features

CSS Optimizer technology features tight integration with other architectures listed in the following:

  • Theme Architecture
  • WebUI Style Manager
  • Layout Manager
  • Style Preview

How to enable CSS Optimizer

You can enable CSS Optimizer only at application-level by configuring the key in web.config such as shown in the following sample.

<

add key="ISNet.WebUI.v3_0_5000.OptimizeCss" value="true"></add>

<

add key="ISNet.WebUI.v3_0_5000.OptimizeCssName" value="true"></add>

When Intersoft's Theme is also applied in the web application, the controls will obtain the setting defined in the Theme configuration file (istheme.config).

Supported Products

This section lists the products which have been implemented to support Xml Compressor.

  • WebGrid.NET Enterprise 4.0 for Visual Studio 2005 (Build 4.0.6200.257+)
  • WebCombo.NET 3.0 for Visual Studio 2005 (Build 3.0.5000.257+)
  • WebInput.NET 2.0 for Visual Studio 2005 (Build 2.0.5000.2511+)
  • WebDesktop.NET 1.0 for Visual Studio 2005 (Build 1.0.2006.1+)

Benefits

The following lists some of the top benefits offered by CSS Optimizer:

  • Faster page load performance with reduced output size.
  • Enables better scalability and extensibility as the application become richer in features.
  • Provides better performance and usability when used in conjunction with Theme architecture.
  • Reduced output size up to 60% since the css class name is not only affecting the style definition. It also properly applied to the Xml-based client storage and control's rendering output.


Essential Concepts

Essential Concepts
Send Feedback
Intersoft WebDesktop > Essential Concepts

Glossary Item Box

This section contains the essential concepts of WebDesktop.NET.

In This Section

The Orchestration of Theme Architecture, WebStyleManager and Deployment

Styles Inheritance model for Uniform Look and Feel across entire Application

WebForm Design Guidelines

Performance Guidelines


The Orchestration of Theme Architecture, WebStyleManager and Deployment

The Orchestration of Theme Architecture, WebStyleManager and Deployment
See Also Send Feedback
Intersoft WebDesktop > Essential Concepts > The Orchestration of Theme Architecture, WebStyleManager and Deployment

Glossary Item Box

Introduction

Intersoft has implemented its own unique theme architecture since WebUI.NET Framework 1.0 which enables a definition of xml-based layout file to be reusable and applied across entire web application to produce consistent visual styles.

At a glance, the theme architecture consists of multi-level inheritable object model represented in following diagram:

WebUI StyleManager comes along in WebDesktop.NET member to provide the capabilities for managing and deploying themes within a web application. It offers Visual Theme editing functions allowing designer to easily work with the components' hierarchy as well as out-of-the-box experience for style editing and previewing.

Workflow Diagram

The following diagram shows the relations and workflow between theme architecture, WebUI StyleManager and theme deployment in more details.

WebUI StyleManager acts as standalone WinForm application allowing designer to work independently. StyleManager will automatically detect all installed Intersoft's components which based on WebUI.NET Framework and allow designers the style for the installed components in WYSIWYG fashion. In the theme deployment process, StyleManager will connect to the web application and automatically deploy necessary files into the specified folder. The deployed theme project will be named as "istheme.config" in the root of your web application.
Administrators or developers can build the application without has to concern the design or style of the component. The application can be deployed as usual through XCOPY deployment to server.
When the application is running and requested through browser, WebUI.NET Framework (through Theme architecture) will detect for istheme.config file and automatically apply the contained theme information and component's style definition to the requested page.

Teamwork View

With the tight integration between WebUI.NET Framework, Theme architecture and WebUI StyleManager; it opens the possibility for better team-mode working where designers can work with developers in parallel. The result is significant productivity enhancement and better resources utilization for further extensibility.

The following illustration shows the orchestration in teamwork view.

See Also

{Standalone WebStyle Manager}
WebStyle Manager Features
Theme Architecture


Styles Inheritance model for Uniform Look and Feel across entire Application.

Styles Inheritance model for Uniform Look and Feel across entire Application.
Send Feedback
Intersoft WebDesktop > Essential Concepts > Styles Inheritance model for Uniform Look and Feel across entire Application.

Glossary Item Box

Introduction

WebDesktop.NET's products are designed with consistent object model and interfaces to make it possible for them to integrate and interact with each other during both designtime and runtime.

At a glance, there are 3 level of style integration which developers can take advantage to design a uniform look and feel in the entire application with minimum efforts.

The root Style begins at WebDesktopManager instance which act as "universal shell" for the rest component members. The WebDesktopManager contains master style definitions such as in the following:

  • WindowSettings
    The global settings which all Windows should inherit. This includes configuration of default Window behavior's values such as BorderType, AllowResize, AllowClose and so on.
  • WindowStyle
    It includes the dynamic style definition such as Normal, Over and Active style for a Window. You can also customize the complex images of a Window in ImagesSettings when the BorderType is set to use ComplexImages.
  • CommandButtonStyle
    The dynamic style definition for CommandButton.
  • CommandButtonDisabledStyle
    The disabled style of CommandButton.
  • MenuStyles
    It includes two global styles for Menu. They are:
    • System
      The menu style used in DesktopManager's system menu, such as in Desktop context menu (when right cliick on desktop) and in Context menu (when right click on title bar)
    • Application
      This style definition will be used for all Menu instances in the application.
With the global style definition at DesktopManager level, other component members would be able to lookup for the configuration and apply it automatically during runtime.

The second level of Style inheritance is managed by PlaceHolderManager instance. PlaceHolderManager represents the container for Bar-based items such as ToolBar, MenuBar and others. It includes the following style definition:

  • WebMenuBarStyleSettings
    The styles definition for MenuBar.
  • WebToolBarStyleSettings
    The styles definition for ToolBar.
  • MenuStyleSettings
    The styles definition for Menu. When the PlaceHolderManager is integrated to DesktopManager, all bar instances contained in this PlaceHolderManager will automatically inherit the style from DesktopManager.MenuStyles.Application

PlaceHolderManager as well as integratable component members exposed IntegratedTo property which determines the integration state of each instance.

The following table shows the integration relations between WebDesktopManager, PlaceHolderManager and applicable component members.

 | DesktopManager Level | PlaceHolderManager Level | WebDialogBox | Menu System | WebMenuBar | WebToolBar | WebButton
WindowSettings | x |  | x |  |  |  | x
WindowStyle | x |  | x |  |  |  |
CommandButtonStyle | x |  | x |  |  |  | x
MenuStyle | x | x |  | x | x |  |
ToolBarStyle |  | x |  |  |  | x |
MenuBarStyle |  | x |  |  | x |  |

Each atomic component such as DialogBox, ContextMenu, ToolBar and Button will seamlessly integrate to DesktopManager (when enabled via IntegratedTo property) at runtime. The style definition in control level does not required and will be ignored.

Workflow Diagram

The previous section has outlined the main concepts of how the style inheritance works between the lowest level of components up to highest level component (WebDesktopManager). The following illustration provides an in-depth representation of the connection and process of the style integration between each level in real-world application scenarios.

The red markup represents a DesktopManager instance. As illustrated in above image, the atomic components such as DialogBox (see "About WebOutlook"), Button, ContextMenu and entire Menu system are applying the styles defined at DesktopManager automatically at runtime.
The blue markup represents a PlaceHolderManager instance. The "Bar"-based items will obtain its styles from its PlaceHolderManager, so that there is no need to specify individual styles at Bar level. For the MenuStyle used in SplitButton or DropDownMenu CommandType, the PlaceHolderManager will determine the appropriate parent based on the Integration mode, such as when integrated to DesktopManager, it will obtain from DesktopManager's Application MenuStyle.

Benefits

  • Uniform visual styles and look&feel across entire application effortlessly through multi-level inheritance feature.
  • Superior rich applications with high performance without sacrificing scalability because css class and individual instance's styles are not generated, so you can drop any number of instances on the page.
  • Reduced overhead in maintenance or administration, since you can change the style definition in one central location (at either DesktopManager or PlaceHolderManager level)
  • Work in harmony with WebUI StyleManager, means that the global style definition can even be defined in WebUI StyleManager and thus resulting greater flexibility and productivity.


WebForm Design Guidelines

WebForm Design Guidelines
Send Feedback
Intersoft WebDesktop > Essential Concepts > WebForm Design Guidelines

Glossary Item Box

This section discusses the recommended WebForm design guidelines for developing applications that hosted inside DesktopManager.

  1. Use HTML 4.0 DTD

    By default, new WebForm in Visual Studio 2005 will automatically include the XHTML 1.1 DTD type. Please remove it and change to HTML 4.0 DTD as shown in the following syntax:

    <!

    DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" >

    Although Intersoft's components are generating XHTML compliant output, the layout rendering and behaviors in XHTML 1.1 are slightly different with expected result. The difference includes the way XHTML treats on dimension and boxes, as well as its inability to support 100% width for certain tags in more advanced scenarios. XHTML Strict is recommended for building basic, static website which needs to be viewable on mobile devices. It is however not recommended for dynamic, rich and advanced interactions website.
  2. Use IFrame content mode when applicable

    For greater reusability of a module in your web application, it's recommended that you use IFrame content mode whenever applicable so that the Form can be reused in the entire application.

    All container controls in WebDesktop.NET, such as WebDesktopManager, WebPaneManager, WebTab and WebNavPane supports both InlineContent and IFrame mode. To use IFrame mode, simply set the ContentMode to UseIFrame.
  3. WebForm style guideline

    Unlike developing traditional style web form, there are several points and techniques that need to be taken care while developing using WebDesktop.NET especially when you are developing WebForms that hosted inside DesktopManager. Since DesktopManager is using the desktop-style of User Interface concepts, you would need to put attention on some of the form design aspects such as the body's spacing and margin, the scrollbars, width and height of the page, and more.

    In this section, provided are several style and design guidelines for designing WebForm targetted for DesktopManager.
    • Remove spacing and padding in Page. By default, a Page will have a margin of 15px. This can be achieved by using one of the following techniques:
      • Set four of the margin to 0 in BODY tag. Example:

        <

        body leftmargin="0" topmargin="0" rightmargin="0" bottommargin="0">

      • Define the margin in global css class. Example:

        BODY
        {
        margin: 0px;
        padding: 0px;
        }
    • Disable Page's scrolling. In most cases, you would use WebPaneManager to create a Layout. For instance, a Page with "Header, Side and Footer" Layout. The Layout should be then responding to browser's resized and perform resizing automatically. In this scenario, the Page's scrollbar is better made disabled. To disable page scrolling, please see the following guides:
      • Set the scroll attribute to "no" value in BODY tag. Example:

        <body scroll="no" >
      • In Mozilla-based browsers, you would need to set the overflow style to hidden. Example:

        <body style="overflow:hidden" >
      • In case that you would need to scroll the Page at designtime, you can add the overflow style programmatically in code behind instead of using above techniques. Example:

        protected

        void Page_Load(object sender, EventArgs e)

        {

        body.Style.Add(

        "overflow", "hidden");

        }

        The above last technique requires you to add runat=server attribute to the body tag. For instance, <body id="body" runat="server">


Performance Guidelines

Performance Guidelines
Send Feedback
Intersoft WebDesktop > Essential Concepts > Performance Guidelines

Glossary Item Box

This section provides best practices and guidelines for developing high performance and rich web applications using WebDesktop.NET components.

  1. Use Theme architecture

    Discover the great potential of utilizing Theme architecture in your web application which enabling you to build rich and professional WebForm and yet producing small amount of output size. You can use WebUI StyleManager which comes with WebDesktop.NET to visually manage the theme, edit and preview the style as well as deploy the theme.

    By using Theme architecture, you are gaining up to 70% reduced output size.
    For instance, having 10 controls inside a WebForm will produce "set of Css Class" per instance. Typically, the "Css Class" definition will increase approximately 70% of page size especially when the control is a complex-styled component. Please see following illustration for in-depth details:

    Without using Theme Architecture

    The styles of each component's instance will be delivered to page's output. The following is a sample of only one desktop manager instance:

    .WebDesktopManager1-FrameStyle{background-color:WhiteSmoke;}
    .WebDesktopManager1-WindowSettings-WindowStyle-Normal{background-color:White; font-family:Tahoma; font-size:8pt; font-weight:normal;border:1px Silver solid;}
    .WebDesktopManager1-WindowSettings-WindowStyle-Active{background-color:White; font-family:Tahoma; font-size:8pt; font-weight:normal;border:1px Gray solid;basestyle:Normal;}
    .WebDesktopManager1-WindowSettings-CaptionStyle-Normal{background-color:Gray; font-family:Tahoma; font-size:10pt; font-weight:bold; color:White;cursor:Default;filter: progid:DXImageTransform.Microsoft.gradient(startColorstr=#FF808080 , endColorstr=#FFDCDCDC, GradientType=1); padding-top:2px; padding-right:2px; padding-left:2px; padding-bottom:2px;overflow:Auto;overflow-x:Auto;overflow-y:Auto;}
    .WebDesktopManager1-WindowSettings-CaptionStyle-Active{background-color:Navy; font-family:Tahoma; font-size:10pt; font-weight:bold; color:White;cursor:Default;filter: progid:DXImageTransform.Microsoft.gradient(startColorstr=#FF000080 , endColorstr=#FFFF0000, GradientType=1); padding-top:2px; padding-right:2px; padding-left:2px; padding-bottom:2px;overflow:Auto;overflow-x:Auto;overflow-y:Auto;basestyle:Normal;}
    .WebDesktopManager1-WindowSettings-CaptionButtonStyle-Normal{border:1px Black solid;height:17px;overflow:Hidden;overflow-x:Hidden;overflow-y:Hidden;}
    .WebDesktopManager1-WindowSettings-CaptionButtonStyle-Over{border:1px Black solid;border-right: 1px Gray solid;border-bottom: 1px Gray solid;height:17px;overflow:Hidden;overflow-x:Hidden;overflow-y:Hidden;basestyle:Normal;}
    ...
    ...

    Using Theme Architecture

    When Theme Architecture is applied appropriately to all Intersoft's components; the styles will not be delivered to the Page's output. Instead, a <link> tag will be inserted to the Page referring to the automatically generated css file produced by the Theme Architecture.

    <link rel="stylesheet" href="/WebDesktopSamples/Themes/Default/Default.css" type="text/css">

    For more information about the concepts and theme's features, see Theme Architecture.
    For more information about the relation between WebUI StyleManager and Theme Architecture, see The Orchestration of Theme Architecture, WebStyleManager and Deployment.
  2. Enable CssName Optimization

    Css Optimization is a new technology introduced along with the release of WebDesktop.NET. Css Optimization is implemented in Framework level and therefore automatically available to all Intersoft's products such as WebGrid.NET Enterprise, WebCombo.NET etc.

    When enabled, Css Optimization can reduce up to 50% of the overall page's output size, especially in the case when most of the controls are inside user control or templates.

    For instance, a css style definition typically has the following format when the control is inside template:

    <style>
    .MasterPage1_Content1_Panel1_WebGrid-LayoutSettings-FrameStyle { color: white; ... }
    </style>

    After Css Optimization enabled, it will automatically produced shortened style definition regardless of the containment mode.

    <style>
    .W8625 { color: white; ... }
    </style>

    To learn how to enable and utilize Css Optimization in your application, see Css Optimizer.

    Css Optimization is implemented in WebUI.NET Framework version 3.0. The version 3.0 has been compiled against native .NET 2.0 Framework to take advantage of new security and performance enhancements.
  3. Enable XmlCompression

    Intersoft's WebUI.NET Framework extensively utilizes Xml for its backend for client side storage, instead of using traditional "unstructured Array". The new Xml approach introduced many new features and possibilities such as the capability to construct object type and hierarchy in client side which has exactly the same hierarchy as in server side. Although there are countless benefits of using this Xml approach, there is one potential weakness: larger output. The larger output does make sense because the xml format is 'self describing".

    The XmlCompressor technology introduced in WebUI.NET Framework 3.0 was developed to solve this weakness and therefore allowing "best of both worlds" benefits while using the Xml approach as clientside's data storage.

    When enabled, XmlCompressor is capable to reduce page's output by 40%. Furthermore, when combined in FlyPostback control such as WebCombo.NET or WebGrid.NET Enterprise, it significantly improves response time without sacrificing the powerful functionalities. The improvement was made possible because the FlyPostback sends "compressed xml string" which is 40% smaller.
  4. Disable ViewStateStorage whenever applicable

    ViewStateStorage is a feature introduced in WebUI.NET Framework 2.0 allowing the view state of Intersoft's controls to be stored in custom storage without additional codes or efforts.

    The view state persistence is useful when used in the conditions where properties such as styles or behaviors are changed dynamically at runtime. The persistence would then be able to track the changes and restore back the modified properties in next postback. With proper understanding of this concept, you may disable the view state persistence in Intersoft's components by setting the ViewStateStorage to None.

    When set to None, there are significant performance gain during page load life cycle since that the controls' serialization doesn't need to be performed in many circumstances.

    ViewStateStorage does not related to EnableViewState and you should always leave the EnableViewState property to True in order for the default ASP.NET process to manage control's internal states.
  5. Gradient Style Guidelines

    Intersoft's components offers rich styles for User Interface appearance. One of the most popular styles is gradient background color. The gradient background color takes advantage of Internet Explorer's special Gradient visual effect and therefore requires designer to properly understand the best applicable elements for using the effect.

    Following are some guidelines for using the gradient effect:

    - Do not apply gradient in "repetitive elements".
    For instance, applying gradient to "row" or "cell" element is not recommended as it would cause significant performance degrade due to more resources consumption.

    - Apply gradient in surface which has "layout".
    For instance, statusbar element, captionbar, groupbox, frame element etc.

    - Limit the number of elements using gradient effect in a page.
    Although there are no known limitations to maximum number of elements using gradient effect in one page, it is advised that you apply the gradient effectively for design consistency and art.
  6. Use Overflow=Visible style whenever possible

    Most of elements in component's user interface do not need automatic overflow style. You should always check and ensure that the Overflow, OverflowX and OverflowY of every Style to use Visible value.

    The default Overflow, OverflowX and OverflowY property in Intersoft's WebStyle is Auto.
  7. Use Animation effectively

    In components that support Animation, it's recommended that you perform thorough testing when Animation is enabled. In most cases, Animation can be enabled without slowing down performance. However, too much use of Animation in one page could even cause inconvenience and ineffective user experience.
  8. Determines the best configuration for FlyPostbackSettings

    FlyPostbackSettings property is exposed to all Intersoft's controls that implement IFlyPostback to support the capability to refresh certain area of Page without full page postback (also known as callback or AJAX). This setting lets developer to have more granular control over the actions being done when performing FlyPostback.

    Following are the list of features which may be turned off to improve the response time of FlyPostback request. These settings can be found in FlyPostbackSettings object in control's instance:

    • PostViewState.

      The value is True by default. When set to true, FlyPostback will automatically restores the viewstate of all server controls available in the page. So, if you do not access other controls' properties in FlyPostback context, you can safely set this property to False. This will give significant improvement especially when the viewstate of the Page is large.

    • PostHiddenFields.

      The default value is True. If you do not access hidden fields on page load or in FlyPostback requests, you can safely turn off this feature by setting it to False.

    • PostInputControls.

      The default value is False. This feature enables you to get the latest value for the html input fields in the FlyPostback context. If you do not need to access other controls' value (such as TextBox's value), then you should have this property's value remain False.

    • PostControlState.

      This is a new property added in WebUI.NET Framework Build 12. The default value is True. In previous build, you have to turn on PostHiddenFields in order for the FlyPostback's control to maintain its state properly during request. However, since PostHiddenFields also send out other controls' hidden fields, it becomes ineffective and causing slower response time due to larger post data. Now, you can safely turn off PostHiddenFields and leaving this property value to True.

      The control state is the most interesting point in the features above since it needs to be configured properly; otherwise client interactions will react improperly. The best value for this configuration is based on the nature of product and which features are enabled. For example, in WebCombo, you may turn off this feature since WebCombo did not have as much client interaction as in WebGrid. As for WebGrid, this feature is recommended to be turned on (by default). There are however, certain scenarios where you can safely turn off this feature in WebGrid. For instance, if your Grid instance does not require clientside user interactions features such as column moving, resizing, sorting, filtering or others, then you can safely turn off this feature. These scenarios are suitable for application which requires only hierarchical load on demand Grid mode or self hierarchical load on demand feature.
For more details on improving FlyPostback performance, see the full article in KB: Improving FlyPostBack performance.


WebCallOut

WebCallOut
See Also Send Feedback
Intersoft WebDesktop > WebCallOut

Glossary Item Box

WebCallOut is an ASP.NET server control enabling you to create tooltip or callout that suits your style.

WebCallOut includes most wanted and first of its kind features such as:

  • Automatically adjust the tooltip and pointing position base on the target control ID.
  • AutoDetect position base on target control ID.
  • Interactive moving.
  • Customizable pointing position.
  • Fully customizable layout elements.
  • Customizable title icon.
  • Animation effects.
  • Support ComplexImages.
  • Support ContentTemplate.
  • Comprehensive client side API for construction and manipulation.

See Also

Other Resources
Concepts
Features


What's New in WebCallOut

What's New in WebCallOut
See Also Send Feedback
Intersoft WebDesktop > WebCallOut > What's New in WebCallOut

Glossary Item Box

Intersoft WebCallOut is a superior replacement for the standard tooltip. With its beautifully designed styles, appealing visual effects, and customizable elements, WebCallOut has everything you need to build the perfect tooltip to complement your web applications.

In version 4, WebCallOut has been refined to fully support the latest web standards. This allows you to use many of the WebCallOut features in your next-generation web applications and at the same time leveraging cutting-edge technologies such as HTML5 and CSS3.

Here are the following details of several enhancements and new features that have been implemented in WebCallout:

  • New Intuitive style

    In this version 4, WebDesktop introduces a brand-new Metro style for each members. Metro style - the latest UI in Windows 8 has been developed and added as a new, elegant and sophisticated UI in WebDesktop family. With Metro style, WebDesktop's layout is transformed into beautiful and eye-catching design and it is also applicable for each members, such as WebCallOut, WebNavePane, WebDialogBox and many others. Last but not least, this intuitive Metro style design also enhances consistency of each controls in HTML5.

    You can simply use Layout Manager to implement Metro style in WebDesktop.

    For more information on how to apply this configuration, see How-To: Using Layout Manager.

See Also

Features and Concepts
WebCallOut
Features


Walkthrough: Getting started with WebCallOut

Walkthrough: Getting started with WebCallOut
See Also Send Feedback
Intersoft WebDesktop > WebCallOut > Walkthrough: Getting started with WebCallOut

Glossary Item Box

This walkthrough shows you how to use WebCallOut with "Hello World" as the text when user hovers the mouse to TextBox..

During this walkthrough, you will learn how to do the following:

  • Use SmartTag to register SmartWebResources.
  • Use WebCallOut.NET Designer to set all settings, such as buttons and visual effects.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Visual Studio 2005 Application.

Step-By-Step Instructions

To create new web application and display WebFishEye control

  1. Launch Visual Studio.NET 2005.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. Drag WebCallOut and ASP.NET TextBox instances from ToolBar to WebForm.

  8. Open Smart Tag and select Register SmartWebResources™ to register all images and scripts needed for the WebCallOut control.
  9. Right click on WebCallOut control and choose WebCallOut.NET Designer or you can go to WebCallOut's Properties by right clicking the control and choose Properties.
  10. Set the following properties:

    Properties | Value
    Text | Hello World!
    Title | My First WebCallOut
    TargetControlID | <TextBox Id>. For Example: TextBox1

  11. Save and run the project. When you hover to TextBox, WebCallOut will appear like following.

See Also

Other Resources
{Overview}
{Concepts}
{Features}


Concepts

Concepts
See Also Send Feedback
Intersoft WebDesktop > WebCallOut > Concepts

Glossary Item Box

The topics in this section help you to understand the concepts of WebCallOut in more details.

In This Section

Control and Browser Support
Read about WebCallOut that is built around Extender type of design and pattern.

Object Model
Read about the LayoutMode of WebCallOut's architecture.

Events and Life Cycle
Read about WebCallOut's architecture to handle callout/tooltip behaviors throughout the entire page life cycle.

FlyPostBack
Read about FlyPostBack feature that has been added in WebCallOut.

See Also

Other Resources
WebCallOut
{Features}


Control and Browser Support

Control and Browser Support
See Also Send Feedback
Intersoft WebDesktop > WebCallOut > Concepts > Control and Browser Support

Glossary Item Box

WebCallOut supports the following type of controls:

  • Built-in ASP.NET Server control
    You can easily assign ASP.NET server control such as <asp:Button>, <asp:TextBox> or <asp:Panel> to have a WebCallOut. You can specify the server control which attached to WebCallOut by using markup declaratively or via WebCallOut's properties window. The most recommended way to attach a WebCallOut to a standard ASP.NET Server control is via properties window. In the collection editor, you can click on the dropdown button that appears in the TargetControlID property, and then quickly select a server control id from the list.

  • Html element
    By default, html elements are not retrieved in the TargetControlID editor. However, you can assign html element by its client ID to the TargetControlID property directly. For instance, <ISWebDesktop:WebCallOut ID="WebCallOut3" TargetControlId="Div1">.

  • Intersoft controls
    In addition to basic controls like built-in ASP.NET server controls and html elements, WebCallOut is built upon open-architecture leveraging custom interfaces and common/base classes. This enables a tight integration between WebCallOut component and Intersoft WebUI Studio.NET® family products. For instance, the WebCallOut can automatically interact with WebDesktop's components such as toolbar items, WebButton, etc.

WebCallOut.NET component and all its unique features listed in Features are fully supported in the following browsers:
- Internet Explorer 6.0+
- Optimized for Internet Explorer 7.0
- Firefox 2.0
- Other Mozilla-based variants.

See Also

Other Resources
{Object Model}
{Events and Life Cycle}
{FlyPostBack}


Object Model

Object Model
See Also Send Feedback
Intersoft WebDesktop > WebCallOut > Concepts > Object Model

Glossary Item Box

ComplexImages LayoutMode architecture

Simple LayoutMode architecture

  • TitleStyle will be applied to the Title Element
  • ContainerStyle will be applied to the Container
  • FrameStyle will be applied to the Frame

The different between Simple and ComplexImages layout mode is in the WebCallOut's style. In ComplexImages, WebCallOut is using ContainerStyle and the images as the background color whereas Simple is using FrameStyle.

See Also

Other Resources
{Control and Browser Support}
{Events and Life Cycle}
{FlyPostBack}


Events and Life Cycle

Events and Life Cycle
See Also Send Feedback
Intersoft WebDesktop > WebCallOut > Concepts > Events and Life Cycle

Glossary Item Box

The following list describes the available client side events and the life cycle in order:

  1. OnInitialize
    This event will be invoked during WebCallOut initialization.

  2. OnShow
    When WebCallOut is shown, OnShow client side event will be invoked.

  3. OnClose
    If the user intentionally closes the WebCallOut or WebCallOut is closed automatically, then OnClose client side event will be invoked.

  4. OnResponse
    Specifies the client-side function to be invoked when a response from server is returned, irregardless of a successful response or error response (FlyPostBack).

  5. OnBeforeShow
    This event will be invoked before WebCallOut is shown.

See Also

Other Resources
{Control and Browser Support}
{Object Model}
{FlyPostBack}


FlyPostBack

FlyPostBack
See Also Send Feedback
Intersoft WebDesktop > WebCallOut > Concepts > FlyPostBack

Glossary Item Box

FlyPostBack feature is added to WebCallOut in WebUIStudio.NET 2008 R2. By implementing FlyPostBack, now you can set WebCallOut's text or title from server side. FlyPostBack will be triggered if you implement OnShow server side event.

Please refer to the following lifecycle illustration for a better picture on FlyPostBack in WebCallOut.

Standard life cycle | FlyPostBack life cycle

In This Section

How-to: Set Text and Title on server side

How-to: Set Text and Title with template ContentMode on server side

See Also

Other Resources
{Control and Browser Support}
{Object Model}
{Events and Life Cycle}


How-to: Set Text and Title on server side

How-to: Set Text and Title on server side
See Also Send Feedback
Intersoft WebDesktop > WebCallOut > Concepts > FlyPostBack > How-to: Set Text and Title on server side

Glossary Item Box

WebCallOut allows you to easily set text and title from server side.

In this topic, you will learn how to implement the scenario above.

To set text and title from server side

  1. Drag WebCallOut and ASP.NET Label controls from toolbox to the WebForm.
  2. Right click on WebCallOut control and choose Properties.
  3. Switch to Events and double click on Show server side event. It will automatically create an event called WebCallOut1_Show in server side.
  4. Put the following code in the event:

    C# Copy Code
    protected
     void WebCallOut1_Show(object sender, ISNet.WebUI.WebDesktop.WebCallOutEventDataArgs e)
    {
       e.Text = Label1.Text;
    }

  5. Save and run the project. When you hover the mouse to the label, it will display the callout like following:

See Also

Tasks
{How-to: Set Text and Title with template ContentMode on server side}
{Walkthrough topics}
{FAQ and How-to topics}

Concepts
{FlyPostBack}


How-to: Set Text and Title with template ContentMode on server side

How-to: Set Text and Title with template ContentMode on server side
See Also Send Feedback
Intersoft WebDesktop > WebCallOut > Concepts > FlyPostBack > How-to: Set Text and Title with template ContentMode on server side

Glossary Item Box

WebCallOut allows you to easily set text and title with template ContentMode from server side.

In this topic, you will learn how to implement the scenario above.

To use text and title with template ContentMode

  1. Drag WebCallOut and two ASP.NET Label controls from toolbox to the WebForm.
  2. Right click on WebCallOut control and choose Properties.
  3. Set ContentMode to UseTemplate.
  4. Place one of ASP.NET Label controls to the WebCallOut and named it as Label2.

  5. Switch to Events and double click on Show server side event. It will automatically create an event called WebCallOut1_Show in server side.
  6. Put the following code in the event:

    C# Copy Code
    protected
     void Webcallout1_Show(object sender, ISNet.WebUI.WebDesktop.WebCallOutEventDataArgs e)
    {
       WebCallOut webCallOut = sender as WebCallOut;
       Label label = webCallOut.FindControl("Label2") as Label;
       label.ForeColor = System.Drawing.
    Color.Green;
       label.Text =
    "This is an owl. Owls are an order of birds of prey. Most are solitary, and nocturnal,
    with some exceptions (e.g. the Burrowing Owl). They are classified in the order Strigiformes, in which there are over 200 extant species.";
    }

  7. Save and run the project. When you hover the mouse to the label, it will display the callout like following:

See Also

Tasks
How-to: Set Text and Title on server side
{Walkthrough topics}
{FAQ and How-to topics}

Concepts
{FlyPostBack}


Features

Features
See Also Send Feedback
Intersoft WebDesktop > WebCallOut > Features

Glossary Item Box

This section lists all key features available in WebCallOut, which are designed to help developers implementing sophisticated callout or tooltip capability with less efforts and time.

In This Section

Customizable DisplaySettings
Read about three display settings available in WebCallOut.

ComplexImages
Read about ComplexImages property that allows users to build their own design for WebCallOut.

CloseBehaviors
Read about three close behaviors available in WebCallOut.

ShowBehaviors
Read about two show behaviors available in WebCallOut.

Customizable pointing Position
Read about five positions that are customizable in WebCallOut.

PreferredPosition
Read about using preferred position to show WebCallOut according to control specified in TargeControlId.

InteractiveMoving
Read about using mouse cursor position to display WebCallOut.

ContentMode
Read about content customization in WebCallOut.

DisplayLatency
Read about using display latency property to show WebCallOut after several milliseconds.

See Also

Other Resources
{Overview}
{Concepts}


Customizable DisplaySettings

Customizable DisplaySettings
See Also Send Feedback
Intersoft WebDesktop > WebCallOut > Features > Customizable DisplaySettings

Glossary Item Box

WebCallOut provides several display settings that can be set based on user interest:

  • DisplayTitleIcon
    Show/Hide WebCallOut's title icon.

  • DisplayTitleText
    Show/Hide WebCallOut's title text.

  • DisplayCloseIcon
    Show/Hide WebCallOut's close icon.

See Also

Tasks
{How-to: Customize DisplaySettings in WebCallOut}

Other Resources
{ComplexImages}
{CloseBehaviors}
{ShowBehaviors}
{Customizable Pointing Position}
{Preferred Position}
{InteractiveMoving}
{ContentMode}
{DisplayLatency}


How-to: Customize DisplaySettings in WebCallOut

How-to: Customize DisplaySettings in WebCallOut
See Also Send Feedback
Intersoft WebDesktop > WebCallOut > Features > Customizable DisplaySettings > How-to: Customize DisplaySettings in WebCallOut

Glossary Item Box

WebCallOut provides several display settings that can be set from its Properties.

This topic shows how to customize DisplaySettings in WebCallOut.

To customize DisplaySettings in WebCallOut

  1. Right click on WebCallOut control and choose Properties.
  2. Set TargetControlId to the control you want to use, such as Panel1.
  3. Set DisplayCloseIcon to False and the WebCallOut will look like following:

  4. Set DisplayTitleText to False and the WebCallOut will look like following:

  5. Set DisplayTitleIcon to False and the WebCallOut will look like following:

See Also

Concepts
{Customizable DisplaySettings}


ComplexImages

ComplexImages
See Also Send Feedback
Intersoft WebDesktop > WebCallOut > Features > ComplexImages

Glossary Item Box

With this feature, you can build your own design for WebCallOut. The ComplexImages allows you to specify the images needed by WebCallOut to render the component. In order to create your own design for WebCallOut, 15 images are needed. You can specify the images in ImagesSettings. Some of the design probably requires the pointing position images to be placed higher or lower in the WebCallOut's form. You can specify the suitable position for the pointing position images by set OffsetBottomPointingPosition and OffsetTopPointingPosition.

By default, ComplexImages is the default LayoutMode.
Design concept illustration:

See Also

Tasks
{How-to: Use ComplexImages in WebCallOut}

Other Resources
{Customizable DisplaySettings}
{CloseBehaviors}
{ShowBehaviors}
{Customizable Pointing Position}
{Preferred Position}
{InteractiveMoving}
{ContentMode}
{DisplayLatency}


How-to: Use ComplexImages in WebCallOut

How-to: Use ComplexImages in WebCallOut
See Also Send Feedback
Intersoft WebDesktop > WebCallOut > Features > ComplexImages > How-to: Use ComplexImages in WebCallOut

Glossary Item Box

By using ComplexImages, you can build your own style in WebCallOut.

This topic shows how to set ComplexImages from WebCallOut's Properties.

To use ComplexImages in WebCallOut

  1. Right click on WebCallOut control and choose Properties.
  2. Set TargetControlId to the control you want to use.
  3. Set LayoutMode to ComplexImages.
  4. Expand ImagesSettings and you can freely customize each property using your own images.

  5. By default, ComplexImages will look like following:

  6. Set LayoutMode to Simple, and the WebCallOut will look following:

See Also

Concepts
{ComplexImages}


CloseBehaviors

CloseBehaviors
See Also Send Feedback
Intersoft WebDesktop > WebCallOut > Features > CloseBehaviors

Glossary Item Box

WebCallOut provides several close behaviors.

  • Latency
    Automatic and by default the WebCallOut will disappear in 30 seconds after shown.
    You can change the fading time in Latency. Beside that, WebCallOut will disappear if user clicks the close icon or the WebCallOut.

  • MouseOut
    WebCallOut will disappear if user hovers the mouse out from the TargetControlId or WebCallOut area.

  • ClickOutsideCallOut
    WebCallOut will disappear if user clicks outside of the WebCallOut.

See Also

Tasks
{How-to: Use CloseBehaviors in WebCallOut}

Other Resources
{Customizable DisplaySettings}
{ComplexImages}
{ShowBehaviors}
{Customizable Pointing Position}
{Preferred Position}
{InteractiveMoving}
{ContentMode}
{DisplayLatency}


How-to: Use CloseBehaviors in WebCallOut

How-to: Use CloseBehaviors in WebCallOut
See Also Send Feedback
Intersoft WebDesktop > WebCallOut > Features > CloseBehaviors > How-to: Use CloseBehaviors in WebCallOut

Glossary Item Box

WebCallOut provides several close behaviors that can be customized from its Properties.

This topic shows how to perform CloseBehaviors in WebCallOut.

To use CloseBehaviors in WebCallOut

  1. CloseBehaviors has 3 types, which are Latency, MouseOut and ClickOutsideCallOut.
  2. Right click on WebCallOut control and choose Properties.
  3. Set TargetControlId to the control you want to use.
  4. By default, WebCallOut will automatically disappear in 30 seconds after it is shown. The Latency property has been set to 30 initially. Beside that, WebCallOut will disappear if user clicks the close icon or click on the WebCallOut.
  5. Using MouseOut, WebCallOut will disappear if user uses MouseOut from the TargetControlId or MouseOut from WebCallOut.
  6. Using ClickOutsideCallOut, WebCallOut will disappear if user clicks outside of the WebCallOut.

See Also

Concepts
{CloseBehaviors}


ShowBehaviors

ShowBehaviors
See Also Send Feedback
Intersoft WebDesktop > WebCallOut > Features > ShowBehaviors

Glossary Item Box

WebCallOut provides two approach as the ShowBehavior:

  • Default
    By default, WebCallOut will appear and disappear with fading animation.

  • NoFading
    WebCallOut will appear and disappear without fading animation.

See Also

Tasks
{How-to: Use ShowBehaviors in WebCallOut}

Other Resources
{Customizable DisplaySettings}
{ComplexImages}
{CloseBehaviors}
{Customizable Pointing Position}
{Preferred Position}
{InteractiveMoving}
{ContentMode}
{DisplayLatency}


How-to: Use ShowBehaviors in WebCallOut

How-to: Use ShowBehaviors in WebCallOut
See Also Send Feedback
Intersoft WebDesktop > WebCallOut > Features > ShowBehaviors > How-to: Use ShowBehaviors in WebCallOut

Glossary Item Box

WebCallOut gives 2 modes option to perform how the WebCallOut will be displayed/shown.

This topic shows how to use ShowBehaviors in WebCallOut.

To use ShowBehaviors in WebCallOut

  1. Right click on WebCallOut control and choose Properties.
  2. Set TargetControlId to the control you want to use.
  3. Set ShowBehavior to Default. This property will give fading animation when WebCallOut appears and disappears.
  4. Set ShowBehavior to No Fading. WebCallOut will appear and disappear without animation.

See Also

Concepts
{ShowBehaviors}


Customizable Pointing Position

Customizable Pointing Position
See Also Send Feedback
Intersoft WebDesktop > WebCallOut > Features > Customizable Pointing Position

Glossary Item Box

WebCallOut introduces several pointing position, such as:

  • AutoDetect
    WebCallOut will adjust the pointing position base on the control position that is specified in TargetControlId's, PreferrableVerticalPosition, and PreferrableHorizontalPosition properties.

  • PointingTopLeft
    WebCallOut will appear on the TopLeft of control specified in TargetControlId.

  • PointingTopRight
    WebCallOut will appear on the TopRight of control specified in TargetControlId.

  • PointingBottomLeft
    WebCallOut will appear on the BottomLeft of control specified in TargetControlId.

  • PointingBottomRight
    WebCallOut will appear on the BottomRight of control specified in TargetControlId.

Except AutoDetect, the others options will not depend on PreferredVerticalPosition and PreferredHorizontalPosition properties.

See Also

Tasks
{How-to: Customize pointing position in WebCallOut}

Other Resources
{Customizable DisplaySettings}
{ComplexImages}
{CloseBehaviors}
{ShowBehaviors}
{Preferred Position}
{InteractiveMoving}
{ContentMode}
{DisplayLatency}


How-to: Customize pointing position in WebCallOut

How-to: Customize pointing position in WebCallOut
See Also Send Feedback
Intersoft WebDesktop > WebCallOut > Features > Customizable Pointing Position > How-to: Customize pointing position in WebCallOut

Glossary Item Box

WebCallOut supports 5 modes to display its pointing position in the Properties.

This topic shows how to customize pointing position in WebCallOut.

To customize pointing position in WebCallOut

  1. Right click on WebCallOut control and choose Properties.
  2. Set TargetControlId to the control you want to use.
  3. When you set PointingPosition to AutoDetect, WebCallOut will adjust the pointing position based on the control position that is specified in TargetControlId, PreferrableVerticalPosition and PreferrableHorizontalPosition properties.

  4. When you set PointingPosition to PointingTopLeft, WebCallOut will appear on the TopLeft of control specified in TargetControlId.

  5. When you set PointingPosition to PointingTopRight, WebCallOut will appear on the TopRight of control specified in TargetControlId.

  6. When you set PointingPosition to PointingBottomLeft, WebCallOut will appear on the BottomLeft of control specified in TargetControlId.

  7. When you set PointingPosition to PointingBottomRight, WebCallOut will appear on the BottomRight of control specified in TargetControlId.

See Also

Concepts
{Customizable Pointing Position}


Preferred Position

Preferred Position
See Also Send Feedback
Intersoft WebDesktop > WebCallOut > Features > Preferred Position

Glossary Item Box

Preferred position means in which position you want the WebCallOut to be shown related to control specified in TargetControlId. There are 2 properties that refer to preferred position, PreferredVerticalPosition and PreferredHorizontalPosition. The default value for PreferredVerticalPosition is Top and PreferredHorizontalPosition is Left. For instance, if the PreferredVerticalPosition is set to Bottom and PreferredHorizontalPositon is set to Right then WebCallOut will be shown at the BottomRight of the control specified in TargetControlId.

These properties will be applied if PointingPosition is set to AutoDetect.

See Also

Tasks
{How-to: Use preferred position in WebCallOut}

Other Resources
{Customizable DisplaySettings}
{ComplexImages}
{CloseBehaviors}
{ShowBehaviors}
{Customizable Pointing Position}
{InteractiveMoving}
{ContentMode}
{DisplayLatency}


How-to: Use preferred position in WebCallOut

How-to: Use preferred position in WebCallOut
See Also Send Feedback
Intersoft WebDesktop > WebCallOut > Features > Preferred Position > How-to: Use preferred position in WebCallOut

Glossary Item Box

WebCallOut provides a feature called preferred position, means that you can position the WebCallOut based on the PreferredVerticalPosition and PreferredHorizontalPosition.

This topics shows how to customize preferred position in WebCallOut.

To use preferred position in WebCallOut

  1. Right click on WebCallOut control and choose Properties.
  2. Set TargetControlId to the control you want to use.
  3. Set PreferredVerticalPosition to Bottom and PreferredHorizontalPosition to Left. The WebCallOut will look like following:

  4. Set PreferredVerticalPosition to Top and PreferredHorizontalPosition to Right.

  5. Set PreferredVerticalPosition to Top and PreferredHorizontalPosition to Left.

  6. Set PreferredVerticalPosition to Bottom and PreferredHorizontalPosition to Right.

See Also

Concepts
{Preferred Position}


InteractiveMoving

InteractiveMoving
See Also Send Feedback
Intersoft WebDesktop > WebCallOut > Features > InteractiveMoving

Glossary Item Box

WebCallOut can move depending on mouse cursor position of the control specified in TargetControlId. For instance, the control specified in TargetControlId is an image. Hence, when your mouse inside the image, WebCallOut will appear and the position will follow the mouse cursor. To enable this feature, simply set EnableInteractiveMoving property to True.

See Also

Tasks
{How-to: Set WebCallOut based on mouse cursor position of the control}

Other Resources
{Customizable DisplaySettings}
{ComplexImages}
{CloseBehaviors}
{ShowBehaviors}
{Customizable Pointing Position}
{Preferred Position}
{ContentMode}
{DisplayLatency}


How-to: Move WebCallOut based on mouse cursor position of the control

How-to: Move WebCallOut based on mouse cursor position of the control
See Also Send Feedback
Intersoft WebDesktop > WebCallOut > Features > InteractiveMoving > How-to: Move WebCallOut based on mouse cursor position of the control

Glossary Item Box

WebCallOut can move depending on mouse cursor position of the control specified in TargetControlId.

This topic shows how to move WebCallOut based on mouse cursor position of the control.

To move WebCallOut based on mouse cursor position of the control

  1. Right click on WebCallOut control and choose Properties.
  2. Set TargetControlId to the control you want to use.
  3. set EnableInteractiveMoving property to True.

See Also

Concepts
{InteractiveMoving}


ContentMode

ContentMode
See Also Send Feedback
Intersoft WebDesktop > WebCallOut > Features > ContentMode

Glossary Item Box

WebCallOut supports 2 types of content mode:

  • UseText
    In this mode, WebCallOut will use the Text as the content.

  • UseTemplate
    In this mode, WebCallOut will use user's custom made template as the content.

Simply set the LayoutMode that you want in LayoutMode property. By default, WebCallOut' LayoutMode is UseText.

See Also

Tasks
{How-to: Set ContentMode in WebCallOut}

Other Resources
{Customizable DisplaySettings}
{ComplexImages}
{CloseBehaviors}
{ShowBehaviors}
{Customizable Pointing Position}
{Preferred Position}
{InteractiveMoving}
{DisplayLatency}


How-to: Set ContentMode in WebCallOut

How-to: Set ContentMode in WebCallOut
See Also Send Feedback
Intersoft WebDesktop > WebCallOut > Features > ContentMode > How-to: Set ContentMode in WebCallOut

Glossary Item Box

WebCallOut supports 2 mode of ContentMode, which are UseText and UseTemplate.

This topic shows how to set ContentMode in WebCallOut.

To set ContentMode in WebCallOut

  1. Right click on WebCallOut control and choose Properties.
  2. By default, ContentMode will be set to UseText. Set Text to WebCallOut's Text and Title to WebCallOut's Title.
  3. Set TargetControlId to the control you want to use, such as Label1. The WebCallOut will look like following:

  4. Now, Set ContentMode to UseTemplate.
  5. Right click on WebCallOut control and choose Edit Template >> WebCallOut Items.
  6. Drag ASP.NET TextBox and HTML button controls to the WebCallOut Items template.
  7. Named the HTML button as Submit and set TargetControlId to the control you want to use, such as Label2.
  8. Create a function called Button1_onclick().

    C# Copy Code
    function Button1_onclick()
{
   var txt = document.getElementById("ctl00_content_WebCallOut2_WebCallOut2_C_TextBox1");
   var lbl = document.getElementById("ctl00_content_Label2");
   lbl.innerText = "Hello : " + txt.value;
}

  9. Invoke the function in HTML button, such as:

    <input id="Button1" type="button" value="Submit" onclick="Button1_onclick()" />

  10. When you run the project, you need to enter your name in the WebCallOut.

  11. Click Submit and the inputted name will be displayed in the label.

See Also

Concepts
{ContentMode}


DisplayLatency

DisplayLatency
See Also Send Feedback
Intersoft WebDesktop > WebCallOut > Features > DisplayLatency

Glossary Item Box

When you mouse over to the control specified in TargetControlId, the WebCallOut will not directly appear. WebCallOut will appear if you hover to the control and wait for several milliseconds (default is 500ms). If the default DisplayLatency does not suit your scenario then you can change it by simply set your desire DisplayLatency in the WebCallOut's properties.

See Also

Tasks
{How-to: Set DisplayLatency in WebCallOut}

Other Resources
{Customizable DisplaySettings}
{ComplexImages}
{CloseBehaviors}
{ShowBehaviors}
{Customizable Pointing Position}
{Preferred Position}
{InteractiveMoving}
{ContentMode}


How-to: Set DisplayLatency in WebCallOut

How-to: Set DisplayLatency in WebCallOut
See Also Send Feedback
Intersoft WebDesktop > WebCallOut > Features > DisplayLatency > How-to: Set DisplayLatency in WebCallOut

Glossary Item Box

WebCallOut introduces new behaviors that never-seen-before, which are DisplayLatency and Latency.

  • DisplayLatency
    Specify how long user should wait (mouse hover) on the TargetControlId before WebCallOut is shown (in milliseconds). The default value is 500ms.
  • Latency
    Specify how long the WebCallOut will appear before it starts to disappear (in seconds). The default value is 30s.
    In order to use this property, you should set CloseBehavior to Latency.

This topic shows how to set both properties in WebCallOut.

To set DisplayLatency and Latency in WebCallOut

  1. Right click on WebCallOut control and choose Properties.
  2. Set TargetControlId to the control you want to use.
  3. Set DisplayLatency to 1000 and Latency to 100 for example.
  4. The WebCallOut will appear after 1 second and start to disappear after 100 seconds.

See Also

Concepts
{DisplayLatency}


How-to: Integrate to WebGrid

How-to: Integrate to WebGrid
Send Feedback
Intersoft WebDesktop > WebCallOut > Features > How-to: Integrate to WebGrid

Glossary Item Box

WebCallOut is tightly integrated with WebGrid.

This topic will show you how to integrate with WebGrid.

To integrate with WebGrid

  1. Drag WebGrid and WebCallOut controls to the WebForm.
  2. Create a cell template by setting ColumnType to Template.
  3. Place an ASP.NET Label control and add onmouseover like following.

    <CellTemplate>
    <asp:Label ID="Label1" runat="server" Text="Label" ToolTip="" onmouseover="return ShowWebCallOut(this)"></asp:Label>
    </CellTemplate>

  4. Now, put the following code in InitializeRow server-side event in order to initialize data when WebGrid first loads.
    C# Copy Image Copy Code
    protected void WebGrid1_InitializeRow(object sender, ISNet.WebUI.WebGrid.RowEventArgs e)
{
   WebGridRow row = (WebGridRow)e.Row;
   WebGridCellTemplateContainer cell = row.Cells.GetNamedItem("Email").GetTemplateContainer();
   Label lbl = (Label)cell.FindControl("Label1");
   lbl.Text = "" + e.Row.Cells.GetNamedItem("FirstName").Text;
}

  5. Create ShowWebCallOut() function in client-side to show WebCallOut in WebGrid.
    JavaScript Copy Image Copy Code
    function ShowWebCallOut(WebGridLabel)
{
   var callout = ISGetObject("WebCallOut1");
   var targetId = document.getElementById(WebGridLabel.id);
   var calloutContent = callout.GetContentElement();

   window.setTimeout(function() {callout.ShowAutoDetect(targetId, true);}, 700);
}

  6. Run the project.


How-to: Integrate to WebCombo and WebInput

How-to: Integrate to WebCombo and WebInput
Send Feedback
Intersoft WebDesktop > WebCallOut > Features > How-to: Integrate to WebCombo and WebInput

Glossary Item Box

WebCallOut is tightly integrated with WebCombo and WebInput.

This topic will show you how to integrate WebCallOut with WebCombo and WebInput.

To integrate with WebCombo and WebInput

  1. Drag WebCallOut and WebInput controls to the WebForm. Named WebInput as WebInput1.
  2. Right-click on WebCallOut control and choose Properties.
  3. Set ContentMode to UseTemplate and TargetControlId to WebInput1.
  4. Right-click on WebCallOut control and choose Edit Template >> WebCallOut Items.
  5. Drag WebInput, WebCombo and ASP.NET Button controls to the content template. Named WebInput as WebInput2.
  6. Bind WebCombo to AccessDataSource control (Use Customers table and bind City to WebCombo).
  7. Right-click on WebCallOut control and choose End Template Editing to apply the settings.
  8. Use OnClick client side event to integrate WebCallOut with WebCombo and WebInput.
    C# Copy Image Copy Code
    function Button1_onclick()
{
   var wiAddress = ISGetObject("WebInput2");
   var wcCity = ISGetObject("WebCombo1");
   var wiResidence = ISGetObject("WebInput1");
   var webCallOut = ISGetObject("WebCallOut1");

   var residence = wiAddress.GetValueData() + " , " + wcCity.Text;

   wiResidence.SetValueData(residence);
   webCallOut.Hide();
}

  9. Trigger Button1_onclick() function in Button1's onclick event.

    <input id="Button2" type="button" value="Button" onclick="return Button2_onclick()" />

  10. Run the project. When you hover the mouse to WebInput1, WebCallOut will appear along with WebInput and WebCombo in it. Fill the address in WebInput and select a city from WebCombo. Finally, click the button to send the information provided into WebInput1.


WebDragDropExtender

WebDragDropExtender
See Also Send Feedback
Intersoft WebDesktop > WebDragDropExtender

Glossary Item Box

WebDragDropExtender.NET is an ASP.NET server control enabling you to add sophisticated drag and drop behaviors to existing server controls or html controls. WebDragDropExtender.NET is a new member of WebDesktop.NET family available in version 2.5.

WebDragDropExtender component is the first of its kind in the industry that provides sophisticated drag and drop implementation with elegant object model so that you can add drag and drop behavior to any existing server controls easily in consistent programming model.
WebDragDropExtender includes unique innovations and never-before-seen features such as:
  • Standard compliance with Winform-style drag and drop implementation and behaviors, including life cycle and event.
  • Automatic transparent shadow. You can also create your own customized shadow.
  • Multiple drag and drop targets.
  • Powerful and highly extensible with object-oriented drag data event argument available in OnDragOver, OnDragEnter and OnDragDrop.
  • Extremely high performance and lightweight with only 20KB scripts.
  • Support cross IFRAME. Both children and nested sibling IFRAME.
  • Built-in Effects cursor and indicator.
  • Vista-style tooltip feedbacks during drag-hover operation.
  • Interactive cursor indicator during drag operation. Notice that mouse cursor will show "Not Allowed" sign when hovered on invalid object. When the pointer is within the boundary of valid dropable object, it will show the cursor effect specified in the drag object.

See Also

Other Resources
WebDragDropExtender Concepts
WebDragDropExtender Features
WebDragDropExtender Client Side References


Concepts

Concepts
See Also Send Feedback
Intersoft WebDesktop > WebDragDropExtender > Concepts

Glossary Item Box

The topics in this section help you to understand the concepts of WebDragDropExtender in more details.

In This Section

Control and Browser Support
Read about WebDragDropExtender that is built around Extender type of design and pattern.

Object Model
Read about the logical object model of WebDragDropExtender and the relation with the WebForm.

Events and Life Cycle
Read about WebDragDropExtender's architecture to handle drag-drop behaviors throughout the entire page life cycle.

Drag Event Arguments
Read about drag-drop event argument that is implemented in client side.

AJAX DragDrop Server Side Event
Read about WebDragDropExtender's built-in features to perform auto postback upon a successful drag-drop operation.

See Also

Other Resources
WebDragDropExtender Overview
WebDragDropExtender Features
WebDragDropExtender Client Side References


Control and Browser Support

Control and Browser Support
See Also Send Feedback
Intersoft WebDesktop > WebDragDropExtender > Concepts > Control and Browser Support

Glossary Item Box

WebDragDropExtender component is built around Extender type of design and pattern. Extender means that the component itself has no standalone User Interface or Element. Extender type components usually take existing controls as the input then add specific behaviors and extend the functionality of the controls.

WebDragDropExtender supports the following type of controls:

  • Built-in ASP.NET Server control
    You can easily assign a server control, such as <asp:Panel> or <asp:Image>, to have either drag behavior or drop behavior. You can specify the server control by using markup declaratively or through designer. The most recommended way to add a drag or drop control is via designer. In the collection editor, you can click on the dropdown button that appears in the ControlID property, and then quickly selects a server control from the list.
  • Html element
    By default, html elements are not retrieved in the ControlID editor. However, you can assign a html element by its client ID to the ControlID property directly. For instance, <ISWebDesktop:DragControl ControlID="Div1">.
  • Intersoft controls
    In addition to basic controls like built-in ASP.NET Server controls and html elements, WebDragDropExtender is built upon open-architecture leveraging custom interfaces and common/base classes. This enables a tight integration between WebDragDropExtender component and Intersoft WebUI Studio.NET® family products. For instance, the WebDragDropExtender can automatically interact with WebDesktopManager's elements such as task bar and shortcut icons. To learn more about the integration features, please refer to Integration with Intersoft Controls.
In this version, WebDragDropExtender does not support other third party components yet. It also cannot be applied to custom server control that does not use standard component programming model. However, you can write your own drag-drop implementation to support your own custom server control through the extensible open-architecture API.

WebDragDropExtender.NET component and all its unique features listed in Features are fully supported in the following browsers:

  • Internet Explorer 6.0+
  • Optimized for Internet Explorer 7.0
  • Firefox 2.0
  • Other Mozilla-based variants.

See Also

Other Resources
{Object Model}
{Events and Life Cycle}
{Drag Event Arguments}
{AJAX DragDrop Server Side Event}


Object Model

Object Model
See Also Send Feedback
Intersoft WebDesktop > WebDragDropExtender > Concepts > Object Model

Glossary Item Box

The following illustration describes the logical object model of WebDragDropExtender and the relation with the Webform.

The above illustration describes four ASP.NET panels (<asp:panel>). Two of them are made as dragable objects, and the other two are made as dropable objects.

With WebDragDropExtender, you can easily add drag behavior to an existing server control by adding DragControl to DragControls collection as shown in above illustration. Likewise, you can make certain containers to accept dragable objects by adding them to DropControls collection.

Using the above simple object model which can be programmed declaratively, you can try to view in browser and discover the drag-drop ability by dragging the specified controls and dropping them into the specified containers.

See Also

Other Resources
Control and Browser Support
{Events and Life Cycle}
{Drag Event Arguments}
{AJAX DragDrop Server Side Event}


Events and Life Cycle

Events and Life Cycle
See Also Send Feedback
Intersoft WebDesktop > WebDragDropExtender > Concepts > Events and Life Cycle

Glossary Item Box

WebDragDropExtender component provides robust event-driven messaging architecture to handle the drag-drop communication throughout the entire page life cycle. Unlike other Web-based drag-drop client scripts available in the industry, WebDragDropExtender encapsulates all drag-drop mechanism and behaviors into an elegant object model. This enables any developers to easily understand and utilize drag-drop behaviors without extensive knowledge of complex drag-drop mechanism.

WebDragDropExtender requires very little effort and almost no code to add drag-drop behavior into your Web application. All that you need to do is basically handling the OnDragDrop event to perform the actions and business-related logics upon a successful drag-drop operation. If you wanted to add some more interactivity, such as providing feedbacks to users when you hover on a drop element, you simply handle the OnDragOver event and assign the Effect available in the drag event arguments.
WebDragDropExtender is designed with high customization and extensibility as one of the key objectives. The following list describes the available client side events and the life cycle in order:
  1. OnDragStart
    When you started a drag operation by holding down left mouse button and move your mouse, this is the first event invoked by WebDragDropExtender.
  2. OnDragEnter
    At the first time you hover on a valid drop element, this event will be invoked against the target drop element.
  3. OnDragOver
    After you entered on a valid drop element and keep moving your mouse over the same element, the WebDragDropExtender control will invoke this event. Since this event will be called repetitively as you move your mouse in the drop area, please handle this event effectively and avoid heavy or long-progress code executions.
  4. OnDragLeave
    When you have entered a valid drop element and move your mouse out from the drop element, this indicates that the drag has leaved the drop element and this event will be invoked.
  5. OnDragEnd
    When you release the left mouse button outside of a valid drop element, this event will be invoked to indicate the end of drag operation.
  6. OnDragDrop
    When you release the left mouse button inside of a valid drop element, this event will be invoked to indicate a successful drag-drop operation.

In addition to the drag-drop events above, there are two additional client side events:

  • OnInitialize
    This event is invoked during WebDragDropExtender initialization.
  • OnShadowCreate
    This event is invoked when WebDragDropExtender is about to create shadow element for the drag control. The shadow is usually created only the first time when the drag operation is initiated. This event allows you to create your own custom shadow in addition to the predefined visual shadow provided in DragSettings.DragVisualHint.

See Also

Other Resources
{Control and Browser Support}
{Object Model}
{Drag Event Arguments}
{AJAX DragDrop Server Side Event}


Drag Event Arguments

Drag Event Arguments
See Also Send Feedback
Intersoft WebDesktop > WebDragDropExtender > Concepts > Drag Event Arguments

Glossary Item Box

WebDragDropExtender implemented drag-drop architecture similar to desktop application (WinForm) which significantly reduces overall learning curve. WinForm developers should be able to understand WebDragDropExtender's drag-drop events and life cycle concept, as well as the object model exposed in the drag event arguments.

The drag-drop event argument is a client side class named ISDragEventArgs providing a set of information according to the current context of a drag-drop operation. Developers can obtain data such as the current drag's data, the allowed effects, the current mouse coordinates from the event argument. You can also give feedback to the current drag-drop event by setting the Effect and EffectText property of the event argument.
The event argument is available in the following events:
Event Name | Event Signature
OnDragEnter | (controlId, dragEventArgs, dropObject)
OnDragOver | (controlId, dragEventArgs, dropObject)
OnDragDrop | (controlId, dragEventArgs, dropObject)

The dragEventArgs passed to the three events listed above contains drag-drop contextual information such as shown in the following table.

Property | Description | Get | Set
DragObject | Represents ISDragableObject instance, which is the object being dragged by the user. | x |
AllowedEffects | The allowed effects specified in DragSettings.AllowedEffects of the WebDragDropExtender control. | x | x
Data | The data associated with a drag control. The native-string type data can be assigned directly in the DragData property of a DragControl object. | x | x
Effect | The default effect associated with a drag control. The effect can be set on the Effect property of a drag control or drag settings (for global appliance). | x | x
EffectText | The effect text (tool tip) that will be displayed when the drag control is over a valid drop target. | x | x
KeyState | The key state in the current context of drag operation. Key state can be combination of Ctrl, Alt, and Shift. | x | x
X | The X point of mouse cursor relative to the document. | x |
Y | The Y point of mouse cursor relative to the document. | x |
CursorX | The X point of mouse cursor relative to the target element. | x |
CursorY | The Y point of mouse cursor relative to the target element. | x |
IsInTargetFrame | Determines whether the drag operation is currently targeting an element inside IFRAME. | x |

To learn more about available enumerations for the Effect and KeyState, please refer to Client Side References.

See Also

Other Resources
{Control and Browser Support}
{Object Model}
{Events and Life Cycle}
{AJAX DragDrop Server Side Event}


AJAX DragDrop Server Side Event

AJAX DragDrop Server Side Event
See Also Send Feedback
Intersoft WebDesktop > WebDragDropExtender > Concepts > AJAX DragDrop Server Side Event

Glossary Item Box

In addition to the rich client side events introduced in Events and Life Cycle, WebDragDropExtender understands the developer's needs to perform business logics and processes in server side by using managed language.

WebDragDropExtender provides built-in features to perform auto postback upon a successful drag-drop operation. The control will firstly invoke OnDragDrop client side event and then proceed to the postback if the return value of the OnDragDrop client side handler is true. This gives you flexibility to control whether a postback should be preceded by specifying return value of the OnDragDrop clent side handler. In the server side, you handle the DragDrop server side event to perform tasks.
WebDragDropExtender includes two properties related to auto postback:
  • AutoPostBackOnDragDrop. The default value is No. Set this property to true to let the control perform postback automatically upon drag drop operation.
  • PostBackMode. The default value is FullPostBack. Set this property to FlyPostBack to perform the postback in AJAX way.
Both properties are available in DropSettings of the WebDragDropExtender instance.

See Also

Tasks
{How-to: Enable AJAX callback and perform server side tasks upon drag drop}

Other Resources
{Control and Browser Support}
{Object Model}
{Events and Life Cycle}
{Drag Event Arguments}


How-to: Enable AJAX callback and perform server side tasks upon drag drop

How-to: Enable AJAX callback and perform server side tasks upon drag drop
See Also Send Feedback
Intersoft WebDesktop > WebDragDropExtender > Concepts > AJAX DragDrop Server Side Event > How-to: Enable AJAX callback and perform server side tasks upon drag drop

Glossary Item Box

You can enable AJAX callback using WebDragDropExtender.NET V1.0.

This topic will show you how to enable AJAX callback and perform server side tasks using drag drop.

To enable AJAX callback

  1. Select a WebDragDropExtender instance, then press F4 to display the property window.
  2. Expand DropSettings.
  3. Set AutoPostBackOnDragDrop to Yes.
  4. Set PostBackMode to FlyPostBack.

The declarative markup sample:

Component's Tags Copy Code
<ISWebDesktop:WebDragDropExtenderID="WebDragDropExtender1" runat="server">
      <DragControls>
           <ISWebDesktop:WebDragControl ControlID="Panel1" DragData="Hello" />
      </DragControls>
      <DropControls>
          <ISWebDesktop:WebDropControl ControlID="Panel3" />
      </DropControls>
      <DropSettings AutoPostBackOnDragDrop="Yes" PostBackMode="FlyPostBack" />
</ISWebDesktop:WebDragDropExtender>

To perform server side tasks upon drag drop

  1. Click Events in the Property Window's command bar.
  2. Double click on the DragDrop event.

As soon as you double click the DragDrop event, you will be taken to the code window as shown in the following image.

Finally, write your own codes to handle business logics according to the drag-drop context available in the event argument.

C# sample codes:

C# Copy Code
protected void WebDragDropExtender1_DragDrop(object sender, ISNet.WebUI.WebDesktop.WebDragDropEventArgs e)
{
     string s = "This data is sent back from server side through FlyPostBack (AJAX) call.<br/><br/>";

     s += "The event argument data:";
     s += "&lt;br/>- DragSource ID: <i>" + e.DragControl.ControlID + "&lt;/i>";
     s += "&lt;br/>- DragData: <i>" + e.Data.ToString() + "&lt;/i>";
     s += "&lt;br/>- Effect: <i>" + e.Effect.ToString() + "&lt;/i>";
     s += "&lt;br/>- EffectText: <i>" + e.EffectText.ToString() + "&lt;/i>";
     s += "&lt;br/>- KeyState: <i>" + e.KeyState.ToString() + "&lt;/i>";
     s += "&lt;br/>- X: <i>" + e.X.ToString() + "&lt;/i>";
     s += "&lt;br/>- Y: <i>" + e.Y.ToString() + "&lt;/i>";

     Panel4.Controls.Add(new LiteralControl(s));
     WebDragDropExtender1.ClientAction.RenderControl(Panel4);
}

See Also

Tasks
{Walkthrough topics}
{FAQ and How-to topics}

Concepts
{AJAX DragDrop Server Side Event}


Features

Features
See Also Send Feedback
Intersoft WebDesktop > WebDragDropExtender > Features

Glossary Item Box

This section lists all key features available in WebDragDropExtender 1.0 which are designed to help developers implementing sophisticated drag and drop capability with less efforts and time.

In This Section

Predefined Cursor Effects
Read about 6 predefined cursor effects available in WebDragDropExtender 1.0.

Automatic Transparent Shadow
Information about automatic transparent shadow that is applied when dragging an object.

Vista Style Tooltip
Read about the new Vista drag-drop tooltip behaviors and styles.

Keyboard State
Read about Keyboard State that allows user to query the keyboard state during a drag operation.

Auto Postback Mode
Read about Auto Postback Mode that allows user to handle DragDrop event in server side.

Use Custom Object as Data
Learn how to use custom object as data in WebDragDropExtender 1.0, such as GetDataPresent() method.

Drag Data Validation
Read about 2 kinds of build-in drag-drop validation in WebDragDropExtender 1.0.

Cross IFRAME Support
Read about one of the most powerful features in WebDragDropExtender 1.0, which is able to perform drag-drop over IFRAME.

Integration with Intersoft Controls
Read about WebDragDropExtender's capability to handle integration with other Intersoft controls.

See Also

Other Resources
WebDragDropExtender Overview
WebDragDropExtender Concepts
WebDragDropExtender Features


Predefined Cursor Effects

Predefined Cursor Effects
See Also Send Feedback
Intersoft WebDesktop > WebDragDropExtender > Features > Predefined Cursor Effects

Glossary Item Box

WebDragDropExtender comes with 6 predefined cursor effects. You can set the effect in two ways:

  • DefaultEffect property in DragSettings. This setting affects all drag controls which Effect is set to Default.
  • Effect property in DragControl level. Set the Effect property at DragControl level to override the Effect only for the individual level of the DragControl.

The following table lists the available effects in WebDragDropExtender 1.0.

Effect Name | Visual Indicator | Description
None | - | No effects is specified.
All | - | This effect shows no special indicator, just the default mouse cursor. This effect also means that the drop target could accept any kind of effects.
Copy |  | Shows a copy effect.
Link |  | Shows a link effect.
Move |  | Shows a move effect.
NotAllowed |  | Shows an invalid effect, usually indicating a not allowed operation.
Scroll | - | This effect is reserved for future use.
Remove |  | Shows X sign, indicating a delete or removal operation.
Default | - | Indicates that the drag control should inherit the setting fro the global DragSettings.

It is recommended to always enable SmartWebResources feature to ensure the availability of the client resources as well as for hassles-free deployment. To learn more about SmartWebResources, please refer to New SmartWebResources Framework.

See Also

Tasks
{Walkthrough: Specifying Cursor Effect for all DragControls}
{Walkthrough: Specifying Cursor Effect for individual DragControl}
{Walkthrough: Changing Cursor Effect Programmatically in Client Side}

Other Resources
{Automatic Transparent Shadow}
{Vista™ Style Tooltip}
Keyboard State
{Auto Postback Mode}
{Use Custom Object as Data}
{Drag Data Validation}
{Cross IFRAME Support}
{Integration with Intersoft Controls}


Walkthrough: Specifying Cursor Effect for all DragControls

Walkthrough: Specifying Cursor Effect for all DragControls
See Also Send Feedback
Intersoft WebDesktop > WebDragDropExtender > Features > Predefined Cursor Effects > Walkthrough: Specifying Cursor Effect for all DragControls

Glossary Item Box

This walkthrough shows you how to specify cursor effect for all DragControls.

During this walkthrough, you will learn how to do the following:

  • Set ASP.NET panel for drag panel and drop panel.
  • Use WebDragDropExtender to allow the dragable panel dragged to dropable panel.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Visual Studio 2005 Application.

Step-By-Step Instructions

To specify cursor effect for all DragControls.

  1. Launch Visual Studio.NET 2005.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. Drag 6 ASP.Net Panel to WebForm.
  8. Drag WebDragDropExtender instance from ToolBar to the page.
  9. Set the BackColor of each ASP.NET Panel.

  10. Focus on WebDragDropExtender and press F4 (to go to WebDragDropExtender's properties).
  11. On DragControls property, click the (collection) to open WebDragControl Collection Editor. Set which panels that will become DragControl.

  12. On DropControls property, click the (collection) to open WebDropControl Collection Editor. Set which panels that will become DropControl.

  13. Search for DragSettings >> DefaultEffect. Set the cursor effect for all DragControls (for example : Copy)

  14. Run the project. You will notice the cursor effect when trying to drag the dragable panel and drop it to the dropable panel.

See Also

Tasks
{Walkthrough: Specifying Cursor Effect for individual DragControl}
{Walkthrough: Changing Cursor Effect Programmatically in Client Side}

Concepts
Predefined Cursor Effects


Walkthrough: Specifying Cursor Effect for individual DragControl

Walkthrough: Specifying Cursor Effect for individual DragControl
See Also Send Feedback
Intersoft WebDesktop > WebDragDropExtender > Features > Predefined Cursor Effects > Walkthrough: Specifying Cursor Effect for individual DragControl

Glossary Item Box

This walkthrough shows you how to specify cursor effect for individual DragControl.

During this walkthrough, you will learn how to do the following:

  • Set ASP.NET panel for dragable panel and dropable panel.
  • Use WebDragDropExtender to allow the dragable panel dragged to dropable panel.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Visual Studio 2005 Application.

Step-By-Step Instructions

To specify cursor effect for individual DragControl.

  1. Launch Visual Studio.NET 2005.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. Drag 6 ASP.Net Panel to WebForm.
  8. Drag WebDragDropExtender instance from ToolBar to the WebForm.
  9. Set the BackColor of each ASP.NET Panel.

  10. Focus on WebDragDropExtender and press F4 (to go to WebDragDropExtender's properties).
  11. On DragControls property, click the (collection) to open WebDragControl Collection Editor. Set which panels that will become DragControl.

  12. Set Panel1's Effect to Move and Panel2's Effect to Link.
  13. On DropControls property, click the (collection) to open WebDropControl Collection Editor. Set which panels that will become DropControl.

  14. Run the project. You will notice the cursor effect when trying to drag the dragable panel and drop it to the dropable panel.

See Also

Tasks
{Walkthrough: Specifying Cursor Effect for all DragControls}
{Walkthrough: Changing Cursor Effect Programmatically in Client Side}

Concepts
{Predefined Cursor Effects}


Walkthrough: Changing Cursor Effect Programmatically in Client Side

Walkthrough: Changing Cursor Effect Programmatically in Client Side
See Also Send Feedback
Intersoft WebDesktop > WebDragDropExtender > Features > Predefined Cursor Effects > Walkthrough: Changing Cursor Effect Programmatically in Client Side

Glossary Item Box

This walkthrough shows you how to change cursor effect programmatically in client side.

During this walkthrough, you will learn how to do the following:

  • Set ASP.NET Panel for dragable panel and dropable panel.
  • Use WebDragDropExtender to allow the dragable panel dragged to dropable panel.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Visual Studio 2005 Application.

Step-By-Step Instructions

To change cursor effect programmatically in client side.

  1. Launch Visual Studio.NET 2005.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. Drag 6 ASP.Net Panel to WebForm.
  8. Drag WebDragDropExtender instance from ToolBar to WebForm.
  9. Set the BackColor of each ASP.NET Panel.

  10. Click on WebDragDropExtender instance and press F4.
  11. On DragControls property, click the (collection) to open WebDragControl Collection Editor. Set which panels that will become DragControl.

  12. On DropControls property, click the (collection) to open WebDropControl Collection Editor. Set which panels that will become DropControl.

  13. Implement OnDragOver client side event

    JavaScript Copy Code
    function WebDragDropExtender1_OnDragOver(controlId, dragEventArgs, dropObject)
{
   var WebDragDropExtender1 = ISGetObject(controlId);
   switch (dropObject.Element.id)
   {
      case "Panel6":
              dragEventArgs.Effect = ISDragDropEffects.Copy;
              break;
      case "Panel4":
              dragEventArgs.Effect = ISDragDropEffects.Move;
              break;
      case "Panel5":
              dragEventArgs.Effect = ISDragDropEffects.Link;
              break;
      case "Panel3":
              dragEventArgs.Effect = ISDragDropEffects.NotAllowed;
              break;
      case "Panel2":
              dragEventArgs.Effect = ISDragDropEffects.Remove;
              break;
   }
   return true;
}

  14. Run the project. You will notice the cursor effect when trying to drag the dragable panel and drop it to the dropable panel.

See Also

Tasks
{Walkthrough: Specifying Cursor Effect for all DragControls}
{Walkthrough: Specifying Cursor Effect for individual DragControl}

Concepts
{Predefined Cursor Effects}


Automatic Transparent Shadow

Automatic Transparent Shadow
See Also Send Feedback
Intersoft WebDesktop > WebDragDropExtender > Features > Automatic Transparent Shadow

Glossary Item Box

WebDragDropExtender is designed to help developers implementing sophisticated drag and drop capability in little efforts and time. When you add a server control into DragControls, you can immediately drag on the control's element when you run it in browser.

Furthermore, when you dragged the control's element, notice that WebDragDropExtender automatically creates a transparent shadow of the original element as the drag visual hint/indicator. This feature enables end users to easily recognize the dragged objects and ensuring they are grabbing the correct objects before dropping it to the target objects.

Drag and drop has become a very important user interaction in an application since the invention of GUI Desktop such as Windows®. It simply enables end users to perform quick data entry with minimal efforts, and hence increasing user's productivity. WebDragDropExtender and its automatic transparent shadow feature provides a visually compelling drag and drop capability which reducing the possibility of data entry errors as well as reducing data entry complexity.
WebDragDropExtender provides two predefined drag visual hints:
  • MakeTransparent, which is the default value.
  • SimpleIndicator
    This mode allows you to create traditional drag visual hint similar to those in older Windows® applications. The simple indicator simply shows a small rectangular hint below the mouse pointer.

The MakeTransparent mode creates transparent shadow similar to the following image.

See Also

Tasks
{How-to: Use simple indicator as drag visual hint}

Other Resources
{Predefined Cursor Effects}
{Vista™ Style Tooltip}
{Keyboard State}
{Auto Postback Mode}
{Use Custom Object as Data}
{Drag Data Validation}
{Cross IFRAME Support}
{Integration with Intersoft Controls}


How-to: Use simple indicator as drag visual hint

How-to: Use simple indicator as drag visual hint
See Also Send Feedback
Intersoft WebDesktop > WebDragDropExtender > Features > Automatic Transparent Shadow > How-to: Use simple indicator as drag visual hint

Glossary Item Box

When you dragged a control, notice that WebDragDropExtender automatically creates a transparent shadow of the original element as the drag visual hint/indicator. This feature enables end users to easily recognize the dragged objects and ensuring they are grabbing the correct objects before dropping it to the target objects.

Beside create transparent shadow, WebDragDropExtender provide another way for drag visual hint. It is SimpleIndicator. This mode allows you to create traditional drag visual hint similar to those in older Windows applications. The simple indicator simply shows a small rectangular hint below the mouse pointer.

In this topic, you will learn how to use simple indicator as drag visual hint.

To use simple indicator as drag visual hint

  1. Focus on WebDragDropExtender and press F4 to open WebDragDropExtender's properties.
  2. Search for DragSettings >> DragVisualHint
  3. Set DragVisualHint to SimpleIndicator.

See Also

Tasks
{Walkthrough topics}
{FAQ and How-to topics}

Concepts
{Automatic Transparent Shadow}


Vista Style Tooltip

Vista Style Tooltip
See Also Send Feedback
Intersoft WebDesktop > WebDragDropExtender > Features > Vista Style Tooltip

Glossary Item Box

WebDragDropExtender does not only bring a whole new possibility to create richer Web application through versatile drag-drop architecture, it also delivers the new Vista™ drag-drop tooltip behaviors and styles.

The new Vista™ tooltip has the following behaviors:

  • When you hover on a valid target object, the effect cursor (eg, Move) should appear immediately to give a real-time visual feedback to end user.
  • When you hold on the mouse button and stay on the same position for at least 500 milliseconds, the tooltip text should appear including the rectangular frame.
  • The rectangular frame should be positioned and has auto-size capability to cover the effect cursor and the text.
  • The visual cursor effect should stay in the same position/location as it is originally shown when the rectangular frame and the tooltip text are displayed.

The following image illustrates the Vista™ style tooltip in WebDragDropExtender control.

See Also

Tasks
{Walkthrough: Setting tooltip text programmatically in client side based on drop target objects.}
{How-to: Specify tooltip text to a drag control}

Other Resources
{Predefined Cursor Effects}
{Automatic Transparent Shadow}
{Keyboard State}
{Auto Postback Mode}
{Use Custom Object as Data}
{Drag Data Validation}
{Cross IFRAME Support}
{Integration with Intersoft Controls}


Walkthrough: Setting tooltip text programmatically in client side based on drop target objects.

Walkthrough: Setting tooltip text programmatically in client side based on drop target objects.
See Also Send Feedback
Intersoft WebDesktop > WebDragDropExtender > Features > Vista Style Tooltip > Walkthrough: Setting tooltip text programmatically in client side based on drop target objects.

Glossary Item Box

This walkthrough shows you how to set tooltip text programmatically in client side based on drop target objects.

During this walkthrough, you will learn how to do the following:

  • Set asp.net panel for drag panel and drop panel.
  • Use WebDragDropExtender to allow the drag panel dragged to drop panel.
  • Use different tooltip for different drop panel.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Visual Studio 2005 Application.

Step-By-Step Instructions

To set tooltip text programmatically in client side based on drop target objects.

  1. Launch Visual Studio.NET 2005.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. Drag WebDragDropExtender instance from ToolBar to WebForm.
  8. Drag 3 ASP.Net panel to WebForm.
  9. Set the background of each panel to different color (e.g : first panel yellow, second panel blue and third panel red).

  10. Click on WebDragDropExtender instance and press F4.
  11. On DragControls property, click the (collection) button to open WebDragControl Collection Editor. You can set which panel will be the DragControl.

  12. On DropControls property, click the (collection) button to open WebDropControl Collection Editor. You can set which panel will be the DropControl.

  13. On ClientSide >> OnDragOver property, click the arrow icon and write DragOver.

  14. On HTML mode create a new client side function and named it function DragOver(controlId, e, dropObject). Here is the complete code :

    JavaScript Copy Code
    function DragOver(controlId, dragEventArgs, dropObject)
{
   switch (dropObject.Owner.ControlID)
   {
       case "Panel3":
        dragEventArgs.Effect = ISDragDropEffects.Copy;
        dragEventArgs.EffectText = "Copy to " + dropObject.Owner.ControlID;
       break;

       case "Panel2":
        dragEventArgs.Effect = ISDragDropEffects.Remove;
        dragEventArgs.EffectText = "Remove this object";
       break;
    }
}

  15. Run and compile the project.
  16. Try to hover the yellow panel to blue panel to see the tooltip.

See Also

Tasks
{How-to: Specify tooltip text to a drag control}
{Walkthrough topics}
{FAQ and How-to topics}

Concepts
{Vista™ Style Tooltip}


How-to: Specify tooltip text to a drag control

How-to: Specify tooltip text to a drag control
See Also Send Feedback
Intersoft WebDesktop > WebDragDropExtender > Features > Vista Style Tooltip > How-to: Specify tooltip text to a drag control

Glossary Item Box

You can specify tooltip text to a drag control.

This topic will show you how to specify tooltip text to a drag control in WebDragDropExtender.

To specify tooltip text to a drag control

  1. Click on WebDragDropExtender instance and press F4.
  2. On DragControls property, click the (collection) button to open WebDragControl Collection Editor.
  3. Set EffectText property to your own text(e.g : Drag here.).
  4. Click OK to apply the changes.

See Also

Tasks
{Walkthrough: Setting tooltip text programmatically in client side based on drop target objects.}
{Walkthrough topics}
{FAQ and How-to topics}

Concepts
{Vista™ Style Tooltip}


Keyboard State

Keyboard State
See Also Send Feedback
Intersoft WebDesktop > WebDragDropExtender > Features > Keyboard State

Glossary Item Box

This feature allows you to query the keyboard state during a drag operation. With this capability, you can easily achieve more advanced scenarios such as determining the Effect based on the key state of the current drag context.

It is very common in Windows® desktop application providing a drag-drop capability which action is determined by the key state. For instance, in Windows Explorer, you can drag some files and while you hover on the target folder, you can press Ctrl key in order to perform Copy action. Likewise, you can press Shift to perform Move action.
WebDragDropExtender brought this feature live to the Web, so you can now add the same rich drag-drop experience to your Web application. This results in a better Web experience for your end users.

See Also

Tasks
{How-to: Obtain key state during DragOver event}
{How-to: Determine Effect programmatically based on current key state}

Other Resources
{Predefined Cursor Effects}
{Automatic Transparent Shadow}
{Vista™ Style Tooltip}
{Auto Postback Mode}
{Use Custom Object as Data}
{Drag Data Validation}
{Cross IFRAME Support}
{Integration with Intersoft Controls}


How-to: Obtain key state during DragDrop event

How-to: Obtain key state during DragDrop event
See Also Send Feedback
Intersoft WebDesktop > WebDragDropExtender > Features > Keyboard State > How-to: Obtain key state during DragDrop event

Glossary Item Box

You can obtain key state during DragDrop event.

This topic will show you how to obtain key state during DragDrop event.

To obtain key state during DragDrop event

  1. Click on WebDragDropExtender instance and press F4.
  2. On ClientSide >> OnDragDrop property, click the arrow icon and write DragDrop.
  3. On HTML mode create a new client side function and named it function DragDrop(controlId, e, dropObject). Here are the complete code :

    JavaScript Copy Code
    function DragDrop(controlId, e, dropObject)
{
    var listBox = document.getElementById("listBox1");
    var op = document.createElement("option");
    var effectText = "";

    if (e.Effect == ISDragDropEffects.Copy)
        effectText = "Copied";
    else if (e.Effect == ISDragDropEffects.Move)
        effectText = "Moved";
    else if (e.Effect == ISDragDropEffects.Link)
        effectText = "Linked";
    else
        effectText = "[Default] Moved";

    op.text = effectText + " '" + e.Data + "' to '" + dropObject.Element.id + "'";
    listBox.options.add(op);
}

  4. Compile and run the project.

See Also

Tasks
{How-to: Determine Effect programmatically based on current key state}

Concepts
Keyboard State


How-to: Determine Effect programmatically based on current key state

How-to: Determine Effect programmatically based on current key state
See Also Send Feedback
Intersoft WebDesktop > WebDragDropExtender > Features > Keyboard State > How-to: Determine Effect programmatically based on current key state

Glossary Item Box

You can set effect programmatically based on current key state.

This topic will show you how to determine effect programmatically based on current key state.

To determine effect programmatically based on current key state

  1. Click on WebDragDropExtender instance and press F4.
  2. On ClientSide >> OnDragOver property, click the arrow icon and write DragOver.
  3. On HTML mode create a new client side function and named it function DragOver(controlId, e, dropObject). Here are the complete code :

    JavaScript Copy Code
    function DragOver(controlId, e, dropObject)
{
    // provide the Effect based on key state during drag over
    if ((e.KeyState & ISKeyState.Ctrl) == ISKeyState.Ctrl)
        e.Effect = ISDragDropEffects.Copy;
    else if ((e.KeyState & ISKeyState.Alt) == ISKeyState.Alt)
        e.Effect = ISDragDropEffects.Link;
    else if ((e.KeyState & ISKeyState.Shift) == ISKeyState.Shift)
        e.Effect = ISDragDropEffects.Move;
    else
        e.Effect = ISDragDropEffects.None;
}
  4. Compile and run the project.

See Also

Tasks
{How-to: Obtain key state during DragDrop event}

Concepts
{Keyboard State}


Auto Postback Mode

Auto Postback Mode
See Also Send Feedback
Intersoft WebDesktop > WebDragDropExtender > Features > Auto Postback Mode

Glossary Item Box

WebDragDropExtender allows you to handle DragDrop event in two ways. Firstly, you can handle the OnDragDrop client side event if you only wanted to perform client-side tasks such as adding or changing an html element dynamically. However in most Web application, oftentimes you need to perform database operations or other server-side related tasks. For instance, you might want to save the modified data to physical database and so on.

With AutoPostback feature, WebDragDropExtender makes it easy for you to handle DragDrop event in server-side. You can also change the Postback mode to FlyPostBack in order to perform the Postback in AJAX way.

To learn more about AJAX and Auto Postback feature, please refer to AJAX DragDrop Server Side Event.

See Also

Tasks
{Walkthrough topics}
{FAQ and How-to topics}

Other Resources
{Predefined Cursor Effects}
{Automatic Transparent Shadow}
{Vista™ Style Tooltip}
{Keyboard State}
{Use Custom Object as Data}
{Drag Data Validation}
{Cross IFRAME Support}
{Integration with Intersoft Controls}


Use Custom Object as Data

Use Custom Object as Data
See Also Send Feedback
Intersoft WebDesktop > WebDragDropExtender > Features > Use Custom Object as Data

Glossary Item Box

Although WebDragDropExtender provides DragData property at WebDragControl class, it can only be used to pass string-type data. In more advanced scenario, you might want to pass more complex object as the DragData, which later queried by the target drop object for validation. WebDragDropExtender allows you to achieve this scenario by assigning the custom object in OnDragStart client side event.

In this type of scenario, developer usually queries against the object type and data in OnDragOver client side event. WebDragDropExtender control provides GetDataPresent method which you can use to validate the type of the object. The GetDataPresent concept is similar to WinForm.NET drag drop architecture.

See Also

Tasks
{Walkthrough: Using GetDataPresent method to query object type in OnDragOver event}

Other Resources
{Predefined Cursor Effects}
{Automatic Transparent Shadow}
{Vista™ Style Tooltip}
{Keyboard State}
{Auto Postback Mode}
{Drag Data Validation}
{Cross IFRAME Support}
{Integration with Intersoft Controls}


Walkthrough: Using GetDataPresent method to query object type in OnDragOver event

Walkthrough: Using GetDataPresent method to query object type in OnDragOver event
See Also Send Feedback
Intersoft WebDesktop > WebDragDropExtender > Features > Use Custom Object as Data > Walkthrough: Using GetDataPresent method to query object type in OnDragOver event

Glossary Item Box

This walkthrough shows you how to use GetDataPresent method to query object type in OnDragOver event.

During this walkthrough, you will learn how to do the following:

  • Set ASP.NET Panel for dragable panel and dropable panel.
  • Use WebDragDropExtender to allow the dragable panel dragged to dropable panel.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Visual Studio 2005 Application.

Step-By-Step Instructions

To use GetDataPresent method to query to object type in OnDragOver event.

  1. Launch Visual Studio.NET 2005.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. Drag 4 ASP.Net Panel to WebForm.
  8. Drag WebDragDropExtender instance from ToolBar to WebForm.
  9. Set the BackColor of each ASP.NET Panel.

  10. Click on WebDragDropExtender instance and press F4.
  11. On DragControls property, click the (collection) to open WebDragControl Collection Editor. Set Panel1 and Panel2 as DragControl.

  12. On DropControls property, click the (collection) to open WebDropControl Collection Editor. Set Panel3 and Panel4 as DropControl.

  13. Create Box and Circle object.
    JavaScript Copy Code
    function Box()
    {
       this._Type = "Box";
       ISObject.call(this);
    }

    function Circle()
    {
       this._Type = "Circle";
       ISObject.call(this);
    }

  14. Assign each Panel with the object.
    JavaScript Copy Code
    function DragStart(controlId, dragObject)
    {
       var dragControl = dragObject.Owner;

       /* assign DragData based on the dragged control */
       if (dragControl.ControlID == "Panel1")
       {
          dragControl.DragData = new Box();
       }
       else if (dragControl.ControlID == "Panel2")
       {
          dragControl.DragData = new Circle();
       }
    }

  15. Specify the effect for each drop able Panel using GetDataPresent method to validate the type of the object.
    JavaScript Copy Image Copy Code
    function DragOver(controlId, e, dropObject)
    {
       if (dropObject.Owner.ControlID == "Panel4")
       {
          if (e.GetDataPresent("object", "Box"))
             e.Effect = ISDragDropEffects.Copy;
          else
             e.Effect = ISDragDropEffects.NotAllowed;
       }
       else
       {
          if (e.GetDataPresent("object", "Circle"))
             e.Effect = ISDragDropEffects.Move;
          else
             e.Effect = ISDragDropEffects.NotAllowed;
       }
    }

  16. Specify an alert for each DragDrop action.
    JavaScript Copy Code
    function DragDrop(controlId, e, dropObject)
    {
        // this function is invoked when a valid dragable element is dropped (mouse up).

        if ((e.Effect & ISDragDropEffects.NotAllowed) == ISDragDropEffects.NotAllowed) // notice that we used bitwise operator to check the flag here
        {
            alert("You tried to drop on me, but sorry - not allowed");
        }
        else
        {
            alert("Congratulations. You have successfully drop '" + e.DragObject.Owner.ControlID + "' element to '" + dropObject.Owner.ControlID + "'!");
        }
}

  17. Run the project. You will notice the cursor effect when trying to drag the drag able panel and drop it to the drop able panel.

See Also

Tasks
{Walkthrough topics}
{FAQ and How-to topics}

Concepts
{Use Custom Object as Data}


Drag Data Validation

Drag Data Validation
See Also Send Feedback
Intersoft WebDesktop > WebDragDropExtender > Features > Drag Data Validation

Glossary Item Box

As your Web application being developed toward a richer and sophisticated user experience, the application of drag and drop may grow significantly and become more advanced and complex. It is very important that you carefully designed drag-drop features to avoid data input error and to allow extensibility in the future.

One of the essential tasks that you should consider to implement during the design is the drag-drop validation. Often times you would like to restrict the drop controls to allow receiving drag controls based on its drag data type. For instance, a Treeview control may expect a drag control containing "GridItems" data. In this scenario, the Treeview control shouldn't receive other kind of data to avoid erroneous data processing.
There are two kinds of built-in drag-drop validation introduced in WebDragDropExtender 1.0:
  • Accept Data Type
    You can specify a drop control to accept certain drag controls which DragData type is equal to a specific data type, by specifying the target data type in the AcceptDataType property.
  • Accept Drag Controls
    You can specify a drop control to accept certain drag controls which ID is included in the AcceptDragControls property of the drop control. You can specify multiple control IDs by separating each control ID with semicolon character.
With both techniques above, you can create basic validation for your drag-drop implementation scenarios. When the drag context does not meet the condition set by either data type or drag controls ID, the drag's cursor effect will be set to NotAllowed automatically to give real-time feedbacks to end users. However, the OnDragDrop client side event will still be called regardless of the current Effect. It is best practice to check the current Effect in the OnDragDrop event before you determine further actions. To learn more, please refer to Walkthrough: Ensuring validity of drag objects based on Effect during DragDrop event.

Accept Drag Controls Sample (ASPX)

Component's Tags Copy Code
<ISWebDesktop:WebDragDropExtender ID="WebDragDropExtender1" runat="server">
   <DragSettings DefaultEffect="Move" />
   <DragControls>
      <ISWebDesktop:WebDragControl ControlID="Image1" />
      <ISWebDesktop:WebDragControl ControlID="Image2" />
      <ISWebDesktop:WebDragControl ControlID="Image3" />
   </DragControls>
   <DropControls>
      <ISWebDesktop:WebDropControl AcceptDragSourceControls="Image1; Image2" ControlID="Panel1" />
   </DropControls>
</ISWebDesktop:WebDragDropExtender>

See Also

Tasks
{Walkthrough: Restricting a drop control to accept only Number data type.}
{Walkthrough: Ensuring validity of drag objects based on Effect during DragDrop event}

Other Resources
{Predefined Cursor Effects}
{Automatic Transparent Shadow}
{Vista™ Style Tooltip}
{Keyboard State}
{Auto Postback Mode}
{Use Custom Object as Data}
{Cross IFRAME Support}
{Integration with Intersoft Controls}


Walkthrough: Restricting a drop control to accept only Number data type

Walkthrough: Restricting a drop control to accept only Number data type
See Also Send Feedback
Intersoft WebDesktop > WebDragDropExtender > Features > Drag Data Validation > Walkthrough: Restricting a drop control to accept only Number data type

Glossary Item Box

This walkthrough shows you how to restrict a drop control to accept only Number data type.

During this walkthrough, you will learn how to do the following:

  • Set asp.net panel for drag panel and drop panel.
  • Use WebDragDropExtender to allow the drag panel dragged to drop panel.
  • Set which panel can be accepted by drop control.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Visual Studio 2005/2008/2010 Application.

Step-By-Step Instructions

To set restricting a drop control to accept only Number data type.

  1. Launch Visual Studio.NET 2008.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. Drag WebDragDropExtender instance from ToolBar to WebForm.
  8. Drag three ASP.Net panel to WebForm.
  9. Set the background of each panel to different color (e.g : first panel pink, second panel yellow and third panel green).

  10. Click on WebDragDropExtender instance and press F4.
  11. On DragControls property, click the (collection) button to open WebDragControl Collection Editor. You can set which panel will be the DragControl.

  12. On DropControls property, click the (collection) button to open WebDropControl Collection Editor. You can set which panel that will be the DropControl.

  13. In ClientSideEvents, set OnDragStart to DragStart.
  14. In ClientSideEvents, set OnDragDrop to DragDrop.

  15. On HTML mode create a new client side function and named it function DragOver(controlId, e, dropObject) and function DragDrop(controlId, e, dropObject). Here is the complete code:

    JavaScript Copy Code
    function DragStart(controlId, e)
{
    var dragControl = e.Owner;

    if (dragControl.ControlID == "Panel2")
    {
        /* assign DragData programmatically in client side */
        dragControl.DragData = 100;
    }
}

function DragDrop(controlId, e, dropObject)
{
    if (e.Effect == ISDragDropEffects.NotAllowed)
    {
        alert("Nice try..");
    }
    else
    {
        alert("Thanks for dropping by..");
    }
}

  16. Run and compile the project.
  17. Try to drag the pink panel and you will see the restricted effect from the pink panel.

See Also

Tasks
Walkthrough: Ensuring validity of drag objects based on Effect

Concepts
{Drag Data Validation}


Walkthrough: Ensuring validity of drag objects based on Effect

Walkthrough: Ensuring validity of drag objects based on Effect
See Also Send Feedback
Intersoft WebDesktop > WebDragDropExtender > Features > Drag Data Validation > Walkthrough: Ensuring validity of drag objects based on Effect

Glossary Item Box

This walkthrough shows you how to ensure validity of drag objects based on WebDragDropExtender effect.

During this walkthrough, you will learn how to do the following:

  • Set asp.net panel for drag panel and drop panel.
  • Use WebDragDropExtender to allow the drag panel dragged to drop panel.
  • Set which panel can be accepted by drop control.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Visual Studio 2005 Application.

Step-By-Step Instructions

To set restricting a drop control to accept only Number data type.

  1. Launch Visual Studio.NET 2005.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. Drag WebDragDropExtender instance from ToolBar to WebForm.
  8. Drag 3 ASP.Net panel to WebForm.
  9. Set the background of each panel to different color (e.g : first panel pink, second panel yellow and third panel green).

  10. Click on WebDragDropExtender instance and press F4.
  11. On DragControls property, click the (collection) button to open WebDragControl Collection Editor. You can set which panel will be the DragControl.

  12. On DropControls property, click the (collection) button to open WebDropControl Collection Editor. You can set which panel will be the DropControl and set AcceptDragSourceControls to Panel1.

  13. Run and compile the project.
  14. Try to drag the pink panel and you will see the restricted effect from the pink panel.

See Also

Tasks
{Walkthrough: Restricting a drop control to accept only Number data type}

Concepts
{Drag Data Validation}


Cross IFRAME Support

Cross IFRAME Support
See Also Send Feedback
Intersoft WebDesktop > WebDragDropExtender > Features > Cross IFRAME Support

Glossary Item Box

One of the most powerful features introduced by WebDragDropExtender is its ability to perform drag-drop over IFRAMEs. With this feature, you can now deliver rich Web application with sophisticated drag and drop capability beyond IFRAME limitation.

IFRAME Support Modes

WebDragDropExtender provides 2 level of IFRAME Support:

  1. Parent to Child
    This mode also called as ChildIFrameOnly mode allows you to drag an element from parent frame and drop it to the target element inside child IFRAMEs. To get a better understanding on how it works, see the following illustration.

    As seen in the illustration above, we can specify an element at the parent window to be dragable in WebDragDropExtender. The dragable control definition should have its AllowCrossIFrame property set to ChildIFrameOnly. Next, in the IFrame1.aspx and IFrame2.aspx, we can specify the drop elements in each Webform by creating WebDragDropExtender control. The specified drop elements will automatically be able to accept dragable elements from the parent window without additional configuration.

  2. Child to Child(Sibling)
    This IFrame Mode allows you to drag an element from one IFRAME and drop it to other IFRAMEs (sibling) in the same page. This powerful feature opens a whole new possibility to deliver rich and sophisticated drag-drop capability that is similar to Windows® desktop application.

    To get a better understanding on how it works, see the following illustration.

    In the illustration above, the WebForm1.aspx contains three floating IFRAMEs. The left one is IFrame1.aspx, and two in the right side are IFrame2.aspx and IFrame3.aspx. The first IFRAME includes two dragable elements, which can be dropped to target element in either second or third IFRAME.

    The Webform which hosts the IFRAME, needs to have at least one WebDragDropExtender instance in order for this feature to work properly, even though there is no drag control or drop control in the WebDragDropExtender.

    For example, please take a look at the following ASPX markup:

    Component's Tags Copy Code
    <ISWebDesktop : WebDragDropExtender ID="WebDragDropExtender1" runat="server">
        <DragSettings AllowCrossIFrame="SiblingAndChildIFrame" />
    </ISWebDesktop:WebDragDropExtender>

See Also

Tasks
Walkthrough: Enabling a panel server control to be dragable across child IFRAMEs
{Walkthrough: Enabling a panel server control to be dragable across sibling child IFRAMEs}

Other Resources
{Predefined Cursor Effects}
{Automatic Transparent Shadow}
{Vista�?� Style Tooltip}
{Keyboard State}
{Auto Postback Mode}
{Use Custom Object as Data}
{Drag Data Validation}
{Integration with Intersoft Controls}


IFRAME Support Modes

IFRAME Support Modes
Send Feedback

Glossary Item Box


Walkthrough: Enabling a panel server control to be dragable across child IFRAMEs

Walkthrough: Enabling a panel server control to be dragable across child IFRAMEs
See Also Send Feedback
Intersoft WebDesktop > WebDragDropExtender > Features > Cross IFRAME Support > Walkthrough: Enabling a panel server control to be dragable across child IFRAMEs

Glossary Item Box

This walkthrough shows you how to enable a panel server control to be dragable across child IFRAMEs.

During this walkthrough, you will learn how to do the following:

  • Set asp.net panel for drag panel and drop panel.
  • Use WebDragDropExtender to allow the drag panel dragged to drop panel.
  • Create IFrame.
  • Set panel to be dragable across child IFRAMEs.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Visual Studio 2005/2008/2010 Application.

Step-By-Step Instructions

To enabling a panel server control to be dragable across child IFRAMEs.

  1. Launch Visual Studio.NET 2008.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as IFrame1.aspx.
  7. Drag WebDragDropExtender instance from ToolBar to WebForm.
  8. Drag ASP.Net panel to WebForm.

  9. Click on WebDragDropExtender instance and press F4.
  10. On DropControls property, click the (collection) button to open WebDropControl Collection Editor. You can set which panel that will be the DropControl.
  11. Right-click on Project's name and select Add New Item.
  12. Select Intersoft AppForm in the My Templates box and named it as IFrame2.aspx.
  13. Drag WebDragDropExtender instance from ToolBar to WebForm.
  14. Drag ASP.Net panel to WebForm.

  15. Click on WebDragDropExtender instance and press F4.
  16. On DropControls property, click the (collection) button to open WebDropControl Collection Editor. You can set which panel that will be the DropControl.
  17. Right-click on Project's name and select Add New Item.
  18. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  19. Drag WebDragDropExtender instance from ToolBar to WebForm.
  20. Drag ASP.Net panel to WebForm.
  21. Create two IFrame and point them to IFrame1.aspx and IFrame2.aspx.

  22. Click on WebDragDropExtender instance and press F4.
  23. On DragControls property, click the (collection) button to open WebDragControl Collection Editor. You can set which panel that will be the DragControl and AllowCrossIFrame property to ChildIFrameOnly.

  24. Run and compile the project.

See Also

Tasks
{Walkthrough: Enabling a panel server control to be dragable across sibling child IFRAMEs}

Concepts
{Cross IFRAME Support}


Walkthrough: Enabling a panel server control to be dragable across sibling child IFRAMEs

Walkthrough: Enabling a panel server control to be dragable across sibling child IFRAMEs
See Also Send Feedback
Intersoft WebDesktop > WebDragDropExtender > Features > Cross IFRAME Support > Walkthrough: Enabling a panel server control to be dragable across sibling child IFRAMEs

Glossary Item Box

This walkthrough shows you how to enable a panel server control to be dragable across sibling child IFRAMEs.

During this walkthrough, you will learn how to do the following:

  • Set asp.net panel for drag panel and drop panel.
  • Use WebDragDropExtender to allow the drag panel dragged to drop panel.
  • Create IFrame.
  • Set panel to be dragable across sibling child IFRAMEs.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Visual Studio 2005 Application.

Step-By-Step Instructions

To enabling a panel server control to be dragable across child IFRAMEs.

  1. Launch Visual Studio.NET 2005.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as IFrame1.aspx.
  7. Drag WebDragDropExtender instance from ToolBar to WebForm.
  8. Drag ASP.Net panel to WebForm.

  9. Click on WebDragDropExtender instance and press F4.
  10. On DragControls property, click the (collection) button to open WebDragControl Collection Editor. You can set which panel that will be the DragControl also set for the Effect and EffectText.
  11. Right-click on Project's name and select Add New Item.
  12. Select Intersoft AppForm in the My Templates box and named it as IFrame2.aspx.
  13. Drag WebDragDropExtender instance from ToolBar to WebForm.
  14. Drag ASP.Net panel to WebForm.

  15. Click on WebDragDropExtender instance and press F4.
  16. On DropControls property, click the (collection) button to open WebDropControl Collection Editor. You can set which panel that will be the DropControl.
  17. Right-click on Project's name and select Add New Item.
  18. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  19. Drag WebDragDropExtender instance from ToolBar to WebForm.
  20. Create 2 IFrame and point them to IFrame1.aspx and IFrame2.aspx.

  21. Click on WebDragDropExtender instance and press F4.
  22. Set DragSettings >> AllowCrossIFrame to SiblingAndChildIFrame.

  23. Run and compile the project. Try to drag the panel in the first IFrame to the panel in second IFrame.

See Also

Tasks
{Walkthrough: Enabling a panel server control to be dragable across child IFRAMEs}

Concepts
{Cross IFRAME Support}


Integration with Intersoft Controls

Integration with Intersoft Controls
See Also Send Feedback
Intersoft WebDesktop > WebDragDropExtender > Features > Integration with Intersoft Controls

Glossary Item Box

WebDragDropExtender is designed with high capability and extensibility as its key objective. In addition to built-in ASP.NET server control and HTML element, WebDragDropExtender is also capable to handle more sophisticated scenarios such as deep integration with other Intersoft's products.

The integration is made possible through the implementation of open-architecture API provided by WebDragDropExtender control. The open-architecture API consists of predefined interfaces and a set of base classes to enable a custom drag and drop implementation with consistent and reliable behaviors. In this release, WebDragDropExtender includes special integration with several major products of Intersoft Solutions, such as WebGrid, WebDesktopManager, WebNavPane and more.
The exclusive integration feature is divided into two major types:
  • Integration for Drag Control
  • Integration for Drop Control

See Also

Tasks
{Walkthrough: Creating Outlook® Style Drag and Drop Application}
{How-to: Enable special drag integration for WebGrid control}
{How-to: Enable special drop integration for WebDesktopManager control}
{How-to: Disable Caching for movable drop objects}

Other Resources
{Predefined Cursor Effects}
Automatic Transparent Shadow
{Vista™ Style Tooltip}
{Keyboard State}
{Auto Postback Mode}
Use Custom Object as Data
{Drag Data Validation}
{Cross IFRAME Support}


Integration for Drag Control

Integration for Drag Control
See Also Send Feedback
Intersoft WebDesktop > WebDragDropExtender > Features > Integration with Intersoft Controls > Integration for Drag Control

Glossary Item Box

Drag Control Integration means special drag features and extra behaviors can be added to the specific Intersoft's controls. For instance, when the WebGrid (version 5.0 or later) integration is enabled, the drag behavior will automatically be added to the WebGrid controls in the page. Based on the configuration, you can choose what objects/elements in WebGrid to be dragable.

In this release, the Drag Control Integration supports the following Intersoft's components:

  • WebGrid.NET Enterprise 5.0 or later
    To utilize the drag control integration on WebGrid, please click the editor button of the AdvancedProperties property. The editor looks like the following screenshot.

    The Advanced Properties Editor will automatically be loaded based on the Type of current assigned ControlID. Therefore, ensure you have assigned the ControlID to one of the supported server control before clicking on the Advanced Properties Editor.

There are several advanced features related to WebGrid Integration:

  • Sophisticated drag support for WebGrid.NET Enterprise 5.0+
    WebDragDropExtender includes a custom interface for extended programmability in order to control all drag drop behaviors in a consistent and structured manner. WebGrid implemented the CustomDragInterfaceBase client interface to provide powerful drag behaviors in WebGrid control.
  • Vista style drag visual hints
    With this feature, you can check on several checkboxes in the mail items, and then notice the drag visual hint will use a special Vista style indicator. The number of dragged items is shown automatically in the visual hint.

  • By default, selected row will be automatically dragable when integration is enabled. Before you can drag a row, you should select it first, then drag from the boundary of the selected row.
  • Use Fixed Width for Shadow Element
    By default, when you drag a selected row, the transparent shadow element will use the same width as the Grid's width. However, this behavior might not be suitable when the Grid has large width. You can set the Grid to use fixed width, eg. 200px, for the shadow element's width.

See Also

Tasks
{Walkthrough: Creating Outlook® Style Drag and Drop Application}
{How-to: Enable special drag integration for WebGrid control}
{How-to: Enable special drop integration for WebDesktopManager control}
{How-to: Disable Caching for movable drop objects}

Other Resources
{Integration for Drop Control}
{Reference Samples for Intersoft Control Integration}


Integration for Drop Control

Integration for Drop Control
See Also Send Feedback
Intersoft WebDesktop > WebDragDropExtender > Features > Integration with Intersoft Controls > Integration for Drop Control

Glossary Item Box

Drop Control Integration means special drop features and extra behaviors can be added to the specific Intersoft's controls. For instance, when the WebExplorerPane (version 2.5 or later) integration is enabled, the drop behavior will automatically be added to the WebExplorerPane controls in the page.

In this release, the Drop Control Integration supports the following Intersoft's components:

  • WebExplorerPane
    WebExplorerPane component, as part of WebDesktop.NET family can be applied as a drop control in WebDragDropExtender through special integration feature. This means you can drag an object/element and drop it to the pane item of the WebExplorerPane control.

    There are several control specific settings for WebExplorerPane:
    • Allow drop on explorer pane
      When checked, you can drop objects onto the pane element of the control.
    • Allow drop on explorer pane items
      When checked, you can drop objects onto the pane items of the control. This is the most popular feature, so that you can perform moving or copying upon successful drag-drop.
    • Allow insertion on pane items
      When checked, you can drop objects between one item and another. In common user interface operation, the objects are usually added into the list around the insertion point.
    • Styles
      You can customize several styles used during the drag-drop process such as the style when a valid object is hovered onto a pane item, or when the insertion point needs to be displayed.
  • The following screenshot shows the WebExplorerPane in action while integrated to WebDragDropExtender.

  • WebNavPane
    WebNavPane is a navigation pane server control and the replica of Outlook navigation pane. WebNavPane component is part of WebDesktop.NET family.

    Similar to WebExplorerPane, WebNavPane integration also exhibits control specific settings such as allow drop on navigation items and style customization.

    When Allow drop on navigation bar is checked, the WebNavPane control will accept objects on the visible bars. In addition, it will also accept objects on the collapsed bars located in the footer part of the WebNavPane control.
  • WebDesktopManager
    WebDesktopManager is the most essential component in WebDesktop.NET family providing a visually-compelling user interface that simulates desktop shell similar to Windows or Mac OS.

    WebDragDropExtender plays an important role to deliver rich user experiences to Web application with its robust drag-drop capability. Combined with WebDesktopManager, these two components together bring a whole new innovation and possibility in providing enhanced Web user experiences. With this objective in mind, we have specifically focused on the WebDesktopManager integration as drop control in order to deliver a phenomenal, magnificent user experiences.

    The following illustration describes the special integration features available for WebDesktopManager.

    The control specific settings for WebDesktopManager in details are:
    • Allow drop on shortcut icons
      When checked, you can start to drag objects and drop it into shortcut icon elements. To give more control over the drag-drop behavior, you can handle the OnDragOver and OnDragDrop client side event. For samples, please refer to Reference Samples for Intersoft Control Integration.
    • Automatic window activation when hover on task bar button
      This exciting feature allows you to drag some items from a WebDesktopWindow to another invisible (minimized or overlapped) WebDesktopWindow by hovering on the application's task bar for 1 second. It will then activate/restore the respective application's window so you can drop the items into the WebDesktopWindow. This behavior is common in popular desktop such as Windows or Mac OS.
    • Robust context-sensitive drag drop architecture
      WebDragDropExtender is capable to detect overlapped drop objects in pixel-perfect sensitivity. For instance, if a drop object is currently overlapped by another window, it will still allow drop onto its partially visible region.
    The following screenshot shows the WebDesktopManager in action while integrated to WebDragDropExtender.

See Also

Tasks
{Walkthrough: Creating Outlook® Style Drag and Drop Application}
{How-to: Enable special drag integration for WebGrid control}
{How-to: Enable special drop integration for WebDesktopManager control}
{How-to: Disable Caching for movable drop objects}

Other Resources
{Integration for Drag Control}
{Reference Samples for Intersoft Control Integration}


Reference Samples for Intersoft Control Integration

Reference Samples for Intersoft Control Integration
See Also Send Feedback
Intersoft WebDesktop > WebDragDropExtender > Features > Integration with Intersoft Controls > Reference Samples for Intersoft Control Integration

Glossary Item Box

Reference samples for Intersoft Control Integration:

  • Scenario 1 - Outlook Style Drag and Drop
  • Scenario 2 - Integration with WebDesktopManager
  • Scenario 3 - Shopping Cart
These samples are available in WebUI Studio.NET 2007 R2 Integrated Samples.

See Also

Tasks
{Walkthrough: Creating Outlook® Style Drag and Drop Application}
{How-to: Enable special drag integration for WebGrid control}
{How-to: Enable special drop integration for WebDesktopManager control}
{How-to: Disable Caching for movable drop objects}

Other Resources
{Integration for Drag Control}
{Integration for Drop Control}


Walkthrough: Creating Outlook® Style Drag and Drop Application

Walkthrough: Creating Outlook® Style Drag and Drop Application
See Also Send Feedback
Intersoft WebDesktop > WebDragDropExtender > Features > Integration with Intersoft Controls > Walkthrough: Creating Outlook® Style Drag and Drop Application

Glossary Item Box

This walkthrough shows you how to create Outlook style drag and drop application.

During this walkthrough, you will learn how to do the following:

  • Use WebDragDropExtender to allow the drag grid row dragged to drop WebNavPane.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Visual Studio 2005 Application.
  • Intersoft controls WebGrid and WebDesktop

Step-By-Step Instructions

To create an Outlook Style Drag and Drop Application.

  1. Launch Visual Studio.NET 2005.
  2. Open an Outlook sample. (Reference Sample: WebGridSamples/Outlook2007Page.aspx).
  3. Drag WebDragDropExtender into the WebForm.
  4. Click on WebDragDropExtender instance and press F4.
  5. On DragControls property, click the (collection) button to open WebDragControl Collection Editor. You can set which panel will be the DropControl.

    drag collection

  6. On DropControls property, click the (collection) button to open WebDropControl Collection Editor. You can set which panel will be the DropControl.

    drop collection

  7. Create 2 clientside events from your WebDragDropExtender, which are onDragDrop and onDragOver and create the functions as following:

    JavaScript Copy Image Copy Code
    function DragOver(controlId, e, dropObject)
{
    if (dropObject.IsSubObject)
    {
        /* get the context of the sub object being hovered */
        var dropItem = dropObject.SubObjectContext;

        /* if the hovered item's type is WebNavBar */
        if (dropItem.ItemType == "WebNavBar")
        {
            /* get the real WebNavBar object being hovered */
            var bar = dropItem.ItemObject;

            /* set effect text based on hovered item to give feedback to user */
            switch (bar.Text)
            {
                case "Mail":
                     e.EffectText = "";
                    break;

                case "Calendar":
                    e.EffectText = "Add mail items to calendar.";
                      break;

                case "Contacts":
                    e.EffectText = "Add sender to contact.";
                    break;

                case "Tasks":
                    e.EffectText = "Create new task for the selected mail items.";
                    break;

                case "Notes":
                    e.EffectText = "Add mail items to notes.";
                    break;

                case "Journals":
                    e.EffectText = "Add mail items to journal.";
                    break;
            }
        }
        else if (dropItem.ItemType == "WebNavBarItem")
        {
            var navPane = ISGetObject("WebNavPane1");
            var activeBar = navPane.GetActiveBar();
            var dropItem = dropItem.ItemObject;

            if (activeBar.Text == "Mail")
            {
                var activeItem = activeBar.GetActiveBarItem();

                if (activeItem.Text == dropItem.Text)
                {
                    e.Effect = ISDragDropEffects.NotAllowed;
                    e.EffectText = "Cannot move mail items to the same folder.";
                }
                else
                {
                    e.Effect = ISDragDropEffects.Move;
                    e.EffectText = "Move mail items to " + dropItem.Text + "";
                }
            }
        }
    }
    else
    {
        e.EffectText = "";
    }
}

function DragDrop(controlId, e, dropObject)
{
    if (dropObject.IsSubObject)
    {
        /* get the context of the sub object being hovered */
        var dropItem = dropObject.SubObjectContext;

        /* if the hovered item's type is WebNavBar */
        if (dropItem.ItemType == "WebNavBar")
        {
            alert("Perform action such as show the create new '" + dropItem.ItemObject.Text + "' dialog box.");
        }
        else
        {
            if (e.Effect == ISDragDropEffects.Move)
            {
                var np = ISGetObject("WebNavPane1");
                var activeBar = np.GetActiveBar();
                var activeItem = activeBar.GetActiveBarItem();

                /* We need to serialize DragData to xml first because object can't be send as event argument.
                   This process optimizes the data sent to the server during AJAX callback for best performance.
                */
                var s = "<dragdata>";
                s += "<currentview>" + activeItem.Text + "</currentview>";
                s += "<targetview>" + dropItem.ItemObject.Text + "</targetview>";
                s += "<maildata>";

                /* loop through the dragged mail items from WebGrid
                   notice that e.DragObject.Data is WebGridDragData object.
                */
                var draggedRows = e.DragObject.Data.Rows;
                for (var i=0; i<draggedrows.length/>";
                }

                s += "</maildata>";
                s += "</dragdata>";
                e.data = s;

                /* proceed with move mail items - see OnDragDrop event in server side */
                return true;
            }
        }
    }
    return false;
}

  8. In WebGrid, add 2 events which are onBeforeResponseProcess and onAfterResponseProcess.

    JavaScript Copy Image Copy Code
    function ReinitializeDragControls()
{
    setTimeout(function()
    {
        /* this function needs to be called when the Grid is refreshed due to AJAX callback */
        var extender = ISGetObject("WebDragDropExtender1");
        extender.ReinitializeDragControls();
    }, 100);
}

function BeforeRefresh(controlId) // taken from onBeforeResponseProcess
{
    /* unload drag controls to free memory before the Grid is refreshed */
    var extender = ISGetObject("WebDragDropExtender1");
    extender.UnloadDragControls();
}

function AfterRefresh(controlId) // taken from onAfterResponseProcess
{
    ReinitializeDragControls();
}

  9. Enable the AutoPostBackDragDrop property and set PostBackMode to FlyPostBack from the WebDragDropExtender properties.

    drop settings

  10. Run and compile the project.

See Also

Tasks
{How-to: Enable special drag integration for WebGrid control}
{How-to: Enable special drop integration for WebDesktopManager control}
{How-to: Disable Caching for movable drop objects}

Concepts
{Integration with Intersoft Controls}


How-to: Enable special drag integration for WebGrid control

How-to: Enable special drag integration for WebGrid control
See Also Send Feedback
Intersoft WebDesktop > WebDragDropExtender > Features > Integration with Intersoft Controls > How-to: Enable special drag integration for WebGrid control

Glossary Item Box

You can enable special drag integration for WebGrid control such as Allow dragging on checked rows, drop shadow element's width.

This topic will show you how to enable special drag integration for WebGrid control.

To enable special drag integration for WebGrid control

  1. Click on WebDragDropExtender instance and press F4 to open its properties window.
  2. Go to the DropControls collection and add WebDragControl into it.
  3. Go to AdvancedProperties and choose the click collection button.
  4. Give check to the "Enable special integration with Intersoft control." Ensure that you see the control type is WebGrid.
  5. Compile and run the project.

See Also

Tasks
{Walkthrough: Creating Outlook® Style Drag and Drop Application}
{How-to: Enable special drop integration for WebDesktopManager control}
{How-to: Disable Caching for movable drop objects}

Concepts
{Integration with Intersoft Controls}


How-to: Enable special drop integration for WebDesktopManager control

How-to: Enable special drop integration for WebDesktopManager control
See Also Send Feedback
Intersoft WebDesktop > WebDragDropExtender > Features > Integration with Intersoft Controls > How-to: Enable special drop integration for WebDesktopManager control

Glossary Item Box

You can enable special drop integration for WebDesktopManager control such as enable/disable the show drop on shortcut icons, detect overlapped drop objects inside WebDesktopWindow and Automatically active target window when hover on taskbar button.

This topic will show you how to enable special drop integration for WebDesktopManager control.

To enable special drop integration for WebDesktopManager control

  1. Click on WebDragDropExtender instance and press F4 to open its properties window.
  2. Go to the DropControls collection and add WebDropControl into it.
  3. Go to AdvancedProperties and choose the click collection button.
  4. Give check to the "Enable special integration with Intersoft Controls." Ensure that you see the control type is WebDesktopWindow.
  5. Compile and run the project.

See Also

Tasks
{Walkthrough: Creating Outlook® Style Drag and Drop Application}
{How-to: Enable special drag integration for WebGrid control}
{How-to: Disable Caching for movable drop objects}

Concepts
{Integration with Intersoft Controls}


How-to: Disable Caching for movable drop objects

How-to: Disable Caching for movable drop objects
See Also Send Feedback
Intersoft WebDesktop > WebDragDropExtender > Features > Integration with Intersoft Controls > How-to: Disable Caching for movable drop objects

Glossary Item Box

You can disable caching for movable drop objects in WebDragDropExtender.

This topic will show you how to disable caching for movable drop objects.

To disable caching for movable drop objects

  1. Click on WebDragDropExtender instance and press F4 to open its Properties window.
  2. Go to the DropControls collection and add WebDropControl into it.
  3. Set EnableCaching to false.
  4. Compile and run the project.

See Also

Tasks
{Walkthrough: Creating Outlook® Style Drag and Drop Application}
{How-to: Enable special drag integration for WebGrid control}
{How-to: Enable special drop integration for WebDesktopManager control}

Concepts
{Integration with Intersoft Controls}


How-to: Use Image Previewer

How-to: Use Image Previewer
Send Feedback
Intersoft WebDesktop > WebDragDropExtender > Features > How-to: Use Image Previewer

Glossary Item Box

WebDragDropExtender enables you to easily add drag behavior to multiple controls using an elegant object model.

This topic will show you how to use Image Previewer.

To use Image Previewer

  1. Drag ASP.NET Image and Panel controls to the WebForm. Named the ID as Image1 and Panel1 respectively.
  2. In Image Properties, set ImageUrl to any thumbnail image you want to display. For example: ../Images/WDMBlockingInteractionT.png.
  3. Right-click on WebDragDropExpander control and choose Properties.
  4. Go to DragControls and click the collection button.
  5. Add a drag control. Set ControlID to Image1 and DragData to any standard image you want to display. For example: WDMBlockingInteractionF. In this case, we are using same image but different size in order to show image previewer.
  6. Go to DropControls and click the collection button.
  7. Set ControlID to Panel1.
  8. Add html image control inside Panel1 like following:

    <asp:Panel ID="panelDrop" runat="server" Width="525px" Height="398px" BackColor="Beige">
    <img id="imagePreview" style="display: none" />
    </asp:Panel>
  9. Create DragDrop() in OnDragDrop client-side events to preview image.
    JavaScript Copy Code
    function DragDrop(controlId, dragEventArgs, dropObject)
{
   var img = document.getElementById("imagePreview");

   img.src = "../images/" + dragEventArgs.Data + ".png";
   img.style.display = "";
}

  10. Run the project. Simply drag image from the left panel into the right panel, and you will preview the image in larger size.


Client Side References

Client Side References
Send Feedback
Intersoft WebDesktop > WebDragDropExtender > Client Side References

Glossary Item Box

This section lists all client side references available in WebDragDropExtender.NET 1.0.

In This Section

Enumeration
Information about enumeration of ISDragDropEffects and ISKeyState.

Class
Information about classes available in WebDragDropExtender.


Enumerations

Enumerations
See Also Send Feedback
Intersoft WebDesktop > WebDragDropExtender > Client Side References > Enumerations

Glossary Item Box

ISDragDropEffects:

  • None = 0
  • All = 1
  • Copy = 4
  • Link = 16
  • Move = 64
  • NotAllowed = 256
  • Scroll = 1024
  • Remove = 4096

ISKeyState:

  • Ctrl = 8
  • Alt = 32
  • Shift = 32

See Also

Other Resources
{Class}


Class

Class
See Also Send Feedback
Intersoft WebDesktop > WebDragDropExtender > Client Side References > Class

Glossary Item Box

Following is the classes available in WebDragDropExtender:

  • WebDragControl
  • WebDropControl
  • WebDragDropExtender
  • ISDragableObject
  • ISDropableObject
  • ISdragEventArgs

See Also

Tasks
{Walkthrough: Using IsSubObject and SubObjectContext to retrieve the target drop object of WebNavPane control}

Other Resources
{Enumerations}


WebDragControl

WebDragControl
See Also Send Feedback
Intersoft WebDesktop > WebDragDropExtender > Client Side References > Class > WebDragControl

Glossary Item Box

Properties:

  • [Follow server-side properties]
  • CustomInterface
    Gets the custom interface assigned to this drag control.

Methods:

  • GetElement
    Gets the HTML element associated to this drag control.

See Also

References
{WebDragControl Properties}
{WebDragControl Methods}


WebDropControl

WebDropControl
See Also Send Feedback
Intersoft WebDesktop > WebDragDropExtender > Client Side References > Class > WebDropControl

Glossary Item Box

Properties:

  • [Follow server-side properties]

Methods:

  • GetElement
    Gets the HTML element associated to this drop control.

See Also

References
{WebDropControl Properties}
{WebDropControl Methods}


WebDragDropExtender

WebDragDropExtender
See Also Send Feedback
Intersoft WebDesktop > WebDragDropExtender > Client Side References > Class > WebDragDropExtender

Glossary Item Box

Properties:

  • DragControls
    The collection of WebDragControl in ISArray format.

  • DropControls
    The collection of WebDropControl in ISArray format.

  • DragSettings
    Contains global settings related to drag behavior.

  • DropSettings
    Contains global settings related to drop behavior.

  • ClientSideEvents
    Contains drag and drop client side events.

Methods:

  • ReinitializeDragControls()
    Perform re-initialization of drag controls in the WebDragDropExtender control. You will need to call this method whenever the drag control is refreshed/updated using AJAX callback. For instance, this method needs to be called in OnResponse client side event of WebGrid so the drag behaviors are initialized back to the WebGrid after its refresh (partial updates). For example of this usage, see the Scenario 1 - Outlook Style Drag and Drop sample.
  • ReinitializeDropControls()
    Perform re-initialization of drop controls in the WebDragDropExtender control. You will need to call this method when the drop control is refreshed/updated using AJAX callback. For instance, if the WebExplorerPane items are removed or added using AJAX, the changes won't take effect until this method is called.
  • ClearDropControlCache()
    Clear the cache of the drop controls. The drop controls are cached in many ways internally by WebDragDropExtender to provide a high performance drag-drop solution. However, when the drop control's properties are modified, for instances, its location or sizes, you need to call this method to invalidate the cache.

See Also

References
{WebDragDropExtender Properties}
{WebDragDropExtender Methods}


ISDragableObject

ISDragableObject
See Also Send Feedback
Intersoft WebDesktop > WebDragDropExtender > Client Side References > Class > ISDragableObject

Glossary Item Box

Represents the native class that contains core drag information. The instance of this class is passed to OnDragStart, OnDragEnd and OnShadowCreate client side event.

Properties:

  • IsDragged
    Determines whether the current drag element is being dragged.

  • Enabled
    Specifies whether the drag element is enabled.

  • Owner
    Gets the associated WebDragControl instance for the drag element.

  • ShadowElement
    Gets the HTML element of the drag element's shadow which is displayed during dragging.

See Also

References
{ISDragableObject Properties}


ISDropableObject

ISDropableObject
See Also Send Feedback
Intersoft WebDesktop > WebDragDropExtender > Client Side References > Class > ISDropableObject

Glossary Item Box

Represents the native class that contains core drop information. The instance of this class is passed to OnDragEnter, OnDragOver and OnDragLeave client side event.

Properties:

  • Enabled
    Specifies whether the drop element is enabled.

  • IsSubObject
    Determines whether the current drop object is a sub object. Sub object concept is usually used in Intersoft Control Integration or other complex objects where the control has more than one drop elements.

  • SubObjectContext
    Gets the CustomSubDropInterfaceBase instance associated to the current drop context. SubObjectContext is used only in complex control integration such as Intersoft Control Integration. SubObjectContext contains information about the sub-object in the context of drag-drop operation, such as during DragOver or DragDrop.

  • Owner
    Gets the associated WebDropControl instance for the drop element.

The IsSubObject and SubObjectContext property are advanced programming subjects in WebDragDropExtender. To get a brief picture on how it works, please refer to the walkthrough or reference samples.

See Also

References
{ISDropableObject Properties}


ISDragEventArgs

ISDragEventArgs
See Also Send Feedback
Intersoft WebDesktop > WebDragDropExtender > Client Side References > Class > ISDragEventArgs

Glossary Item Box

This class represents the drag event argument used in many drag-drop events such as in OnDragEnter, OnDragOver and OnDragDrop.

Properties:

  • To see the properties available in ISDragEventArgs, please refer to Concepts: Drag Event Arguments.

Methods:

  • GetDataPresent(type, className)
    Determines whether the Data associated in the drag control is matching with the specified type and class name.

    For sample, see Walkthrough: Using GetDataPresent method to query object type in OnDragOver event.

See Also

References
{ISDragEventArgs Properties}
{ISDragEventArgs Methods}


Walkthrough: Using IsSubObject and SubObjectContext to retrieve the target drop object of WebNavPane control

Walkthrough: Using IsSubObject and SubObjectContext to retrieve the target drop object of WebNavPane control
See Also Send Feedback
Intersoft WebDesktop > WebDragDropExtender > Client Side References > Class > Walkthrough: Using IsSubObject and SubObjectContext to retrieve the target drop object of WebNavPane control

Glossary Item Box

This walkthrough shows you how to use IsSubObject and SubObjectContext to retrieve the target drop object of WebNavPane control.

During this walkthrough, you will learn how to do the following:

  • Use WebDragDropExtender to allow the drag panel dragged to drop panel.
  • Use IsSubObject and SubObjectContext.
  • Integrate WebDragDropExtender and Intersoft controls.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Visual Studio 2005 Application.

Step-By-Step Instructions

To enable a panel server control to be dragable across child IFRAMEs.

  1. Launch Visual Studio.NET 2005.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. Drag WebPaneManager instance from ToolBar to WebForm and set the pane to 3 parts.
  8. Drag WebNavPane instance to the first pane. Don't forget to set the WebNavPane's bar and items.
  9. Drag WebGrid instance to the second pane.
  10. Drag WebFlyPostBackManager instance to the page.
  11. Drag WebDragDropExtender instance from ToolBar to WebForm.

  12. Set the grid's datasource from code behind.

    C# Copy Code
    protected void WebGrid1_InitializeDataSource(object sender, ISNet.WebUI.WebGrid.DataSourceEventArgs e)
{
    XmlDataDocument xml = new XmlDataDocument();
    WebNavPane navPane = WebPaneManager1.FindControl("WebNavPane1") as WebNavPane;

    if (!IsPostBack)
        xml.DataSet.ReadXml(Server.MapPath("Inbox_Data.xml"), XmlReadMode.Auto);
    else
        xml.DataSet.ReadXml(Server.MapPath(navPane.ActiveBar.ActiveBarItem.Text + "_Data.xml"), XmlReadMode.Auto);

    if (xml.DataSet.Tables.Count > 0)
    {
        e.DataSource = xml.DataSet.Tables[0].Copy();
    }
    else
    {
        xml.DataSet.ReadXmlSchema(Server.MapPath("Schema.xml"));
        e.DataSource = xml.DataSet.Tables[0].Clone();
    }
}

  13. You also need to set the InitializeRow and RowChanged event handler and use the following code:

    C# Copy Code
    protected void WebGrid1_RowChanged(object sender, RowChangedEventArgs e)
{
    if (e.Row.Type == RowType.Record)
    {
        // get the content's object
        Label subjectLabel = WebPaneManager1.FindControl("subjectLabel") as Label;
        Label toLabel = WebPaneManager1.FindControl("toLabel") as Label;
        Label fromLabel = WebPaneManager1.FindControl("fromLabel") as Label;
        Label contentLabel = WebPaneManager1.FindControl("contentLabel") as Label;

        // set the content's data
        subjectLabel.Text = e.Row.Cells.GetNamedItem("Subject").Text;
        toLabel.Text = "To : " + e.Row.Cells.GetNamedItem("To").Text;
        fromLabel.Text = "From : " + e.Row.Cells.GetNamedItem("From").Text;
        contentLabel.Text = e.Row.Cells.GetNamedItem("Contents").Text;
    }
}

protected void WebGrid1_InitializeRow(object sender, RowEventArgs e)
{
    if (e.Row.Type == RowType.Record)
    {
        WebGridCell hasAttachment = e.Row.Cells.GetNamedItem("HasAttachment");

        if (hasAttachment.Value.ToString() == "True")
            hasAttachment.Text = "../images/Attachment.gif";
        else
            hasAttachment.Text = "../images/wg_blank.gif";
    }
}

  14. Click on WebDragDropExtender instance and press F4.
  15. On DragControls property, click the (collection) button to open WebDragControl Collection Editor. You can set which panel will be the DragControl.

  16. On DropControls property, click the (collection) button to open WebDropControl Collection Editor. You can set which panel will be the DropControl.
  17. In ClientSideEvents, set OnDragOver to DragOver.
  18. In ClientSideEvents, set OnDragDrop to DragDrop.

  19. Here is the complete javascript code for all the client side events:

    JavaScript Copy Code
    function DragOver(controlId, e, dropObject)
{
    if (dropObject.IsSubObject)
    {
        /* get the context of the sub object being hovered */
        var dropItem = dropObject.SubObjectContext;

        /* if the hovered item's type is WebNavBar */
        if (dropItem.ItemType == "WebNavBar")
        {
            /* get the real WebNavBar object being hovered */
            var bar = dropItem.ItemObject;

            /* set effect text based on hovered item to give feedback to user */
            switch (bar.Text)
            {
                case "Mail":
                    e.EffectText = "";
                    break;

                case "Calendar":
                    e.EffectText = "Add mail items to calendar.";
                    break;

                case "Contacts":
                    e.EffectText = "Add sender to contact.";
                    break;

                case "Tasks":
                    e.EffectText = "Create new task for the selected mail items.";
                    break;

                case "Notes":
                    e.EffectText = "Add mail items to notes.";
                    break;

                case "Journals":
                    e.EffectText = "Add mail items to journal.";
                    break;
            }
        }
        else if (dropItem.ItemType == "WebNavBarItem")
        {
            var navPane = ISGetObject("WebNavPane1");
            var activeBar = navPane.GetActiveBar();
            var dropItem = dropItem.ItemObject;

            if (activeBar.Text == "Mail")
            {
                var activeItem = activeBar.GetActiveBarItem();

                if (activeItem.Text == dropItem.Text)
                {
                    e.Effect = ISDragDropEffects.NotAllowed;
                    e.EffectText = "Cannot move mail items to the same folder.";
                }
                else
                {
                    e.Effect = ISDragDropEffects.Move;
                    e.EffectText = "Move mail items to " + dropItem.Text + "";
                }
            }
        }
    }
    else
    {
        e.EffectText = "";
    }
}

function DragDrop(controlId, e, dropObject)
{
    if (dropObject.IsSubObject)
    {
        /* get the context of the sub object being hovered */
        var dropItem = dropObject.SubObjectContext;

        /* if the hovered item's type is WebNavBar */
        if (dropItem.ItemType == "WebNavBar")
        {
            alert("Perform action such as show the create new '" + dropItem.ItemObject.Text + "' dialog box.");
        }
        else
        {
            if (e.Effect == ISDragDropEffects.Move)
            {
                var np = ISGetObject("WebNavPane1");
                var activeBar = np.GetActiveBar();
                var activeItem = activeBar.GetActiveBarItem();

                /* We need to serialize DragData to xml first because object can't be send as event argument.
                   This process optimizes the data sent to the server during AJAX callback for best performance.
                */
                var s = "<dragdata>";
                s += "<currentview>" + activeItem.Text + "</currentview>";
                s += "<targetview>" + dropItem.ItemObject.Text + "</targetview>";
                s += "<maildata>";

                /* loop through the dragged mail items from WebGrid
                   notice that e.DragObject.Data is WebGridDragData object.
                */
                var draggedRows = e.DragObject.Data.Rows;
                for (var i=0; i<draggedrows.length/>";
                }

                s += "</maildata>";
                s += "</dragdata>";
                e.data = s;

                /* proceed with move mail items - see OnDragDrop event in server side */
                return true;
            }
        }
    }

    return false;
}

function ReinitializeDragControls()
{
    setTimeout(function()
    {
        /* this function needs to be called when the Grid is refreshed due to AJAX callback */
        var extender = ISGetObject("WebDragDropExtender1");
        extender.ReinitializeDragControls();
    }, 100);
}

function RefreshMailItems()
{
    var grid = ISGetObject("WebGrid1");
    grid.Refresh();
}

/* grid event */
function BeforeRefresh(controlId)
{
    /* unload drag controls to free memory before the Grid is refreshed */
    var extender = ISGetObject("WebDragDropExtender1");
    extender.UnloadDragControls();
}

/* grid event */
function AfterRefresh(controlId)
{
    ReinitializeDragControls();
}

  20. On the server side, you also need to set WebDragDropExtender1_DragDrop and WebNavPane1_ActiveBarItemChanged. Here is the code:

    C# Copy Code
    protected void WebDragDropExtender1_DragDrop(object sender, ISNet.WebUI.WebDesktop.WebDragDropEventArgs e)
{
    XmlDocument xml = new XmlDocument();
    xml.LoadXml(e.Data.ToString());

    XmlDocument xmlSource = new XmlDocument();
    string sourceXmlPath = Server.MapPath(xml.SelectSingleNode("//CurrentView").InnerText + "_Data.xml");
    xmlSource.Load(sourceXmlPath);

    XmlDocument xmlTarget = new XmlDocument();
    string targetXmlPath = Server.MapPath(xml.SelectSingleNode("//TargetView").InnerText + "_Data.xml");
    xmlTarget.Load(targetXmlPath);

    XmlNodeList mailItems = xml.SelectNodes("//MailData/Item");
    foreach (XmlNode item in mailItems)
    {
        string messageID = item.Attributes.GetNamedItem("MessageID").Value;
        XmlNode srcNode = xmlSource.SelectSingleNode("//MailMessages[MessageID='" + messageID + "']");

        srcNode.ParentNode.RemoveChild(srcNode);
        XmlNode newNode = xmlTarget.CreateNode(XmlNodeType.Element, "MailMessages", null);
        newNode.InnerXml = srcNode.InnerXml;
        xmlTarget.DocumentElement.AppendChild(newNode);
    }

    xmlSource.Save(sourceXmlPath);
    xmlTarget.Save(targetXmlPath);

    WebDragDropExtender1.ClientAction.Alert("Successfully moved " + mailItems.Count.ToString()
        + " item(s) to " + xml.SelectSingleNode("//TargetView").InnerText + ".");

    WebDragDropExtender1.ClientAction.InvokeScript("RefreshMailItems();");
}

protected void WebNavPane1_ActiveBarItemChanged(object sender, ActiveBarItemChangedEventArgs e)
{
    XmlDataDocument xml = new XmlDataDocument();
    xml.DataSet.ReadXml(Server.MapPath(e.ActiveBarItem.Text + "_Data.xml"), XmlReadMode.Auto);

    WebGrid grid = WebPaneManager1.FindControl("WebGrid1") as WebGrid;
    DataTable dt = null;

    if (xml.DataSet.Tables.Count > 0)
        dt = xml.DataSet.Tables[0].Copy();
    else
    {
        xml.DataSet.ReadXmlSchema(Server.MapPath("Schema.xml"));
        dt = xml.DataSet.Tables[0].Clone();
    }

    fpb.ClientAction.InvokeScript("BeforeRefresh();");

    grid.SetSelectedObject(null);
    grid.DataSource = dt;
    grid.RequiresUIRefresh = true;
    grid.RebindDataSource();

    fpb.ClientAction.InvokeScript("AfterRefresh();");
}

  21. Run and compile the project.

See Also

Tasks
{Walkthrough topics}
{FAQ and How-to topics}

Concepts
{ISDropableObject}


WebDesktopManager

WebDesktopManager
See Also Send Feedback
Intersoft WebDesktop > WebDesktopManager

Glossary Item Box

WebDesktopManager
Member of WebDesktop.NET

DesktopManager lets you quickly create professional, advanced web applications using desktop-like user interface concepts, including built-in Windowing navigation system, shorcuts, context menus and new High Clarity Desktop technology.

What's New in WebDesktopManager

Learn the Features

Working with ClickAndEdit

Understanding Concepts

Understanding ContentMode

Working with ClientSide Events

Quick Start

Creating Simple Desktop

Using IFrame as Default ContentMode

Enabling Shortcut Icons

Create elegant Windows desktop-like web applications

Use WebDesktopManager as your primary Application Navigation component to easily manage Shortcuts and Windows. WebDesktopManager lets you easily create features-rich and high performance Windows desktop-style web applications. Its High Clarity Desktop technology implements 98% behaviors of a desktop user interface and concepts, such as window movement, resizing, minimizing, maximizing, context menus and many more.

Deliver uncluttered workspace's web applications

The innovative DesktopManager introduced a new level of user experience by implementing advanced Windowing navigation system. It enables you to quickly build web applications that deliver better user interface with uncluttered workspace's approach to browsers which at the end significantly increase user's productivity.

Improve efficiency and usability dramatically

You can improve efficiency and usability of your enterprise web application by replacing traditional's "single tasking" approach application with DesktopManager's "multi tasking" approach.

Single tasking basically means that you can perform only one task at a time. For instance, a traditional web application typically provides one main page view which requires you to complete the task before you can access other page or module. In most events, you would need to repetitively go back and forth in order to find a piece of information.

Multiple tasking concepts in DesktopManager completely changed the way of working in browser-based application by offering the Windowing navigation system which allows you to launch multiple windows hosting different modules/pages. Further you can easily switch between windows, arrange them vertically or horizontally to look at different information at the same time.

With multitasking-enabled, you can build new kind of applications with desktop-style user experience which is not possible to be done with traditional's single-tasking approach. For instance, you can now launch a New Message window while the users are at Inbox screen and thus it didn't interrupt the currently working spaces.

The following shows the illustration of comparison between single and multiple tasking applications.

See Also

Getting Started
{Features}
WebDesktop Concepts


What's New in WebDesktopManager

What's New in WebDesktopManager
See Also Send Feedback
Intersoft WebDesktop > WebDesktopManager > What's New in WebDesktopManager

Glossary Item Box

WebDesktopManager employs an object-based approach to give you granular control over every visual aspect of its elements. Offering a rich set of properties to control shortcut, icons, taskbar, and window elements, it enables you to create the precise appearance your desktop requires with a minimum of effort.

In version 4, WebDesktopmanager has been fully support for latest web standards and style sheet language which are HTML5 and CSS3. WebDesktopManager also allows you to use many cutting-edge technologies such as HTML5, CSS3 and powerful features offered for your next-generation web applications.

These are the following details of enhancements and new features that have been implemented in WebDesktopManager:

  • Fluid content

    To enable height percentage of WebDesktopManager, you only have to set Height property in TaskBarStyle and WindowHeaderHeight in WindowSettings. During implementation, height of Desktop will depend on WebDesktopManager’s Height property and TaskBarStyle’s Height property and the rest will be calculated automatically by our control. Also the content of WebDesktopWindow will be fluid as it should be regarding to WindowHeaderHeight and its Height. This configuration is necessary because of element changed from table to div.

  • Smooth moving and resizing

    Adoption of HTML5 causes changes in performance on WebDesktopManager. HTML5 enables consistent results and pixel-perfect rendering in all modern browsers that makes smooth moving and resizing in all browsers that support HTML5.

  • Stand-alone TaskBar’s image

    In WebDesktop 4, you can specify image inside Taskbar by using TaskBarImage in WebDesktopWindow or WebDesktopShortcut.

  • Container style when using complex images border

    When using complex images border type, you can apply container style inside WebDesktopWindow by changing the value of ApplyContainerStyle to true value. In usage the container will have the specific class that shows the container in different way from its frame.

  • New intuitive style in WebDesktop 4

    In version 4, WebDesktop present a new style in each of its control. Metro style as the latest UI in Windows 8 had been implemented and became brand new UI in our WebDesktop control. Metro style makes WebDesktop simpler, tidier, and more attractive for each control's UI. The intuitive design of Metro style also provides consistency of each control in HTML5.

    You can simply use Layout Manager to implement Metro style in WebDesktop.

    For more information on how to apply this configuration, see How-To: Using Layout Manager.

    Note that Internet Explorer 10 or later no longer supports the legacy DX filters when the document type is HTML5. Therefore, some features such as loader transition will no longer work in such conditions. You can, however, force to enable legacy filters in Internet Explorer 10 by enabling the Render Legacy Filters option in Internet Options' Security tab.

See Also

WebDesktopManager

Features
Features


Features

Features
See Also Send Feedback
Intersoft WebDesktop > WebDesktopManager > Features

Glossary Item Box

WebDesktopManager is a member of the WebDesktop.NET which plays one of the most significant role in the suite. We have designed the DesktopManager component to be extremely easy to use and easy to configure, yet is very powerful and rich in functions and features. DesktopManager is the first of its kind to offer the Windows-like navigation system which has been carefully modeled into component for high reusability. It offers built-in "Shell" features such as shortcut icons, taskbars, window buttons, complete window management features, professional animation to enrich the Windowing system, highly customizable styles and appearance for most elements, strongly-typed client side object model and as always, complete keyboard navigation system.

DesktopManager is designed to be highly customizable as we have prepared a lot of scenarios which might be used in enterprise-class rapid application development. Following is only some of the key features out of 40+ features in total.
  • Cinematic visual experiences.
    WebDesktopManager now comes with 8 visual effects that you can easily apply to your project. The visual effect allows the desktop manager to look more appealing and smoother especially when it is combined with Preloader feature. You can apply the visual effect in two levels:
    • DesktopManager level.
    • Window level.
  • Built-in preloader for scripts and images.
    This feature allows you to quickly add "preloading" effect to the WebDesktopManager instance. As web application becomes richer, the amount of scripts and images are growing too. This can cause significant delays to the loading time especially to narrow-band connection. This feature helps to solve the issue with an interactive loading progress bar so that your users are aware with the current loading progress and the estimated finish time of the loading.

    Instead of using the built-in preloader, you can also create your own custom preloader layout by utilizing the LoaderTemplate.
  • Blocking user interactions in busy mode.
    WebDesktopManager now comes with built-in capability to set a WebDesktopWindow to busy mode programmatically. When you set to busy mode through API, the specified Window will be non responsive to users. I.e., non clickable and cursor will change to HourGlass. This is useful especially when you need to perform lengthy operation and do not want users to change anything inside the Window while the action is in progress.
  • Windowing navigation system.
    Free your users for having to switch a webpage forth-and-back and totally improve the user experience by using the new innovative Windowing navigation system which works in both Internet Explorer or any favorite browsers of Gecko/Mozilla. Implementing the UI Standard already familiar in today's modern OS such as Windows XP or Mac OS, DesktopManager automatically shows any active windows in a centralized place called TaskBar, unless the specific Window has ShowInTaskBar set to False. The window can be easily arranged with one of 3 predefined WindowArrangement, such as Cascaded, TiledHorizontally or TiledVertically.
  • ClickAndEdit™
    With this innovative technology, you no longer need to work in separate window to edit the content of the Window. ClickAndEdit greatly enhances developer's productivity by simplifying editing mechanism which takes advantages of Visual Studio 2005. With it, developers can simply click on an inactive Window object directly in the IDE, the clicked Window will then become Active Window and you can start typing inside the editing region of the Active Window. You also do not need to worry when and how to end the editing, as the content will be automatically saved when the Control lost focus or when you click on somewhere outside the editing region.
  • Shortcut system.
    The built-in shortcut system can be used to represent a module or application that runs on the top of DesktopManager. This is a powerful feature developers would not miss! You can specify what action should be taken when the shortcut is opened (that is when double clicked or Enter is pressed when the shortcut has focus). Built-in actions are to open a new Window with its ContentURL, or activate an existing Window which is currently hidden or minimized. Furthermore, you can implement your own codes to fit your application needs by utilizing the extensive client side events.
  • Shortcut settings.
    DesktopManager offers numerous advanced settings for the Shorcut system. There are configurable AutoArrangement feature which automatically arrange the icons from top to bottom, and move to 2nd column and so on when there are more icons. The AutoArrangement feature will rearrange the icons to keep them visible and in order everytime the Desktop is resized. The other noteworthy feature is Movable. When Enabled, user may move the shortcut to any location they preferred, just like the way they did it in Windows. The shortcut system also enables specified shortcuts to be located individually by specifying its own Location property.
  • Desktop management.
    Desktop is one of the element that cannot be separated from the DesktopManager entirely. With the provided complete desktop management functions, such as the ability to save latest structure from client side or at server side, the ability to focus on the desktop and right click on it to display available actions, and much more. The desktop is the primary used object for the integration with the rest of 10+ Intersoft's components, such as tight integration with WebNotification for displaying Notification at desktop level, tight integration with DialogBox to create a modal window on the top of Desktop architecture, tight integration with ContextMenu, Button, ToolBar, and others to take advantage of the built-in Window and Desktop features. Another important feature is its capability to manage minimized Windows in special Minimized Form when TaskBar is not Visible.
  • Window management.
    Window is the atomic element of the Desktop, where a Desktop could contain multiple Windows. DesktopManager carefully implemented the Window to be easily manageable through built-in User Interface (through TaskBar Buttons) or via object-based codes. Any windows can be quickly accessible by clicking the WindowButton in the TaskBar area. The WindowButton will be synchronized at real time when a new Window is created, closed, minimized, hidden or become activated. The WindowButton area has also been designed to comfort with UI Standard, such as, it will be able to adjust and shrink perfectly when more windows are opened. The text caption will then be automatically clipped as ellipsis. In this context, when user mouse over on the clipped text, the tooltip will appear to show the complete text.
  • Window features.
    DesktopManager offers complete windowing features similar to those we can find in today's popular Desktop. A Window can use its Default configuration or individually configured to allow Minimize, Maximize/Restore and Close as well as Resizing. Windows will be automatically managed by the Desktop to be shown at its initial Location and Size according to the specified WindowArrangement. You can also specify individual Location and Size at Window level in order to be shown at specified coordinate and sized instead of using managed arrangement. Another essential feature is the configurable WindowState where one can easily specify the state of Window when initially loaded.
  • TaskBar and TaskBarButton.
    DesktopManager is equipped with built-in TaskBar element which you can easily enable by setting TaskBarVisible property. The TaskBar is used as the placeholder where open Windows are shown. Moreover, the TaskBar has been designed with highly customizability in mind where it can be also be used to hold other objects in the left and right side of the WindowGroupButton area. With the TaskBarLeftTemplate and TaskBarRightTemplate which used new Visual Studio 2005's Templating feature, you can put virtually any kind of server controls to create even richer style of web apps, such as you can put a "Start Menu" like button, or integrate Intersoft's WebToolBar for Quick Launch function, or create Tray notification icons in the right side of the TaskBar.
  • TaskBar settings.
    With the already powerful features offered by the DesktopManager, the TaskBar can also be configured to use more advanced settings. Some north worthy settings are Position, to configure where the TaskBar should be positioned in the Desktop; ShowWindows lets you configure whether the open Windows should be listed and accessible, WindowButtonSpacing and WindowButtonWidth to configure the spacing and width of the WindowButton.
  • High performance Animation, Moving and Resizing architecture.
    DesktopManager comes with a high performance architecture for Animation, Moving and Resizing functions. The architecture ensures your users to have complete peace of mind when interacting with the Desktop, Windows, Shortcuts and other DesktopManager elements. Animation can be easily configured by specifying the EnableAnimation property which is set to True by default. Every window is movable by default and users can easily move any visible window by dragging the CaptionBar just the same way as in today's popular desktop.
  • Strong keyboard support.
    Strong keyboard support is one of Intersoft's renowned features which implemented extensively across all product lines. It is a key to the successful of web applications especially when connected to desktop like Rich Internet Applications. The keyboard support in DesktopManager has been extensively implemented to work under Internet Explorer and Gecko-based browsers. The supported keyboard actions includes fast windows switching in ascending or descending order, closing window, arrow key navigation for shortcuts when focus is on the desktop, as well as Task Manager like switching (similar to pressing Alt+Tab or Alt+Shift+Tab in Windows desktop). The extensive keyboard support means that the DesktopManager automatically complies to U.S. Section 508 Accessibility standard.
  • Clientside construct-able objects.
    The new breakthrough introduced in DesktopManager is not only about server side technologies and masterpiece in browsers API. The new WebUI collection including DesktopManager added more power and turn the Clientside Object Framework already introduced in WebUI.NET Framework into perfection. For example, instead of creating Window or Shortcut at server side level, you can now construct the Shortcut and Window object at client side programmatically and add it to the collection the same way and manner as you did it in server side. For instance, to show new Window programmatically, you only need 3 steps. Firstly, you constructed the Window object by using new WebDesktopWindow() syntax, then configure the properties and add it to collection by using desktop.Windows.Add(newWindow) syntax, and finally simply call newWindow.Show(). This introduced new paradigm in the world of web development where developers no longer need to face different kind of object model between server and client side.
  • Extensive clientside events.
    Client side events are the way to greatest level of extensibility where developer can integrate their own algorithm or logic when specific events are occurred. DesktopManager offers up to 17 client events, from context menu, control initialize, shortcut selected and created to complete window events such as creation, moved, destroyed, resized and more.
  • Highly customizable elements.
    Design any popular styles for your WebDesktop, from Windows XP to MacOS Tiger appearance. Elements that are customizable including Frame, Window, Caption, CaptionButton, TaskBar, TaskBarButton, Shortcut, and more. The DynamicStyle for some of Styles enables developers to easily define the interactive style for Normal, Over and Active in object model design -- not CSS coding!
  • ComplexImages BorderType.
    In order to enable higher level of customization, DesktopManager offers ComplexImages BorderType. The term "ComplexImages" is used in almost WebDesktop.NET components to indicate that the rendering will use many images to draw up an element. For instance, there needs to be 3 separate images in order to draw left part of caption, the body of the caption and right part of caption. In DesktopManager alone, there are more than 20+ properties under ImagesSettings provided in order to let developers to design high detailed, gradient, shadowed or round corner style of border. Developer would be able to design virtually any kind of skins or styles as significant added value for end user experience.
  • ContentMode.
    DesktopManager and the rest components in WebDesktop.NET introduced two kind of Content Mode. The default is UseInlineContent which used the content defined in the template within the page itself and UseIFrame which will use IFrame as the content source. When configured to use IFrame, developers can easily pick which WebForm to be assigned into each Window by using ClickAndSelect feature supported in Visual Studio 2005.
  • IFrame Transparency and built-in Loader.
    These are two advanced features when Window is configured to use IFrame ContentMode. IFrameTransparency which is set to True by default enable the ContainerStyle of the Window to stay visible and ignoring the background color of the loaded WebPage. IFrameShowLoader is an useful feature which shows a loading progress bar and loading text inside the center of Window during the loading of WebForm in the IFrame. When the WebForm finished loading, the content of the Window will show up immediately. This process of loading, hiding and showing the content are done automatically by DesktopManager and requires no additional codes.
  • Natively supporting ASP.NET 2.0.
    DesktopManager as well as the entire WebDesktop.NET components are compiled on .NET Framework 2.0 and therefore it has utilized numerous new features available in ASP.NET 2.0 and C# 2.0 to deliver even higher performance, secure, scalable and reusable components.

See Also

Related Topics
{Overview}
{WebDesktop Concepts}


WebDesktop Concepts

WebDesktop Concepts
See Also Send Feedback
Intersoft WebDesktop > WebDesktopManager > WebDesktop Concepts

Glossary Item Box

The WebDesktopManager introduces new user interface concepts modelled on today's popular desktop. WebDesktopManager exposes 5 user interface concepts such as illustrated in the following screenshot.

Represents the shortcut icons defined in the DesktopManager. Shortcuts can be automatically arranged, that is, it will wrap the shortcuts to the next column as more shortcuts are added. The arrangement is also maintained accordingly during browser's resize events.
Represents a collection of windows.
Represents the built-in context menu.
Represents the main desktop area.
Represents the taskbar element which lists all open windows.

See Also

Related Topics
{Overview}
{Features}


Desktop

Desktop
Send Feedback
Intersoft WebDesktop > WebDesktopManager > WebDesktop Concepts > Desktop

Glossary Item Box

Introduction

The WebDesktopManager component exposed rich Desktop's behavior which is close to the popular's desktops with the implementation of Desktop element in the user interface.

A Desktop represents the main working area, where a collection of shortcuts and open Windows resides. In today's popular concept, a Desktop also contains TaskBar which lists all currently open Windows.

More Details

All elements and aspects of a Desktop have been implemented as a reusable component in WebDesktopManager with high details. This section will explain the componentized WebDesktopManager in both development and runtime environment.

At design time, developers can interact with the Desktop through an instance of WebDesktopManager control. The Desktop boundary is represented in the Width and Height of the WebDesktopManager's instance which have default value of 100%.

The following shows a WebDesktopManager instance on the top of a WebForm in design time.

Most Desktop's configurations can be customized at the WebDesktopManager control instance, such as the visibility of shortcut icons, taskbars, taskbar configurations and more.

The following is an illustration of a Desktop of WebDesktopManager in runtime environment.


Shortcut

Shortcut
Send Feedback
Intersoft WebDesktop > WebDesktopManager > WebDesktop Concepts > Shortcut

Glossary Item Box

Introduction

The WebDesktopManager implements Shortcut system as one of its essential user interface element in order to represent a high-end Desktop component.

A Shortcut typically represents a module or application that can be quickly accessible by users by simply double clicking on it. In traditional web application development, developers usually include available modules in navigation system such as Top-side Menu or Left-side Collapsible Panel. This new Shortcut system implementation in DesktopManager enrich the existing navigation system by bringing the user-friendly concept of a Desktop into web application development.

More Details

A shortcut element in WebDesktopManager is represented as an Image and Text. The shortcut is selectable when clicked or navigated through keyboard arrow keys. A shortcut oftenly has ToolTip as well when the mouse is over the visible Image or Text area.

The following shows an illustration of a shortcut in WebDesktopManager.

At the component implementation, shortcuts are represented in ShortcutIcons collection. Each shortcut is represented with WebDesktopShortcut object.

A WebDesktopShortcut object includes important properties related to a Shortcut system, such as its Image, Text, ToolTip and what module that the Shortcut should launch when doule clicked. The following shows a detailed picture of ShortcutIcons hierarchy and important properties available in WebDesktopShortcut object.

The following table describes the function of available properties shown in above image.

Property Name | Function
Enabled | Determines whether the shortcut is enabled or disabled. When set to False, the shortcut will not be selectable or clickable.
Image | A valid URL path represents the Image used for this shortcut. Typically, a transparent GIF image with 32x32 size is the most recommended Image.
Location | The location of the shortcut. When specified to a coordinate other than Empty (0, 0), the Shortcut will be displayed at the specified coordinate in the Desktop. In this case, the specified Shortcut will not be automatically arranged by DesktopManager.
Name | The name of the shortcut. It is recommended that you specify a short and descriptive name which corresponds to the Text. For instance, scInbox or scEmail.
TargetControlBoxImage | A valid URL path represents the Image used for the target Window's ControlBox. Typically, a control box image is best using transparent GIF with 16x16 size.
TargetURL | A valid URL path represents a WebForm Page to be accessed when the shortcut is launched. You may leave this property to Empty if the shortcut is designated to launch an existing Window (such as hidden Window).
Text | The text of the shortcut displayed in Desktop area.
ToolTip | The tooltip of the shortcut.
Visible | Determines whether the shortcut should be visible in Desktop area.
WindowName | The Window name associated with this shortcut. This property must be specified in order for the shortcut to be able to activate existing Window. It is also recommended that you assign the WindowName accordingly to the Text and the Name of the shortcut. For instance, wndInbox or wndEmail.

Features and Styles

By default, the shortcut element is not enabled in DesktopManager when the first time you create it in design time. You can easily enable this feature by configuring ShortcutIconsVisible property to True.

In this release, there are two configurations related to shortcut's behaviors such as presented in following table.

Property Name | Function
AllowAutoArrange | Specifies whether the shortcuts should be automatically arranged and managed by DesktopManager. The default value is True.
Movable | Specifies whether the shortcuts are movable by users at runtime. The default value is False. When this property is set to True, the shortcuts which have been moved by users will not be automatically arranged by the DesktopManager eventhough AllowAutoArrange is set to True.

The above configurations can be accessed in ShortcutSettings property under WebDesktopManager control.

You can also customize the interactive styles of the shortcut such as the Normal, Over and Active style. The interactive styles customization enables you to create professional and great looking DesktopManager toward your user's requirements. The following shows the property list for the ShortcutStyle.


Window

Window
Send Feedback
Intersoft WebDesktop > WebDesktopManager > WebDesktop Concepts > Window

Glossary Item Box

Introduction

Window is the core and most essential user interface element in WebDesktopManager. In Windows-based application, a Window typically represents an application or a module of application compiled on Win32 executable format. In WebDesktopManager, a Window represents content which can be in-line contents using HTML markups or webform page using IFrame.

Window user interface element is typically represented by a rectangular shape containing an Image and Text describing the running application of the Window. In WebDesktopManager, a Window consists of:

  • ControlBox element.
  • TitleBar.
  • Minimize button.
  • Maximize button (swapable with Restore).
  • Close button.
  • The window's behaviors can be easily customized at global WindowSettings or at individual Window configurations.

More Details

In addition to the highly customizable elements, WebDesktopManager also implements most of functions found in a Desktop. The following lists some of the implementation:

  • Window moving.
  • Window resizing.
  • Window states.
  • Window context menu.

For a complete list of WebDesktopManager's behaviors in this release, see High Clarity Desktop technology.

At component level, a Window is represented by WebDesktopWindow object which contained in Windows collection of a WebDesktopManager instance. The windows are arranged in Cascading tiling style by default at design time which can be seen in following screenshot. You can change the default arrangement in the WindowArrangement property under DesktopManager instance.

WebDesktopManager is developed to following today's popular Desktop specification and guidelines in high details. As seen in above screenshot, there are two states of Window in a DestkopManager instance: Active and Inactive windows. There can be up to one Active Window specified in the ActiveWindowIndex property. DesktopManager also supports no active window scenarios, that is when all windows are minimized or hidden.

Features

In this release, WebDesktopWindow supports wide range of features such as shown in following screenshot.

The following table describes the functions of available properties.

Property Name | Function
AllowClose | Specifies whether Window can be closed.
AllowMaximize | Specifies whether Window can be maximized.
AllowMinimize | Specifies whether Window can be minimized.
AllowResize | Specifies whether Window can be resized.
BorderType | The type of the border used to render the Window's border.
CaptionButtonSpacing | The amount of spacing in pixel between the buttons in Caption. The buttons in context are Minimize, Maximize, Close.
CaptionDisplayMode | The display mode of the Caption. You can use your own custom content in the Caption by setting this property to UseTemplate.
CommandBarPadding | The amount of padding in pixel of the CommandButtons relative to content area. This property is applicable to WebDialogBox component when integrated to DesktopManager.
CommandButtonBorderType | The type of the border used to render the CommandButtons border. This property is applicable to WebDialogBox component when integrated to DesktopManager.
ContentMode | The content mode of the Window.
ControlBox | Specifies whether the ControlBox of the Window is visible.
IFrameAllowTransparency | Specifies whether the IFrame should allow transparency in its background.
IFrameShowLoader | Specifies whether the IFrame should show loading indicator when the content is being loaded.
MaximumSize | The maximum size in pixel allowed when resized.
MinimumSize | The minimum size in pixel allowed when resized.
Size | The preferred size of the Window in pixel.
TextAlignment | The horizontal alignment of caption's text.

Complex Images Support

This release of WebDesktopManager supports ComplexImages border type in addition to the Simple type. The ComplexImages border type enables you to create great looking visual style of today popular's desktop in high details. You can use transparent image format such as GIF to create round-corner borders or use PNG format to create translucent title bars.

Built-in PNG image format is only supported in Internet Explorer 7.0 and Mozilla browsers with Gecko engine version 1.5+

The complex images border type are made up of more than 32 images which allow you to skin most of the elements in the Window. The images configuration are centrally available in ImagesSettings property. The following lists the configurable images:
  • 3 set of interactive ButtonLeft
  • 3 set of interactive ButtonCenter
  • 3 set of interactive ButtonRight
  • 2 set of interactive CaptionLeft
  • 2 set of interactive CaptionCenter
  • 2 set of interactive CaptionRight
  • 4 set of interactive Close
  • 4 set of interactive Maximize
  • 4 set of interactive Minimize
  • 4 set of interactive Restore
The "interactive set" above means that an element requires three state of images. The states are Normal (Inactive), Over and Active. There are several elements which require 4 states. The last state is Down.

The following screenshot illustrates a DesktopManager with ComplexImages border type configuration.

The above sample has the properties configured like in the following image.

Styles

WebDesktopManager comes along with fully customizable visual styles for the Window's elements. The styles are defined in strong object model which can be easily applied through Designer or code-behind without the need to use css syntax.

The following table lists the available styles applicable to Window elements.

Style Name | Description
CaptionButtonStyle | The dynamic interactive styles applied to caption button element.
CaptionStyle | The dynamic interactive styles applied to the caption bar element.
CommandButtonDisabledStyle | The style applied to command button when disabled.
CommandButtonStyle | The dynamic interactive styles applied to command button element.
ContainerStyle | The style applied to the content area.
ScrollBarStyle | The scrollbar style of the Window.
WindowStyle | The dynamic interactive styles applied to the Window client area.


Task Bar

Task Bar
Send Feedback
Intersoft WebDesktop > WebDesktopManager > WebDesktop Concepts > Task Bar

Glossary Item Box

Introduction

WebDesktopManager brings the "universal shell" concept from Desktop to browser-based applications by introducing five essential user interface concepts. To achieve the objective of universal shell functions, WebDesktopManager extensively implements TaskBar element as one of its core user interface.

A TaskBar represents panel contains a list of open Windows which displayed in "Button" widget. The buttons of the open Windows are also called as TaskBarWindowButton. The TaskBar provides a convenient and quick access for the currently open Windows and also serve as centralized navigation system for desktop-style web application.

The TaskBar allows end users to easily switch between Windows by clicking on the TaskBarWindowButton. The click behavior of the TaskBarWindowButton has some built-in functions such as:

  • Switch a Window to active when an Inactive Window is clicked.
  • Minimize a Window when an Active Window is clicked.
  • Restore or Maximize a Window when a previously minimized Window is clicked.
The TaskBar reflects the open windows and manages the entire window system in real-time, so that any newly created window will be shown immediately in the TaskBar as well as closed Window. This also applies to window that dynamically created or closed through codes (API).

Features

At the component design, the TaskBar element can be easily configured through one property, TaskBarVisible. By default, the TaskBarVisible is set to True when you instantiate a new instance at design time.

In this release, there are several configurations related to TaskBar that you can customize. The configurations can be found in TaskBarSettings property under the DesktopManager object.

The following table lists the available properties and its functions.

Property Name | Function
Position | The position of the TaskBar relative to the Desktop client area. The default value is Bottom.
ShowWindows | Specifies whether the TaskBarWindowButton should be visible. The default value is True. When set to False, the open windows will not managed by the DesktopManager and will not be shown in the TaskBar.
WindowButtonSpacing | The amount of the spacing in pixel between each TaskBarWindowButton.
WindowButtonWidth | The preferred amount of the Width in pixel applied to TaskBarWindowButton.

In this release, the TaskBar implements Automatic TaskBarWindowButton Resizing in conjunction with WindowButtonWidth property mentioned in above table. This built-in mechanism enables the Button's width to be automatically shrinked as more open windows are added. As opposed, when more spaces become available, the Button's width will be restored to the preferred width specified in WindowButtonWidth.

Extensibility with Custom Contents

While the TaskBar features built-in management for the entire windowing navigation system, developers oftenly need to extend the TaskBar's functionalities by incorporating application specific features. One of the most common scenarios is by incorporating a "Start menu"-like control for centralized access to application's modules. The other scenario might be incorporating a "Quick launch toolbar"-like control for allowing users to access most frequently accessed application's modules.

These application-specific functionalities can be extended to the TaskBar by implementing your own custom contents in the provided Template which available under the DesktopManager instance.

In this release, WebDesktopManager provides two Templates that you can use to extend the TaskBar functionalities. The templates are:

  • TaskBarLeftTemplate

This template allows you to incorporate your contents and functionalities to the left side of the TaskBar relative to the TaskBarWindowButton groups.

  • TaskBarRightTemplate

This template allows you to incorporate your contents and functionalities to the right side of the TaskBar relative to the TaskBarWindowButton groups.

The following shows a sample that used WebMenuBar and WebToolBar control to extend the left side functionalities of the TaskBar. It also demonstrates a simple "clock" function at the right side of the TaskBar.

<

TaskBarLeftTemplate>

  <div style="width: 165px">

                <ISWebDesktop:WebMenuBar ID="WebMenuBar1" runat="server" Width="60px" IntegratedTo="None"

                  FillDockingRow="No" AllowCustomize="No" AllowExpandCollapse="No" HandleVisible="No"

                 DisplayMode="TextAndImage">

            <Menus>

                       <ISWebDesktop:MenuCommand Text="Start" Image="/CommonLibrary/Images/WebDesktop/is_webdesktop-16.gif"

                           Name="cmdStart">

                               <Items>

                                       <ISWebDesktop:WebMenuItem Text="My Documents"></ISWebDesktop:WebMenuItem>

                                 <ISWebDesktop:WebMenuItem Text="My Computer"></ISWebDesktop:WebMenuItem>

                                  <ISWebDesktop:WebMenuItem Type="Separator"></ISWebDesktop:WebMenuItem>

                                    <ISWebDesktop:WebMenuItem Text="Calculator"></ISWebDesktop:WebMenuItem>

                                   <ISWebDesktop:WebMenuItem Text="Paint"></ISWebDesktop:WebMenuItem>

                                        <ISWebDesktop:WebMenuItem Text="WordPad"></ISWebDesktop:WebMenuItem>

                                      <ISWebDesktop:WebMenuItem Type="Separator"></ISWebDesktop:WebMenuItem>

                                    <ISWebDesktop:WebMenuItem Text="Log Off"></ISWebDesktop:WebMenuItem>

                              </Items>

                      </ISWebDesktop:MenuCommand>

                       <ISWebDesktop:MenuCommand Type="Separator">

                   </ISWebDesktop:MenuCommand>

               </Menus>

              <BodyStyle BackColor="Transparent" />

         </ISWebDesktop:WebMenuBar>

            <ISWebDesktop:WebToolBar ID="WebToolBar1" runat="server" AllowCustomize="No" AllowExpandCollapse="No"

              FillDockingRow="No" IntegratedTo="None" Width="100px" DisplayMode="Image" DisplayToolTip="Yes">

                <BodyStyle BackColor="WhiteSmoke" BackColor2="Silver" GradientType="Vertical" />

          <Commands>

                    <ISWebDesktop:ToolCommand Category="WebToolBar1" Image="/WebDesktopSamples/Images/webpad-16.gif"

                               Name="cmdWebpad" Text="WebPad">

                      </ISWebDesktop:ToolCommand>

                       <ISWebDesktop:ToolCommand Category="WebToolBar1" Image="/WebDesktopSamples/Images/outlook-16.gif"

                              Name="cmdWebOutlook" Text="WebOutlook">

                      </ISWebDesktop:ToolCommand>

                       <ISWebDesktop:ToolCommand Category="WebToolBar1" Image="/WebDesktopSamples/Images/writemail-16.gif"

                            Name="cmdNewEmail" Text="New Email">

                 </ISWebDesktop:ToolCommand>

               </Commands>

           </ISWebDesktop:WebToolBar>

        </div>

</TaskBarLeftTemplate>

<TaskBarRightTemplate>

    <div style="font-size: 8pt; font-family: Tahoma">
              [DateTimeDIV]

</div>

</TaskBarRightTemplate>

The design-time environment looks like in the following screenshot.

The following screenshot shows a desktop with extended TaskBar functionalities at runtime environment (Internet Explorer browser).

Styles

The following table lists all customizable styles related to the TaskBar and its sub elements.

Style Name | Description
TaskBarButtonStyle | The dynamic interactive styles applied to the TaskBarWindowButton elements.
TaskBarStyle | The style applied to the main TaskBar element.


Context Menu

Context Menu
Send Feedback
Intersoft WebDesktop > WebDesktopManager > Context Menu

Glossary Item Box

Introduction

To deliver a rich DesktopManager with true Desktop concepts, built-in Context Menu has been added as one of the core user interface elements in WebDesktopManager.

The built-in Context Menu in DesktopManager is built on the top of Hybrid Menu System, that is the base architecture for the runtime menu system which is used in MenuBar, ToolBar, ContextMenu and other component members which require menu functionalities.

More Details

In this release, the context menu is implemented on three objects listed in the following:

  • Desktop
  • Window
  • TaskBar
The context menu is not enabled by default. To enable context menu, simply configure the EnableContextMenu property to True.
The text for the context menu items can also be customized in the TextSettings, where all text configurations are stored.

The context menu items automatically reflects on the object's state in context. For instance, when activated on a Window that has AllowMinimize=False, the Minimize menu item in the context menu will be disabled. The items will also dynamically reflected on the real-time object's state change. For instance, when a Window is maximized, the Size and Maximize items will be disabled.

The following shows the Context Menu functions in WebDesktopManager.

Extensibility

WebDesktopManager and entire WebDesktop.NET components provide a solid Web User Interface platform engineered with extensibility in mind. In the Context Menu area, developers can extend the menu further to meet application-specific scenarios.

It was made possible through the OnContextMenu client side event where you can handle and put your codes to perform additional logics to the menu in the context. The OnContextMenu property can be found in ClientSideEvents property which contains all available client side events of DesktopManager.

OnContextMenu event provides following parameters:

  • DesktopManager ID The control ID of the WebDesktopManager instance.
  • Object Type A string representing the type of the Object which activated the context menu.
  • Context Object The object which activated the context menu.
  • Menu Object A WebMenu object representing the activated context menu.

Following sample demonstrates how to extend the window's system context menu by adding a new About menu item.

function DesktopManager_OnContextMenu(controlId, objectType, contextObject, menu)
{
        if (objectType == "Window")
        {
                        if (menu.Items.GetNamedItem("mnuAbout") == null)
                                menu.Items.Add( new WebMenuItem("mnuAbout", "About...") );
        }
}

The menu system is designed to have consistency in object model between server and client side. This enables you to easily create the menu item object at either server or client side without has to learn two set of different API. To learn more about Menu's features, see WebMenu Features.

Styles

The WebDesktopManager provides two predefined style for the Menu purpose. The predefined styles are:

  • System The style of the menu applied to system's context menu such as desktop or window.
  • Application The style of the menu applied to WebDesktop.NET components which integrated to DesktopManager, such as PlaceHolderManager, WebToolBar or ContextMenu.
The Application MenuStyle offers centralized management of the menu instances' visual styles used in entire web application. This time-saving feature enables you to easily produce consistent visual style for all integrated Menu-based controls. For more information, see Styles Inheritance model for Uniform Look and Feel concept.

The following screenshot shows the customizable menu styles at design time.

For more information about customizable elements in Menu Styles, see WebMenu Styles.


Working with ClickAndEdit and Window in design time

Working with ClickAndEdit and Window in design time
See Also Send Feedback
Intersoft WebDesktop > WebDesktopManager > Working with ClickAndEdit and Window in design time

Glossary Item Box

Introduction

ClickAndEdit is one of powerfull productivity features from WebDesktop.NET for Visual Studio 2005 Development Environment. It's technology makes possible for you to easily perform editing in a container-type control in WYSIWYG visualization which results in faster user interface implementation.

Adding a new Window

Adding a new window can be easily perform inside the WebDesktopManager working area. It is simply done by clicking on the "Add new window" button at the right top of the WebDesktopManager instance, and it will directly create a new window for you with a default settings that you have already specified in WebDesktopManager.

For more information on how you can create a new window, you can follow the "See Also" section at the end of this article.

ClickAndEdit

Combined with ClickAndSelect technology, ClickAndEdit enables you to interact with different instances of one container control easily. For example, you would like to edit a few windows that are created within 1 WebDesktopManager. It is not quite an easy task to do without WebDesktopManager, since you have to switch between one window to another window which is not in the same control and then edit their content separately. The ClickAndEdit technology adding the capability to edit directly into the control's visual boundary and expose new functions. So now, the process of editing the window is as simple as 3 simple steps: select the window, click the content part of the window, and start edit it.

The following image illustrates the main function of ClickAndEdit inside WebDesktopManager:

See Also

Related Articles
Creating Simple Desktop


ContentMode and Most Common Scenarios

ContentMode and Most Common Scenarios
Send Feedback
Intersoft WebDesktop > WebDesktopManager > ContentMode and Most Common Scenarios

Glossary Item Box

Introduction

DesktopManager in WebDesktop.NET introduced two kind of Content Mode. The default is UseInlineContent which used the content defined in the template within the page itself and UseIFrame which will use IFrame as the content source. When configured to use IFrame, developers can easily pick which WebForm to be assigned into each Window by using ClickAndSelect™ feature supported in Visual Studio 2005 or by specifying the content URL when adding new window.

Two advanced features when Window is configured to use IFrame ContentMode are IFrame Transparency and IFrameShowLoader. IFrameTransparency which is set to True by default enable the ContainerStyle of the Window to stay visible and ignoring the background color of the loaded WebPage. IFrameShowLoader is an useful feature which shows a loading progress bar and loading text inside the center of Window during the loading of WebForm in the IFrame. When the WebForm finished loading, the content of the Window will show up immediately. This process of loading, hiding and showing the content are done automatically by DesktopManager and requires no additional codes.

When you choose to UseIFrame as the content mode, you can modify the content file of the IFrame or change the IFrame source's URL simply by clicking the button that linked to the content file.

When you choose to UseInlineContent as the content mode, you can instantly editing its content simply by clicking on the editable area and start putting the control or text as you like.

In above example, Windows1 content is containing WebPaneManager control combined with other HTML and WebControls.

When we run the application on the browser, it will look like the following image.


Integration with other WebDesktop controls

Integration with other WebDesktop controls
Send Feedback
Intersoft WebDesktop > WebDesktopManager > Integration with other WebDesktop controls

Glossary Item Box

Introduction

WebDesktopManager is designed with great extensibility architecture as one of its key design in order to achieve the objective to be universal "shell" for web application. WebDesktopManager is engineered with deep integration capabilities with other WebDesktop-members such as WebDialogBox, WebContextMenu, PlaceHolderManager and WebButton.

Diagram

The following diagram illustrates how WebDesktop components integrates into WebDesktopManager.

More Details

This section lists the references on how each component integrates into WebDesktopManager in details.

  • WebDialogBox Integration
  • WebButton Integration
  • Hybrid Menu System
  • Styles Inheritance Model


Working with ClientSide Events

Working with ClientSide Events
Send Feedback
Intersoft WebDesktop > WebDesktopManager > Working with ClientSide Events

Glossary Item Box

Introduction

One of WebDesktop's most powerful features is the ability to accommodate a broad range of scenarios through its extendable capability using client-side events. In this section, we will see how we can attach a client-side event handler to the event using the Client-side Event Editor.

Assuming that you have already created the shortcut icon and you want to perform other tasks after the shortcut is created, the steps needed are as following:

  1. Switch to design view of the page and right-click on the WebDesktopManager, then select Properties.
  2. In the Properties tab, expand ClientSideEvents node.

  3. Find the OnShortcutCreated event and click the drop down arrow. In the drop down list you will see an item 'Add New Handler - WebDesktopManager1_OnShortcutCreated_1(controlId, shortcut)' and/or other event handler names if the page has already contained other client-side event handlers.
  4. Click on the 'Add New Handler...' item. The page will then automatically switch to HTML view and the event handler will be automatically added in the page.


Advanced ClientSide Events

Advanced ClientSide Events
Send Feedback
Intersoft WebDesktop > WebDesktopManager > Advanced ClientSide Events

Glossary Item Box

Introduction

Client side events are the way to greatest level of extensibility where developer can integrate their own algorithm or logic when specific events are occurred. DesktopManager offers the most comprehensive client side events up to 17 client events, from context menu, control initialize, shortcut selected and created to complete window events such as creation, moved, destroyed, resized and more.

Client Side Events

The following table lists the client side events available in this release.

Client Side Event | Description
OnContextMenu | Invoked when a context menu is about to be displayed.
OnInitialize | Invoked when the control is initialized.
OnShortcutAfterLaunched | Invoked after Shortcut has been launched.
OnShortcutBeforeLaunched | Invoked before Shortcut is launched.
OnShortcutCreated | Invoked when the Shortcut is created.
OnShortcutSelected | Invoked when the Shortcut is selected.
OnWindowAfterActivated | Invoked after the Window is activated.
OnWindowAfterClosed | Invoked after the Window is closed.
OnWindowBeforeActivated | Invoked before the Window is activated.
OnWindowBeforeClosed | Invoked before the Window is closed.
OnWindowCreated | Invoked when a Window is created.
OnWindowCreating | Invoked when a Window is in the process of creating.
OnWindowMaximized | Invoked when a Window is maximized.
OnWindowMinimized | Invoked when a Window is minimized.
OnWindowMoved | Invoked when a Window is moved.
OnWindowResized | Invoked when a Window is resized.
OnWindowRestored | Invoked when a Window is restored.

Handling Client Side Events

Handling client side event in WebDesktopManager can be easily done using ClientSideEvent TypeEditor which is integrated in Visual Studio's property window. This time-saving feature enables you to assign the function name and let the designer automatically creates the function definition as well as the parameters.

The following image shows the ClientSideEvent TypeEditor.

The following is a sample for handling OnWindowCreating event to manipulate window settings before the window is created.

function

 WebDesktopManager1_OnWindowCreating(id, win)
{

 if (win.Name == "wndContactManagement")
  {

                win.Size.Width = 780;

            win.Size.Height = 450;

           win.AllowResize =

"No";
         win.AllowMaximize =

"No";
       }

}

Advanced Feature

In addition to the client side events listed above, DesktopManager introduced an advanced way in handling client side event in a late-binding scenario.

Since WebDesktopManager is designed with "universal shell" in mind, the windows (applications) that hosted on the top of DesktopManager needs to have a scalability degree where the application itself can subscribe to the Window event without has to handle from the DesktopManager level.

In this context, DesktopManager is only serving as host and does not know the application's information it contain at the time of loading, until the application is launched and registered to the DesktopManager at latter time.

In this release, there are 9 individual events available at Window level, which can be subscribed using late-binding scenarios:

  • OnAfterActivated
  • OnAfterClosed
  • OnPrepareClosed
  • OnBeforeActivated
  • OnBeforeClosed
  • OnMaximized
  • OnMinimized
  • OnResized
  • OnRestored

The following illustration describes the details on how to handling the events in late-binding way.

Assume there are 2 webforms, one is the Default.aspx containing WebDesktopManager instance, and the second is the App.aspx that hosted by the WebDesktopManager in Default.aspx

Default.aspx - WebDesktopManager1

|------ App.aspx

In App.aspx, you might want to handle the OnBeforeClosed event so that you can prompt the users to save modified files before the Window is destroyed.

To do so, you're required to do the following:

  • Attach a function for window's onload. The attached function will call necessary codes to register the event handling shown in details below.
  • Attach a function for window's onunload event. The attached function is to clear up any resources used for the event handling.

function

 PageLoaded()
{

     // hook WebDesktopWindow event programmatically

 // this uses special client side events which exposed for programmatic created window

   var curWindow = ISGetCurrentWindow();
       ISEvent.AddFunctionHandler(curWindow,

"OnBeforeClosed", OnWebPadBeforeClosed);
 curWindow.EventsRegistered =

true;
}

// called when the page is unloaded. ie, when the page is refreshed.

function PageUnloaded()

{

     var curWindow = ISGetCurrentWindow();

  // important to unregister the window handler by calling RemoveFunctionHandler

       ISEvent.RemoveFunctionHandler(curWindow,

"OnBeforeClosed", OnWebPadBeforeClosed);

}

Codes Discussion

  • In the App.aspx, you can obtain the WebDesktopWindow object that host the WebForm by using ISGetCurrentWindow() global function.
  • You used ISEvent.AddFunctionHandler to register the function pointer to the specific window and event name. First parameter of the function is the object to register, followed by the event name and the function pointer.
  • In PageUnloaded function, you must remember to unregister the event by calling ISEvent.RemoveFunctionHandler.

Your application may result in crash or unexpected behaviors if you did not implement the RemoveFunctionHandler during window's unload event.


Accessibility Compliant

Accessibility Compliant
See Also Send Feedback
Intersoft WebDesktop > WebDesktopManager > Accessibility Compliant

Glossary Item Box

Introduction

As the key to build successful rich web applications that behave closely with desktop's application functions, WebDesktopManager provides comprehensive keyboard supports so that certain tasks can be easily invoked through combined keys. The keyboard supports also help people with disabilities, and comfort to U.S. Section 508 Accessibility standard.

Supported Keys

The following is a list of supported keys in WebDesktopManager control implemented in this release.

  • Ctrl + 1 Activate next window
  • Ctrl + Shift + 1 Activate previous window
  • Ctrl + Alt + C Close current active window
  • Esc Close or cancel a Menu (if shown)

The following keys are valid when the focus is at Desktop.

  • Left Arrow Key Navigate to previous shortcut
  • Right Arrow Key Navigate to next shortcut
  • Up Arrow Key Navigate to previous shortcut
  • Down Arrow Key Navigate to next shortcut
  • Enter key Launch currently active shortcut

Advanced Keys Support

In addition to the built-in keys supported in above list, WebDesktopManager also provides extended keys support when integrated with other WebDesktop.NET's members.

WebDesktopManager supports specific scenarios listed in the following:

  • WebToolBar
    • Supports AccessKey at Window level.
    • Supports ShortcutKey.
  • WebMenuBar
    • Supports AccessKey.
    • Supports ShortcutKey.
    • Supports Menu Navigations.
  • WebContextMenu
    • Supports Menu Navigations.
    • Supports AccessKey (when active).
    • Supports ShortcutKey (when active).

Some keystrokes are not working properly in Mozilla browsers due to limitation or known issues. For more information, see Known Issues

See Also

Concepts
{Shortcut}
{Desktop}


Tutorials

Tutorials
Send Feedback
Intersoft WebDesktop > WebDesktopManager > Tutorials

Glossary Item Box

This section contains tutorials topics in WebDesktopManager.

In This Section

Creating Simple Desktop

Using IFrame as Default Content

Hiding a Window from TaskBar

Enabling ShortcutIcons feature

Hiding a Window at initial load

Configuring Desktop to use VerticalTile WindowArrangement

Using Custom Template for Left and Right part of TaskBar

Using Window Options

Specifying Custom Location for a Window

Specifying Minimum and Maximum Size for a Window

Adding new Window at Client Side

Adding new Shortcut at Client Side

Configuring Window to use Complex Images

How-to: Create TasksBar without Window Group


Creating Simple Desktop

Creating Simple Desktop
See Also Send Feedback
Intersoft WebDesktop > WebDesktopManager > Tutorials > Creating Simple Desktop

Glossary Item Box

Objectives

Create a simple desktop with a window and define a shortcut icon that points to the window using WebDesktopManager Designer.

  1. Drag the WebDesktopManager component from the Toolbox and drop it onto the form. Remember to remove the DOCTYPE declaration and the html tag's xmlns attribute from the form before doing this.

    Drag WebDesktopManager from the Toolbox

  2. Click the Add Windows button in the upper-right corner. Then enter 'My About Page' for the new window's text and set the Content Mode to UseInlineContent. If you would like to use a stand-alone Web page for the window content, select UseIFrame for the Content Mode.

  3. A new window is created in the WebDesktopManager. Note that you can directly type the page content in the new window.

    A New Window

  4. Next, using the WebDesktop Designer we will create an icon shortcut that points to the 'My About Page' page.

  5. Right-click on the WebDesktopManager and select 'WebDesktopManager Designer...' from the menu. Click on the ShortcutIcons node which is the last node in the treeview and click the Add button to add a shortcut icon. Fill in the property grid fields according to the following screenshot and click OK.

    We set MyAboutPage for the WindowName because we have added a new window with that name in previous step. If you choose not to create a window for the page, you can specify the TargetURL instead. This will open a window with the TargetURL as its content.

  6. Select the Windows node and MyAboutPage item from the listbox. Set the ClientVisible property to false to make the windows not visible the first time the desktop loads.

  7. Run the page and then click the 'My About Page' shortcut icon.

    My About Page

See Also

Related Articles
Using IFrame as Default Content
{Enabling ShortcutIcons feature}
Hiding a Window at initial load
{Using Window Options}
{Using Custom Template for Left and Right part of TaskBar}
Specifying Custom Location for a Window
{Specifying Minimum and Maximum Size for a Window}
{Configuring Window to use Complex Images}


Using IFrame as Default Content

Using IFrame as Default Content
See Also Send Feedback
Intersoft WebDesktop > WebDesktopManager > Tutorials > Using IFrame as Default Content

Glossary Item Box

Objectives

Create a window that use IFrame that points to a page as its content. This tutorial is based on the Creating Simple Desktop which is very similar in the steps.

  1. Drag WebDesktopManager component to the WebForm. Remember to remove the DOCTYPE declaration and the html tag's xmlns attribute from the form before doing this.

    Drag WebDesktopManager from the Toolbox

  2. Click the Add Windows button in the upper-right corner. Then set 'About' for the new window's text. Set the Content Mode to UseIFrame and Content URL to '~/About.aspx'. Note that About.aspx is a page that resides in the same directory as this page. If you would like to use in-line content for the window content, select UseInlineContent instead.

  3. A new window is created in the WebDesktopManager. As you can see, the new window contains the 'Edit About.aspx' button. Click on the button if you have already had the About.aspx page created. Otherwise you will receive a MessageBox notifying about the missing link.

  4. Next, using the WebDesktop Designer we will create an icon shortcut that points to the 'About' page.

  5. Right-click on the WebDesktopManager and select 'WebDesktopManager Designer...' from the menu. Click on the ShortcutIcons node which is the last node in the treeview and click the Add button to add a shortcut icon.

    Fill in the property grid fields according to the following screenshot and click OK.

    We set 'About' for the WindowName because we have added a new window with that name in previous steps. Because the window uses IFrame you also need to specify the TargetURL

  6. Select the Windows node and About page from the listbox. Set the ClientVisible property to false to make the windows not visible the first time the WebDesktop loads.

  7. Run the page and then click the 'About' shortcut icon.

    Using IFrame as Default Content

See Also

Related Articles
{Creating Simple Desktop}


Hiding a Window from TaskBar

Hiding a Window from TaskBar
See Also Send Feedback
Intersoft WebDesktop > WebDesktopManager > Tutorials > Hiding a Window from TaskBar

Glossary Item Box

Objectives

Hiding a window from TaskBar using WebDesktopManager Designer. It gives you a freedom to set the ShowInTaskBar to be displayed or hidden.

  1. Drag WebDesktopManager from Toolbox into a WebForm page.

  2. Add a Window using AddWindow button on the right-upper side and named it Window1.

  3. Right click on WebDesktopManager's instance, and select WebDesktopManager Designer.
  4. Click on Windows, and choose the added Window which is Window1.
  5. Set the ShowInTaskBar to False.
  6. Click OK to take affect of the setting.

  7. Run the Project and you should see something like the following.

See Also

Related Articles
{Creating Simple Desktop}


Enabling ShortcutIcons feature

Enabling ShortcutIcons feature
See Also Send Feedback
Intersoft WebDesktop > WebDesktopManager > Tutorials > Enabling ShortcutIcons feature

Glossary Item Box

WebDesktopManager has capability to enable shortcut.

This topic will show you how to create a simple Shortcut Icons using WebDesktopManager Designer.

To enable ShortcutIcons feature

  1. Drag WebDesktopManager from Toolbox into a WebForm page.
  2. Right click on WebDesktopManager control and choose WebDesktopManager Designer.
  3. Click on ShortcutIcons, and add a Shortcut.
  4. Customize the added Shortcut like the following snapshot.

  5. Set the ShortcutIconsVisible to True.

  6. Click OK to take affect of the setting.
  7. Run the Project and you should see something like the following.

See Also

Related Articles
{Creating Simple Desktop}


Hiding a Window at initial load

Hiding a Window at initial load
See Also Send Feedback
Intersoft WebDesktop > WebDesktopManager > Tutorials > Hiding a Window at initial load

Glossary Item Box

Objectives

Hiding a window at initial load using WebDesktopManager Designer. It enables you to freely set the WindowState to be normal, minimized or maximized.

  1. Drag WebDesktopManager from Toolbox into a WebForm page.

  2. Add 3 Windows using AddWindow button on the right-upper side and named it Window1, Window2 and Window3 respectively.

  3. Right click on WebDesktopManager's instance, and select WebDesktopManager Designer.
  4. Click on Windows, and choose one of the added Windows which is Window2.
  5. Set the ClientVisible to False.
  6. Click OK to take affect of the setting.

  7. Run the Project and you should see something like the following.

See Also

Related Articles
{Creating Simple Desktop}


Configuring Desktop to use VerticalTile WindowArrangement

Configuring Desktop to use VerticalTile WindowArrangement
See Also Send Feedback
Intersoft WebDesktop > WebDesktopManager > Tutorials > Configuring Desktop to use VerticalTile WindowArrangement

Glossary Item Box

WebDesktop gives you a freedom to customize the window arrangement to be either "TiledVertically", "TiledHorizontally" or "Cascade".

This topic will show you how to configure your WebDesktop to use vertical tile window arrangement. By default, the window arrangement property is set to "Cascade".

  1. Drag WebDesktopManager control into a WebForm.
  2. Add 3 windows into WebDesktopManager using AddWindow button on the right-upper side, and named it Window1, Window2 and Window3 respectively.

  3. Right click on the WebDesktopManager's instance and click Properties to display the properties window.
  4. Set the WindowArrangementProperty to "TiledVertically".

  5. Save all the changes that you have made, and run the WebForm.
  6. In the browser, you will see something like the following.

See Also

Related Articles
{Creating Simple Desktop}


Using Custom Template for Left and Right part of TaskBar

Using Custom Template for Left and Right part of TaskBar
See Also Send Feedback
Intersoft WebDesktop > WebDesktopManager > Tutorials > Using Custom Template for Left and Right part of TaskBar

Glossary Item Box

The WebDesktopManager provides flexibility to the TaskBar by allowing developers to add more sophisticated contents and functions to the TaskBar area. You can add your own contents in the TaskBar element by using the provided TaskBarLeft and TaskBarRight Template.

This topic will show you how to use custom template for left and right part of TaskBar.

To use custom template for left and right part of TaskBar

  1. Create a DesktopManager instance by dragging a WebDesktopManager component from ToolBox to the Design Surface.
  2. Right-click on the WebDesktopManager control then choose EditTemplate >> TaskBar.
    The below snapshot should be displayed to you. This is the Template View for editing the Left and Right TaskBar in WebDesktopManager.

    In this sample, simply put an image in the left side of the TaskBar and a time indicator at the right side of the TaskBar.

  3. To add extra implementation in this sample, create a JavaScript function which will refresh the time indicator on the right TaskBar. The time indicator is refreshed using a JavaScript function which is called every 60 seconds.

  4. JavaScript Copy Code
    function window_onload()
{
   runTime();
   setInterval(runTime, 60000);
}

function runTime()
{
   var rightPart = document.getElementById("dvRightTemplate");
   var time = new Date();
   rightPart.innerText = time.getHours() + ":" + time.getMinutes();
}

See Also

Related Articles
{Creating Simple Desktop}


Using Window Options

Using Window Options
See Also Send Feedback
Intersoft WebDesktop > WebDesktopManager > Tutorials > Using Window Options

Glossary Item Box

Objectives

WebDesktopManager gives you the flexibility to customize each window appearance just like in WinForm development. Some properties you might be familiar already include AllowMinimize, AllowMaximize and AllowClose which control the basic behavior of the window.

The WebDesktopManager provided WindowSettings property which contains the default configuration of all Window behaviors. When the properties at Window level are set to Default, the designated property will inherit the value from the WindowSettings.

You can of course override each window property so it does not use the Default parent property but use its own overridden property. This OO approach is not just so you can conveniently change/modify the whole window appearance from one integrated place but it also gives lighter page in result.

  1. Create a DesktopManager instance by dragging a WebDesktopManager component from ToolBox to the Design Surface.

  2. Select the DesktopManager instance by pressing F4 from your keyboard so that the property grid appears.
    The property of the DesktopManager instance will be displayed in the property Grid.
    Look for WindowSettings property and then set the property behavior which will be inherited by the windows owned by the Desktop Manager instance.

  3. Add 2 windows using the Window Collection Editor by navigating to Windows property of WebDesktopManager instance. Press the button with "..." text and a pop-up form will appear. Add 2 windows there and set the AllowMinimize to Yes in the second Window.

  4. The final result should look like below. At DesktopLevel the WindowSettings are set to have No Minimize and Maximize button.
    So by the default when a window is created it will have no Minimize and Maximize button unless the default value in the window itself is overridden. Here Window2 overrides the AllowMinimize to Yes instead of Default so it now has a minimize button.

See Also

Related Articles
{Creating Simple Desktop}


Specifying Custom Location for a Window

Specifying Custom Location for a Window
See Also Send Feedback
Intersoft WebDesktop > WebDesktopManager > Tutorials > Specifying Custom Location for a Window

Glossary Item Box

Objectives

WebDesktopManager offers great flexibility architecture which allows you to customize numerous window configurations at individual Window level such as the location of the window. This tutorial will guide you to customize the location of an individual window.

  1. Drag WebDesktopManager into a WebForm.

  2. Add a window into WebDesktopManager using AddWindow button on the right-upper side, and named it Window1.

  3. Right click on the WebDesktopManager's instance and click WebDesktopManager Designer to display the Designer Window.
  4. Click on the Properties - Windows and select "Window1". Set the Location to 150,150 or any other location that you want.

  5. Click on Apply button on bottom right corner of the designer, and then click OK to apply all the changes.
  6. Save all the changes and run the WebForm.
  7. Finally, you will see something like the following.

See Also

Related Articles
{Creating Simple Desktop}


Specifying Minimum and Maximum Size for a Window

Specifying Minimum and Maximum Size for a Window
See Also Send Feedback
Intersoft WebDesktop > WebDesktopManager > Tutorials > Specifying Minimum and Maximum Size for a Window

Glossary Item Box

Objectives

WebDesktopManager which implements great flexibility architecture, gives you the options to customize numerous window configurations. This tutorial will guide you to specify minimum and maximum size for a Window to be resized.

  1. Drag WebDesktopManager into a WebForm.

  2. Right click on the WebDesktopManager's instance and click WebDesktopManager Designer to display the Designer Window.
  3. Click on the Properties - Windows and select "Window1" or any other windows that you want to set the maximum and minimum size. Change the MaximumSize and MinimumSize in WindowSettings property to suit your needs.

  4. Click on Apply button on bottom right corner of the designer, and then click OK to apply all the changes.
  5. Save all the changes, build the project, and run the application.

See Also

Related Articles
{Creating Simple Desktop}


Adding new Window at Client Side

Adding new Window at Client Side
See Also Send Feedback
Intersoft WebDesktop > WebDesktopManager > Tutorials > Adding new Window at Client Side

Glossary Item Box

WebDesktopManager allows user to create new window at runtime.

This topic will show you how to add new window from client-side.

To add new window at client-side

  1. Drag WebDesktopManager from Toolbox into a WebForm page.
  2. On the upper-right corner, click the arrow next to Add Window TaskBar. It is known as WebDesktopManager Tasks.
  3. Click Edit Templates.

  4. Click the DropDownArrow and choose TaskBarLeft.
  5. Drag a HTML Image control from the ToolBox to the TaskBarLeft. You may customize the image from its properties according to your needs.

  6. In the client-side, add the following code:

    JavaScript Copy Code
    function AddWindow()
{
    var dm = ISGetDesktopManager();
    var wnd = dm.GetWindow("wndAboutDM");
    if (wnd == null)
    {
        wnd = new WebDesktopWindow();
        wnd.Text = "About DesktopManager";
        wnd.Name = "wndAboutDM";
        wnd.ControlBoxImage = "is_webdesktop-16.gif";
        wnd.ContentURL = "../About.aspx";
        wnd.ContentMode = "UseIFrame";
        wnd.AllowMinimize = "No";
        wnd.AllowMaximize = "No";

        dm.Windows.Add(wnd);
        wnd.Show();
        wnd.ResizeTo(600, 400);
        wnd.MoveToCenterDesktop();
    }
    else
    {
        wnd.Activate();
    }
}

  7. Invoke AddWindow() function from the image's onclick event.

    Script Copy Code
    <taskbarlefttemplate>
   <img src="../Images/WebDesktopIconRound.png" onclick="AddWindow()" style="CURSOR: pointer" title="New Window">
</taskbarlefttemplate>

  8. Run the project and click the image on the bottom-left corner, which is indicated as New Window. It will display a new window like the following.

See Also

Related Articles
{Creating Simple Desktop}


Adding new Shortcut at Client Side

Adding new Shortcut at Client Side
See Also Send Feedback
Intersoft WebDesktop > WebDesktopManager > Tutorials > Adding new Shortcut at Client Side

Glossary Item Box

Objectives

This tutorial shows how to add a new shortcut via Client-side code. It will create an image on the TaskBar left which will invoke onclick event from client-side code to implement adding a new shortcut.

  1. Drag WebDesktopManager from Toolbox into a WebForm page.

  2. On the upper-right corner, click the arrow next to Add Window TaskBar. It is known as WebDesktopManager Tasks.
  3. Click Edit Templates.

  4. Click the DropDownArrow and choose TaskBarLeft.
  5. Drag a HTML Image control from the ToolBox to the TaskBarLeft. You may customize the image from its properties according to your needs.

  6. In the client-side, add the following codes:

    Javascript Copy Code
    <script language="javascript" type="text/javascript">
function AddShorcut()
{
    // To add a Shortcut Icon
    var dm = ISGetDesktopManager();
    var shortcut1 = new WebDesktopShortcut();
    shortcut1.Name = "WebDesktopShortcut1";
    shortcut1.Text = "Welcome to WebDesktop.NET";
    shortcut1.Image = "../Images/welcome-32.gif";
    shortcut1.TargetURL = "../About.aspx";
    shortcut1.ToolTip = "Display Welcome Screen.";
    shortcut1.WindowName = "wndWelcome";

    dm.ShortcutIcons.Add(shortcut1);
    dm.ShortcutIconsVisible = true;
    shortcut1.Show();
}

function window::onload()
{
    // To add a Window
    var dm = ISGetDesktopManager();
    var wnd = dm.GetWindow("wndAboutDM");
    wnd = new WebDesktopWindow();
    wnd.Text = "About DesktopManager";
    wnd.Name = "wndWelcome";
    wnd.ControlBoxImage = "is_webdesktop-16.gif";
    wnd.ContentURL = "../About.aspx";
    wnd.ContentMode = "UseIFrame";
    wnd.AllowMinimize = "Yes";
    wnd.AllowMaximize = "Yes";

    dm.Windows.Add(wnd);
    wnd.Hide();
    wnd.Activate();
    wnd.MoveToCenterDesktop();
}
</script>

  7. Invoke AddShorcut() function from the image's onclick event.

    Script Copy Code
    <taskbarlefttemplate>
   <img src="../Images/WebDesktopIconRound.png" onclick="AddShorcut()" style="CURSOR: pointer" title="New Shortcut">
</taskbarlefttemplate>

  8. Run the project and click the image on the bottom-left corner, which is indicated as New Shortcut.

  9. It will display a new shortcut like the following.

  10. When you double-click on the shortcut icon, it will directly link to the new window created in the client-side.

See Also

Related Articles
{Creating Simple Desktop}


Obtaining Desktop Structure at Client Side

Obtaining Desktop Structure at Client Side
See Also Send Feedback
Intersoft WebDesktop > WebDesktopManager > Tutorials > Obtaining Desktop Structure at Client Side

Glossary Item Box

Objectives

This tutorial provides you a step-by-step guidance to obtain desktop structure at client side.

  1. Drag WebDesktopManager control to the WebForm. Named the control as WebDesktopManager1.
  2. Add some WebDesktopWindow, WebDesktopShortcut to WebDesktopManager1. In this example: one WebDekstopWindow and two WebDesktopShortcut are added to WebDesktopManager1.

  3. In Properties window, add a handler for OnInitialize client side events.

  4. To obtain the WebDesktopManager structure, you can use SaveDesktopStateToXml function. You can put this command in WebDesktopManager1_OnIntialize client side function that is just created.

  5. Compile and run the application.

See Also

Related Articles
{Creating Simple Desktop}


Configuring Window to use Complex Images

Configuring Window to use Complex Images
See Also Send Feedback
Intersoft WebDesktop > WebDesktopManager > Tutorials > Configuring Window to use Complex Images

Glossary Item Box

Objectives

This tutorial provides you step-by-step guidance to configure window to use complex image.

  1. Drag WebDesktopManager control to the WebForm. Named the control as WebDesktopManager1.
  2. Click AddWindow at the top right of WebDesktop to add a new WebDesktopWindow to WebDesktopManager1.

  3. In WebDesktopManager Designer, choose Window Settings, and set the BorderType property to ComplexImages.

  4. Choose Images Settings and set the images file name for the following properties.

  5. Compile and run the application.

See Also

Related Articles
{Creating Simple Desktop}


How-to: Create TaskBar without Window Group

How-to: Create TaskBar without Window Group
Send Feedback
Intersoft WebDesktop > WebDesktopManager > Tutorials > How-to: Create TaskBar without Window Group

Glossary Item Box

When TaskBar is enabled, the open windows are not visible on the TaskBar.

This topic will show you how to create TaskBar without Window Group.

To create TaskBar without Window Group

  1. Right click on WebDesktopManager control and choose Properties.
  2. Expand TaskBarSettings and set ShowWindows to False.
  3. Run the project. With this configuration, minimized Windows will appear in desktop area and can be moved. You can try to minimize a Window to see the behavior.


WebToolBar

WebToolBar
See Also Send Feedback
Intersoft WebDesktop > WebToolBar

Glossary Item Box

WebToolBar
Member of WebDesktop.NET

WebToolBar offers most functionalities a ToolBar control should have, integrated with a powerful designer which will ease the process of design time.

What's New in WebToolBar

Learn the Features

Understanding PlaceHolderManager Concept

Understanding ToolBar Architecture

Learn More about Rich Design-time Experience

Working with ToolBar Designer

Using Customization DialogBox

Quick Start

Creating Standalone ToolBar

Using ToolCommand Types

Using Images for ToolBar Appearance

Create Professional Desktop Application's ToolBar

Use WebToolBar control to quickly build a professional desktop application-style's ToolBar. WebToolBar is designed with an elegant architecture and object model as well as specialized user interface for each element. That means, you no longer require any workarounds to create a look like ToolBar object which is not only rich in styles, but also in every functions and behaviors.

Docking capability into a PlaceHolderManager

When combined with PlaceHolder manager, you can easily deploy dockable ToolBars which commonly found in desktop-based applications. Supported by PlaceHolderManager architecture, you can dock the ToolBar quickly with just a property change, no extensive coding required.

Interactive Designer

WebToolBar is also supported with an interactive designer which eases you during design and development time process. No more unvisualized designer or hard coding, with Interactive PlaceHoderManager Designer and VisualMenu Builder you are given a visualization in high WYSIWYG details.

See Also

Getting Started
Features
{PlaceHolderManager Concept}
Understanding ToolBar Architecture
Rich Design-time Experience
{Working with ToolBar Designer}
{Using Customization Dialog Box}


Redistributable Files

Redistributable Files
Send Feedback

Glossary Item Box

WebDesktop.NET V1.0

Following is the list of assemblies of WebDesktop.NET which are redistributable:

File Name | Location | Description
ISNet.WebUI.WebDesktop.dll | [Program Files]Intersoft Solutions\WebDesktop.NET V1.0\Bin | WebDesktop.NET assembly.

Following is the list of client files in CommonLibrary folder that are redistributable:

File Name | Location | Description
Images File (*.jpg; *.gif; *.png) | Images | Image files that shipped along with product installation.
Scripts File (*.js) | WebDesktop\V1_0_2006 | WebDesktop.NET Enterprise client side implementation.

The CommonLibrary Virtual Directory is created automatically during the installation of WebUI.NET Framework. By default, it should be pointed to [Program Files]Intersoft Solutions\CommonLibrary.

WebUI.NET Framework 3.0

Following is the list of assemblies that are redistributable:

File Name | Location | Description
ISNet.dll | [Program Files]Intersoft Solutions\WebUI.NET Framework 3.0\Bin | Intersoft core objects, interfaces and implementation.
ISNet.WebUI.dll | [Program Files]Intersoft Solutions\WebUI.NET Framework 3.0\Bin | Intersoft core controls

Following is the list of client files in CommonLibrary folder that are redistributable:

File Name | Location | Description
Images File (*.jpg; *.gif; *.png) | Images | Image files that shipped along with product installation.
ISCore.js | Shared | Intersoft client object framework and core implementation.
ISCultureInfo.js | Shared | Intersoft culture info object and implementation.
ISCoreValidator.js | Shared | Intersoft core validator objects and implementation.
IEMozBridge.js | Shared | Intersoft javascript library to emulate Internet Explorer�??s javascript DOM API in Mozilla browser
WebUIValidation.js | Shared | Asp.net validators script that are modified to be suitable for WebUI�??s Framework.
XmlCompressor.js | Shared | Intersoft's javascript library to compress and decompress XML data from Intersoft�??s control.


System Requirements

System Requirements
Send Feedback

Glossary Item Box


WebPaneBase Methods

WebPaneBase Methods
Send Feedback

Glossary Item Box

WebPaneBase Methods

GetPaneManager Description
Get WebPaneManager object

Parameters

Remarks

Return Value

object (WebPaneManager)

Samples

GetElement

Description
Get WebPane Element

Parameters

Remarks

Return Value

object (HTML Element)

Samples

GetHeaderCellElement

Description
Gets WebPane Header Cell Element (if isInfoText is true, it get the InfoText Cell Element, if isInfoText is false, it get the WebPane Title Cell Element)

Parameters
isInfoText (boolean)

Remarks

Return Value

object (HTML Element)

Samples
SetText

Description
Set the title of WebPane

Parameters

text (String)
WebPane's Title

Remarks

Return Value

Samples
SetInfoText

Description
Set the InfoText of WebPane

Parameters

text (string)
WebPane's InfoText

Remarks

Return Value

Samples

SetImage

Description
Set the Image for WebPane Header

Parameters

imageURL (string)
URL of the Image

Remarks

Return Value

Samples

SetVisible

Description
Set the Visibility of WebPane

Parameters

isVisible (boolean)
WebPane visibility

Remarks

Return Value

Samples

SetContentVisible

Description
Set the Visibility of WebPane's content area

Parameters

isVisible (boolean)
Visibility of WebPane's content area

Remarks

Return Value

Samples

Collapse

Description
Collapse the WebPane

Parameters

Remarks

Return Value

Samples

Expand

Description
Expand the WebPane

Parameters

Remarks

Return Value

Samples

IsCollapsed

Description
Get WebPane status whether its Collapsed or Not

Parameters

Remarks

Return Value

boolean

Samples


WebPane Methods

WebPane Methods
Send Feedback

Glossary Item Box

WebPane Methods

GetContentDivElement

Description
Get the Content's DivElement of WebPane

Parameters

Remarks

Return Value
object (HTML Element)
Samples
GetContentElement

Description
Get the Content's Element of WebPane

Parameters

Remarks

Return Value
object (HTML Element)
Samples
GetPanelFrameElement

Description
Get PanelFrame's Element of WebPane

Parameters

Remarks

Return Value

object (HTML Element)

Samples

GetInProgressText

Description
Get WebPane's InProgress Text

Parameters

Remarks

Return Value

String

Samples

SetContentURL Description
Set WebPane Content URL

Parameters
url (String)
Address of the URL

Remarks

Return Value

Samples


WebDesktopWindow Methods

WebDesktopWindow Methods
Send Feedback

Glossary Item Box

WebDesktopWindow Properties

GetWindowDivElement Description
Gets the HTML Div element of this WebDesktopWindow

Parameters

Remarks

Return Value
object (HTML Element)

Samples

GetCaptionBarCellElement Description
Gets the HTML caption bar cell element of WebDesktopWindow

Parameters

Remarks

Return Value
object (HTML Element)

Samples

GetControlBoxElement Description
Gets the HTML ControlBox element of WebDesktopWindow

Parameters

Remarks

Return Value
object (HTML Element)

Samples

GetCaptionBarTableElement Description
Gets the HTML Caption Bar Table element of WebDesktopWindow

Parameters

Remarks

Return Value
object (HTML Element)

Samples

GetInProgressText Description
Gets the progress text of this WebDesktopWindow

Parameters

Remarks

Return Value
String

Samples
GetContentDivElement Description
Gets the HTML Content Div Element of this WebDesktopWindow

Parameters

Remarks

Return Value
object (HTML Element)

Samples

GetDesktopManager Description
Gets the DesktopManager object where this WebDesktopWindow is created

Parameters

Remarks

Return Value
object (DesktopManager)

Samples

GetWindowOptionsCellElement Description
Gets the HTML Window Options Element of this WebDesktopWindow

Parameters

Remarks

Return Value
object (HTML Element)

Samples

GetControlBoxCellElement Description
Gets the HTML Control Box Cell Element of this WebDesktopWindow

Parameters

Remarks

Return Value
object (HTML Element)

Samples

GetMaximizeButtonElement Description
Gets the HTML Maximize Button Element of this WebDesktopWindow

Parameters

Remarks

Return Value
object (HTML Element)

Samples
GetCloseButtonElement Description
Gets the HTML Close Button Element of this WebDesktopWindow

Parameters

Remarks

Return Value
object (HTML Element)

Samples

GetMinimizeButtonElement Description
Gets the HTML Minimize ButtonElement of this WebDesktopWindow

Parameters

Remarks

Return Value
object (HTML Element)

Samples
IsActiveWindow Description
Check whether this WebDesktopWindow is the active window

Parameters

Remarks

Return Value
boolean

Samples
GetTaskBarButtonElement Description
Gets the HTML TaskBar Button Element of this WebDesktopWindow

Parameters

Remarks

Return Value
object (HTML Element)

Samples

GetWindowIFrameElement Description
Gets the HTML Window IFrame element of WebDesktop

Parameters

Remarks

Return Value
object (HTML Element)

Samples
MoveTo Description
Move this WebDesktopWindow to specific location that has been specified from the parameters

Parameters
x ( int )
the x coordinate of where this window will be moved
y ( int )
the y coordinate of where this window will be moved

Remarks

Return Value

Samples
MoveToCenterDesktop Description
Move the position of this WebDesktopWindow to the center of the desktop

Parameters

Remarks

Return Value

Samples

ResizeTo Description
Resize this WebDesktopWindow to specific width and height from the parameters

Parameters
width ( unit )
The width of the Window wants to be resized to
height ( unit )
The height of the Window wants to be resized to

Remarks

Return Value

Samples

Minimize Description
Minimize WebDesktopWindow

Parameters
raiseEvent ( boolean )
An inidicator of whether this minimize action will rise an event
runAnimation ( boolean )
An inidicator of whether this minimize action will run any animation

Remarks

Return Value

Samples

Maximize Description
Maximize this WebDesktopWindow

Parameters
raiseEvent ( boolean )
An inidicator of whether this maximize action will rise an event
runAnimation ( boolean )
An inidicator of whether this maximize action will run any animation

Remarks

Return Value

Samples

Restore Description
Restore this WebDesktopWindow

Parameters
raiseEvent ( boolean )
An inidicator of whether this restore action will rise an event

runAnimation ( boolean )
An inidicator of whether this restore action will run any animation

Remarks

Return Value

Samples

Close Description
Close this WebDesktopWindow

Parameters
raiseEvent ( boolean )
An inidicator of whether this close action will rise an event

Remarks

Return Value

Samples

Activate Description
Activate this WebDesktopWindow

Parameters

Remarks

Return Value

Samples

Show Description
Show this WebDesktopWindow

Parameters
shortcutDiv ( HTML element )
The HTML element of the shortcut

Remarks

Return Value

Samples

Hide Description
Hide this WebDesktopWindow

Parameters

Remarks

Return Value

Samples

BringToFront Description
Bring this WebDesktopWindow to the front of other windows

Parameters

Remarks

Return Value

Samples
SendToBack Description
Send this WebDesktopWindow to the back of other windows

Parameters

Remarks

Return Value

Samples

SetCaption Description
Sets the caption of this WebDesktopWindow

Parameters
text ( String )
The text that will be set as the caption of this WebDesktopWindow

Remarks

Return Value

Samples

SetControlBoxImage Description
Sets the control box image of this WebDesktopWindow

Parameters
imgURL ( String )
The image url that will be set as the ControlBoxImage

Remarks

Return Value

Samples

SetContentURL Description
Sets the content URL of this WebDesktopWindow

Parameters
url ( String )
The content url that will be set as the content url

Remarks

Return Value

Samples

LoadContent Description
Load the content of the Window

Parameters

Remarks

Return Value

Samples
SaveLocationAndSize Description
Save the location and size of this window

Parameters

Remarks

Return Value

Samples

IsTargetSizeValid Description
Check whether the Target size passed from the parameter is a valid size

Parameters
width ( unit )
the width of the target size
height ( unit )
the height of the target size

Remarks

Return Value

Samples

GetPreferredSize Description
Gets the preferred size of this Window

Parameters
width ( unit )
The width of the preferred size
height ( unit )
The height of the preferred size

Remarks

Return Value

Samples

GetNextWindow Description
Gets the next window from the parent WebDesktopManager

Parameters

Remarks

Return Value

Samples

GetPreviousWindow Description
Gets the previous window from the parent WebDesktopManager

Parameters

Remarks

Return Value

Samples

SetInlineContent Description
Sets the inline content from this WebDesktopWindow

Parameters
strHTML ( HTML element )
The String HTML to be set as the Inline Content for this WebDesktopWindow instance

Remarks

Return Value

Samples

SetBusy

Description
Sets the WebDesktopWindow to be busy

Parameters

Remarks

Return Value

Samples

SetIdle Description
Sets the WebDesktopWindow to be Idle

Parameters

Remarks

Return Value

Samples


WebDialogBox Methods

WebDialogBox Methods
Send Feedback

Glossary Item Box

WebDialogBox Methods

CreateWebDialogBox

Description
Create the WebDialogBox control.

Parameters

id (string)
Name of the control's id

Remarks

Return Value

object

Samples

ShowDialog Description
Show the WebDialogBox which by default is not shown.

Parameters

Remarks

Return Value

Samples

CloseDialog

Description
Close the WebDialogBox

Parameters

Remarks

Return Value

Samples
GetContentElement

Description
Gets the WebDialogBox's Content Element

Parameters

Remarks

Return Value

object (HTML Element)

Samples
GetContentWindow

Description
Gets the WebDesktop content window

Parameters

Remarks

Return Value

object (WebDesktopWindow)

Samples

FindControl

Description
Gets the Control inside WebDialogBox's TemplateContent

Parameters

id (string)
Name of the Control to be found

Remarks

Return Value

object

Samples

SetContentURL Description
Sets the content URL of this WebDialogBox

Parameters
url ( String )
The url that will be set as the content url.

Remarks

Return Value

Samples


WebContextMenu

WebContextMenu
Send Feedback

Glossary Item Box


WebContextMenuClientSideEvents

WebContextMenuClientSideEvents
Send Feedback

Glossary Item Box


WebContextMenu Properties

WebContextMenu Properties
Send Feedback

Glossary Item Box

WebContextMenu Properties

RootMenu | Description Gets or sets the root menu of this WebContextMenu instance. ValueType String Default Value
Items | Description Gets or sets the items collection this WebContextMenu instance. ValueType Collection ( ISArray) Default Value
ControlId | Description Gets or sets the control id of WebContextMenu instance. ValueType String Default Value
ClientSideEvents | Description Gets the ClientSideEvents of this WebContextMenu instance. ValueType WebContextMenuClientSideEvents Default Value


WebContextMenu Methods

WebContextMenu Methods
Send Feedback

Glossary Item Box

WebContextMenu Methods

ClearAll | Description Client side (Java Script) function that will clear all the WebContextMenuItem. Parameters Remarks Return Value Samples
Show | Description Client side (Java Script) function that will show this WebContextMenu instance. Parameters x ( int ) the x coordinate where the WebContextMenu will be shown. y ( int ) the y coordinate where the WebContextMenu will be shown. Remarks Return Value Samples
SetOffsetElement | Description Client side (Java Script) function to set the element which will be used as the offset when showing the WebContextMenu Parameters o ( HTML element ) The HTML Element which will be used as the offset Remarks Return Value Samples
HideAll | Description Client side (Java Script) function that will hide this WebContextMenu instance Parameters Remarks Return Value Samples
RefreshStructure | Description Client side (Java Script) function that will refresh the structure of this WebContextMenu instance Parameters Remarks Return Value Samples


WebContextMenuClientSideEvents Properties

WebContextMenuClientSideEvents Properties
Send Feedback

Glossary Item Box

WebContextMenuClientSideEvents Properties

OnInitialize | Description Specifies the client side (JavaScript) function that will be invoked when the WebContextMenu object is in initialization process. ValueType String Default Value
OnShowMenu | Description Specifies the client side (JavaScript) function that will be invoked when the WebContextMenu shows the menu. ValueType String Default Value
OnMenuItemClick | Description Specifies the client side (JavaScript) function that will be invoked when the WebContextMenu Item is clicked. ValueType String Default Value


WebMenu Properties
Send Feedback

Glossary Item Box

WebMenu Properties

Name | Description Gets or sets the name of this WebMenu instance. ValueType String Default Value
Items | Description Gets or sets the items collection in this WebMenu instance. ValueType Collection ( ISArray) Default Value
ParentMenu | Description Gets the WebContextMenu object which is the parent of this WebMenu instance. ValueType WebContextMenu Default Value
ParentMenuItem | Description Gets the WebContextMenuItem object which is the parent of this WebMenu instance. ValueType WebContextMenuItem Default Value
MenuControl | Description Gets or sets the menu control of this WebMenu instance. ValueType Default Value
DisplayMode | Description Gets or sets the display mode of this WebMenu instance. ValueType Default Value
IconViewMode | Description Gets or sets the icon view mode of this WebMenu instance. ValueType Default Value
ActiveItemIndex | Description Gets or sets the active item index for this WebMenu instance. ValueType Default Value
ActiveItem | Description Gets or sets the active item of this WebMenu instance. ValueType Default Value
Direction | Description Gets or sets the direction of this WebMenu instance. ValueType Default Value
OffsetAlignment | Description Gets or sets the offset alignment of this WebMenu instance. ValueType Default Value
Width | Description Gets or sets the width of this WebMenu instance. ValueType Default Value
Initialized | Description Gets or sets the value to indicate whether the WebMenu object is already initialized. ValueType Default Value
OffsetElement | Description Gets or sets the element which will be used as the offset for this WebMenu. ValueType Default Value
ScrollEnabled | Description Gets or sets the value to indicate whether the WebMenu object is scroll enabled. ValueType Default Value


WebMenu Methods

WebMenu Methods
Send Feedback

Glossary Item Box

WebMenu Methods

IsOpen | Description Determines whether WebMenu is opened. Parameters Remarks Return Value Boolean Samples
IsRootMenu | Description Determines the RootMenu of MenuBar. Parameters Remarks Return Value Boolean Samples
GetId | Description Gets the id of WebMenu. Parameters Remarks Return Value Samples
GetDocument | Description Returns the html element of the document used by the webmenu instance. Parameters Remarks Return Value Samples
GetElement | Description Gets the HTML element from current MenuBar instance. Parameters Remarks Return Value object (HTML element) Samples
GetMenuBodyElement | Description Gets the WebMenu's Menu body element. Parameters Remarks Return Value object (HTML element) Samples
GetScrollElement | Description Gets the WebMenu's Scroll Element. Parameters part ( ) The part of the scroll element. Remarks Return Value object (HTML element) Samples
GetSelectedItemByGroup | Description Gets the WebMenu's selected item according to its group. Parameters groupName ( ) Gets or sets the name for Menu Bar item which should appear in the same group. String Remarks Return Value Samples
Destroy | Description Destroys a menu bar after it has been removed. Parameters Remarks Return Value Samples
Show | Description Shows the WebMenu. Parameters x ( int ) the x coordinate where the WebMenu will be shown. y ( int ) the y coordinate where the WebMenu will be shown. Remarks Return Value Samples
Hide | Description Hides the WebMenu. Parameters Remarks Return Value Samples
Invalidate | Description Refresh the user interface. Parameters Remarks Return Value Samples


WebMenuSeparatoItem Properties

WebMenuSeparatoItem Properties
Send Feedback

Glossary Item Box

WebMenuSeparatorItem Properties

Type Description
Gets or sets the type of WebMenu control.

ValueType
String

Default Value


WebMenuRadioItem Properties

WebMenuRadioItem Properties
Send Feedback

Glossary Item Box

WebMenuRadioItem Properties

GroupName | Description Gets or sets the name for radio menu item which should appear in the same group. ValueType WebMenuRadioItem Default Value
Checked | Description Determines whether the current WebMenuRadioItem is checked. ValueType Boolean Default Value


WebMenuCheckBoxItem Properties

WebMenuCheckBoxItem Properties
Send Feedback

Glossary Item Box

WebMenuCheckBoxItem Properties

Type | Description Gets or sets the type of WebMenuCheckBoxItem control. ValueType WebMenuCheckBoxItem Default Value
Checked | Description Determines whether the current WebMenuCheckBoxItem is checked. ValueType Boolean Default Value


WebMenuItem Properties

WebMenuItem Properties
Send Feedback

Glossary Item Box

WebMenuItem Properties

Name | Description Gets the name of the WebMenuItem control. ValueType String Default Value
Index | Description Gets or sets the index of the WebMenuUItem object. ValueType String Default Value
Collection | Description Gets the Collection that contains the WebMenuItem. ValueType Array Default Value
ParentMenu | Description Gets the ParentMenu of WebMenuItem. ValueType WebMenuItem Default Value
SubMenu | Description Gets the SubMenu of this WebMenuItem. ValueType WebMenuItem Default Value
OwnerMenu | Description Gets the OwnerMenu of this WebMenuItem. ValueType WebMenuItem Default Value
Items | Description Gets the Items collection of WebMenuItem. ValueType WebMenuItem Default Value
Type | Description Gets or sets the type of WebMenuItem control. ValueType WebMenuItem Default Value
Text | Description Gets or sets the text caption displayed in the WebMenuItem control ValueType String Default Value
ImageURL | Description Gets or sets the images URL link in WebMenuItem ValueType String Default Value
OnClick | Description Specifies the client-side function to be invoked when a client performs a click event ValueType String Default Value
KeepMenuVisible | Description Indicates whether the menu which own this item should be kept visible after clicked. ValueType Boolean Default Value False
Enabled | Description Gets the value that indicates whether the WebMenuItem control is enabled. ValueType Boolean Default Value True
AccessKey | Description Sets or retrieves the keyboard shortcut key for setting focus to the Command. ValueType String Default Value
Shortcut | Description Gets or sets the shortcut key for the menu item, which will invoke the associated command when pressed. ValueType WebMenuItem Default Value
Tooltip | Description Gets or sets the tool tip text that will be displayed on mouse over action. ValueType String Default Value
Visible | Description Gets the value that indicates whether the control is visible. ValueType Boolean Default Value True
TargetURL | Description Gets or sets the target URL of WebMenuItem. ValueType String Default Value
TargetFrame | Description Gets or sets the target frame where the URL specified in TargetURL should be displayed. ValueType WebMenuItem Default Value
GroupName | Description Gets or sets the name for radio menu item which should appear in the same group. ValueType String Default Value
IconViewDisplayMode | Description Gets or sets the display mode when the menu is operating in IconView mode. ValueType WebMenuItem Default Value
IconViewMode | Description Specifies whether this menu should be displayed in IconViewMode. ValueType Boolean Default Value False
UseFontImage | Description Indicates whether font should be used as replacement for Image. When set to True, the text specified in ImageURL will be rendered using WebDings font. ValueType Boolean Default Value False
AutoPostBack | Description Specifies whether Postback will be automatically invoked when the MenuItem is clicked ValueType Boolean Default Value False
Selected | Description Determines whether the current menu item is selected. ValueType Boolean Default Value
Checked | Description Gets or sets whether this menu item is checked. This property only applicable to menu item which Type is either Radio or CheckBox. ValueType Boolean Default Value False
PredefinedId | Description The predefined identifier for this item. ValueType String Default Value
IsPredefinedItem | Description Indicates whether this menu item is a predefined item. This flag is used to mark built-in menu items used in other Intersoft's product. ValueType Boolean Default Value False
CustomElement | Description Specify the custom element for the menu item which Type is Custom. ValueType String Default Value


WebMenuItem Methods

WebMenuItem Methods
Send Feedback

Glossary Item Box

WebMenuItem Methods

IsUsingImageIconViewMode | Description Determines whether WebMenuItem is using ImageIconViewMode Parameters Remarks Return Value Boolean Samples
ScrollIntoView | Description To scroll the menu item into view, when scrolling is enabled. Parameters Remarks Return Value Samples
GetElement | Description Gets the HTML element from current WebMenuItem instance. Parameters Remarks Return Value object (HTML element) Samples
HasSubMenu | Description Determines whether WebMenuItem has SubMenu collection. Parameters Remarks Return Value Boolean Samples
Click | Description Performs click action on WebMenuItem. Parameters Remarks Return Value Samples
GetPreviousSelectableItem | Description Gets the previous Selectable Item. Parameters Remarks Return Value Samples
GetNextSelectableItem | Description Gets the next Selectable Item. Parameters Remarks Return Value Samples
SetChecked | Description Sets a menu item which Type is Radio or CheckBox to Checked state. Parameters isChecked It will set the item as checked. if it is false, then it will be unchecked. fromCode ( ) It needs to be set to true when called from API call. Remarks Return Value Samples
Enable | Description Enables the WebMenuItem control Parameters Remarks Return Value Samples
Disable | Description Disables the WebMenuItem control Parameters Remarks Return Value Samples
Show | Description Client side (Java Script) function that will show this WebMenuItem instance. Parameters Remarks Return Value Samples
Hide | Description Client side (Java Script) function that will hide this WebMenuItem instance. Parameters Remarks Return Value Samples
SetText | Description Sets the text property of WebMenuItem. Parameters text (String) Text of the WebMenuItem String Remarks Return Value Samples
SetImage | Description Sets WebMenuItem's Image URL. Parameters imageURL (url(String)) Address of the image URL Remarks Return Value Samples
Destroy | Description Destroys a menu item after it has been removed. Parameters Remarks Return Value Samples
Delete | Description Deletes the WebMenuItem control. Parameters Remarks Return Value Samples
Unselect | Description Deselect the WebMenuItem. Parameters Remarks Return Value Samples
IsSelected | Description Determines whether the WebMenuItem is selected. Parameters Remarks Return Value Boolean Samples
Select | Description Selects the WebMenuItem. Parameters unselectPreviousItem ( ) Deselect the previous MenuItem. Remarks Return Value Samples
IsSubMenuOpen | Description Determines whether SubMenu of WebMenuItem is opened. Parameters Remarks Return Value Boolean Samples


WebNavPane Properties

WebNavPane Properties
Send Feedback

Glossary Item Box

WebNavPane Properties

Id | Description The ID of the control ValueType String Default Value
NavType | Description Gets or sets the NavType of this WebNavPane instance ValueType NavType Default Value
BarItems | Description Gets the collection of WebNavBar items in this WebNavPane ValueType Collection (ISArray) Default Value
ActiveBarIndex | Description Gets or sets the active WebNavBar index inside this WebNavPane object ValueType int Default Value
AllowResize | Description Gets or sets the value to indicate whether the WebNavPane object is allowed to be resized ValueType boolean Default Value
BarItemSettings | Description Gets or sets the WebNavBar item settings in this WebNavPane object ValueType BarItemSettings Default Value
BarSettings | Description Gets or sets the WebNavBar settings in this WebNavPane object ValueType BarSettings Default Value
FooterSettings | Description Gets or sets the footer settings in WebNavPane object ValueType FooterSettings Default Value
BarVisible | Description Gets or sets the value to indicate whether the WebNavBar is visible in WebNavPane Object ValueType boolean Default Value
ImagesDirectory | Description Gets or sets the images directory in this WebNavPane object ValueType String Default Value
OnBarClick | Description Specifies the client side (Java Script) function that will be invoked when the bar is clicked ValueType String Default Value
OnBarItemClick | Description Specifies the client side (Java Script) function that will be invoked when the bar item is clicked ValueType String Default Value
OnPaneResize | Description Specifies the client side (Java Script) function that will be invoked when the pane is resized ValueType String Default Value
OnInitialize | Description Specifies the client side (JavaScript) function that will be invoked when the WebNavPane object is in initialization process. ValueType String Default Value
OnClientUnload | Description Specifies the client side (JavaScript) function that will be invoked when client object is in unload process. ValueType String Default Value


WebNavPane Methods

WebNavPane Methods
Send Feedback

Glossary Item Box

WebNavPane Methods

ResolveImagePath | Description Resolves the image path Parameters img ( String ) path of the image Remarks Return Value Samples
GetCaptionElement | Description Gets the HTML Caption element of WebNavPane object Parameters Remarks Return Value object (HTML element) Samples
GetGripElement | Description Gets the HTML Grip element of WebNavPane object Parameters Remarks Return Value object (HTML element) Samples
GetFooterElement | Description Gets the HTML Footer element of WebNavPane object Parameters Remarks Return Value object (HTML element) Samples
GetActiveBar | Description Gets the active WebNavBar instance inside this WebNavPane Parameters Remarks Return Value object (WebNavBar) Samples
SetActiveBar | Description Sets the active WebNavBar instance inside this WebNavPane Parameters idx ( int ) The index of the active WebNavBar instance Remarks Return Value Samples


WebNavBar Properties

WebNavBar Properties
Send Feedback

Glossary Item Box

WebNavBar Properties

Name | Description Gets or sets the name of this WebNavBar instance ValueType String Default Value
Index | Description Gets or sets the index of this WebNavBar instance ValueType int Default Value
Size | Description Gets or sets the size of this WebNavBar instance ValueType unit size Default Value
Text | Description Gets or sets the text of this WebNavBar instance ValueType String Default Value
Image | Description Gets or sets the image of this WebNavBar instance ValueType String Default Value
ImageSize | Description Gets or sets the image size of this WebNavBar instance ValueType unit size Default Value
ToolTip | Description Gets or sets the tooltip of this WebNavBar instance ValueType String Default Value
Visible | Description Gets or sets the value to indicate whether this WebNavBar instance is visible ValueType boolean Default Value
Enabled | Description Gets or sets the value to indicate whether this WebNavBar instance is enabled ValueType boolean Default Value
Collapse | Description Gets or sets the value to indicate whether this WebNavBar instance is collapsed ValueType boolean Default Value
CaptionDisplayMode | Description Gets or sets the caption display mode of this WebNavBar instance ValueType CaptionDisplayMode Default Value
CaptionStyle | Description Gets or sets the caption style of this WebNavBar instance ValueType WebStyle Default Value
Items | Description Gets or sets the items in this WebNavBar instance ValueType Collection (ISArray) Default Value
ActiveBarItemIndex | Description Gets or sets the active WebNavBarItem index of this WebNavBar instance ValueType int Default Value
ContentMode | Description Gets or sets the content mode of this WebNavBar instance ValueType ContentMode Default Value
ContentURL | Description Gets or sets the content URL of this WebNavBar instance when using IFrame as ContentMode ValueType String Default Value
IFrameContentLoaded | Description Gets IFrameContentLoaded status of this WebNavBar instance ValueType boolean Default Value
ItemSettings | Description Gets or sets the ItemSettings of this WebNavBar instance ValueType ItemSettings Default Value
CaptionText | Description Gets or sets the CaptionText of this WebNavBar instance ValueType String Default Value


WebNavBar Methods

WebNavBar Methods
Send Feedback

Glossary Item Box

WebNavBar Methods

GetActiveBarItem | Description Gets the active WebNavBar Item Parameters Remarks Return Value object ( WebNavBarItem) Samples
GetItemsContainerElement | Description Gets the HTML Items Container element of this WebNavBar instance Parameters Remarks Return Value object (HTML element) Samples
GetIFrameElement | Description Gets the HTML IFrame element of this WebNavBar instance Parameters Remarks Return Value object (HTML element) Samples
GetImageElement | Description Gets the HTML Image element of this WebNavBar instance Parameters Remarks Return Value object (HTML element) Samples
GetTextElement | Description Gets the HTML Text element of this WebNavBar instance Parameters Remarks Return Value object (HTML element) Samples
GetElement | Description Gets the HTML element of this WebNavBar instance Parameters Remarks Return Value object (HTML element) Samples
GetFooterElement | Description Gets the HTML footer element of this WebNavBar instance Parameters Remarks Return Value object (HTML element) Samples
IsActive | Description Gets the value indicating whether this WebNavBar instance is currently active Parameters Remarks Return Value boolean Samples
SetCaption | Description Sets the caption of this WebNavBar instance Parameters caption ( String ) Caption to be set for this WebnavBar instance Remarks Return Value Samples
SetImage | Description Sets the image of this WebNavBar instance Parameters img ( String ) path of the image Remarks Return Value Samples
SetDisable | Description Disabled this WebNavBar instance Parameters Remarks Return Value Samples
SetEnable | Description Enabled this WebNavBar instance Parameters Remarks Return Value Samples
SetActive | Description Activated this WebNavBar instance Parameters Remarks Return Value Samples
Click | Description Trigger the click event of this WebNavBar instance Parameters Remarks Return Value Samples


WebNavBarItem Properties

WebNavBarItem Properties
Send Feedback

Glossary Item Box

WebNavBarItem Properties

Name | Description Gets or sets the name of this WebNavBarItem instance ValueType String Default Value
Index | Description Gets or sets the index of this WebNavBarItem instance ValueType int Default Value
Text | Description Gets or sets the text of this WebNavBarItem instance ValueType String Default Value
Image | Description Gets or sets the image of this WebNavBarItem instance ValueType String Default Value
ImageSize | Description Gets or sets the image size of this WebNavBarItem instance ValueType unit Default Value
ToolTip | Description Gets or sets the tooltip of this WebNavBarItem instance ValueType String Default Value
Enabled | Description Gets or sets the value to indicate whether this WebNavBarItem instance is enabled ValueType boolean Default Value true
DisplayMode | Description Gets or sets the display mode of this WebNavBarItem instance ValueType DisplayMode Default Value
ImagePosition | Description Gets or sets the image position of this WebNavBarItem instance ValueType ImagePosition Default Value
Visible | Description Gets or sets the value to indicate whether this WebNavBarItem instance is visible ValueType boolean Default Value true
TargetURL | Description Gets or sets the target URL of this WebNavBarItem instance ValueType String Default Value
TargetWindow | Description Gets or sets the target window of this WebNavBarItem instance ValueType String Default Value


WebNavBarItem Methods

WebNavBarItem Methods
Send Feedback

Glossary Item Box

WebNavBarItem Methods

GetElement | Description Gets the HTML element of this WebNavBarItem instance Parameters Remarks Return Value Object (HTML Element) Samples
IsActive | Description Gets the value indicating whether this WebNavBarItem instance is currently active Parameters Remarks Return Value boolean Samples
Click | Description Trigger the click event of this WebNavBarItem instance Parameters Remarks Return Value Samples


WebNavBarSettings Properties

WebNavBarSettings Properties
Send Feedback

Glossary Item Box

WebNavBarSettings Properties

CaptionDisplayMode | Description Gets or sets the caption display mode of this WebNavBarSettings ValueType DisplayMode Default Value
ContentMode | Description Gets or sets the content mode of this WebNavBarSettings ValueType ContentMode Default Value
ImageSize | Description Gets or sets the image size of this WebNavBarSettings ValueType unit Default Value
Size | Description Gets or sets the size of this WebNavBarSettings ValueType unit Default Value
Image | Description Gets or sets the image of this WebNavBarSettings ValueType String Default Value


WebNavBarItemSettings Properties

WebNavBarItemSettings Properties
Send Feedback

Glossary Item Box

WebNavBarItemSettings Properties

DisplayMode | Description Gets or sets the display mode of this WebNavBarItemSettings ValueType DisplayMode Default Value
ImagePosition | Description Gets or sets the image position of this WebNavBarItemSettings ValueType ImagePosition Default Value
ImageSize | Description Gets or sets the image size of this WebNavBarItemSettings ValueType unit Default Value
TargetWindow | Description Gets or sets the target window of this WebNavBarItemSettings ValueType String Default Value


WebNavPaneFooterSettings Properties

WebNavPaneFooterSettings Properties
Send Feedback

Glossary Item Box

WebNavPaneFooterSettings Properties

ImageSize Description
Gets or sets the image size in this WebNavPaneFooter

ValueType
unit

Default Value


What's New in WebToolBar

What's New in WebToolBar
See Also Send Feedback
Intersoft WebDesktop > WebToolBar > What's New in WebToolBar

Glossary Item Box

WebToolBar delivers a desktop toolbar experience equal to that of Microsoft Office 2007. Faithfully replicating the Office 2007 toolbar style and behaviors, it features sliding visual effects, docking, and more.

In version 4, WebToolBar has been refined to fully support the latest web standards. This allows you to use many of the WebToolBar features in your next-generation web applications and at the same time leveraging cutting-edge technologies such as HTML5 and CSS3.

Following are list details of the enhancements and new features introduced in WebToolBar:

  • New intuitive style in WebToolBar

    In version 4, WebDesktop presents a new style in each of its control. Metro style as the latest UI in Windows 8 have been implemented and becomes brand new UI in WebDesktop control. Metro style makes WebDesktop simpler, tidier, and more attractive for each control’s UI. The intuitive design of Metro style also provide consistency of each control in HTML5.

    You can simply use Layout Manager to implement Metro style in WebDesktop.

    For more information on how to apply this configuration, see How-To: Using Layout Manager.

See Also

WebToolBar

Features
Features


What's New in PlaceHolderManager

What's New in PlaceHolderManager
Send Feedback

Glossary Item Box

A PlaceHolderManager represents four-edge partitioned table, where each side acts as a container for docking, and the middle area acts as the content placeholder.

In version 4, PlaceHolderManager has been refined to fully support the latest web standards. This allows you to use many of the PlaceHolderManager features in your next-generation web applications and at the same time leveraging cutting-edge technologies such as HTML5 and CSS3.

Following are list details of the enhancements and new features introduced in PlaceHolderManager:

  • Fluid Layout with HTML5 doc type

    It is very common to have the height of PlaceHolderManager fill the available space vertically. Here, available space means space of its parent control. If the height of parent control is not 100% then height of the table couldn’t be 100%.

    If we are trying to set 100% height of the table directly contained the body of an html page then we will need to set the height of the body and html first.

    The same thing applies when users resize the window of PlaceHolderManager.


Features

Features
See Also Send Feedback
Intersoft WebDesktop > WebToolBar > Features

Glossary Item Box

WebToolBar is one of essential member in WebDesktop.NET which allows you to create rich toolbar functions in the rich styles and behaviors of desktop's ToolBar. WebToolBar offers a set of advanced and unique features such as in the following:

  • TrueShape

    TrueShape is an innovative rendering technology which enables round corner shape to be rendered without the needs to use images. It is called TrueShape, because it does not only capable to render round corner between four edges, it also has the ability to blend perfectly into transparent background and filled gradient. With all these capabilities, you can create any kind of themes, for example, the blue Theme of Office Toolbar style or the silver theme, or any colors blending you liked. TrueShape technology is the beginning of new web applications model.

  • TrueDock

    TrueDock is the only correct implementation today which allowing end users to dock a ToolBar into four edges of designated content area. It is a truly powerful docking technology recognizing its capabilities to intelligently dock into multiple bars or dock into the same row in any edges. TrueDock automatically maintain its configuration and adjust required settings when the docking changed from horizontal to vertical position. All of these capabilities enable you to offer a high level of user interactivity and personalization for your end users.

  • Docking and Floating

    WebToolBar can be configured as docking and floating. For Docking mode, it allows you to freely customize the docking position of WebToolBar in the PlaceHolderManager, such as left, right, top and bottom. For Floating mode, it allows you to set the WebToolBar to be floated whenever you drag the WebToolBar.

  • Rich ToolCommand Types

    WebToolBar has several command types for its Items. These ToolCommand's Types consist of : Button, Toggle Button, DropDown Button, Split Button, Separator, Custom, and Container. To know how to configure ToolCommand Types, you may refer to Using ToolCommand Types tutorials section.

  • Stand Alone and Integration Mode

    Stand Alone mode is best applied when you want to use the component in a single page which does not hosted in DesktopManager, whereas Integration mode is best applied when components are in the page which is hosted in DesktopManager and used Docking feature.

  • ToolBar Merging

    WebToolBar introduces Merging feature which allows you to Merge ToolBar from your parent page with child page. There are 2 types of Merging, which are ToolBar Merging and ToolCommand Merging. ToolBar Merging is used to combine Parent ToolBar with Child ToolBar from different pages. Hence, it will merge the whole ToolBars. ToolCommand Merging is slightly different compared to ToolBar Merging. It does not merge the whole ToolBar, but it does merge the ToolCommand instead. Hence, the Child's ToolCommand will be merged to Parent's ToolCommand using the container.

    Parent ToolBar

    Child ToolBar

    ToolBar Merging

    ToolCommand Merging
  • Predefined Styles

    WebToolBar gives you a convenience way to define your own style or to use the predefined styles to create a stylish and professional looking ToolBar in minutes.

  • ToolCommand Events

    WebToolBar introduces numerous client side events that you can implement in order to create rich interaction and extensible web applications. Following is the list of available client-side events:

    - OnClick
    - OnDblClick
    - OnMouseDown
    - OnMouseMove
    - OnMouseOut
    - OnMouseOver
    - OnMouseUp

    The OnMouseUp event is the best event handler where you can put your codes to perform some actions for the ToolBar Button such as open new window, save documents, exit from application, etc. For instance, you may want to display a WebDialogBox, you can use OnMouseUp Event to perform this action.

    The parameters passed to the events will be automatically created when you select "Add new handler..." on CommandClientSideEvents in Properties window.

See Also

Related Topics
{Overview}
{PlaceHolderManager Concept}
{Understanding ToolBar Architecture}
{Rich Design-time Experience}
{Working with ToolBar Designer}
{Using Customization Dialog Box}


PlaceHolderManager Concept

PlaceHolderManager Concept
See Also Send Feedback
Intersoft WebDesktop > WebToolBar > PlaceHolderManager Concept

Glossary Item Box

Introduction

A PlaceHolderManager represents a partitioned container in a WebForm which supports docking capabilities for IBar implemented controls. In this release, PlaceHolderManager can be used with following components:

  • WebMenuBar
  • WebToolBar

The main objective of the PlaceHolderManager is to enable a certain zone in the WebForm to be marked as "dockable boundaries". This is also called PlaceHolderManager's Container. The container can be one of the following type:

  • Html Server Control DIV
  • Html Server Control TABLE

At component design, the PlaceHolderManager is a non-visual server side control which can be instantiated by dropping it from ToolBox. The PlaceHolderManager is also accompanied with a new innovative PlaceHolder Designer to let developers work easily with the PlaceHolderManager and the contained Bars.

The following illustration shows the PlaceHolderManager Concept in overall.

With the modular design of the PlaceHolderContainer, you can attach the container at any level in your WebForm instead the main view of the Form. For instance, you might have an existing Layout of "Header, Side and Footer". You can put the container inside the "Side" content and the docking zone will only be applicable to the specified Side zone.
The PlaceHolderManager also supports more than 1 instance in a WebForm Page. So you can put more than one dockable zone in one page scenario which oftenly needed in complex application.

Features

PlaceHolderManager offers several advanced features such as provided in the following:

  • Automatic Resizing
  • MaxDockingRows
  • FillDockingRow
  • DockingArea
  • DockingOffset
  • Individual AllowDocking container for default properties and styles, automatic resizing, maxdockingrows, filldockingrow, samerowdocking

Integration

One of the key benefit of PlaceHolderManager is its tight integration with IBar implemented controls. The PlaceHolderManager acts as the manager for all bars that it owned. PlaceHolderManager contains all master configurations such as styles and behaviors of the ToolBar and MenuBar.

The tight integration feature significantly improves developer's productivity with the global configurations managed by the PlaceHolderManager, since you do not have to configure the style or behavior of all Bars individually (especially when there are large number of Bars in the WebForm).

The other popular benefit of the integration is the clean tags and reduced HTML output for the Bars server control definition. Each Bar typically would only need to have the Collection definition since other behaviors and the styles are inherited automatically from its PlaceHolderManager.

To integrate a Bar into specific PlaceHolderManager, you can simply set the PlaceHolder property. By default, when you drop a new Bar from ToolBox to the designer surface, the Bar will automatically looking for the default PlaceHolderManager instance, set its PlaceHolder property to the PlaceHolderManager's ID and finally set its IntegratedTo property to PlaceHolderManager. For more information on how the PlaceHolderManager works in design time, see Interactive PlaceHolderManager Designer.

The following illustration shows a snapshot of PlaceHolderManager properties and ToolBar properties. You can notice that most of ToolBar's properties are set to Default, which means the value will be obtained from its PlaceHolderManager.

As seen in above illustration, when a Bar is integrated into PlaceHolderManager, you can not customize the individual styles of the ToolBar. Notice that the BodyStyle, HandleStyle, and the rest styles can no longer be expanded (no + sign). However, the behaviors can still be customized at individual level, that is by changing the property's value from Default to other available value.

When to use PlaceHolderManager

In this section, provided are some recommendations on best practices for using PlaceHolderManager.

Use PlaceHolderManager when:

  • The page requires docking functionalities.
  • The page contains more than one bar instance.
  • The page requires bars which is customizable (through AllowCustomize).
  • The page contains multiple type of Bars. For instance, MenuBar and ToolBar.
  • The page requires visual styles consistency of all Bars, and style inherittance from DesktopManager.

Do not use PlaceHolderManager when:

  • The page contains only one instance of Bar and there are no intentions to add more Bars in the future.
  • The page contains bars which doesn't require docking functionalities.
When a Bar is working in standalone mode, the drag and drop functionality (AllowMove) of the Bar will be disabled at runtime, as well as other manager-dependent features such as AllowCustomize, Merging etc.

See Also

Related Topics
{Overview}
{Features}
{Understanding ToolBar Architecture}
{Rich Design-time Experience}
{Working with ToolBar Designer}
{Using Customization Dialog Box}


Understanding ToolBar Architecture

Understanding ToolBar Architecture
Send Feedback
Intersoft WebDesktop > WebToolBar > Understanding ToolBar Architecture

Glossary Item Box

Introduction

One of WebToolBar most powerful features is its ability to imitate the command button's behavior of common Desktop's Application. This section will illustrate the architecture of WebToolBar corresponds to its Command Types.

WebToolBar's Architecture

WebToolBar can be placed either inside/outside (standalone mode) a place holder. The advantages of having a WebToolBar inside a place holder is the ability to perform two innovative actions ("merging" and "docking").

In general the Architecture can be represent as follows :

ISNet.WebUI.WebDesktop.PlaceHolderManager
ISNet.WebUI.WebDesktop.WebToolBar
ISNet.WebUI.WebDesktop.ToolCommand
ISNet.WebUI.WebDesktop.CommandType.Button
ISNet.WebUI.WebDesktop.CommandType.ToggleButton
ISNet.WebUI.WebDesktop.CommandType.DropDownButton
ISNet.WebUI.WebDesktop.WebMenuItem
ISNet.WebUI.WebDesktop.CommandType.SplitButton
ISNet.WebUI.WebDesktop.WebMenuItem
ISNet.WebUI.WebDesktop.CommandType.Separator
ISNet.WebUI.WebDesktop.CommandType.Custom
ITemplate
ISNet.WebUI.WebDesktop.CommandType.Container
(ISNet.WebUI.WebDesktop.WebToolBar)

Merging

WebToolBar implements unique merging capabilities which allow you to merge bars contained in a different page (typically inside IFrame) into parent WebToolBar contained in parent window. The merging feature enables a better scalability to your application design, where you can define the WebToolBar's items specific to a module inside that Page, instead of defining every functions in the same parent Page. This approach also solved extensibility issues where page developers can work and extend their own modules without has to modify the parent container Page.

There are two type of merging :

  • Bar Merging
    In Bar Merging we merge another WebToolBar (let say WebToolBar2) from another page into PlaceHolderManager where WebToolBar1 resides.
    WebToolBar1 (Parent)

    WebToolBar2

    Merged WebToolBar

  • Command Merging
    In Command Merging we merge another WebToolBar (let say WebToolBar2) from another page into WebToolBar1 CommandType which type of Container.
    WebToolBar1 (Parent)

    WebToolBar2

    Merged WebToolBar

Docking

WebToolBar also has Docking Capability just like the common Desktop Application's ToolBar. To enable the Docking Capability we need to Integrate the WebToolBar with PlaceHolderManager (see PlaceHolderManager Concept).

Command Types

As you can see from the Architecture above, WebToolBar has built-in command types which use to imitate the original behavior of ToolBar in Desktop's Application. Those built-in command types are :

  • Button
    Button Type is the most common type in any ToolBar. It simply represent a button behavior in toolBar.
  • ToggleButton
    ToggleButton is a button that has select and unselect state. This type of button can be either used in a group of toggle buttons (linked with Toggle's GroupName) or act in SingleMode.
    Usually a SingleMode ToggleButton is used for as a flag to set active/inactive of certain state. On the other hand a GroupMode ToggleButton is used as a selection from several states that included in the Toggle Group.
  • DropDownButton
    DropDown Button consist of sub items (Collection of WebMenuItem) where each of sub items then can have it owns action
  • SplitButton
    Similar with DropDown Button, it consist sub items (Collection of WebMenuItem), however unlike DropDown Button, the SplitButton's parent command can also have it own action.
  • Custom
    Using the ITemplate to design the custom command type for WebToolBar ensure the flexibility to use any control(s) to represent a command type in WebToolBar
  • Container
    One of key features of WebToolBar is ability to merge two or more WebToolBars inside a given WebTolBar, this can be achieved using Container Type where it will act as the container for the merged WebToolbar


Live Demo

Live Demo
Send Feedback

Glossary Item Box


Rich Design-time Experience

Rich Design-time Experience
See Also Send Feedback
Intersoft WebDesktop > WebToolBar > Rich Design-time Experience

Glossary Item Box

Introduction

WebDesktop.NET provides an innovative way to enhance the process at design-time. Related to WebToolBar there are two particular designers which very useful, they are Visual Menu Builder and Interactive PlaceHolderManager Designer.

These two designers are intended to give some visualization and ease the process when the design-time is take place.

Interactive PlaceHolderManager Designer

Interactive PlaceHolderManager Designer allows us to configure the docking area easily and at the same time give us freedom to works on the content of PlaceHolder directly.

The PlaceHolderManager structure is represented as a four-edge partitioned table, where each side acts as a container for docking, and the middle area acts as the content placeholder.

Using this interactive PlaceHolderManager Designer, the WebToolBar can be placed directly to any docking area by just clicking and dragging the object. Furthermore the content placeholder type is not a ITemplate, which mean any content/controls can be placed directly in it and later on it can be accessed in code behind without has to use FindControl.

For further information see Interactive PlaceHolderManager Designer Topic

Visual Menu Builder

WebToolBar has a builtin capability to show DropDown Buttons and Split Buttons. Managing these DropDownButtons and SplitButtons menu items might be hectic, because it might need to go deep inside the designer. This is the time where Visual Menu Builder can help.

With a visualization of a WinForm menu editor, the Visual Menu Builder is intended to allow us easily and quickly define menu items (add/insert/delete), and also at the same time manage the properties of each menu object.

For more information see Visual Menu Builder Topic

See Also

Related Article
Interactive PlaceHolderManager Designer
Visual Menu Builder

© 2012 Intersoft Solutions Corp. All Rights Reserved.

© 2012 Intersoft Solutions Corp. All Rights Reserved.


Working with ToolBar Designer

Working with ToolBar Designer
See Also Send Feedback
Intersoft WebDesktop > WebToolBar > Working with ToolBar Designer

Glossary Item Box

Introduction

WebToolBar has lots of features that might not be able to be discovered directly. WebToolBar provides some additional Designers to help you configuring the WebToolBar as easy as possible. Overall there are two additional designers which serve its own purposes, both designers focus and highlight specific details so hopefully it give you some pictures what the WebToolBar can do.

WebToolBar Designer

WebToolBar Designer is the common designer that Intersoft Component has, and also the complete designer which used to handle all property management of WebToolBar. In addition, the structure of WebToolBar can also be managed using StructureManager.

In general WebToolBar Designer is divided into two Main tabs:

  • Properties

Properties Tab is use to manage all Property that WebToolBar has, it also separate some specific detail such as Client Side Events, Default Styles, and Commands into sub category.

  • Client Side Events

This sub category used to manage WebToolBar Client Side Events.

Note: when using the WebToolBar Designer you can not use the automatic function generation, to generate WebToolBar ClientSide Events.

    • Default Styles
      This sub category used to manage all the WebToolBar Default's Styles.

    • Commands
      This sub category used to manage WebToolBar's Command Type. You can add/remove/re-order the command and also manage the properties.

  • Structure Manager

Structure Manager is use to manage the structure of WebToolBar, so you can save / load the structure for later used.

WebToolBar Quick Designer

WebToolBar Quick Designer is a more specific Designer, it focus on properties that related to WebToolBar Features.

In general WebToolBar Quick Designer is divided into three Main tabs :

  • Bar

Bar Tab focus on properties that relate to WebToolBar's Features.

    • Style
      You can select predefined style that WebToolBar provide
    • Display
      This category focus on WebToolBar runtime Display.
      You can configure whether the WebToolBar can have Customization DialogBox or not.
      In addition you can also set the WebToolBar whether it will fill the docking row or not (Using True Fill Technology)
    • Merged ToolBar
      This category focus on WebToolBar merging capability. You can configure the merging settings from this designer.
    • PlaceHolderManager
      This category focus on where the WebToolBar should be place on.
  • Docking

Docking section focus on the Docking Layout configuration. This docking layout informs the WebToolBar the position to where it can be docked to.

  • Command

Command Tab focus on Command Type's Appearance, you can set the General settings for all CommandTypes of WebToolBar. The settings include Display Mode, Display ToolTips, and Text Alignment.

Visual Menu Builder

Visual Menu Builder is another Designer that integrated to WebToolBar, it used to help you managing WebToolBar CommandTypes of type DropDown Buttons and Split Buttons.

Previously you need to go deep through Properties to manage the menu items. This Designer give you some visualization to manage DropDown Buttons and Split Buttons menu items you can manage and see the result directly in the designer.

For more information see Visual Menu Builder Topic

See Also

Related Article
Visual Menu Builder

© 2012 Intersoft Solutions Corp. All Rights Reserved.

© 2012 Intersoft Solutions Corp. All Rights Reserved.


Using Customization Dialog Box

Using Customization Dialog Box
Send Feedback
Intersoft WebDesktop > WebToolBar > Using Customization Dialog Box

Glossary Item Box

Introduction

Like the common Desktop's ToolBar, WebToolBar also implemented a Customization DialogBox. Customization DialogBox is a feature which allows the user to configure the WebToolBar(s) settings at run-time. One of benefit having this feature is the customized WebToolBar, where the user can modify it to their own requirement, which later on the structure can be saved to xml.

Enabling Customization

To enable WebToolBar's Customization, you need to set the property AllowCustomize to "True"

After that in the runtime you'll see arrow picture at the right side of your WebToolBar. To access it, simply click on the arrow picture.

Using Customization

By enabling Customization DialogBox, the WebToolBar can be configured at runtime. The most direct functionality is to add/remove command types of the specific WebToolBar where the command types can be customized to be shown or hidden.

The other functionalities of this Customization DialogBox, is to customize all WebToolBars which reside in the same PlaceHolderManager. Things that can be customized are categorized as follows:

  • ToolBars

    Manage the existence of WebToolBar, which one should be activated/deactivated and also ability to add/remove a WebToolBar
  • Commands

    Manage (Add/Remove/Exchange) Command Types between Toolbars which reside in the same PlaceHolderManager
  • Options

    Configure Menus and WebToolBars settings.


Working with PaneManager Editor

Working with PaneManager Editor
Send Feedback

Glossary Item Box


Tutorials

Tutorials
Send Feedback
Intersoft WebDesktop > WebToolBar > Tutorials

Glossary Item Box

This section contains tutorial topics in WebToolBar

In This Section

Creating Dockable Toolbar

Creating Standalone Toolbar

Changing Toolbar docking at design time

Using ToolCommand Types

Configuring Multiple Rows Docking

Configuring Multiple Bars in Same Row

Configuring Floating Mode

Configuring ToolBar Merging

Configuring ToolCommand Toolbar Merging

Changing Toolbar Styles

Using Images for Toolbar Appearance

How-to: Enable Keyboard support

How-to: Create Custom Content

How-to: Save and Load structure programmatically


Creating Dockable Toolbar

Creating Dockable Toolbar
See Also Send Feedback
Intersoft WebDesktop > WebToolBar > Tutorials > Creating Dockable Toolbar

Glossary Item Box

WebToolbar can be dockable when it is placed in PlaceHolderManager.

This topic will show you how to create dockable Toolbar in PlaceHolderManager.

To create dockable Toolbar in PlaceHolderManager

  1. Drag PlaceHolderManager from Toolbox into a WebForm page.
  2. Drag WebToolBar from Toolbox into the PlaceHolderManager.
  3. When you run the project, docking capability is enabled automatically. You can drag the toolbar to be floating and dock the toolbar to the right or left or bottom.

See Also

Related Articles
{Creating Standalone Toolbar}
{Changing Toolbar docking at design time}
{Using ToolCommand Types}
{Configuring Multiple Rows Docking}
{Configuring Floating Mode}
{Configuring Multiple Bars in Same Row}


Creating Standalone Toolbar

Creating Standalone Toolbar
See Also Send Feedback
Intersoft WebDesktop > WebToolBar > Tutorials > Creating Standalone Toolbar

Glossary Item Box

Objectives

WebToolBar could be created as a stand-alone Toolbar as well. This tutorial provides you step-by-step guidance to create stand-alone Toolbar.

  1. Drag WebToolBar from Toolbox into a WebForm page.
  2. You may customize WebToolBar from its properties. For example: Customizing the WebToolBar Button using Commands Collection from properties like the following snapshot, and many other features available.

See Also

Related Articles
{Creating Dockable Toolbar}
{Using ToolCommand Types}
{Using Templated Command}


Changing Toolbar docking at design time

Changing Toolbar docking at design time
See Also Send Feedback
Intersoft WebDesktop > WebToolBar > Tutorials > Changing Toolbar docking at design time

Glossary Item Box

Objectives

This tutorial demonstrates how to customize Docking layout using WebToolBar Designer. There are many Docking layout combinations you could use in the designer.

  1. Drag PlaceHolderManager from Toolbox into a WebForm page.

  2. Drag WebToolBar from Toolbox into the PlaceHolderManager. Note that in the snapshot below, it displays 2 WebToolBar in the top and left docking.

  3. Customize the Docking layout using WebToolBar Quick Designer like the following snapshot.
  4. Click OK to take affect of the setting.

  5. Finally, the docking layout will apply the changes and it will display like the following.

See Also

Related Articles
{Creating Dockable Toolbar}
{Configuring Multiple Rows Docking}


Using ToolCommand Types

Using ToolCommand Types
See Also Send Feedback
Intersoft WebDesktop > WebToolBar > Tutorials > Using ToolCommand Types

Glossary Item Box

WebToolBar has several command types for its Items. These ToolCommand's Types consist of : Button, Toggle Button, DropDown Button, Split Button, Separator, Custom, Container and Normal.

This topic will show you how to assign a command type to each item in WebToolBar and what the functionality of each type.

To use ToolCommand Types

  1. Right click WebToolBar control and choose Properties.
  2. Go to Commands and click the collection button.
  3. ToolCommand Collection Editor will appear.
  4. Click Add to add New Item and Remove to remove the Selected Item.
  5. To change the ToolCommand Types, set Type to any available ToolCommand types.

See Also

Related Articles
{Using Templated Command}
{Creating Standalone Toolbar}


Configuring Multiple Rows Docking

Configuring Multiple Rows Docking
See Also Send Feedback
Intersoft WebDesktop > WebToolBar > Tutorials > Configuring Multiple Rows Docking

Glossary Item Box

Objectives

WebToolBar supports Multiple Rows Docking, just like what we used to see in common desktop application.
This tutorial will show you how to configure a Multiple Rows Docking.

Following are steps to add item to WebToolBar and change the command type.

  1. Drag PlaceHolderManager to WebForm.

  2. Right click on PlaceHolderManager and choose PlaceHolderManager Designer.

    You can change the layout and properties of PlaceHolderManager in this designer, ultimately you need to specify maximum docking rows for the WebToolBars.

  3. Drag First WebToolBar to PlaceHolder Manager.

    This will place the WebToolBar to Top Most Row in PlaceHolder manager, to learn how to change the docking position see "Changing Toolbar docking at design time" Tutorial.

  4. Drag Second WebToolBar to WebForm.

    This will place the WebToolBar on second row bellow the first WebToolBar.

  5. Open First & Second WebToolBar's Property Window.
  6. In Docking Property Set, change DockingArea Property to "Top" or others.
  7. In Docking Property Set, change DockingRow to 0 (for First WebToolBar) and 1 (for Second WebToolBar).

  8. Run the project.

  • You might want to add some ToolBar Command Buttons in your WebToolBar. To see more information about this please refer to "Using ToolCommand Types" Tutorial
  • FillDockingRow's Property is used to expand the ToolBar's width to fill the Docking's Row. If you want to specify the width of the WebToolBar, you need set FillDocking's Row Property to false before you change the width settings.

See Also

Related Articles
{Creating Dockable Toolbar}
{Changing Toolbar docking at design time}
Configuring Multiple Bars in Same Row


Configuring Multiple Bars in Same Row

Configuring Multiple Bars in Same Row
See Also Send Feedback
Intersoft WebDesktop > WebToolBar > Tutorials > Configuring Multiple Bars in Same Row

Glossary Item Box

Objectives

WebToolBar supports multiple ToolBars in same Row, just like what we used to see in common desktop application.
This tutorial will show you how to configure a multiple ToolBars in same Row.

Following are steps to add item to WebToolBar and change the command type.

  1. Drag PlaceHolderManager to WebForm.

  2. Drag First WebToolBar to PlaceHolder Manager.

    This will place the WebToolBar to Top Most Row in PlaceHolder manager, to learn how to change the docking position see "Changing Toolbar docking at design time" Tutorial.

  3. Drag Second WebToolBar to WebForm.

    This will place the WebToolBar on second row bellow the first WebToolBar.

  4. Open First & Second WebToolBar's Property Window.
  5. In Docking Property Set, ensure DockingArea's Property and DockingRow's Property of First & Second WebToolBar are the same.

  6. Set FillDockingRow's Property of First & Second WebToolBar to false.

  7. Set Width of First WebToolBar to 50% and Width of Second WebToolBar to 30%.

  8. Run the project and you should see something like this.

You might want to add some ToolBar Command Buttons in your WebToolBar, to see more information about this please refer to "Using ToolCommand Types" Tutorial

See Also

Related Articles
{Creating Dockable Toolbar}
{Configuring Multiple Rows Docking}


Configuring Floating Mode

Configuring Floating Mode
See Also Send Feedback
Intersoft WebDesktop > WebToolBar > Tutorials > Configuring Floating Mode

Glossary Item Box

Objectives

WebToolBar can also be set in floating mode.
This tutorial will show you how to configure a floating mode WebToolBar.

Following are steps to add item to WebToolBar and change the command type.

  1. Drag PlaceHolderManager to WebForm.

  2. Drag First WebToolBar to PlaceHolder Manager.

    This will place the WebToolBar to Top Most Row in PlaceHolder manager, to learn how to change the docking position see "Changing Toolbar docking at design time" Tutorial.

  3. Open WebToolBar's Property Window.
  4. In Docking Property Set, set AllowFloat's Property to True.
  5. Set isFloat's Property to True if you want the WebToolBar is on Floating Mode from the start.

  6. Run the project and you should see something like this.

See Also

Related Articles
{Creating Dockable Toolbar}


Configuring ToolBar Merging

Configuring ToolBar Merging
See Also Send Feedback
Intersoft WebDesktop > WebToolBar > Tutorials > Configuring ToolBar Merging

Glossary Item Box

If you have a main WebToolBar in a page and an IFrame that has its own WebToolBar, you can merge both WebToolBar.

This topic will show you how to merge WebToolBar.

To configure ToolBar Merging

  1. Create a parent page, for example : ParentWindow.aspx.
  2. In ParentWindow.aspx, drag PlaceHolderManager from ToolBox into WebForm.
  3. Drag WebToolBar from ToolBox into the PlaceHolderManager. Set the ID property to WebToolBar1.
  4. In Commands property, add ToolCommand Collection in ToolCommand Collection Editor. Click here for further information on how to define a ToolCommand. Add three Button ToolCommand (New, Open, Save) in ToolCommand Collection Editor. Set the sequence of the ToolCommands like the screenshots below.

  5. In Properties window, set DockingArea property to Top.
  6. Create another page, for example : childWindow.aspx.
  7. In childWindow.aspx, drag WebToolBar from ToolBox into WebForm. Set the ID of the WebToolBar as WebToolBarChild1.
  8. In Commands property, add ToolCommand Collection in ToolCommand Collection Editor. Add two Button ToolCommand (Help, LicenseAgreement).

  9. In Properties window, set the MergeToolBar property to True.
  10. Go back to ParentWindow.aspx, add an IFrame and set the source property to childWindow.aspx.

    <iframe src="childWindow.aspx" style="display: none;"></iframe>

  11. Right click on PlaceHolderManager control and choose Properties.
  12. Set EnableMergeBar to True.
  13. Run the project. The WebToolBar from another page (ChildWindow.aspx)is merged and added into the PlaceHolderManager in this Page.

See Also

Related Articles
{Creating Dockable Toolbar}
{Configuring ToolCommand Toolbar Merging}


Configuring ToolCommand Toolbar Merging

Configuring ToolCommand Toolbar Merging
See Also Send Feedback
Intersoft WebDesktop > WebToolBar > Tutorials > Configuring ToolCommand Toolbar Merging

Glossary Item Box

Objectives

If you have a main WebToolBar in a page and an IFrame that has its own WebToolBar, you can merge the ToolCommand of both WebToolBar. This tutorial provides you a step-by-step guidance to merge ToolCommands of a WebToolBar to another WebToolBar.

  1. Create a parent page, for example : ParentWindow.aspx.
  2. In ParentWindow.aspx, drag PlaceHolderManager from ToolBox into WebForm.
  3. Drag WebToolBar from ToolBox into the PlaceHolderManager. Set the ID property to WebToolBar1.

  4. In Commands property, add ToolCommand Collection in ToolCommand Collection Editor. Click here for further information on how to define a ToolCommand. Add five Button ToolCommand (New, Open, Save, Print, Refresh) and two Container ToolCommand (Container1, Container2) in ToolCommand Collection Editor. Set the sequence of the ToolCommands like the screenshots below.

  5. The WebToolBar in ParentWindow.aspx will look like the screenshot below.

  6. Create another page, for example : srcFile.aspx.
  7. In srcFile.aspx, drag WebToolBar from ToolBox into WebForm. Set the ID of the WebToolBar as WebToolBar1.
  8. In Commands property, add ToolCommand Collection in ToolCommand Collection Editor. Add three Button ToolCommand (Home, Help, Inbox).
  9. Set the MergeCommandID of the ToolCommands.

    Name | MergeCommandID
    Home | Container2
    Help | Container1
    Inbox | Container1

  10. In srcFile.aspx, display the property window for WebToolBar1. Set the following properties.

    Property | Value
    MergeToolBar | True
    MergeToolBarParentID | WebToolBar1

  11. The WebToolBar in srcFile.aspx will look like the screenshot below.

  12. In ParentWindow.aspx, add an IFrame and set the source property to srcFile.aspx.

    Script Copy Image Copy Code
    <iframe src="srcFile.aspx"></iframe>

  13. Compile and run the application.

Help and Inbox ToolCommand from srcFile.aspx is placed in the Container1 ToolCommand of ParentWindow.aspx and Home ToolCommand from srcFile.aspx is placed in Container2 ToolCommand of ParentWindow.aspx.

See Also

Related Articles
{Creating Dockable Toolbar}
Configuring ToolBar Merging


Changing Toolbar Styles

Changing Toolbar Styles
See Also Send Feedback
Intersoft WebDesktop > WebToolBar > Tutorials > Changing Toolbar Styles

Glossary Item Box

WebToolBar has various styles that can be customized from its quick designer.

This topic will show you how to change the styles of WebToolBar.

To change ToolBar styles

  1. Drag WebToolBar from ToolBox into WebForm.
  2. Right click on WebToolBar control and choose WebToolBar Quick Designer. The WebToolBar Quick Designer dialog box will be displayed. In the Bar tab, choose OfficeXP as the Style. Press Apply and then OK.

  3. Run the project.

See Also

Related Articles
{Creating Dockable Toolbar}
{Creating Standalone Toolbar}


Using Images for Toolbar Appearance

Using Images for Toolbar Appearance
See Also Send Feedback
Intersoft WebDesktop > WebToolBar > Tutorials > Using Images for Toolbar Appearance

Glossary Item Box

Objectives

This tutorials provides you step-by-step guidance to use Image for WebToolBar appearance.

  1. Drag WebToolBar from ToolBox into WebForm. Set the ID of the WebToolBar as WebToolBar1.
  2. In the Properties window, click in Commands property. ToolCommand Collection Editor will be displayed.

  3. Click Add. A new ToolCommand will be added to the editor. Set these properties below.

    Properties | Value
    Image | images/New.gif
    DisplayMode | Image
    Name (optional) | New

  4. Compile and run the application.

See Also

Related Articles
{Changing Toolbar Styles}
{Creating Dockable Toolbar}
{Creating Standalone Toolbar}


How-to: Enable keyboard support

How-to: Enable keyboard support
Send Feedback
Intersoft WebDesktop > WebToolBar > Tutorials > How-to: Enable keyboard support

Glossary Item Box

WebToolBar provides accessibility feature for user to be able to use AccessKey to access the menu.

This topic will show you how to enable keyboard support.

To enable keyboard support

  1. Right click on WebToolBar control and choose Properties.
  2. Set ShowFocusBorder to True. This property is used to show border around the Active command when tabbed via keyboard.
  3. In ToolCommand Collection Editor, you can set AccessKey property to each ToolCommand member. This key is used to access the menu via keyboard.


How-to: Create Custom Content

How-to: Create Custom Content
Send Feedback
Intersoft WebDesktop > WebToolBar > Tutorials > How-to: Create Custom Content

Glossary Item Box

WebToolBar provides a template to use custom content.

This topic will show you how to create custom content.

To create custom content

  1. Right click WebToolBar control and choose Properties.
  2. Go to Commands and click the collection button.
  3. Add one ToolCommand and set Type to Custom.
  4. Right click on WebToolBar and select Edit Template >> ToolCommand Items.
  5. Drag a standard ASP.NET Dropdownlist and a TextBox control.
  6. Configure the following value in CommandTemplate:
    <CommandTemplate>
   <asp:DropDownList ID="DropDownList1" runat="server" CssClass="text">
      <asp:ListItem>(Select a Product)</asp:ListItem>
      <asp:ListItem>WebToolBar</asp:ListItem>
      <asp:ListItem>WebMenuBar</asp:ListItem>
      <asp:ListItem>WebDesktopManager</asp:ListItem>
      <asp:ListItem>Others</asp:ListItem>
   </asp:DropDownList>
   <asp:TextBox ID="TextBox1" runat="server" CssClass="text">(Search)</asp:TextBox>
</CommandTemplate>
  7. Run the project.


How-to: Save and Load structure programmatically

How-to: Save and Load structure programmatically
Send Feedback
Intersoft WebDesktop > WebToolBar > Tutorials > How-to: Save and Load structure programmatically

Glossary Item Box

WebToolBar provides method to save and load structure from xml file.

This topic will show you how to save and load structure programmatically.

To save and load structure programmatically

  1. Create two ASP.NET button controls.
  2. Place the following code in the first button Click event to save WebToolBar's structure.
    C# Copy Code
    protected void WebButton1_Clicked(object sender, ISNet.WebUI.WebDesktop.WebButtonClickedEventArgs e)
{
   WebToolBar1.SaveCommandsStructureToXml(Server.MapPath("SampleStructure.xml"));
}

  3. Place the following code in the second button Click event to load WebToolBar's structure.
    C# Copy Code
    protected void WebButton2_Clicked(object sender, ISNet.WebUI.WebDesktop.WebButtonClickedEventArgs e)
{
   WebToolBar1.LoadCommandsStructureToXml(Server.MapPath("SampleStructure.xml"));
}


WebPaneManager

WebPaneManager
See Also Send Feedback
Intersoft WebDesktop > WebPaneManager

Glossary Item Box

WebPaneManager
Member of WebDesktop.NET 1.0

PaneManager lets you easily create any kind of layout from simple horizontal layout to complex Outlook-like layout with its rock solid object model.

Learn the Features

Working with PaneManager Editor

Understanding Concepts

Working with ClickAndEdit and Designers

Splitter Integration

Quick Start

Creating Simple Layout

Creating Layout from Predefined Template

Configuring Collapsible Pane

Create Professional Office-like Layout in minutes

Use WebPaneManager as your primary Form Layouting component to easily manage the Pane structure as you desired. WebPaneManager lets you quickly create simple layout to complex Office-style layout which contains Header Element and fully customizable appearances. Use the provided Visual PaneManager Designer to create common Layout from Predefined Template with one click away.

Replace traditional Frame-based Layout with resizable one page-based Layout

WebPaneManager's TrueFill architecture makes it possible for you to build consistent Layout with Panes that are resizable and responding properly to window resize. Instead of creating separate pages by using Frame approach which caused inconvenience in scripting interactions, you can now create a single page with resizable Panes which you can configure easily in strong object model approach.

Create resolution-independence Form with better utilization of screen real estate

With WebPaneManager, you no longer has to worry about the various screen resolution of your end users' display. That is made possible with Automatic Resizing feature in conjunction with TrueFill architecture, which manages the dimension of all available Panes to take best dimension of available spaces. Combine with AllowCollapse feature, you can let your users to maximize the utilization of screen real estate by collapsing a Pane into a specific direction at runtime.

See following screenshot for more details.

Original Layout

Maximized View for Message Details

See Also

Getting Started
{Features}
{Understanding Concepts}
{Working with ClickAndEdit and Designers}
{Splitter Integration}


What's New in WebPaneManager

What's New in WebPaneManager
See Also Send Feedback
Intersoft WebDesktop > WebPaneManager > What's New in WebPaneManager

Glossary Item Box

WebPaneManager puts you in control of the screen, providing all the tools you need to develop layouts that organize your applications content and give it a consistent, professional appearance. ClickAndEdit and ClickAndSelect technology make building even complex layouts a breeze.

In version 4, WebPaneManager couldn’t grow its height automatically. This happens because in version 4, the element of WebPaneManager has changed from table element to div element. You can specify each height in each WebPane tag and WebPaneManager will do the rest for collapse, expand, resize, and etc. Table layouting is no longer supported because with table element in HTML5, WebPaneManager will decrease its performance because the features of WebPaneManager need to maintain its fluid content.

This is the following details of enhancements and new features that have been implemented in WebPaneManager:

  • Fluid content

    WebPaneManager has fluid content that can adjust its size when the window or panes are being resized. This fluid content behavior also depends on the height of each pane. After specify the height of each pane, the client side method will handle the features of WebPaneManager. The usage of calc is crucial in this version to organize the height and width of WebPaneManager. So it is necessary to use browser that has supported calc element in CSS3.

  • Auto-growing Header when InfoText is availabe

    When InfoText is available, WebPane will itself calculate the best height based on Height's WebPane settings. This makes WebPane's header auto-growth when InfoText is defined with long sentences.

  • New splitter engine for WebPaneManager

    The usage of splitter in version 4 has been changed completely. This is because the earlier version of splitter doesn't meet the requirement in version 4. In this version, WebpaneManager has a built-in splitter that supports HTML5 and CSS3 standards. It shows a good performance result when resizing and smooth animation when moving. You can also add style to the splitter indicator by assigning the value of the splitter image.

  • High performance using shadow animation

    While resizing, you can use shadow to improve the resizing method. With shadow animation, some of client-side methods won’t be called / invoked during the cursor movement.

  • New intuitive style in WebDesktop 4

    In version 4, WebDesktop presents a new style in each of its control. Metro style as the latest UI in Windows 8 had been implemented and became brand new UI in our WebDesktop control. Metro style makes WebDesktop simpler, tidier, and more attractive for each control's UI. The intuitive design of Metro style also provides consistency of each control in HTML5.

    You can simply use Layout Manager to implement Metro style in WebDesktop.

    For more information on how to apply this configuration, see How-To: Using Layout Manager.

See Also

WebPaneManager

Features
Features


What's New in WebSplitter

What's New in WebSplitter
Send Feedback

Glossary Item Box

WebSplitter control is specifically designed to integrate with the HTML table element. No changes are required to the existing layout – you only need to add one additional cell between the two cells you want to split, then drag-and-drop the WebSplitter control inside that cell. With an accurate unit measurement which returns the original unit type, WebSplitter delivers consistent results regardless of the overall layout complexity and browser window size.

In version 4, WebSplitter's client-side method has been changed. It’s calculation of splitter's height and container has been adapted with HTML5 behavior. Although there are no changes in its structure, WebSplitter still shows great performance like its earlier version.


Features

Features
See Also Send Feedback
Intersoft WebDesktop > WebPaneManager > Features

Glossary Item Box

WebPaneManager offers time-saving and innovative features listed in the following:

  • Rich Design Time experience

    WebPaneManager makes it possible for you to design and develop your rapid web application the same way and manner as in WinForm IDE. WebPaneManager implements ClickAndEdit and ClickAndSelect technologies to deliver this time-saving and elegant architecture to life. See following screenshot for more details.

    With this new level of design time experience, you can develop rich form application efficiently, effectively and quicker than ever before.
  • TrueFill Layout

    TrueFill is a new technology introducing a new way of creating complex Layout in less effort by automating common layout tasks as well as automatically adjusting incorrect dimension values to produce consistent and extensible layout. TrueFill will also prevent your layout to have "vacuum gaps" as the results of unspecified or incorrectly specified dimension. See following image for more details.

    As you can see in above diagram, TrueFill allows you to configure such complex layout by simply specifying the Pane which dimension needs to be customized. Other Panes will have its Width and Height set to Auto and does not require you to calculate or specify the rest values.

    TrueFill automatically manages following layout scenarios:
    • All Auto dimension.
    • Width/Height with combination of Auto and Percentage.
    • Width/Height with combination of Percentage and Pixel.
    • Width/Height with combination of Auto, Percentage and Pixel.

When used in combination mode, WebPaneManager will automatically determine the dimension values for Panes which set to Auto. The automatic calculation will take into account the other Panes which used absolute dimension (pixel) and percentage dimension.

  • Nested Layout Grouping in strong object model

    WebPaneManager is built with strong object model and clear separation between Group and Pane to enable nested Layout Grouping to be shown in consistent fashion. With the object model, it opens the possibility for developers to add a Pane or create the Layout dynamically from code behind as well as saving the Structure into a XML file and load it later.

    For more information about Group concept, please see Understanding Concepts.
  • AllowCollapse and AllowResize

    Two of the most useful features in WebPaneManager are the capabilities which allow users to resize the dimension of Pane at runtime. The resizing works in conjunction with TrueFill architecture which intelligently determines the target size and convert the value back to the original unit type. When a Pane is resized, it will resize the other pair of the Pane and extend its dimension properly. The resizing however, will not affect other Panes or other Group's dimension.

    The other useful feature is the AllowCollapse which adds the capability for users to collapse a Pane into specified direction. With AllowCollapse, you can easily let your users to maximize the layout to use available screen real estate which dramatically enhance the user experience resulting in greater productivity.

    For more information, please see Splitter Integration.
  • Automatic Resizing

    When configured to use percentage Width and Height (default is 100%), WebPaneManager with its TrueFill™ architecture will be able to resize its size along as the available Panes automatically responding to the current Window's size. With this Automatic Resizing, you can build rich web application that behave exactly the same as in desktop application where the layout can be expanded or shrinked as needed (resolution independence). When the layout shrinked to the size and the content of the Pane exceeds the boundaries of the layout, a scrollbar in the Pane's content will appear. See following for more details.

    Before Resized

    After Resized

  • Component Designer

    Instead of changing properties in Visual Studio Property Window, you can configure most properties shown in "logical group" from WebPaneManager Component Designer. You can easily manipulate the global PaneSettings, Styles, as well as changing properties of Pane inside RootGroupPane.

    Most Intersoft's components that exposed rich functionalities, complex objects and collection would implement Component Designer similar to the screenshot above. The consistency of the user interface and functions throughout all Intersoft's components would significantly reduce learning time as well as increasing productivity.

  • Visual PaneManager Designer (Advanced)

    Visual PaneManager is an advanced designer for WebPaneManager which lets you easily and quickly design layout in WYSIWYG fashion. With this time-saving feature, you can conveniently design complex layout from either scratch or predefined template. The predefined template feature makes it possible for you to construct a complex layout in 1 click away. See following screenshot.

    Visual PaneManager also makes Panes manipulation a breeze, such as adding new Pane to its next sibling, converting a Pane into GroupPane without losing its properties, adding or removing Pane or GroupPane, moving Pane around the same group and more.

    For more details on Working with Visual Editor, please click here.
  • Three Predefined Global Header Styles

    WebPaneManager allows you to define up to three global header styles to be applied to individual Pane. This approach has numerous advantages, such as, producing consistent styles of Pane in the PaneManager control. Furthermore, you will only need to define the styles once and reuse it easily in the Pane level by specifying its HeaderAppearance property.

    In the above screenshot, the Side and PaneTop Pane are using HeaderMainStyle for the HeaderAppearance. The PaneBottom is using HeaderSubStyle. Both styles are defined at Global level so that changes to the style will automatically be applied to Pane that used it.

  • IFrame ContentMode

    By default, the WebPaneManager will operate in "UseInlineContent" mode when a new instance is dropped to designer surface. UseInlineContent is the most suitable when the contents inside each tab page are relatively small. You can also determine the "content load" by inspecting the performance during page load as well as the size of the output. UseInlineContent mode utilized .NET Framework's Templating archictecture and therefore all contents are loaded at once in first load (although the inactive pages are set to hidden).

    In most cases where you want to develop a more reusable form, you should use UseIFrame for the content mode. When using IFrame mode, you would need to specify the ContentURL which page you want to load for the designated Tab item.

    The ContentURL accepts three formats of URL:
    1. .NET specific application relative URL. This format starts with "~" character, for instance, "~/FolderA/Page1.aspx".
    2. Absolute URL. This format starts with "/" character, for instance, "/SharedModule/Page1.aspx".
    3. Relative URL. This format usually starts with "." character or no special characters (which assume the page can be found in the current folder's context).
    You can configure different ContentMode for each WebPane. To apply all WebPane to use a specific ContentMode, configure the ContentMode in WebPane control level and leave WebPane's ContentMode to Default.

  • Advanced IFrame-related Features

    WebPaneManager introduced several advanced features related to IFrame (that is when ContentMode is set to UseIFrame). These advanced features are:
    • IFrameAllowTransparency. The Default value is True.
      When set to True, the IFrame will show the background color specified in ContainerStyle instead of the background color in the page specified in ContentURL. This feature will produce better consistency of the user interface and appearance, without having to configure background color of each webform.
The webform specified in ContentURL must have its bgColor set to transparent. For instance, <body bgColor="transparent">

  • IFrameShowLoader. The Default value is True.
    When set to True, the WebPaneManager will display an animated image and text indicating that the Page is currently in loading progress. This feature is helpful when loading a relatively large page and still keep informing the user of the loading progress.

See Also

Related Topics
{Overview}
{Understanding Concepts}


PaneManager Overview

PaneManager Overview
Send Feedback
Intersoft WebDesktop > WebPaneManager > PaneManager Overview

Glossary Item Box

Overview

As has been known Page Layouting using table is very famous in Web design. Using tables, developer then divide their page into several categories and sub-categories such as Header, Side, Content ,Footer and so on. Later though a new layout approach is introduced in the form of a concept famously known as "Tableless CSS", where table is replaced by <DIV> and using CSS style. Though this new approach brings advantages unavailable using traditional approach, table is still an unseparateable part of layouting. It is the easiest and most convenient way to layout your page.

The intention to develop a PaneManager editor comes from the limitation of available editors. Developers usually create their own layout from scratch which is very troublesome especially when complex structure is involved (table inside table and so on). Another problem is about the calculation of each TableData's size (more well known as <TD> in HTML) where they can't conveniently set the dimension of each <TD>. In Pane Manager those sort of thing are no longer a problem where different types of Dimension Unit is supported such as %, px, and even Fill.

PaneManager editor is used as a tool to quickly create and modify pane layout. There are 2 main types of objects in PaneManager which are WebPane and WebGroupPane. WebPane are the panes used to put contents. On the other hand WebGroupPane contains a collection of Panes with either Horizontal or Vertical Orientation.

PaneManager editor also comes with a set of predefined templates where developers can quickly select the intended layout and do further modification to the layout as needed. It also has splitter capability to resize the dimension of two associate Panes during UI Design and ContextMenu capability. This is a complement to the PropertyGrid provided in the WebPaneManager Advanced Designer where the stage is not only used for displaying layout but also for UI Interaction.

Pane Manager UI Introduction

ToolStripMenu
This toolstrip is used for navigation in PaneManager Editor

ToolStripActions
This toolstrip is for action related

Stage
This is the stage where the panes are organized.

SelectedPane PropertyGrid
This is the PropertyGrid listing all properties of currently selected pane.

SelectedPane information
This is a label defining the type and name of currently selected pane.


PaneManager Editor UI Introduction

PaneManager Editor UI Introduction
Send Feedback

Glossary Item Box


Selected Pane Indication
Send Feedback
Intersoft WebDesktop > WebPaneManager > Working with PaneManager Editor > Selected Pane Indication

Glossary Item Box

To perform actions available in PaneManager Editor, selecting the right pane is crucial.
This is why we have made a clear distinction between object which is selected and object(s) which are not.
The other thing is only one Pane can be selected at a time so when you select a new Pane, the old Pane automatically becomes unselected.

Selected Pane Indication

When a pane is selected both the header and body of the Pane is shaded with blue background

Selected GroupPane Indication

When a GroupPane is selected only the header is shaded with blue background


Overview
Send Feedback

Glossary Item Box

Overview

Maintaining consistent look and feel across the whole application is a daunting task without some sort of a centralized mechanism to manage styles. The WebStyleManager is created to accommodate these needs to allow designers and developers to easily apply consistent styles and behaviors to Intersoft WebUI.NET® family components with minimal efforts.

WebStyleManager is built to harness the power of the Theme Architecture and Serialization features which are part of the Intersoft WebUI.NET Framework. <talk more about theme architecture and serialization>


Using ToolStrip Actions

Using ToolStrip Actions
Send Feedback
Intersoft WebDesktop > WebPaneManager > Working with PaneManager Editor > Using ToolStrip Actions

Glossary Item Box

This section contains information on how to use ToolStrip Actions.

In This Section

Add GroupPane

Add Pane

Add Sibling GroupPane

Add Sibling Pane

Convert to GroupPane

Convert to Pane

Delete Pane


Add GroupPane

Add GroupPane
Send Feedback
Intersoft WebDesktop > WebPaneManager > Working with PaneManager Editor > Using ToolStrip Actions > Add GroupPane

Glossary Item Box

Objective

The "Add Group Pane" toolStrip DropDown is used to add a Group Pane to the currently selected pane.
A Group Pane which contains pane(s) inside of it has a property named GroupType the value is an enumeration of type GroupPaneType, it's either Vertical or Horizontal.
So you can not for example create a GroupPane with a 2(rows) x 2(columns) panes. You will need to have 2 GroupPanes and 4 Panes.
This toolStrip menu is only visible when a GroupPane is selected.
To better illustrate about this property look at the snapshot below.

Horizontal GroupPane with 3 Panes

Click on the AddGroupPane then choose Horizontal then add 3 panes using "AddPane".
The result should be like below:

Vertical GroupPane with 3 Panes

Click on the AddGroupPane then choose Vertical then add 3 panes using "AddPane".
The result should be like below:


Add Pane

Add Pane
Send Feedback
Intersoft WebDesktop > WebPaneManager > Working with PaneManager Editor > Using ToolStrip Actions > Add Pane

Glossary Item Box

Objective

The Add Pane toolstrip menu is used to add pane to the currently selected GroupPane. You can add as many pane as you like to the currently selected GroupPane using this command.
Since the items in ToolStripActions is dynamically visible depending on the currently selected object in the Designer, this toolStrip menu is only visible when a GroupPane is selected.

SnapShot

© 2012 Intersoft Solutions Corp. All Rights Reserved.

© 2012 Intersoft Solutions Corp. All Rights Reserved.


Add Sibling GroupPane

Add Sibling GroupPane
Send Feedback
Intersoft WebDesktop > WebPaneManager > Working with PaneManager Editor > Using ToolStrip Actions > Add Sibling GroupPane

Glossary Item Box

Objective

The Add Sibling GroupPane menu is used to add a Pane under the same GroupPane as the selected Pane. Basically it has the same functionality as Add GroupPane. As with adding you also have 2 options in the DropDown value which is Horizontal and Vertical to create different type of GroupPane.
The only difference is when clicked a "sibling" GroupPane is created not child GroupPane. This menu is only visible when a Pane is selected.

SnapShots

  1. Before the "Add Sibling GroupPane" is clicked.

  2. After the "Add Sibling GroupPane" is clicked, notice the new GroupPane added.


Add Sibling Pane

Add Sibling Pane
Send Feedback
Intersoft WebDesktop > WebPaneManager > Working with PaneManager Editor > Using ToolStrip Actions > Add Sibling Pane

Glossary Item Box

Objective

The Add Sibling Pane menu is used to add a Pane under the same GroupPane as the selected Pane. Basically it has the same functionality as AddPane.
The only difference is when clicked a "sibling" Pane is created not child Pane. This menu is only visible when a Pane is selected.

SnapShots

  1. Before the "Add Sibling Pane is clicked.

  2. After the "Add Sibling Pane" is clicked, notice the new Pane added.


Convert to GroupPane

Convert to GroupPane
Send Feedback
Intersoft WebDesktop > WebPaneManager > Working with PaneManager Editor > Using ToolStrip Actions > Convert to GroupPane

Glossary Item Box

Objective

The Convert to GroupPane feature is intended so a Pane can be converted to GroupPane. It automatically provides two options which are "Horizontal with 2 Panes" and "Vertical with 2 Panes".

Since we cannot add a Pane to Pane this feature is crucial so we won't need to remove the Pane and then Add a GroupPane. This feature is very useful when we change our mind during layout design and want to add more pane to a pane. It will automatically convert the SelectedPane to a GroupPane and add 2 Panes inside of it

This toolStrip menu is only visible when a Pane is selected.

SnapShots

  1. A Pane is selected then the "Convert to GroupPane" > "Vertical With 2 Panes" is about to be clicked

  2. The resulting Vertical GroupPane with 2 Panes inside of it


Convert to Pane

Convert to Pane
Send Feedback
Intersoft WebDesktop > WebPaneManager > Working with PaneManager Editor > Using ToolStrip Actions > Convert to Pane

Glossary Item Box

Objective

The Convert to GroupPane feature is intended so a GroupPane can be easily converted to a Pane. This feature is crucial so we won't need to remove the GroupPane and then add a Pane replace it.

When we change our mind during layout design and want to directly use a GroupPane as a Pane. It will automatically convert the Selected GroupPane to a Pane.

This toolStrip menu is only visible when a GroupPane is selected and it has no child Pane inside of it.

SnapShots

  1. A Pane is selected then the "Convert to GroupPane" > "Vertical With 2 Panes" is about to be clicked

  2. The resulting Vertical GroupPane with 2 Panes inside of it


Delete Pane

Delete Pane
Send Feedback
Intersoft WebDesktop > WebPaneManager > Working with PaneManager Editor > Using ToolStrip Actions > Delete Pane

Glossary Item Box

Objective

The Convert to GroupPane feature is intended so a GroupPane can be easily converted to a Pane. This feature is crucial so we won't need to remove the GroupPane and then add a Pane replace it.

When we change our mind during layout design and want to directly use a GroupPane as a Pane. It will automatically convert the Selected GroupPane to a Pane.

This toolStrip menu is only visible when a GroupPane is selected and it has no child Pane inside of it.

SnapShots

  1. A Pane is selected then the "Convert to GroupPane" > "Vertical With 2 Panes" is about to be clicked

  2. The resulting Vertical GroupPane with 2 Panes inside of it


Using ToolStrip Menu

Using ToolStrip Menu
Send Feedback
Intersoft WebDesktop > WebPaneManager > Working with PaneManager Editor > Using ToolStrip Menu

Glossary Item Box

This section contains information on how to use ToolStrip Menu.

In This Section

Pick Template Layout

Create Custom Tabular

Load Layout

Save Layout

Clear All


Pick Template Layout

Pick Template Layout
Send Feedback
Intersoft WebDesktop > WebPaneManager > Working with PaneManager Editor > Using ToolStrip Menu > Pick Template Layout

Glossary Item Box

When the toolStrip button "Pick Template/Create Custom Tabular is clicked, a form will pop up as below

The Default Selected Radio Button is Template where a ComboBox with Image is provided so user can select from a predefined templates. Those are the templates commonly used when designing an application. User can select from those predefined templates and then either directly use the template or perform modification to the template.

When you have made your selection, simply click apply and you will be returned to the main designer form and see your Tabular Panes generated already there.


Create Custom Tabular

Create Custom Tabular
Send Feedback
Intersoft WebDesktop > WebPaneManager > Working with PaneManager Editor > Using ToolStrip Menu > Create Custom Tabular

Glossary Item Box

Other than providing the user with common predefined Layout, another feature which is Custom Tabular is also provided, using this feature, user can simply create Tabular Panes. This is extremely useful especially in situations where you want to create a large matrix of tabular cells.

Simply by moving the Radio Button to Custom, the GroupBox TabularMode will be activated and you will be able to create tabular panes conveniently. The interesting thing to notice here is there are 2 types of grouping which is Horizontal or Vertical. When Horizontal is selected the Pane will be grouped Horizontally since a GroupPane can only be either Vertical or Horizontal.

When you have made your selection, simply click apply and you will be returned to the main designer form and see your Tabular Panes generated already there.


Load Layout

Load Layout
Send Feedback
Intersoft WebDesktop > WebPaneManager > Working with PaneManager Editor > Using ToolStrip Menu > Load Layout

Glossary Item Box

When the LoadLayout button in toolStrip Menu is clicked, an OpenFileDialog will appear. From there you can select the xml file which contains the WebPane object information. The designer will DeSerialize the XML to a Pane Object.

When you have finished choosing the intended xml file, you will then be returned to the main stage designer with the Panes loaded already.


Save Layout

Save Layout
Send Feedback
Intersoft WebDesktop > WebPaneManager > Working with PaneManager Editor > Using ToolStrip Menu > Save Layout

Glossary Item Box

When the SaveLayout button in toolStrip Menu is clicked, an SaveFileDialog will appear. From there you can type the xml file name you wish to save or replace and existing one. The actual object in the stage will then be serialized in the form of XML file.

When you have finished saving the WebPane object to xml, you will be returned to the main stage designer.


Clear All

Clear All
Send Feedback
Intersoft WebDesktop > WebPaneManager > Working with PaneManager Editor > Using ToolStrip Menu > Clear All

Glossary Item Box

When ClearAll button in the ToolStripMenu is clicked. It will prompt you whether the stage will be cleared. If you click OK then the stage will be cleared and you will be faced with an empty stage.


WebPaneBase Properties

WebPaneBase Properties
Send Feedback

Glossary Item Box

WebPaneBase Properties

Name | Description Gets or sets the name for this Pane Item. ValueType String Default Value
IsEnabled | Description Specifies whether this Pane Item is enabled. ValueType Boolean Default Value True
Text | Description Gets or sets the text for this Pane Item. ValueType String Default Value
ToolTip | Description Gets or sets the tooltip text for this Pane. ValueType String Default Value
Width | Description Gets or sets the dimension mode for this Pane's width. ValueType DimensionMode Default Value Fill
Height | Description Gets or sets the dimension mode for this Pane's height. ValueType DimensionMode Default Value Fill
WidthValue | Description Gets or sets the value of Width in Unit. This property is applicable when Width is set to Custom. ValueType Unit Default Value
HeightValue | Description Gets or sets the value of the Height in Unit. This property is applicable when Height mode is set to Custom. ValueType Unit Default Value
PaneManager | Description Gets the PaneManager from WebPaneBase Control. ValueType WebPaneManager Default Value
ParentGroupPane | Description Gets the ParentGroupPane of this Pane Item. ValueType WebGroupPane Default Value
AllowResize | Description Determines whether this Pane can be resized by users. ValueType AllowResize Default Value
TextAlignment | Description Gets or sets the alignment of the text. ValueType TextAlignment Default Value Default
Index | Description Gets the index of this Pane Item in the collection ValueType Integer Default Value
ActualWidth | Description Gets the actual width of this Pane Item. ValueType Unit Default Value
ActualHeight | Description Gets the actual height of this Pane Item. ValueType Unit Default Value
AllowCollapse | Description Gets whether users are allowed to collapse this Pane through splitter. ValueType AllowCollapse Default Value Default
Collection | Description Gets the collection which owns this Pane Item. ValueType ISCollectionBase Default Value
IFrameContentLoaded | Description Determines whether the IFrame Content has been loaded. ValueType Boolean Default Value
IsRootPane | Description Determines whether this Pane is root Pane. ValueType Boolean Default Value


WebPane Properties

WebPane Properties
Send Feedback

Glossary Item Box

WebPane Properties

ContentMode | Description Gets or sets the content mode of this Pane. ValueType ContentMode Default Value Default
ContentURL | Description Gets or sets the URL for the IFrame content. This property is applicable when ContentMode is set to UseIFrame. ValueType String Default Value
InProgressText | Description Gets or sets the text which will be displayed when the Active IFrame is in loading progress. This property only applicable when IFrameShowLoader is set to True and ContentMode is set to UseIFrame. ValueType String Default Value


WebPaneClientSideEvents Properties

WebPaneClientSideEvents Properties
Send Feedback

Glossary Item Box

WebPaneClientSideEvents Properties

OnInitialize | Description Gets or sets the javascript function to invoke when the control is being initialized. ValueType String Default Value
OnBeforeResize | Description Gets or sets the javascript function to invoke when the Pane is about to be resized through splitter. ValueType String Default Value
OnAfterResize | Description Gets or sets the javascript function to invoke after the Pane is resized through splitter. ValueType String Default Value


WebPaneManager Properties

WebPaneManager Properties
Send Feedback

Glossary Item Box

WebPaneManager Properties

SplitterSettings | Description Contains default settings for the Splitter. ValueType WebPaneSplitterSettings Default Value
ClientSideEvents | Description Contains client side events for WebPaneManager. ValueType WebPaneClientSideEvents Default Value
ImagesSettings | Description Contains images settings for WebPaneManager. ValueType WebPaneImagesSettings Default Value
RootGroupPane | Description Gets or sets the RootGroupPane used by the WebPaneManager. ValueType WebGroupPane Default Value
PaneSettings | Description Contains default settings for the WebPaneManager. ValueType WebPaneSetting Default Value
ImagesDirectory | Description Gets or sets the location of Images used to render the WebPaneManager control. ValueType String Default Value /CommonLibrary/Images/WebDesktop/
TextSettings | Description Contains text settings used by the control. ValueType WebPaneTextSettings Default Value
ClientID | Description Gets the server control identifier generated by ASP.NET. ValueType String Default Value
ID | Description The ID name of the control ValueType String Default Value


WebPaneManager Methods

WebPaneManager Methods
Send Feedback

Glossary Item Box

WebPaneManager Methods

GetPaneByName | Description returns the pane of specified name Parameters name ( ) Remarks Return Value WebPaneBase Samples
GetAllPanes | Description returns all Panes objects available in the PaneManager regardless of the hierarchy structure. Parameters Remarks Return Value WebPaneCollection Samples


WebPaneSettings Properties

WebPaneSettings Properties
Send Feedback

Glossary Item Box

WebPaneSettings Properties

AllowResize | Description Determines whether panes are resizable. ValueType AllowResize Default Value Yes
CaptionDisplayMode | Description Gets or sets the mode of the caption display. ValueType DisplayMode Default Value Text
HeaderVisible | Description Gets or sets whether the header part should be rendered. ValueType Visibility Default Value Yes
HeaderAppearance | Description Gets or sets the default predefined style applied to Header part. ValueType HeaderAppearanceMode Default Value UseMainStyle
ImageAlignment | Description Gets or sets the alignment of the image. The image alignment is relative to the caption text. ValueType DisplayAlignment Default Value Left
TextAlignment | Description Gets or sets the alignment of the text. ValueType TextAlignment Default Value Left
InfoTextAlignment | Description Gets or sets the alignment of the InfoText relative its placeholder. ValueType TextAlignment Default Value Right
InfoTextPosition | Description Gets or sets the position of the InfoText part. ValueType InfoTextPosition Default Value BesideCaption
ContentMode | Description Gets or sets the content mode of the WebPaneManager control. ValueType ContentMode Default Value UseInlineContent
IFrameAllowTransparency | Description Specifies whether the IFRAME should allow transparency. This property is applicable when ContentMode is set to UseIFrame. ValueType Boolean Default Value True
IFrameShowLoader | Description Specifies whether to show loader text when the active IFrame is in loading progress. This property only applicable when ContentMode is set to UseIFrame. ValueType Boolean Default Value True
PaneSpacing | Description Specifies the spacing between each Pane in pixel. ValueType Integer Default Value 4
ScrollBarStyle | Description Gets or sets the scrollbar style for WebPane. ValueType WebScrollBarStyle Default Value
AllowCollapse | Description Indicates whether users are allowed to collapsed Panes through splitter. ValueType AllowCollapse Default Value No


WebPaneTextSettings Properties

WebPaneTextSettings Properties
Send Feedback

Glossary Item Box

WebPaneTextSettings Properties

InProgressText Description
Gets or sets the text which will be displayed when an IFrame is in loading progress.

ValueType
String

Default Value


WebSplitter Properties

WebSplitter Properties
Send Feedback

Glossary Item Box

WebSplitter Properties

Id | Description Gets or sets the Id of the WebSplitter. ValueType String Default Value
Size | Description Gets or sets the Size of the WebSplitter (in pixel). ValueType Integer Default Value 4
Shadow | Description Gets or sets the behavior of WebSplitter's resizing method. true indicating shadow movement, false indicating realtime movement. currently only support shadow movement. ValueType Boolean Default Value True
AllowCollapse | Description Gets or sets whether the WebSplitter is able to collapse or not. ValueType Boolean Default Value True
AllowResize | Description Gets or sets whether the WebSplitter is able to resize or not. ValueType Boolean Default Value True
Panel1Min | Description Gets or sets the minimum size of panel1 to collapse or resize (in pixel). valid value is greater or equal to 1. ValueType Integer Default Value 1
Panel2Min | Description Gets or sets the minimum size of panel2 to collapse or resize (in pixel). valid value is greater or equal to 1. ValueType Integer Default Value 1
Panel1Scrollable | Description Gets or sets whether the panel1 of the WebSplitter is scrollable or not. ValueType Boolean Default Value False
Panel2Scrollable | Description Gets or sets whether the panel2 of the WebSplitter is scrollable or not. ValueType Boolean Default Value False
PlaceholderId | Description Gets or sets the Id of the WebSplitter's placeholder. it supposed to be a td element id. ValueType String Default Value
Orientation | Description Gets or sets the Orientation of the WebSplitter, either "Horizontal" or "Vertical". ValueType String Default Value
CollapseDirection | Description Gets or sets the direction of the grip to collapse, either "Panel1" or "Panel2". ValueType String Default Value
GripImageCollapse | Description Gets or sets the Image path icon to collapse. ValueType String Default Value
GripImageRestore | Description Gets or sets the Image path icon to restore. ValueType String Default Value
Integrated | Description Gets or sets whether the WebSplitter control is integrated into PaneManager object. ValueType Boolean Default Value False
PaneManager | Description Gets or sets the PaneManager instance associated with this WebSplitter control. Used when integrating into PaneManager, in order to have a consistent style. ValueType Object Default Value


WebTab

WebTab
Send Feedback

Glossary Item Box


WebTabClientEvents

WebTabClientEvents
Send Feedback

Glossary Item Box


WebTabItem

WebTabItem
Send Feedback

Glossary Item Box


WebTabRoundCornerSettings

WebTabRoundCornerSettings
Send Feedback

Glossary Item Box


WebTabTextSettings

WebTabTextSettings
Send Feedback

Glossary Item Box


WebTab Properties

WebTab Properties
Send Feedback

Glossary Item Box

WebTab Properties

ActiveTabIndex | Description Gets or sets the active WebTab index. ValueType Integer Default Value 0
TabPages | Description Gets the collection of WebTab pages in this WebTab control. ValueType WebTab[] Default Value
ActiveTab | Description Gets or sets the active WebTab object. ValueType WebTab object Default Value
ClientID | Description Gets the server control identifier generated by ASP.NET. ValueType String Default Value The server control identifier generated by ASP.NET
ID | Description Gets or sets the programmatic identifier assigned to the WebTab control. ValueType String Default Value The programmatic identifier assigned to the control
RenderMode | Description Gets or sets the active WebExplorerPane index. ValueType String Default Value


WebTab Methods

WebTab Methods
Send Feedback

Glossary Item Box

WebTab Methods

GetContainerBorderWidth

Description
Gets the container's border width

Parameters

Remarks

Return Value

unit (Container's border's width)

Samples

GetHeaderTableElement

Description
Gets the HTML table element of WebTab's header part

Parameters

Remarks

Return Value

object ( HTML element)

Samples

GetTabContentDivElement

Description
Gets the HTML content div element of WebTab

Parameters

Remarks

Return Value

object ( HTML element)

Samples

GetTabItemNormalStyle

Description
Gets the tab item's normal style

Parameters

Remarks

Return Value

Samples

GetIFrameWindow Description
Get the IFrameWindow of the WebTab object

Parameters
name ( String )
The name of IFrameWindow that you want to get.

Remarks

Return Value

object ( Window)

Samples
GetScrollCellElement

Description
Gets the HTML ScrollCell element of the WebTab

Parameters

Remarks

Return Value

object ( HTML element)

Samples
GetScrollLeftButtonElement

Description
Gets the HTML ScrollLeftButton element of the WebTab

Parameters

Remarks

Return Value

object ( HTML element)

Samples
GetScrollRightButtonElement

Description
Gets the HTML ScrollRighttButton element of the WebTab

Parameters

Remarks

Return Value

object ( HTML element)

Samples
GetCloseButtonElement

Description
Gets the HTML CloseButton element of the WebTab

Parameters

Remarks

Return Value

object ( HTML element)

Samples
GetActiveTab

Description
Gets the active WebTab object

Parameters

Remarks

Return Value

WebTab object

Samples
AddNewTabItem Description
Add a new tab item which has properties based on the parameters

Parameters
name ( String )
The name of the new TabItem
captionText ( String )
The caption text of the new TabItem
imagePath ( String )
The imagePath of the new TabItem
contentURL ( String )
The contentURL of the new TabItem
setActive ( boolean )
The active status of the new TabItem

Remarks

Return Value

Samples


WebTabClientEvents Properties

WebTabClientEvents Properties
Send Feedback

Glossary Item Box

WebTabClientEvents Properties

OnBeforeTabChanged | Description Specifies the client-side function to be invoked before client changed the tab ValueType String Default Value
OnAfterTabChanged | Description Specifies the client-side function to be invoked after client changed the tab ValueType String Default Value
OnInitialize | Description Specified the client side function to be invoked when the WebTab is in initialization process ValueType String Default Value
OnBeforeClosed | Description Specified the client side function to be invoked before the WebTab is closed ValueType String Default Value
OnAfterClosed | Description Specified the client side function to be invoked after the WebTab is closed ValueType String Default Value
OnCreated | Description Specified the client side function to be invoked when the WebTab is created ValueType String Default Value
OnScroll | Description Specified the client side function to be invoked when the WebTab is scrolled ValueType String Default Value


WebTabItem Properties

WebTabItem Properties
Send Feedback

Glossary Item Box

WebTabItem Properties

Name | Description Gets or sets the name of the WebTabItem ValueType String Default Value
CaptionDisplayMode | Description Gets or sets the CaptionDisplayMode for WebTabItem ValueType DisplayMode Default Value
ImageAlignment | Description The alignment of image in this WebTabItem ValueType String Default Value
IsEnabled | Description Gets or sets a value indicating whether the WebTabItem can respond to user interaction ValueType boolean Default Value true
IsSeparator | Description Gets or sets a value indicating whether the WebTabItem is a separator ValueType boolean Default Value true
Text | Description Gets or sets the text to display on the WebTabItem ValueType String Default Value
Image | Description Gets or sets the image inside WebTabItem ValueType object ( Image ) Default Value
Index | Description Gets the index of the WebTabItem ValueType integer Default Value
ToolTip | Description Gets or sets the tooltip for the WebTabItem ValueType String Default Value
ContentMode | Description Gets or sets the ContentMode of WebTabItem ValueType Default Value
ContentURL | Description Gets or sets the ContentURL of the WebTabItem ValueType String Default Value
AllowClose | Description When this property is set to true, there will be a close button at the right most of the Tab ValueType boolean Default Value true
InProgressText | Description Specifies the text that will be displayed when the specific WebTabItem is in progress processing request ValueType String Default Value
Collection | Description Gets the collection of WebTabItem ValueType WebTabItem[] Default Value
IFrameLoaded | Description Gets or sets a value indicating whether content of the IFrame has been successfully loaded into WebTabItem ValueType boolean Default Value false
IsClosed | Description Gets or sets the status of the WebTabItem ValueType boolean Default Value false


WebTabItem Methods

WebTabItem Methods
Send Feedback

Glossary Item Box

WebTabItem Methods

Enable Description
Enable the WebTab control

Parameters

Remarks

Return Value

void

Samples

Disable Description
Disable the WebTab control

Parameters

Remarks

Return Value

void

Samples

Close Description
Close the WebTab control

Parameters

Remarks

Return Value

void

Samples

GetElement Description
Gets the HTML element from current WebTab object

Parameters

Remarks

Return Value

object ( HTML element)

Samples

GetInnerTableElement Description
Gets the HTML Inner Table element of the WebTab

Parameters

Remarks

Return Value

object ( HTML element)

Samples

GetLeftImageElement Description
Gets the HTML Left Image element of the WebTab

Parameters

Remarks

Return Value

object ( HTML element)

Samples

GetCenterImageCellElement Description
Gets the HTML Center Image element of the WebTab

Parameters

Remarks

Return Value

object ( HTML element)

Samples

GetRightImageElement Description
Gets the HTML Right Image element of the WebTab

Parameters

Remarks

Return Value

object ( HTML element)

Samples

GetDivElement

Description
Gets the HTML Div element of the WebTab

Parameters

Remarks

Return Value

object ( HTML element)

Samples

IsActiveTab Description
Gets the value indicating whether this TabItem is the active tab

Parameters

Remarks

Return Value

boolean

Samples
SetActive Description
Sets this TabItem to become the active tab item

Parameters

Remarks

Return Value

Samples
SetCaption Description
Sets the caption text of this WebTabItem

Parameters
text ( String )
The text to be set as the caption for this WebTabItem

Remarks

Return Value

Samples
SetImage Description
Sets the image of this WebTabItem's header

Parameters
imageURL( String )
The image url to be set as the image of this WebTabItem

Remarks

Return Value

Samples
SetContentURL Description
Sets the content's URL of this WebTabItem

Parameters
url( String )
The content URL to be set as the content of this WebTabItem

Remarks

The ContentMode of the WebTabItem must be set to UseIFrame in order for this method to take affect.

Return Value

Samples
IsFirstItem

Description
Gets the value indicating whether this TabItem is the first tab item

Parameters

Remarks

Return Value

boolean

Samples
IsLastItem

Description
Gets the value indicating whether this TabItem is the last tab item

Parameters

Remarks

Return Value

boolean

Samples
GetTabPageElement

Description
Gets the HTML element of this TabPage

Parameters

Remarks

Return Value

object ( HTML element)

Samples

GetTabPageIFrameElement

Description
Gets the HTML element of this TabPage's IFrame

Parameters

Remarks

Return Value

object ( HTML element)

Samples

LoadContent

Description
Load the content of this WebTabItem

Parameters

Remarks

Return Value

Samples

GetInProgressText

Description
Gets the InProgressText of this TabItem

Parameters

Remarks

Return Value

String

Samples

ScrollIntoView

Description

Scroll this WebTabItem into visible view. This method is useful when the WebTab is using AllowScrolling feature.

Parameters

Remarks

Return Value

Samples


WebTabRoundCornerSettings Properties

WebTabRoundCornerSettings Properties
Send Feedback

Glossary Item Box

WebTabRoundCornerSettings Properties

TopBorderColor | Description Gets or sets the top border color of WebTab ValueType Color Default Value
FillerBorderColor | Description Gets or sets the filler border color of WebTab ValueType Color Default Value
ApplyHover | Description Gets or sets a value indicating whether the Over style will be applied ValueType boolean Default Value true


WebTabTextSettings Properties

WebTabTextSettings Properties
Send Feedback

Glossary Item Box

WebTabTextSettings Properties

InProgressText | Description Specifies the text that will be displayed when the specific WebTab object is in progress processing request ValueType String Default Value
ScrollLeftButtonTooltipText | Description Gets or sets the tooltip text of ScrollLeftButton for this WebTab object ValueType String Default Value
ScrollRightButtonTooltipText | Description Gets or sets the tooltip text of ScrollRighttButton for this WebTab object ValueType String Default Value
CloseButtonTooltipText | Description Gets or sets the tooltip text of CloseButton for this WebTab object ValueType String Default Value


Using Splitter

Using Splitter
Send Feedback
Intersoft WebDesktop > WebPaneManager > Working with PaneManager Editor > Using Splitter

Glossary Item Box

Objective

To provide splitter ability in the Stage Surface so 2 associate Pane can be resize using splitter capability.

When a mouse cursor is between 2 panels, it will change the cursor to a splitter. You can simply hold the mouse and a shaded line will appear you can move that line to adjust the dimension of the 2 panes involved.

SnapShots

  1. The mouse is hold and the splitter is moved to the right

  2. The resulting pane dimension after the mouse press is released


Using Context Menu

Using Context Menu
Send Feedback
Intersoft WebDesktop > WebPaneManager > Working with PaneManager Editor > Using Context Menu

Glossary Item Box

The ContextMenu which is available at the top right at every pane is used to move the location of a Pane.
It is signified with a down arrow [image]. When you clicked on the arrow a ContextMenu will appear.
Depending on the location of a Pane whose ContextMenu is clicked, the ContextMenu will give the possible movement options. The possible movements are Up, Down, Left and Right.

Following is a screen shot to give you a better picture of the ContextMenu Utilization


Using PropertyGrid

Using PropertyGrid
Send Feedback
Intersoft WebDesktop > WebPaneManager > Working with PaneManager Editor > Using PropertyGrid

Glossary Item Box

The property Grid which is used to display the properties of the currently selected Pane is not only useful for showing data. The other useful function is that changes made in the propertyGrid is automatically reflected to the UI in the Stage.

The PropertyGrid is able to reflect most of the properties related with Dimension and UserInterface, below are the list of properties supported:

  • Text
  • CaptionDisplayMode
  • Height
  • HeightValue
  • Width
  • WidthValue
  • GroupType (Only when GroupPane is selected)
  • GroupPaneHeaderVisible (Only when GroupPane is selected)
  • HeaderVisible (Only when Pane is selected)


Class Library

Class Library
Send Feedback

Glossary Item Box


WebDesktopClientSideEvents

WebDesktopClientSideEvents
Send Feedback

Glossary Item Box


WebDesktopManager

WebDesktopManager
Send Feedback

Glossary Item Box


WebDesktopShortcut

WebDesktopShortcut
Send Feedback

Glossary Item Box


WebDesktopShortcutSettings

WebDesktopShortcutSettings
Send Feedback

Glossary Item Box


WebDesktopTaskBarSettings

WebDesktopTaskBarSettings
Send Feedback

Glossary Item Box


WebDesktopTextSettings

WebDesktopTextSettings
Send Feedback

Glossary Item Box


WebDesktopWindow

WebDesktopWindow
Send Feedback

Glossary Item Box


WebDesktopWindowSettings

WebDesktopWindowSettings
Send Feedback

Glossary Item Box


Global Functions

Global Functions
Send Feedback

Glossary Item Box


Core

Core
Send Feedback

Glossary Item Box


WebDesktopClientSideEvents Properties

WebDesktopClientSideEvents Properties
Send Feedback

Glossary Item Box

WebDesktopClientSideEvents Properties

OnInitialize | Description Specifies the client side (JavaScript) function that will be invoked when the webdesktop is in initialization process. ValueType String Default Value
OnShortcutCreated | Description Specifies the client side (JavaScript) function that will be invoked when the webdesktop's shortcut is created ValueType String Default Value
OnShortcutSelected | Description Specifies the client side (JavaScript) function that will be invoked when the webdesktop's shortcut is selected ValueType String Default Value
OnShortcutBeforeLaunched | Description Specifies the client side (JavaScript) function that will be invoked before the webdesktop's shortcut is launched ValueType String Default Value
OnShortcutAfterLaunched | Description Specifies the client side (JavaScript) function that will be invoked after the webdesktop's shortcut is launched ValueType String Default Value
OnWindowCreating | Description Specifies the client side (JavaScript) function that will be invoked when creating window ValueType String Default Value
OnWindowCreated | Description Specifies the client side (JavaScript) function that will be invoked after the window is created ValueType String Default Value
OnWindowMinimized | Description Specifies the client side (JavaScript) function that will be invoked when the window is minimized ValueType String Default Value
OnWindowMaximized | Description Specifies the client side (JavaScript) function that will be invoked when the window is maximized ValueType String Default Value
OnWindowRestored | Description Specifies the client side (JavaScript) function that will be invoked when the window is restored ValueType String Default Value
OnWindowBeforeClosed | Description Specifies the client side (JavaScript) function that will be invoked before the window is closed ValueType String Default Value
OnWindowAfterClosed | Description Specifies the client side (JavaScript) function that will be invoked after the window is closed ValueType String Default Value
OnWindowResized | Description Specifies the client side (JavaScript) function that will be invoked when the window is resized ValueType String Default Value
OnWindowMoved | Description Specifies the client side (JavaScript) function that will be invoked when the window is moved ValueType String Default Value
OnContextMenu | Description Specifies the client side (JavaScript) function that will be invoked when the context menu is called ValueType String Default Value
OnWindowBeforeActivated | Description Specifies the client side (JavaScript) function that will be invoked before the window is activated ValueType String Default Value
OnWindowAfterActivated | Description Specifies the client side (JavaScript) function that will be invoked after the window is activated ValueType String Default Value


WebDesktopManager Properties

WebDesktopManager Properties
Send Feedback

Glossary Item Box

WebDesktopManager Properties

Windows | Description Gets the collection of Windows available in this DesktopManager instance ValueType Collection (ISArray) Default Value
ShortcutIcons | Description Gets the collection of shortcut icons available in this WebDesktop Manager ValueType Collection (ISArray) Default Value
WindowArrangement | Description Gets or sets window arrangement in this WebDesktop Manager ValueType String Default Value
TaskBarVisible | Description Gets or sets the value to indicate whether taskbar is visible in WebDesktop ValueType boolean Default Value
TaskBarSettings | Description Gets or sets the taskbar settings in WebDesktop Manager ValueType TaskBarSettings Default Value
ImagesSettings | Description Gets or sets the images settings in WebDesktop Manager ValueType ImageSettings Default Value
WindowSettings | Description Gets or sets the window settings ValueType WindowSettings Default Value
ShortcutIconsVisible | Description Gets or sets the value to indicate whether shortcut icons are visible in WebDesktop ValueType boolean Default Value
EnableAnimation | Description Gets or sets the value to indicate whether animation should be enabled in WebDesktop ValueType boolean Default Value
EnableKeyboardNavigation | Description Gets or sets the value to indicate whether keyboard navigation should be enabled in WebDesktop ValueType boolean Default Value
ClientSideEvents | Description Gets the object containing list of client side events. ValueType Default Value
ImagesDirectory | Description Gets or sets the images directory used in WebDesktop ValueType String Default Value
TextSettings | Description Gets or sets the text settings used in WebDesktop ValueType TextSettings Default Value
ShortcutSettings | Description Gets or sets shortcut settings ValueType ShortcutSettings Default Value
ActiveWindowIndex | Description Gets or sets the index of currently active window ValueType int Default Value
EnableContextMenu | Description Gets or sets the value to indicate whether context menu should be enabled when user right click on valid objects in DesktopManager ValueType boolean Default Value
ClientID | Description Gets the server control identifier generated by ASP.NET ValueType String Default Value
ID | Description Gets or sets the programmatic identifier assigned to the WebManager ValueType String Default Value
ActiveShortcutIndex | Description Gets or sets the index of currently active shortcut ValueType int Default Value
CreatedAtRuntime | Description Gets or sets the value to indicate whether the WebDesktopManager is created at runtime ValueType boolean Default Value


WebDesktopManager Methods

WebDesktopManager Methods
Send Feedback

Glossary Item Box

WebDesktopManager Methods

GetIFrameWindow Description
Get the IFrameWindow of the WebDesktopManager object by given name

Parameters
name ( String )
The name of IFrameWindow that you want to get.

Remarks

Return Value

object (window)

Samples

CreateWindow

Description
Creates a new WebDesktopWindow instance with default configurations

Parameters

Remarks

Return Value

object (WebDesktopWindow)

Samples

GetDocument

Description
Gets the WebDesktop document

Parameters

Remarks

Return Value

object

Samples

GetContentWindow

Description
Gets the WebDesktop content window

Parameters

Remarks

Return Value

object (WebDesktopWindow)

Samples

GetTaskBarElement

Description
Gets the HTML taskbar element of WebDesktop

Parameters

Remarks

Return Value

object (HTML element)

Samples

GetTaskBarWindowGroupElement

Description
Gets the HTML taskbar element of the WebDesktop's WindowGroup

Parameters

Remarks

Return Value

object (HTML element)

Samples

GetTaskBarLeftTemplateElement

Description
Gets the HTML taskbar element of WebDesktop's left template

Parameters

Remarks

Return Value

object (HTML element)

Samples

GetTaskBarRightTemplateElement

Description
Gets the HTML taskbar element of WebDesktop's right template

Parameters

Remarks

Return Value

object (HTML element)

Samples

GetDesktopElement

Description
Gets the HTML desktop element

Parameters

Remarks

Return Value

object (HTML element)

Samples

GetDesktopSize

Description
Gets the desktop size

Parameters

Remarks

Return Value

unit size

Samples

CascadeWindows Decription
Performs cascade windows tiling to all open Windows

Parameters
skipCustomLocation ( String )
Skip the windows if the location is custom

Remarks

Return Value

Samples

TileWindowsHorizontally Description
Tiling all open windows horizontally

Parameters
skipCustomLocation ( String )
Skip the windows if the location is custom

Remarks

Return Value

Samples

TileWindowsVertically Description
Tiling all open windows vertically

Parameters
skipCustomLocation ( String )
Skip the windows if the location is custom

Remarks

Return Value

Samples

GetActiveWindow

Description
Gets the active WebDesktopWindow instance

Parameters

Remarks

Return Value

object (WebDesktopWindow)

Samples

GetActiveShortcut

Description
Gets the WebDesktop active shortcut

Parameters

Remarks

Return Value

object (WebDesktopShortcut)

Samples

GetWindow Description
Gets WebDesktopWindow instance by given name

Parameters
name ( String )
Name of the window

Remarks

Return Value

object (WebDesktopWindow)
Samples

ResolveImagePath Description
Resolves the image path

Parameters
img ( )
path of the image

Remarks

Return Value

Samples

RearrangeShortCutIcons

Description
Rearrange WebDesktop's ShortCut Icons

Parameters

Remarks

Return Value

Samples

ShowShortcutIcons

Description
Show WebDesktop's ShortCut Icons

Parameters

Remarks

Return Value

Samples

HideShortcutIcons

Description
Hide WebDesktop's ShortCut Icons

Parameters

Remarks

Return Value

Samples

ShowDesktop

Description
Minimize all Window and show the Desktop

Parameters

Remarks

Return Value

Samples

SaveDesktopStateToXml

Description
Save Desktop State to XML object

Parameters

Remarks

Return Value

xml object

Samples

GetNotificationControl

Description

Parameters

Remarks

Return Value

Samples


WebDesktopShortcut Properties

WebDesktopShortcut Properties
Send Feedback

Glossary Item Box

WebDesktopShortcut Properties

Name | Description Gets the name of the WebDesktopShortcut control. ValueType String Default Value
Index | Description Gets or sets the index of the WebDesktopShortcut object. ValueType String Default Value
DesktopManager | Description Gets or sets the DesktopManager instance associated with WebDesktopShortcut control. ValueType DesktopManager Default Value
Text | Description Gets or sets the text caption displayed in the WebDesktopShortcut control. ValueType String Default Value
TargetURL | Description Gets or sets the target URL of WebDesktopShortcut. ValueType String Default Value
WindowName | Description Gets or sets the WebDesktopWindow's name associated with the WebDesktopShortcut. ValueType String Default Value
Visible | Description Gets the value that indicates whether the control is visible. ValueType Boolean Default Value True
Enabled | Description Gets the value that indicates whether the WebDesktopShortcut control is enabled. ValueType Boolean Default Value True
Location | Description Gets or sets the location of WebDesktopShortcut. ValueType OffsetLocation Default Value
Collection | Description Gets the Collection that contains the WebDesktopShortcut. ValueType Array Default Value
ToolTip | Description Gets or sets the tool tip text that will be displayed on mouse over action. ValueType String Default Value
TargetControlBoxImage | Description Gets or sets the image that will be displayed as the control box image of WebDesktopShortcut. ValueType String Default Value


WebDesktopShortcut Methods

WebDesktopShortcut Methods
Send Feedback

Glossary Item Box

WebDesktopShortcut Methods

GetElement Description
Returns the outer part of Frame element of WebDesktopShortcut.

Parameters

Remarks

Return Value
object (HTML element)

GetTextElement Description
Returns the text element of WebDesktopShortcut.

Parameters

Remarks

Return Value
object (HTML element)

Rearrange Description
Rearranges the collection of WebDesktopShortcut.

Parameters

Remarks

Return Value
void

Select Description
Selects the WebDesktopShortcut.

Parameters

Remarks

Return Value
void

Open Description
Opens the WebDesktopWindows associated with the WebDesktopShortcut.

Parameters

Remarks

Return Value
void

SetText Description
Sets the text property of WebDesktopShortcut.

Parameters

Remarks

Return Value
void

Delete Description
Deletes the WebDesktopShortcut.

Parameters

Remarks

Return Value
void

Show Description
Show the WebDesktopShortcut.

Parameters

Remarks

Return Value
void

Hide Description
Hide the WebDesktopShortcut.

Parameters

Remarks

Return Value
void


WebDesktopShortcutSettings Properties

WebDesktopShortcutSettings Properties
Send Feedback

Glossary Item Box

WebDesktopShortcutSettings Properties

AllowAutoArrange | Description Specifies whether the WebDesktopShortcut will be automatically arranged when moved. ValueType Boolean Default Value true
Movable | Description Specifies whether the WebDesktopShortcut is able to be moved. ValueType Boolean Default Value true


WebDesktopTaskBarSettings Properties

WebDesktopTaskBarSettings Properties
Send Feedback

Glossary Item Box

WebDesktopTaskBarSettings Properties

Position | Description Gets or sets the position of the taskbar. ValueType OffsetLocation Default Value
Movable | Description Specifies whether the taskbar is able to be moved. ValueType Boolean Default Value
Resizable | Description Specifies whether the taskbar is able to be resized. ValueType Boolean Default Value
ShowWindows | Description Specifies whether the opened windows should be displayed in the Taskbar. ValueType Boolean Default Value
WindowButtonWidth | Description Gets or sets the width of the button inside the Taskbar. ValueType Integer Default Value


WebDesktopTextSettings Properties

WebDesktopTextSettings Properties
Send Feedback

Glossary Item Box

WebDesktopTextSettings Properties

InProgressText | Description Specifies the text configuration that will be displayed for all inprogress processing behaviors. ValueType String Default Value
MaximizeText | Description Specifies the text configuration that will be displayed for all maximizing behaviors. ValueType String Default Value
MinimizeText | Description Specifies the text configuration that will be displayed for all minimizing behaviors. ValueType String Default Value
RestoreText | Description Specifies the text configuration that will be displayed for all restoring behaviors. ValueType String Default Value
CloseText | Description Specifies the text configuration that will be displayed for all closing behaviors. ValueType String Default Value


WebDesktopWindow Properties

WebDesktopWindow Properties
Send Feedback

Glossary Item Box

WebDesktopWindow Properties

AllowMinimize | Description Gets or sets whether minimizing WebDesktopWindow control is allowed. ValueType String Default Value "Default"
AllowMaximize | Description Gets or sets whether maximizing WebDesktopWindow control is allowed. ValueType String Default Value "Default"
AllowResize | Description Gets or sets whether resizing WebDesktopWindow control is allowed. ValueType String Default Value "Default"
AllowClose | Description Gets or sets whether closing WebDesktopWindow control is allowed. ValueType String Default Value "Default"
ControlBox | Description Gets or sets the value indicating whether a control box is displayed in the caption bar of the WebDesktopWindow. ValueType Boolean Default Value
Text | Description Gets or sets the text caption displayed in the WebDesktopWindow control. ValueType String Default Value
TextAlignment | Description Gets or sets the text alignment displayed in the WebDesktopWindow control. ValueType String Default Value
CaptionDisplayMode | Description Gets or sets the display mode of the caption of WebDesktopWindow. ValueType String Default Value
ContentMode | Description Gets or sets whether the content of this Window is using native HTML content or IFrame. ValueType String Default Value
ClientVisible | Description Indicates whether the WebDesktopWindow is visible in the client side at initialization. ValueType Boolean Default Value
Size | Description The size of the WebDesktopWindow control. ValueType UnitSize Default Value
MaximumSize | Description The Maximum size of the WebDesktopWindow control. ValueType UnitSize Default Value
MinimumSize | Description The Minimum size of the WebDesktopWindow control. ValueType UnitSize Default Value
Location | Description Gets or sets the location of WebDesktopWindow control. ValueType String Default Value
Name | Description Gets the name of the WebDesktopWindow control. ValueType String Default Value
InProgressText | Description Gets or sets the text of the InProgressText. ValueType String Default Value
ShowInTaskBar | Description Indicates whether to show the WebDesktopWindow in task bar. ValueType Boolean Default Value
ControlBoxImage | Description Gets or sets the image displayed in the WebDesktopWindow control. ValueType String Default Value
ShortcutImage | Description Gets or sets the image that will be used in WebDesktopShortcut that links to this window. ValueType String Default Value
Index | Description Gets or sets the index of the WebDialogBoxButton object. ValueType String Default Value
DesktopManager | Description Gets or sets the DesktopManager instance associated with WebDialogBoxButton control. ValueType DesktopManager Default Value
ContentURL | Description Gets or sets the URL string of a page that will be displayed inside the container (Window, Pane, Tab). ValueType String Default Value
Collection | Description Gets the Collection that contains the WebDesktopWindow. ValueType Array Default Value
IsClosed | Description Indicates whether or not the WebDesktopWindow is closed. ValueType Boolean Default Value
Initialized | Description Indicates whether or not the WebDesktopWindow has been initialized. ValueType Boolean Default Value
IFrameContentLoaded | Description Indicates whether or not the IFrame content has been loaded. ValueType Boolean Default Value
WindowState | Description Gets or sets the WebDesktopWindow's state ValueType Boolean Default Value
CreatedAtRuntime | Description Indicates whether or not the WebDesktopWindow is created at runtime. ValueType Boolean Default Value
DialogBoxShown | Description Determines whether the dialog box should be shown. ValueType Boolean Default Value
CurrentDialogBox | Description Gets the currently active dialog box owned by the WebDesktopWindow. ValueType WebDialogBox Default Value


WebDesktopWindowSettings Properties

WebDesktopWindowSettings Properties
Send Feedback

Glossary Item Box

WebDesktopWindowSettings Properties

AllowMinimize | Description Specifies whether the WebDesktopWindow object is able to be minimized. ValueType Boolean Default Value
AllowMaximize | Description Specifies whether the WebDesktopWindow object is able to be maximized. ValueType Boolean Default Value
AllowResize | Description Specifies whether the WebDesktopWindow object is able to be resized. ValueType Boolean Default Value
AllowClose | Description Specifies whether the WebDesktopWindow object is able to be closed. ValueType Boolean Default Value
ControlBox | Description Gets or sets the value indicating whether a control box is displayed in the caption bar of the WebDesktopWindow. ValueType Boolean Default Value
CaptionDisplayMode | Description Gets or sets the display mode of the caption of WebDesktopWindow. ValueType String Default Value
ContentMode | Description Gets or sets whether the content of the WebDesktopWindow is using native HTML content or IFrame. ValueType String Default Value
Size | Description Gets or sets the size of WebDesktopWindow. ValueType UnitSize Default Value
MaximumSize | Description Gets or sets the maximum size of WebDesktopWindow. ValueType UnitSize Default Value
MinimumSize | Description Gets or sets the minimum size of WebDesktopWindow. ValueType UnitSize Default Value
BorderType | Description Gets or sets the border type of WebDesktopWindow. ValueType Default Value


WebButton

WebButton
Send Feedback

Glossary Item Box


WebButton Properties

WebButton Properties
Send Feedback

Glossary Item Box

WebButton Properties

Text | Description Gets or sets the text caption displayed in the Button control ValueType String Default Value
Type | Description Gets or sets the type of Button control ValueType String Default Value
Parameter | Description Gets the parameter of the Button control ValueType String Default Value
IntegratedToDesktopManager | Description Gets or sets the status of whether the Button control is integrated to Desktop Manager or not ValueType boolean Default Value False
AutoPostback | Description Specifies whether Postback will be automatically invoked when the button is clicked ValueType boolean Default Value False
OnClientClick | Description Specifies the client-side function to be invoked when a client performs a click event ValueType String Default Value
OnClientResponse | Description Specifies the client-side function to be invoked when a response from client is returned, irregardless of a successful response or error response ValueType String Default Value
PostBackMode | Description Gets or sets whether the postback should be performed by using OnTheFly or FullPagePostback mode when the Button control is clicked. ValueType PostbackMode Default Value OnTheFly
DisableOnClicked | Description Gets or sets whether this button control will be disabled on click event ValueType boolean Default Value False
ClientID | Description Gets the server control identifier generated by ASP.NET ValueType String Default Value The server control identifier generated by ASP.NET
ID | Description Gets or sets the programmatic identifier assigned to the Button control ValueType String Default Value The programmatic identifier assigned to the control
FlyPostBackSettings | Description Configures the settings used by the control when performing OnTheFly postback. ValueType FlyPostBackSettings object Default Value
DesktopManager | Description Gets or sets the DesktopManager instance associated with this Button control ValueType DesktopManager object Default Value


WebButton Methods

WebButton Methods
Send Feedback

Glossary Item Box

WebButton Methods

GetElement Description
Gets the HTML element from current button

Parameters

Remarks

Return Value
object ( HTML element)

Samples

Disable Description
Disable the button control

Parameters

Return Value
void

Enable Description
Enable the button control

Parameters

Return Value
void

Click Description
Invoke the Click event from this WebButton

Parameters

Return Value
void


WebDialogBox

WebDialogBox
Send Feedback

Glossary Item Box


WebDialogBoxButton

WebDialogBoxButton
Send Feedback

Glossary Item Box


WebDialogBoxClientSideEvents

WebDialogBoxClientSideEvents
Send Feedback

Glossary Item Box


WebDialogBox Properties

WebDialogBox Properties
Send Feedback

Glossary Item Box

WebDialogBox Properties

CommandButtons | Description Creates command buttons in the dialog box. ValueType Object Default Value
WindowSettings | Description Get or sets the global settings of Window. ValueType Object Default Value
Text | Description Gets or sets the text caption displayed in the WebDialogBox control. ValueType String Default Value
Location | Description Gets or sets the location of WebDialogBox control. ValueType OffsetLocation Default Value
ControlBoxImage | Description Gets or sets the image displayed in the WebDialogBox caption. ValueType String Default Value
ContentURL | Description Gets or sets the URL string of a page that will be displayed inside the container (Window, Pane, Tab). ValueType String Default Value
IntegratedToDesktopManager | Description Gets or sets the status of whether the WebDialogBox control is integrated to Desktop Manager or not. ValueType Boolean Default Value
ClientSideEvents | Description Represents ClientEvents object that hold list of client events. ValueType Object (WebDialogBoxClientSideEvents) Default Value
InProgressText | Description Gets or sets the text displayed when the IFrame is in loading progress. ValueType String Default Value
StartPosition | Description Gets or sets the initial startup position of WebDialogBox. ValueType OffsetLocation Default Value
ClientID | Description Gets the server control identifier generated by ASP.NET. ValueType String Default Value
ID | Description Gets or sets the programmatic identifier assigned to the WebDialogBox control. ValueType Default Value
Window | Description Returns the WebDesktopWindow object associated with the WebDialogBox ValueType WebDesktopWindow Default Value
ParentWindow | Description Gets the parent Window of the WebDialogBox object. ValueType WebDesktopWindow Default Value


WebDialogBoxButton Properties

WebDialogBoxButton Properties
Send Feedback

Glossary Item Box

WebDialogBoxButton Properties

Text | Description Gets or sets the text caption displayed in the WebDialogBoxButton control. ValueType String Default Value
Enabled | Description Gets the value that indicates whether the WebDialogBoxButton control is enabled. ValueType Boolean Default Value True
Name | Description Gets the name of the WebDialogBoxButton control. ValueType String Default Value
Type | Description Gets or sets the type of WebDialogBoxButton control. ValueType String Default Value
Parameter | Description Gets the parameter of the WebDialogBoxButton control. ValueType String Default Value
DesktopManager | Description Gets or sets the DesktopManager instance associated with WebDialogBoxButton control. ValueType Default Value DesktopManager
Index | Description Gets or sets the index of the WebDialogBoxButton object. ValueType String Default Value


WebDialogBoxClientSideEvents Properties

WebDialogBoxClientSideEvents Properties
Send Feedback

Glossary Item Box

WebDialogBoxClientSideEvents Properties

OnCreated | Description Specifies the client-side function to be invoked when WebDialogBox is created. ValueType String Default Value
OnClosed | Description Specifies the client-side function to be invoked when a WebDialogBox is closed. ValueType String Default Value
OnButtonClicked | Description Specifies the client-side function to be invoked when a WebDialogBoxButton is clicked. ValueType String Default Value


WebPaneBase

WebPaneBase
Send Feedback

Glossary Item Box


WebPane

WebPane
Send Feedback

Glossary Item Box


WebPaneClientSideEvents

WebPaneClientSideEvents
Send Feedback

Glossary Item Box


WebPaneManager

WebPaneManager
Send Feedback

Glossary Item Box


WebPaneSettings

WebPaneSettings
Send Feedback

Glossary Item Box


WebPaneTextSettings

WebPaneTextSettings
Send Feedback

Glossary Item Box


Apply Modification

Apply Modification
Send Feedback
Intersoft WebDesktop > WebPaneManager > Working with PaneManager Editor > Apply Modification

Glossary Item Box

After modification to the object passed in PaneManager Editor is finished, you can then apply the modification by using the OK button at the bottom of the editor. The editor will be automatically closed and you will be returned to the VisualStudio .NET IDE. In the design surface you will then see the new layout applied previously in the Editor.

As opposed if you click Cancel instead, the modification done to the grid will not be applied and you will get the original object you previously passed to the editor.


Understanding Concepts

Understanding Concepts
See Also Send Feedback
Intersoft WebDesktop > WebPaneManager > Understanding Concepts

Glossary Item Box

Main Concept

WebPaneManager Layout concept is based on WebPane object and WebGroupPane object which support unlimited nested level of another WebPane or WebGroupPane objects.

WebPane is the lowest level object which represent a Pane. A Pane is similar to Panel which can contain server side controls or html controls when used in UseInlineContent mode.

WebGroupPane has the same terminology and function as in WebPane with one exception, that is WebGroupPane is used to contain collection of Panes and can not contain server side controls. So, WebGroupPane represents a Pane which contains nested children of type WebPane or WebGroupPane.

WebGroupPane can be used to layout the contained children in Horizontal Tiling or Vertical Tiling arrangement. The combination of WebGroupPane with its arrangement mode and nested WebPane enables you to create any kind of complex Layout in consistent fashion by using strong object model.

Object Hierarchy Concept and Diagram

The following diagram illustrates a nested complex Layout represented in WebPaneManager. Each part of the marked bullet will be described below.

WebPaneManager starts with RootGroupPane which is the root of WebGroupPane object. The RootGroupPane in the above illustration has its GroupType set to VerticalTile. The default value for GroupType in a WebGroupPane is VerticalTile.
The "Side" Pane is represented as WebPane object, which is the children of "RootGroupPane" GroupPane.

The "GroupPaneContent" Pane is represented as WebGroupPane object, which is the children of "RootGroupPane" GroupPane and the sibling of "Side" Pane. The GroupPaneContent itself contains another nested children of WebPane and WebGroupPane objects.

The GroupPaneContent's GroupType is set to HorizontalTile.
The "Pane Top" is a WebPane object, the first children of GroupPane Content.
GroupPaneContent0 is a WebGroupPane object which GroupType is VerticalTile. It is the second children of GroupPane Content, or the next sibling of "Pane Top" WebPane.
A WebPane, the first children of GroupPaneContent0
A WebPane, the second children of GroupPaneContent0
A WebPane, the third children of GroupPaneContent0

The above illustration's object hierarchy can be shown in the following:

See Also

Related Topics
{Overview}
{Features}


Working with ClickAndEdit and Designers

Working with ClickAndEdit and Designers
Send Feedback
Intersoft WebDesktop > WebPaneManager > Working with ClickAndEdit and Designers

Glossary Item Box

WebPaneManager component comes with rich designtime support that take advantage of new Visual Studio 2005 designer architecture. Combining with Intersoft's unique ClickAndEdit and ClickAndSelect technologies, WebPaneManager brings you a new level of design experience with richer WYSIWYG editing mode.

Image 1 - The design time environment of WebPaneManager in Visual Studio 2005

The Mail WebPane is configured to use InlineContent mode. When using this mode, content of the Pane can be directly edited by clicking on the "dashed-border box". You can put any controls inside the Content, including server side controls, html contols, user controls and so on. The Pane with InlineContent mode will be persisted in ContentTemplate property seemlessly. The ability to click on the region and edit inside the component directly is known as ClickAndEdit technology.
The Find WebPane used InlineContent mode. As illustrated in above image, it can contain html table with WebCombo.NET and WebButton.NET. Scrollbar will automatically appear when the content exceeds the boundary of the dimension.
The Messages WebPane is configured to use IFrame content mode. When the ContentURL is already specified, a Button "Edit [Page]" will appear in the center of the Pane. This is called ClickAndSelect technology, where you can interact with the design time object directly inside the component region. When the Button is clicked, it will open the specified WebForm in Visual Studio 2005.
The MessageDetails WebPane is configured to use IFrame content mode. When there is no ContentURL specified yet, the Button "[Specify ContentURL]" will appear to let you easily specify the ContentURL for the specified Pane. An URL Picker DialogBox will appear as soon as you click on the Button, and accept the changes in HTML once applied.

All Intersoft's components come with rich designtime experience enabling you to be more productive in designing and developing rapid web applications. The rich designtime experience includes the visual designtime styles and appearances, behaviors and layout which offer WYSIWYG representation of the runtime display. Furthermore, the designtime experience is even more enhanced and improved in Visual Studio 2005 with the introduction ClickAndEdit and ClickAndSelect technologies.


Splitter Integration

Splitter Integration
Send Feedback
Intersoft WebDesktop > WebPaneManager > Splitter Integration

Glossary Item Box

WebPaneManager integrates closely with WebSplitter in order to provide sophisticated resizing and collapsing functionalities. The functions can be configured in the properties described in following:

  • AllowResize

    The default value in Global level is True. When enabled, users can resize the Pane conveniently in runtime. This feature can be configured in Global level and Individual Pane level.

    When a WebPane's AllowResize is set to False, the WebPane in its next sibling would also be affected (disabled as well) since that resizing process involves two paired Panes.

    In above illustration, The "Side" and "Pane Top" can't be resized vertically because the "Side" Pane has its AllowResize set to No which affect its next sibling although the "Pane Top" is configured to use Default (in this case Yes since its Global PaneSettings is Yes). However, the horizontal resizing between "Pane Top" and "Pane Bottom" can be performed as desired.
  • AllowCollapse

    The default value in Global level is False. The best recommendation for enabling this feature is by configuring the AllowCollapse in Individual Pane level so that you can have more control over which direction should the Pane collapsed to. To better understand the usage of AllowCollapse, please see following illustration.

    The images for Splitter's Grip can be customized in ImagesSettings. The dynamic interactive style for Splitter (used for resizing) can also be customized in SplitterStyle.


Tutorials

Tutorials
Send Feedback
Intersoft WebDesktop > WebPaneManager > Tutorials

Glossary Item Box

This section contains tutorial topics in WebPaneManager.

In This Section

Creating Simple Layout

Creating Layout from Predefined Template

Creating Outlook 2003 Style Layout

Creating Complex Layout using Editor

Using CaptionMode Types

Using IFrame as ContentMode

Configuring Styles and Appearance

How-to: Customize styles

How-to: Configure Allow Collapse

How-to: Load layout programmatically in Server-side

How-to: Prevent resize on specific pane


Creating Simple Layout

Creating Simple Layout
See Also Send Feedback
Intersoft WebDesktop > WebPaneManager > Tutorials > Creating Simple Layout

Glossary Item Box

Objectives

To create a simple layout such as HeaderSide Layout, you can use our WebPaneManager Advanced Designer to aid you in doing it conveniently.

  1. Drag the WebPaneManager component from the Toolbox into the WebForm.
    Remember to remove the DOCTYPE declaration and the html tag's xmlns attribute from the form before doing this.

  2. Right Click on a WebPaneManager instance and choose WebPaneManager Advanced Designer.

  3. You will immediately have a Vertical "Root" GroupPane with a Pane inside of it. Named the Pane as Header. Change the "Root" GroupPane GroupType property to Horizontal then add a new GroupPane to the GroupPane. Named the newly added GroupPane as GroupContent.

  4. Adjust the height of "Header" Pane and "GroupContent" GroupPane by using splitter. Simply mouse over space between them and your mouse cursor will change into a splitter.
  5. Set the GroupContent GroupType property to Vertical, then add 2 Panes to the GroupContent. Named the first pane as "Side" and the second one as "Content".

  6. Finally, adjust the width of "Side" Pane and "Content" Pane using the splitter.

See Also

Related Tutorials
{Creating Layout from Predefined Template}
{Creating Outlook 2003 Style Layout}
{Creating Complex Layout using Editor}
{Configuring Collapsible Pane}
{Disabling Resizing for specific Pane}
{Using CaptionMode Types}
{Using IFrame as ContentMode}
{Configuring Styles and Appearance}


Creating Layout from Predefined Template

Creating Layout from Predefined Template
See Also Send Feedback
Intersoft WebDesktop > WebPaneManager > Tutorials > Creating Layout from Predefined Template

Glossary Item Box

Objectives

In most cases you will only need to Layout your page using common layouting. For this purpose, a set of common layout has been provided for you such as HeaderAndSide, HeaderFooterAndSide, and more.

Here is step by step guide to use this feature:

  1. Drag the WebPaneManager component from the Toolbox into WebForm.
    Remember to remove the DOCTYPE declaration and the html tag's xmlns attribute from the form before doing this.

  2. Right Click on a WebPaneManager instance and choose WebPaneManager Advanced Designer.

  3. Once the Advanced Designer Form is popped, in the first toolStrip click on "Pick Template Layout / Create Custom Tabular" (refer to Pick Template Layout). Simply choose the Layout you desire.
  4. Once you choose your layout and click Apply, you will be returned to the designer then click OK to apply it in VS Design Surface. (Assuming you pick the HeaderFooter&Side template layout, you will get as below in your design surface).

See Also

Related Tutorials
{Creating Simple Layout}


Creating Outlook 2003 Style Layout

Creating Outlook 2003 Style Layout
See Also Send Feedback
Intersoft WebDesktop > WebPaneManager > Tutorials > Creating Outlook 2003 Style Layout

Glossary Item Box

Objectives

To create Outlook 2003 Style Layout using WebPaneManager is fairly easy. Outlook 2003 style is very popular because its convenient layouting and sizeable panes.

  1. Drag the WebPaneManager component from the Toolbox into the WebForm.
    Remember to remove the DOCTYPE declaration and the html tag's xmlns attribute from the form before doing this.

  2. Right Click on a WebPaneManager instance and choose WebPaneManager Advanced Designer.

  3. Use the WebPaneManager Advanced Designer to configure the appearance resembling the style below:

    • Basically, what we are trying to do is to layout so there will be 3 main panes which are Mail, Messages, MessageDetails. However, we also need a "No Header" Pane above Messages Pane (the pane highlighted in the image above). This pane will be used as a place holder for frequently-used actions controls.
    • Next, configure the "Messages" Pane ContentMode property as "UseIFrame", since we are going to need to refresh the Messages Pane when a hyperlink in "Mail" Pane is clicked.

    • Next, you will need to configure the ContentTemplate for "Mail" Pane, the desired result will be as below when viewed in source mode

      C# Copy Code
      <ISWebDesktop:WebPane AllowCollapse="Yes" Name="paneMail" Text="Mail" Width="Custom"
          WidthValue="30%">
          <ContentTemplate>
              <asp:HyperLink ID="HyperLink1" runat="server" NavigateUrl="Inbox.aspx" Target="paneMessages">Inbox</asp:HyperLink><br />
              <br />
              <asp:HyperLink ID="HyperLink2" runat="server" NavigateUrl="Empty.aspx" Target="paneMessages">Calendar</asp:HyperLink>
              <br />
          </ContentTemplate>
      </ISWebDesktop:WebPane>
    • One thing to note here is you must not forget to set the Target of the Hyperlink to "paneMessages" as now the "Messages" Pane has been configured to use IFrame as its content

See Also

Related Tutorials
{Creating Simple Layout}


Creating Complex Layout using Editor

Creating Complex Layout using Editor
See Also Send Feedback
Intersoft WebDesktop > WebPaneManager > Tutorials > Creating Complex Layout using Editor

Glossary Item Box

Objectives

Creating complex layout is now simpler than ever. Knowing the limitations and complexity of layout relying solely on the tools provided in VS.NET, we decided to build an external designer solely to aid WebPaneManager users to design and layout conveniently.

  1. Drag the WebPaneManager component from the Toolbox into the WebForm.
    Remember to remove the DOCTYPE declaration and the html tag's xmlns attribute from the form before doing this.

  2. Right Click on a WebPaneManager instance and choose WebPaneManager Advanced Designer.

  3. Use the toolbars on WebPaneManager Advanced Designer to create the layout. You can choose to add either GroupPane or a normal pane.

  4. To create another GroupPane, click on the [image] or if you would like to create a sibling group pane, click on and choose whether you would like to create a vertical or horizontal sibling group pane. Your decision on Vertical or Horizontal will control the layout inside that group pane.

  5. To create another normal Pane, click on the [image].

  6. To create a sibling pane, simply click on the [image] which would create another equal size in the selected group pane.

  7. You also can convert the normal pane become a GroupPane, by clicking on the normal pane that you would like to convert, then click on [image].

  8. Finally, you can create something like this with only clicking on the button.

  9. Once you satisfied with your design, you can click on "OK" to apply it.

  10. To put any text or any control inside WebPaneManager, simply click on the area inside WebPane, and start edit it.

About How to fully utilize the WebPaneManager external Editor you can refer to Working with PaneManager editor section.

See Also

Related Tutorials
{Creating Simple Layout}


Using CaptionMode Types

Using CaptionMode Types
See Also Send Feedback
Intersoft WebDesktop > WebPaneManager > Tutorials > Using CaptionMode Types

Glossary Item Box

Objectives

You can customize the caption appearance of a WebPane in WebPaneManager. All you need to do is set the WebPane CaptionDisplayMode property. The value of the property is an enumeration of type AllowCollapse which values are

C# Copy Code
/// <summary>
/// Enumerations for caption or footer display mode.
/// </summary>
public enum DisplayMode
{
    Default = 0,
    /// <summary>
    /// Only Text will be rendered.
    /// </summary>
    Text = 1,
    /// <summary>
    /// Text and Image will be rendered.
    /// </summary>
    TextAndImage = 2,
    /// <summary>
    /// Only Image will be rendered.
    /// </summary>
    Image = 3,
    /// <summary>
    /// The container should render the content specified in the Template, ignoring built-in rendering mechanism.
    /// </summary>
    UseTemplate = 4
}

The last enumeration value enables you to write your own implementation how the Caption should be rendered. You can write the implementation inside the <HeaderTemplate> tag under the Source View in the Design Surface.

  1. You can access that property during DesignTime either by right clicking the WebPaneManager and choosing WebPane Designer or WebPane Advanced Designer.
  2. In the snapshot below, the Pane Content CaptionDisplayMode property is set to Image. It makes the image of the Pane will appear at Run-time. Therefore, no Header Text will be visible.

See Also

Related Tutorials
{Creating Simple Layout}


Using IFrame as ContentMode

Using IFrame as ContentMode
See Also Send Feedback
Intersoft WebDesktop > WebPaneManager > Tutorials > Using IFrame as ContentMode

Glossary Item Box

Objectives

You can use IFrame as a content in a WebPane. This property is only available for a WebPane object and not available in WebGroupPane.
The value of the property is an enumeration of type ContentMode which values are

C# Copy Code
/// <summary>
/// Enumerations for the content mode used by a container.
/// </summary>
public enum ContentMode
{
    /// <summary>
    /// The default content mode.
    /// </summary>
    Default = 0,
    /// <summary>
    /// The content is specified in Template.
    /// </summary>
    UseInlineContent = 1,
    /// <summary>
    /// The content is specified in another page which displayed in an IFrame.
    /// </summary>
    UseIFrame = 2
}

  1. You can access that property during DesignTime either by right clicking the WebPaneManager and choosing WebPane Designer or WebPane Advanced Designer.
  2. When you choose the value of that property as UseIFrame, you can specify the ContentURL property as that property will only be used when the value of Content mode is set to UseIFrame. For example you can put ~/About.aspx as the value of ContentURL.
  3. In the snap shot below inside WebPaneManager Advanced Designer, the middle Pane is configured using IFrame Content mode.

  4. Once you return to the VisualStudio Design Surface, you will get something like below:

  5. If you notice, there is a button in the middle Pane with a Text "Edit About.aspx", when the button is clicked you will be automatically redirected to About.aspx page and it will appear in the Design Surface.

If you still insist on using the InlineContent because you want to have other implementations in that WebPane, that is also possible.

To do that you can simply click on the Source Button in the VisualStudio Design Surface and write the <iframe> HTML Tag inside the Content Template tag. Below is one implementation how a WebPane with ContentMode = UseInlineContent can contain an iframe.
Script Copy Code
<iswebdesktop:webpane>
    <contenttemplate>
        <b>This is my iframe in a template</b>
        <iframe id="left" src="About.aspx" height="100%" width="100%">
        </iframe>
    </contenttemplate>
</iswebdesktop:webpane>

See Also

Related Tutorials
{Creating Simple Layout}


Configuring Styles and Appearance

Configuring Styles and Appearance
See Also Send Feedback
Intersoft WebDesktop > WebPaneManager > Tutorials > Configuring Styles and Appearance

Glossary Item Box

Objectives

This tutorial objective is to show developer by demonstrating the properties which will affect the style and appearance in WebPaneManager. Basically, the properties are divided into 3 which are BasePane, GroupPane and Pane properties.

BasePane properties are inherited by both GroupPane and Pane, for example: CaptionDisplayMode. There are also other properties such as GroupPaneHeaderVisible for GroupPane and HeaderVisible for Pane.

The most important thing though, is the ability to inherit properties set at parent level. You can set the PaneSettings property of WebPaneManager and when it is set, it will automatically be inherited to all Panes contained in WebPaneManager.

This tutorial will guide you to configure the styles and appearance to suit your requirement.

  1. Basically, several designers have been provided for you to aid you in this. The WebPaneManager Designer and WebPaneManager Advanced Designer are both available to be utilized for this purpose. To use the Advanced Designer, simply right click on the WebPaneManager, and choose "WebPaneManager Advanced Designer", and to use WebPaneDesigner, click on "WebPaneManager Designer".

  2. If you want to set individual Pane properties, using the "WebPaneManager Advanced Designer" is highly recommended.
  3. But if you want to set the PaneSettings property which will be inherited to all panes, the WebPaneManager designer will be the right option. It categorizes the PaneSettings sub properties in a convenient way for you to work with.

See Also

Related Tutorials
{Creating Simple Layout}


How-to: Customize styles

How-to: Customize styles
Send Feedback
Intersoft WebDesktop > WebPaneManager > Tutorials > How-to: Customize styles

Glossary Item Box

WebPaneManager has various built-in predefined styles that you can choose.

This topic will show you how to customize styles.

To customize styles

  1. Right click on WebPaneManager control and choose Properties.
  2. Switch to Layout Manager tab and expand Predefined Layout.
  3. You can select any built-in style available in the layout manager.


How-to: Hide pane initially

How-to: Hide pane initially
Send Feedback
Intersoft WebDesktop > WebPaneManager > Tutorials > How-to: Hide pane initially

Glossary Item Box

WebPaneManager provides property to show/hide pane.

This topic will show you how to hide pane initially.

To hide pane initially

  1. Create 3 panes using WebPaneManager Advanced Designer to produce Top, Middle and Bottom panes.
  2. Select the Top pane and set Visible to False.
  3. When you run the project, the Top pane will be hidden initially.
  4. You can use a button to show the Top pane. Place the following code in Button click server-side event.
    C# Copy Code
    protected void Button1_Click(object sender, EventArgs e)
{
   WebPaneManager1.RootGroupPane.Panes[0].Visible = true;
}


How-to: Configure Allow Collapse

How-to: Configure Allow Collapse
Send Feedback
Intersoft WebDesktop > WebPaneManager > Tutorials > How-to: Configure Allow Collapse

Glossary Item Box

You can have a collapsible pane in WebPaneManager.

This topic will show you how to configure Allow Collapse.

To configure Allow Collapse

  1. Create pane layout using WebPaneManager Advanced Designer.
  2. In WebPaneManager Advanced Designer, select a pane to be collapsible and set AllowCollapse to Yes.
  3. Go to WebPaneManager Designer >> Images Settings.
  4. Set SplitterGridBottom to SplitterDown.gif, SplitterGridLeft to SpliterLeft.gif, SplitterGridRight to SplitterRight.gif and SplitterGridTop to SplitterTop.gif.
  5. Run the project.


How-to: Load layout programmatically in Server-Side

How-to: Load layout programmatically in Server-Side
Send Feedback
Intersoft WebDesktop > WebPaneManager > Tutorials > How-to: Load layout programmatically in Server-Side

Glossary Item Box

You can load WebPaneManager dynamically from runtime.

This topic will show you how to load layout programmatically in Server-Side.

To load layout programmatically in Server-Side

  1. Drag WebPaneManager control to the WebForm.
  2. Create xml file that contains layout structure of the panes.
    <WebGroupPane GroupType="VerticalTile" Name="RootGroup">
  <Panes>
    <WebPane WidthValue="30%" ContentScrollable="False" Text="Mail" Width="Custom" AllowCollapse="Yes" Name="paneMail">
      <ContentPadding />
    </WebPane>
    <WebGroupPane Text="GroupPane 0" Name="GroupPane0">
      <Panes>
        <WebPane Visible="False" HeaderVisible="No" HeightValue="30px" AllowResize="No" Height="Custom" AllowCollapse="No" Name="paneFind">
          <ContentPadding Top="0px" Left="0px" Bottom="0px" Right="0px" />
        </WebPane>
        <WebPane CaptionDisplayMode="TextAndImage" ContentMode="UseIFrame" Text="Messages" AllowCollapse="Yes" Image="../Images/Inbox.gif" Name="paneMessages" HeaderAppearance="UseMainStyle" ContentURL="../Empty.aspx">
          <ContentPadding />
        </WebPane>
        <WebPane ContentMode="UseIFrame" Text="Message Details" Name="paneMessageDetail" HeaderAppearance="UseSubStyle">
          <ContentPadding />
        </WebPane>
      </Panes>
    </WebGroupPane>
  </Panes>
</WebGroupPane>
  3. Place the following code in Page_Load event to load the layout structure from xml file.
    C# Copy Code
    protected void Page_Load(object sender, EventArgs e)
{
   WebPaneManager1.LoadPanesStructureFromXml(Server.MapPath("../Structures/SampleWebPaneManager.xml"));
}

  4. Run the project and WebPaneManager will load the layout programmatically using the xml file.


How-to: Prevent resize on specific pane

How-to: Prevent resize on specific pane
Send Feedback
Intersoft WebDesktop > WebPaneManager > Tutorials > How-to: Prevent resize on specific pane

Glossary Item Box

WebPaneManager offers the flexiblity to disable resize in specific pane.

This topic will show you how to prevent resize on specific pane.

To prevent resize on specific pane

  1. Drag WebPaneManager control to the WebForm.
  2. Open WebPaneManager Advanced Designer, select a pane and set AllowResize to No.
  3. Run the project.


WebStyleManager

WebStyleManager
See Also Send Feedback
Intersoft WebDesktop > WebStyleManager

Glossary Item Box

New Features in WebStyleManager v1.5

As the centralized theming requirements grows along in the complex web application development, WebStyleManager version 1.5 now comes with significant enhancements and new features to solve more advanced theming scenarios.

Automatic Output Partitioning

This new feature enables the style manager compiler to automatically break down the generated output file into separate smaller CSS files. By default, the WebUI.NET Framework runtime will compile the specified theme configuration on first request (in the condition when output file has not existed or has been outdated), then resulting into one single output file.

The single output file approach -- which is the default setting -- is recommended when applied to small or medium-sized web application. However, when it comes to larger complex application, the single output file could become too large (more than 50KB) and may cause performance issues.

With partitioned output, the runtime will break down the CSS file into smaller individual files according to the number of the themed components. This approach allows the web application to perform much faster and responsive because the runtime will selectively include the CSS files required by the page. For instance, in a page where only WebCombo is used, the runtime will include only the Default_WebCombo.css (size approximately 3KB) instead of the big single output file (Default.css with size up to 50KB).

To enable output partition, simply check the "Enable Output Partition" checkbox in the General tab of WebStyleManager application.

Custom Stylesheet Inclusion

Custom stylesheet inclusion allows you to include your own specific stylesheets along with the theme. For instance, most of time a web application has global CSS stylesheet which is used throughout the entire application. However, the global CSS stylesheet doesn't match all themes. I.e. it looks good in Default theme, but not in other themes. This new feature solved this problem by allowing specific CSS stylesheets to be included automatically depending on the current active theme.

The custom stylesheet can be specified in two areas:

  • Theme level
    The stylesheets specified in theme level will be applied to the entire web application. To add custom stylesheets in theme level, click on the ThemeGroup node in WebStyleManager, then click on the StyleSheets property editor.
  • Page level
    The stylesheets specified in page level will be applied only to the specific page. To add custom stylesheets in page level, select the page node then click on the StyleSheets property editor.

How it works

When the StyleSheets are defined in either Theme or Page level, the runtime will include them automatically. For example, examine the following theme project file:

<ISTheme>
<ThemeGroup Name="Default" IsDefault="true">
</ThemeGroup>
<StyleSheets>
<StyleSheet>GlobalDefault.css</StyleSheet>
</StyleSheets>
</ISTheme>

With above configuration, the WebUI.NET Framework runtime will include the GlobalDefault.css when a page containing one of the themed control is requested.

The format of the stylesheet inclusion is as following:

<link src=[ThemePath]\[ThemeProject]\GlobalDefault.css>

Enhancements

WebStyleManager version 1.5 includes numerous enhancements to make the application easier to use and more robust, such as:

  • Improved algorithm in detecting themeable Intersoft's components in more scenarios such as when multiple versions of the components are detected.
  • Added "Recent Projects" to File menu in the WebStyleManager UI. You can now quickly access to the last four recent projects.
  • Numerous bug fixes to ensure robustness of the application and better Exception management.

See Also

Getting Started
Features
{Understanding Concepts}


WebExplorerPane Properties
Send Feedback

Glossary Item Box

WebExplorerPane Properties

Id | Description Gets or sets the programmatic identifier assigned to the WebExplorerPane control. ValueType String Default Value
Panes | Description Gets the collection of WebExplorerBar items in this WebExplorerPane. ValueType Collection (ISArray) Default Value
PaneItemSettings | Description Gets or sets the WebExplorerBar item settings in this WebExplorerPane object ValueType WebNavBarItemSettings Default Value
PaneSettings | Description Contains default settings for the WebExplorerPane. ValueType WebExplorerBarSettings Default Value
ClientSideEvents | Description Contains client side events for WebExplorerPane. ValueType WebExplorerClientSideEvents Default Value
RenderMode | Description Gets or sets the rendering mode of WebExplorerPane control (Simple, RoundCorner and ComplexImages). ValueType String Default Value
SpecialBarIndex | Description Gets or sets the active WebExplorerPane index. ValueType Int Default Value 0
EnableAnimation | Description Sets the control to enable/activate animated Expand and Collapse of WebExplorerPane. ValueType Boolean Default Value

WebExplorerPane Methods

ResolveImagePath Description
Resolves the image path.

Parameters
img ( String )
Path of the image.

Remarks

Return Value

Samples


WebExplorerPane Methods

WebExplorerPane Methods
Send Feedback

Glossary Item Box

WebExplorerPane Methods

ResolveImagePath Description
Resolves the image path.

Parameters
img ( String )
Path of the image.

Remarks

Return Value

Samples


WebExplorerBar Properties

WebExplorerBar Properties
Send Feedback

Glossary Item Box

WebExplorerBar Properties

Name | Description Gets or sets the name of this WebExplorerBar instance. ValueType String Default Value
Index | Description Gets or sets the index of this WebExplorerBar instance. ValueType Int Default Value
Size | Description Gets or sets the size of this WebExplorerBar instance. ValueType unit size Default Value
Text | Description Gets or sets the text of this WebExplorerBar instance. ValueType String Default Value
Image | Description Gets or sets the image of this WebExplorerBar instance. ValueType String Default Value
ImageSize | Description Gets or sets the image size of this WebExplorerBar instance. ValueType unit size Default Value
ToolTip | Description Gets or sets the tooltip of this WebExplorerBar instance. ValueType String Default Value
Visible | Description Gets or sets the value to indicate whether this WebExplorerBar instance is visible. ValueType Boolean Default Value
Enabled | Description Gets or sets the value to indicate whether this WebExplorerBar instance is enabled. ValueType Boolean Default Value
Collapse | Description Gets or sets the value to indicate whether this WebExplorerBar instance is collapsed ValueType Boolean Default Value
CaptionDisplayMode | Description Gets or sets the caption display mode of this WebExplorerBar instance. ValueType CaptionDisplayMode Default Value
PaneItems | Description Gets or sets the items in this WebExplorerBar instance. ValueType Collection (ISArray) Default Value
ContentMode | Description Gets or sets the content mode of this WebExplorerBar instance. ValueType ContentMode Default Value
ContentURL | Description Gets or sets the content URL of this WebExplorerBar instance when using IFrame as ContentMode. ValueType String Default Value
IFrameContentLoaded | Description Gets IFrameContentLoaded status of this WebExplorerBar instance. ValueType Boolean Default Value
ItemSettings | Description Gets or sets the ItemSettings of this WebExplorerBar instance. ValueType ItemSettings Default Value
ImagesSettings | Description Gets or sets the images settings in WebExplorerBar. ValueType ImageSettings Default Value


WebExplorerBar Methods

WebExplorerBar Methods
Send Feedback

Glossary Item Box

WebExplorerBar Methods

GetItemsContainerElement Description
Gets the HTML Items Container element of the WebExplorerBar instance.

Parameters

Remarks

Return Value
object (HTML element)

Samples

GetIFrameElement Description
Gets the HTML IFrame element of the WebExplorerBar instance.

Parameters

Remarks

Return Value
object (HTML element)

Samples

GetHeaderElement Description
Gets the HTML header element of the WebExplorerBar instance.

Parameters

Remarks

Return Value
object (HTML element)

Samples

GetContentElement Description
Gets the HTML content element of the WebExplorerBar instance.

Parameters

Remarks

Return Value
object (HTML element)

Samples

GetElement Description
Gets the HTML element of the WebExplorerBar instance.

Parameters

Remarks

Return Value
object (HTML element)

Samples

IsActive Description
Gets the value indicating whether the WebExplorerBar instance is currently active.

Parameters

Remarks

Return Value
Boolean

Samples

SetImage Description
Sets the image of the WebExplorerBar instance.

Parameters
img ( String )
Path of the image.

Remarks

Return Value

Samples

SetDisable Description
Disabled the WebExplorerBar instance.

Parameters

Remarks

Return Value

Samples

SetEnable Description
Enabled the WebNavBar instance.

Parameters

Remarks

Return Value

Samples

SetActive Description
Activated the WebExplorerBar instance.

Parameters

Remarks

Return Value

Samples

Click Description
Trigger the click event of the WebExplorerBar instance.

Parameters

Remarks

Return Value

Samples

DoExpand Description
Expand the WebExplorerBar instance.

Parameters

Remarks

Return Value

Samples

DoCollapse Description
Collapse the WebExplorerBar instance.

Parameters

Remarks

Return Value

Samples

HideAllItems Description
Hides all items WebExplorerBarItem.

Parameters

Remarks

Return Value

Samples

ShowAllItems Description
Shows all items of WebExplorerBarItem.

Parameters

Remarks

Return Value

Samples

ShowItems Description
Shows items of WebExplorerBarItem specified in the parameters.

Parameters
arrItemName ( Collection (ISArray) )
Adds the items defined.
isReflectAll ( Boolean )
Shows only the defined items according to arrItemName parameters.
False

Remarks

Return Value

Samples

HideItems Description
Hide items of WebExplorerBarItem specified in the parameters.

Parameters
arrItemName ( Collection (ISArray) )
Hides the items defined.
isReflectAll ( Boolean )
Hides only the defined items according to arrItemName parameters.
False

Remarks

Return Value

Samples

ChangeInlineContent Description
Modifiy WebExplorerBar's content when ContentMode sets to UseInlineContent.

Parameters
newContent ( String )
Sets the content of WebExplorerBar.

Remarks

Return Value

Samples
AnimateHeight Description
Invokes height animation of WebExplorerPane.

Parameters

Remarks

Return Value

Samples


WebExplorerBarItem Properties

WebExplorerBarItem Properties
Send Feedback

Glossary Item Box

WebExplorerBarItem Properties

Name | Description Gets or sets the name of this WebExplorerBarItem instance. ValueType String Default Value
Index | Description Gets or sets the index of this WebExplorerBarItem instance. ValueType Int Default Value
Text | Description Gets or sets the text of this WebExplorerBarItem instance. ValueType String Default Value
Image | Description Gets or sets the image of this WebExplorerBarItem instance. ValueType String Default Value
ImageSize | Description Gets or sets the image size of this WebExplorerBarItem instance. ValueType unit size Default Value
ToolTip | Description Gets or sets the tooltip of this WebExplorerBarItem instance. ValueType String Default Value
Enabled | Description Gets or sets the value to indicate whether this WebExplorerBarItem instance is enabled. ValueType Boolean Default Value True
DisplayMode | Description Gets or sets the display mode of this WebExplorerBarItem instance. ValueType DisplayMode Default Value
ImagePosition | Description Gets or sets the image position of this WebExplorerBarItem instance. ValueType ImagePosition Default Value
Visible | Description Gets or sets the value to indicate whether this WebExplorerBarItem instance is visible. ValueType Boolean Default Value
TargetURL | Description Gets or sets the target URL of this WebExplorerBarItem instance. ValueType String Default Value
TargetWindow | Description Gets or sets the target window of this WebExplorerBarItem instance. ValueType String Default Value


WebExplorerBarItem Methods

WebExplorerBarItem Methods
Send Feedback

Glossary Item Box

WebExplorerBarItem Methods

GetElement | Description Gets the HTML element of this WebExplorerBarItem instance. Parameters Remarks Return Value Object (HTML Element) Samples
Click | Description Trigger the click event of this WebExplorerBarItem instance. Parameters Remarks Return Value Samples


Understanding Concepts

Understanding Concepts
See Also Send Feedback
Intersoft WebDesktop > WebStyleManager > Understanding Concepts

Glossary Item Box

Introduction

Maintaining consistent styles between components, pages and controls in a Web application can be frustating without a mechanism to organize the style and configuration.

The previous approaches embraced by Intersoft's components prior to WebUI.NET Framework 2.0, namely XML-based Layout Manager and Layout API, lack a capability to allow designers and developers to reuse created layout files efficiently.

WebStyleManager

The new WebStyleManager is aimed to make the most of Intersoft's Theme Architecture and enable developers and designers to manage styles through out the Web application more effectively.

For more detailed information please see following topics:

  • Standalone WebUIStyleManager
  • The Orchestration of Theme Architecture, WebStyleManager and Deployment
  • Styles Inheritance model for Uniform Look and Feel across entire Application

See Also

Related Topics
{New in v1.5}
{Features}


Features
See Also Send Feedback
Intersoft WebDesktop > WebStyleManager > Features

Glossary Item Box

Features

Maintaining consistent look and feel across the whole application is a daunting task without some sort of a centralized mechanism to manage styles. The WebStyleManager is created to accommodate these needs to allow designers and developers to easily apply consistent styles and behaviors to Intersoft WebUI.NET® family components with minimal efforts.

WebStyleManager is built to harness the power of the Theme Architecture and Serialization features which are part of the Intersoft WebUI.NET Framework.

Stand-alone Application

As a stand-alone application WebStyleManager does not need Visual Studio 2005 installed to be used. You can use WebStyleManager on the production server provided you have .NET Framework 2.0 and the required Intersoft WebUI.NET family components installed. The latter means you need to have, for example, WebGrid.NET installed so you can create or edit the style of the WebGrid in your Web application.

And of course, WebStyleManager would be integrated into Visual Studio 2005 if you have it installed prior to the WebDesktop.NET installation.

One-click Deployment

One-click deployment is made possible thanks to Intersoft WebUI.NET Theme Architecture. With this feature you can deploy your newly created or edited theme to your production server by clicking the Deploy Theme button. This is possible because the theme definition is stored in one file (istheme.config) that can simply be copied to the Web application's root directory. The Theme Architecture will then read the file and apply styles to your components according to the definitions.

Previewing and Saving Layout for Multiple Components

WebStyleManager is designed so that it can be used to edit styles for all Intersoft WebUI.NET family components, thus providing flexibility. Previewing and saving newly created or edited layout can be done in one style manager.

See Also

Related Topics
{New in v1.5}
{Understanding Concepts}


Working with WebStyleManager

Working with WebStyleManager
Send Feedback
Intersoft WebDesktop > WebStyleManager > Working with WebStyleManager

Glossary Item Box

This section contains information on how to work with WebStyleManager

In This Section

Using Styles Editor

Using Theme Editor

Using Theme List Editor

Using Project Editor

Deploying Theme


New Topic

New Topic
Send Feedback

Glossary Item Box


Using Style Editor
Send Feedback
Intersoft WebDesktop > WebStyleManager > Working with WebStyleManager > Using Style Editor

Glossary Item Box

Using Style Editor

The style editor is used to create or edit a style for a specific component or control whose node is selected in the Theme tab. After clicking the Edit Style button this style editor dialog will be shown.

To edit a style, simply click one of the styles listed in the treeview. Then you can change its properties in the property grid. After changing the style properties, you need to save the layout file by clicking the Save button.

The Save To button allows you to save the layout file to another place for other uses or purposes, but it would not save the layout file to the current theme data folder. All layout files are saved as ISL files (*.ISL).

Finally, to preview the changes simply select the the Preview tab.


Using Theme Editor
Send Feedback
Intersoft WebDesktop > WebStyleManager > Working with WebStyleManager > Using Theme Editor

Glossary Item Box

Using Theme Editor

The Theme Tab is the place where we can create a theme definition for our Web application. The Theme tab represents a single file (*.ISTHEME) that contains configurations for all the components, pages and/or controls that are contained within the Web application.

The theme consists of a hierarchy of items:

  1. Theme

    The theme node is the top node that contains one or more defined groups. The treeview shows the name of the selected theme that you choose in the Project tab.

  2. Group

    The group is the direct child of a theme. A group consists of Components node that can contain components that are installed on the machine; and Pages node that contains all pages (*.aspx) and user control files (*.ascx) that are available in the Web application. Simply click on the Add Group button to add a group.

    The group's properties are:

    BaseGroup
    The group on which this group is based.
    IsDefault
    Specifies if this group is a default group. A theme must have at least one and only one default group defined.
    Name
    The name of the group.
  3. Components

    The Components node may contain one or more installed components. If you apply style for a specific component here, say WebGrid, then all WebGrids in the Web application will follow the style. You can, however, override the style of certain WebGrid controls by selecting a page and applying different style to the controls directly.

    After adding a component you need to specify values for the following properties:

    DataFile
    The filename of the layout/style file. You can select an existing layout file (*.ISL files) from the open file dialog, or just enter a new filename to create a new layout and then click the Edit Style button.
    LayoutName
    The name you give to the layout.
  4. Pages

    The Pages node allows you to configure style for a specific page. To add a page to the node simply select a page from the Add Page dropdown. The page list in the dropdown is filled based on the Web application physical path that you supply in the Project tab.

    The Page object has a number of properties:

    EnableTheming
    Enable theming for this page.
    FileName
    The page or user control filename, for example: ~/Default.aspx. The tilde mark (~) represents the PhysicalPath of the Web application.
    ThemedControl
    Specifies whether all the controls on the page should be styled. If "Partial" is selected, you have to style each control on the page separately.
  5. Controls

    This node contains controls that you want to apply styles on. To add a control, simply select a control from the Add Control dropdown. The Add Control dropdown lists all Intersoft WebUI.NET controls on the selected page. The control would not be listed in the dropdown if you do not have the component of that control type installed.

    DataFile
    The filename of the layout/style file. You can select an existing layout file (*.ISL files) from the open file dialog, or just enter a new filename to create a new layout then click the Edit Style button.
    EnableTheming
    Specifies whether to enable theming for the control.
    ID
    The control ID.
    LayoutName
    The name that you give to the layout.
    Type
    The type of this component.


Using Theme List Editor
Send Feedback
Intersoft WebDesktop > WebStyleManager > Working with WebStyleManager > Using Theme List Editor

Glossary Item Box

Using Theme List Editor

The Theme List Editor is used to manage a list of available themes in the designated Theme Location that you choose in the Project tab. Theme list editor stores the list as an XML file namely "List.xml", and the Theme Name dropdown is populated according to this list. Before you can create a theme you must add the theme information such as name, data folder, filename to the list and then select the theme in the Theme Name dropdown.

Project tab - Theming Configuration

To add a theme simply click on the Add Theme button and enter the name. Right after entering the name, the DataFolder and Filename will automatically be filled according to the name. Note that the list cannot accept duplicate names and removing a theme from the list would not delete the theme data folder that is already created. After supplying the neccessary information, click OK to save the list and select the theme you are going to create in the Theme Name dropdown on the Project tab. Then you can proceed to creating a theme in the Theme tab.

Theme List Editor


Using Project Editor
Send Feedback
Intersoft WebDesktop > WebStyleManager > Working with WebStyleManager > Using Project Editor

Glossary Item Box

Using Project Editor

The Project tab represents a single project XML file (*.xml) or a deployed project file (istheme.config) which is used to configure Intersoft WebUI.NET components look and feel throughout the entire Web application.

One project file can only contain configurations for one Web application. You can create as many themes as possible within a project but only one can be selected for use at a time.

Below are the details of each field on the Project tab:

  • Application Name

    The name of the Web application to which you are applying a theme. This is optional but it is recommended so the Web application can be identified easily.

  • Web Path

    The URL of the Web application.

  • Physical Path

    The physical path that points directly to the web application's root directory in the drive. This is automatically filled when creating a new project after the Web path has been specified with the condition the Web path is pointing to application that is is located in the same machine and the virtual directory has been set up in the IIS.

  • Apply Behaviors

    Check this to indicate whether the Theme Manager should use the defined behaviors -that resides in the .ISL file- for the controls when it is available.

  • Theme Location

    The location in which all themes and the List.xml file would be put together. There are three options available:

    Global
    This would be the "CommonLibrary\Themes" folder under the "Program Files\Intersoft Solutions" folder.
    Private
    Private location would be PhysicalPath + "\Themes".
    Custom
    Custom specified location, e.g: C:\MyCustomDirectory.

  • Theme Name

    The name of the selected theme configured for this project. You can select which theme to use from here.

  • Enable Theming

    Enable theme to be applied to the Web application.

  • Edit Theme List

    Clicking on this link will bring up a dialog box where we can edit the theme list. The theme list is stored as List.xml that resides in the Theme Location folder.

  • Enable CSS Optimization

    Check this to enable the CSS Optimization. If this is unchecked, none of the optimization methods (Optimize Name and Group Styles) will be applied regardless of their values.

  • Optimize Name

    Check to optimize the style name. When this is enabled, it will convert a long style name from, for instance, ".WebGrid1-LayoutSettings-DropDownStyle-Normal" to ".BS12345", thus reducing the size of the generated CSS style.

  • Group Styles

    Check to enable grouping style definitions that have similar values.

After filling all the fields above we are ready to configure the theme for our Web application in the Theme tab.


Deploying Theme
Send Feedback
Intersoft WebDesktop > WebStyleManager > Working with WebStyleManager > Deploying Theme

Glossary Item Box

Deploying Theme

Deploying a theme is a very simple task. All we need to do is clicking on the Deploy Theme button and then confirm the deployment when a dialog box is shown. What happens after you click the deploy button is the WebStyleManager copies the project file to the Web application physical path and change its name to "istheme.config".

When you run your Web application after deploying the theme, the WebUI.NET Framework will look into the Web application physical path for the istheme.config file and apply the theme definitions that you have created to the Web application.


Tutorials

Tutorials
Send Feedback
Intersoft WebDesktop > WebStyleManager > Tutorials

Glossary Item Box

This section contains tutorial topics in WebStyleManager.

In This Section

Creating a New Project

Creating New Theme

Create New Style

Configuring Styles for Web Application

Configuring Styles for Pages and Controls

Deploying Theme Project


Creating a New Project

Creating a New Project
Send Feedback
Intersoft WebDesktop > WebStyleManager > Tutorials > Creating a New Project

Glossary Item Box

Objectives

Create and configure a new ISTheme project for a Web application. It is recommended to read the topic Using Project Editor before following this tutorial.

  1. Open the WebStyleManager and click New Project from the File menu.

  2. In this tutorial, the WebDesktopSamples will be used as a sample project. Next, fill in the fields of the WebStyleManager as shown below.

    First, we put in the name of the Web application. Then, we specify the Web Path of the Web application. If you put in the correct Web path, the Physical Path will automatically be filled.

    Please see Using Project Editor for more information about the purpose of each field here.

    Fill in the fields

  3. Click the Edit Theme List link to edit the theme list and the Theme List Editor will be shown.

    Click the Add Theme button and enter WebDesktopNewTheme for the new theme. After you finish adding the new theme, click OK to save the list.

    Theme List Editor

  4. Now the name of the new theme we defined in the Theme List Editor should be available in the Theme Name DropDownList. Select WebDeskotpNewTheme from the Theme Name.

    Select a Theme

  5. Select Enable Theming checkbox to use theme for this Web application.

  6. Select all Checkboxes that are available in the CSS Optimization group.

  7. At this point we are ready to proceed to the next tutorial, that is Creating New Theme.


Editing an Existing Project

Editing an Existing Project
Send Feedback

Glossary Item Box


Creating New Theme

Creating New Theme
Send Feedback
Intersoft WebDesktop > WebStyleManager > Tutorials > Creating New Theme

Glossary Item Box

Objectives

Create a new theme definition for Web application. Please read the topic Using Theme Editor before starting this tutorial for better understanding.

  1. Continuing from the previous tutorial (Creating a New Project), we are now ready to create a new theme definition. Select the WebDesktopNewTheme node and click the Add Group button to add a new group. A theme definition may contain one or more group for better organization purpose. (More information)

  2. Create a new group as the Default group and select WebDialogBox from the Add Component DropDownButton.

    Create the a default group

  3. Add the page 'WebPad.aspx' from the 'Add Control' DropDownbutton. As explained in Using Theme Editor topics, you add a page to override the styles that are defined in Components node for this specific page. You can set the Enable Theming property of the page to false to enable/disable theming for the page.

  4. At this point we are ready to proceed to the next tutorial which is Creating New Style.


Creating New Style

Creating New Style
Send Feedback
Intersoft WebDesktop > WebStyleManager > Tutorials > Creating New Style

Glossary Item Box

Objectives

Create a new style for a component or control. Continuing from previous tutorial (Creating New Theme) it is now ready to edit a style for our WebDialogBox component.

  1. Enter 'WebDialogbox_Blue.isl' as the layout file name in the DataFile property and click the Edit Style button to proceed to creating a new style. The WebStyleManager confirms if the theme file (WebDesktopNewTheme.theme) should be saved before proceeding. Click OK to proceed.

    Create New Style

  2. The dialog box below informs that you do not have this file and you are going to create a new file with this file name.

    Create New Layout File

  3. Click OK and the Style Editor dialog will be shown. Select the WindowStyle node which is the child of the Styles node in the Style treeview and change the Normal BackColor to #C0C0FF.

  4. You may also change other styles as needed. Remember to click the Save button before previewing the style, otherwise the changes will not be shown in the Preview tab. Then, click the Preview Tab to preview the new style.

  5. Click Save to save the new style and check the 'Include behaviors when saving style' CheckBox if you want to include behaviors settings in the layout file as well. You can modify the behaviors by selecting the WebDialogBox node in the treeview and modify its properties through the PropertyGrid.

  6. Click Close to go back to WebStyleManager's Theme tab. Next (Configuring Styles for Web Application), we are going to configure the style for our Web application.


Configuring Styles for Web Application

Configuring Styles for Web Application
Send Feedback
Intersoft WebDesktop > WebStyleManager > Tutorials > Configuring Styles for Web Application

Glossary Item Box

Objectives

Configure styles of a Web application using WebStyleManager.

More Information

Configuring styles for Web application is actually defining styles for components that are used in your Web application. For instance, in the previous tutorial (Creating New Style) you already created a new style for the WebDialogBox component, that means you already configured all the controls of WebDialogBox type in your Web application to use that new WebDialogBox style. You can, however, override that style by creating a new style for a specific page or control which will be discussed in the next tutorial (Configuring Styles for Pages and Controls). The same rule applies to all other components.

Since the previous tutorial has shown you how to create a new style for the WebDialogBox component, we would not show you the same process again.


Configuring Styles for Pages and Controls

Configuring Styles for Pages and Controls
Send Feedback
Intersoft WebDesktop > WebStyleManager > Tutorials > Configuring Styles for Pages and Controls

Glossary Item Box

Objective

Configure the style of a specific page or control. It is recommended to read the previous tutorial (Configuring Styles for Web Application) for better understanding of using the WebStyleManager.

More Information

Continuing from previous tutorial we are now going to configure a style for a specific page and the controls within.

  1. Click on the ~/WebPad.aspx page node and select the dlgBoxAbout control from the Add Control DropDownButton.

    New Style for dlgBoxAbout

  2. Enter the DataFile file name for the new layout. The DataFile here is the file name of the layout file (*.isl) of the control. You can select an existing layout file or just enter a new file name. If use an existing layout file, the file will be copied to the WebDesktopNewTheme directory. On the other hand, if you enter a new file name a layout file will be created, also in the WebDesktopTheme directory.

  3. In this case, enter a new layout filename 'MyAboutDialogBoxStyle.isl' and click Save. Then click the Edit Style button to start editing the style. A dialog box will show up and informs that the layout file is not found and therefore we are going to create a new layout. Click OK to proceed.

    Create a new layout file

  4. The style editor window is displayed and we can start editing the new style. Modify some styles and then click the Save button so the changes can be reflected on the preview.

  5. Click the Preview tab to preview the changes.

  6. After previewing the style click the Close button. Now you can start deploying the theme project to your Web application. The next tutorial (Deploying Theme Project) will show you how to deploy a theme to your Web application.


Deploying Theme Project

Deploying Theme Project
Send Feedback
Intersoft WebDesktop > WebStyleManager > Tutorials > Deploying Theme Project

Glossary Item Box

Objectives

Deploy the newly created ISTheme project file to the Web application.

  1. After we finish with defining a new theme and creating a new style/layout file. We are ready to deploy the theme project file.

  2. Confirm the deployment by clicking OK.

  3. Confirm overwriting by clicking OK. If the Web application has already had an istheme.config file inside, you need to overwrite the file since one Web application can contain only one istheme.config file (Theme project file).

  4. A dialog box informs that the project file has been deployed successfully.

    Project File Deployed


WebNavPane

WebNavPane
See Also Send Feedback
Intersoft WebDesktop > WebNavPane

Glossary Item Box

WebNavPane
Member of WebDesktop.NET

WebNavPane lets you create advanced navigation user interface with the richness of desktop's navigation in every details of styles and behaviors.

What's New in WebNavPane

Learn the Features

Understanding Concepts

Quick Start

Creating Simple NavPane

Using BarItem for Content Navigation

Handling Client Side Events

Create professional Outlook-style navigation control

Use WebNavPane control to quickly create rich and fully-functional Outlook-like navigation user interface in a professional way. Unlike "traditional Panel or Navigation controls", WebNavPane is designed with elegant architecture and object model as well as specialized user interface for each element. That means, you no longer require any workarounds in order to achieve a modern navigation control which is not only rich in styles, but also in every functions and behaviors.

Dramatically enhances user experience through resizable Bars.

WebNavPane lets your users resize the bar to determine how many bars should be visible in the navigation control. That means, you don't need to worry on the extensibility side of your application, e.g. the limited number of visible bars. WebNavPane will automatically manage the available bars and collapse them in the Footer section as users drag the ResizerGrip to the bottom way. WebNavPane also maintain every states of the Bar, such as the currently ActiveBar and properly restore them whether the bar is collapsed or restored.

Increase developer's productivity through advanced flexibility and extensibility

WebNavPane sets a new standard in navigation user interface by providing advanced features for greater flexibility and extensibility. You can choose one of three ContentMode for each Bar's contents, or having all of them to use the global setting specified in BarSettings. The UseItems ContentMode enables you to quickly build navigation links by manipulating the Items collection. For better extensibility, you can also use InlineContent mode and put any kind of server controls.

See Also

Getting Started
{Features}
{Understanding Concepts}


What's New in WebNavPane

What's New in WebNavPane
See Also Send Feedback
Intersoft WebDesktop > WebNavPane > What's New in WebNavPane

Glossary Item Box

WebNavPane give users a superior Microsoft Windows-style navigation and control pane in your web applications. WebNavPane offers a superior navigation pane system, with rich visual styles and advanced features.

In version 4, WebNavPane has been refined to fully support the latest web standards. This allows you to use many of the WebNavPane features in your next-generation web applications and at the same time leveraging cutting-edge technologies such as HTML5 and CSS3.

The following list shows the enhancements and new features introduced in WebNavPane:

  • Fluid content

    In HTML5 environment, height of an element refers to its parent's height. Hence, it is required/necessary to define its parent element. In other words, the parent container of WebNavPane must have the height value of 100% to the fluid content.

  • Border frame style

    In HTML4 doctype, WebNavePane's border frame style is set to solid by default, even if user doesn't determine the property initially. In HTML5 doc type, user must specifiy the border frame style. Otherwise, the border is unable to render the frame style properly.

  • Bars size

    In HTML4, you don’t have to specify the height or size of WebNavPane’s bars. However, if you use WebNavPane in HTML5 doc type, you must set the height or size of WebNavPane’s bars. In HTML5, when the size of image or font is larger than bar's (default) size, it will cause WebNavPane not properly render.

  • New Intuitive style

    In this version 4, WebDesktop introduces a brand-new Metro style for each members. Metro style - the latest UI in Windows 8 has been developed and added as a new, elegant and sophisticated UI in WebDesktop family. With Metro style, WebDesktop's layout is transformed into beautiful and eye-catching design and it is also applicable for each members, such as WebCallOut, WebNavePane, WebDialogBox and many others. Last but not least, this intuitive Metro style design also enhances consistency of each controls in HTML5.

    You can simply use Layout Manager to implement Metro style in WebDesktop.

    For more information on how to apply this configuration, see How-To: Using Layout Manager.

See Also

WebNavPane

Features
Features


Features

Features
See Also Send Feedback
Intersoft WebDesktop > WebNavPane > Features

Glossary Item Box

Intersoft's WebUI navigation pane control,WebNavPane, has several unique features that will be explained below in details:

  • CaptionDisplayMode

By default, the CaptionDisplayMode is set to "Text" mode when a new instance is dropped to designer surface. You can also have Text&Images, Images, and UseTemplate for CaptionDisplaymode.

picture1 : Use Text And Images as the Caption Mode

picture2 : Use Text as the Caption Mode

  • Client Side Events

WebNavPane exposed numerous client side events that you can consume in order to create rich interaction and extensible web applications. Following is the list of available client side events:
- OnBarClick
- OnBarItemClick
- OnClickUnload
- OnInitialize
- OnPaneResize

  • Comprehensive Client Side OOP and API

As member of WebUI.NET Framework family, WebNavPane is extensively taking advantage of the client side framework enabling the same structure of object model between server and client side.

Additionally, WebNavPane provides comprehensive API for you to easily interact and manipulate the objects at client side (runtime). For example, you can easily disable or enable a WebNavBar by calling WebNavPane.Enable(). You can also programmatically get the WebNavBar collection or WebNavBarItems collection, changing the caption, tooltip or image of a WebNavBar or WebNavBarItem, and much more properties you can get to work at client side. For a list of complete WebNavPane API, please see "Client Side Reference >> WebNavPane".

  • IFrame ContentMode

By default, the WebNavBar will operate in "UseInlineContent" mode when a new instance is dropped to designer surface. UseInlineContent is the most suitable when the contents inside each WebNavBar page are relatively small. UseInlineContent mode utilized .NET Framework's template architecture and therefore all contents are loaded at once in first load (although the contents in inactive bar are set to hidden).

In most cases where you want to develop a more reusable form, you should use UseIFrame as the content mode. When using IFrame mode, you would need to specify the ContentURL which page you want to load for the designated WebNavBar.

The ContentURL accepts three formats of URL:
1. .NET specific application relative URL. This format starts with "~" character, for instance, "~/FolderA/Page1.aspx".
2. Absolute URL. This format starts with "/" character, for instance, "/SharedModule/Page1.aspx".
3. Relative URL. This format usually starts with "." character or no special characters (which assume the page can be found in the current folder's context).

You can configure different ContentMode for each NavBar. To apply all NavBar to use a specific ContentMode, configure the ContentMode in WebNavPane control level and leave WebNav's ContentMode to Default.
  • Fully customizable styles and appearances

WebNavPane allows you to customize most of the elements' styles by using strongly typed WebStyle and DynamicStyle properties listed in following:

  • FrameStyle
  • GripStyle
  • NavType

Currently the NavType in WebNavPane is using Outlook2003 Style, later on NavType is also planned to support WinXP Style and many other today's popular styles.

  • WebNavPane Designer

Instead of changing properties in Visual Studio Property Window, you can configure most properties shown in "logical group" from WebNavPane Designer. You can also easily manipulate the styles, properties as well as managing the WebNavBar and WebNavBarItems.

Most Intersoft's components that exposed rich functionalities, complex objects and collection would implement Component Designer similar to the screenshot above. The consistency of the user interface and functions throughout all Intersoft's components would significantly reduce learning time as well as increasing productivity.

See Also

Related Topics
{Overview}
{Understanding Concepts}


Understanding Concepts

Understanding Concepts
See Also Send Feedback
Intersoft WebDesktop > WebNavPane > Understanding Concepts

Glossary Item Box

Introduction

WebNavPane is the server control object serving as the root container for WebNavBar objects as well as other available configurations. WebNavPane consists of five main user interface elements listed in the following:

  • Header
  • Content
  • BarResizer
  • Bars
  • Footer

A bar is represented by WebNavBar object which is contained in Bars collection of WebNavPane. WebNavBar can be constructed in either design-time or runtime.

A bar may consists of one or more items called WebNavBarItem which mainly used as navigation links. The WebNavBarItem can be easily manipulated and accessed through Items collection provided by each WebNavBar object.

The WebNavBar's Items will be used and rendered when the WebNavBar's ContentMode is set to UseItems by default. For extensibility or customized content, you may set the ContentMode to UseInlineContent and put any kind of ASP.NET's server controls. You can also use IFrame ContentMode for better reusability. The ContentMode property can be found in BarSettings object which contains global configurations for Bar.

The WebNavBarItem object provides following features for effective navigation purpose:

  • TargetURL
  • TargetWindow

More Details

The following shows the hierarchy of a common WebNavPane configuration:

  • WebNavPane - NavPane1 (Root Control)
    • Bars (Collection)
      • WebNavBar - barCustomers
        • Items (Collection)
          • WebNavBarItem - itmDefaultView
          • WebNavBarItem - itmDetailedView
          • WebNavBarItem - itmTopCustomers
      • WebNavBar - Employees

For better understanding of WebNavPane hierarchy in visual details, please examine the illustration provided in the following:

The header section shows the currently selected bar's caption, it is set automatically when a Bar becomes selected.

In this release, WebNavPane contains a special Footer element which is used as placeholder for collapsed Bars. A bar become collapsed when user modify the visible Bars by dragging the Resizer Grip to bottom direction. In component level, you can determine how many bars should be visible in the NavPane by specifying the BarVisible property. By default, all bars are set to be visible (BarVisible = -1).

WebNavPane also allows you to customize many user interface elements behaviors, such as CaptionDisplayMode, ImageSize, Size for the Bar, ImagePosition and Alignment for the BarItem and more. The configurations for Bar can be set in global level at BarSettings or at individual WebNavBar object level. Likewise, configurations for BarItem can be set in global level at BarItemSettings or at invidiual WebNavBarItem object level.

Styles

In addition to the sophisticated object model design and rich behaviors, WebNavPane also provides comprehensive customization in visual styles which allow you to achieve professional desktop-like styles in minutes. As the standard of all Intersoft's products, the styles can be easily programmed and configured through strongly-typed object oriented Style.

The following image shows the illustration of all configurable Style in WebNavPane.

The above is the default style of WebNavPane which is applied automatically when you drop an instance of WebNavPane to designer's surface. For most cases, there are no significant changes required to the default styles and hence lets you quickly proceed to your further application development tasks.

See Also

Related Topics
{Overview}
{Features}


Tutorials

Tutorials
Send Feedback

Glossary Item Box


Version 1.0

Version 1.0
Send Feedback

Glossary Item Box

Final Release Notes

The following notes applied to final version of WebDesktop.NET 1.0.

  • WebDesktop.NET v1.0 requires WebUI.NET Framework 3.0 Build 17 or above.
  • If you have installed WebUI.NET Framework 3.0 Build 16, you can update to Build 17 by using Update Manager, or obtain latest WebUI.NET Framework Installer and reinstall.
  • FlyPostBackManager and WebNotification will not be available in v1.0 release (postponed to 2006 Q1).
  • All C# samples and tutorials are completely available and included in the Installer.
  • VB.NET version of samples and tutorials are not included in the Installer. However they can be downloaded separately at http://www.intersoftpt.com/WebDesktop/Download

Other products' assembly is included for demonstration purpose:

  • Trial version of WebGrid.NET 4.0 for Visual Studio 2005
  • Trial version of WebCombo.NET 3.0 for Visual Studio 2005
  • Trial version of WebInput.NET 2.0 for Visual Studio 2005
    Only the assemblies of the products are included in the package. If you do not have the licensed version, please download and install the full Trial version before proceeding to assembly update. If you have a licensed version, you can download the Retail version of the assemblies in the latest Installer (released on December 9, 2005). Note that full reinstallation is required.

Assembly updates guideline to use WebGrid.NET, WebCombo.NET and WebInput.NET for Visual Studio 2005 in the samples:

  • Ensure latest (requires December 2005 Build) full version of the products have been installed properly.
  • Copy [Program Files]\Intersoft Solutions\WebDesktop.NET\Samples\CompanionAssemblies\*.DLL to [Program Files]\Intersoft Solutions\WebDesktop.NET\Samples\cs\Root\Bin.

Note: All products which have been compiled on .NET Framework 2.0 will require WebUI.NET Framework 3.0 to be installed.

Official WebUI.NET Framework 3.0 release build is: 3.0.5000.16

New addition and changes in this release:

  • Improved server-side performance during serialization. See What's new in WebUI.NET Framework 3.0
  • Improved client-side performance by consistently releasing allocated memory when a Window is closed (using IFrame content mode).
  • Diagonal resizing for WebDesktopWindow.
  • SmartKeys�?� architecture.
  • AutoPostBack for WebToolBar, WebMenuBar and WebContextMenu.
  • Server-side OnClick event for WebToolBar, WebMenuBar and WebContextMenu.
  • ShortcutDisplayMode added to WebDesktopManager.
  • ClientSideEvents added to WebContextMenu for control-level event handling.
  • WebContextMenu can now be attached to Intersoft's controls automatically through ControlId.
  • Better Mozilla support for window interaction and taskbar customization.
  • Gecko 1.8-based browsers support (i.e. FireFox 1.5).
  • Improved usability on WebUI Style Manager application.
  • Enhanced Visual Menu Builder with automatic canvas scrollbar support.
  • Fixed numerous bugs reported in Beta release.

Visual Studio 2005 Integration

WebDesktop.NET features tight integration with Visual Studio 2005 by performing following automation during installation:

  • Controls automatically added to ToolBox in Intersoft WebUI Studio.NET tab group.
  • Help collection is plugged into Visual Studio Help.
  • WebForm Templates added under "My Templates" group in New Item dialog box.


Product Support

Product Support
Send Feedback

Glossary Item Box


Tutorials

Tutorials
Send Feedback
Intersoft WebDesktop > WebNavPane > Tutorials

Glossary Item Box

This section contains tutorial topics in WebNavPane.

In This Section

Creating Simple NavPane

Creating NavPane with Images

Using BarItem for Content Navigation

Using Template and IFrame Content mode

Loading NavPane Structure Programmatically

Handling Client Side Events

Creating NavBar and NavBarItem at client-side

How-to: Customize various NavPane styles

How-to: Configure NavPane with Navigator

How-to: Customize NavPane with IconStyle and Images

How-to: Display Number of NavBar


Creating Simple NavPane

Creating Simple NavPane
See Also Send Feedback
Intersoft WebDesktop > WebNavPane > Tutorials > Creating Simple NavPane

Glossary Item Box

Objectives

Create a simple WebNavPane which demonstrates WebNavPane behavior both at design time and run time.

Follows are the steps to create a simple WebNavPane :

  1. Create a WebPaneManager as shown in the picture bellow (you can see tutorial how to do it in WebPaneManager Tutorials)

  2. Drag a WebNavPane inside the Left Pane.

  3. Click the Add New Bar at the bottom of WebNavPane, and fill the information about the new Bar.

  4. Adding a new Bar can also use WebNavPane Designer. Right click the WebNavPane - WebNavPane Designer.

  5. On Bar SubCategory Add new NavBar and fill the information about the new Bar.

  6. To add the BarItem go to Items Collection to show WebNavBarItem Collection Editor.
  7. Add a new BarItem and fill the information about the new BarItem.

  8. Apply all the changes, and run the page. You will see something like following.

See Also

Related Tutorials
Creating Simple WebPane Layout


Creating NavPane With Images

Creating NavPane With Images
See Also Send Feedback
Intersoft WebDesktop > WebNavPane > Tutorials > Creating NavPane With Images

Glossary Item Box

Objectives

Create a simple WebNavPane that uses images for its UI Representation.

Following are the steps to create a NavPane with images:

  1. Create a WebPaneManager as shown in the picture bellow (you can see tutorial how to do it in WebPaneManager Tutorials).

  2. Drag a WebNavPane inside the Left Pane .

  3. Right click the WebNavPane - WebNavPane Designer to open WebnavPane Designer.
  4. On Bar SubCategory Add new NavBar and fill the information about the new Bar. Make sure you fill Image property with image URL and change the CaptionDisplayMode to TextAndImage or Image.

  5. To apply Image to BarItem simply do same thing by fill Image Property with image URL and change the DisplayMode to TextAndImage or Image.

  6. Apply all the changes, and run the page. You should got something like this.

See Also

Related Tutorials
Creating Simple WebPane Layout


Using BarItem for Content Navigation

Using BarItem for Content Navigation
See Also Send Feedback
Intersoft WebDesktop > WebNavPane > Tutorials > Using BarItem for Content Navigation

Glossary Item Box

Objectives

Serving its purposes WebNavPane's BarItem has the ability to open a contentURL as navigation tool.

Following are the steps to configureBarItem for Content Navigation :

  1. Create a WebPaneManager as shown in the picture bellow (you can see tutorial how to do it in WebPaneManager Tutorials).

  2. Change the ContentMode of RightPane to IFrame.

  3. Drag a WebNavPane inside the Left Pane.

  4. Right click the WebNavPane - WebNavPane Designer to open WebnavPane Designer.
  5. Open BarItem Settings and Change Target Window to "Pane01" (Note : Pane01 is the name of RightPane).

  6. On Bar SubCategory Add new NavBar and fill the information about the new Bar.

  7. Open NavBar BarItem's Collection and add new BarItem.
  8. Fill the information about the new BarItem. Make sure you configure the TargetURL (e.g "../About.aspx").

See Also

Related Tutorials
Creating Simple WebPane Layout


Using Template and IFrame Content mode

Using Template and IFrame Content mode
See Also Send Feedback
Intersoft WebDesktop > WebNavPane > Tutorials > Using Template and IFrame Content mode

Glossary Item Box

Objectives

IFrame or Template Content can be used to give some flexibility of WebNavPane contents.

Following are the steps to utilize IFrame and/or Template Content Mode :

  1. Create a WebPaneManager as shown in the picture bellow (you can see tutorial how to do it in WebPaneManager Tutorials).

  2. Drag a WebNavPane inside the Left Pane.

  3. Right click the WebNavPane - WebNavPane Designer to open WebnavPane Designer.
  4. On Bar SubCategory Add new NavBar and fill the information about the new Bar. Make sure you change the ContentMode to UseIFrame and specify the ContentURL.

  5. Add another NavBar and fill the information about the new Bar. This time change the ContentMode to UseInlineContent.

  6. Back to the DesignPage, click NavBar02 to show the InlineContent.
  7. Add some controls / text / etc inside the InlineContent.

  8. Run the pages you should get something like this.

See Also

Related Tutorials
Creating Simple WebPane Layout


Loading NavPane Structure Programmatically

Loading NavPane Structure Programmatically
See Also Send Feedback
Intersoft WebDesktop > WebNavPane > Tutorials > Loading NavPane Structure Programmatically

Glossary Item Box

Objectives

NavPane Structure can be created using designer or code behind programmatically.

Following are the steps how to create it NavPane structure programmatically:

  1. Create a WebPaneManager as shown in the picture bellow (you can see tutorial how to do it in WebPaneManager Tutorials).

  2. Drag a WebNavPane inside the Left Pane.

  3. Open View Code and Write following code at Page_Load.

    C# Copy Code
    // initialize navPane
    ISNet.WebUI.WebDesktop.WeNavPane navPane = (ISNet.WebUI.WebDesktop.WebNavPane)WebPaneManager1.FindControl("WebNavPane1");

    // initialize navBar

    ISNet.WebUI.WebDesktop.    WebNavBar navBar = new ISNet.WebUI.WebDesktop.WebNavBar();

    // initialize navBarItem

    ISNet.WebUI.WebDesktop.    WebNavBarItem navBarItem = new ISNet.WebUI.WebDesktop.WebNavBarItem();

    // configure navBarItem's settings

    navBarItem.Name =     "itmBarItem1";

    navBarItem.Text =     "Item 1";

    navBarItem.Image =     "~/Images/Home.gif";

    navBarItem.DisplayMode = ISNet.WebUI.WebDesktop.    DisplayMode.TextAndImage;

    // configure navBar's settings

    navBar.Name =     "wnbBar1";

    navBar.Text =     "NavBar 1";

    navBar.Image =     "~/Images/S_Cust-24.gif";

    navBar.CaptionDisplayMode = ISNet.WebUI.WebDesktop.    DisplayMode.TextAndImage;

    // add navBarItem to navBar Item's Collection

    navBar.Items.Add(navBarItem);

    // add navBar to navNape Bar's Collection

    navPane.Bars.Add(navBar);

See Also

Related Tutorials
Creating Simple WebPane Layout


Handling Client Side Events

Handling Client Side Events
See Also Send Feedback
Intersoft WebDesktop > WebNavPane > Tutorials > Handling Client Side Events

Glossary Item Box

Objectives

WebNavPane has some ClientSide Events. This tutorial will show what are the ClientSide Events and how to handle it.

Following are the steps :

  1. Refer to Creating NavPane WithImages to create a simple WebNavPane.
  2. Open WebNavPane Property Window
  3. At ClientSideEvent Category, fill all the EventHandler as follows:

  4. Create JavaScript function that correspond to each EventHandler.
    Script Copy Code
    <script type ="text/javascript">

      function onBarClick()

      {

        alert(    "NavBar is Clicked");

      }

          function onBarItemClick()

      {

        alert(    "NavBar's Item is Click");

      }

      function     onClientUnload()

      {

        alert(    "Client Unload");

      }

      function     onInitialize()

      {

        alert(    "Initializing");

      }

      function     onPaneResize()

      {

        alert(    "Resizing Pane");

      }

    </script>

See Also

Related Tutorials
Creating Simple WebPane Layout
{Creating NavPane With Images}


Creating NavBar and NavBarItem at client side

Creating NavBar and NavBarItem at client side
See Also Send Feedback
Intersoft WebDesktop > WebNavPane > Tutorials > Creating NavBar and NavBarItem at client side

Glossary Item Box

Objectives

WebNavPane enhances its feature to allow user to create NavBar and NavBarItem from client side.

This tutorial will guide you on how to perform the above scenario.

Following are the steps to create NavBar and NavBarItem:

  1. Drag WebNavPane and HTML button controls from Toolbox to the WebForm.

  2. Switch to Source code to create a javascript function called Create_ClientSide(). The code will look like following:

    Script Copy Code
    <script type="text/javascript">
function Create_ClientSide()
{
   var nav = ISGetObject("WebNavPane1");

   var navbar = new WebNavBar();
   navbar.Text = "test";
   navbar.Name = "test";
   nav.AddBar(navbar);

   var item = new WebNavBarItem();
   item.Text = "1";
   item.Name = "1";
   navbar.AddBarItem(item);

   navbar.Click();
}
</script>

  3. In HTML button, you need to invoke function Create_ClientSide() using onclick event.

    <input type="button" onclick="Create_ClientSide()" value="Click to create NavBar from client side" />

  4. Compile and run the sample. When you click the button, it will automatically add the NavBar along with its NavBarItem.

See Also

Tasks
{Creating Simple NavPane}
{Creating NavPane With Images}
{Using BarItem for Content Navigation}
{Using Template and IFrame Content mode}
{Loading NavPane Structure Programmatically}
{Handling Client Side Events}


How-to: Customize various NavPane styles

How-to: Customize various NavPane styles
Send Feedback
Intersoft WebDesktop > WebNavPane > Tutorials > How-to: Customize various NavPane styles

Glossary Item Box

WebNavPane has several various styles that you can customize.

This topic will show you how to customize various NavPane styles.

To customize various NavPane styles

  1. Right click on WebNavPane control and choose WebNavPane Designer.
  2. Switch to Layout Manager.
  3. Expand Predefined Layout and choose the style available.


How-to: Configure NavPane with Navigator

How-to: Configure NavPane with Navigator
Send Feedback
Intersoft WebDesktop > WebNavPane > Tutorials > How-to: Configure NavPane with Navigator

Glossary Item Box

WebNavPane is able to be configured as navigator.

This topic will show you how to configure NavPane with Navigator.

To configure NavPane with Navigator

  1. Right click WebNavPane control and choose WebNavPane Designer.
  2. Go to Bars and select one member of WebNavBar collection.
  3. Choose Items and click the collection button.
  4. Select one member of WebNavBarItem collection and set TargetURL to http://www.yahoo.com.
  5. You can specify TargetWindow at global setting (BarItemSettings.TargetWindow) to have all BarItems to use the specified TargetWindow. You can override the TargetWindow at WebNavBarItem level for individual scenarios.


How-to: Customize NavPane with IconStyle and Images

How-to: Customize NavPane with IconStyle and Images
Send Feedback
Intersoft WebDesktop > WebNavPane > Tutorials > How-to: Customize NavPane with IconStyle and Images

Glossary Item Box

WebNavPane is able to display item with images.

This topic will show you how to customize NavPane with IconStyle and Images.

To customize NavPane with IconStyle and Images

  1. Right click on WebNavPane control and choose WebNavPane Designer.
  2. Go to Bars. Set CaptionDisplayMode to TextAndImage. This setting is used to set the global display mode.
  3. Expand ItemSettings. Set DisplayMode to TextAndImage. This setting is used to set the display mode of the NavBarItem.
  4. Set ImagePosition to AboveText. This setting is used to set the image position of NavBarItem.


How-to: Display Number of NavBar

How-to: Display Number of NavBar
Send Feedback
Intersoft WebDesktop > WebNavPane > Tutorials > How-to: Display Number of NavBar

Glossary Item Box

WebNavPane can show only certain number of NavBar instances.

This topic will show you how to display number of NavBar.

To display number of WebBar

  1. Right click on WebNavPane control and choose Properties.
  2. Set BarVisible to 2.
  3. Run the project. In this case, only two bars are visible and the rest of the bars are placed as icons at the footer.


WebTab

WebTab
See Also Send Feedback
Intersoft WebDesktop > WebTab

Glossary Item Box

WebTab
Member of WebDesktop.NET

WebTab offers most of functionalities a Tab control should have, plus several unique features allowing you to create modern visual styles with some properties configuration.

What's New in WebTab

Learn the Features

Working with Complex Images

Understanding Concepts

Working with ClickAndEdit and Designers

TrueShape Rendering

Quick Start

Creating Simple Tab

Creating Overlapped Edges Tab

Adding new TabItem at Client Side

Create Windows XP-like Tab without images

Use WebTab control to build well-organized user interface in the form of "Tab" navigations and easily achieve modern visual styles with the ease of couple properties changes. WebTab features TrueShape rendering which lets you design a rich Windows XP-like Tab control without requiring any images. It also exposes the exact details of modern Tab's behaviors. For instance, the active tab's offset, separator between normal tabs and active tabs, and many more - which handled automatically in the WebTab control.

Improve user experience with automatic Scrolling and closeable tab features

In addition to the regular Tab's functionalities, WebTab offers numerous innovative features which you can consume as easy as one property change. Some of the noteworthy features are automatic scrolling and AllowClose features. The scrolling feature lets you define as many tabs as you like without compromising the layout functions. The AllowClose feature gives a richer experience for your users by letting them close any unused tabs.

Increase usability and extensibility with client-side constructable tab items

WebTab includes strong client side object model and API which lets developers to easily interact with the control programmatically. This capability enables you to extend the functions of the tab according to your application-specific scenarios. For instance of one most common scenario, creating new TabItem programmatically, set its caption, or change the content's URL. You can perform these functions without the need to perform page postback.

See Also

Getting Started
Features
{Understanding Concepts}
{Working with ClickAndEdit and Designers}
{Enabling TrueShape rendering}
{Working with Complex Images}


What's New in WebTab

What's New in WebTab
See Also Send Feedback
Intersoft WebDesktop > WebTab > What's New in WebTab

Glossary Item Box

WebTab offers numerous customizations, such as flexible tab size, structure management, scroll enable, closure enable, and automatic resizing. Set global widths, or switch to automatic adjustment according to the content’s width. Structure management is a unique feature which enables you to load the last saved tab structure programmatically at runtime. Scrolling enables users to scroll through all tab items when there are too many tabs to fit the width of the WebTab control.

In version 4, WebTab has adopted HTML5 and CSS3 standards. The container has fluid height regarding to DefaultTabItemHeight property and WebTab’s Height. The consistency of HTML5 rendering also makes WebTab as pixel-perfect control which can be filled regarding its container.

These are the following details of enhancements and new features that have been implemented in WebTab:

  • Fluid content

    There are differences between HTML4 and HTML5 rendering and they cause a height gap in WebTabItem. To resolve this issue, you can specify the height of its header by using DefaultTabItemHeight property. Please take a note as well about padding inside WebTabItem. In version 4, you don’t have to use padding to make the content inside WebTabItem centered in HTML5. The content inside WebTabItem by default is centered using our code. Default value in HTML5 for DefaultTabItemHeight is 23px.

  • Separator visibility

    In version 4, you can also define the visibility of Tab item's separator whether in active state or normal state. Simply by changing AlwaysVisibleSeparator to true value, WebTab will show the separator whether in active or normal state.

  • New intuitive style in WebDesktop 4

    In version 4, WebDesktop presents a new style in each of its control. Metro style as the latest UI in Windows 8 had been implemented and became brand new UI in our WebDesktop control. Metro style makes WebDesktop simpler, tidier, and more attractive for each control's UI. The intuitive design of Metro style also provide consistency of each control in HTML5.

    You can simply use Layout Manager to implement Metro style in WebDesktop.

    For more information on how to apply this configuration, see How-To: Using Layout Manager.

See Also

WebTab

Features
Features


Features

Features
See Also Send Feedback
Intersoft WebDesktop > WebTab > Features

Glossary Item Box

WebTab includes most functions a "Tab control" should have, in addition to its unique features in the following:

  • Rich Design Time experience

    WebTab makes it possible for you to design and develop your rapid web application the same way and manner as in WinForm IDE. WebTab implements ClickAndEdit and ClickAndSelect technologies to deliver this time-saving and elegant architecture to life. See following screenshot for more details.

    With this new level of design time experience, you can develop rich form application efficiently, effectively and quicker than ever before.
  • TabHeader Position

    You can configure the TabHeader Position to be at Top (Default) or Bottom. When you change the Position configuration, WebTab will automatically determine the best style as well as adjusting it for the consistency of the configured WebTab behaviors.

    This feature will also work in conjunction of RoundCorner RenderMode.
  • Size Mode

    WebTab allows you to configure the tab header to use one of three sizing mode below:

    1. Automatic
    This is the default value for the SizeMode. The automatic sizing mode is the most recommended configuration which allowing you to enter any length of characters in the tab header's text. The TabHeader will shrink and expand automatically depend on the size of the text.

    2. Fixed
    This sizing mode is suitable when you want all tab headers to have same width. When using this mode, if the size of the text exceeds the width of the tab header, the text will be wrapped automatically. To prevent text wrapping, set AllowTextWrapping to False. In the case when AllowTextWrapping is False, the overflowed text will be truncated and shown as ellipsis.

    3. Justified
    The Justified sizing mode will automatically adjust tab header's width of all headers to fit the width of the tab control. This mode is suitable when you have fixed width of tab control with a lot of tab items and in the case where empty gaps are not preferred.
  • Innovative Rendering Mode

    WebTab introduced 3 Rendering Mode that you can use to easily create professional Tab control in your web application. The RenderMode values are:

    1. Simple
    This is the default RenderMode where WebTab will render basic and simple rectangle edge for the tab header. Use this mode for best performance and compact output.

    2. RoundCorner
    Thanks to TrueShape architecture which enables WebTab to render round corner without the need of using images. With this mode, the tab header's edge will be rendered in round corner fashion allowing you simulate XP-like Tab control. You can even configure the round corner colors and other advanced settings in RoundCornerSettings property enabling you to design a XP-like Tab control in any color schemes easily.

    3. ComplexImages
    The ComplexImages rendering mode lets you create a more sophisticated style and appearance of a Tab control. You can specify the images of every part of the element's edges in ImagesSettings. Each element's part requires two set of images which is the Inactive and Active state of the tab header, and another set for the junction/intersection part.

  • Structure Management

    WebTab extensively implements Structure Management API as well as in other members. With this feature, you can load previously saved structure file or stream from either design-time or runtime (via code behind).

    To load layout programmatically, use LoadTabsStructureFromXml method available in WebTab object.
    To save layout, use SaveTabsStructureToXml method available in WebTab object.
  • Keyboard support and Accessibility

    As WebUI.NET Framework family, WebTab offers complete keyboard support and accessibility that you would expect in desktop Tab control. You can easily enable keyboard navigation by setting EnableKeyboardNavigation to True.

    When enabled, you can navigate the active tab in runtime by using following keys:
    * Ctrl+Alt+Left Arrow. Navigate active tab to the left visible and enabled tab.
    * Ctrl+Alt+Right Arrow. Navigate active tab to the right visible and enabled tab.

    The accessibility supports can be enabled through two properties:
    * ShowFocusBorder.
    By enabling this property, users can press Tab key to navigate between TabHeader. When the designated TabHeader has the Focus Border, users can hit Space or Enter in order to activate the Page for that Tab.

    * AccessKey.
    WebTabItem has AccessKey property which you can configure for each tab items. The AccessKey term is similar to Mnemonic key used in WinForm development. For instance, you have the tab header's Text set to "General" and would like user to be able to access the General page by pressing Alt+G, you can then set the AccessKey to "g" (note that AccessKey is case-insensitive). In runtime mode, you will see an underline beneath G character automatically.
  • AllowScrolling and Automatic Resizing

    For scalability objective, you may use WebTab to contain a lot of tab items which might exceed the boundary of the Tab control itself. WebTab allows you to accomplish this scenario by turning on Scrolling feature.

    The feature can be easily enabled with setting AllowScrolling to True. When set to True, a Left and Right arrow will appear at the right end of the Tab control.

    The AllowScrolling feature worked in conjunction with Automatic Resizing, that is the arrows will appear as "disabled" when there are no items exceeding the Tab width boundary. However, when later user resized the browser window which cause the Tab control to be smaller than available items, the WebTab will automatically enable the Scroll arrows. Furthermore, any active tab which set from either codes or invoked by keyboard keys will be scrolled into view automatically.

    The AllowScrolling feature will also work perfectly in conjunction with programmatic API call to the WebTab. For instance, adding or removing tab items dynamically at client side.

    You can customize the Text and Image for the Scroll Arrows in TextSettings and ImagesSettings.

  • AllowClose

    For most common scenarios, you may want your users to close a Tab item by clicking on a Close button at right end of the Tab control. For example, in the scenario of "Text Editor application" or closable property pages. You can achieve this easily by configure AllowClose property to True.

    When enabled, a Close control will appear at the right end of the Tab control, after the Scroll arrows if AllowScrolling is enabled. When clicked, it will close the currently Active Tab and activate the nearest tab at the right or left side depend on the which is available.

    There should be at least one Active Tab so that the only Tab left in the WebTab control can't be closed.

  • Client Side Events

    WebTab exposed numerous client side events that you can consume in order to create rich interaction and extensible web applications. Following is the list of available client side events:

    - OnAfterTabClosed
    - OnAfterTabChanged
    - OnBeforeClosed
    - OnBeforeTabChanged
    - OnCreated
    - OnInitialize
    - OnScroll

    The OnBeforeClosed event is the best place where you can put your codes to validate some actions before the Tab is really closed. For instance, you may want to display a WebDialogBox asking "Do you want to save the changes?". You can cancel the Close action by returning false in your javascript function which used to handle the event.

    The other most common scenario would be populating some information when a Tab is activated. For instance, you might want to call a FlyPostBack action through FlyPostBackManager to fill the fields on demand when the Tab is activated. In this case, you can handle OnAfterTabChanged client side event.

    The parameters passed to the events will be automatically created for you when you chosen "Create new handler..." in Visual Studio Property Window's Dropdown designer.

  • Comprehensive Client Side OOP and API

    As member of WebUI.NET Framework family, WebTab is extensively taking advantage of the client side framework enabling the same structure of object model between server and client side.

    Additionally, WebTab provides comprehensive API for you to easily interact and manipulate the objects at clientside (runtime). For example, you can easily disable or enable a TabItem by calling tabItem.Enable(). You can also programmatically closing a tab, creating a new tab and add it the TabPages collection, switching active tab, changing the caption or image of a Tab item, and more. For a list of complete WebTab API, please see "Client Side Reference >> WebTab".
  • IFrame ContentMode

    By default, the WebTab will operate in "UseInlineContent" mode when a new instance is dropped to designer surface. UseInlineContent is the most suitable when the contents inside each tab page are relatively small. You can also determine the "content load" by inspecting the performance during page load as well as the size of the output. UseInlineContent mode utilized .NET Framework's Templating archictecture and therefore all contents are loaded at once in first load (although the inactive pages are set to hidden).

    In most cases where you want to develop a more reusable form, you should use UseIFrame for the content mode. When using IFrame mode, you would need to specify the ContentURL which page you want to load for the designated Tab item.

    The ContentURL accepts three formats of URL:
    1. .NET specific application relative URL. This format starts with "~" character, for instance, "~/FolderA/Page1.aspx".
    2. Absolute URL. This format starts with "/" character, for instance, "/SharedModule/Page1.aspx".
    3. Relative URL. This format usually starts with "." character or no special characters (which assume the page can be found in the current folder's context).

    You can configure different ContentMode for each TabItem. To apply all TabItem to use a specific ContentMode, configure the ContentMode in WebTab control level and leave TabItem's ContentMode to Default.
  • Advanced IFrame-related Features

    WebTab introduced several advanced features related to IFrame (that is when ContentMode is set to UseIFrame). These advanced features are:
    • IFrameAllowTransparency. The Default value is True.
      When set to True, the IFrame will show the background color specified in ContainerStyle instead of the background color in the page specifid in ContentURL. This feature will produce better consistency of the user interface and appearance, without having to configure background color of each webform.

      The webform specified in ContentURL must have its bgColor set to transparent. For instance, <body bgColor="transparent">

    • IFrameAutoLoadContent. The Default value is False.
      When set to True, WebTab will automatically load all the pages specified in each tab's ContentURL at first load. This is not recommended when you have numerous tab items as it will degrade the performance at first load. When set to False (default), the IFrame's URL will be populated on demand only when the TabHeader is clicked (activated).
    • IFrameShowLoader. The Default value is True.
      When set to True, the WebTab will display an animated image and text indicating that the Page is currently in loading progress. This feature is helpful when loading a relatively large page and still keep informing the user of the loading progress. See following screenshot for more details.

      You can customize the in progress image and text in ImagesSettings and TextSettings respectively.

  • Advanced ComplexImages Features

    In "Innovative Rendering Mode" point above, we have mentioned about ComplexImages rendering mode which makes it possible for designers to create the images of every part of elements to simulate the look&feel of modern styles such as irregular MSN style or Visual Studio style.

    WebTab introduced three unique advanced features related to the ComplexImages:
    • AllowOverlappingEdges. Default value is False.
    • RenderDividerForActiveTab. Default value is True.
    • UseSpecialRightSeparator. Default value is False.
  • Fully customizable styles and appearances

    WebTab allows you to customize most of the elements' styles by using strongly typed WebStyle and DynamicStyle properties listed in following:
    • ContainerStyle
    • DisabledStyle
    • FrameStyle
    • TabItemImageStyle (DynamicStyle including Normal, Over and Active styles)
    • TabItemStyle (DynamicStyle)
    • TabSeparatorStyle
  • Component Designer

    Instead of changing properties in Visual Studio Property Window, you can configure most properties shown in "logical group" from WebTab Component Designer. You can also easily manipulate the styles, properties as well as managing the TabPages.

    Most Intersoft's components that exposed rich functionalities, complex objects and collection would implement Component Designer similar to the screenshot above. The consistency of the user interface and functions throughout all Intersoft's components would significantly reduce learning time as well as increasing productivity.

See Also

Related Topics
{Overview}
{Understanding Concepts}


Understanding Concepts

Understanding Concepts
See Also Send Feedback
Intersoft WebDesktop > WebTab > Understanding Concepts

Glossary Item Box

Introduction

Intersoft's WebTab component implements the appearances and rich behaviors of Tab in Desktop Application.

The WebTab object represents the main operational area which contains a collection of tab items. You can add as many tab items as you like into this collection, you can even configure it globally through the main WebTab object, or set it individually through each item's property.

All Tab items that are currently inside the collection will be displayed in the design time, and as a result of ClickAndEdit™ and ClickAndSelect™ technologies you can edit the content of each tab item straight away, regardless of using IFrame or InlineContent as the ContentMode.

More Details

WebTab component has been designed in high details. The component hierarchy of WebTab in both development and runtime environment will be explained in this section.

WebTab object is created by default to have a value of height 300px and width 500px which you can easily resize either by setting it in the property, or resizing it directly through the designer. You can specify the size of WebTab in pixels or in percentage measurement.

As what we have mentioned above, a WebTab object consists of a tab items collection. Each of this tab items has its own property that can be set individually, or set globally using the default property inherited from the WebTab object.

The list of properties that can be set at Tab Item level:

  • Style
  • AccessKey
  • AllowClose
  • CaptionDisplayMode
  • ContentMode
  • ContentURL
  • Image
  • ImageAlignment
  • InProgressText
  • IsEnabled
  • IsSeparator
  • Name
  • Text
  • Tooltip
  • Width

Component Hierarchy Illustration

Picture 1: WebTab object property list.

Picture 2: Tab item property list from WebTab Designer.

WebTab's main property is shown in picture 1. In WebTab1, we have a collection of Tab Items which consists of "Customers", "Products", and "Description" Tab.

For example, In the WebTab object's property, we set the ContentMode into "InlineContent", which means by default, all of the Tab Items in the collection will have "InlineContent" as the default ContentMode. You can still configure each individual TabItem from the designer (WebTab Designer).

See Also

Related Topics
{Overview}
{Features}


Working with ClickAndEdit and Designers

Working with ClickAndEdit and Designers
Send Feedback
Intersoft WebDesktop > WebTab > Working with ClickAndEdit and Designers

Glossary Item Box

Introduction

WebTab that is supported by Intersoft's new technologies, ClickAndEdit™and ClickAndSelect™, has brought a new unique design time experience with more convenient and efficient WYSIWYG editing mode.

Picture 1:

Both of these WebTabs' ContentMode above are configured to use IFrame. When you have already specified the ContentURL, a Button "Edit [Page" will appear in the center of the TabItem, as you can see through Tab1 example in above picture. Using the ClickAndSelect™ technology, this button will lead you to interact directly with the object related with this IFrame. The second tab (Tab2) demonstrates when there is no ContentURL specified yet. When there is no ContentURL specified yet, the Button "Specify ContentURL for this Tab" will appear. Once you click on the button, an URL Picker DialogBox will appear asking for the URL that will be linked to this IFrame, and when you pick the URL, it will apply it straight away to the HTML.

Picture 2:

In picture2, The tab's ContentMode is configured to use InlineContent. When using this mode, Intersoft has used ClickAndEdit technology to make possible for you to edit the content of the Tab directly, just by clicking on the content inside the "dashed-border box" region. You can put any controls inside it, including server side controls, html controls, user controls.


Enabling TrueShape rendering

Enabling TrueShape rendering
Send Feedback
Intersoft WebDesktop > WebTab > Enabling TrueShape rendering

Glossary Item Box

Introduction

TrueShape architecture has made WebTab possible to render round corner without the need of using images. To be able to use this feature, you would need to set the value of RenderMode property to "RoundCorner". With "RoundCorner" RenderMode, the tab header's edge will be rendered in round corner fashion allowing you simulate XP-like Tab control. WebTab also facilitate you with configuration for the round corner colors and other settings related with RoundCorner in RoundCornerSettings property. With all of this accessibility to configure your WebTab's RoundCorner properties, to design a XP-like Tab control in any color schemes is no longer a troubled matter to be done.

RoundCornerSettings facilitates you to configure 2 colors for RoundCorner tab header, which represent FillerBorderColor and TopBorderColor of the active tab item.

FillerBorderColor

The first color is the FillerBorderColor. The color specified in this property will become the filler color of the WebTab header's border.

TopBorderColor

The second color is the TopBorderColor which will turn out to be the color for the top part of the WebTab header's border.

ApplyHover

In RoundCornerSettings, you can customize your WebTab to apply active colors in mouse over event for your inactive WebTabItems. To use this feature, you will need to set the ApplyHover property to true ( by default, this property is set to false).

picture1: When ApplyHover property is set to false, the color that is applied on the inactive-hovered tab item is the inactive color.

picture2: When ApplyHover property is set to true, the color that is applied on the inactive-hovered tab item is the active color.


Working with Complex Images

Working with Complex Images
Send Feedback
Intersoft WebDesktop > WebTab > Working with Complex Images

Glossary Item Box

Introduction

With WebTab's ComplexImages RenderMode option, you can customize your WebTab appearance using images to be more stylish and complex.

Customizing the appearance and behavior of your WebTab control by using "ComplexImages" RenderMode enable three new unique advanced features which include the capability of having a True Tab behavior which allows the inactive tabs'edges to be overlapped by the active-tab item, setting the visibility of the active tab's divider, and using the special right separator.

picture1: Properties included in ComplexImagesSettings

AllowOverlappingEdges Feature

As what have been stated in the introduction section, by setting the RenderMode into "ComplexImages", we can simulate the true tab behavior which allows the inactive tabs' edges to be overlapped by the active-tab item.

picture2: When AllowOverlappingEdges is set to false, then the edges of the tab will not overlapped each other.

picture 3: When AllowOverlappingEdges is set to true, then the edges of the tab will overlapped each other.

To enable the overlapping edges feature from WebTab, firstly you will need to set the RenderMode to "ComplexImages", followed by setting the property AllowOverlappingEdges to true (by default the value of this property is false). You will also need to specify the images of every part of the element's edges in ImagesSettings. Each element's part requires two set of images to represent the Inactive and Active state of the tab header's intersection part.

picture4: Images that need to be set in order to get OverlappingEdges feature.

RenderDeviderForActiveTab

RenderDividerForActiveTab property indicates whether the divider between header and content should be rendered in ActiveTab. For this property to take an effect, you will need to set the RenderMode to "ComplexImages". By default, RenderDeviderForActiveTab property is set to true. To disable the divider for active tab, you will need to set the property RenderDeviderForActiveTab to false.

UseSpecialRightSeparator

UseSpecialRightSeparator indicates whether the Tab control should render the tabs'separator on the right side of ActiveTab using special images. This property can be used to achieve look and feel similar to Visual Studio 2005 tabs.

For this property to take an effect, you will need to set the RenderMode to "ComplexImages". By default, UseSpecialRightSeparator property is set to false. To use special right separator, you will need to set the property UseSpecialRightSeparator to true. You will also need to specify the images of every part of the element's edges, and one image that will make a difference by using special right separator is SpecialRightSeparator image. Each element's part requires two set of images to represent the Inactive and Active state of the tab header's intersection part.

The pictures below illustrate how the UseSpecialRightSeparator will have an effect on your WebTab appearance.

picture1: The normal tab with some image settings, UseSpecialRightSeparator is set to false.

picture2: When UseSpecialRightSeparator property is set to true and SpecialRightSeparator image is set to use specific image.


Tutorials

Tutorials
Send Feedback
Intersoft WebDesktop > WebTab > Tutorials

Glossary Item Box

This section contains tutorial topics in WebTab.

In This Section

Creating Simple Tab

Creating Overlapped Edges Tab

Changing Tab Position

Configuring Scrolling Tab Mode

Configuring Closable Tab Mode

Adding new TabItem at Client-side

Changing TabItem Caption at Client-side

Displaying confirmation box before TabItem is closed

Creating Visual Studio 2005 Style Tab

Saving and Loading Structure Programmatically

Configuring Justify Sizing mode

Enabling Focus border for Accessibility

How-to: Configure WebTab Modes

How-to: Add/Close Tab in Client-Side

How-to: Use Tab in User Control

How-to: Populate Tab Content Programmatically in Server-side


Creating Simple Tab

Creating Simple Tab
See Also Send Feedback
Intersoft WebDesktop > WebTab > Tutorials > Creating Simple Tab

Glossary Item Box

Objectives

WebTab gives you a freedom to customize the Render Mode of the WebTab to be either "Simple", "RoundCorner" or "ComplexImages". This tutorial will guide you to configure your WebTab to use Simple Render Mode. By default, the render mode property is set to "Simple". This tutorial will guide you to create a simple WebTab.

  1. Drag WebTab into a WebForm to create a new WebTab's instance.

  2. To add another TabItem objects, click on "Add New Tab", and there will be a window prompted asking for the TabItem's caption.

  3. To change the TabItem's caption, right click on the WebTab's instance, and choose WebTab Designer. Choose TabPages on the Properties, and then select the TabItem that you want to edit. To change the text that will be displayed on the TabItem's caption, change the "Text" property.

  4. To edit the text inside the TabItem, select on the WebTabItem, then click on the area inside the TabItem.

  5. Save all the changes that you have made, build the project and run it. In the browser, you will see something like the following.

See Also

Related Tutorials
{Creating Overlapped Edges Tab}
{Changing Tab Position}
{Configuring Scrolling Tab mode}
{Configuring Closable Tab mode}
{Configuring Justify Sizing mode}
{Enabling Focus border for Accessibility}


Creating Overlapped Edges Tab

Creating Overlapped Edges Tab
See Also Send Feedback
Intersoft WebDesktop > WebTab > Tutorials > Creating Overlapped Edges Tab

Glossary Item Box

Objectives

WebTab, which demonstrates a true desktop's behaviors, allows you to create not only a regular tab, but a tab with a true tab behaviors such as the overlapped edges tab. This tutorial will guide you to configure your WebTab to use overlapped edges.

  1. Create a new WebTab's instance, and add few more TabItem objects by clicking "Add New Tab".

  2. Right Click on the WebTab's instance, click on WebTab Designer, set the RenderMode property to "ComplexImages".

  3. Set AllowOverlappingEdges under ComplexImagesSettings to "True".
    The properties inside ComplexImagesSettings will be applicable only when RenderMode is set to UseComplexImages.

  4. In Image Settings, set the Images property of all necessary images to the overlapped edges' image of the WebTab. By default, the image folder path is set to the /CommonLibrary/Images/WebDesktop/.

  5. After you clicked on "Apply" then "OK" button, your WebTab item is now set to use the ComplexImages to create overlapped edges.

  6. Save all the changes, build and run it on the browser. Finally, the WebTab will look like following:

  1. picture 1: Show the Customers tab as the active tab. Notice that the Customers right tab's edge is overlapping the Products tab's left edge.

    picture 2: Show the Products tab as the active tab. Notice that the Products tab's edges are overlapping the other tabs' edges.

See Also

Related Tutorials
{Creating Simple Tab}


Changing Tab Position

Changing Tab Position
See Also Send Feedback
Intersoft WebDesktop > WebTab > Tutorials > Changing Tab Position

Glossary Item Box

Objectives

WebTab lets you choose the tab position. You can choose to put the tab at the top position or in bottom position. By default, the property is set to "Top".

  1. Drag WebTab into a WebForm to create a new WebTab's instance. Create another few TabItem objects by using "Add Tab Pages".

  2. To change the position of the Tab, right click on the WebTab object, and choose Properties to display Properties window. Choose "Position" from the property window.

  3. Change the Position Property from "Top" to "Bottom".

  4. Save all the changes, build the program and run it.
  5. WebTab will look like following:

See Also

Related Tutorials
{Creating Simple Tab}


Configuring Scrolling Tab mode

Configuring Scrolling Tab mode
See Also Send Feedback
Intersoft WebDesktop > WebTab > Tutorials > Configuring Scrolling Tab mode

Glossary Item Box

Objectives

WebTab gives you an option whether the WebTab control should have a scroll button when the number of TabItem exceeds the controls' width. By default, the scroll button is not visible. This tutorial will guide you on how to configure the scrolling tab mode.

  1. Drag WebTab into a WebForm to create a new WebTab's instance.

  2. Create few more TabItem objects "Add New Tab", until the number of TabItem exceeds the controls' width.

  3. To make the scrolling button visible, right click on the WebTab object, and choose Properties to display Properties window. Choose "AllowScrolling" from the property window and set it to "True".

  4. Save all the changes, build the program, and run it. In the browser, you should see something like following.

    picture 1: When we have reached the left end of the WebTab, and we still have items on the right that are not visible because they exceed the controls' width.

    picture 2: When there are items on the left and on the right that are not visible because it exceeds the controls' width.

See Also

Related Tutorials
{Creating Simple Tab}


Configuring Closable Tab mode

Configuring Closable Tab mode
See Also Send Feedback
Intersoft WebDesktop > WebTab > Tutorials > Configuring Closable Tab mode

Glossary Item Box

Objectives

WebTab gives you many options to configure the behaviors of your WebTab, one of them is to configure it to be closable. This tutorial will guide you to configure it.

1. Drag WebTab into a WebForm to create a new WebTab's instance.

2. Create few more TabItem objects by clicking "Add New Tab".

3. To make the close button in WebTabItem visible, right click on the WebTab object, and choose Properties to display Properties window. Choose "AllowClose" from the property window and set it to "Yes".

4. Save all the changes, build and run it. In the browser, you should see something like the following.

5. You can click on [image] button to close the TabItem. After you close the TabItem, it will straight away display the next TabItem.

See Also

Related Tutorials
{Creating Simple Tab}


Adding new TabItem at Client Side

Adding new TabItem at Client Side
See Also Send Feedback
Intersoft WebDesktop > WebTab > Tutorials > Adding new TabItem at Client Side

Glossary Item Box

Objectives

WebTab enables you to add a new TabItem not only at the designer or at the server side, but also at Client Side. This tutorial will guide you to create a new TabItem at ClientSide.

  1. Drag WebTab into a WebForm to create a new WebTab's instance.

  2. Add a button into the WebForm.

  3. Add an OnClick client side events to the button to relate it to the AddNewTab function.

    Script Copy Image Copy Code
    <input id="Button1" type="button" value="Add New Tab" onclick="AddNewTab()" />

  4. Add a AddNewTab function to the WebForm.
    Script Copy Code
    <script language="javascript">
var tabNewIndex = 1;
function AddNewTab()
{
   var tab = ISGetObject("WebTab1");
   var newItem = tab.AddNewTabItem("Untitled" + tabNewIndex, "Untitled " + tabNewIndex, null);

   newItem.SetActive(); // set the newly created tab item as active.
   tabNewIndex++;
}
</script>

  5. Add a AddNewTab function to the WebForm.
  6. Save all the changes and build the project. When you run it in the browser you will see something like the following.

  7. If you click on the "Add New Tab" button, it will add a new TabItem that is processed at client side. The result would be something like this.

See Also

Related Tutorials
{Creating Simple Tab}


Changing TabItem Caption at Client Side

Changing TabItem Caption at Client Side
See Also Send Feedback
Intersoft WebDesktop > WebTab > Tutorials > Changing TabItem Caption at Client Side

Glossary Item Box

Objective

WebTab, with its flexible architecture, allows you to change the TabItem's caption either from server side or client side. This tutorial will guide you to change the TabItem's caption at client side.

  1. Create a new WebTab's instance, and add few more TabItem objects by clicking "Add New Tab".

  2. Drag a TextBox object, and a button object to the WebForm.

  3. Switch to the HTML Source of the page. Add the following code to change the tab item caption at client side.

    Script Copy Code
    <script language="javascript" type="text/javascript">
function ActionPerformed()
{
   var WebTab = ISGetObject("WebTab1");
   var textBox = document.getElementById("TextBox1").value;
   var activeTab = WebTab.GetActiveTab();
   activeTab.SetCaption(textBox);
}
</script>

  4. Add an onclick event on the button.

    C# Copy Code
    <input id="Button1" type="button" value="Change TabItem Caption" onclick="ActionPerformed()" />

  5. Save all the changes, build and run it on the browser. Try to input something inside the textbox, and click the button, and you will see the text you have just inputted into the textbox has replaced the current active tab's caption.

See Also

Related Tutorials
{Creating Simple Tab}


Displaying confirmation box before TabItem is closed

Displaying confirmation box before TabItem is closed
See Also Send Feedback
Intersoft WebDesktop > WebTab > Tutorials > Displaying confirmation box before TabItem is closed

Glossary Item Box

Objective

WebTab, with its true tab's behavior and its strong integration with other component, makes possible for you to customize the WebTabItem to display a confirmation box, which is made using WebDialogBox, before TabItem is closed. This tutorial will demonstrate how to make it.

  1. Drag WebTab into a WebForm to create a new WebTab's instance.

  2. To make the close button in WebTabItem visible, right click on the WebTab object, and choose Properties to display Properties window. Choose "AllowClose" from the property window and set it to "Yes".

  3. Add a HTML Input TextBox into "Tab 1" to represent the editable area and named it "txt_Untitled0".

  4. Switch to your HTML page and add all of these codes.

    Javascript Copy Code
    <script language = "JScript" type="text/javascript">
function OnBeforeClosed(controlId, tabItem)
{
   if(tabItem.ForceClose)
   {
      return true;
   }
   else
   {
      if(tabItem.DocumentChanged)
      {
         var dlgBoxPrompt = ISGetObject("dlgBoxPrompt");
         dlgBoxPrompt.ShowDialog();
      }
      else
      {
         //not changed, close immidiately
         return true;
      }
         return false; // don't close at this time
   }
}
//This function is called when the dialog box has been closed.
//Demonstrate how to obtain dialogResult and perform logic based
//on the dialogResult

function dlgBoxPrompt_Closed(controlId, dialogResult)
{
   var tab = ISGetObject("WebTab1");
   var activeTab = tab.GetActiveTab();
   if(dialogResult == "Yes")
   {
      //perform save logic
         alert("Do Save Logic");
         activeTab.DocumentChanged = false;
   }
   else if (dialogResult == "No")
   {
      if(tab.TabPages.length > 1)
      {
         activeTab.ForceClose = true;
         activeTab.Close();  // really close this time
      }
      else
      {
         // the only tab item can't be closed, so clear the textbox and focus it.
         activeTab.DocumentChanged = false;
         ClearActiveTextBox();
         FocusActiveTextBox();
      }
   }
   else
   {
      // cancel, don't close the tab and focus back to the textbox.
      FocusActiveTextBox();
   }
}

function ClearActiveTextBox()
{
   var tab = ISGetObject("WebTab1");
   var activeTab = tab.GetActiveTab();
   var textBox = document.getElementById("txt_"+ activeTab.Name);
   if(textBox)
      textBox.value = "";
}

function FocusActiveTextBox()
{
   var tab = ISGetObject("WebTab1");
   var activeTab = tab.GetActiveTab();
   var textBox = document.getElementById("txt_"+ activeTab.Name);
   if (textBox)
      textBox.focus();
}
// This function is called when the text is changed.
// Demonstrates how to obtain activetab and set tab's caption dynamically.

function OnTextChanged()
{
   var tab = ISGetObject(WebTab1");
   var activeTab = tab.GetActiveTab();
   if( event.keyCode != 16 && event.keyCode != 17 && event.keyCode != 18 && event.keyCode != ISKeyboardKey.LEFT && event.keyCode != ISKeyboardKey.RIGHT)
   {
      if(!activeTab.DocumentChanged)
      {
         activeTab.DocumentChanged = true;
         activeTab.SetCaption(activeTab.Text + "*");
      }
   }
}
</script>

  5. Add an onkeydown event for the HTML Input TextBox so it would change the DocumentChanged properties from the WebTabItem to "True" (note: see the related client side events above).

    C# Copy Code
    <input id="txt_Untitled0" style="width: 487px; height: 266px" type="text"
    onkeydown="OnTextChanged()" />

  6. Click on the ClientSideEvents in the WebTab's instance's properties window. Add OnBeforeClosed event handler by adding "OnBeforeClosed" event on the property.

  7. Click on the ClientSideEvents in the WebDialogBox's instance's properties window. Add OnClose event handler by adding "dlgBoxPrompt_Closed" event on the property.

  8. Save all the changes and build the project. When you run it in the browser you would see something like the following.

  9. Try to input something inside the editable area, and you would see that automatically it will have a (*) indicating that page has been changed.

  10. And if you try to close "Tab 1" by clicking the [image] button, it will display a confirmation box asking whether you want to save the changes before you close the item.

  11. If you choose "Cancel", it will come back to the screen without making any changes. If you choose yes, it will perform the save logic.

  12. After you click on "OK", you will see that the the tab is already closed.

See Also

Related Tutorials
{Creating Simple Tab}


Creating Visual Studio 2005 Style Tab

Creating Visual Studio 2005 Style Tab
See Also Send Feedback
Intersoft WebDesktop > WebTab > Tutorials > Creating Visual Studio 2005 Style Tab

Glossary Item Box

Objective

WebTab gives you a convenient way of applying different style for your WebTab's instance. Other than the Style that you make by your own, WebTab Designer will provide a few different predefined style. This tutorial will guide you how to change the style using Visual Studio 2005 Style Tab.

  1. Create a new WebTab's instance, and add few more TabItem objects by clicking "Add New Tab".

  2. Right Click on the WebTab's instance, click on WebTab Designer, choose "Layout Manager". Expand the "Predefined Layout" node, and choose "Visual Studio 2005".

  3. Click on the "Apply Layout" button at the top of the Designer, and then click on the "Apply" button at the bottom right of the Designer, if you want to see the Preview, click on "Preview Current Layout".

  4. Once you click on "OK" button, you will see the style has been applied to the WebTab.

See Also

Related Tutorials
{Creating Simple Tab}


Saving and Loading Structure Programmatically

Saving and Loading Structure Programmatically
See Also Send Feedback
Intersoft WebDesktop > WebTab > Tutorials > Saving and Loading Structure Programmatically

Glossary Item Box

Objective

WebTab brings you a new way of developing your application. It gives an easy way to save the current structure of the WebTab to be reused on another WebTab. This tutorial will guide you how to use the feature.

  1. Create a new WebTab's instance, and add few more TabItem objects by clicking "Add New Tab".

  2. Create another plain WebTab's instance, and 2 buttons. 1 Button is for Saving the Layout and another button is for Loading the Layout.
  3. Add a OnClick Server Side Event for Save Layout Button.

    C# Copy Code

    protected void Button2_Click(object sender, EventArgs e)

    {
       WebTab1.SaveTabsStructureToXml("Style1.xml");
    }

  4. Add a OnClick Server Side Event for Load Layout Button.

    C# Copy Code

    protected void Button1_Click(object sender, EventArgs e)

    {

       WebTab2.LoadTabsStructureFromXml("Style1.xml");

    }

  5. Save all the changes, Build, and Run in the browser.

  6. Click on "Save Layout" and then click on "Apply Layout", what you will see is the Tab Structure in WebTab1 is applied to WebTab2.

See Also

Related Tutorials
{Creating Simple Tab}


Configuring Justify Sizing mode

Configuring Justify Sizing mode
See Also Send Feedback
Intersoft WebDesktop > WebTab > Tutorials > Configuring Justify Sizing mode

Glossary Item Box

Objective

WebTab offers you a selection in arranging the layout of the WebTab to use either "Default", "Automatic", "Fixed" or "Justify". This tutorial will guide you how to use set the sizing mode into "Justify".

  1. Create a new WebTab's instance, and add few more TabItem objects by clicking "Add New Tab".

  2. Right Click on the WebTab's instance, click on WebTab Designer, set the SizeMode property to "Justify".

  3. Finally, click on "Apply", and then "Ok". In the designer, you will see that the size of your WebTabItem has already changed, it is already being justified to match the size of the WebTab.

See Also

Related Tutorials
{Creating Simple Tab}


Enabling Focus border for Accessibility

Enabling Focus border for Accessibility
See Also Send Feedback
Intersoft WebDesktop > WebTab > Tutorials > Enabling Focus border for Accessibility

Glossary Item Box

Objective

WebTab which expresses the true desktop's behaviors, gives you an accessibility of enabling the focus border from the keyboard. This tutorial will guide you how enable the feature.

  1. Create a new WebTab's instance, and add few more TabItem objects by clicking "Add New Tab".

  2. To enable the focus border, right click on the WebTab object, and choose Properties to display Properties window. Choose "ShowFocusBorder" from the property window and set it to "True".

  3. Save all the changes, and run it on the browser. In the browser, it will be something like the following. To activate the tab border, click on "Tab" key on the keyboard. To navigate between the TabItem, press the "Tab" key from the keyboard. To activate the TabItem's page of the focused tab item, press "Enter" or "Space" Key.

See Also

Related Tutorials
{Creating Simple Tab}


How-to: Configure WebTab Modes

How-to: Configure WebTab Modes
Send Feedback
Intersoft WebDesktop > WebTab > Tutorials > How-to: Configure WebTab Modes

Glossary Item Box

WebTab has several modes that user can customized. They are ContentMode, DisplayMode and SizingMode.

In this topic, you will learn how to configure WebTab Modes.

To configure Content Mode

  1. By default, ContentMode is set to UseInlineContent. Therefore, to use inline content, WebTab has used ClickAndEdit technology to make possible for you to edit the content of the Tab directly, just by clicking on the content inside the "dashed-border box" region. You can put any controls inside it, including server side controls, html controls, user controls.
  2. To use IFrame, simply set ContentMode to UseIFrame and set the ContentURL to the page you want to display in the IFrame. When you have already specified the ContentURL, a Button �??Edit [Page]�?� will appear in the center of the TabItem. Using the ClickAndSelect�?� technology, this button will lead you to interact directly with the object related with this IFrame.

To configure Display Mode

  1. You can configure WebTab with different position. Simply set Position to Bottom.
  2. To change WebTab's caption mode, go to TabPages and click the collection button.
  3. Set CaptionDisplayMode to TextAndImage. Then, set Image to location of the image itself.
  4. To change the image's position, simply set ImageAlignment to either Top, Bottom, Left or Right.

To configure Sizing Mode

  1. The default SizeMode is Automatic, where each TabItem's width depends on its Text's length. When SizeMode is set to Justify, the WebTabItem's size will be justified according to the WebTab's Size.
  2. When SizeMode is set to Fixed and DefaultTabItemWidth is set to 100px, each Tab's Size will use the value specified in DefaultTabItemWidth.


How-to: Add/Close Tab in Client-Side

How-to: Add/Close Tab in Client-Side
Send Feedback
Intersoft WebDesktop > WebTab > Tutorials > How-to: Add/Close Tab in Client-Side

Glossary Item Box

You can add and close new tab items programmatically at client side.

This topic will show you how to add/close tab in client side.

To add/close tab in client-side

  1. Drag 2 HTML buttons from the toolbox.
  2. Create AddNewTab() function to implement adding new tab.
    JavaScript Copy Code
    var tabNewIndex = 0;
function AddNewTab()
{
   tabNewIndex++;

   var tab = ISGetObject("WebTab1");
   var newItem = tab.AddNewTabItem("WebTab" + tabNewIndex, "WebTab " + tabNewIndex, null);
   var activeTab = newItem;

   activeTab.ContentMode = "UseInlineContent";
   newItem.SetActive(); // set the newly created tab item as active
}

  3. Create CloseTab() function to implement closing tab items.
    JavaScript Copy Code
    function CloseTab()
{
   var tab = ISGetObject("WebTab1");
   var tabItem = tab.GetActiveTab();

   tabItem.Close();
}

  4. Invoke AddNewTab() and CloseTab() using html button onclick event.

    <input id="Button1" type="button" value="button" onclick="AddNewTab()" />

    <input id="Button2" type="button" value="button" onclick="CloseTab()" />

  5. Run the project.


How-to: Use Tab in User Control

How-to: Use Tab in User Control
Send Feedback
Intersoft WebDesktop > WebTab > Tutorials > How-to: Use Tab in User Control

Glossary Item Box

WebTab is able to be used inside user control.

This topic will show you how to use tab in user control.

To use tab in user control

  1. Create a Web User Control containing WebTab. Named it as ucWebTab.ascx.
  2. Create a WebForm and drag ucWebTab.ascx into the page.
  3. Run the project. In this case, WebTab is able to work inside a user control.


How-to: Populate Tab Content Programmatically in Server-Side

How-to: Populate Tab Content Programmatically in Server-Side
Send Feedback
Intersoft WebDesktop > WebTab > Tutorials > How-to: Populate Tab Content Programmatically in Server-Side

Glossary Item Box

WebTab can populate tab content from code behind.

This topic will show you how to populate tab content programmatically in server-side,

To populate tab content programmatically in server-side

  1. Drag WebTab control to the WebForm.
  2. Place the following code in Page_load in order to populate tab content.
    C# Copy Code
    protected void Page_Load(object sender, EventArgs e)
{
   String strContent =
         "<div class='text'>This window is using InlineContent mode created from code behind.</div>";

   WebTab1.TabPages[1].PageTemplate = new GenericContainerTemplate(strContent);
   WebTab1.TabPages[2].ContentURL = "HTMLpage.htm";
   WebTab1.TabPages[2].ContentMode = ContentMode.UseIFrame;
}

  3. Run the project.


WebMenu

WebMenu
See Also Send Feedback
Intersoft WebDesktop > WebMenu

Glossary Item Box

WebMenu
Member of WebDesktop.NET

WebMenu is the core runtime system that builds up WebMenuBar and WebContextMenu control. Featured with ClickAndBuild Visual Editor, you can easily build any complex menu with rich WYSIWYG experience.

What's New in WebMenu

Learn the Features

WebMenuBar control

WebContextMenu control

Working with Visual Menu Builder
Quick Start

Using MenuBar in PlaceHolderManager

Working with MenuItem Types

Handling Command Client-side Events

Easily create professional Office 2003-like menu system

Use WebMenuBar control to quickly build a professional Office-like, dockable menu user interface to your web application. The MenuBar is modeled after the popular desktop's Menu system, and provides unique functions in addition to the regular features of a Menu. For instance, the MenuBar can work properly in modern visual styles with very minimum changes. You can create a professional Menu as easy as within 2 steps. First, simply drop a new instance of MenuBar from ToolBox. Next, define the Menus and its MenuItem using Intersoft's flagship Visual Menu Builder.

Multiple functions, one architecture

The hybrid menu system enables tight integration with various WebDesktop.NET's members that requires menu functions, which is also the same core foundation that builds WebMenuBar and WebContextMenu control. By using the same base architecture, developers will get consistent object model and API across products that implement the menu system which significantly reduce learning time and complexity.

Improved user experience with familiar desktop-style keyboard supports

WebMenu does not only offer the capability to simulate latest visual styles which are highly configurable through property settings. WebMenu implements every single details of a Desktop's Menu, from every keystroke, mouse events to advanced behaviors. The result is a great benefit for end users who have been familiar with desktop applications, such as navigation of menu items through keyboard arrow keys, navigation between menus and sub menus, accesskey (MnemonicKey) supports for active menu, and more.

See Also

Getting Started
{Features}
{Styles}
{Keyboard Supports}


What's New in WebMenuBar

What's New in WebMenuBar
See Also Send Feedback
Intersoft WebDesktop > WebMenu > What's New in WebMenuBar

Glossary Item Box

WebMenu feature include: auto-adjust to browser size, unlimited submenus with intelligent positioning, automatic vertical item scrolling, sticky behavior, and mnemonic key support.

In version 4, WebMenu has been refined to fully support the latest web standards. This allows you to use many of the WebMenu features in your next-generation web applications and at the same time leveraging cutting-edge technologies such as HTML5 and CSS3.

Following are list details of the enhancements and new features introduced in WebMenu:

  • New intuitive style in WebMenuBar

    In version 4, WebDesktop presents a new style in each of its control. Metro style as the latest UI in Windows 8 have been implemented and becomes brand new UI in WebDesktop control. Metro style makes WebDesktop more simple, more tidy, and more attractive for each control’s UI. The intuitive design of Metro style also provide consistency of each control in HTML5.

    You can simply use Layout Manager to implement Metro style in WebDesktop.

    For more information on how to apply this configuration, see How-To: Using Layout Manager.

See Also

WebMenu

Features
Features


WebMenuBar

WebMenuBar
See Also Send Feedback
Intersoft WebDesktop > WebMenu > WebMenuBar

Glossary Item Box

WebMenuBar
Member of WebDesktop.NET

WebMenuBar introduces most of functionalities a MenuBar control should have, plus integrated with PlaceHolderManager and completed with powerful Designer which will help the process of design time in a more convenient way.

What's New in WebMenuBar

Learn the Features

Working with WebMenuStyles

Keyboard Supports Available

Quick Start

Creating Standalone MenuBar

Working with MenuItem Types

Enabling and Disabling MenuItem

Create Windows Desktop-like MenuBar

Use WebMenuBar control to easily build a Windows Desktop-like's MenuBar. WebMenuBar is designed with a professional architecture and object model as well as specialized user interface for each elements. Therefore, WebMenuBar provides a flexibility to create a Windows-like MenuBar object which is not only rich in styles, but also in every functions and behaviors.

Integration with PlaceHolderManager

WebMenuBar has the ability to be integrated with PlaceHolderManager. You may perform a dockable MenuBar which commonly found in desktop-based applications. By using PlaceHolderManager architecture, you can freely dock the MenuBar together with WebToolBar with no extensive coding required. Learn more about PlaceHolderManager concepts and Interactive PlaceHolderManager Designer for better understanding concepts.

Interactive Designer

WebMenuBar is also supported with an interactive designer which eases you during design and development time process. No more unvisualized designer or hard coding, with Interactive PlaceHoderManager Designer and VisualMenu Builder you are given a visualization in high WYSIWYG details.

MenuItem Types

In MenuItem Types, we have 5 different types of command, such as:
- Normal
- Radio
- CheckBox
- Separator
- Custom

Interactive Designer

The following table lists the client side events available in this release.

Client Side Event | Description
OnClick | Invoked when control is clicked.
OnDblClick | Invoked when control is double-clicked.
OnMouseDown | Invoked when MouseDown event is fired on control.
OnMouseMove | Invoked when OnMouseMove event is fired on control.
OnMouseOut | Invoked when mouse is outside while event is fired on control.
OnMouseOver | Invoked when MouseOver event is fired on control.
OnMouseUp | Invoked when MouseUp event is fired on control.

Refer to Handling Command Client Side Events for Tutorial guidance.

See Also

Getting Started
{Features}
{Styles}
{Keyboard Supports}


WebContextMenu

WebContextMenu
See Also Send Feedback
Intersoft WebDesktop > WebMenu > WebContextMenu

Glossary Item Box

WebContextMenu
Member of WebDesktop.NET

WebContextMenu introduces most of functionalities a MenuBar control should have, plus integrated with DesktopManager, bind with Server-side controls capability and completed with powerful Designer which will help the process of design time in a more convenient way.

Learn the Features

Working with WebMenuStyles

Keyboard Supports Available

Quick Start

Attaching ContextMenu to a Control

Showing ContextMenu Programmatically

Create Windows Desktop-like ContextMenu

Use WebContextMenu control to easily build a Windows Desktop-like's ContextMenu. WebContextMenu is designed with a professional architecture and object model as well as specialized user interface for each elements. Therefore, WebContextMenu provides a flexibility to create a Windows-like ContextMenu object which is not only rich in styles, but also in every functions and behaviors.

Integration with DesktopManager

WebContextMenu has the ability to be integrated with DesktopManager. When integrated, WebContextMenu will refer to the DesktopManager instance and use the Styles defined in DesktopManager automatically. The benefits of this integration are faster page performance with reduced output and maintain the uniform "look & feel" in entire application effortlessly. Learn more about PlaceHolderManager concepts and Interactive PlaceHolderManager Designer for better understanding concepts.

Bind To Control

WebContextMenu provides you the easiest way on performing server-side controls integration. You just simply set the ControlId property to the server control's id, and the designer will do the integration part automatically without any extensive coding required.

MenuItem Types

In MenuItem Types, we have 5 different types of command, such as:
- Normal
- Radio
- CheckBox
- Separator
- Custom

Client Side Events

The following table lists the client side events available in this release.

Client Side Event | Description
OnInitialize | Invoked when control is initialized.
OnMenuItemClick | Invoked when the menu item is clicked.
OnShowMenu | Invoked when the menu is about to show.

Refer to Handling Command Client Side Events for Tutorial guidance.

See Also

Getting Started
{Features}
{Styles}
{Keyboard Supports}


Features

Features
See Also Send Feedback
Intersoft WebDesktop > WebMenu > Features

Glossary Item Box

  • TrueMenu behavior

Exposing the highest details of every Menu behavior which has closest behavior to Desktop-based Menu. The behaviors including:

    • Menu is not limited by browser size (special feature for IE)
    • Unlimited sub menu with intelligent positioning.
    • Automatic scrolling when height dimension is not sufficient for contained items.
    • Sticky behavior, where submenu will stay visible when mouse cursor has left the area of the submenu and went back to the submenu within specified delay in milliseconds. This is similar to the Menu system implemented in Office 2003.
    • Show submenu only after specified milliseconds, if mouse cursor has left the menu item, the submenu will be cancelled from showing.
    • Supports mnemonic keys where users can type directly on the underlined character to access the matched item.
    • Supports shortcut keys
    • Supports Images or Font-based Image for Icon display
    • When a submenu is previously shown in Scrolling mode, it should be able to remember last scroll position and automatically restore last scroll position in next show.
  • Hybrid Menu System
    The menu system incorporates hybrid architecture enabling server side WebContextMenu control and built-in menu system used in other WebDesktop members to use the same menu runtime system, which built upon WebUI.NET Framework and taking advantange of advanced Object concept such as encapsulation and inherittance allowing all Menu system to be running in one hybrid menu runtime system.

    For example, context menu in DesktopManager, menu system in Toolbar's SplitMenu and DropDownMenu, as well as in WebMenuBar and WebContextMenu are all using the same runtime engine. With this architecture, developers will find the same object model or API whenever they need to access or manipulate the context menu. This produces new, unique development experience with totally enhanced productivity and efficiency by reducing coding efforts.
  • Desktop Manager Integration
    WebMenu and WebContextMenu system can be used in both stand alone and integration mode. In stand alone mode, you can specify each style for each menu instance's appearances. However, most of time, developers would want to consolidate all menu instances in entire application to use one style definition. Thanks to the hybrid menu system which enables tight integration with desktop manager and allow developers to specify the menu styles at desktop manager level.

    With this time-saving feature, developers no longer need to configure every instances of the menu in the entire applications one-by-one. There are 2 integration mode available to both WebMenu and WebContextMenu:
    • Integration to Desktop Manager.
      This is the most recommended configuration to create a uniform and consistent look&feel for all menu instances throughout entire applications. When integrated to DesktopManager, the Menu will use Application MenuStyles defined in DesktopManager level. To do this, you simply set the IntegratedTo property to DesktopManager. The menu system will automatically apply the styles at runtime, and hence the integration also means compact output since styles and CSS classes for the menu instance are no longer rendered.
    • Integration to PlaceHolder Manager.
      This scenario is the best applied when you want to have all menu instances inside a WebForm to use one single style definition which is different with DesktopManager's Application MenuStyle. The easiest way to understand this integration mode is by examining how Office 2003 application works. So all menu system in Office 2003 applications are using one single style definition which is separate to Windows menu style. Likewise, all menu system in Visual Studio 2005 used one single style defined at application level, which differs from Windows menu style.
  • Highly customizable styles and appearances
    WebMenu is designed with rich and highly customizable styles in mind. It can simulate almost any kind of menu appearances, from Windows system menu to latest Outlook 2003 style in every high detail. Following are list of configurable elements:
    • ItemStyle with 3 states: Normal, Over and Active.
      ItemStyle represent the dynamic style for each menu item.
    • CheckedItemStyle with 3 states: Normal, Over and Active.
      This dynamic style is applied to the "icon part" of checked menu item.
    • DisabledItemStyle with 3 states
      This dynamic style is applied for disabled menu item.
    • SeparatorStyle
      The style applied to Separator.
    • FrameStyle
      The style applied to the menu's frame.
  • Automatic Layout Management,

Enabling the Menu to be drawn in consistent fashion and in proper layout which conforms to Desktop User Interface standard with at minimal styles configuration as possible. For instance, designer is not require to specify width or height of a style or other dimension-related appearance since the Menu system implemented Automatic Layout Management which is capable to show the Menu in required Width and Height following the maximum extent of boundaries available in the Items. With this feature, designer can concentrate on major appearances such as the background color, fore color, font or other appearance properties of styles.

  • Customizable BackgroundStrip Gradient Colors
    You can easily configure the "BackgroundStrip" visibility in the menu style object. BackgroundStrip menu appearance is firstly introduced in Office XP application and later enhanced in Outlook 2003 where gradient colors can be applied to make the icons looks nicer. In WebMenu, you can also configure its gradient and colors in the property configuration and hence allow you to create any kind of menu themes with futuristic look, whether you wanted a blue gradient theme similar to Office 2003, or a gray gradient theme similar to Visual Studio 2005 -- all without requiring images!
  • Extensive keyboard support
    WebMenu and its entire runtime system which acts as the backend for all Menu needs (such as ContextMenu as well as any menu integrated in DesktopManager, ToolBar, NavBar and others) supports keyboard navigation extensively. The keyboard navigation includes the following:
    • Up and down arrow keys for navigating items.
    • Left arrow key will navigate to previous menu item.
    • Right arrow key will navigate to sub menu and automatically highlight first item in the sub menu.
    • Escape key will close the current sub menu and move focus back to previous sub menu until all menus are closed.
    • Enter key will execute currently selected item's action.
    • Any specified mnemonic keys in the current active menu will be executed when pressed.

Furthermore, the keyboard support implementation has been implemented to follow Windows User Interface guideline. For example, users can start to use the valid keyboard keys once the menu is shown without additional focus or clicks, and the keyboard strokes should not affect the behavior of elements in the page.

  • Client side constructable

Most of the times developers will find that constructing the Menu such as WebMenuBar or ContextMenu is more convenient and sufficient to be done at server side where the instances can be declared on the WebForm page. However in some advanced scenarios, the Menu can't be defined at server side due to the information availability in client side. In this context, the menu items need to be able to be constructed at client side instead of server side.

With this powerful feature, you can construct the WebContextMenu object programmatically at client side and adds as much items as you want by using the extensive WebMenu API which discussed in the below item.

  • Strong Client side OOP

For easy setup and comprehensive Item management API

WebMenu provides extensive object model for representing Menu and MenuItem as well as rich API for manipulating the objects in client side. This makes it possible for developers to create rich interaction in the web applications, such as, disabling or enabling menu item, make it hidden or visible, remove items as well as late-bound new item addition. Finally, it also supports bulk refresh when massive changes have been performed to the WebMenu.

  • ClickAndBuild Visual Menu Editor

    WebMenu comes with advanced menu builder allowing developers to conveniently and easily build any kind of menus. The menu editor is tightly integrated into Visual Studio 2005 IDE featuring innovative functions below:
    • Replaces treeview interface with WinForm-like MenuEditor which exposes greater WYSIWYG design-time experience.
    • Click and Type metaphor. All you need to do is clicking on Empty Menu Item area and type the Text. If you click on an empty item in the sub menu, it will automatically become item in the submenu.
    • Complete keyboard and mouse navigations and behaviors.
  • IconView Mode

    WebMenu supports an innovative feature called IconView mode. This mode enables the Menu to be displayed in compact form where MenuItem with Image are arranged horizontally and automatically flows to the next line as it reaches more items. This mode is especially useful when there are lots of menu items that used Images as users can easily find the command they're looking for.
  • Superior Mozilla Support

    The menu system will run perfectly in Mozilla-based browsers with equal dimensioning, layout and behaviors as appear in Internet Explorer. There will even no difference in any "pixel" by using the same style definition, no matter whether you specified padding, margin, or any border size.

See Also

Related Topics
{Overview}
{WebMenuBar}
{WebContextMenu}


Styles

Styles
Send Feedback
Intersoft WebDesktop > WebMenu > Styles

Glossary Item Box

Introduction

This documentation provides in-depth information on customizable styles in Hybrid Menu System. As part of Intersoft WebUI Studio.NET family, every component requires high-level style encapsulation which provides easy and convenient way to customize styles, look and feel as well as visual appearances of the component in WebForm.

Unique to Intersoft Menu System, there are numerous styles and behaviors that can be easily applied through property change where previously require extensive image editing and tedious workarounds. For instance, you can easily draw a background strip similar to Office-style menu by setting HasBackgroundStrip property to True. You can even customize its colors by specifying the BackgroundStripColor and additionally BackgroundStripColor2 to achieve gradient effect.

Menu Styles

The following table lists customizable styles available in control which implements Menu System.

Style/Behavior | Description
BackgroundStripColor | The background color of the strip.
BackgroundStripColor2 | The second background color of the strip. When specified, gradient fill will be applied to the strip.
BackgroundStripWidth | The width of the background strip.
CheckedItemStyle | The interactive style of Menu Item when checked.
ContentPadding | The padding width between Menu Item, applied to Content (Text) part.
DisabledItemStyle | The interactive style of Menu Item when disabled.
FrameStyle | The style of Menu's Frame.
HasBackgroundStrip | Indicates whether the background strip should be drawn.
ItemPadding | The padding width between Menu Item.
ItemStyle | The interactive style of Menu Item.
SeparatorStyle | The style of Separator Menu Item.

The following image shows the Menu Styles in visual details.


Keyboard Supports

Keyboard Supports
See Also Send Feedback
Intersoft WebDesktop > WebMenu > Keyboard Supports

Glossary Item Box

Introduction

As the key to build successful rich web applications that behave closely with desktop's application functions, WebMenu provides comprehensive keyboard supports so that certain tasks can be easily invoked through combined keys. The keyboard supports intended to help people with disabilities, and to follow U.S. Section 508 Accessibility standard.

Supported Navigation Keys

The following is a list of supported navigation keys in WebMenu control implemented in this release.

The following keys are valid when the focus is at the WebMenuItem.

· Left Arrow Key Navigate to the Parent WebMenuItem.

· Right Arrow Key Navigate to the SubItem of the current WebMenuItem

· Up Arrow Key Navigate to the MenuItem above the current WebMenuItem

· Down Arrow Key Navigate to the MenuItem below the current WebMenuItem

Supported Access Keys

You can specify our own accelerator key by defining it in the AccessKey property inside every WebMenuItem. You can access to MenuBar through alt key (e.g. Alt + f for File)

Alt-key access is also supported for cross-frames. Any sub-frames will respond to the alt-key in parent level that contain Menu controls.

Supported Shortcut Keys

The following is a list of supported shortcut keys in WebMenu control implemented in this release.

  • Esc Key Cancelling Menu
  • Enter Key Invoking command of selected menu item

See Also

Related Articles
{Smart Keys}


Overview

Overview
Send Feedback
Intersoft WebDesktop > WebMenu > Overview

Glossary Item Box

Introduction

The Visual Menu Builder was built to let you effortlessly create menu structures of WebContextMenu, WebMenuBar or WebToolBar for your Web application. The menu builder is designed with simplicity in mind and you will find its behaviors very similar to Visual Studio 2005's built-in WinForm menu editor, therefore eliminating learning curves.

The rich-designer feature of the WebMenu (WebContextMenu, WebMenuBar and WebToolBar) means that you can use Visual Menu Builder to build menu structures and add/insert/delete menu items to the menu structure at the same time. You can also modify the properties of the WebMenu object and the menu items it contains through the provided PropertyGrid.

Visual Menu Builder

Features

Here are some of the benefits introduced by Visual Menu Builder designer:

  • Significant developer's productivity gains through rich and interactive designer.
  • Reduced lines of codes required to program the Page with the elegant architecture of the Visual Menu Builder.
  • Reduced learning curve with the ease-of-use since the Visual Menu Builder's usage is very similar to that found in WinForm's built-in menu editor.
  • Reduced overhead in Page's maintenance when required at future development phase.


Features

Features
Send Feedback

Glossary Item Box


Working with Visual Menu Builder

Working with Visual Menu Builder
Send Feedback
Intersoft WebDesktop > WebMenu > Visual Menu Builder > Working with Visual Menu Builder

Glossary Item Box

This section contains information on how to work with Visual Menu Builder.

In This Section

Building WebToolBar Structure

Building WebMenuBar Structure

Building WebContextMenu Structure


Building WebToolBar Structure

Building WebToolBar Structure
See Also Send Feedback
Intersoft WebDesktop > WebMenu > Visual Menu Builder > Working with Visual Menu Builder > Building WebToolBar Structure

Glossary Item Box

Introduction

Building a WebToolBar using Visual Menu Builder is different from building a WebContextMenu or WebMenuBar in terms of usage. Although WebToolBar implements the IBar interface as with WebMenuBar and thus have a visual representation of a bar, you cannot directly add menu items to the bar.

In WebToolBar the Visual Menu Builder is used only for adding menu items to ToolCommand objects whose type is DropDownButton or SplitButton. That said, you first need to add a ToolCommand object to the WebToolBar object and set its type to DropDownbutton or SplitButton. Only then you can add menu items to the ToolCommand object. To add ToolCommands to WebToolBar you can use the WebToolBar Designer which is available in the context menu when you right click a WebToolBar object.

When you open the Visual Menu Builder by right-clicking the WebToolBar and select "Visual Menu Builder" you will be shown the designer as below (the menu items shown here are for example):

Visual Menu Builder showing a menu item's Context Menu

More Information

In Visual Menu Builder a WebToolBar object is represented by the menu bar. Clicking on the menu bar will have the property grid show all the properties of the WebToolBar object.

After you create a ToolCommand object with DropDownButton or SplitButton type, you can click on the ToolCommand object to add a menu item. If you click on a menu item, its properties will show up in the property grid and you can change the values from here. As you might have noticed, only a Normal menu item type can have sub menu items or children. To add a sub menu item simply click on the normal menu item and then a type selector will show up and enable you to add a new sub menu item. It is not recommended to add sub menu items using the property grid as the added menu items will not be reflected on the visual representation of the menu items. There are some properties that will be reflected on the visual representation upon changes: Checked, Enabled, Text, Type and ShortCut.

You can also change a menu item's text by clicking the menu item, or double-click if the menu item has not gotten focus (indicated by a solid border). Changing the menu item Text, however, will not change the menu item Name.

After finishing adding/deleting menu items in the WebToolBar object click OK to apply changes to your object, or click Cancel to revert back to the object prior to changes.

See Also

Related Topics
Building WebContextMenu Structure
{Building WebMenuBar Structure}


Building WebMenuBar Structure

Building WebMenuBar Structure
See Also Send Feedback
Intersoft WebDesktop > WebMenu > Visual Menu Builder > Working with Visual Menu Builder > Building WebMenuBar Structure

Glossary Item Box

Introduction

Using Visual Menu Builder to build a WebContextMenu is similar to using it to build the other WebMenu components (WebContextBar and WebToolBar). However, there are some significant differences between them. A WebMenuBar in the Visual Menu Builder is represented by the menu bar whereas a WebContextMenu is represented by the "Context Menu" menu item. Since the WebMenuBar implements the IBar interface, it has a visual representation of a bar.

When you open the Visual Menu Builder by right-clicking the WebMenuBar you will be shown the designer as below (the menu items shown here are for example):

More Information

In Visual Menu Builder a WebMenuBar object is represented by the menu bar. Clicking on the menu bar will have the property grid to show all the properties of the WebMenuBar object. A menu type selector will also be added to the end of the menu item collection. You can add menu items to the WebMenuBar by typing text into the "Type Here" TextBox or simply select a menu type from the menu type selector dropdown.

Note that menu items that were added to the bar are of MenuCommand type and menu items that were added as its sub menu item are of WebMenuItem type. Both this types share very similar properties with the exception the MenuCommand type is specifically used for menu items on the Bar.

Clicking on the created menu item will show up its properties in the property grid and you can change the values from here. As you might have noticed, only a Normal menu item type can have sub menu items or children. To add a sub menu item simply click on the normal menu item and then a type selector will show up and enable you to add a new sub menu item. It is not recommended to add sub menu items using the property grid as the added menu items will not be reflected on the visual representation of the menu items. There are some properties that will be reflected on the visual representation upon changes: Checked, Enabled, Text, Type and ShortCut.

You can also change a menu item's text by clicking the menu item, or double-click if the menu item has not gotten focus (indicated by a solid border). Changing the menu item Text, however, will not change the menu item Name.

After finishing creating or modifying the WebMenuBar object click OK to apply changes to your object, or click Cancel to revert back to the object prior to changes.

See Also

Related Topics
{Building WebContextMenu Structure}
{Building WebToolBar Structure}


Building WebToolBar

Building WebToolBar
Send Feedback

Glossary Item Box


Building WebContextMenu Structure

Building WebContextMenu Structure
See Also Send Feedback
Intersoft WebDesktop > WebMenu > Visual Menu Builder > Working with Visual Menu Builder > Building WebContextMenu Structure

Glossary Item Box

Introduction

Although using Visual Menu Builder to build a WebContextMenu is similar to using it to build the other WebMenu components (WebMenuBar and WebToolBar) there are some significant differences between them. WebContextMenu does not implement the IBar interface and therefore, at runtime, does not have a bar or a visual representation to mark its presence. To see a WebContextMenu you have to right-click on an item that has a context menu in your form.

When you open the Visual Menu Builder by right-clicking the WebContextMenu you will be shown the designer as below:

Visual Menu Builder showing WebContextMenu

More Information

As you can see from the screenshot above, the WebContextMenu object is represented by the "Context Menu" menu item in the MenuBar. Clicking on this menu item will pop a dropdown menu up, and the property grid will show the properties of the WebContextMenu object. In the dropdown menu you can add menu items to the context menu by typing text into the "Type Here" TextBox or simply select a menu type from the menu type selector dropdown.

Clicking on the created menu item will show up its properties in the property grid and you can change the values from here. As you might have noticed, only a Normal menu item type can have sub menu items or children. To add a sub menu item simply click on the normal menu item and then a type selector will show up and enable you to add a new sub menu item. However it is not recommended to add sub menu items using the property grid as the added menu items will not be reflected on the visual representation of the menu items. There are some properties that will be reflected on the visual representation upon changes: Checked, Enabled, Text, Type and ShortCut.

You can also change a menu item's text by clicking the menu item, or double-click if the menu item has not gotten focus (indicated by a solid border). Changing the menu item Text, however, will not change the menu item Name.

After finishing creating or modifying the WebContextMenu object click OK to apply changes to your object, or click Cancel to revert back to the object prior to changes.

See Also

Related Topics
{Building WebMenuBar Structure}
{Building WebToolBar Structure}


Tutorials

Tutorials
Send Feedback
Intersoft WebDesktop > WebMenu > Tutorials

Glossary Item Box

This section contains tutorial topics in WebMenu.

In This Section

Using MenuBar in PlaceHolderManager mode

Creating Standalone MenuBar

Working with MenuItem Types

Handling Command Client Side Events

Attaching ContextMenu to a Control

Showing ContextMenu Programmatically

Enabling and Disabling MenuItem

Add new MenuItem at Client Side

How-to: Create MenuBar with Shortcuts

How-to: Create Template Menu Item

How-to: Enable Navigation and AutoPostBack

How-to: Create WebMenu programmatically in Server-side


Using MenuBar in PlaceHolderManager mode

Using MenuBar in PlaceHolderManager mode
See Also Send Feedback
Intersoft WebDesktop > WebMenu > Tutorials > Using MenuBar in PlaceHolderManager mode

Glossary Item Box

Objectives

This tutorial demonstrates how to use WebMenu with PlaceHolderManager and how you can add WebToolBar together with WebMenu in the same PlaceHolderManager.

  1. Drag PlaceHolderManager from Toolbox into a WebForm page.

  2. Drag WebMenuBar from Toolbox into the PlaceHolderManager.

  3. You may customize Docking position for WebMenu using its properties and set the DockingArea to your desired location.

  4. Drag WebToolBar from Toolbox into the PlaceHolderManager.

    As you can see, WebMenu can be placed together along with WebToolbar in the same PlaceHolderManager. You may also customize the commands for each WebMenu and WebToolBar using their designer respectively.

  5. Run the Project and you should see something like the following.

See Also

Related Articles
Creating Standalone MenuBar
{Working with MenuItem Types}
{Enabling and Disabling MenuItem}
{Add new MenuItem at Client Side}
{Creating Dockable Toolbar}


Creating Standalone MenuBar

Creating Standalone MenuBar
Send Feedback
Intersoft WebDesktop > WebMenu > Tutorials > Creating Standalone MenuBar

Glossary Item Box

Objectives

WebMenu can be created as a stand-alone MenuBar as well. This tutorial provides you step-by-step guidance to create stand-alone MenuBar.

  1. Drag WebMenuBar from Toolbox into a WebForm page.

  2. You may customize WebMenu from its properties. For example: Customizing the WebMenu Button using Commands Collection from properties or designer like the following snapshot, and many other features available.


Working with MenuItem Types

Working with MenuItem Types
See Also Send Feedback
Intersoft WebDesktop > WebMenu > Tutorials > Working with MenuItem Types

Glossary Item Box

WebMenuBar provides various type options available in MenuItem.

This topic will show you how to work with MenuItem Types by using WebMenuBarBar Designer.

To customize various MenuItem Types

  1. Right-click on the MenuBar and choose WebMenuBarBar Designer. The designer box will appear as the following.
  2. Go to Menus and add menu commands as you desired.

  3. In Items property on Menus node, click the Collection button. It will bring you to the WebMenuBarItem Collection Editor box.
  4. You may freely customize menu commands item as you desired. Click OK to apply the settings

    In MenuItem Types, we have 5 different types of command, such as:
    - Normal
    - Radio
    - CheckBox
    - Separator
    - Custom

  5. Run the Project and you will see something like following.

See Also

Related Articles
{Using MenuBar in PlaceHolderManager mode}
{Creating Standalone MenuBar}


Handling Command Client Side Events

Handling Command Client Side Events
Send Feedback
Intersoft WebDesktop > WebMenu > Tutorials > Handling Command Client Side Events

Glossary Item Box

Objectives

WebMenuBar provides a set of Command ClientSide Events in order to give you an easier way to implement or handle the processing of selected menu item through its ClientSide events. This tutorial will demonstrate how to invoke selected menu item using MouseUp client side event.

  1. Drag WebMenuBar from Toolbox into a WebForm page.

  2. Right-click on the MenuBar and choose WebMenuBarBar Designer. The designer box will appear as the following.
  3. Go to Menus and add menu commands as you desired.

  4. In Items property on Menus node, click the Collection button. It will bring you to the WebMenuBarItem Collection Editor box.
  5. Again, you may freely customize menu commands item as you desired.

    In MenuItem Types, we have 5 different types of command, such as:
    - Normal
    - Radio
    - CheckBox
    - Separator
    - Custom

  6. In the client-side, add the following codes:
    Javascript Copy Code
    <script language="javascript" type="text/javascript">
function OnMenuCommands(controlId, menuCommand)
{
   if(menuCommand.Text == "File")
   {
      if(menuCommand.SelectedMenuItem != null)
      {
         var mi = menuCommand.SelectedMenuItem;
         ExecCommand(mi.Text);
      }
   }
}

function ExecCommand(commandText)
{
   switch (commandText)
   {
      case "New":
               alert("Implement New function");
               break;

      case "Open":
               alert("Implement Open function");
               break;
   }
}
</script>

  7. Invoke OnMenuCommands() function from CommandClientSideEvents under MouseUp event.

  8. Run the Project and you will see something like following.


Attaching ContextMenu to a Control

Attaching ContextMenu to a Control
See Also Send Feedback
Intersoft WebDesktop > WebMenu > Tutorials > Attaching ContextMenu to a Control

Glossary Item Box

WebContextMenu allows you to apply the same context menu's behavior from Windows and customize its items collection by using properties or Visual Menu Builder.

This topic will show you how to create simple WebContextMenu and attach it to a control.

  1. Drag WebContextMenu and a ASP.NET Button controls.
  2. Right-click on the WebContextMenu and choose Properties.
  3. Attach WebContextMenu to ASP.NET Button control by setting the ControlId to Button1, which is the id of the ASP.NET Button.
  4. Go to Items and click the Collection button. It will bring you to the WebMenuItem Collection Editor box.
  5. You may freely customize menu commands item as you desired. Click OK to apply the settings.

    In MenuItem Types, we have 5 different types of command, such as:
    - Normal
    - Radio
    - CheckBox
    - Separator
    - Custom

  6. Run the Project. Right-click your mouse on the ASP.NET Button, and you will see something like following.

See Also

Related Articles
{Showing ContextMenu Programmatically}


Showing ContextMenu Programmatically

Showing ContextMenu Programmatically
Send Feedback
Intersoft WebDesktop > WebMenu > Tutorials > Showing ContextMenu Programmatically

Glossary Item Box

Objectives

WebContextMenu comes up with its ability to be shown programmatically from Server Side.

  1. Drag a Server Button from Toolbox into a WebForm page.

  2. In the Server-side or Code-behind, add the following codes:

    C# Copy Code
    protected void Page_Load(object sender, EventArgs e)
    {
     WebContextMenu wcm = new WebContextMenu();
     wcm.ControlId = "Button1";

     WebMenuItem  wmi1 = new WebMenuItem();
     wmi1.Name = "mnuContextMenu1";
     wmi1.Text = "ContextMenu1";
     wcm.Items.Add(wmi1);

     WebMenuItem wmi2 = new WebMenuItem();
     wmi2.Name = "mnuContextMenu2";
     wmi2.Text = "ContextMenu2";
     wcm.Items.Add(wmi2);

     HtmlForm frm = (HtmlForm)Page.FindControl("Form1");
     frm.Controls.Add(wcm);
    }

  3. Run the Project and right-click your mouse on the Server Button, and you will see something like following.


Enabling and Disabling MenuItem

Enabling and Disabling MenuItem
See Also Send Feedback
Intersoft WebDesktop > WebMenu > Tutorials > Enabling and Disabling MenuItem

Glossary Item Box

Objectives

WebMenu gives you a flexibility to customize MenuItem where you can freely set MenuItem Collection to be enabled or disabled according to your needs. This tutorial will give a step-by-step guidance on how to enable and disable MenuItem using Designer, Server-Side Event, and Client-Side Event.

Using Designer

  1. Drag WebMenu from Toolbox into a WebForm page.

  2. Right-click on the MenuBar and choose WebMenuBar Designer. The designer box will appear as the following.
  3. Go to Menus and add menu commands as you desired.
  4. Set IsEnabled to false for cmdView menu command.

  5. In Items property on Menus node, click the Collection button. It will bring you to the WebMenuItem Collection Editor box.
  6. Again, you may freely customize menu commands item as you desired.

    In Menu command Types, we have 8 different types of command, such as:
    - Normal
    - Button
    - ToggleButton
    - DropDownButton
    - SplitButton
    - Separator
    - Custom
    - Container
  7. Set Enabled to false for mnuSave and mnuSaveAll MenuItem Collection commands.

  8. Run the Project and you will see something like following.

Using Server Side Event

  1. Drag WebMenu, Server Buttons, and Label from Toolbox into a WebForm page. Named the Server Buttons "MenuItem Enabled" and "MenuItem Disabled" respectively.

  2. Refer to Working with MenuItem Types Tutorial for configuring MenuItems.
  3. In the Server-side or Code-behind, add the following codes:
    C# Copy Code
    protected void Button1_Click(object sender, EventArgs e)
    {
        WebMenuBar1.Menus[0].Items.GetNamedItem("mnuSave").Enabled = false;
        WebMenuBar1.Menus[0].Items.GetNamedItem("mnuSaveAll").Enabled = false;
        Label1.Text = "MenuItem Save and SaveAll have been disabled";
    }
    protected void Button2_Click(object sender, EventArgs e)
    {
        WebMenuBar1.Menus[0].Items.GetNamedItem("mnuSave").Enabled = true;
        WebMenuBar1.Menus[0].Items.GetNamedItem("mnuSaveAll").Enabled = true;
        Label1.Text = "MenuItem Save and SaveAll have been enabled";
    }

  4. Run the Project.
  5. Click the "MenuItem Enabled" Button. You will notice that the Label will display its text and when you click on the File Menu, MenuItems Save and Save All have been enabled.

  6. Now, Click the "MenuItem Disabled" button and notice that the label will display its text, and when you click on the File Menu, MenuItems Save and Save All have been disabled.

Using Client Side Event

  1. Drag WebMenu, HTML Buttons, and HTML Text from Toolbox into a WebForm page. Named the html Buttons "MenuItem Enabled" and "MenuItem Disabled" respectively.

  2. Refer to Working with MenuItem Types Tutorial for configuring MenuItems.
  3. In the Client-side, add the following codes:
    Script Copy Code
    <script language="javascript">
    function DisabledMenuItem()
    {
        var menuBar = ISGetObject("WebMenuBar1");
        menuBar.Menus[0].Menu.Items[2].Disable();
        menuBar.Menus[0].Menu.Items[3].Disable();
        document.getElementById("Text1").value = "MenuItem Save and SaveAll have been disabled";
    }

    function EnabledMenuItem()
    {
        var menuBar = ISGetObject("WebMenuBar1");
        menuBar.Menus[0].Menu.Items[2].Enable();
        menuBar.Menus[0].Menu.Items[3].Enable();
        document.getElementById("Text1").value = "MenuItem Save and SaveAll have been enabled";
    }
    </script>

  4. Invoke EnabledMenuItem() and DisableMenuItem() functions from the HTML buttons' onclick event respectively.

    Script Copy Image Copy Code
    <input id="Button2" type="button" value="MenuItem Enabled" onclick="EnabledMenuItem()"/>
    <input id="Button1" type="button" value="MenuItem Disabled" onclick="DisabledMenuItem()"/>

  5. Run the Project.
  6. Click the "MenuItem Enabled" HTML Button. You will notice that the HTML Text will display its value and when you click on the File Menu, MenuItems Save and Save All have been enabled.

  7. Now, Click the "MenuItem Disabled" HTML button and notice that the HTML Text will display its value, and when you click on the File Menu, MenuItems Save and Save All have been disabled.

See Also

Related Articles
{Using MenuBar in PlaceHolderManager mode}
{Creating Standalone MenuBar}
{Working with MenuItem Types}
{Handling Command Client Side Events}
{Add new MenuItem at Client Side}


Add new MenuItem at Client Side

Add new MenuItem at Client Side
See Also Send Feedback
Intersoft WebDesktop > WebMenu > Tutorials > Add new MenuItem at Client Side

Glossary Item Box

Objectives

This tutorial provides a step-by-step guidance on how to add new MenuItem via Client side.

  1. Drag WebMenu and HTML Button from Toolbox into a WebForm page. Named the HTML button "Add MenuItem"
  2. Refer to Working with MenuItem Types Tutorial for configuring MenuItems.

  3. In the client-side, add the following codes:
    Script Copy Code
    <script language="javascript" type="text/javascript">
function AddMenu()
{
   var menuBar = ISGetObject("WebMenuBar1");
   var menuItem1 = new WebMenuItem();
   var menuItem2 = new WebMenuItem();

   menuItem1.Name = "mnuSave";
   menuItem1.ImageURL = "../../images/save.gif";
   menuItem1.Text = "Save";
   menuItem1.Enabled = true;

   menuItem2.Name = "mnuSaveAll";
   menuItem2.ImageURL = "../../images/saveall.gif";
   menuItem2.Text = "Save All";
   menuItem2.Enabled = true;

   menuBar.Menus[0].Menu.Items.Add(menuItem1);
   menuBar.Menus[0].Menu.Items.Add(menuItem2);
   alert("MenuItem Save and SaveAll have been added");

   document.getElementById("Button1").disabled = "disabled";
}
</script>

  4. Invoke AddMenu() function from the HTML button's onclick event.

    Script Copy Code
    <input id="Button1" type="button" value="Add MenuItem" onclick="AddMenu()"/>

  5. Run the Project and you will notice that in the File Menu, there are only 2 MenuItems which are New and Open.

  6. Click the "Add MenuItem" button and it will display an Alert box.

  7. Click the File Menu and you will see that MenuItems Save and Save all have been added, and "Add MenuItem" button has been disabled.

See Also

Related Articles
{Working with MenuItem Types}
{Using MenuBar in PlaceHolderManager mode}
{Creating Standalone MenuBar}
{Enabling and Disabling MenuItem}
{Handling Command Client Side Events}


How-to: Create MenuBar with Shortcuts

How-to: Create MenuBar with Shortcuts
Send Feedback
Intersoft WebDesktop > WebMenu > Tutorials > How-to: Create MenuBar with Shortcuts

Glossary Item Box

You can have various shortcut types in MenuBar.

This topic will show you how to create MenuBar with shortcuts.

To create MenuBar with Shortcuts

  1. Right click on WebMenuBar control and choose Visual Menu Builder.
  2. Create a MenuBar item. For example: File or Edit.
  3. Create the MenuBar item collection. For example: New Window, New Tab.
  4. In MenuBar item collection Properties, expand Shortcut.
  5. In Shortcut, you can customize shortcut types. In this case, set AlphabetKey to N and Ctrl to True.
  6. Set OnClick to scCTRLN.

  7. Create scCTRLN() function to give alert when you press CTRL+N from keyboard.
    JavaScript Copy Code
    function scCTRLN()
{
   alert("Performing Ctrl+N : File-New Window");
}

  8. Run the project. When you press CTRL+N, MenuBar will trigger New Window and invoke scCTRLN() function.


How-to: Create Template Menu Item

How-to: Create Template Menu Item
Send Feedback
Intersoft WebDesktop > WebMenu > Tutorials > How-to: Create Template Menu Item

Glossary Item Box

WebMenuBar provides Template type that can be used to place other controls.

This topic will show you how to create Template menu item.

To create Template menu item

  1. Attach ContextMenu to a control.
  2. In WebMenuItem Collection Editor, select mnuContextMenu2. Select Items and click the collection button.
  3. Create one menu item named mnuContextMenuTemplate and set Type to Template.
  4. Right click on WebContextMenu and choose Edit Template >> Items.
  5. In mnuContextMenuTemplateItem, drag any control you want to use. In this case, WebCombo control is used and bound to Customers table using AccessDataSource control.
  6. Right click on the template page and choose End Template Editing to apply the settings.
  7. Go to WebContextMenu's Properties. Expand MenuStyleSettings and set MenuWindowType to Normal.
  8. Run the project. Right click on the button and point your mouse to ContextMenu2. The sub menu item is using template type which contains WebCombo control.


How-to: Enable Navigation and AutoPostBack

How-to: Enable Navigation and AutoPostBack
Send Feedback
Intersoft WebDesktop > WebMenu > Tutorials > How-to: Enable Navigation and AutoPostBack

Glossary Item Box

WebMenuBar has capability to enable navigation and AutoPostBack features.

This topic will show you how to enable Navigation and AutoPostBack.

To enable Navigation and AutoPostBack

  1. Create menu item in WebMenuBar.
  2. In cmdHelp menu command, select Items and click the collection button.
  3. Create one menu item. Set Text to Perform AutoPostBack and AutoPostBack to Yes.
  4. Create another menu item. Set Text to Open Intersoft Website and TargetURL to http://www.intersoftpt.com.
  5. Run the project.


How-to: Create WebMenu programmatically in Server-Side

How-to: Create WebMenu programmatically in Server-Side
Send Feedback
Intersoft WebDesktop > WebMenu > Tutorials > How-to: Create WebMenu programmatically in Server-Side

Glossary Item Box

WebMenuBar can be created programmatically from server-side.

This topic will show you how to create WebMenuBar's structure programmatically in server-side.

To create WebMenu programmatically in server-side

  1. Place the following code in Page_Load to create WebMenuBar's structure.
    C# Copy Code
    protected void Page_Load(object sender, EventArgs e)
{
   // programmatically create command and items
   MenuCommand cmdFile = new MenuCommand();
   cmdFile.Name = "cmdFile";
   cmdFile.AccessKey = "F";
   cmdFile.Text = "File";

   WebMenuItem itmNew = new WebMenuItem();
   itmNew.Name = "itmNew";
   itmNew.Text = "New";

   WebMenuItem itmNewWindow = new WebMenuItem();
   itmNewWindow.Name = "itmNewWindow";
   itmNewWindow.Text = "New Window";

   WebMenuItem itmNewTab = new WebMenuItem();
   itmNewTab.Name = "itmNewTab";
   itmNewTab.Text = "New Tab";

   WebMenuItem separator = new WebMenuItem();
   separator.Type = MenuItemType.Separator;

   itmNew.Items.Add(itmNewTab);
   cmdFile.Items.Add(itmNew);
   cmdFile.Items.Add(new WebMenuItem("Open"));
   cmdFile.Items.Add(new WebMenuItem("Save", "mnuSave", "../Images/Save.gif"));
   cmdFile.Items.Add(separator);
   cmdFile.Items.Add(new WebMenuItem("Exit", "mnuExit", "", "e"));
   WebMenuBar1.Menus.Add(cmdFile);
}

  2. Run the project.


WebDialogBox

WebDialogBox
See Also Send Feedback
Intersoft WebDesktop > WebDialogBox

Glossary Item Box

WebDialogBox
Member of WebDesktop.NET

WebDialogBox enables you to easily create modal dialog box on the top of DesktopManager which perfectly replicating the behavior of desktop's dialog box.

What's New in WebDialogBox

Learn the Features

Integrating to DesktopManager

Quick Start

Creating Simple DialogBox

Designing custom DialogBox

Showing DialogBox

Enhanced user experience by providing modern-styled dialog box

Use WebDialogBox control to easily display professional looking dialogbox in your webform. WebDialogBox features modal dialogbox capabilities similar to desktop's behaviors. For instance, the parent form that show the dialogbox should become non-focusable and non-clickable. With the detailed dialogbox implementation, WebDialogBox dramatically enhance user's experience while working in web-based application.

Replace traditional web page dialog with customized dialogbox

In most cases, developer would need to provide a modal dialogbox when requiring input from end users. The traditional web page dialog approach requires you to create a Page for every dialog box and caused ineffectivity in the long run when developing complex web application. WebDialogBox enables you to create customized dialogbox by using reusable component model with the ease-of-use of ClickAndEdit development experience and built-in CommandButtons collection.

Increased usability and extensibility with DesktopManager integration

When integrated to DesktopManager, WebDialogBox will automatically inherit style definition specified in DesktopManager. This provides zero-efforts for delivering consistent visual styles of the WindowStyle. In addition, WebDialogBox is further extended with the Window behaviors available in DesktopManager. Although WebDialogBox fully supports standalone mode, it's best to be used along together with DesktopManager.

See Also

Getting Started
{Overview}
{Integrating to DesktopManager}


What's New in WebDialogBox

What's New in WebDialogBox
See Also Send Feedback
Intersoft WebDesktop > WebDialogBox > What's New in WebDialogBox

Glossary Item Box

WebDialogBox provides you a powerful dialog box component from Intersoft that delivers a true desktop experience. WebDialogBox has keyboard support and eight predefined button types returned as DialogResult when it is close. Offers you with easiest way to change the style of dialog box, WebDialogBox allows you to make stylish dialog box in web applications.

In version 4, WebDialogBox fully supports the latest web standards and style sheet language which is HTML5 and CSS3. In use, WebDialogBox will appear like WebDesktopWindow but it has more simplicity in terms of content because it has been configured based on CSS3. Take a deep consideration on usage of padding. Padding in HTML5 has different rendering because HTML5 has content-box as default value of box-sizing. With consistency for each modern browsers, WebDialogBox stands out as fabulous component in creating web application.

These are the following details of enhancements and new features that have been implemented in WebDialogBox:

  • Fluid content

    Adopting from WebDesktopWindow, in version 4, you can specify the height of its header by using WindowHeaderHeight property in WindowSettings. The default value is 24 and the rest area of container will be calculated automatically by WebDialogBox.

  • Smooth moving and resizing

    In version 4, WebDialogBox also revamps all of its structures. Now, by using div element, this control can resize smoother than the earlier version and it has good performance on moving.

  • Automatic partition area

    The content inside WebDialogBox has been changed due to table differences in HTML. In version 4, the area between image, text, and button are divided by CSS3 calc. This methods let the browser to adjust the size of WebDialogBox' content regarding its frame.

  • New intuitive style in WebDesktop 4

    In version 4, WebDesktop present a new style in each of its control. Metro style as the latest UI in Windows 8 had been implemented and became brand new UI in our WebDesktop control. Metro style makes WebDesktop simpler, tidier, and more attractive for each control's UI. The intuitive design of Metro style also provides consistency of each control in HTML5.

    To enable this feature, you just need to Integrate WebDialogBox to WebDesktopManager with Metro Style by setting the value of IntegrateToDesktopManager property to true value. When you integrate WebDialogBox to WebDesktopManager, WebDialogBox will inherit all the styles from WebDesktopManager and add it to WebDialogBox even if WebDesktopManager has complex images border inside it.

See Also

WebDialogBox

Features
Features


Features

Features
See Also Send Feedback
Intersoft WebDesktop > WebDialogBox > Features

Glossary Item Box

WebDialogBox offers unique dialog box UI functionalities with highly customizable appearances and styles. It simulates a true "modal" dialog which has closest behavior to desktop's dialog box.

WebDialogBox introduced new breakthrough in Web User Interface by providing following key features:

  • TrueModal behavior
    One of the big challenges in web-based user interface is to create a custom dialog box which has true modal behavior similar to desktop's dialog boxes. Intersoft's WebDialogBox is so far the only web component being able to simulate modal behavior closely to desktop's style. The modal behavior consists of following attributes:
    - When DialogBox shown, the parent window which own the DialogBox should become unclickable.
    - Parent window and all objects inside the parent window must not be focusable, means that the focus should not change from the current dialog box to the parent window's objects.
    - When tab key is pressed, focus should not move to the parent window. That means, focus must be cycled between objects in DialogBox scope only.
    - When window has lost its focus, the DialogBox should stay on the top of parent window. And when the window gains back its focus, the focus should be automatically set on the DialogBox.
  • DesktopManager Integration
    WebDialogBox can be used in either StandAlone mode or Integrated mode. By default, DialogBox will use StandAlone mode when constructed at the first time. You can easily configure the Integration by setting IntegratedToDesktopManager property to True. When running in StandAlone mode, the dialog box will be displayed on the top of the document's body. The best usage would be integrating DialogBox into DesktopManager, where the DialogBox will be created on demand only when the ShowDialogBox method is called in client side. Furthermore, when Integrated, the DialogBox will automatically apply the Styles and Appearance of the Window and Button and therefore the DialogBox will have consistent look&feel throughout entire application.
  • ClickAndEdit design time experience
    Thanks to Intersoft's unique ClickAndEdit architecture which enables control rendering to take place inside IDE with combination of region editing. Extensively implemented in DialogBox and entire members of WebDesktop.NET, it enables developers to conveniently click on the editable area of the DialogBox and edit it right away. You can put any formatting on the text and even any kind of third party ASP.NET controls. With it, you can create rich dialog boxes for any kind of functionalities, for instance, a dialog box listing modified files to be saved, and much more.
  • CommandButtons collection
    WebDialogBox comes with built-in CommandButtons feature. This allows developer to easily add what buttons should appear in the dialogbox instead of having developer to create their own button. The advantage of the built-in CommandButtons is its tight integration with DesktopManager as well as correct implementation of DialogResult similar to Windows Form applications. You can easily set each Button's Type which will be used as DialogResult when the dialog box is closed.
  • DialogResult and CommandButton's Type
    DialogResult exposed the same concept and behavior as in Windows Form application. There are 8 predefined button types which will be used as DialogResult when the dialog box is closed. The enumerations are Abort, Retry, Ignore, OK, Cancel, Yes, No and Custom. You may set the Button's Text differently than the Button Type. You can also set the DisplayMode of each Button that is whether the Button should contain Image, Text or combination of both of them. The Image's position can also be configured to be displayed at left or right relatively to the Text.
  • Predefined DialogBoxImage
    The predefined DialogBoxImage lets developers easily create any type of DialogBox with default Image assigned to it. This feature simulates the behavior of Windows Form's MessageBox where the Icon of the box can be specified. The valid enumerations for DialogBoxImage are: Information, Error, Warning, Question, None and Custom. You can also set your own Image by setting the DialogBoxImage to Custom, and then specify the image source in CustomDialogBoxImage property.
  • Highly customizable appearance
    As of other Intersoft's components, the WebDialogBox also exposes fully customizable appearances and styles. Developers can change the style of every major elements of the DialogBox, such as the Window's CaptionStyle, the FrameStyle, ContainerStyle, CommandButtonStyle, CommandButtonDisabledStyle and more. Furthermore, you can also set the ControlBoxImage and taking advantages of powerful features exposed by the DesktopManager since the DialogBox inheritted the same architecture of Window and high performance user interaction library.
  • Keyboard support
    WebDialogBox fully support keyboard interaction as one of the standard in all Intersoft's components. When WebDialogBox is shown, users can press Tab key to change the focus from one button to another. Likewise, pressing Shift+Tab will move the focus to previous button. One of the proper implementation of Dialogbox is the focus will remain inside the DialogBox when pressing Tab repetitively. This enables the DialogBox to have true modal behavior described above.
  • Client side events
    WebDialogBox exposed 3 client side events which are OnCreated, OnClosed and OnButtonClicked. Developers can easily hook the OnClosed event to a function in javascript which will be fired when the dialog box has been closed as the result of button click. The OnClosed event will be mainly used to perform applications logic based on the pressed button which represented into the DialogResult parameter. The DialogResult enumeration can be found in above DialogResult description.
  • StartPosition
    When Integrated to Desktop Manager, WebDialogBox can be shown in one of three positions: Custom, CenterParent and CenterScreen. When set to Custom, the DialogBox will appear to the exact location specified in Location property. When set to CenterParent, the DialogBox will be automatically displayed at the center of parent's window. Finally when set to CenterScreen, the DialogBox will be displayd at the center screen of the entire desktop manager size.

See Also

Related Topics
WebDialogBox
{Integrating to DesktopManager}


Integrating to DesktopManager

Integrating to DesktopManager
See Also Send Feedback
Intersoft WebDesktop > WebDialogBox > Integrating to DesktopManager

Glossary Item Box

WebDialogBox can be used in either StandAlone mode or Integrated mode. To enable the Integration mode, simply change the IntegratedToDesktopManager property to True.

When the WebDialogBox is integrated, the Window and Button styles of WebDialogBox will be inherited from from WebDesktop. Therefore the consistent look and feel of all WebDialogBox can be maintained through out the entire application.

One important thing to highlight is that when the WebDialogBox is integrated all the styles will be overridden with inherited styles from WebDesktop, this is to intended to ensure consistent look and feel of all Integrated WebDialogBox.

See Also

Related Topics
{Overview}
{Features}


Tutorials

Tutorials
Send Feedback
Intersoft WebDesktop > WebDialogBox > Tutorials

Glossary Item Box

This section contains tutorial topics in WebDiaplgBox.

In This Section

Creating Simple DialogBox

Designing custom DialogBox

Showing DialogBox at client-side

Obtaining DialogResult at client-side

How-to: Customize Content Modes

How-to: Customize Various Command Button Types

How-to: Display Various Predefined DialogBox Image

How-to: Modify ControlBox Image

How-to: Integrate with WebDesktopManager


Creating Simple DialogBox

Creating Simple DialogBox
Send Feedback
Intersoft WebDesktop > WebDialogBox > Tutorials > Creating Simple DialogBox

Glossary Item Box

Objectives

Create a simple dialog box using Intersoft WebDialogBox with using some key features such as ClickAndEdit, CommandButtons, DialogResult, Predefined DialogBoxImage.

Following are the steps to create a simple dialog box:

  1. Drag WebDialogBox to WebForm (It doesn't matter where you place it because it would be hidden during runtime).

  2. To insert / change the content of WebDialogBox you can simply left-click the box marked with dashed border, and make any changes there.

    Alternatively, you can use HTML Definition to modify the content by inserting the HTML Code in "Source" Mode.

    Script Copy Code
    <ISWebDesktop:WebDialogBox ID="WebDialogBox1"
          runat="server" Height="150px" Width    ="400px">

      ...

      <    ContentTemplate    >
            <div>
              WebPad 1.0 <br/>

          Sample developed for WebDesktop.NET®     <br/>

          Copyright © 2005 Intersoft Solutions Corp.     <br/>

          <br/>

          Features demonstrated in WebPad:    <br/>

          <ul>

            <li>
              <    strong>WebToolBar</strong> <br/>
                  TrueShape, Docking, ToolCommand Type, Shrinkable,
               Styles and WebPlaceHolderManager.    <br/>

            </li>

            <li>
              <    strong>WebMenuBar</strong> <br/>

              Basic MenuBar with Integrated Menu system,
               using Images ItemCommand and ShortcutKey enabled.    <br/>

            </li>

            <li>
              <    strong>WebTab</strong> <br/>
                  ComplexImages rendering, AllowScrolling,
               AllowClose, ClientSideEvents, Object model
               and API such as Create or Close tab item
               dynamically at client side.     <br/>

            </li>

            <li>
              <    strong>WebDialogBox</strong> <br/>
                  Various dialog boxes samples using
                   <span style="text-decoration: underline">
                    IntegratedToDesktopManager
                  </span>

              feature, Custom content text, CommandButtons collection,
               appearance and alignment. Notice that DialogBox is truly
                   <strong>modal</strong>,
               the parent window will become unclick able.
               Also demonstrated the client side object model
               and API to show the dialog box and obtain the DialogResult.
                </li>

          </ul>

        </div>

      </ContentTemplate>

    </ISWebDesktop:WebDialogBox>

  3. By default, WebDialogBox uses a QuestionMark image on the left part. To change this image, you can select one of our predefined image or leave it "NotSet" in DialogBoxImage property.

    The following images are the predefined DialogBox images that we provide:

  4. We can also put some buttons in WebDialogBox, the same as what common DialogBox has. To insert a button or collection of buttons, open "WebDialogBox Buttons Collection Editor" by clicking the CommandButtons property.

    You can add or remove WebDialogBox's Button(s) in this editor. Ultimately you will have to specify the type of the WebDialogBox's Button (by default is NotSet) which will determine its DialogResult.

  5. Finally, you need to determine where will be the position of DialogBox when the showDialogBox() is triggered using StartPosition Property.

  • To test your WebDialogBox, see Showing DialogBox at client side.
  • For more details in designing the WebDialogBox (such as scrollable content, custom WebDialogBox Image, custom button's image/style/alignment and custom contents), see Designing custom DialogBox.
  • In integrated mode with WebDesktop, we need to specify the IntegratedToDesktop Property to "True"


Designing custom DialogBox

Designing custom DialogBox
Send Feedback
Intersoft WebDesktop > WebDialogBox > Tutorials > Designing custom DialogBox

Glossary Item Box

Objectives

Designing Intersoft WebDialogBox, which introduces new breakthrough in Web User Interface. WebDialogBox has an ability to be customized using many configurations involving WebDialogBox's contents, WebDialogBox's Buttons, and WebDialogBox's Images.

In this tutorial we will introduce some properties to customize your WebDialogBox.

  1. Drag WebDialogBox to WebForm (It doesn't matter where you place it because it would be hidden during runtime).

  2. Specify the WebDialogBox Title by setting the Text property.

    Set the ContentScrollable to true.

    Insert the WebDialogBox's content by left-click the box marked with dashed border, and make any changes there.

    Alternatively, you can use HTML Definition to modify the content by inserting the HTML Code in "Source" Mode.

    Script Copy Code
    <ISWebDesktop:WebDialogBox ID="WebDialogBox1"
      runat="server" Height="150px" Width="400px"
      ContentScrollable="True"
     Text="WebPad">

      ...
     <ContentTemplate>

        The following documents have been changed.
         Please select an action.    <br/>

       <br/>

       <select id="lstChangedFiles" multiple="multiple"
             name="lstChangedFiles" size="5"

        style="width: 100%">
            </select>

     </ContentTemplate>

    </ISWebDesktop:WebDialogBox>

    You will get something like this:

    WebDialogBox content can also consist of other control such as ListBox as the example below.

  3. Customize the Image on the left part of WebDiaogBox by setting the DialogBoxImage property to "Custom" and specifying the image's URL in CustomDialogBoxImage property.

    Change the value of DialogBoxVAlign property to specify the vertical alignment of the DialogBoxImage.

  4. To insert a button or collection of buttons, open "WebDialogBox Buttons Collection Editor" by clicking the CommandButtons property.

    Add a WebDialogBox's Button of Type "Yes".

    Add a WebDialogBox's Button of Type "No".

    Add a WebDialogBox's Button of Type "Cancel".

    Alternatively, to change the display of the WebDialogBox's Button, we can specify it using DisplayMode Property.

    To specify WebDialogBox's Buttons' Alignment, change the value of CommandButtonAlignment property.

    You can also adjust the spacing between the WebDialogButtons using CommandButtonSpacing Property.

    To specify the layout of the WebDialogBox's Button, you can set the following properties (Layout Properties):

  • To test your WebDialogBox, see Showing DialogBox at Client-side.
  • In integrated mode with WebDesktop, we need to specify the IntegratedToDesktop Property to true.


Showing DialogBox at client side

Showing DialogBox at client side
Send Feedback
Intersoft WebDesktop > WebDialogBox > Tutorials > Showing DialogBox at client side

Glossary Item Box

Objectives

This tutorial will show how to call a WebDialogBox instance, which you have designed using the previous tutorials, at client side using Javascript.

Following are the steps to call a WebDialogBox instance :

  1. See Creating Simple DialogBox to create a simple WebDialogBox.
  2. Drag a HTML Button to the WebForm (You can use other control to trigger the client side event)

  3. Create a javascript function and attached it to the button's onclick event.

    Script Copy Code
    <script language="javascript">
    function viewWDBAbout()
    {
           var dlgBoxAbout = ISGetObject("WebDialogBox1");
       dlgBoxAbout.ShowDialog();
    }
    </script>

    <input id="Button1" type="button" value="View Simple WebDialogBox" onclick="viewWDBAbout()"/>

  4. In your browser, you will get something like this.

When the WebDialogBox is showed, you can not click the controls behind it, as an implementation of a true Desktop DialogBox behavior).

In integrated mode with WebDesktop, we need to specify the IntegratedToDesktop Property to true


Obtaining DialogResult at client side

Obtaining DialogResult at client side
Send Feedback
Intersoft WebDesktop > WebDialogBox > Tutorials > Obtaining DialogResult at client side

Glossary Item Box

Objectives

When a WebDialogBox contains a WebDialogBox's button of certain type, it will have a DialogResult when this button is clicked. This tutorial will show how to retrieve the active DialogResult of WebDialogBox's button.

The following are the steps to retrieve the DialogResult of WebDialogBox at client side:

  1. See Designing custom DialogBox tutorial to create a custom DialogBox
  2. Drag a HTML Button to the WebForm (You can use other control to trigger the client side event)

  3. Create a javascript function and attached it to the button's onclick event.

    Script Copy Code
    function viewDialogBox()
    {
       var dlgBox = ISGetObject("WebDialogBox1");
       dlgBox.ShowDialog();
    }

  4. Create OnClosed Client Side Event in WebDialogBox's instance.

    And add the following code in javascript:

    Script Copy Code
    function dlgBoxQuit_Closed(controlId, dialogResult)
    {

     // get active Window Object when integrated with WebDesktop

     // var win = ISGetCurrentWindow();

     if (dialogResult == "Yes")
      {
     // ForceClose of current Window Object when integrated with WebDesktop

     // win.ForceClosed = true;
             alert("Do Save Logic");
      }
      else if (dialogResult == "No")
      {
            // ForceClose of current Window Object when integrated with WebDesktop
            // win.ForceClosed = true;
             alert("Do Not Perform Save Logic");
      }
      else
      {
        alert(    "Cancel");
            // cancel, nothing to do
            return;
      }

     // really close current Window Object when integrated with WebDesktop
      //win.Close();
     }

  5. In the browser, you will get something like this.

    In integrated mode with WebDesktop, we need to specify the IntegratedToDesktop Property to true


How-to: Customize Content Modes

How-to: Customize Content Modes
Send Feedback
Intersoft WebDesktop > WebDialogBox > Tutorials > How-to: Customize Content Modes

Glossary Item Box

There are 2 types of ContentMode of a WebDialogBox, which are InlineContent and IFrame.

This topic will show you how to customize content modes.

To customize content modes

  1. Drag two WebDialogBox and two WebButton controls to the WebForm.
  2. For the second WebDialogBox, set ContentURL to any content you want to include. For example: HTMLPage.htm.
  3. Use WebButton's OnClientClick client-side event to show dialog box.
    JavaScript Copy Code
    function WebButton1_OnClientClick(controlId, parameter)
{
   var WebButton1 = ISGetObject(controlId);
   var WebDialogBox1 = ISGetObject("WebDialogBox1");

   WebDialogBox1.ShowDialog();
   return true;
}

function WebButton2_OnClientClick(controlId, parameter)
{
   var WebButton2 = ISGetObject(controlId);
   var WebDialogBox2 = ISGetObject("WebDialogBox2");

   WebDialogBox2.ShowDialog();
   return true;
}

  4. Run the project.


How-to: Customize Various Command Button Types

How-to: Customize Various Command Button Types
Send Feedback
Intersoft WebDesktop > WebDialogBox > Tutorials > How-to: Customize Various Command Button Types

Glossary Item Box

WebDialogBox comes with built-in CommandButtons feature.

This topic will show you how to customize various command button types.

To customize various command button types

  1. Right-click on WebDialogBox control and choose Properties.
  2. Go to CommandButtons and click the collection button.
  3. Add a button. Set Type to either Abort, Retry, Ignore, OK, Cancel, Yes, No, Custom, NotSet.
  4. Run the project.


How-to: Display Various Predefined DialogBox Image

How-to: Display Various Predefined DialogBox Image
Send Feedback
Intersoft WebDesktop > WebDialogBox > Tutorials > How-to: Display Various Predefined DialogBox Image

Glossary Item Box

The predefined DialogBoxImage lets developers easily create any type of DialogBox with default Image assigned to it.

This topic will show you how to display various predefined DialogBox image.

To display various predefined DialogBox image

  1. Right-click on WebDialogBox control and choose Properties.
  2. Set DialogBoxImage to either Information, Error, Warning, Question, None, Custom, NotSet.
  3. Run the project.


How-to: Modify ControlBox Image

How-to: Modify ControlBox Image
Send Feedback
Intersoft WebDesktop > WebDialogBox > Tutorials > How-to: Modify ControlBox Image

Glossary Item Box

WebDialogBox allows user to customize its control box.

This topic will show you how to modify ControlBox image.

To modify ControlBox image

  1. Right-click on WebDialogBox control and choose Properties.
  2. Set ControlBoxImage to the image url you want to display. For example: ../Images/WebNotification-16.gif.
  3. Expand WindowSettings and set ControlBox to Yes.


How-to: Integrate with WebDesktopManager

How-to: Integrate with WebDesktopManager
Send Feedback
Intersoft WebDesktop > WebDialogBox > Tutorials > How-to: Integrate with WebDesktopManager

Glossary Item Box

WebDialogBox is tightly integrated with WebDesktopManager.

This topic will show you how to integrate WebDialogBox with WebDesktopManager.

To integrate with WebDesktopManager

  1. Create a page containing WebDialogBox control.
  2. Right-click on WebDialogBox control and choose Properties.
  3. Set IntegratedToDesktopManager to True.
  4. Create a page containing WebDesktopManager control.
  5. Right-click on WebDesktopManager control and choose Properties.
  6. Go to Windows and click the button collection.
  7. Add a window. Set ContentURL to the page url which contains WebDialogBox control.
  8. Run the project.


WebFlyPostBack

WebFlyPostBack
Send Feedback
Intersoft WebDesktop > WebFlyPostBack

Glossary Item Box

WebFlyPostBackManager
Member of WebDesktop.NET

WebFlyPostBackManager is the standalone server side component that built on the top of FlyPostBack architecture which invented by Intersoft Solutions back in year 2002. The component used asynchronous calls (a.k.a. AJAX) to communicate with server side resources.

Learn the Features

Understanding Concepts

Quick Start

Retrieving data from WebService

Showing loading progress

Converting standard controls to use callback

Easily invoke server side methods from client side

Use WebFlyPostBackManager to invoke server side methods from client side as easy as writing one line of code. With this capability, you can be more productive in the development while at the same time increasing the reusability and maintainability factor of your codes. That also means you can now call the server side functions in more straightforward manner than the previous approach which require you to create a wrapper or implement a specific interface before they are accessible to the client side.

Conveniently retrieve any kind of data, including complex types

WebFlyPostBackManager allows you to retrieve any kind of data types, in either synchronous or asynchronous mode. The control supports basic data types such as string, integer, boolean and arrays -- as well as complex types such as collection, custom business objects and nested objects. The control even allows you to return ADO.NET objects such as DataTable or DataSet with multiple tables, relations and constraints. At the client side, you can access the returned object the same way as you access the object model in the server side.

Turns any standard ASP.NET server controls into FlyPostBack requests (a.k.a callback) without javascript codes

One of the unique innovations in WebFlyPostBackManager component is the ability to change the service as UI (User Interface) mode. When used in UI mode, the control can be used to partially refresh specified server side controls without full page postback. During the FlyPostBack (a.k.a. callback) request, only the refreshed controls are delivered back to the client side and hence reducing the output size. You can customize a lot of behavioral settings related to the UI mode, such as whether you want to make all standard ASP.NET controls in the page to use FlyPostBack requests, or only a specific set of controls.


Concepts

Concepts
Send Feedback

Glossary Item Box


Features

Features
See Also Send Feedback
Intersoft WebDesktop > WebFlyPostBackManager > Features

Glossary Item Box

Following is the list of features available in WebFlyPostBackManager control.

  • Invoke mode

    By default, the component will operate in asynchronous mode. The asynchronous mode is the preferred operation mode since it delivers smoother user experience by performing actions in the background. However in some scenarios, you may want to use synchronous invocation. You can change the operation mode to synchronous by setting Asynchronous property to False.
  • Call to WebService method

    The component offers the capability to invoke a function in WebService page (asmx) right out-of-the-box. The protocol for the WebService invocation used SOAP protocol which is today's standards used by XML Web Services application.

    WebService service type is recommended for application that require open API and standards implementation. To use WebService service type, simply set the ServiceType property to WebService value.
  • Call to WebForm method

    In addition to the WebService method invocation, the component also offers the built-in capability to invoke WebForm-based pages (aspx). The callable functions in the WebForm required to have [WebFlyPostBackMethod()] attribute.

    WebForm service type is recommended for application that does not require to be exposed as public API. This service type has some advantages compared to WebService type such as in term of performance and security. It also has the capability to handle wider data types, including Intersoft's proprietary collection objects.
  • Automatic meta data loading

    This feature tells the component to perform automatic meta data loading when the component is initialized successfully in client side. The automatic meta data loading is useful so that you can call the exposed methods directly in the client side.

    For instance, you may have the codes in the following without metadata loaded:

    fpbManager.Invoke("FunctionA", param1);

    With metadata loaded, you can call the function directly instead of above code:

    fpbManager.FunctionA(param1);
  • Automatic event wiring

    By default, developers would need to attach the function name manually to the client side events of the component. For instance, setting the OnResponseSuccess property to "DoResponse" will have the DoResponse function called on every success calls. However, you would need to perform some conditional checking against the methodName because the single WebFlyPostBackManager component can be used for any number of different method calls.

    By enabling the AutoEventWireup, you do not need to attach to the OnResponseSuccess client side event. The component runtime will automatically look for the prefixed function name and call it if it existed. See following sample codes.

    Expand Sample

    function Button1_Click()
    {
    var fpbManager1 = ISGetObject("dataService");
    fpbManager1.GetCollection();
    }

    function dataService_OnGetCollection(result)
    {
    alert("GetCollection result is :" + result);
    }
    As shown in the sample codes above, the component will automatically call specific function name having this format: [component ID]_On[method name]
  • Error and time-out handling

    The component implements error handling in automatic form. That means the error thrown during FlyPostBack call or during client side processing will not be directly shown to users. In other words, any exceptions thrown by the server side method will not cause major failure to the caller.

    You can intercept the error in the OnError client side event when there is exception thrown by the server side method.

    For the asynchronous calls, their time-outs are also automatically managed. The default value of asynchronous call time-out is 60 seconds, which is configurable in TimeoutInterval property. You can handle the time-out event by handling the OnTimeout client side event.
  • Basic data types support

    WebFlyPostBackManager can accept basic data types that returned from a server side method. The basic types are:
    • String
    • Int32
    • Int64
    • Decimal
    • Byte
    • Double
    • Float
    • Boolean
    • Array
  • Advanced data types support
    In addition to the basic data types support listed in above point, the component also includes the capability to accept advanced data types without additional codes in javascript. The advanced data types are:
    • Strongly-typed Collection
    • Simple Object
    • Complex nested Object
    • Intersoft's Collection (supported in WebForm mode only)
    • Error Object
    • Parameterized Object
          If you are returning advanced data type such as custom business object, ensure that your objects are serializable and comforts to Xml Serialization specification.

          You can access the custom objects automatically in the client side, even without the function definition in the javascript codes. See following screenshot for more details.

        • DataSet data types support

          As an innovative and powerful component, WebFlyPostBackManager is also designed to natively supports ADO.NET data types such as DataSet or DataTable.

          When you are returning DataSet or DataTable object from the server side method, the component will serialize it back to client in SOAP format. The component runtime will then deserialize and mapping back the columns, rows and cells. As the result, you can access the DataSet or DataTable object in the same way and manner as you access them in server side.
        • Loader and busy progress

          As web application becomes more interactive with loads of asynchronous calls, users are sometimes confused with the state of the progress. The FlyPostBackManager component allows you to show the visual loading hints and gives you the flexibility to define your own loader HTML template.

          To enable the component to display visual hints, firstly you need to set its ShowLoaderOnBusy property to True. After that, you can define the loader template in the designer by right clicking on the component instance and select "Edit Template" and click on the "Loader" menu item. Finally, you will need to set the LoaderHostControlID which is the placeholder where the LoaderTemplate should be inserted to, during busy state.

          The following screenshot shows the LoaderTemplate in designer.

          In addition to the visual loading hints feature, you can also block the page UI while the component is busy retrieving data from server side. While the page is blocked, the mouse cursor will be changed to hour glass and UI elements in the page become non-clickable. This feature can be used in conjunction with the loading template to deliver highly sophisticated web application. This feature can be enabled by setting BlockPageUIOnBusy property to True.
        • Automatic callback (UI mode)

          WebFlyPostBackManager component provides robust, high performance architecture which is based on FlyPostBack technology. While it can be used as general purpose function for client/server communication and data exchange, it can also be operated in UI (User Interface) mode. In UI mode, you can use the FlyPostBackManager component to refresh specific server side controls without causing full page postback.

          When the EnableUIMode property is set to True, you can decide whether all ASP.NET standard controls should be converted to use FlyPostBack or only specific individual controls by configuring the UpdateMode property. The default value is AllControls.

          If you would like only specific invidual controls to take advantage of the automatic callback, you can specify the controls' ID in the UpdateControls collection.

          This feature can only be enabled when the component is using WebForm mode (ServiceType = WebFom).
          • You can place your codes in the control's events the same way and manner as the WebForm is operating in full postback.
          • The results of the rendering are delta. That means modified controls are automatically detected, and only modified controls are rendered back to client.
          • Page life cycle and view state is persisted automatically between postbacks. Note that the PostInputControls and PostViewState property in the FlyPostBackSettings should be automatically set to True when you enable the UI mode.
          • No single line of javascript codes is required.

        See Also

        Related Topics
        WebFlyPostBack
        Service Type
        {Metadata Collection}
        {Data Types}
        {Advanced Data Types}
        {Life Cycle}
        {ClientSide Events}


Concepts

Concepts
Send Feedback
Intersoft WebDesktop > WebFlyPostBackManager > Concepts

Glossary Item Box

This section containst essential concepts of WebFlyPostBackManager.

In This Section

Service Type

Metadata Collection

Data Types

Advanced Data Types

Life Cycle

ClientSide Events


Service Type

Service Type
See Also Send Feedback
Intersoft WebDesktop > WebFlyPostBackManager > Concepts > Service Type

Glossary Item Box

WebFlyPostBackManager can be used to retrieve data or execute methods from two type of services.

  • SOAP-based XML WebService Page
  • WebForm Page (.aspx)

WebService

To request an execution of method from WebServices, change WebFlyPostManager's ServiceType property to WebService and specify its ServiceURL.

With this settings you must have a .asmx file that points to WebService Class which WebFlyPostBackManager will refer to.
Later on at ClientSide, with WebFlyPostBackManager you can request an execution of method at WebService (e.g HelloWorld()) and retrieve its return value at OnResponseSuccess event.

Note: The Method that is going to be executed must be marked with [WebMethod()]

Sample Code

WebServiceSamples.asmx

<%@ WebService Language="C#" CodeBehind="~/App_Code/WebServiceSamples.cs" Class="WebServiceSamples" %>
WebServiceSamples.cs
[WebService(Namespace = "http://tempuri.org/")]

[WebServiceBinding(ConformsTo = WsiProfiles.BasicProfile1_1)]
public class WebServiceSamples : System.Web.Services.WebService {
    public WebServiceSamples () {
        //Uncomment the following line if using designed components
        //InitializeComponent();
    }

    [WebMethod]

    public string HelloWorld() {
        return "Hello World";
    }

}
Page.aspx
<script language="javascript" type="text/javascript">
<!--
    function OnClientClick(controlId, parameter)
    {

         var FPBMan = ISGetObject("WebFlyPostBackManager1");

         FPBMan.HelloWorld();
         return true;
    }

    function OnResponseSuccess(controlId, method, returnValue)
    {
        alert("The return value of HelloWorld method is: " + returnValue);
     }
-->
</script>

WebForm

To request an execution of method from WebServices, change WebFlyPostManager's ServiceType property to WebService and specify its ServiceURL.

With this settings you must have a .aspx file (WebForm) which has a listener (WebFlyPostBackListener).
Later on at ClientSide, with WebFlyPostBackManager you can request an execution of Method at WebForm (e.g HelloWorld()) and retrieve its return value at OnResponseSuccess Event.

Note: The Method that is going to be executed must be marked with[WebFlyPostBackMethod()]

Sample Code

MyPage.aspx.cs

public partial class MyPage : System.Web.UI.Page

{
    WebFlyPostBackListener listener = null;

    protected void Page_Load(object sender, EventArgs e)

    {

        listener = new WebFlyPostBackListener(this);

    }

    [WebFlyPostBackMethod()]

    public string HelloWorld()

    {

         return "Hello World";

    }

}
MyPage.aspx
<script language="javascript" type="text/javascript">

<!--
    function OnClientClick(controlId, parameter)

    {

         var FPBMan = ISGetObject("WebFlyPostBackManager1");

         FPBMan.HelloWorld();
         return true;
     }

    function OnResponseSuccess(controlId, method, returnValue)
     {
         alert("The return value of HelloWorld method is: " + returnValue);
     }
-->
</script>

See Also

Related Topics
WebFlyPostBack
Features


Metadata Collection

Metadata Collection
See Also Send Feedback
Intersoft WebDesktop > WebFlyPostBackManager > Concepts > Metadata Collection

Glossary Item Box

Metadata Collection is a set of information needed by WebFlyPostBackManager to perform FlyPostBack request. The information itself basically is a list of methods declaration (name of the methods, its parameters and its return value) for methods that marked as [WebMethod] or [WebFlyPostBackMethod].

This Metadata Collection by default is automatically retrieved during Page_Load. However, you can set the WebFlyPostBackManager to retrieve the Metadata manually by changing the AutoloadMetadata property to false. Retrieving the metadata collection manually means that collecting the Metadata only when a request is being sent for the first time.

See Also

Related Topics
WebFlyPostBack
{Features}


Data Types

Data Types
See Also Send Feedback
Intersoft WebDesktop > WebFlyPostBackManager > Concepts > Data Types

Glossary Item Box

WebFlyPostBackManager is used to request an execution of Method at server side. Most of the time you want the execution of this method returns a value. The type of this value can vary from very simple one as string to more complex type as CustomObject.

Here are the list of simple data types supported by WebFlyPostBackManager :

  • string
  • int
  • decimal
  • long
  • float
  • bool
  • DateTime
  • array[]

**byte isn't supported at this version yet.

For complex data type WebFlyPostBackManager only supports those object that can be serialized ([Serializable()])

See Also

Related Topics
{Overview}
{Features}


Advanced Data Types

Advanced Data Types
See Also Send Feedback
Intersoft WebDesktop > WebFlyPostBackManager > Concepts > Advanced Data Types

Glossary Item Box

Advanced Data Types that is supported by WebFlyPostBackManager are :

  • DataSet
  • DataTable
  • Custom Object that can be serialized

DataSet and DataTable

Due to complexity in DataSet and DataTable , currently WebFlyPostBackManager is only able to map the data.

The data structure at client side will be :

DataSet
+ Tables
+ Rows
+ Cells

DataTable
+ Rows
+ Cells

Custom Object

Custom Object that can be serialized is able to be mapped by WebFlyPostBackManager.
Below is a sample of Custom Object that can be mapped by WebFlyPostBackManager

Custom Object (Server Side)

[Serializable()]

public class CustomClass
{
    private int _CustomerID;
    private string _CustomerName;
    private OrderCollection _Orders;

    public int CustomerID

    {
        get { return _CustomerID; }
         set { _CustomerID = value; }
    }

    public string CustomerName
    {
        get { return _CustomerName; }
        set { _CustomerName = value; }
    }

    public CustomClass()
    {
    }

    public CustomClass(int customerID, string customerName)
    {
        _CustomerID = customerID;
        _CustomerName = customerName;
    }

    public OrderCollection Orders
    {
        get
        {
            if (_Orders == null) {
                _Orders = new OrderCollection();
            }
            return _Orders;
        }
        set

        {
            _Orders = value;
        }
    }
}

[Serializable()]

public class Order

{
    private int _OrderID;
    public int OrderID
    {
        get { return _OrderID; }
        set { _OrderID = value; }

    }

    public Order()
    {

    }

    public Order(int orderID)

    {

        _OrderID = orderID;

    }

}

public class CustomClassCollection : CollectionBase

{
    public CustomClassCollection()

    {
    }

    public CustomClass this[int index]

    {
        get { return ((CustomClass)List[index]); }

        set { List[index] = value; }
    }

    public int Add(CustomClass value)
    {

        return (List.Add(value));
    }

    public int IndexOf(CustomClass value)

    {

        return (List.IndexOf(value));

    }

    public void Insert(int index, CustomClass value)

    {

        List.Insert(index, value);

    }

    public void Remove(CustomClass value)

    {

        List.Remove(value);

    }

    public bool Contains(CustomClass value)

    {
        // If value is not of type TestCustomClass, this will return false.

        return (List.Contains(value));

    }

    protected override void OnInsert(int index, Object value)

    {

        // Insert additional code to be run only when inserting values.

    }

    protected override void OnRemove(int index, Object value)

    {

        // Insert additional code to be run only when removing values.

    }

    protected override void OnSet(int index, Object oldValue, Object newValue)

    {

        // Insert additional code to be run only when setting values.

    }

    protected override void OnValidate(Object value)

    {

        if (value.GetType() != typeof(CustomClass))

            throw new ArgumentException("value must be of type TestCustomClass.", "value");

    }

}
With this custom object Class we can have a Method that returns a value with type of CustomClass.
Sample Code
Client

function OnClientClick(controlId, parameter)

{
    var FPBMan = ISGetObject("WebFlyPostBackManager1");

    FPBMan.GetCustomObject();

}

function WebFlyPostBackManager1_OnGetCustomObject(returnValue)

{

    alert("GetCustomObject result: \n" +

      "Type = CustomClass\n" +

      "obj.CustomerID : type=Int; value=" + returnValue.CustomerID + "\n" +

      "obj.CustomerName : type=String; value=\"" + returnValue.CustomerName + "\"\n" +

      "obj.Orders : type=Collection; length=" + returnValue.Orders.length + "\n\n" +

      "To inspect in more details, please watch the returnValue object in debugger."

    );

}
Web Service
[WebService(Namespace = "http://tempuri.org/")]

[WebServiceBinding(ConformsTo = WsiProfiles.BasicProfile1_1)]
public class WebServiceSamples : System.Web.Services.WebService {
    public WebServiceSamples () {
        //Uncomment the following line if using designed components
        //InitializeComponent();
    }

    [WebMethod]
    public CustomClass GetCustomObject()
    {

        CustomClass obj = new CustomClass();

        obj.CustomerID = 10;

        obj.CustomerName = "Blacksmith";

        return obj;

    }

}

See Also

Related Topics
{Overview}
{Features}


Life Cycle

Life Cycle
See Also Send Feedback
Intersoft WebDesktop > WebFlyPostBackManager > Concepts > Life Cycle

Glossary Item Box

WebFlyPostBackManager life cycle includes two processes, one is collecting and retrieving MetaDataCollection and the other one is requesting an execution of methods and retrieving the response.

MetaDataCollection Retrieval

WebFlyPostBackManager by default is set to retrieve the MetaDataCollection automatically at PageLoad. Alternatively we can retrieve the MetaDataCollection manually, which means it will be collected and retrieved when we send a request of method execution at the first time.

AutoLoadMetaData

At PageLoad WebFlyPostBackManager collects and retrieves the MetaDataCollection

Manually Load MetaData

WebFlyPostBackManager will not retrieve the MetaDataCollection at PageLoad.

During the first execution of InvokeMethod, WebFlyPostBackManager will check whether the MetaDataCollection already existed.

If the MetaDataCollection does not exist, it will request MetaDataCollection first.

When collecting the MetaDataCollection, the InvokeMethod request is pending, until the MetaDataCollection is retrieved

Request and Response

When WebFlyPostBackManager requests an execution of method , it will wait for response from WebService / WebForm for certain timeout interval. The response can be either a success response, error response or no response which means it is already timeout. Each of this response type has its corresponding ClientSideEvents where you can do some action later on.

Success

Error

TimeOut

See Also

Related Topics
{Overview}
{Features}


ClientSide Events

ClientSide Events
See Also Send Feedback
Intersoft WebDesktop > WebFlyPostBackManager > Concepts > ClientSide Events

Glossary Item Box

WebFlyPostBackManager will give a response to client side whenever there is a request. Regardless, the state of WebFlyPostbackManager will give a response.

Follows are the list of events :

  • OnResponse
    Listen to all success and error type of responses. Executed when the WebFlyPostBackManager responses that the request is executed successfully or failed
  • OnResponseSuccess
    Executed when the WebFlyPostBackManager responses that the request is executed successfully
  • OnError
    Executed when the WebFlyPostBackManager responses that the request is invalid
  • OnTimeout
    Executed when the WebFlyPostBackManager does not response in certain period of time defined in TimeoutInterval property

Additionally WebFlyPostBackManager allows AutoEventWireUp which will automatically wire the event for each function in MetaData Collection

For example:

FPBMan.GetString() will be attached with an event WebFlyPostBackManagerInstance_OnGetString()

Sample Code

function OnClientClick(controlId, parameter)

{
    var FPBMan = ISGetObject("WebFlyPostBackManager1");

    FPBMan.GetString();
}

function WebFlyPostBackManager1_OnGetString(returnValue)

{

    alert("GetString result: " + unescape(returnValue));

}

See Also

Related Topics
{Overview}
{Features}


Tutorials

Tutorials
Send Feedback
Intersoft WebDesktop > WebFlyPostBackManager > Tutorials

Glossary Item Box

This section contains tutorial topics in WebFlyPostBackManager.

In This Section

Retrieving simple types using WebService

Retrieving simple types using WebForm service

Showing loading progress

Programmatically refresh server control

Converting standard controls to use callback

Selectively converting standard controls to use callback

How-to: Use WebFlyPostBackManager with Intersoft Controls


Retrieving simple types using WebService

Retrieving simple types using WebService
Send Feedback
Intersoft WebDesktop > WebFlyPostBackManager > Tutorials > Retrieving simple types using WebService

Glossary Item Box

Objectives

This tutorial demonstrates the basic function of WebFlyPostBackManager to retrieve simple-type results from a SOAP-based XML WebService page.

  1. Drag WebFlyPostBackManager from Toolbox into a WebForm page.

  2. Create a WebService page in the same directory and leave the name as default, which is "WebServiceSamples.asmx". It will automatically create "WebServiceSamples.cs" in the App_code folder.
  3. Set ServiceType to WebService and ServiceUrl to WebServiceSamples.asmx (The URL path of the page) in the properties box.

  4. Add a HTML button and named it "Call WebService".
  5. Add the "OnResponseSuccess" Client Side Events of WebFlyPostBackManager.

  6. Add the following code in client-side:

    Script Copy Code
    <script language="javascript">
    function DoClick()
    {
        var FPBMan = ISGetObject("WebFlyPostBackManager1");

        // call the HelloWorld method of the specified ServiceUrl
        FPBMan.HelloWorld();
    }

    function WebFlyPostBackManager1_OnResponseSuccess(controlId, methodName, returnValue)
    {
        alert("The return value of HelloWorld method is: " + returnValue);
    }
    </script>

  7. Invoke DoClick() function in onclick event like the following:

    Script Copy Code
    <input id="Button1" type="button" value="Call WebService" onclick="DoClick()"/>

  8. When you click the button, it will retrieve the simple type result from the defined WebService.
  9. Run the project and you will see something like following:


Retrieving simple types using WebForm service

Retrieving simple types using WebForm service
Send Feedback
Intersoft WebDesktop > WebFlyPostBackManager > Tutorials > Retrieving simple types using WebForm service

Glossary Item Box

Objectives

This tutorial demonstrates the basic function of WebFlyPostBackManager to retrieve simple-type results from a WebForm (aspx) page.

  1. Drag WebFlyPostBackManager from Toolbox into a WebForm page.

  2. Create a WebForm in the same directory and named it "WebFormListener.aspx". Add the following code in code behind:

    C# Copy Code
    using System;
    using System.Data;
    using System.Configuration;
    using System.Collections;
    using System.Web;
    using System.Web.Security;
    using System.Web.UI;
    using System.Web.UI.WebControls;
    using System.Web.UI.WebControls.WebParts;
    using System.Web.UI.HtmlControls;
    using ISNet.WebUI.WebDesktop;

    public partial class Samples_WebFlyPostbackManager_WebFormListener : System.Web.UI.Page
    {
        WebFlyPostBackListener listener = null;

        protected void Page_Load(object sender, EventArgs e)
        {
            listener = new WebFlyPostBackListener(this);
        }

        [WebFlyPostBackMethod()]
        public string HelloWorld()
        {
            return "Hello World";
        }
    }

  3. Set ServiceType to WebForm and ServiceUrl to WebFormListener.aspx (The URL path of the page) in the properties box.

  4. Add a HTML button and name it "Call WebForm Service".
  5. Add the "OnResponseSuccess" Client Side Events of WebFlyPostBackManager.

  6. Add the following code in the client-side:

    Script Copy Code
    <script language="javascript">
    function DoClick()
    {
        var FPBMan = ISGetObject("WebFlyPostBackManager1");

        // call the HelloWorld method of the specified ServiceUrl
        FPBMan.HelloWorld();
    }

    function WebFlyPostBackManager1_OnResponseSuccess(controlId, methodName, returnValue)
    {
        alert("The return value of HelloWorld method is: " + returnValue);
    }
    </script>

  7. Invoke DoClick() function in onclick event like the following:

    Script Copy Code
    <input id="Button1" type="button" value="Call WebForm Service" onclick="DoClick()"/>

  8. When you click the button, it will retrieve the simple type result from the defined WebForm.
  9. Run the project and you will see something like following:


Showing loading progress

Showing loading progress
Send Feedback
Intersoft WebDesktop > WebFlyPostBackManager > Tutorials > Showing loading progress

Glossary Item Box

Objectives

The tutorial demonstrates the LoaderTemplate and built-in capabilities to display the loader progress during the busy status. The loader UI is controlled automatically and does not require to write any single codes.

  1. Drag WebFlyPostBackManager from Toolbox into a WebForm page.

  2. Create a HTML button and named it "Show Loading Progress".
  3. Add the following code in the code-behind:

    C# Copy Code
    using System;
    using System.Data;
    using System.Configuration;
    using System.Collections;
    using System.Web;
    using System.Web.Security;
    using System.Web.UI;
    using System.Web.UI.WebControls;
    using System.Web.UI.WebControls.WebParts;
    using System.Web.UI.HtmlControls;
    using ISNet.WebUI.WebDesktop;

    public partial class ShowingLoadingProgress : System.Web.UI.Page
    {
        WebFlyPostBackListener listener = null;

        protected void Page_Load(object sender, EventArgs e)
        {
            listener = new WebFlyPostBackListener(this);
        }

        [WebFlyPostBackMethod()]
        public string LoadingProgress()
        {
            for (int i = 0; i < 10000; i++)
            {
                for (int j = 0; j < 10000; j++)
                {
                }
            }
            return "Showing Loading Progress";
        }
    }

  4. In the properties box of WebFlyPostBackManager, set the following:

    Properties | Values
    ServiceType | WebForm
    ServiceUrl | The URL path of the page (in this case, the path is ShowingLoadingProgress.aspx)
    ShowLoaderOnBusy | True
    LoaderHostControlID | LoadingTemplate

  5. Right-click on the WebFlyPostBackManager and choose Edit Template --> Loader.
  6. The Loader template will be displayed. Put a HTML image in the template and set the Image Src to /CommonLibrary/Images/WebDesktop/is_progress-16.gif and type "Loading Item" next to the image.
  7. Right-click on the template and choose End Template Editing.

  8. In the HTML code, put the following line under the HTML button tag:

    <input id="Button1" type="button" value="Show Loading Progress"/>
    <br />
    <div id="LoadingTemplate"></div>
    The div id of "LoadingTemplate" is used to be defined in LoaderHostControlID. Therefore, the loading template will be displayed in this div according to the Id specified in LoaderHostControlID.
  9. Add the "OnResponseSuccess" Client Side Events of WebFlyPostBackManager.
  10. Add the following code in the client-side:

    Script Copy Code
    <script language="javascript">
    function DoClick()
    {
        var FPBMan = ISGetObject("WebFlyPostBackManager1");

        // call the HelloWorld method of the specified ServiceUrl
        FPBMan.LoadingProgress();
    }

    function WebFlyPostBackManager1_OnResponseSuccess(controlId, methodName, returnValue)
    {
        alert("The return value of HelloWorld method is: " + returnValue);
    }
    </script>

  11. Invoke DoClick() function in onclick event like the following:

    Script Copy Code
    <input id="Button1" type="button" value="Show Loading Progress" onclick="DoClick()"/>

  12. When you click the button, it will show the loading progress defined in the loader template.

  13. Afterwards, it will display the return value defined in the WebForm.


Programmatically refresh server control

Programmatically refresh server control
Send Feedback
Intersoft WebDesktop > WebFlyPostBackManager > Tutorials > Programmatically refresh server control

Glossary Item Box

Objectives

This tutorial demonstrates how to refresh server control programmatically without causing full page postback.

  1. Drag two DropDownList controls into the WebForm and name them ddlMake and ddlModel.

  2. Drag WebFlyPostBackManager from Toolbox into a WebForm page.

  3. In code behind, add the following code.

    C# Copy Code
    using ISNet.WebUI.WebDesktop;

    public partial class ProgrammaticallyRefresh : System.Web.UI.Page
    {
        WebFlyPostBackListener listener = null;

        protected void Page_Load(object sender, EventArgs e)
        {
            body.Style.Add("overflow", "hidden");
            listener = new WebFlyPostBackListener(this);
        }
    }

  4. Add some items to ddlMake.

  5. Add a method to populate data for ddlModel based on the value of ddlMake. Note that you must add WebFlyPostBackMethod() attribute so that the method can be included in the Metadata collection.

    C# Copy Code
    [WebFlyPostBackMethod()]
public void PopulateModel()
{
   ddlModel.Items.Clear();
   if (ddlMake.Text != "- Select a Make -")
   {
      for (int i = 1; i <= 5; i++)
         ddlModel.Items.Add(new ListItem(ddlMake.Text + " Model " + i.ToString(), i.ToString()));
   }
   ddlMake.SelectedIndex = 1;

   WebFlyPostBackManager1.ClientAction.UpdateViewState();
   WebFlyPostBackManager1.ClientAction.RenderControl(ddlModel);
}

  6. Add onchange event for ddlMake to call PopulateModel method from client side using WebFlyPostBackManager.

    Script Copy Code
    <script language="javascript">
    function PopulateModel()
    {
       var fpb = ISGetObject("WebFlyPostBackManager1");
       fpb.PopulateModel();
    }
    </script>

  7. Set the following properties of WebFlyPostBackManager.
    Properties | Values
    ServiceType | WebForm
    ServiceUrl | The URL path of the page (in this case, the path is ~/test/ProgrammaticallyRefresh.aspx)
    PostInputControls | True
    PostViewState | True

  8. Run the page. Select a value from ddlMake and data will be populated in ddlModel without causing full page postback.


Converting standard controls to use callback

Converting standard controls to use callback
Send Feedback
Intersoft WebDesktop > WebFlyPostBackManager > Tutorials > Converting standard controls to use callback

Glossary Item Box

Objectives

This tutorial demonstrates how to convert standard controls to use callback.

  1. Drag two DropDownList controls into the WebForm and name them ddlMake and ddlModel.

  2. Drag two CheckBoxList control into the WebForm.

  3. Drag 4 Button controls into the WebForm.

  4. Add some items to ddlMake.

  5. Set AutoPostBack property of ddlMake to True.

  6. Specify a method for SelectedIndexChanged server side events and add the following code.

    C# Copy Code
    protected void ddlMake_SelectedIndexChanged(object sender, EventArgs e)
{
   ddlModel.Items.Clear();

   if (ddlMake.Text != "- Select a Make -")
   {
      for (int i = 1; i <= 5; i++)
         ddlModel.Items.Add(new ListItem(ddlMake.Text + " Model " + i.ToString(), i.ToString()));
   }
    ddlMake.SelectedIndex = 1;
}

  7. Add button's OnClick event to add and remove items between CheckBoxLists.

    C# Copy Code
    protected void Button3_Click(object sender, EventArgs e)
{
   // move to right
   bool hasSelection = false;
   for (int i = 0; i < CheckBoxList1.Items.Count; i++)
   {
      ListItem item = CheckBoxList1.Items[i];

      if (item.Selected)
      {
         hasSelection = true;
         MoveItem(item, CheckBoxList1, CheckBoxList2);
         i--;
      }
  }
}

protected void Button1_Click(object sender, EventArgs e)
{
   // move all to left
   for (int i = 0; i < CheckBoxList2.Items.Count; i++)
   {
      ListItem item = CheckBoxList2.Items[i];
      MoveItem(item, CheckBoxList2, CheckBoxList1);
      i--;
   }
}

protected void Button2_Click(object sender, EventArgs e)
{
   // move to left
   bool hasSelection = false;

   for (int i = 0; i < CheckBoxList2.Items.Count; i++)
   {
      ListItem item = CheckBoxList2.Items[i];

      if (item.Selected)
      {
         hasSelection = true;
         MoveItem(item, CheckBoxList2, CheckBoxList1);
         i--;
      }
   }
}

protected void Button4_Click(object sender, EventArgs e)
{
   // move all to right
   for (int i = 0; i < CheckBoxList1.Items.Count; i++)
   {
      ListItem item = CheckBoxList1.Items[i];
      MoveItem(item, CheckBoxList1, CheckBoxList2);
      i--;
   }
}

private void MoveItem(ListItem item, CheckBoxList from, CheckBoxList to)
{
   to.Items.Add(new ListItem(item.Text));
   item.Selected = false;
   from.Items.Remove(item);
}

  8. Run the page. Selecting a value from ddlMake to populate data in ddlModel will cause full page postback.

    Clicking the button to remove items between CheckBoxLists will also cause full page postback.

  9. Drag WebFlyPostBackManager from Toolbox into a WebForm page.

  10. In code behind, add the following code.

    C# Copy Image Copy Code
    using ISNet.WebUI.WebDesktop;

public partial class ConvertStandardControls : System.Web.UI.Page
{
   WebFlyPostBackListener listener = null;

   protected void Page_Load(object sender, EventArgs e)
   {
      body.Style.Add("overflow", "hidden");
      listener = new WebFlyPostBackListener(this);
   }
}

  11. Set the following properties of WebFlyPostBackManager.

    Properties | Values
    ServiceType | WebForm
    ServiceUrl | The URL path of the page (in this case, the path is ~/test/ConvertStandardControls.aspx)
    EnableUIMode | True
    PostInputControls | True
    PostViewState | True

  12. Add the following code in MoveItem method so that removed items in CheckBoxList are considered as Dirty in view state.

    C# Copy Code
    WebFlyPostBackManager1.ClientAction.MarkDirty(from);

  13. Run the page. Selecting a value from ddlMake will populate data in ddlModel without causing full page postback.

    Clicking the button to remove items between CheckBoxLists will not cause full page postback.


Selectively converting standard controls to use callback

Selectively converting standard controls to use callback
Send Feedback
Intersoft WebDesktop > WebFlyPostBackManager > Tutorials > Selectively converting standard controls to use callback

Glossary Item Box

Objectives

This tutorial demonstrates how to selectively converting standard controls to use callback.

  1. Converting standard controls to use callback.

  2. Set UpdateMode properties to Custom.

  3. Add selected controls that will be set to use callback. In this tutorial, add ddlMake and ddlModel.

  4. Run the page. The controls in this page can be selectively set to use callback. Selecting a value from ddlMake will populate data in ddlModel without causing full page postback.

    Clicking the button to remove items between CheckBoxLists will cause full page postback.


How-to: Use WebFlyPostBackManager with Intersoft Controls

How-to: Use WebFlyPostBackManager with Intersoft Controls
Send Feedback
Intersoft WebDesktop > WebFlyPostBackManager > Tutorials > How-to: Use WebFlyPostBackManager with Intersoft Controls

Glossary Item Box

WebFlyPostBackManager is tightly integrated with other Intersoft controls.

This topic will show you how to use WebFlyPostBack with Intersoft controls.

To use WebFlyPostBackManager with Intersoft Control

  1. Add a new page in your project and named it as UsingWebFlyPostBackManagerWithIntersoftControl.aspx.
  2. Drag WebFlyPostBackManager, WebCombo and WebGrid controls into the WebForm.
  3. Right-click on WebCombo control and choose WebCombo.NET Designer.
  4. Go to Columns and Rows section and create a new column.

  5. Go to Rows tab, add Customers as a new row and click OK.

  6. Go to Advanced Settings and set AllowAutoPostback to True.
  7. Bind and customize WebGrid using code-behind like following:
    C# Copy Code
    protected void WebGrid1_InitializeDataSource(object sender, ISNet.WebUI.WebGrid.DataSourceEventArgs e)
{
   if (WebCombo1.Text == "Customers")
   {
      dsNorthwind.CustomersDataTable dt = new dsNorthwind.CustomersDataTable();
      dsNorthwindTableAdapters.CustomersTableAdapter da = new dsNorthwindTableAdapters.CustomersTableAdapter();
      da.Fill(dt);
      e.DataSource = dt;
   }
}

protected void WebGrid1_PrepareDataBinding(object sender, ISNet.WebUI.WebGrid.DataSourceEventArgs e)
{
   if (WebCombo1.Text == "Customers")
   {
      WebGrid1.RootTable.DataKeyField = "CustomerID";
      WebGrid1.RetrieveStructure();
   }
}

  8. Call RebindDataSource() using ValueChanged WebCombo server-side event.
    C# Copy Code
    protected void WebCombo1_ValueChanged(object sender, ISNet.WebUI.WebCombo.ValueChangedEventArgs e)
{
   WebGrid1.ClearCachedDataSource();
   WebGrid1.RequiresUIRefresh = true;
   WebGrid1.RebindDataSource();
}

  9. Now, create a page with WebFlyPostBackManager control included in it.
  10. Right-click on WebFlyPostBackManager control and choose Properties.
  11. Set EnableUIMode to True and locate ServiceURL into UsingWebFlyPostBackManagerWithIntersoftControl.aspx.
  12. Expand FlyPostBackSettings and set the following properties.
    Property | Value
    PostControlState | True
    PostHiddenFields | True
    PostInputControls | True
    PostViewState | True

  13. Add ISNet.WebUI.WebDesktop as reference and configure WebFlyPostbackManager at server side.
    C# Copy Code
    using ISNet.WebUI.WebDesktop;

WebFlyPostBackListener listener = null;

protected void Page_Load(object sender, EventArgs e)
{
   listener = new WebFlyPostBackListener(this);
}

  14. Run the project.


WebExplorerPane

WebExplorerPane
See Also Send Feedback
Intersoft WebDesktop > WebExplorerPane

Glossary Item Box

WebExplorerPane Overview

WebExplorerPane logo

WebExplorerPane
Member of WebDesktop.NET

WebExplorerPane allows you to create advanced navigation user interface with the richness of desktop's ExplorerPane in every details of styles and behaviors.

What's New in WebExplorerPane

Learn the Features

Concepts

Quick Start

Creating Simple ExplorerPane

Using BarItem for Content Navigation

Handling Client Side Events

Create professional Desktop's Explorer-style navigation control

Use WebExplorerPane control to quickly create rich and fully-functional Desktop's Explorer-like navigation user interface in a professional way. Unlike "traditional Panel or Navigation controls", WebExplorerPane is designed with elegant architecture and object model as well as specialized user interface for each element. That means, you no longer require any workaround in order to achieve a modern navigation control which is not only rich in styles, but also in every functions and behaviors.

Dramatically enhances user experience through expand/collapse pane with animation.

WebExplorerPane lets you determine which pane is more related to the selected object by setting the Collapse property. WebExplorerPane will automatically manage the animation behavior (EnableAnimation set to True) when switching between one navigation to another just like desktop's explorer pane behavior. WebExplorerPane also maintains every state of the pane (WebExplorerBar), such as the currently selected item and properly restore them whether the pane (WebExplorerBar) is collapsed or restored.

Increase developer's productivity through advanced flexibility and extensibility

WebExplorerPane sets a new standard in navigation user interface by providing advanced features for great flexibility and extensibility. You can choose one of three ContentMode for each Bar's contents, or having all of them to use the global setting specified in PaneSettings. The UseItems ContentMode enables you to quickly build navigation links by manipulating the Items collection. For better extensibility, you can also use InlineContent mode and put any kind of server controls.

See Also

Getting Started
Features
Concepts


What's New in WebExplorerPane

What's New in WebExplorerPane
See Also Send Feedback
Intersoft WebDesktop > WebExplorerPane > What's New in WebExplorerPane

Glossary Item Box

WebExplorerPane give users a superior Microsoft Windows-style navigation and control pane in your web applications. WebExplorerPane offers a true Explorer look with sleek visual styles and advanced features.

In version 4, WebExplorerPane has been refined to fully support the latest web standards. This allows you to use many of the WebExplorerPane features in your next-generation web applications and at the same time leveraging cutting-edge technologies such as HTML5 and CSS3.

Here are the following details of several enhancements and new features that have been implemented in WebExplorerPane:

  • Fluid content

    In HTML5 environment, height of an element refers to its parent's height. Hence, it is required/necessary to define its parent element. In other words, the parent container of WebExplorerPane must have the height value of 100% to the fluid content.

  • Border frame style

    In HTML4 doctype, WebExplorer's border frame style is set to solid by default, even if user doesn't determine the property initially. In HTML5 doc type, user must specifiy the border frame style. Otherwise, the border is unable to render the frame style properly.

  • New Intuitive style

    In this version 4, WebDesktop introduces a brand-new Metro style for each members. Metro style - the latest UI in Windows 8 has been developed and added as a new, elegant and sophisticated UI in WebDesktop family. With Metro style, WebDesktop's layout is transformed into beautiful and eye-catching design and it is also applicable for each members, such as WebCallOut, WebNavePane, WebDialogBox and many others. Last but not least, this intuitive Metro style design also enhances consistency of each controls in HTML5.

    You can simply use Layout Manager to implement Metro style in WebDesktop.

    For more information on how to apply this configuration, see How-To: Using Layout Manager.

See Also

WebExplorerPane

Features
Features


Features

Features
See Also Send Feedback
Intersoft WebDesktop > WebExplorerPane > Features

Glossary Item Box

Intersoft's WebUI navigation pane control, WebExplorerPane, has several unique features that will be explained below in details:

  • CaptionDisplayMode

By default, the CaptionDisplayMode is set to "Text" mode when a new instance is dropped to .NET IDE designer. You can also have TextAndImage, Image, and UseTemplate for CaptionDisplaymode.

picture1 : Use TextAndImage as the Caption Mode

picture2 : Use Text as the Caption Mode

  • Client Side Events

WebExplorerPane exposed numerous client side events that you can consume in order to create rich interaction and extensible web applications. Following is the list of available client side events:
- OnAfterCollapse
- OnAfterExpand
- OnBeforeCollapse
- OnBeforeExpand
- OnClientUnload
- OnInitialize
- OnPaneHeaderClick
- OnPaneItemClick

  • Comprehensive Client Side OOP and API

As member of WebUI.NET Framework family, WebExplorerPane is extensively taking advantage of the client side framework enabling the same structure of object model between server and client side.

Additionally, WebExplorerPane provides comprehensive API for you to easily interact and manipulate the objects at client side (runtime). For example, you can perform Expand/Collapse at runtime by calling WebExplorerBarInstance.DoCollapse(). You can also programmatically get the WebExplorerBar collection or WebExplorerBarItems collection, show/hide PaneItems, animate pane height, and much more properties you can get to work at client side. For a list of complete WebExplorerPane API, please see "Client Side Reference >> WebExplorerPane".

  • ContentMode

By default, the WebExplorerBar will operate in UseItems mode when a new instance is dropped to .NET IDE designer. UseItems is the most suitable mode to simulate Desktop style of explorer pane as it is a collection based and support text and image rendering mode. WebExplorerPane also supports UseInlineContent mode to utilize .NET Framework's template architecture and therefore you can drag and drop other controls onto it.

In most cases where you want to develop a more reusable form, you should use UseIFrame as the content mode. When using IFrame mode, you will need to specify the ContentURL which page you want to load for the designated WebExplorerBar.

The ContentURL accepts three formats of URL:
1. .NET specific application relative URL. This format starts with "~" character, for instance, "~/FolderA/Page1.aspx".
2. Absolute URL. This format starts with "/" character, for instance, "/SharedModule/Page1.aspx".
3. Relative URL. This format usually starts with "." character or no special characters (which assume the page can be found in the current folder's context).

You can configure different ContentMode for each Pane. To apply all Panes to use a specific ContentMode, configure the ContentMode in WebExplorerPane control level and leave WebExplorerBar's ContentMode to Default.
  • Fully customizable styles and appearances

WebExplorerPane allows you to customize most of the elements' styles by using strongly typed WebStyle and DynamicStyle properties listed in following:

  • FrameStyle
  • SpecialBarStyle
  • BarStyle
  • BarFrameStyle
  • ItemsContainerStyle
  • ItemStyle
  • WebExplorerPane Designer

Instead of changing properties in Visual Studio Property Window, you can configure most properties shown in "logical group" from WebExplorerPane Designer. You can also easily manipulate the styles, properties as well as managing the WebExplorerBar and WebExplorerBarItems.

Most Intersoft's components that exposed rich functionalities, complex objects and collection will implement Component Designer similar to the screenshot above. The consistency of the user interface and functions throughout all Intersoft's components will significantly reduce learning time as well as increasing productivity.

See Also

Related Topics
WebExplorerPane
Concepts


Concepts

Concepts
See Also Send Feedback
Intersoft WebDesktop > WebExplorerPane > Concepts

Glossary Item Box

Introduction

WebExplorerPane is the server control object serving as the root container for WebExplorerBar objects as well as other available configurations. WebExplorerPane consists of two main user interface elements listed in the following:

  • Pane Header
    • Image
    • Text
    • Expand/Collapse Image
  • Pane Content (expandable/collapsible)
    • PaneItem

A Pane is represented by WebExplorerBar object which is contained in Panes collection of WebExplorerPane. WebExplorerBar can be constructed in either design-time or runtime.

A Pane may consist of one or more items called PaneItem, represented by WebExplorerBarItem, which mainly used as navigation links. The WebExplorerBarItem can be easily manipulated and accessed through Items collection provided by each WebExplorerBar object.

The WebExplorerBar's Items will be used and rendered when the WebExplorerBar's ContentMode is set to UseItems by default. For extensibility or customized content, you may set the ContentMode to UseInlineContent and put any kind of ASP.NET's server controls. You can also use UseIFrame ContentMode for better reusability. The ContentMode property can be found in PaneSettings object which contains global configurations for WebExplorerBar (Pane).

The WebExplorerBarItem object provides following features for effective navigation purpose:

  • TargetURL
  • TargetWindow

More Details

The following shows the hierarchy of a common WebExplorerPane configuration:

  • WebExplorerPane - WebExplorerPane1 (Root Control)
    • Panes (Collection)
      • WebExplorerBar - barFileAndFolder
        • PaneItems (Collection)
          • WebExplorerBarItem - itmRenameFolder
          • WebExplorerBarItem - itmMoveFolder
          • WebExplorerBarItem - itmCopyFolder
          • WebExplorerBarItem - itmPublishFolder
          • WebExplorerBarItem - itmShareFolder
          • WebExplorerBarItem - itmEmailFolder
          • WebExplorerBarItem - itmDeleteFolder
      • WebExplorerBar - barOtherPlaces
        • PaneItems (Collection)
          • WebExplorerBarItem - itmMyDocuments
          • WebExplorerBarItem - itmMyComputer
          • WebExplorerBarItem - itmMyNetworkPlaces
      • WebExplorerBar - barDetails

For better understanding of WebExplorerPane hierarchy in visual details, please examine the illustration provided in the following:

The Pane of "File and Folder Tasks" is the SpecialPane, as displayed in the above image, the pane header style is different to the others pane header style. The SpecialPane can be set through SpecialBarIndex property, whose default value is 0 means the first pane in the Panes collection. The pane header image can be set floating (the image height exceed the bar height (size)) by setting the ImageHeight property bigger than the Size property.

WebExplorerPane also allows you to customize many user interface elements behaviors, such as CaptionDisplayMode, ContentMode, ImageSize, ImageHeight, Size of the pane header, BarSpacing and more. The configurations for WebExplorerBar (pane) can be set in global level at PaneSettings or at individual WebExplorerBar object level. Likewise, configurations for PaneItem can be set in global level at BarItemSettings or at individual WebExplorerBarItem object level.

Styles

In addition to the sophisticated object model design and rich behaviors, WebExplorerPane also provides comprehensive customization in visual styles which allow you to achieve professional desktop-like styles in minutes. As the standard of all Intersoft's products, the styles can be easily programmed and configured through strongly-typed object oriented Style.

The following image shows the illustration of all configurable Style in WebExplorerPane.

The above is the default style of WebExplorerPane which is applied automatically when you drop an instance of WebExplorerPane to designer's surface. For most cases, there are no significant changes required to the default styles and hence lets you quickly proceed to your further application development tasks.
The pane header style of SpecialPane can be set separately using SpecialBarStyle property. The SpecialBarStyle is an Intersoft dynamic style just like BarStyle property that has Normal, Active and Over style. At the PaneSettings, there's a property called MergeBarStyleOver, it is a boolean value to indicate whether the Over style can be merged to either Normal or Active style.

See Also

Related Topics
{Overview}
{Features}


Tutorials

Tutorials
Send Feedback
Intersoft WebDesktop > WebExplorerPane > Tutorials

Glossary Item Box

This section contains tutorial topics in WebExplorerPane.

In This Section

Creating Simple ExplorerPane

Configuring Expand and Collapse ExplorerPane

Show and hide ExplorerBar items

Changing Inline content of ExplorerPane

Handling Client Side Events

How-to: Customize Various WebExplorerPane Styles

How-to: Enable Expand/Collapse


Creating Simple ExplorerPane

Creating Simple ExplorerPane
See Also Send Feedback
Intersoft WebDesktop > WebExplorerPane > Tutorials > Creating Simple ExplorerPane

Glossary Item Box

Objectives

This tutorial demonstrates how to create a simple ExplorerPane using WebExplorerPane Designer. There are 3 modes for the content which are UseItems, UseInlineContent and UseIFrame.

  1. Drag WebExplorerPane from Toolbox into a WebForm page.

  2. Right-click on the WebExplorerPane and choose WebExplorerPane Designer.
  3. In the designer, choose Panes. Set ContentMode to UseItems, CaptionDisplayMode to TextAndImage and set the Image URL.

  4. Click PaneItems (collection) and the WebExplorerBarItem Collection Editor dialog appears.
  5. Set the bar Items respectively like the following snapshot. Now, you have learned how to create an explorer bar with UseItems as the ContentMode.

  6. Go back to WebExplorerPane Designer. Add a new WebExplorerBar and set ContentMode to UseInlineContent.

  7. In the HTML code, add the following code-snippet under ContentTemplate:
    Script Copy Code
    <ISWebDesktop:WebExplorerBar ContentMode="UseInlineContent" name="WebExplorerBar1"
       text="File and Folder Tasks">
       <ContentTemplate>
            <table style="margin: 3px">
                <tr>
                    <td>
                        <img src="Images/newfolder.gif" />
                    </td>
                    <td>
                        Make a new folder
                    </td>
                </tr>
                <tr>
                    <td>
                        <img src="Images/publishthisfolder.gif" />
                    </td>
                    <td>
                        Publish this folder to the Web
                    </td>
                </tr>
                <tr>
                    <td>
                        <img src="Images/sharethisfolder.gif" />
                    </td>
                    <td>
                        Share this folder
                    </td>
                </tr>
            </table>
       </ContentTemplate>
    </ISWebDesktop:WebExplorerBar>

  8. Now, you have learned how to create an explorer bar with UseInlineContent as the ContentMode.
  9. Again, go back to WebExplorerPane Designer. Add a new WebExplorerBar and set ContentMode to UseIFrame and ContentURL to http://www.google.com like the following snapshot.

  10. Run the project and you will see something like following.

See Also

Related Tutorials
Configuring Expand and Collapse ExplorePane
Show and hide ExplorerBar items
Changing Inline content of ExplorerPane
Handling Client Side Events


Configuring Expand and Collapse ExplorePane

Configuring Expand and Collapse ExplorePane
See Also Send Feedback
Intersoft WebDesktop > WebExplorerPane > Tutorials > Configuring Expand and Collapse ExplorePane

Glossary Item Box

Objectives

This tutorial shows how to configure expand and collapse ExplorerPane. By default, the ExplorerBar will be expanded. Therefore, you need to modify the property by setting Collapse to true for instance.

  1. Refer to Creating Simple ExplorerPane to create a basic ExplorerPane.
  2. Add 2 HTML buttons and named them "Expand Picture Tasks" and "Collapse File and Folder" Tasks respectively.
  3. Right-click on the WebExplorerPane and choose WebExplorerPane Designer.
  4. Go to Panes and choose WebExplorerBar0. Set Collapse to True.

  5. Add the following code in the client-side:

    Script Copy Code
    <script language="javascript">
    function DoExpand()
    {
        var expPane = ISGetObject("WebExplorerPane1");
        var pane = expPane.Panes.GetNamedItem("WebExplorerBar0");
        pane.DoExpand();
    }

    function DoCollapse()
    {
        var expPane = ISGetObject("WebExplorerPane1");
        var pane = expPane.Panes.GetNamedItem("WebExplorerBar1");
        pane.DoCollapse();
    }
    </script>

  6. Invoke DoExpand() and DoCollapse() functions in onclick event respectively like the following:

    Script Copy Code
    <input id="Button1" type="button" value="Expand Picture Tasks " onclick="DoExpand()"/>
    <input id="Button2" type="button" value="Collapse File and Folder Tasks" onclick="DoCollapse()"/>

  7. Run the project and you will see something like following:

See Also

Related Tutorials
Creating Simple ExplorerPane
Handling Client Side Events


Show and hide ExplorerBar items

Show and hide ExplorerBar items
See Also Send Feedback
Intersoft WebDesktop > WebExplorerPane > Tutorials > Show and hide ExplorerBar items

Glossary Item Box

WebExplorerPane gives you flexibility to show and hide ExplorerBar item.

This topic will show you how to show and hide the items in the WebExplorerBar.

To show and hide ExplorerBar items

  1. In WebExplorerBarItem Collection Editor, add 3 more items which are Move, Copy and Rename this file.
  2. Set Visible to false in the property window for those 3 items.

  3. Add 4 HTML buttons and named them "Show All Items", "Hide All Items", "Show Items" and "Hide Items" respectively.
  4. Add the following code in client-side to perform show/hide all items and show/hide several items:
    JavaScript Copy Code
    function ShowAllItems()
{
   var expPane = ISGetObject("WebExplorerPane1");
   var paneFileFolder = expPane.Panes.GetNamedItem("WebExplorerBarFile");
   paneFileFolder.ShowAllItems();
   paneFileFolder.AnimateHeight();
}

function HideAllItems()
{
   var expPane = ISGetObject("WebExplorerPane1");
   var paneFileFolder = expPane.Panes.GetNamedItem("WebExplorerBarFile");
   paneFileFolder.HideAllItems();
   paneFileFolder.AnimateHeight();
}

function ShowItems()
{
   var expPane = ISGetObject("WebExplorerPane1");
   var paneFileFolder = expPane.Panes.GetNamedItem("WebExplorerBarFile");
   paneFileFolder.ShowItems(["itm_Move", "itm_Copy", "itm_Rename"], true);
}

function HideItems()
{
   var expPane = ISGetObject("WebExplorerPane1");
   var paneFileFolder = expPane.Panes.GetNamedItem("WebExplorerBarFile");
   paneFileFolder.HideItems(["itm_Move", "itm_Copy", "itm_Rename"], true);
}

  5. Invoke ShowAllItems(), HideAllItems(), ShowItems() and HideItems() functions in onclick event respectively like the following:
    JavaScript Copy Code
    <input id="Button1" type="button" value="Show All Items" onclick="ShowAllItems()"/>
<input id="Button2" type="button" value="Hide All Items" onclick="HideAllItems()"/>
<input id="Button3" type="button" value="Show Items (Move, Copy, Rename)" onclick="ShowItems()"/>
<input id="Button4" type="button" value="Hide Items (View, Order, Print)" onclick="HideItems()"/>

  6. Run the project. Hence,
    • When you click "Show All Items" button, it will display all the items.
    • When you click "Hide All Items" button, it will hide all the items.
    • When you click "Show Items" button, it will show the items defined in the function, which are Move this file, Copy this file and Rename this file. The rest will be hidden.
    • When you click "Hide Items" button, it will hide the items defined in the function, which are Move this file, Copy this file and Rename this file. The rest will be displayed.

See Also

Related Tutorials
Creating Simple ExplorerPane
Handling Client Side Events


Changing Inline content of ExplorerPane

Changing Inline content of ExplorerPane
See Also Send Feedback
Intersoft WebDesktop > WebExplorerPane > Tutorials > Changing Inline content of ExplorerPane

Glossary Item Box

WebExplorePane allows user to replace the pane content from client-side dynamically.

This topic will show you on how to change the inline content of WebExplorerBar.

To change inline content of ExplorerPane

  1. Add a HTML button and named it "Change InlineContent".
  2. Add the following code in client-side to implement changing inline content:

    JavaScript Copy Code
    function DoChange()
{
   var expPane = ISGetObject("WebExplorerPane1");
   var pane = expPane.Panes.GetNamedItem("WebExplorerBarFile");
   pane.ChangeInlineContent("Change Inline Content");
}

  3. Invoke DoChange() function in onclick event like the following:

    JavaScript Copy Code
    <input id="Button1" type="button" value="Change InlineContent" onclick="DoChange()"/>

  4. Run the project. When you click the button, it will change the content in the specified pane.

See Also

Related Tutorials
Creating Simple ExplorerPane
Handling Client Side Events


Handling Client Side Events

Handling Client Side Events
See Also Send Feedback
Intersoft WebDesktop > WebExplorerPane > Tutorials > Handling Client Side Events

Glossary Item Box

Objective

WebExplorerPane has a capability to handle some ClientSide Events. This tutorial will show the list of ClientSide Events available and how to invoke them respectively.

  1. Refer to Creating Simple ExplorerPane to create a basic ExplorerPane.
  2. Open WebExplorerPane Property Window.
  3. At ClientSideEvent Category, fill all the EventHandler like following

  4. Create JavaScript function that corresponds to each EventHandler
    Script Copy Code
    <script type ="text/javascript">

     function onAfterCollapse()

      {

        alert(    "After Collapse");

      }

        function onAfterExpand()

      {

        alert(    "After Expand");

      }

      function     onBeforeCollapse()

      {

        alert(    "Before Collapse");

      }

      function     onBeforeExpand()

      {

        alert("Before Expand");

      }
      function onClientUnload()

      {

        alert("Client Unload");

      }
      function onInitialize()

      {

        alert("Initializing");

      }
      function onPaneHeaderClick()

      {

        alert("Pane's Header is clicked");

      }
      function onPaneItemClick()

      {

        alert("Pane's Item is clicked");

      }

    </script    >

See Also

Related Tutorials
Creating Simple ExplorerPane
Configuring Expand and Collapse ExplorePane
Show and hide ExplorerBar items
Changing Inline content of ExplorerPane


How-to: Customize Various WebExplorerPane Styles

How-to: Customize Various WebExplorerPane Styles
Send Feedback
Intersoft WebDesktop > WebExplorerPane > Tutorials > How-to: Customize Various WebExplorerPane Styles

Glossary Item Box

WebExplorePane has several styles to be configured.

This topic will show you how to customize various WebExplorerPane styles.

To customize various WebExplorerPane styles

  1. Right click on WebExplorerPane control and choose WebExplorerPane Designer.
  2. Switch to Layout Manager.
  3. Expand Predefined Layout and choose the style available.


How-to: Enable Expand/Collapse

How-to: Enable Expand/Collapse
Send Feedback
Intersoft WebDesktop > WebExplorerPane > Tutorials > How-to: Enable Expand/Collapse

Glossary Item Box

You can perform expand and collapse in WebExplorerPane. Simply click on the Up/Down arrow at the right most part of ExplorerPane header to Expand and Collapse the ExplorerPane.

In this topic, you will learn how to enable expand/collapse from client-side.

To enable expand/collapse

  1. Drag a HTML button control to the WebForm.
  2. Create ExpandPane() function to implement expand and collapse pane.
    JavaScript Copy Code
    function ExpandPane(paneId, buttonId)
{
   var expPane = ISGetObject("WebExplorerPane1");
   var button = ISGetObject(buttonId);
   var pane = expPane.Panes.GetNamedItem(paneId);

   if (pane.Collapse)
   {
      pane.DoExpand();
   }
   else
   {
      pane.DoCollapse();
   }
}

  3. Trigger ExpandPane() using onclick on HTML button.

    <input ID="Button1" type="button" value="button" onclick="ExpandPane('barPictureTasks', 'Button1')"/>

  4. Run the project.


WebNotification

WebNotification
See Also Send Feedback
Intersoft WebDesktop > WebNotification

Glossary Item Box

WebNotification
Member of WebDesktop.NET

WebNotification control allows you to quickly add professional notifications functionality to your next-gen web application. The control is based on FlyPostBack™ architecture (a.k.a. AJAX) and provides you elegant, object-model approach to obtain notifications from server side.

What's new in WebNotification

Learn the Features

Understanding Concepts

Quick Start

Retrieving Notifications from WebService

Retrieving Notification from WebForm Listener

Integrating into WebDesktopManager

Display visually stunning Notification

Use WebNotification to notify new events to your end users in stylish and professional way, such as displaying new emails or alerting server maintenance process. WebNotification allows you to configure numerous visual effect settings such as the animation style, fading speed and more. This will result in smooth and exciting user experiences while they are working with the application.

Easily retrieve new Notifications

WebNotification component asynchronously retrieves new Notifications from server side in every certain time interval. The control can retrieves the Notifications from either WebService (asmx) or WebForm (aspx) page. Designed with strongly-typed object model, you can easily return new notification events from server side codes. The asynchronous process allows seamless data retrieval and ensures extremely fast communication between client and server since WebNotification returns only the events data in XML format, instead of HTML control rendering result.

Create Outlook 2003 or MSN Messenger style Notification with built-in Action Context Menu

With WebNotification, you can quickly create modern notifications with Outlook or Messenger behavior. Since that WebNotification is designed specifically for notifications purpose, WebNotification replicates every single details of behavior available in Outlook or Messenger. For instance, when the WebNotification is configured in Outlook mode, the fade-out animation process will be canceled when mouse is over the WebNotification window. In addition, you can also configure the Action Context Menu so that end users can perform a choice of actions available to the notification event.

See Also

Getting Started
{Features}
{Understanding Concepts}


What's New in WebNotification

What's New in WebNotification
See Also Send Feedback
Intersoft WebDesktop > WebNotification > What's New in WebNotification

Glossary Item Box

WebNotification enables interactive push message systems to your ASP.NET applications. It’s an ideal tool for the ability to send notification messages from servers to clients. It also provides several popular themes, such as Microsoft Outlook 2003, MSN Messenger, and Metro style in version 4. WebNotification's broad and rich feature set supports all types of web applications regardless of their size and complexity. A few of its advanced features include a built-in context menu, clickable notification, and audio visual notification effects.

In version 4, WebNotification has been converted into HTML5 and CSS3 standards. It becomes more customizable and easily adapt with HTML5 pages.

These are the following details of enhancements and new features that have been implemented in WebNotification:

  • Customizable caption

    In HTML4, WebNotification only has CaptionStyle to adjust the caption styling. In HTML5, using CaptionTextStyle, you can adjust the text style inside Caption of WebNotification.

  • New intuitive style in WebDesktop 4

    In version 4, WebDesktop presents a new style in each of its control. Metro style as the latest UI in Windows 8 had been implemented and became brand new UI in our WebDesktop control. Metro style makes WebDesktop simpler, tidier, and more attractive for each control's UI. The intuitive design of Metro style also provide consistency of each control in HTML5.

    You can simply use Layout Manager to implement Metro style in WebDesktop.

    For more information on how to apply this configuration, see How-To: Using Layout Manager.

See Also

WebNotification

Features
Features


Features

Features
See Also Send Feedback
Intersoft WebDesktop > WebNotification > Features

Glossary Item Box

WebNotification component offers unique innovations and advanced features such as listed in the following.

  • Asynchronous notifications retrieval

    WebNotification used FlyPostBack technology (a.k.a. AJAX) to perform communication with server side in order to obtain Notifications data. The asynchronous approach is crucial for smooth and uninterrupted user experience. This feature is built-in and does not require you to perform additional configuration.
  • Service types

    Offers two methods that you can choose for the client/server communication purpose:
  1. WebForm ServiceType.

    This is the default value for ServiceType property. WebForm mode is recommended when the data provider is private and does not need to be exposed. With this mode, you need to set the WebForm (aspx) page which the control will invoke. You can set the ServiceUrl to either the current caller page or another WebForm page in the application.

    The best practice for WebForm ServiceType is by assigning the ServiceUrl to another WebForm page which especially created to serve the notifications purpose. With this flexibility, you are no longer restricted to call the self current page which exposes performance issues and ineffective codes design.
  2. WebService ServiceType.

    This type allows you to retrieve Notifications data from a web service (asmx) page. When set to this mode, you set the ServiceUrl to the web service page containing the method required by WebNotification control.

    The WebService mode is the recommended data provider setting when the methods need to be exposed for other usage.

    Note that both WebForm and WebService have similar method signature and returned object type. This allows you to easily switch between WebForm and WebService as necessary in certain phase of development.
  • Elegant object model and API
    WebNotification is designed to be easy to consume by developers from any background. Unlike other similar controls, WebNotification provides a set of strongly-typed object model as the data backbone for client/server communication.

    The central of the architecture is the WebNotificationEvent object which contains the information required by WebNotification control to receive new notification events.

    The following sample shows the object model usage in WebService mode.

    Expand Sample

    [WebMethod]

    public WebNotificationEventCollection GetNotifications(WebNotificationEventArgs e)

    {

    WebNotificationEventCollection collection = new WebNotificationEventCollection();

    WebNotificationEvent evnt = new WebNotificationEvent();

    evnt.CaptionText = "Samples";

    evnt.ContentText = "Hello world from WebNotification!\nCurrent time is:" + DateTime.Now.ToLongTimeString();

    collection.Notifications = new WebNotificationEvent[] { evnt };

    return collection;

    }

    While the data communication is using strongly-typed object model which benefitting developers, the WebNotification sent the object result back to client in XML Format to ensure high performance and smooth user experience.
  • Visual effects

    WebNotification includes two predefined animation for visual effects: Fading and Sliding.

    When set to Fading, the WebNotification window will be displayed (fading from transparent to opaque). The animation speed can be set in FadingSpeed property. The Fading mode resembles the Outlook 2003® animation's style and behavior.

    The Sliding mode resembles the MSN Messenger® animation's style and behavior where notification window will be slided from bottom to top.
  • WebDesktopManager integration

    The web application development that built around WebDesktopManager has a lot of advantages for developers, in addition to the definitive benefits for end users experience. The WebDesktopManager is designed with extensibility as a key goal in mind to serve the purpose of universal shell. With a single property set, you can set the WebNotification control to be integrated into the WebDesktopManager instance which hosts the WebForm.

    When integrated, the notification popup window will be displayed at desktop level instead of current Window. This feature enables end users to conveniently access to the notification popup regardless of the active Window.

    The display position of the notification popup window is set to RightBottom by default (as in most modern applications). You may want to change the display to other position by changing the DisplayPosition property.
  • Built-in Action context menu

    Action context menu provides a way for end users to access a list of available actions and perform an action against notification event. The Action context menu takes advantage of Hybrid Menu architecture and Visual Menu Builder for design consistency and enhanced integrated development experience.

    To enable action context menu, simply set the ShowActionDropdown to true then defines the menu items. You can also manipulate the action menu items programmatically at client side, such as during OnActionClick client side event.
  • Clickable notification window

    WebNotification includes built-in capability for setting the popup window as clickable when the notification popup window appears. With this handy feature, you can redirect the users to other page when the control's window is displayed due to a notifiy event. For instance, you may want to launch the Mail Inbox home page when users clicked on the new email notification event.

    To enable clickable window, simply set the NotifyWindowClickable to True. You would also need to set the corresponding URL in the NotifyWindowURL property.
  • Full control on interval, display timeout and behavioral settings

    You can customize many runtime aspects and behaviors on how you want the WebNotification to behave, in addition to the fully customizable styles. For example, you can change the Interval property to specify how often the control should check for new notifications. The DisplayLatency property allows you to control how long a notification window should stay visible to the user.

    Other behavioral settings that you should consider:
    • Do you want to prevent the control from starting the timer automatically? Set its AutoStart property to False.
    • Do you want the control to run only once instead of periodically? Set its RunOnce property to True.
  • Sound effect

    WebNotification includes unique innovations which are not only enabling developers to easily create visually stunning notifications system, but also the built-in capability to play a sound file when valid notification events occur. This unique innovation allows you to deliver a sophisticated web application that resembles a desktop system.

    To enable sound, set the EnableSound property to True and set the SoundFile property to a valid sound file URL. A valid sound file should be one of the following extensions:
    • .wav
    • .midi
    • .au

    The sound effect feature works in Internet Explorer browsers without any extra efforts. However, this feature requires Sound System plug-in for Mozilla-based browsers to work properly.

  • Object collection-based custom properties
    WebNotification is built to cover some advanced scenarios which would commonly be faced by developers while building complex web application. One of the scenarios is the ability to pass custom properties along with the notification event to the client side.

    For instance, you may want to send the RowID along with the notification event so you can get the ID in the client side and perform further extensibility. In WebNotification, you can send custom property easily in collection-object friendly approach. WebNotification used Dictionary based type and is able to be serialized perfectly into XML Format.

    The following codes snippet demonstrates how you can pass the EmailID value along with the notification event.

    WebNotificationEvent

    evnt = new WebNotificationEvent();

    evnt.CaptionText =

    "Samples: Outlook 2003";
    evnt.Properties["EmailID"] = emailObj.ID;

See Also

Related Topics
{Overview}
{Understanding Concepts}


Understanding Concepts

Understanding Concepts
See Also Send Feedback
Intersoft WebDesktop > WebNotification > Understanding Concepts

Glossary Item Box

Introduction

WebNotification is a server control designed to retrieve new notifications from server side using object model. With the object model, it allows WebNotification to act as universal which communicates to the designated service to return the data. In short, WebNotification does not enforce or restrict any physical storage of your notifications data, or where you would like to retrieve it from.

You can use WebService (asmx) or WebForm page (aspx) as the primary data source provider for WebNotification control.

More Details

WebNotification communicates with a WebService or WebForm page provider through asynchronous call (a.k.a. AJAX) which is based on WebFlyPostBackManager component.

The following diagram shows the WebNotification control life cycle and how it works.

As illustrated in above diagram, WebNotification control begins its life cycle by requesting data from WebService. The GetNotifications function will then execute the contained codes and add new WebNotificationEvent object to the collection when data existed. Finally, the collection is returned from the function. The collection object will then serialized back to the client as XML data and processed internally by the WebNotification control.

When the collection contains one or more WebNotificationEvent objects, the notification popup window will be displayed in the client's screen. The text, image and the caption text of the notification will be based on the data provided in the WebNotificationEvent object which passed from the server side.

With this architecture, developers no longer being restricted to use the same WebForm page for the notifications data retrieval, which will result in slower performance and bottleneck because of the normal page lifecycle execution and ineffective non-reusable codes.

Object Model

The following diagram shows the object model used by WebNotification control during retrieval process.

The WebNotificationEventArgs object is constructed internally at client side and passed into the function as parameter value. It is used to provide the current context of the WebNotification caller, such as the RawUrl of the WebForm page which invokes the service, or the Id of the WebNotification which in charge calling the service.

The WebNotificationEvent object is the central notification data that contains information about an event. As seen in above diagram, the object contains information such as the CaptionText, NotifyURL and so on; which provided by the developers. The information provided in the object will be automatically retrieved by the WebNotification control in the client side for the end user notification display process.

UI Elements

The WebNotification component supports fully customizable styles for most of the UI elements. The following diagram shows you the WebNotification's UI elements in details, so that you can easily customize the style for the elements you desired.

With this flexibility, WebNotification component is not only powerful in the term of architecture and object model, it also offers fully customizable styles for most of the elements as described in above diagram.

See Also

Related Topics
{Overview}
{Features}


Tutorials

Tutorials
Send Feedback
Intersoft WebDesktop > WebNotification > Tutorials

Glossary Item Box

This section contains tutorial topics in WebNotification.

In This Section

Retrieving notifications from WebService

Retrieving notifications from WebForm listener

Integrating into WebDesktopManager

Using action context menu

Passing custom properties


Retrieving notifications from webservice

Retrieving notifications from webservice
Send Feedback
Intersoft WebDesktop > WebNotification > Tutorials > Retrieving notifications from webservice

Glossary Item Box

Objectives

WebNotification control will call the specified ServiceUrl periodically. In this tutorial, the WebNotification will use WebService engine as its ServiceType.

  1. Drag the WebNotification from ToolBox into the webform page.

  3. Create a WebService, then add a webmethod into it. In this webmethod, you can set text and caption to be shown by the WebNotification. The WebNotification control will look for "GetNotifications" method in the specified webform page. The code looks like the following:
  4. C# Copy Image Copy Code
    [WebMethod ]
    public WebNotificationEventCollection GetNotifications( WebNotificationEventArgs e)
    {
             WebNotificationEventCollection collection = new WebNotificationEventCollection ();
             WebNotificationEvent evnt = new WebNotificationEvent ();

             evnt.CaptionText = "Samples";
             evnt.ContentText = "Hello world from WebNotification!\nCurrent time is:" + DateTime.Now.ToLongTimeString();

             collection.Notifications = new WebNotificationEvent[] { evnt };
             return collection;
    }

  5. Open the WebNotification designer. Set the ServiceType to WebService, and the ServiceUrl to the created webservice.

    Designer

  6. Finally, run the WebForm to see the notification.


Retrieving notifications from webform listener

Retrieving notifications from webform listener
Send Feedback
Intersoft WebDesktop > WebNotification > Tutorials > Retrieving notifications from webform listener

Glossary Item Box

Objectives

WebNotification control is able to use WebForm type as its ServiceType. WebForm-based service has an advantage because it has a tighter security since this service is not directly exposed to public. Hence, it is not call-able from other pages except from WebNotification control itself. The WebForm service engine is built on the top of FlyPostBack architecture.

  1. Drag the WebNotification from ToolBox into the webform page.

    WNCtrl

  2. Create a WebForm as a listener for the control. In this webform, you can set text and caption to be shown by the WebNotification. The WebNotification control will look for "GetNotifications" method in the specified webform page. The code looks like the following:

    C# Copy Image Copy Code
    [WebFlyPostBackMethod() ]
    public WebNotificationEventCollection GetNotifications( WebNotificationEventArgs e)
    {
             WebNotificationEventCollection collection = new WebNotificationEventCollection ();
             WebNotificationEvent evnt = new WebNotificationEvent();

             evnt.CaptionText = "Samples";
             evnt.ContentText = "Hello world from WebNotification!\nCurrent time is:" + DateTime.Now.ToLongTimeString();

             collection.Notifications = new WebNotificationEvent[] { evnt };
             return collection;
    }

    In addition, you also need to include the code in Page_Load which constructs the listener. The Listener is an independent lightweight callback implementation to avoid HttpModule utilization, and built on the same architecture as Intersoft's FlyPostBack architecture.

    C# CopyHover Image Copy Code
    listener = new WebFlyPostBackListener(this);

    This code describes that the function basically should return the "collection of events" which type is WebNotificationEventCollection. In this sample, it only returns single event which is passed to the Notifications property of the collection object.

  3. Open the WebNotification designer. Set the ServiceType to WebForm, and point the ServiceUrl to the created listener WebForm.

    Designer

  4. Finally, run the WebForm to see the notification.


Integrating into WebDesktopManager

Integrating into WebDesktopManager
Send Feedback
Intersoft WebDesktop > WebNotification > Tutorials > Integrating into WebDesktopManager

Glossary Item Box

WebNotification can be used in both stand-alone and integration mode. However, most of time developers will prefer to consolidate all menu instances in entire application to use one style definition. Thanks to the hybrid menu system which enables tight integration with desktop manager and allow developers to specify the menu styles at desktop manager level. In this tutorial we will see how to implement it.

  1. Create a page containing WebNotification control.

  2. Following are properties to be set in the WebNotification designer. Ensure the IntegratedToDesktopManager is set to true.

    Properties | Values
    ServiceType | WebService
    ServiceUrl | WebNotificationService.asmx
    IntegratedToDesktopManager | True
    Interval | 20 seconds
    AnimationType | Sliding
    NotifyWindowClickable | True
    NotifyWindowURL | http://dev2.intersoftpt.com

  3. Create a page containing WebDesktopManager control.
  4. Add a window and set ContentMode to UseIFrame.
  5. Set ContentURL to the page that contains WebNotification.
  6. Run the project.


Using action context menu

Using action context menu
Send Feedback
Intersoft WebDesktop > WebNotification > Tutorials > Using action context menu

Glossary Item Box

Objectives

This tutorial demonstrates how to use Action context menu in WebNotification. Action context menu provides a way for end users to access a list of available actions and perform an action against notification event.

  1. Drag WebNotification control from ToolBox into the WebForm.

  2. Create a WebService page in the same directory and name it "NotificationService.asmx". It will automatically create "NotificationService.cs" in the App_code folder. WebNotification control will look for GetNotifications method in the WebService. Use the following code for GetNotifications method:

    C# Copy Code
    [WebMethod]
public WebNotificationEventCollection GetNotifications(WebNotificationEventArgs e)
{
   WebNotificationEventCollection collection = new WebNotificationEventCollection();
   WebNotificationEvent evnt = new WebNotificationEvent();

   evnt.CaptionText = "Samples";
   evnt.ContentText = "Hello world from WebNotification!\nCurrent time is:" + DateTime.Now.ToLongTimeString();

   collection.Notifications = new WebNotificationEvent[] { evnt };
   return collection;
}

  3. Open WebNotification Designer and set the following properties of WebNotification control:

    Properties | Values
    ServiceType | WebService
    ServiceUrl | NotificationService.asmx
    ShowActionDropdown | True

  4. Add some menu items in Items property and specify a function name for OnClick event.

  5. Add client side script for OnClick event:

    JavaScript Copy Code
    function doClick(mi)
{
   alert("Clicked : " + mi.Name);
}

  6. Run the page. Menu items will be displayed when Action context menu is clicked.

    When the menu item is clicked, an alert box will be displayed.


Passing custom properties

Passing custom properties
Send Feedback
Intersoft WebDesktop > WebNotification > Tutorials > Passing custom properties

Glossary Item Box

Objectives

This tutorial demonstrates how to pass custom properties to be used in WebNotification.

  1. Drag WebNotification control from ToolBox into the WebForm.

  2. Create a WebService page in the same directory and name it "NotificationService.asmx". It will automatically create "NotificationService.cs" in the App_code folder. WebNotification control will look for GetNotifications method in the WebService. Use the following code for GetNotifications method:

    C# Copy Code
    [WebMethod]
    public WebNotificationEventCollection GetNotifications(WebNotificationEventArgs e)
    {
            WebNotificationEventCollection collection = new WebNotificationEventCollection();
            WebNotificationEvent evnt = new WebNotificationEvent();

            evnt.CaptionText = "Samples";
            evnt.ContentText = "Hello world from WebNotification!\nCurrent time is:" + DateTime.Now.ToLongTimeString();
            evnt.Properties["CustomerId"] = "ALFKI";

            collection.Notifications = new WebNotificationEvent[] { evnt };
            return collection;
    }

  3. Open WebNotification Designer and set the following properties of WebNotification control:

    Product | Sample Location
    ServiceType | WebService
    ServiceUrl | NotificationService.asmx

  4. Open WebNotification Designer, add an event handler for OnNotify client side event.

  5. Add the following code for OnNotify client side event:

    Script Copy Code
    <script language="javascript" type="text/javascript">
    function WebNotification1_OnNotify(controlId, notifyObject)
    {
       var WebNotification1 = ISGetObject(controlId);
       alert(notifyObject.Properties[0].Key + " = " + notifyObject.Properties[0].Value);
       return true;
    }
    </script>

  6. Run the page. The custom properties' key and value will be displayed in an alert box on OnNotify client side event.


WebButton

WebButton
See Also Send Feedback
Intersoft WebDesktop > WebButton

Glossary Item Box

WebButton.NET component is included as a perfect complement for the WebDesktop.NET. By using WebButton, you can resemble a consistent look&feel for the buttons throughout the entire application. Furthermore, the WebButton incorporates Framework's DynamicStyle to enable the rich interactive styles for the WebButton. In addition, the WebButton also support DisplayMode feature allowing you to put a custom image at the left or right part of the WebButton. Finally, it enables the command buttons in your application to have a rich look and convenient behavior.

WebButton offers time-saving features such as in the following:

  • AutoPostBack
    WebButton can operate in client side or server side mode. The default is client side mode where AutoPostBack is set to False. When operates in client side mode, developers generally implement the OnClientClick client side event to execute the javascript codes to response the button click. Otherwise, when operates in server side mode, developers can write codes in OnClick server side event to response the button click. Optionally, developers can also handle both client and server side events for maximum interactivity. If the return value is false in client side event, the server post back will not be invoked further.
  • PostBackMode
    Built on the top of Intersoft's unique WebUI.NET Framework, WebButton is taking advantage of FlyPostBack and ClientAction architecture enabling the Button to execute server side codes in Button's OnClick event without full page refresh. Since it implements the FlyPostBack and other interfaces, WebButton has the same power and capabilities as with other Intersoft's flagship products such as WebCombo.NET. Instead of FlyPostBack, WebButton also supports traditional page postback by setting it to FullPostBack value.
  • DesktopManager Integration
    Instead of using WebButton in stand alone mode, you can also operate the Button in Integration mode. The integration to DesktopManager component enables the button to resemble the look and feel of CommandButtonStyle, CommandButtonDisabledStyle, CommandButtonBorderType and CommandButton's ComplexImages which specified in DesktopManager level. This is very powerful feature since by integrating to desktop manager, the built-in styles for the specific page does not need to be rendered since the WebButton implemented new breakthrough in applying the styles defined at DesktopManager level dynamically at client side regardless of where the page resides.
  • Interactive Styles
    WebButton extensively utilize the powerful features already available in WebUI.NET Framework. One of the powerful features is the DynamicStyle feature for the rich interaction styles of the WebButton. The interactive style is available to configure in ButtonStyle property.
  • Images and ImagePosition
    Unlike traditional button, you can specify the DisplayMode of WebButton to use TextAndImage instead of only Text. With WebButton, you can display rich command button by displaying your own Image at the left or right part relative to the Text. You can easily specify the image's position in the ImagePosition property.
  • Convenient Parameter Passing
    WebButton introduced a convenient way in passing parameter which is one of the most common practice required in web application development. The Parameter property can be set in both server side and client side to pass information during postbacks. For example, you may want to set some data or flag which need to be passed during postback, you firstly set the Parameter property in client side. The information in Parameter property can then be accessible in OnClick server side event, exactly in the Parameter property of the event argument.
  • DisableOnClick
    Another most common practice for WebButton is to disable the button when clicked. This time-saving feature will automatically disable the Button when clicked to prevent users to press the Button twice accidentally which could cause duplicate postbacks and human error issues that affect the accuracy and stability of web application.
  • WinForm-like Mnemonic Key Support
    For even greater keyboard support, WebButton properly implements the WinForm-like Mnemonic key support. You can specify the key in AccessKey property to conform the standard of Web. During rendering, WebButton automatically adds underline at the position where the character specified in AccessKey is found. As the result, your end users can conveniently and quickly access to the command button from anywhere in the form by pressing Alt + AccessKey.

See Also

Related Topics
{Integrating To DesktopManager}


Integrating To DesktopManager

Integrating To DesktopManager
See Also Send Feedback
Intersoft WebDesktop > WebButton > Integrating To DesktopManager

Glossary Item Box

WebButton can be used in either StandAlone mode or Integrated mode. To enable the Integration mode, simply change the IntegratedToDesktopManager property to True.

When the WebButton is integrated, the Interactive Styles of WebButton will be inherited from from WebDesktop. Therefore the look and feel of all WebButton can be maintain through out the entire application.

Active | Normal | Over
Button's Style inherited From WebDesktop with Vista Theme

One important thing to highlight is that when the WebButton is integrated, all the styles will be overridden with inherited styles from WebDesktopManager, with intention to ensure consistent look and feel of all Integrated WebButton.

See Also

Related Topics
{Features}


Tutorials

Tutorials
Send Feedback
Intersoft WebDesktop > WebButton > Tutorials

Glossary Item Box

This section contains tutorial topics in WebButton.

In This Section

Configuring Interactive Style of WebButton

Enabling Automatic Postback when Clicked

Executing server side codes in FlyPostBack mode

Using ClientAction engine during FlyPostBack execution

How-to: Use FlyPostBack and Standard PostBack Mode


Configuring Interactive Style of WebButton

Configuring Interactive Style of WebButton
Send Feedback
Intersoft WebDesktop > WebButton > Tutorials > Configuring Interactive Style of WebButton

Glossary Item Box

Objectives

Configuring Interactive Style of WebButton

WebButton is designed to have the true Desktop's button behavior. It has three states (Active, Over, Normal) in enable mode, where we can apply styles to each states to experience the same behavior as in Desktop's Button (e.g minimize/max/restore/close button styles in every window).

Following are steps to configure the styles for each states : (in "Stand alone Mode")

  1. Drag WebButton control to the WebForm.
  2. Right-click on WebButton control and choose Properties.
  3. Expand ButtonStyle and you will see Active, Normal, and Over States.

  4. Expand Active State, change BackColor and BackColor2.

  5. Expand Normal State, change BackColor and BackColor2.

  6. Expand Over State, change BackColor and BackColor2.

  7. Run The Project and you will see something like this.

    Normal

    Over

    Active

  • This tutorial only shows you changing the BackColor and BackColor2 property, feel free to experiment with other property style.
  • In "Integrated Mode" (The WebButton is integrated with WebDesktopManager), the styles of WebButton are inherited from DesktopManager's WindowSetting's CommandButtonStyle


Enabling Automatic Postback when Clicked

Enabling Automatic Postback when Clicked
Send Feedback
Intersoft WebDesktop > WebButton > Tutorials > Enabling Automatic Postback when Clicked

Glossary Item Box

Objectives

Unlike the usual .NET's Button where Automatic Postback is set up by default, WebButton by default is not configured for Automatic Postback. This tutorial will guide you on how to enable automatic postback when clicked.

The following are the steps to enable WebButton's Automatic Postback :

  1. Drag WebButton to WebForm.

  2. Open WebButton's Property Window.
  3. In WebButton's Properties, change AutoPostBack property to True.

  4. Specify the PostBackMode value. You can choose between FlyPostBack or FullPostBack mode.


Executing server side codes in FlyPostBack mode

Executing server side codes in FlyPostBack mode
Send Feedback
Intersoft WebDesktop > WebButton > Tutorials > Executing server side codes in FlyPostBack mode

Glossary Item Box

Objectives

WebButton has two types of PostBack OnTheFlyPostBack and FullPostBack. This tutorial will show you how to execute server side codes in OnTheFlyPostBack mode.

  1. Drag WebButton to WebForm.

  2. Open WebButton's Property Window.
  3. In WebButton's Property, change AutoPostBack Property to True.

  4. In WebButton's Property, change PostBackMode Value to FlyPostBack

  5. In Event Properties, initiate Clicked Event.

  6. Put some server side codes inside the Clicked Event
    In this case i will set a value into session state.

    C# Copy Code
    protected void WebButton1_Clicked(object sender, ISNet.WebUI.WebDesktop.WebButtonClickedEventArgs e)

    {

     // put value to session

      Session[    "Message"] = "Hello World";

    }


Using ClientAction engine during FlyPostBack execution

Using ClientAction engine during FlyPostBack execution
Send Feedback
Intersoft WebDesktop > WebButton > Tutorials > Using ClientAction engine during FlyPostBack execution

Glossary Item Box

Objectives

WebButton has two types of PostBack OnTheFlyPostBack and FullPostBack. This tutorial will show you how to execute ClientAction Engine during FlyPostBack execution.
  1. Drag Label to WebForm.

  2. Drag WebButton to WebForm.

  3. Open WebButton's Property Window.
  4. In WebButton's Property, change AutoPostBack Property Value to True.

  5. In WebButton's Property, change PostBackMode Value to FlyPostBack.

  6. In Event Properties, initiate Clicked Event.

  7. Change Text Property of Label in Clicked Event and Alert the User.

    C# Copy Code
    protected void WebButton1_Clicked(object sender, ISNet.WebUI.WebDesktop.WebButtonClickedEventArgs e)

    {

     // change the text of Label1

      Label1.Text =     "Label1 is changed, and you should see an alert message";

     // refresh the controls which being modified , in this case only Label1

      WebButton1.ClientAction.RefreshModifiedControls();

     // execute alert message

      WebButton1.ClientAction.Alert(    "Label1 is changed");
    }


How-to: Use FlyPostBack and Standard PostBack Mode

How-to: Use FlyPostBack and Standard PostBack Mode
Send Feedback
Intersoft WebDesktop > WebButton > Tutorials > How-to: Use FlyPostBack and Standard PostBack Mode

Glossary Item Box

WebButton provides two postback mode to be used, which are FlyPostBack and FullPostBack.

This topic will show you how to use FlyPostBack and standard PostBack mode.

To use FlyPostBack

  1. Right-click on WebButton control and choose Properties.
  2. Set PostBackMode to FlyPostBack and AutoPostBack to True.
  3. Put the following code in Clicked server-side event.
    C# Copy Code
    protected void WebButton1_Clicked(object sender, ISNet.WebUI.WebDesktop.WebButtonClickedEventArgs e)
{
   if (WebButton1.IsFlyPostBack)
   {
      Label1.Text = "Fly PostBack has occured, there should be a javascript alert ";
      WebButton1.ClientAction.Alert("Fly Postback");
      WebButton1.ClientAction.RefreshModifiedControls();
   }
}

  4. Run the project. When you click the button, it will show an alert since it is in FlyPostBack mode.

To use FullPostBack

  1. Right-click on WebButton control and choose Properties.
  2. Set PostBackMode to FullPostBack and AutoPostBack to True.
  3. Put the following code in Clicked server-side event.
    C# Copy Code
    protected void WebButton1_Clicked(object sender, ISNet.WebUI.WebDesktop.WebButtonClickedEventArgs e)
{
   WebButton1.Text = "Full PostBack";
}

  4. Run the project. When you click the button, it will perform FullPostBack and the button's label will be changed to Full PostBack.


Working with Component Editor

Working with Component Editor
Send Feedback
Intersoft WebDesktop > Working with Component Editor

Glossary Item Box

Background

One of the main distinguish of Intersoft Components is we provide developers with a unique design-time experience through our Component Editors. Design-time experience has been one of the key development aspect here at Intersoft where run-time features and performance is just as important as the experience during designing.

By emphasizing strongly on this issue, all of our products have an external Component Editor as a complement to standard PropertyGrid in Visual Studio IDE. The component Editor works more and less the same way as the standard Property Grid in the IDE where you can set the currently selected object property. The difference lies in the organization of the property and a convenient layouting where properties with similar interest are then grouped to nodes.

Special Features

The two unique features available in the external Component Editor is what we call by Layout Manager and Structure Manager. Usually when you drag a component from the toolBox, it will have the default appearance and empty structure. Problem occurs when you need to retain the Layout and Structure and apply it to other component, you will need to do a repetitive task to replicate the Layout and Structure.

As a solution to the problem above, by using these 2 features available in our Component Editor, you will have the ability to Serialize the Layout and Structure of the component to XML file(s). The XML file will then be deserialized and applied to the component when the Layout and Structure needs to be used again.

  • Layout Manager provides the ability to persist the layouting you have done to the component such as color, style and other things related to the UI appearance of the component. You can later on apply the same appearance to other instance of the same component.
  • Structure Manager provides the ability to persist the structure of the component so you can save then load the component structure, this is very useful in cases where you have a complex structure so you can simply load the structure without needing to build the structure from scratch anymore.


Using Component Editor

Using Component Editor
Send Feedback
Intersoft WebDesktop > Working with Component Editor > Using Component Editor

Glossary Item Box

Step By Step Guide to use Component Editor

  1. Drag one of the WebDesktop Components from the ToolBox to the Design Surface
  2. Right click on the Component and choose Component Name* Designer
    * Depends on the name of the Component eg. Web Desktop Designer

  3. The Designer then pops up and you can do the modification of the component there.


Working with Properties Manager

Working with Properties Manager
Send Feedback
Intersoft WebDesktop > Working with Component Editor > Working with Properties Manager

Glossary Item Box

Background

The properties Manager is the first and basic feature of the Component Editor. This feature exists to give better layouting and organization of the properties available in the component you are editing. Other than that it also offers a better property editing experience.

In this tab, there will be a TreeView on the Left of the TabPage and a Content Area on the Right side which will be used to display the selected TreeNode information.

UI Introduction

The Properties Tab
The TabPage which holds the entire Properties Manager feature
The TreeView
Used to divide the component properties into several categories.
When the TreeView Node is clicked it will display the corresponding property on the Stage
The Stage
Acts as a container which will display the properties of the currently selected Node in the TreeView
Footer Section *
Consist of OK, Cancel, Apply Button.

* Not part of Properties Manager but it is a part of Component Editor, so it will appear no matter which TabPage is selected.

TreeView NodeType

There are basically 3 Types of Node in the TreeView.

  • The first one is for Text Nodes which are nodes which is only used as a PlaceHolder, it will have no content displayed on the stage when clicked.
  • The second node is for Normal Nodes which are nodes which has an object associated with it. When clicked a PropertyGrid will appear on the Stage.
  • The third node is for Collection Nodes, which are nodes which contain a Collection of Object. When clicked a composite control consisting ListView on the Left. a PropertyGrid on the Right, and a toolBar on the Top of the Stage.


Working with Layout Manager

Working with Layout Manager
Send Feedback
Intersoft WebDesktop > Working with Component Editor > Working with Layout Manager

Glossary Item Box

Background

The Layout Manager is the second major feature available in Component Editor. This feature allows predefined or custom layouts be applied into the currently edited component.

Layout modification done to the component can be saved into an XML file by clicking on Save Layout Button and can then be re-used by other components. This will ensure that the other instance of the same component will have exactly the same Layout appearance. Other than that it also improves efficiency cause we can simply load the XML settings rather than having to apply the Layout properties one by one.

UI Introduction

The Layout Manager Tab
The TabPage which holds the entire Layout Manager feature
The TreeView
Used to list the available layout for the component edited.
It is basically divided into 2 major nodes which are Predefined and Custom (user-defined layout).
The Command Panel
A panel which contains command buttons which are used to Add, Save, Apply and Preview layout.
The Web Browser
A browser inside Component Editor to provide integrated HTML-based user assistance, so the behavior and look of the component can be identified during design-time.


Working with Structure Manager

Working with Structure Manager
Send Feedback
Intersoft WebDesktop > Working with Component Editor > Working with Structure Manager

Glossary Item Box

Background

The Structure Manager is the third and last major feature available in Component Editor. This feature is only available for components which have structure. An example of a structure is Windows Collection in WebDesktopManager, this is named as the structure of the component.

This feature allows structure modification done to the component to be saved into an XML file by clicking on Save Button and can then be re-used by other components. This is one of the main distinguish of Intersoft component where the component object structure can be saved into a file and be loaded again when needed.

Without this feature you will need create your component structure from scratch again which is time consuming and prone to error especially in complex component structure.

UI Introduction

The Layout Manager Tab
The TabPage which holds the entire Structure Manager feature
The Structure TreeView
Used to list the available XML structure in the component's structure folder.
The structure folder resides in [InstallFolder]\Structure\[ComponentName].
The Command Panel
A panel which contains command buttons containing New, Load and Save.
When the New button is clicked the structure of the component will be cleared.
The Selected Structure Panel
A panel which contains information regarding the currently selected node in the Structure TreeView


Common Tasks

Common Tasks
Send Feedback
Intersoft WebDesktop > Common Tasks

Glossary Item Box

This section contains common tasks available in WebDesktop.NET.

In This Section

Creating Simple Desktop

Using IFrame as Default Content

Enabling ShortcutIcons feature

Using Window Options

Creating Dockable Toolbar

Using ToolCommand Types

Using Templated Command

Using Images for Toolbar Appearance

Creating Layout from Predefined Template

Creating Outlook 2003 Style Layout

Configuring Collapsible Pane

Disabling Resizing for specific Pane

Creating a New Project

Creating New Theme

Creating New Style

Deploying Theme Project

Configuring Closable Tab mode

Displaying confirmation box before TabItem is closed

Creating Visual Studio 2005 Style Tab

Saving and Loading Structure Programmatically

Creating NavPane with Images

Using BarItem for Content Navigation

Using Template and IFrame Content mode

Handling Client Side Events

Attaching ContextMenu to a Control

Working with MenuItem Types

Handling Command Client Side Events

Enabling and Disabling MenuItem

Using WebSplitter to split basic two cells

Using WebSplitter to split two rows

Using AllowCollapse feature

Creating Simple DialogBox

Designing custom DialogBox

Showing DialogBox at client side

Obtaining DialogResult at client side

Enabling Automatic Postback when clicked

Executing server side codes in FlyPostBack mode

Using ClientAction engine during FlyPostBack execution


Using Templated Command

Using Templated Command
See Also Send Feedback
Intersoft WebDesktop > Common Tasks > Using Templated Command

Glossary Item Box

Objectives

In previous tutorial [Using ToolCommand Types], it show some predefined WebToolBar command. Furthermore, WebToolBar also gives a flexibility to use a Customized Command which can be anything.

This tutorial will show you how to use a Templated command in WebToolBar (we will use WebCombo as customized command for WebToolBar). The steps are as follows:

  1. Drag WebToolBar to WebForm.

  2. Open WebToolBar's Property Window.
  3. In Behavior Property Set, Open ToolCommand Collection Editor at Command Property.

  4. Click "Add" to add New Item and "Remove" to Remove the Selected Item
  5. Change the ToolCommand Types to "Custom", find "Type" Property at the "ToolCommand Collection Editor"'s Property Window
  6. To add theTemplatedCommand Right click the WebToolBar and Expand Edit Template -> WebToolBar Items.

  7. This will show the Edit Template's sub window, where you can put any TemplatedCommand there.

  8. Drag WebCombo to Edit Template's sub window.

  9. When you done, Right click the Edit Template's sub window and Click End Template Editing.

  10. Run the Project and you will get something like this.

See Also

Related Articles
{Using ToolCommand Types}
{Creating Standalone Toolbar}


Configuring Collapsible Pane

Configuring Collapsible Pane
See Also Send Feedback
Intersoft WebDesktop > Common Tasks > Configuring Collapsible Pane

Glossary Item Box

Objectives

Configuring a Collapsible Pane is fairly simple. All you need to do in set the WebPane AllowCollapse property to Yes. The value of the property is an enumeration of type AllowCollapse which values are

C# Copy Code
/// <summary>
/// Enumerations for allow collapse.
/// </summary>
public enum AllowCollapse
{
    Default = 0,
    /// <summary>
    /// Element can be collapsed.
    /// </summary>
    Yes = 1,
    /// <summary>
    /// Element can't be collapsed.
    /// </summary>
    No = 2
}
  1. You can access that property during DesignTime either by right clicking the WebPaneManager and choosing WebPane Designer or WebPane Advanced Designer.
  2. In the snapshot below, the PaneSide AllowCollapse property is set to Yes so at run-time the Pane will be collapsible.

In the current version, the AllowCollapse property is dependant with the AllowResize property. When you set the AllowCollapse Property to Yes

See Also

Related Tutorials
{Creating Simple Layout}


Disabling Resizing for specific Pane

Disabling Resizing for specific Pane
See Also Send Feedback
Intersoft WebDesktop > Common Tasks > Disabling Resizing for specific Pane

Glossary Item Box

Objectives

Disabling Resizing for a specific Pane is fairly simple. All you need to do in set the WebPane AllowResize property to No. The value of the property is an enumeration of type AllowCollapse which values are

C# Copy Code
/// <summary>
/// Enumerations for allow resizing.
/// </summary>
public enum AllowResize
{
    Default = 0,
    /// <summary>
    /// Indicates that a container element such as Pane or Window is allowed to be resized by users.
    /// </summary>
    Yes = 1,
    /// <summary>
    /// Indicates that a container element such as Pane or Window is not allowed to be resized by users.
    /// </summary>
    No = 2
}
  1. You can access that property during DesignTime either by right clicking the WebPaneManager and choosing WebPane Designer or WebPane Advanced Designer.
  2. In the snapshot below, the PaneSide AllowResize property is set to No so at run-time the Pane will be un-resizable.

  3. After the property AllowResize is set to No, when you mouse over the border between the unresizable Pane and other Pane, the cursor will not change to splitter.

See Also

Related Tutorials
{Creating Simple Layout}


Server-side References

Server-side References
Send Feedback
Intersoft WebDesktop > Server-side References

Glossary Item Box

This section is designated to help user working with server-side references in WebDesktop.


ISNet.WebUI.WebDesktop Namespace

ISNet.WebUI.WebDesktop Namespace
See Also Inheritance Hierarchy Send Feedback

Glossary Item Box

Classes

 | Class | Description
Class | ActiveBarChangedEventArgs | Provides data for ActiveBar changed related event.
Class | ActiveBarItemChangedEventArgs | Provides data for ActiveBarItem changed related event.
Class | BarSectionStyle | The style properties of body bar section in the bar control.
Class | Command | List of WebToolBar Command Type properties.
Class | CommandCollection | Collection of WebToolBar's Command Type.
Class | IBarCollection | Collection of interfaces used by PlaceHolderManager. A PlaceHolderManager - which can be used with WebToolBar and WebMenuBar - represents a partitioned container in a WebForm which supports docking capabilities for IBar implemented controls.
Class | IBarEventArgs | Provides data for IBar related event.
Class | MenuCommand | List of menu command in WebMenuBar.
Class | MenuCommandClickEventArgs | Provides data for MenuCommand clicked related event.
Class | MenuCommandCollection | Collection of MenuCommand.
Class | NotificationProperties | Collection of notification properties used in WebNotification control.
Class | PaneItemClickEventArgs |
Class | PlaceHolderManager | Represents a partitioned container in a WebForm which supports docking capabilities for IBar implemented controls. PlaceHolderManager can be used with WebMenuBar and WebToolBar components.
Class | PlaceHolderManagerDesigner | The designer of PlaceHolderManager which allows users to work with dockable bars in the designer surface, similar to WinForm-style development experience.
Class | Property | Represents the property object used in NotificationProperties.
Class | ToggleGroup | Gets the collection of toggle group commands in WebToolBar.
Class | ToggleGroupCollection | Collection of ToggleGroup.
Class | ToolCommand | List of tool command in WebToolBar.
Class | ToolCommandClickEventArgs | Provides data for ToolCommand clicked related event.
Class | ToolCommandCollection | Collection of ToolCommand.
Class | UnitSize | The unit size of Window in pixel.
Class | UpdateControl | Collection of controls that will be automatically converted to use callback instead of full postback.
Class | WebBarStyleSettings | A collection of settings to customize the bar style in WebMenuBar and WebToolBar.
Class | WebButton | Intersoft's unique button component to complement the WebDesktop.NET which incorporates Framework's DynamicStyle to enable the rich interactive styles. WebButton supports DisplayMode feature which allows you to put a custom image at the left or right part of the WebButton.
Class | WebButtonClickedEventArgs | Provides data for WebButton clicked related event.
Class | WebButtonFlyPostBackSettings | A collection of settings used by the control when performing OnTheFly postback.
Class | WebCallOut | WebCallOut is an ASP.NET server control enabling you to create tooltip or callout that suits your style.
Class | WebCallOutClientSideEvents | Javascript functions which invoked from client side in WebCallOut.
Class | WebCallOutEventDataArgs |
Class | WebCallOutImagesSettings | A collection of images settings for WebCallOut object.
Class | WebContextMenu | WebContextMenu offers a MenuBar control functionality, an integration with DesktopManager bind with Server-side controls capability and completed with powerful Designer which will help the process of design time in a more convenient way.
Class | WebContextMenuClientSideEvents | Javascript functions which invoked from client side in WebContextMenu.
Class | WebDesktopClientSideEvents | Javascript functions which invoked from client side in WebDesktop.
Class | WebDesktopImagesSettings | A collection of images settings for WebDesktopWindow object.
Class | WebDesktopLoaderSettings | Provides settings for desktop loader.
Class | WebDesktopManager | WebDesktopManager is a member of the WebDesktop.NET which offers the Windows-like navigation system. Users can use and configure it easily since it has very powerful functions and features. WebDesktopManager has been carefully modeled into component for high reusability.
Class | WebDesktopMenuStyles | The predefined styles provided by WebDesktopManager.
Class | WebDesktopShortcut | Shortcut system implemented by the WebDesktopManager as an essential user interface element. This new Shortcut system implementation enriches the existing navigation system by bringing the user-friendly concept of a Desktop into web application development.
Class | WebDesktopShortcutCollection | Collection of WebDesktopShortcut.
Class | WebDesktopShortcutSettings | Collection of settings for desktop shortcut icons.
Class | WebDesktopTaskBarSettings | Collection of task bar settings for WebDesktopWindow object.
Class | WebDesktopTextSettings | Collection of text settings for WebDesktop object.
Class | WebDesktopWindow | The core and most essential user interface element in WebDesktopManager. In WebDesktopManager, a Window represents content which can be in-line contents using HTML markups or webform page using IFrame.
Class | WebDesktopWindowCollection | Collection of WebDesktopWindow.
Class | WebDesktopWindowSettings | Collection of settings for WebDesktopWindow object.
Class | WebDialogBox | The control that replicates the behavior of WebDesktop's dialog box. WebDialogBox offers unique dialog box UI functionalities with highly customizable appearances and styles. It simulates a true "modal" dialog which has closest behavior to desktop's dialog box.
Class | WebDialogBoxButton | Collection of command buttons used in WebDialogBox.
Class | WebDialogBoxButtonCollection | Collection of WebDialogBoxButton.
Class | WebDialogBoxClientSideEvents | Javascript functions which invoked from client side in WebDialogBox.
Class | WebDialogBoxImagesSettings | Collection of image settings for WebDialogBox object.
Class | WebDialogBoxTextSettings | Collection of text settings for WebDialogBox object.
Class | WebDialogBoxWindowSettings | Collection of window settings for WebDialogBox object.
Class | WebDragControl | Gets or sets the collection of drag-able controls.
Class | WebDragDropClientSideEvents | The collection of WebDragDrop's client-side events.
Class | WebDragDropEventArgs | Provides data for WebDragDrop related event.
Class | WebDragDropExtender | WebDragDropExtender is a component which allows you to easily perform drag-drop operation in a Web-based application.
Class | WebDragSettings | Contains a collection of properties controlling the drag-operation settings.
Class | WebDropControl | Get or sets the collection of drop-able controls.
Class | WebDropSettings | Contains a collection of properties controlling the drop-operation settings.
Class | WebExplorerBar | Represents a pane or collection of panes in the WebExplorerPane.
Class | WebExplorerBarCollection | Collection of WebExplorerBar.
Class | WebExplorerBarComplexImagesSettings | Contains images settings such as images to render the WebExplorerBar using RenderMode of ComplexImages.
Class | WebExplorerBarImagesSettings | Contains images settings such as images of expand/collapse to all type of WebExplorerBar.
Class | WebExplorerBarItem | Item or collection of items in the WebExplorerBar, similar like collection of panes in WebExplorerPane.
Class | WebExplorerBarItemCollection | Collection of WebExplorerBarItem.
Class | WebExplorerBarSettings | A collection of bar settings to customize the WebNavbar.
Class | WebExplorerClientSideEvents | Javascript functions which invoked from client side in WebExplorer.
Class | WebExplorerPane | WebExplorerPane is one of WebDesktop.NET member which allows you to create advanced navigation user interface with the richness of desktop's ExplorerPane in every details of styles and behaviors.
Class | WebExplorerPaneImagesSettings | Contains image settings such as images of expand/collapse to all type of WebExplorerBar.
Class | WebFlyPostBackListener | Listener function in WebFlyPostBack to listen or detect if there is any request from WebFlyPostBackManager.
Class | WebFlyPostBackManager | Standalone server side component that built on the top of FlyPostBack architecture, used as asynchronous calls (a.k.a. AJAX) to communicate with server side resources.
Class | WebFlyPostBackManagerClientSideEvents | Javascript functions which invoked from client side in WebFlyPostBackManager.
Class | WebFlyPostBackManagerSettings | A collection of fly-postback settings for WebDesktopWindow object.
Class | WebFlyPostBackMethodAttribute | Attribute representing a method which can be called by WebFlyPostBackManager.
Class | WebGroupPane | Collection of panes contain nested children of type WebPane or WebGroupPane. WebGroupPane can not contain server side controls.
Class | WebMenu | WebMenu is the core runtime system that builds up WebMenuBar and WebContextMenu control.
Class | WebMenuBar | WebMenuBar offers a MenuBar control functionality, an integration with PlaceHolderManager and completed with powerful Designer which will help the process of design time in a more convenient way.
Class | WebMenuImagesSettings | The class that contains images configuration used in WebMenu.
Class | WebMenuItem | Command menu item collection in WebMenuBar and WebContextMenu.
Class | WebMenuItemClickedEventArgs | Provides data for WebMenuItem clicked related event.
Class | WebMenuItemCollection | Collection of WebMenuItem.
Class | WebMenuRoot | Command menu root implementation in WebMenuBar.
Class | WebMenuStyles | Styles and behaviors that can be applied to WebMenu.
Class | WebNavBar | Collection of bars in WebNavPane which can be constructed in either design-time or runtime.
Class | WebNavBarCollection | Collection of WebNavBar.
Class | WebNavBarItem | Items in WebNavBar which mainly used as navigation links. The WebNavBarItem can be easily manipulated and accessed through Items collection provided by each WebNavBar object.
Class | WebNavBarItemCollection | Collection of WebNavBarItem.
Class | WebNavBarItemSettings | A collection of bar item settings to customize the WebNavbarItem.
Class | WebNavBarSettings | A collection of bar settings to configure the WebNavbar in global level.
Class | WebNavPane | WebNavPane is the server control object serving as the root container for WebNavBar objects as well as other available configurations. WebNavPane lets you create advanced navigation user interface with the richness of desktop's navigation.
Class | WebNavPaneFooterSettings | Collection of footer settings in WebNavPane. The settings are applicable when NavType is set to Outlook 2003.
Class | WebNavPaneItemSettings | Collection of settings to configure WebNavBarItem.
Class | WebNotification | WebNotification is a server control designed to retrieve new notifications from server side using object model.
Class | WebNotificationClientSideEvents | Javascript functions which invoked from client side in WebNotification.
Class | WebNotificationEvent | Contains the information required by WebNotification control to receive new notification events, which passed from the server side.
Class | WebNotificationEventArgs | Object that constructed internally at the client side of WebNotification and passed into the function as parameter value.
Class | WebNotificationEventCollection | Collection of WebNotificationEvent.
Class | WebNotificationImagesSettings | Collection of settings for images used by WebNotification control.
Class | WebPane | The lowest level object of WebPaneManager which represent a Pane. It can contain server side or html controls when used in UseInlineContent mode.
Class | WebPaneBase | List of settings to customize WebPane object.
Class | WebPaneClientSideEvents | Javascript functions which invoked from client side in WebPane.
Class | WebPaneCollection | Collection of WebPane.
Class | WebPaneImagesSettings | Collection of images settings for WebPaneManager.
Class | WebPaneManager | WebPaneManager is a component that allows you to easily manage the Pane structure. Using WebPaneManager you can quickly create simple layout to complex Office-style layout.
Class | WebPaneSettings | A collection of default settings for WebPaneManager.
Class | WebPaneSplitterSettings | A collection of default settings for the integration of WebPaneManager and WebSplitter.
Class | WebPaneTextSettings | Contains text settings used by the control.
Class | WebScrollBarStyle | The style you can apply to WebScrollBar.
Class | WebSplitter | The control which integrated with WebPaneManager and used to split or resize the pane in WebDesktop.
Class | WebTab | WebTab is a component which implements the appearances and rich behaviors of Tab in Dekstop application. The WebTab object represents the main operational area which contains a collection of tab items.
Class | WebTabChangedEventArgs | Provides data for WebTab changed related event.
Class | WebTabClientEvents | Client side events of WebTab that you can use to create interactions and extensible web applications.
Class | WebTabCollection | Collection of WebTab.
Class | WebTabComplexImagesSettings | The ComplexImages RenderMode option of WebTab which you can customize your WebTab appearance using images to be more stylish and complex.
Class | WebTabImageSettings | The image settings that applied to the WebTab.
Class | WebTabItem | Tab item or collection of tab items on WebTab.
Class | WebTabRoundCornerSettings | A collection of settings that related with WebTab's round corner. Using the RoundCornerSettings you can design a XP-like Tab control in any color schemes.
Class | WebTabStyle | The style you can apply to WebTab.
Class | WebTabTextSettings | Collection of text settings used by the Tab control.
Class | WebToolBar | Intersoft WebToolBar.NET WebControl for ASP.NET which offers most functionalities a ToolBar control should have, and integrated with a powerful designer which will ease the process of design time.
Class | WebWindowBorderStyle | Style of the border around the WebDesktopWindow.

Interfaces

 | Interface | Description
Interface | IBar | IBar interface. This Interface is used to support intersoft products development only, not to be used by developers.
Interface | ICommand | ICommand interface. This Interface is used to support intersoft products development only, not to be used by developers.
Interface | IDock | IDock interface. This Interface is used to support intersoft products development only, not to be used by developers.
Interface | IWebMenu | IWebMenu interface. This interface is used to support Intersoft products development only, not to be used by developers.
Interface | IWebMenuControl | IWebMenuControl interface. This Interface is used to support intersoft products development only, not to be used by developers.

Delegates

 | Delegate | Description
Delegate | ActiveBarChangedDelegate | Delegate that handle ActiveBarChanged event.
Delegate | ActiveBarItemChangedDelegate | Delegate that handle ActiveBarItemChanged event.
Delegate | IBarEventHandler | Delegate that handle IBar event.
Delegate | MenuCommandClickEventHandler | Delegate that handle CommandClick event in WebMenuBar.
Delegate | ToolCommandClickEventHandler | Delegate that handle CommandClick event in WebToolBar.
Delegate | WebButtonClickedEventHandler | Delegate that handle Clicked event in WebButton.
Delegate | WebCallOutOnShowEventHandler |
Delegate | WebMenuItemClickedEventHandler | Delegate that handle Clicked event in WebMenuItem.
Delegate | WebSplitter.GripClickedDelegate | Delegate that handle GripClick event in WebSplitter.
Delegate | WebTabChangedEventHandler | Delegate that handle TabChanged event in WebTab.

Enumerations

 | Enumeration | Description
Enumeration | AddRemoveOptionMenuViewMode | Gets or sets the add remove option menu view mode.
Enumeration | Alignment | Value representing the horizontal alignment of an element.
Enumeration | AllowCollapse | Value indicating whether users are allowed to collapse Panes through splitter.
Enumeration | AllowCustomize | Value indicating whether a control is customizable
Enumeration | AllowDock | Value indicating whether a control is dockable.
Enumeration | AllowExpandCollapse | Value indicating whether a bar control is expandable and collapsible.
Enumeration | AllowFloat | Value indicating whether a bar control is floatable.
Enumeration | AllowMaximize | Value indicating whether user is allowed to maximize Window.
Enumeration | AllowMinimize | Value indicating whether user is allowed to minimize Window.
Enumeration | AllowMove | Value indicating whether a bar control is moveable.
Enumeration | AllowResize | Value indicating whether panes are resizable.
Enumeration | AnimationSpeed | Value representing the speed of animation.
Enumeration | AutoPostBackMode | Value indicating whether a command is autopostback.
Enumeration | BarStyle | Value representing the style of Bar in WebMenuBar and WebToolBar.
Enumeration | BarTextAlign | Value representing bar commands text align type.
Enumeration | BorderType | Value representing the type of the border applied to Window.
Enumeration | ButtonAlignment | Value representing buttons alignment type in the dialog box.
Enumeration | ButtonDisplayMode | Value representing caption display mode for the button.
Enumeration | CloseBehavior |
Enumeration | CloseIndicatorPosition |
Enumeration | CloseMode | Value indicating whether users are allowed to close the Tab.
Enumeration | CollapseDirection | Value indicating the direction of panel's collapse.
Enumeration | CommandDisplayMode | Value representing the MenuCommand display mode.
Enumeration | CommandType | Value representing the command type.
Enumeration | ContainerType | Value representing the container type of WebSplitter.
Enumeration | ContentMode | Value representing the content mode used by a container.
Enumeration | ControlBox | Value indicating whether the control box for the Window is visible.
Enumeration | ControlBoxPosition |
Enumeration | ControlType |
Enumeration | CrossIFrameMode | Specifies the behavior when drag operation is performed across an IFrame element in a Web page.
Enumeration | DialogBoxButtonType | Value representing the type of button which will automatically perform built-in behavior accordingly.
Enumeration | DialogBoxImageType | Value representing the type of WebDialogBox image.
Enumeration | DialogBoxPosition | Value representing the position of WebDialogBox.
Enumeration | DimensionMode | Value indicating the dimension/sizing mode.
Enumeration | DisplayAccessKeyOnToolTip | Value indicating whether access key is displayed on command tooltip.
Enumeration | DisplayAlignment | Value representing element's display alignment.
Enumeration | DisplayMode | Value representing caption or footer display mode.
Enumeration | DisplayToolTip | Value indicating whether command tooltip is displayed.
Enumeration | DockingArea | Value representing the docking area for WebToolBar and WebMenuBar.
Enumeration | DragDataTypes | Specifies which data types are acceptable for a drag control to perform a drop operation.
Enumeration | DragDropEffects | Specifies the effect when drag-drop is performed.
Enumeration | DragVisualHint | Specifies the visual effect which is displayed during drag operation.
Enumeration | FillDockingRow | Value indicating whether a Bar control dimension fills the row region of PlaceHolderManager docking row.
Enumeration | FrameTarget | Value representing the target frame where the URL specified in TargetURL should be displayed.
Enumeration | GreyImageWhenDisabled | Value indicating whether a grey image is applied when command is disabled.
Enumeration | GroupPaneType | Value representing the group type of the GroupPane.
Enumeration | HandleVisible | Value indicating whether a bar handle is visible.
Enumeration | HeaderAppearanceMode | Value representing predefined style applied to the WebPane's header part.
Enumeration | IconViewDisplayMode | Value representing the display mode when the menu is operating in IconView mode.
Enumeration | ImagePosition | Value representing the position of the image relative to the text.
Enumeration | InfoTextPosition | Value representing the position of the InfoText part.
Enumeration | InteractivityMode | Specifies the interactivity type when a window is moved or resized in WebDesktopManager.
Enumeration | IsFloat | Value indicating whether Bar control is floated on the page.
Enumeration | LayoutMode |
Enumeration | LoaderMode | Value representing WebDesktopManager's loader mode.
Enumeration | MenuAnimationMode |
Enumeration | MenuAnimationType | Value representing animation type for showing popup menu.
Enumeration | MenuHighlightMode | Contains the options used to highlight the menu item.
Enumeration | MenuIntegrationMode | Value representing menu integration mode in WebToolBar, WebMenuBar or PlaceHolderManager.
Enumeration | MenuItemType | Value representing the type of the MenuItem.
Enumeration | NavBarContentMode | Value representing content mode of the NavBar.
Enumeration | NotificationAnimationStyle | Value representing the animation style for this notification control.
Enumeration | Orientation | Value representing the orientation of WebSplitter.
Enumeration | OrientationMode | Value representing window type to be used as the menu container.
Enumeration | PlaceHolderIntegrationMode | Value representing PlaceHolder integration mode.
Enumeration | PointingPosition |
Enumeration | PopupWindowType | Value representing the window type to be used as the menu container.
Enumeration | PostbackMode | Value indicating postback mode when the button is clicked and AutoPostback is enabled.
Enumeration | PreferredHorizontalPosition |
Enumeration | PreferredVerticalPosition |
Enumeration | RenderMode | Value representing the type of rendering mode that you can use to create professional Tab control in your web application.
Enumeration | ServiceType | Value representing the service type used by the notification control to request data.
Enumeration | ShortcutDisplayMode | Value representing display mode of the shortcut icons.
Enumeration | ShowBehavior |
Enumeration | SizeMode | Value representing the tool command sizing mode.
Enumeration | SpecificDragObjectEffects | Specifies the single effect applied to drag control.
Enumeration | TextAlignment | Value representing the type of command text alignment.
Enumeration | TextDirection | Value representing the direction of the text in each TabItem.
Enumeration | Theme |
Enumeration | ToggleGroupType | Value representing ToggleGroup type.
Enumeration | UIUpdateMode | Value representing the update behavior of automatic callback feature.
Enumeration | Visibility | Value indicating whether the element should be visible or not.
Enumeration | VisualTransitionEffect | Value representing visual transition effect used when the desktop has been loaded successfully.
Enumeration | WebCallOutContentMode |
Enumeration | WebNavImagePosition | Value representing the image position of NavBarItem.
Enumeration | WebNavType | Value representing the type of WebNavPane.
Enumeration | WindowAnimationStyle |
Enumeration | WindowArrangementMode | Value representing the arrangement mode for all windows.
Enumeration | WindowCaptionDisplayMode | Value representing display mode for the Caption.
Enumeration | WindowOptionsPosition |
Enumeration | WindowState | Value representing the initial state for Window.

See Also

Reference

ISNet.WebUI.WebDesktop Assembly


ISNet.WebUI.WebDesktop Namespace Inheritance Hierarchy

ISNet.WebUI.WebDesktop Namespace Inheritance Hierarchy
See Also Send Feedback

Glossary Item Box

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebDesktop.Property
ISNet.WebUI.WebDesktop.WebNotificationEvent
ISNet.WebUI.WebDesktop.WebNotificationEventArgs
ISNet.WebUI.WebDesktop.WebNotificationEventCollection
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.ClientEvents
ISNet.WebUI.WebDesktop.WebFlyPostBackManagerClientSideEvents
ISNet.WebUI.FlyPostBackSettings
ISNet.WebUI.WebDesktop.WebButtonFlyPostBackSettings
ISNet.WebUI.WebDesktop.WebFlyPostBackManagerSettings
ISNet.WebUI.NamedObjectBase
ISNet.WebUI.WebDesktop.Command
ISNet.WebUI.WebDesktop.MenuCommand
ISNet.WebUI.WebDesktop.ToolCommand
ISNet.WebUI.WebDesktop.ToggleGroup
ISNet.WebUI.WebDesktop.WebDesktopShortcut
ISNet.WebUI.WebDesktop.WebDesktopWindow
ISNet.WebUI.WebDesktop.WebDialogBoxButton
ISNet.WebUI.WebDesktop.WebMenuItem
ISNet.WebUI.WebDesktop.WebNavBar
ISNet.WebUI.WebDesktop.WebExplorerBar
ISNet.WebUI.WebDesktop.WebNavBarItem
ISNet.WebUI.WebDesktop.WebExplorerBarItem
ISNet.WebUI.WebDesktop.WebPaneBase
ISNet.WebUI.WebDesktop.WebGroupPane
ISNet.WebUI.WebDesktop.WebPane
ISNet.WebUI.WebDesktop.WebTabItem
ISNet.WebUI.WebDesktop.UnitSize
ISNet.WebUI.WebDesktop.UpdateControl
ISNet.WebUI.WebDesktop.WebBarStyleSettings
ISNet.WebUI.WebDesktop.WebCallOutClientSideEvents
ISNet.WebUI.WebDesktop.WebCallOutImagesSettings
ISNet.WebUI.WebDesktop.WebContextMenuClientSideEvents
ISNet.WebUI.WebDesktop.WebDesktopClientSideEvents
ISNet.WebUI.WebDesktop.WebDesktopImagesSettings
ISNet.WebUI.WebDesktop.WebDesktopLoaderSettings
ISNet.WebUI.WebDesktop.WebDesktopMenuStyles
ISNet.WebUI.WebDesktop.WebDesktopShortcutSettings
ISNet.WebUI.WebDesktop.WebDesktopTaskBarSettings
ISNet.WebUI.WebDesktop.WebDesktopTextSettings
ISNet.WebUI.WebDesktop.WebDesktopWindowSettings
ISNet.WebUI.WebDesktop.WebDialogBoxWindowSettings
ISNet.WebUI.WebDesktop.WebDialogBoxClientSideEvents
ISNet.WebUI.WebDesktop.WebDialogBoxImagesSettings
ISNet.WebUI.WebDesktop.WebDialogBoxTextSettings
ISNet.WebUI.WebDesktop.WebDragControl
ISNet.WebUI.WebDesktop.WebDragDropClientSideEvents
ISNet.WebUI.WebDesktop.WebDragSettings
ISNet.WebUI.WebDesktop.WebDropControl
ISNet.WebUI.WebDesktop.WebDropSettings
ISNet.WebUI.WebDesktop.WebExplorerBarComplexImagesSettings
ISNet.WebUI.WebDesktop.WebExplorerBarImagesSettings
ISNet.WebUI.WebDesktop.WebExplorerPaneImagesSettings
ISNet.WebUI.WebDesktop.WebExplorerClientSideEvents
ISNet.WebUI.WebDesktop.WebFlyPostBackListener
ISNet.WebUI.WebDesktop.WebMenu
ISNet.WebUI.WebDesktop.WebMenuRoot
ISNet.WebUI.WebDesktop.WebMenuImagesSettings
ISNet.WebUI.WebDesktop.WebMenuStyles
ISNet.WebUI.WebDesktop.WebNavBarSettings
ISNet.WebUI.WebDesktop.WebExplorerBarSettings
ISNet.WebUI.WebDesktop.WebNavPaneFooterSettings
ISNet.WebUI.WebDesktop.WebNavPaneItemSettings
ISNet.WebUI.WebDesktop.WebNavBarItemSettings
ISNet.WebUI.WebDesktop.WebNotificationClientSideEvents
ISNet.WebUI.WebDesktop.WebNotificationImagesSettings
ISNet.WebUI.WebDesktop.WebPaneClientSideEvents
ISNet.WebUI.WebDesktop.WebPaneImagesSettings
ISNet.WebUI.WebDesktop.WebPaneSettings
ISNet.WebUI.WebDesktop.WebPaneSplitterSettings
ISNet.WebUI.WebDesktop.WebPaneTextSettings
ISNet.WebUI.WebDesktop.WebScrollBarStyle
ISNet.WebUI.WebDesktop.WebTabClientEvents
ISNet.WebUI.WebDesktop.WebTabComplexImagesSettings
ISNet.WebUI.WebDesktop.WebTabImageSettings
ISNet.WebUI.WebDesktop.WebTabRoundCornerSettings
ISNet.WebUI.WebDesktop.WebTabTextSettings
System.Attribute
ISNet.WebUI.BaseFlyPostBackMethodAttribute
ISNet.WebUI.WebDesktop.WebFlyPostBackMethodAttribute
System.Collections.CollectionBase
ISNet.WebUI.ISCollectionBase
ISNet.WebUI.WebDesktop.CommandCollection
ISNet.WebUI.WebDesktop.MenuCommandCollection
ISNet.WebUI.WebDesktop.ToggleGroupCollection
ISNet.WebUI.WebDesktop.ToolCommandCollection
ISNet.WebUI.WebDesktop.WebDesktopShortcutCollection
ISNet.WebUI.WebDesktop.WebDesktopWindowCollection
ISNet.WebUI.WebDesktop.WebDialogBoxButtonCollection
ISNet.WebUI.WebDesktop.WebExplorerBarCollection
ISNet.WebUI.WebDesktop.WebExplorerBarItemCollection
ISNet.WebUI.WebDesktop.WebMenuItemCollection
ISNet.WebUI.WebDesktop.WebNavBarCollection
ISNet.WebUI.WebDesktop.WebNavBarItemCollection
ISNet.WebUI.WebDesktop.WebPaneCollection
ISNet.WebUI.WebDesktop.WebTabCollection
ISNet.WebUI.WebDesktop.IBarCollection
System.Collections.DictionaryBase
ISNet.WebUI.WebDesktop.NotificationProperties
System.ComponentModel.Design.ComponentDesigner
System.Web.UI.Design.HtmlControlDesigner
System.Web.UI.Design.ControlDesigner
ISNet.WebUI.ISDesignerBase
ISNet.WebUI.WebDesktop.PlaceHolderManagerDesigner
System.EventArgs
ISNet.WebUI.WebDesktop.ActiveBarChangedEventArgs
ISNet.WebUI.WebDesktop.ActiveBarItemChangedEventArgs
ISNet.WebUI.WebDesktop.IBarEventArgs
ISNet.WebUI.WebDesktop.MenuCommandClickEventArgs
ISNet.WebUI.WebDesktop.PaneItemClickEventArgs
ISNet.WebUI.WebDesktop.ToolCommandClickEventArgs
ISNet.WebUI.WebDesktop.WebButtonClickedEventArgs
ISNet.WebUI.WebDesktop.WebCallOutEventDataArgs
ISNet.WebUI.WebDesktop.WebDragDropEventArgs
ISNet.WebUI.WebDesktop.WebMenuItemClickedEventArgs
ISNet.WebUI.WebDesktop.WebTabChangedEventArgs
System.MarshalByRefObject
System.ComponentModel.Component
System.Web.UI.WebControls.Style
ISNet.WebUI.WebStyle
ISNet.WebUI.WebDesktop.BarSectionStyle
ISNet.WebUI.WebDesktop.WebTabStyle
ISNet.WebUI.WebDesktop.WebWindowBorderStyle
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
ISNet.WebUI.ISNetControl
ISNet.WebUI.WebDesktop.PlaceHolderManager
ISNet.WebUI.WebDesktop.WebButton
ISNet.WebUI.WebDesktop.WebCallOut
ISNet.WebUI.WebDesktop.WebContextMenu
ISNet.WebUI.WebDesktop.WebDesktopManager
ISNet.WebUI.WebDesktop.WebDialogBox
ISNet.WebUI.WebDesktop.WebDragDropExtender
ISNet.WebUI.WebDesktop.WebFlyPostBackManager
ISNet.WebUI.WebDesktop.WebMenuBar
ISNet.WebUI.WebDesktop.WebNavPane
ISNet.WebUI.WebDesktop.WebExplorerPane
ISNet.WebUI.WebDesktop.WebNotification
ISNet.WebUI.WebDesktop.WebPaneManager
ISNet.WebUI.WebDesktop.WebSplitter
ISNet.WebUI.WebDesktop.WebTab
ISNet.WebUI.WebDesktop.WebToolBar

See Also

Reference

ISNet.WebUI.WebDesktop Assembly


ActiveBarChangedEventArgs Class

[image]
Intersoft WebDesktop Documentation
ActiveBarChangedEventArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : ActiveBarChangedEventArgs Class

Glossary Item Box

Provides data for ActiveBar changed related event.

Object Model

ActiveBarChangedEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class ActiveBarChangedEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As ActiveBarChangedEventArgs
C#
public class ActiveBarChangedEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebDesktop.ActiveBarChangedEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActiveBarChangedEventArgs Members
ISNet.WebUI.WebDesktop Namespace


ActiveBarChangedEventArgs Class Members

[image]
Intersoft WebDesktop Documentation
ActiveBarChangedEventArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebDesktop Namespace : ActiveBarChangedEventArgs Class

Glossary Item Box

The following tables list the members exposed by ActiveBarChangedEventArgs.

Public Constructors

 | Name | Description
Public Constructor | ActiveBarChangedEventArgs Constructor | Initializes a new instance of the ActiveBarChangedEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | ActiveBar | Gets or sets the active NavBar.
Public Property | NewIndex | Gets or sets the new NavBar index.
Public Property | OldIndex | Gets or sets the old NavBar index.
Top

See Also

Reference

ActiveBarChangedEventArgs Class
ISNet.WebUI.WebDesktop Namespace


ActiveBarChangedEventArgs Constructor

[image]
Intersoft WebDesktop Documentation
ActiveBarChangedEventArgs Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ActiveBarChangedEventArgs Class : ActiveBarChangedEventArgs Constructor

navpane
oldIdx
newIdx

Glossary Item Box

Initializes a new instance of the ActiveBarChangedEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal navpane As WebNavPane, _
   ByVal oldIdx As Integer, _
   ByVal newIdx As Integer _
)
Visual Basic (Usage) Copy Code
Dim navpane As WebNavPane
Dim oldIdx As Integer
Dim newIdx As Integer

Dim instance As New ActiveBarChangedEventArgs(navpane, oldIdx, newIdx)
C#
public ActiveBarChangedEventArgs(
   WebNavPane navpane,
   int oldIdx,
   int newIdx
)

Parameters

navpane
oldIdx
newIdx

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActiveBarChangedEventArgs Class
ActiveBarChangedEventArgs Members


ActiveBarChangedEventArgs Class Properties

[image]
Intersoft WebDesktop Documentation
ActiveBarChangedEventArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : ActiveBarChangedEventArgs Class

Glossary Item Box

For a list of all members of this type, see ActiveBarChangedEventArgs members.

Public Properties

 | Name | Description
Public Property | ActiveBar | Gets or sets the active NavBar.
Public Property | NewIndex | Gets or sets the new NavBar index.
Public Property | OldIndex | Gets or sets the old NavBar index.
Top

See Also

Reference

ActiveBarChangedEventArgs Class
ISNet.WebUI.WebDesktop Namespace


ActiveBar Property

[image]
Intersoft WebDesktop Documentation
ActiveBar Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ActiveBarChangedEventArgs Class : ActiveBar Property

Glossary Item Box

Gets or sets the active NavBar.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ActiveBar As WebNavBar
Visual Basic (Usage) Copy Code
Dim instance As ActiveBarChangedEventArgs
Dim value As WebNavBar

value = instance.ActiveBar
C#
public WebNavBar ActiveBar {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActiveBarChangedEventArgs Class
ActiveBarChangedEventArgs Members


NewIndex Property

[image]
Intersoft WebDesktop Documentation
NewIndex Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ActiveBarChangedEventArgs Class : NewIndex Property

Glossary Item Box

Gets or sets the new NavBar index.

Syntax

Visual Basic (Declaration)
Public Property NewIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As ActiveBarChangedEventArgs
Dim value As Integer

instance.NewIndex = value

value = instance.NewIndex
C#
public int NewIndex {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActiveBarChangedEventArgs Class
ActiveBarChangedEventArgs Members


OldIndex Property

[image]
Intersoft WebDesktop Documentation
OldIndex Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ActiveBarChangedEventArgs Class : OldIndex Property

Glossary Item Box

Gets or sets the old NavBar index.

Syntax

Visual Basic (Declaration)
Public Property OldIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As ActiveBarChangedEventArgs
Dim value As Integer

instance.OldIndex = value

value = instance.OldIndex
C#
public int OldIndex {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActiveBarChangedEventArgs Class
ActiveBarChangedEventArgs Members


ActiveBarItemChangedEventArgs Class

[image]
Intersoft WebDesktop Documentation
ActiveBarItemChangedEventArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : ActiveBarItemChangedEventArgs Class

Glossary Item Box

Provides data for ActiveBarItem changed related event.

Object Model

ActiveBarItemChangedEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class ActiveBarItemChangedEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As ActiveBarItemChangedEventArgs
C#
public class ActiveBarItemChangedEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebDesktop.ActiveBarItemChangedEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActiveBarItemChangedEventArgs Members
ISNet.WebUI.WebDesktop Namespace


ActiveBarItemChangedEventArgs Class Members

[image]
Intersoft WebDesktop Documentation
ActiveBarItemChangedEventArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebDesktop Namespace : ActiveBarItemChangedEventArgs Class

Glossary Item Box

The following tables list the members exposed by ActiveBarItemChangedEventArgs.

Public Constructors

 | Name | Description
Public Constructor | ActiveBarItemChangedEventArgs Constructor | Initializes a new instance of the ActiveBarItemChangedEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | ActiveBar | Gets or sets the active NavBarItem.
Public Property | ActiveBarItem | Gets or sets the active NavBarItem.
Public Property | NewIndex | Gets or sets the new NavBarItem index.
Public Property | OldIndex | Gets or sets the old NavBarItem index.
Top

See Also

Reference

ActiveBarItemChangedEventArgs Class
ISNet.WebUI.WebDesktop Namespace


ActiveBarItemChangedEventArgs Constructor

[image]
Intersoft WebDesktop Documentation
ActiveBarItemChangedEventArgs Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ActiveBarItemChangedEventArgs Class : ActiveBarItemChangedEventArgs Constructor

navpane
navbar
oldIdx
newIdx

Glossary Item Box

Initializes a new instance of the ActiveBarItemChangedEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal navpane As WebNavPane, _
   ByVal navbar As WebNavBar, _
   ByVal oldIdx As Integer, _
   ByVal newIdx As Integer _
)
Visual Basic (Usage) Copy Code
Dim navpane As WebNavPane
Dim navbar As WebNavBar
Dim oldIdx As Integer
Dim newIdx As Integer

Dim instance As New ActiveBarItemChangedEventArgs(navpane, navbar, oldIdx, newIdx)
C#
public ActiveBarItemChangedEventArgs(
   WebNavPane navpane,
   WebNavBar navbar,
   int oldIdx,
   int newIdx
)

Parameters

navpane
navbar
oldIdx
newIdx

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActiveBarItemChangedEventArgs Class
ActiveBarItemChangedEventArgs Members


ActiveBarItemChangedEventArgs Class Properties

[image]
Intersoft WebDesktop Documentation
ActiveBarItemChangedEventArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : ActiveBarItemChangedEventArgs Class

Glossary Item Box

For a list of all members of this type, see ActiveBarItemChangedEventArgs members.

Public Properties

 | Name | Description
Public Property | ActiveBar | Gets or sets the active NavBarItem.
Public Property | ActiveBarItem | Gets or sets the active NavBarItem.
Public Property | NewIndex | Gets or sets the new NavBarItem index.
Public Property | OldIndex | Gets or sets the old NavBarItem index.
Top

See Also

Reference

ActiveBarItemChangedEventArgs Class
ISNet.WebUI.WebDesktop Namespace


ActiveBar Property

[image]
Intersoft WebDesktop Documentation
ActiveBar Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ActiveBarItemChangedEventArgs Class : ActiveBar Property

Glossary Item Box

Gets or sets the active NavBarItem.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ActiveBar As WebNavBar
Visual Basic (Usage) Copy Code
Dim instance As ActiveBarItemChangedEventArgs
Dim value As WebNavBar

value = instance.ActiveBar
C#
public WebNavBar ActiveBar {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActiveBarItemChangedEventArgs Class
ActiveBarItemChangedEventArgs Members


ActiveBarItem Property

[image]
Intersoft WebDesktop Documentation
ActiveBarItem Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ActiveBarItemChangedEventArgs Class : ActiveBarItem Property

Glossary Item Box

Gets or sets the active NavBarItem.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ActiveBarItem As WebNavBarItem
Visual Basic (Usage) Copy Code
Dim instance As ActiveBarItemChangedEventArgs
Dim value As WebNavBarItem

value = instance.ActiveBarItem
C#
public WebNavBarItem ActiveBarItem {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActiveBarItemChangedEventArgs Class
ActiveBarItemChangedEventArgs Members


NewIndex Property

[image]
Intersoft WebDesktop Documentation
NewIndex Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ActiveBarItemChangedEventArgs Class : NewIndex Property

Glossary Item Box

Gets or sets the new NavBarItem index.

Syntax

Visual Basic (Declaration)
Public Property NewIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As ActiveBarItemChangedEventArgs
Dim value As Integer

instance.NewIndex = value

value = instance.NewIndex
C#
public int NewIndex {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActiveBarItemChangedEventArgs Class
ActiveBarItemChangedEventArgs Members


OldIndex Property

[image]
Intersoft WebDesktop Documentation
OldIndex Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ActiveBarItemChangedEventArgs Class : OldIndex Property

Glossary Item Box

Gets or sets the old NavBarItem index.

Syntax

Visual Basic (Declaration)
Public Property OldIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As ActiveBarItemChangedEventArgs
Dim value As Integer

instance.OldIndex = value

value = instance.OldIndex
C#
public int OldIndex {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActiveBarItemChangedEventArgs Class
ActiveBarItemChangedEventArgs Members


BarSectionStyle Class

[image]
Intersoft WebDesktop Documentation
BarSectionStyle Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : BarSectionStyle Class

Glossary Item Box

The style properties of body bar section in the bar control.

Object Model

BarSectionStyle Class

Syntax

Visual Basic (Declaration)
Public Class BarSectionStyle
   Inherits ISNet.WebUI.WebStyle
   Implements ISNet.ICopyable, ISNet.IEmpty, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlLayoutSerialize
Visual Basic (Usage) Copy Code
Dim instance As BarSectionStyle
C#
public class BarSectionStyle : ISNet.WebUI.WebStyle, ISNet.ICopyable, ISNet.IEmpty, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlLayoutSerialize

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Web.UI.WebControls.Style
ISNet.WebUI.WebStyle
ISNet.WebUI.WebDesktop.BarSectionStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarSectionStyle Members
ISNet.WebUI.WebDesktop Namespace


BarSectionStyle Class Members

[image]
Intersoft WebDesktop Documentation
BarSectionStyle Class Members
See Also Fields Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : BarSectionStyle Class

Glossary Item Box

The following tables list the members exposed by BarSectionStyle.

Public Constructors

 | Name | Description
Public Constructor | BarSectionStyle Constructor |
Top

Public Fields

 | Name | Description
Public Field | dynamicStyle | (Inherited from ISNet.WebUI.WebStyle)
Public Field | layoutKey | (Inherited from ISNet.WebUI.WebStyle)
Public Field | styleState | (Inherited from ISNet.WebUI.WebStyle)
Top

Public Properties

 | Name | Description
Public Property | BackColor | Overridden. Background color of the controls applied with this style.
Public Property | BackColor2 | Overridden. End background color of the controls applied with this style. When specified, gradient back color will be rendered from BackColor to BackColor2.
Public Property | BackgroundImageHorizontal | Gets or sets the background image with horizontal direction.
Public Property | BackgroundImageVertical | Gets or sets the background image with vertical direction.
Public Property | ForeColor | Overridden. Foreground color of the controls applied with this style.
Public Property | GradientType | Specifies the gradient type for back color when BackColor2 is specified.
Top

Public Methods

 | Name | Description
Public Method | AddAttributesToRender | Overloaded. (Inherited from System.Web.UI.WebControls.Style)
Public Method | Clone | (Inherited from ISNet.WebUI.WebStyle)
Public Method | CopyFrom | Overloaded.
Public Method | CopyFromNative | (Inherited from ISNet.WebUI.WebStyle)
Public Method | CopyMerge | (Inherited from ISNet.WebUI.WebStyle)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | CreateXmlNode |
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebStyle)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetMergedCssStyleName | (Inherited from ISNet.WebUI.WebStyle)
Public Method | GetObjectData | Overridden.
Public Method | GetStyleAttributes | (Inherited from System.Web.UI.WebControls.Style)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | IsEmpty | Overridden.
Public Method | IsFontEmpty | (Inherited from ISNet.WebUI.WebStyle)
Public Method | IsStyleEmpty | (Inherited from ISNet.WebUI.WebStyle)
Public Method | MergeWith | (Inherited from System.Web.UI.WebControls.Style)
Public Method | Reset | (Inherited from ISNet.WebUI.WebStyle)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebStyle)
Public Method | SetDirty | (Inherited from System.Web.UI.WebControls.Style)
Public Method | ToString | (Inherited from ISNet.WebUI.WebStyle)
Top

See Also

Reference

BarSectionStyle Class
ISNet.WebUI.WebDesktop Namespace


BarSectionStyle Class Fields

[image]
Intersoft WebDesktop Documentation
BarSectionStyle Class Fields
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : BarSectionStyle Class

Glossary Item Box

For a list of all members of this type, see BarSectionStyle members.

Public Fields

 | Name | Description
Public Field | dynamicStyle | (Inherited from ISNet.WebUI.WebStyle)
Public Field | layoutKey | (Inherited from ISNet.WebUI.WebStyle)
Public Field | styleState | (Inherited from ISNet.WebUI.WebStyle)
Top

See Also

Reference

BarSectionStyle Class
ISNet.WebUI.WebDesktop Namespace


BarSectionStyle Constructor

[image]
Intersoft WebDesktop Documentation
BarSectionStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > BarSectionStyle Class : BarSectionStyle Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New BarSectionStyle()
C#
public BarSectionStyle()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarSectionStyle Class
BarSectionStyle Members


AddAttributesToRender Method

[image]
Intersoft WebDesktop Documentation
AddAttributesToRender Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > BarSectionStyle Class : AddAttributesToRender Method

Glossary Item Box

Overload List

Overload | Description
AddAttributesToRender(HtmlTextWriter) | (Inherited from System.Web.UI.WebControls.Style)
AddAttributesToRender(HtmlTextWriter,WebControl) | (Inherited from System.Web.UI.WebControls.Style)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarSectionStyle Class
BarSectionStyle Members


AddAttributesToRender(HtmlTextWriter) Method

[image]
Intersoft WebDesktop Documentation
AddAttributesToRender(HtmlTextWriter) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > BarSectionStyle Class > AddAttributesToRender Method : AddAttributesToRender(HtmlTextWriter) Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddAttributesToRender( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As BarSectionStyle
Dim writer As System.Web.UI.HtmlTextWriter

instance.AddAttributesToRender(writer)
C#
public void AddAttributesToRender(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarSectionStyle Class
BarSectionStyle Members
Overload List


AddAttributesToRender(HtmlTextWriter,WebControl) Method

[image]
Intersoft WebDesktop Documentation
AddAttributesToRender(HtmlTextWriter,WebControl) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > BarSectionStyle Class > AddAttributesToRender Method : AddAttributesToRender(HtmlTextWriter,WebControl) Method

writer
owner

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub AddAttributesToRender( _
   ByVal writer As System.Web.UI.HtmlTextWriter, _
   ByVal owner As System.Web.UI.WebControls.WebControl _
)
Visual Basic (Usage) Copy Code
Dim instance As BarSectionStyle
Dim writer As System.Web.UI.HtmlTextWriter
Dim owner As System.Web.UI.WebControls.WebControl

instance.AddAttributesToRender(writer, owner)
C#
public virtual void AddAttributesToRender(
   System.Web.UI.HtmlTextWriter writer,
   System.Web.UI.WebControls.WebControl owner
)

Parameters

writer
owner

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarSectionStyle Class
BarSectionStyle Members
Overload List


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > BarSectionStyle Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As BarSectionStyle
Dim value As Object

value = instance.Clone()
C#
public object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarSectionStyle Class
BarSectionStyle Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > BarSectionStyle Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Style) | (Inherited from ISNet.WebUI.WebStyle)
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebStyle)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebStyle)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarSectionStyle Class
BarSectionStyle Members


CopyFrom(Style) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Style) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > BarSectionStyle Class > CopyFrom Method : CopyFrom(Style) Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As BarSectionStyle
Dim s As System.Web.UI.WebControls.Style

instance.CopyFrom(s)
C#
public virtual void CopyFrom(
   System.Web.UI.WebControls.Style s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarSectionStyle Class
BarSectionStyle Members
Overload List


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > BarSectionStyle Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As BarSectionStyle
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarSectionStyle Class
BarSectionStyle Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > BarSectionStyle Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As BarSectionStyle
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarSectionStyle Class
BarSectionStyle Members
Overload List


CopyFromNative Method

[image]
Intersoft WebDesktop Documentation
CopyFromNative Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > BarSectionStyle Class : CopyFromNative Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub CopyFromNative( _
   ByVal s As ISNet.WebUI.WebStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As BarSectionStyle
Dim s As ISNet.WebUI.WebStyle

instance.CopyFromNative(s)
C#
public virtual void CopyFromNative(
   ISNet.WebUI.WebStyle s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarSectionStyle Class
BarSectionStyle Members


CopyMerge Method

[image]
Intersoft WebDesktop Documentation
CopyMerge Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > BarSectionStyle Class : CopyMerge Method

style

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyMerge( _
   ByVal style As ISNet.WebUI.WebStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As BarSectionStyle
Dim style As ISNet.WebUI.WebStyle

instance.CopyMerge(style)
C#
public void CopyMerge(
   ISNet.WebUI.WebStyle style
)

Parameters

style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarSectionStyle Class
BarSectionStyle Members


CreateObjRef Method

[image]
Intersoft WebDesktop Documentation
CreateObjRef Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > BarSectionStyle Class : CreateObjRef Method

requestedType

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function CreateObjRef( _
   ByVal requestedType As Type _
) As System.Runtime.Remoting.ObjRef
Visual Basic (Usage) Copy Code
Dim instance As BarSectionStyle
Dim requestedType As Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
C#
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   Type requestedType
)

Parameters

requestedType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarSectionStyle Class
BarSectionStyle Members


BarSectionStyle Class Methods

[image]
Intersoft WebDesktop Documentation
BarSectionStyle Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : BarSectionStyle Class

Glossary Item Box

For a list of all members of this type, see BarSectionStyle members.

Public Methods

 | Name | Description
Public Method | AddAttributesToRender | Overloaded. (Inherited from System.Web.UI.WebControls.Style)
Public Method | Clone | (Inherited from ISNet.WebUI.WebStyle)
Public Method | CopyFrom | Overloaded.
Public Method | CopyFromNative | (Inherited from ISNet.WebUI.WebStyle)
Public Method | CopyMerge | (Inherited from ISNet.WebUI.WebStyle)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | CreateXmlNode |
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebStyle)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetMergedCssStyleName | (Inherited from ISNet.WebUI.WebStyle)
Public Method | GetObjectData | Overridden.
Public Method | GetStyleAttributes | (Inherited from System.Web.UI.WebControls.Style)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | IsEmpty | Overridden.
Public Method | IsFontEmpty | (Inherited from ISNet.WebUI.WebStyle)
Public Method | IsStyleEmpty | (Inherited from ISNet.WebUI.WebStyle)
Public Method | MergeWith | (Inherited from System.Web.UI.WebControls.Style)
Public Method | Reset | (Inherited from ISNet.WebUI.WebStyle)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebStyle)
Public Method | SetDirty | (Inherited from System.Web.UI.WebControls.Style)
Public Method | ToString | (Inherited from ISNet.WebUI.WebStyle)
Top

See Also

Reference

BarSectionStyle Class
ISNet.WebUI.WebDesktop Namespace


CreateXmlNode Method

[image]
Intersoft WebDesktop Documentation
CreateXmlNode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > BarSectionStyle Class : CreateXmlNode Method

nodeName
doc
parentNode

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CreateXmlNode( _
   ByVal nodeName As String, _
   ByVal doc As System.Xml.XmlDocument, _
   ByVal parentNode As System.Xml.XmlNode _
)
Visual Basic (Usage) Copy Code
Dim instance As BarSectionStyle
Dim nodeName As String
Dim doc As System.Xml.XmlDocument
Dim parentNode As System.Xml.XmlNode

instance.CreateXmlNode(nodeName, doc, parentNode)
C#
public void CreateXmlNode(
   string nodeName,
   System.Xml.XmlDocument doc,
   System.Xml.XmlNode parentNode
)

Parameters

nodeName
doc
parentNode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarSectionStyle Class
BarSectionStyle Members


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > BarSectionStyle Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As BarSectionStyle
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarSectionStyle Class
BarSectionStyle Members


Dispose Method

[image]
Intersoft WebDesktop Documentation
Dispose Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > BarSectionStyle Class : Dispose Method

Glossary Item Box

Overload List

Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarSectionStyle Class
BarSectionStyle Members


Dispose() Method

[image]
Intersoft WebDesktop Documentation
Dispose() Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > BarSectionStyle Class : Dispose() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As BarSectionStyle

instance.Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarSectionStyle Class
BarSectionStyle Members


GetLifetimeService Method

[image]
Intersoft WebDesktop Documentation
GetLifetimeService Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > BarSectionStyle Class : GetLifetimeService Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As BarSectionStyle
Dim value As Object

value = instance.GetLifetimeService()
C#
public object GetLifetimeService()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarSectionStyle Class
BarSectionStyle Members


GetMergedCssStyleName Method

[image]
Intersoft WebDesktop Documentation
GetMergedCssStyleName Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > BarSectionStyle Class : GetMergedCssStyleName Method

finalKey

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetMergedCssStyleName( _
   ByVal finalKey As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As BarSectionStyle
Dim finalKey As String
Dim value As String

value = instance.GetMergedCssStyleName(finalKey)
C#
public string GetMergedCssStyleName(
   string finalKey
)

Parameters

finalKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarSectionStyle Class
BarSectionStyle Members


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > BarSectionStyle Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As BarSectionStyle
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarSectionStyle Class
BarSectionStyle Members


GetStyleAttributes Method

[image]
Intersoft WebDesktop Documentation
GetStyleAttributes Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > BarSectionStyle Class : GetStyleAttributes Method

urlResolver

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetStyleAttributes( _
   ByVal urlResolver As System.Web.UI.IUrlResolutionService _
) As System.Web.UI.CssStyleCollection
Visual Basic (Usage) Copy Code
Dim instance As BarSectionStyle
Dim urlResolver As System.Web.UI.IUrlResolutionService
Dim value As System.Web.UI.CssStyleCollection

value = instance.GetStyleAttributes(urlResolver)
C#
public System.Web.UI.CssStyleCollection GetStyleAttributes(
   System.Web.UI.IUrlResolutionService urlResolver
)

Parameters

urlResolver

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarSectionStyle Class
BarSectionStyle Members


InitializeLifetimeService Method

[image]
Intersoft WebDesktop Documentation
InitializeLifetimeService Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > BarSectionStyle Class : InitializeLifetimeService Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function InitializeLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As BarSectionStyle
Dim value As Object

value = instance.InitializeLifetimeService()
C#
public virtual object InitializeLifetimeService()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarSectionStyle Class
BarSectionStyle Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > BarSectionStyle Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BarSectionStyle
Dim value As Boolean

value = instance.IsEmpty()
C#
public override bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarSectionStyle Class
BarSectionStyle Members


IsFontEmpty Method

[image]
Intersoft WebDesktop Documentation
IsFontEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > BarSectionStyle Class : IsFontEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFontEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BarSectionStyle
Dim value As Boolean

value = instance.IsFontEmpty()
C#
public virtual bool IsFontEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarSectionStyle Class
BarSectionStyle Members


IsStyleEmpty Method

[image]
Intersoft WebDesktop Documentation
IsStyleEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > BarSectionStyle Class : IsStyleEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsStyleEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BarSectionStyle
Dim value As Boolean

value = instance.IsStyleEmpty()
C#
public virtual bool IsStyleEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarSectionStyle Class
BarSectionStyle Members


MergeWith Method

[image]
Intersoft WebDesktop Documentation
MergeWith Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > BarSectionStyle Class : MergeWith Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub MergeWith( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As BarSectionStyle
Dim s As System.Web.UI.WebControls.Style

instance.MergeWith(s)
C#
public virtual void MergeWith(
   System.Web.UI.WebControls.Style s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarSectionStyle Class
BarSectionStyle Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > BarSectionStyle Class : Reset Method

Glossary Item Box

Overload List

Overload | Description
Reset | (Inherited from ISNet.WebUI.WebStyle)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarSectionStyle Class
BarSectionStyle Members


Reset() Method

[image]
Intersoft WebDesktop Documentation
Reset() Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > BarSectionStyle Class : Reset() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As BarSectionStyle

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarSectionStyle Class
BarSectionStyle Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > BarSectionStyle Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As BarSectionStyle
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarSectionStyle Class
BarSectionStyle Members


SetDirty Method

[image]
Intersoft WebDesktop Documentation
SetDirty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > BarSectionStyle Class : SetDirty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetDirty()
Visual Basic (Usage) Copy Code
Dim instance As BarSectionStyle

instance.SetDirty()
C#
public void SetDirty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarSectionStyle Class
BarSectionStyle Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > BarSectionStyle Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As BarSectionStyle
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarSectionStyle Class
BarSectionStyle Members


BarSectionStyle Class Properties

[image]
Intersoft WebDesktop Documentation
BarSectionStyle Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : BarSectionStyle Class

Glossary Item Box

For a list of all members of this type, see BarSectionStyle members.

Public Properties

 | Name | Description
Public Property | BackColor | Overridden. Background color of the controls applied with this style.
Public Property | BackColor2 | Overridden. End background color of the controls applied with this style. When specified, gradient back color will be rendered from BackColor to BackColor2.
Public Property | BackgroundImageHorizontal | Gets or sets the background image with horizontal direction.
Public Property | BackgroundImageVertical | Gets or sets the background image with vertical direction.
Public Property | ForeColor | Overridden. Foreground color of the controls applied with this style.
Public Property | GradientType | Specifies the gradient type for back color when BackColor2 is specified.
Top

See Also

Reference

BarSectionStyle Class
ISNet.WebUI.WebDesktop Namespace


BarSectionStyle Constructor

[image]
Intersoft WebDesktop Documentation
BarSectionStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > BarSectionStyle Class : BarSectionStyle Constructor

Glossary Item Box

Initializes a new instance of the BarSectionStyle class.

Overload List

Overload | Description
BarSectionStyle Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarSectionStyle Class
BarSectionStyle Members


BackColor Property

[image]
Intersoft WebDesktop Documentation
BackColor Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > BarSectionStyle Class : BackColor Property

Glossary Item Box

Background color of the controls applied with this style.

Syntax

Visual Basic (Declaration)
Public Overrides Property BackColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As BarSectionStyle
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
C#
public override System.Drawing.Color BackColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarSectionStyle Class
BarSectionStyle Members


BackColor2 Property

[image]
Intersoft WebDesktop Documentation
BackColor2 Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > BarSectionStyle Class : BackColor2 Property

Glossary Item Box

End background color of the controls applied with this style. When specified, gradient back color will be rendered from BackColor to BackColor2.

Syntax

Visual Basic (Declaration)
Public Overrides Property BackColor2 As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As BarSectionStyle
Dim value As System.Drawing.Color

instance.BackColor2 = value

value = instance.BackColor2
C#
public override System.Drawing.Color BackColor2 {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarSectionStyle Class
BarSectionStyle Members


BackgroundImageHorizontal Property

[image]
Intersoft WebDesktop Documentation
BackgroundImageHorizontal Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > BarSectionStyle Class : BackgroundImageHorizontal Property

Glossary Item Box

Gets or sets the background image with horizontal direction.

Syntax

Visual Basic (Declaration)
Public Property BackgroundImageHorizontal As String
Visual Basic (Usage) Copy Code
Dim instance As BarSectionStyle
Dim value As String

instance.BackgroundImageHorizontal = value

value = instance.BackgroundImageHorizontal
C#
public string BackgroundImageHorizontal {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarSectionStyle Class
BarSectionStyle Members


BackgroundImageVertical Property

[image]
Intersoft WebDesktop Documentation
BackgroundImageVertical Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > BarSectionStyle Class : BackgroundImageVertical Property

Glossary Item Box

Gets or sets the background image with vertical direction.

Syntax

Visual Basic (Declaration)
Public Property BackgroundImageVertical As String
Visual Basic (Usage) Copy Code
Dim instance As BarSectionStyle
Dim value As String

instance.BackgroundImageVertical = value

value = instance.BackgroundImageVertical
C#
public string BackgroundImageVertical {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarSectionStyle Class
BarSectionStyle Members


ForeColor Property

[image]
Intersoft WebDesktop Documentation
ForeColor Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > BarSectionStyle Class : ForeColor Property

Glossary Item Box

Foreground color of the controls applied with this style.

Syntax

Visual Basic (Declaration)
Public Overrides Property ForeColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As BarSectionStyle
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
C#
public override System.Drawing.Color ForeColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarSectionStyle Class
BarSectionStyle Members


GradientType Property

[image]
Intersoft WebDesktop Documentation
GradientType Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > BarSectionStyle Class : GradientType Property

Glossary Item Box

Specifies the gradient type for back color when BackColor2 is specified.

Syntax

Visual Basic (Declaration)
Public Shadows Property GradientType As ISNet.WebUI.GradientType
Visual Basic (Usage) Copy Code
Dim instance As BarSectionStyle
Dim value As ISNet.WebUI.GradientType

instance.GradientType = value

value = instance.GradientType
C#
public new ISNet.WebUI.GradientType GradientType {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarSectionStyle Class
BarSectionStyle Members


dynamicStyle Field

[image]
Intersoft WebDesktop Documentation
dynamicStyle Field
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > BarSectionStyle Class : dynamicStyle Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public dynamicStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As BarSectionStyle
Dim value As ISNet.WebUI.DynamicStyle

value = instance.dynamicStyle

instance.dynamicStyle = value
C#
public ISNet.WebUI.DynamicStyle dynamicStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarSectionStyle Class
BarSectionStyle Members


layoutKey Field

[image]
Intersoft WebDesktop Documentation
layoutKey Field
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > BarSectionStyle Class : layoutKey Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public layoutKey As String
Visual Basic (Usage) Copy Code
Dim instance As BarSectionStyle
Dim value As String

value = instance.layoutKey

instance.layoutKey = value
C#
public string layoutKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarSectionStyle Class
BarSectionStyle Members


styleState Field

[image]
Intersoft WebDesktop Documentation
styleState Field
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > BarSectionStyle Class : styleState Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public styleState As String
Visual Basic (Usage) Copy Code
Dim instance As BarSectionStyle
Dim value As String

value = instance.styleState

instance.styleState = value
C#
public string styleState

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarSectionStyle Class
BarSectionStyle Members


Command Class

[image]
Intersoft WebDesktop Documentation
Command Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : Command Class

Glossary Item Box

List of WebToolBar Command Type properties.

Object Model

Command Class

Syntax

Visual Basic (Declaration)
Public Class Command
   Inherits ISNet.WebUI.NamedObjectBase
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject, ICommand
Visual Basic (Usage) Copy Code
Dim instance As Command
C#
public class Command : ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject, ICommand

Remarks

You can customize the WebToolBar's Command Type properties using WebToolBar Designer. You can add/remove/re-order and manage the command properties. For better understanding and illustration please refer to Working with ToolBar Designer.

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase
ISNet.WebUI.WebDesktop.Command
ISNet.WebUI.WebDesktop.MenuCommand
ISNet.WebUI.WebDesktop.ToolCommand

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Command Members
ISNet.WebUI.WebDesktop Namespace

Concepts

Working with ToolBar Designer


Command Class Members

[image]
Intersoft WebDesktop Documentation
Command Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : Command Class

Glossary Item Box

The following tables list the members exposed by Command.

Public Constructors

 | Name | Description
Public Constructor | Command Constructor |
Top

Public Properties

 | Name | Description
Public Property | AccessKey |
Public Property | AutoCheck |
Public Property | AutoPostBack |
Public Property | Category |
Public Property | Checked |
Public Property | CommandSize |
Public Property | DisplayAccessKeyOnToolTip |
Public Property | DisplayMode |
Public Property | DisplayToolTip |
Public Property | Image |
Public Property | ImageSize |
Public Property | IsEnabled |
Public Property | MergeCommandID |
Public Property | Name | Overridden. Specifies the ToolCommand name.
Public Property | Text |
Public Property | TextAlign |
Public Property | ToggleGroupName |
Public Property | ToolTip |
Public Property | Type | Gets or sets command type.
Public Property | Visible |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

Command Class
ISNet.WebUI.WebDesktop Namespace

Concepts

Working with ToolBar Designer


Command Constructor

[image]
Intersoft WebDesktop Documentation
Command Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > Command Class : Command Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New Command()
C#
public Command()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Command Class
Command Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > Command Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As Command
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Command Class
Command Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > Command Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Command Class
Command Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > Command Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As Command
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Command Class
Command Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > Command Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As Command
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Command Class
Command Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > Command Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As Command
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Command Class
Command Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > Command Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As Command
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Command Class
Command Members


Command Class Methods

[image]
Intersoft WebDesktop Documentation
Command Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : Command Class

Glossary Item Box

For a list of all members of this type, see Command members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

Command Class
ISNet.WebUI.WebDesktop Namespace

Concepts

Working with ToolBar Designer


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > Command Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As Command
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Command Class
Command Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > Command Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Command
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Command Class
Command Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > Command Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As Command

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Command Class
Command Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > Command Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As Command
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Command Class
Command Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > Command Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As Command
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Command Class
Command Members


Command Class Properties

[image]
Intersoft WebDesktop Documentation
Command Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : Command Class

Glossary Item Box

For a list of all members of this type, see Command members.

Public Properties

 | Name | Description
Public Property | AccessKey |
Public Property | AutoCheck |
Public Property | AutoPostBack |
Public Property | Category |
Public Property | Checked |
Public Property | CommandSize |
Public Property | DisplayAccessKeyOnToolTip |
Public Property | DisplayMode |
Public Property | DisplayToolTip |
Public Property | Image |
Public Property | ImageSize |
Public Property | IsEnabled |
Public Property | MergeCommandID |
Public Property | Name | Overridden. Specifies the ToolCommand name.
Public Property | Text |
Public Property | TextAlign |
Public Property | ToggleGroupName |
Public Property | ToolTip |
Public Property | Type | Gets or sets command type.
Public Property | Visible |
Top

See Also

Reference

Command Class
ISNet.WebUI.WebDesktop Namespace

Concepts

Working with ToolBar Designer


Command Constructor

[image]
Intersoft WebDesktop Documentation
Command Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > Command Class : Command Constructor

Glossary Item Box

Initializes a new instance of the Command class.

Overload List

Overload | Description
Command Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Command Class
Command Members


AccessKey Property

[image]
Intersoft WebDesktop Documentation
AccessKey Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > Command Class : AccessKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property AccessKey As String
Visual Basic (Usage) Copy Code
Dim instance As Command
Dim value As String

instance.AccessKey = value

value = instance.AccessKey
C#
public virtual string AccessKey {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Command Class
Command Members


AutoCheck Property

[image]
Intersoft WebDesktop Documentation
AutoCheck Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > Command Class : AutoCheck Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property AutoCheck As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Command
Dim value As Boolean

instance.AutoCheck = value

value = instance.AutoCheck
C#
public virtual bool AutoCheck {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Command Class
Command Members


AutoPostBack Property

[image]
Intersoft WebDesktop Documentation
AutoPostBack Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > Command Class : AutoPostBack Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property AutoPostBack As AutoPostBackMode
Visual Basic (Usage) Copy Code
Dim instance As Command
Dim value As AutoPostBackMode

instance.AutoPostBack = value

value = instance.AutoPostBack
C#
public virtual AutoPostBackMode AutoPostBack {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Command Class
Command Members


Category Property

[image]
Intersoft WebDesktop Documentation
Category Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > Command Class : Category Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Category As String
Visual Basic (Usage) Copy Code
Dim instance As Command
Dim value As String

instance.Category = value

value = instance.Category
C#
public virtual string Category {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Command Class
Command Members


Checked Property

[image]
Intersoft WebDesktop Documentation
Checked Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > Command Class : Checked Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Checked As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Command
Dim value As Boolean

instance.Checked = value

value = instance.Checked
C#
public virtual bool Checked {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Command Class
Command Members


CommandSize Property

[image]
Intersoft WebDesktop Documentation
CommandSize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > Command Class : CommandSize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property CommandSize As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As Command
Dim value As System.Web.UI.WebControls.Unit

instance.CommandSize = value

value = instance.CommandSize
C#
public virtual System.Web.UI.WebControls.Unit CommandSize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Command Class
Command Members


DisplayAccessKeyOnToolTip Property

[image]
Intersoft WebDesktop Documentation
DisplayAccessKeyOnToolTip Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > Command Class : DisplayAccessKeyOnToolTip Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property DisplayAccessKeyOnToolTip As DisplayAccessKeyOnToolTip
Visual Basic (Usage) Copy Code
Dim instance As Command
Dim value As DisplayAccessKeyOnToolTip

instance.DisplayAccessKeyOnToolTip = value

value = instance.DisplayAccessKeyOnToolTip
C#
public DisplayAccessKeyOnToolTip DisplayAccessKeyOnToolTip {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Command Class
Command Members


DisplayMode Property

[image]
Intersoft WebDesktop Documentation
DisplayMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > Command Class : DisplayMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property DisplayMode As CommandDisplayMode
Visual Basic (Usage) Copy Code
Dim instance As Command
Dim value As CommandDisplayMode

instance.DisplayMode = value

value = instance.DisplayMode
C#
public CommandDisplayMode DisplayMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Command Class
Command Members


DisplayToolTip Property

[image]
Intersoft WebDesktop Documentation
DisplayToolTip Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > Command Class : DisplayToolTip Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property DisplayToolTip As DisplayToolTip
Visual Basic (Usage) Copy Code
Dim instance As Command
Dim value As DisplayToolTip

instance.DisplayToolTip = value

value = instance.DisplayToolTip
C#
public DisplayToolTip DisplayToolTip {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Command Class
Command Members


Image Property

[image]
Intersoft WebDesktop Documentation
Image Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > Command Class : Image Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Image As String
Visual Basic (Usage) Copy Code
Dim instance As Command
Dim value As String

instance.Image = value

value = instance.Image
C#
public virtual string Image {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Command Class
Command Members


ImageSize Property

[image]
Intersoft WebDesktop Documentation
ImageSize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > Command Class : ImageSize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ImageSize As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As Command
Dim value As System.Drawing.Size

instance.ImageSize = value

value = instance.ImageSize
C#
public System.Drawing.Size ImageSize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Command Class
Command Members


IsEnabled Property

[image]
Intersoft WebDesktop Documentation
IsEnabled Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > Command Class : IsEnabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property IsEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Command
Dim value As Boolean

instance.IsEnabled = value

value = instance.IsEnabled
C#
public virtual bool IsEnabled {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Command Class
Command Members


MergeCommandID Property

[image]
Intersoft WebDesktop Documentation
MergeCommandID Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > Command Class : MergeCommandID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property MergeCommandID As String
Visual Basic (Usage) Copy Code
Dim instance As Command
Dim value As String

instance.MergeCommandID = value

value = instance.MergeCommandID
C#
public virtual string MergeCommandID {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Command Class
Command Members


Name Property

[image]
Intersoft WebDesktop Documentation
Name Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > Command Class : Name Property

Glossary Item Box

Specifies the ToolCommand name.

Syntax

Visual Basic (Declaration)
Public Overrides Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As Command
Dim value As String

instance.Name = value

value = instance.Name
C#
public override string Name {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Command Class
Command Members


Text Property

[image]
Intersoft WebDesktop Documentation
Text Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > Command Class : Text Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As Command
Dim value As String

instance.Text = value

value = instance.Text
C#
public virtual string Text {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Command Class
Command Members


TextAlign Property

[image]
Intersoft WebDesktop Documentation
TextAlign Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > Command Class : TextAlign Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property TextAlign As BarTextAlign
Visual Basic (Usage) Copy Code
Dim instance As Command
Dim value As BarTextAlign

instance.TextAlign = value

value = instance.TextAlign
C#
public BarTextAlign TextAlign {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Command Class
Command Members


ToggleGroupName Property

[image]
Intersoft WebDesktop Documentation
ToggleGroupName Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > Command Class : ToggleGroupName Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ToggleGroupName As String
Visual Basic (Usage) Copy Code
Dim instance As Command
Dim value As String

instance.ToggleGroupName = value

value = instance.ToggleGroupName
C#
public virtual string ToggleGroupName {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Command Class
Command Members


ToolTip Property

[image]
Intersoft WebDesktop Documentation
ToolTip Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > Command Class : ToolTip Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ToolTip As String
Visual Basic (Usage) Copy Code
Dim instance As Command
Dim value As String

instance.ToolTip = value

value = instance.ToolTip
C#
public string ToolTip {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Command Class
Command Members


Type Property

[image]
Intersoft WebDesktop Documentation
Type Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > Command Class : Type Property

Glossary Item Box

Gets or sets command type.

Syntax

Visual Basic (Declaration)
Public Overridable Property Type As CommandType
Visual Basic (Usage) Copy Code
Dim instance As Command
Dim value As CommandType

instance.Type = value

value = instance.Type
C#
public virtual CommandType Type {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Command Class
Command Members


Visible Property

[image]
Intersoft WebDesktop Documentation
Visible Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > Command Class : Visible Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Command
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public virtual bool Visible {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Command Class
Command Members


CommandCollection Class

[image]
Intersoft WebDesktop Documentation
CommandCollection Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : CommandCollection Class

Glossary Item Box

Collection of WebToolBar's Command Type.

Object Model

CommandCollection Class

Syntax

Visual Basic (Declaration)
Public Class CommandCollection
   Inherits ISNet.WebUI.ISCollectionBase
Visual Basic (Usage) Copy Code
Dim instance As CommandCollection
C#
public class CommandCollection : ISNet.WebUI.ISCollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
ISNet.WebUI.ISCollectionBase
ISNet.WebUI.WebDesktop.CommandCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CommandCollection Members
ISNet.WebUI.WebDesktop Namespace

Concepts

Working with ToolBar Designer


CommandCollection Class Members

[image]
Intersoft WebDesktop Documentation
CommandCollection Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : CommandCollection Class

Glossary Item Box

The following tables list the members exposed by CommandCollection.

Public Constructors

 | Name | Description
Public Constructor | CommandCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden. Returns a Boolean value indicating whether the collection is read-only.
Public Property | Item | Property indexer for the collection.
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | GetObjectData |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

CommandCollection Class
ISNet.WebUI.WebDesktop Namespace

Concepts

Working with ToolBar Designer


CommandCollection Constructor

[image]
Intersoft WebDesktop Documentation
CommandCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > CommandCollection Class : CommandCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New CommandCollection()
C#
public CommandCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CommandCollection Class
CommandCollection Members


CommandCollection Class Methods

[image]
Intersoft WebDesktop Documentation
CommandCollection Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : CommandCollection Class

Glossary Item Box

For a list of all members of this type, see CommandCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | GetObjectData |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

CommandCollection Class
ISNet.WebUI.WebDesktop Namespace

Concepts

Working with ToolBar Designer


Add Method

[image]
Intersoft WebDesktop Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > CommandCollection Class : Add Method

Glossary Item Box

Overload List

Overload | Description
Add(Command) |
Add(String) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CommandCollection Class
CommandCollection Members


Add(Command) Method

[image]
Intersoft WebDesktop Documentation
Add(Command) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > CommandCollection Class > Add Method : Add(Command) Method

command

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function Add( _
   ByVal command As Command _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As CommandCollection
Dim command As Command
Dim value As Integer

value = instance.Add(command)
C#
public virtual int Add(
   Command command
)

Parameters

command

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CommandCollection Class
CommandCollection Members
Overload List


Add(String) Method

[image]
Intersoft WebDesktop Documentation
Add(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > CommandCollection Class > Add Method : Add(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal name As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As CommandCollection
Dim name As String
Dim value As Integer

value = instance.Add(name)
C#
public int Add(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CommandCollection Class
CommandCollection Members
Overload List


Clear Method

[image]
Intersoft WebDesktop Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > CommandCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As CommandCollection

instance.Clear()
C#
public new void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CommandCollection Class
CommandCollection Members


Contains Method

[image]
Intersoft WebDesktop Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > CommandCollection Class : Contains Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As ISNet.WebUI.INamedObject _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CommandCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As Boolean

value = instance.Contains(value)
C#
public bool Contains(
   ISNet.WebUI.INamedObject value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CommandCollection Class
CommandCollection Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > CommandCollection Class : CopyFrom Method

passIn

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CopyFrom( _
   ByVal passIn As CommandCollection _
) As CommandCollection
Visual Basic (Usage) Copy Code
Dim instance As CommandCollection
Dim passIn As CommandCollection
Dim value As CommandCollection

value = instance.CopyFrom(passIn)
C#
public CommandCollection CopyFrom(
   CommandCollection passIn
)

Parameters

passIn

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CommandCollection Class
CommandCollection Members


CopyTo Method

[image]
Intersoft WebDesktop Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > CommandCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As CommandCollection
Dim array() As ISNet.WebUI.INamedObject
Dim index As Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   ISNet.WebUI.INamedObject[] array,
   int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CommandCollection Class
CommandCollection Members


Exists Method

[image]
Intersoft WebDesktop Documentation
Exists Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > CommandCollection Class : Exists Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Exists( _
   ByVal name As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CommandCollection
Dim name As String
Dim value As Boolean

value = instance.Exists(name)
C#
public bool Exists(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CommandCollection Class
CommandCollection Members


GetEnumerator Method

[image]
Intersoft WebDesktop Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > CommandCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Function GetEnumerator() As System.Collections.IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As CommandCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
public new System.Collections.IEnumerator GetEnumerator()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CommandCollection Class
CommandCollection Members


GetItem Method

[image]
Intersoft WebDesktop Documentation
GetItem Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > CommandCollection Class : GetItem Method

Glossary Item Box

Overload List

Overload | Description
GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CommandCollection Class
CommandCollection Members


GetItem(Int32) Method

[image]
Intersoft WebDesktop Documentation
GetItem(Int32) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > CommandCollection Class : GetItem(Int32) Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetItem( _
   ByVal index As Integer _
) As ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As CommandCollection
Dim index As Integer
Dim value As ISNet.WebUI.INamedObject

value = instance.GetItem(index)
C#
public virtual ISNet.WebUI.INamedObject GetItem(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CommandCollection Class
CommandCollection Members


GetNamedItem Method

[image]
Intersoft WebDesktop Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > CommandCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNamedItem( _
   ByVal name As String _
) As Command
Visual Basic (Usage) Copy Code
Dim instance As CommandCollection
Dim name As String
Dim value As Command

value = instance.GetNamedItem(name)
C#
public Command GetNamedItem(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CommandCollection Class
CommandCollection Members


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > CommandCollection Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As CommandCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CommandCollection Class
CommandCollection Members


IndexOf Method

[image]
Intersoft WebDesktop Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > CommandCollection Class : IndexOf Method

Glossary Item Box

Overload List

Overload | Description
IndexOf(String) | (Inherited from ISNet.WebUI.ISCollectionBase)
IndexOf(INamedObject) | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CommandCollection Class
CommandCollection Members


IndexOf(String) Method

[image]
Intersoft WebDesktop Documentation
IndexOf(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > CommandCollection Class > IndexOf Method : IndexOf(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function IndexOf( _
   ByVal name As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As CommandCollection
Dim name As String
Dim value As Integer

value = instance.IndexOf(name)
C#
public virtual int IndexOf(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CommandCollection Class
CommandCollection Members
Overload List


IndexOf(INamedObject) Method

[image]
Intersoft WebDesktop Documentation
IndexOf(INamedObject) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > CommandCollection Class > IndexOf Method : IndexOf(INamedObject) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal value As ISNet.WebUI.INamedObject _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As CommandCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As Integer

value = instance.IndexOf(value)
C#
public int IndexOf(
   ISNet.WebUI.INamedObject value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CommandCollection Class
CommandCollection Members
Overload List


Insert Method

[image]
Intersoft WebDesktop Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > CommandCollection Class : Insert Method

index
command

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal command As Command _
)
Visual Basic (Usage) Copy Code
Dim instance As CommandCollection
Dim index As Integer
Dim command As Command

instance.Insert(index, command)
C#
public void Insert(
   int index,
   Command command
)

Parameters

index
command

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CommandCollection Class
CommandCollection Members


IntInsert Method

[image]
Intersoft WebDesktop Documentation
IntInsert Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > CommandCollection Class : IntInsert Method

index
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub IntInsert( _
   ByVal index As Integer, _
   ByVal value As ISNet.WebUI.INamedObject _
)
Visual Basic (Usage) Copy Code
Dim instance As CommandCollection
Dim index As Integer
Dim value As ISNet.WebUI.INamedObject

instance.IntInsert(index, value)
C#
public void IntInsert(
   int index,
   ISNet.WebUI.INamedObject value
)

Parameters

index
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CommandCollection Class
CommandCollection Members


Remove Method

[image]
Intersoft WebDesktop Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > CommandCollection Class : Remove Method

command

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal command As Command _
)
Visual Basic (Usage) Copy Code
Dim instance As CommandCollection
Dim command As Command

instance.Remove(command)
C#
public void Remove(
   Command command
)

Parameters

command

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CommandCollection Class
CommandCollection Members


setParent Method

[image]
Intersoft WebDesktop Documentation
setParent Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > CommandCollection Class : setParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub setParent( _
   ByVal parent As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As CommandCollection
Dim parent As Object

instance.setParent(parent)
C#
public virtual void setParent(
   object parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CommandCollection Class
CommandCollection Members


Capacity Property

[image]
Intersoft WebDesktop Documentation
Capacity Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > CommandCollection Class : Capacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
Visual Basic (Usage) Copy Code
Dim instance As CommandCollection
Dim value As Integer

instance.Capacity = value

value = instance.Capacity
C#
public int Capacity {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CommandCollection Class
CommandCollection Members


Count Property

[image]
Intersoft WebDesktop Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > CommandCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As CommandCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CommandCollection Class
CommandCollection Members


CommandCollection Class Properties

[image]
Intersoft WebDesktop Documentation
CommandCollection Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : CommandCollection Class

Glossary Item Box

For a list of all members of this type, see CommandCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden. Returns a Boolean value indicating whether the collection is read-only.
Public Property | Item | Property indexer for the collection.
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

CommandCollection Class
ISNet.WebUI.WebDesktop Namespace

Concepts

Working with ToolBar Designer


CommandCollection Constructor

[image]
Intersoft WebDesktop Documentation
CommandCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > CommandCollection Class : CommandCollection Constructor

Glossary Item Box

Initializes a new instance of the CommandCollection class.

Overload List

Overload | Description
CommandCollection Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CommandCollection Class
CommandCollection Members


IsReadOnly Property

[image]
Intersoft WebDesktop Documentation
IsReadOnly Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > CommandCollection Class : IsReadOnly Property

Glossary Item Box

Returns a Boolean value indicating whether the collection is read-only.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CommandCollection
Dim value As Boolean

value = instance.IsReadOnly
C#
public override bool IsReadOnly {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CommandCollection Class
CommandCollection Members


Item Property

[image]
Intersoft WebDesktop Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > CommandCollection Class : Item Property

index

Glossary Item Box

Property indexer for the collection.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As Command
Visual Basic (Usage) Copy Code
Dim instance As CommandCollection
Dim index As Integer
Dim value As Command

instance.Item(index) = value

value = instance.Item(index)
C#
public Command this[
   int index
]; {get; set;}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CommandCollection Class
CommandCollection Members


Parent Property

[image]
Intersoft WebDesktop Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > CommandCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As Object
Visual Basic (Usage) Copy Code
Dim instance As CommandCollection
Dim value As Object

value = instance.Parent
C#
public object Parent {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CommandCollection Class
CommandCollection Members


IBarCollection Class

[image]
Intersoft WebDesktop Documentation
IBarCollection Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : IBarCollection Class

Glossary Item Box

Collection of interfaces used by PlaceHolderManager. A PlaceHolderManager - which can be used with WebToolBar and WebMenuBar - represents a partitioned container in a WebForm which supports docking capabilities for IBar implemented controls.

Object Model

IBarCollection Class

Syntax

Visual Basic (Declaration)
Public Class IBarCollection
   Inherits System.Collections.CollectionBase
Visual Basic (Usage) Copy Code
Dim instance As IBarCollection
C#
public class IBarCollection : System.Collections.CollectionBase

Remarks

PlaceHolderManager has a firm integration with IBar implemented controls. The PlaceHolderManager acts as the manager for all bars that it owned. It contains all master configurations such as styles and behaviors of the ToolBar and MenuBar. The tight integration feature significantly improve developer's productivity with the global configurations managed by the PlaceHolderManager. For more information please refer to PlaceHolderManager Concept.

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
ISNet.WebUI.WebDesktop.IBarCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarCollection Members
ISNet.WebUI.WebDesktop Namespace

Concepts

PlaceHolderManager Concept


IBarCollection Class Members

[image]
Intersoft WebDesktop Documentation
IBarCollection Class Members
See Also Properties Methods Events Send Feedback
ISNet.WebUI.WebDesktop Namespace : IBarCollection Class

Glossary Item Box

The following tables list the members exposed by IBarCollection.

Public Constructors

 | Name | Description
Public Constructor | IBarCollection Constructor | Initializes a new instance of the IBarCollection class.
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets the item contained in the CollectionBase instance.
Top

Public Methods

 | Name | Description
Public Method | Add |
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Contains |
Public Method | GetEnumerator | (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf |
Public Method | Insert |
Public Method | Remove |
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top

Public Events

 | Name | Description
Public Event | InsertCompleted | Occurs when a WebToolBar or WebMenuBar is inserted into a bar collection.
Public Event | RemoveCompleted | Occurs when a WebToolBar or WebMenuBar is removed from a bar collection.
Top

See Also

Reference

IBarCollection Class
ISNet.WebUI.WebDesktop Namespace

Concepts

PlaceHolderManager Concept


IBarCollection Constructor

[image]
Intersoft WebDesktop Documentation
IBarCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBarCollection Class : IBarCollection Constructor

Glossary Item Box

Initializes a new instance of the IBarCollection class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New IBarCollection()
C#
public IBarCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarCollection Class
IBarCollection Members


IBarCollection Class Methods

[image]
Intersoft WebDesktop Documentation
IBarCollection Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : IBarCollection Class

Glossary Item Box

For a list of all members of this type, see IBarCollection members.

Public Methods

 | Name | Description
Public Method | Add |
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Contains |
Public Method | GetEnumerator | (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf |
Public Method | Insert |
Public Method | Remove |
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

IBarCollection Class
ISNet.WebUI.WebDesktop Namespace

Concepts

PlaceHolderManager Concept


Add Method

[image]
Intersoft WebDesktop Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBarCollection Class : Add Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal value As IBar _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As IBarCollection
Dim value As IBar
Dim value As Integer

value = instance.Add(value)
C#
public int Add(
   IBar value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarCollection Class
IBarCollection Members


Clear Method

[image]
Intersoft WebDesktop Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBarCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As IBarCollection

instance.Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarCollection Class
IBarCollection Members


Contains Method

[image]
Intersoft WebDesktop Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBarCollection Class : Contains Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As IBar _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As IBarCollection
Dim value As IBar
Dim value As Boolean

value = instance.Contains(value)
C#
public bool Contains(
   IBar value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarCollection Class
IBarCollection Members


GetEnumerator Method

[image]
Intersoft WebDesktop Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBarCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As System.Collections.IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As IBarCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
public System.Collections.IEnumerator GetEnumerator()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarCollection Class
IBarCollection Members


IndexOf Method

[image]
Intersoft WebDesktop Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBarCollection Class : IndexOf Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal value As IBar _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As IBarCollection
Dim value As IBar
Dim value As Integer

value = instance.IndexOf(value)
C#
public int IndexOf(
   IBar value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarCollection Class
IBarCollection Members


Insert Method

[image]
Intersoft WebDesktop Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBarCollection Class : Insert Method

index
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As IBar _
)
Visual Basic (Usage) Copy Code
Dim instance As IBarCollection
Dim index As Integer
Dim value As IBar

instance.Insert(index, value)
C#
public void Insert(
   int index,
   IBar value
)

Parameters

index
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarCollection Class
IBarCollection Members


Remove Method

[image]
Intersoft WebDesktop Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBarCollection Class : Remove Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal value As IBar _
)
Visual Basic (Usage) Copy Code
Dim instance As IBarCollection
Dim value As IBar

instance.Remove(value)
C#
public void Remove(
   IBar value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarCollection Class
IBarCollection Members


RemoveAt Method

[image]
Intersoft WebDesktop Documentation
RemoveAt Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBarCollection Class : RemoveAt Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As IBarCollection
Dim index As Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarCollection Class
IBarCollection Members


Capacity Property

[image]
Intersoft WebDesktop Documentation
Capacity Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBarCollection Class : Capacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
Visual Basic (Usage) Copy Code
Dim instance As IBarCollection
Dim value As Integer

instance.Capacity = value

value = instance.Capacity
C#
public int Capacity {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarCollection Class
IBarCollection Members


Count Property

[image]
Intersoft WebDesktop Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBarCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As IBarCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarCollection Class
IBarCollection Members


IBarCollection Class Properties

[image]
Intersoft WebDesktop Documentation
IBarCollection Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : IBarCollection Class

Glossary Item Box

For a list of all members of this type, see IBarCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets the item contained in the CollectionBase instance.
Top

See Also

Reference

IBarCollection Class
ISNet.WebUI.WebDesktop Namespace

Concepts

PlaceHolderManager Concept


Item Property

[image]
Intersoft WebDesktop Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBarCollection Class : Item Property

index

Glossary Item Box

Gets the item contained in the CollectionBase instance.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As IBar
Visual Basic (Usage) Copy Code
Dim instance As IBarCollection
Dim index As Integer
Dim value As IBar

instance.Item(index) = value

value = instance.Item(index)
C#
public IBar this[
   int index
]; {get; set;}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarCollection Class
IBarCollection Members


IBarCollection Class Events

[image]
Intersoft WebDesktop Documentation
IBarCollection Class Events
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : IBarCollection Class

Glossary Item Box

For a list of all members of this type, see IBarCollection members.

Public Events

 | Name | Description
Public Event | InsertCompleted | Occurs when a WebToolBar or WebMenuBar is inserted into a bar collection.
Public Event | RemoveCompleted | Occurs when a WebToolBar or WebMenuBar is removed from a bar collection.
Top

See Also

Reference

IBarCollection Class
ISNet.WebUI.WebDesktop Namespace

Concepts

PlaceHolderManager Concept


InsertCompleted Event

[image]
Intersoft WebDesktop Documentation
InsertCompleted Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBarCollection Class : InsertCompleted Event

Glossary Item Box

Occurs when a WebToolBar or WebMenuBar is inserted into a bar collection.

Syntax

Visual Basic (Declaration)
Public Event InsertCompleted As IBarEventHandler
Visual Basic (Usage) Copy Code
Dim instance As IBarCollection
Dim handler As IBarEventHandler

AddHandler instance.InsertCompleted, handler
C#
public event IBarEventHandler InsertCompleted

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarCollection Class
IBarCollection Members


RemoveCompleted Event

[image]
Intersoft WebDesktop Documentation
RemoveCompleted Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBarCollection Class : RemoveCompleted Event

Glossary Item Box

Occurs when a WebToolBar or WebMenuBar is removed from a bar collection.

Syntax

Visual Basic (Declaration)
Public Event RemoveCompleted As IBarEventHandler
Visual Basic (Usage) Copy Code
Dim instance As IBarCollection
Dim handler As IBarEventHandler

AddHandler instance.RemoveCompleted, handler
C#
public event IBarEventHandler RemoveCompleted

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarCollection Class
IBarCollection Members


IBarEventArgs Class

[image]
Intersoft WebDesktop Documentation
IBarEventArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : IBarEventArgs Class

Glossary Item Box

Provides data for IBar related event.

Object Model

IBarEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class IBarEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As IBarEventArgs
C#
public class IBarEventArgs : System.EventArgs

Remarks

IBarCollection and IBarEventArgs are used in PlaceHolderManager to configure the styles and behavior of WebToolBar and WebMenuBar.

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebDesktop.IBarEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarEventArgs Members
ISNet.WebUI.WebDesktop Namespace


IBarEventArgs Class Members

[image]
Intersoft WebDesktop Documentation
IBarEventArgs Class Members
See Also Fields Send Feedback
ISNet.WebUI.WebDesktop Namespace : IBarEventArgs Class

Glossary Item Box

The following tables list the members exposed by IBarEventArgs.

Public Constructors

 | Name | Description
Public Constructor | IBarEventArgs Constructor | Initializes a new instance of the IBarEventArgs class.
Top

Public Fields

 | Name | Description
Public Field | Bar |
Top

See Also

Reference

IBarEventArgs Class
ISNet.WebUI.WebDesktop Namespace


IBarEventArgs Constructor

[image]
Intersoft WebDesktop Documentation
IBarEventArgs Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBarEventArgs Class : IBarEventArgs Constructor

bar

Glossary Item Box

Initializes a new instance of the IBarEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal bar As IBar _
)
Visual Basic (Usage) Copy Code
Dim bar As IBar

Dim instance As New IBarEventArgs(bar)
C#
public IBarEventArgs(
   IBar bar
)

Parameters

bar

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarEventArgs Class
IBarEventArgs Members


IBarEventArgs Class Fields

[image]
Intersoft WebDesktop Documentation
IBarEventArgs Class Fields
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : IBarEventArgs Class

Glossary Item Box

For a list of all members of this type, see IBarEventArgs members.

Public Fields

 | Name | Description
Public Field | Bar |
Top

See Also

Reference

IBarEventArgs Class
ISNet.WebUI.WebDesktop Namespace


Bar Field

[image]
Intersoft WebDesktop Documentation
Bar Field
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBarEventArgs Class : Bar Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Bar As IBar
Visual Basic (Usage) Copy Code
Dim instance As IBarEventArgs
Dim value As IBar

value = instance.Bar

instance.Bar = value
C#
public IBar Bar

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarEventArgs Class
IBarEventArgs Members


MenuCommand Class

[image]
Intersoft WebDesktop Documentation
MenuCommand Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : MenuCommand Class

Glossary Item Box

List of menu command in WebMenuBar.

Object Model

MenuCommand Class

Syntax

Visual Basic (Declaration)
Public Class MenuCommand
   Inherits Command
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject, ICommand, IWebMenu
Visual Basic (Usage) Copy Code
Dim instance As MenuCommand
C#
public class MenuCommand : Command, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject, ICommand, IWebMenu

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase
ISNet.WebUI.WebDesktop.Command
ISNet.WebUI.WebDesktop.MenuCommand

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommand Members
ISNet.WebUI.WebDesktop Namespace


MenuCommand Class Members

[image]
Intersoft WebDesktop Documentation
MenuCommand Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : MenuCommand Class

Glossary Item Box

The following tables list the members exposed by MenuCommand.

Public Constructors

 | Name | Description
Public Constructor | MenuCommand Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | AutoPostBack | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | Category | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | CommandSize | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | DisplayAccessKeyOnToolTip | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | DisplayMode | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | DisplayToolTip | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | Image | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | ImageSize | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | IsEnabled | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | Items | Gets command menu item collection.
Public Property | Menu | Gets or sets command menu implementation.
Public Property | Name | Overridden. Specifies MenuCommand name.
Public Property | TargetFrame |
Public Property | TargetURL |
Public Property | Text | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | TextAlign | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | ToolTip | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | Type | Overridden. Gets or sets command type.
Public Property | Visible | Overridden. Gets or sets a value that indicates whether a Command is visibled.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebDesktop.Command)
Top

See Also

Reference

MenuCommand Class
ISNet.WebUI.WebDesktop Namespace


MenuCommand Constructor

[image]
Intersoft WebDesktop Documentation
MenuCommand Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommand Class : MenuCommand Constructor

Glossary Item Box

Initializes a new instance of the MenuCommand class.

Overload List

Overload | Description
MenuCommand Constructor() | Initializes a new instance of the MenuCommand class with no argument.
MenuCommand Constructor(String) | Initializes a new instance of the MenuCommand class with text parameter.
MenuCommand Constructor(String,String) | Initializes a new instance of the MenuCommand class with text and name parameters.
MenuCommand Constructor(String,String,String) | Initializes a new instance of the MenuCommand class with text, name and AccessKey parameters.
MenuCommand Constructor(String,String,CommandType) | Initializes a new instance of the MenuCommand class with text, name and CommandType parameters.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommand Class
MenuCommand Members


MenuCommand Constructor()

[image]
Intersoft WebDesktop Documentation
MenuCommand Constructor()
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommand Class > MenuCommand Constructor : MenuCommand Constructor()

Glossary Item Box

Initializes a new instance of the MenuCommand class with no argument.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New MenuCommand()
C#
public MenuCommand()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommand Class
MenuCommand Members
Overload List


MenuCommand Constructor(String)

[image]
Intersoft WebDesktop Documentation
MenuCommand Constructor(String)
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommand Class > MenuCommand Constructor : MenuCommand Constructor(String)

text

Glossary Item Box

Initializes a new instance of the MenuCommand class with text parameter.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim text As String

Dim instance As New MenuCommand(text)
C#
public MenuCommand(
   string text
)

Parameters

text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommand Class
MenuCommand Members
Overload List


MenuCommand Constructor(String,String)

[image]
Intersoft WebDesktop Documentation
MenuCommand Constructor(String,String)
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommand Class > MenuCommand Constructor : MenuCommand Constructor(String,String)

text
name

Glossary Item Box

Initializes a new instance of the MenuCommand class with text and name parameters.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal text As String, _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim text As String
Dim name As String

Dim instance As New MenuCommand(text, name)
C#
public MenuCommand(
   string text,
   string name
)

Parameters

text
name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommand Class
MenuCommand Members
Overload List


MenuCommand Constructor(String,String,String)

[image]
Intersoft WebDesktop Documentation
MenuCommand Constructor(String,String,String)
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommand Class > MenuCommand Constructor : MenuCommand Constructor(String,String,String)

text
name
accessKey

Glossary Item Box

Initializes a new instance of the MenuCommand class with text, name and AccessKey parameters.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal text As String, _
   ByVal name As String, _
   ByVal accessKey As String _
)
Visual Basic (Usage) Copy Code
Dim text As String
Dim name As String
Dim accessKey As String

Dim instance As New MenuCommand(text, name, accessKey)
C#
public MenuCommand(
   string text,
   string name,
   string accessKey
)

Parameters

text
name
accessKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommand Class
MenuCommand Members
Overload List


MenuCommand Constructor(String,String,CommandType)

[image]
Intersoft WebDesktop Documentation
MenuCommand Constructor(String,String,CommandType)
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommand Class > MenuCommand Constructor : MenuCommand Constructor(String,String,CommandType)

text
name
type

Glossary Item Box

Initializes a new instance of the MenuCommand class with text, name and CommandType parameters.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal text As String, _
   ByVal name As String, _
   ByVal type As CommandType _
)
Visual Basic (Usage) Copy Code
Dim text As String
Dim name As String
Dim type As CommandType

Dim instance As New MenuCommand(text, name, type)
C#
public MenuCommand(
   string text,
   string name,
   CommandType type
)

Parameters

text
name
type

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommand Class
MenuCommand Members
Overload List


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommand Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As MenuCommand
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommand Class
MenuCommand Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommand Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommand Class
MenuCommand Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommand Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As MenuCommand
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommand Class
MenuCommand Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommand Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As MenuCommand
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommand Class
MenuCommand Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommand Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As MenuCommand
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommand Class
MenuCommand Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommand Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As MenuCommand
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommand Class
MenuCommand Members


MenuCommand Class Methods

[image]
Intersoft WebDesktop Documentation
MenuCommand Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : MenuCommand Class

Glossary Item Box

For a list of all members of this type, see MenuCommand members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebDesktop.Command)
Top

See Also

Reference

MenuCommand Class
ISNet.WebUI.WebDesktop Namespace


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommand Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As MenuCommand
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommand Class
MenuCommand Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommand Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As MenuCommand
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommand Class
MenuCommand Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommand Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As MenuCommand

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommand Class
MenuCommand Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommand Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As MenuCommand
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommand Class
MenuCommand Members


MenuCommand Class Properties

[image]
Intersoft WebDesktop Documentation
MenuCommand Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : MenuCommand Class

Glossary Item Box

For a list of all members of this type, see MenuCommand members.

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | AutoPostBack | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | Category | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | CommandSize | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | DisplayAccessKeyOnToolTip | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | DisplayMode | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | DisplayToolTip | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | Image | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | ImageSize | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | IsEnabled | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | Items | Gets command menu item collection.
Public Property | Menu | Gets or sets command menu implementation.
Public Property | Name | Overridden. Specifies MenuCommand name.
Public Property | TargetFrame |
Public Property | TargetURL |
Public Property | Text | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | TextAlign | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | ToolTip | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | Type | Overridden. Gets or sets command type.
Public Property | Visible | Overridden. Gets or sets a value that indicates whether a Command is visibled.
Top

See Also

Reference

MenuCommand Class
ISNet.WebUI.WebDesktop Namespace


Items Property

[image]
Intersoft WebDesktop Documentation
Items Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommand Class : Items Property

Glossary Item Box

Gets command menu item collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Items As WebMenuItemCollection
Visual Basic (Usage) Copy Code
Dim instance As MenuCommand
Dim value As WebMenuItemCollection

value = instance.Items
C#
public WebMenuItemCollection Items {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommand Class
MenuCommand Members


Menu Property

[image]
Intersoft WebDesktop Documentation
Menu Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommand Class : Menu Property

Glossary Item Box

Gets or sets command menu implementation.

Syntax

Visual Basic (Declaration)
Public Property Menu As WebMenu
Visual Basic (Usage) Copy Code
Dim instance As MenuCommand
Dim value As WebMenu

instance.Menu = value

value = instance.Menu
C#
public WebMenu Menu {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommand Class
MenuCommand Members


Name Property

[image]
Intersoft WebDesktop Documentation
Name Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommand Class : Name Property

Glossary Item Box

Specifies MenuCommand name.

Syntax

Visual Basic (Declaration)
Public Overrides Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As MenuCommand
Dim value As String

instance.Name = value

value = instance.Name
C#
public override string Name {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommand Class
MenuCommand Members


TargetFrame Property

[image]
Intersoft WebDesktop Documentation
TargetFrame Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommand Class : TargetFrame Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property TargetFrame As FrameTarget
Visual Basic (Usage) Copy Code
Dim instance As MenuCommand
Dim value As FrameTarget

instance.TargetFrame = value

value = instance.TargetFrame
C#
public FrameTarget TargetFrame {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommand Class
MenuCommand Members


TargetURL Property

[image]
Intersoft WebDesktop Documentation
TargetURL Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommand Class : TargetURL Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property TargetURL As String
Visual Basic (Usage) Copy Code
Dim instance As MenuCommand
Dim value As String

instance.TargetURL = value

value = instance.TargetURL
C#
public string TargetURL {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommand Class
MenuCommand Members


Type Property

[image]
Intersoft WebDesktop Documentation
Type Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommand Class : Type Property

Glossary Item Box

Gets or sets command type.

Syntax

Visual Basic (Declaration)
Public Overrides Property Type As CommandType
Visual Basic (Usage) Copy Code
Dim instance As MenuCommand
Dim value As CommandType

instance.Type = value

value = instance.Type
C#
public override CommandType Type {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommand Class
MenuCommand Members


Visible Property

[image]
Intersoft WebDesktop Documentation
Visible Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommand Class : Visible Property

Glossary Item Box

Gets or sets a value that indicates whether a Command is visibled.

Syntax

Visual Basic (Declaration)
Public Overrides Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As MenuCommand
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public override bool Visible {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommand Class
MenuCommand Members


MenuCommandClickEventArgs Class

[image]
Intersoft WebDesktop Documentation
MenuCommandClickEventArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : MenuCommandClickEventArgs Class

Glossary Item Box

Provides data for MenuCommand clicked related event.

Object Model

MenuCommandClickEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class MenuCommandClickEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As MenuCommandClickEventArgs
C#
public class MenuCommandClickEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebDesktop.MenuCommandClickEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommandClickEventArgs Members
ISNet.WebUI.WebDesktop Namespace


MenuCommandClickEventArgs Class Members

[image]
Intersoft WebDesktop Documentation
MenuCommandClickEventArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebDesktop Namespace : MenuCommandClickEventArgs Class

Glossary Item Box

The following tables list the members exposed by MenuCommandClickEventArgs.

Public Constructors

 | Name | Description
Public Constructor | MenuCommandClickEventArgs Constructor | Initializes a new instance of the MenuCommandClickEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | ClickedCommand | Gets the clicked command in MenuCommand.
Public Property | ClickedMenuItem | Gets the clicked menu item in MenuCommand.
Top

See Also

Reference

MenuCommandClickEventArgs Class
ISNet.WebUI.WebDesktop Namespace


MenuCommandClickEventArgs Constructor

[image]
Intersoft WebDesktop Documentation
MenuCommandClickEventArgs Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommandClickEventArgs Class : MenuCommandClickEventArgs Constructor

clickedCommand
clickedMenuItem

Glossary Item Box

Initializes a new instance of the MenuCommandClickEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal clickedCommand As MenuCommand, _
   ByVal clickedMenuItem As WebMenuItem _
)
Visual Basic (Usage) Copy Code
Dim clickedCommand As MenuCommand
Dim clickedMenuItem As WebMenuItem

Dim instance As New MenuCommandClickEventArgs(clickedCommand, clickedMenuItem)
C#
public MenuCommandClickEventArgs(
   MenuCommand clickedCommand,
   WebMenuItem clickedMenuItem
)

Parameters

clickedCommand
clickedMenuItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommandClickEventArgs Class
MenuCommandClickEventArgs Members


MenuCommandClickEventArgs Class Properties

[image]
Intersoft WebDesktop Documentation
MenuCommandClickEventArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : MenuCommandClickEventArgs Class

Glossary Item Box

For a list of all members of this type, see MenuCommandClickEventArgs members.

Public Properties

 | Name | Description
Public Property | ClickedCommand | Gets the clicked command in MenuCommand.
Public Property | ClickedMenuItem | Gets the clicked menu item in MenuCommand.
Top

See Also

Reference

MenuCommandClickEventArgs Class
ISNet.WebUI.WebDesktop Namespace


ClickedCommand Property

[image]
Intersoft WebDesktop Documentation
ClickedCommand Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommandClickEventArgs Class : ClickedCommand Property

Glossary Item Box

Gets the clicked command in MenuCommand.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClickedCommand As MenuCommand
Visual Basic (Usage) Copy Code
Dim instance As MenuCommandClickEventArgs
Dim value As MenuCommand

value = instance.ClickedCommand
C#
public MenuCommand ClickedCommand {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommandClickEventArgs Class
MenuCommandClickEventArgs Members


ClickedMenuItem Property

[image]
Intersoft WebDesktop Documentation
ClickedMenuItem Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommandClickEventArgs Class : ClickedMenuItem Property

Glossary Item Box

Gets the clicked menu item in MenuCommand.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClickedMenuItem As WebMenuItem
Visual Basic (Usage) Copy Code
Dim instance As MenuCommandClickEventArgs
Dim value As WebMenuItem

value = instance.ClickedMenuItem
C#
public WebMenuItem ClickedMenuItem {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommandClickEventArgs Class
MenuCommandClickEventArgs Members


MenuCommandCollection Class

[image]
Intersoft WebDesktop Documentation
MenuCommandCollection Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : MenuCommandCollection Class

Glossary Item Box

Collection of MenuCommand.

Object Model

MenuCommandCollection Class

Syntax

Visual Basic (Declaration)
Public Class MenuCommandCollection
   Inherits ISNet.WebUI.ISCollectionBase
Visual Basic (Usage) Copy Code
Dim instance As MenuCommandCollection
C#
public class MenuCommandCollection : ISNet.WebUI.ISCollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
ISNet.WebUI.ISCollectionBase
ISNet.WebUI.WebDesktop.MenuCommandCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommandCollection Members
ISNet.WebUI.WebDesktop Namespace


MenuCommandCollection Class Members

[image]
Intersoft WebDesktop Documentation
MenuCommandCollection Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : MenuCommandCollection Class

Glossary Item Box

The following tables list the members exposed by MenuCommandCollection.

Public Constructors

 | Name | Description
Public Constructor | MenuCommandCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden. Returns a Boolean value indicating whether the collection is read-only.
Public Property | Item | Property indexer for the collection.
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | GetObjectData |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

MenuCommandCollection Class
ISNet.WebUI.WebDesktop Namespace


MenuCommandCollection Constructor

[image]
Intersoft WebDesktop Documentation
MenuCommandCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommandCollection Class : MenuCommandCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New MenuCommandCollection()
C#
public MenuCommandCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommandCollection Class
MenuCommandCollection Members


MenuCommandCollection Class Methods

[image]
Intersoft WebDesktop Documentation
MenuCommandCollection Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : MenuCommandCollection Class

Glossary Item Box

For a list of all members of this type, see MenuCommandCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | GetObjectData |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

MenuCommandCollection Class
ISNet.WebUI.WebDesktop Namespace


Add Method

[image]
Intersoft WebDesktop Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommandCollection Class : Add Method

Glossary Item Box

Overload List

Overload | Description
Add(MenuCommand) |
Add(String) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommandCollection Class
MenuCommandCollection Members


Add(MenuCommand) Method

[image]
Intersoft WebDesktop Documentation
Add(MenuCommand) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommandCollection Class > Add Method : Add(MenuCommand) Method

command

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function Add( _
   ByVal command As MenuCommand _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As MenuCommandCollection
Dim command As MenuCommand
Dim value As Integer

value = instance.Add(command)
C#
public virtual int Add(
   MenuCommand command
)

Parameters

command

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommandCollection Class
MenuCommandCollection Members
Overload List


Add(String) Method

[image]
Intersoft WebDesktop Documentation
Add(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommandCollection Class > Add Method : Add(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal name As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As MenuCommandCollection
Dim name As String
Dim value As Integer

value = instance.Add(name)
C#
public int Add(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommandCollection Class
MenuCommandCollection Members
Overload List


Clear Method

[image]
Intersoft WebDesktop Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommandCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As MenuCommandCollection

instance.Clear()
C#
public new void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommandCollection Class
MenuCommandCollection Members


Contains Method

[image]
Intersoft WebDesktop Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommandCollection Class : Contains Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As ISNet.WebUI.INamedObject _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As MenuCommandCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As Boolean

value = instance.Contains(value)
C#
public bool Contains(
   ISNet.WebUI.INamedObject value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommandCollection Class
MenuCommandCollection Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommandCollection Class : CopyFrom Method

passIn

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CopyFrom( _
   ByVal passIn As MenuCommandCollection _
) As MenuCommandCollection
Visual Basic (Usage) Copy Code
Dim instance As MenuCommandCollection
Dim passIn As MenuCommandCollection
Dim value As MenuCommandCollection

value = instance.CopyFrom(passIn)
C#
public MenuCommandCollection CopyFrom(
   MenuCommandCollection passIn
)

Parameters

passIn

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommandCollection Class
MenuCommandCollection Members


CopyTo Method

[image]
Intersoft WebDesktop Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommandCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As MenuCommandCollection
Dim array() As ISNet.WebUI.INamedObject
Dim index As Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   ISNet.WebUI.INamedObject[] array,
   int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommandCollection Class
MenuCommandCollection Members


Exists Method

[image]
Intersoft WebDesktop Documentation
Exists Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommandCollection Class : Exists Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Exists( _
   ByVal name As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As MenuCommandCollection
Dim name As String
Dim value As Boolean

value = instance.Exists(name)
C#
public bool Exists(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommandCollection Class
MenuCommandCollection Members


GetEnumerator Method

[image]
Intersoft WebDesktop Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommandCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Function GetEnumerator() As System.Collections.IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As MenuCommandCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
public new System.Collections.IEnumerator GetEnumerator()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommandCollection Class
MenuCommandCollection Members


GetItem Method

[image]
Intersoft WebDesktop Documentation
GetItem Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommandCollection Class : GetItem Method

Glossary Item Box

Overload List

Overload | Description
GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommandCollection Class
MenuCommandCollection Members


GetItem(Int32) Method

[image]
Intersoft WebDesktop Documentation
GetItem(Int32) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommandCollection Class : GetItem(Int32) Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetItem( _
   ByVal index As Integer _
) As ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As MenuCommandCollection
Dim index As Integer
Dim value As ISNet.WebUI.INamedObject

value = instance.GetItem(index)
C#
public virtual ISNet.WebUI.INamedObject GetItem(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommandCollection Class
MenuCommandCollection Members


GetNamedItem Method

[image]
Intersoft WebDesktop Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommandCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNamedItem( _
   ByVal name As String _
) As MenuCommand
Visual Basic (Usage) Copy Code
Dim instance As MenuCommandCollection
Dim name As String
Dim value As MenuCommand

value = instance.GetNamedItem(name)
C#
public MenuCommand GetNamedItem(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommandCollection Class
MenuCommandCollection Members


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommandCollection Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As MenuCommandCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommandCollection Class
MenuCommandCollection Members


IndexOf Method

[image]
Intersoft WebDesktop Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommandCollection Class : IndexOf Method

Glossary Item Box

Overload List

Overload | Description
IndexOf(String) | (Inherited from ISNet.WebUI.ISCollectionBase)
IndexOf(INamedObject) | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommandCollection Class
MenuCommandCollection Members


IndexOf(String) Method

[image]
Intersoft WebDesktop Documentation
IndexOf(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommandCollection Class > IndexOf Method : IndexOf(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function IndexOf( _
   ByVal name As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As MenuCommandCollection
Dim name As String
Dim value As Integer

value = instance.IndexOf(name)
C#
public virtual int IndexOf(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommandCollection Class
MenuCommandCollection Members
Overload List


IndexOf(INamedObject) Method

[image]
Intersoft WebDesktop Documentation
IndexOf(INamedObject) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommandCollection Class > IndexOf Method : IndexOf(INamedObject) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal value As ISNet.WebUI.INamedObject _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As MenuCommandCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As Integer

value = instance.IndexOf(value)
C#
public int IndexOf(
   ISNet.WebUI.INamedObject value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommandCollection Class
MenuCommandCollection Members
Overload List


Insert Method

[image]
Intersoft WebDesktop Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommandCollection Class : Insert Method

index
command

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal command As MenuCommand _
)
Visual Basic (Usage) Copy Code
Dim instance As MenuCommandCollection
Dim index As Integer
Dim command As MenuCommand

instance.Insert(index, command)
C#
public void Insert(
   int index,
   MenuCommand command
)

Parameters

index
command

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommandCollection Class
MenuCommandCollection Members


IntInsert Method

[image]
Intersoft WebDesktop Documentation
IntInsert Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommandCollection Class : IntInsert Method

index
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub IntInsert( _
   ByVal index As Integer, _
   ByVal value As ISNet.WebUI.INamedObject _
)
Visual Basic (Usage) Copy Code
Dim instance As MenuCommandCollection
Dim index As Integer
Dim value As ISNet.WebUI.INamedObject

instance.IntInsert(index, value)
C#
public void IntInsert(
   int index,
   ISNet.WebUI.INamedObject value
)

Parameters

index
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommandCollection Class
MenuCommandCollection Members


Remove Method

[image]
Intersoft WebDesktop Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommandCollection Class : Remove Method

command

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal command As MenuCommand _
)
Visual Basic (Usage) Copy Code
Dim instance As MenuCommandCollection
Dim command As MenuCommand

instance.Remove(command)
C#
public void Remove(
   MenuCommand command
)

Parameters

command

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommandCollection Class
MenuCommandCollection Members


setParent Method

[image]
Intersoft WebDesktop Documentation
setParent Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommandCollection Class : setParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub setParent( _
   ByVal parent As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As MenuCommandCollection
Dim parent As Object

instance.setParent(parent)
C#
public virtual void setParent(
   object parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommandCollection Class
MenuCommandCollection Members


Capacity Property

[image]
Intersoft WebDesktop Documentation
Capacity Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommandCollection Class : Capacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
Visual Basic (Usage) Copy Code
Dim instance As MenuCommandCollection
Dim value As Integer

instance.Capacity = value

value = instance.Capacity
C#
public int Capacity {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommandCollection Class
MenuCommandCollection Members


Count Property

[image]
Intersoft WebDesktop Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommandCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As MenuCommandCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommandCollection Class
MenuCommandCollection Members


MenuCommandCollection Class Properties

[image]
Intersoft WebDesktop Documentation
MenuCommandCollection Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : MenuCommandCollection Class

Glossary Item Box

For a list of all members of this type, see MenuCommandCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden. Returns a Boolean value indicating whether the collection is read-only.
Public Property | Item | Property indexer for the collection.
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

MenuCommandCollection Class
ISNet.WebUI.WebDesktop Namespace


MenuCommandCollection Constructor

[image]
Intersoft WebDesktop Documentation
MenuCommandCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommandCollection Class : MenuCommandCollection Constructor

Glossary Item Box

Initializes a new instance of the MenuCommandCollection class.

Overload List

Overload | Description
MenuCommandCollection Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommandCollection Class
MenuCommandCollection Members


IsReadOnly Property

[image]
Intersoft WebDesktop Documentation
IsReadOnly Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommandCollection Class : IsReadOnly Property

Glossary Item Box

Returns a Boolean value indicating whether the collection is read-only.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As MenuCommandCollection
Dim value As Boolean

value = instance.IsReadOnly
C#
public override bool IsReadOnly {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommandCollection Class
MenuCommandCollection Members


Item Property

[image]
Intersoft WebDesktop Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommandCollection Class : Item Property

index

Glossary Item Box

Property indexer for the collection.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As MenuCommand
Visual Basic (Usage) Copy Code
Dim instance As MenuCommandCollection
Dim index As Integer
Dim value As MenuCommand

instance.Item(index) = value

value = instance.Item(index)
C#
public MenuCommand this[
   int index
]; {get; set;}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommandCollection Class
MenuCommandCollection Members


Parent Property

[image]
Intersoft WebDesktop Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > MenuCommandCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As Object
Visual Basic (Usage) Copy Code
Dim instance As MenuCommandCollection
Dim value As Object

value = instance.Parent
C#
public object Parent {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommandCollection Class
MenuCommandCollection Members


NotificationProperties Class

[image]
Intersoft WebDesktop Documentation
NotificationProperties Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : NotificationProperties Class

Glossary Item Box

Collection of notification properties used in WebNotification control.

Object Model

NotificationProperties Class

Syntax

Visual Basic (Declaration)
Public Class NotificationProperties
   Inherits System.Collections.DictionaryBase
Visual Basic (Usage) Copy Code
Dim instance As NotificationProperties
C#
public class NotificationProperties : System.Collections.DictionaryBase

Inheritance Hierarchy

System.Object
System.Collections.DictionaryBase
ISNet.WebUI.WebDesktop.NotificationProperties

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NotificationProperties Members
ISNet.WebUI.WebDesktop Namespace


NotificationProperties Class Members

[image]
Intersoft WebDesktop Documentation
NotificationProperties Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : NotificationProperties Class

Glossary Item Box

The following tables list the members exposed by NotificationProperties.

Public Constructors

 | Name | Description
Public Constructor | NotificationProperties Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.DictionaryBase)
Public Property | Item | Collection of menu items to be displayed in Action Context Menu.
Public Property | Keys | Collection of keys to be sent to the client side. Users can configure the keys in client side.
Public Property | Values | Collection of values to be sent to the client side. Users can customize the values in client side.
Top

Public Methods

 | Name | Description
Public Method | Add |
Public Method | Clear | (Inherited from System.Collections.DictionaryBase)
Public Method | Contains |
Public Method | ContainsKey |
Public Method | ContainsValue |
Public Method | CopyTo | (Inherited from System.Collections.DictionaryBase)
Public Method | GetEnumerator | (Inherited from System.Collections.DictionaryBase)
Public Method | Remove |
Top

See Also

Reference

NotificationProperties Class
ISNet.WebUI.WebDesktop Namespace


NotificationProperties Constructor

[image]
Intersoft WebDesktop Documentation
NotificationProperties Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > NotificationProperties Class : NotificationProperties Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New NotificationProperties()
C#
public NotificationProperties()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NotificationProperties Class
NotificationProperties Members


NotificationProperties Class Methods

[image]
Intersoft WebDesktop Documentation
NotificationProperties Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : NotificationProperties Class

Glossary Item Box

For a list of all members of this type, see NotificationProperties members.

Public Methods

 | Name | Description
Public Method | Add |
Public Method | Clear | (Inherited from System.Collections.DictionaryBase)
Public Method | Contains |
Public Method | ContainsKey |
Public Method | ContainsValue |
Public Method | CopyTo | (Inherited from System.Collections.DictionaryBase)
Public Method | GetEnumerator | (Inherited from System.Collections.DictionaryBase)
Public Method | Remove |
Top

See Also

Reference

NotificationProperties Class
ISNet.WebUI.WebDesktop Namespace


Add Method

[image]
Intersoft WebDesktop Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > NotificationProperties Class : Add Method

key
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Add( _
   ByVal key As String, _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As NotificationProperties
Dim key As String
Dim value As String

instance.Add(key, value)
C#
public virtual void Add(
   string key,
   string value
)

Parameters

key
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NotificationProperties Class
NotificationProperties Members


Clear Method

[image]
Intersoft WebDesktop Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > NotificationProperties Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As NotificationProperties

instance.Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NotificationProperties Class
NotificationProperties Members


Contains Method

[image]
Intersoft WebDesktop Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > NotificationProperties Class : Contains Method

key

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Contains( _
   ByVal key As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As NotificationProperties
Dim key As String
Dim value As Boolean

value = instance.Contains(key)
C#
public virtual bool Contains(
   string key
)

Parameters

key

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NotificationProperties Class
NotificationProperties Members


ContainsKey Method

[image]
Intersoft WebDesktop Documentation
ContainsKey Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > NotificationProperties Class : ContainsKey Method

key

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ContainsKey( _
   ByVal key As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As NotificationProperties
Dim key As String
Dim value As Boolean

value = instance.ContainsKey(key)
C#
public virtual bool ContainsKey(
   string key
)

Parameters

key

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NotificationProperties Class
NotificationProperties Members


ContainsValue Method

[image]
Intersoft WebDesktop Documentation
ContainsValue Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > NotificationProperties Class : ContainsValue Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ContainsValue( _
   ByVal value As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As NotificationProperties
Dim value As String
Dim value As Boolean

value = instance.ContainsValue(value)
C#
public virtual bool ContainsValue(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NotificationProperties Class
NotificationProperties Members


CopyTo Method

[image]
Intersoft WebDesktop Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > NotificationProperties Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As NotificationProperties
Dim array As Array
Dim index As Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   Array array,
   int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NotificationProperties Class
NotificationProperties Members


GetEnumerator Method

[image]
Intersoft WebDesktop Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > NotificationProperties Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As System.Collections.IDictionaryEnumerator
Visual Basic (Usage) Copy Code
Dim instance As NotificationProperties
Dim value As System.Collections.IDictionaryEnumerator

value = instance.GetEnumerator()
C#
public System.Collections.IDictionaryEnumerator GetEnumerator()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NotificationProperties Class
NotificationProperties Members


Remove Method

[image]
Intersoft WebDesktop Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > NotificationProperties Class : Remove Method

key

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Remove( _
   ByVal key As String _
)
Visual Basic (Usage) Copy Code
Dim instance As NotificationProperties
Dim key As String

instance.Remove(key)
C#
public virtual void Remove(
   string key
)

Parameters

key

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NotificationProperties Class
NotificationProperties Members


Count Property

[image]
Intersoft WebDesktop Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > NotificationProperties Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As NotificationProperties
Dim value As Integer

value = instance.Count
C#
public int Count {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NotificationProperties Class
NotificationProperties Members


NotificationProperties Class Properties

[image]
Intersoft WebDesktop Documentation
NotificationProperties Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : NotificationProperties Class

Glossary Item Box

For a list of all members of this type, see NotificationProperties members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.DictionaryBase)
Public Property | Item | Collection of menu items to be displayed in Action Context Menu.
Public Property | Keys | Collection of keys to be sent to the client side. Users can configure the keys in client side.
Public Property | Values | Collection of values to be sent to the client side. Users can customize the values in client side.
Top

See Also

Reference

NotificationProperties Class
ISNet.WebUI.WebDesktop Namespace


Item Property

[image]
Intersoft WebDesktop Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > NotificationProperties Class : Item Property

key

Glossary Item Box

Collection of menu items to be displayed in Action Context Menu.

Syntax

Visual Basic (Declaration)
Public Overridable Default Property Item( _
   ByVal key As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As NotificationProperties
Dim key As String
Dim value As String

instance.Item(key) = value

value = instance.Item(key)
C#
public virtual string this[
   string key
]; {get; set;}

Parameters

key

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NotificationProperties Class
NotificationProperties Members


Keys Property

[image]
Intersoft WebDesktop Documentation
Keys Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > NotificationProperties Class : Keys Property

Glossary Item Box

Collection of keys to be sent to the client side. Users can configure the keys in client side.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Keys As System.Collections.ICollection
Visual Basic (Usage) Copy Code
Dim instance As NotificationProperties
Dim value As System.Collections.ICollection

value = instance.Keys
C#
public virtual System.Collections.ICollection Keys {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NotificationProperties Class
NotificationProperties Members


Values Property

[image]
Intersoft WebDesktop Documentation
Values Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > NotificationProperties Class : Values Property

Glossary Item Box

Collection of values to be sent to the client side. Users can customize the values in client side.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Values As System.Collections.ICollection
Visual Basic (Usage) Copy Code
Dim instance As NotificationProperties
Dim value As System.Collections.ICollection

value = instance.Values
C#
public virtual System.Collections.ICollection Values {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NotificationProperties Class
NotificationProperties Members


PaneItemClickEventArgs Class

[image]
Intersoft WebDesktop Documentation
PaneItemClickEventArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : PaneItemClickEventArgs Class

Glossary Item Box

Object Model

PaneItemClickEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class PaneItemClickEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As PaneItemClickEventArgs
C#
public class PaneItemClickEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebDesktop.PaneItemClickEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaneItemClickEventArgs Members
ISNet.WebUI.WebDesktop Namespace


PaneItemClickEventArgs Class Members

[image]
Intersoft WebDesktop Documentation
PaneItemClickEventArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebDesktop Namespace : PaneItemClickEventArgs Class

Glossary Item Box

The following tables list the members exposed by PaneItemClickEventArgs.

Public Constructors

 | Name | Description
Public Constructor | PaneItemClickEventArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Item |
Top

See Also

Reference

PaneItemClickEventArgs Class
ISNet.WebUI.WebDesktop Namespace


PaneItemClickEventArgs Constructor

[image]
Intersoft WebDesktop Documentation
PaneItemClickEventArgs Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PaneItemClickEventArgs Class : PaneItemClickEventArgs Constructor

paneItem

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal paneItem As WebExplorerBarItem _
)
Visual Basic (Usage) Copy Code
Dim paneItem As WebExplorerBarItem

Dim instance As New PaneItemClickEventArgs(paneItem)
C#
public PaneItemClickEventArgs(
   WebExplorerBarItem paneItem
)

Parameters

paneItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaneItemClickEventArgs Class
PaneItemClickEventArgs Members


PaneItemClickEventArgs Class Properties

[image]
Intersoft WebDesktop Documentation
PaneItemClickEventArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : PaneItemClickEventArgs Class

Glossary Item Box

For a list of all members of this type, see PaneItemClickEventArgs members.

Public Properties

 | Name | Description
Public Property | Item |
Top

See Also

Reference

PaneItemClickEventArgs Class
ISNet.WebUI.WebDesktop Namespace


Item Property

[image]
Intersoft WebDesktop Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PaneItemClickEventArgs Class : Item Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Item As WebExplorerBarItem
Visual Basic (Usage) Copy Code
Dim instance As PaneItemClickEventArgs
Dim value As WebExplorerBarItem

value = instance.Item
C#
public WebExplorerBarItem Item {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaneItemClickEventArgs Class
PaneItemClickEventArgs Members


PlaceHolderManager Class

[image]
Intersoft WebDesktop Documentation
PlaceHolderManager Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : PlaceHolderManager Class

Glossary Item Box

Represents a partitioned container in a WebForm which supports docking capabilities for IBar implemented controls. PlaceHolderManager can be used with WebMenuBar and WebToolBar components.

Object Model

PlaceHolderManager Class

Syntax

Visual Basic (Declaration)
Public Class PlaceHolderManager
   Inherits ISNet.WebUI.ISNetControl
   Implements ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, IWebMenuControl
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
C#
public class PlaceHolderManager : ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, IWebMenuControl

Remarks

The main objective of the PlaceHolderManager is to enable a certain zone in the WebForm to be marked as "dockable boundaries". This is also called PlaceHolderManager's Container. The container can be either Html Server Control DIV type or Html Server Control TABLE type.

At component design, the PlaceHolderManager is a non-visual server side control which can be instantiated by dropping it from ToolBox. The PlaceHolderManager is also accompanied with a new innovative PlaceHolder Designer to let developers work easily with the PlaceHolderManager and the contained Bars.

One of the important benefits of PlaceHolderManager is its tight integration with IBar implemented controls. The PlaceHolderManager acts as the manager for all bars that it owned. PlaceHolderManager contains all master configurations such as styles and behaviors of the ToolBar and MenuBar.

The tight integration feature significantly improves developer's productivity with the global configurations managed by the PlaceHolderManager, since you don't have to configure the style or behavior of all Bars individually (especially when there are large number of Bars in the WebForm).

Other popular benefit of the integration is the clean tags and reduced HTML output for the Bars server control definition. Each Bar typically would only need to have the Collection definition since other behaviors and the styles are inherited automatically from its PlaceHolderManager.

The following are some recommendations on best practices for using PlaceHolderManager.

Use PlaceHolderManager when:

  • The page requires docking functionalities.
  • The page contains more than one bar instance.
  • The page requires bars which is customizable (through AllowCustomize).
  • The page contains multiple type of Bars. For instance, MenuBar and ToolBar.
  • The page requires visual styles consistency of all Bars, and style inherittance from DesktopManager.

Do not use PlaceHolderManager when:

  • The page contains only one instance of Bar and there are no intentions to add more Bars in the future.
  • The page contains bars which doesn't require docking functionalities

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
ISNet.WebUI.ISNetControl
ISNet.WebUI.WebDesktop.PlaceHolderManager

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Members
ISNet.WebUI.WebDesktop Namespace

Concepts

PlaceHolderManager Concept

Tasks

Using MenuBar in PlaceHolderManager mode

concepts

Interactive PlaceHolderManager Designer


PlaceHolderManager Class Members

[image]
Intersoft WebDesktop Documentation
PlaceHolderManager Class Members
See Also Properties Methods Events Send Feedback
ISNet.WebUI.WebDesktop Namespace : PlaceHolderManager Class

Glossary Item Box

The following tables list the members exposed by PlaceHolderManager.

Public Constructors

 | Name | Description
Public Constructor | PlaceHolderManager Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | AddRemoveOptionMenuViewMode |
Public Property | AllowCustomize |
Public Property | AllowDockBottom | Gets or sets a value that indicates whether Bar controls in PlaceHolderManager can be dock to bottom area of PlaceHolderManager.
Public Property | AllowDockLeft | Gets or sets a value that indicates whether Bar controls in PlaceHolderManager can be dock to left area of PlaceHolderManager.
Public Property | AllowDockRight | Gets or sets a value that indicates whether Bar controls in PlaceHolderManager can be dock to right area of PlaceHolderManager.
Public Property | AllowDockTop | Gets or sets a value that indicates whether Bar controls in PlaceHolderManager can be dock to top area of PlaceHolderManager.
Public Property | AllowExpandCollapse |
Public Property | AllowFloat |
Public Property | AllowMove |
Public Property | AlwaysShowFullMenus | Specifies whether PlaceHolderManager always show full menu of WebMenuBar and WebToolBar.
Public Property | BackColor | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | BarStyle |
Public Property | BorderColor | Color of the border around the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | BorderStyle | Style of the border around the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | BorderWidth | Width of the border around the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | CommandSize |
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | CssClass | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | DisplayAccessKeyOnToolTip |
Public Property | DisplayMode |
Public Property | DisplayToolTip |
Public Property | DockAreaStyle |
Public Property | DockingArea |
Public Property | DockingOffset |
Public Property | Enabled | Enables state of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableManagedTheming | Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableMergeBar |
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | Gets or sets whether the control automatically saves its state for use in round-trip. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). (Inherited from ISNet.WebUI.ISNetControl)
Public Property | FillDockingRow |
Public Property | ForeColor | Color of the text within the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | GreyImageWhenDisabled |
Public Property | HandleVisible |
Public Property | HeaderHeight |
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ImagesDirectory | Gets or sets the location of images used to render the control.
Public Property | ImageSize |
Public Property | IntegratedTo |
Public Property | IsDefaultPagePlaceHolderManager |
Public Property | IsFloat |
Public Property | MaxDockingRows | Gets or sets maximum docking rows for docking area.
Public Property | MenuStyleSettings |
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | PlaceHolderContainer |
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden. Gets or sets the directory where all required scripts for the control are stored.
Public Property | SharedScriptDirectory | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ShowDelay |
Public Property | SizeMode |
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | TextAlign |
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateItems | Gets or sets the items to be stored in view state storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | Gets or sets the server connection string for file server-based viewstate storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | Gets or sets the location to store the viewstate of this control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | WebMenuBarStyleSettings | Gets or sets the style properties of WebMenuBar control managed by PlaceHolderManager.
Public Property | WebToolBarStyleSettings | Gets or sets the style properties of WebToolBar control managed by PlaceHolderManager.
Public Property | XmlCompressionEnabled | Specifies whether the Xml used for clientside state storage should be compressed. (Inherited from ISNet.WebUI.ISNetControl)
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CheckConstrains | Overridden.
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ContainsAnyWebMenuBar |
Public Method | ContainsAnyWebToolBar |
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CustomDeserialize |
Public Method | CustomSerialize |
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | GetXMLData | Overridden.
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAnyAllowCustomize |
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadInstanceFromStream |
Public Method | LoadInstanceFromXml |
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPostData | Overridden.
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterScript | Overridden.
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResetUsageData |
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveInstanceToXml |
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SynchronizeBarProperties |
Top

Public Events

 | Name | Description
Public Event | BarPropertiesChanged | Fires when the properties of WebMenuBar or WebToolBar are changed.
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

PlaceHolderManager Class
ISNet.WebUI.WebDesktop Namespace

Concepts

PlaceHolderManager Concept

Tasks

Using MenuBar in PlaceHolderManager mode

concepts

Interactive PlaceHolderManager Designer


PlaceHolderManager Constructor

[image]
Intersoft WebDesktop Documentation
PlaceHolderManager Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : PlaceHolderManager Constructor

Glossary Item Box

Initializes a new instance of the PlaceHolderManager class.

Overload List

Overload | Description
PlaceHolderManager Constructor() |
PlaceHolderManager Constructor(IContainer) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


PlaceHolderManager Constructor()

[image]
Intersoft WebDesktop Documentation
PlaceHolderManager Constructor()
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class > PlaceHolderManager Constructor : PlaceHolderManager Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New PlaceHolderManager()
C#
public PlaceHolderManager()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members
Overload List


PlaceHolderManager Constructor(IContainer)

[image]
Intersoft WebDesktop Documentation
PlaceHolderManager Constructor(IContainer)
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class > PlaceHolderManager Constructor : PlaceHolderManager Constructor(IContainer)

container

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal container As System.ComponentModel.IContainer _
)
Visual Basic (Usage) Copy Code
Dim container As System.ComponentModel.IContainer

Dim instance As New PlaceHolderManager(container)
C#
public PlaceHolderManager(
   System.ComponentModel.IContainer container
)

Parameters

container

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members
Overload List


ApplyStyle Method

[image]
Intersoft WebDesktop Documentation
ApplyStyle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : ApplyStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ApplyStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim s As System.Web.UI.WebControls.Style

instance.ApplyStyle(s)
C#
public void ApplyStyle(
   System.Web.UI.WebControls.Style s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


ApplyStyleSheetSkin Method

[image]
Intersoft WebDesktop Documentation
ApplyStyleSheetSkin Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : ApplyStyleSheetSkin Method

page

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub ApplyStyleSheetSkin( _
   ByVal page As System.Web.UI.Page _
)
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim page As System.Web.UI.Page

instance.ApplyStyleSheetSkin(page)
C#
public virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page page
)

Parameters

page

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


CanUseWebResources Method

[image]
Intersoft WebDesktop Documentation
CanUseWebResources Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : CanUseWebResources Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CanUseWebResources() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As Boolean

value = instance.CanUseWebResources()
C#
public bool CanUseWebResources()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


PlaceHolderManager Class Methods

[image]
Intersoft WebDesktop Documentation
PlaceHolderManager Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : PlaceHolderManager Class

Glossary Item Box

For a list of all members of this type, see PlaceHolderManager members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CheckConstrains | Overridden.
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ContainsAnyWebMenuBar |
Public Method | ContainsAnyWebToolBar |
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CustomDeserialize |
Public Method | CustomSerialize |
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | GetXMLData | Overridden.
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAnyAllowCustomize |
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadInstanceFromStream |
Public Method | LoadInstanceFromXml |
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPostData | Overridden.
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterScript | Overridden.
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResetUsageData |
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveInstanceToXml |
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SynchronizeBarProperties |
Top

See Also

Reference

PlaceHolderManager Class
ISNet.WebUI.WebDesktop Namespace

Concepts

PlaceHolderManager Concept

Tasks

Using MenuBar in PlaceHolderManager mode

concepts

Interactive PlaceHolderManager Designer


CheckConstrains Method

[image]
Intersoft WebDesktop Documentation
CheckConstrains Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : CheckConstrains Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub CheckConstrains()
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager

instance.CheckConstrains()
C#
public override void CheckConstrains()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


ContainsAnyWebMenuBar Method

[image]
Intersoft WebDesktop Documentation
ContainsAnyWebMenuBar Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : ContainsAnyWebMenuBar Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ContainsAnyWebMenuBar() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As Boolean

value = instance.ContainsAnyWebMenuBar()
C#
public bool ContainsAnyWebMenuBar()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


ContainsAnyWebToolBar Method

[image]
Intersoft WebDesktop Documentation
ContainsAnyWebToolBar Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : ContainsAnyWebToolBar Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ContainsAnyWebToolBar() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As Boolean

value = instance.ContainsAnyWebToolBar()
C#
public bool ContainsAnyWebToolBar()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


CopyBaseAttributes Method

[image]
Intersoft WebDesktop Documentation
CopyBaseAttributes Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : CopyBaseAttributes Method

controlSrc

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyBaseAttributes( _
   ByVal controlSrc As System.Web.UI.WebControls.WebControl _
)
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim controlSrc As System.Web.UI.WebControls.WebControl

instance.CopyBaseAttributes(controlSrc)
C#
public void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl controlSrc
)

Parameters

controlSrc

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.ISNetControl)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members
Overload List


CustomDeserialize Method

[image]
Intersoft WebDesktop Documentation
CustomDeserialize Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : CustomDeserialize Method

mi
currentObj
parentNode
currentNode

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CustomDeserialize( _
   ByVal mi As System.Reflection.MemberInfo, _
   ByVal currentObj As Object, _
   ByVal parentNode As System.Xml.XmlNode, _
   ByVal currentNode As System.Xml.XmlNode _
)
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim mi As System.Reflection.MemberInfo
Dim currentObj As Object
Dim parentNode As System.Xml.XmlNode
Dim currentNode As System.Xml.XmlNode

instance.CustomDeserialize(mi, currentObj, parentNode, currentNode)
C#
public void CustomDeserialize(
   System.Reflection.MemberInfo mi,
   object currentObj,
   System.Xml.XmlNode parentNode,
   System.Xml.XmlNode currentNode
)

Parameters

mi
currentObj
parentNode
currentNode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


CustomSerialize Method

[image]
Intersoft WebDesktop Documentation
CustomSerialize Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : CustomSerialize Method

doc
node

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CustomSerialize( _
   ByVal doc As System.Xml.XmlDocument, _
   ByVal node As System.Xml.XmlNode _
)
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim doc As System.Xml.XmlDocument
Dim node As System.Xml.XmlNode

instance.CustomSerialize(doc, node)
C#
public void CustomSerialize(
   System.Xml.XmlDocument doc,
   System.Xml.XmlNode node
)

Parameters

doc
node

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


DataBind Method

[image]
Intersoft WebDesktop Documentation
DataBind Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : DataBind Method

Glossary Item Box

Overload List

Overload | Description
DataBind | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


DataBind() Method

[image]
Intersoft WebDesktop Documentation
DataBind() Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : DataBind() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub DataBind()
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager

instance.DataBind()
C#
public virtual void DataBind()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


Dispose Method

[image]
Intersoft WebDesktop Documentation
Dispose Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : Dispose Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager

instance.Dispose()
C#
public virtual void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


FindControl Method

[image]
Intersoft WebDesktop Documentation
FindControl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : FindControl Method

Glossary Item Box

Overload List

Overload | Description
FindControl | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


FindControl(String) Method

[image]
Intersoft WebDesktop Documentation
FindControl(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : FindControl(String) Method

id

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function FindControl( _
   ByVal id As String _
) As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim id As String
Dim value As System.Web.UI.Control

value = instance.FindControl(id)
C#
public virtual System.Web.UI.Control FindControl(
   string id
)

Parameters

id

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


Focus Method

[image]
Intersoft WebDesktop Documentation
Focus Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : Focus Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Focus()
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager

instance.Focus()
C#
public virtual void Focus()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


ForceDisableXmlCompression Method

[image]
Intersoft WebDesktop Documentation
ForceDisableXmlCompression Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : ForceDisableXmlCompression Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ForceDisableXmlCompression()
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager

instance.ForceDisableXmlCompression()
C#
public void ForceDisableXmlCompression()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


GetCurrentControlLifeCycle Method

[image]
Intersoft WebDesktop Documentation
GetCurrentControlLifeCycle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : GetCurrentControlLifeCycle Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentControlLifeCycle() As ISNet.WebUI.ControlLifeCycle
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As ISNet.WebUI.ControlLifeCycle

value = instance.GetCurrentControlLifeCycle()
C#
public ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


GetCurrentTheme Method

[image]
Intersoft WebDesktop Documentation
GetCurrentTheme Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : GetCurrentTheme Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentTheme() As ISNet.WebUI.ThemeInfo
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As ISNet.WebUI.ThemeInfo

value = instance.GetCurrentTheme()
C#
public ISNet.WebUI.ThemeInfo GetCurrentTheme()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


GetFrameworkDataFolder Method

[image]
Intersoft WebDesktop Documentation
GetFrameworkDataFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : GetFrameworkDataFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkDataFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As String

value = instance.GetFrameworkDataFolder()
C#
public string GetFrameworkDataFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


GetFrameworkFolder Method

[image]
Intersoft WebDesktop Documentation
GetFrameworkFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : GetFrameworkFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As String

value = instance.GetFrameworkFolder()
C#
public string GetFrameworkFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


GetFrameworkVersion Method

[image]
Intersoft WebDesktop Documentation
GetFrameworkVersion Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : GetFrameworkVersion Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkVersion() As Version
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As Version

value = instance.GetFrameworkVersion()
C#
public Version GetFrameworkVersion()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


GetIntersoftFolder Method

[image]
Intersoft WebDesktop Documentation
GetIntersoftFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : GetIntersoftFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetIntersoftFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As String

value = instance.GetIntersoftFolder()
C#
public string GetIntersoftFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


GetLayoutFolder Method

[image]
Intersoft WebDesktop Documentation
GetLayoutFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : GetLayoutFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetLayoutFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As String

value = instance.GetLayoutFolder()
C#
public string GetLayoutFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


GetPostedXMLData Method

[image]
Intersoft WebDesktop Documentation
GetPostedXMLData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : GetPostedXMLData Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPostedXMLData() As String
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As String

value = instance.GetPostedXMLData()
C#
public string GetPostedXMLData()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


GetProductInfoKey Method

[image]
Intersoft WebDesktop Documentation
GetProductInfoKey Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : GetProductInfoKey Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductInfoKey() As String
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As String

value = instance.GetProductInfoKey()
C#
public string GetProductInfoKey()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


GetProductSimpleName Method

[image]
Intersoft WebDesktop Documentation
GetProductSimpleName Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : GetProductSimpleName Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductSimpleName() As String
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As String

value = instance.GetProductSimpleName()
C#
public string GetProductSimpleName()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


GetPropertyValue Method

[image]
Intersoft WebDesktop Documentation
GetPropertyValue Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : GetPropertyValue Method

defValue
propValue
webConfigKey

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPropertyValue( _
   ByVal defValue As String, _
   ByVal propValue As String, _
   ByVal webConfigKey As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim defValue As String
Dim propValue As String
Dim webConfigKey As String
Dim value As String

value = instance.GetPropertyValue(defValue, propValue, webConfigKey)
C#
public string GetPropertyValue(
   string defValue,
   string propValue,
   string webConfigKey
)

Parameters

defValue
propValue
webConfigKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


GetResourceStream Method

[image]
Intersoft WebDesktop Documentation
GetResourceStream Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : GetResourceStream Method

resourceUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetResourceStream( _
   ByVal resourceUrl As String _
) As System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim resourceUrl As String
Dim value As System.IO.Stream

value = instance.GetResourceStream(resourceUrl)
C#
public System.IO.Stream GetResourceStream(
   string resourceUrl
)

Parameters

resourceUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


GetRouteUrl Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : GetRouteUrl Method

Glossary Item Box

Overload List

Overload | Description
GetRouteUrl(Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(RouteValueDictionary) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,RouteValueDictionary) | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


GetRouteUrl(Object) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class > GetRouteUrl Method : GetRouteUrl(Object) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As Object _
) As String
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim routeParameters As Object
Dim value As String

value = instance.GetRouteUrl(routeParameters)
C#
public string GetRouteUrl(
   object routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members
Overload List


GetRouteUrl(String,Object) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(String,Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class > GetRouteUrl Method : GetRouteUrl(String,Object) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As String, _
   ByVal routeParameters As Object _
) As String
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim routeName As String
Dim routeParameters As Object
Dim value As String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public string GetRouteUrl(
   string routeName,
   object routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members
Overload List


GetRouteUrl(RouteValueDictionary) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(RouteValueDictionary) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class > GetRouteUrl Method : GetRouteUrl(RouteValueDictionary) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As String
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As String

value = instance.GetRouteUrl(routeParameters)
C#
public string GetRouteUrl(
   System.Web.Routing.RouteValueDictionary routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members
Overload List


GetRouteUrl(String,RouteValueDictionary) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(String,RouteValueDictionary) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class > GetRouteUrl Method : GetRouteUrl(String,RouteValueDictionary) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As String, _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As String
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim routeName As String
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public string GetRouteUrl(
   string routeName,
   System.Web.Routing.RouteValueDictionary routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members
Overload List


GetUniqueIDRelativeTo Method

[image]
Intersoft WebDesktop Documentation
GetUniqueIDRelativeTo Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : GetUniqueIDRelativeTo Method

control

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetUniqueIDRelativeTo( _
   ByVal control As System.Web.UI.Control _
) As String
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim control As System.Web.UI.Control
Dim value As String

value = instance.GetUniqueIDRelativeTo(control)
C#
public string GetUniqueIDRelativeTo(
   System.Web.UI.Control control
)

Parameters

control

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


GetXMLData Method

[image]
Intersoft WebDesktop Documentation
GetXMLData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : GetXMLData Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function GetXMLData() As String
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As String

value = instance.GetXMLData()
C#
public override string GetXMLData()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


HasControls Method

[image]
Intersoft WebDesktop Documentation
HasControls Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : HasControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function HasControls() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As Boolean

value = instance.HasControls()
C#
public virtual bool HasControls()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


IsAnyAllowCustomize Method

[image]
Intersoft WebDesktop Documentation
IsAnyAllowCustomize Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : IsAnyAllowCustomize Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsAnyAllowCustomize() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As Boolean

value = instance.IsAnyAllowCustomize()
C#
public bool IsAnyAllowCustomize()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


IsAtlasCallback Method

[image]
Intersoft WebDesktop Documentation
IsAtlasCallback Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : IsAtlasCallback Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsAtlasCallback() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As Boolean

value = instance.IsAtlasCallback()
C#
public bool IsAtlasCallback()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


IsBetaRelease Method

[image]
Intersoft WebDesktop Documentation
IsBetaRelease Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : IsBetaRelease Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsBetaRelease() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As Boolean

value = instance.IsBetaRelease()
C#
public bool IsBetaRelease()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


IsChromeBrowser Method

[image]
Intersoft WebDesktop Documentation
IsChromeBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : IsChromeBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsChromeBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As Boolean

value = instance.IsChromeBrowser()
C#
public bool IsChromeBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


IsFlyPostBackControl Method

[image]
Intersoft WebDesktop Documentation
IsFlyPostBackControl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : IsFlyPostBackControl Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackControl() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As Boolean

value = instance.IsFlyPostBackControl()
C#
public virtual bool IsFlyPostBackControl()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


IsFlyPostBackRequest Method

[image]
Intersoft WebDesktop Documentation
IsFlyPostBackRequest Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : IsFlyPostBackRequest Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackRequest() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As Boolean

value = instance.IsFlyPostBackRequest()
C#
public virtual bool IsFlyPostBackRequest()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


IsGeckoBasedBrowser Method

[image]
Intersoft WebDesktop Documentation
IsGeckoBasedBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : IsGeckoBasedBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoBasedBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As Boolean

value = instance.IsGeckoBasedBrowser()
C#
public bool IsGeckoBasedBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


IsGeckoVersion18 Method

[image]
Intersoft WebDesktop Documentation
IsGeckoVersion18 Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : IsGeckoVersion18 Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoVersion18() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As Boolean

value = instance.IsGeckoVersion18()
C#
public bool IsGeckoVersion18()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


IsInDesignMode Method

[image]
Intersoft WebDesktop Documentation
IsInDesignMode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : IsInDesignMode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInDesignMode() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As Boolean

value = instance.IsInDesignMode()
C#
public bool IsInDesignMode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


IsInternetExplorer8Browser Method

[image]
Intersoft WebDesktop Documentation
IsInternetExplorer8Browser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : IsInternetExplorer8Browser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorer8Browser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As Boolean

value = instance.IsInternetExplorer8Browser()
C#
public bool IsInternetExplorer8Browser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


IsInternetExplorerBrowser Method

[image]
Intersoft WebDesktop Documentation
IsInternetExplorerBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : IsInternetExplorerBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorerBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As Boolean

value = instance.IsInternetExplorerBrowser()
C#
public bool IsInternetExplorerBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


IsOperaBrowser Method

[image]
Intersoft WebDesktop Documentation
IsOperaBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : IsOperaBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsOperaBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As Boolean

value = instance.IsOperaBrowser()
C#
public bool IsOperaBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


IsSafariBrowser Method

[image]
Intersoft WebDesktop Documentation
IsSafariBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : IsSafariBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsSafariBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As Boolean

value = instance.IsSafariBrowser()
C#
public bool IsSafariBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


IsW3CStandardBrowser Method

[image]
Intersoft WebDesktop Documentation
IsW3CStandardBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : IsW3CStandardBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsW3CStandardBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As Boolean

value = instance.IsW3CStandardBrowser()
C#
public bool IsW3CStandardBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


LoadInstanceFromStream Method

[image]
Intersoft WebDesktop Documentation
LoadInstanceFromStream Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : LoadInstanceFromStream Method

stream

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub LoadInstanceFromStream( _
   ByVal stream As System.IO.Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim stream As System.IO.Stream

instance.LoadInstanceFromStream(stream)
C#
public void LoadInstanceFromStream(
   System.IO.Stream stream
)

Parameters

stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


LoadInstanceFromXml Method

[image]
Intersoft WebDesktop Documentation
LoadInstanceFromXml Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : LoadInstanceFromXml Method

fileName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub LoadInstanceFromXml( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim fileName As String

instance.LoadInstanceFromXml(fileName)
C#
public void LoadInstanceFromXml(
   string fileName
)

Parameters

fileName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


LoadLayout Method

[image]
Intersoft WebDesktop Documentation
LoadLayout Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : LoadLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim settings As ISNet.WebUI.LayoutInfo

instance.LoadLayout(settings)
C#
public virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


LoadLayoutFromFile Method

[image]
Intersoft WebDesktop Documentation
LoadLayoutFromFile Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : LoadLayoutFromFile Method

filePath

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromFile( _
   ByVal filePath As String _
)
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim filePath As String

instance.LoadLayoutFromFile(filePath)
C#
public virtual void LoadLayoutFromFile(
   string filePath
)

Parameters

filePath

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


LoadLayoutFromPredefinedName Method

[image]
Intersoft WebDesktop Documentation
LoadLayoutFromPredefinedName Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : LoadLayoutFromPredefinedName Method

predefinedName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromPredefinedName( _
   ByVal predefinedName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim predefinedName As String

instance.LoadLayoutFromPredefinedName(predefinedName)
C#
public virtual void LoadLayoutFromPredefinedName(
   string predefinedName
)

Parameters

predefinedName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


LoadLayoutFromStream Method

[image]
Intersoft WebDesktop Documentation
LoadLayoutFromStream Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : LoadLayoutFromStream Method

stream

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromStream( _
   ByVal stream As System.IO.Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim stream As System.IO.Stream

instance.LoadLayoutFromStream(stream)
C#
public virtual void LoadLayoutFromStream(
   System.IO.Stream stream
)

Parameters

stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


LoadPostData Method

[image]
Intersoft WebDesktop Documentation
LoadPostData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : LoadPostData Method

postDataKey
postCollection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function LoadPostData( _
   ByVal postDataKey As String, _
   ByVal postCollection As System.Collections.Specialized.NameValueCollection _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim postDataKey As String
Dim postCollection As System.Collections.Specialized.NameValueCollection
Dim value As Boolean

value = instance.LoadPostData(postDataKey, postCollection)
C#
public override bool LoadPostData(
   string postDataKey,
   System.Collections.Specialized.NameValueCollection postCollection
)

Parameters

postDataKey
postCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


MergeStyle Method

[image]
Intersoft WebDesktop Documentation
MergeStyle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : MergeStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub MergeStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim s As System.Web.UI.WebControls.Style

instance.MergeStyle(s)
C#
public void MergeStyle(
   System.Web.UI.WebControls.Style s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


OnInfoChanged Method

[image]
Intersoft WebDesktop Documentation
OnInfoChanged Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : OnInfoChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnInfoChanged( _
   ByVal e As ISNet.WebUI.SynchronizeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim e As ISNet.WebUI.SynchronizeEventArgs

instance.OnInfoChanged(e)
C#
public void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


OnPreInitialize Method

[image]
Intersoft WebDesktop Documentation
OnPreInitialize Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : OnPreInitialize Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnPreInitialize()
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager

instance.OnPreInitialize()
C#
public virtual void OnPreInitialize()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


RaisePostDataChangedEvent Method

[image]
Intersoft WebDesktop Documentation
RaisePostDataChangedEvent Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : RaisePostDataChangedEvent Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RaisePostDataChangedEvent()
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager

instance.RaisePostDataChangedEvent()
C#
public virtual void RaisePostDataChangedEvent()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


ReadWebConfigValue Method

[image]
Intersoft WebDesktop Documentation
ReadWebConfigValue Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : ReadWebConfigValue Method

key

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ReadWebConfigValue( _
   ByVal key As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim key As String
Dim value As String

value = instance.ReadWebConfigValue(key)
C#
public string ReadWebConfigValue(
   string key
)

Parameters

key

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


RegisterBoxSizing Method

[image]
Intersoft WebDesktop Documentation
RegisterBoxSizing Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : RegisterBoxSizing Method

Glossary Item Box

Overload List

Overload | Description
RegisterBoxSizing() | (Inherited from ISNet.WebUI.ISNetControl)
RegisterBoxSizing(Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


RegisterBoxSizing() Method

[image]
Intersoft WebDesktop Documentation
RegisterBoxSizing() Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class > RegisterBoxSizing Method : RegisterBoxSizing() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing()
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager

instance.RegisterBoxSizing()
C#
public void RegisterBoxSizing()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members
Overload List


RegisterBoxSizing(Boolean) Method

[image]
Intersoft WebDesktop Documentation
RegisterBoxSizing(Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class > RegisterBoxSizing Method : RegisterBoxSizing(Boolean) Method

forceAll

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing( _
   ByVal forceAll As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim forceAll As Boolean

instance.RegisterBoxSizing(forceAll)
C#
public void RegisterBoxSizing(
   bool forceAll
)

Parameters

forceAll

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members
Overload List


RegisterGlobalStyle Method

[image]
Intersoft WebDesktop Documentation
RegisterGlobalStyle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : RegisterGlobalStyle Method

style

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterGlobalStyle( _
   ByVal style As ISNet.WebUI.WebStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim style As ISNet.WebUI.WebStyle

instance.RegisterGlobalStyle(style)
C#
public void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle style
)

Parameters

style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


RegisterLink Method

[image]
Intersoft WebDesktop Documentation
RegisterLink Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : RegisterLink Method

name
url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterLink( _
   ByVal name As String, _
   ByVal url As String _
)
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim name As String
Dim url As String

instance.RegisterLink(name, url)
C#
public void RegisterLink(
   string name,
   string url
)

Parameters

name
url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


RegisterOptimizedCssClasses Method

[image]
Intersoft WebDesktop Documentation
RegisterOptimizedCssClasses Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : RegisterOptimizedCssClasses Method

runtimeStyleOnly

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterOptimizedCssClasses( _
   ByVal runtimeStyleOnly As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim runtimeStyleOnly As Boolean

instance.RegisterOptimizedCssClasses(runtimeStyleOnly)
C#
public void RegisterOptimizedCssClasses(
   bool runtimeStyleOnly
)

Parameters

runtimeStyleOnly

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


RegisterPreloadImage Method

[image]
Intersoft WebDesktop Documentation
RegisterPreloadImage Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : RegisterPreloadImage Method

image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterPreloadImage( _
   ByVal image As String _
)
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim image As String

instance.RegisterPreloadImage(image)
C#
public void RegisterPreloadImage(
   string image
)

Parameters

image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


RegisterScript Method

[image]
Intersoft WebDesktop Documentation
RegisterScript Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : RegisterScript Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub RegisterScript()
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager

instance.RegisterScript()
C#
public override void RegisterScript()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


RegisterSharePointHandler Method

[image]
Intersoft WebDesktop Documentation
RegisterSharePointHandler Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : RegisterSharePointHandler Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RegisterSharePointHandler()
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager

instance.RegisterSharePointHandler()
C#
public virtual void RegisterSharePointHandler()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


RenderBeginTag Method

[image]
Intersoft WebDesktop Documentation
RenderBeginTag Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : RenderBeginTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderBeginTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderBeginTag(writer)
C#
public virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


RenderControl Method

[image]
Intersoft WebDesktop Documentation
RenderControl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : RenderControl Method

Glossary Item Box

Overload List

Overload | Description
RenderControl | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


RenderControl(HtmlTextWriter) Method

[image]
Intersoft WebDesktop Documentation
RenderControl(HtmlTextWriter) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : RenderControl(HtmlTextWriter) Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderControl( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderControl(writer)
C#
public virtual void RenderControl(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


RenderEndTag Method

[image]
Intersoft WebDesktop Documentation
RenderEndTag Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : RenderEndTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub RenderEndTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderEndTag(writer)
C#
public override void RenderEndTag(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


ResetUsageData Method

[image]
Intersoft WebDesktop Documentation
ResetUsageData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : ResetUsageData Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ResetUsageData()
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager

instance.ResetUsageData()
C#
public void ResetUsageData()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


ResolveClientUrl Method

[image]
Intersoft WebDesktop Documentation
ResolveClientUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : ResolveClientUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveClientUrl( _
   ByVal relativeUrl As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim relativeUrl As String
Dim value As String

value = instance.ResolveClientUrl(relativeUrl)
C#
public string ResolveClientUrl(
   string relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


ResolveImagePath Method

[image]
Intersoft WebDesktop Documentation
ResolveImagePath Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : ResolveImagePath Method

folder
image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveImagePath( _
   ByVal folder As String, _
   ByVal image As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim folder As String
Dim image As String
Dim value As String

value = instance.ResolveImagePath(folder, image)
C#
public string ResolveImagePath(
   string folder,
   string image
)

Parameters

folder
image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


ResolveRelativeURL Method

[image]
Intersoft WebDesktop Documentation
ResolveRelativeURL Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : ResolveRelativeURL Method

url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ResolveRelativeURL( _
   ByVal url As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim url As String
Dim value As String

value = instance.ResolveRelativeURL(url)
C#
public virtual string ResolveRelativeURL(
   string url
)

Parameters

url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


ResolveResourceUrl Method

[image]
Intersoft WebDesktop Documentation
ResolveResourceUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : ResolveResourceUrl Method

kind
defaultFolder
currentFolder
resourceName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveResourceUrl( _
   ByVal kind As ISNet.WebUI.ResourceKind, _
   ByVal defaultFolder As String, _
   ByVal currentFolder As String, _
   ByVal resourceName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim kind As ISNet.WebUI.ResourceKind
Dim defaultFolder As String
Dim currentFolder As String
Dim resourceName As String
Dim value As String

value = instance.ResolveResourceUrl(kind, defaultFolder, currentFolder, resourceName)
C#
public string ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   string defaultFolder,
   string currentFolder,
   string resourceName
)

Parameters

kind
defaultFolder
currentFolder
resourceName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


ResolveUrl Method

[image]
Intersoft WebDesktop Documentation
ResolveUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : ResolveUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveUrl( _
   ByVal relativeUrl As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim relativeUrl As String
Dim value As String

value = instance.ResolveUrl(relativeUrl)
C#
public string ResolveUrl(
   string relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


SaveInstanceToXml Method

[image]
Intersoft WebDesktop Documentation
SaveInstanceToXml Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : SaveInstanceToXml Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function SaveInstanceToXml() As System.Xml.XmlDocument
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As System.Xml.XmlDocument

value = instance.SaveInstanceToXml()
C#
public System.Xml.XmlDocument SaveInstanceToXml()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


SaveLayout Method

[image]
Intersoft WebDesktop Documentation
SaveLayout Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : SaveLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim settings As ISNet.WebUI.LayoutInfo

instance.SaveLayout(settings)
C#
public virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


SaveLayoutToFile Method

[image]
Intersoft WebDesktop Documentation
SaveLayoutToFile Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : SaveLayoutToFile Method

filePath
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToFile( _
   ByVal filePath As String, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim filePath As String
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToFile(filePath, saveOptions)
C#
public virtual void SaveLayoutToFile(
   string filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

filePath
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


SaveLayoutToStream Method

[image]
Intersoft WebDesktop Documentation
SaveLayoutToStream Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : SaveLayoutToStream Method

stream
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToStream( _
   ByVal stream As System.IO.Stream, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim stream As System.IO.Stream
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToStream(stream, saveOptions)
C#
public virtual void SaveLayoutToStream(
   System.IO.Stream stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

stream
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


SetRenderMethodDelegate Method

[image]
Intersoft WebDesktop Documentation
SetRenderMethodDelegate Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : SetRenderMethodDelegate Method

renderMethod

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetRenderMethodDelegate( _
   ByVal renderMethod As System.Web.UI.RenderMethod _
)
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim renderMethod As System.Web.UI.RenderMethod

instance.SetRenderMethodDelegate(renderMethod)
C#
public void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod renderMethod
)

Parameters

renderMethod

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


SetSessionTheme Method

[image]
Intersoft WebDesktop Documentation
SetSessionTheme Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : SetSessionTheme Method

themeInfo

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetSessionTheme( _
   ByVal themeInfo As ISNet.WebUI.ThemeInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim themeInfo As ISNet.WebUI.ThemeInfo

instance.SetSessionTheme(themeInfo)
C#
public void SetSessionTheme(
   ISNet.WebUI.ThemeInfo themeInfo
)

Parameters

themeInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


ShouldReturnJson Method

[image]
Intersoft WebDesktop Documentation
ShouldReturnJson Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : ShouldReturnJson Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ShouldReturnJson() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As Boolean

value = instance.ShouldReturnJson()
C#
public virtual bool ShouldReturnJson()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


SynchronizeBarProperties Method

[image]
Intersoft WebDesktop Documentation
SynchronizeBarProperties Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : SynchronizeBarProperties Method

propName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SynchronizeBarProperties( _
   ByVal propName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim propName As String

instance.SynchronizeBarProperties(propName)
C#
public void SynchronizeBarProperties(
   string propName
)

Parameters

propName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


AccessKey Property

[image]
Intersoft WebDesktop Documentation
AccessKey Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : AccessKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property AccessKey As String
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As String

instance.AccessKey = value

value = instance.AccessKey
C#
public virtual string AccessKey {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


PlaceHolderManager Class Properties

[image]
Intersoft WebDesktop Documentation
PlaceHolderManager Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : PlaceHolderManager Class

Glossary Item Box

For a list of all members of this type, see PlaceHolderManager members.

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | AddRemoveOptionMenuViewMode |
Public Property | AllowCustomize |
Public Property | AllowDockBottom | Gets or sets a value that indicates whether Bar controls in PlaceHolderManager can be dock to bottom area of PlaceHolderManager.
Public Property | AllowDockLeft | Gets or sets a value that indicates whether Bar controls in PlaceHolderManager can be dock to left area of PlaceHolderManager.
Public Property | AllowDockRight | Gets or sets a value that indicates whether Bar controls in PlaceHolderManager can be dock to right area of PlaceHolderManager.
Public Property | AllowDockTop | Gets or sets a value that indicates whether Bar controls in PlaceHolderManager can be dock to top area of PlaceHolderManager.
Public Property | AllowExpandCollapse |
Public Property | AllowFloat |
Public Property | AllowMove |
Public Property | AlwaysShowFullMenus | Specifies whether PlaceHolderManager always show full menu of WebMenuBar and WebToolBar.
Public Property | BackColor | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | BarStyle |
Public Property | BorderColor | Color of the border around the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | BorderStyle | Style of the border around the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | BorderWidth | Width of the border around the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | CommandSize |
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | CssClass | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | DisplayAccessKeyOnToolTip |
Public Property | DisplayMode |
Public Property | DisplayToolTip |
Public Property | DockAreaStyle |
Public Property | DockingArea |
Public Property | DockingOffset |
Public Property | Enabled | Enables state of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableManagedTheming | Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableMergeBar |
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | Gets or sets whether the control automatically saves its state for use in round-trip. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). (Inherited from ISNet.WebUI.ISNetControl)
Public Property | FillDockingRow |
Public Property | ForeColor | Color of the text within the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | GreyImageWhenDisabled |
Public Property | HandleVisible |
Public Property | HeaderHeight |
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ImagesDirectory | Gets or sets the location of images used to render the control.
Public Property | ImageSize |
Public Property | IntegratedTo |
Public Property | IsDefaultPagePlaceHolderManager |
Public Property | IsFloat |
Public Property | MaxDockingRows | Gets or sets maximum docking rows for docking area.
Public Property | MenuStyleSettings |
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | PlaceHolderContainer |
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden. Gets or sets the directory where all required scripts for the control are stored.
Public Property | SharedScriptDirectory | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ShowDelay |
Public Property | SizeMode |
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | TextAlign |
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateItems | Gets or sets the items to be stored in view state storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | Gets or sets the server connection string for file server-based viewstate storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | Gets or sets the location to store the viewstate of this control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | WebMenuBarStyleSettings | Gets or sets the style properties of WebMenuBar control managed by PlaceHolderManager.
Public Property | WebToolBarStyleSettings | Gets or sets the style properties of WebToolBar control managed by PlaceHolderManager.
Public Property | XmlCompressionEnabled | Specifies whether the Xml used for clientside state storage should be compressed. (Inherited from ISNet.WebUI.ISNetControl)
Top

See Also

Reference

PlaceHolderManager Class
ISNet.WebUI.WebDesktop Namespace

Concepts

PlaceHolderManager Concept

Tasks

Using MenuBar in PlaceHolderManager mode

concepts

Interactive PlaceHolderManager Designer


AddRemoveOptionMenuViewMode Property

[image]
Intersoft WebDesktop Documentation
AddRemoveOptionMenuViewMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : AddRemoveOptionMenuViewMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property AddRemoveOptionMenuViewMode As AddRemoveOptionMenuViewMode
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As AddRemoveOptionMenuViewMode

instance.AddRemoveOptionMenuViewMode = value

value = instance.AddRemoveOptionMenuViewMode
C#
public AddRemoveOptionMenuViewMode AddRemoveOptionMenuViewMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


AllowCustomize Property

[image]
Intersoft WebDesktop Documentation
AllowCustomize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : AllowCustomize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property AllowCustomize As AllowCustomize
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As AllowCustomize

instance.AllowCustomize = value

value = instance.AllowCustomize
C#
public AllowCustomize AllowCustomize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


AllowDockBottom Property

[image]
Intersoft WebDesktop Documentation
AllowDockBottom Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : AllowDockBottom Property

Glossary Item Box

Gets or sets a value that indicates whether Bar controls in PlaceHolderManager can be dock to bottom area of PlaceHolderManager.

Syntax

Visual Basic (Declaration)
Public Property AllowDockBottom As AllowDock
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As AllowDock

instance.AllowDockBottom = value

value = instance.AllowDockBottom
C#
public AllowDock AllowDockBottom {get; set;}

Remarks

Using this property you can drag any bars to anywhere in the designer surface and the PlaceHolderManager system will automatically dock the new bar into available slot according to the specified MaxDockingRows, AllowDockBottom, AllowDockTop, AllowDockLeft and AllowDockRight properties.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members

Concepts

Interactive PlaceHolderManager Designer

concepts

PlaceHolderManager Concept


AllowDockLeft Property

[image]
Intersoft WebDesktop Documentation
AllowDockLeft Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : AllowDockLeft Property

Glossary Item Box

Gets or sets a value that indicates whether Bar controls in PlaceHolderManager can be dock to left area of PlaceHolderManager.

Syntax

Visual Basic (Declaration)
Public Property AllowDockLeft As AllowDock
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As AllowDock

instance.AllowDockLeft = value

value = instance.AllowDockLeft
C#
public AllowDock AllowDockLeft {get; set;}

Remarks

Using this property you can drag any bars to anywhere in the designer surface and the PlaceHolderManager system will automatically dock the new bar into available slot according to the specified MaxDockingRows, AllowDockBottom, AllowDockTop, AllowDockLeft and AllowDockRight properties.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members

Concepts

PlaceHolderManager Concept

concepts

Interactive PlaceHolderManager Designer


AllowDockRight Property

[image]
Intersoft WebDesktop Documentation
AllowDockRight Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : AllowDockRight Property

Glossary Item Box

Gets or sets a value that indicates whether Bar controls in PlaceHolderManager can be dock to right area of PlaceHolderManager.

Syntax

Visual Basic (Declaration)
Public Property AllowDockRight As AllowDock
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As AllowDock

instance.AllowDockRight = value

value = instance.AllowDockRight
C#
public AllowDock AllowDockRight {get; set;}

Remarks

Using this property you can drag any bars to anywhere in the designer surface and the PlaceHolderManager system will automatically dock the new bar into available slot according to the specified MaxDockingRows, AllowDockBottom, AllowDockTop, AllowDockLeft and AllowDockRight properties.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members

Concepts

Interactive PlaceHolderManager Designer

concepts

PlaceHolderManager Concept


AllowDockTop Property

[image]
Intersoft WebDesktop Documentation
AllowDockTop Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : AllowDockTop Property

Glossary Item Box

Gets or sets a value that indicates whether Bar controls in PlaceHolderManager can be dock to top area of PlaceHolderManager.

Syntax

Visual Basic (Declaration)
Public Property AllowDockTop As AllowDock
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As AllowDock

instance.AllowDockTop = value

value = instance.AllowDockTop
C#
public AllowDock AllowDockTop {get; set;}

Remarks

Using this property you can drag any bars to anywhere in the designer surface and the PlaceHolderManager system will automatically dock the new bar into available slot according to the specified MaxDockingRows, AllowDockBottom, AllowDockTop, AllowDockLeft and AllowDockRight properties.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members

Concepts

PlaceHolderManager Concept

concepts

Interactive PlaceHolderManager Designer


AllowExpandCollapse Property

[image]
Intersoft WebDesktop Documentation
AllowExpandCollapse Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : AllowExpandCollapse Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property AllowExpandCollapse As AllowExpandCollapse
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As AllowExpandCollapse

instance.AllowExpandCollapse = value

value = instance.AllowExpandCollapse
C#
public AllowExpandCollapse AllowExpandCollapse {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


AllowFloat Property

[image]
Intersoft WebDesktop Documentation
AllowFloat Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : AllowFloat Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property AllowFloat As AllowFloat
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As AllowFloat

instance.AllowFloat = value

value = instance.AllowFloat
C#
public AllowFloat AllowFloat {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


AllowMove Property

[image]
Intersoft WebDesktop Documentation
AllowMove Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : AllowMove Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property AllowMove As AllowMove
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As AllowMove

instance.AllowMove = value

value = instance.AllowMove
C#
public AllowMove AllowMove {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


AlwaysShowFullMenus Property

[image]
Intersoft WebDesktop Documentation
AlwaysShowFullMenus Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : AlwaysShowFullMenus Property

Glossary Item Box

Specifies whether PlaceHolderManager always show full menu of WebMenuBar and WebToolBar.

Syntax

Visual Basic (Declaration)
Public Property AlwaysShowFullMenus As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As Boolean

instance.AlwaysShowFullMenus = value

value = instance.AlwaysShowFullMenus
C#
public bool AlwaysShowFullMenus {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


BackColor Property

[image]
Intersoft WebDesktop Documentation
BackColor Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : BackColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property BackColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
C#
public virtual System.Drawing.Color BackColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


BarStyle Property

[image]
Intersoft WebDesktop Documentation
BarStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : BarStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property BarStyle As BarStyle
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As BarStyle

instance.BarStyle = value

value = instance.BarStyle
C#
public BarStyle BarStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


BorderColor Property

[image]
Intersoft WebDesktop Documentation
BorderColor Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : BorderColor Property

Glossary Item Box

Color of the border around the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property BorderColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As System.Drawing.Color

instance.BorderColor = value

value = instance.BorderColor
C#
public virtual System.Drawing.Color BorderColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


BorderStyle Property

[image]
Intersoft WebDesktop Documentation
BorderStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : BorderStyle Property

Glossary Item Box

Style of the border around the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property BorderStyle As System.Web.UI.WebControls.BorderStyle
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As System.Web.UI.WebControls.BorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
C#
public virtual System.Web.UI.WebControls.BorderStyle BorderStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


BorderWidth Property

[image]
Intersoft WebDesktop Documentation
BorderWidth Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : BorderWidth Property

Glossary Item Box

Width of the border around the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property BorderWidth As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As System.Web.UI.WebControls.Unit

instance.BorderWidth = value

value = instance.BorderWidth
C#
public virtual System.Web.UI.WebControls.Unit BorderWidth {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


ClientIDMode Property

[image]
Intersoft WebDesktop Documentation
ClientIDMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : ClientIDMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ClientIDMode As System.Web.UI.ClientIDMode
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As System.Web.UI.ClientIDMode

instance.ClientIDMode = value

value = instance.ClientIDMode
C#
public virtual System.Web.UI.ClientIDMode ClientIDMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


CommandSize Property

[image]
Intersoft WebDesktop Documentation
CommandSize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : CommandSize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property CommandSize As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As System.Web.UI.WebControls.Unit

instance.CommandSize = value

value = instance.CommandSize
C#
public System.Web.UI.WebControls.Unit CommandSize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


ControlDataTransferFormat Property

[image]
Intersoft WebDesktop Documentation
ControlDataTransferFormat Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : ControlDataTransferFormat Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ControlDataTransferFormat As ISNet.WebUI.DataTransferFormat
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As ISNet.WebUI.DataTransferFormat

instance.ControlDataTransferFormat = value

value = instance.ControlDataTransferFormat
C#
public virtual ISNet.WebUI.DataTransferFormat ControlDataTransferFormat {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


CssClass Property

[image]
Intersoft WebDesktop Documentation
CssClass Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : CssClass Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property CssClass As String
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As String

instance.CssClass = value

value = instance.CssClass
C#
public virtual string CssClass {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


DisplayAccessKeyOnToolTip Property

[image]
Intersoft WebDesktop Documentation
DisplayAccessKeyOnToolTip Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : DisplayAccessKeyOnToolTip Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property DisplayAccessKeyOnToolTip As DisplayAccessKeyOnToolTip
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As DisplayAccessKeyOnToolTip

instance.DisplayAccessKeyOnToolTip = value

value = instance.DisplayAccessKeyOnToolTip
C#
public DisplayAccessKeyOnToolTip DisplayAccessKeyOnToolTip {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


DisplayMode Property

[image]
Intersoft WebDesktop Documentation
DisplayMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : DisplayMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property DisplayMode As CommandDisplayMode
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As CommandDisplayMode

instance.DisplayMode = value

value = instance.DisplayMode
C#
public CommandDisplayMode DisplayMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


DisplayToolTip Property

[image]
Intersoft WebDesktop Documentation
DisplayToolTip Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : DisplayToolTip Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property DisplayToolTip As DisplayToolTip
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As DisplayToolTip

instance.DisplayToolTip = value

value = instance.DisplayToolTip
C#
public DisplayToolTip DisplayToolTip {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


DockAreaStyle Property

[image]
Intersoft WebDesktop Documentation
DockAreaStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : DockAreaStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property DockAreaStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As ISNet.WebUI.WebStyle

instance.DockAreaStyle = value

value = instance.DockAreaStyle
C#
public virtual ISNet.WebUI.WebStyle DockAreaStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


DockingArea Property

[image]
Intersoft WebDesktop Documentation
DockingArea Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : DockingArea Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property DockingArea As DockingArea
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As DockingArea

instance.DockingArea = value

value = instance.DockingArea
C#
public DockingArea DockingArea {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


DockingOffset Property

[image]
Intersoft WebDesktop Documentation
DockingOffset Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : DockingOffset Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property DockingOffset As Integer
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As Integer

instance.DockingOffset = value

value = instance.DockingOffset
C#
public int DockingOffset {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


Enabled Property

[image]
Intersoft WebDesktop Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : Enabled Property

Glossary Item Box

Enables state of the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property Enabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As Boolean

instance.Enabled = value

value = instance.Enabled
C#
public virtual bool Enabled {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


EnableManagedTheming Property

[image]
Intersoft WebDesktop Documentation
EnableManagedTheming Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : EnableManagedTheming Property

Glossary Item Box

Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.

Syntax

Visual Basic (Declaration)
Public Overridable Property EnableManagedTheming As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As Boolean

instance.EnableManagedTheming = value

value = instance.EnableManagedTheming
C#
public virtual bool EnableManagedTheming {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


EnableMergeBar Property

[image]
Intersoft WebDesktop Documentation
EnableMergeBar Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : EnableMergeBar Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property EnableMergeBar As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As Boolean

instance.EnableMergeBar = value

value = instance.EnableMergeBar
C#
public bool EnableMergeBar {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


EnableTheming Property

[image]
Intersoft WebDesktop Documentation
EnableTheming Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : EnableTheming Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property EnableTheming As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As Boolean

instance.EnableTheming = value

value = instance.EnableTheming
C#
public virtual bool EnableTheming {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


EnableViewState Property

[image]
Intersoft WebDesktop Documentation
EnableViewState Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : EnableViewState Property

Glossary Item Box

Gets or sets whether the control automatically saves its state for use in round-trip.

Syntax

Visual Basic (Declaration)
Public Overridable Property EnableViewState As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As Boolean

instance.EnableViewState = value

value = instance.EnableViewState
C#
public virtual bool EnableViewState {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


EnableWebResources Property

[image]
Intersoft WebDesktop Documentation
EnableWebResources Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : EnableWebResources Property

Glossary Item Box

Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory).

Syntax

Visual Basic (Declaration)
Public Property EnableWebResources As ISNet.WebUI.WebResourceType
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As ISNet.WebUI.WebResourceType

instance.EnableWebResources = value

value = instance.EnableWebResources
C#
public ISNet.WebUI.WebResourceType EnableWebResources {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


FillDockingRow Property

[image]
Intersoft WebDesktop Documentation
FillDockingRow Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : FillDockingRow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property FillDockingRow As FillDockingRow
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As FillDockingRow

instance.FillDockingRow = value

value = instance.FillDockingRow
C#
public FillDockingRow FillDockingRow {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


ForeColor Property

[image]
Intersoft WebDesktop Documentation
ForeColor Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : ForeColor Property

Glossary Item Box

Color of the text within the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property ForeColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
C#
public virtual System.Drawing.Color ForeColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


GreyImageWhenDisabled Property

[image]
Intersoft WebDesktop Documentation
GreyImageWhenDisabled Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : GreyImageWhenDisabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property GreyImageWhenDisabled As GreyImageWhenDisabled
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As GreyImageWhenDisabled

instance.GreyImageWhenDisabled = value

value = instance.GreyImageWhenDisabled
C#
public GreyImageWhenDisabled GreyImageWhenDisabled {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


HandleVisible Property

[image]
Intersoft WebDesktop Documentation
HandleVisible Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : HandleVisible Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property HandleVisible As HandleVisible
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As HandleVisible

instance.HandleVisible = value

value = instance.HandleVisible
C#
public HandleVisible HandleVisible {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


HeaderHeight Property

[image]
Intersoft WebDesktop Documentation
HeaderHeight Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : HeaderHeight Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property HeaderHeight As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As System.Web.UI.WebControls.Unit

instance.HeaderHeight = value

value = instance.HeaderHeight
C#
public System.Web.UI.WebControls.Unit HeaderHeight {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


ID Property

[image]
Intersoft WebDesktop Documentation
ID Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : ID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ID As String
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As String

instance.ID = value

value = instance.ID
C#
public virtual string ID {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


ImagesDirectory Property

[image]
Intersoft WebDesktop Documentation
ImagesDirectory Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : ImagesDirectory Property

Glossary Item Box

Gets or sets the location of images used to render the control.

Syntax

Visual Basic (Declaration)
Public Property ImagesDirectory As String
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As String

instance.ImagesDirectory = value

value = instance.ImagesDirectory
C#
public string ImagesDirectory {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


ImageSize Property

[image]
Intersoft WebDesktop Documentation
ImageSize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : ImageSize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ImageSize As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As System.Drawing.Size

instance.ImageSize = value

value = instance.ImageSize
C#
public System.Drawing.Size ImageSize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


IntegratedTo Property

[image]
Intersoft WebDesktop Documentation
IntegratedTo Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : IntegratedTo Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property IntegratedTo As MenuIntegrationMode
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As MenuIntegrationMode

instance.IntegratedTo = value

value = instance.IntegratedTo
C#
public MenuIntegrationMode IntegratedTo {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


IsDefaultPagePlaceHolderManager Property

[image]
Intersoft WebDesktop Documentation
IsDefaultPagePlaceHolderManager Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : IsDefaultPagePlaceHolderManager Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property IsDefaultPagePlaceHolderManager As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As Boolean

instance.IsDefaultPagePlaceHolderManager = value

value = instance.IsDefaultPagePlaceHolderManager
C#
public virtual bool IsDefaultPagePlaceHolderManager {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


IsFloat Property

[image]
Intersoft WebDesktop Documentation
IsFloat Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : IsFloat Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property IsFloat As IsFloat
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As IsFloat

instance.IsFloat = value

value = instance.IsFloat
C#
public IsFloat IsFloat {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


MaxDockingRows Property

[image]
Intersoft WebDesktop Documentation
MaxDockingRows Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : MaxDockingRows Property

Glossary Item Box

Gets or sets maximum docking rows for docking area.

Syntax

Visual Basic (Declaration)
Public Property MaxDockingRows As Integer
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As Integer

instance.MaxDockingRows = value

value = instance.MaxDockingRows
C#
public int MaxDockingRows {get; set;}

Remarks

Using this property you can drag any bars to anywhere in the designer surface and the PlaceHolderManager system will automatically dock the new bar into available slot according to the specified MaxDockingRows. The default value of this property is 2.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members

Concepts

Interactive PlaceHolderManager Designer

concepts

PlaceHolderManager Concept


MenuStyleSettings Property

[image]
Intersoft WebDesktop Documentation
MenuStyleSettings Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : MenuStyleSettings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property MenuStyleSettings As WebMenuStyles
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As WebMenuStyles

instance.MenuStyleSettings = value

value = instance.MenuStyleSettings
C#
public WebMenuStyles MenuStyleSettings {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


Page Property

[image]
Intersoft WebDesktop Documentation
Page Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : Page Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Page As System.Web.UI.Page
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As System.Web.UI.Page

instance.Page = value

value = instance.Page
C#
public virtual System.Web.UI.Page Page {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


PlaceHolderContainer Property

[image]
Intersoft WebDesktop Documentation
PlaceHolderContainer Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : PlaceHolderContainer Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property PlaceHolderContainer As String
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As String

instance.PlaceHolderContainer = value

value = instance.PlaceHolderContainer
C#
public string PlaceHolderContainer {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


RenderingMode Property

[image]
Intersoft WebDesktop Documentation
RenderingMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : RenderingMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property RenderingMode As ISNet.WebUI.RenderMode
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As ISNet.WebUI.RenderMode

instance.RenderingMode = value

value = instance.RenderingMode
C#
public virtual ISNet.WebUI.RenderMode RenderingMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


RuntimeLicenseKey Property

[image]
Intersoft WebDesktop Documentation
RuntimeLicenseKey Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : RuntimeLicenseKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property RuntimeLicenseKey As String
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As String

instance.RuntimeLicenseKey = value

value = instance.RuntimeLicenseKey
C#
public virtual string RuntimeLicenseKey {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


ScriptDirectory Property

[image]
Intersoft WebDesktop Documentation
ScriptDirectory Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : ScriptDirectory Property

Glossary Item Box

Gets or sets the directory where all required scripts for the control are stored.

Syntax

Visual Basic (Declaration)
Public Overrides Property ScriptDirectory As String
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As String

instance.ScriptDirectory = value

value = instance.ScriptDirectory
C#
public override string ScriptDirectory {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


SharedScriptDirectory Property

[image]
Intersoft WebDesktop Documentation
SharedScriptDirectory Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : SharedScriptDirectory Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property SharedScriptDirectory As String
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As String

instance.SharedScriptDirectory = value

value = instance.SharedScriptDirectory
C#
public virtual string SharedScriptDirectory {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


ShowDelay Property

[image]
Intersoft WebDesktop Documentation
ShowDelay Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : ShowDelay Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ShowDelay As Integer
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As Integer

instance.ShowDelay = value

value = instance.ShowDelay
C#
public int ShowDelay {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


SizeMode Property

[image]
Intersoft WebDesktop Documentation
SizeMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : SizeMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property SizeMode As SizeMode
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As SizeMode

instance.SizeMode = value

value = instance.SizeMode
C#
public SizeMode SizeMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


SkinID Property

[image]
Intersoft WebDesktop Documentation
SkinID Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : SkinID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property SkinID As String
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As String

instance.SkinID = value

value = instance.SkinID
C#
public virtual string SkinID {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


TabIndex Property

[image]
Intersoft WebDesktop Documentation
TabIndex Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : TabIndex Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property TabIndex As Short
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As Short

instance.TabIndex = value

value = instance.TabIndex
C#
public virtual short TabIndex {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


TextAlign Property

[image]
Intersoft WebDesktop Documentation
TextAlign Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : TextAlign Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property TextAlign As BarTextAlign
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As BarTextAlign

instance.TextAlign = value

value = instance.TextAlign
C#
public BarTextAlign TextAlign {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


ValidateRequestMode Property

[image]
Intersoft WebDesktop Documentation
ValidateRequestMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : ValidateRequestMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ValidateRequestMode As System.Web.UI.ValidateRequestMode
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As System.Web.UI.ValidateRequestMode

instance.ValidateRequestMode = value

value = instance.ValidateRequestMode
C#
public virtual System.Web.UI.ValidateRequestMode ValidateRequestMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


ViewStateItems Property

[image]
Intersoft WebDesktop Documentation
ViewStateItems Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : ViewStateItems Property

Glossary Item Box

Gets or sets the items to be stored in view state storage.

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateItems As ISNet.WebUI.ViewStateItem
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As ISNet.WebUI.ViewStateItem

instance.ViewStateItems = value

value = instance.ViewStateItems
C#
public virtual ISNet.WebUI.ViewStateItem ViewStateItems {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


ViewStateMode Property

[image]
Intersoft WebDesktop Documentation
ViewStateMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : ViewStateMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateMode As System.Web.UI.ViewStateMode
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As System.Web.UI.ViewStateMode

instance.ViewStateMode = value

value = instance.ViewStateMode
C#
public virtual System.Web.UI.ViewStateMode ViewStateMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


ViewStateServerConnection Property

[image]
Intersoft WebDesktop Documentation
ViewStateServerConnection Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : ViewStateServerConnection Property

Glossary Item Box

Gets or sets the server connection string for file server-based viewstate storage.

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateServerConnection As String
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As String

instance.ViewStateServerConnection = value

value = instance.ViewStateServerConnection
C#
public virtual string ViewStateServerConnection {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


ViewStateStorage Property

[image]
Intersoft WebDesktop Documentation
ViewStateStorage Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : ViewStateStorage Property

Glossary Item Box

Gets or sets the location to store the viewstate of this control.

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateStorage As ISNet.WebUI.StateCacheStorage
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As ISNet.WebUI.StateCacheStorage

instance.ViewStateStorage = value

value = instance.ViewStateStorage
C#
public virtual ISNet.WebUI.StateCacheStorage ViewStateStorage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


WebMenuBarStyleSettings Property

[image]
Intersoft WebDesktop Documentation
WebMenuBarStyleSettings Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : WebMenuBarStyleSettings Property

Glossary Item Box

Gets or sets the style properties of WebMenuBar control managed by PlaceHolderManager.

Syntax

Visual Basic (Declaration)
Public Overridable Property WebMenuBarStyleSettings As WebBarStyleSettings
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As WebBarStyleSettings

instance.WebMenuBarStyleSettings = value

value = instance.WebMenuBarStyleSettings
C#
public virtual WebBarStyleSettings WebMenuBarStyleSettings {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


WebToolBarStyleSettings Property

[image]
Intersoft WebDesktop Documentation
WebToolBarStyleSettings Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : WebToolBarStyleSettings Property

Glossary Item Box

Gets or sets the style properties of WebToolBar control managed by PlaceHolderManager.

Syntax

Visual Basic (Declaration)
Public Overridable Property WebToolBarStyleSettings As WebBarStyleSettings
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As WebBarStyleSettings

instance.WebToolBarStyleSettings = value

value = instance.WebToolBarStyleSettings
C#
public virtual WebBarStyleSettings WebToolBarStyleSettings {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


XmlCompressionEnabled Property

[image]
Intersoft WebDesktop Documentation
XmlCompressionEnabled Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : XmlCompressionEnabled Property

Glossary Item Box

Specifies whether the Xml used for clientside state storage should be compressed.

Syntax

Visual Basic (Declaration)
Public Overridable Property XmlCompressionEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim value As Boolean

instance.XmlCompressionEnabled = value

value = instance.XmlCompressionEnabled
C#
public virtual bool XmlCompressionEnabled {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


PlaceHolderManager Class Events

[image]
Intersoft WebDesktop Documentation
PlaceHolderManager Class Events
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : PlaceHolderManager Class

Glossary Item Box

For a list of all members of this type, see PlaceHolderManager members.

Public Events

 | Name | Description
Public Event | BarPropertiesChanged | Fires when the properties of WebMenuBar or WebToolBar are changed.
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

PlaceHolderManager Class
ISNet.WebUI.WebDesktop Namespace

Concepts

PlaceHolderManager Concept

Tasks

Using MenuBar in PlaceHolderManager mode

concepts

Interactive PlaceHolderManager Designer


BarPropertiesChanged Event

[image]
Intersoft WebDesktop Documentation
BarPropertiesChanged Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : BarPropertiesChanged Event

Glossary Item Box

Fires when the properties of WebMenuBar or WebToolBar are changed.

Syntax

Visual Basic (Declaration)
Public Event BarPropertiesChanged As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim handler As EventHandler

AddHandler instance.BarPropertiesChanged, handler
C#
public event EventHandler BarPropertiesChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


DataBinding Event

[image]
Intersoft WebDesktop Documentation
DataBinding Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : DataBinding Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event DataBinding As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim handler As EventHandler

AddHandler instance.DataBinding, handler
C#
public event EventHandler DataBinding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


Disposed Event

[image]
Intersoft WebDesktop Documentation
Disposed Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim handler As EventHandler

AddHandler instance.Disposed, handler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


Init Event

[image]
Intersoft WebDesktop Documentation
Init Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : Init Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Init As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim handler As EventHandler

AddHandler instance.Init, handler
C#
public event EventHandler Init

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


Load Event

[image]
Intersoft WebDesktop Documentation
Load Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : Load Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Load As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim handler As EventHandler

AddHandler instance.Load, handler
C#
public event EventHandler Load

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


PreInitialize Event

[image]
Intersoft WebDesktop Documentation
PreInitialize Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : PreInitialize Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event PreInitialize As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim handler As EventHandler

AddHandler instance.PreInitialize, handler
C#
public event EventHandler PreInitialize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


PreRender Event

[image]
Intersoft WebDesktop Documentation
PreRender Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : PreRender Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event PreRender As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim handler As EventHandler

AddHandler instance.PreRender, handler
C#
public event EventHandler PreRender

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


Unload Event

[image]
Intersoft WebDesktop Documentation
Unload Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManager Class : Unload Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Unload As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManager
Dim handler As EventHandler

AddHandler instance.Unload, handler
C#
public event EventHandler Unload

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManager Class
PlaceHolderManager Members


PlaceHolderManagerDesigner Class

[image]
Intersoft WebDesktop Documentation
PlaceHolderManagerDesigner Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : PlaceHolderManagerDesigner Class

Glossary Item Box

The designer of PlaceHolderManager which allows users to work with dockable bars in the designer surface, similar to WinForm-style development experience.

Object Model

PlaceHolderManagerDesigner Class

Syntax

Visual Basic (Declaration)
Public Class PlaceHolderManagerDesigner
   Inherits ISNet.WebUI.ISDesignerBase
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner
C#
public class PlaceHolderManagerDesigner : ISNet.WebUI.ISDesignerBase

Remarks

The PlaceHolderManager designer architecture maintains the docking system of every IBar implemented components (WebMenuBar and WebToolBar). However, it still allows you to freely working on the content of the PlaceHolderManager. The content of the PlaceHolderManager is not the type of ITemplate, and therefore enables you to access the controls directly in the code behind without has to use FindControl.

The following is a list of top benefits introduced by PlaceHolderManager designer:

  • Significant developer's productivity gains through rich and interactive PlaceHolderManager.
  • Reduced lines of codes required to program the Page with the elegant architecture of PlaceHolderManager which used table system instead of Template.
  • Reduced learning curves with the ease-of-use since the interactive features are similar to WinForm development experience.
  • Reduced overhead in Page's maintenance when required at the future development phase.

Inheritance Hierarchy

System.Object
System.ComponentModel.Design.ComponentDesigner
System.Web.UI.Design.HtmlControlDesigner
System.Web.UI.Design.ControlDesigner
ISNet.WebUI.ISDesignerBase
ISNet.WebUI.WebDesktop.PlaceHolderManagerDesigner

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Members
ISNet.WebUI.WebDesktop Namespace

Concepts

Interactive PlaceHolderManager Designer


PlaceHolderManagerDesigner Class Members

[image]
Intersoft WebDesktop Documentation
PlaceHolderManagerDesigner Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : PlaceHolderManagerDesigner Class

Glossary Item Box

The following tables list the members exposed by PlaceHolderManagerDesigner.

Public Constructors

 | Name | Description
Public Constructor | PlaceHolderManagerDesigner Constructor | Initializes a new instance of the PlaceHolderManagerDesigner class.
Top

Public Properties

 | Name | Description
Public Property | ActionLists | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Property | AllowResize | Overridden. Gets or sets a value that indicates whether Bar controls in PlaceHolderManager is resizable.
Public Property | AssociatedComponents | (Inherited from System.ComponentModel.Design.ComponentDesigner)
Public Property | AutoFormats | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Property | Behavior | (Inherited from System.Web.UI.Design.HtmlControlDesigner)
Public Property | Component | (Inherited from System.ComponentModel.Design.ComponentDesigner)
Public Property | Control | (Inherited from ISNet.WebUI.ISDesignerBase)
Public Property | DataBindings | (Inherited from System.Web.UI.Design.HtmlControlDesigner)
Public Property | DesignTimeHtmlRequiresLoadComplete | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Property | Expressions | (Inherited from System.Web.UI.Design.HtmlControlDesigner)
Public Property | ID | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Property | IsDirty | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Property | IsStandalone | (Inherited from ISNet.WebUI.ISDesignerBase)
Public Property | ReadOnly | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Property | ShouldCodeSerialize | (Inherited from System.Web.UI.Design.HtmlControlDesigner)
Public Property | TemplateGroups | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Property | Verbs | (Inherited from ISNet.WebUI.ISDesignerBase)
Public Property | ViewControl | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Property | ViewControlCreated | (Inherited from System.Web.UI.Design.ControlDesigner)
Top

Public Methods

 | Name | Description
Public Method | Dispose | (Inherited from System.ComponentModel.Design.ComponentDesigner)
Public Method | DoDefaultAction | (Inherited from System.ComponentModel.Design.ComponentDesigner)
Public Method | GetBounds | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | GetDesignTimeHtml | Overloaded. Overridden.
Public Method | GetEditableDesignerRegionContent | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | GetPersistenceContent | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | GetPersistInnerHtml | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | GetViewRendering | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | GetVisualStudioVersion | (Inherited from ISNet.WebUI.ISDesignerBase)
Public Method | Initialize | Overridden.
Public Method | InitializeExistingComponent | (Inherited from System.ComponentModel.Design.ComponentDesigner)
Public Method | InitializeNewComponent | (Inherited from System.ComponentModel.Design.ComponentDesigner)
Public Method | InitializeNonDefault | (Inherited from System.ComponentModel.Design.ComponentDesigner)
Public Method | Invalidate | Overloaded. (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | IsPropertyBound | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | IsVisualStudio2008Plus | (Inherited from ISNet.WebUI.ISDesignerBase)
Public Method | Localize | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | OnAboutClick | (Inherited from ISNet.WebUI.ISDesignerBase)
Public Method | OnAutoFormatApplied | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | OnComponentChanged | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | OnComponentChanging | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | OnPlaceHolderManagerDesignerClick |
Public Method | OnSetComponentDefaults | (Inherited from System.ComponentModel.Design.ComponentDesigner)
Public Method | OnSetParent | Overridden.
Public Method | RaiseResizeEvent | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | RegisterClone | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | RegisterSmartWebResources | (Inherited from ISNet.WebUI.ISDesignerBase)
Public Method | ResolveDesignTimeRelativeURL | (Inherited from ISNet.WebUI.ISDesignerBase)
Public Method | SetDirty | (Inherited from ISNet.WebUI.ISDesignerBase)
Public Method | SetEditableDesignerRegionContent | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | UpdateDesignTimeHtml | (Inherited from System.Web.UI.Design.ControlDesigner)
Top

See Also

Reference

PlaceHolderManagerDesigner Class
ISNet.WebUI.WebDesktop Namespace

Concepts

Interactive PlaceHolderManager Designer


PlaceHolderManagerDesigner Constructor

[image]
Intersoft WebDesktop Documentation
PlaceHolderManagerDesigner Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : PlaceHolderManagerDesigner Constructor

Glossary Item Box

Initializes a new instance of the PlaceHolderManagerDesigner class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New PlaceHolderManagerDesigner()
C#
public PlaceHolderManagerDesigner()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


Dispose Method

[image]
Intersoft WebDesktop Documentation
Dispose Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : Dispose Method

Glossary Item Box

Overload List

Overload | Description
Dispose | (Inherited from System.ComponentModel.Design.ComponentDesigner)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


Dispose() Method

[image]
Intersoft WebDesktop Documentation
Dispose() Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : Dispose() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner

instance.Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


DoDefaultAction Method

[image]
Intersoft WebDesktop Documentation
DoDefaultAction Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : DoDefaultAction Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub DoDefaultAction()
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner

instance.DoDefaultAction()
C#
public virtual void DoDefaultAction()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


GetBounds Method

[image]
Intersoft WebDesktop Documentation
GetBounds Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : GetBounds Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetBounds() As System.Drawing.Rectangle
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner
Dim value As System.Drawing.Rectangle

value = instance.GetBounds()
C#
public System.Drawing.Rectangle GetBounds()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


PlaceHolderManagerDesigner Class Methods

[image]
Intersoft WebDesktop Documentation
PlaceHolderManagerDesigner Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : PlaceHolderManagerDesigner Class

Glossary Item Box

For a list of all members of this type, see PlaceHolderManagerDesigner members.

Public Methods

 | Name | Description
Public Method | Dispose | (Inherited from System.ComponentModel.Design.ComponentDesigner)
Public Method | DoDefaultAction | (Inherited from System.ComponentModel.Design.ComponentDesigner)
Public Method | GetBounds | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | GetDesignTimeHtml | Overloaded. Overridden.
Public Method | GetEditableDesignerRegionContent | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | GetPersistenceContent | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | GetPersistInnerHtml | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | GetViewRendering | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | GetVisualStudioVersion | (Inherited from ISNet.WebUI.ISDesignerBase)
Public Method | Initialize | Overridden.
Public Method | InitializeExistingComponent | (Inherited from System.ComponentModel.Design.ComponentDesigner)
Public Method | InitializeNewComponent | (Inherited from System.ComponentModel.Design.ComponentDesigner)
Public Method | InitializeNonDefault | (Inherited from System.ComponentModel.Design.ComponentDesigner)
Public Method | Invalidate | Overloaded. (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | IsPropertyBound | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | IsVisualStudio2008Plus | (Inherited from ISNet.WebUI.ISDesignerBase)
Public Method | Localize | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | OnAboutClick | (Inherited from ISNet.WebUI.ISDesignerBase)
Public Method | OnAutoFormatApplied | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | OnComponentChanged | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | OnComponentChanging | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | OnPlaceHolderManagerDesignerClick |
Public Method | OnSetComponentDefaults | (Inherited from System.ComponentModel.Design.ComponentDesigner)
Public Method | OnSetParent | Overridden.
Public Method | RaiseResizeEvent | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | RegisterClone | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | RegisterSmartWebResources | (Inherited from ISNet.WebUI.ISDesignerBase)
Public Method | ResolveDesignTimeRelativeURL | (Inherited from ISNet.WebUI.ISDesignerBase)
Public Method | SetDirty | (Inherited from ISNet.WebUI.ISDesignerBase)
Public Method | SetEditableDesignerRegionContent | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | UpdateDesignTimeHtml | (Inherited from System.Web.UI.Design.ControlDesigner)
Top

See Also

Reference

PlaceHolderManagerDesigner Class
ISNet.WebUI.WebDesktop Namespace

Concepts

Interactive PlaceHolderManager Designer


GetDesignTimeHtml Method

[image]
Intersoft WebDesktop Documentation
GetDesignTimeHtml Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : GetDesignTimeHtml Method

Glossary Item Box

Overload List

Overload | Description
GetDesignTimeHtml() |
GetDesignTimeHtml(DesignerRegionCollection) | (Inherited from ISNet.WebUI.ISDesignerBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


GetDesignTimeHtml() Method

[image]
Intersoft WebDesktop Documentation
GetDesignTimeHtml() Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class > GetDesignTimeHtml Method : GetDesignTimeHtml() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetDesignTimeHtml() As String
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner
Dim value As String

value = instance.GetDesignTimeHtml()
C#
public override string GetDesignTimeHtml()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members
Overload List


GetDesignTimeHtml(DesignerRegionCollection) Method

[image]
Intersoft WebDesktop Documentation
GetDesignTimeHtml(DesignerRegionCollection) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class > GetDesignTimeHtml Method : GetDesignTimeHtml(DesignerRegionCollection) Method

regions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetDesignTimeHtml( _
   ByVal regions As System.Web.UI.Design.DesignerRegionCollection _
) As String
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner
Dim regions As System.Web.UI.Design.DesignerRegionCollection
Dim value As String

value = instance.GetDesignTimeHtml(regions)
C#
public virtual string GetDesignTimeHtml(
   System.Web.UI.Design.DesignerRegionCollection regions
)

Parameters

regions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members
Overload List


GetEditableDesignerRegionContent Method

[image]
Intersoft WebDesktop Documentation
GetEditableDesignerRegionContent Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : GetEditableDesignerRegionContent Method

region

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetEditableDesignerRegionContent( _
   ByVal region As System.Web.UI.Design.EditableDesignerRegion _
) As String
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner
Dim region As System.Web.UI.Design.EditableDesignerRegion
Dim value As String

value = instance.GetEditableDesignerRegionContent(region)
C#
public virtual string GetEditableDesignerRegionContent(
   System.Web.UI.Design.EditableDesignerRegion region
)

Parameters

region

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


GetPersistenceContent Method

[image]
Intersoft WebDesktop Documentation
GetPersistenceContent Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : GetPersistenceContent Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetPersistenceContent() As String
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner
Dim value As String

value = instance.GetPersistenceContent()
C#
public virtual string GetPersistenceContent()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


GetPersistInnerHtml Method

[image]
Intersoft WebDesktop Documentation
GetPersistInnerHtml Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : GetPersistInnerHtml Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetPersistInnerHtml() As String
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner
Dim value As String

value = instance.GetPersistInnerHtml()
C#
public virtual string GetPersistInnerHtml()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


GetViewRendering Method

[image]
Intersoft WebDesktop Documentation
GetViewRendering Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : GetViewRendering Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetViewRendering() As System.Web.UI.Design.ViewRendering
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner
Dim value As System.Web.UI.Design.ViewRendering

value = instance.GetViewRendering()
C#
public System.Web.UI.Design.ViewRendering GetViewRendering()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


GetVisualStudioVersion Method

[image]
Intersoft WebDesktop Documentation
GetVisualStudioVersion Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : GetVisualStudioVersion Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetVisualStudioVersion() As ISNet.WebUI.ISDesignerBase.VisualStudioVersion
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner
Dim value As ISNet.WebUI.ISDesignerBase.VisualStudioVersion

value = instance.GetVisualStudioVersion()
C#
public ISNet.WebUI.ISDesignerBase.VisualStudioVersion GetVisualStudioVersion()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


Initialize Method

[image]
Intersoft WebDesktop Documentation
Initialize Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : Initialize Method

component

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub Initialize( _
   ByVal component As System.ComponentModel.IComponent _
)
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner
Dim component As System.ComponentModel.IComponent

instance.Initialize(component)
C#
public override void Initialize(
   System.ComponentModel.IComponent component
)

Parameters

component

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


InitializeExistingComponent Method

[image]
Intersoft WebDesktop Documentation
InitializeExistingComponent Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : InitializeExistingComponent Method

defaultValues

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub InitializeExistingComponent( _
   ByVal defaultValues As System.Collections.IDictionary _
)
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner
Dim defaultValues As System.Collections.IDictionary

instance.InitializeExistingComponent(defaultValues)
C#
public virtual void InitializeExistingComponent(
   System.Collections.IDictionary defaultValues
)

Parameters

defaultValues

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


InitializeNewComponent Method

[image]
Intersoft WebDesktop Documentation
InitializeNewComponent Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : InitializeNewComponent Method

defaultValues

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub InitializeNewComponent( _
   ByVal defaultValues As System.Collections.IDictionary _
)
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner
Dim defaultValues As System.Collections.IDictionary

instance.InitializeNewComponent(defaultValues)
C#
public virtual void InitializeNewComponent(
   System.Collections.IDictionary defaultValues
)

Parameters

defaultValues

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


InitializeNonDefault Method

[image]
Intersoft WebDesktop Documentation
InitializeNonDefault Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : InitializeNonDefault Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub InitializeNonDefault()
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner

instance.InitializeNonDefault()
C#
public virtual void InitializeNonDefault()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


Invalidate Method

[image]
Intersoft WebDesktop Documentation
Invalidate Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : Invalidate Method

Glossary Item Box

Overload List

Overload | Description
Invalidate() | (Inherited from System.Web.UI.Design.ControlDesigner)
Invalidate(Rectangle) | (Inherited from System.Web.UI.Design.ControlDesigner)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


Invalidate() Method

[image]
Intersoft WebDesktop Documentation
Invalidate() Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class > Invalidate Method : Invalidate() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate()
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner

instance.Invalidate()
C#
public void Invalidate()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members
Overload List


Invalidate(Rectangle) Method

[image]
Intersoft WebDesktop Documentation
Invalidate(Rectangle) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class > Invalidate Method : Invalidate(Rectangle) Method

rectangle

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal rectangle As System.Drawing.Rectangle _
)
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner
Dim rectangle As System.Drawing.Rectangle

instance.Invalidate(rectangle)
C#
public void Invalidate(
   System.Drawing.Rectangle rectangle
)

Parameters

rectangle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members
Overload List


IsPropertyBound Method

[image]
Intersoft WebDesktop Documentation
IsPropertyBound Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : IsPropertyBound Method

propName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsPropertyBound( _
   ByVal propName As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner
Dim propName As String
Dim value As Boolean

value = instance.IsPropertyBound(propName)
C#
public bool IsPropertyBound(
   string propName
)

Parameters

propName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


IsVisualStudio2008Plus Method

[image]
Intersoft WebDesktop Documentation
IsVisualStudio2008Plus Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : IsVisualStudio2008Plus Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsVisualStudio2008Plus() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner
Dim value As Boolean

value = instance.IsVisualStudio2008Plus()
C#
public bool IsVisualStudio2008Plus()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


Localize Method

[image]
Intersoft WebDesktop Documentation
Localize Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : Localize Method

resourceWriter

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Localize( _
   ByVal resourceWriter As System.Web.UI.Design.IDesignTimeResourceWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner
Dim resourceWriter As System.Web.UI.Design.IDesignTimeResourceWriter

instance.Localize(resourceWriter)
C#
public void Localize(
   System.Web.UI.Design.IDesignTimeResourceWriter resourceWriter
)

Parameters

resourceWriter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


OnAboutClick Method

[image]
Intersoft WebDesktop Documentation
OnAboutClick Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : OnAboutClick Method

sender
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnAboutClick( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner
Dim sender As Object
Dim e As EventArgs

instance.OnAboutClick(sender, e)
C#
public void OnAboutClick(
   object sender,
   EventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


OnAutoFormatApplied Method

[image]
Intersoft WebDesktop Documentation
OnAutoFormatApplied Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : OnAutoFormatApplied Method

appliedAutoFormat

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnAutoFormatApplied( _
   ByVal appliedAutoFormat As System.Web.UI.Design.DesignerAutoFormat _
)
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner
Dim appliedAutoFormat As System.Web.UI.Design.DesignerAutoFormat

instance.OnAutoFormatApplied(appliedAutoFormat)
C#
public virtual void OnAutoFormatApplied(
   System.Web.UI.Design.DesignerAutoFormat appliedAutoFormat
)

Parameters

appliedAutoFormat

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


OnComponentChanged Method

[image]
Intersoft WebDesktop Documentation
OnComponentChanged Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : OnComponentChanged Method

sender
ce

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnComponentChanged( _
   ByVal sender As Object, _
   ByVal ce As System.ComponentModel.Design.ComponentChangedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner
Dim sender As Object
Dim ce As System.ComponentModel.Design.ComponentChangedEventArgs

instance.OnComponentChanged(sender, ce)
C#
public virtual void OnComponentChanged(
   object sender,
   System.ComponentModel.Design.ComponentChangedEventArgs ce
)

Parameters

sender
ce

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


OnComponentChanging Method

[image]
Intersoft WebDesktop Documentation
OnComponentChanging Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : OnComponentChanging Method

sender
ce

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnComponentChanging( _
   ByVal sender As Object, _
   ByVal ce As System.ComponentModel.Design.ComponentChangingEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner
Dim sender As Object
Dim ce As System.ComponentModel.Design.ComponentChangingEventArgs

instance.OnComponentChanging(sender, ce)
C#
public virtual void OnComponentChanging(
   object sender,
   System.ComponentModel.Design.ComponentChangingEventArgs ce
)

Parameters

sender
ce

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


OnPlaceHolderManagerDesignerClick Method

[image]
Intersoft WebDesktop Documentation
OnPlaceHolderManagerDesignerClick Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : OnPlaceHolderManagerDesignerClick Method

sender
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnPlaceHolderManagerDesignerClick( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner
Dim sender As Object
Dim e As EventArgs

instance.OnPlaceHolderManagerDesignerClick(sender, e)
C#
public void OnPlaceHolderManagerDesignerClick(
   object sender,
   EventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


OnSetComponentDefaults Method

[image]
Intersoft WebDesktop Documentation
OnSetComponentDefaults Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : OnSetComponentDefaults Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnSetComponentDefaults()
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner

instance.OnSetComponentDefaults()
C#
public virtual void OnSetComponentDefaults()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


OnSetParent Method

[image]
Intersoft WebDesktop Documentation
OnSetParent Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : OnSetParent Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub OnSetParent()
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner

instance.OnSetParent()
C#
public override void OnSetParent()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


RaiseResizeEvent Method

[image]
Intersoft WebDesktop Documentation
RaiseResizeEvent Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : RaiseResizeEvent Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RaiseResizeEvent()
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner

instance.RaiseResizeEvent()
C#
public void RaiseResizeEvent()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


RegisterClone Method

[image]
Intersoft WebDesktop Documentation
RegisterClone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : RegisterClone Method

original
clone

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterClone( _
   ByVal original As Object, _
   ByVal clone As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner
Dim original As Object
Dim clone As Object

instance.RegisterClone(original, clone)
C#
public void RegisterClone(
   object original,
   object clone
)

Parameters

original
clone

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


RegisterSmartWebResources Method

[image]
Intersoft WebDesktop Documentation
RegisterSmartWebResources Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : RegisterSmartWebResources Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterSmartWebResources()
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner

instance.RegisterSmartWebResources()
C#
public void RegisterSmartWebResources()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


ResolveDesignTimeRelativeURL Method

[image]
Intersoft WebDesktop Documentation
ResolveDesignTimeRelativeURL Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : ResolveDesignTimeRelativeURL Method

relativeURL

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveDesignTimeRelativeURL( _
   ByVal relativeURL As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner
Dim relativeURL As String
Dim value As String

value = instance.ResolveDesignTimeRelativeURL(relativeURL)
C#
public string ResolveDesignTimeRelativeURL(
   string relativeURL
)

Parameters

relativeURL

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


SetDirty Method

[image]
Intersoft WebDesktop Documentation
SetDirty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : SetDirty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetDirty()
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner

instance.SetDirty()
C#
public void SetDirty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


SetEditableDesignerRegionContent Method

[image]
Intersoft WebDesktop Documentation
SetEditableDesignerRegionContent Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : SetEditableDesignerRegionContent Method

region
content

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SetEditableDesignerRegionContent( _
   ByVal region As System.Web.UI.Design.EditableDesignerRegion, _
   ByVal content As String _
)
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner
Dim region As System.Web.UI.Design.EditableDesignerRegion
Dim content As String

instance.SetEditableDesignerRegionContent(region, content)
C#
public virtual void SetEditableDesignerRegionContent(
   System.Web.UI.Design.EditableDesignerRegion region,
   string content
)

Parameters

region
content

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


UpdateDesignTimeHtml Method

[image]
Intersoft WebDesktop Documentation
UpdateDesignTimeHtml Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : UpdateDesignTimeHtml Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub UpdateDesignTimeHtml()
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner

instance.UpdateDesignTimeHtml()
C#
public virtual void UpdateDesignTimeHtml()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


ActionLists Property

[image]
Intersoft WebDesktop Documentation
ActionLists Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : ActionLists Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ActionLists As System.ComponentModel.Design.DesignerActionListCollection
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner
Dim value As System.ComponentModel.Design.DesignerActionListCollection

value = instance.ActionLists
C#
public virtual System.ComponentModel.Design.DesignerActionListCollection ActionLists {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


PlaceHolderManagerDesigner Class Properties

[image]
Intersoft WebDesktop Documentation
PlaceHolderManagerDesigner Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : PlaceHolderManagerDesigner Class

Glossary Item Box

For a list of all members of this type, see PlaceHolderManagerDesigner members.

Public Properties

 | Name | Description
Public Property | ActionLists | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Property | AllowResize | Overridden. Gets or sets a value that indicates whether Bar controls in PlaceHolderManager is resizable.
Public Property | AssociatedComponents | (Inherited from System.ComponentModel.Design.ComponentDesigner)
Public Property | AutoFormats | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Property | Behavior | (Inherited from System.Web.UI.Design.HtmlControlDesigner)
Public Property | Component | (Inherited from System.ComponentModel.Design.ComponentDesigner)
Public Property | Control | (Inherited from ISNet.WebUI.ISDesignerBase)
Public Property | DataBindings | (Inherited from System.Web.UI.Design.HtmlControlDesigner)
Public Property | DesignTimeHtmlRequiresLoadComplete | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Property | Expressions | (Inherited from System.Web.UI.Design.HtmlControlDesigner)
Public Property | ID | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Property | IsDirty | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Property | IsStandalone | (Inherited from ISNet.WebUI.ISDesignerBase)
Public Property | ReadOnly | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Property | ShouldCodeSerialize | (Inherited from System.Web.UI.Design.HtmlControlDesigner)
Public Property | TemplateGroups | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Property | Verbs | (Inherited from ISNet.WebUI.ISDesignerBase)
Public Property | ViewControl | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Property | ViewControlCreated | (Inherited from System.Web.UI.Design.ControlDesigner)
Top

See Also

Reference

PlaceHolderManagerDesigner Class
ISNet.WebUI.WebDesktop Namespace

Concepts

Interactive PlaceHolderManager Designer


AllowResize Property

[image]
Intersoft WebDesktop Documentation
AllowResize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : AllowResize Property

Glossary Item Box

Gets or sets a value that indicates whether Bar controls in PlaceHolderManager is resizable.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property AllowResize As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner
Dim value As Boolean

value = instance.AllowResize
C#
public override bool AllowResize {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


AssociatedComponents Property

[image]
Intersoft WebDesktop Documentation
AssociatedComponents Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : AssociatedComponents Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property AssociatedComponents As System.Collections.ICollection
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner
Dim value As System.Collections.ICollection

value = instance.AssociatedComponents
C#
public virtual System.Collections.ICollection AssociatedComponents {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


AutoFormats Property

[image]
Intersoft WebDesktop Documentation
AutoFormats Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : AutoFormats Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property AutoFormats As System.Web.UI.Design.DesignerAutoFormatCollection
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner
Dim value As System.Web.UI.Design.DesignerAutoFormatCollection

value = instance.AutoFormats
C#
public virtual System.Web.UI.Design.DesignerAutoFormatCollection AutoFormats {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


Behavior Property

[image]
Intersoft WebDesktop Documentation
Behavior Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : Behavior Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Behavior As System.Web.UI.Design.IHtmlControlDesignerBehavior
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner
Dim value As System.Web.UI.Design.IHtmlControlDesignerBehavior

instance.Behavior = value

value = instance.Behavior
C#
public System.Web.UI.Design.IHtmlControlDesignerBehavior Behavior {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


Component Property

[image]
Intersoft WebDesktop Documentation
Component Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : Component Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Component As System.ComponentModel.IComponent
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner
Dim value As System.ComponentModel.IComponent

value = instance.Component
C#
public System.ComponentModel.IComponent Component {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


Control Property

[image]
Intersoft WebDesktop Documentation
Control Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : Control Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Control As ISNet.WebUI.ISNetControl
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner
Dim value As ISNet.WebUI.ISNetControl

value = instance.Control
C#
public ISNet.WebUI.ISNetControl Control {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


DataBindings Property

[image]
Intersoft WebDesktop Documentation
DataBindings Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : DataBindings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataBindings As System.Web.UI.DataBindingCollection
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner
Dim value As System.Web.UI.DataBindingCollection

value = instance.DataBindings
C#
public System.Web.UI.DataBindingCollection DataBindings {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


DesignTimeHtmlRequiresLoadComplete Property

[image]
Intersoft WebDesktop Documentation
DesignTimeHtmlRequiresLoadComplete Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : DesignTimeHtmlRequiresLoadComplete Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property DesignTimeHtmlRequiresLoadComplete As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner
Dim value As Boolean

value = instance.DesignTimeHtmlRequiresLoadComplete
C#
public virtual bool DesignTimeHtmlRequiresLoadComplete {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


Expressions Property

[image]
Intersoft WebDesktop Documentation
Expressions Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : Expressions Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Expressions As System.Web.UI.ExpressionBindingCollection
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner
Dim value As System.Web.UI.ExpressionBindingCollection

value = instance.Expressions
C#
public System.Web.UI.ExpressionBindingCollection Expressions {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


ID Property

[image]
Intersoft WebDesktop Documentation
ID Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : ID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ID As String
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner
Dim value As String

instance.ID = value

value = instance.ID
C#
public virtual string ID {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


IsDirty Property

[image]
Intersoft WebDesktop Documentation
IsDirty Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : IsDirty Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property IsDirty As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner
Dim value As Boolean

instance.IsDirty = value

value = instance.IsDirty
C#
public bool IsDirty {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


IsStandalone Property

[image]
Intersoft WebDesktop Documentation
IsStandalone Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : IsStandalone Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property IsStandalone As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner
Dim value As Boolean

instance.IsStandalone = value

value = instance.IsStandalone
C#
public bool IsStandalone {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


ReadOnly Property

[image]
Intersoft WebDesktop Documentation
ReadOnly Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : ReadOnly Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner
Dim value As Boolean

instance.ReadOnly = value

value = instance.ReadOnly
C#
public bool ReadOnly {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


ShouldCodeSerialize Property

[image]
Intersoft WebDesktop Documentation
ShouldCodeSerialize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : ShouldCodeSerialize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ShouldCodeSerialize As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner
Dim value As Boolean

instance.ShouldCodeSerialize = value

value = instance.ShouldCodeSerialize
C#
public virtual bool ShouldCodeSerialize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


TemplateGroups Property

[image]
Intersoft WebDesktop Documentation
TemplateGroups Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : TemplateGroups Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property TemplateGroups As System.Web.UI.Design.TemplateGroupCollection
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner
Dim value As System.Web.UI.Design.TemplateGroupCollection

value = instance.TemplateGroups
C#
public virtual System.Web.UI.Design.TemplateGroupCollection TemplateGroups {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


Verbs Property

[image]
Intersoft WebDesktop Documentation
Verbs Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : Verbs Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Verbs As System.ComponentModel.Design.DesignerVerbCollection
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner
Dim value As System.ComponentModel.Design.DesignerVerbCollection

value = instance.Verbs
C#
public virtual System.ComponentModel.Design.DesignerVerbCollection Verbs {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


ViewControl Property

[image]
Intersoft WebDesktop Documentation
ViewControl Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : ViewControl Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ViewControl As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner
Dim value As System.Web.UI.Control

instance.ViewControl = value

value = instance.ViewControl
C#
public System.Web.UI.Control ViewControl {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


ViewControlCreated Property

[image]
Intersoft WebDesktop Documentation
ViewControlCreated Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > PlaceHolderManagerDesigner Class : ViewControlCreated Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewControlCreated As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderManagerDesigner
Dim value As Boolean

instance.ViewControlCreated = value

value = instance.ViewControlCreated
C#
public virtual bool ViewControlCreated {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaceHolderManagerDesigner Class
PlaceHolderManagerDesigner Members


Property Class

[image]
Intersoft WebDesktop Documentation
Property Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : Property Class

Glossary Item Box

Represents the property object used in NotificationProperties.

Object Model

Property Class

Syntax

Visual Basic (Declaration)
Public Class Property
Visual Basic (Usage) Copy Code
Dim instance As Property
C#
public class Property

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebDesktop.Property

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Property Members
ISNet.WebUI.WebDesktop Namespace


Property Class Members

[image]
Intersoft WebDesktop Documentation
Property Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebDesktop Namespace : Property Class

Glossary Item Box

The following tables list the members exposed by Property.

Public Constructors

 | Name | Description
Public Constructor | Property Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Name | Gets or sets the name of Property.
Public Property | Value | Gets or sets the value of Property.
Top

See Also

Reference

Property Class
ISNet.WebUI.WebDesktop Namespace


Property Constructor

[image]
Intersoft WebDesktop Documentation
Property Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > Property Class : Property Constructor

Glossary Item Box

Overload List

Overload | Description
Property Constructor() |
Property Constructor(String,String) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Property Class
Property Members


Property Constructor()

[image]
Intersoft WebDesktop Documentation
Property Constructor()
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > Property Class > Property Constructor : Property Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New Property()
C#
public Property()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Property Class
Property Members
Overload List


Property Constructor(String,String)

[image]
Intersoft WebDesktop Documentation
Property Constructor(String,String)
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > Property Class > Property Constructor : Property Constructor(String,String)

name
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim name As String
Dim value As String

Dim instance As New Property(name, value)
C#
public Property(
   string name,
   string value
)

Parameters

name
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Property Class
Property Members
Overload List


Property Class Properties

[image]
Intersoft WebDesktop Documentation
Property Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : Property Class

Glossary Item Box

For a list of all members of this type, see Property members.

Public Properties

 | Name | Description
Public Property | Name | Gets or sets the name of Property.
Public Property | Value | Gets or sets the value of Property.
Top

See Also

Reference

Property Class
ISNet.WebUI.WebDesktop Namespace


Name Property

[image]
Intersoft WebDesktop Documentation
Name Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > Property Class : Name Property

Glossary Item Box

Gets or sets the name of Property.

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As Property
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Property Class
Property Members


Value Property

[image]
Intersoft WebDesktop Documentation
Value Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > Property Class : Value Property

Glossary Item Box

Gets or sets the value of Property.

Syntax

Visual Basic (Declaration)
Public Property Value As String
Visual Basic (Usage) Copy Code
Dim instance As Property
Dim value As String

instance.Value = value

value = instance.Value
C#
public string Value {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Property Class
Property Members


ToggleGroup Class

[image]
Intersoft WebDesktop Documentation
ToggleGroup Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : ToggleGroup Class

Glossary Item Box

Gets the collection of toggle group commands in WebToolBar.

Object Model

ToggleGroup Class

Syntax

Visual Basic (Declaration)
Public Class ToggleGroup
   Inherits ISNet.WebUI.NamedObjectBase
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As ToggleGroup
C#
public class ToggleGroup : ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase
ISNet.WebUI.WebDesktop.ToggleGroup

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleGroup Members
ISNet.WebUI.WebDesktop Namespace


ToggleGroup Class Members

[image]
Intersoft WebDesktop Documentation
ToggleGroup Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : ToggleGroup Class

Glossary Item Box

The following tables list the members exposed by ToggleGroup.

Public Constructors

 | Name | Description
Public Constructor | ToggleGroup Constructor |
Top

Public Properties

 | Name | Description
Public Property | Name | Overridden. Specifies ToggleGroup name.
Public Property | ToggleGroupType | Gets or sets ToggleGroup type.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

ToggleGroup Class
ISNet.WebUI.WebDesktop Namespace


ToggleGroup Constructor

[image]
Intersoft WebDesktop Documentation
ToggleGroup Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToggleGroup Class : ToggleGroup Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ToggleGroup()
C#
public ToggleGroup()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleGroup Class
ToggleGroup Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToggleGroup Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As ToggleGroup
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleGroup Class
ToggleGroup Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToggleGroup Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleGroup Class
ToggleGroup Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToggleGroup Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ToggleGroup
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleGroup Class
ToggleGroup Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToggleGroup Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ToggleGroup
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleGroup Class
ToggleGroup Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToggleGroup Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ToggleGroup
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleGroup Class
ToggleGroup Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToggleGroup Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As ToggleGroup
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleGroup Class
ToggleGroup Members


ToggleGroup Class Methods

[image]
Intersoft WebDesktop Documentation
ToggleGroup Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : ToggleGroup Class

Glossary Item Box

For a list of all members of this type, see ToggleGroup members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

ToggleGroup Class
ISNet.WebUI.WebDesktop Namespace


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToggleGroup Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ToggleGroup
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleGroup Class
ToggleGroup Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToggleGroup Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ToggleGroup
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleGroup Class
ToggleGroup Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToggleGroup Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ToggleGroup

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleGroup Class
ToggleGroup Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToggleGroup Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ToggleGroup
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleGroup Class
ToggleGroup Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToggleGroup Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As ToggleGroup
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleGroup Class
ToggleGroup Members


ToggleGroup Class Properties

[image]
Intersoft WebDesktop Documentation
ToggleGroup Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : ToggleGroup Class

Glossary Item Box

For a list of all members of this type, see ToggleGroup members.

Public Properties

 | Name | Description
Public Property | Name | Overridden. Specifies ToggleGroup name.
Public Property | ToggleGroupType | Gets or sets ToggleGroup type.
Top

See Also

Reference

ToggleGroup Class
ISNet.WebUI.WebDesktop Namespace


ToggleGroup Constructor

[image]
Intersoft WebDesktop Documentation
ToggleGroup Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToggleGroup Class : ToggleGroup Constructor

Glossary Item Box

Initializes a new instance of the ToggleGroup class.

Overload List

Overload | Description
ToggleGroup Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleGroup Class
ToggleGroup Members


Name Property

[image]
Intersoft WebDesktop Documentation
Name Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToggleGroup Class : Name Property

Glossary Item Box

Specifies ToggleGroup name.

Syntax

Visual Basic (Declaration)
Public Overrides Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As ToggleGroup
Dim value As String

instance.Name = value

value = instance.Name
C#
public override string Name {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleGroup Class
ToggleGroup Members


ToggleGroupType Property

[image]
Intersoft WebDesktop Documentation
ToggleGroupType Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToggleGroup Class : ToggleGroupType Property

Glossary Item Box

Gets or sets ToggleGroup type.

Syntax

Visual Basic (Declaration)
Public Overridable Property ToggleGroupType As ToggleGroupType
Visual Basic (Usage) Copy Code
Dim instance As ToggleGroup
Dim value As ToggleGroupType

instance.ToggleGroupType = value

value = instance.ToggleGroupType
C#
public virtual ToggleGroupType ToggleGroupType {get; set;}

Remarks

The default value of this property is SelectNone.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleGroup Class
ToggleGroup Members


ToggleGroupCollection Class

[image]
Intersoft WebDesktop Documentation
ToggleGroupCollection Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : ToggleGroupCollection Class

Glossary Item Box

Collection of ToggleGroup.

Object Model

ToggleGroupCollection Class

Syntax

Visual Basic (Declaration)
Public Class ToggleGroupCollection
   Inherits ISNet.WebUI.ISCollectionBase
Visual Basic (Usage) Copy Code
Dim instance As ToggleGroupCollection
C#
public class ToggleGroupCollection : ISNet.WebUI.ISCollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
ISNet.WebUI.ISCollectionBase
ISNet.WebUI.WebDesktop.ToggleGroupCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleGroupCollection Members
ISNet.WebUI.WebDesktop Namespace


ToggleGroupCollection Class Members

[image]
Intersoft WebDesktop Documentation
ToggleGroupCollection Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : ToggleGroupCollection Class

Glossary Item Box

The following tables list the members exposed by ToggleGroupCollection.

Public Constructors

 | Name | Description
Public Constructor | ToggleGroupCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden. Returns a Boolean value indicating whether the collection is read-only.
Public Property | Item | Property indexer for the collection.
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | GetObjectData |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

ToggleGroupCollection Class
ISNet.WebUI.WebDesktop Namespace


ToggleGroupCollection Constructor

[image]
Intersoft WebDesktop Documentation
ToggleGroupCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToggleGroupCollection Class : ToggleGroupCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ToggleGroupCollection()
C#
public ToggleGroupCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleGroupCollection Class
ToggleGroupCollection Members


ToggleGroupCollection Class Methods

[image]
Intersoft WebDesktop Documentation
ToggleGroupCollection Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : ToggleGroupCollection Class

Glossary Item Box

For a list of all members of this type, see ToggleGroupCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | GetObjectData |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

ToggleGroupCollection Class
ISNet.WebUI.WebDesktop Namespace


Add Method

[image]
Intersoft WebDesktop Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToggleGroupCollection Class : Add Method

Glossary Item Box

Overload List

Overload | Description
Add(ToggleGroup) |
Add(String) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleGroupCollection Class
ToggleGroupCollection Members


Add(ToggleGroup) Method

[image]
Intersoft WebDesktop Documentation
Add(ToggleGroup) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToggleGroupCollection Class > Add Method : Add(ToggleGroup) Method

command

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function Add( _
   ByVal command As ToggleGroup _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ToggleGroupCollection
Dim command As ToggleGroup
Dim value As Integer

value = instance.Add(command)
C#
public virtual int Add(
   ToggleGroup command
)

Parameters

command

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleGroupCollection Class
ToggleGroupCollection Members
Overload List


Add(String) Method

[image]
Intersoft WebDesktop Documentation
Add(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToggleGroupCollection Class > Add Method : Add(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal name As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ToggleGroupCollection
Dim name As String
Dim value As Integer

value = instance.Add(name)
C#
public int Add(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleGroupCollection Class
ToggleGroupCollection Members
Overload List


Clear Method

[image]
Intersoft WebDesktop Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToggleGroupCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As ToggleGroupCollection

instance.Clear()
C#
public new void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleGroupCollection Class
ToggleGroupCollection Members


Contains Method

[image]
Intersoft WebDesktop Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToggleGroupCollection Class : Contains Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As ISNet.WebUI.INamedObject _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ToggleGroupCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As Boolean

value = instance.Contains(value)
C#
public bool Contains(
   ISNet.WebUI.INamedObject value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleGroupCollection Class
ToggleGroupCollection Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToggleGroupCollection Class : CopyFrom Method

passIn

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CopyFrom( _
   ByVal passIn As ToggleGroupCollection _
) As ToggleGroupCollection
Visual Basic (Usage) Copy Code
Dim instance As ToggleGroupCollection
Dim passIn As ToggleGroupCollection
Dim value As ToggleGroupCollection

value = instance.CopyFrom(passIn)
C#
public ToggleGroupCollection CopyFrom(
   ToggleGroupCollection passIn
)

Parameters

passIn

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleGroupCollection Class
ToggleGroupCollection Members


CopyTo Method

[image]
Intersoft WebDesktop Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToggleGroupCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ToggleGroupCollection
Dim array() As ISNet.WebUI.INamedObject
Dim index As Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   ISNet.WebUI.INamedObject[] array,
   int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleGroupCollection Class
ToggleGroupCollection Members


Exists Method

[image]
Intersoft WebDesktop Documentation
Exists Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToggleGroupCollection Class : Exists Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Exists( _
   ByVal name As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ToggleGroupCollection
Dim name As String
Dim value As Boolean

value = instance.Exists(name)
C#
public bool Exists(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleGroupCollection Class
ToggleGroupCollection Members


GetEnumerator Method

[image]
Intersoft WebDesktop Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToggleGroupCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Function GetEnumerator() As System.Collections.IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As ToggleGroupCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
public new System.Collections.IEnumerator GetEnumerator()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleGroupCollection Class
ToggleGroupCollection Members


GetItem Method

[image]
Intersoft WebDesktop Documentation
GetItem Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToggleGroupCollection Class : GetItem Method

Glossary Item Box

Overload List

Overload | Description
GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleGroupCollection Class
ToggleGroupCollection Members


GetItem(Int32) Method

[image]
Intersoft WebDesktop Documentation
GetItem(Int32) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToggleGroupCollection Class : GetItem(Int32) Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetItem( _
   ByVal index As Integer _
) As ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As ToggleGroupCollection
Dim index As Integer
Dim value As ISNet.WebUI.INamedObject

value = instance.GetItem(index)
C#
public virtual ISNet.WebUI.INamedObject GetItem(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleGroupCollection Class
ToggleGroupCollection Members


GetNamedItem Method

[image]
Intersoft WebDesktop Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToggleGroupCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNamedItem( _
   ByVal name As String _
) As ToggleGroup
Visual Basic (Usage) Copy Code
Dim instance As ToggleGroupCollection
Dim name As String
Dim value As ToggleGroup

value = instance.GetNamedItem(name)
C#
public ToggleGroup GetNamedItem(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleGroupCollection Class
ToggleGroupCollection Members


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToggleGroupCollection Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ToggleGroupCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleGroupCollection Class
ToggleGroupCollection Members


IndexOf Method

[image]
Intersoft WebDesktop Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToggleGroupCollection Class : IndexOf Method

Glossary Item Box

Overload List

Overload | Description
IndexOf(String) | (Inherited from ISNet.WebUI.ISCollectionBase)
IndexOf(INamedObject) | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleGroupCollection Class
ToggleGroupCollection Members


IndexOf(String) Method

[image]
Intersoft WebDesktop Documentation
IndexOf(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToggleGroupCollection Class > IndexOf Method : IndexOf(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function IndexOf( _
   ByVal name As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ToggleGroupCollection
Dim name As String
Dim value As Integer

value = instance.IndexOf(name)
C#
public virtual int IndexOf(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleGroupCollection Class
ToggleGroupCollection Members
Overload List


IndexOf(INamedObject) Method

[image]
Intersoft WebDesktop Documentation
IndexOf(INamedObject) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToggleGroupCollection Class > IndexOf Method : IndexOf(INamedObject) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal value As ISNet.WebUI.INamedObject _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ToggleGroupCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As Integer

value = instance.IndexOf(value)
C#
public int IndexOf(
   ISNet.WebUI.INamedObject value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleGroupCollection Class
ToggleGroupCollection Members
Overload List


Insert Method

[image]
Intersoft WebDesktop Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToggleGroupCollection Class : Insert Method

index
command

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal command As ToggleGroup _
)
Visual Basic (Usage) Copy Code
Dim instance As ToggleGroupCollection
Dim index As Integer
Dim command As ToggleGroup

instance.Insert(index, command)
C#
public void Insert(
   int index,
   ToggleGroup command
)

Parameters

index
command

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleGroupCollection Class
ToggleGroupCollection Members


IntInsert Method

[image]
Intersoft WebDesktop Documentation
IntInsert Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToggleGroupCollection Class : IntInsert Method

index
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub IntInsert( _
   ByVal index As Integer, _
   ByVal value As ISNet.WebUI.INamedObject _
)
Visual Basic (Usage) Copy Code
Dim instance As ToggleGroupCollection
Dim index As Integer
Dim value As ISNet.WebUI.INamedObject

instance.IntInsert(index, value)
C#
public void IntInsert(
   int index,
   ISNet.WebUI.INamedObject value
)

Parameters

index
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleGroupCollection Class
ToggleGroupCollection Members


Remove Method

[image]
Intersoft WebDesktop Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToggleGroupCollection Class : Remove Method

command

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal command As ToggleGroup _
)
Visual Basic (Usage) Copy Code
Dim instance As ToggleGroupCollection
Dim command As ToggleGroup

instance.Remove(command)
C#
public void Remove(
   ToggleGroup command
)

Parameters

command

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleGroupCollection Class
ToggleGroupCollection Members


setParent Method

[image]
Intersoft WebDesktop Documentation
setParent Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToggleGroupCollection Class : setParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub setParent( _
   ByVal parent As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ToggleGroupCollection
Dim parent As Object

instance.setParent(parent)
C#
public virtual void setParent(
   object parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleGroupCollection Class
ToggleGroupCollection Members


Capacity Property

[image]
Intersoft WebDesktop Documentation
Capacity Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToggleGroupCollection Class : Capacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
Visual Basic (Usage) Copy Code
Dim instance As ToggleGroupCollection
Dim value As Integer

instance.Capacity = value

value = instance.Capacity
C#
public int Capacity {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleGroupCollection Class
ToggleGroupCollection Members


Count Property

[image]
Intersoft WebDesktop Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToggleGroupCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ToggleGroupCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleGroupCollection Class
ToggleGroupCollection Members


ToggleGroupCollection Class Properties

[image]
Intersoft WebDesktop Documentation
ToggleGroupCollection Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : ToggleGroupCollection Class

Glossary Item Box

For a list of all members of this type, see ToggleGroupCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden. Returns a Boolean value indicating whether the collection is read-only.
Public Property | Item | Property indexer for the collection.
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

ToggleGroupCollection Class
ISNet.WebUI.WebDesktop Namespace


ToggleGroupCollection Constructor

[image]
Intersoft WebDesktop Documentation
ToggleGroupCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToggleGroupCollection Class : ToggleGroupCollection Constructor

Glossary Item Box

Overload List

Overload | Description
ToggleGroupCollection Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleGroupCollection Class
ToggleGroupCollection Members


IsReadOnly Property

[image]
Intersoft WebDesktop Documentation
IsReadOnly Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToggleGroupCollection Class : IsReadOnly Property

Glossary Item Box

Returns a Boolean value indicating whether the collection is read-only.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ToggleGroupCollection
Dim value As Boolean

value = instance.IsReadOnly
C#
public override bool IsReadOnly {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleGroupCollection Class
ToggleGroupCollection Members


Item Property

[image]
Intersoft WebDesktop Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToggleGroupCollection Class : Item Property

index

Glossary Item Box

Property indexer for the collection.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As ToggleGroup
Visual Basic (Usage) Copy Code
Dim instance As ToggleGroupCollection
Dim index As Integer
Dim value As ToggleGroup

instance.Item(index) = value

value = instance.Item(index)
C#
public ToggleGroup this[
   int index
]; {get; set;}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleGroupCollection Class
ToggleGroupCollection Members


Parent Property

[image]
Intersoft WebDesktop Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToggleGroupCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As Object
Visual Basic (Usage) Copy Code
Dim instance As ToggleGroupCollection
Dim value As Object

value = instance.Parent
C#
public object Parent {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleGroupCollection Class
ToggleGroupCollection Members


ToolCommand Class

[image]
Intersoft WebDesktop Documentation
ToolCommand Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : ToolCommand Class

Glossary Item Box

List of tool command in WebToolBar.

Object Model

ToolCommand Class

Syntax

Visual Basic (Declaration)
Public Class ToolCommand
   Inherits Command
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject, ICommand, IWebMenu
Visual Basic (Usage) Copy Code
Dim instance As ToolCommand
C#
public class ToolCommand : Command, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject, ICommand, IWebMenu

Remarks

WebToolBar offers you eight Types of ToolCommand, they are Button, Toggle Button, DropDown Button, Split Button, Separator, Custom, and Container. You can assign a command type to each item in WebToolBar. For more information please refer to Using ToolCommand Types.

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase
ISNet.WebUI.WebDesktop.Command
ISNet.WebUI.WebDesktop.ToolCommand

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommand Members
ISNet.WebUI.WebDesktop Namespace

Tasks

Using ToolCommand Types

tasks

Using Templated Command

Concepts

WebToolBar Features
Understanding ToolBar Architecture


ToolCommand Class Members

[image]
Intersoft WebDesktop Documentation
ToolCommand Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : ToolCommand Class

Glossary Item Box

The following tables list the members exposed by ToolCommand.

Public Constructors

 | Name | Description
Public Constructor | ToolCommand Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | AutoPostBack | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | Category | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | CommandSize | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | DisplayAccessKeyOnToolTip | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | DisplayMode | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | DisplayToolTip | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | Image | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | ImageSize | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | IsEnabled | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | Items | Gets command menu item collection.
Public Property | Menu | Gets or sets command menu implementation.
Public Property | MergeCommandID | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | Name | Overridden. Specifies ToolCommand name.
Public Property | Pushed | Gets or sets a value that indicates whether a Command is pushed.
Public Property | Text | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | TextAlign | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | ToggleGroupName | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | ToolTip | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | Type | Overridden. Gets or sets command type.
Public Property | Visible | Overridden. Gets or sets a value that indicates whether a Command is visibled.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebDesktop.Command)
Top

See Also

Reference

ToolCommand Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Using ToolCommand Types

tasks

Using Templated Command

Concepts

WebToolBar Features
Understanding ToolBar Architecture


ToolCommand Constructor

[image]
Intersoft WebDesktop Documentation
ToolCommand Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommand Class : ToolCommand Constructor

Glossary Item Box

Initializes a new instance of the ToolCommand class.

Overload List

Overload | Description
ToolCommand Constructor() |
ToolCommand Constructor(String) |
ToolCommand Constructor(String,String) |
ToolCommand Constructor(String,String,String) |
ToolCommand Constructor(String,String,CommandType) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommand Class
ToolCommand Members


ToolCommand Constructor()

[image]
Intersoft WebDesktop Documentation
ToolCommand Constructor()
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommand Class > ToolCommand Constructor : ToolCommand Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ToolCommand()
C#
public ToolCommand()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommand Class
ToolCommand Members
Overload List


ToolCommand Constructor(String)

[image]
Intersoft WebDesktop Documentation
ToolCommand Constructor(String)
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommand Class > ToolCommand Constructor : ToolCommand Constructor(String)

text

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim text As String

Dim instance As New ToolCommand(text)
C#
public ToolCommand(
   string text
)

Parameters

text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommand Class
ToolCommand Members
Overload List


ToolCommand Constructor(String,String)

[image]
Intersoft WebDesktop Documentation
ToolCommand Constructor(String,String)
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommand Class > ToolCommand Constructor : ToolCommand Constructor(String,String)

text
name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal text As String, _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim text As String
Dim name As String

Dim instance As New ToolCommand(text, name)
C#
public ToolCommand(
   string text,
   string name
)

Parameters

text
name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommand Class
ToolCommand Members
Overload List


ToolCommand Constructor(String,String,String)

[image]
Intersoft WebDesktop Documentation
ToolCommand Constructor(String,String,String)
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommand Class > ToolCommand Constructor : ToolCommand Constructor(String,String,String)

text
name
accessKey

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal text As String, _
   ByVal name As String, _
   ByVal accessKey As String _
)
Visual Basic (Usage) Copy Code
Dim text As String
Dim name As String
Dim accessKey As String

Dim instance As New ToolCommand(text, name, accessKey)
C#
public ToolCommand(
   string text,
   string name,
   string accessKey
)

Parameters

text
name
accessKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommand Class
ToolCommand Members
Overload List


ToolCommand Constructor(String,String,CommandType)

[image]
Intersoft WebDesktop Documentation
ToolCommand Constructor(String,String,CommandType)
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommand Class > ToolCommand Constructor : ToolCommand Constructor(String,String,CommandType)

text
name
type

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal text As String, _
   ByVal name As String, _
   ByVal type As CommandType _
)
Visual Basic (Usage) Copy Code
Dim text As String
Dim name As String
Dim type As CommandType

Dim instance As New ToolCommand(text, name, type)
C#
public ToolCommand(
   string text,
   string name,
   CommandType type
)

Parameters

text
name
type

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommand Class
ToolCommand Members
Overload List


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommand Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As ToolCommand
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommand Class
ToolCommand Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommand Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommand Class
ToolCommand Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommand Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ToolCommand
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommand Class
ToolCommand Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommand Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ToolCommand
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommand Class
ToolCommand Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommand Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ToolCommand
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommand Class
ToolCommand Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommand Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As ToolCommand
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommand Class
ToolCommand Members


ToolCommand Class Methods

[image]
Intersoft WebDesktop Documentation
ToolCommand Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : ToolCommand Class

Glossary Item Box

For a list of all members of this type, see ToolCommand members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebDesktop.Command)
Top

See Also

Reference

ToolCommand Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Using ToolCommand Types

tasks

Using Templated Command

Concepts

WebToolBar Features
Understanding ToolBar Architecture


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommand Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ToolCommand
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommand Class
ToolCommand Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommand Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ToolCommand
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommand Class
ToolCommand Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommand Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ToolCommand

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommand Class
ToolCommand Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommand Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ToolCommand
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommand Class
ToolCommand Members


ToolCommand Class Properties

[image]
Intersoft WebDesktop Documentation
ToolCommand Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : ToolCommand Class

Glossary Item Box

For a list of all members of this type, see ToolCommand members.

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | AutoPostBack | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | Category | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | CommandSize | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | DisplayAccessKeyOnToolTip | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | DisplayMode | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | DisplayToolTip | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | Image | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | ImageSize | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | IsEnabled | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | Items | Gets command menu item collection.
Public Property | Menu | Gets or sets command menu implementation.
Public Property | MergeCommandID | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | Name | Overridden. Specifies ToolCommand name.
Public Property | Pushed | Gets or sets a value that indicates whether a Command is pushed.
Public Property | Text | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | TextAlign | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | ToggleGroupName | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | ToolTip | (Inherited from ISNet.WebUI.WebDesktop.Command)
Public Property | Type | Overridden. Gets or sets command type.
Public Property | Visible | Overridden. Gets or sets a value that indicates whether a Command is visibled.
Top

See Also

Reference

ToolCommand Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Using ToolCommand Types

tasks

Using Templated Command

Concepts

WebToolBar Features
Understanding ToolBar Architecture


Items Property

[image]
Intersoft WebDesktop Documentation
Items Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommand Class : Items Property

Glossary Item Box

Gets command menu item collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Items As WebMenuItemCollection
Visual Basic (Usage) Copy Code
Dim instance As ToolCommand
Dim value As WebMenuItemCollection

value = instance.Items
C#
public WebMenuItemCollection Items {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommand Class
ToolCommand Members


Menu Property

[image]
Intersoft WebDesktop Documentation
Menu Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommand Class : Menu Property

Glossary Item Box

Gets or sets command menu implementation.

Syntax

Visual Basic (Declaration)
Public Property Menu As WebMenu
Visual Basic (Usage) Copy Code
Dim instance As ToolCommand
Dim value As WebMenu

instance.Menu = value

value = instance.Menu
C#
public WebMenu Menu {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommand Class
ToolCommand Members


Name Property

[image]
Intersoft WebDesktop Documentation
Name Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommand Class : Name Property

Glossary Item Box

Specifies ToolCommand name.

Syntax

Visual Basic (Declaration)
Public Overrides Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As ToolCommand
Dim value As String

instance.Name = value

value = instance.Name
C#
public override string Name {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommand Class
ToolCommand Members


Pushed Property

[image]
Intersoft WebDesktop Documentation
Pushed Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommand Class : Pushed Property

Glossary Item Box

Gets or sets a value that indicates whether a Command is pushed.

Syntax

Visual Basic (Declaration)
Public Overridable Property Pushed As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ToolCommand
Dim value As Boolean

instance.Pushed = value

value = instance.Pushed
C#
public virtual bool Pushed {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommand Class
ToolCommand Members


Type Property

[image]
Intersoft WebDesktop Documentation
Type Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommand Class : Type Property

Glossary Item Box

Gets or sets command type.

Syntax

Visual Basic (Declaration)
Public Overrides Property Type As CommandType
Visual Basic (Usage) Copy Code
Dim instance As ToolCommand
Dim value As CommandType

instance.Type = value

value = instance.Type
C#
public override CommandType Type {get; set;}

Remarks

ToolCommand types consist of Button, Toggle Button, DropDown Button, Split Button, Separator, Custom, and Container.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommand Class
ToolCommand Members

Tasks

Using ToolCommand Types

tasks

Using Templated Command

Concepts

WebToolBar Features

concepts

Understanding ToolBar Architecture


Visible Property

[image]
Intersoft WebDesktop Documentation
Visible Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommand Class : Visible Property

Glossary Item Box

Gets or sets a value that indicates whether a Command is visibled.

Syntax

Visual Basic (Declaration)
Public Overrides Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ToolCommand
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public override bool Visible {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommand Class
ToolCommand Members


ToolCommandClickEventArgs Class

[image]
Intersoft WebDesktop Documentation
ToolCommandClickEventArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : ToolCommandClickEventArgs Class

Glossary Item Box

Provides data for ToolCommand clicked related event.

Object Model

ToolCommandClickEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class ToolCommandClickEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As ToolCommandClickEventArgs
C#
public class ToolCommandClickEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebDesktop.ToolCommandClickEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommandClickEventArgs Members
ISNet.WebUI.WebDesktop Namespace


ToolCommandClickEventArgs Class Members

[image]
Intersoft WebDesktop Documentation
ToolCommandClickEventArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebDesktop Namespace : ToolCommandClickEventArgs Class

Glossary Item Box

The following tables list the members exposed by ToolCommandClickEventArgs.

Public Constructors

 | Name | Description
Public Constructor | ToolCommandClickEventArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | ClickedCommand | Gets the clicked command in ToolCommand.
Public Property | ClickedMenuItem | Gets the clicked menu item in ToolCommand.
Top

See Also

Reference

ToolCommandClickEventArgs Class
ISNet.WebUI.WebDesktop Namespace


ToolCommandClickEventArgs Constructor

[image]
Intersoft WebDesktop Documentation
ToolCommandClickEventArgs Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommandClickEventArgs Class : ToolCommandClickEventArgs Constructor

clickedCommand
clickedMenuItem

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal clickedCommand As ToolCommand, _
   ByVal clickedMenuItem As WebMenuItem _
)
Visual Basic (Usage) Copy Code
Dim clickedCommand As ToolCommand
Dim clickedMenuItem As WebMenuItem

Dim instance As New ToolCommandClickEventArgs(clickedCommand, clickedMenuItem)
C#
public ToolCommandClickEventArgs(
   ToolCommand clickedCommand,
   WebMenuItem clickedMenuItem
)

Parameters

clickedCommand
clickedMenuItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommandClickEventArgs Class
ToolCommandClickEventArgs Members


ToolCommandClickEventArgs Class Properties

[image]
Intersoft WebDesktop Documentation
ToolCommandClickEventArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : ToolCommandClickEventArgs Class

Glossary Item Box

For a list of all members of this type, see ToolCommandClickEventArgs members.

Public Properties

 | Name | Description
Public Property | ClickedCommand | Gets the clicked command in ToolCommand.
Public Property | ClickedMenuItem | Gets the clicked menu item in ToolCommand.
Top

See Also

Reference

ToolCommandClickEventArgs Class
ISNet.WebUI.WebDesktop Namespace


ClickedCommand Property

[image]
Intersoft WebDesktop Documentation
ClickedCommand Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommandClickEventArgs Class : ClickedCommand Property

Glossary Item Box

Gets the clicked command in ToolCommand.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClickedCommand As ToolCommand
Visual Basic (Usage) Copy Code
Dim instance As ToolCommandClickEventArgs
Dim value As ToolCommand

value = instance.ClickedCommand
C#
public ToolCommand ClickedCommand {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommandClickEventArgs Class
ToolCommandClickEventArgs Members


ClickedMenuItem Property

[image]
Intersoft WebDesktop Documentation
ClickedMenuItem Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommandClickEventArgs Class : ClickedMenuItem Property

Glossary Item Box

Gets the clicked menu item in ToolCommand.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClickedMenuItem As WebMenuItem
Visual Basic (Usage) Copy Code
Dim instance As ToolCommandClickEventArgs
Dim value As WebMenuItem

value = instance.ClickedMenuItem
C#
public WebMenuItem ClickedMenuItem {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommandClickEventArgs Class
ToolCommandClickEventArgs Members


ToolCommandCollection Class

[image]
Intersoft WebDesktop Documentation
ToolCommandCollection Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : ToolCommandCollection Class

Glossary Item Box

Collection of ToolCommand.

Object Model

ToolCommandCollection Class

Syntax

Visual Basic (Declaration)
Public Class ToolCommandCollection
   Inherits ISNet.WebUI.ISCollectionBase
Visual Basic (Usage) Copy Code
Dim instance As ToolCommandCollection
C#
public class ToolCommandCollection : ISNet.WebUI.ISCollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
ISNet.WebUI.ISCollectionBase
ISNet.WebUI.WebDesktop.ToolCommandCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommandCollection Members
ISNet.WebUI.WebDesktop Namespace


ToolCommandCollection Class Members

[image]
Intersoft WebDesktop Documentation
ToolCommandCollection Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : ToolCommandCollection Class

Glossary Item Box

The following tables list the members exposed by ToolCommandCollection.

Public Constructors

 | Name | Description
Public Constructor | ToolCommandCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden. Returns a Boolean value indicating whether the collection is read-only.
Public Property | Item | Property indexer for the collection.
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | GetObjectData |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

ToolCommandCollection Class
ISNet.WebUI.WebDesktop Namespace


ToolCommandCollection Constructor

[image]
Intersoft WebDesktop Documentation
ToolCommandCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommandCollection Class : ToolCommandCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ToolCommandCollection()
C#
public ToolCommandCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommandCollection Class
ToolCommandCollection Members


ToolCommandCollection Class Methods

[image]
Intersoft WebDesktop Documentation
ToolCommandCollection Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : ToolCommandCollection Class

Glossary Item Box

For a list of all members of this type, see ToolCommandCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | GetObjectData |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

ToolCommandCollection Class
ISNet.WebUI.WebDesktop Namespace


Add Method

[image]
Intersoft WebDesktop Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommandCollection Class : Add Method

Glossary Item Box

Overload List

Overload | Description
Add(ToolCommand) |
Add(String) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommandCollection Class
ToolCommandCollection Members


Add(ToolCommand) Method

[image]
Intersoft WebDesktop Documentation
Add(ToolCommand) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommandCollection Class > Add Method : Add(ToolCommand) Method

command

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function Add( _
   ByVal command As ToolCommand _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ToolCommandCollection
Dim command As ToolCommand
Dim value As Integer

value = instance.Add(command)
C#
public virtual int Add(
   ToolCommand command
)

Parameters

command

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommandCollection Class
ToolCommandCollection Members
Overload List


Add(String) Method

[image]
Intersoft WebDesktop Documentation
Add(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommandCollection Class > Add Method : Add(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal name As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ToolCommandCollection
Dim name As String
Dim value As Integer

value = instance.Add(name)
C#
public int Add(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommandCollection Class
ToolCommandCollection Members
Overload List


Clear Method

[image]
Intersoft WebDesktop Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommandCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As ToolCommandCollection

instance.Clear()
C#
public new void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommandCollection Class
ToolCommandCollection Members


Contains Method

[image]
Intersoft WebDesktop Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommandCollection Class : Contains Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As ISNet.WebUI.INamedObject _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ToolCommandCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As Boolean

value = instance.Contains(value)
C#
public bool Contains(
   ISNet.WebUI.INamedObject value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommandCollection Class
ToolCommandCollection Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommandCollection Class : CopyFrom Method

passIn

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CopyFrom( _
   ByVal passIn As ToolCommandCollection _
) As ToolCommandCollection
Visual Basic (Usage) Copy Code
Dim instance As ToolCommandCollection
Dim passIn As ToolCommandCollection
Dim value As ToolCommandCollection

value = instance.CopyFrom(passIn)
C#
public ToolCommandCollection CopyFrom(
   ToolCommandCollection passIn
)

Parameters

passIn

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommandCollection Class
ToolCommandCollection Members


CopyTo Method

[image]
Intersoft WebDesktop Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommandCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ToolCommandCollection
Dim array() As ISNet.WebUI.INamedObject
Dim index As Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   ISNet.WebUI.INamedObject[] array,
   int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommandCollection Class
ToolCommandCollection Members


Exists Method

[image]
Intersoft WebDesktop Documentation
Exists Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommandCollection Class : Exists Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Exists( _
   ByVal name As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ToolCommandCollection
Dim name As String
Dim value As Boolean

value = instance.Exists(name)
C#
public bool Exists(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommandCollection Class
ToolCommandCollection Members


GetEnumerator Method

[image]
Intersoft WebDesktop Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommandCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Function GetEnumerator() As System.Collections.IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As ToolCommandCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
public new System.Collections.IEnumerator GetEnumerator()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommandCollection Class
ToolCommandCollection Members


GetItem Method

[image]
Intersoft WebDesktop Documentation
GetItem Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommandCollection Class : GetItem Method

Glossary Item Box

Overload List

Overload | Description
GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommandCollection Class
ToolCommandCollection Members


GetItem(Int32) Method

[image]
Intersoft WebDesktop Documentation
GetItem(Int32) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommandCollection Class : GetItem(Int32) Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetItem( _
   ByVal index As Integer _
) As ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As ToolCommandCollection
Dim index As Integer
Dim value As ISNet.WebUI.INamedObject

value = instance.GetItem(index)
C#
public virtual ISNet.WebUI.INamedObject GetItem(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommandCollection Class
ToolCommandCollection Members


GetNamedItem Method

[image]
Intersoft WebDesktop Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommandCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNamedItem( _
   ByVal name As String _
) As ToolCommand
Visual Basic (Usage) Copy Code
Dim instance As ToolCommandCollection
Dim name As String
Dim value As ToolCommand

value = instance.GetNamedItem(name)
C#
public ToolCommand GetNamedItem(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommandCollection Class
ToolCommandCollection Members


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommandCollection Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ToolCommandCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommandCollection Class
ToolCommandCollection Members


IndexOf Method

[image]
Intersoft WebDesktop Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommandCollection Class : IndexOf Method

Glossary Item Box

Overload List

Overload | Description
IndexOf(String) | (Inherited from ISNet.WebUI.ISCollectionBase)
IndexOf(INamedObject) | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommandCollection Class
ToolCommandCollection Members


IndexOf(String) Method

[image]
Intersoft WebDesktop Documentation
IndexOf(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommandCollection Class > IndexOf Method : IndexOf(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function IndexOf( _
   ByVal name As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ToolCommandCollection
Dim name As String
Dim value As Integer

value = instance.IndexOf(name)
C#
public virtual int IndexOf(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommandCollection Class
ToolCommandCollection Members
Overload List


IndexOf(INamedObject) Method

[image]
Intersoft WebDesktop Documentation
IndexOf(INamedObject) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommandCollection Class > IndexOf Method : IndexOf(INamedObject) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal value As ISNet.WebUI.INamedObject _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ToolCommandCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As Integer

value = instance.IndexOf(value)
C#
public int IndexOf(
   ISNet.WebUI.INamedObject value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommandCollection Class
ToolCommandCollection Members
Overload List


Insert Method

[image]
Intersoft WebDesktop Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommandCollection Class : Insert Method

index
command

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal command As ToolCommand _
)
Visual Basic (Usage) Copy Code
Dim instance As ToolCommandCollection
Dim index As Integer
Dim command As ToolCommand

instance.Insert(index, command)
C#
public void Insert(
   int index,
   ToolCommand command
)

Parameters

index
command

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommandCollection Class
ToolCommandCollection Members


IntInsert Method

[image]
Intersoft WebDesktop Documentation
IntInsert Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommandCollection Class : IntInsert Method

index
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub IntInsert( _
   ByVal index As Integer, _
   ByVal value As ISNet.WebUI.INamedObject _
)
Visual Basic (Usage) Copy Code
Dim instance As ToolCommandCollection
Dim index As Integer
Dim value As ISNet.WebUI.INamedObject

instance.IntInsert(index, value)
C#
public void IntInsert(
   int index,
   ISNet.WebUI.INamedObject value
)

Parameters

index
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommandCollection Class
ToolCommandCollection Members


Remove Method

[image]
Intersoft WebDesktop Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommandCollection Class : Remove Method

command

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal command As ToolCommand _
)
Visual Basic (Usage) Copy Code
Dim instance As ToolCommandCollection
Dim command As ToolCommand

instance.Remove(command)
C#
public void Remove(
   ToolCommand command
)

Parameters

command

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommandCollection Class
ToolCommandCollection Members


setParent Method

[image]
Intersoft WebDesktop Documentation
setParent Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommandCollection Class : setParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub setParent( _
   ByVal parent As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ToolCommandCollection
Dim parent As Object

instance.setParent(parent)
C#
public virtual void setParent(
   object parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommandCollection Class
ToolCommandCollection Members


Capacity Property

[image]
Intersoft WebDesktop Documentation
Capacity Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommandCollection Class : Capacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
Visual Basic (Usage) Copy Code
Dim instance As ToolCommandCollection
Dim value As Integer

instance.Capacity = value

value = instance.Capacity
C#
public int Capacity {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommandCollection Class
ToolCommandCollection Members


Count Property

[image]
Intersoft WebDesktop Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommandCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ToolCommandCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommandCollection Class
ToolCommandCollection Members


ToolCommandCollection Class Properties

[image]
Intersoft WebDesktop Documentation
ToolCommandCollection Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : ToolCommandCollection Class

Glossary Item Box

For a list of all members of this type, see ToolCommandCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden. Returns a Boolean value indicating whether the collection is read-only.
Public Property | Item | Property indexer for the collection.
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

ToolCommandCollection Class
ISNet.WebUI.WebDesktop Namespace


ToolCommandCollection Constructor

[image]
Intersoft WebDesktop Documentation
ToolCommandCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommandCollection Class : ToolCommandCollection Constructor

Glossary Item Box

Initializes a new instance of the ToolCommandCollection class.

Overload List

Overload | Description
ToolCommandCollection Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommandCollection Class
ToolCommandCollection Members


IsReadOnly Property

[image]
Intersoft WebDesktop Documentation
IsReadOnly Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommandCollection Class : IsReadOnly Property

Glossary Item Box

Returns a Boolean value indicating whether the collection is read-only.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ToolCommandCollection
Dim value As Boolean

value = instance.IsReadOnly
C#
public override bool IsReadOnly {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommandCollection Class
ToolCommandCollection Members


Item Property

[image]
Intersoft WebDesktop Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommandCollection Class : Item Property

index

Glossary Item Box

Property indexer for the collection.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As ToolCommand
Visual Basic (Usage) Copy Code
Dim instance As ToolCommandCollection
Dim index As Integer
Dim value As ToolCommand

instance.Item(index) = value

value = instance.Item(index)
C#
public ToolCommand this[
   int index
]; {get; set;}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommandCollection Class
ToolCommandCollection Members


Parent Property

[image]
Intersoft WebDesktop Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ToolCommandCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As Object
Visual Basic (Usage) Copy Code
Dim instance As ToolCommandCollection
Dim value As Object

value = instance.Parent
C#
public object Parent {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommandCollection Class
ToolCommandCollection Members


UnitSize Class

[image]
Intersoft WebDesktop Documentation
UnitSize Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : UnitSize Class

Glossary Item Box

The unit size of Window in pixel.

Object Model

UnitSize Class

Syntax

Visual Basic (Declaration)
Public Class UnitSize
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As UnitSize
C#
public class UnitSize : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebDesktop.UnitSize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UnitSize Members
ISNet.WebUI.WebDesktop Namespace


UnitSize Class Members

[image]
Intersoft WebDesktop Documentation
UnitSize Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : UnitSize Class

Glossary Item Box

The following tables list the members exposed by UnitSize.

Public Constructors

 | Name | Description
Public Constructor | UnitSize Constructor |
Top

Public Properties

 | Name | Description
Public Property | Height | The height of Window in pixel.
Public Property | Width | The width of Window in pixel.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Equals |
Public Method | GetHashCode |
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | OnHeightChanged |
Public Method | OnWidthChanged |
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

UnitSize Class
ISNet.WebUI.WebDesktop Namespace


UnitSize Constructor

[image]
Intersoft WebDesktop Documentation
UnitSize Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > UnitSize Class : UnitSize Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New UnitSize()
C#
public UnitSize()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UnitSize Class
UnitSize Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > UnitSize Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As UnitSize
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UnitSize Class
UnitSize Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > UnitSize Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UnitSize Class
UnitSize Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > UnitSize Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As UnitSize
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UnitSize Class
UnitSize Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > UnitSize Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As UnitSize
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UnitSize Class
UnitSize Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > UnitSize Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As UnitSize
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UnitSize Class
UnitSize Members


UnitSize Class Methods

[image]
Intersoft WebDesktop Documentation
UnitSize Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : UnitSize Class

Glossary Item Box

For a list of all members of this type, see UnitSize members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Equals |
Public Method | GetHashCode |
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | OnHeightChanged |
Public Method | OnWidthChanged |
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

UnitSize Class
ISNet.WebUI.WebDesktop Namespace


Equals Method

[image]
Intersoft WebDesktop Documentation
Equals Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > UnitSize Class : Equals Method

obj

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As UnitSize
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)

Parameters

obj

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UnitSize Class
UnitSize Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > UnitSize Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As UnitSize
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UnitSize Class
UnitSize Members


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > UnitSize Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As UnitSize
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UnitSize Class
UnitSize Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > UnitSize Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As UnitSize
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UnitSize Class
UnitSize Members


OnHeightChanged Method

[image]
Intersoft WebDesktop Documentation
OnHeightChanged Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > UnitSize Class : OnHeightChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnHeightChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As UnitSize
Dim e As EventArgs

instance.OnHeightChanged(e)
C#
public void OnHeightChanged(
   EventArgs e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UnitSize Class
UnitSize Members


OnWidthChanged Method

[image]
Intersoft WebDesktop Documentation
OnWidthChanged Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > UnitSize Class : OnWidthChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnWidthChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As UnitSize
Dim e As EventArgs

instance.OnWidthChanged(e)
C#
public void OnWidthChanged(
   EventArgs e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UnitSize Class
UnitSize Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > UnitSize Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As UnitSize

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UnitSize Class
UnitSize Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > UnitSize Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As UnitSize
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UnitSize Class
UnitSize Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > UnitSize Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As UnitSize
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UnitSize Class
UnitSize Members


UnitSize Class Properties

[image]
Intersoft WebDesktop Documentation
UnitSize Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : UnitSize Class

Glossary Item Box

For a list of all members of this type, see UnitSize members.

Public Properties

 | Name | Description
Public Property | Height | The height of Window in pixel.
Public Property | Width | The width of Window in pixel.
Top

See Also

Reference

UnitSize Class
ISNet.WebUI.WebDesktop Namespace


UnitSize Constructor

[image]
Intersoft WebDesktop Documentation
UnitSize Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > UnitSize Class : UnitSize Constructor

Glossary Item Box

Initializes a new instance of the UnitSize class.

Overload List

Overload | Description
UnitSize Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UnitSize Class
UnitSize Members


Height Property

[image]
Intersoft WebDesktop Documentation
Height Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > UnitSize Class : Height Property

Glossary Item Box

The height of Window in pixel.

Syntax

Visual Basic (Declaration)
Public Overridable Property Height As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As UnitSize
Dim value As System.Web.UI.WebControls.Unit

instance.Height = value

value = instance.Height
C#
public virtual System.Web.UI.WebControls.Unit Height {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UnitSize Class
UnitSize Members


Width Property

[image]
Intersoft WebDesktop Documentation
Width Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > UnitSize Class : Width Property

Glossary Item Box

The width of Window in pixel.

Syntax

Visual Basic (Declaration)
Public Overridable Property Width As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As UnitSize
Dim value As System.Web.UI.WebControls.Unit

instance.Width = value

value = instance.Width
C#
public virtual System.Web.UI.WebControls.Unit Width {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UnitSize Class
UnitSize Members


UpdateControl Class

[image]
Intersoft WebDesktop Documentation
UpdateControl Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : UpdateControl Class

Glossary Item Box

Collection of controls that will be automatically converted to use callback instead of full postback.

Object Model

UpdateControl Class

Syntax

Visual Basic (Declaration)
Public Class UpdateControl
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As UpdateControl
C#
public class UpdateControl : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebDesktop.UpdateControl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UpdateControl Members
ISNet.WebUI.WebDesktop Namespace


UpdateControl Class Members

[image]
Intersoft WebDesktop Documentation
UpdateControl Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : UpdateControl Class

Glossary Item Box

The following tables list the members exposed by UpdateControl.

Public Constructors

 | Name | Description
Public Constructor | UpdateControl Constructor |
Top

Public Properties

 | Name | Description
Public Property | ControlID | Gets or sets the ID of the control to be updated when modified in callback context.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

UpdateControl Class
ISNet.WebUI.WebDesktop Namespace


UpdateControl Constructor

[image]
Intersoft WebDesktop Documentation
UpdateControl Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > UpdateControl Class : UpdateControl Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New UpdateControl()
C#
public UpdateControl()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UpdateControl Class
UpdateControl Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > UpdateControl Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As UpdateControl
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UpdateControl Class
UpdateControl Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > UpdateControl Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UpdateControl Class
UpdateControl Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > UpdateControl Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As UpdateControl
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UpdateControl Class
UpdateControl Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > UpdateControl Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As UpdateControl
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UpdateControl Class
UpdateControl Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > UpdateControl Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As UpdateControl
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UpdateControl Class
UpdateControl Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > UpdateControl Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As UpdateControl
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UpdateControl Class
UpdateControl Members


UpdateControl Class Methods

[image]
Intersoft WebDesktop Documentation
UpdateControl Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : UpdateControl Class

Glossary Item Box

For a list of all members of this type, see UpdateControl members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

UpdateControl Class
ISNet.WebUI.WebDesktop Namespace


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > UpdateControl Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As UpdateControl
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UpdateControl Class
UpdateControl Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > UpdateControl Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As UpdateControl
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UpdateControl Class
UpdateControl Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > UpdateControl Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As UpdateControl

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UpdateControl Class
UpdateControl Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > UpdateControl Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As UpdateControl
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UpdateControl Class
UpdateControl Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > UpdateControl Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As UpdateControl
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UpdateControl Class
UpdateControl Members


UpdateControl Class Properties

[image]
Intersoft WebDesktop Documentation
UpdateControl Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : UpdateControl Class

Glossary Item Box

For a list of all members of this type, see UpdateControl members.

Public Properties

 | Name | Description
Public Property | ControlID | Gets or sets the ID of the control to be updated when modified in callback context.
Top

See Also

Reference

UpdateControl Class
ISNet.WebUI.WebDesktop Namespace


UpdateControl Constructor

[image]
Intersoft WebDesktop Documentation
UpdateControl Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > UpdateControl Class : UpdateControl Constructor

Glossary Item Box

Initializes a new instance of the UpdateControl class.

Overload List

Overload | Description
UpdateControl Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UpdateControl Class
UpdateControl Members


ControlID Property

[image]
Intersoft WebDesktop Documentation
ControlID Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > UpdateControl Class : ControlID Property

Glossary Item Box

Gets or sets the ID of the control to be updated when modified in callback context.

Syntax

Visual Basic (Declaration)
Public Property ControlID As String
Visual Basic (Usage) Copy Code
Dim instance As UpdateControl
Dim value As String

instance.ControlID = value

value = instance.ControlID
C#
public string ControlID {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UpdateControl Class
UpdateControl Members


WebBarStyleSettings Class

[image]
Intersoft WebDesktop Documentation
WebBarStyleSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebBarStyleSettings Class

Glossary Item Box

A collection of settings to customize the bar style in WebMenuBar and WebToolBar.

Object Model

WebBarStyleSettings Class

Syntax

Visual Basic (Declaration)
Public Class WebBarStyleSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer
Visual Basic (Usage) Copy Code
Dim instance As WebBarStyleSettings
C#
public class WebBarStyleSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebDesktop.WebBarStyleSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebBarStyleSettings Members
ISNet.WebUI.WebDesktop Namespace

Tasks

Changing Toolbar Styles


WebBarStyleSettings Class Members

[image]
Intersoft WebDesktop Documentation
WebBarStyleSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebBarStyleSettings Class

Glossary Item Box

The following tables list the members exposed by WebBarStyleSettings.

Public Constructors

 | Name | Description
Public Constructor | WebBarStyleSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | BodyStyle | Gets or sets the style properties of body bar section in the bar control.
Public Property | CommandDisabledStyle | Gets or sets the style properties of disable command style.
Public Property | CommandStyle | Gets or sets the style properties of command in the bar control.
Public Property | HandleStyle | Gets or sets the style properties of handle bar section in the bar control.
Public Property | HeaderButtonStyle | Gets or sets the style properties of the header bar close button in the bar control.
Public Property | HeaderCaptionStyle | Gets or sets the style properties of the header bar caption in the bar control.
Public Property | OptionStyle | Gets or sets the style properties of option bar section in the bar control.
Public Property | SeparatorStyle | Gets or sets the style properties of separator command in the bar control.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CustomDeserialize |
Public Method | CustomSerialize |
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebBarStyleSettings Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Changing Toolbar Styles


WebBarStyleSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebBarStyleSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebBarStyleSettings Class : WebBarStyleSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebBarStyleSettings()
C#
public WebBarStyleSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebBarStyleSettings Class
WebBarStyleSettings Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebBarStyleSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebBarStyleSettings
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebBarStyleSettings Class
WebBarStyleSettings Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebBarStyleSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebBarStyleSettings Class
WebBarStyleSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebBarStyleSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebBarStyleSettings
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebBarStyleSettings Class
WebBarStyleSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebBarStyleSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebBarStyleSettings
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebBarStyleSettings Class
WebBarStyleSettings Members
Overload List


WebBarStyleSettings Class Methods

[image]
Intersoft WebDesktop Documentation
WebBarStyleSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebBarStyleSettings Class

Glossary Item Box

For a list of all members of this type, see WebBarStyleSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CustomDeserialize |
Public Method | CustomSerialize |
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebBarStyleSettings Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Changing Toolbar Styles


CustomDeserialize Method

[image]
Intersoft WebDesktop Documentation
CustomDeserialize Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebBarStyleSettings Class : CustomDeserialize Method

mi
currentObj
parentNode
currentNode

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CustomDeserialize( _
   ByVal mi As System.Reflection.MemberInfo, _
   ByVal currentObj As Object, _
   ByVal parentNode As System.Xml.XmlNode, _
   ByVal currentNode As System.Xml.XmlNode _
)
Visual Basic (Usage) Copy Code
Dim instance As WebBarStyleSettings
Dim mi As System.Reflection.MemberInfo
Dim currentObj As Object
Dim parentNode As System.Xml.XmlNode
Dim currentNode As System.Xml.XmlNode

instance.CustomDeserialize(mi, currentObj, parentNode, currentNode)
C#
public void CustomDeserialize(
   System.Reflection.MemberInfo mi,
   object currentObj,
   System.Xml.XmlNode parentNode,
   System.Xml.XmlNode currentNode
)

Parameters

mi
currentObj
parentNode
currentNode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebBarStyleSettings Class
WebBarStyleSettings Members


CustomSerialize Method

[image]
Intersoft WebDesktop Documentation
CustomSerialize Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebBarStyleSettings Class : CustomSerialize Method

doc
node

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CustomSerialize( _
   ByVal doc As System.Xml.XmlDocument, _
   ByVal node As System.Xml.XmlNode _
)
Visual Basic (Usage) Copy Code
Dim instance As WebBarStyleSettings
Dim doc As System.Xml.XmlDocument
Dim node As System.Xml.XmlNode

instance.CustomSerialize(doc, node)
C#
public void CustomSerialize(
   System.Xml.XmlDocument doc,
   System.Xml.XmlNode node
)

Parameters

doc
node

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebBarStyleSettings Class
WebBarStyleSettings Members


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebBarStyleSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebBarStyleSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebBarStyleSettings Class
WebBarStyleSettings Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebBarStyleSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebBarStyleSettings
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebBarStyleSettings Class
WebBarStyleSettings Members


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebBarStyleSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebBarStyleSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebBarStyleSettings Class
WebBarStyleSettings Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebBarStyleSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebBarStyleSettings
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebBarStyleSettings Class
WebBarStyleSettings Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebBarStyleSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebBarStyleSettings

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebBarStyleSettings Class
WebBarStyleSettings Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebBarStyleSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebBarStyleSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebBarStyleSettings Class
WebBarStyleSettings Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebBarStyleSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebBarStyleSettings
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebBarStyleSettings Class
WebBarStyleSettings Members


WebBarStyleSettings Class Properties

[image]
Intersoft WebDesktop Documentation
WebBarStyleSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebBarStyleSettings Class

Glossary Item Box

For a list of all members of this type, see WebBarStyleSettings members.

Public Properties

 | Name | Description
Public Property | BodyStyle | Gets or sets the style properties of body bar section in the bar control.
Public Property | CommandDisabledStyle | Gets or sets the style properties of disable command style.
Public Property | CommandStyle | Gets or sets the style properties of command in the bar control.
Public Property | HandleStyle | Gets or sets the style properties of handle bar section in the bar control.
Public Property | HeaderButtonStyle | Gets or sets the style properties of the header bar close button in the bar control.
Public Property | HeaderCaptionStyle | Gets or sets the style properties of the header bar caption in the bar control.
Public Property | OptionStyle | Gets or sets the style properties of option bar section in the bar control.
Public Property | SeparatorStyle | Gets or sets the style properties of separator command in the bar control.
Top

See Also

Reference

WebBarStyleSettings Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Changing Toolbar Styles


WebBarStyleSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebBarStyleSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebBarStyleSettings Class : WebBarStyleSettings Constructor

Glossary Item Box

Initializes a new instance of the WebBarStyleSettings class.

Overload List

Overload | Description
WebBarStyleSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebBarStyleSettings Class
WebBarStyleSettings Members


BodyStyle Property

[image]
Intersoft WebDesktop Documentation
BodyStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebBarStyleSettings Class : BodyStyle Property

Glossary Item Box

Gets or sets the style properties of body bar section in the bar control.

Syntax

Visual Basic (Declaration)
Public Property BodyStyle As BarSectionStyle
Visual Basic (Usage) Copy Code
Dim instance As WebBarStyleSettings
Dim value As BarSectionStyle

instance.BodyStyle = value

value = instance.BodyStyle
C#
public BarSectionStyle BodyStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebBarStyleSettings Class
WebBarStyleSettings Members


CommandDisabledStyle Property

[image]
Intersoft WebDesktop Documentation
CommandDisabledStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebBarStyleSettings Class : CommandDisabledStyle Property

Glossary Item Box

Gets or sets the style properties of disable command style.

Syntax

Visual Basic (Declaration)
Public Overridable Property CommandDisabledStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebBarStyleSettings
Dim value As ISNet.WebUI.WebStyle

instance.CommandDisabledStyle = value

value = instance.CommandDisabledStyle
C#
public virtual ISNet.WebUI.WebStyle CommandDisabledStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebBarStyleSettings Class
WebBarStyleSettings Members


CommandStyle Property

[image]
Intersoft WebDesktop Documentation
CommandStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebBarStyleSettings Class : CommandStyle Property

Glossary Item Box

Gets or sets the style properties of command in the bar control.

Syntax

Visual Basic (Declaration)
Public Overridable Property CommandStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebBarStyleSettings
Dim value As ISNet.WebUI.DynamicStyle

instance.CommandStyle = value

value = instance.CommandStyle
C#
public virtual ISNet.WebUI.DynamicStyle CommandStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebBarStyleSettings Class
WebBarStyleSettings Members

Tasks

Changing Toolbar Styles


HandleStyle Property

[image]
Intersoft WebDesktop Documentation
HandleStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebBarStyleSettings Class : HandleStyle Property

Glossary Item Box

Gets or sets the style properties of handle bar section in the bar control.

Syntax

Visual Basic (Declaration)
Public Property HandleStyle As BarSectionStyle
Visual Basic (Usage) Copy Code
Dim instance As WebBarStyleSettings
Dim value As BarSectionStyle

instance.HandleStyle = value

value = instance.HandleStyle
C#
public BarSectionStyle HandleStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebBarStyleSettings Class
WebBarStyleSettings Members


HeaderButtonStyle Property

[image]
Intersoft WebDesktop Documentation
HeaderButtonStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebBarStyleSettings Class : HeaderButtonStyle Property

Glossary Item Box

Gets or sets the style properties of the header bar close button in the bar control.

Syntax

Visual Basic (Declaration)
Public Overridable Property HeaderButtonStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebBarStyleSettings
Dim value As ISNet.WebUI.DynamicStyle

instance.HeaderButtonStyle = value

value = instance.HeaderButtonStyle
C#
public virtual ISNet.WebUI.DynamicStyle HeaderButtonStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebBarStyleSettings Class
WebBarStyleSettings Members


HeaderCaptionStyle Property

[image]
Intersoft WebDesktop Documentation
HeaderCaptionStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebBarStyleSettings Class : HeaderCaptionStyle Property

Glossary Item Box

Gets or sets the style properties of the header bar caption in the bar control.

Syntax

Visual Basic (Declaration)
Public Overridable Property HeaderCaptionStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebBarStyleSettings
Dim value As ISNet.WebUI.WebStyle

instance.HeaderCaptionStyle = value

value = instance.HeaderCaptionStyle
C#
public virtual ISNet.WebUI.WebStyle HeaderCaptionStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebBarStyleSettings Class
WebBarStyleSettings Members


OptionStyle Property

[image]
Intersoft WebDesktop Documentation
OptionStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebBarStyleSettings Class : OptionStyle Property

Glossary Item Box

Gets or sets the style properties of option bar section in the bar control.

Syntax

Visual Basic (Declaration)
Public Property OptionStyle As BarSectionStyle
Visual Basic (Usage) Copy Code
Dim instance As WebBarStyleSettings
Dim value As BarSectionStyle

instance.OptionStyle = value

value = instance.OptionStyle
C#
public BarSectionStyle OptionStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebBarStyleSettings Class
WebBarStyleSettings Members


SeparatorStyle Property

[image]
Intersoft WebDesktop Documentation
SeparatorStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebBarStyleSettings Class : SeparatorStyle Property

Glossary Item Box

Gets or sets the style properties of separator command in the bar control.

Syntax

Visual Basic (Declaration)
Public Overridable Property SeparatorStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebBarStyleSettings
Dim value As ISNet.WebUI.WebStyle

instance.SeparatorStyle = value

value = instance.SeparatorStyle
C#
public virtual ISNet.WebUI.WebStyle SeparatorStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebBarStyleSettings Class
WebBarStyleSettings Members


WebButton Class

[image]
Intersoft WebDesktop Documentation
WebButton Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebButton Class

Glossary Item Box

Intersoft's unique button component to complement the WebDesktop.NET which incorporates Framework's DynamicStyle to enable the rich interactive styles. WebButton supports DisplayMode feature which allows you to put a custom image at the left or right part of the WebButton.

Object Model

WebButton Class

Syntax

Visual Basic (Declaration)
Public Class WebButton
   Inherits ISNet.WebUI.ISNetControl
   Implements ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings
Visual Basic (Usage) Copy Code
Dim instance As WebButton
C#
public class WebButton : ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings

Remarks

WebButton can be used either stand-alone or integrated with WebDesktopManager. To cover the flexibility and to manage a consistent look and feel throughout the application, WebButton's styles will be inherited from WebDesktopManager to guarantee the consistent dynamic styles throughout the entire application. On the other hand, you can also choose your WebButton instances to become stand-alone component, which means you are free to choose your own styles and behaviors for each button.

Following are some important features of WebButton.

  • AutoPostBack
    WebButton can operate in client side or server side mode. The default is client side mode where AutoPostBack is set to False. When operates in client side mode, developers generally implement the OnClientClick client side event to execute the javascript codes to response the button click.
  • PostBackMode
    WebButton is taking advantage of FlyPostBack and ClientAction architecture enabling the Button to execute server side codes in Button's OnClick event without full page refresh.
  • DesktopManager Integration
    The integration to DesktopManager component enables the button to resemble the look and feel of CommandButtonStyle, CommandButtonDisabledStyle, CommandButtonBorderType and CommandButton's ComplexImages which specified in DesktopManager level.
  • Convenient Parameter Passing
    WebButton introduces a convenient way in passing parameter which is one of the most common practice required in web application development. The Parameter property can be set in both server side and client side to pass information during postbacks.

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
ISNet.WebUI.ISNetControl
ISNet.WebUI.WebDesktop.WebButton

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Members
ISNet.WebUI.WebDesktop Namespace

Tasks

Configuring Interactive Style of WebButton

tasks

Enabling Automatic Postback when Clicked
Executing server side codes in FlyPostBack mode
Using ClientAction engine during FlyPostBack execution.

Concepts

WebButton Features

concepts

WebButton Integrating to DesktopManager


WebButton Class Members

[image]
Intersoft WebDesktop Documentation
WebButton Class Members
See Also Properties Methods Events Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebButton Class

Glossary Item Box

The following tables list the members exposed by WebButton.

Public Constructors

 | Name | Description
Public Constructor | WebButton Constructor |
Top

Public Properties

 | Name | Description
Public Property | AccessKey | Keyboard shortcut used by the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | AutoPostback | Specifies whether the button should perform postback automatically when clicked.
Public Property | BackColor | Overridden. Color of the background of the control.
Public Property | BorderColor | Overridden. Color of the border around the control.
Public Property | BorderStyle | Overridden. Style of the border around the control.
Public Property | BorderWidth | Overridden. Width of the border around the control.
Public Property | ButtonStyle | Contains interactive style for the Button.
Public Property | CausesValidation | Gets or sets a value indicating whether validation is performed when the WebButton control is clicked.
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | DisabledStyle | Gets or sets the disabled style for the Button.
Public Property | DisableOnClicked | Specifies whether the button should be disabled after clicked.
Public Property | DisplayMode | Gets or sets the caption display mode for the button.
Public Property | Enabled | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableManagedTheming | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | FlyPostBackSettings | Configures the settings used by the control when performing OnTheFly postback.
Public Property | Font | Overridden. The font used for text within the control.
Public Property | ForeColor | Overridden. Color of the text within the control.
Public Property | Height | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | Image | Gets or sets the image displayed in the button.
Public Property | ImagePosition | Gets or sets the image position relative to the text.
Public Property | InProgressImage |
Public Property | InProgressText |
Public Property | IntegratedToDesktopManager | Specifies whether the button should be integrated to Desktop Manager.
Public Property | IsToggleButton | Determinse whether the button is a toggle button.
Public Property | OnClientClick | Specifies the javascript function to invoke when the button is clicked.
Public Property | OnClientInitialize | Specifies the javascript function to invoke when the button is being initialized.
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Parameter | Gets or sets the parameter or data that will be passed to client side event when the button is clicked.
Public Property | PostBackMode | Gets or sets the postback mode when the button is clicked and AutoPostback is enabled.
Public Property | ProgressTextStyle |
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden. Gets or sets the directory where all required scripts for the control are stored.
Public Property | SharedScriptDirectory | Overridden.
Public Property | ShowProgressOnClicked |
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | The tab order of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Text | Gets or sets the text displayed in the button.
Public Property | ToolTip | The tooltip displayed when the mouse is over the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Type | Gets or sets the type of the button which will automatically perform built-in behavior accordingly.
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ValidationGroup | Gets or sets the group of controls for which the WebButton control causes validation when it posts back to the server.
Public Property | ViewStateItems | Gets or sets the items to be stored in view state storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | Gets or sets the server connection string for file server-based viewstate storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | Gets or sets the location to store the viewstate of this control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | Indicates whether the control is visible and rendered. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Width | The width of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | XmlCompressionEnabled | Specifies whether the Xml used for clientside state storage should be compressed. (Inherited from ISNet.WebUI.ISNetControl)
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetClientAction |
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPostData | Overridden.
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnClicked |
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreRender |
Public Method | OnRequest |
Public Method | RaisePostBackEvent |
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RecreateChildControls |
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetPushed |
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Top

Public Events

 | Name | Description
Public Event | Clicked | Occurs when WebButton is clicked.
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebButton Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Configuring Interactive Style of WebButton

tasks

Enabling Automatic Postback when Clicked
Executing server side codes in FlyPostBack mode
Using ClientAction engine during FlyPostBack execution.

Concepts

WebButton Features

concepts

WebButton Integrating to DesktopManager


WebButton Constructor

[image]
Intersoft WebDesktop Documentation
WebButton Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : WebButton Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebButton()
C#
public WebButton()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


ApplyStyle Method

[image]
Intersoft WebDesktop Documentation
ApplyStyle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : ApplyStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ApplyStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim s As System.Web.UI.WebControls.Style

instance.ApplyStyle(s)
C#
public void ApplyStyle(
   System.Web.UI.WebControls.Style s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


ApplyStyleSheetSkin Method

[image]
Intersoft WebDesktop Documentation
ApplyStyleSheetSkin Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : ApplyStyleSheetSkin Method

page

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub ApplyStyleSheetSkin( _
   ByVal page As System.Web.UI.Page _
)
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim page As System.Web.UI.Page

instance.ApplyStyleSheetSkin(page)
C#
public virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page page
)

Parameters

page

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


CanUseWebResources Method

[image]
Intersoft WebDesktop Documentation
CanUseWebResources Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : CanUseWebResources Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CanUseWebResources() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As Boolean

value = instance.CanUseWebResources()
C#
public bool CanUseWebResources()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


CopyBaseAttributes Method

[image]
Intersoft WebDesktop Documentation
CopyBaseAttributes Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : CopyBaseAttributes Method

controlSrc

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyBaseAttributes( _
   ByVal controlSrc As System.Web.UI.WebControls.WebControl _
)
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim controlSrc As System.Web.UI.WebControls.WebControl

instance.CopyBaseAttributes(controlSrc)
C#
public void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl controlSrc
)

Parameters

controlSrc

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.ISNetControl)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members
Overload List


DataBind Method

[image]
Intersoft WebDesktop Documentation
DataBind Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : DataBind Method

Glossary Item Box

Overload List

Overload | Description
DataBind | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


DataBind() Method

[image]
Intersoft WebDesktop Documentation
DataBind() Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : DataBind() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub DataBind()
Visual Basic (Usage) Copy Code
Dim instance As WebButton

instance.DataBind()
C#
public virtual void DataBind()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


Dispose Method

[image]
Intersoft WebDesktop Documentation
Dispose Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : Dispose Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As WebButton

instance.Dispose()
C#
public virtual void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


FindControl Method

[image]
Intersoft WebDesktop Documentation
FindControl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : FindControl Method

Glossary Item Box

Overload List

Overload | Description
FindControl | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


FindControl(String) Method

[image]
Intersoft WebDesktop Documentation
FindControl(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : FindControl(String) Method

id

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function FindControl( _
   ByVal id As String _
) As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim id As String
Dim value As System.Web.UI.Control

value = instance.FindControl(id)
C#
public virtual System.Web.UI.Control FindControl(
   string id
)

Parameters

id

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


Focus Method

[image]
Intersoft WebDesktop Documentation
Focus Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : Focus Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Focus()
Visual Basic (Usage) Copy Code
Dim instance As WebButton

instance.Focus()
C#
public virtual void Focus()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


ForceDisableXmlCompression Method

[image]
Intersoft WebDesktop Documentation
ForceDisableXmlCompression Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : ForceDisableXmlCompression Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ForceDisableXmlCompression()
Visual Basic (Usage) Copy Code
Dim instance As WebButton

instance.ForceDisableXmlCompression()
C#
public void ForceDisableXmlCompression()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


WebButton Class Methods

[image]
Intersoft WebDesktop Documentation
WebButton Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebButton Class

Glossary Item Box

For a list of all members of this type, see WebButton members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetClientAction |
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPostData | Overridden.
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnClicked |
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreRender |
Public Method | OnRequest |
Public Method | RaisePostBackEvent |
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RecreateChildControls |
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetPushed |
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Top

See Also

Reference

WebButton Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Configuring Interactive Style of WebButton

tasks

Enabling Automatic Postback when Clicked
Executing server side codes in FlyPostBack mode
Using ClientAction engine during FlyPostBack execution.

Concepts

WebButton Features

concepts

WebButton Integrating to DesktopManager


GetClientAction Method

[image]
Intersoft WebDesktop Documentation
GetClientAction Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : GetClientAction Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetClientAction() As ISNet.WebUI.BaseClientSideAction
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As ISNet.WebUI.BaseClientSideAction

value = instance.GetClientAction()
C#
public ISNet.WebUI.BaseClientSideAction GetClientAction()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


GetCurrentControlLifeCycle Method

[image]
Intersoft WebDesktop Documentation
GetCurrentControlLifeCycle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : GetCurrentControlLifeCycle Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentControlLifeCycle() As ISNet.WebUI.ControlLifeCycle
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As ISNet.WebUI.ControlLifeCycle

value = instance.GetCurrentControlLifeCycle()
C#
public ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


GetCurrentTheme Method

[image]
Intersoft WebDesktop Documentation
GetCurrentTheme Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : GetCurrentTheme Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentTheme() As ISNet.WebUI.ThemeInfo
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As ISNet.WebUI.ThemeInfo

value = instance.GetCurrentTheme()
C#
public ISNet.WebUI.ThemeInfo GetCurrentTheme()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


GetFrameworkDataFolder Method

[image]
Intersoft WebDesktop Documentation
GetFrameworkDataFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : GetFrameworkDataFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkDataFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As String

value = instance.GetFrameworkDataFolder()
C#
public string GetFrameworkDataFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


GetFrameworkFolder Method

[image]
Intersoft WebDesktop Documentation
GetFrameworkFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : GetFrameworkFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As String

value = instance.GetFrameworkFolder()
C#
public string GetFrameworkFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


GetFrameworkVersion Method

[image]
Intersoft WebDesktop Documentation
GetFrameworkVersion Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : GetFrameworkVersion Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkVersion() As Version
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As Version

value = instance.GetFrameworkVersion()
C#
public Version GetFrameworkVersion()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


GetIntersoftFolder Method

[image]
Intersoft WebDesktop Documentation
GetIntersoftFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : GetIntersoftFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetIntersoftFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As String

value = instance.GetIntersoftFolder()
C#
public string GetIntersoftFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


GetLayoutFolder Method

[image]
Intersoft WebDesktop Documentation
GetLayoutFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : GetLayoutFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetLayoutFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As String

value = instance.GetLayoutFolder()
C#
public string GetLayoutFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


GetPostedXMLData Method

[image]
Intersoft WebDesktop Documentation
GetPostedXMLData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : GetPostedXMLData Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPostedXMLData() As String
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As String

value = instance.GetPostedXMLData()
C#
public string GetPostedXMLData()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


GetProductInfoKey Method

[image]
Intersoft WebDesktop Documentation
GetProductInfoKey Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : GetProductInfoKey Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductInfoKey() As String
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As String

value = instance.GetProductInfoKey()
C#
public string GetProductInfoKey()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


GetProductSimpleName Method

[image]
Intersoft WebDesktop Documentation
GetProductSimpleName Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : GetProductSimpleName Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductSimpleName() As String
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As String

value = instance.GetProductSimpleName()
C#
public string GetProductSimpleName()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


GetPropertyValue Method

[image]
Intersoft WebDesktop Documentation
GetPropertyValue Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : GetPropertyValue Method

defValue
propValue
webConfigKey

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPropertyValue( _
   ByVal defValue As String, _
   ByVal propValue As String, _
   ByVal webConfigKey As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim defValue As String
Dim propValue As String
Dim webConfigKey As String
Dim value As String

value = instance.GetPropertyValue(defValue, propValue, webConfigKey)
C#
public string GetPropertyValue(
   string defValue,
   string propValue,
   string webConfigKey
)

Parameters

defValue
propValue
webConfigKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


GetResourceStream Method

[image]
Intersoft WebDesktop Documentation
GetResourceStream Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : GetResourceStream Method

resourceUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetResourceStream( _
   ByVal resourceUrl As String _
) As System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim resourceUrl As String
Dim value As System.IO.Stream

value = instance.GetResourceStream(resourceUrl)
C#
public System.IO.Stream GetResourceStream(
   string resourceUrl
)

Parameters

resourceUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


GetRouteUrl Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : GetRouteUrl Method

Glossary Item Box

Overload List

Overload | Description
GetRouteUrl(Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(RouteValueDictionary) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,RouteValueDictionary) | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


GetRouteUrl(Object) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class > GetRouteUrl Method : GetRouteUrl(Object) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As Object _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim routeParameters As Object
Dim value As String

value = instance.GetRouteUrl(routeParameters)
C#
public string GetRouteUrl(
   object routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members
Overload List


GetRouteUrl(String,Object) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(String,Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class > GetRouteUrl Method : GetRouteUrl(String,Object) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As String, _
   ByVal routeParameters As Object _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim routeName As String
Dim routeParameters As Object
Dim value As String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public string GetRouteUrl(
   string routeName,
   object routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members
Overload List


GetRouteUrl(RouteValueDictionary) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(RouteValueDictionary) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class > GetRouteUrl Method : GetRouteUrl(RouteValueDictionary) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As String

value = instance.GetRouteUrl(routeParameters)
C#
public string GetRouteUrl(
   System.Web.Routing.RouteValueDictionary routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members
Overload List


GetRouteUrl(String,RouteValueDictionary) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(String,RouteValueDictionary) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class > GetRouteUrl Method : GetRouteUrl(String,RouteValueDictionary) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As String, _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim routeName As String
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public string GetRouteUrl(
   string routeName,
   System.Web.Routing.RouteValueDictionary routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members
Overload List


GetUniqueIDRelativeTo Method

[image]
Intersoft WebDesktop Documentation
GetUniqueIDRelativeTo Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : GetUniqueIDRelativeTo Method

control

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetUniqueIDRelativeTo( _
   ByVal control As System.Web.UI.Control _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim control As System.Web.UI.Control
Dim value As String

value = instance.GetUniqueIDRelativeTo(control)
C#
public string GetUniqueIDRelativeTo(
   System.Web.UI.Control control
)

Parameters

control

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


HasControls Method

[image]
Intersoft WebDesktop Documentation
HasControls Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : HasControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function HasControls() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As Boolean

value = instance.HasControls()
C#
public virtual bool HasControls()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


IsAtlasCallback Method

[image]
Intersoft WebDesktop Documentation
IsAtlasCallback Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : IsAtlasCallback Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsAtlasCallback() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As Boolean

value = instance.IsAtlasCallback()
C#
public bool IsAtlasCallback()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


IsBetaRelease Method

[image]
Intersoft WebDesktop Documentation
IsBetaRelease Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : IsBetaRelease Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsBetaRelease() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As Boolean

value = instance.IsBetaRelease()
C#
public bool IsBetaRelease()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


IsChromeBrowser Method

[image]
Intersoft WebDesktop Documentation
IsChromeBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : IsChromeBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsChromeBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As Boolean

value = instance.IsChromeBrowser()
C#
public bool IsChromeBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


IsFlyPostBackControl Method

[image]
Intersoft WebDesktop Documentation
IsFlyPostBackControl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : IsFlyPostBackControl Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackControl() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As Boolean

value = instance.IsFlyPostBackControl()
C#
public virtual bool IsFlyPostBackControl()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


IsFlyPostBackRequest Method

[image]
Intersoft WebDesktop Documentation
IsFlyPostBackRequest Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : IsFlyPostBackRequest Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackRequest() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As Boolean

value = instance.IsFlyPostBackRequest()
C#
public virtual bool IsFlyPostBackRequest()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


IsGeckoBasedBrowser Method

[image]
Intersoft WebDesktop Documentation
IsGeckoBasedBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : IsGeckoBasedBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoBasedBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As Boolean

value = instance.IsGeckoBasedBrowser()
C#
public bool IsGeckoBasedBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


IsGeckoVersion18 Method

[image]
Intersoft WebDesktop Documentation
IsGeckoVersion18 Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : IsGeckoVersion18 Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoVersion18() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As Boolean

value = instance.IsGeckoVersion18()
C#
public bool IsGeckoVersion18()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


IsInDesignMode Method

[image]
Intersoft WebDesktop Documentation
IsInDesignMode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : IsInDesignMode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInDesignMode() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As Boolean

value = instance.IsInDesignMode()
C#
public bool IsInDesignMode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


IsInternetExplorer8Browser Method

[image]
Intersoft WebDesktop Documentation
IsInternetExplorer8Browser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : IsInternetExplorer8Browser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorer8Browser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As Boolean

value = instance.IsInternetExplorer8Browser()
C#
public bool IsInternetExplorer8Browser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


IsInternetExplorerBrowser Method

[image]
Intersoft WebDesktop Documentation
IsInternetExplorerBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : IsInternetExplorerBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorerBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As Boolean

value = instance.IsInternetExplorerBrowser()
C#
public bool IsInternetExplorerBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


IsOperaBrowser Method

[image]
Intersoft WebDesktop Documentation
IsOperaBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : IsOperaBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsOperaBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As Boolean

value = instance.IsOperaBrowser()
C#
public bool IsOperaBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


IsSafariBrowser Method

[image]
Intersoft WebDesktop Documentation
IsSafariBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : IsSafariBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsSafariBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As Boolean

value = instance.IsSafariBrowser()
C#
public bool IsSafariBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


IsW3CStandardBrowser Method

[image]
Intersoft WebDesktop Documentation
IsW3CStandardBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : IsW3CStandardBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsW3CStandardBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As Boolean

value = instance.IsW3CStandardBrowser()
C#
public bool IsW3CStandardBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


LoadLayout Method

[image]
Intersoft WebDesktop Documentation
LoadLayout Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : LoadLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim settings As ISNet.WebUI.LayoutInfo

instance.LoadLayout(settings)
C#
public virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


LoadLayoutFromFile Method

[image]
Intersoft WebDesktop Documentation
LoadLayoutFromFile Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : LoadLayoutFromFile Method

filePath

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromFile( _
   ByVal filePath As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim filePath As String

instance.LoadLayoutFromFile(filePath)
C#
public virtual void LoadLayoutFromFile(
   string filePath
)

Parameters

filePath

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


LoadLayoutFromPredefinedName Method

[image]
Intersoft WebDesktop Documentation
LoadLayoutFromPredefinedName Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : LoadLayoutFromPredefinedName Method

predefinedName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromPredefinedName( _
   ByVal predefinedName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim predefinedName As String

instance.LoadLayoutFromPredefinedName(predefinedName)
C#
public virtual void LoadLayoutFromPredefinedName(
   string predefinedName
)

Parameters

predefinedName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


LoadLayoutFromStream Method

[image]
Intersoft WebDesktop Documentation
LoadLayoutFromStream Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : LoadLayoutFromStream Method

stream

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromStream( _
   ByVal stream As System.IO.Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim stream As System.IO.Stream

instance.LoadLayoutFromStream(stream)
C#
public virtual void LoadLayoutFromStream(
   System.IO.Stream stream
)

Parameters

stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


LoadPostData Method

[image]
Intersoft WebDesktop Documentation
LoadPostData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : LoadPostData Method

postDataKey
postCollection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function LoadPostData( _
   ByVal postDataKey As String, _
   ByVal postCollection As System.Collections.Specialized.NameValueCollection _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim postDataKey As String
Dim postCollection As System.Collections.Specialized.NameValueCollection
Dim value As Boolean

value = instance.LoadPostData(postDataKey, postCollection)
C#
public override bool LoadPostData(
   string postDataKey,
   System.Collections.Specialized.NameValueCollection postCollection
)

Parameters

postDataKey
postCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


MergeStyle Method

[image]
Intersoft WebDesktop Documentation
MergeStyle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : MergeStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub MergeStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim s As System.Web.UI.WebControls.Style

instance.MergeStyle(s)
C#
public void MergeStyle(
   System.Web.UI.WebControls.Style s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


OnClicked Method

[image]
Intersoft WebDesktop Documentation
OnClicked Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : OnClicked Method

parameter

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function OnClicked( _
   ByVal parameter As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim parameter As Object
Dim value As Boolean

value = instance.OnClicked(parameter)
C#
public virtual bool OnClicked(
   object parameter
)

Parameters

parameter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


OnInfoChanged Method

[image]
Intersoft WebDesktop Documentation
OnInfoChanged Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : OnInfoChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnInfoChanged( _
   ByVal e As ISNet.WebUI.SynchronizeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim e As ISNet.WebUI.SynchronizeEventArgs

instance.OnInfoChanged(e)
C#
public void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


OnPreInitialize Method

[image]
Intersoft WebDesktop Documentation
OnPreInitialize Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : OnPreInitialize Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnPreInitialize()
Visual Basic (Usage) Copy Code
Dim instance As WebButton

instance.OnPreInitialize()
C#
public virtual void OnPreInitialize()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


OnPreRender Method

[image]
Intersoft WebDesktop Documentation
OnPreRender Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : OnPreRender Method

Glossary Item Box

Overload List

Overload | Description
OnPreRender |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


OnPreRender() Method

[image]
Intersoft WebDesktop Documentation
OnPreRender() Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : OnPreRender() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnPreRender()
Visual Basic (Usage) Copy Code
Dim instance As WebButton

instance.OnPreRender()
C#
public void OnPreRender()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


OnRequest Method

[image]
Intersoft WebDesktop Documentation
OnRequest Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : OnRequest Method

requestObject

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnRequest( _
   ByVal requestObject As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim requestObject As Object

instance.OnRequest(requestObject)
C#
public void OnRequest(
   object requestObject
)

Parameters

requestObject

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


RaisePostBackEvent Method

[image]
Intersoft WebDesktop Documentation
RaisePostBackEvent Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : RaisePostBackEvent Method

eventArgument

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RaisePostBackEvent( _
   ByVal eventArgument As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim eventArgument As String

instance.RaisePostBackEvent(eventArgument)
C#
public void RaisePostBackEvent(
   string eventArgument
)

Parameters

eventArgument

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


RaisePostDataChangedEvent Method

[image]
Intersoft WebDesktop Documentation
RaisePostDataChangedEvent Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : RaisePostDataChangedEvent Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RaisePostDataChangedEvent()
Visual Basic (Usage) Copy Code
Dim instance As WebButton

instance.RaisePostDataChangedEvent()
C#
public virtual void RaisePostDataChangedEvent()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


ReadWebConfigValue Method

[image]
Intersoft WebDesktop Documentation
ReadWebConfigValue Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : ReadWebConfigValue Method

key

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ReadWebConfigValue( _
   ByVal key As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim key As String
Dim value As String

value = instance.ReadWebConfigValue(key)
C#
public string ReadWebConfigValue(
   string key
)

Parameters

key

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


RecreateChildControls Method

[image]
Intersoft WebDesktop Documentation
RecreateChildControls Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : RecreateChildControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RecreateChildControls()
Visual Basic (Usage) Copy Code
Dim instance As WebButton

instance.RecreateChildControls()
C#
public void RecreateChildControls()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


RegisterBoxSizing Method

[image]
Intersoft WebDesktop Documentation
RegisterBoxSizing Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : RegisterBoxSizing Method

Glossary Item Box

Overload List

Overload | Description
RegisterBoxSizing() | (Inherited from ISNet.WebUI.ISNetControl)
RegisterBoxSizing(Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


RegisterBoxSizing() Method

[image]
Intersoft WebDesktop Documentation
RegisterBoxSizing() Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class > RegisterBoxSizing Method : RegisterBoxSizing() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing()
Visual Basic (Usage) Copy Code
Dim instance As WebButton

instance.RegisterBoxSizing()
C#
public void RegisterBoxSizing()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members
Overload List


RegisterBoxSizing(Boolean) Method

[image]
Intersoft WebDesktop Documentation
RegisterBoxSizing(Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class > RegisterBoxSizing Method : RegisterBoxSizing(Boolean) Method

forceAll

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing( _
   ByVal forceAll As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim forceAll As Boolean

instance.RegisterBoxSizing(forceAll)
C#
public void RegisterBoxSizing(
   bool forceAll
)

Parameters

forceAll

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members
Overload List


RegisterGlobalStyle Method

[image]
Intersoft WebDesktop Documentation
RegisterGlobalStyle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : RegisterGlobalStyle Method

style

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterGlobalStyle( _
   ByVal style As ISNet.WebUI.WebStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim style As ISNet.WebUI.WebStyle

instance.RegisterGlobalStyle(style)
C#
public void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle style
)

Parameters

style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


RegisterLink Method

[image]
Intersoft WebDesktop Documentation
RegisterLink Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : RegisterLink Method

name
url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterLink( _
   ByVal name As String, _
   ByVal url As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim name As String
Dim url As String

instance.RegisterLink(name, url)
C#
public void RegisterLink(
   string name,
   string url
)

Parameters

name
url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


RegisterOptimizedCssClasses Method

[image]
Intersoft WebDesktop Documentation
RegisterOptimizedCssClasses Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : RegisterOptimizedCssClasses Method

runtimeStyleOnly

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterOptimizedCssClasses( _
   ByVal runtimeStyleOnly As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim runtimeStyleOnly As Boolean

instance.RegisterOptimizedCssClasses(runtimeStyleOnly)
C#
public void RegisterOptimizedCssClasses(
   bool runtimeStyleOnly
)

Parameters

runtimeStyleOnly

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


RegisterPreloadImage Method

[image]
Intersoft WebDesktop Documentation
RegisterPreloadImage Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : RegisterPreloadImage Method

image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterPreloadImage( _
   ByVal image As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim image As String

instance.RegisterPreloadImage(image)
C#
public void RegisterPreloadImage(
   string image
)

Parameters

image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


RegisterSharePointHandler Method

[image]
Intersoft WebDesktop Documentation
RegisterSharePointHandler Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : RegisterSharePointHandler Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RegisterSharePointHandler()
Visual Basic (Usage) Copy Code
Dim instance As WebButton

instance.RegisterSharePointHandler()
C#
public virtual void RegisterSharePointHandler()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


RenderBeginTag Method

[image]
Intersoft WebDesktop Documentation
RenderBeginTag Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : RenderBeginTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderBeginTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderBeginTag(writer)
C#
public virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


RenderControl Method

[image]
Intersoft WebDesktop Documentation
RenderControl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : RenderControl Method

Glossary Item Box

Overload List

Overload | Description
RenderControl | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


RenderControl(HtmlTextWriter) Method

[image]
Intersoft WebDesktop Documentation
RenderControl(HtmlTextWriter) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : RenderControl(HtmlTextWriter) Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderControl( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderControl(writer)
C#
public virtual void RenderControl(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


RenderEndTag Method

[image]
Intersoft WebDesktop Documentation
RenderEndTag Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : RenderEndTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub RenderEndTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderEndTag(writer)
C#
public override void RenderEndTag(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebButton

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


ResolveClientUrl Method

[image]
Intersoft WebDesktop Documentation
ResolveClientUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : ResolveClientUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveClientUrl( _
   ByVal relativeUrl As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim relativeUrl As String
Dim value As String

value = instance.ResolveClientUrl(relativeUrl)
C#
public string ResolveClientUrl(
   string relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


ResolveImagePath Method

[image]
Intersoft WebDesktop Documentation
ResolveImagePath Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : ResolveImagePath Method

folder
image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveImagePath( _
   ByVal folder As String, _
   ByVal image As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim folder As String
Dim image As String
Dim value As String

value = instance.ResolveImagePath(folder, image)
C#
public string ResolveImagePath(
   string folder,
   string image
)

Parameters

folder
image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


ResolveRelativeURL Method

[image]
Intersoft WebDesktop Documentation
ResolveRelativeURL Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : ResolveRelativeURL Method

url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ResolveRelativeURL( _
   ByVal url As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim url As String
Dim value As String

value = instance.ResolveRelativeURL(url)
C#
public virtual string ResolveRelativeURL(
   string url
)

Parameters

url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


ResolveResourceUrl Method

[image]
Intersoft WebDesktop Documentation
ResolveResourceUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : ResolveResourceUrl Method

kind
defaultFolder
currentFolder
resourceName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveResourceUrl( _
   ByVal kind As ISNet.WebUI.ResourceKind, _
   ByVal defaultFolder As String, _
   ByVal currentFolder As String, _
   ByVal resourceName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim kind As ISNet.WebUI.ResourceKind
Dim defaultFolder As String
Dim currentFolder As String
Dim resourceName As String
Dim value As String

value = instance.ResolveResourceUrl(kind, defaultFolder, currentFolder, resourceName)
C#
public string ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   string defaultFolder,
   string currentFolder,
   string resourceName
)

Parameters

kind
defaultFolder
currentFolder
resourceName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


ResolveUrl Method

[image]
Intersoft WebDesktop Documentation
ResolveUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : ResolveUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveUrl( _
   ByVal relativeUrl As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim relativeUrl As String
Dim value As String

value = instance.ResolveUrl(relativeUrl)
C#
public string ResolveUrl(
   string relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


SaveLayout Method

[image]
Intersoft WebDesktop Documentation
SaveLayout Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : SaveLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim settings As ISNet.WebUI.LayoutInfo

instance.SaveLayout(settings)
C#
public virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


SaveLayoutToFile Method

[image]
Intersoft WebDesktop Documentation
SaveLayoutToFile Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : SaveLayoutToFile Method

filePath
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToFile( _
   ByVal filePath As String, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim filePath As String
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToFile(filePath, saveOptions)
C#
public virtual void SaveLayoutToFile(
   string filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

filePath
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


SaveLayoutToStream Method

[image]
Intersoft WebDesktop Documentation
SaveLayoutToStream Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : SaveLayoutToStream Method

stream
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToStream( _
   ByVal stream As System.IO.Stream, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim stream As System.IO.Stream
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToStream(stream, saveOptions)
C#
public virtual void SaveLayoutToStream(
   System.IO.Stream stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

stream
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


SetPushed Method

[image]
Intersoft WebDesktop Documentation
SetPushed Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : SetPushed Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetPushed()
Visual Basic (Usage) Copy Code
Dim instance As WebButton

instance.SetPushed()
C#
public void SetPushed()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


SetRenderMethodDelegate Method

[image]
Intersoft WebDesktop Documentation
SetRenderMethodDelegate Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : SetRenderMethodDelegate Method

renderMethod

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetRenderMethodDelegate( _
   ByVal renderMethod As System.Web.UI.RenderMethod _
)
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim renderMethod As System.Web.UI.RenderMethod

instance.SetRenderMethodDelegate(renderMethod)
C#
public void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod renderMethod
)

Parameters

renderMethod

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


SetSessionTheme Method

[image]
Intersoft WebDesktop Documentation
SetSessionTheme Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : SetSessionTheme Method

themeInfo

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetSessionTheme( _
   ByVal themeInfo As ISNet.WebUI.ThemeInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim themeInfo As ISNet.WebUI.ThemeInfo

instance.SetSessionTheme(themeInfo)
C#
public void SetSessionTheme(
   ISNet.WebUI.ThemeInfo themeInfo
)

Parameters

themeInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


ShouldReturnJson Method

[image]
Intersoft WebDesktop Documentation
ShouldReturnJson Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : ShouldReturnJson Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ShouldReturnJson() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As Boolean

value = instance.ShouldReturnJson()
C#
public virtual bool ShouldReturnJson()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


AccessKey Property

[image]
Intersoft WebDesktop Documentation
AccessKey Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : AccessKey Property

Glossary Item Box

Keyboard shortcut used by the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property AccessKey As String
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As String

instance.AccessKey = value

value = instance.AccessKey
C#
public virtual string AccessKey {get; set;}

Remarks

WebButton properly implements the WinForm-like Mnemonic key support. You can specify the key in AccessKey property to conform the standard of Web. During rendering, WebButton automatically adds underline at the position where the character specified in AccessKey is found. As the result, your end users can conveniently and quickly access to the command button from anywhere in the form by pressing Alt + AccessKey.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


WebButton Class Properties

[image]
Intersoft WebDesktop Documentation
WebButton Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebButton Class

Glossary Item Box

For a list of all members of this type, see WebButton members.

Public Properties

 | Name | Description
Public Property | AccessKey | Keyboard shortcut used by the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | AutoPostback | Specifies whether the button should perform postback automatically when clicked.
Public Property | BackColor | Overridden. Color of the background of the control.
Public Property | BorderColor | Overridden. Color of the border around the control.
Public Property | BorderStyle | Overridden. Style of the border around the control.
Public Property | BorderWidth | Overridden. Width of the border around the control.
Public Property | ButtonStyle | Contains interactive style for the Button.
Public Property | CausesValidation | Gets or sets a value indicating whether validation is performed when the WebButton control is clicked.
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | DisabledStyle | Gets or sets the disabled style for the Button.
Public Property | DisableOnClicked | Specifies whether the button should be disabled after clicked.
Public Property | DisplayMode | Gets or sets the caption display mode for the button.
Public Property | Enabled | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableManagedTheming | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | FlyPostBackSettings | Configures the settings used by the control when performing OnTheFly postback.
Public Property | Font | Overridden. The font used for text within the control.
Public Property | ForeColor | Overridden. Color of the text within the control.
Public Property | Height | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | Image | Gets or sets the image displayed in the button.
Public Property | ImagePosition | Gets or sets the image position relative to the text.
Public Property | InProgressImage |
Public Property | InProgressText |
Public Property | IntegratedToDesktopManager | Specifies whether the button should be integrated to Desktop Manager.
Public Property | IsToggleButton | Determinse whether the button is a toggle button.
Public Property | OnClientClick | Specifies the javascript function to invoke when the button is clicked.
Public Property | OnClientInitialize | Specifies the javascript function to invoke when the button is being initialized.
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Parameter | Gets or sets the parameter or data that will be passed to client side event when the button is clicked.
Public Property | PostBackMode | Gets or sets the postback mode when the button is clicked and AutoPostback is enabled.
Public Property | ProgressTextStyle |
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden. Gets or sets the directory where all required scripts for the control are stored.
Public Property | SharedScriptDirectory | Overridden.
Public Property | ShowProgressOnClicked |
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | The tab order of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Text | Gets or sets the text displayed in the button.
Public Property | ToolTip | The tooltip displayed when the mouse is over the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Type | Gets or sets the type of the button which will automatically perform built-in behavior accordingly.
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ValidationGroup | Gets or sets the group of controls for which the WebButton control causes validation when it posts back to the server.
Public Property | ViewStateItems | Gets or sets the items to be stored in view state storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | Gets or sets the server connection string for file server-based viewstate storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | Gets or sets the location to store the viewstate of this control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | Indicates whether the control is visible and rendered. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Width | The width of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | XmlCompressionEnabled | Specifies whether the Xml used for clientside state storage should be compressed. (Inherited from ISNet.WebUI.ISNetControl)
Top

See Also

Reference

WebButton Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Configuring Interactive Style of WebButton

tasks

Enabling Automatic Postback when Clicked
Executing server side codes in FlyPostBack mode
Using ClientAction engine during FlyPostBack execution.

Concepts

WebButton Features

concepts

WebButton Integrating to DesktopManager


WebButton Constructor

[image]
Intersoft WebDesktop Documentation
WebButton Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : WebButton Constructor

Glossary Item Box

Initializes a new instance of the WebButton class.

Overload List

Overload | Description
WebButton Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


AutoPostback Property

[image]
Intersoft WebDesktop Documentation
AutoPostback Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : AutoPostback Property

Glossary Item Box

Specifies whether the button should perform postback automatically when clicked.

Syntax

Visual Basic (Declaration)
Public Property AutoPostback As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As Boolean

instance.AutoPostback = value

value = instance.AutoPostback
C#
public bool AutoPostback {get; set;}

Remarks

WebButton can operate in client side or server side mode. The default is client side mode where AutoPostBack is set to False. When operates in client side mode, developers generally implement the OnClientClick client side event to execute the javascript codes to response the button click. Otherwise, when operates in server side mode, developers can write codes in OnClick server side event to response the button click. Optionally, developers can also handle both client and server side events for maximum interactivity. If the return value is False in client side event, the server post back will not be invoked further.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members

Tasks

Enabling Automatic Postback when Clicked
Executing server side codes in FlyPostBack mode

tasks

Using ClientAction engine during FlyPostBack execution.

Concepts

WebButton Features


BackColor Property

[image]
Intersoft WebDesktop Documentation
BackColor Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : BackColor Property

Glossary Item Box

Color of the background of the control.

Syntax

Visual Basic (Declaration)
Public Overrides Property BackColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
C#
public override System.Drawing.Color BackColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


BorderColor Property

[image]
Intersoft WebDesktop Documentation
BorderColor Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : BorderColor Property

Glossary Item Box

Color of the border around the control.

Syntax

Visual Basic (Declaration)
Public Overrides Property BorderColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As System.Drawing.Color

instance.BorderColor = value

value = instance.BorderColor
C#
public override System.Drawing.Color BorderColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


BorderStyle Property

[image]
Intersoft WebDesktop Documentation
BorderStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : BorderStyle Property

Glossary Item Box

Style of the border around the control.

Syntax

Visual Basic (Declaration)
Public Overrides Property BorderStyle As System.Web.UI.WebControls.BorderStyle
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As System.Web.UI.WebControls.BorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
C#
public override System.Web.UI.WebControls.BorderStyle BorderStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


BorderWidth Property

[image]
Intersoft WebDesktop Documentation
BorderWidth Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : BorderWidth Property

Glossary Item Box

Width of the border around the control.

Syntax

Visual Basic (Declaration)
Public Overrides Property BorderWidth As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As System.Web.UI.WebControls.Unit

instance.BorderWidth = value

value = instance.BorderWidth
C#
public override System.Web.UI.WebControls.Unit BorderWidth {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


ButtonStyle Property

[image]
Intersoft WebDesktop Documentation
ButtonStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : ButtonStyle Property

Glossary Item Box

Contains interactive style for the Button.

Syntax

Visual Basic (Declaration)
Public Property ButtonStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As ISNet.WebUI.DynamicStyle

instance.ButtonStyle = value

value = instance.ButtonStyle
C#
public ISNet.WebUI.DynamicStyle ButtonStyle {get; set;}

Remarks

One of the powerful features in WebButton is the DynamicStyle feature for the rich interaction styles of the WebButton. You can configure the interactive style in ButtonStyle property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members

Concepts

WebButton Features


CausesValidation Property

[image]
Intersoft WebDesktop Documentation
CausesValidation Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : CausesValidation Property

Glossary Item Box

Gets or sets a value indicating whether validation is performed when the WebButton control is clicked.

Syntax

Visual Basic (Declaration)
Public Property CausesValidation As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As Boolean

instance.CausesValidation = value

value = instance.CausesValidation
C#
public bool CausesValidation {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


ClientIDMode Property

[image]
Intersoft WebDesktop Documentation
ClientIDMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : ClientIDMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ClientIDMode As System.Web.UI.ClientIDMode
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As System.Web.UI.ClientIDMode

instance.ClientIDMode = value

value = instance.ClientIDMode
C#
public virtual System.Web.UI.ClientIDMode ClientIDMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


ControlDataTransferFormat Property

[image]
Intersoft WebDesktop Documentation
ControlDataTransferFormat Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : ControlDataTransferFormat Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ControlDataTransferFormat As ISNet.WebUI.DataTransferFormat
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As ISNet.WebUI.DataTransferFormat

instance.ControlDataTransferFormat = value

value = instance.ControlDataTransferFormat
C#
public virtual ISNet.WebUI.DataTransferFormat ControlDataTransferFormat {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


DisabledStyle Property

[image]
Intersoft WebDesktop Documentation
DisabledStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : DisabledStyle Property

Glossary Item Box

Gets or sets the disabled style for the Button.

Syntax

Visual Basic (Declaration)
Public Property DisabledStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As ISNet.WebUI.WebStyle

instance.DisabledStyle = value

value = instance.DisabledStyle
C#
public ISNet.WebUI.WebStyle DisabledStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


DisableOnClicked Property

[image]
Intersoft WebDesktop Documentation
DisableOnClicked Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : DisableOnClicked Property

Glossary Item Box

Specifies whether the button should be disabled after clicked.

Syntax

Visual Basic (Declaration)
Public Property DisableOnClicked As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As Boolean

instance.DisableOnClicked = value

value = instance.DisableOnClicked
C#
public bool DisableOnClicked {get; set;}

Remarks

This feature will automatically disable the Button when clicked to prevent users to press the Button twice accidentally which could cause duplicate postbacks and human error issues that affect the accuracy and stability of web application.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members

Concepts

WebButton Features


DisplayMode Property

[image]
Intersoft WebDesktop Documentation
DisplayMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : DisplayMode Property

Glossary Item Box

Gets or sets the caption display mode for the button.

Syntax

Visual Basic (Declaration)
Public Property DisplayMode As ButtonDisplayMode
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As ButtonDisplayMode

instance.DisplayMode = value

value = instance.DisplayMode
C#
public ButtonDisplayMode DisplayMode {get; set;}

Remarks

You can specify the DisplayMode of WebButton to use TextAndImage instead of only Text. Moreover, you can display rich command button by displaying your own Image at the left or right part relative to the Text. You can easily specify the image's position in the ImagePosition property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


Enabled Property

[image]
Intersoft WebDesktop Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : Enabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Enabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As Boolean

instance.Enabled = value

value = instance.Enabled
C#
public virtual bool Enabled {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


EnableManagedTheming Property

[image]
Intersoft WebDesktop Documentation
EnableManagedTheming Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : EnableManagedTheming Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property EnableManagedTheming As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As Boolean

instance.EnableManagedTheming = value

value = instance.EnableManagedTheming
C#
public virtual bool EnableManagedTheming {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


EnableTheming Property

[image]
Intersoft WebDesktop Documentation
EnableTheming Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : EnableTheming Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property EnableTheming As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As Boolean

instance.EnableTheming = value

value = instance.EnableTheming
C#
public virtual bool EnableTheming {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


EnableViewState Property

[image]
Intersoft WebDesktop Documentation
EnableViewState Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : EnableViewState Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property EnableViewState As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As Boolean

instance.EnableViewState = value

value = instance.EnableViewState
C#
public virtual bool EnableViewState {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


EnableWebResources Property

[image]
Intersoft WebDesktop Documentation
EnableWebResources Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : EnableWebResources Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property EnableWebResources As ISNet.WebUI.WebResourceType
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As ISNet.WebUI.WebResourceType

instance.EnableWebResources = value

value = instance.EnableWebResources
C#
public ISNet.WebUI.WebResourceType EnableWebResources {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


FlyPostBackSettings Property

[image]
Intersoft WebDesktop Documentation
FlyPostBackSettings Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : FlyPostBackSettings Property

Glossary Item Box

Configures the settings used by the control when performing OnTheFly postback.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FlyPostBackSettings As ISNet.WebUI.FlyPostBackSettings
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As ISNet.WebUI.FlyPostBackSettings

value = instance.FlyPostBackSettings
C#
public ISNet.WebUI.FlyPostBackSettings FlyPostBackSettings {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


Font Property

[image]
Intersoft WebDesktop Documentation
Font Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : Font Property

Glossary Item Box

The font used for text within the control.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Font As System.Web.UI.WebControls.FontInfo
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As System.Web.UI.WebControls.FontInfo

value = instance.Font
C#
public override System.Web.UI.WebControls.FontInfo Font {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


ForeColor Property

[image]
Intersoft WebDesktop Documentation
ForeColor Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : ForeColor Property

Glossary Item Box

Color of the text within the control.

Syntax

Visual Basic (Declaration)
Public Overrides Property ForeColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
C#
public override System.Drawing.Color ForeColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


Height Property

[image]
Intersoft WebDesktop Documentation
Height Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : Height Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Height As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As System.Web.UI.WebControls.Unit

instance.Height = value

value = instance.Height
C#
public virtual System.Web.UI.WebControls.Unit Height {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


ID Property

[image]
Intersoft WebDesktop Documentation
ID Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : ID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ID As String
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As String

instance.ID = value

value = instance.ID
C#
public virtual string ID {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


Image Property

[image]
Intersoft WebDesktop Documentation
Image Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : Image Property

Glossary Item Box

Gets or sets the image displayed in the button.

Syntax

Visual Basic (Declaration)
Public Property Image As String
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As String

instance.Image = value

value = instance.Image
C#
public string Image {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


ImagePosition Property

[image]
Intersoft WebDesktop Documentation
ImagePosition Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : ImagePosition Property

Glossary Item Box

Gets or sets the image position relative to the text.

Syntax

Visual Basic (Declaration)
Public Property ImagePosition As ImagePosition
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As ImagePosition

instance.ImagePosition = value

value = instance.ImagePosition
C#
public ImagePosition ImagePosition {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


InProgressImage Property

[image]
Intersoft WebDesktop Documentation
InProgressImage Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : InProgressImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property InProgressImage As String
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As String

instance.InProgressImage = value

value = instance.InProgressImage
C#
public string InProgressImage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


InProgressText Property

[image]
Intersoft WebDesktop Documentation
InProgressText Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : InProgressText Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property InProgressText As String
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As String

instance.InProgressText = value

value = instance.InProgressText
C#
public string InProgressText {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


IntegratedToDesktopManager Property

[image]
Intersoft WebDesktop Documentation
IntegratedToDesktopManager Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : IntegratedToDesktopManager Property

Glossary Item Box

Specifies whether the button should be integrated to Desktop Manager.

Syntax

Visual Basic (Declaration)
Public Property IntegratedToDesktopManager As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As Boolean

instance.IntegratedToDesktopManager = value

value = instance.IntegratedToDesktopManager
C#
public bool IntegratedToDesktopManager {get; set;}

Remarks

You can operate the WebButton in Integration mode. The integration to WebDesktopManager component enables the button to resemble the look and feel of CommandButtonStyle, CommandButtonDisabledStyle, CommandButtonBorderType and CommandButton's ComplexImages which specified in DesktopManager level. To enable the Integration mode, simply set this property to True.

When the WebButton is integrated, all the styles will be overridden with inherited styles from WebDesktopManager, with intention to ensure consistent look and feel of all Integrated WebButton.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members

Concepts

Integrating To DesktopManager


IsToggleButton Property

[image]
Intersoft WebDesktop Documentation
IsToggleButton Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : IsToggleButton Property

Glossary Item Box

Determinse whether the button is a toggle button.

Syntax

Visual Basic (Declaration)
Public Property IsToggleButton As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As Boolean

instance.IsToggleButton = value

value = instance.IsToggleButton
C#
public bool IsToggleButton {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


OnClientClick Property

[image]
Intersoft WebDesktop Documentation
OnClientClick Property
See Also Example Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : OnClientClick Property

Glossary Item Box

Specifies the javascript function to invoke when the button is clicked.

Syntax

Visual Basic (Declaration)
Public Property OnClientClick As String
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As String

instance.OnClientClick = value

value = instance.OnClientClick
C#
public string OnClientClick {get; set;}

Remarks

When operates in client side mode, developers generally implement the OnClientClick client side event to execute the javascript codes to response the button click. Otherwise, when operates in server side mode, developers can write codes in OnClick server side event to response the button click.

Example

The following example shows you how to use WebButton's client side event OnClientClick to invoke JavaScript Alert and show a WebDialogBox. You need to type 'onclick' in the OnClientClick property.
JScript Copy Code
<script language="javascript">
   function onClick()
   {
       if(!IS.moz)
           alert("WebButton OnClientClick Event");
       var dlg = ISGetObject("WebDialogBox1");
       dlg.ShowDialog();
    }
</script>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members

Concepts

WebButton Features


OnClientInitialize Property

[image]
Intersoft WebDesktop Documentation
OnClientInitialize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : OnClientInitialize Property

Glossary Item Box

Specifies the javascript function to invoke when the button is being initialized.

Syntax

Visual Basic (Declaration)
Public Property OnClientInitialize As String
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As String

instance.OnClientInitialize = value

value = instance.OnClientInitialize
C#
public string OnClientInitialize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


Page Property

[image]
Intersoft WebDesktop Documentation
Page Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : Page Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Page As System.Web.UI.Page
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As System.Web.UI.Page

instance.Page = value

value = instance.Page
C#
public virtual System.Web.UI.Page Page {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


Parameter Property

[image]
Intersoft WebDesktop Documentation
Parameter Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : Parameter Property

Glossary Item Box

Gets or sets the parameter or data that will be passed to client side event when the button is clicked.

Syntax

Visual Basic (Declaration)
Public Property Parameter As String
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As String

instance.Parameter = value

value = instance.Parameter
C#
public string Parameter {get; set;}

Remarks

This property can be set in both server side and client side to pass information during postbacks. For example, you may want to set some data or flag which need to be passed during postback. First, you need to set the Parameter property in client side. The information in Parameter property can then be accessible in OnClick server side event, exactly in the Parameter property of the event argument.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


PostBackMode Property

[image]
Intersoft WebDesktop Documentation
PostBackMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : PostBackMode Property

Glossary Item Box

Gets or sets the postback mode when the button is clicked and AutoPostback is enabled.

Syntax

Visual Basic (Declaration)
Public Property PostBackMode As PostbackMode
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As PostbackMode

instance.PostBackMode = value

value = instance.PostBackMode
C#
public PostbackMode PostBackMode {get; set;}

Remarks

WebButton is taking advantage of FlyPostBack and ClientAction architecture enabling the Button to execute server side codes in Button's OnClick event without full page refresh. Instead of FlyPostBack, WebButton also supports traditional page postback by setting it to FullPostBack value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members

Concepts

WebButton Features


ProgressTextStyle Property

[image]
Intersoft WebDesktop Documentation
ProgressTextStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : ProgressTextStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ProgressTextStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As ISNet.WebUI.WebStyle

instance.ProgressTextStyle = value

value = instance.ProgressTextStyle
C#
public ISNet.WebUI.WebStyle ProgressTextStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


RenderingMode Property

[image]
Intersoft WebDesktop Documentation
RenderingMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : RenderingMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property RenderingMode As ISNet.WebUI.RenderMode
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As ISNet.WebUI.RenderMode

instance.RenderingMode = value

value = instance.RenderingMode
C#
public virtual ISNet.WebUI.RenderMode RenderingMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


RuntimeLicenseKey Property

[image]
Intersoft WebDesktop Documentation
RuntimeLicenseKey Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : RuntimeLicenseKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property RuntimeLicenseKey As String
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As String

instance.RuntimeLicenseKey = value

value = instance.RuntimeLicenseKey
C#
public virtual string RuntimeLicenseKey {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


ScriptDirectory Property

[image]
Intersoft WebDesktop Documentation
ScriptDirectory Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : ScriptDirectory Property

Glossary Item Box

Gets or sets the directory where all required scripts for the control are stored.

Syntax

Visual Basic (Declaration)
Public Overrides Property ScriptDirectory As String
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As String

instance.ScriptDirectory = value

value = instance.ScriptDirectory
C#
public override string ScriptDirectory {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


SharedScriptDirectory Property

[image]
Intersoft WebDesktop Documentation
SharedScriptDirectory Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : SharedScriptDirectory Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Property SharedScriptDirectory As String
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As String

instance.SharedScriptDirectory = value

value = instance.SharedScriptDirectory
C#
public override string SharedScriptDirectory {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


ShowProgressOnClicked Property

[image]
Intersoft WebDesktop Documentation
ShowProgressOnClicked Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : ShowProgressOnClicked Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ShowProgressOnClicked As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As Boolean

instance.ShowProgressOnClicked = value

value = instance.ShowProgressOnClicked
C#
public bool ShowProgressOnClicked {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


SkinID Property

[image]
Intersoft WebDesktop Documentation
SkinID Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : SkinID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property SkinID As String
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As String

instance.SkinID = value

value = instance.SkinID
C#
public virtual string SkinID {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


TabIndex Property

[image]
Intersoft WebDesktop Documentation
TabIndex Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : TabIndex Property

Glossary Item Box

The tab order of the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property TabIndex As Short
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As Short

instance.TabIndex = value

value = instance.TabIndex
C#
public virtual short TabIndex {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


Text Property

[image]
Intersoft WebDesktop Documentation
Text Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : Text Property

Glossary Item Box

Gets or sets the text displayed in the button.

Syntax

Visual Basic (Declaration)
Public Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As String

instance.Text = value

value = instance.Text
C#
public string Text {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


ToolTip Property

[image]
Intersoft WebDesktop Documentation
ToolTip Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : ToolTip Property

Glossary Item Box

The tooltip displayed when the mouse is over the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property ToolTip As String
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As String

instance.ToolTip = value

value = instance.ToolTip
C#
public virtual string ToolTip {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


Type Property

[image]
Intersoft WebDesktop Documentation
Type Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : Type Property

Glossary Item Box

Gets or sets the type of the button which will automatically perform built-in behavior accordingly.

Syntax

Visual Basic (Declaration)
Public Property Type As DialogBoxButtonType
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As DialogBoxButtonType

instance.Type = value

value = instance.Type
C#
public DialogBoxButtonType Type {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


ValidateRequestMode Property

[image]
Intersoft WebDesktop Documentation
ValidateRequestMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : ValidateRequestMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ValidateRequestMode As System.Web.UI.ValidateRequestMode
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As System.Web.UI.ValidateRequestMode

instance.ValidateRequestMode = value

value = instance.ValidateRequestMode
C#
public virtual System.Web.UI.ValidateRequestMode ValidateRequestMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


ValidationGroup Property

[image]
Intersoft WebDesktop Documentation
ValidationGroup Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : ValidationGroup Property

Glossary Item Box

Gets or sets the group of controls for which the WebButton control causes validation when it posts back to the server.

Syntax

Visual Basic (Declaration)
Public Property ValidationGroup As String
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As String

instance.ValidationGroup = value

value = instance.ValidationGroup
C#
public string ValidationGroup {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


ViewStateItems Property

[image]
Intersoft WebDesktop Documentation
ViewStateItems Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : ViewStateItems Property

Glossary Item Box

Gets or sets the items to be stored in view state storage.

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateItems As ISNet.WebUI.ViewStateItem
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As ISNet.WebUI.ViewStateItem

instance.ViewStateItems = value

value = instance.ViewStateItems
C#
public virtual ISNet.WebUI.ViewStateItem ViewStateItems {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


ViewStateMode Property

[image]
Intersoft WebDesktop Documentation
ViewStateMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : ViewStateMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateMode As System.Web.UI.ViewStateMode
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As System.Web.UI.ViewStateMode

instance.ViewStateMode = value

value = instance.ViewStateMode
C#
public virtual System.Web.UI.ViewStateMode ViewStateMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


ViewStateServerConnection Property

[image]
Intersoft WebDesktop Documentation
ViewStateServerConnection Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : ViewStateServerConnection Property

Glossary Item Box

Gets or sets the server connection string for file server-based viewstate storage.

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateServerConnection As String
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As String

instance.ViewStateServerConnection = value

value = instance.ViewStateServerConnection
C#
public virtual string ViewStateServerConnection {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


ViewStateStorage Property

[image]
Intersoft WebDesktop Documentation
ViewStateStorage Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : ViewStateStorage Property

Glossary Item Box

Gets or sets the location to store the viewstate of this control.

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateStorage As ISNet.WebUI.StateCacheStorage
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As ISNet.WebUI.StateCacheStorage

instance.ViewStateStorage = value

value = instance.ViewStateStorage
C#
public virtual ISNet.WebUI.StateCacheStorage ViewStateStorage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


Visible Property

[image]
Intersoft WebDesktop Documentation
Visible Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : Visible Property

Glossary Item Box

Indicates whether the control is visible and rendered.

Syntax

Visual Basic (Declaration)
Public Overridable Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public virtual bool Visible {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


Width Property

[image]
Intersoft WebDesktop Documentation
Width Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : Width Property

Glossary Item Box

The width of the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property Width As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As System.Web.UI.WebControls.Unit

instance.Width = value

value = instance.Width
C#
public virtual System.Web.UI.WebControls.Unit Width {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


XmlCompressionEnabled Property

[image]
Intersoft WebDesktop Documentation
XmlCompressionEnabled Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : XmlCompressionEnabled Property

Glossary Item Box

Specifies whether the Xml used for clientside state storage should be compressed.

Syntax

Visual Basic (Declaration)
Public Overridable Property XmlCompressionEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim value As Boolean

instance.XmlCompressionEnabled = value

value = instance.XmlCompressionEnabled
C#
public virtual bool XmlCompressionEnabled {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


WebButton Class Events

[image]
Intersoft WebDesktop Documentation
WebButton Class Events
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebButton Class

Glossary Item Box

For a list of all members of this type, see WebButton members.

Public Events

 | Name | Description
Public Event | Clicked | Occurs when WebButton is clicked.
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebButton Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Configuring Interactive Style of WebButton

tasks

Enabling Automatic Postback when Clicked
Executing server side codes in FlyPostBack mode
Using ClientAction engine during FlyPostBack execution.

Concepts

WebButton Features

concepts

WebButton Integrating to DesktopManager


Clicked Event

[image]
Intersoft WebDesktop Documentation
Clicked Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : Clicked Event

Glossary Item Box

Occurs when WebButton is clicked.

Syntax

Visual Basic (Declaration)
Public Event Clicked As WebButtonClickedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim handler As WebButtonClickedEventHandler

AddHandler instance.Clicked, handler
C#
public event WebButtonClickedEventHandler Clicked

Event Data

The event handler receives an argument of type WebButtonClickedEventArgs containing data related to this event. The following WebButtonClickedEventArgs properties provide information specific to this event.

Property | Description
Parameter | Gets or sets the parameter in WebButton clicked event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


DataBinding Event

[image]
Intersoft WebDesktop Documentation
DataBinding Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : DataBinding Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event DataBinding As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim handler As EventHandler

AddHandler instance.DataBinding, handler
C#
public event EventHandler DataBinding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


Disposed Event

[image]
Intersoft WebDesktop Documentation
Disposed Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim handler As EventHandler

AddHandler instance.Disposed, handler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


Init Event

[image]
Intersoft WebDesktop Documentation
Init Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : Init Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Init As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim handler As EventHandler

AddHandler instance.Init, handler
C#
public event EventHandler Init

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


Load Event

[image]
Intersoft WebDesktop Documentation
Load Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : Load Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Load As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim handler As EventHandler

AddHandler instance.Load, handler
C#
public event EventHandler Load

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


PreInitialize Event

[image]
Intersoft WebDesktop Documentation
PreInitialize Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : PreInitialize Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event PreInitialize As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim handler As EventHandler

AddHandler instance.PreInitialize, handler
C#
public event EventHandler PreInitialize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


PreRender Event

[image]
Intersoft WebDesktop Documentation
PreRender Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : PreRender Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event PreRender As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim handler As EventHandler

AddHandler instance.PreRender, handler
C#
public event EventHandler PreRender

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


Unload Event

[image]
Intersoft WebDesktop Documentation
Unload Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButton Class : Unload Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Unload As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebButton
Dim handler As EventHandler

AddHandler instance.Unload, handler
C#
public event EventHandler Unload

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButton Class
WebButton Members


WebButtonClickedEventArgs Class

[image]
Intersoft WebDesktop Documentation
WebButtonClickedEventArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebButtonClickedEventArgs Class

Glossary Item Box

Provides data for WebButton clicked related event.

Object Model

WebButtonClickedEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class WebButtonClickedEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As WebButtonClickedEventArgs
C#
public class WebButtonClickedEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebDesktop.WebButtonClickedEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButtonClickedEventArgs Members
ISNet.WebUI.WebDesktop Namespace


WebButtonClickedEventArgs Class Members

[image]
Intersoft WebDesktop Documentation
WebButtonClickedEventArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebButtonClickedEventArgs Class

Glossary Item Box

The following tables list the members exposed by WebButtonClickedEventArgs.

Public Properties

 | Name | Description
Public Property | Parameter | Gets or sets the parameter in WebButton clicked event.
Top

See Also

Reference

WebButtonClickedEventArgs Class
ISNet.WebUI.WebDesktop Namespace


WebButtonClickedEventArgs Class Properties

[image]
Intersoft WebDesktop Documentation
WebButtonClickedEventArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebButtonClickedEventArgs Class

Glossary Item Box

For a list of all members of this type, see WebButtonClickedEventArgs members.

Public Properties

 | Name | Description
Public Property | Parameter | Gets or sets the parameter in WebButton clicked event.
Top

See Also

Reference

WebButtonClickedEventArgs Class
ISNet.WebUI.WebDesktop Namespace


Parameter Property

[image]
Intersoft WebDesktop Documentation
Parameter Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButtonClickedEventArgs Class : Parameter Property

Glossary Item Box

Gets or sets the parameter in WebButton clicked event.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parameter As Object
Visual Basic (Usage) Copy Code
Dim instance As WebButtonClickedEventArgs
Dim value As Object

value = instance.Parameter
C#
public object Parameter {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButtonClickedEventArgs Class
WebButtonClickedEventArgs Members


WebButtonFlyPostBackSettings Class

[image]
Intersoft WebDesktop Documentation
WebButtonFlyPostBackSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebButtonFlyPostBackSettings Class

Glossary Item Box

A collection of settings used by the control when performing OnTheFly postback.

Object Model

WebButtonFlyPostBackSettings Class

Syntax

Visual Basic (Declaration)
Public Class WebButtonFlyPostBackSettings
   Inherits ISNet.WebUI.FlyPostBackSettings
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebButtonFlyPostBackSettings
C#
public class WebButtonFlyPostBackSettings : ISNet.WebUI.FlyPostBackSettings, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.FlyPostBackSettings
ISNet.WebUI.WebDesktop.WebButtonFlyPostBackSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButtonFlyPostBackSettings Members
ISNet.WebUI.WebDesktop Namespace


WebButtonFlyPostBackSettings Class Members

[image]
Intersoft WebDesktop Documentation
WebButtonFlyPostBackSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebButtonFlyPostBackSettings Class

Glossary Item Box

The following tables list the members exposed by WebButtonFlyPostBackSettings.

Public Constructors

 | Name | Description
Public Constructor | WebButtonFlyPostBackSettings Constructor | Initializes a new instance of the WebButtonFlyPostBackSettings class.
Top

Public Properties

 | Name | Description
Public Property | PostControlState | Gets or sets a value indicating whether this control's state should be posted during OnTheFly postback. (Inherited from ISNet.WebUI.FlyPostBackSettings)
Public Property | PostHiddenFields | Overridden. Gets or sets whether hidden fields should be posted to server during OnTheFly postback.
Public Property | PostInputControls | Gets or sets whether HTML INPUT controls as well as SELECT and TEXT AREA should be posted to server during OnTheFly postback. (Inherited from ISNet.WebUI.FlyPostBackSettings)
Public Property | PostViewState | Overridden. Gets or set whether the __VIEWSTATE content should be posted to server during OnTheFly postback.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.FlyPostBackSettings)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebButtonFlyPostBackSettings Class
ISNet.WebUI.WebDesktop Namespace


WebButtonFlyPostBackSettings Class Methods

[image]
Intersoft WebDesktop Documentation
WebButtonFlyPostBackSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebButtonFlyPostBackSettings Class

Glossary Item Box

For a list of all members of this type, see WebButtonFlyPostBackSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.FlyPostBackSettings)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebButtonFlyPostBackSettings Class
ISNet.WebUI.WebDesktop Namespace


WebButtonFlyPostBackSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebButtonFlyPostBackSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButtonFlyPostBackSettings Class : WebButtonFlyPostBackSettings Constructor

Glossary Item Box

Initializes a new instance of the WebButtonFlyPostBackSettings class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebButtonFlyPostBackSettings()
C#
public WebButtonFlyPostBackSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButtonFlyPostBackSettings Class
WebButtonFlyPostBackSettings Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButtonFlyPostBackSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebButtonFlyPostBackSettings
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButtonFlyPostBackSettings Class
WebButtonFlyPostBackSettings Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButtonFlyPostBackSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButtonFlyPostBackSettings Class
WebButtonFlyPostBackSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButtonFlyPostBackSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebButtonFlyPostBackSettings
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButtonFlyPostBackSettings Class
WebButtonFlyPostBackSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButtonFlyPostBackSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebButtonFlyPostBackSettings
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButtonFlyPostBackSettings Class
WebButtonFlyPostBackSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButtonFlyPostBackSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebButtonFlyPostBackSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButtonFlyPostBackSettings Class
WebButtonFlyPostBackSettings Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButtonFlyPostBackSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebButtonFlyPostBackSettings
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButtonFlyPostBackSettings Class
WebButtonFlyPostBackSettings Members


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButtonFlyPostBackSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebButtonFlyPostBackSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButtonFlyPostBackSettings Class
WebButtonFlyPostBackSettings Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButtonFlyPostBackSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebButtonFlyPostBackSettings
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButtonFlyPostBackSettings Class
WebButtonFlyPostBackSettings Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButtonFlyPostBackSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebButtonFlyPostBackSettings

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButtonFlyPostBackSettings Class
WebButtonFlyPostBackSettings Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButtonFlyPostBackSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebButtonFlyPostBackSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButtonFlyPostBackSettings Class
WebButtonFlyPostBackSettings Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButtonFlyPostBackSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebButtonFlyPostBackSettings
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButtonFlyPostBackSettings Class
WebButtonFlyPostBackSettings Members


PostControlState Property

[image]
Intersoft WebDesktop Documentation
PostControlState Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButtonFlyPostBackSettings Class : PostControlState Property

Glossary Item Box

Gets or sets a value indicating whether this control's state should be posted during OnTheFly postback.

Syntax

Visual Basic (Declaration)
Public Overridable Property PostControlState As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebButtonFlyPostBackSettings
Dim value As Boolean

instance.PostControlState = value

value = instance.PostControlState
C#
public virtual bool PostControlState {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButtonFlyPostBackSettings Class
WebButtonFlyPostBackSettings Members


WebButtonFlyPostBackSettings Class Properties

[image]
Intersoft WebDesktop Documentation
WebButtonFlyPostBackSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebButtonFlyPostBackSettings Class

Glossary Item Box

For a list of all members of this type, see WebButtonFlyPostBackSettings members.

Public Properties

 | Name | Description
Public Property | PostControlState | Gets or sets a value indicating whether this control's state should be posted during OnTheFly postback. (Inherited from ISNet.WebUI.FlyPostBackSettings)
Public Property | PostHiddenFields | Overridden. Gets or sets whether hidden fields should be posted to server during OnTheFly postback.
Public Property | PostInputControls | Gets or sets whether HTML INPUT controls as well as SELECT and TEXT AREA should be posted to server during OnTheFly postback. (Inherited from ISNet.WebUI.FlyPostBackSettings)
Public Property | PostViewState | Overridden. Gets or set whether the __VIEWSTATE content should be posted to server during OnTheFly postback.
Top

See Also

Reference

WebButtonFlyPostBackSettings Class
ISNet.WebUI.WebDesktop Namespace


PostHiddenFields Property

[image]
Intersoft WebDesktop Documentation
PostHiddenFields Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButtonFlyPostBackSettings Class : PostHiddenFields Property

Glossary Item Box

Gets or sets whether hidden fields should be posted to server during OnTheFly postback.

Syntax

Visual Basic (Declaration)
Public Overrides Property PostHiddenFields As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebButtonFlyPostBackSettings
Dim value As Boolean

instance.PostHiddenFields = value

value = instance.PostHiddenFields
C#
public override bool PostHiddenFields {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButtonFlyPostBackSettings Class
WebButtonFlyPostBackSettings Members


PostInputControls Property

[image]
Intersoft WebDesktop Documentation
PostInputControls Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButtonFlyPostBackSettings Class : PostInputControls Property

Glossary Item Box

Gets or sets whether HTML INPUT controls as well as SELECT and TEXT AREA should be posted to server during OnTheFly postback.

Syntax

Visual Basic (Declaration)
Public Overridable Property PostInputControls As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebButtonFlyPostBackSettings
Dim value As Boolean

instance.PostInputControls = value

value = instance.PostInputControls
C#
public virtual bool PostInputControls {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButtonFlyPostBackSettings Class
WebButtonFlyPostBackSettings Members


PostViewState Property

[image]
Intersoft WebDesktop Documentation
PostViewState Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebButtonFlyPostBackSettings Class : PostViewState Property

Glossary Item Box

Gets or set whether the __VIEWSTATE content should be posted to server during OnTheFly postback.

Syntax

Visual Basic (Declaration)
Public Overrides Property PostViewState As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebButtonFlyPostBackSettings
Dim value As Boolean

instance.PostViewState = value

value = instance.PostViewState
C#
public override bool PostViewState {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButtonFlyPostBackSettings Class
WebButtonFlyPostBackSettings Members


WebCallOut Class

[image]
Intersoft WebDesktop Documentation
WebCallOut Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebCallOut Class

Glossary Item Box

WebCallOut is an ASP.NET server control enabling you to create tooltip or callout that suits your style.

Object Model

WebCallOut Class

Syntax

Visual Basic (Declaration)
Public Class WebCallOut
   Inherits ISNet.WebUI.ISNetControl
   Implements ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
C#
public class WebCallOut : ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings

Remarks

WebCallOut includes most wanted and first of its kind features such as:

  • Automatically adjust the tooltip and pointing position base on the target control ID.
  • AutoDetect position base on target control ID.
  • Interactive moving.
  • Customizable pointing position.
  • Fully customizable layout elements.
  • Customizable title icon.
  • Animation effects.
  • Support ComplexImages.
  • Support ContentTemplate.
  • Comprehensive client side API for construction and manipulation.

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
ISNet.WebUI.ISNetControl
ISNet.WebUI.WebDesktop.WebCallOut

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Members
ISNet.WebUI.WebDesktop Namespace

Concepts

WebCallOut Concepts
WebCallOut Features


WebCallOut Class Members

[image]
Intersoft WebDesktop Documentation
WebCallOut Class Members
See Also Properties Methods Events Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebCallOut Class

Glossary Item Box

The following tables list the members exposed by WebCallOut.

Public Constructors

 | Name | Description
Public Constructor | WebCallOut Constructor |
Top

Public Properties

 | Name | Description
Public Property | AccessKey | Keyboard shortcut used by the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | BackColor | Overridden. Color of the background of the control.
Public Property | BorderColor | Overridden. Border color of the controls applied with this style.
Public Property | BorderStyle | Overridden. Style of the border around the control.
Public Property | BorderWidth | Overridden. Width of the border around the control.
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ClientSideEvents | Contains Javascript ClientSide events.
Public Property | CloseBehavior | Specifies the close behavior of WebCallOut.
Public Property | ContainerStyle | Sets the style applied to WebCallOut's container.
Public Property | ContentMode | Gets or sets the content mode of the WebCallOut control.
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | DisplayCloseIcon | Specifies whether WebCallOut's close icon image is displayed.
Public Property | DisplayLatency | Specifies how long WebCallOut will be displayed (in milliseconds).
Public Property | DisplayTitleIcon | Specifies whether WebCallOut's title icon image is displayed.
Public Property | DisplayTitleText | Specifies whether WebCallOut's title text is displayed.
Public Property | Enabled | Enabled state of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableInteractiveMoving | Specifies whether WebCallOut follows mouse cursor inside TargetControlId.
Public Property | EnableManagedTheming | Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | Specifies whether the control automatically saves its state for use in round-trips. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). (Inherited from ISNet.WebUI.ISNetControl)
Public Property | FlyPostBackSettings |
Public Property | ForeColor | Overridden. Color of the text within the control.
Public Property | FrameStyle | Gets or sets the style applied to Frame.
Public Property | GroupName |
Public Property | Height | The height of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from System.Web.UI.Control)
Public Property | ImagesDirectory | Gets or sets the images directory used by ImagesSettings.
Public Property | ImagesSettings | Contains images settings.
Public Property | Latency | Specifies how long WebCallOut will be closed automatically (in seconds). This property will be used if CloseBehavior is set to Latency.
Public Property | LayoutMode | Specifies the layout mode of WebCallOut.
Public Property | LeftPointerIndentation |
Public Property | OffsetBottomPointingPosition | Specifies the bottom pointing position offset of WebCallOut.
Public Property | OffsetTopPointingPosition | Specifies the top pointing position offset of WebCallOut.
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | PointingPosition | Specifies the pointing position of WebCallOut.
Public Property | PreferredHorizontalPosition | Specifies the preferred horizontal position of WebCallOut.
Public Property | PreferredVerticalPosition | Specifies the preferred vertical position of WebCallOut.
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RightPointerIndentation |
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden. Gets or sets the directory where all required scripts for the control are stored.
Public Property | SharedScriptDirectory | Overridden. Gets or sets the directory where all shared scripts for Intersoft controls are stored.
Public Property | ShowBehavior | Specifies the show behavior of WebCallOut.
Public Property | SkinID | The SkinId of the control skin that provides the skin of the control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | TargetControlId | Specifies the target ControlId of WebCallOut.
Public Property | Text | Specifies the text of WebCallOut. This property will be used if ContentMode is set to UseText.
Public Property | Title | Specifies the title of WebCallOut.
Public Property | TitleStyle | Sets the style applied to WebCallOut's title.
Public Property | UseAdvancedCalculation |
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateItems | Gets or sets the items to be stored in view state storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | Gets or sets the server connection string for file server-based viewstate storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | Gets or sets the location to store the viewstate of this control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | Indicates whether the control is visible and rendered. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | VisibleBasedOnTargetControlId |
Public Property | Width | The width of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | XmlCompressionEnabled | Specifies whether the Xml used for clientside state storage should be compressed. (Inherited from ISNet.WebUI.ISNetControl)
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
static (Shared in Visual Basic) | EnsureWebCallOutScripts |
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetClientAction |
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPostData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RecreateChildControls |
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Show |
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebCallOut Class
ISNet.WebUI.WebDesktop Namespace

Concepts

WebCallOut Concepts
WebCallOut Features


WebCallOut Constructor

[image]
Intersoft WebDesktop Documentation
WebCallOut Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : WebCallOut Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebCallOut()
C#
public WebCallOut()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


ApplyStyle Method

[image]
Intersoft WebDesktop Documentation
ApplyStyle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : ApplyStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ApplyStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim s As System.Web.UI.WebControls.Style

instance.ApplyStyle(s)
C#
public void ApplyStyle(
   System.Web.UI.WebControls.Style s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


ApplyStyleSheetSkin Method

[image]
Intersoft WebDesktop Documentation
ApplyStyleSheetSkin Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : ApplyStyleSheetSkin Method

page

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub ApplyStyleSheetSkin( _
   ByVal page As System.Web.UI.Page _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim page As System.Web.UI.Page

instance.ApplyStyleSheetSkin(page)
C#
public virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page page
)

Parameters

page

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


CanUseWebResources Method

[image]
Intersoft WebDesktop Documentation
CanUseWebResources Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : CanUseWebResources Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CanUseWebResources() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As Boolean

value = instance.CanUseWebResources()
C#
public bool CanUseWebResources()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


CopyBaseAttributes Method

[image]
Intersoft WebDesktop Documentation
CopyBaseAttributes Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : CopyBaseAttributes Method

controlSrc

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyBaseAttributes( _
   ByVal controlSrc As System.Web.UI.WebControls.WebControl _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim controlSrc As System.Web.UI.WebControls.WebControl

instance.CopyBaseAttributes(controlSrc)
C#
public void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl controlSrc
)

Parameters

controlSrc

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.ISNetControl)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members
Overload List


DataBind Method

[image]
Intersoft WebDesktop Documentation
DataBind Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : DataBind Method

Glossary Item Box

Overload List

Overload | Description
DataBind | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


DataBind() Method

[image]
Intersoft WebDesktop Documentation
DataBind() Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : DataBind() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub DataBind()
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut

instance.DataBind()
C#
public virtual void DataBind()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


Dispose Method

[image]
Intersoft WebDesktop Documentation
Dispose Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : Dispose Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut

instance.Dispose()
C#
public virtual void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


WebCallOut Class Methods

[image]
Intersoft WebDesktop Documentation
WebCallOut Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebCallOut Class

Glossary Item Box

For a list of all members of this type, see WebCallOut members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
static (Shared in Visual Basic) | EnsureWebCallOutScripts |
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetClientAction |
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPostData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RecreateChildControls |
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Top

See Also

Reference

WebCallOut Class
ISNet.WebUI.WebDesktop Namespace

Concepts

WebCallOut Concepts
WebCallOut Features


EnsureWebCallOutScripts Method

[image]
Intersoft WebDesktop Documentation
EnsureWebCallOutScripts Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : EnsureWebCallOutScripts Method

page

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Sub EnsureWebCallOutScripts( _
   ByVal page As System.Web.UI.Page _
)
Visual Basic (Usage) Copy Code
Dim page As System.Web.UI.Page

WebCallOut.EnsureWebCallOutScripts(page)
C#
public static void EnsureWebCallOutScripts(
   System.Web.UI.Page page
)

Parameters

page

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


FindControl Method

[image]
Intersoft WebDesktop Documentation
FindControl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : FindControl Method

Glossary Item Box

Overload List

Overload | Description
FindControl | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


FindControl(String) Method

[image]
Intersoft WebDesktop Documentation
FindControl(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : FindControl(String) Method

id

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function FindControl( _
   ByVal id As String _
) As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim id As String
Dim value As System.Web.UI.Control

value = instance.FindControl(id)
C#
public virtual System.Web.UI.Control FindControl(
   string id
)

Parameters

id

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


Focus Method

[image]
Intersoft WebDesktop Documentation
Focus Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : Focus Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Focus()
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut

instance.Focus()
C#
public virtual void Focus()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


ForceDisableXmlCompression Method

[image]
Intersoft WebDesktop Documentation
ForceDisableXmlCompression Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : ForceDisableXmlCompression Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ForceDisableXmlCompression()
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut

instance.ForceDisableXmlCompression()
C#
public void ForceDisableXmlCompression()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


GetClientAction Method

[image]
Intersoft WebDesktop Documentation
GetClientAction Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : GetClientAction Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetClientAction() As ISNet.WebUI.BaseClientSideAction
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As ISNet.WebUI.BaseClientSideAction

value = instance.GetClientAction()
C#
public ISNet.WebUI.BaseClientSideAction GetClientAction()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


GetCurrentControlLifeCycle Method

[image]
Intersoft WebDesktop Documentation
GetCurrentControlLifeCycle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : GetCurrentControlLifeCycle Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentControlLifeCycle() As ISNet.WebUI.ControlLifeCycle
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As ISNet.WebUI.ControlLifeCycle

value = instance.GetCurrentControlLifeCycle()
C#
public ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


GetCurrentTheme Method

[image]
Intersoft WebDesktop Documentation
GetCurrentTheme Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : GetCurrentTheme Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentTheme() As ISNet.WebUI.ThemeInfo
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As ISNet.WebUI.ThemeInfo

value = instance.GetCurrentTheme()
C#
public ISNet.WebUI.ThemeInfo GetCurrentTheme()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


GetFrameworkDataFolder Method

[image]
Intersoft WebDesktop Documentation
GetFrameworkDataFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : GetFrameworkDataFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkDataFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As String

value = instance.GetFrameworkDataFolder()
C#
public string GetFrameworkDataFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


GetFrameworkFolder Method

[image]
Intersoft WebDesktop Documentation
GetFrameworkFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : GetFrameworkFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As String

value = instance.GetFrameworkFolder()
C#
public string GetFrameworkFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


GetFrameworkVersion Method

[image]
Intersoft WebDesktop Documentation
GetFrameworkVersion Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : GetFrameworkVersion Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkVersion() As Version
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As Version

value = instance.GetFrameworkVersion()
C#
public Version GetFrameworkVersion()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


GetIntersoftFolder Method

[image]
Intersoft WebDesktop Documentation
GetIntersoftFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : GetIntersoftFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetIntersoftFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As String

value = instance.GetIntersoftFolder()
C#
public string GetIntersoftFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


GetLayoutFolder Method

[image]
Intersoft WebDesktop Documentation
GetLayoutFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : GetLayoutFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetLayoutFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As String

value = instance.GetLayoutFolder()
C#
public string GetLayoutFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


GetPostedXMLData Method

[image]
Intersoft WebDesktop Documentation
GetPostedXMLData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : GetPostedXMLData Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPostedXMLData() As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As String

value = instance.GetPostedXMLData()
C#
public string GetPostedXMLData()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


GetProductInfoKey Method

[image]
Intersoft WebDesktop Documentation
GetProductInfoKey Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : GetProductInfoKey Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductInfoKey() As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As String

value = instance.GetProductInfoKey()
C#
public string GetProductInfoKey()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


GetProductSimpleName Method

[image]
Intersoft WebDesktop Documentation
GetProductSimpleName Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : GetProductSimpleName Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductSimpleName() As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As String

value = instance.GetProductSimpleName()
C#
public string GetProductSimpleName()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


GetPropertyValue Method

[image]
Intersoft WebDesktop Documentation
GetPropertyValue Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : GetPropertyValue Method

defValue
propValue
webConfigKey

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPropertyValue( _
   ByVal defValue As String, _
   ByVal propValue As String, _
   ByVal webConfigKey As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim defValue As String
Dim propValue As String
Dim webConfigKey As String
Dim value As String

value = instance.GetPropertyValue(defValue, propValue, webConfigKey)
C#
public string GetPropertyValue(
   string defValue,
   string propValue,
   string webConfigKey
)

Parameters

defValue
propValue
webConfigKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


GetResourceStream Method

[image]
Intersoft WebDesktop Documentation
GetResourceStream Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : GetResourceStream Method

resourceUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetResourceStream( _
   ByVal resourceUrl As String _
) As System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim resourceUrl As String
Dim value As System.IO.Stream

value = instance.GetResourceStream(resourceUrl)
C#
public System.IO.Stream GetResourceStream(
   string resourceUrl
)

Parameters

resourceUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


GetRouteUrl Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : GetRouteUrl Method

Glossary Item Box

Overload List

Overload | Description
GetRouteUrl(Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(RouteValueDictionary) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,RouteValueDictionary) | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


GetRouteUrl(Object) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class > GetRouteUrl Method : GetRouteUrl(Object) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As Object _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim routeParameters As Object
Dim value As String

value = instance.GetRouteUrl(routeParameters)
C#
public string GetRouteUrl(
   object routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members
Overload List


GetRouteUrl(String,Object) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(String,Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class > GetRouteUrl Method : GetRouteUrl(String,Object) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As String, _
   ByVal routeParameters As Object _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim routeName As String
Dim routeParameters As Object
Dim value As String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public string GetRouteUrl(
   string routeName,
   object routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members
Overload List


GetRouteUrl(RouteValueDictionary) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(RouteValueDictionary) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class > GetRouteUrl Method : GetRouteUrl(RouteValueDictionary) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As String

value = instance.GetRouteUrl(routeParameters)
C#
public string GetRouteUrl(
   System.Web.Routing.RouteValueDictionary routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members
Overload List


GetRouteUrl(String,RouteValueDictionary) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(String,RouteValueDictionary) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class > GetRouteUrl Method : GetRouteUrl(String,RouteValueDictionary) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As String, _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim routeName As String
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public string GetRouteUrl(
   string routeName,
   System.Web.Routing.RouteValueDictionary routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members
Overload List


GetUniqueIDRelativeTo Method

[image]
Intersoft WebDesktop Documentation
GetUniqueIDRelativeTo Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : GetUniqueIDRelativeTo Method

control

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetUniqueIDRelativeTo( _
   ByVal control As System.Web.UI.Control _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim control As System.Web.UI.Control
Dim value As String

value = instance.GetUniqueIDRelativeTo(control)
C#
public string GetUniqueIDRelativeTo(
   System.Web.UI.Control control
)

Parameters

control

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


HasControls Method

[image]
Intersoft WebDesktop Documentation
HasControls Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : HasControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function HasControls() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As Boolean

value = instance.HasControls()
C#
public virtual bool HasControls()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


IsAtlasCallback Method

[image]
Intersoft WebDesktop Documentation
IsAtlasCallback Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : IsAtlasCallback Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsAtlasCallback() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As Boolean

value = instance.IsAtlasCallback()
C#
public bool IsAtlasCallback()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


IsBetaRelease Method

[image]
Intersoft WebDesktop Documentation
IsBetaRelease Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : IsBetaRelease Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsBetaRelease() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As Boolean

value = instance.IsBetaRelease()
C#
public bool IsBetaRelease()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


IsChromeBrowser Method

[image]
Intersoft WebDesktop Documentation
IsChromeBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : IsChromeBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsChromeBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As Boolean

value = instance.IsChromeBrowser()
C#
public bool IsChromeBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


IsFlyPostBackControl Method

[image]
Intersoft WebDesktop Documentation
IsFlyPostBackControl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : IsFlyPostBackControl Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackControl() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As Boolean

value = instance.IsFlyPostBackControl()
C#
public virtual bool IsFlyPostBackControl()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


IsFlyPostBackRequest Method

[image]
Intersoft WebDesktop Documentation
IsFlyPostBackRequest Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : IsFlyPostBackRequest Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackRequest() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As Boolean

value = instance.IsFlyPostBackRequest()
C#
public virtual bool IsFlyPostBackRequest()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


IsGeckoBasedBrowser Method

[image]
Intersoft WebDesktop Documentation
IsGeckoBasedBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : IsGeckoBasedBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoBasedBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As Boolean

value = instance.IsGeckoBasedBrowser()
C#
public bool IsGeckoBasedBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


IsGeckoVersion18 Method

[image]
Intersoft WebDesktop Documentation
IsGeckoVersion18 Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : IsGeckoVersion18 Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoVersion18() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As Boolean

value = instance.IsGeckoVersion18()
C#
public bool IsGeckoVersion18()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


IsInDesignMode Method

[image]
Intersoft WebDesktop Documentation
IsInDesignMode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : IsInDesignMode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInDesignMode() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As Boolean

value = instance.IsInDesignMode()
C#
public bool IsInDesignMode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


IsInternetExplorer8Browser Method

[image]
Intersoft WebDesktop Documentation
IsInternetExplorer8Browser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : IsInternetExplorer8Browser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorer8Browser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As Boolean

value = instance.IsInternetExplorer8Browser()
C#
public bool IsInternetExplorer8Browser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


IsInternetExplorerBrowser Method

[image]
Intersoft WebDesktop Documentation
IsInternetExplorerBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : IsInternetExplorerBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorerBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As Boolean

value = instance.IsInternetExplorerBrowser()
C#
public bool IsInternetExplorerBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


IsOperaBrowser Method

[image]
Intersoft WebDesktop Documentation
IsOperaBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : IsOperaBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsOperaBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As Boolean

value = instance.IsOperaBrowser()
C#
public bool IsOperaBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


IsSafariBrowser Method

[image]
Intersoft WebDesktop Documentation
IsSafariBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : IsSafariBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsSafariBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As Boolean

value = instance.IsSafariBrowser()
C#
public bool IsSafariBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


IsW3CStandardBrowser Method

[image]
Intersoft WebDesktop Documentation
IsW3CStandardBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : IsW3CStandardBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsW3CStandardBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As Boolean

value = instance.IsW3CStandardBrowser()
C#
public bool IsW3CStandardBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


LoadLayout Method

[image]
Intersoft WebDesktop Documentation
LoadLayout Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : LoadLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim settings As ISNet.WebUI.LayoutInfo

instance.LoadLayout(settings)
C#
public virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


LoadLayoutFromFile Method

[image]
Intersoft WebDesktop Documentation
LoadLayoutFromFile Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : LoadLayoutFromFile Method

filePath

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromFile( _
   ByVal filePath As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim filePath As String

instance.LoadLayoutFromFile(filePath)
C#
public virtual void LoadLayoutFromFile(
   string filePath
)

Parameters

filePath

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


LoadLayoutFromPredefinedName Method

[image]
Intersoft WebDesktop Documentation
LoadLayoutFromPredefinedName Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : LoadLayoutFromPredefinedName Method

predefinedName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromPredefinedName( _
   ByVal predefinedName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim predefinedName As String

instance.LoadLayoutFromPredefinedName(predefinedName)
C#
public virtual void LoadLayoutFromPredefinedName(
   string predefinedName
)

Parameters

predefinedName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


LoadLayoutFromStream Method

[image]
Intersoft WebDesktop Documentation
LoadLayoutFromStream Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : LoadLayoutFromStream Method

stream

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromStream( _
   ByVal stream As System.IO.Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim stream As System.IO.Stream

instance.LoadLayoutFromStream(stream)
C#
public virtual void LoadLayoutFromStream(
   System.IO.Stream stream
)

Parameters

stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


LoadPostData Method

[image]
Intersoft WebDesktop Documentation
LoadPostData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : LoadPostData Method

postDataKey
postCollection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function LoadPostData( _
   ByVal postDataKey As String, _
   ByVal postCollection As System.Collections.Specialized.NameValueCollection _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim postDataKey As String
Dim postCollection As System.Collections.Specialized.NameValueCollection
Dim value As Boolean

value = instance.LoadPostData(postDataKey, postCollection)
C#
public virtual bool LoadPostData(
   string postDataKey,
   System.Collections.Specialized.NameValueCollection postCollection
)

Parameters

postDataKey
postCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


MergeStyle Method

[image]
Intersoft WebDesktop Documentation
MergeStyle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : MergeStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub MergeStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim s As System.Web.UI.WebControls.Style

instance.MergeStyle(s)
C#
public void MergeStyle(
   System.Web.UI.WebControls.Style s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


OnInfoChanged Method

[image]
Intersoft WebDesktop Documentation
OnInfoChanged Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : OnInfoChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnInfoChanged( _
   ByVal e As ISNet.WebUI.SynchronizeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim e As ISNet.WebUI.SynchronizeEventArgs

instance.OnInfoChanged(e)
C#
public void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


OnPreInitialize Method

[image]
Intersoft WebDesktop Documentation
OnPreInitialize Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : OnPreInitialize Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnPreInitialize()
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut

instance.OnPreInitialize()
C#
public virtual void OnPreInitialize()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


RaisePostDataChangedEvent Method

[image]
Intersoft WebDesktop Documentation
RaisePostDataChangedEvent Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : RaisePostDataChangedEvent Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RaisePostDataChangedEvent()
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut

instance.RaisePostDataChangedEvent()
C#
public virtual void RaisePostDataChangedEvent()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


ReadWebConfigValue Method

[image]
Intersoft WebDesktop Documentation
ReadWebConfigValue Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : ReadWebConfigValue Method

key

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ReadWebConfigValue( _
   ByVal key As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim key As String
Dim value As String

value = instance.ReadWebConfigValue(key)
C#
public string ReadWebConfigValue(
   string key
)

Parameters

key

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


RecreateChildControls Method

[image]
Intersoft WebDesktop Documentation
RecreateChildControls Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : RecreateChildControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RecreateChildControls()
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut

instance.RecreateChildControls()
C#
public void RecreateChildControls()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


RegisterBoxSizing Method

[image]
Intersoft WebDesktop Documentation
RegisterBoxSizing Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : RegisterBoxSizing Method

Glossary Item Box

Overload List

Overload | Description
RegisterBoxSizing() | (Inherited from ISNet.WebUI.ISNetControl)
RegisterBoxSizing(Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


RegisterBoxSizing() Method

[image]
Intersoft WebDesktop Documentation
RegisterBoxSizing() Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class > RegisterBoxSizing Method : RegisterBoxSizing() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing()
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut

instance.RegisterBoxSizing()
C#
public void RegisterBoxSizing()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members
Overload List


RegisterBoxSizing(Boolean) Method

[image]
Intersoft WebDesktop Documentation
RegisterBoxSizing(Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class > RegisterBoxSizing Method : RegisterBoxSizing(Boolean) Method

forceAll

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing( _
   ByVal forceAll As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim forceAll As Boolean

instance.RegisterBoxSizing(forceAll)
C#
public void RegisterBoxSizing(
   bool forceAll
)

Parameters

forceAll

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members
Overload List


RegisterGlobalStyle Method

[image]
Intersoft WebDesktop Documentation
RegisterGlobalStyle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : RegisterGlobalStyle Method

style

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterGlobalStyle( _
   ByVal style As ISNet.WebUI.WebStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim style As ISNet.WebUI.WebStyle

instance.RegisterGlobalStyle(style)
C#
public void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle style
)

Parameters

style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


RegisterLink Method

[image]
Intersoft WebDesktop Documentation
RegisterLink Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : RegisterLink Method

name
url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterLink( _
   ByVal name As String, _
   ByVal url As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim name As String
Dim url As String

instance.RegisterLink(name, url)
C#
public void RegisterLink(
   string name,
   string url
)

Parameters

name
url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


RegisterOptimizedCssClasses Method

[image]
Intersoft WebDesktop Documentation
RegisterOptimizedCssClasses Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : RegisterOptimizedCssClasses Method

runtimeStyleOnly

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterOptimizedCssClasses( _
   ByVal runtimeStyleOnly As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim runtimeStyleOnly As Boolean

instance.RegisterOptimizedCssClasses(runtimeStyleOnly)
C#
public void RegisterOptimizedCssClasses(
   bool runtimeStyleOnly
)

Parameters

runtimeStyleOnly

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


RegisterPreloadImage Method

[image]
Intersoft WebDesktop Documentation
RegisterPreloadImage Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : RegisterPreloadImage Method

image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterPreloadImage( _
   ByVal image As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim image As String

instance.RegisterPreloadImage(image)
C#
public void RegisterPreloadImage(
   string image
)

Parameters

image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


RegisterSharePointHandler Method

[image]
Intersoft WebDesktop Documentation
RegisterSharePointHandler Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : RegisterSharePointHandler Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RegisterSharePointHandler()
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut

instance.RegisterSharePointHandler()
C#
public virtual void RegisterSharePointHandler()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


RenderBeginTag Method

[image]
Intersoft WebDesktop Documentation
RenderBeginTag Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : RenderBeginTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderBeginTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderBeginTag(writer)
C#
public virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


RenderControl Method

[image]
Intersoft WebDesktop Documentation
RenderControl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : RenderControl Method

Glossary Item Box

Overload List

Overload | Description
RenderControl | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


RenderControl(HtmlTextWriter) Method

[image]
Intersoft WebDesktop Documentation
RenderControl(HtmlTextWriter) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : RenderControl(HtmlTextWriter) Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderControl( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderControl(writer)
C#
public virtual void RenderControl(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


RenderEndTag Method

[image]
Intersoft WebDesktop Documentation
RenderEndTag Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : RenderEndTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub RenderEndTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderEndTag(writer)
C#
public override void RenderEndTag(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


ResolveClientUrl Method

[image]
Intersoft WebDesktop Documentation
ResolveClientUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : ResolveClientUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveClientUrl( _
   ByVal relativeUrl As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim relativeUrl As String
Dim value As String

value = instance.ResolveClientUrl(relativeUrl)
C#
public string ResolveClientUrl(
   string relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


ResolveImagePath Method

[image]
Intersoft WebDesktop Documentation
ResolveImagePath Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : ResolveImagePath Method

folder
image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveImagePath( _
   ByVal folder As String, _
   ByVal image As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim folder As String
Dim image As String
Dim value As String

value = instance.ResolveImagePath(folder, image)
C#
public string ResolveImagePath(
   string folder,
   string image
)

Parameters

folder
image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


ResolveRelativeURL Method

[image]
Intersoft WebDesktop Documentation
ResolveRelativeURL Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : ResolveRelativeURL Method

url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ResolveRelativeURL( _
   ByVal url As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim url As String
Dim value As String

value = instance.ResolveRelativeURL(url)
C#
public virtual string ResolveRelativeURL(
   string url
)

Parameters

url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


ResolveResourceUrl Method

[image]
Intersoft WebDesktop Documentation
ResolveResourceUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : ResolveResourceUrl Method

kind
defaultFolder
currentFolder
resourceName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveResourceUrl( _
   ByVal kind As ISNet.WebUI.ResourceKind, _
   ByVal defaultFolder As String, _
   ByVal currentFolder As String, _
   ByVal resourceName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim kind As ISNet.WebUI.ResourceKind
Dim defaultFolder As String
Dim currentFolder As String
Dim resourceName As String
Dim value As String

value = instance.ResolveResourceUrl(kind, defaultFolder, currentFolder, resourceName)
C#
public string ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   string defaultFolder,
   string currentFolder,
   string resourceName
)

Parameters

kind
defaultFolder
currentFolder
resourceName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


ResolveUrl Method

[image]
Intersoft WebDesktop Documentation
ResolveUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : ResolveUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveUrl( _
   ByVal relativeUrl As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim relativeUrl As String
Dim value As String

value = instance.ResolveUrl(relativeUrl)
C#
public string ResolveUrl(
   string relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


SaveLayout Method

[image]
Intersoft WebDesktop Documentation
SaveLayout Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : SaveLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim settings As ISNet.WebUI.LayoutInfo

instance.SaveLayout(settings)
C#
public virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


SaveLayoutToFile Method

[image]
Intersoft WebDesktop Documentation
SaveLayoutToFile Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : SaveLayoutToFile Method

filePath
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToFile( _
   ByVal filePath As String, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim filePath As String
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToFile(filePath, saveOptions)
C#
public virtual void SaveLayoutToFile(
   string filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

filePath
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


SaveLayoutToStream Method

[image]
Intersoft WebDesktop Documentation
SaveLayoutToStream Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : SaveLayoutToStream Method

stream
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToStream( _
   ByVal stream As System.IO.Stream, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim stream As System.IO.Stream
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToStream(stream, saveOptions)
C#
public virtual void SaveLayoutToStream(
   System.IO.Stream stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

stream
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


SetRenderMethodDelegate Method

[image]
Intersoft WebDesktop Documentation
SetRenderMethodDelegate Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : SetRenderMethodDelegate Method

renderMethod

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetRenderMethodDelegate( _
   ByVal renderMethod As System.Web.UI.RenderMethod _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim renderMethod As System.Web.UI.RenderMethod

instance.SetRenderMethodDelegate(renderMethod)
C#
public void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod renderMethod
)

Parameters

renderMethod

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


SetSessionTheme Method

[image]
Intersoft WebDesktop Documentation
SetSessionTheme Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : SetSessionTheme Method

themeInfo

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetSessionTheme( _
   ByVal themeInfo As ISNet.WebUI.ThemeInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim themeInfo As ISNet.WebUI.ThemeInfo

instance.SetSessionTheme(themeInfo)
C#
public void SetSessionTheme(
   ISNet.WebUI.ThemeInfo themeInfo
)

Parameters

themeInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


ShouldReturnJson Method

[image]
Intersoft WebDesktop Documentation
ShouldReturnJson Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : ShouldReturnJson Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ShouldReturnJson() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As Boolean

value = instance.ShouldReturnJson()
C#
public virtual bool ShouldReturnJson()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


AccessKey Property

[image]
Intersoft WebDesktop Documentation
AccessKey Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : AccessKey Property

Glossary Item Box

Keyboard shortcut used by the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property AccessKey As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As String

instance.AccessKey = value

value = instance.AccessKey
C#
public virtual string AccessKey {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


WebCallOut Class Properties

[image]
Intersoft WebDesktop Documentation
WebCallOut Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebCallOut Class

Glossary Item Box

For a list of all members of this type, see WebCallOut members.

Public Properties

 | Name | Description
Public Property | AccessKey | Keyboard shortcut used by the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | BackColor | Overridden. Color of the background of the control.
Public Property | BorderColor | Overridden. Border color of the controls applied with this style.
Public Property | BorderStyle | Overridden. Style of the border around the control.
Public Property | BorderWidth | Overridden. Width of the border around the control.
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ClientSideEvents | Contains Javascript ClientSide events.
Public Property | CloseBehavior | Specifies the close behavior of WebCallOut.
Public Property | ContainerStyle | Sets the style applied to WebCallOut's container.
Public Property | ContentMode | Gets or sets the content mode of the WebCallOut control.
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | DisplayCloseIcon | Specifies whether WebCallOut's close icon image is displayed.
Public Property | DisplayLatency | Specifies how long WebCallOut will be displayed (in milliseconds).
Public Property | DisplayTitleIcon | Specifies whether WebCallOut's title icon image is displayed.
Public Property | DisplayTitleText | Specifies whether WebCallOut's title text is displayed.
Public Property | Enabled | Enabled state of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableInteractiveMoving | Specifies whether WebCallOut follows mouse cursor inside TargetControlId.
Public Property | EnableManagedTheming | Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | Specifies whether the control automatically saves its state for use in round-trips. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). (Inherited from ISNet.WebUI.ISNetControl)
Public Property | FlyPostBackSettings |
Public Property | ForeColor | Overridden. Color of the text within the control.
Public Property | FrameStyle | Gets or sets the style applied to Frame.
Public Property | GroupName |
Public Property | Height | The height of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from System.Web.UI.Control)
Public Property | ImagesDirectory | Gets or sets the images directory used by ImagesSettings.
Public Property | ImagesSettings | Contains images settings.
Public Property | Latency | Specifies how long WebCallOut will be closed automatically (in seconds). This property will be used if CloseBehavior is set to Latency.
Public Property | LayoutMode | Specifies the layout mode of WebCallOut.
Public Property | LeftPointerIndentation |
Public Property | OffsetBottomPointingPosition | Specifies the bottom pointing position offset of WebCallOut.
Public Property | OffsetTopPointingPosition | Specifies the top pointing position offset of WebCallOut.
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | PointingPosition | Specifies the pointing position of WebCallOut.
Public Property | PreferredHorizontalPosition | Specifies the preferred horizontal position of WebCallOut.
Public Property | PreferredVerticalPosition | Specifies the preferred vertical position of WebCallOut.
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RightPointerIndentation |
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden. Gets or sets the directory where all required scripts for the control are stored.
Public Property | SharedScriptDirectory | Overridden. Gets or sets the directory where all shared scripts for Intersoft controls are stored.
Public Property | ShowBehavior | Specifies the show behavior of WebCallOut.
Public Property | SkinID | The SkinId of the control skin that provides the skin of the control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | TargetControlId | Specifies the target ControlId of WebCallOut.
Public Property | Text | Specifies the text of WebCallOut. This property will be used if ContentMode is set to UseText.
Public Property | Title | Specifies the title of WebCallOut.
Public Property | TitleStyle | Sets the style applied to WebCallOut's title.
Public Property | UseAdvancedCalculation |
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateItems | Gets or sets the items to be stored in view state storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | Gets or sets the server connection string for file server-based viewstate storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | Gets or sets the location to store the viewstate of this control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | Indicates whether the control is visible and rendered. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | VisibleBasedOnTargetControlId |
Public Property | Width | The width of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | XmlCompressionEnabled | Specifies whether the Xml used for clientside state storage should be compressed. (Inherited from ISNet.WebUI.ISNetControl)
Top

See Also

Reference

WebCallOut Class
ISNet.WebUI.WebDesktop Namespace

Concepts

WebCallOut Concepts
WebCallOut Features


WebCallOut Constructor

[image]
Intersoft WebDesktop Documentation
WebCallOut Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : WebCallOut Constructor

Glossary Item Box

Overload List

Overload | Description
WebCallOut Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


BackColor Property

[image]
Intersoft WebDesktop Documentation
BackColor Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : BackColor Property

Glossary Item Box

Color of the background of the control.

Syntax

Visual Basic (Declaration)
Public Overrides Property BackColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
C#
public override System.Drawing.Color BackColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


BorderColor Property

[image]
Intersoft WebDesktop Documentation
BorderColor Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : BorderColor Property

Glossary Item Box

Border color of the controls applied with this style.

Syntax

Visual Basic (Declaration)
Public Overrides Property BorderColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As System.Drawing.Color

instance.BorderColor = value

value = instance.BorderColor
C#
public override System.Drawing.Color BorderColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


BorderStyle Property

[image]
Intersoft WebDesktop Documentation
BorderStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : BorderStyle Property

Glossary Item Box

Style of the border around the control.

Syntax

Visual Basic (Declaration)
Public Overrides Property BorderStyle As System.Web.UI.WebControls.BorderStyle
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As System.Web.UI.WebControls.BorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
C#
public override System.Web.UI.WebControls.BorderStyle BorderStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


BorderWidth Property

[image]
Intersoft WebDesktop Documentation
BorderWidth Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : BorderWidth Property

Glossary Item Box

Width of the border around the control.

Syntax

Visual Basic (Declaration)
Public Overrides Property BorderWidth As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As System.Web.UI.WebControls.Unit

instance.BorderWidth = value

value = instance.BorderWidth
C#
public override System.Web.UI.WebControls.Unit BorderWidth {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


ClientIDMode Property

[image]
Intersoft WebDesktop Documentation
ClientIDMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : ClientIDMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ClientIDMode As System.Web.UI.ClientIDMode
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As System.Web.UI.ClientIDMode

instance.ClientIDMode = value

value = instance.ClientIDMode
C#
public virtual System.Web.UI.ClientIDMode ClientIDMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


ClientSideEvents Property

[image]
Intersoft WebDesktop Documentation
ClientSideEvents Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : ClientSideEvents Property

Glossary Item Box

Contains Javascript ClientSide events.

Syntax

Visual Basic (Declaration)
Public Property ClientSideEvents As WebCallOutClientSideEvents
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As WebCallOutClientSideEvents

instance.ClientSideEvents = value

value = instance.ClientSideEvents
C#
public WebCallOutClientSideEvents ClientSideEvents {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


CloseBehavior Property

[image]
Intersoft WebDesktop Documentation
CloseBehavior Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : CloseBehavior Property

Glossary Item Box

Specifies the close behavior of WebCallOut.

Syntax

Visual Basic (Declaration)
Public Property CloseBehavior As CloseBehavior
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As CloseBehavior

instance.CloseBehavior = value

value = instance.CloseBehavior
C#
public CloseBehavior CloseBehavior {get; set;}

Remarks

WebCallOut provides several close behaviors.

  • Latency
    Automatic and by default the WebCallOut will disappear in 30 seconds after shown.
    You can change the fading time in Latency. Beside that, WebCallOut will disappear if user clicks the close icon or the WebCallOut.
  • MouseOut
    WebCallOut will disappear if user hovers the mouse out from the TargetControlId or WebCallOut area.
  • ClickOutsideCallOut
    WebCallOut will disappear if user clicks outside of the WebCallOut.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members

Concepts

WebCallOut Concepts
WebCallOut Features

Tasks

How-to: Use CloseBehaviors in WebCallOut


ContainerStyle Property

[image]
Intersoft WebDesktop Documentation
ContainerStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : ContainerStyle Property

Glossary Item Box

Sets the style applied to WebCallOut's container.

Syntax

Visual Basic (Declaration)
Public Property ContainerStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As ISNet.WebUI.WebStyle

instance.ContainerStyle = value

value = instance.ContainerStyle
C#
public ISNet.WebUI.WebStyle ContainerStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


ContentMode Property

[image]
Intersoft WebDesktop Documentation
ContentMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : ContentMode Property

Glossary Item Box

Gets or sets the content mode of the WebCallOut control.

Syntax

Visual Basic (Declaration)
Public Property ContentMode As WebCallOutContentMode
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As WebCallOutContentMode

instance.ContentMode = value

value = instance.ContentMode
C#
public WebCallOutContentMode ContentMode {get; set;}

Remarks

WebCallOut supports two types of content mode:

  • UseText
    In this mode, WebCallOut will use the Text as the content.
  • UseTemplate
    In this mode, WebCallOut will use user’s custom made template as the content.

Simply set the LayoutMode that you want in LayoutMode property. By default, WebCallOut’a LayoutMode is UseText.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members

Concepts

WebCallOut Concepts
WebCallOut Features

Tasks

How-to: Set ContentMode in WebCallOut


ControlDataTransferFormat Property

[image]
Intersoft WebDesktop Documentation
ControlDataTransferFormat Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : ControlDataTransferFormat Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ControlDataTransferFormat As ISNet.WebUI.DataTransferFormat
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As ISNet.WebUI.DataTransferFormat

instance.ControlDataTransferFormat = value

value = instance.ControlDataTransferFormat
C#
public virtual ISNet.WebUI.DataTransferFormat ControlDataTransferFormat {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


DisplayCloseIcon Property

[image]
Intersoft WebDesktop Documentation
DisplayCloseIcon Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : DisplayCloseIcon Property

Glossary Item Box

Specifies whether WebCallOut's close icon image is displayed.

Syntax

Visual Basic (Declaration)
Public Property DisplayCloseIcon As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As Boolean

instance.DisplayCloseIcon = value

value = instance.DisplayCloseIcon
C#
public bool DisplayCloseIcon {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


DisplayLatency Property

[image]
Intersoft WebDesktop Documentation
DisplayLatency Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : DisplayLatency Property

Glossary Item Box

Specifies how long WebCallOut will be displayed (in milliseconds).

Syntax

Visual Basic (Declaration)
Public Property DisplayLatency As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As Integer

instance.DisplayLatency = value

value = instance.DisplayLatency
C#
public int DisplayLatency {get; set;}

Remarks

When you mouse over to the control specified in TargetControlId, the WebCallOut will not directly appear. WebCallOut will appear if you hover to the control and wait for several milliseconds (default is 500ms). If the default DisplayLatency does not suit your scenario then you can change it by simply set your desire DisplayLatency in the WebCallOut’s properties.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members

Concepts

WebCallOut Concepts
WebCallOut Features

Tasks

How-to: Set DisplayLatency in WebCallOut


DisplayTitleIcon Property

[image]
Intersoft WebDesktop Documentation
DisplayTitleIcon Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : DisplayTitleIcon Property

Glossary Item Box

Specifies whether WebCallOut's title icon image is displayed.

Syntax

Visual Basic (Declaration)
Public Property DisplayTitleIcon As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As Boolean

instance.DisplayTitleIcon = value

value = instance.DisplayTitleIcon
C#
public bool DisplayTitleIcon {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


DisplayTitleText Property

[image]
Intersoft WebDesktop Documentation
DisplayTitleText Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : DisplayTitleText Property

Glossary Item Box

Specifies whether WebCallOut's title text is displayed.

Syntax

Visual Basic (Declaration)
Public Property DisplayTitleText As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As Boolean

instance.DisplayTitleText = value

value = instance.DisplayTitleText
C#
public bool DisplayTitleText {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


Enabled Property

[image]
Intersoft WebDesktop Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : Enabled Property

Glossary Item Box

Enabled state of the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property Enabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As Boolean

instance.Enabled = value

value = instance.Enabled
C#
public virtual bool Enabled {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


EnableInteractiveMoving Property

[image]
Intersoft WebDesktop Documentation
EnableInteractiveMoving Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : EnableInteractiveMoving Property

Glossary Item Box

Specifies whether WebCallOut follows mouse cursor inside TargetControlId.

Syntax

Visual Basic (Declaration)
Public Property EnableInteractiveMoving As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As Boolean

instance.EnableInteractiveMoving = value

value = instance.EnableInteractiveMoving
C#
public bool EnableInteractiveMoving {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


EnableManagedTheming Property

[image]
Intersoft WebDesktop Documentation
EnableManagedTheming Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : EnableManagedTheming Property

Glossary Item Box

Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.

Syntax

Visual Basic (Declaration)
Public Overridable Property EnableManagedTheming As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As Boolean

instance.EnableManagedTheming = value

value = instance.EnableManagedTheming
C#
public virtual bool EnableManagedTheming {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


EnableTheming Property

[image]
Intersoft WebDesktop Documentation
EnableTheming Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : EnableTheming Property

Glossary Item Box

Gets or sets a value indicating whether themes apply to this control.

Syntax

Visual Basic (Declaration)
Public Overridable Property EnableTheming As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As Boolean

instance.EnableTheming = value

value = instance.EnableTheming
C#
public virtual bool EnableTheming {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


EnableViewState Property

[image]
Intersoft WebDesktop Documentation
EnableViewState Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : EnableViewState Property

Glossary Item Box

Specifies whether the control automatically saves its state for use in round-trips.

Syntax

Visual Basic (Declaration)
Public Overridable Property EnableViewState As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As Boolean

instance.EnableViewState = value

value = instance.EnableViewState
C#
public virtual bool EnableViewState {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


EnableWebResources Property

[image]
Intersoft WebDesktop Documentation
EnableWebResources Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : EnableWebResources Property

Glossary Item Box

Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory).

Syntax

Visual Basic (Declaration)
Public Property EnableWebResources As ISNet.WebUI.WebResourceType
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As ISNet.WebUI.WebResourceType

instance.EnableWebResources = value

value = instance.EnableWebResources
C#
public ISNet.WebUI.WebResourceType EnableWebResources {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


FlyPostBackSettings Property

[image]
Intersoft WebDesktop Documentation
FlyPostBackSettings Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : FlyPostBackSettings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FlyPostBackSettings As ISNet.WebUI.FlyPostBackSettings
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As ISNet.WebUI.FlyPostBackSettings

value = instance.FlyPostBackSettings
C#
public ISNet.WebUI.FlyPostBackSettings FlyPostBackSettings {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


ForeColor Property

[image]
Intersoft WebDesktop Documentation
ForeColor Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : ForeColor Property

Glossary Item Box

Color of the text within the control.

Syntax

Visual Basic (Declaration)
Public Overrides Property ForeColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
C#
public override System.Drawing.Color ForeColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


FrameStyle Property

[image]
Intersoft WebDesktop Documentation
FrameStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : FrameStyle Property

Glossary Item Box

Gets or sets the style applied to Frame.

Syntax

Visual Basic (Declaration)
Public Property FrameStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As ISNet.WebUI.WebStyle

instance.FrameStyle = value

value = instance.FrameStyle
C#
public ISNet.WebUI.WebStyle FrameStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


GroupName Property

[image]
Intersoft WebDesktop Documentation
GroupName Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : GroupName Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property GroupName As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As String

instance.GroupName = value

value = instance.GroupName
C#
public string GroupName {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


Height Property

[image]
Intersoft WebDesktop Documentation
Height Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : Height Property

Glossary Item Box

The height of the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property Height As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As System.Web.UI.WebControls.Unit

instance.Height = value

value = instance.Height
C#
public virtual System.Web.UI.WebControls.Unit Height {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


ID Property

[image]
Intersoft WebDesktop Documentation
ID Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : ID Property

Glossary Item Box

Gets or sets the programmatic identifier assigned to the server control.

Syntax

Visual Basic (Declaration)
Public Overridable Property ID As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As String

instance.ID = value

value = instance.ID
C#
public virtual string ID {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


ImagesDirectory Property

[image]
Intersoft WebDesktop Documentation
ImagesDirectory Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : ImagesDirectory Property

Glossary Item Box

Gets or sets the images directory used by ImagesSettings.

Syntax

Visual Basic (Declaration)
Public Property ImagesDirectory As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As String

instance.ImagesDirectory = value

value = instance.ImagesDirectory
C#
public string ImagesDirectory {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


ImagesSettings Property

[image]
Intersoft WebDesktop Documentation
ImagesSettings Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : ImagesSettings Property

Glossary Item Box

Contains images settings.

Syntax

Visual Basic (Declaration)
Public Property ImagesSettings As WebCallOutImagesSettings
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As WebCallOutImagesSettings

instance.ImagesSettings = value

value = instance.ImagesSettings
C#
public WebCallOutImagesSettings ImagesSettings {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


Latency Property

[image]
Intersoft WebDesktop Documentation
Latency Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : Latency Property

Glossary Item Box

Specifies how long WebCallOut will be closed automatically (in seconds). This property will be used if CloseBehavior is set to Latency.

Syntax

Visual Basic (Declaration)
Public Property Latency As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As Integer

instance.Latency = value

value = instance.Latency
C#
public int Latency {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


LayoutMode Property

[image]
Intersoft WebDesktop Documentation
LayoutMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : LayoutMode Property

Glossary Item Box

Specifies the layout mode of WebCallOut.

Syntax

Visual Basic (Declaration)
Public Property LayoutMode As LayoutMode
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As LayoutMode

instance.LayoutMode = value

value = instance.LayoutMode
C#
public LayoutMode LayoutMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


LeftPointerIndentation Property

[image]
Intersoft WebDesktop Documentation
LeftPointerIndentation Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : LeftPointerIndentation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property LeftPointerIndentation As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As Integer

instance.LeftPointerIndentation = value

value = instance.LeftPointerIndentation
C#
public int LeftPointerIndentation {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


OffsetBottomPointingPosition Property

[image]
Intersoft WebDesktop Documentation
OffsetBottomPointingPosition Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : OffsetBottomPointingPosition Property

Glossary Item Box

Specifies the bottom pointing position offset of WebCallOut.

Syntax

Visual Basic (Declaration)
Public Property OffsetBottomPointingPosition As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As Integer

instance.OffsetBottomPointingPosition = value

value = instance.OffsetBottomPointingPosition
C#
public int OffsetBottomPointingPosition {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


OffsetTopPointingPosition Property

[image]
Intersoft WebDesktop Documentation
OffsetTopPointingPosition Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : OffsetTopPointingPosition Property

Glossary Item Box

Specifies the top pointing position offset of WebCallOut.

Syntax

Visual Basic (Declaration)
Public Property OffsetTopPointingPosition As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As Integer

instance.OffsetTopPointingPosition = value

value = instance.OffsetTopPointingPosition
C#
public int OffsetTopPointingPosition {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


Page Property

[image]
Intersoft WebDesktop Documentation
Page Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : Page Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Page As System.Web.UI.Page
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As System.Web.UI.Page

instance.Page = value

value = instance.Page
C#
public virtual System.Web.UI.Page Page {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


PointingPosition Property

[image]
Intersoft WebDesktop Documentation
PointingPosition Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : PointingPosition Property

Glossary Item Box

Specifies the pointing position of WebCallOut.

Syntax

Visual Basic (Declaration)
Public Property PointingPosition As PointingPosition
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As PointingPosition

instance.PointingPosition = value

value = instance.PointingPosition
C#
public PointingPosition PointingPosition {get; set;}

Remarks

WebCallOut introduces several pointing position, such as:

  • AutoDetect
    WebCallOut will adjust the pointing position base on the control position that is specified in TargetControlId’s, PreferrableVerticalPosition, and PreferrableHorizontalPosition properties.
  • PointingTopLeft
    WebCallOut will appear on the TopLeft of control specified in TargetControlId.
  • PointingTopRight
    WebCallOut will appear on the TopRight of control specified in TargetControlId.
  • PointingBottomLeft
    WebCallOut will appear on the BottomLeft of control specified in TargetControlId.
  • PointingBottomRight
    WebCallOut will appear on the BottomRight of control specified in TargetControlId.

Except AutoDetect, the others options will not depend on PreferredVerticalPosition and PreferredHorizontalPosition properties.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members

Concepts

WebCallOut Concepts
WebCallOut Features

Tasks

How-to: Customize pointing position in WebCallOut


PreferredHorizontalPosition Property

[image]
Intersoft WebDesktop Documentation
PreferredHorizontalPosition Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : PreferredHorizontalPosition Property

Glossary Item Box

Specifies the preferred horizontal position of WebCallOut.

Syntax

Visual Basic (Declaration)
Public Property PreferredHorizontalPosition As PreferredHorizontalPosition
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As PreferredHorizontalPosition

instance.PreferredHorizontalPosition = value

value = instance.PreferredHorizontalPosition
C#
public PreferredHorizontalPosition PreferredHorizontalPosition {get; set;}

Remarks

Preferred position means in which position you want the WebCallOut to be shown related to control specified in TargetControlId. There are 2 properties that refer to preferred position, PreferredVerticalPosition and PreferredHorizontalPosition. The default value for PreferredVerticalPosition is Top and PreferredHorizontalPosition is Left. For instance, if the PreferredVerticalPosition is set to Bottom and PreferredHorizontalPositon is set to Right then WebCallOut will be shown at the BottomRight of the control specified in TargetControlId.

These properties will be applied if PointingPosition is set to AutoDetect.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members

Concepts

WebCallOut Concepts
WebCallOut Features

Tasks

How-to: Use preferred position in WebCallOut


PreferredVerticalPosition Property

[image]
Intersoft WebDesktop Documentation
PreferredVerticalPosition Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : PreferredVerticalPosition Property

Glossary Item Box

Specifies the preferred vertical position of WebCallOut.

Syntax

Visual Basic (Declaration)
Public Property PreferredVerticalPosition As PreferredVerticalPosition
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As PreferredVerticalPosition

instance.PreferredVerticalPosition = value

value = instance.PreferredVerticalPosition
C#
public PreferredVerticalPosition PreferredVerticalPosition {get; set;}

Remarks

Preferred position means in which position you want the WebCallOut to be shown related to control specified in TargetControlId. There are 2 properties that refer to preferred position, PreferredVerticalPosition and PreferredHorizontalPosition. The default value for PreferredVerticalPosition is Top and PreferredHorizontalPosition is Left. For instance, if the PreferredVerticalPosition is set to Bottom and PreferredHorizontalPositon is set to Right then WebCallOut will be shown at the BottomRight of the control specified in TargetControlId.

These properties will be applied if PointingPosition is set to AutoDetect.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members

Concepts

WebCallOut Concepts
WebCallOut Features

Tasks

How-to: Use preferred position in WebCallOut


RenderingMode Property

[image]
Intersoft WebDesktop Documentation
RenderingMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : RenderingMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property RenderingMode As ISNet.WebUI.RenderMode
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As ISNet.WebUI.RenderMode

instance.RenderingMode = value

value = instance.RenderingMode
C#
public virtual ISNet.WebUI.RenderMode RenderingMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


RightPointerIndentation Property

[image]
Intersoft WebDesktop Documentation
RightPointerIndentation Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : RightPointerIndentation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property RightPointerIndentation As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As Integer

instance.RightPointerIndentation = value

value = instance.RightPointerIndentation
C#
public int RightPointerIndentation {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


RuntimeLicenseKey Property

[image]
Intersoft WebDesktop Documentation
RuntimeLicenseKey Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : RuntimeLicenseKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property RuntimeLicenseKey As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As String

instance.RuntimeLicenseKey = value

value = instance.RuntimeLicenseKey
C#
public virtual string RuntimeLicenseKey {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


ScriptDirectory Property

[image]
Intersoft WebDesktop Documentation
ScriptDirectory Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : ScriptDirectory Property

Glossary Item Box

Gets or sets the directory where all required scripts for the control are stored.

Syntax

Visual Basic (Declaration)
Public Overrides Property ScriptDirectory As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As String

instance.ScriptDirectory = value

value = instance.ScriptDirectory
C#
public override string ScriptDirectory {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


SharedScriptDirectory Property

[image]
Intersoft WebDesktop Documentation
SharedScriptDirectory Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : SharedScriptDirectory Property

Glossary Item Box

Gets or sets the directory where all shared scripts for Intersoft controls are stored.

Syntax

Visual Basic (Declaration)
Public Overrides Property SharedScriptDirectory As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As String

instance.SharedScriptDirectory = value

value = instance.SharedScriptDirectory
C#
public override string SharedScriptDirectory {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


ShowBehavior Property

[image]
Intersoft WebDesktop Documentation
ShowBehavior Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : ShowBehavior Property

Glossary Item Box

Specifies the show behavior of WebCallOut.

Syntax

Visual Basic (Declaration)
Public Property ShowBehavior As ShowBehavior
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As ShowBehavior

instance.ShowBehavior = value

value = instance.ShowBehavior
C#
public ShowBehavior ShowBehavior {get; set;}

Remarks

WebCallOut provides two approach as the ShowBehavior:

  • Default
    By default, WebCallOut will appear and disappear with fading animation.
  • NoFading
    WebCallOut will appear and disappear without fading animation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members

Concepts

WebCallOut Concepts
WebCallOut Features

Tasks

How-to: Use ShowBehaviors in WebCallOut


SkinID Property

[image]
Intersoft WebDesktop Documentation
SkinID Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : SkinID Property

Glossary Item Box

The SkinId of the control skin that provides the skin of the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property SkinID As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As String

instance.SkinID = value

value = instance.SkinID
C#
public virtual string SkinID {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


TabIndex Property

[image]
Intersoft WebDesktop Documentation
TabIndex Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : TabIndex Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property TabIndex As Short
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As Short

instance.TabIndex = value

value = instance.TabIndex
C#
public virtual short TabIndex {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


TargetControlId Property

[image]
Intersoft WebDesktop Documentation
TargetControlId Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : TargetControlId Property

Glossary Item Box

Specifies the target ControlId of WebCallOut.

Syntax

Visual Basic (Declaration)
Public Property TargetControlId As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As String

instance.TargetControlId = value

value = instance.TargetControlId
C#
public string TargetControlId {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


Text Property

[image]
Intersoft WebDesktop Documentation
Text Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : Text Property

Glossary Item Box

Specifies the text of WebCallOut. This property will be used if ContentMode is set to UseText.

Syntax

Visual Basic (Declaration)
Public Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As String

instance.Text = value

value = instance.Text
C#
public string Text {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


Title Property

[image]
Intersoft WebDesktop Documentation
Title Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : Title Property

Glossary Item Box

Specifies the title of WebCallOut.

Syntax

Visual Basic (Declaration)
Public Property Title As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As String

instance.Title = value

value = instance.Title
C#
public string Title {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


TitleStyle Property

[image]
Intersoft WebDesktop Documentation
TitleStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : TitleStyle Property

Glossary Item Box

Sets the style applied to WebCallOut's title.

Syntax

Visual Basic (Declaration)
Public Property TitleStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As ISNet.WebUI.WebStyle

instance.TitleStyle = value

value = instance.TitleStyle
C#
public ISNet.WebUI.WebStyle TitleStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


UseAdvancedCalculation Property

[image]
Intersoft WebDesktop Documentation
UseAdvancedCalculation Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : UseAdvancedCalculation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property UseAdvancedCalculation As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As Boolean

instance.UseAdvancedCalculation = value

value = instance.UseAdvancedCalculation
C#
public bool UseAdvancedCalculation {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


ValidateRequestMode Property

[image]
Intersoft WebDesktop Documentation
ValidateRequestMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : ValidateRequestMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ValidateRequestMode As System.Web.UI.ValidateRequestMode
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As System.Web.UI.ValidateRequestMode

instance.ValidateRequestMode = value

value = instance.ValidateRequestMode
C#
public virtual System.Web.UI.ValidateRequestMode ValidateRequestMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


ViewStateItems Property

[image]
Intersoft WebDesktop Documentation
ViewStateItems Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : ViewStateItems Property

Glossary Item Box

Gets or sets the items to be stored in view state storage.

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateItems As ISNet.WebUI.ViewStateItem
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As ISNet.WebUI.ViewStateItem

instance.ViewStateItems = value

value = instance.ViewStateItems
C#
public virtual ISNet.WebUI.ViewStateItem ViewStateItems {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


ViewStateMode Property

[image]
Intersoft WebDesktop Documentation
ViewStateMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : ViewStateMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateMode As System.Web.UI.ViewStateMode
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As System.Web.UI.ViewStateMode

instance.ViewStateMode = value

value = instance.ViewStateMode
C#
public virtual System.Web.UI.ViewStateMode ViewStateMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


ViewStateServerConnection Property

[image]
Intersoft WebDesktop Documentation
ViewStateServerConnection Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : ViewStateServerConnection Property

Glossary Item Box

Gets or sets the server connection string for file server-based viewstate storage.

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateServerConnection As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As String

instance.ViewStateServerConnection = value

value = instance.ViewStateServerConnection
C#
public virtual string ViewStateServerConnection {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


ViewStateStorage Property

[image]
Intersoft WebDesktop Documentation
ViewStateStorage Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : ViewStateStorage Property

Glossary Item Box

Gets or sets the location to store the viewstate of this control.

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateStorage As ISNet.WebUI.StateCacheStorage
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As ISNet.WebUI.StateCacheStorage

instance.ViewStateStorage = value

value = instance.ViewStateStorage
C#
public virtual ISNet.WebUI.StateCacheStorage ViewStateStorage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


Visible Property

[image]
Intersoft WebDesktop Documentation
Visible Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : Visible Property

Glossary Item Box

Indicates whether the control is visible and rendered.

Syntax

Visual Basic (Declaration)
Public Overridable Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public virtual bool Visible {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


VisibleBasedOnTargetControlId Property

[image]
Intersoft WebDesktop Documentation
VisibleBasedOnTargetControlId Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : VisibleBasedOnTargetControlId Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property VisibleBasedOnTargetControlId As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As Boolean

instance.VisibleBasedOnTargetControlId = value

value = instance.VisibleBasedOnTargetControlId
C#
public bool VisibleBasedOnTargetControlId {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


Width Property

[image]
Intersoft WebDesktop Documentation
Width Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : Width Property

Glossary Item Box

The width of the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property Width As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As System.Web.UI.WebControls.Unit

instance.Width = value

value = instance.Width
C#
public virtual System.Web.UI.WebControls.Unit Width {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


XmlCompressionEnabled Property

[image]
Intersoft WebDesktop Documentation
XmlCompressionEnabled Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : XmlCompressionEnabled Property

Glossary Item Box

Specifies whether the Xml used for clientside state storage should be compressed.

Syntax

Visual Basic (Declaration)
Public Overridable Property XmlCompressionEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim value As Boolean

instance.XmlCompressionEnabled = value

value = instance.XmlCompressionEnabled
C#
public virtual bool XmlCompressionEnabled {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


DataBinding Event

[image]
Intersoft WebDesktop Documentation
DataBinding Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : DataBinding Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event DataBinding As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim handler As EventHandler

AddHandler instance.DataBinding, handler
C#
public event EventHandler DataBinding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


Disposed Event

[image]
Intersoft WebDesktop Documentation
Disposed Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim handler As EventHandler

AddHandler instance.Disposed, handler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


Init Event

[image]
Intersoft WebDesktop Documentation
Init Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : Init Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Init As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim handler As EventHandler

AddHandler instance.Init, handler
C#
public event EventHandler Init

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


Load Event

[image]
Intersoft WebDesktop Documentation
Load Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : Load Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Load As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim handler As EventHandler

AddHandler instance.Load, handler
C#
public event EventHandler Load

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


PreInitialize Event

[image]
Intersoft WebDesktop Documentation
PreInitialize Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : PreInitialize Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event PreInitialize As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim handler As EventHandler

AddHandler instance.PreInitialize, handler
C#
public event EventHandler PreInitialize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


PreRender Event

[image]
Intersoft WebDesktop Documentation
PreRender Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : PreRender Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event PreRender As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim handler As EventHandler

AddHandler instance.PreRender, handler
C#
public event EventHandler PreRender

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


WebCallOut Class Events

[image]
Intersoft WebDesktop Documentation
WebCallOut Class Events
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebCallOut Class

Glossary Item Box

For a list of all members of this type, see WebCallOut members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Show |
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebCallOut Class
ISNet.WebUI.WebDesktop Namespace

Concepts

WebCallOut Concepts
WebCallOut Features


Show Event

[image]
Intersoft WebDesktop Documentation
Show Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : Show Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Show As WebCallOutOnShowEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim handler As WebCallOutOnShowEventHandler

AddHandler instance.Show, handler
C#
public event WebCallOutOnShowEventHandler Show

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


Unload Event

[image]
Intersoft WebDesktop Documentation
Unload Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOut Class : Unload Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Unload As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebCallOut
Dim handler As EventHandler

AddHandler instance.Unload, handler
C#
public event EventHandler Unload

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOut Class
WebCallOut Members


WebCallOutClientSideEvents Class

[image]
Intersoft WebDesktop Documentation
WebCallOutClientSideEvents Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebCallOutClientSideEvents Class

Glossary Item Box

Javascript functions which invoked from client side in WebCallOut.

Object Model

WebCallOutClientSideEvents Class

Syntax

Visual Basic (Declaration)
Public Class WebCallOutClientSideEvents
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebCallOutClientSideEvents
C#
public class WebCallOutClientSideEvents : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebDesktop.WebCallOutClientSideEvents

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutClientSideEvents Members
ISNet.WebUI.WebDesktop Namespace


WebCallOutClientSideEvents Class Members

[image]
Intersoft WebDesktop Documentation
WebCallOutClientSideEvents Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebCallOutClientSideEvents Class

Glossary Item Box

The following tables list the members exposed by WebCallOutClientSideEvents.

Public Constructors

 | Name | Description
Public Constructor | WebCallOutClientSideEvents Constructor |
Top

Public Properties

 | Name | Description
Public Property | OnBeforeShow |
Public Property | OnClose | Gets or sets the event handler when WebCallOut is closed.
Public Property | OnInitialize | Gets or sets the event handler when WebCallOut is initialized.
Public Property | OnResponse |
Public Property | OnShow | Gets or sets the event handler when WebCallOut is shown.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebCallOutClientSideEvents Class
ISNet.WebUI.WebDesktop Namespace


WebCallOutClientSideEvents Constructor

[image]
Intersoft WebDesktop Documentation
WebCallOutClientSideEvents Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOutClientSideEvents Class : WebCallOutClientSideEvents Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebCallOutClientSideEvents()
C#
public WebCallOutClientSideEvents()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutClientSideEvents Class
WebCallOutClientSideEvents Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOutClientSideEvents Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebCallOutClientSideEvents
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutClientSideEvents Class
WebCallOutClientSideEvents Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOutClientSideEvents Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutClientSideEvents Class
WebCallOutClientSideEvents Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOutClientSideEvents Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCallOutClientSideEvents
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutClientSideEvents Class
WebCallOutClientSideEvents Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOutClientSideEvents Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCallOutClientSideEvents
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutClientSideEvents Class
WebCallOutClientSideEvents Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOutClientSideEvents Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCallOutClientSideEvents
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutClientSideEvents Class
WebCallOutClientSideEvents Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOutClientSideEvents Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebCallOutClientSideEvents
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutClientSideEvents Class
WebCallOutClientSideEvents Members


WebCallOutClientSideEvents Class Methods

[image]
Intersoft WebDesktop Documentation
WebCallOutClientSideEvents Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebCallOutClientSideEvents Class

Glossary Item Box

For a list of all members of this type, see WebCallOutClientSideEvents members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebCallOutClientSideEvents Class
ISNet.WebUI.WebDesktop Namespace


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOutClientSideEvents Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCallOutClientSideEvents
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutClientSideEvents Class
WebCallOutClientSideEvents Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOutClientSideEvents Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCallOutClientSideEvents
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutClientSideEvents Class
WebCallOutClientSideEvents Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOutClientSideEvents Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebCallOutClientSideEvents

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutClientSideEvents Class
WebCallOutClientSideEvents Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOutClientSideEvents Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCallOutClientSideEvents
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutClientSideEvents Class
WebCallOutClientSideEvents Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOutClientSideEvents Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOutClientSideEvents
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutClientSideEvents Class
WebCallOutClientSideEvents Members


WebCallOutClientSideEvents Class Properties

[image]
Intersoft WebDesktop Documentation
WebCallOutClientSideEvents Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebCallOutClientSideEvents Class

Glossary Item Box

For a list of all members of this type, see WebCallOutClientSideEvents members.

Public Properties

 | Name | Description
Public Property | OnBeforeShow |
Public Property | OnClose | Gets or sets the event handler when WebCallOut is closed.
Public Property | OnInitialize | Gets or sets the event handler when WebCallOut is initialized.
Public Property | OnResponse |
Public Property | OnShow | Gets or sets the event handler when WebCallOut is shown.
Top

See Also

Reference

WebCallOutClientSideEvents Class
ISNet.WebUI.WebDesktop Namespace


WebCallOutClientSideEvents Constructor

[image]
Intersoft WebDesktop Documentation
WebCallOutClientSideEvents Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOutClientSideEvents Class : WebCallOutClientSideEvents Constructor

Glossary Item Box

Overload List

Overload | Description
WebCallOutClientSideEvents Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutClientSideEvents Class
WebCallOutClientSideEvents Members


OnBeforeShow Property

[image]
Intersoft WebDesktop Documentation
OnBeforeShow Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOutClientSideEvents Class : OnBeforeShow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property OnBeforeShow As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOutClientSideEvents
Dim value As String

instance.OnBeforeShow = value

value = instance.OnBeforeShow
C#
public string OnBeforeShow {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutClientSideEvents Class
WebCallOutClientSideEvents Members


OnClose Property

[image]
Intersoft WebDesktop Documentation
OnClose Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOutClientSideEvents Class : OnClose Property

Glossary Item Box

Gets or sets the event handler when WebCallOut is closed.

Syntax

Visual Basic (Declaration)
Public Property OnClose As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOutClientSideEvents
Dim value As String

instance.OnClose = value

value = instance.OnClose
C#
public string OnClose {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutClientSideEvents Class
WebCallOutClientSideEvents Members


OnInitialize Property

[image]
Intersoft WebDesktop Documentation
OnInitialize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOutClientSideEvents Class : OnInitialize Property

Glossary Item Box

Gets or sets the event handler when WebCallOut is initialized.

Syntax

Visual Basic (Declaration)
Public Property OnInitialize As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOutClientSideEvents
Dim value As String

instance.OnInitialize = value

value = instance.OnInitialize
C#
public string OnInitialize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutClientSideEvents Class
WebCallOutClientSideEvents Members


OnResponse Property

[image]
Intersoft WebDesktop Documentation
OnResponse Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOutClientSideEvents Class : OnResponse Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property OnResponse As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOutClientSideEvents
Dim value As String

instance.OnResponse = value

value = instance.OnResponse
C#
public string OnResponse {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutClientSideEvents Class
WebCallOutClientSideEvents Members


OnShow Property

[image]
Intersoft WebDesktop Documentation
OnShow Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOutClientSideEvents Class : OnShow Property

Glossary Item Box

Gets or sets the event handler when WebCallOut is shown.

Syntax

Visual Basic (Declaration)
Public Property OnShow As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOutClientSideEvents
Dim value As String

instance.OnShow = value

value = instance.OnShow
C#
public string OnShow {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutClientSideEvents Class
WebCallOutClientSideEvents Members


WebCallOutEventDataArgs Class

[image]
Intersoft WebDesktop Documentation
WebCallOutEventDataArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebCallOutEventDataArgs Class

Glossary Item Box

Object Model

WebCallOutEventDataArgs Class

Syntax

Visual Basic (Declaration)
Public Class WebCallOutEventDataArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As WebCallOutEventDataArgs
C#
public class WebCallOutEventDataArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebDesktop.WebCallOutEventDataArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutEventDataArgs Members
ISNet.WebUI.WebDesktop Namespace


WebCallOutEventDataArgs Class Members

[image]
Intersoft WebDesktop Documentation
WebCallOutEventDataArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebCallOutEventDataArgs Class

Glossary Item Box

The following tables list the members exposed by WebCallOutEventDataArgs.

Public Constructors

 | Name | Description
Public Constructor | WebCallOutEventDataArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Text |
Public Property | Title |
Top

See Also

Reference

WebCallOutEventDataArgs Class
ISNet.WebUI.WebDesktop Namespace


WebCallOutEventDataArgs Constructor

[image]
Intersoft WebDesktop Documentation
WebCallOutEventDataArgs Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOutEventDataArgs Class : WebCallOutEventDataArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebCallOutEventDataArgs()
C#
public WebCallOutEventDataArgs()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutEventDataArgs Class
WebCallOutEventDataArgs Members


WebCallOutEventDataArgs Class Properties

[image]
Intersoft WebDesktop Documentation
WebCallOutEventDataArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebCallOutEventDataArgs Class

Glossary Item Box

For a list of all members of this type, see WebCallOutEventDataArgs members.

Public Properties

 | Name | Description
Public Property | Text |
Public Property | Title |
Top

See Also

Reference

WebCallOutEventDataArgs Class
ISNet.WebUI.WebDesktop Namespace


Text Property

[image]
Intersoft WebDesktop Documentation
Text Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOutEventDataArgs Class : Text Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOutEventDataArgs
Dim value As String

instance.Text = value

value = instance.Text
C#
public string Text {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutEventDataArgs Class
WebCallOutEventDataArgs Members


Title Property

[image]
Intersoft WebDesktop Documentation
Title Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOutEventDataArgs Class : Title Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Title As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOutEventDataArgs
Dim value As String

instance.Title = value

value = instance.Title
C#
public string Title {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutEventDataArgs Class
WebCallOutEventDataArgs Members


WebCallOutImagesSettings Class

[image]
Intersoft WebDesktop Documentation
WebCallOutImagesSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebCallOutImagesSettings Class

Glossary Item Box

A collection of images settings for WebCallOut object.

Object Model

WebCallOutImagesSettings Class

Syntax

Visual Basic (Declaration)
Public Class WebCallOutImagesSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebCallOutImagesSettings
C#
public class WebCallOutImagesSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebDesktop.WebCallOutImagesSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutImagesSettings Members
ISNet.WebUI.WebDesktop Namespace


WebCallOutImagesSettings Class Members

[image]
Intersoft WebDesktop Documentation
WebCallOutImagesSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebCallOutImagesSettings Class

Glossary Item Box

The following tables list the members exposed by WebCallOutImagesSettings.

Public Constructors

 | Name | Description
Public Constructor | WebCallOutImagesSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | BottomCenter |
Public Property | BottomLeft |
Public Property | BottomRight |
Public Property | Close |
Public Property | CloseHover |
Public Property | MiddleLeft |
Public Property | MiddleRight |
Public Property | PointingBottomLeft |
Public Property | PointingBottomRight |
Public Property | PointingTopLeft |
Public Property | PointingTopRight |
Public Property | Title |
Public Property | TopCenter |
Public Property | TopLeft |
Public Property | TopRight |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebCallOutImagesSettings Class
ISNet.WebUI.WebDesktop Namespace


WebCallOutImagesSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebCallOutImagesSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOutImagesSettings Class : WebCallOutImagesSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebCallOutImagesSettings()
C#
public WebCallOutImagesSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutImagesSettings Class
WebCallOutImagesSettings Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOutImagesSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebCallOutImagesSettings
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutImagesSettings Class
WebCallOutImagesSettings Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOutImagesSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutImagesSettings Class
WebCallOutImagesSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOutImagesSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCallOutImagesSettings
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutImagesSettings Class
WebCallOutImagesSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOutImagesSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCallOutImagesSettings
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutImagesSettings Class
WebCallOutImagesSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOutImagesSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCallOutImagesSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutImagesSettings Class
WebCallOutImagesSettings Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOutImagesSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebCallOutImagesSettings
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutImagesSettings Class
WebCallOutImagesSettings Members


WebCallOutImagesSettings Class Methods

[image]
Intersoft WebDesktop Documentation
WebCallOutImagesSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebCallOutImagesSettings Class

Glossary Item Box

For a list of all members of this type, see WebCallOutImagesSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebCallOutImagesSettings Class
ISNet.WebUI.WebDesktop Namespace


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOutImagesSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCallOutImagesSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutImagesSettings Class
WebCallOutImagesSettings Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOutImagesSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCallOutImagesSettings
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutImagesSettings Class
WebCallOutImagesSettings Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOutImagesSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebCallOutImagesSettings

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutImagesSettings Class
WebCallOutImagesSettings Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOutImagesSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCallOutImagesSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutImagesSettings Class
WebCallOutImagesSettings Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOutImagesSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOutImagesSettings
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutImagesSettings Class
WebCallOutImagesSettings Members


WebCallOutImagesSettings Class Properties

[image]
Intersoft WebDesktop Documentation
WebCallOutImagesSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebCallOutImagesSettings Class

Glossary Item Box

For a list of all members of this type, see WebCallOutImagesSettings members.

Public Properties

 | Name | Description
Public Property | BottomCenter |
Public Property | BottomLeft |
Public Property | BottomRight |
Public Property | Close |
Public Property | CloseHover |
Public Property | MiddleLeft |
Public Property | MiddleRight |
Public Property | PointingBottomLeft |
Public Property | PointingBottomRight |
Public Property | PointingTopLeft |
Public Property | PointingTopRight |
Public Property | Title |
Public Property | TopCenter |
Public Property | TopLeft |
Public Property | TopRight |
Top

See Also

Reference

WebCallOutImagesSettings Class
ISNet.WebUI.WebDesktop Namespace


WebCallOutImagesSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebCallOutImagesSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOutImagesSettings Class : WebCallOutImagesSettings Constructor

Glossary Item Box

Overload List

Overload | Description
WebCallOutImagesSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutImagesSettings Class
WebCallOutImagesSettings Members


BottomCenter Property

[image]
Intersoft WebDesktop Documentation
BottomCenter Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOutImagesSettings Class : BottomCenter Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property BottomCenter As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOutImagesSettings
Dim value As String

instance.BottomCenter = value

value = instance.BottomCenter
C#
public string BottomCenter {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutImagesSettings Class
WebCallOutImagesSettings Members


BottomLeft Property

[image]
Intersoft WebDesktop Documentation
BottomLeft Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOutImagesSettings Class : BottomLeft Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property BottomLeft As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOutImagesSettings
Dim value As String

instance.BottomLeft = value

value = instance.BottomLeft
C#
public string BottomLeft {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutImagesSettings Class
WebCallOutImagesSettings Members


BottomRight Property

[image]
Intersoft WebDesktop Documentation
BottomRight Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOutImagesSettings Class : BottomRight Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property BottomRight As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOutImagesSettings
Dim value As String

instance.BottomRight = value

value = instance.BottomRight
C#
public string BottomRight {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutImagesSettings Class
WebCallOutImagesSettings Members


Close Property

[image]
Intersoft WebDesktop Documentation
Close Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOutImagesSettings Class : Close Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Close As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOutImagesSettings
Dim value As String

instance.Close = value

value = instance.Close
C#
public string Close {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutImagesSettings Class
WebCallOutImagesSettings Members


CloseHover Property

[image]
Intersoft WebDesktop Documentation
CloseHover Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOutImagesSettings Class : CloseHover Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property CloseHover As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOutImagesSettings
Dim value As String

instance.CloseHover = value

value = instance.CloseHover
C#
public string CloseHover {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutImagesSettings Class
WebCallOutImagesSettings Members


MiddleLeft Property

[image]
Intersoft WebDesktop Documentation
MiddleLeft Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOutImagesSettings Class : MiddleLeft Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property MiddleLeft As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOutImagesSettings
Dim value As String

instance.MiddleLeft = value

value = instance.MiddleLeft
C#
public string MiddleLeft {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutImagesSettings Class
WebCallOutImagesSettings Members


MiddleRight Property

[image]
Intersoft WebDesktop Documentation
MiddleRight Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOutImagesSettings Class : MiddleRight Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property MiddleRight As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOutImagesSettings
Dim value As String

instance.MiddleRight = value

value = instance.MiddleRight
C#
public string MiddleRight {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutImagesSettings Class
WebCallOutImagesSettings Members


PointingBottomLeft Property

[image]
Intersoft WebDesktop Documentation
PointingBottomLeft Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOutImagesSettings Class : PointingBottomLeft Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property PointingBottomLeft As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOutImagesSettings
Dim value As String

instance.PointingBottomLeft = value

value = instance.PointingBottomLeft
C#
public string PointingBottomLeft {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutImagesSettings Class
WebCallOutImagesSettings Members


PointingBottomRight Property

[image]
Intersoft WebDesktop Documentation
PointingBottomRight Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOutImagesSettings Class : PointingBottomRight Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property PointingBottomRight As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOutImagesSettings
Dim value As String

instance.PointingBottomRight = value

value = instance.PointingBottomRight
C#
public string PointingBottomRight {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutImagesSettings Class
WebCallOutImagesSettings Members


PointingTopLeft Property

[image]
Intersoft WebDesktop Documentation
PointingTopLeft Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOutImagesSettings Class : PointingTopLeft Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property PointingTopLeft As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOutImagesSettings
Dim value As String

instance.PointingTopLeft = value

value = instance.PointingTopLeft
C#
public string PointingTopLeft {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutImagesSettings Class
WebCallOutImagesSettings Members


PointingTopRight Property

[image]
Intersoft WebDesktop Documentation
PointingTopRight Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOutImagesSettings Class : PointingTopRight Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property PointingTopRight As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOutImagesSettings
Dim value As String

instance.PointingTopRight = value

value = instance.PointingTopRight
C#
public string PointingTopRight {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutImagesSettings Class
WebCallOutImagesSettings Members


Title Property

[image]
Intersoft WebDesktop Documentation
Title Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOutImagesSettings Class : Title Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Title As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOutImagesSettings
Dim value As String

instance.Title = value

value = instance.Title
C#
public string Title {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutImagesSettings Class
WebCallOutImagesSettings Members


TopCenter Property

[image]
Intersoft WebDesktop Documentation
TopCenter Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOutImagesSettings Class : TopCenter Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property TopCenter As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOutImagesSettings
Dim value As String

instance.TopCenter = value

value = instance.TopCenter
C#
public string TopCenter {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutImagesSettings Class
WebCallOutImagesSettings Members


TopLeft Property

[image]
Intersoft WebDesktop Documentation
TopLeft Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOutImagesSettings Class : TopLeft Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property TopLeft As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOutImagesSettings
Dim value As String

instance.TopLeft = value

value = instance.TopLeft
C#
public string TopLeft {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutImagesSettings Class
WebCallOutImagesSettings Members


TopRight Property

[image]
Intersoft WebDesktop Documentation
TopRight Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebCallOutImagesSettings Class : TopRight Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property TopRight As String
Visual Basic (Usage) Copy Code
Dim instance As WebCallOutImagesSettings
Dim value As String

instance.TopRight = value

value = instance.TopRight
C#
public string TopRight {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutImagesSettings Class
WebCallOutImagesSettings Members


WebContextMenu Class

[image]
Intersoft WebDesktop Documentation
WebContextMenu Class
Members Example See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebContextMenu Class

Glossary Item Box

WebContextMenu offers a MenuBar control functionality, an integration with DesktopManager bind with Server-side controls capability and completed with powerful Designer which will help the process of design time in a more convenient way.

Object Model

WebContextMenu Class

Syntax

Visual Basic (Declaration)
Public Class WebContextMenu
   Inherits ISNet.WebUI.ISNetControl
   Implements ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, ISNet.WebUI.ITemplateSync, IWebMenu, IWebMenuControl
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
C#
public class WebContextMenu : ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, ISNet.WebUI.ITemplateSync, IWebMenu, IWebMenuControl

Remarks

WebContextMenu is designed with a professional architecture and object model as well as specialized user interface for each elements. Therefore, WebContextMenu provides a flexibility to create a Windows-like ContextMenu object which is rich in styles, functions, and behaviors.

WebContextMenu can be integrated with DesktopManager. When integrated, WebContextMenu will refer to the DesktopManager instance and use the Styles defined in DesktopManager automatically. The benefits of this integration are faster page performance with reduced output and maintain the consistency of "look & feel" in entire application effortlessly.

WebContextMenu provides you the easiest way on performing server-side controls integration. You just simply set the ControlId property to the server control's Id, and the designer will do the integration part automatically without any extensive coding required.

Example

The following codes show you how to display WebContextMenu programmatically from server side.
C# Copy Code
protected void Page_Load(object sender, EventArgs e)
{
    WebContextMenu wcm = new WebContextMenu();
    wcm.ControlId = "Button1";

    WebMenuItem  wmi1 = new WebMenuItem();
    wmi1.Name = "mnuContextMenu1";
    wmi1.Text = "ContextMenu1";
    wcm.Items.Add(wmi1);

    WebMenuItem wmi2 = new WebMenuItem();
    wmi2.Name = "mnuContextMenu2";
    wmi2.Text = "ContextMenu2";
    wcm.Items.Add(wmi2);

    HtmlForm frm = (HtmlForm)Page.FindControl("Form1");
    frm.Controls.Add(wcm);
}

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
ISNet.WebUI.ISNetControl
ISNet.WebUI.WebDesktop.WebContextMenu

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Members
ISNet.WebUI.WebDesktop Namespace

Tasks

Attaching ContextMenu to a Control

tasks

Showing ContextMenu Programmatically

Concepts

WebContextMenu Overview

concepts

Features
Visual Menu Builder
Building WebContextMenu Structure


WebContextMenu Class Members

[image]
Intersoft WebDesktop Documentation
WebContextMenu Class Members
See Also Properties Methods Events Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebContextMenu Class

Glossary Item Box

The following tables list the members exposed by WebContextMenu.

Public Constructors

 | Name | Description
Public Constructor | WebContextMenu Constructor |
Top

Public Properties

 | Name | Description
Public Property | AccessKey | Keyboard shortcut used by the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | AutoPostBack | Specifies whether the control should cause postback automatically when clicked.
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ClientSideEvents | Provides client side events for WebContextMenu control.
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ControlId | Gets or sets the server or client control ID of which context menu will be assigned to.
Public Property | Enabled | Enabled state of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableManagedTheming | Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to False, this control will not apply the style defined in Theme Architecture. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | Whether the control automatically saves its state for use in round-trips. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Height | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ImageSize | Gets or sets the default size of Image used in entire menu hierarchy.
Public Property | IntegratedTo | Specifies whether this menu control should be operated in Integration mode. When integrated, the menu will automatically inherit all styles defined in the Integration Object (whether it is PlaceHolderManager or DesktopManager).
Public Property | Items | Gets the collection containing WebMenuItem objects for this menu control.
Public Property | MenuStyleSettings | Contains styles and appearance definition for the Menu.
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RootMenu | Gets the WebMenu object which is RootMenu for this context menu control.
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden. Gets or sets the directory where all required scripts for the control are stored.
Public Property | SharedScriptDirectory | Overridden. Gets or sets the directory where all shared scripts for Intersoft controls are stored.
Public Property | ShowDelay | Gets or sets the amount of submenu show delay in milliseconds.
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ToolTip | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateItems | Gets or sets the items to be stored in view state storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | Gets or sets the server connection string for file server-based viewstate storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | Gets or sets the location to store the viewstate of this control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | Indicates whether the control is visible and rendered. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Width | The width of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | XmlCompressionEnabled | Specifies whether the Xml used for clientside state storage should be compressed. (Inherited from ISNet.WebUI.ISNetControl)
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetMenuItemRecursive |
Public Method | GetObjectData | Overridden.
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPostData | Overridden.
Public Method | LoadStructureFromXml | Overloaded.
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnMenuItemClicked |
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RaisePostBackEvent |
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RecreateChildControls |
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterScript | Overridden.
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveStructureToXml | Overloaded.
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SynchronizeTemplatesFrom |
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | MenuItemClicked | Occurs when menu item is clicked.
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebContextMenu Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Attaching ContextMenu to a Control

tasks

Showing ContextMenu Programmatically

Concepts

WebContextMenu Overview

concepts

Features
Visual Menu Builder
Building WebContextMenu Structure


WebContextMenu Constructor

[image]
Intersoft WebDesktop Documentation
WebContextMenu Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : WebContextMenu Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebContextMenu()
C#
public WebContextMenu()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


ApplyStyle Method

[image]
Intersoft WebDesktop Documentation
ApplyStyle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : ApplyStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ApplyStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim s As System.Web.UI.WebControls.Style

instance.ApplyStyle(s)
C#
public void ApplyStyle(
   System.Web.UI.WebControls.Style s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


ApplyStyleSheetSkin Method

[image]
Intersoft WebDesktop Documentation
ApplyStyleSheetSkin Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : ApplyStyleSheetSkin Method

page

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub ApplyStyleSheetSkin( _
   ByVal page As System.Web.UI.Page _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim page As System.Web.UI.Page

instance.ApplyStyleSheetSkin(page)
C#
public virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page page
)

Parameters

page

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


CanUseWebResources Method

[image]
Intersoft WebDesktop Documentation
CanUseWebResources Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : CanUseWebResources Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CanUseWebResources() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As Boolean

value = instance.CanUseWebResources()
C#
public bool CanUseWebResources()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


CopyBaseAttributes Method

[image]
Intersoft WebDesktop Documentation
CopyBaseAttributes Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : CopyBaseAttributes Method

controlSrc

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyBaseAttributes( _
   ByVal controlSrc As System.Web.UI.WebControls.WebControl _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim controlSrc As System.Web.UI.WebControls.WebControl

instance.CopyBaseAttributes(controlSrc)
C#
public void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl controlSrc
)

Parameters

controlSrc

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.ISNetControl)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members
Overload List


DataBind Method

[image]
Intersoft WebDesktop Documentation
DataBind Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : DataBind Method

Glossary Item Box

Overload List

Overload | Description
DataBind | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


DataBind() Method

[image]
Intersoft WebDesktop Documentation
DataBind() Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : DataBind() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub DataBind()
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu

instance.DataBind()
C#
public virtual void DataBind()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


Dispose Method

[image]
Intersoft WebDesktop Documentation
Dispose Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : Dispose Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu

instance.Dispose()
C#
public virtual void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


FindControl Method

[image]
Intersoft WebDesktop Documentation
FindControl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : FindControl Method

Glossary Item Box

Overload List

Overload | Description
FindControl | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


FindControl(String) Method

[image]
Intersoft WebDesktop Documentation
FindControl(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : FindControl(String) Method

id

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function FindControl( _
   ByVal id As String _
) As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim id As String
Dim value As System.Web.UI.Control

value = instance.FindControl(id)
C#
public virtual System.Web.UI.Control FindControl(
   string id
)

Parameters

id

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


Focus Method

[image]
Intersoft WebDesktop Documentation
Focus Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : Focus Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Focus()
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu

instance.Focus()
C#
public virtual void Focus()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


ForceDisableXmlCompression Method

[image]
Intersoft WebDesktop Documentation
ForceDisableXmlCompression Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : ForceDisableXmlCompression Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ForceDisableXmlCompression()
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu

instance.ForceDisableXmlCompression()
C#
public void ForceDisableXmlCompression()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


GetCurrentControlLifeCycle Method

[image]
Intersoft WebDesktop Documentation
GetCurrentControlLifeCycle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : GetCurrentControlLifeCycle Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentControlLifeCycle() As ISNet.WebUI.ControlLifeCycle
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As ISNet.WebUI.ControlLifeCycle

value = instance.GetCurrentControlLifeCycle()
C#
public ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


GetCurrentTheme Method

[image]
Intersoft WebDesktop Documentation
GetCurrentTheme Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : GetCurrentTheme Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentTheme() As ISNet.WebUI.ThemeInfo
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As ISNet.WebUI.ThemeInfo

value = instance.GetCurrentTheme()
C#
public ISNet.WebUI.ThemeInfo GetCurrentTheme()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


GetFrameworkDataFolder Method

[image]
Intersoft WebDesktop Documentation
GetFrameworkDataFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : GetFrameworkDataFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkDataFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As String

value = instance.GetFrameworkDataFolder()
C#
public string GetFrameworkDataFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


GetFrameworkFolder Method

[image]
Intersoft WebDesktop Documentation
GetFrameworkFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : GetFrameworkFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As String

value = instance.GetFrameworkFolder()
C#
public string GetFrameworkFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


GetFrameworkVersion Method

[image]
Intersoft WebDesktop Documentation
GetFrameworkVersion Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : GetFrameworkVersion Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkVersion() As Version
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As Version

value = instance.GetFrameworkVersion()
C#
public Version GetFrameworkVersion()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


GetIntersoftFolder Method

[image]
Intersoft WebDesktop Documentation
GetIntersoftFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : GetIntersoftFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetIntersoftFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As String

value = instance.GetIntersoftFolder()
C#
public string GetIntersoftFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


GetLayoutFolder Method

[image]
Intersoft WebDesktop Documentation
GetLayoutFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : GetLayoutFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetLayoutFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As String

value = instance.GetLayoutFolder()
C#
public string GetLayoutFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


GetMenuItemRecursive Method

[image]
Intersoft WebDesktop Documentation
GetMenuItemRecursive Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : GetMenuItemRecursive Method

Glossary Item Box

Overload List

Overload | Description
GetMenuItemRecursive |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


WebContextMenu Class Methods

[image]
Intersoft WebDesktop Documentation
WebContextMenu Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebContextMenu Class

Glossary Item Box

For a list of all members of this type, see WebContextMenu members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetMenuItemRecursive |
Public Method | GetObjectData | Overridden.
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPostData | Overridden.
Public Method | LoadStructureFromXml | Overloaded.
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnMenuItemClicked |
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RaisePostBackEvent |
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RecreateChildControls |
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterScript | Overridden.
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveStructureToXml | Overloaded.
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SynchronizeTemplatesFrom |
Top

See Also

Reference

WebContextMenu Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Attaching ContextMenu to a Control

tasks

Showing ContextMenu Programmatically

Concepts

WebContextMenu Overview

concepts

Features
Visual Menu Builder
Building WebContextMenu Structure


GetMenuItemRecursive(String) Method

[image]
Intersoft WebDesktop Documentation
GetMenuItemRecursive(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : GetMenuItemRecursive(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetMenuItemRecursive( _
   ByVal name As String _
) As WebMenuItem
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim name As String
Dim value As WebMenuItem

value = instance.GetMenuItemRecursive(name)
C#
public WebMenuItem GetMenuItemRecursive(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


GetPostedXMLData Method

[image]
Intersoft WebDesktop Documentation
GetPostedXMLData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : GetPostedXMLData Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPostedXMLData() As String
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As String

value = instance.GetPostedXMLData()
C#
public string GetPostedXMLData()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


GetProductInfoKey Method

[image]
Intersoft WebDesktop Documentation
GetProductInfoKey Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : GetProductInfoKey Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductInfoKey() As String
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As String

value = instance.GetProductInfoKey()
C#
public string GetProductInfoKey()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


GetProductSimpleName Method

[image]
Intersoft WebDesktop Documentation
GetProductSimpleName Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : GetProductSimpleName Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductSimpleName() As String
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As String

value = instance.GetProductSimpleName()
C#
public string GetProductSimpleName()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


GetPropertyValue Method

[image]
Intersoft WebDesktop Documentation
GetPropertyValue Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : GetPropertyValue Method

defValue
propValue
webConfigKey

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPropertyValue( _
   ByVal defValue As String, _
   ByVal propValue As String, _
   ByVal webConfigKey As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim defValue As String
Dim propValue As String
Dim webConfigKey As String
Dim value As String

value = instance.GetPropertyValue(defValue, propValue, webConfigKey)
C#
public string GetPropertyValue(
   string defValue,
   string propValue,
   string webConfigKey
)

Parameters

defValue
propValue
webConfigKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


GetResourceStream Method

[image]
Intersoft WebDesktop Documentation
GetResourceStream Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : GetResourceStream Method

resourceUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetResourceStream( _
   ByVal resourceUrl As String _
) As System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim resourceUrl As String
Dim value As System.IO.Stream

value = instance.GetResourceStream(resourceUrl)
C#
public System.IO.Stream GetResourceStream(
   string resourceUrl
)

Parameters

resourceUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


GetRouteUrl Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : GetRouteUrl Method

Glossary Item Box

Overload List

Overload | Description
GetRouteUrl(Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(RouteValueDictionary) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,RouteValueDictionary) | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


GetRouteUrl(Object) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class > GetRouteUrl Method : GetRouteUrl(Object) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As Object _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim routeParameters As Object
Dim value As String

value = instance.GetRouteUrl(routeParameters)
C#
public string GetRouteUrl(
   object routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members
Overload List


GetRouteUrl(String,Object) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(String,Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class > GetRouteUrl Method : GetRouteUrl(String,Object) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As String, _
   ByVal routeParameters As Object _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim routeName As String
Dim routeParameters As Object
Dim value As String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public string GetRouteUrl(
   string routeName,
   object routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members
Overload List


GetRouteUrl(RouteValueDictionary) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(RouteValueDictionary) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class > GetRouteUrl Method : GetRouteUrl(RouteValueDictionary) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As String

value = instance.GetRouteUrl(routeParameters)
C#
public string GetRouteUrl(
   System.Web.Routing.RouteValueDictionary routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members
Overload List


GetRouteUrl(String,RouteValueDictionary) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(String,RouteValueDictionary) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class > GetRouteUrl Method : GetRouteUrl(String,RouteValueDictionary) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As String, _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim routeName As String
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public string GetRouteUrl(
   string routeName,
   System.Web.Routing.RouteValueDictionary routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members
Overload List


GetUniqueIDRelativeTo Method

[image]
Intersoft WebDesktop Documentation
GetUniqueIDRelativeTo Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : GetUniqueIDRelativeTo Method

control

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetUniqueIDRelativeTo( _
   ByVal control As System.Web.UI.Control _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim control As System.Web.UI.Control
Dim value As String

value = instance.GetUniqueIDRelativeTo(control)
C#
public string GetUniqueIDRelativeTo(
   System.Web.UI.Control control
)

Parameters

control

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


HasControls Method

[image]
Intersoft WebDesktop Documentation
HasControls Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : HasControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function HasControls() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As Boolean

value = instance.HasControls()
C#
public virtual bool HasControls()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


IsAtlasCallback Method

[image]
Intersoft WebDesktop Documentation
IsAtlasCallback Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : IsAtlasCallback Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsAtlasCallback() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As Boolean

value = instance.IsAtlasCallback()
C#
public bool IsAtlasCallback()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


IsBetaRelease Method

[image]
Intersoft WebDesktop Documentation
IsBetaRelease Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : IsBetaRelease Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsBetaRelease() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As Boolean

value = instance.IsBetaRelease()
C#
public bool IsBetaRelease()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


IsChromeBrowser Method

[image]
Intersoft WebDesktop Documentation
IsChromeBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : IsChromeBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsChromeBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As Boolean

value = instance.IsChromeBrowser()
C#
public bool IsChromeBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


IsFlyPostBackControl Method

[image]
Intersoft WebDesktop Documentation
IsFlyPostBackControl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : IsFlyPostBackControl Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackControl() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As Boolean

value = instance.IsFlyPostBackControl()
C#
public virtual bool IsFlyPostBackControl()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


IsFlyPostBackRequest Method

[image]
Intersoft WebDesktop Documentation
IsFlyPostBackRequest Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : IsFlyPostBackRequest Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackRequest() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As Boolean

value = instance.IsFlyPostBackRequest()
C#
public virtual bool IsFlyPostBackRequest()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


IsGeckoBasedBrowser Method

[image]
Intersoft WebDesktop Documentation
IsGeckoBasedBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : IsGeckoBasedBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoBasedBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As Boolean

value = instance.IsGeckoBasedBrowser()
C#
public bool IsGeckoBasedBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


IsGeckoVersion18 Method

[image]
Intersoft WebDesktop Documentation
IsGeckoVersion18 Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : IsGeckoVersion18 Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoVersion18() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As Boolean

value = instance.IsGeckoVersion18()
C#
public bool IsGeckoVersion18()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


IsInDesignMode Method

[image]
Intersoft WebDesktop Documentation
IsInDesignMode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : IsInDesignMode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInDesignMode() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As Boolean

value = instance.IsInDesignMode()
C#
public bool IsInDesignMode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


IsInternetExplorer8Browser Method

[image]
Intersoft WebDesktop Documentation
IsInternetExplorer8Browser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : IsInternetExplorer8Browser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorer8Browser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As Boolean

value = instance.IsInternetExplorer8Browser()
C#
public bool IsInternetExplorer8Browser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


IsInternetExplorerBrowser Method

[image]
Intersoft WebDesktop Documentation
IsInternetExplorerBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : IsInternetExplorerBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorerBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As Boolean

value = instance.IsInternetExplorerBrowser()
C#
public bool IsInternetExplorerBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


IsOperaBrowser Method

[image]
Intersoft WebDesktop Documentation
IsOperaBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : IsOperaBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsOperaBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As Boolean

value = instance.IsOperaBrowser()
C#
public bool IsOperaBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


IsSafariBrowser Method

[image]
Intersoft WebDesktop Documentation
IsSafariBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : IsSafariBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsSafariBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As Boolean

value = instance.IsSafariBrowser()
C#
public bool IsSafariBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


IsW3CStandardBrowser Method

[image]
Intersoft WebDesktop Documentation
IsW3CStandardBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : IsW3CStandardBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsW3CStandardBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As Boolean

value = instance.IsW3CStandardBrowser()
C#
public bool IsW3CStandardBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


LoadLayout Method

[image]
Intersoft WebDesktop Documentation
LoadLayout Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : LoadLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim settings As ISNet.WebUI.LayoutInfo

instance.LoadLayout(settings)
C#
public virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


LoadLayoutFromFile Method

[image]
Intersoft WebDesktop Documentation
LoadLayoutFromFile Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : LoadLayoutFromFile Method

filePath

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromFile( _
   ByVal filePath As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim filePath As String

instance.LoadLayoutFromFile(filePath)
C#
public virtual void LoadLayoutFromFile(
   string filePath
)

Parameters

filePath

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


LoadLayoutFromPredefinedName Method

[image]
Intersoft WebDesktop Documentation
LoadLayoutFromPredefinedName Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : LoadLayoutFromPredefinedName Method

predefinedName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromPredefinedName( _
   ByVal predefinedName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim predefinedName As String

instance.LoadLayoutFromPredefinedName(predefinedName)
C#
public virtual void LoadLayoutFromPredefinedName(
   string predefinedName
)

Parameters

predefinedName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


LoadLayoutFromStream Method

[image]
Intersoft WebDesktop Documentation
LoadLayoutFromStream Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : LoadLayoutFromStream Method

stream

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromStream( _
   ByVal stream As System.IO.Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim stream As System.IO.Stream

instance.LoadLayoutFromStream(stream)
C#
public virtual void LoadLayoutFromStream(
   System.IO.Stream stream
)

Parameters

stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


LoadPostData Method

[image]
Intersoft WebDesktop Documentation
LoadPostData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : LoadPostData Method

postDataKey
postCollection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function LoadPostData( _
   ByVal postDataKey As String, _
   ByVal postCollection As System.Collections.Specialized.NameValueCollection _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim postDataKey As String
Dim postCollection As System.Collections.Specialized.NameValueCollection
Dim value As Boolean

value = instance.LoadPostData(postDataKey, postCollection)
C#
public override bool LoadPostData(
   string postDataKey,
   System.Collections.Specialized.NameValueCollection postCollection
)

Parameters

postDataKey
postCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


LoadStructureFromXml Method

[image]
Intersoft WebDesktop Documentation
LoadStructureFromXml Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : LoadStructureFromXml Method

Glossary Item Box

Overload List

Overload | Description
LoadStructureFromXml(Stream) |
LoadStructureFromXml(String) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


LoadStructureFromXml(Stream) Method

[image]
Intersoft WebDesktop Documentation
LoadStructureFromXml(Stream) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class > LoadStructureFromXml Method : LoadStructureFromXml(Stream) Method

stream

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadStructureFromXml( _
   ByVal stream As System.IO.Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim stream As System.IO.Stream

instance.LoadStructureFromXml(stream)
C#
public void LoadStructureFromXml(
   System.IO.Stream stream
)

Parameters

stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members
Overload List


LoadStructureFromXml(String) Method

[image]
Intersoft WebDesktop Documentation
LoadStructureFromXml(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class > LoadStructureFromXml Method : LoadStructureFromXml(String) Method

fileName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadStructureFromXml( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim fileName As String

instance.LoadStructureFromXml(fileName)
C#
public void LoadStructureFromXml(
   string fileName
)

Parameters

fileName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members
Overload List


MergeStyle Method

[image]
Intersoft WebDesktop Documentation
MergeStyle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : MergeStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub MergeStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim s As System.Web.UI.WebControls.Style

instance.MergeStyle(s)
C#
public void MergeStyle(
   System.Web.UI.WebControls.Style s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


OnInfoChanged Method

[image]
Intersoft WebDesktop Documentation
OnInfoChanged Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : OnInfoChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnInfoChanged( _
   ByVal e As ISNet.WebUI.SynchronizeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim e As ISNet.WebUI.SynchronizeEventArgs

instance.OnInfoChanged(e)
C#
public void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


OnMenuItemClicked Method

[image]
Intersoft WebDesktop Documentation
OnMenuItemClicked Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : OnMenuItemClicked Method

menuItem

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function OnMenuItemClicked( _
   ByVal menuItem As WebMenuItem _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim menuItem As WebMenuItem
Dim value As Boolean

value = instance.OnMenuItemClicked(menuItem)
C#
public virtual bool OnMenuItemClicked(
   WebMenuItem menuItem
)

Parameters

menuItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


OnPreInitialize Method

[image]
Intersoft WebDesktop Documentation
OnPreInitialize Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : OnPreInitialize Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnPreInitialize()
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu

instance.OnPreInitialize()
C#
public virtual void OnPreInitialize()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


RaisePostBackEvent Method

[image]
Intersoft WebDesktop Documentation
RaisePostBackEvent Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : RaisePostBackEvent Method

eventArgument

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RaisePostBackEvent( _
   ByVal eventArgument As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim eventArgument As String

instance.RaisePostBackEvent(eventArgument)
C#
public void RaisePostBackEvent(
   string eventArgument
)

Parameters

eventArgument

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


RaisePostDataChangedEvent Method

[image]
Intersoft WebDesktop Documentation
RaisePostDataChangedEvent Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : RaisePostDataChangedEvent Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RaisePostDataChangedEvent()
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu

instance.RaisePostDataChangedEvent()
C#
public virtual void RaisePostDataChangedEvent()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


ReadWebConfigValue Method

[image]
Intersoft WebDesktop Documentation
ReadWebConfigValue Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : ReadWebConfigValue Method

key

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ReadWebConfigValue( _
   ByVal key As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim key As String
Dim value As String

value = instance.ReadWebConfigValue(key)
C#
public string ReadWebConfigValue(
   string key
)

Parameters

key

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


RecreateChildControls Method

[image]
Intersoft WebDesktop Documentation
RecreateChildControls Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : RecreateChildControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RecreateChildControls()
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu

instance.RecreateChildControls()
C#
public void RecreateChildControls()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


RegisterBoxSizing Method

[image]
Intersoft WebDesktop Documentation
RegisterBoxSizing Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : RegisterBoxSizing Method

Glossary Item Box

Overload List

Overload | Description
RegisterBoxSizing() | (Inherited from ISNet.WebUI.ISNetControl)
RegisterBoxSizing(Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


RegisterBoxSizing() Method

[image]
Intersoft WebDesktop Documentation
RegisterBoxSizing() Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class > RegisterBoxSizing Method : RegisterBoxSizing() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing()
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu

instance.RegisterBoxSizing()
C#
public void RegisterBoxSizing()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members
Overload List


RegisterBoxSizing(Boolean) Method

[image]
Intersoft WebDesktop Documentation
RegisterBoxSizing(Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class > RegisterBoxSizing Method : RegisterBoxSizing(Boolean) Method

forceAll

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing( _
   ByVal forceAll As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim forceAll As Boolean

instance.RegisterBoxSizing(forceAll)
C#
public void RegisterBoxSizing(
   bool forceAll
)

Parameters

forceAll

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members
Overload List


RegisterGlobalStyle Method

[image]
Intersoft WebDesktop Documentation
RegisterGlobalStyle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : RegisterGlobalStyle Method

style

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterGlobalStyle( _
   ByVal style As ISNet.WebUI.WebStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim style As ISNet.WebUI.WebStyle

instance.RegisterGlobalStyle(style)
C#
public void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle style
)

Parameters

style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


RegisterLink Method

[image]
Intersoft WebDesktop Documentation
RegisterLink Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : RegisterLink Method

name
url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterLink( _
   ByVal name As String, _
   ByVal url As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim name As String
Dim url As String

instance.RegisterLink(name, url)
C#
public void RegisterLink(
   string name,
   string url
)

Parameters

name
url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


RegisterOptimizedCssClasses Method

[image]
Intersoft WebDesktop Documentation
RegisterOptimizedCssClasses Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : RegisterOptimizedCssClasses Method

runtimeStyleOnly

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterOptimizedCssClasses( _
   ByVal runtimeStyleOnly As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim runtimeStyleOnly As Boolean

instance.RegisterOptimizedCssClasses(runtimeStyleOnly)
C#
public void RegisterOptimizedCssClasses(
   bool runtimeStyleOnly
)

Parameters

runtimeStyleOnly

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


RegisterPreloadImage Method

[image]
Intersoft WebDesktop Documentation
RegisterPreloadImage Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : RegisterPreloadImage Method

image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterPreloadImage( _
   ByVal image As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim image As String

instance.RegisterPreloadImage(image)
C#
public void RegisterPreloadImage(
   string image
)

Parameters

image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


RegisterScript Method

[image]
Intersoft WebDesktop Documentation
RegisterScript Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : RegisterScript Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub RegisterScript()
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu

instance.RegisterScript()
C#
public override void RegisterScript()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


RegisterSharePointHandler Method

[image]
Intersoft WebDesktop Documentation
RegisterSharePointHandler Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : RegisterSharePointHandler Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RegisterSharePointHandler()
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu

instance.RegisterSharePointHandler()
C#
public virtual void RegisterSharePointHandler()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


RenderBeginTag Method

[image]
Intersoft WebDesktop Documentation
RenderBeginTag Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : RenderBeginTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderBeginTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderBeginTag(writer)
C#
public virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


RenderControl Method

[image]
Intersoft WebDesktop Documentation
RenderControl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : RenderControl Method

Glossary Item Box

Overload List

Overload | Description
RenderControl | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


RenderControl(HtmlTextWriter) Method

[image]
Intersoft WebDesktop Documentation
RenderControl(HtmlTextWriter) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : RenderControl(HtmlTextWriter) Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderControl( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderControl(writer)
C#
public virtual void RenderControl(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


RenderEndTag Method

[image]
Intersoft WebDesktop Documentation
RenderEndTag Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : RenderEndTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub RenderEndTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderEndTag(writer)
C#
public override void RenderEndTag(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


ResolveClientUrl Method

[image]
Intersoft WebDesktop Documentation
ResolveClientUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : ResolveClientUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveClientUrl( _
   ByVal relativeUrl As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim relativeUrl As String
Dim value As String

value = instance.ResolveClientUrl(relativeUrl)
C#
public string ResolveClientUrl(
   string relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


ResolveImagePath Method

[image]
Intersoft WebDesktop Documentation
ResolveImagePath Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : ResolveImagePath Method

folder
image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveImagePath( _
   ByVal folder As String, _
   ByVal image As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim folder As String
Dim image As String
Dim value As String

value = instance.ResolveImagePath(folder, image)
C#
public string ResolveImagePath(
   string folder,
   string image
)

Parameters

folder
image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


ResolveRelativeURL Method

[image]
Intersoft WebDesktop Documentation
ResolveRelativeURL Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : ResolveRelativeURL Method

url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ResolveRelativeURL( _
   ByVal url As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim url As String
Dim value As String

value = instance.ResolveRelativeURL(url)
C#
public virtual string ResolveRelativeURL(
   string url
)

Parameters

url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


ResolveResourceUrl Method

[image]
Intersoft WebDesktop Documentation
ResolveResourceUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : ResolveResourceUrl Method

kind
defaultFolder
currentFolder
resourceName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveResourceUrl( _
   ByVal kind As ISNet.WebUI.ResourceKind, _
   ByVal defaultFolder As String, _
   ByVal currentFolder As String, _
   ByVal resourceName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim kind As ISNet.WebUI.ResourceKind
Dim defaultFolder As String
Dim currentFolder As String
Dim resourceName As String
Dim value As String

value = instance.ResolveResourceUrl(kind, defaultFolder, currentFolder, resourceName)
C#
public string ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   string defaultFolder,
   string currentFolder,
   string resourceName
)

Parameters

kind
defaultFolder
currentFolder
resourceName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


ResolveUrl Method

[image]
Intersoft WebDesktop Documentation
ResolveUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : ResolveUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveUrl( _
   ByVal relativeUrl As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim relativeUrl As String
Dim value As String

value = instance.ResolveUrl(relativeUrl)
C#
public string ResolveUrl(
   string relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


SaveLayout Method

[image]
Intersoft WebDesktop Documentation
SaveLayout Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : SaveLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim settings As ISNet.WebUI.LayoutInfo

instance.SaveLayout(settings)
C#
public virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


SaveLayoutToFile Method

[image]
Intersoft WebDesktop Documentation
SaveLayoutToFile Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : SaveLayoutToFile Method

filePath
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToFile( _
   ByVal filePath As String, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim filePath As String
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToFile(filePath, saveOptions)
C#
public virtual void SaveLayoutToFile(
   string filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

filePath
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


SaveLayoutToStream Method

[image]
Intersoft WebDesktop Documentation
SaveLayoutToStream Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : SaveLayoutToStream Method

stream
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToStream( _
   ByVal stream As System.IO.Stream, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim stream As System.IO.Stream
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToStream(stream, saveOptions)
C#
public virtual void SaveLayoutToStream(
   System.IO.Stream stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

stream
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


SaveStructureToXml Method

[image]
Intersoft WebDesktop Documentation
SaveStructureToXml Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : SaveStructureToXml Method

Glossary Item Box

Overload List

Overload | Description
SaveStructureToXml(String) |
SaveStructureToXml() |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


SaveStructureToXml(String) Method

[image]
Intersoft WebDesktop Documentation
SaveStructureToXml(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class > SaveStructureToXml Method : SaveStructureToXml(String) Method

fileName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub SaveStructureToXml( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim fileName As String

instance.SaveStructureToXml(fileName)
C#
public void SaveStructureToXml(
   string fileName
)

Parameters

fileName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members
Overload List


SaveStructureToXml() Method

[image]
Intersoft WebDesktop Documentation
SaveStructureToXml() Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class > SaveStructureToXml Method : SaveStructureToXml() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function SaveStructureToXml() As System.Xml.XmlDocument
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As System.Xml.XmlDocument

value = instance.SaveStructureToXml()
C#
public System.Xml.XmlDocument SaveStructureToXml()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members
Overload List


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


SetRenderMethodDelegate Method

[image]
Intersoft WebDesktop Documentation
SetRenderMethodDelegate Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : SetRenderMethodDelegate Method

renderMethod

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetRenderMethodDelegate( _
   ByVal renderMethod As System.Web.UI.RenderMethod _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim renderMethod As System.Web.UI.RenderMethod

instance.SetRenderMethodDelegate(renderMethod)
C#
public void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod renderMethod
)

Parameters

renderMethod

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


SetSessionTheme Method

[image]
Intersoft WebDesktop Documentation
SetSessionTheme Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : SetSessionTheme Method

themeInfo

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetSessionTheme( _
   ByVal themeInfo As ISNet.WebUI.ThemeInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim themeInfo As ISNet.WebUI.ThemeInfo

instance.SetSessionTheme(themeInfo)
C#
public void SetSessionTheme(
   ISNet.WebUI.ThemeInfo themeInfo
)

Parameters

themeInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


ShouldReturnJson Method

[image]
Intersoft WebDesktop Documentation
ShouldReturnJson Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : ShouldReturnJson Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ShouldReturnJson() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As Boolean

value = instance.ShouldReturnJson()
C#
public virtual bool ShouldReturnJson()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


SynchronizeTemplatesFrom Method

[image]
Intersoft WebDesktop Documentation
SynchronizeTemplatesFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : SynchronizeTemplatesFrom Method

source

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SynchronizeTemplatesFrom( _
   ByVal source As ISNet.WebUI.ISNetControl _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim source As ISNet.WebUI.ISNetControl

instance.SynchronizeTemplatesFrom(source)
C#
public void SynchronizeTemplatesFrom(
   ISNet.WebUI.ISNetControl source
)

Parameters

source

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


AccessKey Property

[image]
Intersoft WebDesktop Documentation
AccessKey Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : AccessKey Property

Glossary Item Box

Keyboard shortcut used by the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property AccessKey As String
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As String

instance.AccessKey = value

value = instance.AccessKey
C#
public virtual string AccessKey {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


WebContextMenu Class Properties

[image]
Intersoft WebDesktop Documentation
WebContextMenu Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebContextMenu Class

Glossary Item Box

For a list of all members of this type, see WebContextMenu members.

Public Properties

 | Name | Description
Public Property | AccessKey | Keyboard shortcut used by the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | AutoPostBack | Specifies whether the control should cause postback automatically when clicked.
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ClientSideEvents | Provides client side events for WebContextMenu control.
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ControlId | Gets or sets the server or client control ID of which context menu will be assigned to.
Public Property | Enabled | Enabled state of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableManagedTheming | Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to False, this control will not apply the style defined in Theme Architecture. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | Whether the control automatically saves its state for use in round-trips. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Height | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ImageSize | Gets or sets the default size of Image used in entire menu hierarchy.
Public Property | IntegratedTo | Specifies whether this menu control should be operated in Integration mode. When integrated, the menu will automatically inherit all styles defined in the Integration Object (whether it is PlaceHolderManager or DesktopManager).
Public Property | Items | Gets the collection containing WebMenuItem objects for this menu control.
Public Property | MenuStyleSettings | Contains styles and appearance definition for the Menu.
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RootMenu | Gets the WebMenu object which is RootMenu for this context menu control.
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden. Gets or sets the directory where all required scripts for the control are stored.
Public Property | SharedScriptDirectory | Overridden. Gets or sets the directory where all shared scripts for Intersoft controls are stored.
Public Property | ShowDelay | Gets or sets the amount of submenu show delay in milliseconds.
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ToolTip | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateItems | Gets or sets the items to be stored in view state storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | Gets or sets the server connection string for file server-based viewstate storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | Gets or sets the location to store the viewstate of this control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | Indicates whether the control is visible and rendered. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Width | The width of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | XmlCompressionEnabled | Specifies whether the Xml used for clientside state storage should be compressed. (Inherited from ISNet.WebUI.ISNetControl)
Top

See Also

Reference

WebContextMenu Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Attaching ContextMenu to a Control

tasks

Showing ContextMenu Programmatically

Concepts

WebContextMenu Overview

concepts

Features
Visual Menu Builder
Building WebContextMenu Structure


WebContextMenu Constructor

[image]
Intersoft WebDesktop Documentation
WebContextMenu Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : WebContextMenu Constructor

Glossary Item Box

Initializes a new instance of the WebContextMenu class.

Overload List

Overload | Description
WebContextMenu Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


AutoPostBack Property

[image]
Intersoft WebDesktop Documentation
AutoPostBack Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : AutoPostBack Property

Glossary Item Box

Specifies whether the control should cause postback automatically when clicked.

Syntax

Visual Basic (Declaration)
Public Property AutoPostBack As AutoPostBackMode
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As AutoPostBackMode

instance.AutoPostBack = value

value = instance.AutoPostBack
C#
public AutoPostBackMode AutoPostBack {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


ClientIDMode Property

[image]
Intersoft WebDesktop Documentation
ClientIDMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : ClientIDMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ClientIDMode As System.Web.UI.ClientIDMode
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As System.Web.UI.ClientIDMode

instance.ClientIDMode = value

value = instance.ClientIDMode
C#
public virtual System.Web.UI.ClientIDMode ClientIDMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


ClientSideEvents Property

[image]
Intersoft WebDesktop Documentation
ClientSideEvents Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : ClientSideEvents Property

Glossary Item Box

Provides client side events for WebContextMenu control.

Syntax

Visual Basic (Declaration)
Public Property ClientSideEvents As WebContextMenuClientSideEvents
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As WebContextMenuClientSideEvents

instance.ClientSideEvents = value

value = instance.ClientSideEvents
C#
public WebContextMenuClientSideEvents ClientSideEvents {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


ControlDataTransferFormat Property

[image]
Intersoft WebDesktop Documentation
ControlDataTransferFormat Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : ControlDataTransferFormat Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ControlDataTransferFormat As ISNet.WebUI.DataTransferFormat
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As ISNet.WebUI.DataTransferFormat

instance.ControlDataTransferFormat = value

value = instance.ControlDataTransferFormat
C#
public virtual ISNet.WebUI.DataTransferFormat ControlDataTransferFormat {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


ControlId Property

[image]
Intersoft WebDesktop Documentation
ControlId Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : ControlId Property

Glossary Item Box

Gets or sets the server or client control ID of which context menu will be assigned to.

Syntax

Visual Basic (Declaration)
Public Property ControlId As String
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As String

instance.ControlId = value

value = instance.ControlId
C#
public string ControlId {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


Enabled Property

[image]
Intersoft WebDesktop Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : Enabled Property

Glossary Item Box

Enabled state of the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property Enabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As Boolean

instance.Enabled = value

value = instance.Enabled
C#
public virtual bool Enabled {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


EnableManagedTheming Property

[image]
Intersoft WebDesktop Documentation
EnableManagedTheming Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : EnableManagedTheming Property

Glossary Item Box

Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to False, this control will not apply the style defined in Theme Architecture.

Syntax

Visual Basic (Declaration)
Public Overridable Property EnableManagedTheming As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As Boolean

instance.EnableManagedTheming = value

value = instance.EnableManagedTheming
C#
public virtual bool EnableManagedTheming {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


EnableTheming Property

[image]
Intersoft WebDesktop Documentation
EnableTheming Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : EnableTheming Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property EnableTheming As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As Boolean

instance.EnableTheming = value

value = instance.EnableTheming
C#
public virtual bool EnableTheming {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


EnableViewState Property

[image]
Intersoft WebDesktop Documentation
EnableViewState Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : EnableViewState Property

Glossary Item Box

Whether the control automatically saves its state for use in round-trips.

Syntax

Visual Basic (Declaration)
Public Overridable Property EnableViewState As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As Boolean

instance.EnableViewState = value

value = instance.EnableViewState
C#
public virtual bool EnableViewState {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


EnableWebResources Property

[image]
Intersoft WebDesktop Documentation
EnableWebResources Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : EnableWebResources Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property EnableWebResources As ISNet.WebUI.WebResourceType
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As ISNet.WebUI.WebResourceType

instance.EnableWebResources = value

value = instance.EnableWebResources
C#
public ISNet.WebUI.WebResourceType EnableWebResources {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


Height Property

[image]
Intersoft WebDesktop Documentation
Height Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : Height Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Height As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As System.Web.UI.WebControls.Unit

instance.Height = value

value = instance.Height
C#
public virtual System.Web.UI.WebControls.Unit Height {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


ID Property

[image]
Intersoft WebDesktop Documentation
ID Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : ID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ID As String
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As String

instance.ID = value

value = instance.ID
C#
public virtual string ID {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


ImageSize Property

[image]
Intersoft WebDesktop Documentation
ImageSize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : ImageSize Property

Glossary Item Box

Gets or sets the default size of Image used in entire menu hierarchy.

Syntax

Visual Basic (Declaration)
Public Property ImageSize As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As System.Drawing.Size

instance.ImageSize = value

value = instance.ImageSize
C#
public System.Drawing.Size ImageSize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


IntegratedTo Property

[image]
Intersoft WebDesktop Documentation
IntegratedTo Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : IntegratedTo Property

Glossary Item Box

Specifies whether this menu control should be operated in Integration mode. When integrated, the menu will automatically inherit all styles defined in the Integration Object (whether it is PlaceHolderManager or DesktopManager).

Syntax

Visual Basic (Declaration)
Public Property IntegratedTo As MenuIntegrationMode
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As MenuIntegrationMode

instance.IntegratedTo = value

value = instance.IntegratedTo
C#
public MenuIntegrationMode IntegratedTo {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


Items Property

[image]
Intersoft WebDesktop Documentation
Items Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : Items Property

Glossary Item Box

Gets the collection containing WebMenuItem objects for this menu control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Items As WebMenuItemCollection
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As WebMenuItemCollection

value = instance.Items
C#
public WebMenuItemCollection Items {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


MenuStyleSettings Property

[image]
Intersoft WebDesktop Documentation
MenuStyleSettings Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : MenuStyleSettings Property

Glossary Item Box

Contains styles and appearance definition for the Menu.

Syntax

Visual Basic (Declaration)
Public Property MenuStyleSettings As WebMenuStyles
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As WebMenuStyles

instance.MenuStyleSettings = value

value = instance.MenuStyleSettings
C#
public WebMenuStyles MenuStyleSettings {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


Page Property

[image]
Intersoft WebDesktop Documentation
Page Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : Page Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Page As System.Web.UI.Page
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As System.Web.UI.Page

instance.Page = value

value = instance.Page
C#
public virtual System.Web.UI.Page Page {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


RenderingMode Property

[image]
Intersoft WebDesktop Documentation
RenderingMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : RenderingMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property RenderingMode As ISNet.WebUI.RenderMode
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As ISNet.WebUI.RenderMode

instance.RenderingMode = value

value = instance.RenderingMode
C#
public virtual ISNet.WebUI.RenderMode RenderingMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


RootMenu Property

[image]
Intersoft WebDesktop Documentation
RootMenu Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : RootMenu Property

Glossary Item Box

Gets the WebMenu object which is RootMenu for this context menu control.

Syntax

Visual Basic (Declaration)
Public Property RootMenu As WebMenu
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As WebMenu

instance.RootMenu = value

value = instance.RootMenu
C#
public WebMenu RootMenu {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


RuntimeLicenseKey Property

[image]
Intersoft WebDesktop Documentation
RuntimeLicenseKey Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : RuntimeLicenseKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property RuntimeLicenseKey As String
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As String

instance.RuntimeLicenseKey = value

value = instance.RuntimeLicenseKey
C#
public virtual string RuntimeLicenseKey {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


ScriptDirectory Property

[image]
Intersoft WebDesktop Documentation
ScriptDirectory Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : ScriptDirectory Property

Glossary Item Box

Gets or sets the directory where all required scripts for the control are stored.

Syntax

Visual Basic (Declaration)
Public Overrides Property ScriptDirectory As String
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As String

instance.ScriptDirectory = value

value = instance.ScriptDirectory
C#
public override string ScriptDirectory {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


SharedScriptDirectory Property

[image]
Intersoft WebDesktop Documentation
SharedScriptDirectory Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : SharedScriptDirectory Property

Glossary Item Box

Gets or sets the directory where all shared scripts for Intersoft controls are stored.

Syntax

Visual Basic (Declaration)
Public Overrides Property SharedScriptDirectory As String
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As String

instance.SharedScriptDirectory = value

value = instance.SharedScriptDirectory
C#
public override string SharedScriptDirectory {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


ShowDelay Property

[image]
Intersoft WebDesktop Documentation
ShowDelay Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : ShowDelay Property

Glossary Item Box

Gets or sets the amount of submenu show delay in milliseconds.

Syntax

Visual Basic (Declaration)
Public Property ShowDelay As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As Integer

instance.ShowDelay = value

value = instance.ShowDelay
C#
public int ShowDelay {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


SkinID Property

[image]
Intersoft WebDesktop Documentation
SkinID Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : SkinID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property SkinID As String
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As String

instance.SkinID = value

value = instance.SkinID
C#
public virtual string SkinID {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


TabIndex Property

[image]
Intersoft WebDesktop Documentation
TabIndex Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : TabIndex Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property TabIndex As Short
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As Short

instance.TabIndex = value

value = instance.TabIndex
C#
public virtual short TabIndex {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


ToolTip Property

[image]
Intersoft WebDesktop Documentation
ToolTip Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : ToolTip Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ToolTip As String
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As String

instance.ToolTip = value

value = instance.ToolTip
C#
public virtual string ToolTip {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


ValidateRequestMode Property

[image]
Intersoft WebDesktop Documentation
ValidateRequestMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : ValidateRequestMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ValidateRequestMode As System.Web.UI.ValidateRequestMode
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As System.Web.UI.ValidateRequestMode

instance.ValidateRequestMode = value

value = instance.ValidateRequestMode
C#
public virtual System.Web.UI.ValidateRequestMode ValidateRequestMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


ViewStateItems Property

[image]
Intersoft WebDesktop Documentation
ViewStateItems Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : ViewStateItems Property

Glossary Item Box

Gets or sets the items to be stored in view state storage.

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateItems As ISNet.WebUI.ViewStateItem
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As ISNet.WebUI.ViewStateItem

instance.ViewStateItems = value

value = instance.ViewStateItems
C#
public virtual ISNet.WebUI.ViewStateItem ViewStateItems {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


ViewStateMode Property

[image]
Intersoft WebDesktop Documentation
ViewStateMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : ViewStateMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateMode As System.Web.UI.ViewStateMode
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As System.Web.UI.ViewStateMode

instance.ViewStateMode = value

value = instance.ViewStateMode
C#
public virtual System.Web.UI.ViewStateMode ViewStateMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


ViewStateServerConnection Property

[image]
Intersoft WebDesktop Documentation
ViewStateServerConnection Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : ViewStateServerConnection Property

Glossary Item Box

Gets or sets the server connection string for file server-based viewstate storage.

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateServerConnection As String
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As String

instance.ViewStateServerConnection = value

value = instance.ViewStateServerConnection
C#
public virtual string ViewStateServerConnection {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


ViewStateStorage Property

[image]
Intersoft WebDesktop Documentation
ViewStateStorage Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : ViewStateStorage Property

Glossary Item Box

Gets or sets the location to store the viewstate of this control.

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateStorage As ISNet.WebUI.StateCacheStorage
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As ISNet.WebUI.StateCacheStorage

instance.ViewStateStorage = value

value = instance.ViewStateStorage
C#
public virtual ISNet.WebUI.StateCacheStorage ViewStateStorage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


Visible Property

[image]
Intersoft WebDesktop Documentation
Visible Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : Visible Property

Glossary Item Box

Indicates whether the control is visible and rendered.

Syntax

Visual Basic (Declaration)
Public Overridable Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public virtual bool Visible {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


Width Property

[image]
Intersoft WebDesktop Documentation
Width Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : Width Property

Glossary Item Box

The width of the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property Width As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As System.Web.UI.WebControls.Unit

instance.Width = value

value = instance.Width
C#
public virtual System.Web.UI.WebControls.Unit Width {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


XmlCompressionEnabled Property

[image]
Intersoft WebDesktop Documentation
XmlCompressionEnabled Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : XmlCompressionEnabled Property

Glossary Item Box

Specifies whether the Xml used for clientside state storage should be compressed.

Syntax

Visual Basic (Declaration)
Public Overridable Property XmlCompressionEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim value As Boolean

instance.XmlCompressionEnabled = value

value = instance.XmlCompressionEnabled
C#
public virtual bool XmlCompressionEnabled {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


DataBinding Event

[image]
Intersoft WebDesktop Documentation
DataBinding Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : DataBinding Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event DataBinding As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim handler As EventHandler

AddHandler instance.DataBinding, handler
C#
public event EventHandler DataBinding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


Disposed Event

[image]
Intersoft WebDesktop Documentation
Disposed Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim handler As EventHandler

AddHandler instance.Disposed, handler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


Init Event

[image]
Intersoft WebDesktop Documentation
Init Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : Init Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Init As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim handler As EventHandler

AddHandler instance.Init, handler
C#
public event EventHandler Init

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


Load Event

[image]
Intersoft WebDesktop Documentation
Load Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : Load Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Load As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim handler As EventHandler

AddHandler instance.Load, handler
C#
public event EventHandler Load

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


WebContextMenu Class Events

[image]
Intersoft WebDesktop Documentation
WebContextMenu Class Events
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebContextMenu Class

Glossary Item Box

For a list of all members of this type, see WebContextMenu members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | MenuItemClicked | Occurs when menu item is clicked.
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebContextMenu Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Attaching ContextMenu to a Control

tasks

Showing ContextMenu Programmatically

Concepts

WebContextMenu Overview

concepts

Features
Visual Menu Builder
Building WebContextMenu Structure


MenuItemClicked Event

[image]
Intersoft WebDesktop Documentation
MenuItemClicked Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : MenuItemClicked Event

Glossary Item Box

Occurs when menu item is clicked.

Syntax

Visual Basic (Declaration)
Public Event MenuItemClicked As WebMenuItemClickedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim handler As WebMenuItemClickedEventHandler

AddHandler instance.MenuItemClicked, handler
C#
public event WebMenuItemClickedEventHandler MenuItemClicked

Event Data

The event handler receives an argument of type WebMenuItemClickedEventArgs containing data related to this event. The following WebMenuItemClickedEventArgs properties provide information specific to this event.

Property | Description
MenuItem | Gets the menu item on WebMenuItem clicked event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


PreInitialize Event

[image]
Intersoft WebDesktop Documentation
PreInitialize Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : PreInitialize Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event PreInitialize As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim handler As EventHandler

AddHandler instance.PreInitialize, handler
C#
public event EventHandler PreInitialize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


PreRender Event

[image]
Intersoft WebDesktop Documentation
PreRender Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : PreRender Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event PreRender As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim handler As EventHandler

AddHandler instance.PreRender, handler
C#
public event EventHandler PreRender

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


Unload Event

[image]
Intersoft WebDesktop Documentation
Unload Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenu Class : Unload Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Unload As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenu
Dim handler As EventHandler

AddHandler instance.Unload, handler
C#
public event EventHandler Unload

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenu Class
WebContextMenu Members


WebContextMenuClientSideEvents Class

[image]
Intersoft WebDesktop Documentation
WebContextMenuClientSideEvents Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebContextMenuClientSideEvents Class

Glossary Item Box

Javascript functions which invoked from client side in WebContextMenu.

Object Model

WebContextMenuClientSideEvents Class

Syntax

Visual Basic (Declaration)
Public Class WebContextMenuClientSideEvents
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenuClientSideEvents
C#
public class WebContextMenuClientSideEvents : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebDesktop.WebContextMenuClientSideEvents

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenuClientSideEvents Members
ISNet.WebUI.WebDesktop Namespace

Tasks

Handling Command Client Side Events


WebContextMenuClientSideEvents Class Members

[image]
Intersoft WebDesktop Documentation
WebContextMenuClientSideEvents Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebContextMenuClientSideEvents Class

Glossary Item Box

The following tables list the members exposed by WebContextMenuClientSideEvents.

Public Constructors

 | Name | Description
Public Constructor | WebContextMenuClientSideEvents Constructor |
Top

Public Properties

 | Name | Description
Public Property | OnInitialize |
Public Property | OnMenuItemClick |
Public Property | OnShowMenu |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebContextMenuClientSideEvents Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Handling Command Client Side Events


WebContextMenuClientSideEvents Constructor

[image]
Intersoft WebDesktop Documentation
WebContextMenuClientSideEvents Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenuClientSideEvents Class : WebContextMenuClientSideEvents Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebContextMenuClientSideEvents()
C#
public WebContextMenuClientSideEvents()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenuClientSideEvents Class
WebContextMenuClientSideEvents Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenuClientSideEvents Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenuClientSideEvents
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenuClientSideEvents Class
WebContextMenuClientSideEvents Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenuClientSideEvents Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenuClientSideEvents Class
WebContextMenuClientSideEvents Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenuClientSideEvents Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenuClientSideEvents
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenuClientSideEvents Class
WebContextMenuClientSideEvents Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenuClientSideEvents Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenuClientSideEvents
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenuClientSideEvents Class
WebContextMenuClientSideEvents Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenuClientSideEvents Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenuClientSideEvents
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenuClientSideEvents Class
WebContextMenuClientSideEvents Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenuClientSideEvents Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenuClientSideEvents
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenuClientSideEvents Class
WebContextMenuClientSideEvents Members


WebContextMenuClientSideEvents Class Methods

[image]
Intersoft WebDesktop Documentation
WebContextMenuClientSideEvents Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebContextMenuClientSideEvents Class

Glossary Item Box

For a list of all members of this type, see WebContextMenuClientSideEvents members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebContextMenuClientSideEvents Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Handling Command Client Side Events


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenuClientSideEvents Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenuClientSideEvents
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenuClientSideEvents Class
WebContextMenuClientSideEvents Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenuClientSideEvents Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenuClientSideEvents
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenuClientSideEvents Class
WebContextMenuClientSideEvents Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenuClientSideEvents Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenuClientSideEvents

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenuClientSideEvents Class
WebContextMenuClientSideEvents Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenuClientSideEvents Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenuClientSideEvents
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenuClientSideEvents Class
WebContextMenuClientSideEvents Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenuClientSideEvents Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenuClientSideEvents
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenuClientSideEvents Class
WebContextMenuClientSideEvents Members


WebContextMenuClientSideEvents Class Properties

[image]
Intersoft WebDesktop Documentation
WebContextMenuClientSideEvents Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebContextMenuClientSideEvents Class

Glossary Item Box

For a list of all members of this type, see WebContextMenuClientSideEvents members.

Public Properties

 | Name | Description
Public Property | OnInitialize |
Public Property | OnMenuItemClick |
Public Property | OnShowMenu |
Top

See Also

Reference

WebContextMenuClientSideEvents Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Handling Command Client Side Events


WebContextMenuClientSideEvents Constructor

[image]
Intersoft WebDesktop Documentation
WebContextMenuClientSideEvents Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenuClientSideEvents Class : WebContextMenuClientSideEvents Constructor

Glossary Item Box

Initializes a new instance of the WebContextMenuClientSideEvent class.

Overload List

Overload | Description
WebContextMenuClientSideEvents Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenuClientSideEvents Class
WebContextMenuClientSideEvents Members


OnInitialize Property

[image]
Intersoft WebDesktop Documentation
OnInitialize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenuClientSideEvents Class : OnInitialize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property OnInitialize As String
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenuClientSideEvents
Dim value As String

instance.OnInitialize = value

value = instance.OnInitialize
C#
public string OnInitialize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenuClientSideEvents Class
WebContextMenuClientSideEvents Members


OnMenuItemClick Property

[image]
Intersoft WebDesktop Documentation
OnMenuItemClick Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenuClientSideEvents Class : OnMenuItemClick Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property OnMenuItemClick As String
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenuClientSideEvents
Dim value As String

instance.OnMenuItemClick = value

value = instance.OnMenuItemClick
C#
public string OnMenuItemClick {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenuClientSideEvents Class
WebContextMenuClientSideEvents Members


OnShowMenu Property

[image]
Intersoft WebDesktop Documentation
OnShowMenu Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebContextMenuClientSideEvents Class : OnShowMenu Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property OnShowMenu As String
Visual Basic (Usage) Copy Code
Dim instance As WebContextMenuClientSideEvents
Dim value As String

instance.OnShowMenu = value

value = instance.OnShowMenu
C#
public string OnShowMenu {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContextMenuClientSideEvents Class
WebContextMenuClientSideEvents Members


WebDesktopClientSideEvents Class

[image]
Intersoft WebDesktop Documentation
WebDesktopClientSideEvents Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopClientSideEvents Class

Glossary Item Box

Javascript functions which invoked from client side in WebDesktop.

Object Model

WebDesktopClientSideEvents Class

Syntax

Visual Basic (Declaration)
Public Class WebDesktopClientSideEvents
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopClientSideEvents
C#
public class WebDesktopClientSideEvents : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Remarks

WebDesktop has ability to accommodate a broad range of scenarios through its extendable capability using client-side events. Using client side events developers can integrate their own algorithm or logic when specific events are occurred. WebDesktopManager provides up to 17 client events, from context menu, control initialize, shortcut selected and created to complete window events such as creation, moved, resized and more.

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebDesktop.WebDesktopClientSideEvents

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopClientSideEvents Members
ISNet.WebUI.WebDesktop Namespace

Concepts

Working with ClientSide Events

concepts

Advanced ClientSide Events


WebDesktopClientSideEvents Class Members

[image]
Intersoft WebDesktop Documentation
WebDesktopClientSideEvents Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopClientSideEvents Class

Glossary Item Box

The following tables list the members exposed by WebDesktopClientSideEvents.

Public Constructors

 | Name | Description
Public Constructor | WebDesktopClientSideEvents Constructor |
Top

Public Properties

 | Name | Description
Public Property | OnContextMenu | Gets or sets the javascript function to invoke when users right click on valid objects to display its context menu.
Public Property | OnInitialize | Gets or sets the javascript function to invoke when the control is in initialization phase.
Public Property | OnLoaderProgress | Gets or sets the javascript function to invoke when the DesktopManage's loaded is in progress,
Public Property | OnShortcutAfterLaunched | Gets or sets the javascript function to invoke when a shortcut has been launched.
Public Property | OnShortcutBeforeLaunched | Gets or Sets the javascript function to invoke when a shortcut is about to be launched.
Public Property | OnShortcutCreated | Gets or sets the javascript function to invoke when a shortcut is created on client side.
Public Property | OnShortcutSelected | Gets or sets the javascript funtion to invoke when a shortcut is selected by user.
Public Property | OnWindowAfterActivated | Gets or sets the javascript function to invoke after a window is activated.
Public Property | OnWindowAfterClosed | Gets or sets the javascript function to invoke after a window is closed.
Public Property | OnWindowBeforeActivated | Gets or sets the javascript function to invoke when a window is about to be activated.
Public Property | OnWindowBeforeClosed | Gets or sets the javascript function to invoke when a window is about to be closed.
Public Property | OnWindowCreated | Gets or sets the javascript function to invoke when a window is created at client side.
Public Property | OnWindowCreating | Gets or sets the javascript function to invoke when a window is in creation process.
Public Property | OnWindowDeactivated | Gets or sets the javascript function to invoke when a window has been deactivated.
Public Property | OnWindowMaximized | Gets or sets the javascript function to invoke when a window is maximized.
Public Property | OnWindowMinimized | Gets or sets the javascript function to invoke when a window is minimized.
Public Property | OnWindowMoved | Gets or sets the javascript function to invoke when a window is moved.
Public Property | OnWindowResized | Gets or sets the javascript function to invoke when a window is resized.
Public Property | OnWindowRestored | Gets or sets the javascript function to invoke when a window is restored.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebDesktopClientSideEvents Class
ISNet.WebUI.WebDesktop Namespace

Concepts

Working with ClientSide Events

concepts

Advanced ClientSide Events


WebDesktopClientSideEvents Constructor

[image]
Intersoft WebDesktop Documentation
WebDesktopClientSideEvents Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopClientSideEvents Class : WebDesktopClientSideEvents Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebDesktopClientSideEvents()
C#
public WebDesktopClientSideEvents()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopClientSideEvents Class
WebDesktopClientSideEvents Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopClientSideEvents Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopClientSideEvents
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopClientSideEvents Class
WebDesktopClientSideEvents Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopClientSideEvents Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopClientSideEvents Class
WebDesktopClientSideEvents Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopClientSideEvents Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopClientSideEvents
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopClientSideEvents Class
WebDesktopClientSideEvents Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopClientSideEvents Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopClientSideEvents
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopClientSideEvents Class
WebDesktopClientSideEvents Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopClientSideEvents Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopClientSideEvents
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopClientSideEvents Class
WebDesktopClientSideEvents Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopClientSideEvents Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopClientSideEvents
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopClientSideEvents Class
WebDesktopClientSideEvents Members


WebDesktopClientSideEvents Class Methods

[image]
Intersoft WebDesktop Documentation
WebDesktopClientSideEvents Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopClientSideEvents Class

Glossary Item Box

For a list of all members of this type, see WebDesktopClientSideEvents members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebDesktopClientSideEvents Class
ISNet.WebUI.WebDesktop Namespace

Concepts

Working with ClientSide Events

concepts

Advanced ClientSide Events


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopClientSideEvents Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopClientSideEvents
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopClientSideEvents Class
WebDesktopClientSideEvents Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopClientSideEvents Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopClientSideEvents
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopClientSideEvents Class
WebDesktopClientSideEvents Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopClientSideEvents Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopClientSideEvents

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopClientSideEvents Class
WebDesktopClientSideEvents Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopClientSideEvents Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopClientSideEvents
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopClientSideEvents Class
WebDesktopClientSideEvents Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopClientSideEvents Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopClientSideEvents
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopClientSideEvents Class
WebDesktopClientSideEvents Members


WebDesktopClientSideEvents Class Properties

[image]
Intersoft WebDesktop Documentation
WebDesktopClientSideEvents Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopClientSideEvents Class

Glossary Item Box

For a list of all members of this type, see WebDesktopClientSideEvents members.

Public Properties

 | Name | Description
Public Property | OnContextMenu | Gets or sets the javascript function to invoke when users right click on valid objects to display its context menu.
Public Property | OnInitialize | Gets or sets the javascript function to invoke when the control is in initialization phase.
Public Property | OnLoaderProgress | Gets or sets the javascript function to invoke when the DesktopManage's loaded is in progress,
Public Property | OnShortcutAfterLaunched | Gets or sets the javascript function to invoke when a shortcut has been launched.
Public Property | OnShortcutBeforeLaunched | Gets or Sets the javascript function to invoke when a shortcut is about to be launched.
Public Property | OnShortcutCreated | Gets or sets the javascript function to invoke when a shortcut is created on client side.
Public Property | OnShortcutSelected | Gets or sets the javascript funtion to invoke when a shortcut is selected by user.
Public Property | OnWindowAfterActivated | Gets or sets the javascript function to invoke after a window is activated.
Public Property | OnWindowAfterClosed | Gets or sets the javascript function to invoke after a window is closed.
Public Property | OnWindowBeforeActivated | Gets or sets the javascript function to invoke when a window is about to be activated.
Public Property | OnWindowBeforeClosed | Gets or sets the javascript function to invoke when a window is about to be closed.
Public Property | OnWindowCreated | Gets or sets the javascript function to invoke when a window is created at client side.
Public Property | OnWindowCreating | Gets or sets the javascript function to invoke when a window is in creation process.
Public Property | OnWindowDeactivated | Gets or sets the javascript function to invoke when a window has been deactivated.
Public Property | OnWindowMaximized | Gets or sets the javascript function to invoke when a window is maximized.
Public Property | OnWindowMinimized | Gets or sets the javascript function to invoke when a window is minimized.
Public Property | OnWindowMoved | Gets or sets the javascript function to invoke when a window is moved.
Public Property | OnWindowResized | Gets or sets the javascript function to invoke when a window is resized.
Public Property | OnWindowRestored | Gets or sets the javascript function to invoke when a window is restored.
Top

See Also

Reference

WebDesktopClientSideEvents Class
ISNet.WebUI.WebDesktop Namespace

Concepts

Working with ClientSide Events

concepts

Advanced ClientSide Events


WebDesktopClientSideEvents Constructor

[image]
Intersoft WebDesktop Documentation
WebDesktopClientSideEvents Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopClientSideEvents Class : WebDesktopClientSideEvents Constructor

Glossary Item Box

Initializes a new instance of the WebDesktopClientSideEvents class.

Overload List

Overload | Description
WebDesktopClientSideEvents Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopClientSideEvents Class
WebDesktopClientSideEvents Members


OnContextMenu Property

[image]
Intersoft WebDesktop Documentation
OnContextMenu Property
See Also Example Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopClientSideEvents Class : OnContextMenu Property

Glossary Item Box

Gets or sets the javascript function to invoke when users right click on valid objects to display its context menu.

Syntax

Visual Basic (Declaration)
Public Property OnContextMenu As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopClientSideEvents
Dim value As String

instance.OnContextMenu = value

value = instance.OnContextMenu
C#
public string OnContextMenu {get; set;}

Remarks

WebDesktopManager provides a solid Web User Interface platform engineered with extensibility in mind. In the Context Menu area, developers can extend the menu further to meet application-specific scenarios.

Using OnContextMenu client side event you can handle and put your codes to perform additional logics to the menu in the context.

Example

The following codes demonstrate how to extend the window's system context menu by adding a new About menu item.
C# Copy Code
function DesktopManager_OnContextMenu(controlId, objectType, contextObject, menu)
{
    if (objectType == "Window")
        {
                if (menu.Items.GetNamedItem("mnuAbout") == null)
                    menu.Items.Add( new WebMenuItem("mnuAbout", "About...") );
    }
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopClientSideEvents Class
WebDesktopClientSideEvents Members

Concepts

Context Menu


OnInitialize Property

[image]
Intersoft WebDesktop Documentation
OnInitialize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopClientSideEvents Class : OnInitialize Property

Glossary Item Box

Gets or sets the javascript function to invoke when the control is in initialization phase.

Syntax

Visual Basic (Declaration)
Public Property OnInitialize As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopClientSideEvents
Dim value As String

instance.OnInitialize = value

value = instance.OnInitialize
C#
public string OnInitialize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopClientSideEvents Class
WebDesktopClientSideEvents Members

Tasks

Obtaining Desktop Structure at Client Side


OnLoaderProgress Property

[image]
Intersoft WebDesktop Documentation
OnLoaderProgress Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopClientSideEvents Class : OnLoaderProgress Property

Glossary Item Box

Gets or sets the javascript function to invoke when the DesktopManage's loaded is in progress,

Syntax

Visual Basic (Declaration)
Public Property OnLoaderProgress As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopClientSideEvents
Dim value As String

instance.OnLoaderProgress = value

value = instance.OnLoaderProgress
C#
public string OnLoaderProgress {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopClientSideEvents Class
WebDesktopClientSideEvents Members


OnShortcutAfterLaunched Property

[image]
Intersoft WebDesktop Documentation
OnShortcutAfterLaunched Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopClientSideEvents Class : OnShortcutAfterLaunched Property

Glossary Item Box

Gets or sets the javascript function to invoke when a shortcut has been launched.

Syntax

Visual Basic (Declaration)
Public Property OnShortcutAfterLaunched As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopClientSideEvents
Dim value As String

instance.OnShortcutAfterLaunched = value

value = instance.OnShortcutAfterLaunched
C#
public string OnShortcutAfterLaunched {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopClientSideEvents Class
WebDesktopClientSideEvents Members


OnShortcutBeforeLaunched Property

[image]
Intersoft WebDesktop Documentation
OnShortcutBeforeLaunched Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopClientSideEvents Class : OnShortcutBeforeLaunched Property

Glossary Item Box

Gets or Sets the javascript function to invoke when a shortcut is about to be launched.

Syntax

Visual Basic (Declaration)
Public Property OnShortcutBeforeLaunched As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopClientSideEvents
Dim value As String

instance.OnShortcutBeforeLaunched = value

value = instance.OnShortcutBeforeLaunched
C#
public string OnShortcutBeforeLaunched {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopClientSideEvents Class
WebDesktopClientSideEvents Members


OnShortcutCreated Property

[image]
Intersoft WebDesktop Documentation
OnShortcutCreated Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopClientSideEvents Class : OnShortcutCreated Property

Glossary Item Box

Gets or sets the javascript function to invoke when a shortcut is created on client side.

Syntax

Visual Basic (Declaration)
Public Property OnShortcutCreated As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopClientSideEvents
Dim value As String

instance.OnShortcutCreated = value

value = instance.OnShortcutCreated
C#
public string OnShortcutCreated {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopClientSideEvents Class
WebDesktopClientSideEvents Members

Concepts

Working with ClientSide Events


OnShortcutSelected Property

[image]
Intersoft WebDesktop Documentation
OnShortcutSelected Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopClientSideEvents Class : OnShortcutSelected Property

Glossary Item Box

Gets or sets the javascript funtion to invoke when a shortcut is selected by user.

Syntax

Visual Basic (Declaration)
Public Property OnShortcutSelected As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopClientSideEvents
Dim value As String

instance.OnShortcutSelected = value

value = instance.OnShortcutSelected
C#
public string OnShortcutSelected {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopClientSideEvents Class
WebDesktopClientSideEvents Members


OnWindowAfterActivated Property

[image]
Intersoft WebDesktop Documentation
OnWindowAfterActivated Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopClientSideEvents Class : OnWindowAfterActivated Property

Glossary Item Box

Gets or sets the javascript function to invoke after a window is activated.

Syntax

Visual Basic (Declaration)
Public Property OnWindowAfterActivated As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopClientSideEvents
Dim value As String

instance.OnWindowAfterActivated = value

value = instance.OnWindowAfterActivated
C#
public string OnWindowAfterActivated {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopClientSideEvents Class
WebDesktopClientSideEvents Members


OnWindowAfterClosed Property

[image]
Intersoft WebDesktop Documentation
OnWindowAfterClosed Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopClientSideEvents Class : OnWindowAfterClosed Property

Glossary Item Box

Gets or sets the javascript function to invoke after a window is closed.

Syntax

Visual Basic (Declaration)
Public Property OnWindowAfterClosed As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopClientSideEvents
Dim value As String

instance.OnWindowAfterClosed = value

value = instance.OnWindowAfterClosed
C#
public string OnWindowAfterClosed {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopClientSideEvents Class
WebDesktopClientSideEvents Members


OnWindowBeforeActivated Property

[image]
Intersoft WebDesktop Documentation
OnWindowBeforeActivated Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopClientSideEvents Class : OnWindowBeforeActivated Property

Glossary Item Box

Gets or sets the javascript function to invoke when a window is about to be activated.

Syntax

Visual Basic (Declaration)
Public Property OnWindowBeforeActivated As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopClientSideEvents
Dim value As String

instance.OnWindowBeforeActivated = value

value = instance.OnWindowBeforeActivated
C#
public string OnWindowBeforeActivated {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopClientSideEvents Class
WebDesktopClientSideEvents Members


OnWindowBeforeClosed Property

[image]
Intersoft WebDesktop Documentation
OnWindowBeforeClosed Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopClientSideEvents Class : OnWindowBeforeClosed Property

Glossary Item Box

Gets or sets the javascript function to invoke when a window is about to be closed.

Syntax

Visual Basic (Declaration)
Public Property OnWindowBeforeClosed As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopClientSideEvents
Dim value As String

instance.OnWindowBeforeClosed = value

value = instance.OnWindowBeforeClosed
C#
public string OnWindowBeforeClosed {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopClientSideEvents Class
WebDesktopClientSideEvents Members


OnWindowCreated Property

[image]
Intersoft WebDesktop Documentation
OnWindowCreated Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopClientSideEvents Class : OnWindowCreated Property

Glossary Item Box

Gets or sets the javascript function to invoke when a window is created at client side.

Syntax

Visual Basic (Declaration)
Public Property OnWindowCreated As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopClientSideEvents
Dim value As String

instance.OnWindowCreated = value

value = instance.OnWindowCreated
C#
public string OnWindowCreated {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopClientSideEvents Class
WebDesktopClientSideEvents Members


OnWindowCreating Property

[image]
Intersoft WebDesktop Documentation
OnWindowCreating Property
See Also Example Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopClientSideEvents Class : OnWindowCreating Property

Glossary Item Box

Gets or sets the javascript function to invoke when a window is in creation process.

Syntax

Visual Basic (Declaration)
Public Property OnWindowCreating As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopClientSideEvents
Dim value As String

instance.OnWindowCreating = value

value = instance.OnWindowCreating
C#
public string OnWindowCreating {get; set;}

Example

The following codes show you how to handle OnWindowCreating event to manipulate window settings before the window is created.
C# Copy Code
function WebDesktopManager1_OnWindowCreating(id, win)
{
    if (win.Name == "wndContactManagement")
    {
        win.Size.Width = 780;
        win.Size.Height = 450;
        win.AllowResize = "No";
        win.AllowMaximize = "No";
    }
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopClientSideEvents Class
WebDesktopClientSideEvents Members

Concepts

Advanced ClientSide Events

concepts

Working with ClientSide Events


OnWindowDeactivated Property

[image]
Intersoft WebDesktop Documentation
OnWindowDeactivated Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopClientSideEvents Class : OnWindowDeactivated Property

Glossary Item Box

Gets or sets the javascript function to invoke when a window has been deactivated.

Syntax

Visual Basic (Declaration)
Public Property OnWindowDeactivated As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopClientSideEvents
Dim value As String

instance.OnWindowDeactivated = value

value = instance.OnWindowDeactivated
C#
public string OnWindowDeactivated {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopClientSideEvents Class
WebDesktopClientSideEvents Members


OnWindowMaximized Property

[image]
Intersoft WebDesktop Documentation
OnWindowMaximized Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopClientSideEvents Class : OnWindowMaximized Property

Glossary Item Box

Gets or sets the javascript function to invoke when a window is maximized.

Syntax

Visual Basic (Declaration)
Public Property OnWindowMaximized As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopClientSideEvents
Dim value As String

instance.OnWindowMaximized = value

value = instance.OnWindowMaximized
C#
public string OnWindowMaximized {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopClientSideEvents Class
WebDesktopClientSideEvents Members


OnWindowMinimized Property

[image]
Intersoft WebDesktop Documentation
OnWindowMinimized Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopClientSideEvents Class : OnWindowMinimized Property

Glossary Item Box

Gets or sets the javascript function to invoke when a window is minimized.

Syntax

Visual Basic (Declaration)
Public Property OnWindowMinimized As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopClientSideEvents
Dim value As String

instance.OnWindowMinimized = value

value = instance.OnWindowMinimized
C#
public string OnWindowMinimized {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopClientSideEvents Class
WebDesktopClientSideEvents Members


OnWindowMoved Property

[image]
Intersoft WebDesktop Documentation
OnWindowMoved Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopClientSideEvents Class : OnWindowMoved Property

Glossary Item Box

Gets or sets the javascript function to invoke when a window is moved.

Syntax

Visual Basic (Declaration)
Public Property OnWindowMoved As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopClientSideEvents
Dim value As String

instance.OnWindowMoved = value

value = instance.OnWindowMoved
C#
public string OnWindowMoved {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopClientSideEvents Class
WebDesktopClientSideEvents Members


OnWindowResized Property

[image]
Intersoft WebDesktop Documentation
OnWindowResized Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopClientSideEvents Class : OnWindowResized Property

Glossary Item Box

Gets or sets the javascript function to invoke when a window is resized.

Syntax

Visual Basic (Declaration)
Public Property OnWindowResized As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopClientSideEvents
Dim value As String

instance.OnWindowResized = value

value = instance.OnWindowResized
C#
public string OnWindowResized {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopClientSideEvents Class
WebDesktopClientSideEvents Members


OnWindowRestored Property

[image]
Intersoft WebDesktop Documentation
OnWindowRestored Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopClientSideEvents Class : OnWindowRestored Property

Glossary Item Box

Gets or sets the javascript function to invoke when a window is restored.

Syntax

Visual Basic (Declaration)
Public Property OnWindowRestored As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopClientSideEvents
Dim value As String

instance.OnWindowRestored = value

value = instance.OnWindowRestored
C#
public string OnWindowRestored {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopClientSideEvents Class
WebDesktopClientSideEvents Members


WebDesktopImagesSettings Class

[image]
Intersoft WebDesktop Documentation
WebDesktopImagesSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopImagesSettings Class

Glossary Item Box

A collection of images settings for WebDesktopWindow object.

Object Model

WebDesktopImagesSettings Class

Syntax

Visual Basic (Declaration)
Public Class WebDesktopImagesSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopImagesSettings
C#
public class WebDesktopImagesSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Remarks

Using WebDesktopImagesSettings you can customize the images configuration, such as ButtonCenterActive, ButtonCenterOver, CaptionCenterActive, etc.

WebDesktopManager supports ComplexImages border type in addition to the Simple type. The ComplexImages border type enables you to create great looking visual style of today popular's desktop in high details. You can use transparent image format such as GIF to create round-corner borders or use PNG format to create translucent title bars.

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebDesktop.WebDesktopImagesSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopImagesSettings Members
ISNet.WebUI.WebDesktop Namespace

Tasks

Configuring Window to use Complex Images

Concepts

Window


WebDesktopImagesSettings Class Members

[image]
Intersoft WebDesktop Documentation
WebDesktopImagesSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopImagesSettings Class

Glossary Item Box

The following tables list the members exposed by WebDesktopImagesSettings.

Public Constructors

 | Name | Description
Public Constructor | WebDesktopImagesSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | ButtonCenterActive | Gets or sets the button center active image.
Public Property | ButtonCenterInactive | Gets or sets the button center inactive image.
Public Property | ButtonCenterOver | Gets or sets the button center over image.
Public Property | ButtonLeftActive | Gets or sets the button left active image.
Public Property | ButtonLeftInactive | Gets or sets the button left inactive image.
Public Property | ButtonLeftOver | Gets or sets the button left over image.
Public Property | ButtonRightActive | Gets or sets the button right active image.
Public Property | ButtonRightInactive | Gets or sets the button right inactive image.
Public Property | ButtonRightOver | Gets or sets the button right over image.
Public Property | CaptionCenterActive | Gets or sets the center image part for the active Caption. This property is applicable when BorderType is set to ComplexImages.
Public Property | CaptionCenterInactive | Gets or sets the center image part for the inactive Caption. This property is applicable when BorderType is set to ComplexImages.
Public Property | CaptionLeftActive | Gets or sets the left image part for the active Caption. This property is applicable when BorderType is set to ComplexImages.
Public Property | CaptionLeftInactive | Gets or sets the left image part for the inactive Caption. This property is applicable when BorderType is set to ComplexImages.
Public Property | CaptionRightActive | Gets or sets the right image part for the active Caption. This property is applicable when BorderType is set to ComplexImages.
Public Property | CaptionRightInactive | Gets or sets the right image part for the inactive Caption. This property is applicable when BorderType is set to ComplexImages.
Public Property | CloseActive | Gets or sets the close image for Window.
Public Property | CloseDown | Gets or sets the pressed image for Close.
Public Property | CloseInactive | Gets or sets the close inactive image.
Public Property | CloseOver | Get or sets the close over image.
Public Property | ControlBox | Gets or sets the default controlbox image for Window.
Public Property | InProgress | Gets or sets the image shown during IFrame loading.
Public Property | MaximizeActive | Gets or sets the maximize image for Window.
Public Property | MaximizeDown | Gets or sets the pressed image for Maximize.
Public Property | MaximizeInactive | Gets or sets the maximize inactive image.
Public Property | MaximizeOver | Gets or sets the maximize over image.
Public Property | MinimizeActive | Gets or sets the minimize image for Window.
Public Property | MinimizeDown | Gets or sets the pressed image for Minimize.
Public Property | MinimizeInactive | Gets or sets the minimize inactive image.
Public Property | MinimizeOver | Gets or sets the minimize over image.
Public Property | OverlayBackground |
Public Property | RestoreActive | Gets or sets the restore image for Window.
Public Property | RestoreDown | Gets or sets the pressed image for Restore.
Public Property | RestoreInactive | Gets or sets the restore inactive image.
Public Property | RestoreOver | Gets or sets the restore over image.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebDesktopImagesSettings Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Configuring Window to use Complex Images

Concepts

Window


WebDesktopImagesSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebDesktopImagesSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopImagesSettings Class : WebDesktopImagesSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebDesktopImagesSettings()
C#
public WebDesktopImagesSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopImagesSettings Class
WebDesktopImagesSettings Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopImagesSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopImagesSettings
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopImagesSettings Class
WebDesktopImagesSettings Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopImagesSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopImagesSettings Class
WebDesktopImagesSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopImagesSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopImagesSettings
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopImagesSettings Class
WebDesktopImagesSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopImagesSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopImagesSettings
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopImagesSettings Class
WebDesktopImagesSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopImagesSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopImagesSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopImagesSettings Class
WebDesktopImagesSettings Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopImagesSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopImagesSettings
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopImagesSettings Class
WebDesktopImagesSettings Members


WebDesktopImagesSettings Class Methods

[image]
Intersoft WebDesktop Documentation
WebDesktopImagesSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopImagesSettings Class

Glossary Item Box

For a list of all members of this type, see WebDesktopImagesSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebDesktopImagesSettings Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Configuring Window to use Complex Images

Concepts

Window


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopImagesSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopImagesSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopImagesSettings Class
WebDesktopImagesSettings Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopImagesSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopImagesSettings
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopImagesSettings Class
WebDesktopImagesSettings Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopImagesSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopImagesSettings

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopImagesSettings Class
WebDesktopImagesSettings Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopImagesSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopImagesSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopImagesSettings Class
WebDesktopImagesSettings Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopImagesSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopImagesSettings
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopImagesSettings Class
WebDesktopImagesSettings Members


WebDesktopImagesSettings Class Properties

[image]
Intersoft WebDesktop Documentation
WebDesktopImagesSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopImagesSettings Class

Glossary Item Box

For a list of all members of this type, see WebDesktopImagesSettings members.

Public Properties

 | Name | Description
Public Property | ButtonCenterActive | Gets or sets the button center active image.
Public Property | ButtonCenterInactive | Gets or sets the button center inactive image.
Public Property | ButtonCenterOver | Gets or sets the button center over image.
Public Property | ButtonLeftActive | Gets or sets the button left active image.
Public Property | ButtonLeftInactive | Gets or sets the button left inactive image.
Public Property | ButtonLeftOver | Gets or sets the button left over image.
Public Property | ButtonRightActive | Gets or sets the button right active image.
Public Property | ButtonRightInactive | Gets or sets the button right inactive image.
Public Property | ButtonRightOver | Gets or sets the button right over image.
Public Property | CaptionCenterActive | Gets or sets the center image part for the active Caption. This property is applicable when BorderType is set to ComplexImages.
Public Property | CaptionCenterInactive | Gets or sets the center image part for the inactive Caption. This property is applicable when BorderType is set to ComplexImages.
Public Property | CaptionLeftActive | Gets or sets the left image part for the active Caption. This property is applicable when BorderType is set to ComplexImages.
Public Property | CaptionLeftInactive | Gets or sets the left image part for the inactive Caption. This property is applicable when BorderType is set to ComplexImages.
Public Property | CaptionRightActive | Gets or sets the right image part for the active Caption. This property is applicable when BorderType is set to ComplexImages.
Public Property | CaptionRightInactive | Gets or sets the right image part for the inactive Caption. This property is applicable when BorderType is set to ComplexImages.
Public Property | CloseActive | Gets or sets the close image for Window.
Public Property | CloseDown | Gets or sets the pressed image for Close.
Public Property | CloseInactive | Gets or sets the close inactive image.
Public Property | CloseOver | Get or sets the close over image.
Public Property | ControlBox | Gets or sets the default controlbox image for Window.
Public Property | InProgress | Gets or sets the image shown during IFrame loading.
Public Property | MaximizeActive | Gets or sets the maximize image for Window.
Public Property | MaximizeDown | Gets or sets the pressed image for Maximize.
Public Property | MaximizeInactive | Gets or sets the maximize inactive image.
Public Property | MaximizeOver | Gets or sets the maximize over image.
Public Property | MinimizeActive | Gets or sets the minimize image for Window.
Public Property | MinimizeDown | Gets or sets the pressed image for Minimize.
Public Property | MinimizeInactive | Gets or sets the minimize inactive image.
Public Property | MinimizeOver | Gets or sets the minimize over image.
Public Property | OverlayBackground |
Public Property | RestoreActive | Gets or sets the restore image for Window.
Public Property | RestoreDown | Gets or sets the pressed image for Restore.
Public Property | RestoreInactive | Gets or sets the restore inactive image.
Public Property | RestoreOver | Gets or sets the restore over image.
Top

See Also

Reference

WebDesktopImagesSettings Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Configuring Window to use Complex Images

Concepts

Window


WebDesktopImagesSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebDesktopImagesSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopImagesSettings Class : WebDesktopImagesSettings Constructor

Glossary Item Box

Initializes a new instance of the WebDesktopImagesSettings class.

Overload List

Overload | Description
WebDesktopImagesSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopImagesSettings Class
WebDesktopImagesSettings Members


ButtonCenterActive Property

[image]
Intersoft WebDesktop Documentation
ButtonCenterActive Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopImagesSettings Class : ButtonCenterActive Property

Glossary Item Box

Gets or sets the button center active image.

Syntax

Visual Basic (Declaration)
Public Property ButtonCenterActive As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopImagesSettings
Dim value As String

instance.ButtonCenterActive = value

value = instance.ButtonCenterActive
C#
public string ButtonCenterActive {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopImagesSettings Class
WebDesktopImagesSettings Members


ButtonCenterInactive Property

[image]
Intersoft WebDesktop Documentation
ButtonCenterInactive Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopImagesSettings Class : ButtonCenterInactive Property

Glossary Item Box

Gets or sets the button center inactive image.

Syntax

Visual Basic (Declaration)
Public Property ButtonCenterInactive As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopImagesSettings
Dim value As String

instance.ButtonCenterInactive = value

value = instance.ButtonCenterInactive
C#
public string ButtonCenterInactive {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopImagesSettings Class
WebDesktopImagesSettings Members


ButtonCenterOver Property

[image]
Intersoft WebDesktop Documentation
ButtonCenterOver Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopImagesSettings Class : ButtonCenterOver Property

Glossary Item Box

Gets or sets the button center over image.

Syntax

Visual Basic (Declaration)
Public Property ButtonCenterOver As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopImagesSettings
Dim value As String

instance.ButtonCenterOver = value

value = instance.ButtonCenterOver
C#
public string ButtonCenterOver {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopImagesSettings Class
WebDesktopImagesSettings Members


ButtonLeftActive Property

[image]
Intersoft WebDesktop Documentation
ButtonLeftActive Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopImagesSettings Class : ButtonLeftActive Property

Glossary Item Box

Gets or sets the button left active image.

Syntax

Visual Basic (Declaration)
Public Property ButtonLeftActive As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopImagesSettings
Dim value As String

instance.ButtonLeftActive = value

value = instance.ButtonLeftActive
C#
public string ButtonLeftActive {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopImagesSettings Class
WebDesktopImagesSettings Members


ButtonLeftInactive Property

[image]
Intersoft WebDesktop Documentation
ButtonLeftInactive Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopImagesSettings Class : ButtonLeftInactive Property

Glossary Item Box

Gets or sets the button left inactive image.

Syntax

Visual Basic (Declaration)
Public Property ButtonLeftInactive As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopImagesSettings
Dim value As String

instance.ButtonLeftInactive = value

value = instance.ButtonLeftInactive
C#
public string ButtonLeftInactive {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopImagesSettings Class
WebDesktopImagesSettings Members


ButtonLeftOver Property

[image]
Intersoft WebDesktop Documentation
ButtonLeftOver Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopImagesSettings Class : ButtonLeftOver Property

Glossary Item Box

Gets or sets the button left over image.

Syntax

Visual Basic (Declaration)
Public Property ButtonLeftOver As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopImagesSettings
Dim value As String

instance.ButtonLeftOver = value

value = instance.ButtonLeftOver
C#
public string ButtonLeftOver {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopImagesSettings Class
WebDesktopImagesSettings Members


ButtonRightActive Property

[image]
Intersoft WebDesktop Documentation
ButtonRightActive Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopImagesSettings Class : ButtonRightActive Property

Glossary Item Box

Gets or sets the button right active image.

Syntax

Visual Basic (Declaration)
Public Property ButtonRightActive As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopImagesSettings
Dim value As String

instance.ButtonRightActive = value

value = instance.ButtonRightActive
C#
public string ButtonRightActive {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopImagesSettings Class
WebDesktopImagesSettings Members


ButtonRightInactive Property

[image]
Intersoft WebDesktop Documentation
ButtonRightInactive Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopImagesSettings Class : ButtonRightInactive Property

Glossary Item Box

Gets or sets the button right inactive image.

Syntax

Visual Basic (Declaration)
Public Property ButtonRightInactive As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopImagesSettings
Dim value As String

instance.ButtonRightInactive = value

value = instance.ButtonRightInactive
C#
public string ButtonRightInactive {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopImagesSettings Class
WebDesktopImagesSettings Members


ButtonRightOver Property

[image]
Intersoft WebDesktop Documentation
ButtonRightOver Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopImagesSettings Class : ButtonRightOver Property

Glossary Item Box

Gets or sets the button right over image.

Syntax

Visual Basic (Declaration)
Public Property ButtonRightOver As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopImagesSettings
Dim value As String

instance.ButtonRightOver = value

value = instance.ButtonRightOver
C#
public string ButtonRightOver {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopImagesSettings Class
WebDesktopImagesSettings Members


CaptionCenterActive Property

[image]
Intersoft WebDesktop Documentation
CaptionCenterActive Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopImagesSettings Class : CaptionCenterActive Property

Glossary Item Box

Gets or sets the center image part for the active Caption. This property is applicable when BorderType is set to ComplexImages.

Syntax

Visual Basic (Declaration)
Public Property CaptionCenterActive As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopImagesSettings
Dim value As String

instance.CaptionCenterActive = value

value = instance.CaptionCenterActive
C#
public string CaptionCenterActive {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopImagesSettings Class
WebDesktopImagesSettings Members


CaptionCenterInactive Property

[image]
Intersoft WebDesktop Documentation
CaptionCenterInactive Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopImagesSettings Class : CaptionCenterInactive Property

Glossary Item Box

Gets or sets the center image part for the inactive Caption. This property is applicable when BorderType is set to ComplexImages.

Syntax

Visual Basic (Declaration)
Public Property CaptionCenterInactive As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopImagesSettings
Dim value As String

instance.CaptionCenterInactive = value

value = instance.CaptionCenterInactive
C#
public string CaptionCenterInactive {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopImagesSettings Class
WebDesktopImagesSettings Members


CaptionLeftActive Property

[image]
Intersoft WebDesktop Documentation
CaptionLeftActive Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopImagesSettings Class : CaptionLeftActive Property

Glossary Item Box

Gets or sets the left image part for the active Caption. This property is applicable when BorderType is set to ComplexImages.

Syntax

Visual Basic (Declaration)
Public Property CaptionLeftActive As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopImagesSettings
Dim value As String

instance.CaptionLeftActive = value

value = instance.CaptionLeftActive
C#
public string CaptionLeftActive {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopImagesSettings Class
WebDesktopImagesSettings Members


CaptionLeftInactive Property

[image]
Intersoft WebDesktop Documentation
CaptionLeftInactive Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopImagesSettings Class : CaptionLeftInactive Property

Glossary Item Box

Gets or sets the left image part for the inactive Caption. This property is applicable when BorderType is set to ComplexImages.

Syntax

Visual Basic (Declaration)
Public Property CaptionLeftInactive As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopImagesSettings
Dim value As String

instance.CaptionLeftInactive = value

value = instance.CaptionLeftInactive
C#
public string CaptionLeftInactive {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopImagesSettings Class
WebDesktopImagesSettings Members


CaptionRightActive Property

[image]
Intersoft WebDesktop Documentation
CaptionRightActive Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopImagesSettings Class : CaptionRightActive Property

Glossary Item Box

Gets or sets the right image part for the active Caption. This property is applicable when BorderType is set to ComplexImages.

Syntax

Visual Basic (Declaration)
Public Property CaptionRightActive As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopImagesSettings
Dim value As String

instance.CaptionRightActive = value

value = instance.CaptionRightActive
C#
public string CaptionRightActive {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopImagesSettings Class
WebDesktopImagesSettings Members


CaptionRightInactive Property

[image]
Intersoft WebDesktop Documentation
CaptionRightInactive Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopImagesSettings Class : CaptionRightInactive Property

Glossary Item Box

Gets or sets the right image part for the inactive Caption. This property is applicable when BorderType is set to ComplexImages.

Syntax

Visual Basic (Declaration)
Public Property CaptionRightInactive As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopImagesSettings
Dim value As String

instance.CaptionRightInactive = value

value = instance.CaptionRightInactive
C#
public string CaptionRightInactive {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopImagesSettings Class
WebDesktopImagesSettings Members


CloseActive Property

[image]
Intersoft WebDesktop Documentation
CloseActive Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopImagesSettings Class : CloseActive Property

Glossary Item Box

Gets or sets the close image for Window.

Syntax

Visual Basic (Declaration)
Public Property CloseActive As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopImagesSettings
Dim value As String

instance.CloseActive = value

value = instance.CloseActive
C#
public string CloseActive {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopImagesSettings Class
WebDesktopImagesSettings Members


CloseDown Property

[image]
Intersoft WebDesktop Documentation
CloseDown Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopImagesSettings Class : CloseDown Property

Glossary Item Box

Gets or sets the pressed image for Close.

Syntax

Visual Basic (Declaration)
Public Property CloseDown As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopImagesSettings
Dim value As String

instance.CloseDown = value

value = instance.CloseDown
C#
public string CloseDown {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopImagesSettings Class
WebDesktopImagesSettings Members


CloseInactive Property

[image]
Intersoft WebDesktop Documentation
CloseInactive Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopImagesSettings Class : CloseInactive Property

Glossary Item Box

Gets or sets the close inactive image.

Syntax

Visual Basic (Declaration)
Public Property CloseInactive As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopImagesSettings
Dim value As String

instance.CloseInactive = value

value = instance.CloseInactive
C#
public string CloseInactive {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopImagesSettings Class
WebDesktopImagesSettings Members


CloseOver Property

[image]
Intersoft WebDesktop Documentation
CloseOver Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopImagesSettings Class : CloseOver Property

Glossary Item Box

Get or sets the close over image.

Syntax

Visual Basic (Declaration)
Public Property CloseOver As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopImagesSettings
Dim value As String

instance.CloseOver = value

value = instance.CloseOver
C#
public string CloseOver {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopImagesSettings Class
WebDesktopImagesSettings Members


ControlBox Property

[image]
Intersoft WebDesktop Documentation
ControlBox Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopImagesSettings Class : ControlBox Property

Glossary Item Box

Gets or sets the default controlbox image for Window.

Syntax

Visual Basic (Declaration)
Public Property ControlBox As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopImagesSettings
Dim value As String

instance.ControlBox = value

value = instance.ControlBox
C#
public string ControlBox {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopImagesSettings Class
WebDesktopImagesSettings Members


InProgress Property

[image]
Intersoft WebDesktop Documentation
InProgress Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopImagesSettings Class : InProgress Property

Glossary Item Box

Gets or sets the image shown during IFrame loading.

Syntax

Visual Basic (Declaration)
Public Property InProgress As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopImagesSettings
Dim value As String

instance.InProgress = value

value = instance.InProgress
C#
public string InProgress {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopImagesSettings Class
WebDesktopImagesSettings Members


MaximizeActive Property

[image]
Intersoft WebDesktop Documentation
MaximizeActive Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopImagesSettings Class : MaximizeActive Property

Glossary Item Box

Gets or sets the maximize image for Window.

Syntax

Visual Basic (Declaration)
Public Property MaximizeActive As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopImagesSettings
Dim value As String

instance.MaximizeActive = value

value = instance.MaximizeActive
C#
public string MaximizeActive {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopImagesSettings Class
WebDesktopImagesSettings Members


MaximizeDown Property

[image]
Intersoft WebDesktop Documentation
MaximizeDown Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopImagesSettings Class : MaximizeDown Property

Glossary Item Box

Gets or sets the pressed image for Maximize.

Syntax

Visual Basic (Declaration)
Public Property MaximizeDown As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopImagesSettings
Dim value As String

instance.MaximizeDown = value

value = instance.MaximizeDown
C#
public string MaximizeDown {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopImagesSettings Class
WebDesktopImagesSettings Members


MaximizeInactive Property

[image]
Intersoft WebDesktop Documentation
MaximizeInactive Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopImagesSettings Class : MaximizeInactive Property

Glossary Item Box

Gets or sets the maximize inactive image.

Syntax

Visual Basic (Declaration)
Public Property MaximizeInactive As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopImagesSettings
Dim value As String

instance.MaximizeInactive = value

value = instance.MaximizeInactive
C#
public string MaximizeInactive {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopImagesSettings Class
WebDesktopImagesSettings Members


MaximizeOver Property

[image]
Intersoft WebDesktop Documentation
MaximizeOver Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopImagesSettings Class : MaximizeOver Property

Glossary Item Box

Gets or sets the maximize over image.

Syntax

Visual Basic (Declaration)
Public Property MaximizeOver As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopImagesSettings
Dim value As String

instance.MaximizeOver = value

value = instance.MaximizeOver
C#
public string MaximizeOver {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopImagesSettings Class
WebDesktopImagesSettings Members


MinimizeActive Property

[image]
Intersoft WebDesktop Documentation
MinimizeActive Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopImagesSettings Class : MinimizeActive Property

Glossary Item Box

Gets or sets the minimize image for Window.

Syntax

Visual Basic (Declaration)
Public Property MinimizeActive As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopImagesSettings
Dim value As String

instance.MinimizeActive = value

value = instance.MinimizeActive
C#
public string MinimizeActive {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopImagesSettings Class
WebDesktopImagesSettings Members


MinimizeDown Property

[image]
Intersoft WebDesktop Documentation
MinimizeDown Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopImagesSettings Class : MinimizeDown Property

Glossary Item Box

Gets or sets the pressed image for Minimize.

Syntax

Visual Basic (Declaration)
Public Property MinimizeDown As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopImagesSettings
Dim value As String

instance.MinimizeDown = value

value = instance.MinimizeDown
C#
public string MinimizeDown {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopImagesSettings Class
WebDesktopImagesSettings Members


MinimizeInactive Property

[image]
Intersoft WebDesktop Documentation
MinimizeInactive Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopImagesSettings Class : MinimizeInactive Property

Glossary Item Box

Gets or sets the minimize inactive image.

Syntax

Visual Basic (Declaration)
Public Property MinimizeInactive As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopImagesSettings
Dim value As String

instance.MinimizeInactive = value

value = instance.MinimizeInactive
C#
public string MinimizeInactive {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopImagesSettings Class
WebDesktopImagesSettings Members


MinimizeOver Property

[image]
Intersoft WebDesktop Documentation
MinimizeOver Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopImagesSettings Class : MinimizeOver Property

Glossary Item Box

Gets or sets the minimize over image.

Syntax

Visual Basic (Declaration)
Public Property MinimizeOver As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopImagesSettings
Dim value As String

instance.MinimizeOver = value

value = instance.MinimizeOver
C#
public string MinimizeOver {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopImagesSettings Class
WebDesktopImagesSettings Members


OverlayBackground Property

[image]
Intersoft WebDesktop Documentation
OverlayBackground Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopImagesSettings Class : OverlayBackground Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property OverlayBackground As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopImagesSettings
Dim value As String

instance.OverlayBackground = value

value = instance.OverlayBackground
C#
public string OverlayBackground {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopImagesSettings Class
WebDesktopImagesSettings Members


RestoreActive Property

[image]
Intersoft WebDesktop Documentation
RestoreActive Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopImagesSettings Class : RestoreActive Property

Glossary Item Box

Gets or sets the restore image for Window.

Syntax

Visual Basic (Declaration)
Public Property RestoreActive As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopImagesSettings
Dim value As String

instance.RestoreActive = value

value = instance.RestoreActive
C#
public string RestoreActive {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopImagesSettings Class
WebDesktopImagesSettings Members


RestoreDown Property

[image]
Intersoft WebDesktop Documentation
RestoreDown Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopImagesSettings Class : RestoreDown Property

Glossary Item Box

Gets or sets the pressed image for Restore.

Syntax

Visual Basic (Declaration)
Public Property RestoreDown As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopImagesSettings
Dim value As String

instance.RestoreDown = value

value = instance.RestoreDown
C#
public string RestoreDown {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopImagesSettings Class
WebDesktopImagesSettings Members


RestoreInactive Property

[image]
Intersoft WebDesktop Documentation
RestoreInactive Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopImagesSettings Class : RestoreInactive Property

Glossary Item Box

Gets or sets the restore inactive image.

Syntax

Visual Basic (Declaration)
Public Property RestoreInactive As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopImagesSettings
Dim value As String

instance.RestoreInactive = value

value = instance.RestoreInactive
C#
public string RestoreInactive {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopImagesSettings Class
WebDesktopImagesSettings Members


RestoreOver Property

[image]
Intersoft WebDesktop Documentation
RestoreOver Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopImagesSettings Class : RestoreOver Property

Glossary Item Box

Gets or sets the restore over image.

Syntax

Visual Basic (Declaration)
Public Property RestoreOver As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopImagesSettings
Dim value As String

instance.RestoreOver = value

value = instance.RestoreOver
C#
public string RestoreOver {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopImagesSettings Class
WebDesktopImagesSettings Members


WebDesktopLoaderSettings Class

[image]
Intersoft WebDesktop Documentation
WebDesktopLoaderSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopLoaderSettings Class

Glossary Item Box

Provides settings for desktop loader.

Object Model

WebDesktopLoaderSettings Class

Syntax

Visual Basic (Declaration)
Public Class WebDesktopLoaderSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopLoaderSettings
C#
public class WebDesktopLoaderSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebDesktop.WebDesktopLoaderSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopLoaderSettings Members
ISNet.WebUI.WebDesktop Namespace


WebDesktopLoaderSettings Class Members

[image]
Intersoft WebDesktop Documentation
WebDesktopLoaderSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopLoaderSettings Class

Glossary Item Box

The following tables list the members exposed by WebDesktopLoaderSettings.

Public Constructors

 | Name | Description
Public Constructor | WebDesktopLoaderSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | Enabled | Specifies a boolean value whether the desktop loader is enabled.
Public Property | Mode | Gets or sets the value indicating the mode of the loader.
Public Property | OnReadyTransitionEffect | Gets or sets the value indicating the visual transition effect used when the desktop has been loaded successfully.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebDesktopLoaderSettings Class
ISNet.WebUI.WebDesktop Namespace


WebDesktopLoaderSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebDesktopLoaderSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopLoaderSettings Class : WebDesktopLoaderSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebDesktopLoaderSettings()
C#
public WebDesktopLoaderSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopLoaderSettings Class
WebDesktopLoaderSettings Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopLoaderSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopLoaderSettings
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopLoaderSettings Class
WebDesktopLoaderSettings Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopLoaderSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopLoaderSettings Class
WebDesktopLoaderSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopLoaderSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopLoaderSettings
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopLoaderSettings Class
WebDesktopLoaderSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopLoaderSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopLoaderSettings
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopLoaderSettings Class
WebDesktopLoaderSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopLoaderSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopLoaderSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopLoaderSettings Class
WebDesktopLoaderSettings Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopLoaderSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopLoaderSettings
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopLoaderSettings Class
WebDesktopLoaderSettings Members


WebDesktopLoaderSettings Class Methods

[image]
Intersoft WebDesktop Documentation
WebDesktopLoaderSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopLoaderSettings Class

Glossary Item Box

For a list of all members of this type, see WebDesktopLoaderSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebDesktopLoaderSettings Class
ISNet.WebUI.WebDesktop Namespace


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopLoaderSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopLoaderSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopLoaderSettings Class
WebDesktopLoaderSettings Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopLoaderSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopLoaderSettings
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopLoaderSettings Class
WebDesktopLoaderSettings Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopLoaderSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopLoaderSettings

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopLoaderSettings Class
WebDesktopLoaderSettings Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopLoaderSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopLoaderSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopLoaderSettings Class
WebDesktopLoaderSettings Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopLoaderSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopLoaderSettings
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopLoaderSettings Class
WebDesktopLoaderSettings Members


WebDesktopLoaderSettings Class Properties

[image]
Intersoft WebDesktop Documentation
WebDesktopLoaderSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopLoaderSettings Class

Glossary Item Box

For a list of all members of this type, see WebDesktopLoaderSettings members.

Public Properties

 | Name | Description
Public Property | Enabled | Specifies a boolean value whether the desktop loader is enabled.
Public Property | Mode | Gets or sets the value indicating the mode of the loader.
Public Property | OnReadyTransitionEffect | Gets or sets the value indicating the visual transition effect used when the desktop has been loaded successfully.
Top

See Also

Reference

WebDesktopLoaderSettings Class
ISNet.WebUI.WebDesktop Namespace


WebDesktopLoaderSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebDesktopLoaderSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopLoaderSettings Class : WebDesktopLoaderSettings Constructor

Glossary Item Box

Initializes a new instance of the WebDesktopLoaderSettings class.

Overload List

Overload | Description
WebDesktopLoaderSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopLoaderSettings Class
WebDesktopLoaderSettings Members


Enabled Property

[image]
Intersoft WebDesktop Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopLoaderSettings Class : Enabled Property

Glossary Item Box

Specifies a boolean value whether the desktop loader is enabled.

Syntax

Visual Basic (Declaration)
Public Property Enabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopLoaderSettings
Dim value As Boolean

instance.Enabled = value

value = instance.Enabled
C#
public bool Enabled {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopLoaderSettings Class
WebDesktopLoaderSettings Members


Mode Property

[image]
Intersoft WebDesktop Documentation
Mode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopLoaderSettings Class : Mode Property

Glossary Item Box

Gets or sets the value indicating the mode of the loader.

Syntax

Visual Basic (Declaration)
Public Property Mode As LoaderMode
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopLoaderSettings
Dim value As LoaderMode

instance.Mode = value

value = instance.Mode
C#
public LoaderMode Mode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopLoaderSettings Class
WebDesktopLoaderSettings Members


OnReadyTransitionEffect Property

[image]
Intersoft WebDesktop Documentation
OnReadyTransitionEffect Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopLoaderSettings Class : OnReadyTransitionEffect Property

Glossary Item Box

Gets or sets the value indicating the visual transition effect used when the desktop has been loaded successfully.

Syntax

Visual Basic (Declaration)
Public Property OnReadyTransitionEffect As VisualTransitionEffect
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopLoaderSettings
Dim value As VisualTransitionEffect

instance.OnReadyTransitionEffect = value

value = instance.OnReadyTransitionEffect
C#
public VisualTransitionEffect OnReadyTransitionEffect {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopLoaderSettings Class
WebDesktopLoaderSettings Members


WebDesktopManager Class

[image]
Intersoft WebDesktop Documentation
WebDesktopManager Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopManager Class

Glossary Item Box

WebDesktopManager is a member of the WebDesktop.NET which offers the Windows-like navigation system. Users can use and configure it easily since it has very powerful functions and features. WebDesktopManager has been carefully modeled into component for high reusability.

Object Model

WebDesktopManager Class

Syntax

Visual Basic (Declaration)
Public Class WebDesktopManager
   Inherits ISNet.WebUI.ISNetControl
   Implements ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, ISNet.WebUI.ITemplateSync
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
C#
public class WebDesktopManager : ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, ISNet.WebUI.ITemplateSync

Remarks

The WebDesktopManager component exposed rich Desktop's behavior which is close to the popular desktops with the implementation of Desktop element in the user interface. A Desktop represents the main working area, where a collection of shortcuts and open Windows resides. In today's popular concept, a Desktop also contains TaskBar which lists all currently open Windows.

You can use WebDesktopManager as your primary Application Navigation component to easily manage Shortcuts and Windows. WebDesktopManager allows you to easily create features-rich and high performance Windows desktop-style web applications. It has HighClarityDesktop technology which implements 98 percent behaviors of a desktop user interface and concepts, such as window movement, resizing, minimizing, maximizing, context menus and many more. Moreover, WebDesktopManager allows you to quickly build web applications that deliver better user interface with uncluttered workspace's approach to browsers which at the end significantly increase users’ productivity.

WebDesktopManager allows you to improve efficiency and usability by replacing traditional's "single tasking" approach application with DesktopManager's "multi tasking" approach. Multiple tasking concepts in DesktopManager allows you to launch multiple windows hosting different modules/pages. Furthermore, you can easily switch between windows, arrange them vertically or horizontally to look at different information at the same time.

WebDesktopManager offers built-in "Shell" features such as shortcut icons, taskbars, window buttons, complete window management features, professional animation to enrich the Windowing system, highly customizable styles and appearance for most elements, strongly-typed client side object model and as always, complete keyboard navigation system.

Following is some of the key features in WebDesktopManager:

  • Cinematic visual experiences.
    WebDesktopManager now comes with 8 visual effects that you can easily apply to your project. You can apply the visual effect in two levels:
    • DesktopManager level.
    • Window level.
  • Built-in preloader for scripts and images.
    This feature allows you to quickly add "preloading" effect to the WebDesktopManager instance.
  • Blocking user interactions in busy mode.
    WebDesktopManager now comes with built-in capability to set a WebDesktopWindow to busy mode programmatically.
  • Windowing navigation system.
    Windowing navigation system works in both Internet Explorer and other Gecko browsers.
  • ClickAndEdit™
    ClickAndEdit greatly enhances developer's productivity by simplifying editing mechanism which takes advantages of Visual Studio 2005.
  • TaskBar settings.
    You can configure TaskBar in more advanced settings using TaskBarSettings property.
  • Clientside construct-able objects.
    You can now construct the Shortcut and Window object at client side programmatically and add it to the collection the same way and manner as you did it in server side.

Using Component Editor on WebDesktopManager you will find three important features, which are Properties Manager, Layout Manager and Structure Manager.

  • Properties Manager is the first and basic feature of the Component Editor. This feature exists to give better layouting and organization of the properties available in the component you are editing. Other than that it offers a better property editing experience.
  • Layout Manager provides the ability to persist the layouting you have done to the component such as color, style and other things related to the UI appearance of the component. You can later on apply the same appearance to other instance of the same component.
  • Structure Manager provides the ability to persist the structure of the component so you can save then load the component structure, this is very useful in cases where you have a complex structure so you can simply load the structure without needing to build the structure from scratch anymore.

For more information and illustration please read Using Component Editor, Working with Properties Manager, Working with Layout Manager, Working with Structure Manager.

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
ISNet.WebUI.ISNetControl
ISNet.WebUI.WebDesktop.WebDesktopManager

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Members
ISNet.WebUI.WebDesktop Namespace

Concepts

WebDesktopManager Overview
Desktop
WebDesktop Concepts
WebDesktop Features
Shortcut
Working with ClickAndEdit and Designers

Tasks

Creating Simple Desktop
Configuring Desktop to use VerticalTile WindowArrangement
Using IFrame as ContentMode

concepts

Using Component Editor
Working with Properties Manager
Working with Layout Manager
Working with Structure Manager


WebDesktopManager Class Members

[image]
Intersoft WebDesktop Documentation
WebDesktopManager Class Members
See Also Properties Methods Events Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopManager Class

Glossary Item Box

The following tables list the members exposed by WebDesktopManager.

Public Constructors

 | Name | Description
Public Constructor | WebDesktopManager Constructor |
Top

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ActiveWindowIndex | Gets or sets the Window index which is currently active.
Public Property | AnimationStyle | Specifies the animation style applied to the window.
Public Property | BackColor | Overridden. Color of the background of the control.
Public Property | BorderColor | Overridden. Border color of the controls aplied with this style.
Public Property | BorderStyle | Overridden. Style of the border around the control.
Public Property | BorderWidth | Overridden. Width of the border around the control.
Public Property | CacheImageResources | Specifies whether all image-type resources should be automatically cached by browsers.
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ClientSideEvents | Contains client side events supported by WebDesktopManager.
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableAnimation | Determines whether there should be animated sequences during Window's minimize, maximize and activate.
Public Property | EnableContextMenu | Determines whether built-in context menu for Window and Desktop is enabled.
Public Property | Enabled | Enables state of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableKeyboardNavigation | Determines whether keyboard navigation is enabled.
Public Property | EnableManagedTheming | Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableTheming | Indicates whether the control can be themed. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | Indicates whether the control automatically saves its state for use in round-trips. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Font | Overridden. The font used for text within the control.
Public Property | ForeColor | Overridden. Color of the text within the control.
Public Property | FrameStyle | Gets or sets the style applied to Frame style of the desktop manager.
Public Property | Height | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ImagesDirectory | Gets or sets the images directory used by ImageSettings.
Public Property | ImagesSettings | Contains images settings.
Public Property | LoaderProgressStyle | Gets or sets the style applied to the loader's progress bar.
Public Property | LoaderSettings | Provides settings for desktop loader.
Public Property | LoaderStyle | Gets or sets the template for the DesktopManager loader.
Public Property | MenuStyles | Contains styles and appearance settings for Menu system.
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden. Gets or sets the directory where all required scripts for the control are stored.
Public Property | ShadowModeAnimation | When WindowInteractiveMode is set to Shadow and ShadowMode Transparency is True. This property specifies whether the transparent shadow should be animated.
Public Property | ShadowModeTransparency | When WindowInteractiveMode is set to Shadow, this property specifies whether the transparent visual effect should be applied to the background of the desktop manager.
Public Property | SharedScriptDirectory | Overridden. Gets or sets the directory where all shared scripts for Intersoft controls are stored.
Public Property | ShortcutDisplayMode | Gets or sets the display mode of the shortcut icons.
Public Property | ShortcutIcons | Contains collection of WebDesktopShorcut object.
Public Property | ShortcutIconsVisible | Specifies whether shortcut icons are visible.
Public Property | ShortcutSettings | Contains settings for desktop shortcut icons.
Public Property | ShortcutStyle | Gets or sets the interactive style of the shortcut icon.
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | TaskBarButtonStyle | Gets os sets the interactive window button style of the task bar.
Public Property | TaskBarSettings | Contains task bar settings.
Public Property | TaskBarStyle | Gets or sets the style applied to the taskbar.
Public Property | TaskBarVisible | Specifies whether task bar which contain opened windows list is visible.
Public Property | TextSettings | Contains text settings used by the control.
Public Property | ToolTip | The tooltip displayed when the mouse is over the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateItems | Gets or sets the items to be stored in view state storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | Gets or sets the server connection string for file server-based viewstate storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | Gets or sets the location to store the viewstate of this control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | Indicates whether the control is visible and rendered. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Width | The width of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | WindowArrangement | Gets or sets the default arrangement for all windows.
Public Property | WindowInteractiveMode | Specifies window intractivity behavior when it is resized or moved using mouse. To improve user interactivity, set this property to Shadow.
Public Property | Windows | Contains collection of WebDesktopWindow object.
Public Property | WindowSettings | Contains default settings for WebDesktopWindow object.
Public Property | XmlCompressionEnabled | Specifies whether the Xml used for clientside state storage should be compressed. (Inherited from ISNet.WebUI.ISNetControl)
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CheckConstrains | Overridden.
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. Overridden.
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadDesktopStateFromXml | Overloaded. Loads Windows and ShortcutIcons structure from a XML file and apply it to this DesktopManager.
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPostData | Overridden.
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | PreloadImage | Register the specified image file to be preloaded. This function is applicable when LoaderSettings is enabled.
Public Method | RaisePostBackEvent |
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RecreateChildControls |
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterScript | Overridden.
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveDesktopStateToXml | Overloaded. Saves WebDesktopWindowCollection structure and WebDesktopShortcutCollection structure to string.
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SynchronizeTemplatesFrom |
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebDesktopManager Class
ISNet.WebUI.WebDesktop Namespace

Concepts

WebDesktopManager Overview
Desktop
WebDesktop Concepts
WebDesktop Features
Shortcut
Working with ClickAndEdit and Designers

Tasks

Creating Simple Desktop
Configuring Desktop to use VerticalTile WindowArrangement
Using IFrame as ContentMode

concepts

Using Component Editor
Working with Properties Manager
Working with Layout Manager
Working with Structure Manager


WebDesktopManager Class Events

[image]
Intersoft WebDesktop Documentation
WebDesktopManager Class Events
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopManager Class

Glossary Item Box

For a list of all members of this type, see WebDesktopManager members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebDesktopManager Class
ISNet.WebUI.WebDesktop Namespace

Concepts

WebDesktopManager Overview
Desktop
WebDesktop Concepts
WebDesktop Features
Shortcut
Working with ClickAndEdit and Designers

Tasks

Creating Simple Desktop
Configuring Desktop to use VerticalTile WindowArrangement
Using IFrame as ContentMode

concepts

Using Component Editor
Working with Properties Manager
Working with Layout Manager
Working with Structure Manager


WebDesktopManager Constructor

[image]
Intersoft WebDesktop Documentation
WebDesktopManager Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : WebDesktopManager Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebDesktopManager()
C#
public WebDesktopManager()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


ApplyStyle Method

[image]
Intersoft WebDesktop Documentation
ApplyStyle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : ApplyStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ApplyStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim s As System.Web.UI.WebControls.Style

instance.ApplyStyle(s)
C#
public void ApplyStyle(
   System.Web.UI.WebControls.Style s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


ApplyStyleSheetSkin Method

[image]
Intersoft WebDesktop Documentation
ApplyStyleSheetSkin Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : ApplyStyleSheetSkin Method

page

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub ApplyStyleSheetSkin( _
   ByVal page As System.Web.UI.Page _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim page As System.Web.UI.Page

instance.ApplyStyleSheetSkin(page)
C#
public virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page page
)

Parameters

page

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


CanUseWebResources Method

[image]
Intersoft WebDesktop Documentation
CanUseWebResources Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : CanUseWebResources Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CanUseWebResources() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As Boolean

value = instance.CanUseWebResources()
C#
public bool CanUseWebResources()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


WebDesktopManager Class Methods

[image]
Intersoft WebDesktop Documentation
WebDesktopManager Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopManager Class

Glossary Item Box

For a list of all members of this type, see WebDesktopManager members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CheckConstrains | Overridden.
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. Overridden.
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadDesktopStateFromXml | Overloaded. Loads Windows and ShortcutIcons structure from a XML file and apply it to this DesktopManager.
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPostData | Overridden.
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | PreloadImage | Register the specified image file to be preloaded. This function is applicable when LoaderSettings is enabled.
Public Method | RaisePostBackEvent |
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RecreateChildControls |
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterScript | Overridden.
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveDesktopStateToXml | Overloaded. Saves WebDesktopWindowCollection structure and WebDesktopShortcutCollection structure to string.
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SynchronizeTemplatesFrom |
Top

See Also

Reference

WebDesktopManager Class
ISNet.WebUI.WebDesktop Namespace

Concepts

WebDesktopManager Overview
Desktop
WebDesktop Concepts
WebDesktop Features
Shortcut
Working with ClickAndEdit and Designers

Tasks

Creating Simple Desktop
Configuring Desktop to use VerticalTile WindowArrangement
Using IFrame as ContentMode

concepts

Using Component Editor
Working with Properties Manager
Working with Layout Manager
Working with Structure Manager


CheckConstrains Method

[image]
Intersoft WebDesktop Documentation
CheckConstrains Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : CheckConstrains Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub CheckConstrains()
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager

instance.CheckConstrains()
C#
public override void CheckConstrains()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


CopyBaseAttributes Method

[image]
Intersoft WebDesktop Documentation
CopyBaseAttributes Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : CopyBaseAttributes Method

controlSrc

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyBaseAttributes( _
   ByVal controlSrc As System.Web.UI.WebControls.WebControl _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim controlSrc As System.Web.UI.WebControls.WebControl

instance.CopyBaseAttributes(controlSrc)
C#
public void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl controlSrc
)

Parameters

controlSrc

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object,Boolean) |
CopyFrom(Object) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public override void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members
Overload List


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members
Overload List


DataBind Method

[image]
Intersoft WebDesktop Documentation
DataBind Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : DataBind Method

Glossary Item Box

Overload List

Overload | Description
DataBind | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


DataBind() Method

[image]
Intersoft WebDesktop Documentation
DataBind() Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : DataBind() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub DataBind()
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager

instance.DataBind()
C#
public virtual void DataBind()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


Dispose Method

[image]
Intersoft WebDesktop Documentation
Dispose Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : Dispose Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager

instance.Dispose()
C#
public virtual void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


FindControl Method

[image]
Intersoft WebDesktop Documentation
FindControl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : FindControl Method

Glossary Item Box

Overload List

Overload | Description
FindControl | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


FindControl(String) Method

[image]
Intersoft WebDesktop Documentation
FindControl(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : FindControl(String) Method

id

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function FindControl( _
   ByVal id As String _
) As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim id As String
Dim value As System.Web.UI.Control

value = instance.FindControl(id)
C#
public virtual System.Web.UI.Control FindControl(
   string id
)

Parameters

id

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


Focus Method

[image]
Intersoft WebDesktop Documentation
Focus Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : Focus Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Focus()
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager

instance.Focus()
C#
public virtual void Focus()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


ForceDisableXmlCompression Method

[image]
Intersoft WebDesktop Documentation
ForceDisableXmlCompression Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : ForceDisableXmlCompression Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ForceDisableXmlCompression()
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager

instance.ForceDisableXmlCompression()
C#
public void ForceDisableXmlCompression()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


GetCurrentControlLifeCycle Method

[image]
Intersoft WebDesktop Documentation
GetCurrentControlLifeCycle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : GetCurrentControlLifeCycle Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentControlLifeCycle() As ISNet.WebUI.ControlLifeCycle
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As ISNet.WebUI.ControlLifeCycle

value = instance.GetCurrentControlLifeCycle()
C#
public ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


GetCurrentTheme Method

[image]
Intersoft WebDesktop Documentation
GetCurrentTheme Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : GetCurrentTheme Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentTheme() As ISNet.WebUI.ThemeInfo
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As ISNet.WebUI.ThemeInfo

value = instance.GetCurrentTheme()
C#
public ISNet.WebUI.ThemeInfo GetCurrentTheme()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


GetFrameworkDataFolder Method

[image]
Intersoft WebDesktop Documentation
GetFrameworkDataFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : GetFrameworkDataFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkDataFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As String

value = instance.GetFrameworkDataFolder()
C#
public string GetFrameworkDataFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


GetFrameworkFolder Method

[image]
Intersoft WebDesktop Documentation
GetFrameworkFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : GetFrameworkFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As String

value = instance.GetFrameworkFolder()
C#
public string GetFrameworkFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


GetFrameworkVersion Method

[image]
Intersoft WebDesktop Documentation
GetFrameworkVersion Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : GetFrameworkVersion Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkVersion() As Version
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As Version

value = instance.GetFrameworkVersion()
C#
public Version GetFrameworkVersion()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


GetIntersoftFolder Method

[image]
Intersoft WebDesktop Documentation
GetIntersoftFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : GetIntersoftFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetIntersoftFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As String

value = instance.GetIntersoftFolder()
C#
public string GetIntersoftFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


GetLayoutFolder Method

[image]
Intersoft WebDesktop Documentation
GetLayoutFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : GetLayoutFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetLayoutFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As String

value = instance.GetLayoutFolder()
C#
public string GetLayoutFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


GetPostedXMLData Method

[image]
Intersoft WebDesktop Documentation
GetPostedXMLData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : GetPostedXMLData Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPostedXMLData() As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As String

value = instance.GetPostedXMLData()
C#
public string GetPostedXMLData()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


GetProductInfoKey Method

[image]
Intersoft WebDesktop Documentation
GetProductInfoKey Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : GetProductInfoKey Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductInfoKey() As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As String

value = instance.GetProductInfoKey()
C#
public string GetProductInfoKey()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


GetProductSimpleName Method

[image]
Intersoft WebDesktop Documentation
GetProductSimpleName Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : GetProductSimpleName Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductSimpleName() As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As String

value = instance.GetProductSimpleName()
C#
public string GetProductSimpleName()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


GetPropertyValue Method

[image]
Intersoft WebDesktop Documentation
GetPropertyValue Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : GetPropertyValue Method

defValue
propValue
webConfigKey

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPropertyValue( _
   ByVal defValue As String, _
   ByVal propValue As String, _
   ByVal webConfigKey As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim defValue As String
Dim propValue As String
Dim webConfigKey As String
Dim value As String

value = instance.GetPropertyValue(defValue, propValue, webConfigKey)
C#
public string GetPropertyValue(
   string defValue,
   string propValue,
   string webConfigKey
)

Parameters

defValue
propValue
webConfigKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


GetResourceStream Method

[image]
Intersoft WebDesktop Documentation
GetResourceStream Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : GetResourceStream Method

resourceUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetResourceStream( _
   ByVal resourceUrl As String _
) As System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim resourceUrl As String
Dim value As System.IO.Stream

value = instance.GetResourceStream(resourceUrl)
C#
public System.IO.Stream GetResourceStream(
   string resourceUrl
)

Parameters

resourceUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


GetRouteUrl Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : GetRouteUrl Method

Glossary Item Box

Overload List

Overload | Description
GetRouteUrl(Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(RouteValueDictionary) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,RouteValueDictionary) | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


GetRouteUrl(Object) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class > GetRouteUrl Method : GetRouteUrl(Object) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As Object _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim routeParameters As Object
Dim value As String

value = instance.GetRouteUrl(routeParameters)
C#
public string GetRouteUrl(
   object routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members
Overload List


GetRouteUrl(String,Object) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(String,Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class > GetRouteUrl Method : GetRouteUrl(String,Object) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As String, _
   ByVal routeParameters As Object _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim routeName As String
Dim routeParameters As Object
Dim value As String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public string GetRouteUrl(
   string routeName,
   object routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members
Overload List


GetRouteUrl(RouteValueDictionary) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(RouteValueDictionary) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class > GetRouteUrl Method : GetRouteUrl(RouteValueDictionary) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As String

value = instance.GetRouteUrl(routeParameters)
C#
public string GetRouteUrl(
   System.Web.Routing.RouteValueDictionary routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members
Overload List


GetRouteUrl(String,RouteValueDictionary) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(String,RouteValueDictionary) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class > GetRouteUrl Method : GetRouteUrl(String,RouteValueDictionary) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As String, _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim routeName As String
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public string GetRouteUrl(
   string routeName,
   System.Web.Routing.RouteValueDictionary routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members
Overload List


GetUniqueIDRelativeTo Method

[image]
Intersoft WebDesktop Documentation
GetUniqueIDRelativeTo Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : GetUniqueIDRelativeTo Method

control

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetUniqueIDRelativeTo( _
   ByVal control As System.Web.UI.Control _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim control As System.Web.UI.Control
Dim value As String

value = instance.GetUniqueIDRelativeTo(control)
C#
public string GetUniqueIDRelativeTo(
   System.Web.UI.Control control
)

Parameters

control

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


HasControls Method

[image]
Intersoft WebDesktop Documentation
HasControls Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : HasControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function HasControls() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As Boolean

value = instance.HasControls()
C#
public virtual bool HasControls()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


IsAtlasCallback Method

[image]
Intersoft WebDesktop Documentation
IsAtlasCallback Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : IsAtlasCallback Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsAtlasCallback() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As Boolean

value = instance.IsAtlasCallback()
C#
public bool IsAtlasCallback()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


IsBetaRelease Method

[image]
Intersoft WebDesktop Documentation
IsBetaRelease Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : IsBetaRelease Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsBetaRelease() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As Boolean

value = instance.IsBetaRelease()
C#
public bool IsBetaRelease()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


IsChromeBrowser Method

[image]
Intersoft WebDesktop Documentation
IsChromeBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : IsChromeBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsChromeBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As Boolean

value = instance.IsChromeBrowser()
C#
public bool IsChromeBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


IsFlyPostBackControl Method

[image]
Intersoft WebDesktop Documentation
IsFlyPostBackControl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : IsFlyPostBackControl Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackControl() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As Boolean

value = instance.IsFlyPostBackControl()
C#
public virtual bool IsFlyPostBackControl()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


IsFlyPostBackRequest Method

[image]
Intersoft WebDesktop Documentation
IsFlyPostBackRequest Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : IsFlyPostBackRequest Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackRequest() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As Boolean

value = instance.IsFlyPostBackRequest()
C#
public virtual bool IsFlyPostBackRequest()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


IsGeckoBasedBrowser Method

[image]
Intersoft WebDesktop Documentation
IsGeckoBasedBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : IsGeckoBasedBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoBasedBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As Boolean

value = instance.IsGeckoBasedBrowser()
C#
public bool IsGeckoBasedBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


IsGeckoVersion18 Method

[image]
Intersoft WebDesktop Documentation
IsGeckoVersion18 Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : IsGeckoVersion18 Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoVersion18() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As Boolean

value = instance.IsGeckoVersion18()
C#
public bool IsGeckoVersion18()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


IsInDesignMode Method

[image]
Intersoft WebDesktop Documentation
IsInDesignMode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : IsInDesignMode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInDesignMode() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As Boolean

value = instance.IsInDesignMode()
C#
public bool IsInDesignMode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


IsInternetExplorer8Browser Method

[image]
Intersoft WebDesktop Documentation
IsInternetExplorer8Browser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : IsInternetExplorer8Browser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorer8Browser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As Boolean

value = instance.IsInternetExplorer8Browser()
C#
public bool IsInternetExplorer8Browser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


IsInternetExplorerBrowser Method

[image]
Intersoft WebDesktop Documentation
IsInternetExplorerBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : IsInternetExplorerBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorerBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As Boolean

value = instance.IsInternetExplorerBrowser()
C#
public bool IsInternetExplorerBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


IsOperaBrowser Method

[image]
Intersoft WebDesktop Documentation
IsOperaBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : IsOperaBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsOperaBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As Boolean

value = instance.IsOperaBrowser()
C#
public bool IsOperaBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


IsSafariBrowser Method

[image]
Intersoft WebDesktop Documentation
IsSafariBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : IsSafariBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsSafariBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As Boolean

value = instance.IsSafariBrowser()
C#
public bool IsSafariBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


IsW3CStandardBrowser Method

[image]
Intersoft WebDesktop Documentation
IsW3CStandardBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : IsW3CStandardBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsW3CStandardBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As Boolean

value = instance.IsW3CStandardBrowser()
C#
public bool IsW3CStandardBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


LoadDesktopStateFromXml Method

[image]
Intersoft WebDesktop Documentation
LoadDesktopStateFromXml Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : LoadDesktopStateFromXml Method

Glossary Item Box

Loads Windows and ShortcutIcons structure from a XML file and apply it to this DesktopManager. Loads Windows and ShortcutIcons structure from a XML file and apply it to this DesktopManager.

Overload List

Overload | Description
LoadDesktopStateFromXml(Stream) | Loads Windows and ShortcutIcons structure from a XML file and apply it to this DesktopManager.
LoadDesktopStateFromXml(String) | Loads Windows and ShortcutIcons structure from stream and apply it to this DesktopManager.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


LoadDesktopStateFromXml(Stream) Method

[image]
Intersoft WebDesktop Documentation
LoadDesktopStateFromXml(Stream) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class > LoadDesktopStateFromXml Method : LoadDesktopStateFromXml(Stream) Method

stream

Glossary Item Box

Loads Windows and ShortcutIcons structure from a XML file and apply it to this DesktopManager.

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadDesktopStateFromXml( _
   ByVal stream As System.IO.Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim stream As System.IO.Stream

instance.LoadDesktopStateFromXml(stream)
C#
public void LoadDesktopStateFromXml(
   System.IO.Stream stream
)

Parameters

stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members
Overload List


LoadDesktopStateFromXml(String) Method

[image]
Intersoft WebDesktop Documentation
LoadDesktopStateFromXml(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class > LoadDesktopStateFromXml Method : LoadDesktopStateFromXml(String) Method

fileName

Glossary Item Box

Loads Windows and ShortcutIcons structure from stream and apply it to this DesktopManager.

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadDesktopStateFromXml( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim fileName As String

instance.LoadDesktopStateFromXml(fileName)
C#
public void LoadDesktopStateFromXml(
   string fileName
)

Parameters

fileName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members
Overload List


LoadLayout Method

[image]
Intersoft WebDesktop Documentation
LoadLayout Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : LoadLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim settings As ISNet.WebUI.LayoutInfo

instance.LoadLayout(settings)
C#
public virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


LoadLayoutFromFile Method

[image]
Intersoft WebDesktop Documentation
LoadLayoutFromFile Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : LoadLayoutFromFile Method

filePath

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromFile( _
   ByVal filePath As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim filePath As String

instance.LoadLayoutFromFile(filePath)
C#
public virtual void LoadLayoutFromFile(
   string filePath
)

Parameters

filePath

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


LoadLayoutFromPredefinedName Method

[image]
Intersoft WebDesktop Documentation
LoadLayoutFromPredefinedName Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : LoadLayoutFromPredefinedName Method

predefinedName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromPredefinedName( _
   ByVal predefinedName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim predefinedName As String

instance.LoadLayoutFromPredefinedName(predefinedName)
C#
public virtual void LoadLayoutFromPredefinedName(
   string predefinedName
)

Parameters

predefinedName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


LoadLayoutFromStream Method

[image]
Intersoft WebDesktop Documentation
LoadLayoutFromStream Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : LoadLayoutFromStream Method

stream

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromStream( _
   ByVal stream As System.IO.Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim stream As System.IO.Stream

instance.LoadLayoutFromStream(stream)
C#
public virtual void LoadLayoutFromStream(
   System.IO.Stream stream
)

Parameters

stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


LoadPostData Method

[image]
Intersoft WebDesktop Documentation
LoadPostData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : LoadPostData Method

postDataKey
postCollection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function LoadPostData( _
   ByVal postDataKey As String, _
   ByVal postCollection As System.Collections.Specialized.NameValueCollection _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim postDataKey As String
Dim postCollection As System.Collections.Specialized.NameValueCollection
Dim value As Boolean

value = instance.LoadPostData(postDataKey, postCollection)
C#
public override bool LoadPostData(
   string postDataKey,
   System.Collections.Specialized.NameValueCollection postCollection
)

Parameters

postDataKey
postCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


MergeStyle Method

[image]
Intersoft WebDesktop Documentation
MergeStyle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : MergeStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub MergeStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim s As System.Web.UI.WebControls.Style

instance.MergeStyle(s)
C#
public void MergeStyle(
   System.Web.UI.WebControls.Style s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


OnInfoChanged Method

[image]
Intersoft WebDesktop Documentation
OnInfoChanged Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : OnInfoChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnInfoChanged( _
   ByVal e As ISNet.WebUI.SynchronizeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim e As ISNet.WebUI.SynchronizeEventArgs

instance.OnInfoChanged(e)
C#
public void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


OnPreInitialize Method

[image]
Intersoft WebDesktop Documentation
OnPreInitialize Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : OnPreInitialize Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnPreInitialize()
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager

instance.OnPreInitialize()
C#
public virtual void OnPreInitialize()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


PreloadImage Method

[image]
Intersoft WebDesktop Documentation
PreloadImage Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : PreloadImage Method

image

Glossary Item Box

Register the specified image file to be preloaded. This function is applicable when LoaderSettings is enabled.

Syntax

Visual Basic (Declaration)
Public Sub PreloadImage( _
   ByVal image As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim image As String

instance.PreloadImage(image)
C#
public void PreloadImage(
   string image
)

Parameters

image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


RaisePostBackEvent Method

[image]
Intersoft WebDesktop Documentation
RaisePostBackEvent Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : RaisePostBackEvent Method

eventArgument

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RaisePostBackEvent( _
   ByVal eventArgument As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim eventArgument As String

instance.RaisePostBackEvent(eventArgument)
C#
public void RaisePostBackEvent(
   string eventArgument
)

Parameters

eventArgument

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


RaisePostDataChangedEvent Method

[image]
Intersoft WebDesktop Documentation
RaisePostDataChangedEvent Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : RaisePostDataChangedEvent Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RaisePostDataChangedEvent()
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager

instance.RaisePostDataChangedEvent()
C#
public virtual void RaisePostDataChangedEvent()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


ReadWebConfigValue Method

[image]
Intersoft WebDesktop Documentation
ReadWebConfigValue Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : ReadWebConfigValue Method

key

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ReadWebConfigValue( _
   ByVal key As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim key As String
Dim value As String

value = instance.ReadWebConfigValue(key)
C#
public string ReadWebConfigValue(
   string key
)

Parameters

key

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


RecreateChildControls Method

[image]
Intersoft WebDesktop Documentation
RecreateChildControls Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : RecreateChildControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RecreateChildControls()
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager

instance.RecreateChildControls()
C#
public void RecreateChildControls()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


RegisterBoxSizing Method

[image]
Intersoft WebDesktop Documentation
RegisterBoxSizing Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : RegisterBoxSizing Method

Glossary Item Box

Overload List

Overload | Description
RegisterBoxSizing() | (Inherited from ISNet.WebUI.ISNetControl)
RegisterBoxSizing(Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


RegisterBoxSizing() Method

[image]
Intersoft WebDesktop Documentation
RegisterBoxSizing() Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class > RegisterBoxSizing Method : RegisterBoxSizing() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing()
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager

instance.RegisterBoxSizing()
C#
public void RegisterBoxSizing()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members
Overload List


RegisterBoxSizing(Boolean) Method

[image]
Intersoft WebDesktop Documentation
RegisterBoxSizing(Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class > RegisterBoxSizing Method : RegisterBoxSizing(Boolean) Method

forceAll

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing( _
   ByVal forceAll As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim forceAll As Boolean

instance.RegisterBoxSizing(forceAll)
C#
public void RegisterBoxSizing(
   bool forceAll
)

Parameters

forceAll

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members
Overload List


RegisterGlobalStyle Method

[image]
Intersoft WebDesktop Documentation
RegisterGlobalStyle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : RegisterGlobalStyle Method

style

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterGlobalStyle( _
   ByVal style As ISNet.WebUI.WebStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim style As ISNet.WebUI.WebStyle

instance.RegisterGlobalStyle(style)
C#
public void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle style
)

Parameters

style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


RegisterLink Method

[image]
Intersoft WebDesktop Documentation
RegisterLink Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : RegisterLink Method

name
url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterLink( _
   ByVal name As String, _
   ByVal url As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim name As String
Dim url As String

instance.RegisterLink(name, url)
C#
public void RegisterLink(
   string name,
   string url
)

Parameters

name
url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


RegisterOptimizedCssClasses Method

[image]
Intersoft WebDesktop Documentation
RegisterOptimizedCssClasses Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : RegisterOptimizedCssClasses Method

runtimeStyleOnly

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterOptimizedCssClasses( _
   ByVal runtimeStyleOnly As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim runtimeStyleOnly As Boolean

instance.RegisterOptimizedCssClasses(runtimeStyleOnly)
C#
public void RegisterOptimizedCssClasses(
   bool runtimeStyleOnly
)

Parameters

runtimeStyleOnly

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


RegisterPreloadImage Method

[image]
Intersoft WebDesktop Documentation
RegisterPreloadImage Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : RegisterPreloadImage Method

image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterPreloadImage( _
   ByVal image As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim image As String

instance.RegisterPreloadImage(image)
C#
public void RegisterPreloadImage(
   string image
)

Parameters

image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


RegisterScript Method

[image]
Intersoft WebDesktop Documentation
RegisterScript Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : RegisterScript Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub RegisterScript()
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager

instance.RegisterScript()
C#
public override void RegisterScript()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


RegisterSharePointHandler Method

[image]
Intersoft WebDesktop Documentation
RegisterSharePointHandler Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : RegisterSharePointHandler Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RegisterSharePointHandler()
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager

instance.RegisterSharePointHandler()
C#
public virtual void RegisterSharePointHandler()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


RenderBeginTag Method

[image]
Intersoft WebDesktop Documentation
RenderBeginTag Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : RenderBeginTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderBeginTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderBeginTag(writer)
C#
public virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


RenderControl Method

[image]
Intersoft WebDesktop Documentation
RenderControl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : RenderControl Method

Glossary Item Box

Overload List

Overload | Description
RenderControl | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


RenderControl(HtmlTextWriter) Method

[image]
Intersoft WebDesktop Documentation
RenderControl(HtmlTextWriter) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : RenderControl(HtmlTextWriter) Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderControl( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderControl(writer)
C#
public virtual void RenderControl(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


RenderEndTag Method

[image]
Intersoft WebDesktop Documentation
RenderEndTag Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : RenderEndTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub RenderEndTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderEndTag(writer)
C#
public override void RenderEndTag(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


ResolveClientUrl Method

[image]
Intersoft WebDesktop Documentation
ResolveClientUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : ResolveClientUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveClientUrl( _
   ByVal relativeUrl As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim relativeUrl As String
Dim value As String

value = instance.ResolveClientUrl(relativeUrl)
C#
public string ResolveClientUrl(
   string relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


ResolveImagePath Method

[image]
Intersoft WebDesktop Documentation
ResolveImagePath Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : ResolveImagePath Method

folder
image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveImagePath( _
   ByVal folder As String, _
   ByVal image As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim folder As String
Dim image As String
Dim value As String

value = instance.ResolveImagePath(folder, image)
C#
public string ResolveImagePath(
   string folder,
   string image
)

Parameters

folder
image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


ResolveRelativeURL Method

[image]
Intersoft WebDesktop Documentation
ResolveRelativeURL Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : ResolveRelativeURL Method

url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ResolveRelativeURL( _
   ByVal url As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim url As String
Dim value As String

value = instance.ResolveRelativeURL(url)
C#
public virtual string ResolveRelativeURL(
   string url
)

Parameters

url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


ResolveResourceUrl Method

[image]
Intersoft WebDesktop Documentation
ResolveResourceUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : ResolveResourceUrl Method

kind
defaultFolder
currentFolder
resourceName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveResourceUrl( _
   ByVal kind As ISNet.WebUI.ResourceKind, _
   ByVal defaultFolder As String, _
   ByVal currentFolder As String, _
   ByVal resourceName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim kind As ISNet.WebUI.ResourceKind
Dim defaultFolder As String
Dim currentFolder As String
Dim resourceName As String
Dim value As String

value = instance.ResolveResourceUrl(kind, defaultFolder, currentFolder, resourceName)
C#
public string ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   string defaultFolder,
   string currentFolder,
   string resourceName
)

Parameters

kind
defaultFolder
currentFolder
resourceName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


ResolveUrl Method

[image]
Intersoft WebDesktop Documentation
ResolveUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : ResolveUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveUrl( _
   ByVal relativeUrl As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim relativeUrl As String
Dim value As String

value = instance.ResolveUrl(relativeUrl)
C#
public string ResolveUrl(
   string relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


SaveDesktopStateToXml Method

[image]
Intersoft WebDesktop Documentation
SaveDesktopStateToXml Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : SaveDesktopStateToXml Method

Glossary Item Box

Saves WebDesktopWindowCollection structure and WebDesktopShortcutCollection structure to string. Saves WebDesktopWindowCollection structure and WebDesktopShortcutCollection structure to a XML file.

Overload List

Overload | Description
SaveDesktopStateToXml(String) | Saves WebDesktopWindowCollection structure and WebDesktopShortcutCollection structure to string.
SaveDesktopStateToXml() | Saves WebDesktopWindowCollection structure and WebDesktopShortcutCollection structure to a XML file.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


SaveDesktopStateToXml(String) Method

[image]
Intersoft WebDesktop Documentation
SaveDesktopStateToXml(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class > SaveDesktopStateToXml Method : SaveDesktopStateToXml(String) Method

fileName

Glossary Item Box

Saves WebDesktopWindowCollection structure and WebDesktopShortcutCollection structure to string.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SaveDesktopStateToXml( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim fileName As String

instance.SaveDesktopStateToXml(fileName)
C#
public void SaveDesktopStateToXml(
   string fileName
)

Parameters

fileName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members
Overload List


SaveDesktopStateToXml() Method

[image]
Intersoft WebDesktop Documentation
SaveDesktopStateToXml() Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class > SaveDesktopStateToXml Method : SaveDesktopStateToXml() Method

Glossary Item Box

Saves WebDesktopWindowCollection structure and WebDesktopShortcutCollection structure to a XML file.

Syntax

Visual Basic (Declaration)
Public Overloads Function SaveDesktopStateToXml() As System.Xml.XmlDocument
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As System.Xml.XmlDocument

value = instance.SaveDesktopStateToXml()
C#
public System.Xml.XmlDocument SaveDesktopStateToXml()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members
Overload List


SaveLayout Method

[image]
Intersoft WebDesktop Documentation
SaveLayout Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : SaveLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim settings As ISNet.WebUI.LayoutInfo

instance.SaveLayout(settings)
C#
public virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


SaveLayoutToFile Method

[image]
Intersoft WebDesktop Documentation
SaveLayoutToFile Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : SaveLayoutToFile Method

filePath
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToFile( _
   ByVal filePath As String, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim filePath As String
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToFile(filePath, saveOptions)
C#
public virtual void SaveLayoutToFile(
   string filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

filePath
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


SaveLayoutToStream Method

[image]
Intersoft WebDesktop Documentation
SaveLayoutToStream Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : SaveLayoutToStream Method

stream
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToStream( _
   ByVal stream As System.IO.Stream, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim stream As System.IO.Stream
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToStream(stream, saveOptions)
C#
public virtual void SaveLayoutToStream(
   System.IO.Stream stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

stream
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


SetRenderMethodDelegate Method

[image]
Intersoft WebDesktop Documentation
SetRenderMethodDelegate Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : SetRenderMethodDelegate Method

renderMethod

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetRenderMethodDelegate( _
   ByVal renderMethod As System.Web.UI.RenderMethod _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim renderMethod As System.Web.UI.RenderMethod

instance.SetRenderMethodDelegate(renderMethod)
C#
public void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod renderMethod
)

Parameters

renderMethod

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


SetSessionTheme Method

[image]
Intersoft WebDesktop Documentation
SetSessionTheme Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : SetSessionTheme Method

themeInfo

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetSessionTheme( _
   ByVal themeInfo As ISNet.WebUI.ThemeInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim themeInfo As ISNet.WebUI.ThemeInfo

instance.SetSessionTheme(themeInfo)
C#
public void SetSessionTheme(
   ISNet.WebUI.ThemeInfo themeInfo
)

Parameters

themeInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


ShouldReturnJson Method

[image]
Intersoft WebDesktop Documentation
ShouldReturnJson Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : ShouldReturnJson Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ShouldReturnJson() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As Boolean

value = instance.ShouldReturnJson()
C#
public virtual bool ShouldReturnJson()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


SynchronizeTemplatesFrom Method

[image]
Intersoft WebDesktop Documentation
SynchronizeTemplatesFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : SynchronizeTemplatesFrom Method

sourceObj

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SynchronizeTemplatesFrom( _
   ByVal sourceObj As ISNet.WebUI.ISNetControl _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim sourceObj As ISNet.WebUI.ISNetControl

instance.SynchronizeTemplatesFrom(sourceObj)
C#
public void SynchronizeTemplatesFrom(
   ISNet.WebUI.ISNetControl sourceObj
)

Parameters

sourceObj

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


AccessKey Property

[image]
Intersoft WebDesktop Documentation
AccessKey Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : AccessKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property AccessKey As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As String

instance.AccessKey = value

value = instance.AccessKey
C#
public virtual string AccessKey {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


WebDesktopManager Class Properties

[image]
Intersoft WebDesktop Documentation
WebDesktopManager Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopManager Class

Glossary Item Box

For a list of all members of this type, see WebDesktopManager members.

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ActiveWindowIndex | Gets or sets the Window index which is currently active.
Public Property | AnimationStyle | Specifies the animation style applied to the window.
Public Property | BackColor | Overridden. Color of the background of the control.
Public Property | BorderColor | Overridden. Border color of the controls aplied with this style.
Public Property | BorderStyle | Overridden. Style of the border around the control.
Public Property | BorderWidth | Overridden. Width of the border around the control.
Public Property | CacheImageResources | Specifies whether all image-type resources should be automatically cached by browsers.
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ClientSideEvents | Contains client side events supported by WebDesktopManager.
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableAnimation | Determines whether there should be animated sequences during Window's minimize, maximize and activate.
Public Property | EnableContextMenu | Determines whether built-in context menu for Window and Desktop is enabled.
Public Property | Enabled | Enables state of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableKeyboardNavigation | Determines whether keyboard navigation is enabled.
Public Property | EnableManagedTheming | Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableTheming | Indicates whether the control can be themed. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | Indicates whether the control automatically saves its state for use in round-trips. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Font | Overridden. The font used for text within the control.
Public Property | ForeColor | Overridden. Color of the text within the control.
Public Property | FrameStyle | Gets or sets the style applied to Frame style of the desktop manager.
Public Property | Height | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ImagesDirectory | Gets or sets the images directory used by ImageSettings.
Public Property | ImagesSettings | Contains images settings.
Public Property | LoaderProgressStyle | Gets or sets the style applied to the loader's progress bar.
Public Property | LoaderSettings | Provides settings for desktop loader.
Public Property | LoaderStyle | Gets or sets the template for the DesktopManager loader.
Public Property | MenuStyles | Contains styles and appearance settings for Menu system.
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden. Gets or sets the directory where all required scripts for the control are stored.
Public Property | ShadowModeAnimation | When WindowInteractiveMode is set to Shadow and ShadowMode Transparency is True. This property specifies whether the transparent shadow should be animated.
Public Property | ShadowModeTransparency | When WindowInteractiveMode is set to Shadow, this property specifies whether the transparent visual effect should be applied to the background of the desktop manager.
Public Property | SharedScriptDirectory | Overridden. Gets or sets the directory where all shared scripts for Intersoft controls are stored.
Public Property | ShortcutDisplayMode | Gets or sets the display mode of the shortcut icons.
Public Property | ShortcutIcons | Contains collection of WebDesktopShorcut object.
Public Property | ShortcutIconsVisible | Specifies whether shortcut icons are visible.
Public Property | ShortcutSettings | Contains settings for desktop shortcut icons.
Public Property | ShortcutStyle | Gets or sets the interactive style of the shortcut icon.
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | TaskBarButtonStyle | Gets os sets the interactive window button style of the task bar.
Public Property | TaskBarSettings | Contains task bar settings.
Public Property | TaskBarStyle | Gets or sets the style applied to the taskbar.
Public Property | TaskBarVisible | Specifies whether task bar which contain opened windows list is visible.
Public Property | TextSettings | Contains text settings used by the control.
Public Property | ToolTip | The tooltip displayed when the mouse is over the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateItems | Gets or sets the items to be stored in view state storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | Gets or sets the server connection string for file server-based viewstate storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | Gets or sets the location to store the viewstate of this control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | Indicates whether the control is visible and rendered. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Width | The width of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | WindowArrangement | Gets or sets the default arrangement for all windows.
Public Property | WindowInteractiveMode | Specifies window intractivity behavior when it is resized or moved using mouse. To improve user interactivity, set this property to Shadow.
Public Property | Windows | Contains collection of WebDesktopWindow object.
Public Property | WindowSettings | Contains default settings for WebDesktopWindow object.
Public Property | XmlCompressionEnabled | Specifies whether the Xml used for clientside state storage should be compressed. (Inherited from ISNet.WebUI.ISNetControl)
Top

See Also

Reference

WebDesktopManager Class
ISNet.WebUI.WebDesktop Namespace

Concepts

WebDesktopManager Overview
Desktop
WebDesktop Concepts
WebDesktop Features
Shortcut
Working with ClickAndEdit and Designers

Tasks

Creating Simple Desktop
Configuring Desktop to use VerticalTile WindowArrangement
Using IFrame as ContentMode

concepts

Using Component Editor
Working with Properties Manager
Working with Layout Manager
Working with Structure Manager


WebDesktopManager Constructor

[image]
Intersoft WebDesktop Documentation
WebDesktopManager Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : WebDesktopManager Constructor

Glossary Item Box

Initializes a new instance of the WebDesktopManager class.

Overload List

Overload | Description
WebDesktopManager Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


ActiveWindowIndex Property

[image]
Intersoft WebDesktop Documentation
ActiveWindowIndex Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : ActiveWindowIndex Property

Glossary Item Box

Gets or sets the Window index which is currently active.

Syntax

Visual Basic (Declaration)
Public Property ActiveWindowIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As Integer

instance.ActiveWindowIndex = value

value = instance.ActiveWindowIndex
C#
public int ActiveWindowIndex {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


AnimationStyle Property

[image]
Intersoft WebDesktop Documentation
AnimationStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : AnimationStyle Property

Glossary Item Box

Specifies the animation style applied to the window.

Syntax

Visual Basic (Declaration)
Public Property AnimationStyle As WindowAnimationStyle
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As WindowAnimationStyle

instance.AnimationStyle = value

value = instance.AnimationStyle
C#
public WindowAnimationStyle AnimationStyle {get; set;}

Remarks

The new WebDesktopManager now includes visually-compelling Vista-like animation when you open or close a WebDesktopWindow. When this feature is enabled, the window will be zoomed in when open (or being shown). Likewise, the window will be zoomed out of view when closed (or being hidden).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members

Tasks

How-to: Enable Vista-style zoom animation in WebDesktopManager

Concepts

WebDesktopManager Features
WebDesktopManager Vista-style animation


BackColor Property

[image]
Intersoft WebDesktop Documentation
BackColor Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : BackColor Property

Glossary Item Box

Color of the background of the control.

Syntax

Visual Basic (Declaration)
Public Overrides Property BackColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
C#
public override System.Drawing.Color BackColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


BorderColor Property

[image]
Intersoft WebDesktop Documentation
BorderColor Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : BorderColor Property

Glossary Item Box

Border color of the controls aplied with this style.

Syntax

Visual Basic (Declaration)
Public Overrides Property BorderColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As System.Drawing.Color

instance.BorderColor = value

value = instance.BorderColor
C#
public override System.Drawing.Color BorderColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


BorderStyle Property

[image]
Intersoft WebDesktop Documentation
BorderStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : BorderStyle Property

Glossary Item Box

Style of the border around the control.

Syntax

Visual Basic (Declaration)
Public Overrides Property BorderStyle As System.Web.UI.WebControls.BorderStyle
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As System.Web.UI.WebControls.BorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
C#
public override System.Web.UI.WebControls.BorderStyle BorderStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


BorderWidth Property

[image]
Intersoft WebDesktop Documentation
BorderWidth Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : BorderWidth Property

Glossary Item Box

Width of the border around the control.

Syntax

Visual Basic (Declaration)
Public Overrides Property BorderWidth As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As System.Web.UI.WebControls.Unit

instance.BorderWidth = value

value = instance.BorderWidth
C#
public override System.Web.UI.WebControls.Unit BorderWidth {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


CacheImageResources Property

[image]
Intersoft WebDesktop Documentation
CacheImageResources Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : CacheImageResources Property

Glossary Item Box

Specifies whether all image-type resources should be automatically cached by browsers.

Syntax

Visual Basic (Declaration)
Public Property CacheImageResources As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As Boolean

instance.CacheImageResources = value

value = instance.CacheImageResources
C#
public bool CacheImageResources {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


ClientIDMode Property

[image]
Intersoft WebDesktop Documentation
ClientIDMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : ClientIDMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ClientIDMode As System.Web.UI.ClientIDMode
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As System.Web.UI.ClientIDMode

instance.ClientIDMode = value

value = instance.ClientIDMode
C#
public virtual System.Web.UI.ClientIDMode ClientIDMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


ClientSideEvents Property

[image]
Intersoft WebDesktop Documentation
ClientSideEvents Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : ClientSideEvents Property

Glossary Item Box

Contains client side events supported by WebDesktopManager.

Syntax

Visual Basic (Declaration)
Public Property ClientSideEvents As WebDesktopClientSideEvents
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As WebDesktopClientSideEvents

instance.ClientSideEvents = value

value = instance.ClientSideEvents
C#
public WebDesktopClientSideEvents ClientSideEvents {get; set;}

Remarks

Client side events are the way to achieve the greatest level of extensibility where developers can integrate their own algorithm or logic when specific events are occurred. DesktopManager offers up to 17 client events, from context menu, control initialize, shortcut selected and created to complete window events such as creation, moved, destroyed, resized and more.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members

Concepts

Working with ClientSide Events
Advanced ClientSide Events

concepts

WebDesktop Features


ControlDataTransferFormat Property

[image]
Intersoft WebDesktop Documentation
ControlDataTransferFormat Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : ControlDataTransferFormat Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ControlDataTransferFormat As ISNet.WebUI.DataTransferFormat
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As ISNet.WebUI.DataTransferFormat

instance.ControlDataTransferFormat = value

value = instance.ControlDataTransferFormat
C#
public virtual ISNet.WebUI.DataTransferFormat ControlDataTransferFormat {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


EnableAnimation Property

[image]
Intersoft WebDesktop Documentation
EnableAnimation Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : EnableAnimation Property

Glossary Item Box

Determines whether there should be animated sequences during Window's minimize, maximize and activate.

Syntax

Visual Basic (Declaration)
Public Property EnableAnimation As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As Boolean

instance.EnableAnimation = value

value = instance.EnableAnimation
C#
public bool EnableAnimation {get; set;}

Remarks

You can enable the animation simply by setting the EnableAnimation to True. The animation architecture ensures your users to have complete peace of mind when interacting with the Desktop, Windows, Shortcuts and other DesktopManager elements.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members

Concepts

WebDesktop Features
WebDesktopManager Vista-style animation

Tasks

How-to: Enable Vista-style zoom animation in WebDesktopManager


EnableContextMenu Property

[image]
Intersoft WebDesktop Documentation
EnableContextMenu Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : EnableContextMenu Property

Glossary Item Box

Determines whether built-in context menu for Window and Desktop is enabled.

Syntax

Visual Basic (Declaration)
Public Property EnableContextMenu As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As Boolean

instance.EnableContextMenu = value

value = instance.EnableContextMenu
C#
public bool EnableContextMenu {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


Enabled Property

[image]
Intersoft WebDesktop Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : Enabled Property

Glossary Item Box

Enables state of the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property Enabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As Boolean

instance.Enabled = value

value = instance.Enabled
C#
public virtual bool Enabled {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


EnableKeyboardNavigation Property

[image]
Intersoft WebDesktop Documentation
EnableKeyboardNavigation Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : EnableKeyboardNavigation Property

Glossary Item Box

Determines whether keyboard navigation is enabled.

Syntax

Visual Basic (Declaration)
Public Property EnableKeyboardNavigation As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As Boolean

instance.EnableKeyboardNavigation = value

value = instance.EnableKeyboardNavigation
C#
public bool EnableKeyboardNavigation {get; set;}

Remarks

The keyboard support in WebDesktopManager has been extensively implemented to work under Internet Explorer and Gecko-based browsers. The supported keyboard actions includes fast windows switching in ascending or descending order, closing window, arrow key navigation for shortcuts when focus is on the desktop, as well as Task Manager like switching. The extensive keyboard support means that the DesktopManager automatically complies to U.S. Section 508 Accessibility standard.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members

Concepts

WebDesktop Features


EnableManagedTheming Property

[image]
Intersoft WebDesktop Documentation
EnableManagedTheming Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : EnableManagedTheming Property

Glossary Item Box

Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.

Syntax

Visual Basic (Declaration)
Public Overridable Property EnableManagedTheming As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As Boolean

instance.EnableManagedTheming = value

value = instance.EnableManagedTheming
C#
public virtual bool EnableManagedTheming {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


EnableTheming Property

[image]
Intersoft WebDesktop Documentation
EnableTheming Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : EnableTheming Property

Glossary Item Box

Indicates whether the control can be themed.

Syntax

Visual Basic (Declaration)
Public Overridable Property EnableTheming As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As Boolean

instance.EnableTheming = value

value = instance.EnableTheming
C#
public virtual bool EnableTheming {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


EnableViewState Property

[image]
Intersoft WebDesktop Documentation
EnableViewState Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : EnableViewState Property

Glossary Item Box

Indicates whether the control automatically saves its state for use in round-trips.

Syntax

Visual Basic (Declaration)
Public Overridable Property EnableViewState As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As Boolean

instance.EnableViewState = value

value = instance.EnableViewState
C#
public virtual bool EnableViewState {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


EnableWebResources Property

[image]
Intersoft WebDesktop Documentation
EnableWebResources Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : EnableWebResources Property

Glossary Item Box

Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory).

Syntax

Visual Basic (Declaration)
Public Property EnableWebResources As ISNet.WebUI.WebResourceType
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As ISNet.WebUI.WebResourceType

instance.EnableWebResources = value

value = instance.EnableWebResources
C#
public ISNet.WebUI.WebResourceType EnableWebResources {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


Font Property

[image]
Intersoft WebDesktop Documentation
Font Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : Font Property

Glossary Item Box

The font used for text within the control.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Font As System.Web.UI.WebControls.FontInfo
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As System.Web.UI.WebControls.FontInfo

value = instance.Font
C#
public override System.Web.UI.WebControls.FontInfo Font {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


ForeColor Property

[image]
Intersoft WebDesktop Documentation
ForeColor Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : ForeColor Property

Glossary Item Box

Color of the text within the control.

Syntax

Visual Basic (Declaration)
Public Overrides Property ForeColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
C#
public override System.Drawing.Color ForeColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


FrameStyle Property

[image]
Intersoft WebDesktop Documentation
FrameStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : FrameStyle Property

Glossary Item Box

Gets or sets the style applied to Frame style of the desktop manager.

Syntax

Visual Basic (Declaration)
Public Property FrameStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As ISNet.WebUI.WebStyle

instance.FrameStyle = value

value = instance.FrameStyle
C#
public ISNet.WebUI.WebStyle FrameStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


Height Property

[image]
Intersoft WebDesktop Documentation
Height Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : Height Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Height As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As System.Web.UI.WebControls.Unit

instance.Height = value

value = instance.Height
C#
public virtual System.Web.UI.WebControls.Unit Height {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


ID Property

[image]
Intersoft WebDesktop Documentation
ID Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : ID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ID As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As String

instance.ID = value

value = instance.ID
C#
public virtual string ID {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


ImagesDirectory Property

[image]
Intersoft WebDesktop Documentation
ImagesDirectory Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : ImagesDirectory Property

Glossary Item Box

Gets or sets the images directory used by ImageSettings.

Syntax

Visual Basic (Declaration)
Public Property ImagesDirectory As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As String

instance.ImagesDirectory = value

value = instance.ImagesDirectory
C#
public string ImagesDirectory {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


ImagesSettings Property

[image]
Intersoft WebDesktop Documentation
ImagesSettings Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : ImagesSettings Property

Glossary Item Box

Contains images settings.

Syntax

Visual Basic (Declaration)
Public Property ImagesSettings As WebDesktopImagesSettings
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As WebDesktopImagesSettings

instance.ImagesSettings = value

value = instance.ImagesSettings
C#
public WebDesktopImagesSettings ImagesSettings {get; set;}

Remarks

In WebDesktopManager there are more than 20 ImagesSettings properties provided in order to let developers to design high detailed, gradient, shadowed or round corner style of border. Developer would be able to design virtually any kind of skins or styles as significant added value for end user experience.

In order to enable higher level of customization, DesktopManager offers ComplexImages BorderType. The term "ComplexImages" indicates that the rendering will use many images to draw up an element.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


LoaderProgressStyle Property

[image]
Intersoft WebDesktop Documentation
LoaderProgressStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : LoaderProgressStyle Property

Glossary Item Box

Gets or sets the style applied to the loader's progress bar.

Syntax

Visual Basic (Declaration)
Public Property LoaderProgressStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As ISNet.WebUI.WebStyle

instance.LoaderProgressStyle = value

value = instance.LoaderProgressStyle
C#
public ISNet.WebUI.WebStyle LoaderProgressStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


LoaderSettings Property

[image]
Intersoft WebDesktop Documentation
LoaderSettings Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : LoaderSettings Property

Glossary Item Box

Provides settings for desktop loader.

Syntax

Visual Basic (Declaration)
Public Property LoaderSettings As WebDesktopLoaderSettings
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As WebDesktopLoaderSettings

instance.LoaderSettings = value

value = instance.LoaderSettings
C#
public WebDesktopLoaderSettings LoaderSettings {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


LoaderStyle Property

[image]
Intersoft WebDesktop Documentation
LoaderStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : LoaderStyle Property

Glossary Item Box

Gets or sets the template for the DesktopManager loader.

Syntax

Visual Basic (Declaration)
Public Property LoaderStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As ISNet.WebUI.WebStyle

instance.LoaderStyle = value

value = instance.LoaderStyle
C#
public ISNet.WebUI.WebStyle LoaderStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


MenuStyles Property

[image]
Intersoft WebDesktop Documentation
MenuStyles Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : MenuStyles Property

Glossary Item Box

Contains styles and appearance settings for Menu system.

Syntax

Visual Basic (Declaration)
Public Property MenuStyles As WebDesktopMenuStyles
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As WebDesktopMenuStyles

instance.MenuStyles = value

value = instance.MenuStyles
C#
public WebDesktopMenuStyles MenuStyles {get; set;}

Remarks

MenuStyles includes two global styles for Menu, which are System and Application.

  • System
    The menu style used in DesktopManager's system menu, such as in Desktop context menu (when right click on desktop) and in Context menu (when right click on title bar)
  • Application
    This style definition will be used for all Menu instances in the application.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members

Concepts

Styles Inheritance model for Uniform Look and Feel across entire Application.


Page Property

[image]
Intersoft WebDesktop Documentation
Page Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : Page Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Page As System.Web.UI.Page
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As System.Web.UI.Page

instance.Page = value

value = instance.Page
C#
public virtual System.Web.UI.Page Page {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


RenderingMode Property

[image]
Intersoft WebDesktop Documentation
RenderingMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : RenderingMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property RenderingMode As ISNet.WebUI.RenderMode
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As ISNet.WebUI.RenderMode

instance.RenderingMode = value

value = instance.RenderingMode
C#
public virtual ISNet.WebUI.RenderMode RenderingMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


RuntimeLicenseKey Property

[image]
Intersoft WebDesktop Documentation
RuntimeLicenseKey Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : RuntimeLicenseKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property RuntimeLicenseKey As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As String

instance.RuntimeLicenseKey = value

value = instance.RuntimeLicenseKey
C#
public virtual string RuntimeLicenseKey {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


ScriptDirectory Property

[image]
Intersoft WebDesktop Documentation
ScriptDirectory Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : ScriptDirectory Property

Glossary Item Box

Gets or sets the directory where all required scripts for the control are stored.

Syntax

Visual Basic (Declaration)
Public Overrides Property ScriptDirectory As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As String

instance.ScriptDirectory = value

value = instance.ScriptDirectory
C#
public override string ScriptDirectory {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


ShadowModeAnimation Property

[image]
Intersoft WebDesktop Documentation
ShadowModeAnimation Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : ShadowModeAnimation Property

Glossary Item Box

When WindowInteractiveMode is set to Shadow and ShadowMode Transparency is True. This property specifies whether the transparent shadow should be animated.

Syntax

Visual Basic (Declaration)
Public Property ShadowModeAnimation As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As Boolean

instance.ShadowModeAnimation = value

value = instance.ShadowModeAnimation
C#
public bool ShadowModeAnimation {get; set;}

Remarks

To change the interactivity mode to Shadow, simply set the WindowInteractiveMode to Shadow in the WebDesktopManager instance.

There are two new properties related to this feature:

  1. ShadowModeAnimation
    The default value is false. This property allows you to add nice fading effect when the moving and resizing is performed in Shadow mode. However, the animation effect is not suitable for complex Web application as it could slow down the screen rendering while performing interaction.
  2. ShadowModeTransparency
    By default, the desktop manager screen would be 100% transparent when the moving and resizing is performed in Shadow mode. When this property is set to true, the background of desktop manager will be dimmed to 50% transparent to give user better focus on the interactive operation. The above screenshot shows the ShadowModeTransparency enabled.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members

Concepts

Shadow mode support for window moving and resizing


ShadowModeTransparency Property

[image]
Intersoft WebDesktop Documentation
ShadowModeTransparency Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : ShadowModeTransparency Property

Glossary Item Box

When WindowInteractiveMode is set to Shadow, this property specifies whether the transparent visual effect should be applied to the background of the desktop manager.

Syntax

Visual Basic (Declaration)
Public Property ShadowModeTransparency As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As Boolean

instance.ShadowModeTransparency = value

value = instance.ShadowModeTransparency
C#
public bool ShadowModeTransparency {get; set;}

Remarks

To change the interactivity mode to Shadow, simply set the WindowInteractiveMode to Shadow in the WebDesktopManager instance.

There are two new properties related to this feature:

  1. ShadowModeAnimation
    The default value is false. This property allows you to add nice fading effect when the moving and resizing is performed in Shadow mode. However, the animation effect is not suitable for complex Web application as it could slow down the screen rendering while performing interaction.
  2. ShadowModeTransparency
    By default, the desktop manager screen would be 100% transparent when the moving and resizing is performed in Shadow mode. When this property is set to true, the background of desktop manager will be dimmed to 50% transparent to give user better focus on the interactive operation. The above screenshot shows the ShadowModeTransparency enabled.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members

Concepts

Shadow mode support for window moving and resizing


SharedScriptDirectory Property

[image]
Intersoft WebDesktop Documentation
SharedScriptDirectory Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : SharedScriptDirectory Property

Glossary Item Box

Gets or sets the directory where all shared scripts for Intersoft controls are stored.

Syntax

Visual Basic (Declaration)
Public Overrides Property SharedScriptDirectory As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As String

instance.SharedScriptDirectory = value

value = instance.SharedScriptDirectory
C#
public override string SharedScriptDirectory {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


ShortcutDisplayMode Property

[image]
Intersoft WebDesktop Documentation
ShortcutDisplayMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : ShortcutDisplayMode Property

Glossary Item Box

Gets or sets the display mode of the shortcut icons.

Syntax

Visual Basic (Declaration)
Public Property ShortcutDisplayMode As ShortcutDisplayMode
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As ShortcutDisplayMode

instance.ShortcutDisplayMode = value

value = instance.ShortcutDisplayMode
C#
public ShortcutDisplayMode ShortcutDisplayMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


ShortcutIcons Property

[image]
Intersoft WebDesktop Documentation
ShortcutIcons Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : ShortcutIcons Property

Glossary Item Box

Contains collection of WebDesktopShorcut object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ShortcutIcons As WebDesktopShortcutCollection
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As WebDesktopShortcutCollection

value = instance.ShortcutIcons
C#
public WebDesktopShortcutCollection ShortcutIcons {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


ShortcutIconsVisible Property

[image]
Intersoft WebDesktop Documentation
ShortcutIconsVisible Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : ShortcutIconsVisible Property

Glossary Item Box

Specifies whether shortcut icons are visible.

Syntax

Visual Basic (Declaration)
Public Property ShortcutIconsVisible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As Boolean

instance.ShortcutIconsVisible = value

value = instance.ShortcutIconsVisible
C#
public bool ShortcutIconsVisible {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members

Tasks

Enabling ShortcutIcons feature


ShortcutSettings Property

[image]
Intersoft WebDesktop Documentation
ShortcutSettings Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : ShortcutSettings Property

Glossary Item Box

Contains settings for desktop shortcut icons.

Syntax

Visual Basic (Declaration)
Public Property ShortcutSettings As WebDesktopShortcutSettings
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As WebDesktopShortcutSettings

instance.ShortcutSettings = value

value = instance.ShortcutSettings
C#
public WebDesktopShortcutSettings ShortcutSettings {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


ShortcutStyle Property

[image]
Intersoft WebDesktop Documentation
ShortcutStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : ShortcutStyle Property

Glossary Item Box

Gets or sets the interactive style of the shortcut icon.

Syntax

Visual Basic (Declaration)
Public Property ShortcutStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As ISNet.WebUI.DynamicStyle

instance.ShortcutStyle = value

value = instance.ShortcutStyle
C#
public ISNet.WebUI.DynamicStyle ShortcutStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


SkinID Property

[image]
Intersoft WebDesktop Documentation
SkinID Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : SkinID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property SkinID As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As String

instance.SkinID = value

value = instance.SkinID
C#
public virtual string SkinID {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


TabIndex Property

[image]
Intersoft WebDesktop Documentation
TabIndex Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : TabIndex Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property TabIndex As Short
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As Short

instance.TabIndex = value

value = instance.TabIndex
C#
public virtual short TabIndex {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


TaskBarButtonStyle Property

[image]
Intersoft WebDesktop Documentation
TaskBarButtonStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : TaskBarButtonStyle Property

Glossary Item Box

Gets os sets the interactive window button style of the task bar.

Syntax

Visual Basic (Declaration)
Public Property TaskBarButtonStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As ISNet.WebUI.DynamicStyle

instance.TaskBarButtonStyle = value

value = instance.TaskBarButtonStyle
C#
public ISNet.WebUI.DynamicStyle TaskBarButtonStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


TaskBarSettings Property

[image]
Intersoft WebDesktop Documentation
TaskBarSettings Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : TaskBarSettings Property

Glossary Item Box

Contains task bar settings.

Syntax

Visual Basic (Declaration)
Public Property TaskBarSettings As WebDesktopTaskBarSettings
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As WebDesktopTaskBarSettings

instance.TaskBarSettings = value

value = instance.TaskBarSettings
C#
public WebDesktopTaskBarSettings TaskBarSettings {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members

Concepts

WebDesktop Features


TaskBarStyle Property

[image]
Intersoft WebDesktop Documentation
TaskBarStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : TaskBarStyle Property

Glossary Item Box

Gets or sets the style applied to the taskbar.

Syntax

Visual Basic (Declaration)
Public Property TaskBarStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As ISNet.WebUI.WebStyle

instance.TaskBarStyle = value

value = instance.TaskBarStyle
C#
public ISNet.WebUI.WebStyle TaskBarStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


TaskBarVisible Property

[image]
Intersoft WebDesktop Documentation
TaskBarVisible Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : TaskBarVisible Property

Glossary Item Box

Specifies whether task bar which contain opened windows list is visible.

Syntax

Visual Basic (Declaration)
Public Property TaskBarVisible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As Boolean

instance.TaskBarVisible = value

value = instance.TaskBarVisible
C#
public bool TaskBarVisible {get; set;}

Remarks

You can easily enable TaskBarVisible by configuring this property to True. TaskBar is used as the placeholder where open Windows are shown. Moreover, the TaskBar can also be used to hold other objects in the left and right side of the WindowGroupButton area by configuring the TaskBarLeftTemplate and TaskBarRightTemplate.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


TextSettings Property

[image]
Intersoft WebDesktop Documentation
TextSettings Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : TextSettings Property

Glossary Item Box

Contains text settings used by the control.

Syntax

Visual Basic (Declaration)
Public Property TextSettings As WebDesktopTextSettings
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As WebDesktopTextSettings

instance.TextSettings = value

value = instance.TextSettings
C#
public WebDesktopTextSettings TextSettings {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


ToolTip Property

[image]
Intersoft WebDesktop Documentation
ToolTip Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : ToolTip Property

Glossary Item Box

The tooltip displayed when the mouse is over the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property ToolTip As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As String

instance.ToolTip = value

value = instance.ToolTip
C#
public virtual string ToolTip {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


ValidateRequestMode Property

[image]
Intersoft WebDesktop Documentation
ValidateRequestMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : ValidateRequestMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ValidateRequestMode As System.Web.UI.ValidateRequestMode
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As System.Web.UI.ValidateRequestMode

instance.ValidateRequestMode = value

value = instance.ValidateRequestMode
C#
public virtual System.Web.UI.ValidateRequestMode ValidateRequestMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


ViewStateItems Property

[image]
Intersoft WebDesktop Documentation
ViewStateItems Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : ViewStateItems Property

Glossary Item Box

Gets or sets the items to be stored in view state storage.

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateItems As ISNet.WebUI.ViewStateItem
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As ISNet.WebUI.ViewStateItem

instance.ViewStateItems = value

value = instance.ViewStateItems
C#
public virtual ISNet.WebUI.ViewStateItem ViewStateItems {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


ViewStateMode Property

[image]
Intersoft WebDesktop Documentation
ViewStateMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : ViewStateMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateMode As System.Web.UI.ViewStateMode
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As System.Web.UI.ViewStateMode

instance.ViewStateMode = value

value = instance.ViewStateMode
C#
public virtual System.Web.UI.ViewStateMode ViewStateMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


ViewStateServerConnection Property

[image]
Intersoft WebDesktop Documentation
ViewStateServerConnection Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : ViewStateServerConnection Property

Glossary Item Box

Gets or sets the server connection string for file server-based viewstate storage.

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateServerConnection As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As String

instance.ViewStateServerConnection = value

value = instance.ViewStateServerConnection
C#
public virtual string ViewStateServerConnection {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


ViewStateStorage Property

[image]
Intersoft WebDesktop Documentation
ViewStateStorage Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : ViewStateStorage Property

Glossary Item Box

Gets or sets the location to store the viewstate of this control.

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateStorage As ISNet.WebUI.StateCacheStorage
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As ISNet.WebUI.StateCacheStorage

instance.ViewStateStorage = value

value = instance.ViewStateStorage
C#
public virtual ISNet.WebUI.StateCacheStorage ViewStateStorage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


Visible Property

[image]
Intersoft WebDesktop Documentation
Visible Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : Visible Property

Glossary Item Box

Indicates whether the control is visible and rendered.

Syntax

Visual Basic (Declaration)
Public Overridable Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public virtual bool Visible {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


Width Property

[image]
Intersoft WebDesktop Documentation
Width Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : Width Property

Glossary Item Box

The width of the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property Width As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As System.Web.UI.WebControls.Unit

instance.Width = value

value = instance.Width
C#
public virtual System.Web.UI.WebControls.Unit Width {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


WindowArrangement Property

[image]
Intersoft WebDesktop Documentation
WindowArrangement Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : WindowArrangement Property

Glossary Item Box

Gets or sets the default arrangement for all windows.

Syntax

Visual Basic (Declaration)
Public Property WindowArrangement As WindowArrangementMode
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As WindowArrangementMode

instance.WindowArrangement = value

value = instance.WindowArrangement
C#
public WindowArrangementMode WindowArrangement {get; set;}

Remarks

Using this property you can easily arrange the window to one of three predefined window arrangement, such as Cascaded, TiledHorizontally or TiledVertically.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members

Tasks

Configuring Desktop to use VerticalTile WindowArrangement

Concepts

WebDesktop Features


WindowInteractiveMode Property

[image]
Intersoft WebDesktop Documentation
WindowInteractiveMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : WindowInteractiveMode Property

Glossary Item Box

Specifies window intractivity behavior when it is resized or moved using mouse. To improve user interactivity, set this property to Shadow.

Syntax

Visual Basic (Declaration)
Public Property WindowInteractiveMode As InteractivityMode
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As InteractivityMode

instance.WindowInteractiveMode = value

value = instance.WindowInteractiveMode
C#
public InteractivityMode WindowInteractiveMode {get; set;}

Remarks

To change the interactivity mode to Shadow, simply set the WindowInteractiveMode to Shadow in the WebDesktopManager instance.

There are two new properties related to this feature:

  1. ShadowModeAnimation
    The default value is false. This property allows you to add nice fading effect when the moving and resizing is performed in Shadow mode. However, the animation effect is not suitable for complex Web application as it could slow down the screen rendering while performing interaction.
  2. ShadowModeTransparency
    By default, the desktop manager screen would be 100% transparent when the moving and resizing is performed in Shadow mode. When this property is set to true, the background of desktop manager will be dimmed to 50% transparent to give user better focus on the interactive operation. The above screenshot shows the ShadowModeTransparency enabled.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members

Concepts

Shadow mode support for window moving and resizing


Windows Property

[image]
Intersoft WebDesktop Documentation
Windows Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : Windows Property

Glossary Item Box

Contains collection of WebDesktopWindow object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Windows As WebDesktopWindowCollection
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As WebDesktopWindowCollection

value = instance.Windows
C#
public WebDesktopWindowCollection Windows {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


WindowSettings Property

[image]
Intersoft WebDesktop Documentation
WindowSettings Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : WindowSettings Property

Glossary Item Box

Contains default settings for WebDesktopWindow object.

Syntax

Visual Basic (Declaration)
Public Property WindowSettings As WebDesktopWindowSettings
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As WebDesktopWindowSettings

instance.WindowSettings = value

value = instance.WindowSettings
C#
public WebDesktopWindowSettings WindowSettings {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


XmlCompressionEnabled Property

[image]
Intersoft WebDesktop Documentation
XmlCompressionEnabled Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : XmlCompressionEnabled Property

Glossary Item Box

Specifies whether the Xml used for clientside state storage should be compressed.

Syntax

Visual Basic (Declaration)
Public Overridable Property XmlCompressionEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim value As Boolean

instance.XmlCompressionEnabled = value

value = instance.XmlCompressionEnabled
C#
public virtual bool XmlCompressionEnabled {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


DataBinding Event

[image]
Intersoft WebDesktop Documentation
DataBinding Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : DataBinding Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event DataBinding As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim handler As EventHandler

AddHandler instance.DataBinding, handler
C#
public event EventHandler DataBinding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


Disposed Event

[image]
Intersoft WebDesktop Documentation
Disposed Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim handler As EventHandler

AddHandler instance.Disposed, handler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


Init Event

[image]
Intersoft WebDesktop Documentation
Init Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : Init Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Init As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim handler As EventHandler

AddHandler instance.Init, handler
C#
public event EventHandler Init

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


Load Event

[image]
Intersoft WebDesktop Documentation
Load Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : Load Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Load As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim handler As EventHandler

AddHandler instance.Load, handler
C#
public event EventHandler Load

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


PreInitialize Event

[image]
Intersoft WebDesktop Documentation
PreInitialize Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : PreInitialize Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event PreInitialize As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim handler As EventHandler

AddHandler instance.PreInitialize, handler
C#
public event EventHandler PreInitialize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


PreRender Event

[image]
Intersoft WebDesktop Documentation
PreRender Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : PreRender Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event PreRender As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim handler As EventHandler

AddHandler instance.PreRender, handler
C#
public event EventHandler PreRender

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


Unload Event

[image]
Intersoft WebDesktop Documentation
Unload Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopManager Class : Unload Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Unload As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopManager
Dim handler As EventHandler

AddHandler instance.Unload, handler
C#
public event EventHandler Unload

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopManager Class
WebDesktopManager Members


WebDesktopMenuStyles Class

[image]
Intersoft WebDesktop Documentation
WebDesktopMenuStyles Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopMenuStyles Class

Glossary Item Box

The predefined styles provided by WebDesktopManager.

Object Model

WebDesktopMenuStyles Class

Syntax

Visual Basic (Declaration)
Public Class WebDesktopMenuStyles
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopMenuStyles
C#
public class WebDesktopMenuStyles : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebDesktop.WebDesktopMenuStyles

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopMenuStyles Members
ISNet.WebUI.WebDesktop Namespace


WebDesktopMenuStyles Class Members

[image]
Intersoft WebDesktop Documentation
WebDesktopMenuStyles Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopMenuStyles Class

Glossary Item Box

The following tables list the members exposed by WebDesktopMenuStyles.

Public Constructors

 | Name | Description
Public Constructor | WebDesktopMenuStyles Constructor |
Top

Public Properties

 | Name | Description
Public Property | Application | Gets or sets the default menu styles for application.
Public Property | System | Gets or sets the menu style used in Desktop Manager system.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebDesktopMenuStyles Class
ISNet.WebUI.WebDesktop Namespace


WebDesktopMenuStyles Constructor

[image]
Intersoft WebDesktop Documentation
WebDesktopMenuStyles Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopMenuStyles Class : WebDesktopMenuStyles Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebDesktopMenuStyles()
C#
public WebDesktopMenuStyles()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopMenuStyles Class
WebDesktopMenuStyles Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopMenuStyles Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopMenuStyles
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopMenuStyles Class
WebDesktopMenuStyles Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopMenuStyles Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopMenuStyles Class
WebDesktopMenuStyles Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopMenuStyles Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopMenuStyles
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopMenuStyles Class
WebDesktopMenuStyles Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopMenuStyles Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopMenuStyles
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopMenuStyles Class
WebDesktopMenuStyles Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopMenuStyles Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopMenuStyles
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopMenuStyles Class
WebDesktopMenuStyles Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopMenuStyles Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopMenuStyles
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopMenuStyles Class
WebDesktopMenuStyles Members


WebDesktopMenuStyles Class Methods

[image]
Intersoft WebDesktop Documentation
WebDesktopMenuStyles Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopMenuStyles Class

Glossary Item Box

For a list of all members of this type, see WebDesktopMenuStyles members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebDesktopMenuStyles Class
ISNet.WebUI.WebDesktop Namespace


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopMenuStyles Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopMenuStyles
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopMenuStyles Class
WebDesktopMenuStyles Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopMenuStyles Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopMenuStyles
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopMenuStyles Class
WebDesktopMenuStyles Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopMenuStyles Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopMenuStyles

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopMenuStyles Class
WebDesktopMenuStyles Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopMenuStyles Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopMenuStyles
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopMenuStyles Class
WebDesktopMenuStyles Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopMenuStyles Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopMenuStyles
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopMenuStyles Class
WebDesktopMenuStyles Members


WebDesktopMenuStyles Class Properties

[image]
Intersoft WebDesktop Documentation
WebDesktopMenuStyles Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopMenuStyles Class

Glossary Item Box

For a list of all members of this type, see WebDesktopMenuStyles members.

Public Properties

 | Name | Description
Public Property | Application | Gets or sets the default menu styles for application.
Public Property | System | Gets or sets the menu style used in Desktop Manager system.
Top

See Also

Reference

WebDesktopMenuStyles Class
ISNet.WebUI.WebDesktop Namespace


WebDesktopMenuStyles Constructor

[image]
Intersoft WebDesktop Documentation
WebDesktopMenuStyles Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopMenuStyles Class : WebDesktopMenuStyles Constructor

Glossary Item Box

Initializes a new instance of the WebDesktopMenuStyles class.

Overload List

Overload | Description
WebDesktopMenuStyles Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopMenuStyles Class
WebDesktopMenuStyles Members


Application Property

[image]
Intersoft WebDesktop Documentation
Application Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopMenuStyles Class : Application Property

Glossary Item Box

Gets or sets the default menu styles for application.

Syntax

Visual Basic (Declaration)
Public Property Application As WebMenuStyles
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopMenuStyles
Dim value As WebMenuStyles

instance.Application = value

value = instance.Application
C#
public WebMenuStyles Application {get; set;}

Remarks

The application style of the menu applied to WebDesktop.NET components can be integrated to DesktopManager, such as PlaceHolderManager, WebToolBar or ContextMenu.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopMenuStyles Class
WebDesktopMenuStyles Members


System Property

[image]
Intersoft WebDesktop Documentation
System Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopMenuStyles Class : System Property

Glossary Item Box

Gets or sets the menu style used in Desktop Manager system.

Syntax

Visual Basic (Declaration)
Public Property System As WebMenuStyles
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopMenuStyles
Dim value As WebMenuStyles

instance.System = value

value = instance.System
C#
public WebMenuStyles System {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopMenuStyles Class
WebDesktopMenuStyles Members


WebDesktopShortcut Class

[image]
Intersoft WebDesktop Documentation
WebDesktopShortcut Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopShortcut Class

Glossary Item Box

Shortcut system implemented by the WebDesktopManager as an essential user interface element. This new Shortcut system implementation enriches the existing navigation system by bringing the user-friendly concept of a Desktop into web application development.

Object Model

WebDesktopShortcut Class

Syntax

Visual Basic (Declaration)
Public Class WebDesktopShortcut
   Inherits ISNet.WebUI.NamedObjectBase
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcut
C#
public class WebDesktopShortcut : ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject

Remarks

A shortcut element in WebDesktopManager is represented as an Image and Text. The shortcut is selectable when clicked or navigated through keyboard arrow keys. A shortcut oftenly has ToolTip as well when the mouse is over the visible Image or Text area

A WebDesktopShortcut object includes important properties related to a Shortcut system, such as its Image, Text, ToolTip and what module that the Shortcut should launch when double clicked.

By default, the shortcut element is not enabled in DesktopManager when the first time you create it in design time. You can easily enable this feature by configuring ShortcutIconsVisible property to True.

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase
ISNet.WebUI.WebDesktop.WebDesktopShortcut

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcut Members
ISNet.WebUI.WebDesktop Namespace

Tasks

Enabling ShortcutIcons feature

Concepts

Shortcut

tasks

Adding new Shortcut at Client Side


WebDesktopShortcut Class Members

[image]
Intersoft WebDesktop Documentation
WebDesktopShortcut Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopShortcut Class

Glossary Item Box

The following tables list the members exposed by WebDesktopShortcut.

Public Constructors

 | Name | Description
Public Constructor | WebDesktopShortcut Constructor |
Top

Public Properties

 | Name | Description
Public Property | Enabled | Determines whether the shortcut is enabled.
Public Property | Image | Gets or sets the image of the shortcut icon.
Public Property | Location | Gets or sets the Location of the shortcut in the desktop. This property is ignored when AutoArrange is enabled.
Public Property | Name | Overridden. Gets or sets the name of the shortcut.
Public Property | TargetControlBoxImage | Gets or sets the image that should be used in the window's ControlBox when the Window is not exist yet.
Public Property | TargetURL | Gets or sets the target URL of the shortcut.
Public Property | TaskBarImage |
Public Property | Text | Gets or sets the text of the shortcut icon.
Public Property | ToolTip | Gets or sets the tooltip for this shortcut.
Public Property | Visible | Determines whether the shortcut is visible on the desktop.
Public Property | WindowName | Gets or sets the window name associated with this shortcut.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebDesktopShortcut Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Enabling ShortcutIcons feature

Concepts

Shortcut

tasks

Adding new Shortcut at Client Side


WebDesktopShortcut Constructor

[image]
Intersoft WebDesktop Documentation
WebDesktopShortcut Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcut Class : WebDesktopShortcut Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebDesktopShortcut()
C#
public WebDesktopShortcut()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcut Class
WebDesktopShortcut Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcut Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcut
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcut Class
WebDesktopShortcut Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcut Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcut Class
WebDesktopShortcut Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcut Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcut
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcut Class
WebDesktopShortcut Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcut Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcut
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcut Class
WebDesktopShortcut Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcut Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcut
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcut Class
WebDesktopShortcut Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcut Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcut
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcut Class
WebDesktopShortcut Members


WebDesktopShortcut Class Methods

[image]
Intersoft WebDesktop Documentation
WebDesktopShortcut Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopShortcut Class

Glossary Item Box

For a list of all members of this type, see WebDesktopShortcut members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebDesktopShortcut Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Enabling ShortcutIcons feature

Concepts

Shortcut

tasks

Adding new Shortcut at Client Side


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcut Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcut
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcut Class
WebDesktopShortcut Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcut Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcut
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcut Class
WebDesktopShortcut Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcut Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcut

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcut Class
WebDesktopShortcut Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcut Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcut
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcut Class
WebDesktopShortcut Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcut Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcut
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcut Class
WebDesktopShortcut Members


WebDesktopShortcut Class Properties

[image]
Intersoft WebDesktop Documentation
WebDesktopShortcut Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopShortcut Class

Glossary Item Box

For a list of all members of this type, see WebDesktopShortcut members.

Public Properties

 | Name | Description
Public Property | Enabled | Determines whether the shortcut is enabled.
Public Property | Image | Gets or sets the image of the shortcut icon.
Public Property | Location | Gets or sets the Location of the shortcut in the desktop. This property is ignored when AutoArrange is enabled.
Public Property | Name | Overridden. Gets or sets the name of the shortcut.
Public Property | TargetControlBoxImage | Gets or sets the image that should be used in the window's ControlBox when the Window is not exist yet.
Public Property | TargetURL | Gets or sets the target URL of the shortcut.
Public Property | TaskBarImage |
Public Property | Text | Gets or sets the text of the shortcut icon.
Public Property | ToolTip | Gets or sets the tooltip for this shortcut.
Public Property | Visible | Determines whether the shortcut is visible on the desktop.
Public Property | WindowName | Gets or sets the window name associated with this shortcut.
Top

See Also

Reference

WebDesktopShortcut Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Enabling ShortcutIcons feature

Concepts

Shortcut

tasks

Adding new Shortcut at Client Side


WebDesktopShortcut Constructor

[image]
Intersoft WebDesktop Documentation
WebDesktopShortcut Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcut Class : WebDesktopShortcut Constructor

Glossary Item Box

Initializes a new instance of the WebDesktopShortcut class.

Overload List

Overload | Description
WebDesktopShortcut Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcut Class
WebDesktopShortcut Members


Enabled Property

[image]
Intersoft WebDesktop Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcut Class : Enabled Property

Glossary Item Box

Determines whether the shortcut is enabled.

Syntax

Visual Basic (Declaration)
Public Property Enabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcut
Dim value As Boolean

instance.Enabled = value

value = instance.Enabled
C#
public bool Enabled {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcut Class
WebDesktopShortcut Members


Image Property

[image]
Intersoft WebDesktop Documentation
Image Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcut Class : Image Property

Glossary Item Box

Gets or sets the image of the shortcut icon.

Syntax

Visual Basic (Declaration)
Public Property Image As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcut
Dim value As String

instance.Image = value

value = instance.Image
C#
public string Image {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcut Class
WebDesktopShortcut Members


Location Property

[image]
Intersoft WebDesktop Documentation
Location Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcut Class : Location Property

Glossary Item Box

Gets or sets the Location of the shortcut in the desktop. This property is ignored when AutoArrange is enabled.

Syntax

Visual Basic (Declaration)
Public Property Location As System.Drawing.Point
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcut
Dim value As System.Drawing.Point

instance.Location = value

value = instance.Location
C#
public System.Drawing.Point Location {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcut Class
WebDesktopShortcut Members


Name Property

[image]
Intersoft WebDesktop Documentation
Name Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcut Class : Name Property

Glossary Item Box

Gets or sets the name of the shortcut.

Syntax

Visual Basic (Declaration)
Public Overrides Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcut
Dim value As String

instance.Name = value

value = instance.Name
C#
public override string Name {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcut Class
WebDesktopShortcut Members


TargetControlBoxImage Property

[image]
Intersoft WebDesktop Documentation
TargetControlBoxImage Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcut Class : TargetControlBoxImage Property

Glossary Item Box

Gets or sets the image that should be used in the window's ControlBox when the Window is not exist yet.

Syntax

Visual Basic (Declaration)
Public Property TargetControlBoxImage As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcut
Dim value As String

instance.TargetControlBoxImage = value

value = instance.TargetControlBoxImage
C#
public string TargetControlBoxImage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcut Class
WebDesktopShortcut Members


TargetURL Property

[image]
Intersoft WebDesktop Documentation
TargetURL Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcut Class : TargetURL Property

Glossary Item Box

Gets or sets the target URL of the shortcut.

Syntax

Visual Basic (Declaration)
Public Property TargetURL As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcut
Dim value As String

instance.TargetURL = value

value = instance.TargetURL
C#
public string TargetURL {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcut Class
WebDesktopShortcut Members


TaskBarImage Property

[image]
Intersoft WebDesktop Documentation
TaskBarImage Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcut Class : TaskBarImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property TaskBarImage As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcut
Dim value As String

instance.TaskBarImage = value

value = instance.TaskBarImage
C#
public string TaskBarImage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcut Class
WebDesktopShortcut Members


Text Property

[image]
Intersoft WebDesktop Documentation
Text Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcut Class : Text Property

Glossary Item Box

Gets or sets the text of the shortcut icon.

Syntax

Visual Basic (Declaration)
Public Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcut
Dim value As String

instance.Text = value

value = instance.Text
C#
public string Text {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcut Class
WebDesktopShortcut Members


ToolTip Property

[image]
Intersoft WebDesktop Documentation
ToolTip Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcut Class : ToolTip Property

Glossary Item Box

Gets or sets the tooltip for this shortcut.

Syntax

Visual Basic (Declaration)
Public Property ToolTip As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcut
Dim value As String

instance.ToolTip = value

value = instance.ToolTip
C#
public string ToolTip {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcut Class
WebDesktopShortcut Members


Visible Property

[image]
Intersoft WebDesktop Documentation
Visible Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcut Class : Visible Property

Glossary Item Box

Determines whether the shortcut is visible on the desktop.

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcut
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public bool Visible {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcut Class
WebDesktopShortcut Members


WindowName Property

[image]
Intersoft WebDesktop Documentation
WindowName Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcut Class : WindowName Property

Glossary Item Box

Gets or sets the window name associated with this shortcut.

Syntax

Visual Basic (Declaration)
Public Property WindowName As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcut
Dim value As String

instance.WindowName = value

value = instance.WindowName
C#
public string WindowName {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcut Class
WebDesktopShortcut Members


WebDesktopShortcutCollection Class

[image]
Intersoft WebDesktop Documentation
WebDesktopShortcutCollection Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopShortcutCollection Class

Glossary Item Box

Collection of WebDesktopShortcut.

Object Model

WebDesktopShortcutCollection Class

Syntax

Visual Basic (Declaration)
Public Class WebDesktopShortcutCollection
   Inherits ISNet.WebUI.ISCollectionBase
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcutCollection
C#
public class WebDesktopShortcutCollection : ISNet.WebUI.ISCollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
ISNet.WebUI.ISCollectionBase
ISNet.WebUI.WebDesktop.WebDesktopShortcutCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcutCollection Members
ISNet.WebUI.WebDesktop Namespace


WebDesktopShortcutCollection Class Members

[image]
Intersoft WebDesktop Documentation
WebDesktopShortcutCollection Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopShortcutCollection Class

Glossary Item Box

The following tables list the members exposed by WebDesktopShortcutCollection.

Public Constructors

 | Name | Description
Public Constructor | WebDesktopShortcutCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden. Returns a Boolean value indicating whether the collection is read-only.
Public Property | Item | Property indexer for the collection.
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebDesktopShortcutCollection Class
ISNet.WebUI.WebDesktop Namespace


WebDesktopShortcutCollection Constructor

[image]
Intersoft WebDesktop Documentation
WebDesktopShortcutCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcutCollection Class : WebDesktopShortcutCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebDesktopShortcutCollection()
C#
public WebDesktopShortcutCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcutCollection Class
WebDesktopShortcutCollection Members


WebDesktopShortcutCollection Class Methods

[image]
Intersoft WebDesktop Documentation
WebDesktopShortcutCollection Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopShortcutCollection Class

Glossary Item Box

For a list of all members of this type, see WebDesktopShortcutCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebDesktopShortcutCollection Class
ISNet.WebUI.WebDesktop Namespace


Add Method

[image]
Intersoft WebDesktop Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcutCollection Class : Add Method

Glossary Item Box

Overload List

Overload | Description
Add(WebDesktopShortcut) |
Add(String) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcutCollection Class
WebDesktopShortcutCollection Members


Add(WebDesktopShortcut) Method

[image]
Intersoft WebDesktop Documentation
Add(WebDesktopShortcut) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcutCollection Class > Add Method : Add(WebDesktopShortcut) Method

webDesktopShortcut

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function Add( _
   ByVal webDesktopShortcut As WebDesktopShortcut _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcutCollection
Dim webDesktopShortcut As WebDesktopShortcut
Dim value As Integer

value = instance.Add(webDesktopShortcut)
C#
public virtual int Add(
   WebDesktopShortcut webDesktopShortcut
)

Parameters

webDesktopShortcut

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcutCollection Class
WebDesktopShortcutCollection Members
Overload List


Add(String) Method

[image]
Intersoft WebDesktop Documentation
Add(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcutCollection Class > Add Method : Add(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal name As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcutCollection
Dim name As String
Dim value As Integer

value = instance.Add(name)
C#
public int Add(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcutCollection Class
WebDesktopShortcutCollection Members
Overload List


Clear Method

[image]
Intersoft WebDesktop Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcutCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcutCollection

instance.Clear()
C#
public new void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcutCollection Class
WebDesktopShortcutCollection Members


Contains Method

[image]
Intersoft WebDesktop Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcutCollection Class : Contains Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As ISNet.WebUI.INamedObject _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcutCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As Boolean

value = instance.Contains(value)
C#
public bool Contains(
   ISNet.WebUI.INamedObject value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcutCollection Class
WebDesktopShortcutCollection Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcutCollection Class : CopyFrom Method

passIn

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CopyFrom( _
   ByVal passIn As WebDesktopShortcutCollection _
) As WebDesktopShortcutCollection
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcutCollection
Dim passIn As WebDesktopShortcutCollection
Dim value As WebDesktopShortcutCollection

value = instance.CopyFrom(passIn)
C#
public WebDesktopShortcutCollection CopyFrom(
   WebDesktopShortcutCollection passIn
)

Parameters

passIn

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcutCollection Class
WebDesktopShortcutCollection Members


CopyTo Method

[image]
Intersoft WebDesktop Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcutCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcutCollection
Dim array() As ISNet.WebUI.INamedObject
Dim index As Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   ISNet.WebUI.INamedObject[] array,
   int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcutCollection Class
WebDesktopShortcutCollection Members


Exists Method

[image]
Intersoft WebDesktop Documentation
Exists Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcutCollection Class : Exists Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Exists( _
   ByVal name As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcutCollection
Dim name As String
Dim value As Boolean

value = instance.Exists(name)
C#
public bool Exists(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcutCollection Class
WebDesktopShortcutCollection Members


GetEnumerator Method

[image]
Intersoft WebDesktop Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcutCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Function GetEnumerator() As System.Collections.IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcutCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
public new System.Collections.IEnumerator GetEnumerator()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcutCollection Class
WebDesktopShortcutCollection Members


GetItem Method

[image]
Intersoft WebDesktop Documentation
GetItem Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcutCollection Class : GetItem Method

Glossary Item Box

Overload List

Overload | Description
GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcutCollection Class
WebDesktopShortcutCollection Members


GetItem(Int32) Method

[image]
Intersoft WebDesktop Documentation
GetItem(Int32) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcutCollection Class : GetItem(Int32) Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetItem( _
   ByVal index As Integer _
) As ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcutCollection
Dim index As Integer
Dim value As ISNet.WebUI.INamedObject

value = instance.GetItem(index)
C#
public virtual ISNet.WebUI.INamedObject GetItem(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcutCollection Class
WebDesktopShortcutCollection Members


GetNamedItem Method

[image]
Intersoft WebDesktop Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcutCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNamedItem( _
   ByVal name As String _
) As WebDesktopShortcut
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcutCollection
Dim name As String
Dim value As WebDesktopShortcut

value = instance.GetNamedItem(name)
C#
public WebDesktopShortcut GetNamedItem(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcutCollection Class
WebDesktopShortcutCollection Members


IndexOf Method

[image]
Intersoft WebDesktop Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcutCollection Class : IndexOf Method

Glossary Item Box

Overload List

Overload | Description
IndexOf(String) | (Inherited from ISNet.WebUI.ISCollectionBase)
IndexOf(INamedObject) | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcutCollection Class
WebDesktopShortcutCollection Members


IndexOf(String) Method

[image]
Intersoft WebDesktop Documentation
IndexOf(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcutCollection Class > IndexOf Method : IndexOf(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function IndexOf( _
   ByVal name As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcutCollection
Dim name As String
Dim value As Integer

value = instance.IndexOf(name)
C#
public virtual int IndexOf(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcutCollection Class
WebDesktopShortcutCollection Members
Overload List


IndexOf(INamedObject) Method

[image]
Intersoft WebDesktop Documentation
IndexOf(INamedObject) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcutCollection Class > IndexOf Method : IndexOf(INamedObject) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal value As ISNet.WebUI.INamedObject _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcutCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As Integer

value = instance.IndexOf(value)
C#
public int IndexOf(
   ISNet.WebUI.INamedObject value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcutCollection Class
WebDesktopShortcutCollection Members
Overload List


Insert Method

[image]
Intersoft WebDesktop Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcutCollection Class : Insert Method

index
webDesktopShortcut

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal webDesktopShortcut As WebDesktopShortcut _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcutCollection
Dim index As Integer
Dim webDesktopShortcut As WebDesktopShortcut

instance.Insert(index, webDesktopShortcut)
C#
public void Insert(
   int index,
   WebDesktopShortcut webDesktopShortcut
)

Parameters

index
webDesktopShortcut

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcutCollection Class
WebDesktopShortcutCollection Members


IntInsert Method

[image]
Intersoft WebDesktop Documentation
IntInsert Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcutCollection Class : IntInsert Method

index
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub IntInsert( _
   ByVal index As Integer, _
   ByVal value As ISNet.WebUI.INamedObject _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcutCollection
Dim index As Integer
Dim value As ISNet.WebUI.INamedObject

instance.IntInsert(index, value)
C#
public void IntInsert(
   int index,
   ISNet.WebUI.INamedObject value
)

Parameters

index
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcutCollection Class
WebDesktopShortcutCollection Members


Remove Method

[image]
Intersoft WebDesktop Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcutCollection Class : Remove Method

webDesktopShortcut

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal webDesktopShortcut As WebDesktopShortcut _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcutCollection
Dim webDesktopShortcut As WebDesktopShortcut

instance.Remove(webDesktopShortcut)
C#
public void Remove(
   WebDesktopShortcut webDesktopShortcut
)

Parameters

webDesktopShortcut

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcutCollection Class
WebDesktopShortcutCollection Members


setParent Method

[image]
Intersoft WebDesktop Documentation
setParent Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcutCollection Class : setParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub setParent( _
   ByVal parent As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcutCollection
Dim parent As Object

instance.setParent(parent)
C#
public virtual void setParent(
   object parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcutCollection Class
WebDesktopShortcutCollection Members


Capacity Property

[image]
Intersoft WebDesktop Documentation
Capacity Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcutCollection Class : Capacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcutCollection
Dim value As Integer

instance.Capacity = value

value = instance.Capacity
C#
public int Capacity {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcutCollection Class
WebDesktopShortcutCollection Members


Count Property

[image]
Intersoft WebDesktop Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcutCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcutCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcutCollection Class
WebDesktopShortcutCollection Members


WebDesktopShortcutCollection Class Properties

[image]
Intersoft WebDesktop Documentation
WebDesktopShortcutCollection Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopShortcutCollection Class

Glossary Item Box

For a list of all members of this type, see WebDesktopShortcutCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden. Returns a Boolean value indicating whether the collection is read-only.
Public Property | Item | Property indexer for the collection.
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebDesktopShortcutCollection Class
ISNet.WebUI.WebDesktop Namespace


WebDesktopShortcutCollection Constructor

[image]
Intersoft WebDesktop Documentation
WebDesktopShortcutCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcutCollection Class : WebDesktopShortcutCollection Constructor

Glossary Item Box

Initializes a new instance of the WebDesktopShortcutCollection class.

Overload List

Overload | Description
WebDesktopShortcutCollection Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcutCollection Class
WebDesktopShortcutCollection Members


IsReadOnly Property

[image]
Intersoft WebDesktop Documentation
IsReadOnly Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcutCollection Class : IsReadOnly Property

Glossary Item Box

Returns a Boolean value indicating whether the collection is read-only.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcutCollection
Dim value As Boolean

value = instance.IsReadOnly
C#
public override bool IsReadOnly {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcutCollection Class
WebDesktopShortcutCollection Members


Item Property

[image]
Intersoft WebDesktop Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcutCollection Class : Item Property

index

Glossary Item Box

Property indexer for the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As WebDesktopShortcut
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcutCollection
Dim index As Integer
Dim value As WebDesktopShortcut

value = instance.Item(index)
C#
public WebDesktopShortcut this[
   int index
]; {get;}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcutCollection Class
WebDesktopShortcutCollection Members


Parent Property

[image]
Intersoft WebDesktop Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcutCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As Object
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcutCollection
Dim value As Object

value = instance.Parent
C#
public object Parent {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcutCollection Class
WebDesktopShortcutCollection Members


WebDesktopShortcutSettings Class

[image]
Intersoft WebDesktop Documentation
WebDesktopShortcutSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopShortcutSettings Class

Glossary Item Box

Collection of settings for desktop shortcut icons.

Object Model

WebDesktopShortcutSettings Class

Syntax

Visual Basic (Declaration)
Public Class WebDesktopShortcutSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcutSettings
C#
public class WebDesktopShortcutSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Remarks

You can configure AllowAutoArrange and Moveable properties which can be accessed on ShortcutSettings.

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebDesktop.WebDesktopShortcutSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcutSettings Members
ISNet.WebUI.WebDesktop Namespace

Concepts

Shortcut


WebDesktopShortcutSettings Class Members

[image]
Intersoft WebDesktop Documentation
WebDesktopShortcutSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopShortcutSettings Class

Glossary Item Box

The following tables list the members exposed by WebDesktopShortcutSettings.

Public Constructors

 | Name | Description
Public Constructor | WebDesktopShortcutSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | AllowAutoArrange | Specifies whether auto arrange should be used to arrange shortcut icons.
Public Property | Movable | Specifies whether shortcut icons can be moved by users.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebDesktopShortcutSettings Class
ISNet.WebUI.WebDesktop Namespace

Concepts

Shortcut


WebDesktopShortcutSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebDesktopShortcutSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcutSettings Class : WebDesktopShortcutSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebDesktopShortcutSettings()
C#
public WebDesktopShortcutSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcutSettings Class
WebDesktopShortcutSettings Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcutSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcutSettings
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcutSettings Class
WebDesktopShortcutSettings Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcutSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcutSettings Class
WebDesktopShortcutSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcutSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcutSettings
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcutSettings Class
WebDesktopShortcutSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcutSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcutSettings
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcutSettings Class
WebDesktopShortcutSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcutSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcutSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcutSettings Class
WebDesktopShortcutSettings Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcutSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcutSettings
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcutSettings Class
WebDesktopShortcutSettings Members


WebDesktopShortcutSettings Class Methods

[image]
Intersoft WebDesktop Documentation
WebDesktopShortcutSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopShortcutSettings Class

Glossary Item Box

For a list of all members of this type, see WebDesktopShortcutSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebDesktopShortcutSettings Class
ISNet.WebUI.WebDesktop Namespace

Concepts

Shortcut


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcutSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcutSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcutSettings Class
WebDesktopShortcutSettings Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcutSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcutSettings
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcutSettings Class
WebDesktopShortcutSettings Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcutSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcutSettings

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcutSettings Class
WebDesktopShortcutSettings Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcutSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcutSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcutSettings Class
WebDesktopShortcutSettings Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcutSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcutSettings
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcutSettings Class
WebDesktopShortcutSettings Members


WebDesktopShortcutSettings Class Properties

[image]
Intersoft WebDesktop Documentation
WebDesktopShortcutSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopShortcutSettings Class

Glossary Item Box

For a list of all members of this type, see WebDesktopShortcutSettings members.

Public Properties

 | Name | Description
Public Property | AllowAutoArrange | Specifies whether auto arrange should be used to arrange shortcut icons.
Public Property | Movable | Specifies whether shortcut icons can be moved by users.
Top

See Also

Reference

WebDesktopShortcutSettings Class
ISNet.WebUI.WebDesktop Namespace

Concepts

Shortcut


WebDesktopShortcutSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebDesktopShortcutSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcutSettings Class : WebDesktopShortcutSettings Constructor

Glossary Item Box

Initializes a new instance of the WebDesktopShortcutSettings class.

Overload List

Overload | Description
WebDesktopShortcutSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcutSettings Class
WebDesktopShortcutSettings Members


AllowAutoArrange Property

[image]
Intersoft WebDesktop Documentation
AllowAutoArrange Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcutSettings Class : AllowAutoArrange Property

Glossary Item Box

Specifies whether auto arrange should be used to arrange shortcut icons.

Syntax

Visual Basic (Declaration)
Public Property AllowAutoArrange As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcutSettings
Dim value As Boolean

instance.AllowAutoArrange = value

value = instance.AllowAutoArrange
C#
public bool AllowAutoArrange {get; set;}

Remarks

The default value of this property is True. This property automatically arrange the icons from top to bottom, and move to second column and so on when there are more icons. Moreover, the AutoArrangement feature will rearrange the icons to keep them visible and in order everytime the Desktop is resized.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcutSettings Class
WebDesktopShortcutSettings Members

Concepts

WebDesktop Features

concepts

Shortcut


Movable Property

[image]
Intersoft WebDesktop Documentation
Movable Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopShortcutSettings Class : Movable Property

Glossary Item Box

Specifies whether shortcut icons can be moved by users.

Syntax

Visual Basic (Declaration)
Public Property Movable As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopShortcutSettings
Dim value As Boolean

instance.Movable = value

value = instance.Movable
C#
public bool Movable {get; set;}

Remarks

The default value of this property is False. When this property is set to True, you may move the shortcuts to any location you preferred, just like the way you did in Windows. The shortcuts which have been moved by users will not be automatically arranged by the DesktopManager eventhough AllowAutoArrange is set to True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopShortcutSettings Class
WebDesktopShortcutSettings Members

Concepts

WebDesktop Features

concepts

Shortcut


WebDesktopTaskBarSettings Class

[image]
Intersoft WebDesktop Documentation
WebDesktopTaskBarSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopTaskBarSettings Class

Glossary Item Box

Collection of task bar settings for WebDesktopWindow object.

Object Model

WebDesktopTaskBarSettings Class

Syntax

Visual Basic (Declaration)
Public Class WebDesktopTaskBarSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopTaskBarSettings
C#
public class WebDesktopTaskBarSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Remarks

A TaskBar represents panel contains a list of open Windows which displayed in "Button" object. The buttons of the open Windows are also called as TaskBarWindowButton. The TaskBar provides a convenient and quick access for the currently open Windows and also serve as centralized navigation system for desktop-style web application.

Some important properties of the WebDesktopTaskBarSettings include Position, ShowWindows, WindowButtonSpacing, and WindowButtonWidth.

The TaskBar implements Automatic TaskBarWindowButton Resizing in conjunction with WindowButtonWidth property. This built-in mechanism enables the Button's width to be automatically shrinked as more open windows are added. As opposed, when more spaces become available, the Button's width will be restored to the preferred width specified in WindowButtonWidth.

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebDesktop.WebDesktopTaskBarSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopTaskBarSettings Members
ISNet.WebUI.WebDesktop Namespace

Tasks

Using Custom Template for Left and Right part of TaskBar

tasks

Hiding a Window from TaskBar

concepts

Task Bar


WebDesktopTaskBarSettings Class Members

[image]
Intersoft WebDesktop Documentation
WebDesktopTaskBarSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopTaskBarSettings Class

Glossary Item Box

The following tables list the members exposed by WebDesktopTaskBarSettings.

Public Constructors

 | Name | Description
Public Constructor | WebDesktopTaskBarSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | Movable | Determines whether users can move the taskbar to other position of the container.
Public Property | Position | Gets or sets the position of the taskbar.
Public Property | Resizable | Determines whether users can resize the taskbar.
Public Property | ShowWindows | Determines whether open windows should be shown in the taskbar.
Public Property | WindowButtonSpacing | Gets or sets the spacing of window button.
Public Property | WindowButtonWidth | Gets or sets the default button width of the taskbar for open Windows.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebDesktopTaskBarSettings Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Using Custom Template for Left and Right part of TaskBar

tasks

Hiding a Window from TaskBar

concepts

Task Bar


WebDesktopTaskBarSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebDesktopTaskBarSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopTaskBarSettings Class : WebDesktopTaskBarSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebDesktopTaskBarSettings()
C#
public WebDesktopTaskBarSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopTaskBarSettings Class
WebDesktopTaskBarSettings Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopTaskBarSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopTaskBarSettings
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopTaskBarSettings Class
WebDesktopTaskBarSettings Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopTaskBarSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopTaskBarSettings Class
WebDesktopTaskBarSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopTaskBarSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopTaskBarSettings
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopTaskBarSettings Class
WebDesktopTaskBarSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopTaskBarSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopTaskBarSettings
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopTaskBarSettings Class
WebDesktopTaskBarSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopTaskBarSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopTaskBarSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopTaskBarSettings Class
WebDesktopTaskBarSettings Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopTaskBarSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopTaskBarSettings
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopTaskBarSettings Class
WebDesktopTaskBarSettings Members


WebDesktopTaskBarSettings Class Methods

[image]
Intersoft WebDesktop Documentation
WebDesktopTaskBarSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopTaskBarSettings Class

Glossary Item Box

For a list of all members of this type, see WebDesktopTaskBarSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebDesktopTaskBarSettings Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Using Custom Template for Left and Right part of TaskBar

tasks

Hiding a Window from TaskBar

concepts

Task Bar


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopTaskBarSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopTaskBarSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopTaskBarSettings Class
WebDesktopTaskBarSettings Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopTaskBarSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopTaskBarSettings
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopTaskBarSettings Class
WebDesktopTaskBarSettings Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopTaskBarSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopTaskBarSettings

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopTaskBarSettings Class
WebDesktopTaskBarSettings Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopTaskBarSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopTaskBarSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopTaskBarSettings Class
WebDesktopTaskBarSettings Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopTaskBarSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopTaskBarSettings
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopTaskBarSettings Class
WebDesktopTaskBarSettings Members


WebDesktopTaskBarSettings Class Properties

[image]
Intersoft WebDesktop Documentation
WebDesktopTaskBarSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopTaskBarSettings Class

Glossary Item Box

For a list of all members of this type, see WebDesktopTaskBarSettings members.

Public Properties

 | Name | Description
Public Property | Movable | Determines whether users can move the taskbar to other position of the container.
Public Property | Position | Gets or sets the position of the taskbar.
Public Property | Resizable | Determines whether users can resize the taskbar.
Public Property | ShowWindows | Determines whether open windows should be shown in the taskbar.
Public Property | WindowButtonSpacing | Gets or sets the spacing of window button.
Public Property | WindowButtonWidth | Gets or sets the default button width of the taskbar for open Windows.
Top

See Also

Reference

WebDesktopTaskBarSettings Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Using Custom Template for Left and Right part of TaskBar

tasks

Hiding a Window from TaskBar

concepts

Task Bar


WebDesktopTaskBarSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebDesktopTaskBarSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopTaskBarSettings Class : WebDesktopTaskBarSettings Constructor

Glossary Item Box

Initializes a new instance of the WebDesktopTaskBarSettings class.

Overload List

Overload | Description
WebDesktopTaskBarSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopTaskBarSettings Class
WebDesktopTaskBarSettings Members


Movable Property

[image]
Intersoft WebDesktop Documentation
Movable Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopTaskBarSettings Class : Movable Property

Glossary Item Box

Determines whether users can move the taskbar to other position of the container.

Syntax

Visual Basic (Declaration)
Public Property Movable As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopTaskBarSettings
Dim value As Boolean

instance.Movable = value

value = instance.Movable
C#
public bool Movable {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopTaskBarSettings Class
WebDesktopTaskBarSettings Members


Position Property

[image]
Intersoft WebDesktop Documentation
Position Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopTaskBarSettings Class : Position Property

Glossary Item Box

Gets or sets the position of the taskbar.

Syntax

Visual Basic (Declaration)
Public Property Position As DisplayAlignment
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopTaskBarSettings
Dim value As DisplayAlignment

instance.Position = value

value = instance.Position
C#
public DisplayAlignment Position {get; set;}

Remarks

You can use this property to configure where the TaskBar should be positioned in the WebDesktop.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopTaskBarSettings Class
WebDesktopTaskBarSettings Members

Concepts

WebDesktop Features


Resizable Property

[image]
Intersoft WebDesktop Documentation
Resizable Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopTaskBarSettings Class : Resizable Property

Glossary Item Box

Determines whether users can resize the taskbar.

Syntax

Visual Basic (Declaration)
Public Property Resizable As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopTaskBarSettings
Dim value As Boolean

instance.Resizable = value

value = instance.Resizable
C#
public bool Resizable {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopTaskBarSettings Class
WebDesktopTaskBarSettings Members


ShowWindows Property

[image]
Intersoft WebDesktop Documentation
ShowWindows Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopTaskBarSettings Class : ShowWindows Property

Glossary Item Box

Determines whether open windows should be shown in the taskbar.

Syntax

Visual Basic (Declaration)
Public Property ShowWindows As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopTaskBarSettings
Dim value As Boolean

instance.ShowWindows = value

value = instance.ShowWindows
C#
public bool ShowWindows {get; set;}

Remarks

This property allows you to configure whether the open Windows should be listed and accessible.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopTaskBarSettings Class
WebDesktopTaskBarSettings Members

Concepts

WebDesktop Features


WindowButtonSpacing Property

[image]
Intersoft WebDesktop Documentation
WindowButtonSpacing Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopTaskBarSettings Class : WindowButtonSpacing Property

Glossary Item Box

Gets or sets the spacing of window button.

Syntax

Visual Basic (Declaration)
Public Property WindowButtonSpacing As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopTaskBarSettings
Dim value As Integer

instance.WindowButtonSpacing = value

value = instance.WindowButtonSpacing
C#
public int WindowButtonSpacing {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopTaskBarSettings Class
WebDesktopTaskBarSettings Members

Concepts

WebDesktop Features


WindowButtonWidth Property

[image]
Intersoft WebDesktop Documentation
WindowButtonWidth Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopTaskBarSettings Class : WindowButtonWidth Property

Glossary Item Box

Gets or sets the default button width of the taskbar for open Windows.

Syntax

Visual Basic (Declaration)
Public Property WindowButtonWidth As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopTaskBarSettings
Dim value As Integer

instance.WindowButtonWidth = value

value = instance.WindowButtonWidth
C#
public int WindowButtonWidth {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopTaskBarSettings Class
WebDesktopTaskBarSettings Members

Concepts

WebDesktop Features


WebDesktopTextSettings Class

[image]
Intersoft WebDesktop Documentation
WebDesktopTextSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopTextSettings Class

Glossary Item Box

Collection of text settings for WebDesktop object.

Object Model

WebDesktopTextSettings Class

Syntax

Visual Basic (Declaration)
Public Class WebDesktopTextSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopTextSettings
C#
public class WebDesktopTextSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebDesktop.WebDesktopTextSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopTextSettings Members
ISNet.WebUI.WebDesktop Namespace


WebDesktopTextSettings Class Members

[image]
Intersoft WebDesktop Documentation
WebDesktopTextSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopTextSettings Class

Glossary Item Box

The following tables list the members exposed by WebDesktopTextSettings.

Public Constructors

 | Name | Description
Public Constructor | WebDesktopTextSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | BusyText | Gets or sets the text that will be displayed in tooltip when the WebDesktopWindow is busy.
Public Property | CloseText | Gets or sets the text for Close button or context menu.
Public Property | InProgressText | Gets or sets the text shown during IFrame loading.
Public Property | LoadingText | Gets or sets the text that will be displayed when the DesktopManager is being loaded.
Public Property | MaximizeText | Gets or sets the text for Maximize button or context menu.
Public Property | MinimizeText | Gets or sets the text for Minimize button or context menu.
Public Property | RestoreText | Gets or sets the text for Restore button or context menu.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebDesktopTextSettings Class
ISNet.WebUI.WebDesktop Namespace


WebDesktopTextSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebDesktopTextSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopTextSettings Class : WebDesktopTextSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebDesktopTextSettings()
C#
public WebDesktopTextSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopTextSettings Class
WebDesktopTextSettings Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopTextSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopTextSettings
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopTextSettings Class
WebDesktopTextSettings Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopTextSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopTextSettings Class
WebDesktopTextSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopTextSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopTextSettings
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopTextSettings Class
WebDesktopTextSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopTextSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopTextSettings
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopTextSettings Class
WebDesktopTextSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopTextSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopTextSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopTextSettings Class
WebDesktopTextSettings Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopTextSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopTextSettings
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopTextSettings Class
WebDesktopTextSettings Members


WebDesktopTextSettings Class Methods

[image]
Intersoft WebDesktop Documentation
WebDesktopTextSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopTextSettings Class

Glossary Item Box

For a list of all members of this type, see WebDesktopTextSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebDesktopTextSettings Class
ISNet.WebUI.WebDesktop Namespace


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopTextSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopTextSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopTextSettings Class
WebDesktopTextSettings Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopTextSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopTextSettings
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopTextSettings Class
WebDesktopTextSettings Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopTextSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopTextSettings

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopTextSettings Class
WebDesktopTextSettings Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopTextSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopTextSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopTextSettings Class
WebDesktopTextSettings Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopTextSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopTextSettings
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopTextSettings Class
WebDesktopTextSettings Members


WebDesktopTextSettings Class Properties

[image]
Intersoft WebDesktop Documentation
WebDesktopTextSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopTextSettings Class

Glossary Item Box

For a list of all members of this type, see WebDesktopTextSettings members.

Public Properties

 | Name | Description
Public Property | BusyText | Gets or sets the text that will be displayed in tooltip when the WebDesktopWindow is busy.
Public Property | CloseText | Gets or sets the text for Close button or context menu.
Public Property | InProgressText | Gets or sets the text shown during IFrame loading.
Public Property | LoadingText | Gets or sets the text that will be displayed when the DesktopManager is being loaded.
Public Property | MaximizeText | Gets or sets the text for Maximize button or context menu.
Public Property | MinimizeText | Gets or sets the text for Minimize button or context menu.
Public Property | RestoreText | Gets or sets the text for Restore button or context menu.
Top

See Also

Reference

WebDesktopTextSettings Class
ISNet.WebUI.WebDesktop Namespace


WebDesktopTextSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebDesktopTextSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopTextSettings Class : WebDesktopTextSettings Constructor

Glossary Item Box

Initializes a new instance of the WebDesktopTextSettings class.

Overload List

Overload | Description
WebDesktopTextSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopTextSettings Class
WebDesktopTextSettings Members


BusyText Property

[image]
Intersoft WebDesktop Documentation
BusyText Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopTextSettings Class : BusyText Property

Glossary Item Box

Gets or sets the text that will be displayed in tooltip when the WebDesktopWindow is busy.

Syntax

Visual Basic (Declaration)
Public Property BusyText As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopTextSettings
Dim value As String

instance.BusyText = value

value = instance.BusyText
C#
public string BusyText {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopTextSettings Class
WebDesktopTextSettings Members


CloseText Property

[image]
Intersoft WebDesktop Documentation
CloseText Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopTextSettings Class : CloseText Property

Glossary Item Box

Gets or sets the text for Close button or context menu.

Syntax

Visual Basic (Declaration)
Public Property CloseText As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopTextSettings
Dim value As String

instance.CloseText = value

value = instance.CloseText
C#
public string CloseText {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopTextSettings Class
WebDesktopTextSettings Members


InProgressText Property

[image]
Intersoft WebDesktop Documentation
InProgressText Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopTextSettings Class : InProgressText Property

Glossary Item Box

Gets or sets the text shown during IFrame loading.

Syntax

Visual Basic (Declaration)
Public Property InProgressText As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopTextSettings
Dim value As String

instance.InProgressText = value

value = instance.InProgressText
C#
public string InProgressText {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopTextSettings Class
WebDesktopTextSettings Members


LoadingText Property

[image]
Intersoft WebDesktop Documentation
LoadingText Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopTextSettings Class : LoadingText Property

Glossary Item Box

Gets or sets the text that will be displayed when the DesktopManager is being loaded.

Syntax

Visual Basic (Declaration)
Public Property LoadingText As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopTextSettings
Dim value As String

instance.LoadingText = value

value = instance.LoadingText
C#
public string LoadingText {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopTextSettings Class
WebDesktopTextSettings Members


MaximizeText Property

[image]
Intersoft WebDesktop Documentation
MaximizeText Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopTextSettings Class : MaximizeText Property

Glossary Item Box

Gets or sets the text for Maximize button or context menu.

Syntax

Visual Basic (Declaration)
Public Property MaximizeText As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopTextSettings
Dim value As String

instance.MaximizeText = value

value = instance.MaximizeText
C#
public string MaximizeText {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopTextSettings Class
WebDesktopTextSettings Members


MinimizeText Property

[image]
Intersoft WebDesktop Documentation
MinimizeText Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopTextSettings Class : MinimizeText Property

Glossary Item Box

Gets or sets the text for Minimize button or context menu.

Syntax

Visual Basic (Declaration)
Public Property MinimizeText As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopTextSettings
Dim value As String

instance.MinimizeText = value

value = instance.MinimizeText
C#
public string MinimizeText {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopTextSettings Class
WebDesktopTextSettings Members


RestoreText Property

[image]
Intersoft WebDesktop Documentation
RestoreText Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopTextSettings Class : RestoreText Property

Glossary Item Box

Gets or sets the text for Restore button or context menu.

Syntax

Visual Basic (Declaration)
Public Property RestoreText As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopTextSettings
Dim value As String

instance.RestoreText = value

value = instance.RestoreText
C#
public string RestoreText {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopTextSettings Class
WebDesktopTextSettings Members


WebDesktopWindow Class

[image]
Intersoft WebDesktop Documentation
WebDesktopWindow Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopWindow Class

Glossary Item Box

The core and most essential user interface element in WebDesktopManager. In WebDesktopManager, a Window represents content which can be in-line contents using HTML markups or webform page using IFrame.

Object Model

WebDesktopWindow Class

Syntax

Visual Basic (Declaration)
Public Class WebDesktopWindow
   Inherits ISNet.WebUI.NamedObjectBase
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindow
C#
public class WebDesktopWindow : ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject

Remarks

Window user interface element is typically represented by a rectangular shape containing an Image and Text describing the running application of the Window. In WebDesktopManager, a Window consists of ControlBox element, TitleBar, Minimize button, Maximize button, Close button.

WebDesktopManager also implements most of functions found in a Desktop. The following lists some of the implementation

  • Window moving.
  • Window resizing.
  • Window states.
  • Window context menu.

For a complete list of WebDesktopManager's behaviors in this release, see High Clarity Desktop technology.

The latest release of WebDesktopManager supports ComplexImages border type in addition to the Simple type. The ComplexImages border type enables you to create great looking visual style of today popular's desktop in high details.

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase
ISNet.WebUI.WebDesktop.WebDesktopWindow

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindow Members
ISNet.WebUI.WebDesktop Namespace

Tasks

Hiding a Window at initial load
Hiding a Window from TaskBar

tasks

Using Window Options
Specifying Custom Location for a Window
Specifying Minimum and Maximum Size for a Window
Adding new Window at Client Side

Concepts

Window
ContentMode and Most Common Scenarios

concepts

High Clarity Desktop


WebDesktopWindow Class Members

[image]
Intersoft WebDesktop Documentation
WebDesktopWindow Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopWindow Class

Glossary Item Box

The following tables list the members exposed by WebDesktopWindow.

Public Constructors

 | Name | Description
Public Constructor | WebDesktopWindow Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | AllowClose | Indicates whether the Window can be closed.
Public Property | AllowMaximize | Indicates whether the Window can be maximized.
Public Property | AllowMinimize | Indicates whether the Window can be minimized.
Public Property | AllowResize | Indicates whether the Window can be resized.
Public Property | BusyText | Gets or sets the text that will be displayed in tooptip when this Window is set to busy.
Public Property | CaptionDisplayMode | Gets or sets the display mode for the caption.
Public Property | ClientVisible | Specifies whether this window should be made visible in initial page load.
Public Property | ContentMode | Gets or sets the default content mode for Window.
Public Property | ContentURL | Gets or sets the Content URL for this Window.
Public Property | ControlBox | Indicates whether the control box for the Window is visible.
Public Property | ControlBoxImage | Specifies the image for window's control box.
Public Property | InProgressText | Gets or sets the text shown during IFrame loading.
Public Property | Location | Gets or sets the initial location that this Window should be displayed at.
Public Property | MaximumSize | Gets or sets the maximum size that Window can be resized to.
Public Property | MinimumSize | Gets or sets the minimum size that Window can be resized to.
Public Property | Name | Overridden. Gets or sets the name of Window.
Public Property | ShortcutImage | Gets or sets the shortcut image for this Window. The shortcut image will only appear when TaskBar is not visible and the Window is minimized. If this image is not specified, the control will use ControlBoxImage.
Public Property | ShowInTaskBar | Determines whether this Window should appear in TaskBar when opened.
Public Property | Size | Gets or sets the size of Window in pixel.
Public Property | TaskBarImage |
Public Property | Text | Gets or sets the caption text for this Window.
Public Property | TextAlignment | Gets or sets the alignment for the text caption.
Public Property | WindowState | Gets or sets the initial state for this Window.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetActualLocation |
Public Method | GetActualSize |
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsActiveWindow |
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebDesktopWindow Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Hiding a Window at initial load
Hiding a Window from TaskBar

tasks

Using Window Options
Specifying Custom Location for a Window
Specifying Minimum and Maximum Size for a Window
Adding new Window at Client Side

Concepts

Window
ContentMode and Most Common Scenarios

concepts

High Clarity Desktop


WebDesktopWindow Constructor

[image]
Intersoft WebDesktop Documentation
WebDesktopWindow Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindow Class : WebDesktopWindow Constructor

Glossary Item Box

Initializes a new instance of the WebDesktopWindow class.

Overload List

Overload | Description
WebDesktopWindow Constructor() | Initializes a new instance of the WebDesktopWindow class with no argument.
WebDesktopWindow Constructor(String) | Initializes a new instance of the WebDesktopWindow class with Text parameter.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindow Class
WebDesktopWindow Members


WebDesktopWindow Constructor()

[image]
Intersoft WebDesktop Documentation
WebDesktopWindow Constructor()
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindow Class > WebDesktopWindow Constructor : WebDesktopWindow Constructor()

Glossary Item Box

Initializes a new instance of the WebDesktopWindow class with no argument.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebDesktopWindow()
C#
public WebDesktopWindow()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindow Class
WebDesktopWindow Members
Overload List


WebDesktopWindow Constructor(String)

[image]
Intersoft WebDesktop Documentation
WebDesktopWindow Constructor(String)
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindow Class > WebDesktopWindow Constructor : WebDesktopWindow Constructor(String)

text

Glossary Item Box

Initializes a new instance of the WebDesktopWindow class with Text parameter.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim text As String

Dim instance As New WebDesktopWindow(text)
C#
public WebDesktopWindow(
   string text
)

Parameters

text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindow Class
WebDesktopWindow Members
Overload List


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindow Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindow
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindow Class
WebDesktopWindow Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindow Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindow Class
WebDesktopWindow Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindow Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindow
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindow Class
WebDesktopWindow Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindow Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindow
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindow Class
WebDesktopWindow Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindow Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindow
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindow Class
WebDesktopWindow Members


WebDesktopWindow Class Methods

[image]
Intersoft WebDesktop Documentation
WebDesktopWindow Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopWindow Class

Glossary Item Box

For a list of all members of this type, see WebDesktopWindow members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetActualLocation |
Public Method | GetActualSize |
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsActiveWindow |
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebDesktopWindow Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Hiding a Window at initial load
Hiding a Window from TaskBar

tasks

Using Window Options
Specifying Custom Location for a Window
Specifying Minimum and Maximum Size for a Window
Adding new Window at Client Side

Concepts

Window
ContentMode and Most Common Scenarios

concepts

High Clarity Desktop


GetActualLocation Method

[image]
Intersoft WebDesktop Documentation
GetActualLocation Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindow Class : GetActualLocation Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetActualLocation() As System.Drawing.Point
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindow
Dim value As System.Drawing.Point

value = instance.GetActualLocation()
C#
public System.Drawing.Point GetActualLocation()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindow Class
WebDesktopWindow Members


GetActualSize Method

[image]
Intersoft WebDesktop Documentation
GetActualSize Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindow Class : GetActualSize Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetActualSize() As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindow
Dim value As System.Drawing.Size

value = instance.GetActualSize()
C#
public System.Drawing.Size GetActualSize()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindow Class
WebDesktopWindow Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindow Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindow
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindow Class
WebDesktopWindow Members


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindow Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindow
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindow Class
WebDesktopWindow Members


IsActiveWindow Method

[image]
Intersoft WebDesktop Documentation
IsActiveWindow Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindow Class : IsActiveWindow Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsActiveWindow() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindow
Dim value As Boolean

value = instance.IsActiveWindow()
C#
public bool IsActiveWindow()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindow Class
WebDesktopWindow Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindow Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindow
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindow Class
WebDesktopWindow Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindow Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindow

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindow Class
WebDesktopWindow Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindow Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindow
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindow Class
WebDesktopWindow Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindow Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindow
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindow Class
WebDesktopWindow Members


WebDesktopWindow Class Properties

[image]
Intersoft WebDesktop Documentation
WebDesktopWindow Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopWindow Class

Glossary Item Box

For a list of all members of this type, see WebDesktopWindow members.

Public Properties

 | Name | Description
Public Property | AllowClose | Indicates whether the Window can be closed.
Public Property | AllowMaximize | Indicates whether the Window can be maximized.
Public Property | AllowMinimize | Indicates whether the Window can be minimized.
Public Property | AllowResize | Indicates whether the Window can be resized.
Public Property | BusyText | Gets or sets the text that will be displayed in tooptip when this Window is set to busy.
Public Property | CaptionDisplayMode | Gets or sets the display mode for the caption.
Public Property | ClientVisible | Specifies whether this window should be made visible in initial page load.
Public Property | ContentMode | Gets or sets the default content mode for Window.
Public Property | ContentURL | Gets or sets the Content URL for this Window.
Public Property | ControlBox | Indicates whether the control box for the Window is visible.
Public Property | ControlBoxImage | Specifies the image for window's control box.
Public Property | InProgressText | Gets or sets the text shown during IFrame loading.
Public Property | Location | Gets or sets the initial location that this Window should be displayed at.
Public Property | MaximumSize | Gets or sets the maximum size that Window can be resized to.
Public Property | MinimumSize | Gets or sets the minimum size that Window can be resized to.
Public Property | Name | Overridden. Gets or sets the name of Window.
Public Property | ShortcutImage | Gets or sets the shortcut image for this Window. The shortcut image will only appear when TaskBar is not visible and the Window is minimized. If this image is not specified, the control will use ControlBoxImage.
Public Property | ShowInTaskBar | Determines whether this Window should appear in TaskBar when opened.
Public Property | Size | Gets or sets the size of Window in pixel.
Public Property | TaskBarImage |
Public Property | Text | Gets or sets the caption text for this Window.
Public Property | TextAlignment | Gets or sets the alignment for the text caption.
Public Property | WindowState | Gets or sets the initial state for this Window.
Top

See Also

Reference

WebDesktopWindow Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Hiding a Window at initial load
Hiding a Window from TaskBar

tasks

Using Window Options
Specifying Custom Location for a Window
Specifying Minimum and Maximum Size for a Window
Adding new Window at Client Side

Concepts

Window
ContentMode and Most Common Scenarios

concepts

High Clarity Desktop


AllowClose Property

[image]
Intersoft WebDesktop Documentation
AllowClose Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindow Class : AllowClose Property

Glossary Item Box

Indicates whether the Window can be closed.

Syntax

Visual Basic (Declaration)
Public Property AllowClose As CloseMode
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindow
Dim value As CloseMode

instance.AllowClose = value

value = instance.AllowClose
C#
public CloseMode AllowClose {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindow Class
WebDesktopWindow Members


AllowMaximize Property

[image]
Intersoft WebDesktop Documentation
AllowMaximize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindow Class : AllowMaximize Property

Glossary Item Box

Indicates whether the Window can be maximized.

Syntax

Visual Basic (Declaration)
Public Property AllowMaximize As AllowMaximize
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindow
Dim value As AllowMaximize

instance.AllowMaximize = value

value = instance.AllowMaximize
C#
public AllowMaximize AllowMaximize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindow Class
WebDesktopWindow Members


AllowMinimize Property

[image]
Intersoft WebDesktop Documentation
AllowMinimize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindow Class : AllowMinimize Property

Glossary Item Box

Indicates whether the Window can be minimized.

Syntax

Visual Basic (Declaration)
Public Property AllowMinimize As AllowMinimize
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindow
Dim value As AllowMinimize

instance.AllowMinimize = value

value = instance.AllowMinimize
C#
public AllowMinimize AllowMinimize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindow Class
WebDesktopWindow Members


AllowResize Property

[image]
Intersoft WebDesktop Documentation
AllowResize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindow Class : AllowResize Property

Glossary Item Box

Indicates whether the Window can be resized.

Syntax

Visual Basic (Declaration)
Public Property AllowResize As AllowResize
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindow
Dim value As AllowResize

instance.AllowResize = value

value = instance.AllowResize
C#
public AllowResize AllowResize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindow Class
WebDesktopWindow Members


BusyText Property

[image]
Intersoft WebDesktop Documentation
BusyText Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindow Class : BusyText Property

Glossary Item Box

Gets or sets the text that will be displayed in tooptip when this Window is set to busy.

Syntax

Visual Basic (Declaration)
Public Property BusyText As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindow
Dim value As String

instance.BusyText = value

value = instance.BusyText
C#
public string BusyText {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindow Class
WebDesktopWindow Members


CaptionDisplayMode Property

[image]
Intersoft WebDesktop Documentation
CaptionDisplayMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindow Class : CaptionDisplayMode Property

Glossary Item Box

Gets or sets the display mode for the caption.

Syntax

Visual Basic (Declaration)
Public Property CaptionDisplayMode As WindowCaptionDisplayMode
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindow
Dim value As WindowCaptionDisplayMode

instance.CaptionDisplayMode = value

value = instance.CaptionDisplayMode
C#
public WindowCaptionDisplayMode CaptionDisplayMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindow Class
WebDesktopWindow Members


ClientVisible Property

[image]
Intersoft WebDesktop Documentation
ClientVisible Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindow Class : ClientVisible Property

Glossary Item Box

Specifies whether this window should be made visible in initial page load.

Syntax

Visual Basic (Declaration)
Public Property ClientVisible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindow
Dim value As Boolean

instance.ClientVisible = value

value = instance.ClientVisible
C#
public bool ClientVisible {get; set;}

Remarks

The default value of this property is True. Using this property you can hide window at initial load simply by setting this property to False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindow Class
WebDesktopWindow Members

Tasks

Hiding a Window at initial load
Creating Simple Desktop


ContentMode Property

[image]
Intersoft WebDesktop Documentation
ContentMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindow Class : ContentMode Property

Glossary Item Box

Gets or sets the default content mode for Window.

Syntax

Visual Basic (Declaration)
Public Property ContentMode As ContentMode
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindow
Dim value As ContentMode

instance.ContentMode = value

value = instance.ContentMode
C#
public ContentMode ContentMode {get; set;}

Remarks

DesktopManager in WebDesktop.NET introduced two kind of Content Mode. The default mode is UseInlineContent which used the content defined in the template within the page itself. The other mode is UseIFrame which will use IFrame as the content source. When configured to use IFrame, developers can easily pick which WebForm to be assigned into each Window by using ClickAndSelect™ feature supported in Visual Studio 2005 or by specifying the content URL when adding new window.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindow Class
WebDesktopWindow Members

Concepts

ContentMode and Most Common Scenarios

concepts

WebDesktop Features

Tasks

Using IFrame as ContentMode

tasks

Creating Simple Desktop


ContentURL Property

[image]
Intersoft WebDesktop Documentation
ContentURL Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindow Class : ContentURL Property

Glossary Item Box

Gets or sets the Content URL for this Window.

Syntax

Visual Basic (Declaration)
Public Property ContentURL As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindow
Dim value As String

instance.ContentURL = value

value = instance.ContentURL
C#
public string ContentURL {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindow Class
WebDesktopWindow Members


ControlBox Property

[image]
Intersoft WebDesktop Documentation
ControlBox Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindow Class : ControlBox Property

Glossary Item Box

Indicates whether the control box for the Window is visible.

Syntax

Visual Basic (Declaration)
Public Property ControlBox As ControlBox
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindow
Dim value As ControlBox

instance.ControlBox = value

value = instance.ControlBox
C#
public ControlBox ControlBox {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindow Class
WebDesktopWindow Members


ControlBoxImage Property

[image]
Intersoft WebDesktop Documentation
ControlBoxImage Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindow Class : ControlBoxImage Property

Glossary Item Box

Specifies the image for window's control box.

Syntax

Visual Basic (Declaration)
Public Property ControlBoxImage As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindow
Dim value As String

instance.ControlBoxImage = value

value = instance.ControlBoxImage
C#
public string ControlBoxImage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindow Class
WebDesktopWindow Members


InProgressText Property

[image]
Intersoft WebDesktop Documentation
InProgressText Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindow Class : InProgressText Property

Glossary Item Box

Gets or sets the text shown during IFrame loading.

Syntax

Visual Basic (Declaration)
Public Property InProgressText As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindow
Dim value As String

instance.InProgressText = value

value = instance.InProgressText
C#
public string InProgressText {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindow Class
WebDesktopWindow Members


Location Property

[image]
Intersoft WebDesktop Documentation
Location Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindow Class : Location Property

Glossary Item Box

Gets or sets the initial location that this Window should be displayed at.

Syntax

Visual Basic (Declaration)
Public Property Location As System.Drawing.Point
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindow
Dim value As System.Drawing.Point

instance.Location = value

value = instance.Location
C#
public System.Drawing.Point Location {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindow Class
WebDesktopWindow Members

Tasks

Specifying Custom Location for a Window


MaximumSize Property

[image]
Intersoft WebDesktop Documentation
MaximumSize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindow Class : MaximumSize Property

Glossary Item Box

Gets or sets the maximum size that Window can be resized to.

Syntax

Visual Basic (Declaration)
Public Property MaximumSize As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindow
Dim value As System.Drawing.Size

instance.MaximumSize = value

value = instance.MaximumSize
C#
public System.Drawing.Size MaximumSize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindow Class
WebDesktopWindow Members

Tasks

Specifying Minimum and Maximum Size for a Window


MinimumSize Property

[image]
Intersoft WebDesktop Documentation
MinimumSize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindow Class : MinimumSize Property

Glossary Item Box

Gets or sets the minimum size that Window can be resized to.

Syntax

Visual Basic (Declaration)
Public Property MinimumSize As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindow
Dim value As System.Drawing.Size

instance.MinimumSize = value

value = instance.MinimumSize
C#
public System.Drawing.Size MinimumSize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindow Class
WebDesktopWindow Members

Tasks

Specifying Minimum and Maximum Size for a Window


Name Property

[image]
Intersoft WebDesktop Documentation
Name Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindow Class : Name Property

Glossary Item Box

Gets or sets the name of Window.

Syntax

Visual Basic (Declaration)
Public Overrides Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindow
Dim value As String

instance.Name = value

value = instance.Name
C#
public override string Name {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindow Class
WebDesktopWindow Members


ShortcutImage Property

[image]
Intersoft WebDesktop Documentation
ShortcutImage Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindow Class : ShortcutImage Property

Glossary Item Box

Gets or sets the shortcut image for this Window. The shortcut image will only appear when TaskBar is not visible and the Window is minimized. If this image is not specified, the control will use ControlBoxImage.

Syntax

Visual Basic (Declaration)
Public Property ShortcutImage As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindow
Dim value As String

instance.ShortcutImage = value

value = instance.ShortcutImage
C#
public string ShortcutImage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindow Class
WebDesktopWindow Members


ShowInTaskBar Property

[image]
Intersoft WebDesktop Documentation
ShowInTaskBar Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindow Class : ShowInTaskBar Property

Glossary Item Box

Determines whether this Window should appear in TaskBar when opened.

Syntax

Visual Basic (Declaration)
Public Property ShowInTaskBar As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindow
Dim value As Boolean

instance.ShowInTaskBar = value

value = instance.ShowInTaskBar
C#
public bool ShowInTaskBar {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindow Class
WebDesktopWindow Members


Size Property

[image]
Intersoft WebDesktop Documentation
Size Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindow Class : Size Property

Glossary Item Box

Gets or sets the size of Window in pixel.

Syntax

Visual Basic (Declaration)
Public Property Size As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindow
Dim value As System.Drawing.Size

instance.Size = value

value = instance.Size
C#
public System.Drawing.Size Size {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindow Class
WebDesktopWindow Members


TaskBarImage Property

[image]
Intersoft WebDesktop Documentation
TaskBarImage Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindow Class : TaskBarImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property TaskBarImage As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindow
Dim value As String

instance.TaskBarImage = value

value = instance.TaskBarImage
C#
public string TaskBarImage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindow Class
WebDesktopWindow Members


Text Property

[image]
Intersoft WebDesktop Documentation
Text Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindow Class : Text Property

Glossary Item Box

Gets or sets the caption text for this Window.

Syntax

Visual Basic (Declaration)
Public Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindow
Dim value As String

instance.Text = value

value = instance.Text
C#
public string Text {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindow Class
WebDesktopWindow Members


TextAlignment Property

[image]
Intersoft WebDesktop Documentation
TextAlignment Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindow Class : TextAlignment Property

Glossary Item Box

Gets or sets the alignment for the text caption.

Syntax

Visual Basic (Declaration)
Public Property TextAlignment As TextAlignment
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindow
Dim value As TextAlignment

instance.TextAlignment = value

value = instance.TextAlignment
C#
public TextAlignment TextAlignment {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindow Class
WebDesktopWindow Members


WindowState Property

[image]
Intersoft WebDesktop Documentation
WindowState Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindow Class : WindowState Property

Glossary Item Box

Gets or sets the initial state for this Window.

Syntax

Visual Basic (Declaration)
Public Property WindowState As WindowState
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindow
Dim value As WindowState

instance.WindowState = value

value = instance.WindowState
C#
public WindowState WindowState {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindow Class
WebDesktopWindow Members


WebDesktopWindowCollection Class

[image]
Intersoft WebDesktop Documentation
WebDesktopWindowCollection Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopWindowCollection Class

Glossary Item Box

Collection of WebDesktopWindow.

Object Model

WebDesktopWindowCollection Class

Syntax

Visual Basic (Declaration)
Public Class WebDesktopWindowCollection
   Inherits ISNet.WebUI.ISCollectionBase
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowCollection
C#
public class WebDesktopWindowCollection : ISNet.WebUI.ISCollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
ISNet.WebUI.ISCollectionBase
ISNet.WebUI.WebDesktop.WebDesktopWindowCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowCollection Members
ISNet.WebUI.WebDesktop Namespace


WebDesktopWindowCollection Class Members

[image]
Intersoft WebDesktop Documentation
WebDesktopWindowCollection Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopWindowCollection Class

Glossary Item Box

The following tables list the members exposed by WebDesktopWindowCollection.

Public Constructors

 | Name | Description
Public Constructor | WebDesktopWindowCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden. Returns a Boolean value indicating whether the collection is read-only.
Public Property | Item | Property indexer for the collection.
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebDesktopWindowCollection Class
ISNet.WebUI.WebDesktop Namespace


WebDesktopWindowCollection Constructor

[image]
Intersoft WebDesktop Documentation
WebDesktopWindowCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowCollection Class : WebDesktopWindowCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebDesktopWindowCollection()
C#
public WebDesktopWindowCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowCollection Class
WebDesktopWindowCollection Members


WebDesktopWindowCollection Class Methods

[image]
Intersoft WebDesktop Documentation
WebDesktopWindowCollection Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopWindowCollection Class

Glossary Item Box

For a list of all members of this type, see WebDesktopWindowCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebDesktopWindowCollection Class
ISNet.WebUI.WebDesktop Namespace


Add Method

[image]
Intersoft WebDesktop Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowCollection Class : Add Method

Glossary Item Box

Overload List

Overload | Description
Add(WebDesktopWindow) |
Add(String) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowCollection Class
WebDesktopWindowCollection Members


Add(WebDesktopWindow) Method

[image]
Intersoft WebDesktop Documentation
Add(WebDesktopWindow) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowCollection Class > Add Method : Add(WebDesktopWindow) Method

webDesktopWindow

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function Add( _
   ByVal webDesktopWindow As WebDesktopWindow _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowCollection
Dim webDesktopWindow As WebDesktopWindow
Dim value As Integer

value = instance.Add(webDesktopWindow)
C#
public virtual int Add(
   WebDesktopWindow webDesktopWindow
)

Parameters

webDesktopWindow

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowCollection Class
WebDesktopWindowCollection Members
Overload List


Add(String) Method

[image]
Intersoft WebDesktop Documentation
Add(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowCollection Class > Add Method : Add(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal name As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowCollection
Dim name As String
Dim value As Integer

value = instance.Add(name)
C#
public int Add(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowCollection Class
WebDesktopWindowCollection Members
Overload List


Clear Method

[image]
Intersoft WebDesktop Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowCollection

instance.Clear()
C#
public new void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowCollection Class
WebDesktopWindowCollection Members


Contains Method

[image]
Intersoft WebDesktop Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowCollection Class : Contains Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As ISNet.WebUI.INamedObject _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As Boolean

value = instance.Contains(value)
C#
public bool Contains(
   ISNet.WebUI.INamedObject value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowCollection Class
WebDesktopWindowCollection Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowCollection Class : CopyFrom Method

passIn

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CopyFrom( _
   ByVal passIn As WebDesktopWindowCollection _
) As WebDesktopWindowCollection
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowCollection
Dim passIn As WebDesktopWindowCollection
Dim value As WebDesktopWindowCollection

value = instance.CopyFrom(passIn)
C#
public WebDesktopWindowCollection CopyFrom(
   WebDesktopWindowCollection passIn
)

Parameters

passIn

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowCollection Class
WebDesktopWindowCollection Members


CopyTo Method

[image]
Intersoft WebDesktop Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowCollection
Dim array() As ISNet.WebUI.INamedObject
Dim index As Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   ISNet.WebUI.INamedObject[] array,
   int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowCollection Class
WebDesktopWindowCollection Members


Exists Method

[image]
Intersoft WebDesktop Documentation
Exists Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowCollection Class : Exists Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Exists( _
   ByVal name As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowCollection
Dim name As String
Dim value As Boolean

value = instance.Exists(name)
C#
public bool Exists(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowCollection Class
WebDesktopWindowCollection Members


GetEnumerator Method

[image]
Intersoft WebDesktop Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Function GetEnumerator() As System.Collections.IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
public new System.Collections.IEnumerator GetEnumerator()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowCollection Class
WebDesktopWindowCollection Members


GetItem Method

[image]
Intersoft WebDesktop Documentation
GetItem Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowCollection Class : GetItem Method

Glossary Item Box

Overload List

Overload | Description
GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowCollection Class
WebDesktopWindowCollection Members


GetItem(Int32) Method

[image]
Intersoft WebDesktop Documentation
GetItem(Int32) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowCollection Class : GetItem(Int32) Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetItem( _
   ByVal index As Integer _
) As ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowCollection
Dim index As Integer
Dim value As ISNet.WebUI.INamedObject

value = instance.GetItem(index)
C#
public virtual ISNet.WebUI.INamedObject GetItem(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowCollection Class
WebDesktopWindowCollection Members


GetNamedItem Method

[image]
Intersoft WebDesktop Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNamedItem( _
   ByVal name As String _
) As WebDesktopWindow
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowCollection
Dim name As String
Dim value As WebDesktopWindow

value = instance.GetNamedItem(name)
C#
public WebDesktopWindow GetNamedItem(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowCollection Class
WebDesktopWindowCollection Members


IndexOf Method

[image]
Intersoft WebDesktop Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowCollection Class : IndexOf Method

Glossary Item Box

Overload List

Overload | Description
IndexOf(String) | (Inherited from ISNet.WebUI.ISCollectionBase)
IndexOf(INamedObject) | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowCollection Class
WebDesktopWindowCollection Members


IndexOf(String) Method

[image]
Intersoft WebDesktop Documentation
IndexOf(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowCollection Class > IndexOf Method : IndexOf(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function IndexOf( _
   ByVal name As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowCollection
Dim name As String
Dim value As Integer

value = instance.IndexOf(name)
C#
public virtual int IndexOf(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowCollection Class
WebDesktopWindowCollection Members
Overload List


IndexOf(INamedObject) Method

[image]
Intersoft WebDesktop Documentation
IndexOf(INamedObject) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowCollection Class > IndexOf Method : IndexOf(INamedObject) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal value As ISNet.WebUI.INamedObject _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As Integer

value = instance.IndexOf(value)
C#
public int IndexOf(
   ISNet.WebUI.INamedObject value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowCollection Class
WebDesktopWindowCollection Members
Overload List


Insert Method

[image]
Intersoft WebDesktop Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowCollection Class : Insert Method

index
webDesktopWindow

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal webDesktopWindow As WebDesktopWindow _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowCollection
Dim index As Integer
Dim webDesktopWindow As WebDesktopWindow

instance.Insert(index, webDesktopWindow)
C#
public void Insert(
   int index,
   WebDesktopWindow webDesktopWindow
)

Parameters

index
webDesktopWindow

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowCollection Class
WebDesktopWindowCollection Members


IntInsert Method

[image]
Intersoft WebDesktop Documentation
IntInsert Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowCollection Class : IntInsert Method

index
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub IntInsert( _
   ByVal index As Integer, _
   ByVal value As ISNet.WebUI.INamedObject _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowCollection
Dim index As Integer
Dim value As ISNet.WebUI.INamedObject

instance.IntInsert(index, value)
C#
public void IntInsert(
   int index,
   ISNet.WebUI.INamedObject value
)

Parameters

index
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowCollection Class
WebDesktopWindowCollection Members


Remove Method

[image]
Intersoft WebDesktop Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowCollection Class : Remove Method

webDesktopWindow

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal webDesktopWindow As WebDesktopWindow _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowCollection
Dim webDesktopWindow As WebDesktopWindow

instance.Remove(webDesktopWindow)
C#
public void Remove(
   WebDesktopWindow webDesktopWindow
)

Parameters

webDesktopWindow

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowCollection Class
WebDesktopWindowCollection Members


setParent Method

[image]
Intersoft WebDesktop Documentation
setParent Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowCollection Class : setParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub setParent( _
   ByVal parent As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowCollection
Dim parent As Object

instance.setParent(parent)
C#
public virtual void setParent(
   object parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowCollection Class
WebDesktopWindowCollection Members


Capacity Property

[image]
Intersoft WebDesktop Documentation
Capacity Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowCollection Class : Capacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowCollection
Dim value As Integer

instance.Capacity = value

value = instance.Capacity
C#
public int Capacity {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowCollection Class
WebDesktopWindowCollection Members


Count Property

[image]
Intersoft WebDesktop Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowCollection Class
WebDesktopWindowCollection Members


WebDesktopWindowCollection Class Properties

[image]
Intersoft WebDesktop Documentation
WebDesktopWindowCollection Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopWindowCollection Class

Glossary Item Box

For a list of all members of this type, see WebDesktopWindowCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden. Returns a Boolean value indicating whether the collection is read-only.
Public Property | Item | Property indexer for the collection.
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebDesktopWindowCollection Class
ISNet.WebUI.WebDesktop Namespace


WebDesktopWindowCollection Constructor

[image]
Intersoft WebDesktop Documentation
WebDesktopWindowCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowCollection Class : WebDesktopWindowCollection Constructor

Glossary Item Box

Initializes a new instance of the WebDesktopWindowCollection class.

Overload List

Overload | Description
WebDesktopWindowCollection Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowCollection Class
WebDesktopWindowCollection Members


IsReadOnly Property

[image]
Intersoft WebDesktop Documentation
IsReadOnly Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowCollection Class : IsReadOnly Property

Glossary Item Box

Returns a Boolean value indicating whether the collection is read-only.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowCollection
Dim value As Boolean

value = instance.IsReadOnly
C#
public override bool IsReadOnly {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowCollection Class
WebDesktopWindowCollection Members


Item Property

[image]
Intersoft WebDesktop Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowCollection Class : Item Property

index

Glossary Item Box

Property indexer for the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As WebDesktopWindow
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowCollection
Dim index As Integer
Dim value As WebDesktopWindow

value = instance.Item(index)
C#
public WebDesktopWindow this[
   int index
]; {get;}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowCollection Class
WebDesktopWindowCollection Members


Parent Property

[image]
Intersoft WebDesktop Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As Object
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowCollection
Dim value As Object

value = instance.Parent
C#
public object Parent {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowCollection Class
WebDesktopWindowCollection Members


WebDesktopWindowSettings Class

[image]
Intersoft WebDesktop Documentation
WebDesktopWindowSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopWindowSettings Class

Glossary Item Box

Collection of settings for WebDesktopWindow object.

Object Model

WebDesktopWindowSettings Class

Syntax

Visual Basic (Declaration)
Public Class WebDesktopWindowSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowSettings
C#
public class WebDesktopWindowSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Remarks

WebDesktopWindowSettings contains the default configuration of all Window behaviors. When the properties at Window level are set to Default, the designated property will inherit the value from the WindowSettings.

You can customize each window appearance by configuring WebDesktopWindowSettings. Some properties which control the basic behavior of the window include AllowMinimize, AllowMaximize and AllowClose.

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebDesktop.WebDesktopWindowSettings
ISNet.WebUI.WebDesktop.WebDialogBoxWindowSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowSettings Members
ISNet.WebUI.WebDesktop Namespace

Tasks

Using Window Options

Concepts

Window

concepts

Styles Inheritance model for Uniform Look and Feel across entire Application.


WebDesktopWindowSettings Class Members

[image]
Intersoft WebDesktop Documentation
WebDesktopWindowSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopWindowSettings Class

Glossary Item Box

The following tables list the members exposed by WebDesktopWindowSettings.

Public Constructors

 | Name | Description
Public Constructor | WebDesktopWindowSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | AllowClose |
Public Property | AllowMaximize |
Public Property | AllowMinimize |
Public Property | AllowResize |
Public Property | ApplyContainerStyle |
Public Property | BorderType | Gets or sets the type of the border applied to Window.
Public Property | CaptionButtonSpacing |
Public Property | CaptionButtonStyle |
Public Property | CaptionDisplayMode |
Public Property | CaptionStyle |
Public Property | CommandBarPadding |
Public Property | CommandButtonBorderType |
Public Property | CommandButtonDisabledStyle | Gets or sets the disabled style of command button.
Public Property | CommandButtonStyle | Gets or sets the style applied to command button.
Public Property | ContainerStyle | Gets or sets the style applied to the content part of the Window.
Public Property | ContentMode | Gets or sets the default content mode for Window.
Public Property | ControlBox |
Public Property | ControlBoxPosition |
Public Property | DimWindowWhenBusy |
Public Property | DropShadow |
Public Property | EnableFastWindowActivation |
Public Property | IFrameAllowTransparency | Specifies whether the IFRAME should allow transparency. This property is applicable when ContentMode is set to UseIFrame.
Public Property | IFrameReadyTransitionEffect | Gets or sets the visual transition effect that will be applied when the IFrame content has been successfully loaded.
Public Property | IFrameShowLoader | Specifies whether to show loader text when the active IFrame is in loading progress. This property only applicables when ContentMode is set to UseIFrame.
Public Property | IgnoreIFramePadding |
Public Property | MaximumSize |
Public Property | MinimumSize |
Public Property | ScrollBarStyle |
Public Property | Size |
Public Property | TextAlignment |
Public Property | WindowHeaderHeight |
Public Property | WindowOptionsPosition |
Public Property | WindowStyle | Gets or sets the style applied to Window.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebDesktopWindowSettings Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Using Window Options

Concepts

Window

concepts

Styles Inheritance model for Uniform Look and Feel across entire Application.


WebDesktopWindowSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebDesktopWindowSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowSettings Class : WebDesktopWindowSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebDesktopWindowSettings()
C#
public WebDesktopWindowSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowSettings Class
WebDesktopWindowSettings Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowSettings
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowSettings Class
WebDesktopWindowSettings Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowSettings Class
WebDesktopWindowSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowSettings
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowSettings Class
WebDesktopWindowSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowSettings
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowSettings Class
WebDesktopWindowSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowSettings Class
WebDesktopWindowSettings Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowSettings
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowSettings Class
WebDesktopWindowSettings Members


WebDesktopWindowSettings Class Methods

[image]
Intersoft WebDesktop Documentation
WebDesktopWindowSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopWindowSettings Class

Glossary Item Box

For a list of all members of this type, see WebDesktopWindowSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebDesktopWindowSettings Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Using Window Options

Concepts

Window

concepts

Styles Inheritance model for Uniform Look and Feel across entire Application.


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowSettings Class
WebDesktopWindowSettings Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowSettings
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowSettings Class
WebDesktopWindowSettings Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowSettings

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowSettings Class
WebDesktopWindowSettings Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowSettings Class
WebDesktopWindowSettings Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowSettings
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowSettings Class
WebDesktopWindowSettings Members


WebDesktopWindowSettings Class Properties

[image]
Intersoft WebDesktop Documentation
WebDesktopWindowSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDesktopWindowSettings Class

Glossary Item Box

For a list of all members of this type, see WebDesktopWindowSettings members.

Public Properties

 | Name | Description
Public Property | AllowClose |
Public Property | AllowMaximize |
Public Property | AllowMinimize |
Public Property | AllowResize |
Public Property | ApplyContainerStyle |
Public Property | BorderType | Gets or sets the type of the border applied to Window.
Public Property | CaptionButtonSpacing |
Public Property | CaptionButtonStyle |
Public Property | CaptionDisplayMode |
Public Property | CaptionStyle |
Public Property | CommandBarPadding |
Public Property | CommandButtonBorderType |
Public Property | CommandButtonDisabledStyle | Gets or sets the disabled style of command button.
Public Property | CommandButtonStyle | Gets or sets the style applied to command button.
Public Property | ContainerStyle | Gets or sets the style applied to the content part of the Window.
Public Property | ContentMode | Gets or sets the default content mode for Window.
Public Property | ControlBox |
Public Property | ControlBoxPosition |
Public Property | DimWindowWhenBusy |
Public Property | DropShadow |
Public Property | EnableFastWindowActivation |
Public Property | IFrameAllowTransparency | Specifies whether the IFRAME should allow transparency. This property is applicable when ContentMode is set to UseIFrame.
Public Property | IFrameReadyTransitionEffect | Gets or sets the visual transition effect that will be applied when the IFrame content has been successfully loaded.
Public Property | IFrameShowLoader | Specifies whether to show loader text when the active IFrame is in loading progress. This property only applicables when ContentMode is set to UseIFrame.
Public Property | IgnoreIFramePadding |
Public Property | MaximumSize |
Public Property | MinimumSize |
Public Property | ScrollBarStyle |
Public Property | Size |
Public Property | TextAlignment |
Public Property | WindowHeaderHeight |
Public Property | WindowOptionsPosition |
Public Property | WindowStyle | Gets or sets the style applied to Window.
Top

See Also

Reference

WebDesktopWindowSettings Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Using Window Options

Concepts

Window

concepts

Styles Inheritance model for Uniform Look and Feel across entire Application.


WebDesktopWindowSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebDesktopWindowSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowSettings Class : WebDesktopWindowSettings Constructor

Glossary Item Box

Initializes a new instance of the WebDesktopWindowSettings class.

Overload List

Overload | Description
WebDesktopWindowSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowSettings Class
WebDesktopWindowSettings Members


AllowClose Property

[image]
Intersoft WebDesktop Documentation
AllowClose Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowSettings Class : AllowClose Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property AllowClose As CloseMode
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowSettings
Dim value As CloseMode

instance.AllowClose = value

value = instance.AllowClose
C#
public CloseMode AllowClose {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowSettings Class
WebDesktopWindowSettings Members


AllowMaximize Property

[image]
Intersoft WebDesktop Documentation
AllowMaximize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowSettings Class : AllowMaximize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property AllowMaximize As AllowMaximize
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowSettings
Dim value As AllowMaximize

instance.AllowMaximize = value

value = instance.AllowMaximize
C#
public virtual AllowMaximize AllowMaximize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowSettings Class
WebDesktopWindowSettings Members


AllowMinimize Property

[image]
Intersoft WebDesktop Documentation
AllowMinimize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowSettings Class : AllowMinimize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property AllowMinimize As AllowMinimize
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowSettings
Dim value As AllowMinimize

instance.AllowMinimize = value

value = instance.AllowMinimize
C#
public virtual AllowMinimize AllowMinimize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowSettings Class
WebDesktopWindowSettings Members


AllowResize Property

[image]
Intersoft WebDesktop Documentation
AllowResize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowSettings Class : AllowResize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property AllowResize As AllowResize
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowSettings
Dim value As AllowResize

instance.AllowResize = value

value = instance.AllowResize
C#
public virtual AllowResize AllowResize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowSettings Class
WebDesktopWindowSettings Members


ApplyContainerStyle Property

[image]
Intersoft WebDesktop Documentation
ApplyContainerStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowSettings Class : ApplyContainerStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ApplyContainerStyle As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowSettings
Dim value As Boolean

instance.ApplyContainerStyle = value

value = instance.ApplyContainerStyle
C#
public bool ApplyContainerStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowSettings Class
WebDesktopWindowSettings Members


BorderType Property

[image]
Intersoft WebDesktop Documentation
BorderType Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowSettings Class : BorderType Property

Glossary Item Box

Gets or sets the type of the border applied to Window.

Syntax

Visual Basic (Declaration)
Public Overridable Property BorderType As BorderType
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowSettings
Dim value As BorderType

instance.BorderType = value

value = instance.BorderType
C#
public virtual BorderType BorderType {get; set;}

Remarks

You can set the BorderType to ComplexImages in order to enable higher level of customization. The term "ComplexImages" indicates that the rendering will use many images to draw up an element. For example, there should be 3 separate images in order to draw left part of caption, the body of the caption and right part of caption.

In WebDesktopManager there are more than 20 ImagesSettings properties provided in order to let developers to design high detailed, gradient, shadowed or round corner style of border.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowSettings Class
WebDesktopWindowSettings Members

Tasks

Configuring Window to use Complex Images

Concepts

WebDesktop Features

concepts

Window


CaptionButtonSpacing Property

[image]
Intersoft WebDesktop Documentation
CaptionButtonSpacing Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowSettings Class : CaptionButtonSpacing Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property CaptionButtonSpacing As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowSettings
Dim value As Integer

instance.CaptionButtonSpacing = value

value = instance.CaptionButtonSpacing
C#
public int CaptionButtonSpacing {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowSettings Class
WebDesktopWindowSettings Members


CaptionButtonStyle Property

[image]
Intersoft WebDesktop Documentation
CaptionButtonStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowSettings Class : CaptionButtonStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property CaptionButtonStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowSettings
Dim value As ISNet.WebUI.DynamicStyle

instance.CaptionButtonStyle = value

value = instance.CaptionButtonStyle
C#
public ISNet.WebUI.DynamicStyle CaptionButtonStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowSettings Class
WebDesktopWindowSettings Members


CaptionDisplayMode Property

[image]
Intersoft WebDesktop Documentation
CaptionDisplayMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowSettings Class : CaptionDisplayMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property CaptionDisplayMode As WindowCaptionDisplayMode
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowSettings
Dim value As WindowCaptionDisplayMode

instance.CaptionDisplayMode = value

value = instance.CaptionDisplayMode
C#
public virtual WindowCaptionDisplayMode CaptionDisplayMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowSettings Class
WebDesktopWindowSettings Members


CaptionStyle Property

[image]
Intersoft WebDesktop Documentation
CaptionStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowSettings Class : CaptionStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property CaptionStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowSettings
Dim value As ISNet.WebUI.DynamicStyle

instance.CaptionStyle = value

value = instance.CaptionStyle
C#
public ISNet.WebUI.DynamicStyle CaptionStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowSettings Class
WebDesktopWindowSettings Members


CommandBarPadding Property

[image]
Intersoft WebDesktop Documentation
CommandBarPadding Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowSettings Class : CommandBarPadding Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property CommandBarPadding As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowSettings
Dim value As Integer

instance.CommandBarPadding = value

value = instance.CommandBarPadding
C#
public int CommandBarPadding {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowSettings Class
WebDesktopWindowSettings Members


CommandButtonBorderType Property

[image]
Intersoft WebDesktop Documentation
CommandButtonBorderType Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowSettings Class : CommandButtonBorderType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property CommandButtonBorderType As BorderType
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowSettings
Dim value As BorderType

instance.CommandButtonBorderType = value

value = instance.CommandButtonBorderType
C#
public virtual BorderType CommandButtonBorderType {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowSettings Class
WebDesktopWindowSettings Members


CommandButtonDisabledStyle Property

[image]
Intersoft WebDesktop Documentation
CommandButtonDisabledStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowSettings Class : CommandButtonDisabledStyle Property

Glossary Item Box

Gets or sets the disabled style of command button.

Syntax

Visual Basic (Declaration)
Public Property CommandButtonDisabledStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowSettings
Dim value As ISNet.WebUI.WebStyle

instance.CommandButtonDisabledStyle = value

value = instance.CommandButtonDisabledStyle
C#
public ISNet.WebUI.WebStyle CommandButtonDisabledStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowSettings Class
WebDesktopWindowSettings Members


CommandButtonStyle Property

[image]
Intersoft WebDesktop Documentation
CommandButtonStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowSettings Class : CommandButtonStyle Property

Glossary Item Box

Gets or sets the style applied to command button.

Syntax

Visual Basic (Declaration)
Public Property CommandButtonStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowSettings
Dim value As ISNet.WebUI.DynamicStyle

instance.CommandButtonStyle = value

value = instance.CommandButtonStyle
C#
public ISNet.WebUI.DynamicStyle CommandButtonStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowSettings Class
WebDesktopWindowSettings Members


ContainerStyle Property

[image]
Intersoft WebDesktop Documentation
ContainerStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowSettings Class : ContainerStyle Property

Glossary Item Box

Gets or sets the style applied to the content part of the Window.

Syntax

Visual Basic (Declaration)
Public Property ContainerStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowSettings
Dim value As ISNet.WebUI.WebStyle

instance.ContainerStyle = value

value = instance.ContainerStyle
C#
public ISNet.WebUI.WebStyle ContainerStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowSettings Class
WebDesktopWindowSettings Members


ContentMode Property

[image]
Intersoft WebDesktop Documentation
ContentMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowSettings Class : ContentMode Property

Glossary Item Box

Gets or sets the default content mode for Window.

Syntax

Visual Basic (Declaration)
Public Property ContentMode As ContentMode
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowSettings
Dim value As ContentMode

instance.ContentMode = value

value = instance.ContentMode
C#
public ContentMode ContentMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowSettings Class
WebDesktopWindowSettings Members


ControlBox Property

[image]
Intersoft WebDesktop Documentation
ControlBox Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowSettings Class : ControlBox Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ControlBox As ControlBox
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowSettings
Dim value As ControlBox

instance.ControlBox = value

value = instance.ControlBox
C#
public virtual ControlBox ControlBox {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowSettings Class
WebDesktopWindowSettings Members


ControlBoxPosition Property

[image]
Intersoft WebDesktop Documentation
ControlBoxPosition Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowSettings Class : ControlBoxPosition Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ControlBoxPosition As ControlBoxPosition
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowSettings
Dim value As ControlBoxPosition

instance.ControlBoxPosition = value

value = instance.ControlBoxPosition
C#
public ControlBoxPosition ControlBoxPosition {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowSettings Class
WebDesktopWindowSettings Members


DimWindowWhenBusy Property

[image]
Intersoft WebDesktop Documentation
DimWindowWhenBusy Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowSettings Class : DimWindowWhenBusy Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property DimWindowWhenBusy As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowSettings
Dim value As Boolean

instance.DimWindowWhenBusy = value

value = instance.DimWindowWhenBusy
C#
public bool DimWindowWhenBusy {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowSettings Class
WebDesktopWindowSettings Members


DropShadow Property

[image]
Intersoft WebDesktop Documentation
DropShadow Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowSettings Class : DropShadow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property DropShadow As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowSettings
Dim value As Boolean

instance.DropShadow = value

value = instance.DropShadow
C#
public bool DropShadow {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowSettings Class
WebDesktopWindowSettings Members


EnableFastWindowActivation Property

[image]
Intersoft WebDesktop Documentation
EnableFastWindowActivation Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowSettings Class : EnableFastWindowActivation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property EnableFastWindowActivation As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowSettings
Dim value As Boolean

instance.EnableFastWindowActivation = value

value = instance.EnableFastWindowActivation
C#
public bool EnableFastWindowActivation {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowSettings Class
WebDesktopWindowSettings Members


IFrameAllowTransparency Property

[image]
Intersoft WebDesktop Documentation
IFrameAllowTransparency Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowSettings Class : IFrameAllowTransparency Property

Glossary Item Box

Specifies whether the IFRAME should allow transparency. This property is applicable when ContentMode is set to UseIFrame.

Syntax

Visual Basic (Declaration)
Public Property IFrameAllowTransparency As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowSettings
Dim value As Boolean

instance.IFrameAllowTransparency = value

value = instance.IFrameAllowTransparency
C#
public bool IFrameAllowTransparency {get; set;}

Remarks

The default value of IFrameTransparency is True. Therefore, it enables the ContainerStyle of the Window to stay visible and ignoring the background color of the loaded WebPage.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowSettings Class
WebDesktopWindowSettings Members

Concepts

WebDesktop Features


IFrameReadyTransitionEffect Property

[image]
Intersoft WebDesktop Documentation
IFrameReadyTransitionEffect Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowSettings Class : IFrameReadyTransitionEffect Property

Glossary Item Box

Gets or sets the visual transition effect that will be applied when the IFrame content has been successfully loaded.

Syntax

Visual Basic (Declaration)
Public Property IFrameReadyTransitionEffect As VisualTransitionEffect
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowSettings
Dim value As VisualTransitionEffect

instance.IFrameReadyTransitionEffect = value

value = instance.IFrameReadyTransitionEffect
C#
public VisualTransitionEffect IFrameReadyTransitionEffect {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowSettings Class
WebDesktopWindowSettings Members


IFrameShowLoader Property

[image]
Intersoft WebDesktop Documentation
IFrameShowLoader Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowSettings Class : IFrameShowLoader Property

Glossary Item Box

Specifies whether to show loader text when the active IFrame is in loading progress. This property only applicables when ContentMode is set to UseIFrame.

Syntax

Visual Basic (Declaration)
Public Property IFrameShowLoader As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowSettings
Dim value As Boolean

instance.IFrameShowLoader = value

value = instance.IFrameShowLoader
C#
public bool IFrameShowLoader {get; set;}

Remarks

IFrameShowLoader is a useful feature which shows a loading progress bar and loading text inside the center of Window during the loading of WebForm in the IFrame. When the WebForm finished loading, the content of the Window will show up immediately. This process of loading, hiding and showing the content are done automatically by WebDesktopManager and requires no additional codes.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowSettings Class
WebDesktopWindowSettings Members

Concepts

WebDesktop Features


IgnoreIFramePadding Property

[image]
Intersoft WebDesktop Documentation
IgnoreIFramePadding Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowSettings Class : IgnoreIFramePadding Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property IgnoreIFramePadding As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowSettings
Dim value As Boolean

instance.IgnoreIFramePadding = value

value = instance.IgnoreIFramePadding
C#
public bool IgnoreIFramePadding {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowSettings Class
WebDesktopWindowSettings Members


MaximumSize Property

[image]
Intersoft WebDesktop Documentation
MaximumSize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowSettings Class : MaximumSize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property MaximumSize As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowSettings
Dim value As System.Drawing.Size

instance.MaximumSize = value

value = instance.MaximumSize
C#
public System.Drawing.Size MaximumSize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowSettings Class
WebDesktopWindowSettings Members


MinimumSize Property

[image]
Intersoft WebDesktop Documentation
MinimumSize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowSettings Class : MinimumSize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property MinimumSize As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowSettings
Dim value As System.Drawing.Size

instance.MinimumSize = value

value = instance.MinimumSize
C#
public System.Drawing.Size MinimumSize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowSettings Class
WebDesktopWindowSettings Members


ScrollBarStyle Property

[image]
Intersoft WebDesktop Documentation
ScrollBarStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowSettings Class : ScrollBarStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ScrollBarStyle As WebScrollBarStyle
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowSettings
Dim value As WebScrollBarStyle

instance.ScrollBarStyle = value

value = instance.ScrollBarStyle
C#
public WebScrollBarStyle ScrollBarStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowSettings Class
WebDesktopWindowSettings Members


Size Property

[image]
Intersoft WebDesktop Documentation
Size Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowSettings Class : Size Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Size As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowSettings
Dim value As System.Drawing.Size

instance.Size = value

value = instance.Size
C#
public System.Drawing.Size Size {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowSettings Class
WebDesktopWindowSettings Members


TextAlignment Property

[image]
Intersoft WebDesktop Documentation
TextAlignment Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowSettings Class : TextAlignment Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property TextAlignment As TextAlignment
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowSettings
Dim value As TextAlignment

instance.TextAlignment = value

value = instance.TextAlignment
C#
public TextAlignment TextAlignment {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowSettings Class
WebDesktopWindowSettings Members


WindowHeaderHeight Property

[image]
Intersoft WebDesktop Documentation
WindowHeaderHeight Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowSettings Class : WindowHeaderHeight Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property WindowHeaderHeight As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowSettings
Dim value As Integer

instance.WindowHeaderHeight = value

value = instance.WindowHeaderHeight
C#
public int WindowHeaderHeight {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowSettings Class
WebDesktopWindowSettings Members


WindowOptionsPosition Property

[image]
Intersoft WebDesktop Documentation
WindowOptionsPosition Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowSettings Class : WindowOptionsPosition Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property WindowOptionsPosition As WindowOptionsPosition
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowSettings
Dim value As WindowOptionsPosition

instance.WindowOptionsPosition = value

value = instance.WindowOptionsPosition
C#
public WindowOptionsPosition WindowOptionsPosition {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowSettings Class
WebDesktopWindowSettings Members


WindowStyle Property

[image]
Intersoft WebDesktop Documentation
WindowStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDesktopWindowSettings Class : WindowStyle Property

Glossary Item Box

Gets or sets the style applied to Window.

Syntax

Visual Basic (Declaration)
Public Property WindowStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebDesktopWindowSettings
Dim value As ISNet.WebUI.DynamicStyle

instance.WindowStyle = value

value = instance.WindowStyle
C#
public ISNet.WebUI.DynamicStyle WindowStyle {get; set;}

Remarks

WindowStyle includes the dynamic style definition such as Normal, Over and Active styles for a Window. You can also customize the complex images of a Window in ImagesSettings when the BorderType is set to ComplexImages.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesktopWindowSettings Class
WebDesktopWindowSettings Members

Concepts

Styles Inheritance model for Uniform Look and Feel across entire Application.


WebDialogBox Class

[image]
Intersoft WebDesktop Documentation
WebDialogBox Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDialogBox Class

Glossary Item Box

The control that replicates the behavior of WebDesktop's dialog box.

WebDialogBox offers unique dialog box UI functionalities with highly customizable appearances and styles. It simulates a true "modal" dialog which has closest behavior to desktop's dialog box.

Object Model

WebDialogBox Class

Syntax

Visual Basic (Declaration)
Public Class WebDialogBox
   Inherits ISNet.WebUI.ISNetControl
   Implements ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, ISNet.WebUI.ITemplateSync
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
C#
public class WebDialogBox : ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, ISNet.WebUI.ITemplateSync

Remarks

You can use WebDialogBox control to easily display professional looking dialogbox in your webform. WebDialogBox features modal dialogbox capabilities similar to desktop's behaviors.

When integrated to DesktopManager, WebDialogBox will automatically inherit style definition specified in DesktopManager. This provides zero-efforts for delivering consistent visual styles of the WindowStyle. In addition, WebDialogBox is further extended with the Window behaviors available in DesktopManager.

The following are some of the key features of WebDialogBox

  • TrueModal behavior
    One of the big challenges in web-based user interface is to create a custom dialog box which has true modal behavior similar to desktop's dialog boxes. Intersoft's WebDialogBox is so far the only web component being able to simulate modal behavior closely to desktop's style. To learn more please refer to WebDialogBox Features.
  • DesktopManager Integration
    WebDialogBox can be used in either StandAlone or Integrated mode. By default, DialogBox will use StandAlone mode when constructed at the first time. When running in StandAlone mode, the dialog box will be displayed on the top of the document's body.
  • ClickAndEdit design time experience
    The ClickAndEdit architecture has been extensively implemented in DialogBox and entire members of WebDesktop.NET. Therefore, developers can conveniently click on the editable area of the DialogBox and edit it right away.
  • CommandButtons collection
    CommandButtons feature allows developer to easily add what buttons should appear in the dialogbox instead of having developer to create their own button.
  • DialogResult and CommandButton's Type
    DialogResult exposed the same concept and behavior as in Windows Form application. There are 8 predefined button types which will be used as DialogResult when the dialog box is closed. The enumerations are Abort, Retry, Ignore, OK, Cancel, Yes, No and Custom.

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
ISNet.WebUI.ISNetControl
ISNet.WebUI.WebDesktop.WebDialogBox

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Members
ISNet.WebUI.WebDesktop Namespace

Tasks

Creating Simple Desktop

tasks

Designing custom DialogBox

Concepts

WebDialogBox Overview
WebDialogBox Features

concepts

Integrating into WebDesktopManager


WebDialogBox Class Members

[image]
Intersoft WebDesktop Documentation
WebDialogBox Class Members
See Also Properties Methods Events Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDialogBox Class

Glossary Item Box

The following tables list the members exposed by WebDialogBox.

Public Constructors

 | Name | Description
Public Constructor | WebDialogBox Constructor |
Top

Public Properties

 | Name | Description
Public Property | AccessKey | Keyboard shortcut used by the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | AnimationStyle | Specifies the animation style applied to the window.
Public Property | BackColor | Overridden. Color of the background of the control.
Public Property | BorderColor | Overridden. Border color of the controls applied with this style.
Public Property | BorderStyle | Overridden. Style of the border around the control.
Public Property | BorderWidth | Overridden. Width of the border around the control.
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ClientSideEvents | Contains client side events for the dialog box.
Public Property | CommandButtonAlignment | Gets or sets the buttons alignment in the dialog box.
Public Property | CommandButtons | Contains the collection of command buttons used in dialog box.
Public Property | CommandButtonSize |
Public Property | CommandButtonSpacing | Gets or sets the default spacing between each command button.
Public Property | ContentScrollable | Specifies whether the content area (when using InlineContent) is scrollable.
Public Property | ContentURL | Gets or sets the Content URL for this window.
Public Property | ControlBoxImage | Gets or sets the default controlbox image for this Window.
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | CustomDialogBoxImage | Gets or sets the custom dialog box image.
Public Property | DialogBoxImage | Gets or sets the predefined image used by the dialog box.
Public Property | DialogBoxImageVAlign | Gets or sets the dialog box image's vertical alignment.
Public Property | EnableAnimation | Specifies whether animation is supported for this dialog box instance.
Public Property | Enabled | Enabled state of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableDropShadow |
Public Property | EnableManagedTheming | Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to False, this control will not apply the style defined in Theme Architecture. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | Whether the control automatically saves its state for use in round-trips. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Font | Overridden. The font used for text within the control.
Public Property | ForeColor | Overridden. Color of the text within the control.
Public Property | Height | Overridden. The height of the control.
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ImagePosition | Gets or sets the dialog box's image position relative to the content text.
Public Property | ImagesDirectory | Gets or sets the images directory for the dialog box control.
Public Property | InProgressText | Gets or sets the text shown during IFrame loading.
Public Property | IntegratedToDesktopManager | Specifies whether the dialog box should be integrated into Desktop Manager.
Public Property | IsModal | Specifies whether the dialog box should be shown as modal.
Public Property | KeepVisibleOnScroll | Specifies whether the dialog box should be kept visible when the Web Page is scrolled.
Public Property | Location | Gets or sets the initial location that this Window should be displayed at.
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden. Gets or sets the directory where all required scripts for the control are stored.
Public Property | ShadowColor | Specifies the color of the dialog box's shadow.
Public Property | ShadowOpacity | Specifies the transparency opacity of the shadow, when ShadowColor is set to a solid color.
Public Property | SharedScriptDirectory | Overridden. Gets os sets the directory where al shared script for Intersoft controls are stored.
Public Property | ShowOnLoad |
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | StartPosition | Gets or sets the start up position of the dialog box.
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Text | Gets or sets the caption text for this window.
Public Property | ToolTip | The tooltip displayed when the mouse is over the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateItems | Gets or sets the items to be stored in view state storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | Gets or sets the server connection string for file server-based viewstate storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | Gets or sets the location to store the viewstate of this control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | Indicates whether the control is visible and rendered. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Width | Overridden. The width of the control.
Public Property | WindowSettings | Contains window settings for the dialog box.
Public Property | XmlCompressionEnabled | Specifies whether the Xml used for clientside state storage should be compressed. (Inherited from ISNet.WebUI.ISNetControl)
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CheckConstrains | Overridden.
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
static (Shared in Visual Basic) | EnsureWebDialogBoxScripts |
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPostData | Overridden.
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RaisePostBackEvent |
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RecreateChildControls |
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterScript | Overridden.
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SynchronizeTemplatesFrom |
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebDialogBox Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Creating Simple Desktop

tasks

Designing custom DialogBox

Concepts

WebDialogBox Overview
WebDialogBox Features

concepts

Integrating into WebDesktopManager


WebDialogBox Class Events

[image]
Intersoft WebDesktop Documentation
WebDialogBox Class Events
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDialogBox Class

Glossary Item Box

For a list of all members of this type, see WebDialogBox members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebDialogBox Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Creating Simple Desktop

tasks

Designing custom DialogBox

Concepts

WebDialogBox Overview
WebDialogBox Features

concepts

Integrating into WebDesktopManager


WebDialogBox Constructor

[image]
Intersoft WebDesktop Documentation
WebDialogBox Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : WebDialogBox Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebDialogBox()
C#
public WebDialogBox()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


ApplyStyle Method

[image]
Intersoft WebDesktop Documentation
ApplyStyle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : ApplyStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ApplyStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim s As System.Web.UI.WebControls.Style

instance.ApplyStyle(s)
C#
public void ApplyStyle(
   System.Web.UI.WebControls.Style s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


ApplyStyleSheetSkin Method

[image]
Intersoft WebDesktop Documentation
ApplyStyleSheetSkin Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : ApplyStyleSheetSkin Method

page

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub ApplyStyleSheetSkin( _
   ByVal page As System.Web.UI.Page _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim page As System.Web.UI.Page

instance.ApplyStyleSheetSkin(page)
C#
public virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page page
)

Parameters

page

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


CanUseWebResources Method

[image]
Intersoft WebDesktop Documentation
CanUseWebResources Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : CanUseWebResources Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CanUseWebResources() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As Boolean

value = instance.CanUseWebResources()
C#
public bool CanUseWebResources()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


WebDialogBox Class Methods

[image]
Intersoft WebDesktop Documentation
WebDialogBox Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDialogBox Class

Glossary Item Box

For a list of all members of this type, see WebDialogBox members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CheckConstrains | Overridden.
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
static (Shared in Visual Basic) | EnsureWebDialogBoxScripts |
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPostData | Overridden.
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RaisePostBackEvent |
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RecreateChildControls |
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterScript | Overridden.
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SynchronizeTemplatesFrom |
Top

See Also

Reference

WebDialogBox Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Creating Simple Desktop

tasks

Designing custom DialogBox

Concepts

WebDialogBox Overview
WebDialogBox Features

concepts

Integrating into WebDesktopManager


CheckConstrains Method

[image]
Intersoft WebDesktop Documentation
CheckConstrains Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : CheckConstrains Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub CheckConstrains()
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox

instance.CheckConstrains()
C#
public override void CheckConstrains()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


CopyBaseAttributes Method

[image]
Intersoft WebDesktop Documentation
CopyBaseAttributes Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : CopyBaseAttributes Method

controlSrc

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyBaseAttributes( _
   ByVal controlSrc As System.Web.UI.WebControls.WebControl _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim controlSrc As System.Web.UI.WebControls.WebControl

instance.CopyBaseAttributes(controlSrc)
C#
public void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl controlSrc
)

Parameters

controlSrc

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.ISNetControl)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members
Overload List


DataBind Method

[image]
Intersoft WebDesktop Documentation
DataBind Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : DataBind Method

Glossary Item Box

Overload List

Overload | Description
DataBind | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


DataBind() Method

[image]
Intersoft WebDesktop Documentation
DataBind() Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : DataBind() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub DataBind()
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox

instance.DataBind()
C#
public virtual void DataBind()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


Dispose Method

[image]
Intersoft WebDesktop Documentation
Dispose Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : Dispose Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox

instance.Dispose()
C#
public virtual void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


EnsureWebDialogBoxScripts Method

[image]
Intersoft WebDesktop Documentation
EnsureWebDialogBoxScripts Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : EnsureWebDialogBoxScripts Method

page

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Sub EnsureWebDialogBoxScripts( _
   ByVal page As System.Web.UI.Page _
)
Visual Basic (Usage) Copy Code
Dim page As System.Web.UI.Page

WebDialogBox.EnsureWebDialogBoxScripts(page)
C#
public static void EnsureWebDialogBoxScripts(
   System.Web.UI.Page page
)

Parameters

page

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


FindControl Method

[image]
Intersoft WebDesktop Documentation
FindControl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : FindControl Method

Glossary Item Box

Overload List

Overload | Description
FindControl | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


FindControl(String) Method

[image]
Intersoft WebDesktop Documentation
FindControl(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : FindControl(String) Method

id

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function FindControl( _
   ByVal id As String _
) As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim id As String
Dim value As System.Web.UI.Control

value = instance.FindControl(id)
C#
public virtual System.Web.UI.Control FindControl(
   string id
)

Parameters

id

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


Focus Method

[image]
Intersoft WebDesktop Documentation
Focus Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : Focus Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Focus()
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox

instance.Focus()
C#
public virtual void Focus()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


ForceDisableXmlCompression Method

[image]
Intersoft WebDesktop Documentation
ForceDisableXmlCompression Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : ForceDisableXmlCompression Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ForceDisableXmlCompression()
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox

instance.ForceDisableXmlCompression()
C#
public void ForceDisableXmlCompression()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


GetCurrentControlLifeCycle Method

[image]
Intersoft WebDesktop Documentation
GetCurrentControlLifeCycle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : GetCurrentControlLifeCycle Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentControlLifeCycle() As ISNet.WebUI.ControlLifeCycle
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As ISNet.WebUI.ControlLifeCycle

value = instance.GetCurrentControlLifeCycle()
C#
public ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


GetCurrentTheme Method

[image]
Intersoft WebDesktop Documentation
GetCurrentTheme Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : GetCurrentTheme Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentTheme() As ISNet.WebUI.ThemeInfo
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As ISNet.WebUI.ThemeInfo

value = instance.GetCurrentTheme()
C#
public ISNet.WebUI.ThemeInfo GetCurrentTheme()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


GetFrameworkDataFolder Method

[image]
Intersoft WebDesktop Documentation
GetFrameworkDataFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : GetFrameworkDataFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkDataFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As String

value = instance.GetFrameworkDataFolder()
C#
public string GetFrameworkDataFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


GetFrameworkFolder Method

[image]
Intersoft WebDesktop Documentation
GetFrameworkFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : GetFrameworkFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As String

value = instance.GetFrameworkFolder()
C#
public string GetFrameworkFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


GetFrameworkVersion Method

[image]
Intersoft WebDesktop Documentation
GetFrameworkVersion Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : GetFrameworkVersion Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkVersion() As Version
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As Version

value = instance.GetFrameworkVersion()
C#
public Version GetFrameworkVersion()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


GetIntersoftFolder Method

[image]
Intersoft WebDesktop Documentation
GetIntersoftFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : GetIntersoftFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetIntersoftFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As String

value = instance.GetIntersoftFolder()
C#
public string GetIntersoftFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


GetLayoutFolder Method

[image]
Intersoft WebDesktop Documentation
GetLayoutFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : GetLayoutFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetLayoutFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As String

value = instance.GetLayoutFolder()
C#
public string GetLayoutFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


GetPostedXMLData Method

[image]
Intersoft WebDesktop Documentation
GetPostedXMLData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : GetPostedXMLData Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPostedXMLData() As String
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As String

value = instance.GetPostedXMLData()
C#
public string GetPostedXMLData()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


GetProductInfoKey Method

[image]
Intersoft WebDesktop Documentation
GetProductInfoKey Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : GetProductInfoKey Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductInfoKey() As String
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As String

value = instance.GetProductInfoKey()
C#
public string GetProductInfoKey()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


GetProductSimpleName Method

[image]
Intersoft WebDesktop Documentation
GetProductSimpleName Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : GetProductSimpleName Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductSimpleName() As String
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As String

value = instance.GetProductSimpleName()
C#
public string GetProductSimpleName()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


GetPropertyValue Method

[image]
Intersoft WebDesktop Documentation
GetPropertyValue Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : GetPropertyValue Method

defValue
propValue
webConfigKey

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPropertyValue( _
   ByVal defValue As String, _
   ByVal propValue As String, _
   ByVal webConfigKey As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim defValue As String
Dim propValue As String
Dim webConfigKey As String
Dim value As String

value = instance.GetPropertyValue(defValue, propValue, webConfigKey)
C#
public string GetPropertyValue(
   string defValue,
   string propValue,
   string webConfigKey
)

Parameters

defValue
propValue
webConfigKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


GetResourceStream Method

[image]
Intersoft WebDesktop Documentation
GetResourceStream Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : GetResourceStream Method

resourceUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetResourceStream( _
   ByVal resourceUrl As String _
) As System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim resourceUrl As String
Dim value As System.IO.Stream

value = instance.GetResourceStream(resourceUrl)
C#
public System.IO.Stream GetResourceStream(
   string resourceUrl
)

Parameters

resourceUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


GetRouteUrl Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : GetRouteUrl Method

Glossary Item Box

Overload List

Overload | Description
GetRouteUrl(Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(RouteValueDictionary) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,RouteValueDictionary) | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


GetRouteUrl(Object) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class > GetRouteUrl Method : GetRouteUrl(Object) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As Object _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim routeParameters As Object
Dim value As String

value = instance.GetRouteUrl(routeParameters)
C#
public string GetRouteUrl(
   object routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members
Overload List


GetRouteUrl(String,Object) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(String,Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class > GetRouteUrl Method : GetRouteUrl(String,Object) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As String, _
   ByVal routeParameters As Object _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim routeName As String
Dim routeParameters As Object
Dim value As String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public string GetRouteUrl(
   string routeName,
   object routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members
Overload List


GetRouteUrl(RouteValueDictionary) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(RouteValueDictionary) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class > GetRouteUrl Method : GetRouteUrl(RouteValueDictionary) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As String

value = instance.GetRouteUrl(routeParameters)
C#
public string GetRouteUrl(
   System.Web.Routing.RouteValueDictionary routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members
Overload List


GetRouteUrl(String,RouteValueDictionary) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(String,RouteValueDictionary) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class > GetRouteUrl Method : GetRouteUrl(String,RouteValueDictionary) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As String, _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim routeName As String
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public string GetRouteUrl(
   string routeName,
   System.Web.Routing.RouteValueDictionary routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members
Overload List


GetUniqueIDRelativeTo Method

[image]
Intersoft WebDesktop Documentation
GetUniqueIDRelativeTo Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : GetUniqueIDRelativeTo Method

control

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetUniqueIDRelativeTo( _
   ByVal control As System.Web.UI.Control _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim control As System.Web.UI.Control
Dim value As String

value = instance.GetUniqueIDRelativeTo(control)
C#
public string GetUniqueIDRelativeTo(
   System.Web.UI.Control control
)

Parameters

control

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


HasControls Method

[image]
Intersoft WebDesktop Documentation
HasControls Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : HasControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function HasControls() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As Boolean

value = instance.HasControls()
C#
public virtual bool HasControls()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


IsAtlasCallback Method

[image]
Intersoft WebDesktop Documentation
IsAtlasCallback Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : IsAtlasCallback Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsAtlasCallback() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As Boolean

value = instance.IsAtlasCallback()
C#
public bool IsAtlasCallback()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


IsBetaRelease Method

[image]
Intersoft WebDesktop Documentation
IsBetaRelease Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : IsBetaRelease Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsBetaRelease() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As Boolean

value = instance.IsBetaRelease()
C#
public bool IsBetaRelease()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


IsChromeBrowser Method

[image]
Intersoft WebDesktop Documentation
IsChromeBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : IsChromeBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsChromeBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As Boolean

value = instance.IsChromeBrowser()
C#
public bool IsChromeBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


IsFlyPostBackControl Method

[image]
Intersoft WebDesktop Documentation
IsFlyPostBackControl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : IsFlyPostBackControl Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackControl() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As Boolean

value = instance.IsFlyPostBackControl()
C#
public virtual bool IsFlyPostBackControl()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


IsFlyPostBackRequest Method

[image]
Intersoft WebDesktop Documentation
IsFlyPostBackRequest Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : IsFlyPostBackRequest Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackRequest() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As Boolean

value = instance.IsFlyPostBackRequest()
C#
public virtual bool IsFlyPostBackRequest()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


IsGeckoBasedBrowser Method

[image]
Intersoft WebDesktop Documentation
IsGeckoBasedBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : IsGeckoBasedBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoBasedBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As Boolean

value = instance.IsGeckoBasedBrowser()
C#
public bool IsGeckoBasedBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


IsGeckoVersion18 Method

[image]
Intersoft WebDesktop Documentation
IsGeckoVersion18 Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : IsGeckoVersion18 Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoVersion18() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As Boolean

value = instance.IsGeckoVersion18()
C#
public bool IsGeckoVersion18()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


IsInDesignMode Method

[image]
Intersoft WebDesktop Documentation
IsInDesignMode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : IsInDesignMode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInDesignMode() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As Boolean

value = instance.IsInDesignMode()
C#
public bool IsInDesignMode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


IsInternetExplorer8Browser Method

[image]
Intersoft WebDesktop Documentation
IsInternetExplorer8Browser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : IsInternetExplorer8Browser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorer8Browser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As Boolean

value = instance.IsInternetExplorer8Browser()
C#
public bool IsInternetExplorer8Browser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


IsInternetExplorerBrowser Method

[image]
Intersoft WebDesktop Documentation
IsInternetExplorerBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : IsInternetExplorerBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorerBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As Boolean

value = instance.IsInternetExplorerBrowser()
C#
public bool IsInternetExplorerBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


IsOperaBrowser Method

[image]
Intersoft WebDesktop Documentation
IsOperaBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : IsOperaBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsOperaBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As Boolean

value = instance.IsOperaBrowser()
C#
public bool IsOperaBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


IsSafariBrowser Method

[image]
Intersoft WebDesktop Documentation
IsSafariBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : IsSafariBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsSafariBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As Boolean

value = instance.IsSafariBrowser()
C#
public bool IsSafariBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


IsW3CStandardBrowser Method

[image]
Intersoft WebDesktop Documentation
IsW3CStandardBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : IsW3CStandardBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsW3CStandardBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As Boolean

value = instance.IsW3CStandardBrowser()
C#
public bool IsW3CStandardBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


LoadLayout Method

[image]
Intersoft WebDesktop Documentation
LoadLayout Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : LoadLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim settings As ISNet.WebUI.LayoutInfo

instance.LoadLayout(settings)
C#
public virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


LoadLayoutFromFile Method

[image]
Intersoft WebDesktop Documentation
LoadLayoutFromFile Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : LoadLayoutFromFile Method

filePath

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromFile( _
   ByVal filePath As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim filePath As String

instance.LoadLayoutFromFile(filePath)
C#
public virtual void LoadLayoutFromFile(
   string filePath
)

Parameters

filePath

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


LoadLayoutFromPredefinedName Method

[image]
Intersoft WebDesktop Documentation
LoadLayoutFromPredefinedName Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : LoadLayoutFromPredefinedName Method

predefinedName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromPredefinedName( _
   ByVal predefinedName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim predefinedName As String

instance.LoadLayoutFromPredefinedName(predefinedName)
C#
public virtual void LoadLayoutFromPredefinedName(
   string predefinedName
)

Parameters

predefinedName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


LoadLayoutFromStream Method

[image]
Intersoft WebDesktop Documentation
LoadLayoutFromStream Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : LoadLayoutFromStream Method

stream

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromStream( _
   ByVal stream As System.IO.Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim stream As System.IO.Stream

instance.LoadLayoutFromStream(stream)
C#
public virtual void LoadLayoutFromStream(
   System.IO.Stream stream
)

Parameters

stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


LoadPostData Method

[image]
Intersoft WebDesktop Documentation
LoadPostData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : LoadPostData Method

postDataKey
postCollection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function LoadPostData( _
   ByVal postDataKey As String, _
   ByVal postCollection As System.Collections.Specialized.NameValueCollection _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim postDataKey As String
Dim postCollection As System.Collections.Specialized.NameValueCollection
Dim value As Boolean

value = instance.LoadPostData(postDataKey, postCollection)
C#
public override bool LoadPostData(
   string postDataKey,
   System.Collections.Specialized.NameValueCollection postCollection
)

Parameters

postDataKey
postCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


MergeStyle Method

[image]
Intersoft WebDesktop Documentation
MergeStyle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : MergeStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub MergeStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim s As System.Web.UI.WebControls.Style

instance.MergeStyle(s)
C#
public void MergeStyle(
   System.Web.UI.WebControls.Style s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


OnInfoChanged Method

[image]
Intersoft WebDesktop Documentation
OnInfoChanged Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : OnInfoChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnInfoChanged( _
   ByVal e As ISNet.WebUI.SynchronizeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim e As ISNet.WebUI.SynchronizeEventArgs

instance.OnInfoChanged(e)
C#
public void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


OnPreInitialize Method

[image]
Intersoft WebDesktop Documentation
OnPreInitialize Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : OnPreInitialize Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnPreInitialize()
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox

instance.OnPreInitialize()
C#
public virtual void OnPreInitialize()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


RaisePostBackEvent Method

[image]
Intersoft WebDesktop Documentation
RaisePostBackEvent Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : RaisePostBackEvent Method

eventArgument

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RaisePostBackEvent( _
   ByVal eventArgument As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim eventArgument As String

instance.RaisePostBackEvent(eventArgument)
C#
public void RaisePostBackEvent(
   string eventArgument
)

Parameters

eventArgument

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


RaisePostDataChangedEvent Method

[image]
Intersoft WebDesktop Documentation
RaisePostDataChangedEvent Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : RaisePostDataChangedEvent Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RaisePostDataChangedEvent()
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox

instance.RaisePostDataChangedEvent()
C#
public virtual void RaisePostDataChangedEvent()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


ReadWebConfigValue Method

[image]
Intersoft WebDesktop Documentation
ReadWebConfigValue Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : ReadWebConfigValue Method

key

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ReadWebConfigValue( _
   ByVal key As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim key As String
Dim value As String

value = instance.ReadWebConfigValue(key)
C#
public string ReadWebConfigValue(
   string key
)

Parameters

key

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


RecreateChildControls Method

[image]
Intersoft WebDesktop Documentation
RecreateChildControls Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : RecreateChildControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RecreateChildControls()
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox

instance.RecreateChildControls()
C#
public void RecreateChildControls()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


RegisterBoxSizing Method

[image]
Intersoft WebDesktop Documentation
RegisterBoxSizing Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : RegisterBoxSizing Method

Glossary Item Box

Overload List

Overload | Description
RegisterBoxSizing() | (Inherited from ISNet.WebUI.ISNetControl)
RegisterBoxSizing(Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


RegisterBoxSizing() Method

[image]
Intersoft WebDesktop Documentation
RegisterBoxSizing() Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class > RegisterBoxSizing Method : RegisterBoxSizing() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing()
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox

instance.RegisterBoxSizing()
C#
public void RegisterBoxSizing()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members
Overload List


RegisterBoxSizing(Boolean) Method

[image]
Intersoft WebDesktop Documentation
RegisterBoxSizing(Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class > RegisterBoxSizing Method : RegisterBoxSizing(Boolean) Method

forceAll

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing( _
   ByVal forceAll As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim forceAll As Boolean

instance.RegisterBoxSizing(forceAll)
C#
public void RegisterBoxSizing(
   bool forceAll
)

Parameters

forceAll

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members
Overload List


RegisterGlobalStyle Method

[image]
Intersoft WebDesktop Documentation
RegisterGlobalStyle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : RegisterGlobalStyle Method

style

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterGlobalStyle( _
   ByVal style As ISNet.WebUI.WebStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim style As ISNet.WebUI.WebStyle

instance.RegisterGlobalStyle(style)
C#
public void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle style
)

Parameters

style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


RegisterLink Method

[image]
Intersoft WebDesktop Documentation
RegisterLink Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : RegisterLink Method

name
url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterLink( _
   ByVal name As String, _
   ByVal url As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim name As String
Dim url As String

instance.RegisterLink(name, url)
C#
public void RegisterLink(
   string name,
   string url
)

Parameters

name
url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


RegisterOptimizedCssClasses Method

[image]
Intersoft WebDesktop Documentation
RegisterOptimizedCssClasses Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : RegisterOptimizedCssClasses Method

runtimeStyleOnly

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterOptimizedCssClasses( _
   ByVal runtimeStyleOnly As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim runtimeStyleOnly As Boolean

instance.RegisterOptimizedCssClasses(runtimeStyleOnly)
C#
public void RegisterOptimizedCssClasses(
   bool runtimeStyleOnly
)

Parameters

runtimeStyleOnly

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


RegisterPreloadImage Method

[image]
Intersoft WebDesktop Documentation
RegisterPreloadImage Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : RegisterPreloadImage Method

image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterPreloadImage( _
   ByVal image As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim image As String

instance.RegisterPreloadImage(image)
C#
public void RegisterPreloadImage(
   string image
)

Parameters

image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


RegisterScript Method

[image]
Intersoft WebDesktop Documentation
RegisterScript Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : RegisterScript Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub RegisterScript()
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox

instance.RegisterScript()
C#
public override void RegisterScript()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


RegisterSharePointHandler Method

[image]
Intersoft WebDesktop Documentation
RegisterSharePointHandler Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : RegisterSharePointHandler Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RegisterSharePointHandler()
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox

instance.RegisterSharePointHandler()
C#
public virtual void RegisterSharePointHandler()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


RenderBeginTag Method

[image]
Intersoft WebDesktop Documentation
RenderBeginTag Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : RenderBeginTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderBeginTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderBeginTag(writer)
C#
public virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


RenderControl Method

[image]
Intersoft WebDesktop Documentation
RenderControl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : RenderControl Method

Glossary Item Box

Overload List

Overload | Description
RenderControl | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


RenderControl(HtmlTextWriter) Method

[image]
Intersoft WebDesktop Documentation
RenderControl(HtmlTextWriter) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : RenderControl(HtmlTextWriter) Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderControl( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderControl(writer)
C#
public virtual void RenderControl(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


RenderEndTag Method

[image]
Intersoft WebDesktop Documentation
RenderEndTag Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : RenderEndTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub RenderEndTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderEndTag(writer)
C#
public override void RenderEndTag(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


ResolveClientUrl Method

[image]
Intersoft WebDesktop Documentation
ResolveClientUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : ResolveClientUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveClientUrl( _
   ByVal relativeUrl As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim relativeUrl As String
Dim value As String

value = instance.ResolveClientUrl(relativeUrl)
C#
public string ResolveClientUrl(
   string relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


ResolveImagePath Method

[image]
Intersoft WebDesktop Documentation
ResolveImagePath Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : ResolveImagePath Method

folder
image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveImagePath( _
   ByVal folder As String, _
   ByVal image As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim folder As String
Dim image As String
Dim value As String

value = instance.ResolveImagePath(folder, image)
C#
public string ResolveImagePath(
   string folder,
   string image
)

Parameters

folder
image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


ResolveRelativeURL Method

[image]
Intersoft WebDesktop Documentation
ResolveRelativeURL Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : ResolveRelativeURL Method

url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ResolveRelativeURL( _
   ByVal url As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim url As String
Dim value As String

value = instance.ResolveRelativeURL(url)
C#
public virtual string ResolveRelativeURL(
   string url
)

Parameters

url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


ResolveResourceUrl Method

[image]
Intersoft WebDesktop Documentation
ResolveResourceUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : ResolveResourceUrl Method

kind
defaultFolder
currentFolder
resourceName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveResourceUrl( _
   ByVal kind As ISNet.WebUI.ResourceKind, _
   ByVal defaultFolder As String, _
   ByVal currentFolder As String, _
   ByVal resourceName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim kind As ISNet.WebUI.ResourceKind
Dim defaultFolder As String
Dim currentFolder As String
Dim resourceName As String
Dim value As String

value = instance.ResolveResourceUrl(kind, defaultFolder, currentFolder, resourceName)
C#
public string ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   string defaultFolder,
   string currentFolder,
   string resourceName
)

Parameters

kind
defaultFolder
currentFolder
resourceName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


ResolveUrl Method

[image]
Intersoft WebDesktop Documentation
ResolveUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : ResolveUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveUrl( _
   ByVal relativeUrl As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim relativeUrl As String
Dim value As String

value = instance.ResolveUrl(relativeUrl)
C#
public string ResolveUrl(
   string relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


SaveLayout Method

[image]
Intersoft WebDesktop Documentation
SaveLayout Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : SaveLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim settings As ISNet.WebUI.LayoutInfo

instance.SaveLayout(settings)
C#
public virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


SaveLayoutToFile Method

[image]
Intersoft WebDesktop Documentation
SaveLayoutToFile Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : SaveLayoutToFile Method

filePath
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToFile( _
   ByVal filePath As String, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim filePath As String
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToFile(filePath, saveOptions)
C#
public virtual void SaveLayoutToFile(
   string filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

filePath
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


SaveLayoutToStream Method

[image]
Intersoft WebDesktop Documentation
SaveLayoutToStream Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : SaveLayoutToStream Method

stream
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToStream( _
   ByVal stream As System.IO.Stream, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim stream As System.IO.Stream
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToStream(stream, saveOptions)
C#
public virtual void SaveLayoutToStream(
   System.IO.Stream stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

stream
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


SetRenderMethodDelegate Method

[image]
Intersoft WebDesktop Documentation
SetRenderMethodDelegate Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : SetRenderMethodDelegate Method

renderMethod

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetRenderMethodDelegate( _
   ByVal renderMethod As System.Web.UI.RenderMethod _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim renderMethod As System.Web.UI.RenderMethod

instance.SetRenderMethodDelegate(renderMethod)
C#
public void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod renderMethod
)

Parameters

renderMethod

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


SetSessionTheme Method

[image]
Intersoft WebDesktop Documentation
SetSessionTheme Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : SetSessionTheme Method

themeInfo

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetSessionTheme( _
   ByVal themeInfo As ISNet.WebUI.ThemeInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim themeInfo As ISNet.WebUI.ThemeInfo

instance.SetSessionTheme(themeInfo)
C#
public void SetSessionTheme(
   ISNet.WebUI.ThemeInfo themeInfo
)

Parameters

themeInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


ShouldReturnJson Method

[image]
Intersoft WebDesktop Documentation
ShouldReturnJson Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : ShouldReturnJson Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ShouldReturnJson() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As Boolean

value = instance.ShouldReturnJson()
C#
public virtual bool ShouldReturnJson()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


SynchronizeTemplatesFrom Method

[image]
Intersoft WebDesktop Documentation
SynchronizeTemplatesFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : SynchronizeTemplatesFrom Method

source

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SynchronizeTemplatesFrom( _
   ByVal source As ISNet.WebUI.ISNetControl _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim source As ISNet.WebUI.ISNetControl

instance.SynchronizeTemplatesFrom(source)
C#
public void SynchronizeTemplatesFrom(
   ISNet.WebUI.ISNetControl source
)

Parameters

source

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


AccessKey Property

[image]
Intersoft WebDesktop Documentation
AccessKey Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : AccessKey Property

Glossary Item Box

Keyboard shortcut used by the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property AccessKey As String
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As String

instance.AccessKey = value

value = instance.AccessKey
C#
public virtual string AccessKey {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


WebDialogBox Class Properties

[image]
Intersoft WebDesktop Documentation
WebDialogBox Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDialogBox Class

Glossary Item Box

For a list of all members of this type, see WebDialogBox members.

Public Properties

 | Name | Description
Public Property | AccessKey | Keyboard shortcut used by the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | AnimationStyle | Specifies the animation style applied to the window.
Public Property | BackColor | Overridden. Color of the background of the control.
Public Property | BorderColor | Overridden. Border color of the controls applied with this style.
Public Property | BorderStyle | Overridden. Style of the border around the control.
Public Property | BorderWidth | Overridden. Width of the border around the control.
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ClientSideEvents | Contains client side events for the dialog box.
Public Property | CommandButtonAlignment | Gets or sets the buttons alignment in the dialog box.
Public Property | CommandButtons | Contains the collection of command buttons used in dialog box.
Public Property | CommandButtonSize |
Public Property | CommandButtonSpacing | Gets or sets the default spacing between each command button.
Public Property | ContentScrollable | Specifies whether the content area (when using InlineContent) is scrollable.
Public Property | ContentURL | Gets or sets the Content URL for this window.
Public Property | ControlBoxImage | Gets or sets the default controlbox image for this Window.
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | CustomDialogBoxImage | Gets or sets the custom dialog box image.
Public Property | DialogBoxImage | Gets or sets the predefined image used by the dialog box.
Public Property | DialogBoxImageVAlign | Gets or sets the dialog box image's vertical alignment.
Public Property | EnableAnimation | Specifies whether animation is supported for this dialog box instance.
Public Property | Enabled | Enabled state of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableDropShadow |
Public Property | EnableManagedTheming | Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to False, this control will not apply the style defined in Theme Architecture. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | Whether the control automatically saves its state for use in round-trips. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Font | Overridden. The font used for text within the control.
Public Property | ForeColor | Overridden. Color of the text within the control.
Public Property | Height | Overridden. The height of the control.
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ImagePosition | Gets or sets the dialog box's image position relative to the content text.
Public Property | ImagesDirectory | Gets or sets the images directory for the dialog box control.
Public Property | InProgressText | Gets or sets the text shown during IFrame loading.
Public Property | IntegratedToDesktopManager | Specifies whether the dialog box should be integrated into Desktop Manager.
Public Property | IsModal | Specifies whether the dialog box should be shown as modal.
Public Property | KeepVisibleOnScroll | Specifies whether the dialog box should be kept visible when the Web Page is scrolled.
Public Property | Location | Gets or sets the initial location that this Window should be displayed at.
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden. Gets or sets the directory where all required scripts for the control are stored.
Public Property | ShadowColor | Specifies the color of the dialog box's shadow.
Public Property | ShadowOpacity | Specifies the transparency opacity of the shadow, when ShadowColor is set to a solid color.
Public Property | SharedScriptDirectory | Overridden. Gets os sets the directory where al shared script for Intersoft controls are stored.
Public Property | ShowOnLoad |
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | StartPosition | Gets or sets the start up position of the dialog box.
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Text | Gets or sets the caption text for this window.
Public Property | ToolTip | The tooltip displayed when the mouse is over the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateItems | Gets or sets the items to be stored in view state storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | Gets or sets the server connection string for file server-based viewstate storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | Gets or sets the location to store the viewstate of this control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | Indicates whether the control is visible and rendered. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Width | Overridden. The width of the control.
Public Property | WindowSettings | Contains window settings for the dialog box.
Public Property | XmlCompressionEnabled | Specifies whether the Xml used for clientside state storage should be compressed. (Inherited from ISNet.WebUI.ISNetControl)
Top

See Also

Reference

WebDialogBox Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Creating Simple Desktop

tasks

Designing custom DialogBox

Concepts

WebDialogBox Overview
WebDialogBox Features

concepts

Integrating into WebDesktopManager


WebDialogBox Constructor

[image]
Intersoft WebDesktop Documentation
WebDialogBox Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : WebDialogBox Constructor

Glossary Item Box

Initializes a new instance of the WebDialogBox class.

Overload List

Overload | Description
WebDialogBox Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


AnimationStyle Property

[image]
Intersoft WebDesktop Documentation
AnimationStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : AnimationStyle Property

Glossary Item Box

Specifies the animation style applied to the window.

Syntax

Visual Basic (Declaration)
Public Property AnimationStyle As WindowAnimationStyle
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As WindowAnimationStyle

instance.AnimationStyle = value

value = instance.AnimationStyle
C#
public WindowAnimationStyle AnimationStyle {get; set;}

Remarks

As in WebDesktopManager, the new WebDialogBox is also featuring Vista-style zoom animation when the WebDialogBox is showing and closing. This visually compelling animation allows end users to easily notice on the dialog box appearance, which dramatically enhances user experience.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members

Concepts

WebDialogBox Vista-style animation

Tasks

How-to: Enable Vista-style zoom animation in WebDialogBox


BackColor Property

[image]
Intersoft WebDesktop Documentation
BackColor Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : BackColor Property

Glossary Item Box

Color of the background of the control.

Syntax

Visual Basic (Declaration)
Public Overrides Property BackColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
C#
public override System.Drawing.Color BackColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


BorderColor Property

[image]
Intersoft WebDesktop Documentation
BorderColor Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : BorderColor Property

Glossary Item Box

Border color of the controls applied with this style.

Syntax

Visual Basic (Declaration)
Public Overrides Property BorderColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As System.Drawing.Color

instance.BorderColor = value

value = instance.BorderColor
C#
public override System.Drawing.Color BorderColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


BorderStyle Property

[image]
Intersoft WebDesktop Documentation
BorderStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : BorderStyle Property

Glossary Item Box

Style of the border around the control.

Syntax

Visual Basic (Declaration)
Public Overrides Property BorderStyle As System.Web.UI.WebControls.BorderStyle
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As System.Web.UI.WebControls.BorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
C#
public override System.Web.UI.WebControls.BorderStyle BorderStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


BorderWidth Property

[image]
Intersoft WebDesktop Documentation
BorderWidth Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : BorderWidth Property

Glossary Item Box

Width of the border around the control.

Syntax

Visual Basic (Declaration)
Public Overrides Property BorderWidth As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As System.Web.UI.WebControls.Unit

instance.BorderWidth = value

value = instance.BorderWidth
C#
public override System.Web.UI.WebControls.Unit BorderWidth {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


ClientIDMode Property

[image]
Intersoft WebDesktop Documentation
ClientIDMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : ClientIDMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ClientIDMode As System.Web.UI.ClientIDMode
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As System.Web.UI.ClientIDMode

instance.ClientIDMode = value

value = instance.ClientIDMode
C#
public virtual System.Web.UI.ClientIDMode ClientIDMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


ClientSideEvents Property

[image]
Intersoft WebDesktop Documentation
ClientSideEvents Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : ClientSideEvents Property

Glossary Item Box

Contains client side events for the dialog box.

Syntax

Visual Basic (Declaration)
Public Property ClientSideEvents As WebDialogBoxClientSideEvents
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As WebDialogBoxClientSideEvents

instance.ClientSideEvents = value

value = instance.ClientSideEvents
C#
public WebDialogBoxClientSideEvents ClientSideEvents {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


CommandButtonAlignment Property

[image]
Intersoft WebDesktop Documentation
CommandButtonAlignment Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : CommandButtonAlignment Property

Glossary Item Box

Gets or sets the buttons alignment in the dialog box.

Syntax

Visual Basic (Declaration)
Public Property CommandButtonAlignment As ButtonAlignment
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As ButtonAlignment

instance.CommandButtonAlignment = value

value = instance.CommandButtonAlignment
C#
public ButtonAlignment CommandButtonAlignment {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


CommandButtons Property

[image]
Intersoft WebDesktop Documentation
CommandButtons Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : CommandButtons Property

Glossary Item Box

Contains the collection of command buttons used in dialog box.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CommandButtons As WebDialogBoxButtonCollection
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As WebDialogBoxButtonCollection

value = instance.CommandButtons
C#
public WebDialogBoxButtonCollection CommandButtons {get;}

Remarks

This feature allows developer to easily add what buttons should appear in the dialogbox instead of having developer to create their own button. The advantage of the built-in CommandButtons is its tight integration with WebDesktopManager as well as correct implementation of DialogResult similar to Windows Form applications. You can easily set each Button's Type which will be used as DialogResult when the dialog box is closed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members

Concepts

WebDialogBox Features


CommandButtonSize Property

[image]
Intersoft WebDesktop Documentation
CommandButtonSize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : CommandButtonSize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property CommandButtonSize As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As System.Drawing.Size

instance.CommandButtonSize = value

value = instance.CommandButtonSize
C#
public System.Drawing.Size CommandButtonSize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


CommandButtonSpacing Property

[image]
Intersoft WebDesktop Documentation
CommandButtonSpacing Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : CommandButtonSpacing Property

Glossary Item Box

Gets or sets the default spacing between each command button.

Syntax

Visual Basic (Declaration)
Public Property CommandButtonSpacing As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As Integer

instance.CommandButtonSpacing = value

value = instance.CommandButtonSpacing
C#
public int CommandButtonSpacing {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


ContentScrollable Property

[image]
Intersoft WebDesktop Documentation
ContentScrollable Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : ContentScrollable Property

Glossary Item Box

Specifies whether the content area (when using InlineContent) is scrollable.

Syntax

Visual Basic (Declaration)
Public Property ContentScrollable As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As Boolean

instance.ContentScrollable = value

value = instance.ContentScrollable
C#
public bool ContentScrollable {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members

Tasks

Designing custom DialogBox


ContentURL Property

[image]
Intersoft WebDesktop Documentation
ContentURL Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : ContentURL Property

Glossary Item Box

Gets or sets the Content URL for this window.

Syntax

Visual Basic (Declaration)
Public Property ContentURL As String
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As String

instance.ContentURL = value

value = instance.ContentURL
C#
public string ContentURL {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


ControlBoxImage Property

[image]
Intersoft WebDesktop Documentation
ControlBoxImage Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : ControlBoxImage Property

Glossary Item Box

Gets or sets the default controlbox image for this Window.

Syntax

Visual Basic (Declaration)
Public Property ControlBoxImage As String
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As String

instance.ControlBoxImage = value

value = instance.ControlBoxImage
C#
public string ControlBoxImage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


ControlDataTransferFormat Property

[image]
Intersoft WebDesktop Documentation
ControlDataTransferFormat Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : ControlDataTransferFormat Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ControlDataTransferFormat As ISNet.WebUI.DataTransferFormat
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As ISNet.WebUI.DataTransferFormat

instance.ControlDataTransferFormat = value

value = instance.ControlDataTransferFormat
C#
public virtual ISNet.WebUI.DataTransferFormat ControlDataTransferFormat {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


CustomDialogBoxImage Property

[image]
Intersoft WebDesktop Documentation
CustomDialogBoxImage Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : CustomDialogBoxImage Property

Glossary Item Box

Gets or sets the custom dialog box image.

Syntax

Visual Basic (Declaration)
Public Property CustomDialogBoxImage As String
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As String

instance.CustomDialogBoxImage = value

value = instance.CustomDialogBoxImage
C#
public string CustomDialogBoxImage {get; set;}

Remarks

Using this property you can set your own Image by setting the DialogBoxImage to Custom, and then specify the image source.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members

Concepts

WebDialogBox Features


DialogBoxImage Property

[image]
Intersoft WebDesktop Documentation
DialogBoxImage Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : DialogBoxImage Property

Glossary Item Box

Gets or sets the predefined image used by the dialog box.

Syntax

Visual Basic (Declaration)
Public Property DialogBoxImage As DialogBoxImageType
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As DialogBoxImageType

instance.DialogBoxImage = value

value = instance.DialogBoxImage
C#
public DialogBoxImageType DialogBoxImage {get; set;}

Remarks

This feature simulates the behavior of Windows Form's MessageBox where the Icon of the box can be specified. The predefined DialogBoxImage lets developers easily create any type of DialogBox with default Image assigned to it. The valid enumerations for DialogBoxImage are Information, Error, Warning, Question, None and Custom.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members

Concepts

WebDialogBox Features

Tasks

Creating Simple DialogBox


DialogBoxImageVAlign Property

[image]
Intersoft WebDesktop Documentation
DialogBoxImageVAlign Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : DialogBoxImageVAlign Property

Glossary Item Box

Gets or sets the dialog box image's vertical alignment.

Syntax

Visual Basic (Declaration)
Public Property DialogBoxImageVAlign As ISNet.WebUI.VerticalAlign
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As ISNet.WebUI.VerticalAlign

instance.DialogBoxImageVAlign = value

value = instance.DialogBoxImageVAlign
C#
public ISNet.WebUI.VerticalAlign DialogBoxImageVAlign {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


EnableAnimation Property

[image]
Intersoft WebDesktop Documentation
EnableAnimation Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : EnableAnimation Property

Glossary Item Box

Specifies whether animation is supported for this dialog box instance.

Syntax

Visual Basic (Declaration)
Public Property EnableAnimation As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As Boolean

instance.EnableAnimation = value

value = instance.EnableAnimation
C#
public bool EnableAnimation {get; set;}

Remarks

As in WebDesktopManager, the new WebDialogBox is also featuring Vista-style zoom animation when the WebDialogBox is showing and closing. This visually compelling animation allows end users to easily notice on the dialog box appearance, which dramatically enhances user experience.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members

Concepts

WebDialogBox Vista-style animation

Tasks

How-to: Enable Vista-style zoom animation in WebDialogBox


Enabled Property

[image]
Intersoft WebDesktop Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : Enabled Property

Glossary Item Box

Enabled state of the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property Enabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As Boolean

instance.Enabled = value

value = instance.Enabled
C#
public virtual bool Enabled {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


EnableDropShadow Property

[image]
Intersoft WebDesktop Documentation
EnableDropShadow Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : EnableDropShadow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property EnableDropShadow As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As Boolean

instance.EnableDropShadow = value

value = instance.EnableDropShadow
C#
public bool EnableDropShadow {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


EnableManagedTheming Property

[image]
Intersoft WebDesktop Documentation
EnableManagedTheming Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : EnableManagedTheming Property

Glossary Item Box

Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to False, this control will not apply the style defined in Theme Architecture.

Syntax

Visual Basic (Declaration)
Public Overridable Property EnableManagedTheming As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As Boolean

instance.EnableManagedTheming = value

value = instance.EnableManagedTheming
C#
public virtual bool EnableManagedTheming {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


EnableTheming Property

[image]
Intersoft WebDesktop Documentation
EnableTheming Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : EnableTheming Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property EnableTheming As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As Boolean

instance.EnableTheming = value

value = instance.EnableTheming
C#
public virtual bool EnableTheming {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


EnableViewState Property

[image]
Intersoft WebDesktop Documentation
EnableViewState Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : EnableViewState Property

Glossary Item Box

Whether the control automatically saves its state for use in round-trips.

Syntax

Visual Basic (Declaration)
Public Overridable Property EnableViewState As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As Boolean

instance.EnableViewState = value

value = instance.EnableViewState
C#
public virtual bool EnableViewState {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


EnableWebResources Property

[image]
Intersoft WebDesktop Documentation
EnableWebResources Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : EnableWebResources Property

Glossary Item Box

Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory).

Syntax

Visual Basic (Declaration)
Public Property EnableWebResources As ISNet.WebUI.WebResourceType
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As ISNet.WebUI.WebResourceType

instance.EnableWebResources = value

value = instance.EnableWebResources
C#
public ISNet.WebUI.WebResourceType EnableWebResources {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


Font Property

[image]
Intersoft WebDesktop Documentation
Font Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : Font Property

Glossary Item Box

The font used for text within the control.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Font As System.Web.UI.WebControls.FontInfo
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As System.Web.UI.WebControls.FontInfo

value = instance.Font
C#
public override System.Web.UI.WebControls.FontInfo Font {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


ForeColor Property

[image]
Intersoft WebDesktop Documentation
ForeColor Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : ForeColor Property

Glossary Item Box

Color of the text within the control.

Syntax

Visual Basic (Declaration)
Public Overrides Property ForeColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
C#
public override System.Drawing.Color ForeColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


Height Property

[image]
Intersoft WebDesktop Documentation
Height Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : Height Property

Glossary Item Box

The height of the control.

Syntax

Visual Basic (Declaration)
Public Overrides Property Height As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As System.Web.UI.WebControls.Unit

instance.Height = value

value = instance.Height
C#
public override System.Web.UI.WebControls.Unit Height {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


ID Property

[image]
Intersoft WebDesktop Documentation
ID Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : ID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ID As String
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As String

instance.ID = value

value = instance.ID
C#
public virtual string ID {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


ImagePosition Property

[image]
Intersoft WebDesktop Documentation
ImagePosition Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : ImagePosition Property

Glossary Item Box

Gets or sets the dialog box's image position relative to the content text.

Syntax

Visual Basic (Declaration)
Public Property ImagePosition As ImagePosition
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As ImagePosition

instance.ImagePosition = value

value = instance.ImagePosition
C#
public ImagePosition ImagePosition {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


ImagesDirectory Property

[image]
Intersoft WebDesktop Documentation
ImagesDirectory Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : ImagesDirectory Property

Glossary Item Box

Gets or sets the images directory for the dialog box control.

Syntax

Visual Basic (Declaration)
Public Property ImagesDirectory As String
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As String

instance.ImagesDirectory = value

value = instance.ImagesDirectory
C#
public string ImagesDirectory {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


InProgressText Property

[image]
Intersoft WebDesktop Documentation
InProgressText Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : InProgressText Property

Glossary Item Box

Gets or sets the text shown during IFrame loading.

Syntax

Visual Basic (Declaration)
Public Property InProgressText As String
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As String

instance.InProgressText = value

value = instance.InProgressText
C#
public string InProgressText {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


IntegratedToDesktopManager Property

[image]
Intersoft WebDesktop Documentation
IntegratedToDesktopManager Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : IntegratedToDesktopManager Property

Glossary Item Box

Specifies whether the dialog box should be integrated into Desktop Manager.

Syntax

Visual Basic (Declaration)
Public Property IntegratedToDesktopManager As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As Boolean

instance.IntegratedToDesktopManager = value

value = instance.IntegratedToDesktopManager
C#
public bool IntegratedToDesktopManager {get; set;}

Remarks

WebDialogBox can be used in either StandAlone mode or Integrated mode. When running in StandAlone mode, the dialog box will be displayed on the top of the document's body.

To configure the Integration mode, simply set the IntegratedToDesktopManager property to True. When you set this property to True, the DialogBox will be created on demand only when the ShowDialogBox method is called in client side. Furthermore, when integrated, the DialogBox will automatically apply the Styles and Appearance of the Window and Button and therefore the DialogBox will have consistent look&feel throughout entire application.

To learn more and see the illustrations please refer to Integrating to DesktopManager.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members

Concepts

Integrating into WebDesktopManager

concepts

WebDialogBox Features


IsModal Property

[image]
Intersoft WebDesktop Documentation
IsModal Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : IsModal Property

Glossary Item Box

Specifies whether the dialog box should be shown as modal.

Syntax

Visual Basic (Declaration)
Public Property IsModal As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As Boolean

instance.IsModal = value

value = instance.IsModal
C#
public bool IsModal {get; set;}

Remarks

The WebDialogBox has been further improved with enhancements such as Modeless mode. In this new release, you can set the WebDialogBox to use Modeless mode, instead of Modal mode which is set by default.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members

Concepts

Modeless mode

Tasks

How-to: Set WebDialogBox to Modeless mode


KeepVisibleOnScroll Property

[image]
Intersoft WebDesktop Documentation
KeepVisibleOnScroll Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : KeepVisibleOnScroll Property

Glossary Item Box

Specifies whether the dialog box should be kept visible when the Web Page is scrolled.

Syntax

Visual Basic (Declaration)
Public Property KeepVisibleOnScroll As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As Boolean

instance.KeepVisibleOnScroll = value

value = instance.KeepVisibleOnScroll
C#
public bool KeepVisibleOnScroll {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


Location Property

[image]
Intersoft WebDesktop Documentation
Location Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : Location Property

Glossary Item Box

Gets or sets the initial location that this Window should be displayed at.

Syntax

Visual Basic (Declaration)
Public Property Location As System.Drawing.Point
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As System.Drawing.Point

instance.Location = value

value = instance.Location
C#
public System.Drawing.Point Location {get; set;}

Remarks

When Integrated to Desktop Manager, WebDialogBox can be shown in one of three positions - Custom, CenterParent and CenterScreen. When you set to Custom, the DialogBox will appear to the exact location specified in Location property. When you set to CenterParent, the DialogBox will be automatically displayed at the center of parent's window. Finally when you set to CenterScreen, the DialogBox will be displayd at the center screen of the entire desktop manager size.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members

Concepts

WebDialogBox Features


Page Property

[image]
Intersoft WebDesktop Documentation
Page Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : Page Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Page As System.Web.UI.Page
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As System.Web.UI.Page

instance.Page = value

value = instance.Page
C#
public virtual System.Web.UI.Page Page {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


RenderingMode Property

[image]
Intersoft WebDesktop Documentation
RenderingMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : RenderingMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property RenderingMode As ISNet.WebUI.RenderMode
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As ISNet.WebUI.RenderMode

instance.RenderingMode = value

value = instance.RenderingMode
C#
public virtual ISNet.WebUI.RenderMode RenderingMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


RuntimeLicenseKey Property

[image]
Intersoft WebDesktop Documentation
RuntimeLicenseKey Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : RuntimeLicenseKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property RuntimeLicenseKey As String
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As String

instance.RuntimeLicenseKey = value

value = instance.RuntimeLicenseKey
C#
public virtual string RuntimeLicenseKey {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


ScriptDirectory Property

[image]
Intersoft WebDesktop Documentation
ScriptDirectory Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : ScriptDirectory Property

Glossary Item Box

Gets or sets the directory where all required scripts for the control are stored.

Syntax

Visual Basic (Declaration)
Public Overrides Property ScriptDirectory As String
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As String

instance.ScriptDirectory = value

value = instance.ScriptDirectory
C#
public override string ScriptDirectory {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


ShadowColor Property

[image]
Intersoft WebDesktop Documentation
ShadowColor Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : ShadowColor Property

Glossary Item Box

Specifies the color of the dialog box's shadow.

Syntax

Visual Basic (Declaration)
Public Property ShadowColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As System.Drawing.Color

instance.ShadowColor = value

value = instance.ShadowColor
C#
public System.Drawing.Color ShadowColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


ShadowOpacity Property

[image]
Intersoft WebDesktop Documentation
ShadowOpacity Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : ShadowOpacity Property

Glossary Item Box

Specifies the transparency opacity of the shadow, when ShadowColor is set to a solid color.

Syntax

Visual Basic (Declaration)
Public Property ShadowOpacity As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As Integer

instance.ShadowOpacity = value

value = instance.ShadowOpacity
C#
public int ShadowOpacity {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


SharedScriptDirectory Property

[image]
Intersoft WebDesktop Documentation
SharedScriptDirectory Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : SharedScriptDirectory Property

Glossary Item Box

Gets os sets the directory where al shared script for Intersoft controls are stored.

Syntax

Visual Basic (Declaration)
Public Overrides Property SharedScriptDirectory As String
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As String

instance.SharedScriptDirectory = value

value = instance.SharedScriptDirectory
C#
public override string SharedScriptDirectory {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


ShowOnLoad Property

[image]
Intersoft WebDesktop Documentation
ShowOnLoad Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : ShowOnLoad Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ShowOnLoad As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As Boolean

instance.ShowOnLoad = value

value = instance.ShowOnLoad
C#
public bool ShowOnLoad {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


SkinID Property

[image]
Intersoft WebDesktop Documentation
SkinID Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : SkinID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property SkinID As String
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As String

instance.SkinID = value

value = instance.SkinID
C#
public virtual string SkinID {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


StartPosition Property

[image]
Intersoft WebDesktop Documentation
StartPosition Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : StartPosition Property

Glossary Item Box

Gets or sets the start up position of the dialog box.

Syntax

Visual Basic (Declaration)
Public Property StartPosition As DialogBoxPosition
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As DialogBoxPosition

instance.StartPosition = value

value = instance.StartPosition
C#
public DialogBoxPosition StartPosition {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members

Tasks

Creating Simple DialogBox

Concepts

WebDialogBox Features


TabIndex Property

[image]
Intersoft WebDesktop Documentation
TabIndex Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : TabIndex Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property TabIndex As Short
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As Short

instance.TabIndex = value

value = instance.TabIndex
C#
public virtual short TabIndex {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


Text Property

[image]
Intersoft WebDesktop Documentation
Text Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : Text Property

Glossary Item Box

Gets or sets the caption text for this window.

Syntax

Visual Basic (Declaration)
Public Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As String

instance.Text = value

value = instance.Text
C#
public string Text {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


ToolTip Property

[image]
Intersoft WebDesktop Documentation
ToolTip Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : ToolTip Property

Glossary Item Box

The tooltip displayed when the mouse is over the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property ToolTip As String
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As String

instance.ToolTip = value

value = instance.ToolTip
C#
public virtual string ToolTip {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


ValidateRequestMode Property

[image]
Intersoft WebDesktop Documentation
ValidateRequestMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : ValidateRequestMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ValidateRequestMode As System.Web.UI.ValidateRequestMode
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As System.Web.UI.ValidateRequestMode

instance.ValidateRequestMode = value

value = instance.ValidateRequestMode
C#
public virtual System.Web.UI.ValidateRequestMode ValidateRequestMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


ViewStateItems Property

[image]
Intersoft WebDesktop Documentation
ViewStateItems Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : ViewStateItems Property

Glossary Item Box

Gets or sets the items to be stored in view state storage.

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateItems As ISNet.WebUI.ViewStateItem
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As ISNet.WebUI.ViewStateItem

instance.ViewStateItems = value

value = instance.ViewStateItems
C#
public virtual ISNet.WebUI.ViewStateItem ViewStateItems {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


ViewStateMode Property

[image]
Intersoft WebDesktop Documentation
ViewStateMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : ViewStateMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateMode As System.Web.UI.ViewStateMode
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As System.Web.UI.ViewStateMode

instance.ViewStateMode = value

value = instance.ViewStateMode
C#
public virtual System.Web.UI.ViewStateMode ViewStateMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


ViewStateServerConnection Property

[image]
Intersoft WebDesktop Documentation
ViewStateServerConnection Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : ViewStateServerConnection Property

Glossary Item Box

Gets or sets the server connection string for file server-based viewstate storage.

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateServerConnection As String
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As String

instance.ViewStateServerConnection = value

value = instance.ViewStateServerConnection
C#
public virtual string ViewStateServerConnection {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


ViewStateStorage Property

[image]
Intersoft WebDesktop Documentation
ViewStateStorage Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : ViewStateStorage Property

Glossary Item Box

Gets or sets the location to store the viewstate of this control.

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateStorage As ISNet.WebUI.StateCacheStorage
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As ISNet.WebUI.StateCacheStorage

instance.ViewStateStorage = value

value = instance.ViewStateStorage
C#
public virtual ISNet.WebUI.StateCacheStorage ViewStateStorage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


Visible Property

[image]
Intersoft WebDesktop Documentation
Visible Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : Visible Property

Glossary Item Box

Indicates whether the control is visible and rendered.

Syntax

Visual Basic (Declaration)
Public Overridable Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public virtual bool Visible {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


Width Property

[image]
Intersoft WebDesktop Documentation
Width Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : Width Property

Glossary Item Box

The width of the control.

Syntax

Visual Basic (Declaration)
Public Overrides Property Width As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As System.Web.UI.WebControls.Unit

instance.Width = value

value = instance.Width
C#
public override System.Web.UI.WebControls.Unit Width {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


WindowSettings Property

[image]
Intersoft WebDesktop Documentation
WindowSettings Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : WindowSettings Property

Glossary Item Box

Contains window settings for the dialog box.

Syntax

Visual Basic (Declaration)
Public Property WindowSettings As WebDialogBoxWindowSettings
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As WebDialogBoxWindowSettings

instance.WindowSettings = value

value = instance.WindowSettings
C#
public WebDialogBoxWindowSettings WindowSettings {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


XmlCompressionEnabled Property

[image]
Intersoft WebDesktop Documentation
XmlCompressionEnabled Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : XmlCompressionEnabled Property

Glossary Item Box

Specifies whether the Xml used for clientside state storage should be compressed.

Syntax

Visual Basic (Declaration)
Public Overridable Property XmlCompressionEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim value As Boolean

instance.XmlCompressionEnabled = value

value = instance.XmlCompressionEnabled
C#
public virtual bool XmlCompressionEnabled {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


DataBinding Event

[image]
Intersoft WebDesktop Documentation
DataBinding Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : DataBinding Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event DataBinding As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim handler As EventHandler

AddHandler instance.DataBinding, handler
C#
public event EventHandler DataBinding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


Disposed Event

[image]
Intersoft WebDesktop Documentation
Disposed Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim handler As EventHandler

AddHandler instance.Disposed, handler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


Init Event

[image]
Intersoft WebDesktop Documentation
Init Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : Init Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Init As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim handler As EventHandler

AddHandler instance.Init, handler
C#
public event EventHandler Init

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


Load Event

[image]
Intersoft WebDesktop Documentation
Load Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : Load Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Load As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim handler As EventHandler

AddHandler instance.Load, handler
C#
public event EventHandler Load

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


PreInitialize Event

[image]
Intersoft WebDesktop Documentation
PreInitialize Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : PreInitialize Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event PreInitialize As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim handler As EventHandler

AddHandler instance.PreInitialize, handler
C#
public event EventHandler PreInitialize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


PreRender Event

[image]
Intersoft WebDesktop Documentation
PreRender Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : PreRender Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event PreRender As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim handler As EventHandler

AddHandler instance.PreRender, handler
C#
public event EventHandler PreRender

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


Unload Event

[image]
Intersoft WebDesktop Documentation
Unload Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBox Class : Unload Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Unload As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBox
Dim handler As EventHandler

AddHandler instance.Unload, handler
C#
public event EventHandler Unload

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBox Class
WebDialogBox Members


WebDialogBoxButton Class

[image]
Intersoft WebDesktop Documentation
WebDialogBoxButton Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDialogBoxButton Class

Glossary Item Box

Collection of command buttons used in WebDialogBox.

Object Model

WebDialogBoxButton Class

Syntax

Visual Basic (Declaration)
Public Class WebDialogBoxButton
   Inherits ISNet.WebUI.NamedObjectBase
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxButton
C#
public class WebDialogBoxButton : ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject

Remarks

WebDialogBox provides built-in CommandButtons feature. Developer easily can add what buttons should appear in the dialogbox instead of having developer to create their own button. The advantage of the built-in CommandButtons is its tight integration with WebDesktopManager as well as correct implementation of DialogResult similar to Windows Form applications.

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase
ISNet.WebUI.WebDesktop.WebDialogBoxButton

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxButton Members
ISNet.WebUI.WebDesktop Namespace

Concepts

WebDialogBox Features


WebDialogBoxButton Class Members

[image]
Intersoft WebDesktop Documentation
WebDialogBoxButton Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDialogBoxButton Class

Glossary Item Box

The following tables list the members exposed by WebDialogBoxButton.

Public Constructors

 | Name | Description
Public Constructor | WebDialogBoxButton Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | AccessKey |
Public Property | DisplayMode |
Public Property | Image | Gets or sets the image displayed in the button.
Public Property | ImagePosition | Gets or sets the image position relative to the text.
Public Property | Name | Overridden. Gets or sets the name of WebDialogBoxButton.
Public Property | Parameter | Gets or sets the parameter or data that will be passed to client side event when the button is clicked.
Public Property | Text | Gets or sets the text displayed in the button.
Public Property | Type | Gets or sets the type of the button which will automatically perform built-in behavior accordingly.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebDialogBoxButton Class
ISNet.WebUI.WebDesktop Namespace

Concepts

WebDialogBox Features


WebDialogBoxButton Constructor

[image]
Intersoft WebDesktop Documentation
WebDialogBoxButton Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxButton Class : WebDialogBoxButton Constructor

Glossary Item Box

Initializes a new instance of the WebDialogBoxButton class.

Overload List

Overload | Description
WebDialogBoxButton Constructor() | Initializes a new instance of the WebDialogBoxButton class with no argument.
WebDialogBoxButton Constructor(String) | Initializes a new instance of the WebDialogBoxButton class with Text parameter.
WebDialogBoxButton Constructor(DialogBoxButtonType) | Initializes a new instance of the WebDialogBoxButton class with DialogBoxButtonType parameter.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxButton Class
WebDialogBoxButton Members


WebDialogBoxButton Constructor()

[image]
Intersoft WebDesktop Documentation
WebDialogBoxButton Constructor()
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxButton Class > WebDialogBoxButton Constructor : WebDialogBoxButton Constructor()

Glossary Item Box

Initializes a new instance of the WebDialogBoxButton class with no argument.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebDialogBoxButton()
C#
public WebDialogBoxButton()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxButton Class
WebDialogBoxButton Members
Overload List


WebDialogBoxButton Constructor(String)

[image]
Intersoft WebDesktop Documentation
WebDialogBoxButton Constructor(String)
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxButton Class > WebDialogBoxButton Constructor : WebDialogBoxButton Constructor(String)

text

Glossary Item Box

Initializes a new instance of the WebDialogBoxButton class with Text parameter.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim text As String

Dim instance As New WebDialogBoxButton(text)
C#
public WebDialogBoxButton(
   string text
)

Parameters

text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxButton Class
WebDialogBoxButton Members
Overload List


WebDialogBoxButton Constructor(DialogBoxButtonType)

[image]
Intersoft WebDesktop Documentation
WebDialogBoxButton Constructor(DialogBoxButtonType)
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxButton Class > WebDialogBoxButton Constructor : WebDialogBoxButton Constructor(DialogBoxButtonType)

type

Glossary Item Box

Initializes a new instance of the WebDialogBoxButton class with DialogBoxButtonType parameter.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal type As DialogBoxButtonType _
)
Visual Basic (Usage) Copy Code
Dim type As DialogBoxButtonType

Dim instance As New WebDialogBoxButton(type)
C#
public WebDialogBoxButton(
   DialogBoxButtonType type
)

Parameters

type

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxButton Class
WebDialogBoxButton Members
Overload List


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxButton Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxButton
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxButton Class
WebDialogBoxButton Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxButton Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxButton Class
WebDialogBoxButton Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxButton Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxButton
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxButton Class
WebDialogBoxButton Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxButton Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxButton
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxButton Class
WebDialogBoxButton Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxButton Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxButton
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxButton Class
WebDialogBoxButton Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxButton Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxButton
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxButton Class
WebDialogBoxButton Members


WebDialogBoxButton Class Methods

[image]
Intersoft WebDesktop Documentation
WebDialogBoxButton Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDialogBoxButton Class

Glossary Item Box

For a list of all members of this type, see WebDialogBoxButton members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebDialogBoxButton Class
ISNet.WebUI.WebDesktop Namespace

Concepts

WebDialogBox Features


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxButton Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxButton
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxButton Class
WebDialogBoxButton Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxButton Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxButton
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxButton Class
WebDialogBoxButton Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxButton Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxButton

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxButton Class
WebDialogBoxButton Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxButton Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxButton
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxButton Class
WebDialogBoxButton Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxButton Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxButton
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxButton Class
WebDialogBoxButton Members


WebDialogBoxButton Class Properties

[image]
Intersoft WebDesktop Documentation
WebDialogBoxButton Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDialogBoxButton Class

Glossary Item Box

For a list of all members of this type, see WebDialogBoxButton members.

Public Properties

 | Name | Description
Public Property | AccessKey |
Public Property | DisplayMode |
Public Property | Image | Gets or sets the image displayed in the button.
Public Property | ImagePosition | Gets or sets the image position relative to the text.
Public Property | Name | Overridden. Gets or sets the name of WebDialogBoxButton.
Public Property | Parameter | Gets or sets the parameter or data that will be passed to client side event when the button is clicked.
Public Property | Text | Gets or sets the text displayed in the button.
Public Property | Type | Gets or sets the type of the button which will automatically perform built-in behavior accordingly.
Top

See Also

Reference

WebDialogBoxButton Class
ISNet.WebUI.WebDesktop Namespace

Concepts

WebDialogBox Features


AccessKey Property

[image]
Intersoft WebDesktop Documentation
AccessKey Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxButton Class : AccessKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property AccessKey As String
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxButton
Dim value As String

instance.AccessKey = value

value = instance.AccessKey
C#
public string AccessKey {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxButton Class
WebDialogBoxButton Members


DisplayMode Property

[image]
Intersoft WebDesktop Documentation
DisplayMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxButton Class : DisplayMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property DisplayMode As ButtonDisplayMode
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxButton
Dim value As ButtonDisplayMode

instance.DisplayMode = value

value = instance.DisplayMode
C#
public ButtonDisplayMode DisplayMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxButton Class
WebDialogBoxButton Members


Image Property

[image]
Intersoft WebDesktop Documentation
Image Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxButton Class : Image Property

Glossary Item Box

Gets or sets the image displayed in the button.

Syntax

Visual Basic (Declaration)
Public Property Image As String
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxButton
Dim value As String

instance.Image = value

value = instance.Image
C#
public string Image {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxButton Class
WebDialogBoxButton Members


ImagePosition Property

[image]
Intersoft WebDesktop Documentation
ImagePosition Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxButton Class : ImagePosition Property

Glossary Item Box

Gets or sets the image position relative to the text.

Syntax

Visual Basic (Declaration)
Public Property ImagePosition As ImagePosition
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxButton
Dim value As ImagePosition

instance.ImagePosition = value

value = instance.ImagePosition
C#
public ImagePosition ImagePosition {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxButton Class
WebDialogBoxButton Members


Name Property

[image]
Intersoft WebDesktop Documentation
Name Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxButton Class : Name Property

Glossary Item Box

Gets or sets the name of WebDialogBoxButton.

Syntax

Visual Basic (Declaration)
Public Overrides Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxButton
Dim value As String

instance.Name = value

value = instance.Name
C#
public override string Name {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxButton Class
WebDialogBoxButton Members


Parameter Property

[image]
Intersoft WebDesktop Documentation
Parameter Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxButton Class : Parameter Property

Glossary Item Box

Gets or sets the parameter or data that will be passed to client side event when the button is clicked.

Syntax

Visual Basic (Declaration)
Public Property Parameter As String
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxButton
Dim value As String

instance.Parameter = value

value = instance.Parameter
C#
public string Parameter {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxButton Class
WebDialogBoxButton Members


Text Property

[image]
Intersoft WebDesktop Documentation
Text Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxButton Class : Text Property

Glossary Item Box

Gets or sets the text displayed in the button.

Syntax

Visual Basic (Declaration)
Public Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxButton
Dim value As String

instance.Text = value

value = instance.Text
C#
public string Text {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxButton Class
WebDialogBoxButton Members


Type Property

[image]
Intersoft WebDesktop Documentation
Type Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxButton Class : Type Property

Glossary Item Box

Gets or sets the type of the button which will automatically perform built-in behavior accordingly.

Syntax

Visual Basic (Declaration)
Public Property Type As DialogBoxButtonType
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxButton
Dim value As DialogBoxButtonType

instance.Type = value

value = instance.Type
C#
public DialogBoxButtonType Type {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxButton Class
WebDialogBoxButton Members


WebDialogBoxButtonCollection Class

[image]
Intersoft WebDesktop Documentation
WebDialogBoxButtonCollection Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDialogBoxButtonCollection Class

Glossary Item Box

Collection of WebDialogBoxButton.

Object Model

WebDialogBoxButtonCollection Class

Syntax

Visual Basic (Declaration)
Public Class WebDialogBoxButtonCollection
   Inherits ISNet.WebUI.ISCollectionBase
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxButtonCollection
C#
public class WebDialogBoxButtonCollection : ISNet.WebUI.ISCollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
ISNet.WebUI.ISCollectionBase
ISNet.WebUI.WebDesktop.WebDialogBoxButtonCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxButtonCollection Members
ISNet.WebUI.WebDesktop Namespace


WebDialogBoxButtonCollection Class Members

[image]
Intersoft WebDesktop Documentation
WebDialogBoxButtonCollection Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDialogBoxButtonCollection Class

Glossary Item Box

The following tables list the members exposed by WebDialogBoxButtonCollection.

Public Constructors

 | Name | Description
Public Constructor | WebDialogBoxButtonCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden. Returns a Boolean value indicating whether the collection is read-only.
Public Property | Item | Property indexer for the collection.
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebDialogBoxButtonCollection Class
ISNet.WebUI.WebDesktop Namespace


WebDialogBoxButtonCollection Constructor

[image]
Intersoft WebDesktop Documentation
WebDialogBoxButtonCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxButtonCollection Class : WebDialogBoxButtonCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebDialogBoxButtonCollection()
C#
public WebDialogBoxButtonCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxButtonCollection Class
WebDialogBoxButtonCollection Members


WebDialogBoxButtonCollection Class Methods

[image]
Intersoft WebDesktop Documentation
WebDialogBoxButtonCollection Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDialogBoxButtonCollection Class

Glossary Item Box

For a list of all members of this type, see WebDialogBoxButtonCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebDialogBoxButtonCollection Class
ISNet.WebUI.WebDesktop Namespace


Add Method

[image]
Intersoft WebDesktop Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxButtonCollection Class : Add Method

Glossary Item Box

Overload List

Overload | Description
Add(WebDialogBoxButton) |
Add(String) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxButtonCollection Class
WebDialogBoxButtonCollection Members


Add(WebDialogBoxButton) Method

[image]
Intersoft WebDesktop Documentation
Add(WebDialogBoxButton) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxButtonCollection Class > Add Method : Add(WebDialogBoxButton) Method

webDialogBoxButton

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function Add( _
   ByVal webDialogBoxButton As WebDialogBoxButton _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxButtonCollection
Dim webDialogBoxButton As WebDialogBoxButton
Dim value As Integer

value = instance.Add(webDialogBoxButton)
C#
public virtual int Add(
   WebDialogBoxButton webDialogBoxButton
)

Parameters

webDialogBoxButton

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxButtonCollection Class
WebDialogBoxButtonCollection Members
Overload List


Add(String) Method

[image]
Intersoft WebDesktop Documentation
Add(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxButtonCollection Class > Add Method : Add(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal name As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxButtonCollection
Dim name As String
Dim value As Integer

value = instance.Add(name)
C#
public int Add(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxButtonCollection Class
WebDialogBoxButtonCollection Members
Overload List


Clear Method

[image]
Intersoft WebDesktop Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxButtonCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxButtonCollection

instance.Clear()
C#
public new void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxButtonCollection Class
WebDialogBoxButtonCollection Members


Contains Method

[image]
Intersoft WebDesktop Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxButtonCollection Class : Contains Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As ISNet.WebUI.INamedObject _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxButtonCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As Boolean

value = instance.Contains(value)
C#
public bool Contains(
   ISNet.WebUI.INamedObject value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxButtonCollection Class
WebDialogBoxButtonCollection Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxButtonCollection Class : CopyFrom Method

passIn

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CopyFrom( _
   ByVal passIn As WebDialogBoxButtonCollection _
) As WebDialogBoxButtonCollection
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxButtonCollection
Dim passIn As WebDialogBoxButtonCollection
Dim value As WebDialogBoxButtonCollection

value = instance.CopyFrom(passIn)
C#
public WebDialogBoxButtonCollection CopyFrom(
   WebDialogBoxButtonCollection passIn
)

Parameters

passIn

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxButtonCollection Class
WebDialogBoxButtonCollection Members


CopyTo Method

[image]
Intersoft WebDesktop Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxButtonCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxButtonCollection
Dim array() As ISNet.WebUI.INamedObject
Dim index As Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   ISNet.WebUI.INamedObject[] array,
   int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxButtonCollection Class
WebDialogBoxButtonCollection Members


Exists Method

[image]
Intersoft WebDesktop Documentation
Exists Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxButtonCollection Class : Exists Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Exists( _
   ByVal name As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxButtonCollection
Dim name As String
Dim value As Boolean

value = instance.Exists(name)
C#
public bool Exists(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxButtonCollection Class
WebDialogBoxButtonCollection Members


GetEnumerator Method

[image]
Intersoft WebDesktop Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxButtonCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Function GetEnumerator() As System.Collections.IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxButtonCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
public new System.Collections.IEnumerator GetEnumerator()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxButtonCollection Class
WebDialogBoxButtonCollection Members


GetItem Method

[image]
Intersoft WebDesktop Documentation
GetItem Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxButtonCollection Class : GetItem Method

Glossary Item Box

Overload List

Overload | Description
GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxButtonCollection Class
WebDialogBoxButtonCollection Members


GetItem(Int32) Method

[image]
Intersoft WebDesktop Documentation
GetItem(Int32) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxButtonCollection Class : GetItem(Int32) Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetItem( _
   ByVal index As Integer _
) As ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxButtonCollection
Dim index As Integer
Dim value As ISNet.WebUI.INamedObject

value = instance.GetItem(index)
C#
public virtual ISNet.WebUI.INamedObject GetItem(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxButtonCollection Class
WebDialogBoxButtonCollection Members


GetNamedItem Method

[image]
Intersoft WebDesktop Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxButtonCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNamedItem( _
   ByVal name As String _
) As WebDialogBoxButton
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxButtonCollection
Dim name As String
Dim value As WebDialogBoxButton

value = instance.GetNamedItem(name)
C#
public WebDialogBoxButton GetNamedItem(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxButtonCollection Class
WebDialogBoxButtonCollection Members


IndexOf Method

[image]
Intersoft WebDesktop Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxButtonCollection Class : IndexOf Method

Glossary Item Box

Overload List

Overload | Description
IndexOf(String) | (Inherited from ISNet.WebUI.ISCollectionBase)
IndexOf(INamedObject) | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxButtonCollection Class
WebDialogBoxButtonCollection Members


IndexOf(String) Method

[image]
Intersoft WebDesktop Documentation
IndexOf(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxButtonCollection Class > IndexOf Method : IndexOf(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function IndexOf( _
   ByVal name As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxButtonCollection
Dim name As String
Dim value As Integer

value = instance.IndexOf(name)
C#
public virtual int IndexOf(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxButtonCollection Class
WebDialogBoxButtonCollection Members
Overload List


IndexOf(INamedObject) Method

[image]
Intersoft WebDesktop Documentation
IndexOf(INamedObject) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxButtonCollection Class > IndexOf Method : IndexOf(INamedObject) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal value As ISNet.WebUI.INamedObject _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxButtonCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As Integer

value = instance.IndexOf(value)
C#
public int IndexOf(
   ISNet.WebUI.INamedObject value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxButtonCollection Class
WebDialogBoxButtonCollection Members
Overload List


Insert Method

[image]
Intersoft WebDesktop Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxButtonCollection Class : Insert Method

index
webDialogBoxButton

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal webDialogBoxButton As WebDialogBoxButton _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxButtonCollection
Dim index As Integer
Dim webDialogBoxButton As WebDialogBoxButton

instance.Insert(index, webDialogBoxButton)
C#
public void Insert(
   int index,
   WebDialogBoxButton webDialogBoxButton
)

Parameters

index
webDialogBoxButton

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxButtonCollection Class
WebDialogBoxButtonCollection Members


IntInsert Method

[image]
Intersoft WebDesktop Documentation
IntInsert Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxButtonCollection Class : IntInsert Method

index
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub IntInsert( _
   ByVal index As Integer, _
   ByVal value As ISNet.WebUI.INamedObject _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxButtonCollection
Dim index As Integer
Dim value As ISNet.WebUI.INamedObject

instance.IntInsert(index, value)
C#
public void IntInsert(
   int index,
   ISNet.WebUI.INamedObject value
)

Parameters

index
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxButtonCollection Class
WebDialogBoxButtonCollection Members


Remove Method

[image]
Intersoft WebDesktop Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxButtonCollection Class : Remove Method

webDialogBoxButton

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal webDialogBoxButton As WebDialogBoxButton _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxButtonCollection
Dim webDialogBoxButton As WebDialogBoxButton

instance.Remove(webDialogBoxButton)
C#
public void Remove(
   WebDialogBoxButton webDialogBoxButton
)

Parameters

webDialogBoxButton

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxButtonCollection Class
WebDialogBoxButtonCollection Members


setParent Method

[image]
Intersoft WebDesktop Documentation
setParent Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxButtonCollection Class : setParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub setParent( _
   ByVal parent As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxButtonCollection
Dim parent As Object

instance.setParent(parent)
C#
public virtual void setParent(
   object parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxButtonCollection Class
WebDialogBoxButtonCollection Members


Capacity Property

[image]
Intersoft WebDesktop Documentation
Capacity Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxButtonCollection Class : Capacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxButtonCollection
Dim value As Integer

instance.Capacity = value

value = instance.Capacity
C#
public int Capacity {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxButtonCollection Class
WebDialogBoxButtonCollection Members


Count Property

[image]
Intersoft WebDesktop Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxButtonCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxButtonCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxButtonCollection Class
WebDialogBoxButtonCollection Members


WebDialogBoxButtonCollection Class Properties

[image]
Intersoft WebDesktop Documentation
WebDialogBoxButtonCollection Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDialogBoxButtonCollection Class

Glossary Item Box

For a list of all members of this type, see WebDialogBoxButtonCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden. Returns a Boolean value indicating whether the collection is read-only.
Public Property | Item | Property indexer for the collection.
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebDialogBoxButtonCollection Class
ISNet.WebUI.WebDesktop Namespace


WebDialogBoxButtonCollection Constructor

[image]
Intersoft WebDesktop Documentation
WebDialogBoxButtonCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxButtonCollection Class : WebDialogBoxButtonCollection Constructor

Glossary Item Box

Initializes a new instance of the WebDialogBoxButton class.

Overload List

Overload | Description
WebDialogBoxButtonCollection Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxButtonCollection Class
WebDialogBoxButtonCollection Members


IsReadOnly Property

[image]
Intersoft WebDesktop Documentation
IsReadOnly Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxButtonCollection Class : IsReadOnly Property

Glossary Item Box

Returns a Boolean value indicating whether the collection is read-only.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxButtonCollection
Dim value As Boolean

value = instance.IsReadOnly
C#
public override bool IsReadOnly {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxButtonCollection Class
WebDialogBoxButtonCollection Members


Item Property

[image]
Intersoft WebDesktop Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxButtonCollection Class : Item Property

index

Glossary Item Box

Property indexer for the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As WebDialogBoxButton
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxButtonCollection
Dim index As Integer
Dim value As WebDialogBoxButton

value = instance.Item(index)
C#
public WebDialogBoxButton this[
   int index
]; {get;}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxButtonCollection Class
WebDialogBoxButtonCollection Members


Parent Property

[image]
Intersoft WebDesktop Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxButtonCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As Object
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxButtonCollection
Dim value As Object

value = instance.Parent
C#
public object Parent {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxButtonCollection Class
WebDialogBoxButtonCollection Members


WebDialogBoxClientSideEvents Class

[image]
Intersoft WebDesktop Documentation
WebDialogBoxClientSideEvents Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDialogBoxClientSideEvents Class

Glossary Item Box

Javascript functions which invoked from client side in WebDialogBox.

Object Model

WebDialogBoxClientSideEvents Class

Syntax

Visual Basic (Declaration)
Public Class WebDialogBoxClientSideEvents
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxClientSideEvents
C#
public class WebDialogBoxClientSideEvents : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Remarks

WebDialogBox exposed 4 client side events which are OnCreated, OnClosed, OnButtonClicked and OnBeforeCreated.

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebDesktop.WebDialogBoxClientSideEvents

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxClientSideEvents Members
ISNet.WebUI.WebDesktop Namespace

Tasks

Showing DialogBox at client side

Concepts

WebDialogBox Features


WebDialogBoxClientSideEvents Class Members

[image]
Intersoft WebDesktop Documentation
WebDialogBoxClientSideEvents Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDialogBoxClientSideEvents Class

Glossary Item Box

The following tables list the members exposed by WebDialogBoxClientSideEvents.

Public Constructors

 | Name | Description
Public Constructor | WebDialogBoxClientSideEvents Constructor |
Top

Public Properties

 | Name | Description
Public Property | OnBeforeCreated | Specifies the javascript function to invoke before the dialog box is created.
Public Property | OnButtonClicked | Specifies the javascript function to invoke when one of the command button is clicked.
Public Property | OnClosed | Specifies the javascript function to invoke when the dialog box is closed.
Public Property | OnCreated | Specifies the javascript function to invoke when the dialog box is created.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebDialogBoxClientSideEvents Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Showing DialogBox at client side

Concepts

WebDialogBox Features


WebDialogBoxClientSideEvents Constructor

[image]
Intersoft WebDesktop Documentation
WebDialogBoxClientSideEvents Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxClientSideEvents Class : WebDialogBoxClientSideEvents Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebDialogBoxClientSideEvents()
C#
public WebDialogBoxClientSideEvents()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxClientSideEvents Class
WebDialogBoxClientSideEvents Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxClientSideEvents Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxClientSideEvents
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxClientSideEvents Class
WebDialogBoxClientSideEvents Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxClientSideEvents Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxClientSideEvents Class
WebDialogBoxClientSideEvents Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxClientSideEvents Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxClientSideEvents
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxClientSideEvents Class
WebDialogBoxClientSideEvents Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxClientSideEvents Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxClientSideEvents
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxClientSideEvents Class
WebDialogBoxClientSideEvents Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxClientSideEvents Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxClientSideEvents
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxClientSideEvents Class
WebDialogBoxClientSideEvents Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxClientSideEvents Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxClientSideEvents
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxClientSideEvents Class
WebDialogBoxClientSideEvents Members


WebDialogBoxClientSideEvents Class Methods

[image]
Intersoft WebDesktop Documentation
WebDialogBoxClientSideEvents Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDialogBoxClientSideEvents Class

Glossary Item Box

For a list of all members of this type, see WebDialogBoxClientSideEvents members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebDialogBoxClientSideEvents Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Showing DialogBox at client side

Concepts

WebDialogBox Features


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxClientSideEvents Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxClientSideEvents
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxClientSideEvents Class
WebDialogBoxClientSideEvents Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxClientSideEvents Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxClientSideEvents
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxClientSideEvents Class
WebDialogBoxClientSideEvents Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxClientSideEvents Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxClientSideEvents

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxClientSideEvents Class
WebDialogBoxClientSideEvents Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxClientSideEvents Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxClientSideEvents
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxClientSideEvents Class
WebDialogBoxClientSideEvents Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxClientSideEvents Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxClientSideEvents
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxClientSideEvents Class
WebDialogBoxClientSideEvents Members


WebDialogBoxClientSideEvents Class Properties

[image]
Intersoft WebDesktop Documentation
WebDialogBoxClientSideEvents Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDialogBoxClientSideEvents Class

Glossary Item Box

For a list of all members of this type, see WebDialogBoxClientSideEvents members.

Public Properties

 | Name | Description
Public Property | OnBeforeCreated | Specifies the javascript function to invoke before the dialog box is created.
Public Property | OnButtonClicked | Specifies the javascript function to invoke when one of the command button is clicked.
Public Property | OnClosed | Specifies the javascript function to invoke when the dialog box is closed.
Public Property | OnCreated | Specifies the javascript function to invoke when the dialog box is created.
Top

See Also

Reference

WebDialogBoxClientSideEvents Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Showing DialogBox at client side

Concepts

WebDialogBox Features


WebDialogBoxClientSideEvents Constructor

[image]
Intersoft WebDesktop Documentation
WebDialogBoxClientSideEvents Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxClientSideEvents Class : WebDialogBoxClientSideEvents Constructor

Glossary Item Box

Initializes a new instance of the WebDialogBoxClientSideEvents class.

Overload List

Overload | Description
WebDialogBoxClientSideEvents Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxClientSideEvents Class
WebDialogBoxClientSideEvents Members


OnBeforeCreated Property

[image]
Intersoft WebDesktop Documentation
OnBeforeCreated Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxClientSideEvents Class : OnBeforeCreated Property

Glossary Item Box

Specifies the javascript function to invoke before the dialog box is created.

Syntax

Visual Basic (Declaration)
Public Property OnBeforeCreated As String
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxClientSideEvents
Dim value As String

instance.OnBeforeCreated = value

value = instance.OnBeforeCreated
C#
public string OnBeforeCreated {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxClientSideEvents Class
WebDialogBoxClientSideEvents Members


OnButtonClicked Property

[image]
Intersoft WebDesktop Documentation
OnButtonClicked Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxClientSideEvents Class : OnButtonClicked Property

Glossary Item Box

Specifies the javascript function to invoke when one of the command button is clicked.

Syntax

Visual Basic (Declaration)
Public Property OnButtonClicked As String
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxClientSideEvents
Dim value As String

instance.OnButtonClicked = value

value = instance.OnButtonClicked
C#
public string OnButtonClicked {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxClientSideEvents Class
WebDialogBoxClientSideEvents Members


OnClosed Property

[image]
Intersoft WebDesktop Documentation
OnClosed Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxClientSideEvents Class : OnClosed Property

Glossary Item Box

Specifies the javascript function to invoke when the dialog box is closed.

Syntax

Visual Basic (Declaration)
Public Property OnClosed As String
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxClientSideEvents
Dim value As String

instance.OnClosed = value

value = instance.OnClosed
C#
public string OnClosed {get; set;}

Remarks

Developers can easily hook the OnClosed event to a function in javascript which will be fired when the dialog box has been closed as the result of button click. The OnClosed event will be mainly used to perform applications logic based on the pressed button which represented into the DialogResult parameter.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxClientSideEvents Class
WebDialogBoxClientSideEvents Members

Concepts

WebDialogBox Features


OnCreated Property

[image]
Intersoft WebDesktop Documentation
OnCreated Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxClientSideEvents Class : OnCreated Property

Glossary Item Box

Specifies the javascript function to invoke when the dialog box is created.

Syntax

Visual Basic (Declaration)
Public Property OnCreated As String
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxClientSideEvents
Dim value As String

instance.OnCreated = value

value = instance.OnCreated
C#
public string OnCreated {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxClientSideEvents Class
WebDialogBoxClientSideEvents Members


WebDialogBoxImagesSettings Class

[image]
Intersoft WebDesktop Documentation
WebDialogBoxImagesSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDialogBoxImagesSettings Class

Glossary Item Box

Collection of image settings for WebDialogBox object.

Object Model

WebDialogBoxImagesSettings Class

Syntax

Visual Basic (Declaration)
Public Class WebDialogBoxImagesSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxImagesSettings
C#
public class WebDialogBoxImagesSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebDesktop.WebDialogBoxImagesSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxImagesSettings Members
ISNet.WebUI.WebDesktop Namespace


WebDialogBoxImagesSettings Class Members

[image]
Intersoft WebDesktop Documentation
WebDialogBoxImagesSettings Class Members
See Also Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDialogBoxImagesSettings Class

Glossary Item Box

The following tables list the members exposed by WebDialogBoxImagesSettings.

Public Constructors

 | Name | Description
Public Constructor | WebDialogBoxImagesSettings Constructor |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebDialogBoxImagesSettings Class
ISNet.WebUI.WebDesktop Namespace


WebDialogBoxImagesSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebDialogBoxImagesSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxImagesSettings Class : WebDialogBoxImagesSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebDialogBoxImagesSettings()
C#
public WebDialogBoxImagesSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxImagesSettings Class
WebDialogBoxImagesSettings Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxImagesSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxImagesSettings
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxImagesSettings Class
WebDialogBoxImagesSettings Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxImagesSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxImagesSettings Class
WebDialogBoxImagesSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxImagesSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxImagesSettings
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxImagesSettings Class
WebDialogBoxImagesSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxImagesSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxImagesSettings
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxImagesSettings Class
WebDialogBoxImagesSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxImagesSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxImagesSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxImagesSettings Class
WebDialogBoxImagesSettings Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxImagesSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxImagesSettings
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxImagesSettings Class
WebDialogBoxImagesSettings Members


WebDialogBoxImagesSettings Class Methods

[image]
Intersoft WebDesktop Documentation
WebDialogBoxImagesSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDialogBoxImagesSettings Class

Glossary Item Box

For a list of all members of this type, see WebDialogBoxImagesSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebDialogBoxImagesSettings Class
ISNet.WebUI.WebDesktop Namespace


WebDialogBoxImagesSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebDialogBoxImagesSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxImagesSettings Class : WebDialogBoxImagesSettings Constructor

Glossary Item Box

Initializes a new instance of the WebDialogBoxImagesSettings class.

Overload List

Overload | Description
WebDialogBoxImagesSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxImagesSettings Class
WebDialogBoxImagesSettings Members


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxImagesSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxImagesSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxImagesSettings Class
WebDialogBoxImagesSettings Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxImagesSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxImagesSettings
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxImagesSettings Class
WebDialogBoxImagesSettings Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxImagesSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxImagesSettings

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxImagesSettings Class
WebDialogBoxImagesSettings Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxImagesSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxImagesSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxImagesSettings Class
WebDialogBoxImagesSettings Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxImagesSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxImagesSettings
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxImagesSettings Class
WebDialogBoxImagesSettings Members


WebDialogBoxTextSettings Class

[image]
Intersoft WebDesktop Documentation
WebDialogBoxTextSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDialogBoxTextSettings Class

Glossary Item Box

Collection of text settings for WebDialogBox object.

Object Model

WebDialogBoxTextSettings Class

Syntax

Visual Basic (Declaration)
Public Class WebDialogBoxTextSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxTextSettings
C#
public class WebDialogBoxTextSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebDesktop.WebDialogBoxTextSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxTextSettings Members
ISNet.WebUI.WebDesktop Namespace


WebDialogBoxTextSettings Class Members

[image]
Intersoft WebDesktop Documentation
WebDialogBoxTextSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDialogBoxTextSettings Class

Glossary Item Box

The following tables list the members exposed by WebDialogBoxTextSettings.

Public Constructors

 | Name | Description
Public Constructor | WebDialogBoxTextSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | InProgressText |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebDialogBoxTextSettings Class
ISNet.WebUI.WebDesktop Namespace


WebDialogBoxTextSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebDialogBoxTextSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxTextSettings Class : WebDialogBoxTextSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebDialogBoxTextSettings()
C#
public WebDialogBoxTextSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxTextSettings Class
WebDialogBoxTextSettings Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxTextSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxTextSettings
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxTextSettings Class
WebDialogBoxTextSettings Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxTextSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxTextSettings Class
WebDialogBoxTextSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxTextSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxTextSettings
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxTextSettings Class
WebDialogBoxTextSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxTextSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxTextSettings
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxTextSettings Class
WebDialogBoxTextSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxTextSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxTextSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxTextSettings Class
WebDialogBoxTextSettings Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxTextSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxTextSettings
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxTextSettings Class
WebDialogBoxTextSettings Members


WebDialogBoxTextSettings Class Methods

[image]
Intersoft WebDesktop Documentation
WebDialogBoxTextSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDialogBoxTextSettings Class

Glossary Item Box

For a list of all members of this type, see WebDialogBoxTextSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebDialogBoxTextSettings Class
ISNet.WebUI.WebDesktop Namespace


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxTextSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxTextSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxTextSettings Class
WebDialogBoxTextSettings Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxTextSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxTextSettings
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxTextSettings Class
WebDialogBoxTextSettings Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxTextSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxTextSettings

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxTextSettings Class
WebDialogBoxTextSettings Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxTextSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxTextSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxTextSettings Class
WebDialogBoxTextSettings Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxTextSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxTextSettings
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxTextSettings Class
WebDialogBoxTextSettings Members


WebDialogBoxTextSettings Class Properties

[image]
Intersoft WebDesktop Documentation
WebDialogBoxTextSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDialogBoxTextSettings Class

Glossary Item Box

For a list of all members of this type, see WebDialogBoxTextSettings members.

Public Properties

 | Name | Description
Public Property | InProgressText |
Top

See Also

Reference

WebDialogBoxTextSettings Class
ISNet.WebUI.WebDesktop Namespace


WebDialogBoxTextSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebDialogBoxTextSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxTextSettings Class : WebDialogBoxTextSettings Constructor

Glossary Item Box

Initializes a new instance of the WebDialogBoxTextSettings class.

Overload List

Overload | Description
WebDialogBoxTextSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxTextSettings Class
WebDialogBoxTextSettings Members


InProgressText Property

[image]
Intersoft WebDesktop Documentation
InProgressText Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxTextSettings Class : InProgressText Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property InProgressText As String
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxTextSettings
Dim value As String

instance.InProgressText = value

value = instance.InProgressText
C#
public string InProgressText {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxTextSettings Class
WebDialogBoxTextSettings Members


WebDialogBoxWindowSettings Class

[image]
Intersoft WebDesktop Documentation
WebDialogBoxWindowSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDialogBoxWindowSettings Class

Glossary Item Box

Collection of window settings for WebDialogBox object.

Object Model

WebDialogBoxWindowSettings Class

Syntax

Visual Basic (Declaration)
Public Class WebDialogBoxWindowSettings
   Inherits WebDesktopWindowSettings
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxWindowSettings
C#
public class WebDialogBoxWindowSettings : WebDesktopWindowSettings, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebDesktop.WebDesktopWindowSettings
ISNet.WebUI.WebDesktop.WebDialogBoxWindowSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxWindowSettings Members
ISNet.WebUI.WebDesktop Namespace


WebDialogBoxWindowSettings Class Members

[image]
Intersoft WebDesktop Documentation
WebDialogBoxWindowSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDialogBoxWindowSettings Class

Glossary Item Box

The following tables list the members exposed by WebDialogBoxWindowSettings.

Public Constructors

 | Name | Description
Public Constructor | WebDialogBoxWindowSettings Constructor | Initializes a new instance of the WebDialogBoxWindowSettings class.
Top

Public Properties

 | Name | Description
Public Property | AllowClose | (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Property | AllowMaximize | Overridden. Indicates whether the Window can be maximized.
Public Property | AllowMinimize | Overridden. Indicates whether the Window can be miniimized.
Public Property | AllowResize | Overridden. Indicates whether the Window can be resized.
Public Property | ApplyContainerStyle | (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Property | BorderType | Overridden. Gets or sets the type of border applied to Window.
Public Property | CaptionButtonSpacing | (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Property | CaptionButtonStyle | (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Property | CaptionDisplayMode | Overridden. Gets or sets the display mode for the Caption.
Public Property | CaptionStyle | (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Property | CommandBarPadding | (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Property | CommandButtonBorderType | Overridden. Gets or sets the border type of the command button.
Public Property | CommandButtonDisabledStyle | Gets or sets the disabled style of command button. (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Property | CommandButtonStyle | Gets or sets the style applied to command button. (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Property | ContainerStyle | Gets or sets the style applied to the content part of the Window. (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Property | ContentMode | Gets or sets the default content mode for Window. (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Property | ControlBox | Overridden. Indicates wheter the control box for the Window is visible.
Public Property | ControlBoxPosition | (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Property | DimWindowWhenBusy | (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Property | DropShadow | (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Property | EnableFastWindowActivation | (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Property | IFrameAllowTransparency | Specifies whether the IFRAME should allow transparency. This property is applicable when ContentMode is set to UseIFrame. (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Property | IFrameReadyTransitionEffect | Gets or sets the visual transition effect that will be applied when the IFrame content has been successfully loaded. (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Property | IFrameShowLoader | Specifies whether to show loader text when the active IFrame is in loading progress. This property only applicables when ContentMode is set to UseIFrame. (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Property | IgnoreIFramePadding | (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Property | MaximumSize | (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Property | MinimumSize | (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Property | ScrollBarStyle | (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Property | Size | (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Property | TextAlignment | (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Property | WindowHeaderHeight | (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Property | WindowOptionsPosition | (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Property | WindowStyle | Gets or sets the style applied to Window. (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebDialogBoxWindowSettings Class
ISNet.WebUI.WebDesktop Namespace


WebDialogBoxWindowSettings Class Methods

[image]
Intersoft WebDesktop Documentation
WebDialogBoxWindowSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDialogBoxWindowSettings Class

Glossary Item Box

For a list of all members of this type, see WebDialogBoxWindowSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebDialogBoxWindowSettings Class
ISNet.WebUI.WebDesktop Namespace


WebDialogBoxWindowSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebDialogBoxWindowSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxWindowSettings Class : WebDialogBoxWindowSettings Constructor

Glossary Item Box

Initializes a new instance of the WebDialogBoxWindowSettings class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebDialogBoxWindowSettings()
C#
public WebDialogBoxWindowSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxWindowSettings Class
WebDialogBoxWindowSettings Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxWindowSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxWindowSettings
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxWindowSettings Class
WebDialogBoxWindowSettings Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxWindowSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxWindowSettings Class
WebDialogBoxWindowSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxWindowSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxWindowSettings
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxWindowSettings Class
WebDialogBoxWindowSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxWindowSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxWindowSettings
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxWindowSettings Class
WebDialogBoxWindowSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxWindowSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxWindowSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxWindowSettings Class
WebDialogBoxWindowSettings Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxWindowSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxWindowSettings
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxWindowSettings Class
WebDialogBoxWindowSettings Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxWindowSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxWindowSettings
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxWindowSettings Class
WebDialogBoxWindowSettings Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxWindowSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxWindowSettings

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxWindowSettings Class
WebDialogBoxWindowSettings Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxWindowSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxWindowSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxWindowSettings Class
WebDialogBoxWindowSettings Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxWindowSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxWindowSettings
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxWindowSettings Class
WebDialogBoxWindowSettings Members


WebDialogBoxWindowSettings Class Properties

[image]
Intersoft WebDesktop Documentation
WebDialogBoxWindowSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDialogBoxWindowSettings Class

Glossary Item Box

For a list of all members of this type, see WebDialogBoxWindowSettings members.

Public Properties

 | Name | Description
Public Property | AllowClose | (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Property | AllowMaximize | Overridden. Indicates whether the Window can be maximized.
Public Property | AllowMinimize | Overridden. Indicates whether the Window can be miniimized.
Public Property | AllowResize | Overridden. Indicates whether the Window can be resized.
Public Property | ApplyContainerStyle | (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Property | BorderType | Overridden. Gets or sets the type of border applied to Window.
Public Property | CaptionButtonSpacing | (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Property | CaptionButtonStyle | (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Property | CaptionDisplayMode | Overridden. Gets or sets the display mode for the Caption.
Public Property | CaptionStyle | (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Property | CommandBarPadding | (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Property | CommandButtonBorderType | Overridden. Gets or sets the border type of the command button.
Public Property | CommandButtonDisabledStyle | Gets or sets the disabled style of command button. (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Property | CommandButtonStyle | Gets or sets the style applied to command button. (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Property | ContainerStyle | Gets or sets the style applied to the content part of the Window. (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Property | ContentMode | Gets or sets the default content mode for Window. (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Property | ControlBox | Overridden. Indicates wheter the control box for the Window is visible.
Public Property | ControlBoxPosition | (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Property | DimWindowWhenBusy | (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Property | DropShadow | (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Property | EnableFastWindowActivation | (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Property | IFrameAllowTransparency | Specifies whether the IFRAME should allow transparency. This property is applicable when ContentMode is set to UseIFrame. (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Property | IFrameReadyTransitionEffect | Gets or sets the visual transition effect that will be applied when the IFrame content has been successfully loaded. (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Property | IFrameShowLoader | Specifies whether to show loader text when the active IFrame is in loading progress. This property only applicables when ContentMode is set to UseIFrame. (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Property | IgnoreIFramePadding | (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Property | MaximumSize | (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Property | MinimumSize | (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Property | ScrollBarStyle | (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Property | Size | (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Property | TextAlignment | (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Property | WindowHeaderHeight | (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Property | WindowOptionsPosition | (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Public Property | WindowStyle | Gets or sets the style applied to Window. (Inherited from ISNet.WebUI.WebDesktop.WebDesktopWindowSettings)
Top

See Also

Reference

WebDialogBoxWindowSettings Class
ISNet.WebUI.WebDesktop Namespace


AllowMaximize Property

[image]
Intersoft WebDesktop Documentation
AllowMaximize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxWindowSettings Class : AllowMaximize Property

Glossary Item Box

Indicates whether the Window can be maximized.

Syntax

Visual Basic (Declaration)
Public Overrides Property AllowMaximize As AllowMaximize
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxWindowSettings
Dim value As AllowMaximize

instance.AllowMaximize = value

value = instance.AllowMaximize
C#
public override AllowMaximize AllowMaximize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxWindowSettings Class
WebDialogBoxWindowSettings Members


AllowMinimize Property

[image]
Intersoft WebDesktop Documentation
AllowMinimize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxWindowSettings Class : AllowMinimize Property

Glossary Item Box

Indicates whether the Window can be miniimized.

Syntax

Visual Basic (Declaration)
Public Overrides Property AllowMinimize As AllowMinimize
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxWindowSettings
Dim value As AllowMinimize

instance.AllowMinimize = value

value = instance.AllowMinimize
C#
public override AllowMinimize AllowMinimize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxWindowSettings Class
WebDialogBoxWindowSettings Members


AllowResize Property

[image]
Intersoft WebDesktop Documentation
AllowResize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxWindowSettings Class : AllowResize Property

Glossary Item Box

Indicates whether the Window can be resized.

Syntax

Visual Basic (Declaration)
Public Overrides Property AllowResize As AllowResize
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxWindowSettings
Dim value As AllowResize

instance.AllowResize = value

value = instance.AllowResize
C#
public override AllowResize AllowResize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxWindowSettings Class
WebDialogBoxWindowSettings Members


BorderType Property

[image]
Intersoft WebDesktop Documentation
BorderType Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxWindowSettings Class : BorderType Property

Glossary Item Box

Gets or sets the type of border applied to Window.

Syntax

Visual Basic (Declaration)
Public Overrides Property BorderType As BorderType
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxWindowSettings
Dim value As BorderType

instance.BorderType = value

value = instance.BorderType
C#
public override BorderType BorderType {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxWindowSettings Class
WebDialogBoxWindowSettings Members


CaptionDisplayMode Property

[image]
Intersoft WebDesktop Documentation
CaptionDisplayMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxWindowSettings Class : CaptionDisplayMode Property

Glossary Item Box

Gets or sets the display mode for the Caption.

Syntax

Visual Basic (Declaration)
Public Overrides Property CaptionDisplayMode As WindowCaptionDisplayMode
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxWindowSettings
Dim value As WindowCaptionDisplayMode

instance.CaptionDisplayMode = value

value = instance.CaptionDisplayMode
C#
public override WindowCaptionDisplayMode CaptionDisplayMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxWindowSettings Class
WebDialogBoxWindowSettings Members


CommandButtonBorderType Property

[image]
Intersoft WebDesktop Documentation
CommandButtonBorderType Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxWindowSettings Class : CommandButtonBorderType Property

Glossary Item Box

Gets or sets the border type of the command button.

Syntax

Visual Basic (Declaration)
Public Overrides Property CommandButtonBorderType As BorderType
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxWindowSettings
Dim value As BorderType

instance.CommandButtonBorderType = value

value = instance.CommandButtonBorderType
C#
public override BorderType CommandButtonBorderType {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxWindowSettings Class
WebDialogBoxWindowSettings Members


ControlBox Property

[image]
Intersoft WebDesktop Documentation
ControlBox Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDialogBoxWindowSettings Class : ControlBox Property

Glossary Item Box

Indicates wheter the control box for the Window is visible.

Syntax

Visual Basic (Declaration)
Public Overrides Property ControlBox As ControlBox
Visual Basic (Usage) Copy Code
Dim instance As WebDialogBoxWindowSettings
Dim value As ControlBox

instance.ControlBox = value

value = instance.ControlBox
C#
public override ControlBox ControlBox {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDialogBoxWindowSettings Class
WebDialogBoxWindowSettings Members


WebDragControl Class

[image]
Intersoft WebDesktop Documentation
WebDragControl Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDragControl Class

Glossary Item Box

Gets or sets the collection of drag-able controls.

Object Model

WebDragControl Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class WebDragControl
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer
Visual Basic (Usage) Copy Code
Dim instance As WebDragControl
C#
public sealed class WebDragControl : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebDesktop.WebDragControl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragControl Members
ISNet.WebUI.WebDesktop Namespace


WebDragControl Class Members

[image]
Intersoft WebDesktop Documentation
WebDragControl Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDragControl Class

Glossary Item Box

The following tables list the members exposed by WebDragControl.

Public Constructors

 | Name | Description
Public Constructor | WebDragControl Constructor |
Top

Public Properties

 | Name | Description
Public Property | AdvancedProperties | Gets or sets the advanced properties for the specified drag controls.
Public Property | AllowCrossIFrame | Specifies the behavior when a drag operation crosses IFrame element under Web page.
Public Property | AllowedEffects | Specifies the allowed effects of a drag operation.
Public Property | ControlID | Gets or sets the name or identifier of the dragable control.
Public Property | DragData | Gets or sets the drag data that is attached to the drag object during drag operation.
Public Property | DragVisualHint | Specifies the visual effect displayed during drag operation.
Public Property | Effect | Specifies the effect which applies to the drop object during drag drop operation.
Public Property | EffectText | Gets or sets the displayed text when a valid drag object is hovered on this drop control.
Public Property | Enabled | Determines whether the drag behavior for this dtrag control should be enabled.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | Overrides ToString() method.
Top

See Also

Reference

WebDragControl Class
ISNet.WebUI.WebDesktop Namespace


WebDragControl Constructor

[image]
Intersoft WebDesktop Documentation
WebDragControl Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragControl Class : WebDragControl Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebDragControl()
C#
public WebDragControl()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragControl Class
WebDragControl Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragControl Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebDragControl
Dim value As Object

value = instance.Clone()
C#
public object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragControl Class
WebDragControl Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragControl Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragControl Class
WebDragControl Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragControl Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDragControl
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragControl Class
WebDragControl Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragControl Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDragControl
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragControl Class
WebDragControl Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragControl Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDragControl
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragControl Class
WebDragControl Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragControl Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebDragControl
Dim value As Integer

value = instance.GetHashCode()
C#
public int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragControl Class
WebDragControl Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragControl Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDragControl
Dim value As Boolean

value = instance.IsEmpty()
C#
public bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragControl Class
WebDragControl Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragControl Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebDragControl

instance.Reset()
C#
public void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragControl Class
WebDragControl Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragControl Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDragControl
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragControl Class
WebDragControl Members


WebDragControl Class Methods

[image]
Intersoft WebDesktop Documentation
WebDragControl Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDragControl Class

Glossary Item Box

For a list of all members of this type, see WebDragControl members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | Overrides ToString() method.
Top

See Also

Reference

WebDragControl Class
ISNet.WebUI.WebDesktop Namespace


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragControl Class : ToString Method

Glossary Item Box

Overrides ToString() method.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebDragControl
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragControl Class
WebDragControl Members


WebDragControl Class Properties

[image]
Intersoft WebDesktop Documentation
WebDragControl Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDragControl Class

Glossary Item Box

For a list of all members of this type, see WebDragControl members.

Public Properties

 | Name | Description
Public Property | AdvancedProperties | Gets or sets the advanced properties for the specified drag controls.
Public Property | AllowCrossIFrame | Specifies the behavior when a drag operation crosses IFrame element under Web page.
Public Property | AllowedEffects | Specifies the allowed effects of a drag operation.
Public Property | ControlID | Gets or sets the name or identifier of the dragable control.
Public Property | DragData | Gets or sets the drag data that is attached to the drag object during drag operation.
Public Property | DragVisualHint | Specifies the visual effect displayed during drag operation.
Public Property | Effect | Specifies the effect which applies to the drop object during drag drop operation.
Public Property | EffectText | Gets or sets the displayed text when a valid drag object is hovered on this drop control.
Public Property | Enabled | Determines whether the drag behavior for this dtrag control should be enabled.
Top

See Also

Reference

WebDragControl Class
ISNet.WebUI.WebDesktop Namespace


WebDragControl Constructor

[image]
Intersoft WebDesktop Documentation
WebDragControl Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragControl Class : WebDragControl Constructor

Glossary Item Box

Initializes a new instance of the WebDragControl class with no argument.

Overload List

Overload | Description
WebDragControl Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragControl Class
WebDragControl Members


AdvancedProperties Property

[image]
Intersoft WebDesktop Documentation
AdvancedProperties Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragControl Class : AdvancedProperties Property

Glossary Item Box

Gets or sets the advanced properties for the specified drag controls.

Syntax

Visual Basic (Declaration)
Public Property AdvancedProperties As String
Visual Basic (Usage) Copy Code
Dim instance As WebDragControl
Dim value As String

instance.AdvancedProperties = value

value = instance.AdvancedProperties
C#
public string AdvancedProperties {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragControl Class
WebDragControl Members


AllowCrossIFrame Property

[image]
Intersoft WebDesktop Documentation
AllowCrossIFrame Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragControl Class : AllowCrossIFrame Property

Glossary Item Box

Specifies the behavior when a drag operation crosses IFrame element under Web page.

Syntax

Visual Basic (Declaration)
Public Property AllowCrossIFrame As CrossIFrameMode
Visual Basic (Usage) Copy Code
Dim instance As WebDragControl
Dim value As CrossIFrameMode

instance.AllowCrossIFrame = value

value = instance.AllowCrossIFrame
C#
public CrossIFrameMode AllowCrossIFrame {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragControl Class
WebDragControl Members


AllowedEffects Property

[image]
Intersoft WebDesktop Documentation
AllowedEffects Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragControl Class : AllowedEffects Property

Glossary Item Box

Specifies the allowed effects of a drag operation.

Syntax

Visual Basic (Declaration)
Public Property AllowedEffects As DragDropEffects
Visual Basic (Usage) Copy Code
Dim instance As WebDragControl
Dim value As DragDropEffects

instance.AllowedEffects = value

value = instance.AllowedEffects
C#
public DragDropEffects AllowedEffects {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragControl Class
WebDragControl Members


ControlID Property

[image]
Intersoft WebDesktop Documentation
ControlID Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragControl Class : ControlID Property

Glossary Item Box

Gets or sets the name or identifier of the dragable control.

Syntax

Visual Basic (Declaration)
Public Property ControlID As String
Visual Basic (Usage) Copy Code
Dim instance As WebDragControl
Dim value As String

instance.ControlID = value

value = instance.ControlID
C#
public string ControlID {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragControl Class
WebDragControl Members


DragData Property

[image]
Intersoft WebDesktop Documentation
DragData Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragControl Class : DragData Property

Glossary Item Box

Gets or sets the drag data that is attached to the drag object during drag operation.

Syntax

Visual Basic (Declaration)
Public Property DragData As String
Visual Basic (Usage) Copy Code
Dim instance As WebDragControl
Dim value As String

instance.DragData = value

value = instance.DragData
C#
public string DragData {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragControl Class
WebDragControl Members


DragVisualHint Property

[image]
Intersoft WebDesktop Documentation
DragVisualHint Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragControl Class : DragVisualHint Property

Glossary Item Box

Specifies the visual effect displayed during drag operation.

Syntax

Visual Basic (Declaration)
Public Property DragVisualHint As DragVisualHint
Visual Basic (Usage) Copy Code
Dim instance As WebDragControl
Dim value As DragVisualHint

instance.DragVisualHint = value

value = instance.DragVisualHint
C#
public DragVisualHint DragVisualHint {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragControl Class
WebDragControl Members


Effect Property

[image]
Intersoft WebDesktop Documentation
Effect Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragControl Class : Effect Property

Glossary Item Box

Specifies the effect which applies to the drop object during drag drop operation.

Syntax

Visual Basic (Declaration)
Public Property Effect As SpecificDragObjectEffects
Visual Basic (Usage) Copy Code
Dim instance As WebDragControl
Dim value As SpecificDragObjectEffects

instance.Effect = value

value = instance.Effect
C#
public SpecificDragObjectEffects Effect {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragControl Class
WebDragControl Members


EffectText Property

[image]
Intersoft WebDesktop Documentation
EffectText Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragControl Class : EffectText Property

Glossary Item Box

Gets or sets the displayed text when a valid drag object is hovered on this drop control.

Syntax

Visual Basic (Declaration)
Public Property EffectText As String
Visual Basic (Usage) Copy Code
Dim instance As WebDragControl
Dim value As String

instance.EffectText = value

value = instance.EffectText
C#
public string EffectText {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragControl Class
WebDragControl Members


Enabled Property

[image]
Intersoft WebDesktop Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragControl Class : Enabled Property

Glossary Item Box

Determines whether the drag behavior for this dtrag control should be enabled.

Syntax

Visual Basic (Declaration)
Public Property Enabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDragControl
Dim value As Boolean

instance.Enabled = value

value = instance.Enabled
C#
public bool Enabled {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragControl Class
WebDragControl Members


WebDragDropClientSideEvents Class

[image]
Intersoft WebDesktop Documentation
WebDragDropClientSideEvents Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDragDropClientSideEvents Class

Glossary Item Box

The collection of WebDragDrop's client-side events.

Object Model

WebDragDropClientSideEvents Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class WebDragDropClientSideEvents
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropClientSideEvents
C#
public sealed class WebDragDropClientSideEvents : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebDesktop.WebDragDropClientSideEvents

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropClientSideEvents Members
ISNet.WebUI.WebDesktop Namespace


WebDragDropClientSideEvents Class Members

[image]
Intersoft WebDesktop Documentation
WebDragDropClientSideEvents Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDragDropClientSideEvents Class

Glossary Item Box

The following tables list the members exposed by WebDragDropClientSideEvents.

Public Constructors

 | Name | Description
Public Constructor | WebDragDropClientSideEvents Constructor |
Top

Public Properties

 | Name | Description
Public Property | OnDragDrop | Gets or sets the javascript function to be invoked when a valid drag source is dropped to a valid drop target.
Public Property | OnDragEnd | Gets or sets the javascript function to be invoked when a drag operation has ended.
Public Property | OnDragEnter | Gets or sets the javascript function to be invoked when a valid drag source is entering a valid drop target for the first time.
Public Property | OnDragLeave | Gets or sets the javascript function to be invoked a valid drag source is leaving a drop target without releasing the mouse button.
Public Property | OnDragOver | Gets or sets the javascript function to be invoked a valid source is over a valid drop target.
Public Property | OnDragStart | Gets or sets the javascript function to be invoked when a drag operation has started.
Public Property | OnInitialize | Gets or sets the javascript function to be invoked when a control is being initialized.
Public Property | OnShadowCreate | Gets or sets the javascript function to be invoked when the control needs to create shadow visual effect for dragging operation.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebDragDropClientSideEvents Class
ISNet.WebUI.WebDesktop Namespace


WebDragDropClientSideEvents Class Methods

[image]
Intersoft WebDesktop Documentation
WebDragDropClientSideEvents Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDragDropClientSideEvents Class

Glossary Item Box

For a list of all members of this type, see WebDragDropClientSideEvents members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebDragDropClientSideEvents Class
ISNet.WebUI.WebDesktop Namespace


WebDragDropClientSideEvents Constructor

[image]
Intersoft WebDesktop Documentation
WebDragDropClientSideEvents Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropClientSideEvents Class : WebDragDropClientSideEvents Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebDragDropClientSideEvents()
C#
public WebDragDropClientSideEvents()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropClientSideEvents Class
WebDragDropClientSideEvents Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropClientSideEvents Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropClientSideEvents
Dim value As Object

value = instance.Clone()
C#
public object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropClientSideEvents Class
WebDragDropClientSideEvents Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropClientSideEvents Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropClientSideEvents Class
WebDragDropClientSideEvents Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropClientSideEvents Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropClientSideEvents
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropClientSideEvents Class
WebDragDropClientSideEvents Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropClientSideEvents Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropClientSideEvents
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropClientSideEvents Class
WebDragDropClientSideEvents Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropClientSideEvents Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropClientSideEvents
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropClientSideEvents Class
WebDragDropClientSideEvents Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropClientSideEvents Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropClientSideEvents
Dim value As Integer

value = instance.GetHashCode()
C#
public int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropClientSideEvents Class
WebDragDropClientSideEvents Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropClientSideEvents Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropClientSideEvents
Dim value As Boolean

value = instance.IsEmpty()
C#
public bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropClientSideEvents Class
WebDragDropClientSideEvents Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropClientSideEvents Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropClientSideEvents

instance.Reset()
C#
public void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropClientSideEvents Class
WebDragDropClientSideEvents Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropClientSideEvents Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropClientSideEvents
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropClientSideEvents Class
WebDragDropClientSideEvents Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropClientSideEvents Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropClientSideEvents
Dim value As String

value = instance.ToString()
C#
public string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropClientSideEvents Class
WebDragDropClientSideEvents Members


WebDragDropClientSideEvents Class Properties

[image]
Intersoft WebDesktop Documentation
WebDragDropClientSideEvents Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDragDropClientSideEvents Class

Glossary Item Box

For a list of all members of this type, see WebDragDropClientSideEvents members.

Public Properties

 | Name | Description
Public Property | OnDragDrop | Gets or sets the javascript function to be invoked when a valid drag source is dropped to a valid drop target.
Public Property | OnDragEnd | Gets or sets the javascript function to be invoked when a drag operation has ended.
Public Property | OnDragEnter | Gets or sets the javascript function to be invoked when a valid drag source is entering a valid drop target for the first time.
Public Property | OnDragLeave | Gets or sets the javascript function to be invoked a valid drag source is leaving a drop target without releasing the mouse button.
Public Property | OnDragOver | Gets or sets the javascript function to be invoked a valid source is over a valid drop target.
Public Property | OnDragStart | Gets or sets the javascript function to be invoked when a drag operation has started.
Public Property | OnInitialize | Gets or sets the javascript function to be invoked when a control is being initialized.
Public Property | OnShadowCreate | Gets or sets the javascript function to be invoked when the control needs to create shadow visual effect for dragging operation.
Top

See Also

Reference

WebDragDropClientSideEvents Class
ISNet.WebUI.WebDesktop Namespace


WebDragDropClientSideEvents Constructor

[image]
Intersoft WebDesktop Documentation
WebDragDropClientSideEvents Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropClientSideEvents Class : WebDragDropClientSideEvents Constructor

Glossary Item Box

Initializes a new instance of WebDragDropClientSideEvents class with no argument.

Overload List

Overload | Description
WebDragDropClientSideEvents Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropClientSideEvents Class
WebDragDropClientSideEvents Members


OnDragDrop Property

[image]
Intersoft WebDesktop Documentation
OnDragDrop Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropClientSideEvents Class : OnDragDrop Property

Glossary Item Box

Gets or sets the javascript function to be invoked when a valid drag source is dropped to a valid drop target.

Syntax

Visual Basic (Declaration)
Public Property OnDragDrop As String
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropClientSideEvents
Dim value As String

instance.OnDragDrop = value

value = instance.OnDragDrop
C#
public string OnDragDrop {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropClientSideEvents Class
WebDragDropClientSideEvents Members


OnDragEnd Property

[image]
Intersoft WebDesktop Documentation
OnDragEnd Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropClientSideEvents Class : OnDragEnd Property

Glossary Item Box

Gets or sets the javascript function to be invoked when a drag operation has ended.

Syntax

Visual Basic (Declaration)
Public Property OnDragEnd As String
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropClientSideEvents
Dim value As String

instance.OnDragEnd = value

value = instance.OnDragEnd
C#
public string OnDragEnd {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropClientSideEvents Class
WebDragDropClientSideEvents Members


OnDragEnter Property

[image]
Intersoft WebDesktop Documentation
OnDragEnter Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropClientSideEvents Class : OnDragEnter Property

Glossary Item Box

Gets or sets the javascript function to be invoked when a valid drag source is entering a valid drop target for the first time.

Syntax

Visual Basic (Declaration)
Public Property OnDragEnter As String
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropClientSideEvents
Dim value As String

instance.OnDragEnter = value

value = instance.OnDragEnter
C#
public string OnDragEnter {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropClientSideEvents Class
WebDragDropClientSideEvents Members


OnDragLeave Property

[image]
Intersoft WebDesktop Documentation
OnDragLeave Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropClientSideEvents Class : OnDragLeave Property

Glossary Item Box

Gets or sets the javascript function to be invoked a valid drag source is leaving a drop target without releasing the mouse button.

Syntax

Visual Basic (Declaration)
Public Property OnDragLeave As String
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropClientSideEvents
Dim value As String

instance.OnDragLeave = value

value = instance.OnDragLeave
C#
public string OnDragLeave {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropClientSideEvents Class
WebDragDropClientSideEvents Members


OnDragOver Property

[image]
Intersoft WebDesktop Documentation
OnDragOver Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropClientSideEvents Class : OnDragOver Property

Glossary Item Box

Gets or sets the javascript function to be invoked a valid source is over a valid drop target.

Syntax

Visual Basic (Declaration)
Public Property OnDragOver As String
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropClientSideEvents
Dim value As String

instance.OnDragOver = value

value = instance.OnDragOver
C#
public string OnDragOver {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropClientSideEvents Class
WebDragDropClientSideEvents Members


OnDragStart Property

[image]
Intersoft WebDesktop Documentation
OnDragStart Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropClientSideEvents Class : OnDragStart Property

Glossary Item Box

Gets or sets the javascript function to be invoked when a drag operation has started.

Syntax

Visual Basic (Declaration)
Public Property OnDragStart As String
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropClientSideEvents
Dim value As String

instance.OnDragStart = value

value = instance.OnDragStart
C#
public string OnDragStart {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropClientSideEvents Class
WebDragDropClientSideEvents Members


OnInitialize Property

[image]
Intersoft WebDesktop Documentation
OnInitialize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropClientSideEvents Class : OnInitialize Property

Glossary Item Box

Gets or sets the javascript function to be invoked when a control is being initialized.

Syntax

Visual Basic (Declaration)
Public Property OnInitialize As String
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropClientSideEvents
Dim value As String

instance.OnInitialize = value

value = instance.OnInitialize
C#
public string OnInitialize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropClientSideEvents Class
WebDragDropClientSideEvents Members


OnShadowCreate Property

[image]
Intersoft WebDesktop Documentation
OnShadowCreate Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropClientSideEvents Class : OnShadowCreate Property

Glossary Item Box

Gets or sets the javascript function to be invoked when the control needs to create shadow visual effect for dragging operation.

Syntax

Visual Basic (Declaration)
Public Property OnShadowCreate As String
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropClientSideEvents
Dim value As String

instance.OnShadowCreate = value

value = instance.OnShadowCreate
C#
public string OnShadowCreate {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropClientSideEvents Class
WebDragDropClientSideEvents Members


WebDragDropEventArgs Class

[image]
Intersoft WebDesktop Documentation
WebDragDropEventArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDragDropEventArgs Class

Glossary Item Box

Provides data for WebDragDrop related event.

Object Model

WebDragDropEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class WebDragDropEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropEventArgs
C#
public class WebDragDropEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebDesktop.WebDragDropEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropEventArgs Members
ISNet.WebUI.WebDesktop Namespace


WebDragDropEventArgs Class Members

[image]
Intersoft WebDesktop Documentation
WebDragDropEventArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDragDropEventArgs Class

Glossary Item Box

The following tables list the members exposed by WebDragDropEventArgs.

Public Constructors

 | Name | Description
Public Constructor | WebDragDropEventArgs Constructor | Initializes a new instance of the WebDragDropEventArgs class with no argument.
Top

Public Properties

 | Name | Description
Public Property | AllowedEffects | Specifies the allowed effects of a drag operation.
Public Property | Data | Specifies the data associated with a drag control.
Public Property | DragControl | Gets or sets the collection of drag-able controls.
Public Property | Effect | Specifies the effect which applies to the drop object during drag drop operation.
Public Property | EffectText | Gets or sets the displayed text when a valid drag object is hovered on this drop control.
Public Property | KeyState | Gets and sets the key state in the current context of drag operation. Key state can be combination of Ctrl, Alt, and Shift.
Public Property | X | Gets the X point of mouse cursor relative to the document.
Public Property | Y | Gets the Y point of mouse cursor relative to the document.
Top

See Also

Reference

WebDragDropEventArgs Class
ISNet.WebUI.WebDesktop Namespace


WebDragDropEventArgs Constructor

[image]
Intersoft WebDesktop Documentation
WebDragDropEventArgs Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropEventArgs Class : WebDragDropEventArgs Constructor

Glossary Item Box

Initializes a new instance of the WebDragDropEventArgs class with no argument.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebDragDropEventArgs()
C#
public WebDragDropEventArgs()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropEventArgs Class
WebDragDropEventArgs Members


WebDragDropEventArgs Class Properties

[image]
Intersoft WebDesktop Documentation
WebDragDropEventArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDragDropEventArgs Class

Glossary Item Box

For a list of all members of this type, see WebDragDropEventArgs members.

Public Properties

 | Name | Description
Public Property | AllowedEffects | Specifies the allowed effects of a drag operation.
Public Property | Data | Specifies the data associated with a drag control.
Public Property | DragControl | Gets or sets the collection of drag-able controls.
Public Property | Effect | Specifies the effect which applies to the drop object during drag drop operation.
Public Property | EffectText | Gets or sets the displayed text when a valid drag object is hovered on this drop control.
Public Property | KeyState | Gets and sets the key state in the current context of drag operation. Key state can be combination of Ctrl, Alt, and Shift.
Public Property | X | Gets the X point of mouse cursor relative to the document.
Public Property | Y | Gets the Y point of mouse cursor relative to the document.
Top

See Also

Reference

WebDragDropEventArgs Class
ISNet.WebUI.WebDesktop Namespace


AllowedEffects Property

[image]
Intersoft WebDesktop Documentation
AllowedEffects Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropEventArgs Class : AllowedEffects Property

Glossary Item Box

Specifies the allowed effects of a drag operation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AllowedEffects As DragDropEffects
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropEventArgs
Dim value As DragDropEffects

value = instance.AllowedEffects
C#
public DragDropEffects AllowedEffects {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropEventArgs Class
WebDragDropEventArgs Members


Data Property

[image]
Intersoft WebDesktop Documentation
Data Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropEventArgs Class : Data Property

Glossary Item Box

Specifies the data associated with a drag control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Data As Object
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropEventArgs
Dim value As Object

value = instance.Data
C#
public object Data {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropEventArgs Class
WebDragDropEventArgs Members


DragControl Property

[image]
Intersoft WebDesktop Documentation
DragControl Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropEventArgs Class : DragControl Property

Glossary Item Box

Gets or sets the collection of drag-able controls.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DragControl As WebDragControl
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropEventArgs
Dim value As WebDragControl

value = instance.DragControl
C#
public WebDragControl DragControl {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropEventArgs Class
WebDragDropEventArgs Members


Effect Property

[image]
Intersoft WebDesktop Documentation
Effect Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropEventArgs Class : Effect Property

Glossary Item Box

Specifies the effect which applies to the drop object during drag drop operation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Effect As SpecificDragObjectEffects
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropEventArgs
Dim value As SpecificDragObjectEffects

value = instance.Effect
C#
public SpecificDragObjectEffects Effect {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropEventArgs Class
WebDragDropEventArgs Members


EffectText Property

[image]
Intersoft WebDesktop Documentation
EffectText Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropEventArgs Class : EffectText Property

Glossary Item Box

Gets or sets the displayed text when a valid drag object is hovered on this drop control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EffectText As String
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropEventArgs
Dim value As String

value = instance.EffectText
C#
public string EffectText {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropEventArgs Class
WebDragDropEventArgs Members


KeyState Property

[image]
Intersoft WebDesktop Documentation
KeyState Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropEventArgs Class : KeyState Property

Glossary Item Box

Gets and sets the key state in the current context of drag operation. Key state can be combination of Ctrl, Alt, and Shift.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property KeyState As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropEventArgs
Dim value As Integer

value = instance.KeyState
C#
public int KeyState {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropEventArgs Class
WebDragDropEventArgs Members


X Property

[image]
Intersoft WebDesktop Documentation
X Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropEventArgs Class : X Property

Glossary Item Box

Gets the X point of mouse cursor relative to the document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property X As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropEventArgs
Dim value As Integer

value = instance.X
C#
public int X {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropEventArgs Class
WebDragDropEventArgs Members


Y Property

[image]
Intersoft WebDesktop Documentation
Y Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropEventArgs Class : Y Property

Glossary Item Box

Gets the Y point of mouse cursor relative to the document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Y As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropEventArgs
Dim value As Integer

value = instance.Y
C#
public int Y {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropEventArgs Class
WebDragDropEventArgs Members


WebDragDropExtender Class

[image]
Intersoft WebDesktop Documentation
WebDragDropExtender Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDragDropExtender Class

Glossary Item Box

WebDragDropExtender is a component which allows you to easily perform drag-drop operation in a Web-based application.

Object Model

WebDragDropExtender Class

Syntax

Visual Basic (Declaration)
Public Class WebDragDropExtender
   Inherits ISNet.WebUI.ISNetControl
   Implements ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
C#
public class WebDragDropExtender : ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
ISNet.WebUI.ISNetControl
ISNet.WebUI.WebDesktop.WebDragDropExtender

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Members
ISNet.WebUI.WebDesktop Namespace


WebDragDropExtender Class Members

[image]
Intersoft WebDesktop Documentation
WebDragDropExtender Class Members
See Also Properties Methods Events Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDragDropExtender Class

Glossary Item Box

The following tables list the members exposed by WebDragDropExtender.

Public Constructors

 | Name | Description
Public Constructor | WebDragDropExtender Constructor |
Top

Public Properties

 | Name | Description
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ClientSideEvents | Contains client-side event for drag drop operation.
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | DragControls | Gets or sets the collection of drag-able controls.
Public Property | DragSettings | Contains drag operation settings.
Public Property | DropControls | Gets or sets the collection of drop-able controls.
Public Property | DropSettings | Contains drop operation settings.
Public Property | Enabled | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableManagedTheming | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableViewState | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | FlyPostBackSettings | Configures the settings used by the control when performing OnTheFly postback.
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ImagesDirectory | Gets or sets the image location that store drag effects and indicators.
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden. Gets or sets the script location of WebDragDropExtender.
Public Property | SharedScriptDirectory | Overridden.
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateItems | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | XmlCompressionEnabled | (Inherited from ISNet.WebUI.ISNetControl)
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetClientAction | Gets the client function directly from server code during OnTheFly postback.
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnDragDrop | Gets or sets the javascript function to be invoked when a valid drag source is dropped to a valid drop target.
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | DragDrop | Fires when a drag and drop operation has been performed successfully.
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebDragDropExtender Class
ISNet.WebUI.WebDesktop Namespace


WebDragDropExtender Constructor

[image]
Intersoft WebDesktop Documentation
WebDragDropExtender Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : WebDragDropExtender Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebDragDropExtender()
C#
public WebDragDropExtender()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


ApplyStyle Method

[image]
Intersoft WebDesktop Documentation
ApplyStyle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : ApplyStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ApplyStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim s As System.Web.UI.WebControls.Style

instance.ApplyStyle(s)
C#
public void ApplyStyle(
   System.Web.UI.WebControls.Style s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


ApplyStyleSheetSkin Method

[image]
Intersoft WebDesktop Documentation
ApplyStyleSheetSkin Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : ApplyStyleSheetSkin Method

page

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub ApplyStyleSheetSkin( _
   ByVal page As System.Web.UI.Page _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim page As System.Web.UI.Page

instance.ApplyStyleSheetSkin(page)
C#
public virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page page
)

Parameters

page

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


CanUseWebResources Method

[image]
Intersoft WebDesktop Documentation
CanUseWebResources Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : CanUseWebResources Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CanUseWebResources() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As Boolean

value = instance.CanUseWebResources()
C#
public bool CanUseWebResources()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


CopyBaseAttributes Method

[image]
Intersoft WebDesktop Documentation
CopyBaseAttributes Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : CopyBaseAttributes Method

controlSrc

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyBaseAttributes( _
   ByVal controlSrc As System.Web.UI.WebControls.WebControl _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim controlSrc As System.Web.UI.WebControls.WebControl

instance.CopyBaseAttributes(controlSrc)
C#
public void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl controlSrc
)

Parameters

controlSrc

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.ISNetControl)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members
Overload List


DataBind Method

[image]
Intersoft WebDesktop Documentation
DataBind Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : DataBind Method

Glossary Item Box

Overload List

Overload | Description
DataBind | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


DataBind() Method

[image]
Intersoft WebDesktop Documentation
DataBind() Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : DataBind() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub DataBind()
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender

instance.DataBind()
C#
public virtual void DataBind()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


Dispose Method

[image]
Intersoft WebDesktop Documentation
Dispose Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : Dispose Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender

instance.Dispose()
C#
public virtual void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


FindControl Method

[image]
Intersoft WebDesktop Documentation
FindControl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : FindControl Method

Glossary Item Box

Overload List

Overload | Description
FindControl | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


FindControl(String) Method

[image]
Intersoft WebDesktop Documentation
FindControl(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : FindControl(String) Method

id

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function FindControl( _
   ByVal id As String _
) As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim id As String
Dim value As System.Web.UI.Control

value = instance.FindControl(id)
C#
public virtual System.Web.UI.Control FindControl(
   string id
)

Parameters

id

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


Focus Method

[image]
Intersoft WebDesktop Documentation
Focus Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : Focus Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Focus()
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender

instance.Focus()
C#
public virtual void Focus()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


ForceDisableXmlCompression Method

[image]
Intersoft WebDesktop Documentation
ForceDisableXmlCompression Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : ForceDisableXmlCompression Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ForceDisableXmlCompression()
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender

instance.ForceDisableXmlCompression()
C#
public void ForceDisableXmlCompression()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


WebDragDropExtender Class Methods

[image]
Intersoft WebDesktop Documentation
WebDragDropExtender Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDragDropExtender Class

Glossary Item Box

For a list of all members of this type, see WebDragDropExtender members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetClientAction | Gets the client function directly from server code during OnTheFly postback.
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnDragDrop | Gets or sets the javascript function to be invoked when a valid drag source is dropped to a valid drop target.
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Top

See Also

Reference

WebDragDropExtender Class
ISNet.WebUI.WebDesktop Namespace


GetClientAction Method

[image]
Intersoft WebDesktop Documentation
GetClientAction Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : GetClientAction Method

Glossary Item Box

Gets the client function directly from server code during OnTheFly postback.

Syntax

Visual Basic (Declaration)
Public Function GetClientAction() As ISNet.WebUI.BaseClientSideAction
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As ISNet.WebUI.BaseClientSideAction

value = instance.GetClientAction()
C#
public ISNet.WebUI.BaseClientSideAction GetClientAction()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


GetCurrentControlLifeCycle Method

[image]
Intersoft WebDesktop Documentation
GetCurrentControlLifeCycle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : GetCurrentControlLifeCycle Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentControlLifeCycle() As ISNet.WebUI.ControlLifeCycle
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As ISNet.WebUI.ControlLifeCycle

value = instance.GetCurrentControlLifeCycle()
C#
public ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


GetCurrentTheme Method

[image]
Intersoft WebDesktop Documentation
GetCurrentTheme Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : GetCurrentTheme Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentTheme() As ISNet.WebUI.ThemeInfo
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As ISNet.WebUI.ThemeInfo

value = instance.GetCurrentTheme()
C#
public ISNet.WebUI.ThemeInfo GetCurrentTheme()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


GetFrameworkDataFolder Method

[image]
Intersoft WebDesktop Documentation
GetFrameworkDataFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : GetFrameworkDataFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkDataFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As String

value = instance.GetFrameworkDataFolder()
C#
public string GetFrameworkDataFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


GetFrameworkFolder Method

[image]
Intersoft WebDesktop Documentation
GetFrameworkFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : GetFrameworkFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As String

value = instance.GetFrameworkFolder()
C#
public string GetFrameworkFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


GetFrameworkVersion Method

[image]
Intersoft WebDesktop Documentation
GetFrameworkVersion Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : GetFrameworkVersion Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkVersion() As Version
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As Version

value = instance.GetFrameworkVersion()
C#
public Version GetFrameworkVersion()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


GetIntersoftFolder Method

[image]
Intersoft WebDesktop Documentation
GetIntersoftFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : GetIntersoftFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetIntersoftFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As String

value = instance.GetIntersoftFolder()
C#
public string GetIntersoftFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


GetLayoutFolder Method

[image]
Intersoft WebDesktop Documentation
GetLayoutFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : GetLayoutFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetLayoutFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As String

value = instance.GetLayoutFolder()
C#
public string GetLayoutFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


GetPostedXMLData Method

[image]
Intersoft WebDesktop Documentation
GetPostedXMLData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : GetPostedXMLData Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPostedXMLData() As String
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As String

value = instance.GetPostedXMLData()
C#
public string GetPostedXMLData()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


GetProductInfoKey Method

[image]
Intersoft WebDesktop Documentation
GetProductInfoKey Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : GetProductInfoKey Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductInfoKey() As String
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As String

value = instance.GetProductInfoKey()
C#
public string GetProductInfoKey()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


GetProductSimpleName Method

[image]
Intersoft WebDesktop Documentation
GetProductSimpleName Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : GetProductSimpleName Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductSimpleName() As String
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As String

value = instance.GetProductSimpleName()
C#
public string GetProductSimpleName()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


GetPropertyValue Method

[image]
Intersoft WebDesktop Documentation
GetPropertyValue Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : GetPropertyValue Method

defValue
propValue
webConfigKey

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPropertyValue( _
   ByVal defValue As String, _
   ByVal propValue As String, _
   ByVal webConfigKey As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim defValue As String
Dim propValue As String
Dim webConfigKey As String
Dim value As String

value = instance.GetPropertyValue(defValue, propValue, webConfigKey)
C#
public string GetPropertyValue(
   string defValue,
   string propValue,
   string webConfigKey
)

Parameters

defValue
propValue
webConfigKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


GetResourceStream Method

[image]
Intersoft WebDesktop Documentation
GetResourceStream Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : GetResourceStream Method

resourceUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetResourceStream( _
   ByVal resourceUrl As String _
) As System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim resourceUrl As String
Dim value As System.IO.Stream

value = instance.GetResourceStream(resourceUrl)
C#
public System.IO.Stream GetResourceStream(
   string resourceUrl
)

Parameters

resourceUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


GetRouteUrl Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : GetRouteUrl Method

Glossary Item Box

Overload List

Overload | Description
GetRouteUrl(Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(RouteValueDictionary) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,RouteValueDictionary) | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


GetRouteUrl(Object) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class > GetRouteUrl Method : GetRouteUrl(Object) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As Object _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim routeParameters As Object
Dim value As String

value = instance.GetRouteUrl(routeParameters)
C#
public string GetRouteUrl(
   object routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members
Overload List


GetRouteUrl(String,Object) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(String,Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class > GetRouteUrl Method : GetRouteUrl(String,Object) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As String, _
   ByVal routeParameters As Object _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim routeName As String
Dim routeParameters As Object
Dim value As String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public string GetRouteUrl(
   string routeName,
   object routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members
Overload List


GetRouteUrl(RouteValueDictionary) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(RouteValueDictionary) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class > GetRouteUrl Method : GetRouteUrl(RouteValueDictionary) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As String

value = instance.GetRouteUrl(routeParameters)
C#
public string GetRouteUrl(
   System.Web.Routing.RouteValueDictionary routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members
Overload List


GetRouteUrl(String,RouteValueDictionary) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(String,RouteValueDictionary) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class > GetRouteUrl Method : GetRouteUrl(String,RouteValueDictionary) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As String, _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim routeName As String
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public string GetRouteUrl(
   string routeName,
   System.Web.Routing.RouteValueDictionary routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members
Overload List


GetUniqueIDRelativeTo Method

[image]
Intersoft WebDesktop Documentation
GetUniqueIDRelativeTo Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : GetUniqueIDRelativeTo Method

control

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetUniqueIDRelativeTo( _
   ByVal control As System.Web.UI.Control _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim control As System.Web.UI.Control
Dim value As String

value = instance.GetUniqueIDRelativeTo(control)
C#
public string GetUniqueIDRelativeTo(
   System.Web.UI.Control control
)

Parameters

control

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


HasControls Method

[image]
Intersoft WebDesktop Documentation
HasControls Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : HasControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function HasControls() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As Boolean

value = instance.HasControls()
C#
public virtual bool HasControls()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


IsAtlasCallback Method

[image]
Intersoft WebDesktop Documentation
IsAtlasCallback Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : IsAtlasCallback Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsAtlasCallback() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As Boolean

value = instance.IsAtlasCallback()
C#
public bool IsAtlasCallback()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


IsBetaRelease Method

[image]
Intersoft WebDesktop Documentation
IsBetaRelease Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : IsBetaRelease Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsBetaRelease() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As Boolean

value = instance.IsBetaRelease()
C#
public bool IsBetaRelease()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


IsChromeBrowser Method

[image]
Intersoft WebDesktop Documentation
IsChromeBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : IsChromeBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsChromeBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As Boolean

value = instance.IsChromeBrowser()
C#
public bool IsChromeBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


IsFlyPostBackControl Method

[image]
Intersoft WebDesktop Documentation
IsFlyPostBackControl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : IsFlyPostBackControl Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackControl() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As Boolean

value = instance.IsFlyPostBackControl()
C#
public virtual bool IsFlyPostBackControl()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


IsFlyPostBackRequest Method

[image]
Intersoft WebDesktop Documentation
IsFlyPostBackRequest Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : IsFlyPostBackRequest Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackRequest() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As Boolean

value = instance.IsFlyPostBackRequest()
C#
public virtual bool IsFlyPostBackRequest()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


IsGeckoBasedBrowser Method

[image]
Intersoft WebDesktop Documentation
IsGeckoBasedBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : IsGeckoBasedBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoBasedBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As Boolean

value = instance.IsGeckoBasedBrowser()
C#
public bool IsGeckoBasedBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


IsGeckoVersion18 Method

[image]
Intersoft WebDesktop Documentation
IsGeckoVersion18 Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : IsGeckoVersion18 Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoVersion18() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As Boolean

value = instance.IsGeckoVersion18()
C#
public bool IsGeckoVersion18()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


IsInDesignMode Method

[image]
Intersoft WebDesktop Documentation
IsInDesignMode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : IsInDesignMode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInDesignMode() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As Boolean

value = instance.IsInDesignMode()
C#
public bool IsInDesignMode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


IsInternetExplorer8Browser Method

[image]
Intersoft WebDesktop Documentation
IsInternetExplorer8Browser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : IsInternetExplorer8Browser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorer8Browser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As Boolean

value = instance.IsInternetExplorer8Browser()
C#
public bool IsInternetExplorer8Browser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


IsInternetExplorerBrowser Method

[image]
Intersoft WebDesktop Documentation
IsInternetExplorerBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : IsInternetExplorerBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorerBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As Boolean

value = instance.IsInternetExplorerBrowser()
C#
public bool IsInternetExplorerBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


IsOperaBrowser Method

[image]
Intersoft WebDesktop Documentation
IsOperaBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : IsOperaBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsOperaBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As Boolean

value = instance.IsOperaBrowser()
C#
public bool IsOperaBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


IsSafariBrowser Method

[image]
Intersoft WebDesktop Documentation
IsSafariBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : IsSafariBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsSafariBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As Boolean

value = instance.IsSafariBrowser()
C#
public bool IsSafariBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


IsW3CStandardBrowser Method

[image]
Intersoft WebDesktop Documentation
IsW3CStandardBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : IsW3CStandardBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsW3CStandardBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As Boolean

value = instance.IsW3CStandardBrowser()
C#
public bool IsW3CStandardBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


LoadLayout Method

[image]
Intersoft WebDesktop Documentation
LoadLayout Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : LoadLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim settings As ISNet.WebUI.LayoutInfo

instance.LoadLayout(settings)
C#
public virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


LoadLayoutFromFile Method

[image]
Intersoft WebDesktop Documentation
LoadLayoutFromFile Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : LoadLayoutFromFile Method

filePath

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromFile( _
   ByVal filePath As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim filePath As String

instance.LoadLayoutFromFile(filePath)
C#
public virtual void LoadLayoutFromFile(
   string filePath
)

Parameters

filePath

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


LoadLayoutFromPredefinedName Method

[image]
Intersoft WebDesktop Documentation
LoadLayoutFromPredefinedName Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : LoadLayoutFromPredefinedName Method

predefinedName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromPredefinedName( _
   ByVal predefinedName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim predefinedName As String

instance.LoadLayoutFromPredefinedName(predefinedName)
C#
public virtual void LoadLayoutFromPredefinedName(
   string predefinedName
)

Parameters

predefinedName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


LoadLayoutFromStream Method

[image]
Intersoft WebDesktop Documentation
LoadLayoutFromStream Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : LoadLayoutFromStream Method

stream

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromStream( _
   ByVal stream As System.IO.Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim stream As System.IO.Stream

instance.LoadLayoutFromStream(stream)
C#
public virtual void LoadLayoutFromStream(
   System.IO.Stream stream
)

Parameters

stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


MergeStyle Method

[image]
Intersoft WebDesktop Documentation
MergeStyle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : MergeStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub MergeStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim s As System.Web.UI.WebControls.Style

instance.MergeStyle(s)
C#
public void MergeStyle(
   System.Web.UI.WebControls.Style s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


OnDragDrop Method

[image]
Intersoft WebDesktop Documentation
OnDragDrop Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : OnDragDrop Method

dragControl
Gets the ISDragableObject instance, which is the object being dragged by the user.
data
Gets or sets the data associated with a drag control.
effect
Gets or sets the default effect associated with a drag control.
effectText
Gets or sets the effect text (tool tip) that will be displayed when the drag control is over a valid drop target.
keyState
Gets or sets the key state in the current context of drag operation. Key state can be combination of Ctrl, Alt, and Shift.
allowedEffects
Gets or sets the allowed effects specified in DragSettings.AllowedEffects of the WebDragDropExtender control.
x
Gets the X point of mouse cursor relative to the document.
y
Gets the Y point of mouse cursor relative to the document.

Glossary Item Box

Gets or sets the javascript function to be invoked when a valid drag source is dropped to a valid drop target.

Syntax

Visual Basic (Declaration)
Public Overridable Function OnDragDrop( _
   ByVal dragControl As WebDragControl, _
   ByVal data As Object, _
   ByVal effect As SpecificDragObjectEffects, _
   ByVal effectText As String, _
   ByVal keyState As Integer, _
   ByVal allowedEffects As DragDropEffects, _
   ByVal x As Integer, _
   ByVal y As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim dragControl As WebDragControl
Dim data As Object
Dim effect As SpecificDragObjectEffects
Dim effectText As String
Dim keyState As Integer
Dim allowedEffects As DragDropEffects
Dim x As Integer
Dim y As Integer
Dim value As Boolean

value = instance.OnDragDrop(dragControl, data, effect, effectText, keyState, allowedEffects, x, y)
C#
public virtual bool OnDragDrop(
   WebDragControl dragControl,
   object data,
   SpecificDragObjectEffects effect,
   string effectText,
   int keyState,
   DragDropEffects allowedEffects,
   int x,
   int y
)

Parameters

dragControl
Gets the ISDragableObject instance, which is the object being dragged by the user.
data
Gets or sets the data associated with a drag control.
effect
Gets or sets the default effect associated with a drag control.
effectText
Gets or sets the effect text (tool tip) that will be displayed when the drag control is over a valid drop target.
keyState
Gets or sets the key state in the current context of drag operation. Key state can be combination of Ctrl, Alt, and Shift.
allowedEffects
Gets or sets the allowed effects specified in DragSettings.AllowedEffects of the WebDragDropExtender control.
x
Gets the X point of mouse cursor relative to the document.
y
Gets the Y point of mouse cursor relative to the document.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


OnInfoChanged Method

[image]
Intersoft WebDesktop Documentation
OnInfoChanged Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : OnInfoChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnInfoChanged( _
   ByVal e As ISNet.WebUI.SynchronizeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim e As ISNet.WebUI.SynchronizeEventArgs

instance.OnInfoChanged(e)
C#
public void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


OnPreInitialize Method

[image]
Intersoft WebDesktop Documentation
OnPreInitialize Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : OnPreInitialize Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnPreInitialize()
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender

instance.OnPreInitialize()
C#
public virtual void OnPreInitialize()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


RaisePostDataChangedEvent Method

[image]
Intersoft WebDesktop Documentation
RaisePostDataChangedEvent Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : RaisePostDataChangedEvent Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RaisePostDataChangedEvent()
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender

instance.RaisePostDataChangedEvent()
C#
public virtual void RaisePostDataChangedEvent()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


ReadWebConfigValue Method

[image]
Intersoft WebDesktop Documentation
ReadWebConfigValue Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : ReadWebConfigValue Method

key

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ReadWebConfigValue( _
   ByVal key As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim key As String
Dim value As String

value = instance.ReadWebConfigValue(key)
C#
public string ReadWebConfigValue(
   string key
)

Parameters

key

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


RegisterBoxSizing Method

[image]
Intersoft WebDesktop Documentation
RegisterBoxSizing Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : RegisterBoxSizing Method

Glossary Item Box

Overload List

Overload | Description
RegisterBoxSizing() | (Inherited from ISNet.WebUI.ISNetControl)
RegisterBoxSizing(Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


RegisterBoxSizing() Method

[image]
Intersoft WebDesktop Documentation
RegisterBoxSizing() Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class > RegisterBoxSizing Method : RegisterBoxSizing() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing()
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender

instance.RegisterBoxSizing()
C#
public void RegisterBoxSizing()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members
Overload List


RegisterBoxSizing(Boolean) Method

[image]
Intersoft WebDesktop Documentation
RegisterBoxSizing(Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class > RegisterBoxSizing Method : RegisterBoxSizing(Boolean) Method

forceAll

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing( _
   ByVal forceAll As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim forceAll As Boolean

instance.RegisterBoxSizing(forceAll)
C#
public void RegisterBoxSizing(
   bool forceAll
)

Parameters

forceAll

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members
Overload List


RegisterGlobalStyle Method

[image]
Intersoft WebDesktop Documentation
RegisterGlobalStyle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : RegisterGlobalStyle Method

style

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterGlobalStyle( _
   ByVal style As ISNet.WebUI.WebStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim style As ISNet.WebUI.WebStyle

instance.RegisterGlobalStyle(style)
C#
public void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle style
)

Parameters

style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


RegisterLink Method

[image]
Intersoft WebDesktop Documentation
RegisterLink Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : RegisterLink Method

name
url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterLink( _
   ByVal name As String, _
   ByVal url As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim name As String
Dim url As String

instance.RegisterLink(name, url)
C#
public void RegisterLink(
   string name,
   string url
)

Parameters

name
url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


RegisterOptimizedCssClasses Method

[image]
Intersoft WebDesktop Documentation
RegisterOptimizedCssClasses Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : RegisterOptimizedCssClasses Method

runtimeStyleOnly

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterOptimizedCssClasses( _
   ByVal runtimeStyleOnly As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim runtimeStyleOnly As Boolean

instance.RegisterOptimizedCssClasses(runtimeStyleOnly)
C#
public void RegisterOptimizedCssClasses(
   bool runtimeStyleOnly
)

Parameters

runtimeStyleOnly

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


RegisterPreloadImage Method

[image]
Intersoft WebDesktop Documentation
RegisterPreloadImage Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : RegisterPreloadImage Method

image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterPreloadImage( _
   ByVal image As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim image As String

instance.RegisterPreloadImage(image)
C#
public void RegisterPreloadImage(
   string image
)

Parameters

image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


RegisterSharePointHandler Method

[image]
Intersoft WebDesktop Documentation
RegisterSharePointHandler Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : RegisterSharePointHandler Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RegisterSharePointHandler()
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender

instance.RegisterSharePointHandler()
C#
public virtual void RegisterSharePointHandler()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


RenderBeginTag Method

[image]
Intersoft WebDesktop Documentation
RenderBeginTag Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : RenderBeginTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderBeginTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderBeginTag(writer)
C#
public virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


RenderControl Method

[image]
Intersoft WebDesktop Documentation
RenderControl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : RenderControl Method

Glossary Item Box

Overload List

Overload | Description
RenderControl | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


RenderControl(HtmlTextWriter) Method

[image]
Intersoft WebDesktop Documentation
RenderControl(HtmlTextWriter) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : RenderControl(HtmlTextWriter) Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderControl( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderControl(writer)
C#
public virtual void RenderControl(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


ResolveClientUrl Method

[image]
Intersoft WebDesktop Documentation
ResolveClientUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : ResolveClientUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveClientUrl( _
   ByVal relativeUrl As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim relativeUrl As String
Dim value As String

value = instance.ResolveClientUrl(relativeUrl)
C#
public string ResolveClientUrl(
   string relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


ResolveImagePath Method

[image]
Intersoft WebDesktop Documentation
ResolveImagePath Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : ResolveImagePath Method

folder
image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveImagePath( _
   ByVal folder As String, _
   ByVal image As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim folder As String
Dim image As String
Dim value As String

value = instance.ResolveImagePath(folder, image)
C#
public string ResolveImagePath(
   string folder,
   string image
)

Parameters

folder
image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


ResolveRelativeURL Method

[image]
Intersoft WebDesktop Documentation
ResolveRelativeURL Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : ResolveRelativeURL Method

url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ResolveRelativeURL( _
   ByVal url As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim url As String
Dim value As String

value = instance.ResolveRelativeURL(url)
C#
public virtual string ResolveRelativeURL(
   string url
)

Parameters

url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


ResolveResourceUrl Method

[image]
Intersoft WebDesktop Documentation
ResolveResourceUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : ResolveResourceUrl Method

kind
defaultFolder
currentFolder
resourceName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveResourceUrl( _
   ByVal kind As ISNet.WebUI.ResourceKind, _
   ByVal defaultFolder As String, _
   ByVal currentFolder As String, _
   ByVal resourceName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim kind As ISNet.WebUI.ResourceKind
Dim defaultFolder As String
Dim currentFolder As String
Dim resourceName As String
Dim value As String

value = instance.ResolveResourceUrl(kind, defaultFolder, currentFolder, resourceName)
C#
public string ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   string defaultFolder,
   string currentFolder,
   string resourceName
)

Parameters

kind
defaultFolder
currentFolder
resourceName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


ResolveUrl Method

[image]
Intersoft WebDesktop Documentation
ResolveUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : ResolveUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveUrl( _
   ByVal relativeUrl As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim relativeUrl As String
Dim value As String

value = instance.ResolveUrl(relativeUrl)
C#
public string ResolveUrl(
   string relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


SaveLayout Method

[image]
Intersoft WebDesktop Documentation
SaveLayout Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : SaveLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim settings As ISNet.WebUI.LayoutInfo

instance.SaveLayout(settings)
C#
public virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


SaveLayoutToFile Method

[image]
Intersoft WebDesktop Documentation
SaveLayoutToFile Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : SaveLayoutToFile Method

filePath
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToFile( _
   ByVal filePath As String, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim filePath As String
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToFile(filePath, saveOptions)
C#
public virtual void SaveLayoutToFile(
   string filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

filePath
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


SaveLayoutToStream Method

[image]
Intersoft WebDesktop Documentation
SaveLayoutToStream Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : SaveLayoutToStream Method

stream
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToStream( _
   ByVal stream As System.IO.Stream, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim stream As System.IO.Stream
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToStream(stream, saveOptions)
C#
public virtual void SaveLayoutToStream(
   System.IO.Stream stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

stream
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


SetRenderMethodDelegate Method

[image]
Intersoft WebDesktop Documentation
SetRenderMethodDelegate Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : SetRenderMethodDelegate Method

renderMethod

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetRenderMethodDelegate( _
   ByVal renderMethod As System.Web.UI.RenderMethod _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim renderMethod As System.Web.UI.RenderMethod

instance.SetRenderMethodDelegate(renderMethod)
C#
public void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod renderMethod
)

Parameters

renderMethod

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


SetSessionTheme Method

[image]
Intersoft WebDesktop Documentation
SetSessionTheme Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : SetSessionTheme Method

themeInfo

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetSessionTheme( _
   ByVal themeInfo As ISNet.WebUI.ThemeInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim themeInfo As ISNet.WebUI.ThemeInfo

instance.SetSessionTheme(themeInfo)
C#
public void SetSessionTheme(
   ISNet.WebUI.ThemeInfo themeInfo
)

Parameters

themeInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


ShouldReturnJson Method

[image]
Intersoft WebDesktop Documentation
ShouldReturnJson Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : ShouldReturnJson Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ShouldReturnJson() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As Boolean

value = instance.ShouldReturnJson()
C#
public virtual bool ShouldReturnJson()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


ClientIDMode Property

[image]
Intersoft WebDesktop Documentation
ClientIDMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : ClientIDMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ClientIDMode As System.Web.UI.ClientIDMode
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As System.Web.UI.ClientIDMode

instance.ClientIDMode = value

value = instance.ClientIDMode
C#
public virtual System.Web.UI.ClientIDMode ClientIDMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


WebDragDropExtender Class Properties

[image]
Intersoft WebDesktop Documentation
WebDragDropExtender Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDragDropExtender Class

Glossary Item Box

For a list of all members of this type, see WebDragDropExtender members.

Public Properties

 | Name | Description
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ClientSideEvents | Contains client-side event for drag drop operation.
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | DragControls | Gets or sets the collection of drag-able controls.
Public Property | DragSettings | Contains drag operation settings.
Public Property | DropControls | Gets or sets the collection of drop-able controls.
Public Property | DropSettings | Contains drop operation settings.
Public Property | Enabled | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableManagedTheming | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableViewState | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | FlyPostBackSettings | Configures the settings used by the control when performing OnTheFly postback.
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ImagesDirectory | Gets or sets the image location that store drag effects and indicators.
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden. Gets or sets the script location of WebDragDropExtender.
Public Property | SharedScriptDirectory | Overridden.
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateItems | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | XmlCompressionEnabled | (Inherited from ISNet.WebUI.ISNetControl)
Top

See Also

Reference

WebDragDropExtender Class
ISNet.WebUI.WebDesktop Namespace


WebDragDropExtender Constructor

[image]
Intersoft WebDesktop Documentation
WebDragDropExtender Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : WebDragDropExtender Constructor

Glossary Item Box

Initializes a new instance of the WebDragDropExtender class with no argument.

Overload List

Overload | Description
WebDragDropExtender Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


ClientSideEvents Property

[image]
Intersoft WebDesktop Documentation
ClientSideEvents Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : ClientSideEvents Property

Glossary Item Box

Contains client-side event for drag drop operation.

Syntax

Visual Basic (Declaration)
Public Property ClientSideEvents As WebDragDropClientSideEvents
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As WebDragDropClientSideEvents

instance.ClientSideEvents = value

value = instance.ClientSideEvents
C#
public WebDragDropClientSideEvents ClientSideEvents {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


ControlDataTransferFormat Property

[image]
Intersoft WebDesktop Documentation
ControlDataTransferFormat Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : ControlDataTransferFormat Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ControlDataTransferFormat As ISNet.WebUI.DataTransferFormat
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As ISNet.WebUI.DataTransferFormat

instance.ControlDataTransferFormat = value

value = instance.ControlDataTransferFormat
C#
public virtual ISNet.WebUI.DataTransferFormat ControlDataTransferFormat {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


DragControls Property

[image]
Intersoft WebDesktop Documentation
DragControls Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : DragControls Property

Glossary Item Box

Gets or sets the collection of drag-able controls.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DragControls As System.Collections.ObjectModel.Collection(Of WebDragControl)
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As System.Collections.ObjectModel.Collection(Of WebDragControl)

value = instance.DragControls
C#
public System.Collections.ObjectModel.Collection<WebDragControl> DragControls {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


DragSettings Property

[image]
Intersoft WebDesktop Documentation
DragSettings Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : DragSettings Property

Glossary Item Box

Contains drag operation settings.

Syntax

Visual Basic (Declaration)
Public Property DragSettings As WebDragSettings
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As WebDragSettings

instance.DragSettings = value

value = instance.DragSettings
C#
public WebDragSettings DragSettings {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


DropControls Property

[image]
Intersoft WebDesktop Documentation
DropControls Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : DropControls Property

Glossary Item Box

Gets or sets the collection of drop-able controls.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DropControls As System.Collections.ObjectModel.Collection(Of WebDropControl)
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As System.Collections.ObjectModel.Collection(Of WebDropControl)

value = instance.DropControls
C#
public System.Collections.ObjectModel.Collection<WebDropControl> DropControls {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


DropSettings Property

[image]
Intersoft WebDesktop Documentation
DropSettings Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : DropSettings Property

Glossary Item Box

Contains drop operation settings.

Syntax

Visual Basic (Declaration)
Public Property DropSettings As WebDropSettings
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As WebDropSettings

instance.DropSettings = value

value = instance.DropSettings
C#
public WebDropSettings DropSettings {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


Enabled Property

[image]
Intersoft WebDesktop Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : Enabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Enabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As Boolean

instance.Enabled = value

value = instance.Enabled
C#
public virtual bool Enabled {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


EnableManagedTheming Property

[image]
Intersoft WebDesktop Documentation
EnableManagedTheming Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : EnableManagedTheming Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property EnableManagedTheming As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As Boolean

instance.EnableManagedTheming = value

value = instance.EnableManagedTheming
C#
public virtual bool EnableManagedTheming {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


EnableViewState Property

[image]
Intersoft WebDesktop Documentation
EnableViewState Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : EnableViewState Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property EnableViewState As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As Boolean

instance.EnableViewState = value

value = instance.EnableViewState
C#
public virtual bool EnableViewState {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


EnableWebResources Property

[image]
Intersoft WebDesktop Documentation
EnableWebResources Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : EnableWebResources Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property EnableWebResources As ISNet.WebUI.WebResourceType
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As ISNet.WebUI.WebResourceType

instance.EnableWebResources = value

value = instance.EnableWebResources
C#
public ISNet.WebUI.WebResourceType EnableWebResources {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


FlyPostBackSettings Property

[image]
Intersoft WebDesktop Documentation
FlyPostBackSettings Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : FlyPostBackSettings Property

Glossary Item Box

Configures the settings used by the control when performing OnTheFly postback.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FlyPostBackSettings As ISNet.WebUI.FlyPostBackSettings
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As ISNet.WebUI.FlyPostBackSettings

value = instance.FlyPostBackSettings
C#
public ISNet.WebUI.FlyPostBackSettings FlyPostBackSettings {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


ID Property

[image]
Intersoft WebDesktop Documentation
ID Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : ID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ID As String
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As String

instance.ID = value

value = instance.ID
C#
public virtual string ID {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


ImagesDirectory Property

[image]
Intersoft WebDesktop Documentation
ImagesDirectory Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : ImagesDirectory Property

Glossary Item Box

Gets or sets the image location that store drag effects and indicators.

Syntax

Visual Basic (Declaration)
Public Property ImagesDirectory As String
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As String

instance.ImagesDirectory = value

value = instance.ImagesDirectory
C#
public string ImagesDirectory {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


Page Property

[image]
Intersoft WebDesktop Documentation
Page Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : Page Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Page As System.Web.UI.Page
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As System.Web.UI.Page

instance.Page = value

value = instance.Page
C#
public virtual System.Web.UI.Page Page {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


RenderingMode Property

[image]
Intersoft WebDesktop Documentation
RenderingMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : RenderingMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property RenderingMode As ISNet.WebUI.RenderMode
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As ISNet.WebUI.RenderMode

instance.RenderingMode = value

value = instance.RenderingMode
C#
public virtual ISNet.WebUI.RenderMode RenderingMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


RuntimeLicenseKey Property

[image]
Intersoft WebDesktop Documentation
RuntimeLicenseKey Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : RuntimeLicenseKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property RuntimeLicenseKey As String
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As String

instance.RuntimeLicenseKey = value

value = instance.RuntimeLicenseKey
C#
public virtual string RuntimeLicenseKey {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


ScriptDirectory Property

[image]
Intersoft WebDesktop Documentation
ScriptDirectory Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : ScriptDirectory Property

Glossary Item Box

Gets or sets the script location of WebDragDropExtender.

Syntax

Visual Basic (Declaration)
Public Overrides Property ScriptDirectory As String
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As String

instance.ScriptDirectory = value

value = instance.ScriptDirectory
C#
public override string ScriptDirectory {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


SharedScriptDirectory Property

[image]
Intersoft WebDesktop Documentation
SharedScriptDirectory Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : SharedScriptDirectory Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Property SharedScriptDirectory As String
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As String

instance.SharedScriptDirectory = value

value = instance.SharedScriptDirectory
C#
public override string SharedScriptDirectory {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


ValidateRequestMode Property

[image]
Intersoft WebDesktop Documentation
ValidateRequestMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : ValidateRequestMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ValidateRequestMode As System.Web.UI.ValidateRequestMode
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As System.Web.UI.ValidateRequestMode

instance.ValidateRequestMode = value

value = instance.ValidateRequestMode
C#
public virtual System.Web.UI.ValidateRequestMode ValidateRequestMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


ViewStateItems Property

[image]
Intersoft WebDesktop Documentation
ViewStateItems Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : ViewStateItems Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateItems As ISNet.WebUI.ViewStateItem
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As ISNet.WebUI.ViewStateItem

instance.ViewStateItems = value

value = instance.ViewStateItems
C#
public virtual ISNet.WebUI.ViewStateItem ViewStateItems {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


ViewStateMode Property

[image]
Intersoft WebDesktop Documentation
ViewStateMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : ViewStateMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateMode As System.Web.UI.ViewStateMode
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As System.Web.UI.ViewStateMode

instance.ViewStateMode = value

value = instance.ViewStateMode
C#
public virtual System.Web.UI.ViewStateMode ViewStateMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


ViewStateServerConnection Property

[image]
Intersoft WebDesktop Documentation
ViewStateServerConnection Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : ViewStateServerConnection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateServerConnection As String
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As String

instance.ViewStateServerConnection = value

value = instance.ViewStateServerConnection
C#
public virtual string ViewStateServerConnection {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


ViewStateStorage Property

[image]
Intersoft WebDesktop Documentation
ViewStateStorage Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : ViewStateStorage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateStorage As ISNet.WebUI.StateCacheStorage
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As ISNet.WebUI.StateCacheStorage

instance.ViewStateStorage = value

value = instance.ViewStateStorage
C#
public virtual ISNet.WebUI.StateCacheStorage ViewStateStorage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


Visible Property

[image]
Intersoft WebDesktop Documentation
Visible Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : Visible Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public virtual bool Visible {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


XmlCompressionEnabled Property

[image]
Intersoft WebDesktop Documentation
XmlCompressionEnabled Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : XmlCompressionEnabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property XmlCompressionEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim value As Boolean

instance.XmlCompressionEnabled = value

value = instance.XmlCompressionEnabled
C#
public virtual bool XmlCompressionEnabled {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


DataBinding Event

[image]
Intersoft WebDesktop Documentation
DataBinding Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : DataBinding Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event DataBinding As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim handler As EventHandler

AddHandler instance.DataBinding, handler
C#
public event EventHandler DataBinding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


Disposed Event

[image]
Intersoft WebDesktop Documentation
Disposed Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim handler As EventHandler

AddHandler instance.Disposed, handler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


WebDragDropExtender Class Events

[image]
Intersoft WebDesktop Documentation
WebDragDropExtender Class Events
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDragDropExtender Class

Glossary Item Box

For a list of all members of this type, see WebDragDropExtender members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | DragDrop | Fires when a drag and drop operation has been performed successfully.
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebDragDropExtender Class
ISNet.WebUI.WebDesktop Namespace


DragDrop Event

[image]
Intersoft WebDesktop Documentation
DragDrop Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : DragDrop Event

Glossary Item Box

Fires when a drag and drop operation has been performed successfully.

Syntax

Visual Basic (Declaration)
Public Event DragDrop As EventHandler(Of WebDragDropEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim handler As EventHandler(Of WebDragDropEventArgs)

AddHandler instance.DragDrop, handler
C#
public event EventHandler<WebDragDropEventArgs> DragDrop

Event Data

The event handler receives an argument of type WebDragDropEventArgs containing data related to this event. The following WebDragDropEventArgs properties provide information specific to this event.

Property | Description
AllowedEffects | Specifies the allowed effects of a drag operation.
Data | Specifies the data associated with a drag control.
DragControl | Gets or sets the collection of drag-able controls.
Effect | Specifies the effect which applies to the drop object during drag drop operation.
EffectText | Gets or sets the displayed text when a valid drag object is hovered on this drop control.
KeyState | Gets and sets the key state in the current context of drag operation. Key state can be combination of Ctrl, Alt, and Shift.
X | Gets the X point of mouse cursor relative to the document.
Y | Gets the Y point of mouse cursor relative to the document.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


Init Event

[image]
Intersoft WebDesktop Documentation
Init Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : Init Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Init As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim handler As EventHandler

AddHandler instance.Init, handler
C#
public event EventHandler Init

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


Load Event

[image]
Intersoft WebDesktop Documentation
Load Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : Load Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Load As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim handler As EventHandler

AddHandler instance.Load, handler
C#
public event EventHandler Load

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


PreInitialize Event

[image]
Intersoft WebDesktop Documentation
PreInitialize Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : PreInitialize Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event PreInitialize As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim handler As EventHandler

AddHandler instance.PreInitialize, handler
C#
public event EventHandler PreInitialize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


PreRender Event

[image]
Intersoft WebDesktop Documentation
PreRender Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : PreRender Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event PreRender As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim handler As EventHandler

AddHandler instance.PreRender, handler
C#
public event EventHandler PreRender

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


Unload Event

[image]
Intersoft WebDesktop Documentation
Unload Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragDropExtender Class : Unload Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Unload As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebDragDropExtender
Dim handler As EventHandler

AddHandler instance.Unload, handler
C#
public event EventHandler Unload

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragDropExtender Class
WebDragDropExtender Members


WebDragSettings Class

[image]
Intersoft WebDesktop Documentation
WebDragSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDragSettings Class

Glossary Item Box

Contains a collection of properties controlling the drag-operation

settings.

Object Model

WebDragSettings Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class WebDragSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer
Visual Basic (Usage) Copy Code
Dim instance As WebDragSettings
C#
public sealed class WebDragSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebDesktop.WebDragSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragSettings Members
ISNet.WebUI.WebDesktop Namespace


WebDragSettings Class Members

[image]
Intersoft WebDesktop Documentation
WebDragSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDragSettings Class

Glossary Item Box

The following tables list the members exposed by WebDragSettings.

Public Constructors

 | Name | Description
Public Constructor | WebDragSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | AllowCrossIFrame | Specifies the behavior when a drag operation crosses IFrame element under Web page.
Public Property | AllowedEffects | Specifies the allowed effects of a drag operation.
Public Property | DefaultEffect | Gets or sets the default effect which applies to valid drop object during a drag drop operation.
Public Property | DefaultEffectText | Gets or sets the default displayed text when a valid drag object is hovered on this drop control.
Public Property | DragVisualHint | Specifies the visual effect displayed during drag operation.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebDragSettings Class
ISNet.WebUI.WebDesktop Namespace


WebDragSettings Class Methods

[image]
Intersoft WebDesktop Documentation
WebDragSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDragSettings Class

Glossary Item Box

For a list of all members of this type, see WebDragSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebDragSettings Class
ISNet.WebUI.WebDesktop Namespace


WebDragSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebDragSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragSettings Class : WebDragSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebDragSettings()
C#
public WebDragSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragSettings Class
WebDragSettings Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebDragSettings
Dim value As Object

value = instance.Clone()
C#
public object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragSettings Class
WebDragSettings Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragSettings Class
WebDragSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDragSettings
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragSettings Class
WebDragSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDragSettings
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragSettings Class
WebDragSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDragSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragSettings Class
WebDragSettings Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebDragSettings
Dim value As Integer

value = instance.GetHashCode()
C#
public int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragSettings Class
WebDragSettings Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDragSettings
Dim value As Boolean

value = instance.IsEmpty()
C#
public bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragSettings Class
WebDragSettings Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebDragSettings

instance.Reset()
C#
public void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragSettings Class
WebDragSettings Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDragSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragSettings Class
WebDragSettings Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebDragSettings
Dim value As String

value = instance.ToString()
C#
public string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragSettings Class
WebDragSettings Members


WebDragSettings Class Properties

[image]
Intersoft WebDesktop Documentation
WebDragSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDragSettings Class

Glossary Item Box

For a list of all members of this type, see WebDragSettings members.

Public Properties

 | Name | Description
Public Property | AllowCrossIFrame | Specifies the behavior when a drag operation crosses IFrame element under Web page.
Public Property | AllowedEffects | Specifies the allowed effects of a drag operation.
Public Property | DefaultEffect | Gets or sets the default effect which applies to valid drop object during a drag drop operation.
Public Property | DefaultEffectText | Gets or sets the default displayed text when a valid drag object is hovered on this drop control.
Public Property | DragVisualHint | Specifies the visual effect displayed during drag operation.
Top

See Also

Reference

WebDragSettings Class
ISNet.WebUI.WebDesktop Namespace


WebDragSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebDragSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragSettings Class : WebDragSettings Constructor

Glossary Item Box

Initializes a new instance of the WebDragSettings class with no argument.

Overload List

Overload | Description
WebDragSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragSettings Class
WebDragSettings Members


AllowCrossIFrame Property

[image]
Intersoft WebDesktop Documentation
AllowCrossIFrame Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragSettings Class : AllowCrossIFrame Property

Glossary Item Box

Specifies the behavior when a drag operation crosses IFrame element under Web page.

Syntax

Visual Basic (Declaration)
Public Property AllowCrossIFrame As CrossIFrameMode
Visual Basic (Usage) Copy Code
Dim instance As WebDragSettings
Dim value As CrossIFrameMode

instance.AllowCrossIFrame = value

value = instance.AllowCrossIFrame
C#
public CrossIFrameMode AllowCrossIFrame {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragSettings Class
WebDragSettings Members


AllowedEffects Property

[image]
Intersoft WebDesktop Documentation
AllowedEffects Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragSettings Class : AllowedEffects Property

Glossary Item Box

Specifies the allowed effects of a drag operation.

Syntax

Visual Basic (Declaration)
Public Property AllowedEffects As DragDropEffects
Visual Basic (Usage) Copy Code
Dim instance As WebDragSettings
Dim value As DragDropEffects

instance.AllowedEffects = value

value = instance.AllowedEffects
C#
public DragDropEffects AllowedEffects {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragSettings Class
WebDragSettings Members


DefaultEffect Property

[image]
Intersoft WebDesktop Documentation
DefaultEffect Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragSettings Class : DefaultEffect Property

Glossary Item Box

Gets or sets the default effect which applies to valid drop object during a drag drop operation.

Syntax

Visual Basic (Declaration)
Public Property DefaultEffect As SpecificDragObjectEffects
Visual Basic (Usage) Copy Code
Dim instance As WebDragSettings
Dim value As SpecificDragObjectEffects

instance.DefaultEffect = value

value = instance.DefaultEffect
C#
public SpecificDragObjectEffects DefaultEffect {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragSettings Class
WebDragSettings Members


DefaultEffectText Property

[image]
Intersoft WebDesktop Documentation
DefaultEffectText Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragSettings Class : DefaultEffectText Property

Glossary Item Box

Gets or sets the default displayed text when a valid drag object is hovered on this drop control.

Syntax

Visual Basic (Declaration)
Public Property DefaultEffectText As String
Visual Basic (Usage) Copy Code
Dim instance As WebDragSettings
Dim value As String

instance.DefaultEffectText = value

value = instance.DefaultEffectText
C#
public string DefaultEffectText {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragSettings Class
WebDragSettings Members


DragVisualHint Property

[image]
Intersoft WebDesktop Documentation
DragVisualHint Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDragSettings Class : DragVisualHint Property

Glossary Item Box

Specifies the visual effect displayed during drag operation.

Syntax

Visual Basic (Declaration)
Public Property DragVisualHint As DragVisualHint
Visual Basic (Usage) Copy Code
Dim instance As WebDragSettings
Dim value As DragVisualHint

instance.DragVisualHint = value

value = instance.DragVisualHint
C#
public DragVisualHint DragVisualHint {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDragSettings Class
WebDragSettings Members


WebDropControl Class

[image]
Intersoft WebDesktop Documentation
WebDropControl Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDropControl Class

Glossary Item Box

Get or sets the collection of drop-able controls.

Object Model

WebDropControl Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class WebDropControl
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebDropControl
C#
public sealed class WebDropControl : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebDesktop.WebDropControl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDropControl Members
ISNet.WebUI.WebDesktop Namespace


WebDropControl Class Members

[image]
Intersoft WebDesktop Documentation
WebDropControl Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDropControl Class

Glossary Item Box

The following tables list the members exposed by WebDropControl.

Public Constructors

 | Name | Description
Public Constructor | WebDropControl Constructor |
Top

Public Properties

 | Name | Description
Public Property | AcceptDataType | Specifies the data type which is accepted by the drop control.
Public Property | AcceptDragSourceControls | Gets or sets the controls that can be accepted by this drop control. Use ";" as a separator when you want to include more that one control identifier.
Public Property | AdvancedProperties | Gets or sets the advanced properties for this drop control.
Public Property | AutoPostBackOnDragDrop | Determines whether postback should be automatically invoked upon a successful drag drop operation.
Public Property | ControlID | Gets or sets the drop-able control. (Able to accept drop object from a valid drag object during a drag drop operation).
Public Property | EnableCaching | Determines whether the drop control should be cached for performance reason.
Public Property | Enabled | Determines whether the drop behavior should be enabled for this control.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | Overrides ToString() method.
Top

See Also

Reference

WebDropControl Class
ISNet.WebUI.WebDesktop Namespace


WebDropControl Constructor

[image]
Intersoft WebDesktop Documentation
WebDropControl Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDropControl Class : WebDropControl Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebDropControl()
C#
public WebDropControl()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDropControl Class
WebDropControl Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDropControl Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebDropControl
Dim value As Object

value = instance.Clone()
C#
public object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDropControl Class
WebDropControl Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDropControl Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDropControl Class
WebDropControl Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDropControl Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDropControl
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDropControl Class
WebDropControl Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDropControl Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDropControl
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDropControl Class
WebDropControl Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDropControl Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDropControl
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDropControl Class
WebDropControl Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDropControl Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebDropControl
Dim value As Integer

value = instance.GetHashCode()
C#
public int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDropControl Class
WebDropControl Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDropControl Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDropControl
Dim value As Boolean

value = instance.IsEmpty()
C#
public bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDropControl Class
WebDropControl Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDropControl Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebDropControl

instance.Reset()
C#
public void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDropControl Class
WebDropControl Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDropControl Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDropControl
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDropControl Class
WebDropControl Members


WebDropControl Class Methods

[image]
Intersoft WebDesktop Documentation
WebDropControl Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDropControl Class

Glossary Item Box

For a list of all members of this type, see WebDropControl members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | Overrides ToString() method.
Top

See Also

Reference

WebDropControl Class
ISNet.WebUI.WebDesktop Namespace


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDropControl Class : ToString Method

Glossary Item Box

Overrides ToString() method.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebDropControl
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDropControl Class
WebDropControl Members


WebDropControl Class Properties

[image]
Intersoft WebDesktop Documentation
WebDropControl Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDropControl Class

Glossary Item Box

For a list of all members of this type, see WebDropControl members.

Public Properties

 | Name | Description
Public Property | AcceptDataType | Specifies the data type which is accepted by the drop control.
Public Property | AcceptDragSourceControls | Gets or sets the controls that can be accepted by this drop control. Use ";" as a separator when you want to include more that one control identifier.
Public Property | AdvancedProperties | Gets or sets the advanced properties for this drop control.
Public Property | AutoPostBackOnDragDrop | Determines whether postback should be automatically invoked upon a successful drag drop operation.
Public Property | ControlID | Gets or sets the drop-able control. (Able to accept drop object from a valid drag object during a drag drop operation).
Public Property | EnableCaching | Determines whether the drop control should be cached for performance reason.
Public Property | Enabled | Determines whether the drop behavior should be enabled for this control.
Top

See Also

Reference

WebDropControl Class
ISNet.WebUI.WebDesktop Namespace


WebDropControl Constructor

[image]
Intersoft WebDesktop Documentation
WebDropControl Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDropControl Class : WebDropControl Constructor

Glossary Item Box

Initializes a new instance of the WebDropControl class with no argument.

Overload List

Overload | Description
WebDropControl Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDropControl Class
WebDropControl Members


AcceptDataType Property

[image]
Intersoft WebDesktop Documentation
AcceptDataType Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDropControl Class : AcceptDataType Property

Glossary Item Box

Specifies the data type which is accepted by the drop control.

Syntax

Visual Basic (Declaration)
Public Property AcceptDataType As DragDataTypes
Visual Basic (Usage) Copy Code
Dim instance As WebDropControl
Dim value As DragDataTypes

instance.AcceptDataType = value

value = instance.AcceptDataType
C#
public DragDataTypes AcceptDataType {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDropControl Class
WebDropControl Members


AcceptDragSourceControls Property

[image]
Intersoft WebDesktop Documentation
AcceptDragSourceControls Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDropControl Class : AcceptDragSourceControls Property

Glossary Item Box

Gets or sets the controls that can be accepted by this drop control. Use ";" as a separator when you want to include more that one control identifier.

Syntax

Visual Basic (Declaration)
Public Property AcceptDragSourceControls As String
Visual Basic (Usage) Copy Code
Dim instance As WebDropControl
Dim value As String

instance.AcceptDragSourceControls = value

value = instance.AcceptDragSourceControls
C#
public string AcceptDragSourceControls {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDropControl Class
WebDropControl Members


AdvancedProperties Property

[image]
Intersoft WebDesktop Documentation
AdvancedProperties Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDropControl Class : AdvancedProperties Property

Glossary Item Box

Gets or sets the advanced properties for this drop control.

Syntax

Visual Basic (Declaration)
Public Property AdvancedProperties As String
Visual Basic (Usage) Copy Code
Dim instance As WebDropControl
Dim value As String

instance.AdvancedProperties = value

value = instance.AdvancedProperties
C#
public string AdvancedProperties {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDropControl Class
WebDropControl Members


AutoPostBackOnDragDrop Property

[image]
Intersoft WebDesktop Documentation
AutoPostBackOnDragDrop Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDropControl Class : AutoPostBackOnDragDrop Property

Glossary Item Box

Determines whether postback should be automatically invoked upon a successful drag drop operation.

Syntax

Visual Basic (Declaration)
Public Property AutoPostBackOnDragDrop As AutoPostBackMode
Visual Basic (Usage) Copy Code
Dim instance As WebDropControl
Dim value As AutoPostBackMode

instance.AutoPostBackOnDragDrop = value

value = instance.AutoPostBackOnDragDrop
C#
public AutoPostBackMode AutoPostBackOnDragDrop {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDropControl Class
WebDropControl Members


ControlID Property

[image]
Intersoft WebDesktop Documentation
ControlID Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDropControl Class : ControlID Property

Glossary Item Box

Gets or sets the drop-able control. (Able to accept drop object from a valid drag object during a drag drop operation).

Syntax

Visual Basic (Declaration)
Public Property ControlID As String
Visual Basic (Usage) Copy Code
Dim instance As WebDropControl
Dim value As String

instance.ControlID = value

value = instance.ControlID
C#
public string ControlID {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDropControl Class
WebDropControl Members


EnableCaching Property

[image]
Intersoft WebDesktop Documentation
EnableCaching Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDropControl Class : EnableCaching Property

Glossary Item Box

Determines whether the drop control should be cached for performance reason.

Syntax

Visual Basic (Declaration)
Public Property EnableCaching As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDropControl
Dim value As Boolean

instance.EnableCaching = value

value = instance.EnableCaching
C#
public bool EnableCaching {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDropControl Class
WebDropControl Members


Enabled Property

[image]
Intersoft WebDesktop Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDropControl Class : Enabled Property

Glossary Item Box

Determines whether the drop behavior should be enabled for this control.

Syntax

Visual Basic (Declaration)
Public Property Enabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDropControl
Dim value As Boolean

instance.Enabled = value

value = instance.Enabled
C#
public bool Enabled {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDropControl Class
WebDropControl Members


WebDropSettings Class

[image]
Intersoft WebDesktop Documentation
WebDropSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDropSettings Class

Glossary Item Box

Contains a collection of properties controlling the drop-operation settings.

Object Model

WebDropSettings Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class WebDropSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebDropSettings
C#
public sealed class WebDropSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebDesktop.WebDropSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDropSettings Members
ISNet.WebUI.WebDesktop Namespace


WebDropSettings Class Members

[image]
Intersoft WebDesktop Documentation
WebDropSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDropSettings Class

Glossary Item Box

The following tables list the members exposed by WebDropSettings.

Public Constructors

 | Name | Description
Public Constructor | WebDropSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | AcceptDataType | Specifies the data type that accepted by the drop control.
Public Property | AutoPostBackOnDragDrop | Determines whether postback should be automatically invoked upon successful drag drop operation.
Public Property | PostBackMode | Gets or sets the postback mode on drag drop operation when AutoPostBack is enabled.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebDropSettings Class
ISNet.WebUI.WebDesktop Namespace


WebDropSettings Class Methods

[image]
Intersoft WebDesktop Documentation
WebDropSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDropSettings Class

Glossary Item Box

For a list of all members of this type, see WebDropSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebDropSettings Class
ISNet.WebUI.WebDesktop Namespace


WebDropSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebDropSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDropSettings Class : WebDropSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebDropSettings()
C#
public WebDropSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDropSettings Class
WebDropSettings Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDropSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebDropSettings
Dim value As Object

value = instance.Clone()
C#
public object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDropSettings Class
WebDropSettings Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDropSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDropSettings Class
WebDropSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDropSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDropSettings
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDropSettings Class
WebDropSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDropSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDropSettings
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDropSettings Class
WebDropSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDropSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDropSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDropSettings Class
WebDropSettings Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDropSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebDropSettings
Dim value As Integer

value = instance.GetHashCode()
C#
public int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDropSettings Class
WebDropSettings Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDropSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebDropSettings
Dim value As Boolean

value = instance.IsEmpty()
C#
public bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDropSettings Class
WebDropSettings Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDropSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebDropSettings

instance.Reset()
C#
public void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDropSettings Class
WebDropSettings Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDropSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebDropSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDropSettings Class
WebDropSettings Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDropSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebDropSettings
Dim value As String

value = instance.ToString()
C#
public string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDropSettings Class
WebDropSettings Members


WebDropSettings Class Properties

[image]
Intersoft WebDesktop Documentation
WebDropSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebDropSettings Class

Glossary Item Box

For a list of all members of this type, see WebDropSettings members.

Public Properties

 | Name | Description
Public Property | AcceptDataType | Specifies the data type that accepted by the drop control.
Public Property | AutoPostBackOnDragDrop | Determines whether postback should be automatically invoked upon successful drag drop operation.
Public Property | PostBackMode | Gets or sets the postback mode on drag drop operation when AutoPostBack is enabled.
Top

See Also

Reference

WebDropSettings Class
ISNet.WebUI.WebDesktop Namespace


WebDropSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebDropSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDropSettings Class : WebDropSettings Constructor

Glossary Item Box

Initializes a new instance of the WebDropSettings class with no argument.

Overload List

Overload | Description
WebDropSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDropSettings Class
WebDropSettings Members


AcceptDataType Property

[image]
Intersoft WebDesktop Documentation
AcceptDataType Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDropSettings Class : AcceptDataType Property

Glossary Item Box

Specifies the data type that accepted by the drop control.

Syntax

Visual Basic (Declaration)
Public Property AcceptDataType As DragDataTypes
Visual Basic (Usage) Copy Code
Dim instance As WebDropSettings
Dim value As DragDataTypes

instance.AcceptDataType = value

value = instance.AcceptDataType
C#
public DragDataTypes AcceptDataType {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDropSettings Class
WebDropSettings Members


AutoPostBackOnDragDrop Property

[image]
Intersoft WebDesktop Documentation
AutoPostBackOnDragDrop Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDropSettings Class : AutoPostBackOnDragDrop Property

Glossary Item Box

Determines whether postback should be automatically invoked upon successful drag drop operation.

Syntax

Visual Basic (Declaration)
Public Property AutoPostBackOnDragDrop As AutoPostBackMode
Visual Basic (Usage) Copy Code
Dim instance As WebDropSettings
Dim value As AutoPostBackMode

instance.AutoPostBackOnDragDrop = value

value = instance.AutoPostBackOnDragDrop
C#
public AutoPostBackMode AutoPostBackOnDragDrop {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDropSettings Class
WebDropSettings Members


PostBackMode Property

[image]
Intersoft WebDesktop Documentation
PostBackMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebDropSettings Class : PostBackMode Property

Glossary Item Box

Gets or sets the postback mode on drag drop operation when AutoPostBack is enabled.

Syntax

Visual Basic (Declaration)
Public Property PostBackMode As PostbackMode
Visual Basic (Usage) Copy Code
Dim instance As WebDropSettings
Dim value As PostbackMode

instance.PostBackMode = value

value = instance.PostBackMode
C#
public PostbackMode PostBackMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDropSettings Class
WebDropSettings Members


WebExplorerBar Class

[image]
Intersoft WebDesktop Documentation
WebExplorerBar Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebExplorerBar Class

Glossary Item Box

Represents a pane or collection of panes in the WebExplorerPane.

Object Model

WebExplorerBar Class

Syntax

Visual Basic (Declaration)
Public Class WebExplorerBar
   Inherits WebNavBar
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBar
C#
public class WebExplorerBar : WebNavBar, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject

Remarks

WebExplorerBar can be constructed in either design-time or runtime. It may consist of one or more items called WebExplorerBarItem, which mainly used as navigation links.

By default, the WebExplorerBar will operate in UseItems mode (set the ContentMode property to UseItems). UseItems is the most suitable mode to simulate Desktop style of explorer pane as it is a collection based and support text and image rendering mode. For extensibility or customized content, you may set the ContentMode to UseInlineContent and put any kind of ASP.NET's server controls. Furthermore, you can also use UseIFrame ContentMode for better reusability. The ContentMode property can be found in WebPaneSettings which contains global configurations for WebExplorerBar (Pane). To learn more on WebExplorerBar you can read WebExplorer Concepts.

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase
ISNet.WebUI.WebDesktop.WebNavBar
ISNet.WebUI.WebDesktop.WebExplorerBar

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBar Members
ISNet.WebUI.WebDesktop Namespace

Tasks

Configuring Expand and Collapse ExplorePane

tasks

Show and hide ExplorerBar items
Changing Inline content of ExplorerPane

Concepts

WebExplorer Concepts


WebExplorerBar Class Members

[image]
Intersoft WebDesktop Documentation
WebExplorerBar Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebExplorerBar Class

Glossary Item Box

The following tables list the members exposed by WebExplorerBar.

Public Constructors

 | Name | Description
Public Constructor | WebExplorerBar Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | CaptionDisplayMode | Gets or sets the display mode of the Caption. (Inherited from ISNet.WebUI.WebDesktop.WebNavBar)
Public Property | Collapse | Overridden. Indicates whether the explorer bar is collapseable.
Public Property | ContentMode | Gets or sets the content mode of the NavBar. (Inherited from ISNet.WebUI.WebDesktop.WebNavBar)
Public Property | ContentURL | Overridden. Gets or sets the content URL od WebExplorerBar
Public Property | Enabled | Indicates whether the NavBar is enable. (Inherited from ISNet.WebUI.WebDesktop.WebNavBar)
Public Property | Image | Overridden. Gets or sets the default image of WebExplorerBar
Public Property | ImageHeight | Gets or sets the image height of the WebExplorerBar.
Public Property | ImageSize | Gets or sets the image size of the NavBar. (Inherited from ISNet.WebUI.WebDesktop.WebNavBar)
Public Property | ImagesSettings | Contains images settings such as images of expand/collapse but excluding to special WebExplorerBar.
Public Property | ItemSettings | Contains NavBarItem settings such as ItemStyle, Items PlaceholderStyle, DisplayMode and ImagePosition. (Inherited from ISNet.WebUI.WebDesktop.WebNavBar)
Public Property | Name | Gets or sets the name of NavBar. (Inherited from ISNet.WebUI.WebDesktop.WebNavBar)
Public Property | PaneItems | Gets or sets the collection of WebExplorerBarItem.
Public Property | Size | Gets or sets the size of the NavBar (in pixel size). (Inherited from ISNet.WebUI.WebDesktop.WebNavBar)
Public Property | Text | Overridden. Gets or sets text of WebExplorerBar.
Public Property | ToolTip | Gets or sets the tooltip of NavBar. (Inherited from ISNet.WebUI.WebDesktop.WebNavBar)
Public Property | Visible | Indicates whether the NavBar is visible. (Inherited from ISNet.WebUI.WebDesktop.WebNavBar)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebDesktop.WebNavBar)
Top

See Also

Reference

WebExplorerBar Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Configuring Expand and Collapse ExplorePane

tasks

Show and hide ExplorerBar items
Changing Inline content of ExplorerPane

Concepts

WebExplorer Concepts


WebExplorerBar Constructor

[image]
Intersoft WebDesktop Documentation
WebExplorerBar Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBar Class : WebExplorerBar Constructor

Glossary Item Box

Initializes a new instance of the WebExplorerBar class.

Overload List

Overload | Description
WebExplorerBar Constructor() | Initializes a new instance of the WebExplorerBar class with no argument.
WebExplorerBar Constructor(String) | Initializes a new instance of the WebExplorerBar class with Text parameter.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBar Class
WebExplorerBar Members


WebExplorerBar Constructor()

[image]
Intersoft WebDesktop Documentation
WebExplorerBar Constructor()
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBar Class > WebExplorerBar Constructor : WebExplorerBar Constructor()

Glossary Item Box

Initializes a new instance of the WebExplorerBar class with no argument.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebExplorerBar()
C#
public WebExplorerBar()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBar Class
WebExplorerBar Members
Overload List


WebExplorerBar Constructor(String)

[image]
Intersoft WebDesktop Documentation
WebExplorerBar Constructor(String)
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBar Class > WebExplorerBar Constructor : WebExplorerBar Constructor(String)

text

Glossary Item Box

Initializes a new instance of the WebExplorerBar class with Text parameter.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim text As String

Dim instance As New WebExplorerBar(text)
C#
public WebExplorerBar(
   string text
)

Parameters

text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBar Class
WebExplorerBar Members
Overload List


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBar Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBar
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBar Class
WebExplorerBar Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBar Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBar Class
WebExplorerBar Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBar Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBar
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBar Class
WebExplorerBar Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBar Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBar
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBar Class
WebExplorerBar Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBar Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBar
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBar Class
WebExplorerBar Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBar Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBar
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBar Class
WebExplorerBar Members


WebExplorerBar Class Methods

[image]
Intersoft WebDesktop Documentation
WebExplorerBar Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebExplorerBar Class

Glossary Item Box

For a list of all members of this type, see WebExplorerBar members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebDesktop.WebNavBar)
Top

See Also

Reference

WebExplorerBar Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Configuring Expand and Collapse ExplorePane

tasks

Show and hide ExplorerBar items
Changing Inline content of ExplorerPane

Concepts

WebExplorer Concepts


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBar Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBar
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBar Class
WebExplorerBar Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBar Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBar
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBar Class
WebExplorerBar Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBar Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBar

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBar Class
WebExplorerBar Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBar Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBar
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBar Class
WebExplorerBar Members


WebExplorerBar Class Properties

[image]
Intersoft WebDesktop Documentation
WebExplorerBar Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebExplorerBar Class

Glossary Item Box

For a list of all members of this type, see WebExplorerBar members.

Public Properties

 | Name | Description
Public Property | CaptionDisplayMode | Gets or sets the display mode of the Caption. (Inherited from ISNet.WebUI.WebDesktop.WebNavBar)
Public Property | Collapse | Overridden. Indicates whether the explorer bar is collapseable.
Public Property | ContentMode | Gets or sets the content mode of the NavBar. (Inherited from ISNet.WebUI.WebDesktop.WebNavBar)
Public Property | ContentURL | Overridden. Gets or sets the content URL od WebExplorerBar
Public Property | Enabled | Indicates whether the NavBar is enable. (Inherited from ISNet.WebUI.WebDesktop.WebNavBar)
Public Property | Image | Overridden. Gets or sets the default image of WebExplorerBar
Public Property | ImageHeight | Gets or sets the image height of the WebExplorerBar.
Public Property | ImageSize | Gets or sets the image size of the NavBar. (Inherited from ISNet.WebUI.WebDesktop.WebNavBar)
Public Property | ImagesSettings | Contains images settings such as images of expand/collapse but excluding to special WebExplorerBar.
Public Property | ItemSettings | Contains NavBarItem settings such as ItemStyle, Items PlaceholderStyle, DisplayMode and ImagePosition. (Inherited from ISNet.WebUI.WebDesktop.WebNavBar)
Public Property | Name | Gets or sets the name of NavBar. (Inherited from ISNet.WebUI.WebDesktop.WebNavBar)
Public Property | PaneItems | Gets or sets the collection of WebExplorerBarItem.
Public Property | Size | Gets or sets the size of the NavBar (in pixel size). (Inherited from ISNet.WebUI.WebDesktop.WebNavBar)
Public Property | Text | Overridden. Gets or sets text of WebExplorerBar.
Public Property | ToolTip | Gets or sets the tooltip of NavBar. (Inherited from ISNet.WebUI.WebDesktop.WebNavBar)
Public Property | Visible | Indicates whether the NavBar is visible. (Inherited from ISNet.WebUI.WebDesktop.WebNavBar)
Top

See Also

Reference

WebExplorerBar Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Configuring Expand and Collapse ExplorePane

tasks

Show and hide ExplorerBar items
Changing Inline content of ExplorerPane

Concepts

WebExplorer Concepts


Collapse Property

[image]
Intersoft WebDesktop Documentation
Collapse Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBar Class : Collapse Property

Glossary Item Box

Indicates whether the explorer bar is collapseable.

Syntax

Visual Basic (Declaration)
Public Overrides Property Collapse As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBar
Dim value As Boolean

instance.Collapse = value

value = instance.Collapse
C#
public override bool Collapse {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBar Class
WebExplorerBar Members

Tasks

Configuring Expand and Collapse ExplorePane


ContentURL Property

[image]
Intersoft WebDesktop Documentation
ContentURL Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBar Class : ContentURL Property

Glossary Item Box

Gets or sets the content URL od WebExplorerBar

Syntax

Visual Basic (Declaration)
Public Overrides Property ContentURL As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBar
Dim value As String

instance.ContentURL = value

value = instance.ContentURL
C#
public override string ContentURL {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBar Class
WebExplorerBar Members


Image Property

[image]
Intersoft WebDesktop Documentation
Image Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBar Class : Image Property

Glossary Item Box

Gets or sets the default image of WebExplorerBar

Syntax

Visual Basic (Declaration)
Public Overrides Property Image As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBar
Dim value As String

instance.Image = value

value = instance.Image
C#
public override string Image {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBar Class
WebExplorerBar Members


ImageHeight Property

[image]
Intersoft WebDesktop Documentation
ImageHeight Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBar Class : ImageHeight Property

Glossary Item Box

Gets or sets the image height of the WebExplorerBar.

Syntax

Visual Basic (Declaration)
Public Property ImageHeight As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBar
Dim value As System.Web.UI.WebControls.Unit

instance.ImageHeight = value

value = instance.ImageHeight
C#
public System.Web.UI.WebControls.Unit ImageHeight {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBar Class
WebExplorerBar Members


ImagesSettings Property

[image]
Intersoft WebDesktop Documentation
ImagesSettings Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBar Class : ImagesSettings Property

Glossary Item Box

Contains images settings such as images of expand/collapse but excluding to special WebExplorerBar.

Syntax

Visual Basic (Declaration)
Public Property ImagesSettings As WebExplorerBarImagesSettings
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBar
Dim value As WebExplorerBarImagesSettings

instance.ImagesSettings = value

value = instance.ImagesSettings
C#
public WebExplorerBarImagesSettings ImagesSettings {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBar Class
WebExplorerBar Members


PaneItems Property

[image]
Intersoft WebDesktop Documentation
PaneItems Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBar Class : PaneItems Property

Glossary Item Box

Gets or sets the collection of WebExplorerBarItem.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PaneItems As WebExplorerBarItemCollection
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBar
Dim value As WebExplorerBarItemCollection

value = instance.PaneItems
C#
public WebExplorerBarItemCollection PaneItems {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBar Class
WebExplorerBar Members


Text Property

[image]
Intersoft WebDesktop Documentation
Text Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBar Class : Text Property

Glossary Item Box

Gets or sets text of WebExplorerBar.

Syntax

Visual Basic (Declaration)
Public Overrides Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBar
Dim value As String

instance.Text = value

value = instance.Text
C#
public override string Text {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBar Class
WebExplorerBar Members


WebExplorerBarCollection Class

[image]
Intersoft WebDesktop Documentation
WebExplorerBarCollection Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebExplorerBarCollection Class

Glossary Item Box

Collection of WebExplorerBar.

Object Model

WebExplorerBarCollection Class

Syntax

Visual Basic (Declaration)
Public Class WebExplorerBarCollection
   Inherits ISNet.WebUI.ISCollectionBase
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarCollection
C#
public class WebExplorerBarCollection : ISNet.WebUI.ISCollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
ISNet.WebUI.ISCollectionBase
ISNet.WebUI.WebDesktop.WebExplorerBarCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarCollection Members
ISNet.WebUI.WebDesktop Namespace


WebExplorerBarCollection Class Members

[image]
Intersoft WebDesktop Documentation
WebExplorerBarCollection Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebExplorerBarCollection Class

Glossary Item Box

The following tables list the members exposed by WebExplorerBarCollection.

Public Constructors

 | Name | Description
Public Constructor | WebExplorerBarCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden. Returns a Boolean value indicating whether the collection is read-only.
Public Property | Item | Property indexer for the collection.
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | GetObjectData |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebExplorerBarCollection Class
ISNet.WebUI.WebDesktop Namespace


WebExplorerBarCollection Constructor

[image]
Intersoft WebDesktop Documentation
WebExplorerBarCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarCollection Class : WebExplorerBarCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebExplorerBarCollection()
C#
public WebExplorerBarCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarCollection Class
WebExplorerBarCollection Members


WebExplorerBarCollection Class Methods

[image]
Intersoft WebDesktop Documentation
WebExplorerBarCollection Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebExplorerBarCollection Class

Glossary Item Box

For a list of all members of this type, see WebExplorerBarCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | GetObjectData |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebExplorerBarCollection Class
ISNet.WebUI.WebDesktop Namespace


Add Method

[image]
Intersoft WebDesktop Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarCollection Class : Add Method

Glossary Item Box

Overload List

Overload | Description
Add(WebExplorerBar) |
Add(String) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarCollection Class
WebExplorerBarCollection Members


Add(WebExplorerBar) Method

[image]
Intersoft WebDesktop Documentation
Add(WebExplorerBar) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarCollection Class > Add Method : Add(WebExplorerBar) Method

bar

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function Add( _
   ByVal bar As WebExplorerBar _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarCollection
Dim bar As WebExplorerBar
Dim value As Integer

value = instance.Add(bar)
C#
public virtual int Add(
   WebExplorerBar bar
)

Parameters

bar

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarCollection Class
WebExplorerBarCollection Members
Overload List


Add(String) Method

[image]
Intersoft WebDesktop Documentation
Add(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarCollection Class > Add Method : Add(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal name As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarCollection
Dim name As String
Dim value As Integer

value = instance.Add(name)
C#
public int Add(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarCollection Class
WebExplorerBarCollection Members
Overload List


Clear Method

[image]
Intersoft WebDesktop Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarCollection

instance.Clear()
C#
public new void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarCollection Class
WebExplorerBarCollection Members


Contains Method

[image]
Intersoft WebDesktop Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarCollection Class : Contains Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As ISNet.WebUI.INamedObject _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As Boolean

value = instance.Contains(value)
C#
public bool Contains(
   ISNet.WebUI.INamedObject value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarCollection Class
WebExplorerBarCollection Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarCollection Class : CopyFrom Method

passIn

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CopyFrom( _
   ByVal passIn As WebExplorerBarCollection _
) As WebExplorerBarCollection
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarCollection
Dim passIn As WebExplorerBarCollection
Dim value As WebExplorerBarCollection

value = instance.CopyFrom(passIn)
C#
public WebExplorerBarCollection CopyFrom(
   WebExplorerBarCollection passIn
)

Parameters

passIn

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarCollection Class
WebExplorerBarCollection Members


CopyTo Method

[image]
Intersoft WebDesktop Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarCollection
Dim array() As ISNet.WebUI.INamedObject
Dim index As Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   ISNet.WebUI.INamedObject[] array,
   int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarCollection Class
WebExplorerBarCollection Members


Exists Method

[image]
Intersoft WebDesktop Documentation
Exists Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarCollection Class : Exists Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Exists( _
   ByVal name As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarCollection
Dim name As String
Dim value As Boolean

value = instance.Exists(name)
C#
public bool Exists(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarCollection Class
WebExplorerBarCollection Members


GetEnumerator Method

[image]
Intersoft WebDesktop Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Function GetEnumerator() As System.Collections.IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
public new System.Collections.IEnumerator GetEnumerator()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarCollection Class
WebExplorerBarCollection Members


GetItem Method

[image]
Intersoft WebDesktop Documentation
GetItem Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarCollection Class : GetItem Method

Glossary Item Box

Overload List

Overload | Description
GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarCollection Class
WebExplorerBarCollection Members


GetItem(Int32) Method

[image]
Intersoft WebDesktop Documentation
GetItem(Int32) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarCollection Class : GetItem(Int32) Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetItem( _
   ByVal index As Integer _
) As ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarCollection
Dim index As Integer
Dim value As ISNet.WebUI.INamedObject

value = instance.GetItem(index)
C#
public virtual ISNet.WebUI.INamedObject GetItem(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarCollection Class
WebExplorerBarCollection Members


GetNamedItem Method

[image]
Intersoft WebDesktop Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNamedItem( _
   ByVal name As String _
) As WebExplorerBar
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarCollection
Dim name As String
Dim value As WebExplorerBar

value = instance.GetNamedItem(name)
C#
public WebExplorerBar GetNamedItem(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarCollection Class
WebExplorerBarCollection Members


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarCollection Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarCollection Class
WebExplorerBarCollection Members


IndexOf Method

[image]
Intersoft WebDesktop Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarCollection Class : IndexOf Method

Glossary Item Box

Overload List

Overload | Description
IndexOf(String) | (Inherited from ISNet.WebUI.ISCollectionBase)
IndexOf(INamedObject) | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarCollection Class
WebExplorerBarCollection Members


IndexOf(String) Method

[image]
Intersoft WebDesktop Documentation
IndexOf(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarCollection Class > IndexOf Method : IndexOf(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function IndexOf( _
   ByVal name As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarCollection
Dim name As String
Dim value As Integer

value = instance.IndexOf(name)
C#
public virtual int IndexOf(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarCollection Class
WebExplorerBarCollection Members
Overload List


IndexOf(INamedObject) Method

[image]
Intersoft WebDesktop Documentation
IndexOf(INamedObject) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarCollection Class > IndexOf Method : IndexOf(INamedObject) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal value As ISNet.WebUI.INamedObject _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As Integer

value = instance.IndexOf(value)
C#
public int IndexOf(
   ISNet.WebUI.INamedObject value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarCollection Class
WebExplorerBarCollection Members
Overload List


Insert Method

[image]
Intersoft WebDesktop Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarCollection Class : Insert Method

index
bar

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal bar As WebExplorerBar _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarCollection
Dim index As Integer
Dim bar As WebExplorerBar

instance.Insert(index, bar)
C#
public void Insert(
   int index,
   WebExplorerBar bar
)

Parameters

index
bar

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarCollection Class
WebExplorerBarCollection Members


IntInsert Method

[image]
Intersoft WebDesktop Documentation
IntInsert Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarCollection Class : IntInsert Method

index
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub IntInsert( _
   ByVal index As Integer, _
   ByVal value As ISNet.WebUI.INamedObject _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarCollection
Dim index As Integer
Dim value As ISNet.WebUI.INamedObject

instance.IntInsert(index, value)
C#
public void IntInsert(
   int index,
   ISNet.WebUI.INamedObject value
)

Parameters

index
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarCollection Class
WebExplorerBarCollection Members


Remove Method

[image]
Intersoft WebDesktop Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarCollection Class : Remove Method

bar

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal bar As WebExplorerBar _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarCollection
Dim bar As WebExplorerBar

instance.Remove(bar)
C#
public void Remove(
   WebExplorerBar bar
)

Parameters

bar

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarCollection Class
WebExplorerBarCollection Members


setParent Method

[image]
Intersoft WebDesktop Documentation
setParent Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarCollection Class : setParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub setParent( _
   ByVal parent As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarCollection
Dim parent As Object

instance.setParent(parent)
C#
public virtual void setParent(
   object parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarCollection Class
WebExplorerBarCollection Members


Capacity Property

[image]
Intersoft WebDesktop Documentation
Capacity Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarCollection Class : Capacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarCollection
Dim value As Integer

instance.Capacity = value

value = instance.Capacity
C#
public int Capacity {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarCollection Class
WebExplorerBarCollection Members


Count Property

[image]
Intersoft WebDesktop Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarCollection Class
WebExplorerBarCollection Members


WebExplorerBarCollection Class Properties

[image]
Intersoft WebDesktop Documentation
WebExplorerBarCollection Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebExplorerBarCollection Class

Glossary Item Box

For a list of all members of this type, see WebExplorerBarCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden. Returns a Boolean value indicating whether the collection is read-only.
Public Property | Item | Property indexer for the collection.
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebExplorerBarCollection Class
ISNet.WebUI.WebDesktop Namespace


WebExplorerBarCollection Constructor

[image]
Intersoft WebDesktop Documentation
WebExplorerBarCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarCollection Class : WebExplorerBarCollection Constructor

Glossary Item Box

Initializes a new instance of the WebExplorerBarCollection class.

Overload List

Overload | Description
WebExplorerBarCollection Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarCollection Class
WebExplorerBarCollection Members


IsReadOnly Property

[image]
Intersoft WebDesktop Documentation
IsReadOnly Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarCollection Class : IsReadOnly Property

Glossary Item Box

Returns a Boolean value indicating whether the collection is read-only.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarCollection
Dim value As Boolean

value = instance.IsReadOnly
C#
public override bool IsReadOnly {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarCollection Class
WebExplorerBarCollection Members


Item Property

[image]
Intersoft WebDesktop Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarCollection Class : Item Property

index

Glossary Item Box

Property indexer for the collection.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As WebExplorerBar
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarCollection
Dim index As Integer
Dim value As WebExplorerBar

instance.Item(index) = value

value = instance.Item(index)
C#
public WebExplorerBar this[
   int index
]; {get; set;}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarCollection Class
WebExplorerBarCollection Members


Parent Property

[image]
Intersoft WebDesktop Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As Object
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarCollection
Dim value As Object

value = instance.Parent
C#
public object Parent {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarCollection Class
WebExplorerBarCollection Members


WebExplorerBarComplexImagesSettings Class

[image]
Intersoft WebDesktop Documentation
WebExplorerBarComplexImagesSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebExplorerBarComplexImagesSettings Class

Glossary Item Box

Contains images settings such as images to render the WebExplorerBar using RenderMode of ComplexImages.

Object Model

WebExplorerBarComplexImagesSettings Class

Syntax

Visual Basic (Declaration)
Public Class WebExplorerBarComplexImagesSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarComplexImagesSettings
C#
public class WebExplorerBarComplexImagesSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebDesktop.WebExplorerBarComplexImagesSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarComplexImagesSettings Members
ISNet.WebUI.WebDesktop Namespace


WebExplorerBarComplexImagesSettings Class Members

[image]
Intersoft WebDesktop Documentation
WebExplorerBarComplexImagesSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebExplorerBarComplexImagesSettings Class

Glossary Item Box

The following tables list the members exposed by WebExplorerBarComplexImagesSettings.

Public Constructors

 | Name | Description
Public Constructor | WebExplorerBarComplexImagesSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | ActiveCenter | Gets or sets the center background image for active style of WebExplorerBar.
Public Property | ActiveLeft | Gets or sets the left background image for active style of WebExplorerBar.
Public Property | ActiveRight | Gets or sets the right background image for active style of WebExplorerBar.
Public Property | NormalCenter | Gets or sets the center background image for normal style of WebExplorerBar.
Public Property | NormalLeft | Gets or sets the left background image for normal style of WebExplorerBar.
Public Property | NormalRight | Gets or sets the right background image for normal style of WebExplorerBar.
Public Property | OverCenter | Gets or sets the center background image for hovered style of WebExplorerBar.
Public Property | OverLeft | Gets or sets the left background image for hovered style of WebExplorerBar.
Public Property | OverRight | Gets or sets the right background image for hovered style of WebExplorerBar.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebExplorerBarComplexImagesSettings Class
ISNet.WebUI.WebDesktop Namespace


WebExplorerBarComplexImagesSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebExplorerBarComplexImagesSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarComplexImagesSettings Class : WebExplorerBarComplexImagesSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebExplorerBarComplexImagesSettings()
C#
public WebExplorerBarComplexImagesSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarComplexImagesSettings Class
WebExplorerBarComplexImagesSettings Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarComplexImagesSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarComplexImagesSettings
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarComplexImagesSettings Class
WebExplorerBarComplexImagesSettings Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarComplexImagesSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarComplexImagesSettings Class
WebExplorerBarComplexImagesSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarComplexImagesSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarComplexImagesSettings
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarComplexImagesSettings Class
WebExplorerBarComplexImagesSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarComplexImagesSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarComplexImagesSettings
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarComplexImagesSettings Class
WebExplorerBarComplexImagesSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarComplexImagesSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarComplexImagesSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarComplexImagesSettings Class
WebExplorerBarComplexImagesSettings Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarComplexImagesSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarComplexImagesSettings
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarComplexImagesSettings Class
WebExplorerBarComplexImagesSettings Members


WebExplorerBarComplexImagesSettings Class Methods

[image]
Intersoft WebDesktop Documentation
WebExplorerBarComplexImagesSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebExplorerBarComplexImagesSettings Class

Glossary Item Box

For a list of all members of this type, see WebExplorerBarComplexImagesSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebExplorerBarComplexImagesSettings Class
ISNet.WebUI.WebDesktop Namespace


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarComplexImagesSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarComplexImagesSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarComplexImagesSettings Class
WebExplorerBarComplexImagesSettings Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarComplexImagesSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarComplexImagesSettings
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarComplexImagesSettings Class
WebExplorerBarComplexImagesSettings Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarComplexImagesSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarComplexImagesSettings

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarComplexImagesSettings Class
WebExplorerBarComplexImagesSettings Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarComplexImagesSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarComplexImagesSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarComplexImagesSettings Class
WebExplorerBarComplexImagesSettings Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarComplexImagesSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarComplexImagesSettings
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarComplexImagesSettings Class
WebExplorerBarComplexImagesSettings Members


WebExplorerBarComplexImagesSettings Class Properties

[image]
Intersoft WebDesktop Documentation
WebExplorerBarComplexImagesSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebExplorerBarComplexImagesSettings Class

Glossary Item Box

For a list of all members of this type, see WebExplorerBarComplexImagesSettings members.

Public Properties

 | Name | Description
Public Property | ActiveCenter | Gets or sets the center background image for active style of WebExplorerBar.
Public Property | ActiveLeft | Gets or sets the left background image for active style of WebExplorerBar.
Public Property | ActiveRight | Gets or sets the right background image for active style of WebExplorerBar.
Public Property | NormalCenter | Gets or sets the center background image for normal style of WebExplorerBar.
Public Property | NormalLeft | Gets or sets the left background image for normal style of WebExplorerBar.
Public Property | NormalRight | Gets or sets the right background image for normal style of WebExplorerBar.
Public Property | OverCenter | Gets or sets the center background image for hovered style of WebExplorerBar.
Public Property | OverLeft | Gets or sets the left background image for hovered style of WebExplorerBar.
Public Property | OverRight | Gets or sets the right background image for hovered style of WebExplorerBar.
Top

See Also

Reference

WebExplorerBarComplexImagesSettings Class
ISNet.WebUI.WebDesktop Namespace


WebExplorerBarComplexImagesSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebExplorerBarComplexImagesSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarComplexImagesSettings Class : WebExplorerBarComplexImagesSettings Constructor

Glossary Item Box

Initializes a new instance of the WebExplorerBarComplexImages class.

Overload List

Overload | Description
WebExplorerBarComplexImagesSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarComplexImagesSettings Class
WebExplorerBarComplexImagesSettings Members


ActiveCenter Property

[image]
Intersoft WebDesktop Documentation
ActiveCenter Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarComplexImagesSettings Class : ActiveCenter Property

Glossary Item Box

Gets or sets the center background image for active style of WebExplorerBar.

Syntax

Visual Basic (Declaration)
Public Property ActiveCenter As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarComplexImagesSettings
Dim value As String

instance.ActiveCenter = value

value = instance.ActiveCenter
C#
public string ActiveCenter {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarComplexImagesSettings Class
WebExplorerBarComplexImagesSettings Members


ActiveLeft Property

[image]
Intersoft WebDesktop Documentation
ActiveLeft Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarComplexImagesSettings Class : ActiveLeft Property

Glossary Item Box

Gets or sets the left background image for active style of WebExplorerBar.

Syntax

Visual Basic (Declaration)
Public Property ActiveLeft As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarComplexImagesSettings
Dim value As String

instance.ActiveLeft = value

value = instance.ActiveLeft
C#
public string ActiveLeft {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarComplexImagesSettings Class
WebExplorerBarComplexImagesSettings Members


ActiveRight Property

[image]
Intersoft WebDesktop Documentation
ActiveRight Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarComplexImagesSettings Class : ActiveRight Property

Glossary Item Box

Gets or sets the right background image for active style of WebExplorerBar.

Syntax

Visual Basic (Declaration)
Public Property ActiveRight As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarComplexImagesSettings
Dim value As String

instance.ActiveRight = value

value = instance.ActiveRight
C#
public string ActiveRight {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarComplexImagesSettings Class
WebExplorerBarComplexImagesSettings Members


NormalCenter Property

[image]
Intersoft WebDesktop Documentation
NormalCenter Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarComplexImagesSettings Class : NormalCenter Property

Glossary Item Box

Gets or sets the center background image for normal style of WebExplorerBar.

Syntax

Visual Basic (Declaration)
Public Property NormalCenter As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarComplexImagesSettings
Dim value As String

instance.NormalCenter = value

value = instance.NormalCenter
C#
public string NormalCenter {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarComplexImagesSettings Class
WebExplorerBarComplexImagesSettings Members


NormalLeft Property

[image]
Intersoft WebDesktop Documentation
NormalLeft Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarComplexImagesSettings Class : NormalLeft Property

Glossary Item Box

Gets or sets the left background image for normal style of WebExplorerBar.

Syntax

Visual Basic (Declaration)
Public Property NormalLeft As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarComplexImagesSettings
Dim value As String

instance.NormalLeft = value

value = instance.NormalLeft
C#
public string NormalLeft {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarComplexImagesSettings Class
WebExplorerBarComplexImagesSettings Members


NormalRight Property

[image]
Intersoft WebDesktop Documentation
NormalRight Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarComplexImagesSettings Class : NormalRight Property

Glossary Item Box

Gets or sets the right background image for normal style of WebExplorerBar.

Syntax

Visual Basic (Declaration)
Public Property NormalRight As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarComplexImagesSettings
Dim value As String

instance.NormalRight = value

value = instance.NormalRight
C#
public string NormalRight {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarComplexImagesSettings Class
WebExplorerBarComplexImagesSettings Members


OverCenter Property

[image]
Intersoft WebDesktop Documentation
OverCenter Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarComplexImagesSettings Class : OverCenter Property

Glossary Item Box

Gets or sets the center background image for hovered style of WebExplorerBar.

Syntax

Visual Basic (Declaration)
Public Property OverCenter As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarComplexImagesSettings
Dim value As String

instance.OverCenter = value

value = instance.OverCenter
C#
public string OverCenter {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarComplexImagesSettings Class
WebExplorerBarComplexImagesSettings Members


OverLeft Property

[image]
Intersoft WebDesktop Documentation
OverLeft Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarComplexImagesSettings Class : OverLeft Property

Glossary Item Box

Gets or sets the left background image for hovered style of WebExplorerBar.

Syntax

Visual Basic (Declaration)
Public Property OverLeft As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarComplexImagesSettings
Dim value As String

instance.OverLeft = value

value = instance.OverLeft
C#
public string OverLeft {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarComplexImagesSettings Class
WebExplorerBarComplexImagesSettings Members


OverRight Property

[image]
Intersoft WebDesktop Documentation
OverRight Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarComplexImagesSettings Class : OverRight Property

Glossary Item Box

Gets or sets the right background image for hovered style of WebExplorerBar.

Syntax

Visual Basic (Declaration)
Public Property OverRight As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarComplexImagesSettings
Dim value As String

instance.OverRight = value

value = instance.OverRight
C#
public string OverRight {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarComplexImagesSettings Class
WebExplorerBarComplexImagesSettings Members


WebExplorerBarImagesSettings Class

[image]
Intersoft WebDesktop Documentation
WebExplorerBarImagesSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebExplorerBarImagesSettings Class

Glossary Item Box

Contains images settings such as images of expand/collapse to all type of WebExplorerBar.

Object Model

WebExplorerBarImagesSettings Class

Syntax

Visual Basic (Declaration)
Public Class WebExplorerBarImagesSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarImagesSettings
C#
public class WebExplorerBarImagesSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebDesktop.WebExplorerBarImagesSettings
ISNet.WebUI.WebDesktop.WebExplorerPaneImagesSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarImagesSettings Members
ISNet.WebUI.WebDesktop Namespace


WebExplorerBarImagesSettings Class Members

[image]
Intersoft WebDesktop Documentation
WebExplorerBarImagesSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebExplorerBarImagesSettings Class

Glossary Item Box

The following tables list the members exposed by WebExplorerBarImagesSettings.

Public Constructors

 | Name | Description
Public Constructor | WebExplorerBarImagesSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | CollapseImage | Gets or sets the collapse image for normal style of WebExplorerBar.
Public Property | CollapseImageOver | Gets or sets the collapse image for hovered style of WebExplorerBar.
Public Property | ExpandImage | Gets or sets the expand image for normal style of WebExplorerBar.
Public Property | ExpandImageOver | Gets or sets the expand image for hovered style of WebExplorerBar.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebExplorerBarImagesSettings Class
ISNet.WebUI.WebDesktop Namespace


WebExplorerBarImagesSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebExplorerBarImagesSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarImagesSettings Class : WebExplorerBarImagesSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebExplorerBarImagesSettings()
C#
public WebExplorerBarImagesSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarImagesSettings Class
WebExplorerBarImagesSettings Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarImagesSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarImagesSettings
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarImagesSettings Class
WebExplorerBarImagesSettings Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarImagesSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarImagesSettings Class
WebExplorerBarImagesSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarImagesSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarImagesSettings
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarImagesSettings Class
WebExplorerBarImagesSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarImagesSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarImagesSettings
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarImagesSettings Class
WebExplorerBarImagesSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarImagesSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarImagesSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarImagesSettings Class
WebExplorerBarImagesSettings Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarImagesSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarImagesSettings
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarImagesSettings Class
WebExplorerBarImagesSettings Members


WebExplorerBarImagesSettings Class Methods

[image]
Intersoft WebDesktop Documentation
WebExplorerBarImagesSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebExplorerBarImagesSettings Class

Glossary Item Box

For a list of all members of this type, see WebExplorerBarImagesSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebExplorerBarImagesSettings Class
ISNet.WebUI.WebDesktop Namespace


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarImagesSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarImagesSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarImagesSettings Class
WebExplorerBarImagesSettings Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarImagesSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarImagesSettings
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarImagesSettings Class
WebExplorerBarImagesSettings Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarImagesSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarImagesSettings

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarImagesSettings Class
WebExplorerBarImagesSettings Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarImagesSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarImagesSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarImagesSettings Class
WebExplorerBarImagesSettings Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarImagesSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarImagesSettings
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarImagesSettings Class
WebExplorerBarImagesSettings Members


WebExplorerBarImagesSettings Class Properties

[image]
Intersoft WebDesktop Documentation
WebExplorerBarImagesSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebExplorerBarImagesSettings Class

Glossary Item Box

For a list of all members of this type, see WebExplorerBarImagesSettings members.

Public Properties

 | Name | Description
Public Property | CollapseImage | Gets or sets the collapse image for normal style of WebExplorerBar.
Public Property | CollapseImageOver | Gets or sets the collapse image for hovered style of WebExplorerBar.
Public Property | ExpandImage | Gets or sets the expand image for normal style of WebExplorerBar.
Public Property | ExpandImageOver | Gets or sets the expand image for hovered style of WebExplorerBar.
Top

See Also

Reference

WebExplorerBarImagesSettings Class
ISNet.WebUI.WebDesktop Namespace


WebExplorerBarImagesSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebExplorerBarImagesSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarImagesSettings Class : WebExplorerBarImagesSettings Constructor

Glossary Item Box

Initializes a new instance of the WebExplorerBarImagesSettings class.

Overload List

Overload | Description
WebExplorerBarImagesSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarImagesSettings Class
WebExplorerBarImagesSettings Members


CollapseImage Property

[image]
Intersoft WebDesktop Documentation
CollapseImage Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarImagesSettings Class : CollapseImage Property

Glossary Item Box

Gets or sets the collapse image for normal style of WebExplorerBar.

Syntax

Visual Basic (Declaration)
Public Overridable Property CollapseImage As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarImagesSettings
Dim value As String

instance.CollapseImage = value

value = instance.CollapseImage
C#
public virtual string CollapseImage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarImagesSettings Class
WebExplorerBarImagesSettings Members


CollapseImageOver Property

[image]
Intersoft WebDesktop Documentation
CollapseImageOver Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarImagesSettings Class : CollapseImageOver Property

Glossary Item Box

Gets or sets the collapse image for hovered style of WebExplorerBar.

Syntax

Visual Basic (Declaration)
Public Overridable Property CollapseImageOver As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarImagesSettings
Dim value As String

instance.CollapseImageOver = value

value = instance.CollapseImageOver
C#
public virtual string CollapseImageOver {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarImagesSettings Class
WebExplorerBarImagesSettings Members


ExpandImage Property

[image]
Intersoft WebDesktop Documentation
ExpandImage Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarImagesSettings Class : ExpandImage Property

Glossary Item Box

Gets or sets the expand image for normal style of WebExplorerBar.

Syntax

Visual Basic (Declaration)
Public Overridable Property ExpandImage As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarImagesSettings
Dim value As String

instance.ExpandImage = value

value = instance.ExpandImage
C#
public virtual string ExpandImage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarImagesSettings Class
WebExplorerBarImagesSettings Members


ExpandImageOver Property

[image]
Intersoft WebDesktop Documentation
ExpandImageOver Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarImagesSettings Class : ExpandImageOver Property

Glossary Item Box

Gets or sets the expand image for hovered style of WebExplorerBar.

Syntax

Visual Basic (Declaration)
Public Overridable Property ExpandImageOver As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarImagesSettings
Dim value As String

instance.ExpandImageOver = value

value = instance.ExpandImageOver
C#
public virtual string ExpandImageOver {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarImagesSettings Class
WebExplorerBarImagesSettings Members


WebExplorerBarItem Class

[image]
Intersoft WebDesktop Documentation
WebExplorerBarItem Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebExplorerBarItem Class

Glossary Item Box

Item or collection of items in the WebExplorerBar, similar like collection of panes in WebExplorerPane.

Object Model

WebExplorerBarItem Class

Syntax

Visual Basic (Declaration)
Public Class WebExplorerBarItem
   Inherits WebNavBarItem
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarItem
C#
public class WebExplorerBarItem : WebNavBarItem, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject

Remarks

WebExplorerBarItem similar like collection of panes in WebExplorerPane. WebExplorerBarItem can be easily manipulated and accessed through Items collection provided by each WebExplorerBar object.

The WebExplorerBarItem object provides TargetURL and TargetWindow features for effective navigation purpose.

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase
ISNet.WebUI.WebDesktop.WebNavBarItem
ISNet.WebUI.WebDesktop.WebExplorerBarItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarItem Members
ISNet.WebUI.WebDesktop Namespace

Tasks

Creating Simple ExplorerPane

tasks

Show and hide ExplorerBar items

Concepts

WebExplorer Concepts


WebExplorerBarItem Class Members

[image]
Intersoft WebDesktop Documentation
WebExplorerBarItem Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebExplorerBarItem Class

Glossary Item Box

The following tables list the members exposed by WebExplorerBarItem.

Public Constructors

 | Name | Description
Public Constructor | WebExplorerBarItem Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | DisplayMode | Gets or sets the display mode of the NavBarItem. (Inherited from ISNet.WebUI.WebDesktop.WebNavBarItem)
Public Property | Enabled | Indicates whether the NavBarItem is enable. (Inherited from ISNet.WebUI.WebDesktop.WebNavBarItem)
Public Property | Image | Gets or sets the image of NavBarItem. (Inherited from ISNet.WebUI.WebDesktop.WebNavBarItem)
Public Property | ImagePosition | Gets or sets the image position of NavBarItem. (Inherited from ISNet.WebUI.WebDesktop.WebNavBarItem)
Public Property | ImageSize | Gets or sets the image size of the NavBarItem. (Inherited from ISNet.WebUI.WebDesktop.WebNavBarItem)
Public Property | ItemCustomRules | Gets or sets the custom rules applied to NavBarItem. (Inherited from ISNet.WebUI.WebDesktop.WebNavBarItem)
Public Property | Name | Gets or sets the name of WebNavBarItem. (Inherited from ISNet.WebUI.WebDesktop.WebNavBarItem)
Public Property | TargetURL | Gets or sets the target url when item is clicked. (Inherited from ISNet.WebUI.WebDesktop.WebNavBarItem)
Public Property | TargetWindow | Gets or sets the target window for the navigation link. If blank, it will use TargetWindow property specified in BarItemSettings. (Inherited from ISNet.WebUI.WebDesktop.WebNavBarItem)
Public Property | Text | Gets or sets text of NavBarItem. (Inherited from ISNet.WebUI.WebDesktop.WebNavBarItem)
Public Property | ToolTip | Gets or sets the tooltip of NavBarItem. (Inherited from ISNet.WebUI.WebDesktop.WebNavBarItem)
Public Property | Visible | Indicates whether the NavBarItem is visible. (Inherited from ISNet.WebUI.WebDesktop.WebNavBarItem)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebDesktop.WebNavBarItem)
Top

See Also

Reference

WebExplorerBarItem Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Creating Simple ExplorerPane

tasks

Show and hide ExplorerBar items

Concepts

WebExplorer Concepts


WebExplorerBarItem Constructor

[image]
Intersoft WebDesktop Documentation
WebExplorerBarItem Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarItem Class : WebExplorerBarItem Constructor

Glossary Item Box

Initializes a new instance of the WebExplorerBarItem class.

Overload List

Overload | Description
WebExplorerBarItem Constructor() | Initializes a new instance of the WebExplorerBarItem class with no arguments.
WebExplorerBarItem Constructor(String) | Initializes a new instance of the WebExplorerBarItem class with Text parameter.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarItem Class
WebExplorerBarItem Members


WebExplorerBarItem Constructor()

[image]
Intersoft WebDesktop Documentation
WebExplorerBarItem Constructor()
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarItem Class > WebExplorerBarItem Constructor : WebExplorerBarItem Constructor()

Glossary Item Box

Initializes a new instance of the WebExplorerBarItem class with no arguments.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebExplorerBarItem()
C#
public WebExplorerBarItem()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarItem Class
WebExplorerBarItem Members
Overload List


WebExplorerBarItem Constructor(String)

[image]
Intersoft WebDesktop Documentation
WebExplorerBarItem Constructor(String)
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarItem Class > WebExplorerBarItem Constructor : WebExplorerBarItem Constructor(String)

text

Glossary Item Box

Initializes a new instance of the WebExplorerBarItem class with Text parameter.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim text As String

Dim instance As New WebExplorerBarItem(text)
C#
public WebExplorerBarItem(
   string text
)

Parameters

text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarItem Class
WebExplorerBarItem Members
Overload List


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarItem Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarItem
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarItem Class
WebExplorerBarItem Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarItem Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarItem Class
WebExplorerBarItem Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarItem Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarItem
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarItem Class
WebExplorerBarItem Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarItem Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarItem
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarItem Class
WebExplorerBarItem Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarItem Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarItem
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarItem Class
WebExplorerBarItem Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarItem Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarItem
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarItem Class
WebExplorerBarItem Members


WebExplorerBarItem Class Methods

[image]
Intersoft WebDesktop Documentation
WebExplorerBarItem Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebExplorerBarItem Class

Glossary Item Box

For a list of all members of this type, see WebExplorerBarItem members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebDesktop.WebNavBarItem)
Top

See Also

Reference

WebExplorerBarItem Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Creating Simple ExplorerPane

tasks

Show and hide ExplorerBar items

Concepts

WebExplorer Concepts


WebExplorerBarItem Class Properties

[image]
Intersoft WebDesktop Documentation
WebExplorerBarItem Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebExplorerBarItem Class

Glossary Item Box

For a list of all members of this type, see WebExplorerBarItem members.

Public Properties

 | Name | Description
Public Property | DisplayMode | Gets or sets the display mode of the NavBarItem. (Inherited from ISNet.WebUI.WebDesktop.WebNavBarItem)
Public Property | Enabled | Indicates whether the NavBarItem is enable. (Inherited from ISNet.WebUI.WebDesktop.WebNavBarItem)
Public Property | Image | Gets or sets the image of NavBarItem. (Inherited from ISNet.WebUI.WebDesktop.WebNavBarItem)
Public Property | ImagePosition | Gets or sets the image position of NavBarItem. (Inherited from ISNet.WebUI.WebDesktop.WebNavBarItem)
Public Property | ImageSize | Gets or sets the image size of the NavBarItem. (Inherited from ISNet.WebUI.WebDesktop.WebNavBarItem)
Public Property | ItemCustomRules | Gets or sets the custom rules applied to NavBarItem. (Inherited from ISNet.WebUI.WebDesktop.WebNavBarItem)
Public Property | Name | Gets or sets the name of WebNavBarItem. (Inherited from ISNet.WebUI.WebDesktop.WebNavBarItem)
Public Property | TargetURL | Gets or sets the target url when item is clicked. (Inherited from ISNet.WebUI.WebDesktop.WebNavBarItem)
Public Property | TargetWindow | Gets or sets the target window for the navigation link. If blank, it will use TargetWindow property specified in BarItemSettings. (Inherited from ISNet.WebUI.WebDesktop.WebNavBarItem)
Public Property | Text | Gets or sets text of NavBarItem. (Inherited from ISNet.WebUI.WebDesktop.WebNavBarItem)
Public Property | ToolTip | Gets or sets the tooltip of NavBarItem. (Inherited from ISNet.WebUI.WebDesktop.WebNavBarItem)
Public Property | Visible | Indicates whether the NavBarItem is visible. (Inherited from ISNet.WebUI.WebDesktop.WebNavBarItem)
Top

See Also

Reference

WebExplorerBarItem Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Creating Simple ExplorerPane

tasks

Show and hide ExplorerBar items

Concepts

WebExplorer Concepts


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarItem Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarItem
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarItem Class
WebExplorerBarItem Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarItem Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarItem
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarItem Class
WebExplorerBarItem Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarItem Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarItem

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarItem Class
WebExplorerBarItem Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarItem Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarItem
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarItem Class
WebExplorerBarItem Members


WebExplorerBarItemCollection Class

[image]
Intersoft WebDesktop Documentation
WebExplorerBarItemCollection Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebExplorerBarItemCollection Class

Glossary Item Box

Collection of WebExplorerBarItem.

Object Model

WebExplorerBarItemCollection Class

Syntax

Visual Basic (Declaration)
Public Class WebExplorerBarItemCollection
   Inherits ISNet.WebUI.ISCollectionBase
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarItemCollection
C#
public class WebExplorerBarItemCollection : ISNet.WebUI.ISCollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
ISNet.WebUI.ISCollectionBase
ISNet.WebUI.WebDesktop.WebExplorerBarItemCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarItemCollection Members
ISNet.WebUI.WebDesktop Namespace


WebExplorerBarItemCollection Class Members

[image]
Intersoft WebDesktop Documentation
WebExplorerBarItemCollection Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebExplorerBarItemCollection Class

Glossary Item Box

The following tables list the members exposed by WebExplorerBarItemCollection.

Public Constructors

 | Name | Description
Public Constructor | WebExplorerBarItemCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden. Returns a Boolean value indicating whether the collection is read-only.
Public Property | Item | Property indexer for the collection.
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | GetObjectData |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebExplorerBarItemCollection Class
ISNet.WebUI.WebDesktop Namespace


WebExplorerBarItemCollection Constructor

[image]
Intersoft WebDesktop Documentation
WebExplorerBarItemCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarItemCollection Class : WebExplorerBarItemCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebExplorerBarItemCollection()
C#
public WebExplorerBarItemCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarItemCollection Class
WebExplorerBarItemCollection Members


WebExplorerBarItemCollection Class Methods

[image]
Intersoft WebDesktop Documentation
WebExplorerBarItemCollection Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebExplorerBarItemCollection Class

Glossary Item Box

For a list of all members of this type, see WebExplorerBarItemCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | GetObjectData |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebExplorerBarItemCollection Class
ISNet.WebUI.WebDesktop Namespace


Add Method

[image]
Intersoft WebDesktop Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarItemCollection Class : Add Method

Glossary Item Box

Overload List

Overload | Description
Add(WebExplorerBarItem) |
Add(String) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarItemCollection Class
WebExplorerBarItemCollection Members


Add(WebExplorerBarItem) Method

[image]
Intersoft WebDesktop Documentation
Add(WebExplorerBarItem) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarItemCollection Class > Add Method : Add(WebExplorerBarItem) Method

navbaritem

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function Add( _
   ByVal navbaritem As WebExplorerBarItem _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarItemCollection
Dim navbaritem As WebExplorerBarItem
Dim value As Integer

value = instance.Add(navbaritem)
C#
public virtual int Add(
   WebExplorerBarItem navbaritem
)

Parameters

navbaritem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarItemCollection Class
WebExplorerBarItemCollection Members
Overload List


Add(String) Method

[image]
Intersoft WebDesktop Documentation
Add(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarItemCollection Class > Add Method : Add(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal name As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarItemCollection
Dim name As String
Dim value As Integer

value = instance.Add(name)
C#
public int Add(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarItemCollection Class
WebExplorerBarItemCollection Members
Overload List


Clear Method

[image]
Intersoft WebDesktop Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarItemCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarItemCollection

instance.Clear()
C#
public new void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarItemCollection Class
WebExplorerBarItemCollection Members


Contains Method

[image]
Intersoft WebDesktop Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarItemCollection Class : Contains Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As ISNet.WebUI.INamedObject _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarItemCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As Boolean

value = instance.Contains(value)
C#
public bool Contains(
   ISNet.WebUI.INamedObject value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarItemCollection Class
WebExplorerBarItemCollection Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarItemCollection Class : CopyFrom Method

passIn

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CopyFrom( _
   ByVal passIn As WebExplorerBarItemCollection _
) As WebExplorerBarItemCollection
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarItemCollection
Dim passIn As WebExplorerBarItemCollection
Dim value As WebExplorerBarItemCollection

value = instance.CopyFrom(passIn)
C#
public WebExplorerBarItemCollection CopyFrom(
   WebExplorerBarItemCollection passIn
)

Parameters

passIn

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarItemCollection Class
WebExplorerBarItemCollection Members


CopyTo Method

[image]
Intersoft WebDesktop Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarItemCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarItemCollection
Dim array() As ISNet.WebUI.INamedObject
Dim index As Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   ISNet.WebUI.INamedObject[] array,
   int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarItemCollection Class
WebExplorerBarItemCollection Members


Exists Method

[image]
Intersoft WebDesktop Documentation
Exists Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarItemCollection Class : Exists Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Exists( _
   ByVal name As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarItemCollection
Dim name As String
Dim value As Boolean

value = instance.Exists(name)
C#
public bool Exists(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarItemCollection Class
WebExplorerBarItemCollection Members


GetEnumerator Method

[image]
Intersoft WebDesktop Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarItemCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Function GetEnumerator() As System.Collections.IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarItemCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
public new System.Collections.IEnumerator GetEnumerator()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarItemCollection Class
WebExplorerBarItemCollection Members


GetItem Method

[image]
Intersoft WebDesktop Documentation
GetItem Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarItemCollection Class : GetItem Method

Glossary Item Box

Overload List

Overload | Description
GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarItemCollection Class
WebExplorerBarItemCollection Members


GetItem(Int32) Method

[image]
Intersoft WebDesktop Documentation
GetItem(Int32) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarItemCollection Class : GetItem(Int32) Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetItem( _
   ByVal index As Integer _
) As ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarItemCollection
Dim index As Integer
Dim value As ISNet.WebUI.INamedObject

value = instance.GetItem(index)
C#
public virtual ISNet.WebUI.INamedObject GetItem(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarItemCollection Class
WebExplorerBarItemCollection Members


GetNamedItem Method

[image]
Intersoft WebDesktop Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarItemCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNamedItem( _
   ByVal name As String _
) As WebExplorerBarItem
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarItemCollection
Dim name As String
Dim value As WebExplorerBarItem

value = instance.GetNamedItem(name)
C#
public WebExplorerBarItem GetNamedItem(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarItemCollection Class
WebExplorerBarItemCollection Members


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarItemCollection Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarItemCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarItemCollection Class
WebExplorerBarItemCollection Members


IndexOf Method

[image]
Intersoft WebDesktop Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarItemCollection Class : IndexOf Method

Glossary Item Box

Overload List

Overload | Description
IndexOf(String) | (Inherited from ISNet.WebUI.ISCollectionBase)
IndexOf(INamedObject) | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarItemCollection Class
WebExplorerBarItemCollection Members


IndexOf(String) Method

[image]
Intersoft WebDesktop Documentation
IndexOf(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarItemCollection Class > IndexOf Method : IndexOf(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function IndexOf( _
   ByVal name As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarItemCollection
Dim name As String
Dim value As Integer

value = instance.IndexOf(name)
C#
public virtual int IndexOf(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarItemCollection Class
WebExplorerBarItemCollection Members
Overload List


IndexOf(INamedObject) Method

[image]
Intersoft WebDesktop Documentation
IndexOf(INamedObject) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarItemCollection Class > IndexOf Method : IndexOf(INamedObject) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal value As ISNet.WebUI.INamedObject _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarItemCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As Integer

value = instance.IndexOf(value)
C#
public int IndexOf(
   ISNet.WebUI.INamedObject value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarItemCollection Class
WebExplorerBarItemCollection Members
Overload List


Insert Method

[image]
Intersoft WebDesktop Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarItemCollection Class : Insert Method

index
navbaritem

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal navbaritem As WebExplorerBarItem _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarItemCollection
Dim index As Integer
Dim navbaritem As WebExplorerBarItem

instance.Insert(index, navbaritem)
C#
public void Insert(
   int index,
   WebExplorerBarItem navbaritem
)

Parameters

index
navbaritem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarItemCollection Class
WebExplorerBarItemCollection Members


IntInsert Method

[image]
Intersoft WebDesktop Documentation
IntInsert Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarItemCollection Class : IntInsert Method

index
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub IntInsert( _
   ByVal index As Integer, _
   ByVal value As ISNet.WebUI.INamedObject _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarItemCollection
Dim index As Integer
Dim value As ISNet.WebUI.INamedObject

instance.IntInsert(index, value)
C#
public void IntInsert(
   int index,
   ISNet.WebUI.INamedObject value
)

Parameters

index
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarItemCollection Class
WebExplorerBarItemCollection Members


Remove Method

[image]
Intersoft WebDesktop Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarItemCollection Class : Remove Method

navbaritem

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal navbaritem As WebExplorerBarItem _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarItemCollection
Dim navbaritem As WebExplorerBarItem

instance.Remove(navbaritem)
C#
public void Remove(
   WebExplorerBarItem navbaritem
)

Parameters

navbaritem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarItemCollection Class
WebExplorerBarItemCollection Members


setParent Method

[image]
Intersoft WebDesktop Documentation
setParent Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarItemCollection Class : setParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub setParent( _
   ByVal parent As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarItemCollection
Dim parent As Object

instance.setParent(parent)
C#
public virtual void setParent(
   object parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarItemCollection Class
WebExplorerBarItemCollection Members


Capacity Property

[image]
Intersoft WebDesktop Documentation
Capacity Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarItemCollection Class : Capacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarItemCollection
Dim value As Integer

instance.Capacity = value

value = instance.Capacity
C#
public int Capacity {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarItemCollection Class
WebExplorerBarItemCollection Members


Count Property

[image]
Intersoft WebDesktop Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarItemCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarItemCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarItemCollection Class
WebExplorerBarItemCollection Members


WebExplorerBarItemCollection Class Properties

[image]
Intersoft WebDesktop Documentation
WebExplorerBarItemCollection Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebExplorerBarItemCollection Class

Glossary Item Box

For a list of all members of this type, see WebExplorerBarItemCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden. Returns a Boolean value indicating whether the collection is read-only.
Public Property | Item | Property indexer for the collection.
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebExplorerBarItemCollection Class
ISNet.WebUI.WebDesktop Namespace


WebExplorerBarItemCollection Constructor

[image]
Intersoft WebDesktop Documentation
WebExplorerBarItemCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarItemCollection Class : WebExplorerBarItemCollection Constructor

Glossary Item Box

Initializes a new instance of the WebExplorerBarItemCollection class.

Overload List

Overload | Description
WebExplorerBarItemCollection Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarItemCollection Class
WebExplorerBarItemCollection Members


IsReadOnly Property

[image]
Intersoft WebDesktop Documentation
IsReadOnly Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarItemCollection Class : IsReadOnly Property

Glossary Item Box

Returns a Boolean value indicating whether the collection is read-only.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarItemCollection
Dim value As Boolean

value = instance.IsReadOnly
C#
public override bool IsReadOnly {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarItemCollection Class
WebExplorerBarItemCollection Members


Item Property

[image]
Intersoft WebDesktop Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarItemCollection Class : Item Property

index

Glossary Item Box

Property indexer for the collection.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As WebExplorerBarItem
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarItemCollection
Dim index As Integer
Dim value As WebExplorerBarItem

instance.Item(index) = value

value = instance.Item(index)
C#
public WebExplorerBarItem this[
   int index
]; {get; set;}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarItemCollection Class
WebExplorerBarItemCollection Members


Parent Property

[image]
Intersoft WebDesktop Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarItemCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As Object
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarItemCollection
Dim value As Object

value = instance.Parent
C#
public object Parent {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarItemCollection Class
WebExplorerBarItemCollection Members


WebExplorerBarSettings Class

[image]
Intersoft WebDesktop Documentation
WebExplorerBarSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebExplorerBarSettings Class

Glossary Item Box

A collection of bar settings to customize the WebNavbar.

Object Model

WebExplorerBarSettings Class

Syntax

Visual Basic (Declaration)
Public Class WebExplorerBarSettings
   Inherits WebNavBarSettings
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarSettings
C#
public class WebExplorerBarSettings : WebNavBarSettings, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebDesktop.WebNavBarSettings
ISNet.WebUI.WebDesktop.WebExplorerBarSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarSettings Members
ISNet.WebUI.WebDesktop Namespace


WebExplorerBarSettings Class Members

[image]
Intersoft WebDesktop Documentation
WebExplorerBarSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebExplorerBarSettings Class

Glossary Item Box

The following tables list the members exposed by WebExplorerBarSettings.

Public Constructors

 | Name | Description
Public Constructor | WebExplorerBarSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | BarFrameStyle | Gets or sets the style of BarFrame style. (Style of Border only)
Public Property | BarSpacing | Gets or sets the spacing between WebExplorerBar.
Public Property | BarStyle | Overridden. Gets or sets the style of WebExplorerBar.
Public Property | CaptionDisplayMode | Gets or sets the display mode of the Caption. (Inherited from ISNet.WebUI.WebDesktop.WebNavBarSettings)
Public Property | ContentMode | Gets or sets the content mode of the NavBar. (Inherited from ISNet.WebUI.WebDesktop.WebNavBarSettings)
Public Property | Image | Gets or sets the default image of NavBar. (Inherited from ISNet.WebUI.WebDesktop.WebNavBarSettings)
Public Property | ImageHeight | Gets or sets the image height of WebExplorerBar.
Public Property | ImageSize | Overridden. Gets or sets the image size of WebExplorerBar.
Public Property | ImagesSettings | Contains images settings such as images of expand/collapse to all type of WebExplorerBar.
Public Property | MergeBarStyleOver | Specify whether the BarStyle Over can be merged to either Normal or Active style.
Public Property | Size | Overridden. Gets or sets the size of WebExplorerBar.
Public Property | SpecialBarStyle | Gets or sets the style of Special WebExplorerBar.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebExplorerBarSettings Class
ISNet.WebUI.WebDesktop Namespace


WebExplorerBarSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebExplorerBarSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarSettings Class : WebExplorerBarSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebExplorerBarSettings()
C#
public WebExplorerBarSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarSettings Class
WebExplorerBarSettings Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarSettings
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarSettings Class
WebExplorerBarSettings Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarSettings Class
WebExplorerBarSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarSettings
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarSettings Class
WebExplorerBarSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarSettings
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarSettings Class
WebExplorerBarSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarSettings Class
WebExplorerBarSettings Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarSettings
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarSettings Class
WebExplorerBarSettings Members


WebExplorerBarSettings Class Methods

[image]
Intersoft WebDesktop Documentation
WebExplorerBarSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebExplorerBarSettings Class

Glossary Item Box

For a list of all members of this type, see WebExplorerBarSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebExplorerBarSettings Class
ISNet.WebUI.WebDesktop Namespace


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarSettings Class
WebExplorerBarSettings Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarSettings
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarSettings Class
WebExplorerBarSettings Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarSettings

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarSettings Class
WebExplorerBarSettings Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarSettings Class
WebExplorerBarSettings Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarSettings
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarSettings Class
WebExplorerBarSettings Members


WebExplorerBarSettings Class Properties

[image]
Intersoft WebDesktop Documentation
WebExplorerBarSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebExplorerBarSettings Class

Glossary Item Box

For a list of all members of this type, see WebExplorerBarSettings members.

Public Properties

 | Name | Description
Public Property | BarFrameStyle | Gets or sets the style of BarFrame style. (Style of Border only)
Public Property | BarSpacing | Gets or sets the spacing between WebExplorerBar.
Public Property | BarStyle | Overridden. Gets or sets the style of WebExplorerBar.
Public Property | CaptionDisplayMode | Gets or sets the display mode of the Caption. (Inherited from ISNet.WebUI.WebDesktop.WebNavBarSettings)
Public Property | ContentMode | Gets or sets the content mode of the NavBar. (Inherited from ISNet.WebUI.WebDesktop.WebNavBarSettings)
Public Property | Image | Gets or sets the default image of NavBar. (Inherited from ISNet.WebUI.WebDesktop.WebNavBarSettings)
Public Property | ImageHeight | Gets or sets the image height of WebExplorerBar.
Public Property | ImageSize | Overridden. Gets or sets the image size of WebExplorerBar.
Public Property | ImagesSettings | Contains images settings such as images of expand/collapse to all type of WebExplorerBar.
Public Property | MergeBarStyleOver | Specify whether the BarStyle Over can be merged to either Normal or Active style.
Public Property | Size | Overridden. Gets or sets the size of WebExplorerBar.
Public Property | SpecialBarStyle | Gets or sets the style of Special WebExplorerBar.
Top

See Also

Reference

WebExplorerBarSettings Class
ISNet.WebUI.WebDesktop Namespace


WebExplorerBarSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebExplorerBarSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarSettings Class : WebExplorerBarSettings Constructor

Glossary Item Box

Initializes a new instance of the WebExplorerBarSettings class.

Overload List

Overload | Description
WebExplorerBarSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarSettings Class
WebExplorerBarSettings Members


BarFrameStyle Property

[image]
Intersoft WebDesktop Documentation
BarFrameStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarSettings Class : BarFrameStyle Property

Glossary Item Box

Gets or sets the style of BarFrame style. (Style of Border only)

Syntax

Visual Basic (Declaration)
Public Property BarFrameStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarSettings
Dim value As ISNet.WebUI.WebStyle

instance.BarFrameStyle = value

value = instance.BarFrameStyle
C#
public ISNet.WebUI.WebStyle BarFrameStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarSettings Class
WebExplorerBarSettings Members


BarSpacing Property

[image]
Intersoft WebDesktop Documentation
BarSpacing Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarSettings Class : BarSpacing Property

Glossary Item Box

Gets or sets the spacing between WebExplorerBar.

Syntax

Visual Basic (Declaration)
Public Property BarSpacing As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarSettings
Dim value As Integer

instance.BarSpacing = value

value = instance.BarSpacing
C#
public int BarSpacing {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarSettings Class
WebExplorerBarSettings Members


BarStyle Property

[image]
Intersoft WebDesktop Documentation
BarStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarSettings Class : BarStyle Property

Glossary Item Box

Gets or sets the style of WebExplorerBar.

Syntax

Visual Basic (Declaration)
Public Overrides Property BarStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarSettings
Dim value As ISNet.WebUI.DynamicStyle

instance.BarStyle = value

value = instance.BarStyle
C#
public override ISNet.WebUI.DynamicStyle BarStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarSettings Class
WebExplorerBarSettings Members


ImageHeight Property

[image]
Intersoft WebDesktop Documentation
ImageHeight Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarSettings Class : ImageHeight Property

Glossary Item Box

Gets or sets the image height of WebExplorerBar.

Syntax

Visual Basic (Declaration)
Public Property ImageHeight As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarSettings
Dim value As System.Web.UI.WebControls.Unit

instance.ImageHeight = value

value = instance.ImageHeight
C#
public System.Web.UI.WebControls.Unit ImageHeight {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarSettings Class
WebExplorerBarSettings Members


ImageSize Property

[image]
Intersoft WebDesktop Documentation
ImageSize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarSettings Class : ImageSize Property

Glossary Item Box

Gets or sets the image size of WebExplorerBar.

Syntax

Visual Basic (Declaration)
Public Overrides Property ImageSize As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarSettings
Dim value As System.Web.UI.WebControls.Unit

instance.ImageSize = value

value = instance.ImageSize
C#
public override System.Web.UI.WebControls.Unit ImageSize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarSettings Class
WebExplorerBarSettings Members


ImagesSettings Property

[image]
Intersoft WebDesktop Documentation
ImagesSettings Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarSettings Class : ImagesSettings Property

Glossary Item Box

Contains images settings such as images of expand/collapse to all type of WebExplorerBar.

Syntax

Visual Basic (Declaration)
Public Property ImagesSettings As WebExplorerPaneImagesSettings
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarSettings
Dim value As WebExplorerPaneImagesSettings

instance.ImagesSettings = value

value = instance.ImagesSettings
C#
public WebExplorerPaneImagesSettings ImagesSettings {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarSettings Class
WebExplorerBarSettings Members


MergeBarStyleOver Property

[image]
Intersoft WebDesktop Documentation
MergeBarStyleOver Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarSettings Class : MergeBarStyleOver Property

Glossary Item Box

Specify whether the BarStyle Over can be merged to either Normal or Active style.

Syntax

Visual Basic (Declaration)
Public Property MergeBarStyleOver As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarSettings
Dim value As Boolean

instance.MergeBarStyleOver = value

value = instance.MergeBarStyleOver
C#
public bool MergeBarStyleOver {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarSettings Class
WebExplorerBarSettings Members


Size Property

[image]
Intersoft WebDesktop Documentation
Size Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarSettings Class : Size Property

Glossary Item Box

Gets or sets the size of WebExplorerBar.

Syntax

Visual Basic (Declaration)
Public Overrides Property Size As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarSettings
Dim value As Integer

instance.Size = value

value = instance.Size
C#
public override int Size {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarSettings Class
WebExplorerBarSettings Members


SpecialBarStyle Property

[image]
Intersoft WebDesktop Documentation
SpecialBarStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerBarSettings Class : SpecialBarStyle Property

Glossary Item Box

Gets or sets the style of Special WebExplorerBar.

Syntax

Visual Basic (Declaration)
Public Property SpecialBarStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerBarSettings
Dim value As ISNet.WebUI.DynamicStyle

instance.SpecialBarStyle = value

value = instance.SpecialBarStyle
C#
public ISNet.WebUI.DynamicStyle SpecialBarStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerBarSettings Class
WebExplorerBarSettings Members


WebExplorerClientSideEvents Class

[image]
Intersoft WebDesktop Documentation
WebExplorerClientSideEvents Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebExplorerClientSideEvents Class

Glossary Item Box

Javascript functions which invoked from client side in WebExplorer.

Object Model

WebExplorerClientSideEvents Class

Syntax

Visual Basic (Declaration)
Public Class WebExplorerClientSideEvents
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerClientSideEvents
C#
public class WebExplorerClientSideEvents : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Remarks

WebExplorerPane exposed numerous client side events that you can consume in order to create rich interaction and extensible web applications. Some of client side events include OnAfterCollapse, OnAfterExpand, OnBeforeCollapse, OnBeforeExpand, and OnInitialize.

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebDesktop.WebExplorerClientSideEvents

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerClientSideEvents Members
ISNet.WebUI.WebDesktop Namespace

Tasks

Handling Client Side Events ExplorerPane

Concepts

WebExplorer Features


WebExplorerClientSideEvents Class Members

[image]
Intersoft WebDesktop Documentation
WebExplorerClientSideEvents Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebExplorerClientSideEvents Class

Glossary Item Box

The following tables list the members exposed by WebExplorerClientSideEvents.

Public Constructors

 | Name | Description
Public Constructor | WebExplorerClientSideEvents Constructor |
Top

Public Properties

 | Name | Description
Public Property | OnAfterCollapse | Gets or sets the javascript function to invoke after the Pane is collapsed.
Public Property | OnAfterExpand | Gets or sets the javascript function to invoke after the Pane is expanded.
Public Property | OnBeforeCollapse | Gets or sets the javascript function to invoke just before the Pane is collapsed.
Public Property | OnBeforeExpand | Gets or sets the javascript function to invoke just before the Pane is expanded.
Public Property | OnClientUnload | Gets or sets the javascript function to invoke when the WebExplorerPane is unload.
Public Property | OnInitialize | Gets or sets the javascript function to invoke when the WebExplorerPane is initialized.
Public Property | OnPaneHeaderClick | Gets or sets the javascript function to invoke when the WebExplorerBar Header is clicked.
Public Property | OnPaneItemClick | Gets or sets the javascript function to invoke when the WebExplorerBar Header is clicked.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

WebExplorerClientSideEvents Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Handling Client Side Events ExplorerPane

Concepts

WebExplorer Features


WebExplorerClientSideEvents Constructor

[image]
Intersoft WebDesktop Documentation
WebExplorerClientSideEvents Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerClientSideEvents Class : WebExplorerClientSideEvents Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebExplorerClientSideEvents()
C#
public WebExplorerClientSideEvents()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerClientSideEvents Class
WebExplorerClientSideEvents Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerClientSideEvents Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerClientSideEvents
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerClientSideEvents Class
WebExplorerClientSideEvents Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerClientSideEvents Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerClientSideEvents Class
WebExplorerClientSideEvents Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerClientSideEvents Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerClientSideEvents
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerClientSideEvents Class
WebExplorerClientSideEvents Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerClientSideEvents Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerClientSideEvents
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerClientSideEvents Class
WebExplorerClientSideEvents Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerClientSideEvents Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerClientSideEvents
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerClientSideEvents Class
WebExplorerClientSideEvents Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerClientSideEvents Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerClientSideEvents
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerClientSideEvents Class
WebExplorerClientSideEvents Members


WebExplorerClientSideEvents Class Methods

[image]
Intersoft WebDesktop Documentation
WebExplorerClientSideEvents Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebExplorerClientSideEvents Class

Glossary Item Box

For a list of all members of this type, see WebExplorerClientSideEvents members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

WebExplorerClientSideEvents Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Handling Client Side Events ExplorerPane

Concepts

WebExplorer Features


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerClientSideEvents Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerClientSideEvents
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerClientSideEvents Class
WebExplorerClientSideEvents Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerClientSideEvents Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerClientSideEvents
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerClientSideEvents Class
WebExplorerClientSideEvents Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerClientSideEvents Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerClientSideEvents

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerClientSideEvents Class
WebExplorerClientSideEvents Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerClientSideEvents Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerClientSideEvents
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerClientSideEvents Class
WebExplorerClientSideEvents Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerClientSideEvents Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerClientSideEvents
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerClientSideEvents Class
WebExplorerClientSideEvents Members


WebExplorerClientSideEvents Class Properties

[image]
Intersoft WebDesktop Documentation
WebExplorerClientSideEvents Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebExplorerClientSideEvents Class

Glossary Item Box

For a list of all members of this type, see WebExplorerClientSideEvents members.

Public Properties

 | Name | Description
Public Property | OnAfterCollapse | Gets or sets the javascript function to invoke after the Pane is collapsed.
Public Property | OnAfterExpand | Gets or sets the javascript function to invoke after the Pane is expanded.
Public Property | OnBeforeCollapse | Gets or sets the javascript function to invoke just before the Pane is collapsed.
Public Property | OnBeforeExpand | Gets or sets the javascript function to invoke just before the Pane is expanded.
Public Property | OnClientUnload | Gets or sets the javascript function to invoke when the WebExplorerPane is unload.
Public Property | OnInitialize | Gets or sets the javascript function to invoke when the WebExplorerPane is initialized.
Public Property | OnPaneHeaderClick | Gets or sets the javascript function to invoke when the WebExplorerBar Header is clicked.
Public Property | OnPaneItemClick | Gets or sets the javascript function to invoke when the WebExplorerBar Header is clicked.
Top

See Also

Reference

WebExplorerClientSideEvents Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Handling Client Side Events ExplorerPane

Concepts

WebExplorer Features


WebExplorerClientSideEvents Constructor

[image]
Intersoft WebDesktop Documentation
WebExplorerClientSideEvents Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerClientSideEvents Class : WebExplorerClientSideEvents Constructor

Glossary Item Box

Initializes a new instance of the WebExplorerClientSideEvents class.

Overload List

Overload | Description
WebExplorerClientSideEvents Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerClientSideEvents Class
WebExplorerClientSideEvents Members


OnAfterCollapse Property

[image]
Intersoft WebDesktop Documentation
OnAfterCollapse Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerClientSideEvents Class : OnAfterCollapse Property

Glossary Item Box

Gets or sets the javascript function to invoke after the Pane is collapsed.

Syntax

Visual Basic (Declaration)
Public Property OnAfterCollapse As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerClientSideEvents
Dim value As String

instance.OnAfterCollapse = value

value = instance.OnAfterCollapse
C#
public string OnAfterCollapse {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerClientSideEvents Class
WebExplorerClientSideEvents Members


OnAfterExpand Property

[image]
Intersoft WebDesktop Documentation
OnAfterExpand Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerClientSideEvents Class : OnAfterExpand Property

Glossary Item Box

Gets or sets the javascript function to invoke after the Pane is expanded.

Syntax

Visual Basic (Declaration)
Public Property OnAfterExpand As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerClientSideEvents
Dim value As String

instance.OnAfterExpand = value

value = instance.OnAfterExpand
C#
public string OnAfterExpand {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerClientSideEvents Class
WebExplorerClientSideEvents Members


OnBeforeCollapse Property

[image]
Intersoft WebDesktop Documentation
OnBeforeCollapse Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerClientSideEvents Class : OnBeforeCollapse Property

Glossary Item Box

Gets or sets the javascript function to invoke just before the Pane is collapsed.

Syntax

Visual Basic (Declaration)
Public Property OnBeforeCollapse As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerClientSideEvents
Dim value As String

instance.OnBeforeCollapse = value

value = instance.OnBeforeCollapse
C#
public string OnBeforeCollapse {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerClientSideEvents Class
WebExplorerClientSideEvents Members


OnBeforeExpand Property

[image]
Intersoft WebDesktop Documentation
OnBeforeExpand Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerClientSideEvents Class : OnBeforeExpand Property

Glossary Item Box

Gets or sets the javascript function to invoke just before the Pane is expanded.

Syntax

Visual Basic (Declaration)
Public Property OnBeforeExpand As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerClientSideEvents
Dim value As String

instance.OnBeforeExpand = value

value = instance.OnBeforeExpand
C#
public string OnBeforeExpand {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerClientSideEvents Class
WebExplorerClientSideEvents Members


OnClientUnload Property

[image]
Intersoft WebDesktop Documentation
OnClientUnload Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerClientSideEvents Class : OnClientUnload Property

Glossary Item Box

Gets or sets the javascript function to invoke when the WebExplorerPane is unload.

Syntax

Visual Basic (Declaration)
Public Property OnClientUnload As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerClientSideEvents
Dim value As String

instance.OnClientUnload = value

value = instance.OnClientUnload
C#
public string OnClientUnload {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerClientSideEvents Class
WebExplorerClientSideEvents Members


OnInitialize Property

[image]
Intersoft WebDesktop Documentation
OnInitialize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerClientSideEvents Class : OnInitialize Property

Glossary Item Box

Gets or sets the javascript function to invoke when the WebExplorerPane is initialized.

Syntax

Visual Basic (Declaration)
Public Property OnInitialize As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerClientSideEvents
Dim value As String

instance.OnInitialize = value

value = instance.OnInitialize
C#
public string OnInitialize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerClientSideEvents Class
WebExplorerClientSideEvents Members


OnPaneHeaderClick Property

[image]
Intersoft WebDesktop Documentation
OnPaneHeaderClick Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerClientSideEvents Class : OnPaneHeaderClick Property

Glossary Item Box

Gets or sets the javascript function to invoke when the WebExplorerBar Header is clicked.

Syntax

Visual Basic (Declaration)
Public Property OnPaneHeaderClick As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerClientSideEvents
Dim value As String

instance.OnPaneHeaderClick = value

value = instance.OnPaneHeaderClick
C#
public string OnPaneHeaderClick {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerClientSideEvents Class
WebExplorerClientSideEvents Members


OnPaneItemClick Property

[image]
Intersoft WebDesktop Documentation
OnPaneItemClick Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerClientSideEvents Class : OnPaneItemClick Property

Glossary Item Box

Gets or sets the javascript function to invoke when the WebExplorerBar Header is clicked.

Syntax

Visual Basic (Declaration)
Public Property OnPaneItemClick As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerClientSideEvents
Dim value As String

instance.OnPaneItemClick = value

value = instance.OnPaneItemClick
C#
public string OnPaneItemClick {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerClientSideEvents Class
WebExplorerClientSideEvents Members


WebExplorerPane Class

[image]
Intersoft WebDesktop Documentation
WebExplorerPane Class
Members Example See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebExplorerPane Class

Glossary Item Box

WebExplorerPane is one of WebDesktop.NET member which allows you to create advanced navigation user interface with the richness of desktop's ExplorerPane in every details of styles and behaviors.

Object Model

WebExplorerPane Class

Syntax

Visual Basic (Declaration)
Public Class WebExplorerPane
   Inherits WebNavPane
   Implements ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, ISNet.WebUI.ITemplateSync
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
C#
public class WebExplorerPane : WebNavPane, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, ISNet.WebUI.ITemplateSync

Remarks

You can use WebExplorerPane control to quickly create rich and fully-functional Desktop's Explorer-like navigation user interface in a professional way. WebExplorerPane is designed with elegant architecture, object model and specialized user interface for each element. Therefore, you do not need to do any workaround in order to achieve a modern navigation control which is not only rich in styles, but also in every functions and behaviors.

WebExplorerPane will enhance your user experience through expand/collapse pane with animation. It allows you determine which pane is more related to the selected object by setting the Collapse property, and it will automatically manage the animation behavior (EnableAnimation set to True) when switching between one navigation to another just like desktop's explorer pane behavior.

WebExplorerPane sets a new standard in navigation user interface by providing advanced features for great flexibility and extensibility. You can choose one of three ContentMode for each Bar's contents, or having all of them to use the global setting specified in PaneSettings.

WebExplorerPane consists of two main user interface elements, which are

  1. Pane Header
    • Image
    • Text
    • Expand/Collapse Image
  2. Pane Content (expandable/collapsible)
    • PaneItem

Example

The following sample shows you how to create a simple WebExplorerPane with default settings. The label in the sample (lblDate) is used to show the current date. To give you better understanding please refer to 'Simple.aspx' file in WebDesktopSamples.
C# Copy Code
protected void Page_Load(object sender, EventArgs e)
{
     body.Style.Add("overflow", "hidden");

     WebExplorerPane WebExplorerPane1 = (WebExplorerPane)WebPaneManager1.FindControl("WebExplorerPane1");
     Label lblDate = (Label)WebExplorerPane1.FindControl("lblDate");
     lblDate.Text = DateTime.Now.ToLongDateString();
}

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
ISNet.WebUI.ISNetControl
ISNet.WebUI.WebDesktop.WebNavPane
ISNet.WebUI.WebDesktop.WebExplorerPane

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Members
ISNet.WebUI.WebDesktop Namespace

Tasks

Creating Simple ExplorerPane

tasks

Configuring Expand and Collapse ExplorePane
Changing Inline content of ExplorerPane

Concepts

WebExplorer Overview

concepts

WebExplorer Concepts
WebExplorer Features


WebExplorerPane Class Members

[image]
Intersoft WebDesktop Documentation
WebExplorerPane Class Members
See Also Properties Methods Events Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebExplorerPane Class

Glossary Item Box

The following tables list the members exposed by WebExplorerPane.

Public Constructors

 | Name | Description
Public Constructor | WebExplorerPane Constructor |
Top

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | AutoPostBack | Specifies whether the navbar or navbar_item should perform autopostback automatically when clicked. (Inherited from ISNet.WebUI.WebDesktop.WebNavPane)
Public Property | BackColor | Overridden. Background color of the control.
Public Property | BarItems | Overridden.
Public Property | BorderColor | Overridden. Color of the border around the control.
Public Property | BorderStyle | Overridden. Style of the border around the control.
Public Property | BorderWidth | Overridden. Width of the border around the control.
Public Property | CausesValidation | (Inherited from ISNet.WebUI.WebDesktop.WebNavPane)
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ClientSideEvents | Contains Javascript ClientSide events.
Public Property | ComplexImagesSettings | Contains images settings such as images to render the WebExplorerBar using RenderMode of ComplexImages.
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableAnimation | Specifies whether the WebExplorerPane support animation.
Public Property | Enabled | Enabled state of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableManagedTheming | Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to False, this control will not apply the style defined in Theme Architecture. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | Whether the control automatically saves its state for use in round-trips. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). (Inherited from ISNet.WebUI.ISNetControl)
Public Property | FrameStyle | Gets or sets the style applied to Frame. (Inherited from ISNet.WebUI.WebDesktop.WebNavPane)
Public Property | Height | (Inherited from ISNet.WebUI.WebDesktop.WebNavPane)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ImagesDirectory | Gets or sets the location of images used to render the control. (Inherited from ISNet.WebUI.WebDesktop.WebNavPane)
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | PaneItemSettings | Contains WebExplorerBarItem settings such as ItemStyle, ItemsPlaceholderStyle, DisplayMode, and ImagePosition.
Public Property | Panes | Gets or sets the collection of WebExplorerBar.
Public Property | PaneSettings | Contains WebExplorerBar settings such as BarStyle, BarFrameStyle, ImagesSettings, ContentMode, Bar size, ImageSize, and ImageHeight.
Public Property | RenderAsListBox | (Inherited from ISNet.WebUI.WebDesktop.WebNavPane)
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RenderMode | Gets or sets the rendering mode of WebExplorerPane.
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Gets or sets the directory where all required scripts for the control are stored. (Inherited from ISNet.WebUI.WebDesktop.WebNavPane)
Public Property | SharedScriptDirectory | Overridden.
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SpecialBarIndex | Gets or sets the Special WebExplorerBar index.
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ToolTip | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ValidationGroup | (Inherited from ISNet.WebUI.WebDesktop.WebNavPane)
Public Property | ViewStateItems | Gets or sets the items to be stored in view state storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | Gets or sets the server connection string for file server-based viewstate storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | Gets or sets the location to store the viewstate of this control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | Indicates whether the control is visible and rendered. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Width | The width of the control. (Inherited from ISNet.WebUI.WebDesktop.WebNavPane)
Public Property | XmlCompressionEnabled | Specifies whether the Xml used for clientside state storage should be compressed. (Inherited from ISNet.WebUI.ISNetControl)
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CheckConstrains | Overridden.
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. Overridden.
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadBarsStructureFromXml | Overloaded. (Inherited from ISNet.WebUI.WebDesktop.WebNavPane)
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPanesStructureFromXml | Overloaded.
Public Method | LoadPostData | Overridden.
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RecreateChildControls | (Inherited from ISNet.WebUI.WebDesktop.WebNavPane)
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveBarsStructureToXml | Overloaded. (Inherited from ISNet.WebUI.WebDesktop.WebNavPane)
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SavePanesStructureToXml |
Public Method | SaveTabsStructureToXml |
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SynchronizeTemplatesFrom | Overridden.
Top

Public Events

 | Name | Description
Public Event | ActiveBarChanged | Occurs when active bar is changed by user. (Inherited from ISNet.WebUI.WebDesktop.WebNavPane)
Public Event | ActiveBarItemChanged | Occurs when active bar item is changed by user. (Inherited from ISNet.WebUI.WebDesktop.WebNavPane)
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | ItemClick |
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebExplorerPane Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Creating Simple ExplorerPane

tasks

Configuring Expand and Collapse ExplorePane
Changing Inline content of ExplorerPane

Concepts

WebExplorer Overview

concepts

WebExplorer Concepts
WebExplorer Features


WebExplorerPane Constructor

[image]
Intersoft WebDesktop Documentation
WebExplorerPane Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : WebExplorerPane Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebExplorerPane()
C#
public WebExplorerPane()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


ApplyStyle Method

[image]
Intersoft WebDesktop Documentation
ApplyStyle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : ApplyStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ApplyStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim s As System.Web.UI.WebControls.Style

instance.ApplyStyle(s)
C#
public void ApplyStyle(
   System.Web.UI.WebControls.Style s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


ApplyStyleSheetSkin Method

[image]
Intersoft WebDesktop Documentation
ApplyStyleSheetSkin Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : ApplyStyleSheetSkin Method

page

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub ApplyStyleSheetSkin( _
   ByVal page As System.Web.UI.Page _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim page As System.Web.UI.Page

instance.ApplyStyleSheetSkin(page)
C#
public virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page page
)

Parameters

page

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


CanUseWebResources Method

[image]
Intersoft WebDesktop Documentation
CanUseWebResources Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : CanUseWebResources Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CanUseWebResources() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As Boolean

value = instance.CanUseWebResources()
C#
public bool CanUseWebResources()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


WebExplorerPane Class Methods

[image]
Intersoft WebDesktop Documentation
WebExplorerPane Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebExplorerPane Class

Glossary Item Box

For a list of all members of this type, see WebExplorerPane members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CheckConstrains | Overridden.
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. Overridden.
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadBarsStructureFromXml | Overloaded. (Inherited from ISNet.WebUI.WebDesktop.WebNavPane)
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPanesStructureFromXml | Overloaded.
Public Method | LoadPostData | Overridden.
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RecreateChildControls | (Inherited from ISNet.WebUI.WebDesktop.WebNavPane)
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveBarsStructureToXml | Overloaded. (Inherited from ISNet.WebUI.WebDesktop.WebNavPane)
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SavePanesStructureToXml |
Public Method | SaveTabsStructureToXml |
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SynchronizeTemplatesFrom | Overridden.
Top

See Also

Reference

WebExplorerPane Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Creating Simple ExplorerPane

tasks

Configuring Expand and Collapse ExplorePane
Changing Inline content of ExplorerPane

Concepts

WebExplorer Overview

concepts

WebExplorer Concepts
WebExplorer Features


CheckConstrains Method

[image]
Intersoft WebDesktop Documentation
CheckConstrains Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : CheckConstrains Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub CheckConstrains()
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane

instance.CheckConstrains()
C#
public override void CheckConstrains()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


CopyBaseAttributes Method

[image]
Intersoft WebDesktop Documentation
CopyBaseAttributes Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : CopyBaseAttributes Method

controlSrc

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyBaseAttributes( _
   ByVal controlSrc As System.Web.UI.WebControls.WebControl _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim controlSrc As System.Web.UI.WebControls.WebControl

instance.CopyBaseAttributes(controlSrc)
C#
public void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl controlSrc
)

Parameters

controlSrc

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object,Boolean) |
CopyFrom(Object) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public override void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members
Overload List


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members
Overload List


DataBind Method

[image]
Intersoft WebDesktop Documentation
DataBind Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : DataBind Method

Glossary Item Box

Overload List

Overload | Description
DataBind | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


DataBind() Method

[image]
Intersoft WebDesktop Documentation
DataBind() Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : DataBind() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub DataBind()
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane

instance.DataBind()
C#
public virtual void DataBind()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


Dispose Method

[image]
Intersoft WebDesktop Documentation
Dispose Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : Dispose Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane

instance.Dispose()
C#
public virtual void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


FindControl Method

[image]
Intersoft WebDesktop Documentation
FindControl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : FindControl Method

Glossary Item Box

Overload List

Overload | Description
FindControl | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


FindControl(String) Method

[image]
Intersoft WebDesktop Documentation
FindControl(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : FindControl(String) Method

id

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function FindControl( _
   ByVal id As String _
) As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim id As String
Dim value As System.Web.UI.Control

value = instance.FindControl(id)
C#
public virtual System.Web.UI.Control FindControl(
   string id
)

Parameters

id

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


Focus Method

[image]
Intersoft WebDesktop Documentation
Focus Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : Focus Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Focus()
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane

instance.Focus()
C#
public virtual void Focus()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


ForceDisableXmlCompression Method

[image]
Intersoft WebDesktop Documentation
ForceDisableXmlCompression Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : ForceDisableXmlCompression Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ForceDisableXmlCompression()
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane

instance.ForceDisableXmlCompression()
C#
public void ForceDisableXmlCompression()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


GetCurrentControlLifeCycle Method

[image]
Intersoft WebDesktop Documentation
GetCurrentControlLifeCycle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : GetCurrentControlLifeCycle Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentControlLifeCycle() As ISNet.WebUI.ControlLifeCycle
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As ISNet.WebUI.ControlLifeCycle

value = instance.GetCurrentControlLifeCycle()
C#
public ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


GetCurrentTheme Method

[image]
Intersoft WebDesktop Documentation
GetCurrentTheme Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : GetCurrentTheme Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentTheme() As ISNet.WebUI.ThemeInfo
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As ISNet.WebUI.ThemeInfo

value = instance.GetCurrentTheme()
C#
public ISNet.WebUI.ThemeInfo GetCurrentTheme()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


GetFrameworkDataFolder Method

[image]
Intersoft WebDesktop Documentation
GetFrameworkDataFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : GetFrameworkDataFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkDataFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As String

value = instance.GetFrameworkDataFolder()
C#
public string GetFrameworkDataFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


GetFrameworkFolder Method

[image]
Intersoft WebDesktop Documentation
GetFrameworkFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : GetFrameworkFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As String

value = instance.GetFrameworkFolder()
C#
public string GetFrameworkFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


GetFrameworkVersion Method

[image]
Intersoft WebDesktop Documentation
GetFrameworkVersion Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : GetFrameworkVersion Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkVersion() As Version
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As Version

value = instance.GetFrameworkVersion()
C#
public Version GetFrameworkVersion()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


GetIntersoftFolder Method

[image]
Intersoft WebDesktop Documentation
GetIntersoftFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : GetIntersoftFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetIntersoftFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As String

value = instance.GetIntersoftFolder()
C#
public string GetIntersoftFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


GetLayoutFolder Method

[image]
Intersoft WebDesktop Documentation
GetLayoutFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : GetLayoutFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetLayoutFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As String

value = instance.GetLayoutFolder()
C#
public string GetLayoutFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


GetPostedXMLData Method

[image]
Intersoft WebDesktop Documentation
GetPostedXMLData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : GetPostedXMLData Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPostedXMLData() As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As String

value = instance.GetPostedXMLData()
C#
public string GetPostedXMLData()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


GetProductInfoKey Method

[image]
Intersoft WebDesktop Documentation
GetProductInfoKey Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : GetProductInfoKey Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductInfoKey() As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As String

value = instance.GetProductInfoKey()
C#
public string GetProductInfoKey()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


GetProductSimpleName Method

[image]
Intersoft WebDesktop Documentation
GetProductSimpleName Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : GetProductSimpleName Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductSimpleName() As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As String

value = instance.GetProductSimpleName()
C#
public string GetProductSimpleName()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


GetPropertyValue Method

[image]
Intersoft WebDesktop Documentation
GetPropertyValue Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : GetPropertyValue Method

defValue
propValue
webConfigKey

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPropertyValue( _
   ByVal defValue As String, _
   ByVal propValue As String, _
   ByVal webConfigKey As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim defValue As String
Dim propValue As String
Dim webConfigKey As String
Dim value As String

value = instance.GetPropertyValue(defValue, propValue, webConfigKey)
C#
public string GetPropertyValue(
   string defValue,
   string propValue,
   string webConfigKey
)

Parameters

defValue
propValue
webConfigKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


GetResourceStream Method

[image]
Intersoft WebDesktop Documentation
GetResourceStream Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : GetResourceStream Method

resourceUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetResourceStream( _
   ByVal resourceUrl As String _
) As System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim resourceUrl As String
Dim value As System.IO.Stream

value = instance.GetResourceStream(resourceUrl)
C#
public System.IO.Stream GetResourceStream(
   string resourceUrl
)

Parameters

resourceUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


GetRouteUrl Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : GetRouteUrl Method

Glossary Item Box

Overload List

Overload | Description
GetRouteUrl(Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(RouteValueDictionary) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,RouteValueDictionary) | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


GetRouteUrl(Object) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class > GetRouteUrl Method : GetRouteUrl(Object) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As Object _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim routeParameters As Object
Dim value As String

value = instance.GetRouteUrl(routeParameters)
C#
public string GetRouteUrl(
   object routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members
Overload List


GetRouteUrl(String,Object) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(String,Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class > GetRouteUrl Method : GetRouteUrl(String,Object) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As String, _
   ByVal routeParameters As Object _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim routeName As String
Dim routeParameters As Object
Dim value As String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public string GetRouteUrl(
   string routeName,
   object routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members
Overload List


GetRouteUrl(RouteValueDictionary) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(RouteValueDictionary) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class > GetRouteUrl Method : GetRouteUrl(RouteValueDictionary) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As String

value = instance.GetRouteUrl(routeParameters)
C#
public string GetRouteUrl(
   System.Web.Routing.RouteValueDictionary routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members
Overload List


GetRouteUrl(String,RouteValueDictionary) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(String,RouteValueDictionary) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class > GetRouteUrl Method : GetRouteUrl(String,RouteValueDictionary) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As String, _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim routeName As String
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public string GetRouteUrl(
   string routeName,
   System.Web.Routing.RouteValueDictionary routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members
Overload List


GetUniqueIDRelativeTo Method

[image]
Intersoft WebDesktop Documentation
GetUniqueIDRelativeTo Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : GetUniqueIDRelativeTo Method

control

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetUniqueIDRelativeTo( _
   ByVal control As System.Web.UI.Control _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim control As System.Web.UI.Control
Dim value As String

value = instance.GetUniqueIDRelativeTo(control)
C#
public string GetUniqueIDRelativeTo(
   System.Web.UI.Control control
)

Parameters

control

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


HasControls Method

[image]
Intersoft WebDesktop Documentation
HasControls Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : HasControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function HasControls() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As Boolean

value = instance.HasControls()
C#
public virtual bool HasControls()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


IsAtlasCallback Method

[image]
Intersoft WebDesktop Documentation
IsAtlasCallback Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : IsAtlasCallback Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsAtlasCallback() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As Boolean

value = instance.IsAtlasCallback()
C#
public bool IsAtlasCallback()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


IsBetaRelease Method

[image]
Intersoft WebDesktop Documentation
IsBetaRelease Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : IsBetaRelease Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsBetaRelease() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As Boolean

value = instance.IsBetaRelease()
C#
public bool IsBetaRelease()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


IsChromeBrowser Method

[image]
Intersoft WebDesktop Documentation
IsChromeBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : IsChromeBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsChromeBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As Boolean

value = instance.IsChromeBrowser()
C#
public bool IsChromeBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


IsFlyPostBackControl Method

[image]
Intersoft WebDesktop Documentation
IsFlyPostBackControl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : IsFlyPostBackControl Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackControl() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As Boolean

value = instance.IsFlyPostBackControl()
C#
public virtual bool IsFlyPostBackControl()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


IsFlyPostBackRequest Method

[image]
Intersoft WebDesktop Documentation
IsFlyPostBackRequest Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : IsFlyPostBackRequest Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackRequest() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As Boolean

value = instance.IsFlyPostBackRequest()
C#
public virtual bool IsFlyPostBackRequest()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


IsGeckoBasedBrowser Method

[image]
Intersoft WebDesktop Documentation
IsGeckoBasedBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : IsGeckoBasedBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoBasedBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As Boolean

value = instance.IsGeckoBasedBrowser()
C#
public bool IsGeckoBasedBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


IsGeckoVersion18 Method

[image]
Intersoft WebDesktop Documentation
IsGeckoVersion18 Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : IsGeckoVersion18 Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoVersion18() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As Boolean

value = instance.IsGeckoVersion18()
C#
public bool IsGeckoVersion18()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


IsInDesignMode Method

[image]
Intersoft WebDesktop Documentation
IsInDesignMode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : IsInDesignMode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInDesignMode() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As Boolean

value = instance.IsInDesignMode()
C#
public bool IsInDesignMode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


IsInternetExplorer8Browser Method

[image]
Intersoft WebDesktop Documentation
IsInternetExplorer8Browser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : IsInternetExplorer8Browser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorer8Browser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As Boolean

value = instance.IsInternetExplorer8Browser()
C#
public bool IsInternetExplorer8Browser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


IsInternetExplorerBrowser Method

[image]
Intersoft WebDesktop Documentation
IsInternetExplorerBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : IsInternetExplorerBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorerBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As Boolean

value = instance.IsInternetExplorerBrowser()
C#
public bool IsInternetExplorerBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


IsOperaBrowser Method

[image]
Intersoft WebDesktop Documentation
IsOperaBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : IsOperaBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsOperaBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As Boolean

value = instance.IsOperaBrowser()
C#
public bool IsOperaBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


IsSafariBrowser Method

[image]
Intersoft WebDesktop Documentation
IsSafariBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : IsSafariBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsSafariBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As Boolean

value = instance.IsSafariBrowser()
C#
public bool IsSafariBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


IsW3CStandardBrowser Method

[image]
Intersoft WebDesktop Documentation
IsW3CStandardBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : IsW3CStandardBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsW3CStandardBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As Boolean

value = instance.IsW3CStandardBrowser()
C#
public bool IsW3CStandardBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


LoadLayout Method

[image]
Intersoft WebDesktop Documentation
LoadLayout Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : LoadLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim settings As ISNet.WebUI.LayoutInfo

instance.LoadLayout(settings)
C#
public virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


LoadLayoutFromFile Method

[image]
Intersoft WebDesktop Documentation
LoadLayoutFromFile Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : LoadLayoutFromFile Method

filePath

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromFile( _
   ByVal filePath As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim filePath As String

instance.LoadLayoutFromFile(filePath)
C#
public virtual void LoadLayoutFromFile(
   string filePath
)

Parameters

filePath

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


LoadLayoutFromPredefinedName Method

[image]
Intersoft WebDesktop Documentation
LoadLayoutFromPredefinedName Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : LoadLayoutFromPredefinedName Method

predefinedName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromPredefinedName( _
   ByVal predefinedName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim predefinedName As String

instance.LoadLayoutFromPredefinedName(predefinedName)
C#
public virtual void LoadLayoutFromPredefinedName(
   string predefinedName
)

Parameters

predefinedName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


LoadLayoutFromStream Method

[image]
Intersoft WebDesktop Documentation
LoadLayoutFromStream Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : LoadLayoutFromStream Method

stream

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromStream( _
   ByVal stream As System.IO.Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim stream As System.IO.Stream

instance.LoadLayoutFromStream(stream)
C#
public virtual void LoadLayoutFromStream(
   System.IO.Stream stream
)

Parameters

stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


LoadPanesStructureFromXml Method

[image]
Intersoft WebDesktop Documentation
LoadPanesStructureFromXml Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : LoadPanesStructureFromXml Method

Glossary Item Box

Overload List

Overload | Description
LoadPanesStructureFromXml(Stream) |
LoadPanesStructureFromXml(String) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


LoadPanesStructureFromXml(Stream) Method

[image]
Intersoft WebDesktop Documentation
LoadPanesStructureFromXml(Stream) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class > LoadPanesStructureFromXml Method : LoadPanesStructureFromXml(Stream) Method

stream

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadPanesStructureFromXml( _
   ByVal stream As System.IO.Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim stream As System.IO.Stream

instance.LoadPanesStructureFromXml(stream)
C#
public void LoadPanesStructureFromXml(
   System.IO.Stream stream
)

Parameters

stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members
Overload List


LoadPanesStructureFromXml(String) Method

[image]
Intersoft WebDesktop Documentation
LoadPanesStructureFromXml(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class > LoadPanesStructureFromXml Method : LoadPanesStructureFromXml(String) Method

fileName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadPanesStructureFromXml( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim fileName As String

instance.LoadPanesStructureFromXml(fileName)
C#
public void LoadPanesStructureFromXml(
   string fileName
)

Parameters

fileName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members
Overload List


LoadPostData Method

[image]
Intersoft WebDesktop Documentation
LoadPostData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : LoadPostData Method

postDataKey
postCollection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function LoadPostData( _
   ByVal postDataKey As String, _
   ByVal postCollection As System.Collections.Specialized.NameValueCollection _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim postDataKey As String
Dim postCollection As System.Collections.Specialized.NameValueCollection
Dim value As Boolean

value = instance.LoadPostData(postDataKey, postCollection)
C#
public override bool LoadPostData(
   string postDataKey,
   System.Collections.Specialized.NameValueCollection postCollection
)

Parameters

postDataKey
postCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


MergeStyle Method

[image]
Intersoft WebDesktop Documentation
MergeStyle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : MergeStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub MergeStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim s As System.Web.UI.WebControls.Style

instance.MergeStyle(s)
C#
public void MergeStyle(
   System.Web.UI.WebControls.Style s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


OnInfoChanged Method

[image]
Intersoft WebDesktop Documentation
OnInfoChanged Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : OnInfoChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnInfoChanged( _
   ByVal e As ISNet.WebUI.SynchronizeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim e As ISNet.WebUI.SynchronizeEventArgs

instance.OnInfoChanged(e)
C#
public void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


OnPreInitialize Method

[image]
Intersoft WebDesktop Documentation
OnPreInitialize Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : OnPreInitialize Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnPreInitialize()
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane

instance.OnPreInitialize()
C#
public virtual void OnPreInitialize()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


RaisePostDataChangedEvent Method

[image]
Intersoft WebDesktop Documentation
RaisePostDataChangedEvent Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : RaisePostDataChangedEvent Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RaisePostDataChangedEvent()
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane

instance.RaisePostDataChangedEvent()
C#
public virtual void RaisePostDataChangedEvent()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


ReadWebConfigValue Method

[image]
Intersoft WebDesktop Documentation
ReadWebConfigValue Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : ReadWebConfigValue Method

key

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ReadWebConfigValue( _
   ByVal key As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim key As String
Dim value As String

value = instance.ReadWebConfigValue(key)
C#
public string ReadWebConfigValue(
   string key
)

Parameters

key

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


RegisterBoxSizing Method

[image]
Intersoft WebDesktop Documentation
RegisterBoxSizing Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : RegisterBoxSizing Method

Glossary Item Box

Overload List

Overload | Description
RegisterBoxSizing() | (Inherited from ISNet.WebUI.ISNetControl)
RegisterBoxSizing(Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


RegisterBoxSizing() Method

[image]
Intersoft WebDesktop Documentation
RegisterBoxSizing() Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class > RegisterBoxSizing Method : RegisterBoxSizing() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing()
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane

instance.RegisterBoxSizing()
C#
public void RegisterBoxSizing()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members
Overload List


RegisterBoxSizing(Boolean) Method

[image]
Intersoft WebDesktop Documentation
RegisterBoxSizing(Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class > RegisterBoxSizing Method : RegisterBoxSizing(Boolean) Method

forceAll

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing( _
   ByVal forceAll As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim forceAll As Boolean

instance.RegisterBoxSizing(forceAll)
C#
public void RegisterBoxSizing(
   bool forceAll
)

Parameters

forceAll

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members
Overload List


RegisterGlobalStyle Method

[image]
Intersoft WebDesktop Documentation
RegisterGlobalStyle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : RegisterGlobalStyle Method

style

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterGlobalStyle( _
   ByVal style As ISNet.WebUI.WebStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim style As ISNet.WebUI.WebStyle

instance.RegisterGlobalStyle(style)
C#
public void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle style
)

Parameters

style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


RegisterLink Method

[image]
Intersoft WebDesktop Documentation
RegisterLink Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : RegisterLink Method

name
url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterLink( _
   ByVal name As String, _
   ByVal url As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim name As String
Dim url As String

instance.RegisterLink(name, url)
C#
public void RegisterLink(
   string name,
   string url
)

Parameters

name
url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


RegisterOptimizedCssClasses Method

[image]
Intersoft WebDesktop Documentation
RegisterOptimizedCssClasses Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : RegisterOptimizedCssClasses Method

runtimeStyleOnly

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterOptimizedCssClasses( _
   ByVal runtimeStyleOnly As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim runtimeStyleOnly As Boolean

instance.RegisterOptimizedCssClasses(runtimeStyleOnly)
C#
public void RegisterOptimizedCssClasses(
   bool runtimeStyleOnly
)

Parameters

runtimeStyleOnly

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


RegisterPreloadImage Method

[image]
Intersoft WebDesktop Documentation
RegisterPreloadImage Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : RegisterPreloadImage Method

image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterPreloadImage( _
   ByVal image As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim image As String

instance.RegisterPreloadImage(image)
C#
public void RegisterPreloadImage(
   string image
)

Parameters

image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


RegisterSharePointHandler Method

[image]
Intersoft WebDesktop Documentation
RegisterSharePointHandler Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : RegisterSharePointHandler Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RegisterSharePointHandler()
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane

instance.RegisterSharePointHandler()
C#
public virtual void RegisterSharePointHandler()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


RenderBeginTag Method

[image]
Intersoft WebDesktop Documentation
RenderBeginTag Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : RenderBeginTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderBeginTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderBeginTag(writer)
C#
public virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


RenderControl Method

[image]
Intersoft WebDesktop Documentation
RenderControl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : RenderControl Method

Glossary Item Box

Overload List

Overload | Description
RenderControl | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


RenderControl(HtmlTextWriter) Method

[image]
Intersoft WebDesktop Documentation
RenderControl(HtmlTextWriter) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : RenderControl(HtmlTextWriter) Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderControl( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderControl(writer)
C#
public virtual void RenderControl(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


RenderEndTag Method

[image]
Intersoft WebDesktop Documentation
RenderEndTag Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : RenderEndTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderEndTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderEndTag(writer)
C#
public virtual void RenderEndTag(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


ResolveClientUrl Method

[image]
Intersoft WebDesktop Documentation
ResolveClientUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : ResolveClientUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveClientUrl( _
   ByVal relativeUrl As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim relativeUrl As String
Dim value As String

value = instance.ResolveClientUrl(relativeUrl)
C#
public string ResolveClientUrl(
   string relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


ResolveImagePath Method

[image]
Intersoft WebDesktop Documentation
ResolveImagePath Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : ResolveImagePath Method

folder
image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveImagePath( _
   ByVal folder As String, _
   ByVal image As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim folder As String
Dim image As String
Dim value As String

value = instance.ResolveImagePath(folder, image)
C#
public string ResolveImagePath(
   string folder,
   string image
)

Parameters

folder
image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


ResolveRelativeURL Method

[image]
Intersoft WebDesktop Documentation
ResolveRelativeURL Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : ResolveRelativeURL Method

url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ResolveRelativeURL( _
   ByVal url As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim url As String
Dim value As String

value = instance.ResolveRelativeURL(url)
C#
public virtual string ResolveRelativeURL(
   string url
)

Parameters

url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


ResolveResourceUrl Method

[image]
Intersoft WebDesktop Documentation
ResolveResourceUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : ResolveResourceUrl Method

kind
defaultFolder
currentFolder
resourceName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveResourceUrl( _
   ByVal kind As ISNet.WebUI.ResourceKind, _
   ByVal defaultFolder As String, _
   ByVal currentFolder As String, _
   ByVal resourceName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim kind As ISNet.WebUI.ResourceKind
Dim defaultFolder As String
Dim currentFolder As String
Dim resourceName As String
Dim value As String

value = instance.ResolveResourceUrl(kind, defaultFolder, currentFolder, resourceName)
C#
public string ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   string defaultFolder,
   string currentFolder,
   string resourceName
)

Parameters

kind
defaultFolder
currentFolder
resourceName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


ResolveUrl Method

[image]
Intersoft WebDesktop Documentation
ResolveUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : ResolveUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveUrl( _
   ByVal relativeUrl As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim relativeUrl As String
Dim value As String

value = instance.ResolveUrl(relativeUrl)
C#
public string ResolveUrl(
   string relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


SaveLayout Method

[image]
Intersoft WebDesktop Documentation
SaveLayout Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : SaveLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim settings As ISNet.WebUI.LayoutInfo

instance.SaveLayout(settings)
C#
public virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


SaveLayoutToFile Method

[image]
Intersoft WebDesktop Documentation
SaveLayoutToFile Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : SaveLayoutToFile Method

filePath
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToFile( _
   ByVal filePath As String, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim filePath As String
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToFile(filePath, saveOptions)
C#
public virtual void SaveLayoutToFile(
   string filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

filePath
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


SaveLayoutToStream Method

[image]
Intersoft WebDesktop Documentation
SaveLayoutToStream Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : SaveLayoutToStream Method

stream
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToStream( _
   ByVal stream As System.IO.Stream, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim stream As System.IO.Stream
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToStream(stream, saveOptions)
C#
public virtual void SaveLayoutToStream(
   System.IO.Stream stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

stream
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


SavePanesStructureToXml Method

[image]
Intersoft WebDesktop Documentation
SavePanesStructureToXml Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : SavePanesStructureToXml Method

fileName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SavePanesStructureToXml( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim fileName As String

instance.SavePanesStructureToXml(fileName)
C#
public void SavePanesStructureToXml(
   string fileName
)

Parameters

fileName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


SaveTabsStructureToXml Method

[image]
Intersoft WebDesktop Documentation
SaveTabsStructureToXml Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : SaveTabsStructureToXml Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function SaveTabsStructureToXml() As System.Xml.XmlDocument
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As System.Xml.XmlDocument

value = instance.SaveTabsStructureToXml()
C#
public System.Xml.XmlDocument SaveTabsStructureToXml()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


SetRenderMethodDelegate Method

[image]
Intersoft WebDesktop Documentation
SetRenderMethodDelegate Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : SetRenderMethodDelegate Method

renderMethod

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetRenderMethodDelegate( _
   ByVal renderMethod As System.Web.UI.RenderMethod _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim renderMethod As System.Web.UI.RenderMethod

instance.SetRenderMethodDelegate(renderMethod)
C#
public void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod renderMethod
)

Parameters

renderMethod

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


SetSessionTheme Method

[image]
Intersoft WebDesktop Documentation
SetSessionTheme Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : SetSessionTheme Method

themeInfo

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetSessionTheme( _
   ByVal themeInfo As ISNet.WebUI.ThemeInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim themeInfo As ISNet.WebUI.ThemeInfo

instance.SetSessionTheme(themeInfo)
C#
public void SetSessionTheme(
   ISNet.WebUI.ThemeInfo themeInfo
)

Parameters

themeInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


ShouldReturnJson Method

[image]
Intersoft WebDesktop Documentation
ShouldReturnJson Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : ShouldReturnJson Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ShouldReturnJson() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As Boolean

value = instance.ShouldReturnJson()
C#
public virtual bool ShouldReturnJson()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


SynchronizeTemplatesFrom Method

[image]
Intersoft WebDesktop Documentation
SynchronizeTemplatesFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : SynchronizeTemplatesFrom Method

sourceObj

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub SynchronizeTemplatesFrom( _
   ByVal sourceObj As ISNet.WebUI.ISNetControl _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim sourceObj As ISNet.WebUI.ISNetControl

instance.SynchronizeTemplatesFrom(sourceObj)
C#
public override void SynchronizeTemplatesFrom(
   ISNet.WebUI.ISNetControl sourceObj
)

Parameters

sourceObj

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


AccessKey Property

[image]
Intersoft WebDesktop Documentation
AccessKey Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : AccessKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property AccessKey As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As String

instance.AccessKey = value

value = instance.AccessKey
C#
public virtual string AccessKey {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


WebExplorerPane Class Properties

[image]
Intersoft WebDesktop Documentation
WebExplorerPane Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebExplorerPane Class

Glossary Item Box

For a list of all members of this type, see WebExplorerPane members.

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | AutoPostBack | Specifies whether the navbar or navbar_item should perform autopostback automatically when clicked. (Inherited from ISNet.WebUI.WebDesktop.WebNavPane)
Public Property | BackColor | Overridden. Background color of the control.
Public Property | BarItems | Overridden.
Public Property | BorderColor | Overridden. Color of the border around the control.
Public Property | BorderStyle | Overridden. Style of the border around the control.
Public Property | BorderWidth | Overridden. Width of the border around the control.
Public Property | CausesValidation | (Inherited from ISNet.WebUI.WebDesktop.WebNavPane)
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ClientSideEvents | Contains Javascript ClientSide events.
Public Property | ComplexImagesSettings | Contains images settings such as images to render the WebExplorerBar using RenderMode of ComplexImages.
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableAnimation | Specifies whether the WebExplorerPane support animation.
Public Property | Enabled | Enabled state of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableManagedTheming | Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to False, this control will not apply the style defined in Theme Architecture. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | Whether the control automatically saves its state for use in round-trips. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). (Inherited from ISNet.WebUI.ISNetControl)
Public Property | FrameStyle | Gets or sets the style applied to Frame. (Inherited from ISNet.WebUI.WebDesktop.WebNavPane)
Public Property | Height | (Inherited from ISNet.WebUI.WebDesktop.WebNavPane)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ImagesDirectory | Gets or sets the location of images used to render the control. (Inherited from ISNet.WebUI.WebDesktop.WebNavPane)
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | PaneItemSettings | Contains WebExplorerBarItem settings such as ItemStyle, ItemsPlaceholderStyle, DisplayMode, and ImagePosition.
Public Property | Panes | Gets or sets the collection of WebExplorerBar.
Public Property | PaneSettings | Contains WebExplorerBar settings such as BarStyle, BarFrameStyle, ImagesSettings, ContentMode, Bar size, ImageSize, and ImageHeight.
Public Property | RenderAsListBox | (Inherited from ISNet.WebUI.WebDesktop.WebNavPane)
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RenderMode | Gets or sets the rendering mode of WebExplorerPane.
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Gets or sets the directory where all required scripts for the control are stored. (Inherited from ISNet.WebUI.WebDesktop.WebNavPane)
Public Property | SharedScriptDirectory | Overridden.
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SpecialBarIndex | Gets or sets the Special WebExplorerBar index.
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ToolTip | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ValidationGroup | (Inherited from ISNet.WebUI.WebDesktop.WebNavPane)
Public Property | ViewStateItems | Gets or sets the items to be stored in view state storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | Gets or sets the server connection string for file server-based viewstate storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | Gets or sets the location to store the viewstate of this control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | Indicates whether the control is visible and rendered. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Width | The width of the control. (Inherited from ISNet.WebUI.WebDesktop.WebNavPane)
Public Property | XmlCompressionEnabled | Specifies whether the Xml used for clientside state storage should be compressed. (Inherited from ISNet.WebUI.ISNetControl)
Top

See Also

Reference

WebExplorerPane Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Creating Simple ExplorerPane

tasks

Configuring Expand and Collapse ExplorePane
Changing Inline content of ExplorerPane

Concepts

WebExplorer Overview

concepts

WebExplorer Concepts
WebExplorer Features


WebExplorerPane Constructor

[image]
Intersoft WebDesktop Documentation
WebExplorerPane Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : WebExplorerPane Constructor

Glossary Item Box

Initializes a new instance of the WebExplorerPane class.

Overload List

Overload | Description
WebExplorerPane Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


BackColor Property

[image]
Intersoft WebDesktop Documentation
BackColor Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : BackColor Property

Glossary Item Box

Background color of the control.

Syntax

Visual Basic (Declaration)
Public Overrides Property BackColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
C#
public override System.Drawing.Color BackColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


BarItems Property

[image]
Intersoft WebDesktop Documentation
BarItems Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : BarItems Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property BarItems As WebNavBarCollection
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As WebNavBarCollection

value = instance.BarItems
C#
public override WebNavBarCollection BarItems {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


BorderColor Property

[image]
Intersoft WebDesktop Documentation
BorderColor Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : BorderColor Property

Glossary Item Box

Color of the border around the control.

Syntax

Visual Basic (Declaration)
Public Overrides Property BorderColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As System.Drawing.Color

instance.BorderColor = value

value = instance.BorderColor
C#
public override System.Drawing.Color BorderColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


BorderStyle Property

[image]
Intersoft WebDesktop Documentation
BorderStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : BorderStyle Property

Glossary Item Box

Style of the border around the control.

Syntax

Visual Basic (Declaration)
Public Overrides Property BorderStyle As System.Web.UI.WebControls.BorderStyle
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As System.Web.UI.WebControls.BorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
C#
public override System.Web.UI.WebControls.BorderStyle BorderStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


BorderWidth Property

[image]
Intersoft WebDesktop Documentation
BorderWidth Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : BorderWidth Property

Glossary Item Box

Width of the border around the control.

Syntax

Visual Basic (Declaration)
Public Overrides Property BorderWidth As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As System.Web.UI.WebControls.Unit

instance.BorderWidth = value

value = instance.BorderWidth
C#
public override System.Web.UI.WebControls.Unit BorderWidth {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


ClientIDMode Property

[image]
Intersoft WebDesktop Documentation
ClientIDMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : ClientIDMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ClientIDMode As System.Web.UI.ClientIDMode
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As System.Web.UI.ClientIDMode

instance.ClientIDMode = value

value = instance.ClientIDMode
C#
public virtual System.Web.UI.ClientIDMode ClientIDMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


ClientSideEvents Property

[image]
Intersoft WebDesktop Documentation
ClientSideEvents Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : ClientSideEvents Property

Glossary Item Box

Contains Javascript ClientSide events.

Syntax

Visual Basic (Declaration)
Public Property ClientSideEvents As WebExplorerClientSideEvents
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As WebExplorerClientSideEvents

instance.ClientSideEvents = value

value = instance.ClientSideEvents
C#
public WebExplorerClientSideEvents ClientSideEvents {get; set;}

Remarks

WebExplorerPane exposed numerous client side events that you can consume in order to create rich interaction and extensible web applications. Following is the list of available client side events

  • OnAfterCollapse
  • OnAfterExpand
  • OnBeforeCollapse
  • OnBeforeExpand
  • OnClientUnload
  • OnInitialize
  • OnPaneHeaderClick
  • OnPaneItemClick

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members

Tasks

Handling Client Side Events

Concepts

WebExplorerPane Features


ComplexImagesSettings Property

[image]
Intersoft WebDesktop Documentation
ComplexImagesSettings Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : ComplexImagesSettings Property

Glossary Item Box

Contains images settings such as images to render the WebExplorerBar using RenderMode of ComplexImages.

Syntax

Visual Basic (Declaration)
Public Property ComplexImagesSettings As WebExplorerBarComplexImagesSettings
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As WebExplorerBarComplexImagesSettings

instance.ComplexImagesSettings = value

value = instance.ComplexImagesSettings
C#
public WebExplorerBarComplexImagesSettings ComplexImagesSettings {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


ControlDataTransferFormat Property

[image]
Intersoft WebDesktop Documentation
ControlDataTransferFormat Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : ControlDataTransferFormat Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ControlDataTransferFormat As ISNet.WebUI.DataTransferFormat
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As ISNet.WebUI.DataTransferFormat

instance.ControlDataTransferFormat = value

value = instance.ControlDataTransferFormat
C#
public virtual ISNet.WebUI.DataTransferFormat ControlDataTransferFormat {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


EnableAnimation Property

[image]
Intersoft WebDesktop Documentation
EnableAnimation Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : EnableAnimation Property

Glossary Item Box

Specifies whether the WebExplorerPane support animation.

Syntax

Visual Basic (Declaration)
Public Property EnableAnimation As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As Boolean

instance.EnableAnimation = value

value = instance.EnableAnimation
C#
public bool EnableAnimation {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


Enabled Property

[image]
Intersoft WebDesktop Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : Enabled Property

Glossary Item Box

Enabled state of the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property Enabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As Boolean

instance.Enabled = value

value = instance.Enabled
C#
public virtual bool Enabled {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


EnableManagedTheming Property

[image]
Intersoft WebDesktop Documentation
EnableManagedTheming Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : EnableManagedTheming Property

Glossary Item Box

Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to False, this control will not apply the style defined in Theme Architecture.

Syntax

Visual Basic (Declaration)
Public Overridable Property EnableManagedTheming As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As Boolean

instance.EnableManagedTheming = value

value = instance.EnableManagedTheming
C#
public virtual bool EnableManagedTheming {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


EnableTheming Property

[image]
Intersoft WebDesktop Documentation
EnableTheming Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : EnableTheming Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property EnableTheming As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As Boolean

instance.EnableTheming = value

value = instance.EnableTheming
C#
public virtual bool EnableTheming {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


EnableViewState Property

[image]
Intersoft WebDesktop Documentation
EnableViewState Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : EnableViewState Property

Glossary Item Box

Whether the control automatically saves its state for use in round-trips.

Syntax

Visual Basic (Declaration)
Public Overridable Property EnableViewState As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As Boolean

instance.EnableViewState = value

value = instance.EnableViewState
C#
public virtual bool EnableViewState {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


EnableWebResources Property

[image]
Intersoft WebDesktop Documentation
EnableWebResources Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : EnableWebResources Property

Glossary Item Box

Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory).

Syntax

Visual Basic (Declaration)
Public Property EnableWebResources As ISNet.WebUI.WebResourceType
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As ISNet.WebUI.WebResourceType

instance.EnableWebResources = value

value = instance.EnableWebResources
C#
public ISNet.WebUI.WebResourceType EnableWebResources {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


ID Property

[image]
Intersoft WebDesktop Documentation
ID Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : ID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ID As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As String

instance.ID = value

value = instance.ID
C#
public virtual string ID {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


Page Property

[image]
Intersoft WebDesktop Documentation
Page Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : Page Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Page As System.Web.UI.Page
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As System.Web.UI.Page

instance.Page = value

value = instance.Page
C#
public virtual System.Web.UI.Page Page {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


PaneItemSettings Property

[image]
Intersoft WebDesktop Documentation
PaneItemSettings Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : PaneItemSettings Property

Glossary Item Box

Contains WebExplorerBarItem settings such as ItemStyle, ItemsPlaceholderStyle, DisplayMode, and ImagePosition.

Syntax

Visual Basic (Declaration)
Public Property PaneItemSettings As WebNavPaneItemSettings
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As WebNavPaneItemSettings

instance.PaneItemSettings = value

value = instance.PaneItemSettings
C#
public WebNavPaneItemSettings PaneItemSettings {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


Panes Property

[image]
Intersoft WebDesktop Documentation
Panes Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : Panes Property

Glossary Item Box

Gets or sets the collection of WebExplorerBar.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Panes As WebExplorerBarCollection
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As WebExplorerBarCollection

value = instance.Panes
C#
public WebExplorerBarCollection Panes {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


PaneSettings Property

[image]
Intersoft WebDesktop Documentation
PaneSettings Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : PaneSettings Property

Glossary Item Box

Contains WebExplorerBar settings such as BarStyle, BarFrameStyle, ImagesSettings, ContentMode, Bar size, ImageSize, and ImageHeight.

Syntax

Visual Basic (Declaration)
Public Property PaneSettings As WebExplorerBarSettings
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As WebExplorerBarSettings

instance.PaneSettings = value

value = instance.PaneSettings
C#
public WebExplorerBarSettings PaneSettings {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


RenderingMode Property

[image]
Intersoft WebDesktop Documentation
RenderingMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : RenderingMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property RenderingMode As ISNet.WebUI.RenderMode
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As ISNet.WebUI.RenderMode

instance.RenderingMode = value

value = instance.RenderingMode
C#
public virtual ISNet.WebUI.RenderMode RenderingMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


RenderMode Property

[image]
Intersoft WebDesktop Documentation
RenderMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : RenderMode Property

Glossary Item Box

Gets or sets the rendering mode of WebExplorerPane.

Syntax

Visual Basic (Declaration)
Public Property RenderMode As RenderMode
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As RenderMode

instance.RenderMode = value

value = instance.RenderMode
C#
public RenderMode RenderMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


RuntimeLicenseKey Property

[image]
Intersoft WebDesktop Documentation
RuntimeLicenseKey Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : RuntimeLicenseKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property RuntimeLicenseKey As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As String

instance.RuntimeLicenseKey = value

value = instance.RuntimeLicenseKey
C#
public virtual string RuntimeLicenseKey {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


SharedScriptDirectory Property

[image]
Intersoft WebDesktop Documentation
SharedScriptDirectory Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : SharedScriptDirectory Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Property SharedScriptDirectory As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As String

instance.SharedScriptDirectory = value

value = instance.SharedScriptDirectory
C#
public override string SharedScriptDirectory {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


SkinID Property

[image]
Intersoft WebDesktop Documentation
SkinID Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : SkinID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property SkinID As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As String

instance.SkinID = value

value = instance.SkinID
C#
public virtual string SkinID {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


SpecialBarIndex Property

[image]
Intersoft WebDesktop Documentation
SpecialBarIndex Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : SpecialBarIndex Property

Glossary Item Box

Gets or sets the Special WebExplorerBar index.

Syntax

Visual Basic (Declaration)
Public Property SpecialBarIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As Integer

instance.SpecialBarIndex = value

value = instance.SpecialBarIndex
C#
public int SpecialBarIndex {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


TabIndex Property

[image]
Intersoft WebDesktop Documentation
TabIndex Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : TabIndex Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property TabIndex As Short
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As Short

instance.TabIndex = value

value = instance.TabIndex
C#
public virtual short TabIndex {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


ToolTip Property

[image]
Intersoft WebDesktop Documentation
ToolTip Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : ToolTip Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ToolTip As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As String

instance.ToolTip = value

value = instance.ToolTip
C#
public virtual string ToolTip {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


ValidateRequestMode Property

[image]
Intersoft WebDesktop Documentation
ValidateRequestMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : ValidateRequestMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ValidateRequestMode As System.Web.UI.ValidateRequestMode
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As System.Web.UI.ValidateRequestMode

instance.ValidateRequestMode = value

value = instance.ValidateRequestMode
C#
public virtual System.Web.UI.ValidateRequestMode ValidateRequestMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


ViewStateItems Property

[image]
Intersoft WebDesktop Documentation
ViewStateItems Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : ViewStateItems Property

Glossary Item Box

Gets or sets the items to be stored in view state storage.

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateItems As ISNet.WebUI.ViewStateItem
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As ISNet.WebUI.ViewStateItem

instance.ViewStateItems = value

value = instance.ViewStateItems
C#
public virtual ISNet.WebUI.ViewStateItem ViewStateItems {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


ViewStateMode Property

[image]
Intersoft WebDesktop Documentation
ViewStateMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : ViewStateMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateMode As System.Web.UI.ViewStateMode
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As System.Web.UI.ViewStateMode

instance.ViewStateMode = value

value = instance.ViewStateMode
C#
public virtual System.Web.UI.ViewStateMode ViewStateMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


ViewStateServerConnection Property

[image]
Intersoft WebDesktop Documentation
ViewStateServerConnection Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : ViewStateServerConnection Property

Glossary Item Box

Gets or sets the server connection string for file server-based viewstate storage.

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateServerConnection As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As String

instance.ViewStateServerConnection = value

value = instance.ViewStateServerConnection
C#
public virtual string ViewStateServerConnection {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


ViewStateStorage Property

[image]
Intersoft WebDesktop Documentation
ViewStateStorage Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : ViewStateStorage Property

Glossary Item Box

Gets or sets the location to store the viewstate of this control.

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateStorage As ISNet.WebUI.StateCacheStorage
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As ISNet.WebUI.StateCacheStorage

instance.ViewStateStorage = value

value = instance.ViewStateStorage
C#
public virtual ISNet.WebUI.StateCacheStorage ViewStateStorage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


Visible Property

[image]
Intersoft WebDesktop Documentation
Visible Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : Visible Property

Glossary Item Box

Indicates whether the control is visible and rendered.

Syntax

Visual Basic (Declaration)
Public Overridable Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public virtual bool Visible {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


XmlCompressionEnabled Property

[image]
Intersoft WebDesktop Documentation
XmlCompressionEnabled Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : XmlCompressionEnabled Property

Glossary Item Box

Specifies whether the Xml used for clientside state storage should be compressed.

Syntax

Visual Basic (Declaration)
Public Overridable Property XmlCompressionEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim value As Boolean

instance.XmlCompressionEnabled = value

value = instance.XmlCompressionEnabled
C#
public virtual bool XmlCompressionEnabled {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


DataBinding Event

[image]
Intersoft WebDesktop Documentation
DataBinding Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : DataBinding Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event DataBinding As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim handler As EventHandler

AddHandler instance.DataBinding, handler
C#
public event EventHandler DataBinding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


Disposed Event

[image]
Intersoft WebDesktop Documentation
Disposed Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim handler As EventHandler

AddHandler instance.Disposed, handler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


Init Event

[image]
Intersoft WebDesktop Documentation
Init Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : Init Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Init As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim handler As EventHandler

AddHandler instance.Init, handler
C#
public event EventHandler Init

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


WebExplorerPane Class Events

[image]
Intersoft WebDesktop Documentation
WebExplorerPane Class Events
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebExplorerPane Class

Glossary Item Box

For a list of all members of this type, see WebExplorerPane members.

Public Events

 | Name | Description
Public Event | ActiveBarChanged | Occurs when active bar is changed by user. (Inherited from ISNet.WebUI.WebDesktop.WebNavPane)
Public Event | ActiveBarItemChanged | Occurs when active bar item is changed by user. (Inherited from ISNet.WebUI.WebDesktop.WebNavPane)
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | ItemClick |
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebExplorerPane Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Creating Simple ExplorerPane

tasks

Configuring Expand and Collapse ExplorePane
Changing Inline content of ExplorerPane

Concepts

WebExplorer Overview

concepts

WebExplorer Concepts
WebExplorer Features


ItemClick Event

[image]
Intersoft WebDesktop Documentation
ItemClick Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : ItemClick Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event ItemClick As EventHandler(Of PaneItemClickEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim handler As EventHandler(Of PaneItemClickEventArgs)

AddHandler instance.ItemClick, handler
C#
public event EventHandler<PaneItemClickEventArgs> ItemClick

Event Data

The event handler receives an argument of type PaneItemClickEventArgs containing data related to this event. The following PaneItemClickEventArgs properties provide information specific to this event.

Property | Description
Item |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


Load Event

[image]
Intersoft WebDesktop Documentation
Load Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : Load Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Load As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim handler As EventHandler

AddHandler instance.Load, handler
C#
public event EventHandler Load

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


PreInitialize Event

[image]
Intersoft WebDesktop Documentation
PreInitialize Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : PreInitialize Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event PreInitialize As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim handler As EventHandler

AddHandler instance.PreInitialize, handler
C#
public event EventHandler PreInitialize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


PreRender Event

[image]
Intersoft WebDesktop Documentation
PreRender Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : PreRender Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event PreRender As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim handler As EventHandler

AddHandler instance.PreRender, handler
C#
public event EventHandler PreRender

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


Unload Event

[image]
Intersoft WebDesktop Documentation
Unload Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPane Class : Unload Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Unload As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPane
Dim handler As EventHandler

AddHandler instance.Unload, handler
C#
public event EventHandler Unload

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPane Class
WebExplorerPane Members


WebExplorerPaneImagesSettings Class

[image]
Intersoft WebDesktop Documentation
WebExplorerPaneImagesSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebExplorerPaneImagesSettings Class

Glossary Item Box

Contains image settings such as images of expand/collapse to all type of WebExplorerBar.

Object Model

WebExplorerPaneImagesSettings Class

Syntax

Visual Basic (Declaration)
Public Class WebExplorerPaneImagesSettings
   Inherits WebExplorerBarImagesSettings
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPaneImagesSettings
C#
public class WebExplorerPaneImagesSettings : WebExplorerBarImagesSettings, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebDesktop.WebExplorerBarImagesSettings
ISNet.WebUI.WebDesktop.WebExplorerPaneImagesSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPaneImagesSettings Members
ISNet.WebUI.WebDesktop Namespace


WebExplorerPaneImagesSettings Class Members

[image]
Intersoft WebDesktop Documentation
WebExplorerPaneImagesSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebExplorerPaneImagesSettings Class

Glossary Item Box

The following tables list the members exposed by WebExplorerPaneImagesSettings.

Public Constructors

 | Name | Description
Public Constructor | WebExplorerPaneImagesSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | CollapseImage | Overridden. Gets ot sets the collapse image for normal style of WebExplorerBar.
Public Property | CollapseImageOver | Overridden. Gets ot sets the collapse image for hovered style of WebExplorerBar.
Public Property | ExpandImage | Overridden. Gets ot sets the expand image for normal style of WebExplorerBar.
Public Property | ExpandImageOver | Overridden. Gets ot sets the expand image for hovered style of WebExplorerBar.
Public Property | SpecialCollapseImage | Gets or sets the collapse image for special WebExplorerBar.
Public Property | SpecialCollapseImageOver | Gets or sets the collapse image for hovered style of special WebExplorerBar.
Public Property | SpecialExpandImage | Gets or sets the expand image for special WebExplorerBar.
Public Property | SpecialExpandImageOver | Gets or sets the expand image for hovered style of special WebExplorerBar.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebExplorerPaneImagesSettings Class
ISNet.WebUI.WebDesktop Namespace


WebExplorerPaneImagesSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebExplorerPaneImagesSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPaneImagesSettings Class : WebExplorerPaneImagesSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebExplorerPaneImagesSettings()
C#
public WebExplorerPaneImagesSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPaneImagesSettings Class
WebExplorerPaneImagesSettings Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPaneImagesSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPaneImagesSettings
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPaneImagesSettings Class
WebExplorerPaneImagesSettings Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPaneImagesSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPaneImagesSettings Class
WebExplorerPaneImagesSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPaneImagesSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPaneImagesSettings
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPaneImagesSettings Class
WebExplorerPaneImagesSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPaneImagesSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPaneImagesSettings
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPaneImagesSettings Class
WebExplorerPaneImagesSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPaneImagesSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPaneImagesSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPaneImagesSettings Class
WebExplorerPaneImagesSettings Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPaneImagesSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPaneImagesSettings
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPaneImagesSettings Class
WebExplorerPaneImagesSettings Members


WebExplorerPaneImagesSettings Class Methods

[image]
Intersoft WebDesktop Documentation
WebExplorerPaneImagesSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebExplorerPaneImagesSettings Class

Glossary Item Box

For a list of all members of this type, see WebExplorerPaneImagesSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebExplorerPaneImagesSettings Class
ISNet.WebUI.WebDesktop Namespace


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPaneImagesSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPaneImagesSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPaneImagesSettings Class
WebExplorerPaneImagesSettings Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPaneImagesSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPaneImagesSettings
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPaneImagesSettings Class
WebExplorerPaneImagesSettings Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPaneImagesSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPaneImagesSettings

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPaneImagesSettings Class
WebExplorerPaneImagesSettings Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPaneImagesSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPaneImagesSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPaneImagesSettings Class
WebExplorerPaneImagesSettings Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPaneImagesSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPaneImagesSettings
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPaneImagesSettings Class
WebExplorerPaneImagesSettings Members


WebExplorerPaneImagesSettings Class Properties

[image]
Intersoft WebDesktop Documentation
WebExplorerPaneImagesSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebExplorerPaneImagesSettings Class

Glossary Item Box

For a list of all members of this type, see WebExplorerPaneImagesSettings members.

Public Properties

 | Name | Description
Public Property | CollapseImage | Overridden. Gets ot sets the collapse image for normal style of WebExplorerBar.
Public Property | CollapseImageOver | Overridden. Gets ot sets the collapse image for hovered style of WebExplorerBar.
Public Property | ExpandImage | Overridden. Gets ot sets the expand image for normal style of WebExplorerBar.
Public Property | ExpandImageOver | Overridden. Gets ot sets the expand image for hovered style of WebExplorerBar.
Public Property | SpecialCollapseImage | Gets or sets the collapse image for special WebExplorerBar.
Public Property | SpecialCollapseImageOver | Gets or sets the collapse image for hovered style of special WebExplorerBar.
Public Property | SpecialExpandImage | Gets or sets the expand image for special WebExplorerBar.
Public Property | SpecialExpandImageOver | Gets or sets the expand image for hovered style of special WebExplorerBar.
Top

See Also

Reference

WebExplorerPaneImagesSettings Class
ISNet.WebUI.WebDesktop Namespace


WebExplorerPaneImagesSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebExplorerPaneImagesSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPaneImagesSettings Class : WebExplorerPaneImagesSettings Constructor

Glossary Item Box

Initializes a new instance of the WebExplorerPaneImagesSettings class.

Overload List

Overload | Description
WebExplorerPaneImagesSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPaneImagesSettings Class
WebExplorerPaneImagesSettings Members


CollapseImage Property

[image]
Intersoft WebDesktop Documentation
CollapseImage Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPaneImagesSettings Class : CollapseImage Property

Glossary Item Box

Gets ot sets the collapse image for normal style of WebExplorerBar.

Syntax

Visual Basic (Declaration)
Public Overrides Property CollapseImage As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPaneImagesSettings
Dim value As String

instance.CollapseImage = value

value = instance.CollapseImage
C#
public override string CollapseImage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPaneImagesSettings Class
WebExplorerPaneImagesSettings Members


CollapseImageOver Property

[image]
Intersoft WebDesktop Documentation
CollapseImageOver Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPaneImagesSettings Class : CollapseImageOver Property

Glossary Item Box

Gets ot sets the collapse image for hovered style of WebExplorerBar.

Syntax

Visual Basic (Declaration)
Public Overrides Property CollapseImageOver As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPaneImagesSettings
Dim value As String

instance.CollapseImageOver = value

value = instance.CollapseImageOver
C#
public override string CollapseImageOver {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPaneImagesSettings Class
WebExplorerPaneImagesSettings Members


ExpandImage Property

[image]
Intersoft WebDesktop Documentation
ExpandImage Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPaneImagesSettings Class : ExpandImage Property

Glossary Item Box

Gets ot sets the expand image for normal style of WebExplorerBar.

Syntax

Visual Basic (Declaration)
Public Overrides Property ExpandImage As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPaneImagesSettings
Dim value As String

instance.ExpandImage = value

value = instance.ExpandImage
C#
public override string ExpandImage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPaneImagesSettings Class
WebExplorerPaneImagesSettings Members


ExpandImageOver Property

[image]
Intersoft WebDesktop Documentation
ExpandImageOver Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPaneImagesSettings Class : ExpandImageOver Property

Glossary Item Box

Gets ot sets the expand image for hovered style of WebExplorerBar.

Syntax

Visual Basic (Declaration)
Public Overrides Property ExpandImageOver As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPaneImagesSettings
Dim value As String

instance.ExpandImageOver = value

value = instance.ExpandImageOver
C#
public override string ExpandImageOver {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPaneImagesSettings Class
WebExplorerPaneImagesSettings Members


SpecialCollapseImage Property

[image]
Intersoft WebDesktop Documentation
SpecialCollapseImage Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPaneImagesSettings Class : SpecialCollapseImage Property

Glossary Item Box

Gets or sets the collapse image for special WebExplorerBar.

Syntax

Visual Basic (Declaration)
Public Property SpecialCollapseImage As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPaneImagesSettings
Dim value As String

instance.SpecialCollapseImage = value

value = instance.SpecialCollapseImage
C#
public string SpecialCollapseImage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPaneImagesSettings Class
WebExplorerPaneImagesSettings Members


SpecialCollapseImageOver Property

[image]
Intersoft WebDesktop Documentation
SpecialCollapseImageOver Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPaneImagesSettings Class : SpecialCollapseImageOver Property

Glossary Item Box

Gets or sets the collapse image for hovered style of special WebExplorerBar.

Syntax

Visual Basic (Declaration)
Public Property SpecialCollapseImageOver As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPaneImagesSettings
Dim value As String

instance.SpecialCollapseImageOver = value

value = instance.SpecialCollapseImageOver
C#
public string SpecialCollapseImageOver {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPaneImagesSettings Class
WebExplorerPaneImagesSettings Members


SpecialExpandImage Property

[image]
Intersoft WebDesktop Documentation
SpecialExpandImage Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPaneImagesSettings Class : SpecialExpandImage Property

Glossary Item Box

Gets or sets the expand image for special WebExplorerBar.

Syntax

Visual Basic (Declaration)
Public Property SpecialExpandImage As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPaneImagesSettings
Dim value As String

instance.SpecialExpandImage = value

value = instance.SpecialExpandImage
C#
public string SpecialExpandImage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPaneImagesSettings Class
WebExplorerPaneImagesSettings Members


SpecialExpandImageOver Property

[image]
Intersoft WebDesktop Documentation
SpecialExpandImageOver Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebExplorerPaneImagesSettings Class : SpecialExpandImageOver Property

Glossary Item Box

Gets or sets the expand image for hovered style of special WebExplorerBar.

Syntax

Visual Basic (Declaration)
Public Property SpecialExpandImageOver As String
Visual Basic (Usage) Copy Code
Dim instance As WebExplorerPaneImagesSettings
Dim value As String

instance.SpecialExpandImageOver = value

value = instance.SpecialExpandImageOver
C#
public string SpecialExpandImageOver {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExplorerPaneImagesSettings Class
WebExplorerPaneImagesSettings Members


WebFlyPostBackListener Class

[image]
Intersoft WebDesktop Documentation
WebFlyPostBackListener Class
Members Example See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebFlyPostBackListener Class

Glossary Item Box

Listener function in WebFlyPostBack to listen or detect if there is any request from WebFlyPostBackManager.

Object Model

WebFlyPostBackListener Class

Syntax

Visual Basic (Declaration)
Public Class WebFlyPostBackListener
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.IFlyPostBack
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackListener
C#
public class WebFlyPostBackListener : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.IFlyPostBack

Example

The following code shows you how to create WebFlyPostBackListener on the page.
C# Copy Code
protected void Page_Load(object sender, EventArgs e)
{
   WebFlyPostBackListener listener = new WebFlyPostBackListener(this.Page);
}

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebDesktop.WebFlyPostBackListener

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackListener Members
ISNet.WebUI.WebDesktop Namespace

Tasks

Retrieving notifications from webform listener


WebFlyPostBackListener Class Members

[image]
Intersoft WebDesktop Documentation
WebFlyPostBackListener Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebFlyPostBackListener Class

Glossary Item Box

The following tables list the members exposed by WebFlyPostBackListener.

Public Constructors

 | Name | Description
Public Constructor | WebFlyPostBackListener Constructor |
Top

Public Properties

 | Name | Description
Public Property | ActionName | Gets or sets the name of action in WebFlyPostBack.
Public Property | FlyPostBackSettings | Specifies fly post back settings.
Public Property | IsCustomAction | Gets the method in WebFlyPostBackManager which defined by users.
Public Property | IsFlyPostBack | Specifies whether a page is loaded normally or on-the-flypostback.
Public Property | IsValidProcess | Specifies whether the action in WebFlyPostBackManager is valid or not.
Public Property | WebFlyPostBackManager |
Public Property | WebFlyPostBackManagerID | Gets or sets the ID of WebFlyPostBack which executes the Listener.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | EnableAsyncMethod |
Public Method | GetFlyPostBackWebFormMetadata |
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetResponseFormat |
Public Method | GetResultCustomAction |
Public Method | InvokeCustomAction |
Public Method | IsAsyncPage |
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SetAsyncResult |
Public Method | SetResponseFormat |
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebFlyPostBackListener Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Retrieving notifications from webform listener


WebFlyPostBackListener Constructor

[image]
Intersoft WebDesktop Documentation
WebFlyPostBackListener Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackListener Class : WebFlyPostBackListener Constructor

page

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal page As System.Web.UI.Page _
)
Visual Basic (Usage) Copy Code
Dim page As System.Web.UI.Page

Dim instance As New WebFlyPostBackListener(page)
C#
public WebFlyPostBackListener(
   System.Web.UI.Page page
)

Parameters

page

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackListener Class
WebFlyPostBackListener Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackListener Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackListener
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackListener Class
WebFlyPostBackListener Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackListener Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackListener Class
WebFlyPostBackListener Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackListener Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackListener
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackListener Class
WebFlyPostBackListener Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackListener Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackListener
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackListener Class
WebFlyPostBackListener Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackListener Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackListener
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackListener Class
WebFlyPostBackListener Members


WebFlyPostBackListener Class Methods

[image]
Intersoft WebDesktop Documentation
WebFlyPostBackListener Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebFlyPostBackListener Class

Glossary Item Box

For a list of all members of this type, see WebFlyPostBackListener members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | EnableAsyncMethod |
Public Method | GetFlyPostBackWebFormMetadata |
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetResponseFormat |
Public Method | GetResultCustomAction |
Public Method | InvokeCustomAction |
Public Method | IsAsyncPage |
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SetAsyncResult |
Public Method | SetResponseFormat |
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebFlyPostBackListener Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Retrieving notifications from webform listener


EnableAsyncMethod Method

[image]
Intersoft WebDesktop Documentation
EnableAsyncMethod Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackListener Class : EnableAsyncMethod Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub EnableAsyncMethod()
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackListener

instance.EnableAsyncMethod()
C#
public void EnableAsyncMethod()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackListener Class
WebFlyPostBackListener Members


GetFlyPostBackWebFormMetadata Method

[image]
Intersoft WebDesktop Documentation
GetFlyPostBackWebFormMetadata Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackListener Class : GetFlyPostBackWebFormMetadata Method

pageType

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFlyPostBackWebFormMetadata( _
   ByVal pageType As Type _
) As System.Xml.XmlDocument
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackListener
Dim pageType As Type
Dim value As System.Xml.XmlDocument

value = instance.GetFlyPostBackWebFormMetadata(pageType)
C#
public System.Xml.XmlDocument GetFlyPostBackWebFormMetadata(
   Type pageType
)

Parameters

pageType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackListener Class
WebFlyPostBackListener Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackListener Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackListener
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackListener Class
WebFlyPostBackListener Members


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackListener Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackListener
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackListener Class
WebFlyPostBackListener Members


GetResponseFormat Method

[image]
Intersoft WebDesktop Documentation
GetResponseFormat Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackListener Class : GetResponseFormat Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetResponseFormat() As ISNet.WebUI.ResponseFormat
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackListener
Dim value As ISNet.WebUI.ResponseFormat

value = instance.GetResponseFormat()
C#
public ISNet.WebUI.ResponseFormat GetResponseFormat()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackListener Class
WebFlyPostBackListener Members


GetResultCustomAction Method

[image]
Intersoft WebDesktop Documentation
GetResultCustomAction Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackListener Class : GetResultCustomAction Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetResultCustomAction() As String
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackListener
Dim value As String

value = instance.GetResultCustomAction()
C#
public virtual string GetResultCustomAction()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackListener Class
WebFlyPostBackListener Members


InvokeCustomAction Method

[image]
Intersoft WebDesktop Documentation
InvokeCustomAction Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackListener Class : InvokeCustomAction Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub InvokeCustomAction()
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackListener

instance.InvokeCustomAction()
C#
public void InvokeCustomAction()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackListener Class
WebFlyPostBackListener Members


IsAsyncPage Method

[image]
Intersoft WebDesktop Documentation
IsAsyncPage Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackListener Class : IsAsyncPage Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsAsyncPage() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackListener
Dim value As Boolean

value = instance.IsAsyncPage()
C#
public bool IsAsyncPage()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackListener Class
WebFlyPostBackListener Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackListener Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackListener
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackListener Class
WebFlyPostBackListener Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackListener Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackListener

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackListener Class
WebFlyPostBackListener Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackListener Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackListener
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackListener Class
WebFlyPostBackListener Members


SetAsyncResult Method

[image]
Intersoft WebDesktop Documentation
SetAsyncResult Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackListener Class : SetAsyncResult Method

result

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetAsyncResult( _
   ByVal result As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackListener
Dim result As Object

instance.SetAsyncResult(result)
C#
public void SetAsyncResult(
   object result
)

Parameters

result

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackListener Class
WebFlyPostBackListener Members


SetResponseFormat Method

[image]
Intersoft WebDesktop Documentation
SetResponseFormat Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackListener Class : SetResponseFormat Method

format

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetResponseFormat( _
   ByVal format As ISNet.WebUI.ResponseFormat _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackListener
Dim format As ISNet.WebUI.ResponseFormat

instance.SetResponseFormat(format)
C#
public void SetResponseFormat(
   ISNet.WebUI.ResponseFormat format
)

Parameters

format

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackListener Class
WebFlyPostBackListener Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackListener Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackListener
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackListener Class
WebFlyPostBackListener Members


WebFlyPostBackListener Class Properties

[image]
Intersoft WebDesktop Documentation
WebFlyPostBackListener Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebFlyPostBackListener Class

Glossary Item Box

For a list of all members of this type, see WebFlyPostBackListener members.

Public Properties

 | Name | Description
Public Property | ActionName | Gets or sets the name of action in WebFlyPostBack.
Public Property | FlyPostBackSettings | Specifies fly post back settings.
Public Property | IsCustomAction | Gets the method in WebFlyPostBackManager which defined by users.
Public Property | IsFlyPostBack | Specifies whether a page is loaded normally or on-the-flypostback.
Public Property | IsValidProcess | Specifies whether the action in WebFlyPostBackManager is valid or not.
Public Property | WebFlyPostBackManager |
Public Property | WebFlyPostBackManagerID | Gets or sets the ID of WebFlyPostBack which executes the Listener.
Top

See Also

Reference

WebFlyPostBackListener Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Retrieving notifications from webform listener


WebFlyPostBackListener Constructor

[image]
Intersoft WebDesktop Documentation
WebFlyPostBackListener Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackListener Class : WebFlyPostBackListener Constructor

Glossary Item Box

Initializes a new instance of the WebFlyPostBackListener class.

Overload List

Overload | Description
WebFlyPostBackListener Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackListener Class
WebFlyPostBackListener Members


ActionName Property

[image]
Intersoft WebDesktop Documentation
ActionName Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackListener Class : ActionName Property

Glossary Item Box

Gets or sets the name of action in WebFlyPostBack.

Syntax

Visual Basic (Declaration)
Public Property ActionName As String
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackListener
Dim value As String

instance.ActionName = value

value = instance.ActionName
C#
public string ActionName {get; set;}

Remarks

Generally ActionName is same with the name of method user defined.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackListener Class
WebFlyPostBackListener Members


FlyPostBackSettings Property

[image]
Intersoft WebDesktop Documentation
FlyPostBackSettings Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackListener Class : FlyPostBackSettings Property

Glossary Item Box

Specifies fly post back settings.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FlyPostBackSettings As ISNet.WebUI.FlyPostBackSettings
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackListener
Dim value As ISNet.WebUI.FlyPostBackSettings

value = instance.FlyPostBackSettings
C#
public ISNet.WebUI.FlyPostBackSettings FlyPostBackSettings {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackListener Class
WebFlyPostBackListener Members


IsCustomAction Property

[image]
Intersoft WebDesktop Documentation
IsCustomAction Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackListener Class : IsCustomAction Property

Glossary Item Box

Gets the method in WebFlyPostBackManager which defined by users.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsCustomAction As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackListener
Dim value As Boolean

value = instance.IsCustomAction
C#
public bool IsCustomAction {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackListener Class
WebFlyPostBackListener Members


IsFlyPostBack Property

[image]
Intersoft WebDesktop Documentation
IsFlyPostBack Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackListener Class : IsFlyPostBack Property

Glossary Item Box

Specifies whether a page is loaded normally or on-the-flypostback.

Syntax

Visual Basic (Declaration)
Public Property IsFlyPostBack As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackListener
Dim value As Boolean

instance.IsFlyPostBack = value

value = instance.IsFlyPostBack
C#
public bool IsFlyPostBack {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackListener Class
WebFlyPostBackListener Members


IsValidProcess Property

[image]
Intersoft WebDesktop Documentation
IsValidProcess Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackListener Class : IsValidProcess Property

Glossary Item Box

Specifies whether the action in WebFlyPostBackManager is valid or not.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsValidProcess As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackListener
Dim value As Boolean

value = instance.IsValidProcess
C#
public bool IsValidProcess {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackListener Class
WebFlyPostBackListener Members


WebFlyPostBackManager Property

[image]
Intersoft WebDesktop Documentation
WebFlyPostBackManager Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackListener Class : WebFlyPostBackManager Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property WebFlyPostBackManager As WebFlyPostBackManager
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackListener
Dim value As WebFlyPostBackManager

value = instance.WebFlyPostBackManager
C#
public WebFlyPostBackManager WebFlyPostBackManager {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackListener Class
WebFlyPostBackListener Members


WebFlyPostBackManagerID Property

[image]
Intersoft WebDesktop Documentation
WebFlyPostBackManagerID Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackListener Class : WebFlyPostBackManagerID Property

Glossary Item Box

Gets or sets the ID of WebFlyPostBack which executes the Listener.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property WebFlyPostBackManagerID As String
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackListener
Dim value As String

value = instance.WebFlyPostBackManagerID
C#
public string WebFlyPostBackManagerID {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackListener Class
WebFlyPostBackListener Members


WebFlyPostBackManager Class

[image]
Intersoft WebDesktop Documentation
WebFlyPostBackManager Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebFlyPostBackManager Class

Glossary Item Box

Standalone server side component that built on the top of FlyPostBack architecture, used as asynchronous calls (a.k.a. AJAX) to communicate with server side resources.

Object Model

WebFlyPostBackManager Class

Syntax

Visual Basic (Declaration)
Public Class WebFlyPostBackManager
   Inherits ISNet.WebUI.ISNetControl
   Implements ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
C#
public class WebFlyPostBackManager : ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings

Remarks

Using WebFlyPostBackManager you can invoke server side methods from client side as easy as writing one line of code. Therefore, you can call the server side functions in more straightforward manner than the previous approach which require you to implement a specific interface before they are accessible to the client side.

WebFlyPostBackManager allows you conveniently to retrieve any kind of data types, in either synchronous or asynchronous mode. The control supports basic data types such as string, integer, boolean and arrays -- as well as complex types such as collection, custom business objects and nested objects.

WebFlyPostBackManager has ability to change the service as UI (User Interface) mode. When used in UI mode, the control can be used to partially refresh specified server side controls without full page postback. During the FlyPostBack (a.k.a. callback) request, only the refreshed controls are delivered back to the client side and hence reducing the output size.

WebFlyPostBackManager is used to request an execution of Method at server side. Most of the time you want the execution of this method returns a value. The type of this value can vary from very simple one as string to more complex type as CustomObject.

Here are the list of simple data types supported by WebFlyPostBackManager :

  • string
  • int
  • decimal
  • long
  • float
  • bool
  • DateTime
  • array[]

Advanced Data Types that is supported by WebFlyPostBackManager are :

  • DataSet
  • DataTable
  • Custom Object that can be serialized

For more information on advanced data types issue, please refer to Advanced Data Types.

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
ISNet.WebUI.ISNetControl
ISNet.WebUI.WebDesktop.WebFlyPostBackManager

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Members
ISNet.WebUI.WebDesktop Namespace

Tasks

Retrieving notifications from webservice

tasks

Retrieving notifications from webform listener
Converting standard controls to use callback
Selectively converting standard controls to use callback
Programmatically refresh server control

Concepts

WebFlyPostBack Overview
WebFlyPostBack Features

concepts

Service Type
Metadata Collection
Data Types
Advanced Data Types


WebFlyPostBackManager Class Members

[image]
Intersoft WebDesktop Documentation
WebFlyPostBackManager Class Members
See Also Properties Methods Events Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebFlyPostBackManager Class

Glossary Item Box

The following tables list the members exposed by WebFlyPostBackManager.

Public Constructors

 | Name | Description
Public Constructor | WebFlyPostBackManager Constructor |
Top

Public Properties

 | Name | Description
Public Property | Asynchronous | Gets or sets a value indicating asynchronous call.
Public Property | AutoEventWireup | Gets or sets a boolean value indicating whether the OnResponseSuccess function event should be wired up automatically.
Public Property | AutoLoadMetaData | Gets or sets a boolean value indicating whether WebFlyPostBackManager should load the service metadata information automatically.
Public Property | BlockPageUIOnBusy | Specifies whether the current page's UI should be blocked in client side when the control is in busy state. When blocked, the mouse cursor will be changed to HourGlass to prevent user interactions.
Public Property | CacheParameterizedRequest |
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ClientSideEvents |
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Enabled | Enabled state of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableManagedTheming | Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to False, this control will not apply the style defined in Theme Architecture. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableUIMode | Specifies whether the WebFlyPostBackManager instance should be used as User Interface mode. See Remarks for more details.
Public Property | EnableViewState | Whether the control automatically saves its state for use in round-trips. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). (Inherited from ISNet.WebUI.ISNetControl)
Public Property | FlyPostBackSettings |
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | LoaderHostControlID | Gets or sets the Client ID of the control which will be used to host the LoaderTemplate.
Public Property | LoaderStyle |
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RegisterRequestHandlerOnPreRenderComplete | Overridden.
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden. Gets or sets the directory where all required scripts for the control are stored.
Public Property | ServiceType | Gets or sets the service type of the fly postback manager instance.
Public Property | ServiceUrl | Gets or sets the relative URL of the service page used by WebFlyPostBackManager for its data retrieval.
Public Property | SharedScriptDirectory | Overridden. Gets or sets the directory where all shared scripts for Intersoft controls are stored.
Public Property | ShowLoaderOnBusy | Specifies whether to show LoaderTemplate when the WebFlyPostBackManager is in busy state.
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | TimeoutInterval | Gets or sets timeout interval for a client side invoke.
Public Property | UpdateControls |
Public Property | UpdateMode | Gets or sets a value representing the update behavior of automatic callback feature.
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateItems | Gets or sets the items to be stored in view state storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | Gets or sets the server connection string for file server-based viewstate storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | Gets or sets the location to store the viewstate of this control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | WebServiceResponseFormat |
Public Property | XmlCompressionEnabled | Specifies whether the Xml used for clientside state storage should be compressed. (Inherited from ISNet.WebUI.ISNetControl)
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CheckConstrains | Overridden.
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CustomDeserialize |
Public Method | CustomSerialize |
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetClientAction |
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | GetXMLData | Overridden.
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPostData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnFlyRender | Overridden.
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreRender |
Public Method | OnRequest |
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebFlyPostBackManager Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Retrieving notifications from webservice

tasks

Retrieving notifications from webform listener
Converting standard controls to use callback
Selectively converting standard controls to use callback
Programmatically refresh server control

Concepts

WebFlyPostBack Overview
WebFlyPostBack Features

concepts

Service Type
Metadata Collection
Data Types
Advanced Data Types


WebFlyPostBackManager Class Events

[image]
Intersoft WebDesktop Documentation
WebFlyPostBackManager Class Events
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebFlyPostBackManager Class

Glossary Item Box

For a list of all members of this type, see WebFlyPostBackManager members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebFlyPostBackManager Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Retrieving notifications from webservice

tasks

Retrieving notifications from webform listener
Converting standard controls to use callback
Selectively converting standard controls to use callback
Programmatically refresh server control

Concepts

WebFlyPostBack Overview
WebFlyPostBack Features

concepts

Service Type
Metadata Collection
Data Types
Advanced Data Types


WebFlyPostBackManager Constructor

[image]
Intersoft WebDesktop Documentation
WebFlyPostBackManager Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : WebFlyPostBackManager Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebFlyPostBackManager()
C#
public WebFlyPostBackManager()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


ApplyStyle Method

[image]
Intersoft WebDesktop Documentation
ApplyStyle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : ApplyStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ApplyStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim s As System.Web.UI.WebControls.Style

instance.ApplyStyle(s)
C#
public void ApplyStyle(
   System.Web.UI.WebControls.Style s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


ApplyStyleSheetSkin Method

[image]
Intersoft WebDesktop Documentation
ApplyStyleSheetSkin Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : ApplyStyleSheetSkin Method

page

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub ApplyStyleSheetSkin( _
   ByVal page As System.Web.UI.Page _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim page As System.Web.UI.Page

instance.ApplyStyleSheetSkin(page)
C#
public virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page page
)

Parameters

page

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


CanUseWebResources Method

[image]
Intersoft WebDesktop Documentation
CanUseWebResources Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : CanUseWebResources Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CanUseWebResources() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As Boolean

value = instance.CanUseWebResources()
C#
public bool CanUseWebResources()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


WebFlyPostBackManager Class Methods

[image]
Intersoft WebDesktop Documentation
WebFlyPostBackManager Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebFlyPostBackManager Class

Glossary Item Box

For a list of all members of this type, see WebFlyPostBackManager members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CheckConstrains | Overridden.
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CustomDeserialize |
Public Method | CustomSerialize |
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetClientAction |
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | GetXMLData | Overridden.
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPostData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnFlyRender | Overridden.
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreRender |
Public Method | OnRequest |
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Top

See Also

Reference

WebFlyPostBackManager Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Retrieving notifications from webservice

tasks

Retrieving notifications from webform listener
Converting standard controls to use callback
Selectively converting standard controls to use callback
Programmatically refresh server control

Concepts

WebFlyPostBack Overview
WebFlyPostBack Features

concepts

Service Type
Metadata Collection
Data Types
Advanced Data Types


CheckConstrains Method

[image]
Intersoft WebDesktop Documentation
CheckConstrains Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : CheckConstrains Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub CheckConstrains()
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager

instance.CheckConstrains()
C#
public override void CheckConstrains()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


CopyBaseAttributes Method

[image]
Intersoft WebDesktop Documentation
CopyBaseAttributes Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : CopyBaseAttributes Method

controlSrc

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyBaseAttributes( _
   ByVal controlSrc As System.Web.UI.WebControls.WebControl _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim controlSrc As System.Web.UI.WebControls.WebControl

instance.CopyBaseAttributes(controlSrc)
C#
public void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl controlSrc
)

Parameters

controlSrc

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.ISNetControl)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members
Overload List


CustomDeserialize Method

[image]
Intersoft WebDesktop Documentation
CustomDeserialize Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : CustomDeserialize Method

mi
currentObj
parentNode
currentNode

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CustomDeserialize( _
   ByVal mi As System.Reflection.MemberInfo, _
   ByVal currentObj As Object, _
   ByVal parentNode As System.Xml.XmlNode, _
   ByVal currentNode As System.Xml.XmlNode _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim mi As System.Reflection.MemberInfo
Dim currentObj As Object
Dim parentNode As System.Xml.XmlNode
Dim currentNode As System.Xml.XmlNode

instance.CustomDeserialize(mi, currentObj, parentNode, currentNode)
C#
public void CustomDeserialize(
   System.Reflection.MemberInfo mi,
   object currentObj,
   System.Xml.XmlNode parentNode,
   System.Xml.XmlNode currentNode
)

Parameters

mi
currentObj
parentNode
currentNode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


CustomSerialize Method

[image]
Intersoft WebDesktop Documentation
CustomSerialize Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : CustomSerialize Method

doc
node

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CustomSerialize( _
   ByVal doc As System.Xml.XmlDocument, _
   ByVal node As System.Xml.XmlNode _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim doc As System.Xml.XmlDocument
Dim node As System.Xml.XmlNode

instance.CustomSerialize(doc, node)
C#
public void CustomSerialize(
   System.Xml.XmlDocument doc,
   System.Xml.XmlNode node
)

Parameters

doc
node

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


DataBind Method

[image]
Intersoft WebDesktop Documentation
DataBind Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : DataBind Method

Glossary Item Box

Overload List

Overload | Description
DataBind | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


DataBind() Method

[image]
Intersoft WebDesktop Documentation
DataBind() Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : DataBind() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub DataBind()
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager

instance.DataBind()
C#
public virtual void DataBind()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


Dispose Method

[image]
Intersoft WebDesktop Documentation
Dispose Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : Dispose Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager

instance.Dispose()
C#
public virtual void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


FindControl Method

[image]
Intersoft WebDesktop Documentation
FindControl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : FindControl Method

Glossary Item Box

Overload List

Overload | Description
FindControl | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


FindControl(String) Method

[image]
Intersoft WebDesktop Documentation
FindControl(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : FindControl(String) Method

id

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function FindControl( _
   ByVal id As String _
) As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim id As String
Dim value As System.Web.UI.Control

value = instance.FindControl(id)
C#
public virtual System.Web.UI.Control FindControl(
   string id
)

Parameters

id

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


Focus Method

[image]
Intersoft WebDesktop Documentation
Focus Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : Focus Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Focus()
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager

instance.Focus()
C#
public virtual void Focus()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


ForceDisableXmlCompression Method

[image]
Intersoft WebDesktop Documentation
ForceDisableXmlCompression Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : ForceDisableXmlCompression Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ForceDisableXmlCompression()
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager

instance.ForceDisableXmlCompression()
C#
public void ForceDisableXmlCompression()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


GetClientAction Method

[image]
Intersoft WebDesktop Documentation
GetClientAction Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : GetClientAction Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetClientAction() As ISNet.WebUI.BaseClientSideAction
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As ISNet.WebUI.BaseClientSideAction

value = instance.GetClientAction()
C#
public ISNet.WebUI.BaseClientSideAction GetClientAction()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


GetCurrentControlLifeCycle Method

[image]
Intersoft WebDesktop Documentation
GetCurrentControlLifeCycle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : GetCurrentControlLifeCycle Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentControlLifeCycle() As ISNet.WebUI.ControlLifeCycle
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As ISNet.WebUI.ControlLifeCycle

value = instance.GetCurrentControlLifeCycle()
C#
public ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


GetCurrentTheme Method

[image]
Intersoft WebDesktop Documentation
GetCurrentTheme Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : GetCurrentTheme Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentTheme() As ISNet.WebUI.ThemeInfo
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As ISNet.WebUI.ThemeInfo

value = instance.GetCurrentTheme()
C#
public ISNet.WebUI.ThemeInfo GetCurrentTheme()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


GetFrameworkDataFolder Method

[image]
Intersoft WebDesktop Documentation
GetFrameworkDataFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : GetFrameworkDataFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkDataFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As String

value = instance.GetFrameworkDataFolder()
C#
public string GetFrameworkDataFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


GetFrameworkFolder Method

[image]
Intersoft WebDesktop Documentation
GetFrameworkFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : GetFrameworkFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As String

value = instance.GetFrameworkFolder()
C#
public string GetFrameworkFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


GetFrameworkVersion Method

[image]
Intersoft WebDesktop Documentation
GetFrameworkVersion Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : GetFrameworkVersion Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkVersion() As Version
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As Version

value = instance.GetFrameworkVersion()
C#
public Version GetFrameworkVersion()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


GetIntersoftFolder Method

[image]
Intersoft WebDesktop Documentation
GetIntersoftFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : GetIntersoftFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetIntersoftFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As String

value = instance.GetIntersoftFolder()
C#
public string GetIntersoftFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


GetLayoutFolder Method

[image]
Intersoft WebDesktop Documentation
GetLayoutFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : GetLayoutFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetLayoutFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As String

value = instance.GetLayoutFolder()
C#
public string GetLayoutFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


GetPostedXMLData Method

[image]
Intersoft WebDesktop Documentation
GetPostedXMLData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : GetPostedXMLData Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPostedXMLData() As String
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As String

value = instance.GetPostedXMLData()
C#
public string GetPostedXMLData()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


GetProductInfoKey Method

[image]
Intersoft WebDesktop Documentation
GetProductInfoKey Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : GetProductInfoKey Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductInfoKey() As String
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As String

value = instance.GetProductInfoKey()
C#
public string GetProductInfoKey()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


GetProductSimpleName Method

[image]
Intersoft WebDesktop Documentation
GetProductSimpleName Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : GetProductSimpleName Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductSimpleName() As String
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As String

value = instance.GetProductSimpleName()
C#
public string GetProductSimpleName()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


GetPropertyValue Method

[image]
Intersoft WebDesktop Documentation
GetPropertyValue Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : GetPropertyValue Method

defValue
propValue
webConfigKey

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPropertyValue( _
   ByVal defValue As String, _
   ByVal propValue As String, _
   ByVal webConfigKey As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim defValue As String
Dim propValue As String
Dim webConfigKey As String
Dim value As String

value = instance.GetPropertyValue(defValue, propValue, webConfigKey)
C#
public string GetPropertyValue(
   string defValue,
   string propValue,
   string webConfigKey
)

Parameters

defValue
propValue
webConfigKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


GetResourceStream Method

[image]
Intersoft WebDesktop Documentation
GetResourceStream Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : GetResourceStream Method

resourceUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetResourceStream( _
   ByVal resourceUrl As String _
) As System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim resourceUrl As String
Dim value As System.IO.Stream

value = instance.GetResourceStream(resourceUrl)
C#
public System.IO.Stream GetResourceStream(
   string resourceUrl
)

Parameters

resourceUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


GetRouteUrl Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : GetRouteUrl Method

Glossary Item Box

Overload List

Overload | Description
GetRouteUrl(Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(RouteValueDictionary) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,RouteValueDictionary) | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


GetRouteUrl(Object) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class > GetRouteUrl Method : GetRouteUrl(Object) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As Object _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim routeParameters As Object
Dim value As String

value = instance.GetRouteUrl(routeParameters)
C#
public string GetRouteUrl(
   object routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members
Overload List


GetRouteUrl(String,Object) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(String,Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class > GetRouteUrl Method : GetRouteUrl(String,Object) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As String, _
   ByVal routeParameters As Object _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim routeName As String
Dim routeParameters As Object
Dim value As String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public string GetRouteUrl(
   string routeName,
   object routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members
Overload List


GetRouteUrl(RouteValueDictionary) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(RouteValueDictionary) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class > GetRouteUrl Method : GetRouteUrl(RouteValueDictionary) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As String

value = instance.GetRouteUrl(routeParameters)
C#
public string GetRouteUrl(
   System.Web.Routing.RouteValueDictionary routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members
Overload List


GetRouteUrl(String,RouteValueDictionary) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(String,RouteValueDictionary) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class > GetRouteUrl Method : GetRouteUrl(String,RouteValueDictionary) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As String, _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim routeName As String
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public string GetRouteUrl(
   string routeName,
   System.Web.Routing.RouteValueDictionary routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members
Overload List


GetUniqueIDRelativeTo Method

[image]
Intersoft WebDesktop Documentation
GetUniqueIDRelativeTo Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : GetUniqueIDRelativeTo Method

control

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetUniqueIDRelativeTo( _
   ByVal control As System.Web.UI.Control _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim control As System.Web.UI.Control
Dim value As String

value = instance.GetUniqueIDRelativeTo(control)
C#
public string GetUniqueIDRelativeTo(
   System.Web.UI.Control control
)

Parameters

control

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


GetXMLData Method

[image]
Intersoft WebDesktop Documentation
GetXMLData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : GetXMLData Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function GetXMLData() As String
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As String

value = instance.GetXMLData()
C#
public override string GetXMLData()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


HasControls Method

[image]
Intersoft WebDesktop Documentation
HasControls Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : HasControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function HasControls() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As Boolean

value = instance.HasControls()
C#
public virtual bool HasControls()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


IsAtlasCallback Method

[image]
Intersoft WebDesktop Documentation
IsAtlasCallback Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : IsAtlasCallback Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsAtlasCallback() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As Boolean

value = instance.IsAtlasCallback()
C#
public bool IsAtlasCallback()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


IsBetaRelease Method

[image]
Intersoft WebDesktop Documentation
IsBetaRelease Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : IsBetaRelease Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsBetaRelease() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As Boolean

value = instance.IsBetaRelease()
C#
public bool IsBetaRelease()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


IsChromeBrowser Method

[image]
Intersoft WebDesktop Documentation
IsChromeBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : IsChromeBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsChromeBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As Boolean

value = instance.IsChromeBrowser()
C#
public bool IsChromeBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


IsFlyPostBackControl Method

[image]
Intersoft WebDesktop Documentation
IsFlyPostBackControl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : IsFlyPostBackControl Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackControl() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As Boolean

value = instance.IsFlyPostBackControl()
C#
public virtual bool IsFlyPostBackControl()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


IsFlyPostBackRequest Method

[image]
Intersoft WebDesktop Documentation
IsFlyPostBackRequest Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : IsFlyPostBackRequest Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackRequest() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As Boolean

value = instance.IsFlyPostBackRequest()
C#
public virtual bool IsFlyPostBackRequest()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


IsGeckoBasedBrowser Method

[image]
Intersoft WebDesktop Documentation
IsGeckoBasedBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : IsGeckoBasedBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoBasedBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As Boolean

value = instance.IsGeckoBasedBrowser()
C#
public bool IsGeckoBasedBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


IsGeckoVersion18 Method

[image]
Intersoft WebDesktop Documentation
IsGeckoVersion18 Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : IsGeckoVersion18 Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoVersion18() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As Boolean

value = instance.IsGeckoVersion18()
C#
public bool IsGeckoVersion18()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


IsInDesignMode Method

[image]
Intersoft WebDesktop Documentation
IsInDesignMode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : IsInDesignMode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInDesignMode() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As Boolean

value = instance.IsInDesignMode()
C#
public bool IsInDesignMode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


IsInternetExplorer8Browser Method

[image]
Intersoft WebDesktop Documentation
IsInternetExplorer8Browser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : IsInternetExplorer8Browser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorer8Browser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As Boolean

value = instance.IsInternetExplorer8Browser()
C#
public bool IsInternetExplorer8Browser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


IsInternetExplorerBrowser Method

[image]
Intersoft WebDesktop Documentation
IsInternetExplorerBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : IsInternetExplorerBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorerBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As Boolean

value = instance.IsInternetExplorerBrowser()
C#
public bool IsInternetExplorerBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


IsOperaBrowser Method

[image]
Intersoft WebDesktop Documentation
IsOperaBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : IsOperaBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsOperaBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As Boolean

value = instance.IsOperaBrowser()
C#
public bool IsOperaBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


IsSafariBrowser Method

[image]
Intersoft WebDesktop Documentation
IsSafariBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : IsSafariBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsSafariBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As Boolean

value = instance.IsSafariBrowser()
C#
public bool IsSafariBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


IsW3CStandardBrowser Method

[image]
Intersoft WebDesktop Documentation
IsW3CStandardBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : IsW3CStandardBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsW3CStandardBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As Boolean

value = instance.IsW3CStandardBrowser()
C#
public bool IsW3CStandardBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


LoadLayout Method

[image]
Intersoft WebDesktop Documentation
LoadLayout Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : LoadLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim settings As ISNet.WebUI.LayoutInfo

instance.LoadLayout(settings)
C#
public virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


LoadLayoutFromFile Method

[image]
Intersoft WebDesktop Documentation
LoadLayoutFromFile Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : LoadLayoutFromFile Method

filePath

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromFile( _
   ByVal filePath As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim filePath As String

instance.LoadLayoutFromFile(filePath)
C#
public virtual void LoadLayoutFromFile(
   string filePath
)

Parameters

filePath

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


LoadLayoutFromPredefinedName Method

[image]
Intersoft WebDesktop Documentation
LoadLayoutFromPredefinedName Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : LoadLayoutFromPredefinedName Method

predefinedName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromPredefinedName( _
   ByVal predefinedName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim predefinedName As String

instance.LoadLayoutFromPredefinedName(predefinedName)
C#
public virtual void LoadLayoutFromPredefinedName(
   string predefinedName
)

Parameters

predefinedName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


LoadLayoutFromStream Method

[image]
Intersoft WebDesktop Documentation
LoadLayoutFromStream Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : LoadLayoutFromStream Method

stream

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromStream( _
   ByVal stream As System.IO.Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim stream As System.IO.Stream

instance.LoadLayoutFromStream(stream)
C#
public virtual void LoadLayoutFromStream(
   System.IO.Stream stream
)

Parameters

stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


LoadPostData Method

[image]
Intersoft WebDesktop Documentation
LoadPostData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : LoadPostData Method

postDataKey
postCollection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function LoadPostData( _
   ByVal postDataKey As String, _
   ByVal postCollection As System.Collections.Specialized.NameValueCollection _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim postDataKey As String
Dim postCollection As System.Collections.Specialized.NameValueCollection
Dim value As Boolean

value = instance.LoadPostData(postDataKey, postCollection)
C#
public virtual bool LoadPostData(
   string postDataKey,
   System.Collections.Specialized.NameValueCollection postCollection
)

Parameters

postDataKey
postCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


MergeStyle Method

[image]
Intersoft WebDesktop Documentation
MergeStyle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : MergeStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub MergeStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim s As System.Web.UI.WebControls.Style

instance.MergeStyle(s)
C#
public void MergeStyle(
   System.Web.UI.WebControls.Style s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


OnFlyRender Method

[image]
Intersoft WebDesktop Documentation
OnFlyRender Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : OnFlyRender Method

data

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub OnFlyRender( _
   ByVal data As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim data As Object

instance.OnFlyRender(data)
C#
public override void OnFlyRender(
   object data
)

Parameters

data

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


OnInfoChanged Method

[image]
Intersoft WebDesktop Documentation
OnInfoChanged Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : OnInfoChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnInfoChanged( _
   ByVal e As ISNet.WebUI.SynchronizeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim e As ISNet.WebUI.SynchronizeEventArgs

instance.OnInfoChanged(e)
C#
public void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


OnPreInitialize Method

[image]
Intersoft WebDesktop Documentation
OnPreInitialize Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : OnPreInitialize Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnPreInitialize()
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager

instance.OnPreInitialize()
C#
public virtual void OnPreInitialize()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


OnPreRender Method

[image]
Intersoft WebDesktop Documentation
OnPreRender Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : OnPreRender Method

Glossary Item Box

Overload List

Overload | Description
OnPreRender |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


OnPreRender() Method

[image]
Intersoft WebDesktop Documentation
OnPreRender() Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : OnPreRender() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnPreRender()
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager

instance.OnPreRender()
C#
public void OnPreRender()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


OnRequest Method

[image]
Intersoft WebDesktop Documentation
OnRequest Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : OnRequest Method

requestObject

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnRequest( _
   ByVal requestObject As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim requestObject As Object

instance.OnRequest(requestObject)
C#
public void OnRequest(
   object requestObject
)

Parameters

requestObject

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


RaisePostDataChangedEvent Method

[image]
Intersoft WebDesktop Documentation
RaisePostDataChangedEvent Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : RaisePostDataChangedEvent Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RaisePostDataChangedEvent()
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager

instance.RaisePostDataChangedEvent()
C#
public virtual void RaisePostDataChangedEvent()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


ReadWebConfigValue Method

[image]
Intersoft WebDesktop Documentation
ReadWebConfigValue Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : ReadWebConfigValue Method

key

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ReadWebConfigValue( _
   ByVal key As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim key As String
Dim value As String

value = instance.ReadWebConfigValue(key)
C#
public string ReadWebConfigValue(
   string key
)

Parameters

key

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


RegisterBoxSizing Method

[image]
Intersoft WebDesktop Documentation
RegisterBoxSizing Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : RegisterBoxSizing Method

Glossary Item Box

Overload List

Overload | Description
RegisterBoxSizing() | (Inherited from ISNet.WebUI.ISNetControl)
RegisterBoxSizing(Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


RegisterBoxSizing() Method

[image]
Intersoft WebDesktop Documentation
RegisterBoxSizing() Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class > RegisterBoxSizing Method : RegisterBoxSizing() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing()
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager

instance.RegisterBoxSizing()
C#
public void RegisterBoxSizing()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members
Overload List


RegisterBoxSizing(Boolean) Method

[image]
Intersoft WebDesktop Documentation
RegisterBoxSizing(Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class > RegisterBoxSizing Method : RegisterBoxSizing(Boolean) Method

forceAll

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing( _
   ByVal forceAll As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim forceAll As Boolean

instance.RegisterBoxSizing(forceAll)
C#
public void RegisterBoxSizing(
   bool forceAll
)

Parameters

forceAll

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members
Overload List


RegisterGlobalStyle Method

[image]
Intersoft WebDesktop Documentation
RegisterGlobalStyle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : RegisterGlobalStyle Method

style

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterGlobalStyle( _
   ByVal style As ISNet.WebUI.WebStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim style As ISNet.WebUI.WebStyle

instance.RegisterGlobalStyle(style)
C#
public void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle style
)

Parameters

style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


RegisterLink Method

[image]
Intersoft WebDesktop Documentation
RegisterLink Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : RegisterLink Method

name
url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterLink( _
   ByVal name As String, _
   ByVal url As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim name As String
Dim url As String

instance.RegisterLink(name, url)
C#
public void RegisterLink(
   string name,
   string url
)

Parameters

name
url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


RegisterOptimizedCssClasses Method

[image]
Intersoft WebDesktop Documentation
RegisterOptimizedCssClasses Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : RegisterOptimizedCssClasses Method

runtimeStyleOnly

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterOptimizedCssClasses( _
   ByVal runtimeStyleOnly As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim runtimeStyleOnly As Boolean

instance.RegisterOptimizedCssClasses(runtimeStyleOnly)
C#
public void RegisterOptimizedCssClasses(
   bool runtimeStyleOnly
)

Parameters

runtimeStyleOnly

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


RegisterPreloadImage Method

[image]
Intersoft WebDesktop Documentation
RegisterPreloadImage Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : RegisterPreloadImage Method

image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterPreloadImage( _
   ByVal image As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim image As String

instance.RegisterPreloadImage(image)
C#
public void RegisterPreloadImage(
   string image
)

Parameters

image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


RegisterSharePointHandler Method

[image]
Intersoft WebDesktop Documentation
RegisterSharePointHandler Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : RegisterSharePointHandler Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RegisterSharePointHandler()
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager

instance.RegisterSharePointHandler()
C#
public virtual void RegisterSharePointHandler()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


RenderBeginTag Method

[image]
Intersoft WebDesktop Documentation
RenderBeginTag Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : RenderBeginTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderBeginTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderBeginTag(writer)
C#
public virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


RenderControl Method

[image]
Intersoft WebDesktop Documentation
RenderControl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : RenderControl Method

Glossary Item Box

Overload List

Overload | Description
RenderControl | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


RenderControl(HtmlTextWriter) Method

[image]
Intersoft WebDesktop Documentation
RenderControl(HtmlTextWriter) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : RenderControl(HtmlTextWriter) Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderControl( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderControl(writer)
C#
public virtual void RenderControl(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


RenderEndTag Method

[image]
Intersoft WebDesktop Documentation
RenderEndTag Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : RenderEndTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderEndTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderEndTag(writer)
C#
public virtual void RenderEndTag(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


ResolveClientUrl Method

[image]
Intersoft WebDesktop Documentation
ResolveClientUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : ResolveClientUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveClientUrl( _
   ByVal relativeUrl As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim relativeUrl As String
Dim value As String

value = instance.ResolveClientUrl(relativeUrl)
C#
public string ResolveClientUrl(
   string relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


ResolveImagePath Method

[image]
Intersoft WebDesktop Documentation
ResolveImagePath Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : ResolveImagePath Method

folder
image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveImagePath( _
   ByVal folder As String, _
   ByVal image As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim folder As String
Dim image As String
Dim value As String

value = instance.ResolveImagePath(folder, image)
C#
public string ResolveImagePath(
   string folder,
   string image
)

Parameters

folder
image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


ResolveRelativeURL Method

[image]
Intersoft WebDesktop Documentation
ResolveRelativeURL Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : ResolveRelativeURL Method

url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ResolveRelativeURL( _
   ByVal url As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim url As String
Dim value As String

value = instance.ResolveRelativeURL(url)
C#
public virtual string ResolveRelativeURL(
   string url
)

Parameters

url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


ResolveResourceUrl Method

[image]
Intersoft WebDesktop Documentation
ResolveResourceUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : ResolveResourceUrl Method

kind
defaultFolder
currentFolder
resourceName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveResourceUrl( _
   ByVal kind As ISNet.WebUI.ResourceKind, _
   ByVal defaultFolder As String, _
   ByVal currentFolder As String, _
   ByVal resourceName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim kind As ISNet.WebUI.ResourceKind
Dim defaultFolder As String
Dim currentFolder As String
Dim resourceName As String
Dim value As String

value = instance.ResolveResourceUrl(kind, defaultFolder, currentFolder, resourceName)
C#
public string ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   string defaultFolder,
   string currentFolder,
   string resourceName
)

Parameters

kind
defaultFolder
currentFolder
resourceName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


ResolveUrl Method

[image]
Intersoft WebDesktop Documentation
ResolveUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : ResolveUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveUrl( _
   ByVal relativeUrl As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim relativeUrl As String
Dim value As String

value = instance.ResolveUrl(relativeUrl)
C#
public string ResolveUrl(
   string relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


SaveLayout Method

[image]
Intersoft WebDesktop Documentation
SaveLayout Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : SaveLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim settings As ISNet.WebUI.LayoutInfo

instance.SaveLayout(settings)
C#
public virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


SaveLayoutToFile Method

[image]
Intersoft WebDesktop Documentation
SaveLayoutToFile Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : SaveLayoutToFile Method

filePath
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToFile( _
   ByVal filePath As String, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim filePath As String
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToFile(filePath, saveOptions)
C#
public virtual void SaveLayoutToFile(
   string filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

filePath
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


SaveLayoutToStream Method

[image]
Intersoft WebDesktop Documentation
SaveLayoutToStream Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : SaveLayoutToStream Method

stream
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToStream( _
   ByVal stream As System.IO.Stream, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim stream As System.IO.Stream
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToStream(stream, saveOptions)
C#
public virtual void SaveLayoutToStream(
   System.IO.Stream stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

stream
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


SetRenderMethodDelegate Method

[image]
Intersoft WebDesktop Documentation
SetRenderMethodDelegate Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : SetRenderMethodDelegate Method

renderMethod

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetRenderMethodDelegate( _
   ByVal renderMethod As System.Web.UI.RenderMethod _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim renderMethod As System.Web.UI.RenderMethod

instance.SetRenderMethodDelegate(renderMethod)
C#
public void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod renderMethod
)

Parameters

renderMethod

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


SetSessionTheme Method

[image]
Intersoft WebDesktop Documentation
SetSessionTheme Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : SetSessionTheme Method

themeInfo

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetSessionTheme( _
   ByVal themeInfo As ISNet.WebUI.ThemeInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim themeInfo As ISNet.WebUI.ThemeInfo

instance.SetSessionTheme(themeInfo)
C#
public void SetSessionTheme(
   ISNet.WebUI.ThemeInfo themeInfo
)

Parameters

themeInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


ShouldReturnJson Method

[image]
Intersoft WebDesktop Documentation
ShouldReturnJson Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : ShouldReturnJson Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ShouldReturnJson() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As Boolean

value = instance.ShouldReturnJson()
C#
public virtual bool ShouldReturnJson()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


WebFlyPostBackManager Class Properties

[image]
Intersoft WebDesktop Documentation
WebFlyPostBackManager Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebFlyPostBackManager Class

Glossary Item Box

For a list of all members of this type, see WebFlyPostBackManager members.

Public Properties

 | Name | Description
Public Property | Asynchronous | Gets or sets a value indicating asynchronous call.
Public Property | AutoEventWireup | Gets or sets a boolean value indicating whether the OnResponseSuccess function event should be wired up automatically.
Public Property | AutoLoadMetaData | Gets or sets a boolean value indicating whether WebFlyPostBackManager should load the service metadata information automatically.
Public Property | BlockPageUIOnBusy | Specifies whether the current page's UI should be blocked in client side when the control is in busy state. When blocked, the mouse cursor will be changed to HourGlass to prevent user interactions.
Public Property | CacheParameterizedRequest |
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ClientSideEvents |
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Enabled | Enabled state of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableManagedTheming | Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to False, this control will not apply the style defined in Theme Architecture. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableUIMode | Specifies whether the WebFlyPostBackManager instance should be used as User Interface mode. See Remarks for more details.
Public Property | EnableViewState | Whether the control automatically saves its state for use in round-trips. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). (Inherited from ISNet.WebUI.ISNetControl)
Public Property | FlyPostBackSettings |
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | LoaderHostControlID | Gets or sets the Client ID of the control which will be used to host the LoaderTemplate.
Public Property | LoaderStyle |
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RegisterRequestHandlerOnPreRenderComplete | Overridden.
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden. Gets or sets the directory where all required scripts for the control are stored.
Public Property | ServiceType | Gets or sets the service type of the fly postback manager instance.
Public Property | ServiceUrl | Gets or sets the relative URL of the service page used by WebFlyPostBackManager for its data retrieval.
Public Property | SharedScriptDirectory | Overridden. Gets or sets the directory where all shared scripts for Intersoft controls are stored.
Public Property | ShowLoaderOnBusy | Specifies whether to show LoaderTemplate when the WebFlyPostBackManager is in busy state.
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | TimeoutInterval | Gets or sets timeout interval for a client side invoke.
Public Property | UpdateControls |
Public Property | UpdateMode | Gets or sets a value representing the update behavior of automatic callback feature.
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateItems | Gets or sets the items to be stored in view state storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | Gets or sets the server connection string for file server-based viewstate storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | Gets or sets the location to store the viewstate of this control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | WebServiceResponseFormat |
Public Property | XmlCompressionEnabled | Specifies whether the Xml used for clientside state storage should be compressed. (Inherited from ISNet.WebUI.ISNetControl)
Top

See Also

Reference

WebFlyPostBackManager Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Retrieving notifications from webservice

tasks

Retrieving notifications from webform listener
Converting standard controls to use callback
Selectively converting standard controls to use callback
Programmatically refresh server control

Concepts

WebFlyPostBack Overview
WebFlyPostBack Features

concepts

Service Type
Metadata Collection
Data Types
Advanced Data Types


WebFlyPostBackManager Constructor

[image]
Intersoft WebDesktop Documentation
WebFlyPostBackManager Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : WebFlyPostBackManager Constructor

Glossary Item Box

Initializes a new instance of the WebFlyPostBackManager class.

Overload List

Overload | Description
WebFlyPostBackManager Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


Asynchronous Property

[image]
Intersoft WebDesktop Documentation
Asynchronous Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : Asynchronous Property

Glossary Item Box

Gets or sets a value indicating asynchronous call.

Syntax

Visual Basic (Declaration)
Public Property Asynchronous As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As Boolean

instance.Asynchronous = value

value = instance.Asynchronous
C#
public bool Asynchronous {get; set;}

Remarks

By default, the component will operate in asynchronous mode. The asynchronous mode is the preferred operation mode since it delivers smoother user experience by performing actions in the background. However in some scenarios, you may want to use synchronous invocation. You can change the operation mode to synchronous by setting Asynchronous property to False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members

Concepts

WebFlyPostBack Features


AutoEventWireup Property

[image]
Intersoft WebDesktop Documentation
AutoEventWireup Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : AutoEventWireup Property

Glossary Item Box

Gets or sets a boolean value indicating whether the OnResponseSuccess function event should be wired up automatically.

Syntax

Visual Basic (Declaration)
Public Property AutoEventWireup As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As Boolean

instance.AutoEventWireup = value

value = instance.AutoEventWireup
C#
public bool AutoEventWireup {get; set;}

Remarks

By enabling the AutoEventWireup, you do not need to attach to the OnResponseSuccess client side event. The component runtime will automatically look for the prefixed function name and call it if it existed. See following sample codes.

function Button1_Click()
{
var fpbManager1 = ISGetObject("dataService");
fpbManager1.GetCollection();
}

function dataService_OnGetCollection(result)
{
alert("GetCollection result is :" + result);
}

As shown in the sample codes above, the component will automatically call specific function name having this format: [component ID]_On[method name]

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


AutoLoadMetaData Property

[image]
Intersoft WebDesktop Documentation
AutoLoadMetaData Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : AutoLoadMetaData Property

Glossary Item Box

Gets or sets a boolean value indicating whether WebFlyPostBackManager should load the service metadata information automatically.

Syntax

Visual Basic (Declaration)
Public Property AutoLoadMetaData As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As Boolean

instance.AutoLoadMetaData = value

value = instance.AutoLoadMetaData
C#
public bool AutoLoadMetaData {get; set;}

Remarks

This feature allows the component to perform automatic meta data loading when the component is initialized successfully in client side. The automatic meta data loading is useful so that you can call the exposed methods directly in the client side.

For instance, you may have the codes in the following without metadata loaded:
fpbManager.Invoke("FunctionA", param1);

With metadata loaded, you can call the function directly instead of above code:
fpbManager.FunctionA(param1);

Metadata Collection is a set of information needed by WebFlyPostBackManager to perform FlyPostBack request. The information basically is a list of methods declaration (name of the methods, its parameters and its return value) for methods that marked as [WebMethod] or [WebFlyPostBackMethod].

This Metadata Collection by default is automatically retrieved during Page_Load. However, you can set the WebFlyPostBackManager to retrieve the Metadata manually by changing the AutoloadMetadata property to False. Retrieving the metadata collection manually means that collecting the Metadata only when a request is being sent for the first time.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members

Concepts

WebFlyPostBack Features

concepts

Metadata Collection
Life Cycle


BlockPageUIOnBusy Property

[image]
Intersoft WebDesktop Documentation
BlockPageUIOnBusy Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : BlockPageUIOnBusy Property

Glossary Item Box

Specifies whether the current page's UI should be blocked in client side when the control is in busy state. When blocked, the mouse cursor will be changed to HourGlass to prevent user interactions.

Syntax

Visual Basic (Declaration)
Public Property BlockPageUIOnBusy As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As Boolean

instance.BlockPageUIOnBusy = value

value = instance.BlockPageUIOnBusy
C#
public bool BlockPageUIOnBusy {get; set;}

Remarks

By setting this property to True you can block the page UI while the component is busy retrieving data from server side. While the page is blocked, the mouse cursor will be changed to hour glass and UI elements in the page become non-clickable.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


CacheParameterizedRequest Property

[image]
Intersoft WebDesktop Documentation
CacheParameterizedRequest Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : CacheParameterizedRequest Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property CacheParameterizedRequest As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As Boolean

instance.CacheParameterizedRequest = value

value = instance.CacheParameterizedRequest
C#
public bool CacheParameterizedRequest {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


ClientIDMode Property

[image]
Intersoft WebDesktop Documentation
ClientIDMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : ClientIDMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ClientIDMode As System.Web.UI.ClientIDMode
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As System.Web.UI.ClientIDMode

instance.ClientIDMode = value

value = instance.ClientIDMode
C#
public virtual System.Web.UI.ClientIDMode ClientIDMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


ClientSideEvents Property

[image]
Intersoft WebDesktop Documentation
ClientSideEvents Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : ClientSideEvents Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ClientSideEvents As WebFlyPostBackManagerClientSideEvents
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As WebFlyPostBackManagerClientSideEvents

instance.ClientSideEvents = value

value = instance.ClientSideEvents
C#
public WebFlyPostBackManagerClientSideEvents ClientSideEvents {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


ControlDataTransferFormat Property

[image]
Intersoft WebDesktop Documentation
ControlDataTransferFormat Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : ControlDataTransferFormat Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ControlDataTransferFormat As ISNet.WebUI.DataTransferFormat
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As ISNet.WebUI.DataTransferFormat

instance.ControlDataTransferFormat = value

value = instance.ControlDataTransferFormat
C#
public virtual ISNet.WebUI.DataTransferFormat ControlDataTransferFormat {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


Enabled Property

[image]
Intersoft WebDesktop Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : Enabled Property

Glossary Item Box

Enabled state of the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property Enabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As Boolean

instance.Enabled = value

value = instance.Enabled
C#
public virtual bool Enabled {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


EnableManagedTheming Property

[image]
Intersoft WebDesktop Documentation
EnableManagedTheming Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : EnableManagedTheming Property

Glossary Item Box

Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to False, this control will not apply the style defined in Theme Architecture.

Syntax

Visual Basic (Declaration)
Public Overridable Property EnableManagedTheming As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As Boolean

instance.EnableManagedTheming = value

value = instance.EnableManagedTheming
C#
public virtual bool EnableManagedTheming {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


EnableTheming Property

[image]
Intersoft WebDesktop Documentation
EnableTheming Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : EnableTheming Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property EnableTheming As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As Boolean

instance.EnableTheming = value

value = instance.EnableTheming
C#
public virtual bool EnableTheming {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


EnableUIMode Property

[image]
Intersoft WebDesktop Documentation
EnableUIMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : EnableUIMode Property

Glossary Item Box

Specifies whether the WebFlyPostBackManager instance should be used as User Interface mode. See Remarks for more details.

Syntax

Visual Basic (Declaration)
Public Property EnableUIMode As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As Boolean

instance.EnableUIMode = value

value = instance.EnableUIMode
C#
public bool EnableUIMode {get; set;}

Remarks

When UIMode is enabled, the ASP.NET standard controls such as DropDownList, ListBox, etc. will be automatically redirected to use FlyPostBack instead of standard full page postback. The page life cycle will be executed as in normal postback life cycle. In UI (User Interface) mode, you can use the FlyPostBackManager component to refresh specific server side controls without causing full page postback. The number of controls that will be affected depend on the value in UpdateMode property. You can decide whether all ASP.NET standard controls should be converted to use FlyPostBack or only specific individual controls by configuring the UpdateMode property.

This feature can only be enabled when the component is using WebForm mode (ServiceType = WebFom).

Several things to note while you are enabling automatic callback feature:

  • You can place your codes in the control's events the same way and manner as the WebForm is operating in full postback.
  • The results of the rendering are delta. That means modified controls are automatically detected, and only modified controls are rendered back to client.
  • Page life cycle and view state is persisted automatically between postbacks. Note that the PostInputControls and PostViewState property in the FlyPostBackSettings should be automatically set to True when you enable the UI mode.
  • No single line of javascript codes is required.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members

Tasks

Converting standard controls to use callback
Selectively converting standard controls to use callback

Concepts

WebFlyPostBack Features


EnableViewState Property

[image]
Intersoft WebDesktop Documentation
EnableViewState Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : EnableViewState Property

Glossary Item Box

Whether the control automatically saves its state for use in round-trips.

Syntax

Visual Basic (Declaration)
Public Overridable Property EnableViewState As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As Boolean

instance.EnableViewState = value

value = instance.EnableViewState
C#
public virtual bool EnableViewState {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


EnableWebResources Property

[image]
Intersoft WebDesktop Documentation
EnableWebResources Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : EnableWebResources Property

Glossary Item Box

Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory).

Syntax

Visual Basic (Declaration)
Public Property EnableWebResources As ISNet.WebUI.WebResourceType
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As ISNet.WebUI.WebResourceType

instance.EnableWebResources = value

value = instance.EnableWebResources
C#
public ISNet.WebUI.WebResourceType EnableWebResources {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


FlyPostBackSettings Property

[image]
Intersoft WebDesktop Documentation
FlyPostBackSettings Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : FlyPostBackSettings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FlyPostBackSettings As WebFlyPostBackManagerSettings
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As WebFlyPostBackManagerSettings

value = instance.FlyPostBackSettings
C#
public WebFlyPostBackManagerSettings FlyPostBackSettings {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


ID Property

[image]
Intersoft WebDesktop Documentation
ID Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : ID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ID As String
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As String

instance.ID = value

value = instance.ID
C#
public virtual string ID {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


LoaderHostControlID Property

[image]
Intersoft WebDesktop Documentation
LoaderHostControlID Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : LoaderHostControlID Property

Glossary Item Box

Gets or sets the Client ID of the control which will be used to host the LoaderTemplate.

Syntax

Visual Basic (Declaration)
Public Property LoaderHostControlID As String
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As String

instance.LoaderHostControlID = value

value = instance.LoaderHostControlID
C#
public string LoaderHostControlID {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


LoaderStyle Property

[image]
Intersoft WebDesktop Documentation
LoaderStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : LoaderStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property LoaderStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As ISNet.WebUI.WebStyle

instance.LoaderStyle = value

value = instance.LoaderStyle
C#
public ISNet.WebUI.WebStyle LoaderStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


Page Property

[image]
Intersoft WebDesktop Documentation
Page Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : Page Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Page As System.Web.UI.Page
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As System.Web.UI.Page

instance.Page = value

value = instance.Page
C#
public virtual System.Web.UI.Page Page {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


RegisterRequestHandlerOnPreRenderComplete Property

[image]
Intersoft WebDesktop Documentation
RegisterRequestHandlerOnPreRenderComplete Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : RegisterRequestHandlerOnPreRenderComplete Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property RegisterRequestHandlerOnPreRenderComplete As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As Boolean

value = instance.RegisterRequestHandlerOnPreRenderComplete
C#
public override bool RegisterRequestHandlerOnPreRenderComplete {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


RenderingMode Property

[image]
Intersoft WebDesktop Documentation
RenderingMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : RenderingMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property RenderingMode As ISNet.WebUI.RenderMode
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As ISNet.WebUI.RenderMode

instance.RenderingMode = value

value = instance.RenderingMode
C#
public virtual ISNet.WebUI.RenderMode RenderingMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


RuntimeLicenseKey Property

[image]
Intersoft WebDesktop Documentation
RuntimeLicenseKey Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : RuntimeLicenseKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property RuntimeLicenseKey As String
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As String

instance.RuntimeLicenseKey = value

value = instance.RuntimeLicenseKey
C#
public virtual string RuntimeLicenseKey {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


ScriptDirectory Property

[image]
Intersoft WebDesktop Documentation
ScriptDirectory Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : ScriptDirectory Property

Glossary Item Box

Gets or sets the directory where all required scripts for the control are stored.

Syntax

Visual Basic (Declaration)
Public Overrides Property ScriptDirectory As String
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As String

instance.ScriptDirectory = value

value = instance.ScriptDirectory
C#
public override string ScriptDirectory {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


ServiceType Property

[image]
Intersoft WebDesktop Documentation
ServiceType Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : ServiceType Property

Glossary Item Box

Gets or sets the service type of the fly postback manager instance.

Syntax

Visual Basic (Declaration)
Public Property ServiceType As ServiceType
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As ServiceType

instance.ServiceType = value

value = instance.ServiceType
C#
public ServiceType ServiceType {get; set;}

Remarks

Using this property you can determine the service type whether to use WebService or WebForm.

WebService service type is recommended for application that require open API and standards implementation. To request an execution of method from WebServices, you need to change WebFlyPostManager's ServiceType property to WebService and specify its ServiceURL. With this settings you must have an .asmx file that points to WebService Class which WebFlyPostBackManager will refer to. Later on at ClientSide, with WebFlyPostBackManager you can request an execution of method at WebService (e.g HelloWorld()) and retrieve its return value at OnResponseSuccess event.

Note: The Method that is going to be executed from WebServices must be marked with [WebMethod()]

WebForm service type is recommended for application that does not require to be exposed as public API. This service type has some advantages compared to WebService type such as in term of performance and security. It also has the capability to handle wider data types, including Intersoft's proprietary collection objects. To request an execution of method from WebServices, change WebFlyPostManager's ServiceType property to WebService and specify its ServiceURL. With this settings you must have an .aspx file (WebForm) which has a listener (WebFlyPostBackListener). Later on at ClientSide, with WebFlyPostBackManager you can request an execution of Method at WebForm (e.g HelloWorld()) and retrieve its return value at OnResponseSuccess event.

Note: The Method that is going to be executed from WebForm must be marked with[WebFlyPostBackMethod()]

To learn more and the sample codes please read the Service Type concepts.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members

Tasks

Retrieving simple types using WebService

tasks

Retrieving simple types using WebForm service

Concepts

Service Type

concepts

WebFlyPostBack Features


ServiceUrl Property

[image]
Intersoft WebDesktop Documentation
ServiceUrl Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : ServiceUrl Property

Glossary Item Box

Gets or sets the relative URL of the service page used by WebFlyPostBackManager for its data retrieval.

Syntax

Visual Basic (Declaration)
Public Property ServiceUrl As String
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As String

instance.ServiceUrl = value

value = instance.ServiceUrl
C#
public string ServiceUrl {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members

Tasks

Retrieving simple types using WebService

tasks

Retrieving simple types using WebForm service

Concepts

Service Type


SharedScriptDirectory Property

[image]
Intersoft WebDesktop Documentation
SharedScriptDirectory Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : SharedScriptDirectory Property

Glossary Item Box

Gets or sets the directory where all shared scripts for Intersoft controls are stored.

Syntax

Visual Basic (Declaration)
Public Overrides Property SharedScriptDirectory As String
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As String

instance.SharedScriptDirectory = value

value = instance.SharedScriptDirectory
C#
public override string SharedScriptDirectory {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


ShowLoaderOnBusy Property

[image]
Intersoft WebDesktop Documentation
ShowLoaderOnBusy Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : ShowLoaderOnBusy Property

Glossary Item Box

Specifies whether to show LoaderTemplate when the WebFlyPostBackManager is in busy state.

Syntax

Visual Basic (Declaration)
Public Property ShowLoaderOnBusy As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As Boolean

instance.ShowLoaderOnBusy = value

value = instance.ShowLoaderOnBusy
C#
public bool ShowLoaderOnBusy {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


SkinID Property

[image]
Intersoft WebDesktop Documentation
SkinID Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : SkinID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property SkinID As String
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As String

instance.SkinID = value

value = instance.SkinID
C#
public virtual string SkinID {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


TabIndex Property

[image]
Intersoft WebDesktop Documentation
TabIndex Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : TabIndex Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property TabIndex As Short
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As Short

instance.TabIndex = value

value = instance.TabIndex
C#
public virtual short TabIndex {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


TimeoutInterval Property

[image]
Intersoft WebDesktop Documentation
TimeoutInterval Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : TimeoutInterval Property

Glossary Item Box

Gets or sets timeout interval for a client side invoke.

Syntax

Visual Basic (Declaration)
Public Property TimeoutInterval As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As Integer

instance.TimeoutInterval = value

value = instance.TimeoutInterval
C#
public int TimeoutInterval {get; set;}

Remarks

The default value for this property is 60 seconds.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


UpdateControls Property

[image]
Intersoft WebDesktop Documentation
UpdateControls Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : UpdateControls Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UpdateControls As System.Collections.ObjectModel.Collection(Of UpdateControl)
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As System.Collections.ObjectModel.Collection(Of UpdateControl)

value = instance.UpdateControls
C#
public System.Collections.ObjectModel.Collection<UpdateControl> UpdateControls {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


UpdateMode Property

[image]
Intersoft WebDesktop Documentation
UpdateMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : UpdateMode Property

Glossary Item Box

Gets or sets a value representing the update behavior of automatic callback feature.

Syntax

Visual Basic (Declaration)
Public Property UpdateMode As UIUpdateMode
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As UIUpdateMode

instance.UpdateMode = value

value = instance.UpdateMode
C#
public UIUpdateMode UpdateMode {get; set;}

Remarks

When the EnableUIMode property is set to True, you can decide whether all ASP.NET standard controls should be converted to use FlyPostBack or only specific individual controls by configuring the UpdateMode property. The default value is AllControls.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members

Tasks

Selectively converting standard controls to use callback


ValidateRequestMode Property

[image]
Intersoft WebDesktop Documentation
ValidateRequestMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : ValidateRequestMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ValidateRequestMode As System.Web.UI.ValidateRequestMode
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As System.Web.UI.ValidateRequestMode

instance.ValidateRequestMode = value

value = instance.ValidateRequestMode
C#
public virtual System.Web.UI.ValidateRequestMode ValidateRequestMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


ViewStateItems Property

[image]
Intersoft WebDesktop Documentation
ViewStateItems Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : ViewStateItems Property

Glossary Item Box

Gets or sets the items to be stored in view state storage.

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateItems As ISNet.WebUI.ViewStateItem
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As ISNet.WebUI.ViewStateItem

instance.ViewStateItems = value

value = instance.ViewStateItems
C#
public virtual ISNet.WebUI.ViewStateItem ViewStateItems {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


ViewStateMode Property

[image]
Intersoft WebDesktop Documentation
ViewStateMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : ViewStateMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateMode As System.Web.UI.ViewStateMode
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As System.Web.UI.ViewStateMode

instance.ViewStateMode = value

value = instance.ViewStateMode
C#
public virtual System.Web.UI.ViewStateMode ViewStateMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


ViewStateServerConnection Property

[image]
Intersoft WebDesktop Documentation
ViewStateServerConnection Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : ViewStateServerConnection Property

Glossary Item Box

Gets or sets the server connection string for file server-based viewstate storage.

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateServerConnection As String
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As String

instance.ViewStateServerConnection = value

value = instance.ViewStateServerConnection
C#
public virtual string ViewStateServerConnection {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


ViewStateStorage Property

[image]
Intersoft WebDesktop Documentation
ViewStateStorage Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : ViewStateStorage Property

Glossary Item Box

Gets or sets the location to store the viewstate of this control.

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateStorage As ISNet.WebUI.StateCacheStorage
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As ISNet.WebUI.StateCacheStorage

instance.ViewStateStorage = value

value = instance.ViewStateStorage
C#
public virtual ISNet.WebUI.StateCacheStorage ViewStateStorage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


WebServiceResponseFormat Property

[image]
Intersoft WebDesktop Documentation
WebServiceResponseFormat Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : WebServiceResponseFormat Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property WebServiceResponseFormat As ISNet.WebUI.ResponseFormat
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As ISNet.WebUI.ResponseFormat

instance.WebServiceResponseFormat = value

value = instance.WebServiceResponseFormat
C#
public ISNet.WebUI.ResponseFormat WebServiceResponseFormat {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


XmlCompressionEnabled Property

[image]
Intersoft WebDesktop Documentation
XmlCompressionEnabled Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : XmlCompressionEnabled Property

Glossary Item Box

Specifies whether the Xml used for clientside state storage should be compressed.

Syntax

Visual Basic (Declaration)
Public Overridable Property XmlCompressionEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim value As Boolean

instance.XmlCompressionEnabled = value

value = instance.XmlCompressionEnabled
C#
public virtual bool XmlCompressionEnabled {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


DataBinding Event

[image]
Intersoft WebDesktop Documentation
DataBinding Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : DataBinding Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event DataBinding As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim handler As EventHandler

AddHandler instance.DataBinding, handler
C#
public event EventHandler DataBinding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


Disposed Event

[image]
Intersoft WebDesktop Documentation
Disposed Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim handler As EventHandler

AddHandler instance.Disposed, handler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


Init Event

[image]
Intersoft WebDesktop Documentation
Init Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : Init Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Init As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim handler As EventHandler

AddHandler instance.Init, handler
C#
public event EventHandler Init

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


Load Event

[image]
Intersoft WebDesktop Documentation
Load Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : Load Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Load As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim handler As EventHandler

AddHandler instance.Load, handler
C#
public event EventHandler Load

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


PreInitialize Event

[image]
Intersoft WebDesktop Documentation
PreInitialize Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : PreInitialize Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event PreInitialize As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim handler As EventHandler

AddHandler instance.PreInitialize, handler
C#
public event EventHandler PreInitialize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


PreRender Event

[image]
Intersoft WebDesktop Documentation
PreRender Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : PreRender Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event PreRender As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim handler As EventHandler

AddHandler instance.PreRender, handler
C#
public event EventHandler PreRender

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


Unload Event

[image]
Intersoft WebDesktop Documentation
Unload Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManager Class : Unload Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Unload As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManager
Dim handler As EventHandler

AddHandler instance.Unload, handler
C#
public event EventHandler Unload

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManager Class
WebFlyPostBackManager Members


WebFlyPostBackManagerClientSideEvents Class

[image]
Intersoft WebDesktop Documentation
WebFlyPostBackManagerClientSideEvents Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebFlyPostBackManagerClientSideEvents Class

Glossary Item Box

Javascript functions which invoked from client side in WebFlyPostBackManager.

Object Model

WebFlyPostBackManagerClientSideEvents Class

Syntax

Visual Basic (Declaration)
Public Class WebFlyPostBackManagerClientSideEvents
   Inherits ISNet.WebUI.ClientEvents
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManagerClientSideEvents
C#
public class WebFlyPostBackManagerClientSideEvents : ISNet.WebUI.ClientEvents, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Remarks

WebFlyPostBackManager will give a response to client side whenever there is a request. Regardless, the state of WebFlyPostbackManager will give a response. The client side events include OnError, OnResponse, OnResponseSuccess, OnTimeout

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.ClientEvents
ISNet.WebUI.WebDesktop.WebFlyPostBackManagerClientSideEvents

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManagerClientSideEvents Members
ISNet.WebUI.WebDesktop Namespace

Concepts

ClientSide Events

concepts

WebFlyPostBackManager Features


WebFlyPostBackManagerClientSideEvents Class Members

[image]
Intersoft WebDesktop Documentation
WebFlyPostBackManagerClientSideEvents Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebFlyPostBackManagerClientSideEvents Class

Glossary Item Box

The following tables list the members exposed by WebFlyPostBackManagerClientSideEvents.

Public Constructors

 | Name | Description
Public Constructor | WebFlyPostBackManagerClientSideEvents Constructor |
Top

Public Properties

 | Name | Description
Public Property | OnError | Specifies the client side (JavaScript) function name that will be invoked when fly postback manager request is failed.
Public Property | OnResponse | Specifies the client side (JavaScript) function name that will be invoked when fly postback manager request gets a response.
Public Property | OnResponseSuccess | Specifies the client side (JavaScript) function name that will be invoked when fly postback manager response completely succeded.
Public Property | OnTimeout | Specifies the client side (JavaScript) function name that will be invoked when fly postback manager request gets a timeout.
Top

Public Methods

 | Name | Description
Public Method | CheckEventHandlerName | (Inherited from ISNet.WebUI.ClientEvents)
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsAnyAttachEventHandlers | (Inherited from ISNet.WebUI.ClientEvents)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | IsValidEventHandlerName | (Inherited from ISNet.WebUI.ClientEvents)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebFlyPostBackManagerClientSideEvents Class
ISNet.WebUI.WebDesktop Namespace

Concepts

ClientSide Events

concepts

WebFlyPostBackManager Features


WebFlyPostBackManagerClientSideEvents Constructor

[image]
Intersoft WebDesktop Documentation
WebFlyPostBackManagerClientSideEvents Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManagerClientSideEvents Class : WebFlyPostBackManagerClientSideEvents Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebFlyPostBackManagerClientSideEvents()
C#
public WebFlyPostBackManagerClientSideEvents()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManagerClientSideEvents Class
WebFlyPostBackManagerClientSideEvents Members


CheckEventHandlerName Method

[image]
Intersoft WebDesktop Documentation
CheckEventHandlerName Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManagerClientSideEvents Class : CheckEventHandlerName Method

eventName
eventHandlerName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub CheckEventHandlerName( _
   ByVal eventName As String, _
   ByVal eventHandlerName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManagerClientSideEvents
Dim eventName As String
Dim eventHandlerName As String

instance.CheckEventHandlerName(eventName, eventHandlerName)
C#
public virtual void CheckEventHandlerName(
   string eventName,
   string eventHandlerName
)

Parameters

eventName
eventHandlerName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManagerClientSideEvents Class
WebFlyPostBackManagerClientSideEvents Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManagerClientSideEvents Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManagerClientSideEvents
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManagerClientSideEvents Class
WebFlyPostBackManagerClientSideEvents Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManagerClientSideEvents Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManagerClientSideEvents Class
WebFlyPostBackManagerClientSideEvents Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManagerClientSideEvents Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManagerClientSideEvents
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManagerClientSideEvents Class
WebFlyPostBackManagerClientSideEvents Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManagerClientSideEvents Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManagerClientSideEvents
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManagerClientSideEvents Class
WebFlyPostBackManagerClientSideEvents Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManagerClientSideEvents Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManagerClientSideEvents
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManagerClientSideEvents Class
WebFlyPostBackManagerClientSideEvents Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManagerClientSideEvents Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManagerClientSideEvents
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManagerClientSideEvents Class
WebFlyPostBackManagerClientSideEvents Members


WebFlyPostBackManagerClientSideEvents Class Methods

[image]
Intersoft WebDesktop Documentation
WebFlyPostBackManagerClientSideEvents Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebFlyPostBackManagerClientSideEvents Class

Glossary Item Box

For a list of all members of this type, see WebFlyPostBackManagerClientSideEvents members.

Public Methods

 | Name | Description
Public Method | CheckEventHandlerName | (Inherited from ISNet.WebUI.ClientEvents)
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsAnyAttachEventHandlers | (Inherited from ISNet.WebUI.ClientEvents)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | IsValidEventHandlerName | (Inherited from ISNet.WebUI.ClientEvents)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebFlyPostBackManagerClientSideEvents Class
ISNet.WebUI.WebDesktop Namespace

Concepts

ClientSide Events

concepts

WebFlyPostBackManager Features


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManagerClientSideEvents Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManagerClientSideEvents
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManagerClientSideEvents Class
WebFlyPostBackManagerClientSideEvents Members


IsAnyAttachEventHandlers Method

[image]
Intersoft WebDesktop Documentation
IsAnyAttachEventHandlers Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManagerClientSideEvents Class : IsAnyAttachEventHandlers Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsAnyAttachEventHandlers() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManagerClientSideEvents
Dim value As Boolean

value = instance.IsAnyAttachEventHandlers()
C#
public virtual bool IsAnyAttachEventHandlers()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManagerClientSideEvents Class
WebFlyPostBackManagerClientSideEvents Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManagerClientSideEvents Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManagerClientSideEvents
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManagerClientSideEvents Class
WebFlyPostBackManagerClientSideEvents Members


IsValidEventHandlerName Method

[image]
Intersoft WebDesktop Documentation
IsValidEventHandlerName Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManagerClientSideEvents Class : IsValidEventHandlerName Method

eventHandlerName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsValidEventHandlerName( _
   ByVal eventHandlerName As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManagerClientSideEvents
Dim eventHandlerName As String
Dim value As Boolean

value = instance.IsValidEventHandlerName(eventHandlerName)
C#
public virtual bool IsValidEventHandlerName(
   string eventHandlerName
)

Parameters

eventHandlerName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManagerClientSideEvents Class
WebFlyPostBackManagerClientSideEvents Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManagerClientSideEvents Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManagerClientSideEvents

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManagerClientSideEvents Class
WebFlyPostBackManagerClientSideEvents Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManagerClientSideEvents Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManagerClientSideEvents
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManagerClientSideEvents Class
WebFlyPostBackManagerClientSideEvents Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManagerClientSideEvents Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManagerClientSideEvents
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManagerClientSideEvents Class
WebFlyPostBackManagerClientSideEvents Members


WebFlyPostBackManagerClientSideEvents Class Properties

[image]
Intersoft WebDesktop Documentation
WebFlyPostBackManagerClientSideEvents Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebFlyPostBackManagerClientSideEvents Class

Glossary Item Box

For a list of all members of this type, see WebFlyPostBackManagerClientSideEvents members.

Public Properties

 | Name | Description
Public Property | OnError | Specifies the client side (JavaScript) function name that will be invoked when fly postback manager request is failed.
Public Property | OnResponse | Specifies the client side (JavaScript) function name that will be invoked when fly postback manager request gets a response.
Public Property | OnResponseSuccess | Specifies the client side (JavaScript) function name that will be invoked when fly postback manager response completely succeded.
Public Property | OnTimeout | Specifies the client side (JavaScript) function name that will be invoked when fly postback manager request gets a timeout.
Top

See Also

Reference

WebFlyPostBackManagerClientSideEvents Class
ISNet.WebUI.WebDesktop Namespace

Concepts

ClientSide Events

concepts

WebFlyPostBackManager Features


WebFlyPostBackManagerClientSideEvents Constructor

[image]
Intersoft WebDesktop Documentation
WebFlyPostBackManagerClientSideEvents Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManagerClientSideEvents Class : WebFlyPostBackManagerClientSideEvents Constructor

Glossary Item Box

Initializes a new instance of the WebFlyPostBackManagerClientSide class.

Overload List

Overload | Description
WebFlyPostBackManagerClientSideEvents Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManagerClientSideEvents Class
WebFlyPostBackManagerClientSideEvents Members


OnError Property

[image]
Intersoft WebDesktop Documentation
OnError Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManagerClientSideEvents Class : OnError Property

Glossary Item Box

Specifies the client side (JavaScript) function name that will be invoked when fly postback manager request is failed.

Syntax

Visual Basic (Declaration)
Public Overridable Property OnError As String
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManagerClientSideEvents
Dim value As String

instance.OnError = value

value = instance.OnError
C#
public virtual string OnError {get; set;}

Remarks

This event is executed when the WebFlyPostBackManager responses to the invalid request.

WebFlyPostBackManager implements error handling in automatic form. Therefore, the error thrown during FlyPostBack™ call or during client side processing will not be directly shown to users. In other words, any exceptions thrown by the server side method will not cause major failure to the caller. You can intercept the error in the OnError client side event when there is exception thrown by the server side method.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManagerClientSideEvents Class
WebFlyPostBackManagerClientSideEvents Members

Concepts

ClientSide Events

concepts

WebFlyPostBack Features


OnResponse Property

[image]
Intersoft WebDesktop Documentation
OnResponse Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManagerClientSideEvents Class : OnResponse Property

Glossary Item Box

Specifies the client side (JavaScript) function name that will be invoked when fly postback manager request gets a response.

Syntax

Visual Basic (Declaration)
Public Overridable Property OnResponse As String
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManagerClientSideEvents
Dim value As String

instance.OnResponse = value

value = instance.OnResponse
C#
public virtual string OnResponse {get; set;}

Remarks

This event is executed when the WebFlyPostBackManager responses to the request, whether it is executed successfully or failed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManagerClientSideEvents Class
WebFlyPostBackManagerClientSideEvents Members

Concepts

ClientSide Events


OnResponseSuccess Property

[image]
Intersoft WebDesktop Documentation
OnResponseSuccess Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManagerClientSideEvents Class : OnResponseSuccess Property

Glossary Item Box

Specifies the client side (JavaScript) function name that will be invoked when fly postback manager response completely succeded.

Syntax

Visual Basic (Declaration)
Public Overridable Property OnResponseSuccess As String
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManagerClientSideEvents
Dim value As String

instance.OnResponseSuccess = value

value = instance.OnResponseSuccess
C#
public virtual string OnResponseSuccess {get; set;}

Remarks

This event is executed when the WebFlyPostBackManager responses to the successfully executed request.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManagerClientSideEvents Class
WebFlyPostBackManagerClientSideEvents Members

Tasks

Retrieving notifications from webservice

tasks

Retrieving notifications from webform listener

Concepts

ClientSide Events


OnTimeout Property

[image]
Intersoft WebDesktop Documentation
OnTimeout Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManagerClientSideEvents Class : OnTimeout Property

Glossary Item Box

Specifies the client side (JavaScript) function name that will be invoked when fly postback manager request gets a timeout.

Syntax

Visual Basic (Declaration)
Public Overridable Property OnTimeout As String
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManagerClientSideEvents
Dim value As String

instance.OnTimeout = value

value = instance.OnTimeout
C#
public virtual string OnTimeout {get; set;}

Remarks

This event is executed when the WebFlyPostBackManager does not response in certain period of time defined in TimeoutInterval property. The default value of TimeoutInterval is 60 seconds.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManagerClientSideEvents Class
WebFlyPostBackManagerClientSideEvents Members

Concepts

ClientSide Events


WebFlyPostBackManagerSettings Class

[image]
Intersoft WebDesktop Documentation
WebFlyPostBackManagerSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebFlyPostBackManagerSettings Class

Glossary Item Box

A collection of fly-postback settings for WebDesktopWindow object.

Object Model

WebFlyPostBackManagerSettings Class

Syntax

Visual Basic (Declaration)
Public Class WebFlyPostBackManagerSettings
   Inherits ISNet.WebUI.FlyPostBackSettings
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManagerSettings
C#
public class WebFlyPostBackManagerSettings : ISNet.WebUI.FlyPostBackSettings, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Remarks

Using WebFlyPostBackManagerSettings you can configure the fly-postback settings, such as PostControlState, PostHiddenFields, PostInputControls, PostViewState, and SelectiveControlsForHiddenFields.

In converting standard controls into FlyPostBack requests, you can customize a lot of behavioral settings related to the UI mode, such as whether you want to make all standard ASP.NET controls in the page to use FlyPostBack requests, or only a specific set of controls.

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.FlyPostBackSettings
ISNet.WebUI.WebDesktop.WebFlyPostBackManagerSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManagerSettings Members
ISNet.WebUI.WebDesktop Namespace

Tasks

Converting standard controls to use callback

Concepts

WebFlyPostBackManager Features


WebFlyPostBackManagerSettings Class Members

[image]
Intersoft WebDesktop Documentation
WebFlyPostBackManagerSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebFlyPostBackManagerSettings Class

Glossary Item Box

The following tables list the members exposed by WebFlyPostBackManagerSettings.

Public Constructors

 | Name | Description
Public Constructor | WebFlyPostBackManagerSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | PostControlState | Overridden. Gets or sets a value indicating whether this control's state should be posted during OnTheFly postback.
Public Property | PostHiddenFields | Overridden. Gets or sets whether hidden fields should be posted to server during OnTheFly postback.
Public Property | PostInputControls | Overridden. Gets or sets whether HTML INPUT controls as well as SELECT and TEXTAREA should be posted to server during OnTheFly postback.
Public Property | PostViewState | Overridden. Gets or sets whether the __VIEWSTATE content should be posted to server during OnTheFly postback.
Public Property | SelectiveControlsForHiddenFields | Gets or sets the collection of controls that will be automatically converted to use callback instead of full postback.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebFlyPostBackManagerSettings Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Converting standard controls to use callback

Concepts

WebFlyPostBackManager Features


WebFlyPostBackManagerSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebFlyPostBackManagerSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManagerSettings Class : WebFlyPostBackManagerSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebFlyPostBackManagerSettings()
C#
public WebFlyPostBackManagerSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManagerSettings Class
WebFlyPostBackManagerSettings Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManagerSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManagerSettings
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManagerSettings Class
WebFlyPostBackManagerSettings Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManagerSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManagerSettings Class
WebFlyPostBackManagerSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManagerSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManagerSettings
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManagerSettings Class
WebFlyPostBackManagerSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManagerSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManagerSettings
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManagerSettings Class
WebFlyPostBackManagerSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManagerSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManagerSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManagerSettings Class
WebFlyPostBackManagerSettings Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManagerSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManagerSettings
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManagerSettings Class
WebFlyPostBackManagerSettings Members


WebFlyPostBackManagerSettings Class Methods

[image]
Intersoft WebDesktop Documentation
WebFlyPostBackManagerSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebFlyPostBackManagerSettings Class

Glossary Item Box

For a list of all members of this type, see WebFlyPostBackManagerSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebFlyPostBackManagerSettings Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Converting standard controls to use callback

Concepts

WebFlyPostBackManager Features


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManagerSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManagerSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManagerSettings Class
WebFlyPostBackManagerSettings Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManagerSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManagerSettings
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManagerSettings Class
WebFlyPostBackManagerSettings Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManagerSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManagerSettings

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManagerSettings Class
WebFlyPostBackManagerSettings Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManagerSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManagerSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManagerSettings Class
WebFlyPostBackManagerSettings Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManagerSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManagerSettings
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManagerSettings Class
WebFlyPostBackManagerSettings Members


WebFlyPostBackManagerSettings Class Properties

[image]
Intersoft WebDesktop Documentation
WebFlyPostBackManagerSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebFlyPostBackManagerSettings Class

Glossary Item Box

For a list of all members of this type, see WebFlyPostBackManagerSettings members.

Public Properties

 | Name | Description
Public Property | PostControlState | Overridden. Gets or sets a value indicating whether this control's state should be posted during OnTheFly postback.
Public Property | PostHiddenFields | Overridden. Gets or sets whether hidden fields should be posted to server during OnTheFly postback.
Public Property | PostInputControls | Overridden. Gets or sets whether HTML INPUT controls as well as SELECT and TEXTAREA should be posted to server during OnTheFly postback.
Public Property | PostViewState | Overridden. Gets or sets whether the __VIEWSTATE content should be posted to server during OnTheFly postback.
Public Property | SelectiveControlsForHiddenFields | Gets or sets the collection of controls that will be automatically converted to use callback instead of full postback.
Top

See Also

Reference

WebFlyPostBackManagerSettings Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Converting standard controls to use callback

Concepts

WebFlyPostBackManager Features


WebFlyPostBackManagerSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebFlyPostBackManagerSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManagerSettings Class : WebFlyPostBackManagerSettings Constructor

Glossary Item Box

Initializes a new instance of the WebFlyPostBackManagerSettings class.

Overload List

Overload | Description
WebFlyPostBackManagerSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManagerSettings Class
WebFlyPostBackManagerSettings Members


PostControlState Property

[image]
Intersoft WebDesktop Documentation
PostControlState Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManagerSettings Class : PostControlState Property

Glossary Item Box

Gets or sets a value indicating whether this control's state should be posted during OnTheFly postback.

Syntax

Visual Basic (Declaration)
Public Overrides Property PostControlState As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManagerSettings
Dim value As Boolean

instance.PostControlState = value

value = instance.PostControlState
C#
public override bool PostControlState {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManagerSettings Class
WebFlyPostBackManagerSettings Members


PostHiddenFields Property

[image]
Intersoft WebDesktop Documentation
PostHiddenFields Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManagerSettings Class : PostHiddenFields Property

Glossary Item Box

Gets or sets whether hidden fields should be posted to server during OnTheFly postback.

Syntax

Visual Basic (Declaration)
Public Overrides Property PostHiddenFields As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManagerSettings
Dim value As Boolean

instance.PostHiddenFields = value

value = instance.PostHiddenFields
C#
public override bool PostHiddenFields {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManagerSettings Class
WebFlyPostBackManagerSettings Members


PostInputControls Property

[image]
Intersoft WebDesktop Documentation
PostInputControls Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManagerSettings Class : PostInputControls Property

Glossary Item Box

Gets or sets whether HTML INPUT controls as well as SELECT and TEXTAREA should be posted to server during OnTheFly postback.

Syntax

Visual Basic (Declaration)
Public Overrides Property PostInputControls As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManagerSettings
Dim value As Boolean

instance.PostInputControls = value

value = instance.PostInputControls
C#
public override bool PostInputControls {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManagerSettings Class
WebFlyPostBackManagerSettings Members


PostViewState Property

[image]
Intersoft WebDesktop Documentation
PostViewState Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManagerSettings Class : PostViewState Property

Glossary Item Box

Gets or sets whether the __VIEWSTATE content should be posted to server during OnTheFly postback.

Syntax

Visual Basic (Declaration)
Public Overrides Property PostViewState As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManagerSettings
Dim value As Boolean

instance.PostViewState = value

value = instance.PostViewState
C#
public override bool PostViewState {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManagerSettings Class
WebFlyPostBackManagerSettings Members


SelectiveControlsForHiddenFields Property

[image]
Intersoft WebDesktop Documentation
SelectiveControlsForHiddenFields Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackManagerSettings Class : SelectiveControlsForHiddenFields Property

Glossary Item Box

Gets or sets the collection of controls that will be automatically converted to use callback instead of full postback.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SelectiveControlsForHiddenFields As System.Collections.ObjectModel.Collection(Of UpdateControl)
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackManagerSettings
Dim value As System.Collections.ObjectModel.Collection(Of UpdateControl)

value = instance.SelectiveControlsForHiddenFields
C#
public System.Collections.ObjectModel.Collection<UpdateControl> SelectiveControlsForHiddenFields {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackManagerSettings Class
WebFlyPostBackManagerSettings Members


WebFlyPostBackMethodAttribute Class

[image]
Intersoft WebDesktop Documentation
WebFlyPostBackMethodAttribute Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebFlyPostBackMethodAttribute Class

Glossary Item Box

Attribute representing a method which can be called by WebFlyPostBackManager.

Object Model

WebFlyPostBackMethodAttribute Class

Syntax

Visual Basic (Declaration)
Public Class WebFlyPostBackMethodAttribute
   Inherits ISNet.WebUI.BaseFlyPostBackMethodAttribute
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackMethodAttribute
C#
public class WebFlyPostBackMethodAttribute : ISNet.WebUI.BaseFlyPostBackMethodAttribute

Inheritance Hierarchy

System.Object
System.Attribute
ISNet.WebUI.BaseFlyPostBackMethodAttribute
ISNet.WebUI.WebDesktop.WebFlyPostBackMethodAttribute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackMethodAttribute Members
ISNet.WebUI.WebDesktop Namespace


WebFlyPostBackMethodAttribute Class Members

[image]
Intersoft WebDesktop Documentation
WebFlyPostBackMethodAttribute Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebFlyPostBackMethodAttribute Class

Glossary Item Box

The following tables list the members exposed by WebFlyPostBackMethodAttribute.

Public Constructors

 | Name | Description
Public Constructor | WebFlyPostBackMethodAttribute Constructor | Initializes a new instance of the WebFlyPostBackMethodAttribute class.
Top

Public Properties

 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top

See Also

Reference

WebFlyPostBackMethodAttribute Class
ISNet.WebUI.WebDesktop Namespace


WebFlyPostBackMethodAttribute Class Methods

[image]
Intersoft WebDesktop Documentation
WebFlyPostBackMethodAttribute Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebFlyPostBackMethodAttribute Class

Glossary Item Box

For a list of all members of this type, see WebFlyPostBackMethodAttribute members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top

See Also

Reference

WebFlyPostBackMethodAttribute Class
ISNet.WebUI.WebDesktop Namespace


WebFlyPostBackMethodAttribute Class Properties

[image]
Intersoft WebDesktop Documentation
WebFlyPostBackMethodAttribute Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebFlyPostBackMethodAttribute Class

Glossary Item Box

For a list of all members of this type, see WebFlyPostBackMethodAttribute members.

Public Properties

 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)
Top

See Also

Reference

WebFlyPostBackMethodAttribute Class
ISNet.WebUI.WebDesktop Namespace


WebFlyPostBackMethodAttribute Constructor

[image]
Intersoft WebDesktop Documentation
WebFlyPostBackMethodAttribute Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackMethodAttribute Class : WebFlyPostBackMethodAttribute Constructor

Glossary Item Box

Initializes a new instance of the WebFlyPostBackMethodAttribute class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebFlyPostBackMethodAttribute()
C#
public WebFlyPostBackMethodAttribute()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackMethodAttribute Class
WebFlyPostBackMethodAttribute Members


Equals Method

[image]
Intersoft WebDesktop Documentation
Equals Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackMethodAttribute Class : Equals Method

obj

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackMethodAttribute
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public virtual bool Equals(
   object obj
)

Parameters

obj

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackMethodAttribute Class
WebFlyPostBackMethodAttribute Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackMethodAttribute Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackMethodAttribute
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackMethodAttribute Class
WebFlyPostBackMethodAttribute Members


IsDefaultAttribute Method

[image]
Intersoft WebDesktop Documentation
IsDefaultAttribute Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackMethodAttribute Class : IsDefaultAttribute Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsDefaultAttribute() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackMethodAttribute
Dim value As Boolean

value = instance.IsDefaultAttribute()
C#
public virtual bool IsDefaultAttribute()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackMethodAttribute Class
WebFlyPostBackMethodAttribute Members


Match Method

[image]
Intersoft WebDesktop Documentation
Match Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackMethodAttribute Class : Match Method

obj

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Match( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackMethodAttribute
Dim obj As Object
Dim value As Boolean

value = instance.Match(obj)
C#
public virtual bool Match(
   object obj
)

Parameters

obj

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackMethodAttribute Class
WebFlyPostBackMethodAttribute Members


TypeId Property

[image]
Intersoft WebDesktop Documentation
TypeId Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebFlyPostBackMethodAttribute Class : TypeId Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property TypeId As Object
Visual Basic (Usage) Copy Code
Dim instance As WebFlyPostBackMethodAttribute
Dim value As Object

value = instance.TypeId
C#
public virtual object TypeId {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFlyPostBackMethodAttribute Class
WebFlyPostBackMethodAttribute Members


WebGroupPane Class

[image]
Intersoft WebDesktop Documentation
WebGroupPane Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebGroupPane Class

Glossary Item Box

Collection of panes contain nested children of type WebPane or WebGroupPane. WebGroupPane can not contain server side controls.

Object Model

WebGroupPane Class

Syntax

Visual Basic (Declaration)
Public Class WebGroupPane
   Inherits WebPaneBase
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebGroupPane
C#
public class WebGroupPane : WebPaneBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject

Remarks

WebGroupPane can be used to layout the contained children in Horizontal Tiling or Vertical Tiling arrangement. The combination of WebGroupPane with its arrangement mode and nested WebPane enables you to create any kind of complex Layout in consistent fashion by using strong object model. For better understanding and illustration please read Understanding Concepts.

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase
ISNet.WebUI.WebDesktop.WebPaneBase
ISNet.WebUI.WebDesktop.WebGroupPane

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGroupPane Members
ISNet.WebUI.WebDesktop Namespace

Concepts

Understanding Concepts
Add GroupPane

concepts

Add Sibling GroupPane
Convert to GroupPane


WebGroupPane Class Members

[image]
Intersoft WebDesktop Documentation
WebGroupPane Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebGroupPane Class

Glossary Item Box

The following tables list the members exposed by WebGroupPane.

Public Constructors

 | Name | Description
Public Constructor | WebGroupPane Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | AccessKey | Keyboard shortcut used by the control. (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | AllowCollapse | Indicates whether users are allowed to collase panes through splitter. (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | AllowResize | Determines whether panes are resizable. (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | CaptionDisplayMode | Gets or sets the mode of the caption display. (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | DiscardContainerStyle | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | GroupPaneHeaderVisible | Determines whether the GroupPane's Header is visible.
Public Property | GroupType | Gets or sets the group type of this GroupPane.
Public Property | HeaderAppearance | Gets or sets the default predefined style applied to Header part. (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | HeaderCustomStyle | Gets or sets the style applied to the Header part of the Pane when the HeaderAppearance is set to Custom. (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | Height | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | HeightValue | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | Image | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | ImageAlignment | Gets or sets the alignment of the image. The image alignment is relative to the caption text. (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | InfoText | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | InfoTextAlignment | Gets or sets the alignment of the InfoText relative to its placeholder. (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | InfoTextPosition | Gets or sets the position of the InfoText part. (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | IsEnabled | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | Name | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | Panes | Gets or sets the child panes inside this GroupPane.
Public Property | Text | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | TextAlignment | Gets or sets the alignment of the text. (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | ToolTip | The tooltip displayed when the mouse is over the control. (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | UseRelativePositioning | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | Visible | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | Width | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | WidthValue | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | RecalculateActualDimension | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebGroupPane Class
ISNet.WebUI.WebDesktop Namespace

Concepts

Understanding Concepts
Add GroupPane

concepts

Add Sibling GroupPane
Convert to GroupPane


WebGroupPane Constructor

[image]
Intersoft WebDesktop Documentation
WebGroupPane Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebGroupPane Class : WebGroupPane Constructor

Glossary Item Box

Overload List

Overload | Description
WebGroupPane Constructor() |
WebGroupPane Constructor(String,GroupPaneType) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGroupPane Class
WebGroupPane Members


WebGroupPane Constructor()

[image]
Intersoft WebDesktop Documentation
WebGroupPane Constructor()
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebGroupPane Class > WebGroupPane Constructor : WebGroupPane Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebGroupPane()
C#
public WebGroupPane()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGroupPane Class
WebGroupPane Members
Overload List


WebGroupPane Constructor(String,GroupPaneType)

[image]
Intersoft WebDesktop Documentation
WebGroupPane Constructor(String,GroupPaneType)
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebGroupPane Class > WebGroupPane Constructor : WebGroupPane Constructor(String,GroupPaneType)

name
type

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal type As GroupPaneType _
)
Visual Basic (Usage) Copy Code
Dim name As String
Dim type As GroupPaneType

Dim instance As New WebGroupPane(name, type)
C#
public WebGroupPane(
   string name,
   GroupPaneType type
)

Parameters

name
type

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGroupPane Class
WebGroupPane Members
Overload List


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebGroupPane Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebGroupPane
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGroupPane Class
WebGroupPane Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebGroupPane Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGroupPane Class
WebGroupPane Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebGroupPane Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGroupPane
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGroupPane Class
WebGroupPane Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebGroupPane Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGroupPane
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGroupPane Class
WebGroupPane Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebGroupPane Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGroupPane
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGroupPane Class
WebGroupPane Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebGroupPane Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGroupPane
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGroupPane Class
WebGroupPane Members


WebGroupPane Class Methods

[image]
Intersoft WebDesktop Documentation
WebGroupPane Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebGroupPane Class

Glossary Item Box

For a list of all members of this type, see WebGroupPane members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | RecalculateActualDimension | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebGroupPane Class
ISNet.WebUI.WebDesktop Namespace

Concepts

Understanding Concepts
Add GroupPane

concepts

Add Sibling GroupPane
Convert to GroupPane


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebGroupPane Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGroupPane
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGroupPane Class
WebGroupPane Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebGroupPane Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGroupPane
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGroupPane Class
WebGroupPane Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebGroupPane Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebGroupPane

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGroupPane Class
WebGroupPane Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebGroupPane Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGroupPane
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGroupPane Class
WebGroupPane Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebGroupPane Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebGroupPane
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGroupPane Class
WebGroupPane Members


WebGroupPane Class Properties

[image]
Intersoft WebDesktop Documentation
WebGroupPane Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebGroupPane Class

Glossary Item Box

For a list of all members of this type, see WebGroupPane members.

Public Properties

 | Name | Description
Public Property | AccessKey | Keyboard shortcut used by the control. (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | AllowCollapse | Indicates whether users are allowed to collase panes through splitter. (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | AllowResize | Determines whether panes are resizable. (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | CaptionDisplayMode | Gets or sets the mode of the caption display. (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | DiscardContainerStyle | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | GroupPaneHeaderVisible | Determines whether the GroupPane's Header is visible.
Public Property | GroupType | Gets or sets the group type of this GroupPane.
Public Property | HeaderAppearance | Gets or sets the default predefined style applied to Header part. (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | HeaderCustomStyle | Gets or sets the style applied to the Header part of the Pane when the HeaderAppearance is set to Custom. (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | Height | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | HeightValue | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | Image | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | ImageAlignment | Gets or sets the alignment of the image. The image alignment is relative to the caption text. (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | InfoText | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | InfoTextAlignment | Gets or sets the alignment of the InfoText relative to its placeholder. (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | InfoTextPosition | Gets or sets the position of the InfoText part. (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | IsEnabled | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | Name | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | Panes | Gets or sets the child panes inside this GroupPane.
Public Property | Text | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | TextAlignment | Gets or sets the alignment of the text. (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | ToolTip | The tooltip displayed when the mouse is over the control. (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | UseRelativePositioning | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | Visible | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | Width | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | WidthValue | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Top

See Also

Reference

WebGroupPane Class
ISNet.WebUI.WebDesktop Namespace

Concepts

Understanding Concepts
Add GroupPane

concepts

Add Sibling GroupPane
Convert to GroupPane


GroupPaneHeaderVisible Property

[image]
Intersoft WebDesktop Documentation
GroupPaneHeaderVisible Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebGroupPane Class : GroupPaneHeaderVisible Property

Glossary Item Box

Determines whether the GroupPane's Header is visible.

Syntax

Visual Basic (Declaration)
Public Property GroupPaneHeaderVisible As Visibility
Visual Basic (Usage) Copy Code
Dim instance As WebGroupPane
Dim value As Visibility

instance.GroupPaneHeaderVisible = value

value = instance.GroupPaneHeaderVisible
C#
public Visibility GroupPaneHeaderVisible {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGroupPane Class
WebGroupPane Members


GroupType Property

[image]
Intersoft WebDesktop Documentation
GroupType Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebGroupPane Class : GroupType Property

Glossary Item Box

Gets or sets the group type of this GroupPane.

Syntax

Visual Basic (Declaration)
Public Property GroupType As GroupPaneType
Visual Basic (Usage) Copy Code
Dim instance As WebGroupPane
Dim value As GroupPaneType

instance.GroupType = value

value = instance.GroupType
C#
public GroupPaneType GroupType {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGroupPane Class
WebGroupPane Members


Panes Property

[image]
Intersoft WebDesktop Documentation
Panes Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebGroupPane Class : Panes Property

Glossary Item Box

Gets or sets the child panes inside this GroupPane.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Panes As WebPaneCollection
Visual Basic (Usage) Copy Code
Dim instance As WebGroupPane
Dim value As WebPaneCollection

value = instance.Panes
C#
public WebPaneCollection Panes {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGroupPane Class
WebGroupPane Members


WebMenu Class

[image]
Intersoft WebDesktop Documentation
WebMenu Class
Members Example See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebMenu Class

Glossary Item Box

WebMenu is the core runtime system that builds up WebMenuBar and WebContextMenu control.

Object Model

WebMenu Class

Syntax

Visual Basic (Declaration)
Public Class WebMenu
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebMenu
C#
public class WebMenu : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Remarks

Using WebMenu you can easily create professional Office® 2003-like menu system. You can use WebMenuBar control to quickly build a professional Office-like, dockable menu user interface to your web application. The MenuBar is modeled after the popular desktop's Menu system, and provides unique functions in addition to the regular features of a Menu.

The hybrid menu system enables tight integration with various WebDesktop.NET's members that requires menu functions. Hybrid menu system is the same core foundation that builds WebMenuBar and WebContextMenu control. Therefore, developers will get consistent object model and API across products that implement the menu system.

WebMenu has the ability to simulate latest visual styles which are highly configurable through property settings. Moreover, WebMenu implements every single details of a Desktop's Menu, from every keystroke, mouse events to advanced behaviors. The result is a great benefit for end users who have been familiar with desktop applications, such as navigation of menu items through keyboard arrow keys and navigation between menus and sub menus.

Example

The following codes show you how to create WebMenu structure programmatically.
C# Copy Code
protected void Page_Load(object sender, EventArgs e)
    {
        body.Style.Add("overflow", "hidden");

        // programmatically create command and items
        MenuCommand cmdFile = new MenuCommand();
        cmdFile.Name = "cmdFile";
        cmdFile.AccessKey = "F";
        cmdFile.Text = "File";

        WebMenuItem itmNew = new WebMenuItem();
        itmNew.Name = "itmNew";
        itmNew.Text = "New";

        WebMenuItem itmNewWindow = new WebMenuItem();
        itmNewWindow.Name = "itmNewWindow";
        itmNewWindow.Text = "New Window";

        WebMenuItem itmNewTab = new WebMenuItem();
        itmNewTab.Name = "itmNewTab";
        itmNewTab.Text = "New Tab";

        WebMenuItem separator = new WebMenuItem();
        separator.Type = MenuItemType.Separator;

        itmNew.Items.Add(itmNewTab);
        cmdFile.Items.Add(itmNew);
        cmdFile.Items.Add(new WebMenuItem("Open"));
        cmdFile.Items.Add(new WebMenuItem("Save", "mnuSave", "../Images/Save.gif"));
        cmdFile.Items.Add(separator);
        cmdFile.Items.Add(new WebMenuItem("Exit", "mnuExit", "", "e"));
        WebMenuBar1.Menus.Add(cmdFile);
    }

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebDesktop.WebMenu
ISNet.WebUI.WebDesktop.WebMenuRoot

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenu Members
ISNet.WebUI.WebDesktop Namespace

Tasks

Using MenuBar in PlaceHolderManager mode

Concepts

WebMenu Overview

concepts

WebMenu Features
WebMenu Styles
Keyboard Supports
Hybrid Menu System


WebMenu Class Members

[image]
Intersoft WebDesktop Documentation
WebMenu Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebMenu Class

Glossary Item Box

The following tables list the members exposed by WebMenu.

Public Constructors

 | Name | Description
Public Constructor | WebMenu Constructor |
Top

Public Properties

 | Name | Description
Public Property | Direction |
Public Property | IconViewMode | Specifies whether this menu should be displayed in IconView mode.
Public Property | OffsetAlignment |
Public Property | Width |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebMenu Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Using MenuBar in PlaceHolderManager mode

Concepts

WebMenu Overview

concepts

WebMenu Features
WebMenu Styles
Keyboard Supports
Hybrid Menu System


WebMenu Constructor

[image]
Intersoft WebDesktop Documentation
WebMenu Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenu Class : WebMenu Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebMenu()
C#
public WebMenu()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenu Class
WebMenu Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenu Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebMenu
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenu Class
WebMenu Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenu Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenu Class
WebMenu Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenu Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenu
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenu Class
WebMenu Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenu Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenu
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenu Class
WebMenu Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenu Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenu
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenu Class
WebMenu Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenu Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebMenu
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenu Class
WebMenu Members


WebMenu Class Methods

[image]
Intersoft WebDesktop Documentation
WebMenu Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebMenu Class

Glossary Item Box

For a list of all members of this type, see WebMenu members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebMenu Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Using MenuBar in PlaceHolderManager mode

Concepts

WebMenu Overview

concepts

WebMenu Features
WebMenu Styles
Keyboard Supports
Hybrid Menu System


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenu Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenu
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenu Class
WebMenu Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenu Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebMenu
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenu Class
WebMenu Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenu Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebMenu

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenu Class
WebMenu Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenu Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenu
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenu Class
WebMenu Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenu Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenu
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenu Class
WebMenu Members


WebMenu Class Properties

[image]
Intersoft WebDesktop Documentation
WebMenu Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebMenu Class

Glossary Item Box

For a list of all members of this type, see WebMenu members.

Public Properties

 | Name | Description
Public Property | Direction |
Public Property | IconViewMode | Specifies whether this menu should be displayed in IconView mode.
Public Property | OffsetAlignment |
Public Property | Width |
Top

See Also

Reference

WebMenu Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Using MenuBar in PlaceHolderManager mode

Concepts

WebMenu Overview

concepts

WebMenu Features
WebMenu Styles
Keyboard Supports
Hybrid Menu System


WebMenu Constructor

[image]
Intersoft WebDesktop Documentation
WebMenu Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenu Class : WebMenu Constructor

Glossary Item Box

Initializes a new instance of the WebMenu class.

Overload List

Overload | Description
WebMenu Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenu Class
WebMenu Members


Direction Property

[image]
Intersoft WebDesktop Documentation
Direction Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenu Class : Direction Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Direction As OrientationMode
Visual Basic (Usage) Copy Code
Dim instance As WebMenu
Dim value As OrientationMode

instance.Direction = value

value = instance.Direction
C#
public virtual OrientationMode Direction {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenu Class
WebMenu Members


IconViewMode Property

[image]
Intersoft WebDesktop Documentation
IconViewMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenu Class : IconViewMode Property

Glossary Item Box

Specifies whether this menu should be displayed in IconView mode.

Syntax

Visual Basic (Declaration)
Public Property IconViewMode As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebMenu
Dim value As Boolean

instance.IconViewMode = value

value = instance.IconViewMode
C#
public bool IconViewMode {get; set;}

Remarks

IconView mode enables the Menu to be displayed in compact form where menu item with Image are arranged horizontally and automatically flows to the next line as it reaches more items. This mode is useful when there are lots of menu items that used Images as users can easily find the command they are looking for.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenu Class
WebMenu Members


OffsetAlignment Property

[image]
Intersoft WebDesktop Documentation
OffsetAlignment Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenu Class : OffsetAlignment Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property OffsetAlignment As ISNet.WebUI.DisplayPosition
Visual Basic (Usage) Copy Code
Dim instance As WebMenu
Dim value As ISNet.WebUI.DisplayPosition

instance.OffsetAlignment = value

value = instance.OffsetAlignment
C#
public virtual ISNet.WebUI.DisplayPosition OffsetAlignment {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenu Class
WebMenu Members


Width Property

[image]
Intersoft WebDesktop Documentation
Width Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenu Class : Width Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Width As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebMenu
Dim value As System.Web.UI.WebControls.Unit

instance.Width = value

value = instance.Width
C#
public System.Web.UI.WebControls.Unit Width {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenu Class
WebMenu Members


WebMenuBar Class

[image]
Intersoft WebDesktop Documentation
WebMenuBar Class
Members Example See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebMenuBar Class

Glossary Item Box

WebMenuBar offers a MenuBar control functionality, an integration with PlaceHolderManager and completed with powerful Designer which will help the process of design time in a more convenient way.

Object Model

WebMenuBar Class

Syntax

Visual Basic (Declaration)
Public Class WebMenuBar
   Inherits ISNet.WebUI.ISNetControl
   Implements ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, ISNet.WebUI.ITemplateSync, IBar, ICommand, IWebMenuControl
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
C#
public class WebMenuBar : ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, ISNet.WebUI.ITemplateSync, IBar, ICommand, IWebMenuControl

Remarks

WebMenuBar is designed with a professional architecture and object model as well as specialized user interface for each elements. Therefore, WebMenuBar provides a flexibility to create a Windows-like MenuBar object which is rich in styles, functions and behaviors.

WebMenuBar can be be integrated with PlaceHolderManager. You may perform a dockable MenuBar which commonly found in desktop-based applications. By using PlaceHolderManager architecture, you can freely dock the MenuBar together with WebToolBar with no extensive coding required.

WebMenuBar is also supported with an interactive designer which eases you during design and development time process.

We have five different MenuItem Types of command. They are Normal, Radio, CheckBox, Separator, and Custom.

Example

The following codes show you how to create WebMenuBar's structures programmatically.
C# Copy Code
protected void Page_Load(object sender, EventArgs e)
    {
        body.Style.Add("overflow", "hidden");

        // programmatically create command and items
        MenuCommand cmdFile = new MenuCommand();
        cmdFile.Name = "cmdFile";
        cmdFile.AccessKey = "F";
        cmdFile.Text = "File";

        WebMenuItem itmNew = new WebMenuItem();
        itmNew.Name = "itmNew";
        itmNew.Text = "New";

        WebMenuItem itmNewWindow = new WebMenuItem();
        itmNewWindow.Name = "itmNewWindow";
        itmNewWindow.Text = "New Window";

        WebMenuItem itmNewTab = new WebMenuItem();
        itmNewTab.Name = "itmNewTab";
        itmNewTab.Text = "New Tab";

        WebMenuItem separator = new WebMenuItem();
        separator.Type = MenuItemType.Separator;

        itmNew.Items.Add(itmNewTab);
        cmdFile.Items.Add(itmNew);
        cmdFile.Items.Add(new WebMenuItem("Open"));
        cmdFile.Items.Add(new WebMenuItem("Save", "mnuSave", "../Images/Save.gif"));
        cmdFile.Items.Add(separator);
        cmdFile.Items.Add(new WebMenuItem("Exit", "mnuExit", "", "e"));
        WebMenuBar1.Menus.Add(cmdFile);
    }

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
ISNet.WebUI.ISNetControl
ISNet.WebUI.WebDesktop.WebMenuBar

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Members
ISNet.WebUI.WebDesktop Namespace

Tasks

Using MenuBar in PlaceHolderManager mode
Creating Standalone MenuBar
Working with MenuItem Types

Concepts

WebMenuBar Overview

concepts

Features
VisualMenuBuilder Overview
Building WebMenuBar Structure


WebMenuBar Class Members

[image]
Intersoft WebDesktop Documentation
WebMenuBar Class Members
See Also Properties Methods Events Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebMenuBar Class

Glossary Item Box

The following tables list the members exposed by WebMenuBar.

Public Constructors

 | Name | Description
Public Constructor | WebMenuBar Constructor |
Top

Public Properties

 | Name | Description
Public Property | AccessKey | Keyboard shortcut used by the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | AddRemoveOptionMenuViewMode |
Public Property | AllowCustomize |
Public Property | AllowDockBottom | Gets or sets a value that indicates whether a WebMenuBar control can be docked to bottom area of PlaceHolderManager.
Public Property | AllowDockLeft | Gets or sets a value that indicates whether a WebMenuBar control can be docked to left area of PlaceHolderManager.
Public Property | AllowDockRight | Gets or sets a value that indicates whether a WebMenuBar control can be docked to right area of PlaceHolderManager.
Public Property | AllowDockTop | Gets or sets a value that indicates whether a WebMenuBar control can be docked to top area of PlaceHolderManager.
Public Property | AllowExpandCollapse | Gets or sets a value that indicates whether a WebMenuBar control is expandable and collapseable.
Public Property | AllowFloat |
Public Property | AllowMove |
Public Property | AutoPostBack |
Public Property | BarStyle |
Public Property | BodyStyle |
Public Property | Caption |
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | CommandClientSideEvents |
Public Property | CommandDisabledStyle |
Public Property | CommandMargin |
Public Property | CommandSize |
Public Property | CommandStyle |
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Display |
Public Property | DisplayAccessKeyOnToolTip |
Public Property | DisplayMode |
Public Property | DisplayToolTip |
Public Property | DockingArea |
Public Property | DockingOffset |
Public Property | DockingRow |
Public Property | Enabled | Enable state of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableManagedTheming | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | Whether the control automatically saves its state for use in round-trips. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). (Inherited from ISNet.WebUI.ISNetControl)
Public Property | FillDockingRow |
Public Property | GreyImageWhenDisabled |
Public Property | HandleStyle |
Public Property | HandleVisible |
Public Property | HeaderButtonStyle |
Public Property | HeaderCaptionStyle |
Public Property | HeaderHeight |
Public Property | Height | Overridden.
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ImagesDirectory | Gets or sets the location of images used to render the control.
Public Property | ImageSize |
Public Property | IntegratedTo | Gets or sets the WebMenuBar menu integrated mode.
Public Property | IsFloat |
Public Property | Menus |
Public Property | MenuStyleSettings | Gets or sets the style properties of menu styles in the bar control.
Public Property | OptionStyle |
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | PlaceHolder |
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden. Gets or sets the directory where all required scripts for the control are stored.
Public Property | SeparatorStyle |
Public Property | SharedScriptDirectory | Overridden. Gets or sets the directory where all shared scripts for Intersoft controls are stored.
Public Property | ShowDelay |
Public Property | ShowFocusBorder |
Public Property | SizeMode |
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | TextAlign |
Public Property | ToolTip | The tooltip displayed when the mouse is over the control.
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateItems | Gets or sets the items to be stored in view state storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | Gets or sets the server connection string for file server-based viewstate storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | Gets or sets the location to store the viewstate of this control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | Overridden. Indicates whether the control is visible and rendered.
Public Property | Width | Overridden. The width of the control.
Public Property | XmlCompressionEnabled | Specifies whether the Xml used for clientside state storage should be compressed. (Inherited from ISNet.WebUI.ISNetControl)
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CheckConstrains | Overridden.
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CustomDeserialize |
Public Method | CustomSerialize |
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetOrientation |
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | GetXMLData | Overridden.
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadMenusStructureFromXml | Overloaded.
Public Method | LoadPostData | Overridden.
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RaisePostBackEvent |
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterScript | Overridden.
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResetUsageData |
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveMenusStructureToXml | Overloaded.
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetPlaceHolder |
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SynchronizeBarProperties |
Public Method | SynchronizeTemplatesFrom |
Top

Public Events

 | Name | Description
Public Event | BarLayoutPropertiesChanged | Occurs when bar layout properties is changed.
Public Event | BarPropertiesChanged | Occurs when bar properties is changed.
Public Event | CommandClick | Occurs when command bar is clicked.
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebMenuBar Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Using MenuBar in PlaceHolderManager mode
Creating Standalone MenuBar
Working with MenuItem Types

Concepts

WebMenuBar Overview

concepts

Features
VisualMenuBuilder Overview
Building WebMenuBar Structure


WebMenuBar Constructor

[image]
Intersoft WebDesktop Documentation
WebMenuBar Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : WebMenuBar Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebMenuBar()
C#
public WebMenuBar()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


ApplyStyle Method

[image]
Intersoft WebDesktop Documentation
ApplyStyle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : ApplyStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ApplyStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim s As System.Web.UI.WebControls.Style

instance.ApplyStyle(s)
C#
public void ApplyStyle(
   System.Web.UI.WebControls.Style s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


ApplyStyleSheetSkin Method

[image]
Intersoft WebDesktop Documentation
ApplyStyleSheetSkin Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : ApplyStyleSheetSkin Method

page

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub ApplyStyleSheetSkin( _
   ByVal page As System.Web.UI.Page _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim page As System.Web.UI.Page

instance.ApplyStyleSheetSkin(page)
C#
public virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page page
)

Parameters

page

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


CanUseWebResources Method

[image]
Intersoft WebDesktop Documentation
CanUseWebResources Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : CanUseWebResources Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CanUseWebResources() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As Boolean

value = instance.CanUseWebResources()
C#
public bool CanUseWebResources()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


WebMenuBar Class Methods

[image]
Intersoft WebDesktop Documentation
WebMenuBar Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebMenuBar Class

Glossary Item Box

For a list of all members of this type, see WebMenuBar members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CheckConstrains | Overridden.
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CustomDeserialize |
Public Method | CustomSerialize |
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetOrientation |
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | GetXMLData | Overridden.
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadMenusStructureFromXml | Overloaded.
Public Method | LoadPostData | Overridden.
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RaisePostBackEvent |
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterScript | Overridden.
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResetUsageData |
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveMenusStructureToXml | Overloaded.
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetPlaceHolder |
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SynchronizeBarProperties |
Public Method | SynchronizeTemplatesFrom |
Top

See Also

Reference

WebMenuBar Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Using MenuBar in PlaceHolderManager mode
Creating Standalone MenuBar
Working with MenuItem Types

Concepts

WebMenuBar Overview

concepts

Features
VisualMenuBuilder Overview
Building WebMenuBar Structure


CheckConstrains Method

[image]
Intersoft WebDesktop Documentation
CheckConstrains Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : CheckConstrains Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub CheckConstrains()
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar

instance.CheckConstrains()
C#
public override void CheckConstrains()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


CopyBaseAttributes Method

[image]
Intersoft WebDesktop Documentation
CopyBaseAttributes Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : CopyBaseAttributes Method

controlSrc

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyBaseAttributes( _
   ByVal controlSrc As System.Web.UI.WebControls.WebControl _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim controlSrc As System.Web.UI.WebControls.WebControl

instance.CopyBaseAttributes(controlSrc)
C#
public void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl controlSrc
)

Parameters

controlSrc

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.ISNetControl)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members
Overload List


CustomDeserialize Method

[image]
Intersoft WebDesktop Documentation
CustomDeserialize Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : CustomDeserialize Method

mi
currentObj
parentNode
currentNode

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CustomDeserialize( _
   ByVal mi As System.Reflection.MemberInfo, _
   ByVal currentObj As Object, _
   ByVal parentNode As System.Xml.XmlNode, _
   ByVal currentNode As System.Xml.XmlNode _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim mi As System.Reflection.MemberInfo
Dim currentObj As Object
Dim parentNode As System.Xml.XmlNode
Dim currentNode As System.Xml.XmlNode

instance.CustomDeserialize(mi, currentObj, parentNode, currentNode)
C#
public void CustomDeserialize(
   System.Reflection.MemberInfo mi,
   object currentObj,
   System.Xml.XmlNode parentNode,
   System.Xml.XmlNode currentNode
)

Parameters

mi
currentObj
parentNode
currentNode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


CustomSerialize Method

[image]
Intersoft WebDesktop Documentation
CustomSerialize Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : CustomSerialize Method

doc
node

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CustomSerialize( _
   ByVal doc As System.Xml.XmlDocument, _
   ByVal node As System.Xml.XmlNode _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim doc As System.Xml.XmlDocument
Dim node As System.Xml.XmlNode

instance.CustomSerialize(doc, node)
C#
public void CustomSerialize(
   System.Xml.XmlDocument doc,
   System.Xml.XmlNode node
)

Parameters

doc
node

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


DataBind Method

[image]
Intersoft WebDesktop Documentation
DataBind Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : DataBind Method

Glossary Item Box

Overload List

Overload | Description
DataBind | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


DataBind() Method

[image]
Intersoft WebDesktop Documentation
DataBind() Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : DataBind() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub DataBind()
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar

instance.DataBind()
C#
public virtual void DataBind()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


Dispose Method

[image]
Intersoft WebDesktop Documentation
Dispose Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : Dispose Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar

instance.Dispose()
C#
public virtual void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


FindControl Method

[image]
Intersoft WebDesktop Documentation
FindControl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : FindControl Method

Glossary Item Box

Overload List

Overload | Description
FindControl | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


FindControl(String) Method

[image]
Intersoft WebDesktop Documentation
FindControl(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : FindControl(String) Method

id

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function FindControl( _
   ByVal id As String _
) As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim id As String
Dim value As System.Web.UI.Control

value = instance.FindControl(id)
C#
public virtual System.Web.UI.Control FindControl(
   string id
)

Parameters

id

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


Focus Method

[image]
Intersoft WebDesktop Documentation
Focus Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : Focus Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Focus()
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar

instance.Focus()
C#
public virtual void Focus()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


ForceDisableXmlCompression Method

[image]
Intersoft WebDesktop Documentation
ForceDisableXmlCompression Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : ForceDisableXmlCompression Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ForceDisableXmlCompression()
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar

instance.ForceDisableXmlCompression()
C#
public void ForceDisableXmlCompression()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


GetCurrentControlLifeCycle Method

[image]
Intersoft WebDesktop Documentation
GetCurrentControlLifeCycle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : GetCurrentControlLifeCycle Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentControlLifeCycle() As ISNet.WebUI.ControlLifeCycle
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As ISNet.WebUI.ControlLifeCycle

value = instance.GetCurrentControlLifeCycle()
C#
public ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


GetCurrentTheme Method

[image]
Intersoft WebDesktop Documentation
GetCurrentTheme Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : GetCurrentTheme Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentTheme() As ISNet.WebUI.ThemeInfo
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As ISNet.WebUI.ThemeInfo

value = instance.GetCurrentTheme()
C#
public ISNet.WebUI.ThemeInfo GetCurrentTheme()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


GetFrameworkDataFolder Method

[image]
Intersoft WebDesktop Documentation
GetFrameworkDataFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : GetFrameworkDataFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkDataFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As String

value = instance.GetFrameworkDataFolder()
C#
public string GetFrameworkDataFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


GetFrameworkFolder Method

[image]
Intersoft WebDesktop Documentation
GetFrameworkFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : GetFrameworkFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As String

value = instance.GetFrameworkFolder()
C#
public string GetFrameworkFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


GetFrameworkVersion Method

[image]
Intersoft WebDesktop Documentation
GetFrameworkVersion Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : GetFrameworkVersion Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkVersion() As Version
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As Version

value = instance.GetFrameworkVersion()
C#
public Version GetFrameworkVersion()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


GetIntersoftFolder Method

[image]
Intersoft WebDesktop Documentation
GetIntersoftFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : GetIntersoftFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetIntersoftFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As String

value = instance.GetIntersoftFolder()
C#
public string GetIntersoftFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


GetLayoutFolder Method

[image]
Intersoft WebDesktop Documentation
GetLayoutFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : GetLayoutFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetLayoutFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As String

value = instance.GetLayoutFolder()
C#
public string GetLayoutFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


GetOrientation Method

[image]
Intersoft WebDesktop Documentation
GetOrientation Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : GetOrientation Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetOrientation() As OrientationMode
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As OrientationMode

value = instance.GetOrientation()
C#
public virtual OrientationMode GetOrientation()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


GetPostedXMLData Method

[image]
Intersoft WebDesktop Documentation
GetPostedXMLData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : GetPostedXMLData Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPostedXMLData() As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As String

value = instance.GetPostedXMLData()
C#
public string GetPostedXMLData()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


GetProductInfoKey Method

[image]
Intersoft WebDesktop Documentation
GetProductInfoKey Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : GetProductInfoKey Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductInfoKey() As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As String

value = instance.GetProductInfoKey()
C#
public string GetProductInfoKey()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


GetProductSimpleName Method

[image]
Intersoft WebDesktop Documentation
GetProductSimpleName Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : GetProductSimpleName Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductSimpleName() As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As String

value = instance.GetProductSimpleName()
C#
public string GetProductSimpleName()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


GetPropertyValue Method

[image]
Intersoft WebDesktop Documentation
GetPropertyValue Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : GetPropertyValue Method

defValue
propValue
webConfigKey

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPropertyValue( _
   ByVal defValue As String, _
   ByVal propValue As String, _
   ByVal webConfigKey As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim defValue As String
Dim propValue As String
Dim webConfigKey As String
Dim value As String

value = instance.GetPropertyValue(defValue, propValue, webConfigKey)
C#
public string GetPropertyValue(
   string defValue,
   string propValue,
   string webConfigKey
)

Parameters

defValue
propValue
webConfigKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


GetResourceStream Method

[image]
Intersoft WebDesktop Documentation
GetResourceStream Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : GetResourceStream Method

resourceUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetResourceStream( _
   ByVal resourceUrl As String _
) As System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim resourceUrl As String
Dim value As System.IO.Stream

value = instance.GetResourceStream(resourceUrl)
C#
public System.IO.Stream GetResourceStream(
   string resourceUrl
)

Parameters

resourceUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


GetRouteUrl Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : GetRouteUrl Method

Glossary Item Box

Overload List

Overload | Description
GetRouteUrl(Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(RouteValueDictionary) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,RouteValueDictionary) | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


GetRouteUrl(Object) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class > GetRouteUrl Method : GetRouteUrl(Object) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As Object _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim routeParameters As Object
Dim value As String

value = instance.GetRouteUrl(routeParameters)
C#
public string GetRouteUrl(
   object routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members
Overload List


GetRouteUrl(String,Object) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(String,Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class > GetRouteUrl Method : GetRouteUrl(String,Object) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As String, _
   ByVal routeParameters As Object _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim routeName As String
Dim routeParameters As Object
Dim value As String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public string GetRouteUrl(
   string routeName,
   object routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members
Overload List


GetRouteUrl(RouteValueDictionary) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(RouteValueDictionary) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class > GetRouteUrl Method : GetRouteUrl(RouteValueDictionary) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As String

value = instance.GetRouteUrl(routeParameters)
C#
public string GetRouteUrl(
   System.Web.Routing.RouteValueDictionary routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members
Overload List


GetRouteUrl(String,RouteValueDictionary) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(String,RouteValueDictionary) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class > GetRouteUrl Method : GetRouteUrl(String,RouteValueDictionary) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As String, _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim routeName As String
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public string GetRouteUrl(
   string routeName,
   System.Web.Routing.RouteValueDictionary routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members
Overload List


GetUniqueIDRelativeTo Method

[image]
Intersoft WebDesktop Documentation
GetUniqueIDRelativeTo Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : GetUniqueIDRelativeTo Method

control

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetUniqueIDRelativeTo( _
   ByVal control As System.Web.UI.Control _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim control As System.Web.UI.Control
Dim value As String

value = instance.GetUniqueIDRelativeTo(control)
C#
public string GetUniqueIDRelativeTo(
   System.Web.UI.Control control
)

Parameters

control

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


GetXMLData Method

[image]
Intersoft WebDesktop Documentation
GetXMLData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : GetXMLData Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function GetXMLData() As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As String

value = instance.GetXMLData()
C#
public override string GetXMLData()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


HasControls Method

[image]
Intersoft WebDesktop Documentation
HasControls Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : HasControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function HasControls() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As Boolean

value = instance.HasControls()
C#
public virtual bool HasControls()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


IsAtlasCallback Method

[image]
Intersoft WebDesktop Documentation
IsAtlasCallback Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : IsAtlasCallback Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsAtlasCallback() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As Boolean

value = instance.IsAtlasCallback()
C#
public bool IsAtlasCallback()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


IsBetaRelease Method

[image]
Intersoft WebDesktop Documentation
IsBetaRelease Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : IsBetaRelease Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsBetaRelease() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As Boolean

value = instance.IsBetaRelease()
C#
public bool IsBetaRelease()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


IsChromeBrowser Method

[image]
Intersoft WebDesktop Documentation
IsChromeBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : IsChromeBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsChromeBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As Boolean

value = instance.IsChromeBrowser()
C#
public bool IsChromeBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


IsFlyPostBackControl Method

[image]
Intersoft WebDesktop Documentation
IsFlyPostBackControl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : IsFlyPostBackControl Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackControl() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As Boolean

value = instance.IsFlyPostBackControl()
C#
public virtual bool IsFlyPostBackControl()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


IsFlyPostBackRequest Method

[image]
Intersoft WebDesktop Documentation
IsFlyPostBackRequest Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : IsFlyPostBackRequest Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackRequest() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As Boolean

value = instance.IsFlyPostBackRequest()
C#
public virtual bool IsFlyPostBackRequest()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


IsGeckoBasedBrowser Method

[image]
Intersoft WebDesktop Documentation
IsGeckoBasedBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : IsGeckoBasedBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoBasedBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As Boolean

value = instance.IsGeckoBasedBrowser()
C#
public bool IsGeckoBasedBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


IsGeckoVersion18 Method

[image]
Intersoft WebDesktop Documentation
IsGeckoVersion18 Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : IsGeckoVersion18 Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoVersion18() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As Boolean

value = instance.IsGeckoVersion18()
C#
public bool IsGeckoVersion18()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


IsInDesignMode Method

[image]
Intersoft WebDesktop Documentation
IsInDesignMode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : IsInDesignMode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInDesignMode() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As Boolean

value = instance.IsInDesignMode()
C#
public bool IsInDesignMode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


IsInternetExplorer8Browser Method

[image]
Intersoft WebDesktop Documentation
IsInternetExplorer8Browser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : IsInternetExplorer8Browser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorer8Browser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As Boolean

value = instance.IsInternetExplorer8Browser()
C#
public bool IsInternetExplorer8Browser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


IsInternetExplorerBrowser Method

[image]
Intersoft WebDesktop Documentation
IsInternetExplorerBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : IsInternetExplorerBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorerBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As Boolean

value = instance.IsInternetExplorerBrowser()
C#
public bool IsInternetExplorerBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


IsOperaBrowser Method

[image]
Intersoft WebDesktop Documentation
IsOperaBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : IsOperaBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsOperaBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As Boolean

value = instance.IsOperaBrowser()
C#
public bool IsOperaBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


IsSafariBrowser Method

[image]
Intersoft WebDesktop Documentation
IsSafariBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : IsSafariBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsSafariBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As Boolean

value = instance.IsSafariBrowser()
C#
public bool IsSafariBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


IsW3CStandardBrowser Method

[image]
Intersoft WebDesktop Documentation
IsW3CStandardBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : IsW3CStandardBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsW3CStandardBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As Boolean

value = instance.IsW3CStandardBrowser()
C#
public bool IsW3CStandardBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


LoadLayout Method

[image]
Intersoft WebDesktop Documentation
LoadLayout Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : LoadLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim settings As ISNet.WebUI.LayoutInfo

instance.LoadLayout(settings)
C#
public virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


LoadLayoutFromFile Method

[image]
Intersoft WebDesktop Documentation
LoadLayoutFromFile Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : LoadLayoutFromFile Method

filePath

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromFile( _
   ByVal filePath As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim filePath As String

instance.LoadLayoutFromFile(filePath)
C#
public virtual void LoadLayoutFromFile(
   string filePath
)

Parameters

filePath

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


LoadLayoutFromPredefinedName Method

[image]
Intersoft WebDesktop Documentation
LoadLayoutFromPredefinedName Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : LoadLayoutFromPredefinedName Method

predefinedName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromPredefinedName( _
   ByVal predefinedName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim predefinedName As String

instance.LoadLayoutFromPredefinedName(predefinedName)
C#
public virtual void LoadLayoutFromPredefinedName(
   string predefinedName
)

Parameters

predefinedName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


LoadLayoutFromStream Method

[image]
Intersoft WebDesktop Documentation
LoadLayoutFromStream Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : LoadLayoutFromStream Method

stream

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromStream( _
   ByVal stream As System.IO.Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim stream As System.IO.Stream

instance.LoadLayoutFromStream(stream)
C#
public virtual void LoadLayoutFromStream(
   System.IO.Stream stream
)

Parameters

stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


LoadMenusStructureFromXml Method

[image]
Intersoft WebDesktop Documentation
LoadMenusStructureFromXml Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : LoadMenusStructureFromXml Method

Glossary Item Box

Overload List

Overload | Description
LoadMenusStructureFromXml(String) |
LoadMenusStructureFromXml(XmlDocument) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


LoadMenusStructureFromXml(String) Method

[image]
Intersoft WebDesktop Documentation
LoadMenusStructureFromXml(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class > LoadMenusStructureFromXml Method : LoadMenusStructureFromXml(String) Method

fileName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadMenusStructureFromXml( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim fileName As String

instance.LoadMenusStructureFromXml(fileName)
C#
public void LoadMenusStructureFromXml(
   string fileName
)

Parameters

fileName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members
Overload List


LoadMenusStructureFromXml(XmlDocument) Method

[image]
Intersoft WebDesktop Documentation
LoadMenusStructureFromXml(XmlDocument) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class > LoadMenusStructureFromXml Method : LoadMenusStructureFromXml(XmlDocument) Method

doc

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadMenusStructureFromXml( _
   ByVal doc As System.Xml.XmlDocument _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim doc As System.Xml.XmlDocument

instance.LoadMenusStructureFromXml(doc)
C#
public void LoadMenusStructureFromXml(
   System.Xml.XmlDocument doc
)

Parameters

doc

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members
Overload List


LoadPostData Method

[image]
Intersoft WebDesktop Documentation
LoadPostData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : LoadPostData Method

postDataKey
postCollection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function LoadPostData( _
   ByVal postDataKey As String, _
   ByVal postCollection As System.Collections.Specialized.NameValueCollection _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim postDataKey As String
Dim postCollection As System.Collections.Specialized.NameValueCollection
Dim value As Boolean

value = instance.LoadPostData(postDataKey, postCollection)
C#
public override bool LoadPostData(
   string postDataKey,
   System.Collections.Specialized.NameValueCollection postCollection
)

Parameters

postDataKey
postCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


MergeStyle Method

[image]
Intersoft WebDesktop Documentation
MergeStyle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : MergeStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub MergeStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim s As System.Web.UI.WebControls.Style

instance.MergeStyle(s)
C#
public void MergeStyle(
   System.Web.UI.WebControls.Style s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


OnInfoChanged Method

[image]
Intersoft WebDesktop Documentation
OnInfoChanged Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : OnInfoChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnInfoChanged( _
   ByVal e As ISNet.WebUI.SynchronizeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim e As ISNet.WebUI.SynchronizeEventArgs

instance.OnInfoChanged(e)
C#
public void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


OnPreInitialize Method

[image]
Intersoft WebDesktop Documentation
OnPreInitialize Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : OnPreInitialize Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnPreInitialize()
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar

instance.OnPreInitialize()
C#
public virtual void OnPreInitialize()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


RaisePostBackEvent Method

[image]
Intersoft WebDesktop Documentation
RaisePostBackEvent Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : RaisePostBackEvent Method

eventArgument

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RaisePostBackEvent( _
   ByVal eventArgument As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim eventArgument As String

instance.RaisePostBackEvent(eventArgument)
C#
public void RaisePostBackEvent(
   string eventArgument
)

Parameters

eventArgument

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


RaisePostDataChangedEvent Method

[image]
Intersoft WebDesktop Documentation
RaisePostDataChangedEvent Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : RaisePostDataChangedEvent Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RaisePostDataChangedEvent()
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar

instance.RaisePostDataChangedEvent()
C#
public virtual void RaisePostDataChangedEvent()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


ReadWebConfigValue Method

[image]
Intersoft WebDesktop Documentation
ReadWebConfigValue Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : ReadWebConfigValue Method

key

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ReadWebConfigValue( _
   ByVal key As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim key As String
Dim value As String

value = instance.ReadWebConfigValue(key)
C#
public string ReadWebConfigValue(
   string key
)

Parameters

key

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


RegisterBoxSizing Method

[image]
Intersoft WebDesktop Documentation
RegisterBoxSizing Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : RegisterBoxSizing Method

Glossary Item Box

Overload List

Overload | Description
RegisterBoxSizing() | (Inherited from ISNet.WebUI.ISNetControl)
RegisterBoxSizing(Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


RegisterBoxSizing() Method

[image]
Intersoft WebDesktop Documentation
RegisterBoxSizing() Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class > RegisterBoxSizing Method : RegisterBoxSizing() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing()
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar

instance.RegisterBoxSizing()
C#
public void RegisterBoxSizing()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members
Overload List


RegisterBoxSizing(Boolean) Method

[image]
Intersoft WebDesktop Documentation
RegisterBoxSizing(Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class > RegisterBoxSizing Method : RegisterBoxSizing(Boolean) Method

forceAll

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing( _
   ByVal forceAll As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim forceAll As Boolean

instance.RegisterBoxSizing(forceAll)
C#
public void RegisterBoxSizing(
   bool forceAll
)

Parameters

forceAll

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members
Overload List


RegisterGlobalStyle Method

[image]
Intersoft WebDesktop Documentation
RegisterGlobalStyle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : RegisterGlobalStyle Method

style

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterGlobalStyle( _
   ByVal style As ISNet.WebUI.WebStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim style As ISNet.WebUI.WebStyle

instance.RegisterGlobalStyle(style)
C#
public void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle style
)

Parameters

style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


RegisterLink Method

[image]
Intersoft WebDesktop Documentation
RegisterLink Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : RegisterLink Method

name
url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterLink( _
   ByVal name As String, _
   ByVal url As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim name As String
Dim url As String

instance.RegisterLink(name, url)
C#
public void RegisterLink(
   string name,
   string url
)

Parameters

name
url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


RegisterOptimizedCssClasses Method

[image]
Intersoft WebDesktop Documentation
RegisterOptimizedCssClasses Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : RegisterOptimizedCssClasses Method

runtimeStyleOnly

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterOptimizedCssClasses( _
   ByVal runtimeStyleOnly As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim runtimeStyleOnly As Boolean

instance.RegisterOptimizedCssClasses(runtimeStyleOnly)
C#
public void RegisterOptimizedCssClasses(
   bool runtimeStyleOnly
)

Parameters

runtimeStyleOnly

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


RegisterPreloadImage Method

[image]
Intersoft WebDesktop Documentation
RegisterPreloadImage Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : RegisterPreloadImage Method

image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterPreloadImage( _
   ByVal image As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim image As String

instance.RegisterPreloadImage(image)
C#
public void RegisterPreloadImage(
   string image
)

Parameters

image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


RegisterScript Method

[image]
Intersoft WebDesktop Documentation
RegisterScript Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : RegisterScript Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub RegisterScript()
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar

instance.RegisterScript()
C#
public override void RegisterScript()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


RegisterSharePointHandler Method

[image]
Intersoft WebDesktop Documentation
RegisterSharePointHandler Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : RegisterSharePointHandler Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RegisterSharePointHandler()
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar

instance.RegisterSharePointHandler()
C#
public virtual void RegisterSharePointHandler()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


RenderBeginTag Method

[image]
Intersoft WebDesktop Documentation
RenderBeginTag Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : RenderBeginTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderBeginTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderBeginTag(writer)
C#
public virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


RenderControl Method

[image]
Intersoft WebDesktop Documentation
RenderControl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : RenderControl Method

Glossary Item Box

Overload List

Overload | Description
RenderControl | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


RenderControl(HtmlTextWriter) Method

[image]
Intersoft WebDesktop Documentation
RenderControl(HtmlTextWriter) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : RenderControl(HtmlTextWriter) Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderControl( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderControl(writer)
C#
public virtual void RenderControl(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


RenderEndTag Method

[image]
Intersoft WebDesktop Documentation
RenderEndTag Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : RenderEndTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub RenderEndTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderEndTag(writer)
C#
public override void RenderEndTag(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


ResetUsageData Method

[image]
Intersoft WebDesktop Documentation
ResetUsageData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : ResetUsageData Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ResetUsageData()
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar

instance.ResetUsageData()
C#
public void ResetUsageData()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


ResolveClientUrl Method

[image]
Intersoft WebDesktop Documentation
ResolveClientUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : ResolveClientUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveClientUrl( _
   ByVal relativeUrl As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim relativeUrl As String
Dim value As String

value = instance.ResolveClientUrl(relativeUrl)
C#
public string ResolveClientUrl(
   string relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


ResolveImagePath Method

[image]
Intersoft WebDesktop Documentation
ResolveImagePath Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : ResolveImagePath Method

folder
image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveImagePath( _
   ByVal folder As String, _
   ByVal image As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim folder As String
Dim image As String
Dim value As String

value = instance.ResolveImagePath(folder, image)
C#
public string ResolveImagePath(
   string folder,
   string image
)

Parameters

folder
image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


ResolveRelativeURL Method

[image]
Intersoft WebDesktop Documentation
ResolveRelativeURL Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : ResolveRelativeURL Method

url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ResolveRelativeURL( _
   ByVal url As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim url As String
Dim value As String

value = instance.ResolveRelativeURL(url)
C#
public virtual string ResolveRelativeURL(
   string url
)

Parameters

url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


ResolveResourceUrl Method

[image]
Intersoft WebDesktop Documentation
ResolveResourceUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : ResolveResourceUrl Method

kind
defaultFolder
currentFolder
resourceName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveResourceUrl( _
   ByVal kind As ISNet.WebUI.ResourceKind, _
   ByVal defaultFolder As String, _
   ByVal currentFolder As String, _
   ByVal resourceName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim kind As ISNet.WebUI.ResourceKind
Dim defaultFolder As String
Dim currentFolder As String
Dim resourceName As String
Dim value As String

value = instance.ResolveResourceUrl(kind, defaultFolder, currentFolder, resourceName)
C#
public string ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   string defaultFolder,
   string currentFolder,
   string resourceName
)

Parameters

kind
defaultFolder
currentFolder
resourceName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


ResolveUrl Method

[image]
Intersoft WebDesktop Documentation
ResolveUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : ResolveUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveUrl( _
   ByVal relativeUrl As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim relativeUrl As String
Dim value As String

value = instance.ResolveUrl(relativeUrl)
C#
public string ResolveUrl(
   string relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


SaveLayout Method

[image]
Intersoft WebDesktop Documentation
SaveLayout Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : SaveLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim settings As ISNet.WebUI.LayoutInfo

instance.SaveLayout(settings)
C#
public virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


SaveLayoutToFile Method

[image]
Intersoft WebDesktop Documentation
SaveLayoutToFile Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : SaveLayoutToFile Method

filePath
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToFile( _
   ByVal filePath As String, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim filePath As String
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToFile(filePath, saveOptions)
C#
public virtual void SaveLayoutToFile(
   string filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

filePath
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


SaveLayoutToStream Method

[image]
Intersoft WebDesktop Documentation
SaveLayoutToStream Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : SaveLayoutToStream Method

stream
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToStream( _
   ByVal stream As System.IO.Stream, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim stream As System.IO.Stream
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToStream(stream, saveOptions)
C#
public virtual void SaveLayoutToStream(
   System.IO.Stream stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

stream
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


SaveMenusStructureToXml Method

[image]
Intersoft WebDesktop Documentation
SaveMenusStructureToXml Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : SaveMenusStructureToXml Method

Glossary Item Box

Overload List

Overload | Description
SaveMenusStructureToXml(String) |
SaveMenusStructureToXml() |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


SaveMenusStructureToXml(String) Method

[image]
Intersoft WebDesktop Documentation
SaveMenusStructureToXml(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class > SaveMenusStructureToXml Method : SaveMenusStructureToXml(String) Method

fileName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub SaveMenusStructureToXml( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim fileName As String

instance.SaveMenusStructureToXml(fileName)
C#
public void SaveMenusStructureToXml(
   string fileName
)

Parameters

fileName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members
Overload List


SaveMenusStructureToXml() Method

[image]
Intersoft WebDesktop Documentation
SaveMenusStructureToXml() Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class > SaveMenusStructureToXml Method : SaveMenusStructureToXml() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function SaveMenusStructureToXml() As System.Xml.XmlDocument
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As System.Xml.XmlDocument

value = instance.SaveMenusStructureToXml()
C#
public System.Xml.XmlDocument SaveMenusStructureToXml()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members
Overload List


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


SetPlaceHolder Method

[image]
Intersoft WebDesktop Documentation
SetPlaceHolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : SetPlaceHolder Method

plHolder

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetPlaceHolder( _
   ByVal plHolder As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim plHolder As String

instance.SetPlaceHolder(plHolder)
C#
public void SetPlaceHolder(
   string plHolder
)

Parameters

plHolder

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


SetRenderMethodDelegate Method

[image]
Intersoft WebDesktop Documentation
SetRenderMethodDelegate Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : SetRenderMethodDelegate Method

renderMethod

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetRenderMethodDelegate( _
   ByVal renderMethod As System.Web.UI.RenderMethod _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim renderMethod As System.Web.UI.RenderMethod

instance.SetRenderMethodDelegate(renderMethod)
C#
public void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod renderMethod
)

Parameters

renderMethod

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


SetSessionTheme Method

[image]
Intersoft WebDesktop Documentation
SetSessionTheme Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : SetSessionTheme Method

themeInfo

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetSessionTheme( _
   ByVal themeInfo As ISNet.WebUI.ThemeInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim themeInfo As ISNet.WebUI.ThemeInfo

instance.SetSessionTheme(themeInfo)
C#
public void SetSessionTheme(
   ISNet.WebUI.ThemeInfo themeInfo
)

Parameters

themeInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


ShouldReturnJson Method

[image]
Intersoft WebDesktop Documentation
ShouldReturnJson Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : ShouldReturnJson Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ShouldReturnJson() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As Boolean

value = instance.ShouldReturnJson()
C#
public virtual bool ShouldReturnJson()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


SynchronizeBarProperties Method

[image]
Intersoft WebDesktop Documentation
SynchronizeBarProperties Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : SynchronizeBarProperties Method

bar

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SynchronizeBarProperties( _
   ByVal bar As IBar _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim bar As IBar

instance.SynchronizeBarProperties(bar)
C#
public void SynchronizeBarProperties(
   IBar bar
)

Parameters

bar

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


SynchronizeTemplatesFrom Method

[image]
Intersoft WebDesktop Documentation
SynchronizeTemplatesFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : SynchronizeTemplatesFrom Method

sourceObj

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SynchronizeTemplatesFrom( _
   ByVal sourceObj As ISNet.WebUI.ISNetControl _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim sourceObj As ISNet.WebUI.ISNetControl

instance.SynchronizeTemplatesFrom(sourceObj)
C#
public void SynchronizeTemplatesFrom(
   ISNet.WebUI.ISNetControl sourceObj
)

Parameters

sourceObj

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


AccessKey Property

[image]
Intersoft WebDesktop Documentation
AccessKey Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : AccessKey Property

Glossary Item Box

Keyboard shortcut used by the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property AccessKey As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As String

instance.AccessKey = value

value = instance.AccessKey
C#
public virtual string AccessKey {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


WebMenuBar Class Properties

[image]
Intersoft WebDesktop Documentation
WebMenuBar Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebMenuBar Class

Glossary Item Box

For a list of all members of this type, see WebMenuBar members.

Public Properties

 | Name | Description
Public Property | AccessKey | Keyboard shortcut used by the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | AddRemoveOptionMenuViewMode |
Public Property | AllowCustomize |
Public Property | AllowDockBottom | Gets or sets a value that indicates whether a WebMenuBar control can be docked to bottom area of PlaceHolderManager.
Public Property | AllowDockLeft | Gets or sets a value that indicates whether a WebMenuBar control can be docked to left area of PlaceHolderManager.
Public Property | AllowDockRight | Gets or sets a value that indicates whether a WebMenuBar control can be docked to right area of PlaceHolderManager.
Public Property | AllowDockTop | Gets or sets a value that indicates whether a WebMenuBar control can be docked to top area of PlaceHolderManager.
Public Property | AllowExpandCollapse | Gets or sets a value that indicates whether a WebMenuBar control is expandable and collapseable.
Public Property | AllowFloat |
Public Property | AllowMove |
Public Property | AutoPostBack |
Public Property | BarStyle |
Public Property | BodyStyle |
Public Property | Caption |
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | CommandClientSideEvents |
Public Property | CommandDisabledStyle |
Public Property | CommandMargin |
Public Property | CommandSize |
Public Property | CommandStyle |
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Display |
Public Property | DisplayAccessKeyOnToolTip |
Public Property | DisplayMode |
Public Property | DisplayToolTip |
Public Property | DockingArea |
Public Property | DockingOffset |
Public Property | DockingRow |
Public Property | Enabled | Enable state of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableManagedTheming | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | Whether the control automatically saves its state for use in round-trips. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). (Inherited from ISNet.WebUI.ISNetControl)
Public Property | FillDockingRow |
Public Property | GreyImageWhenDisabled |
Public Property | HandleStyle |
Public Property | HandleVisible |
Public Property | HeaderButtonStyle |
Public Property | HeaderCaptionStyle |
Public Property | HeaderHeight |
Public Property | Height | Overridden.
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ImagesDirectory | Gets or sets the location of images used to render the control.
Public Property | ImageSize |
Public Property | IntegratedTo | Gets or sets the WebMenuBar menu integrated mode.
Public Property | IsFloat |
Public Property | Menus |
Public Property | MenuStyleSettings | Gets or sets the style properties of menu styles in the bar control.
Public Property | OptionStyle |
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | PlaceHolder |
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden. Gets or sets the directory where all required scripts for the control are stored.
Public Property | SeparatorStyle |
Public Property | SharedScriptDirectory | Overridden. Gets or sets the directory where all shared scripts for Intersoft controls are stored.
Public Property | ShowDelay |
Public Property | ShowFocusBorder |
Public Property | SizeMode |
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | TextAlign |
Public Property | ToolTip | The tooltip displayed when the mouse is over the control.
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateItems | Gets or sets the items to be stored in view state storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | Gets or sets the server connection string for file server-based viewstate storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | Gets or sets the location to store the viewstate of this control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | Overridden. Indicates whether the control is visible and rendered.
Public Property | Width | Overridden. The width of the control.
Public Property | XmlCompressionEnabled | Specifies whether the Xml used for clientside state storage should be compressed. (Inherited from ISNet.WebUI.ISNetControl)
Top

See Also

Reference

WebMenuBar Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Using MenuBar in PlaceHolderManager mode
Creating Standalone MenuBar
Working with MenuItem Types

Concepts

WebMenuBar Overview

concepts

Features
VisualMenuBuilder Overview
Building WebMenuBar Structure


WebMenuBar Constructor

[image]
Intersoft WebDesktop Documentation
WebMenuBar Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : WebMenuBar Constructor

Glossary Item Box

Initializes a new instance of the WebMenuBar class.

Overload List

Overload | Description
WebMenuBar Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


AddRemoveOptionMenuViewMode Property

[image]
Intersoft WebDesktop Documentation
AddRemoveOptionMenuViewMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : AddRemoveOptionMenuViewMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property AddRemoveOptionMenuViewMode As AddRemoveOptionMenuViewMode
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As AddRemoveOptionMenuViewMode

instance.AddRemoveOptionMenuViewMode = value

value = instance.AddRemoveOptionMenuViewMode
C#
public AddRemoveOptionMenuViewMode AddRemoveOptionMenuViewMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


AllowCustomize Property

[image]
Intersoft WebDesktop Documentation
AllowCustomize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : AllowCustomize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property AllowCustomize As AllowCustomize
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As AllowCustomize

instance.AllowCustomize = value

value = instance.AllowCustomize
C#
public AllowCustomize AllowCustomize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


AllowDockBottom Property

[image]
Intersoft WebDesktop Documentation
AllowDockBottom Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : AllowDockBottom Property

Glossary Item Box

Gets or sets a value that indicates whether a WebMenuBar control can be docked to bottom area of PlaceHolderManager.

Syntax

Visual Basic (Declaration)
Public Property AllowDockBottom As AllowDock
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As AllowDock

instance.AllowDockBottom = value

value = instance.AllowDockBottom
C#
public AllowDock AllowDockBottom {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


AllowDockLeft Property

[image]
Intersoft WebDesktop Documentation
AllowDockLeft Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : AllowDockLeft Property

Glossary Item Box

Gets or sets a value that indicates whether a WebMenuBar control can be docked to left area of PlaceHolderManager.

Syntax

Visual Basic (Declaration)
Public Property AllowDockLeft As AllowDock
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As AllowDock

instance.AllowDockLeft = value

value = instance.AllowDockLeft
C#
public AllowDock AllowDockLeft {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


AllowDockRight Property

[image]
Intersoft WebDesktop Documentation
AllowDockRight Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : AllowDockRight Property

Glossary Item Box

Gets or sets a value that indicates whether a WebMenuBar control can be docked to right area of PlaceHolderManager.

Syntax

Visual Basic (Declaration)
Public Property AllowDockRight As AllowDock
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As AllowDock

instance.AllowDockRight = value

value = instance.AllowDockRight
C#
public AllowDock AllowDockRight {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


AllowDockTop Property

[image]
Intersoft WebDesktop Documentation
AllowDockTop Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : AllowDockTop Property

Glossary Item Box

Gets or sets a value that indicates whether a WebMenuBar control can be docked to top area of PlaceHolderManager.

Syntax

Visual Basic (Declaration)
Public Property AllowDockTop As AllowDock
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As AllowDock

instance.AllowDockTop = value

value = instance.AllowDockTop
C#
public AllowDock AllowDockTop {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


AllowExpandCollapse Property

[image]
Intersoft WebDesktop Documentation
AllowExpandCollapse Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : AllowExpandCollapse Property

Glossary Item Box

Gets or sets a value that indicates whether a WebMenuBar control is expandable and collapseable.

Syntax

Visual Basic (Declaration)
Public Property AllowExpandCollapse As AllowExpandCollapse
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As AllowExpandCollapse

instance.AllowExpandCollapse = value

value = instance.AllowExpandCollapse
C#
public AllowExpandCollapse AllowExpandCollapse {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


AllowFloat Property

[image]
Intersoft WebDesktop Documentation
AllowFloat Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : AllowFloat Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property AllowFloat As AllowFloat
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As AllowFloat

instance.AllowFloat = value

value = instance.AllowFloat
C#
public AllowFloat AllowFloat {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


AllowMove Property

[image]
Intersoft WebDesktop Documentation
AllowMove Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : AllowMove Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property AllowMove As AllowMove
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As AllowMove

instance.AllowMove = value

value = instance.AllowMove
C#
public AllowMove AllowMove {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


AutoPostBack Property

[image]
Intersoft WebDesktop Documentation
AutoPostBack Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : AutoPostBack Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property AutoPostBack As AutoPostBackMode
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As AutoPostBackMode

instance.AutoPostBack = value

value = instance.AutoPostBack
C#
public virtual AutoPostBackMode AutoPostBack {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


BarStyle Property

[image]
Intersoft WebDesktop Documentation
BarStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : BarStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property BarStyle As BarStyle
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As BarStyle

instance.BarStyle = value

value = instance.BarStyle
C#
public BarStyle BarStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


BodyStyle Property

[image]
Intersoft WebDesktop Documentation
BodyStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : BodyStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property BodyStyle As BarSectionStyle
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As BarSectionStyle

instance.BodyStyle = value

value = instance.BodyStyle
C#
public BarSectionStyle BodyStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


Caption Property

[image]
Intersoft WebDesktop Documentation
Caption Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : Caption Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Caption As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As String

instance.Caption = value

value = instance.Caption
C#
public virtual string Caption {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


ClientIDMode Property

[image]
Intersoft WebDesktop Documentation
ClientIDMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : ClientIDMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ClientIDMode As System.Web.UI.ClientIDMode
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As System.Web.UI.ClientIDMode

instance.ClientIDMode = value

value = instance.ClientIDMode
C#
public virtual System.Web.UI.ClientIDMode ClientIDMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


CommandClientSideEvents Property

[image]
Intersoft WebDesktop Documentation
CommandClientSideEvents Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : CommandClientSideEvents Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property CommandClientSideEvents As ISNet.WebUI.BaseMouseElementClientSideEvents
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As ISNet.WebUI.BaseMouseElementClientSideEvents

instance.CommandClientSideEvents = value

value = instance.CommandClientSideEvents
C#
public ISNet.WebUI.BaseMouseElementClientSideEvents CommandClientSideEvents {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


CommandDisabledStyle Property

[image]
Intersoft WebDesktop Documentation
CommandDisabledStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : CommandDisabledStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property CommandDisabledStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As ISNet.WebUI.WebStyle

instance.CommandDisabledStyle = value

value = instance.CommandDisabledStyle
C#
public virtual ISNet.WebUI.WebStyle CommandDisabledStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


CommandMargin Property

[image]
Intersoft WebDesktop Documentation
CommandMargin Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : CommandMargin Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property CommandMargin As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As System.Web.UI.WebControls.Unit

instance.CommandMargin = value

value = instance.CommandMargin
C#
public System.Web.UI.WebControls.Unit CommandMargin {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


CommandSize Property

[image]
Intersoft WebDesktop Documentation
CommandSize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : CommandSize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property CommandSize As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As System.Web.UI.WebControls.Unit

instance.CommandSize = value

value = instance.CommandSize
C#
public System.Web.UI.WebControls.Unit CommandSize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


CommandStyle Property

[image]
Intersoft WebDesktop Documentation
CommandStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : CommandStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property CommandStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As ISNet.WebUI.DynamicStyle

instance.CommandStyle = value

value = instance.CommandStyle
C#
public virtual ISNet.WebUI.DynamicStyle CommandStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


ControlDataTransferFormat Property

[image]
Intersoft WebDesktop Documentation
ControlDataTransferFormat Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : ControlDataTransferFormat Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ControlDataTransferFormat As ISNet.WebUI.DataTransferFormat
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As ISNet.WebUI.DataTransferFormat

instance.ControlDataTransferFormat = value

value = instance.ControlDataTransferFormat
C#
public virtual ISNet.WebUI.DataTransferFormat ControlDataTransferFormat {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


Display Property

[image]
Intersoft WebDesktop Documentation
Display Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : Display Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Display As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As Boolean

instance.Display = value

value = instance.Display
C#
public bool Display {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


DisplayAccessKeyOnToolTip Property

[image]
Intersoft WebDesktop Documentation
DisplayAccessKeyOnToolTip Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : DisplayAccessKeyOnToolTip Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property DisplayAccessKeyOnToolTip As DisplayAccessKeyOnToolTip
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As DisplayAccessKeyOnToolTip

instance.DisplayAccessKeyOnToolTip = value

value = instance.DisplayAccessKeyOnToolTip
C#
public DisplayAccessKeyOnToolTip DisplayAccessKeyOnToolTip {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


DisplayMode Property

[image]
Intersoft WebDesktop Documentation
DisplayMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : DisplayMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property DisplayMode As CommandDisplayMode
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As CommandDisplayMode

instance.DisplayMode = value

value = instance.DisplayMode
C#
public CommandDisplayMode DisplayMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


DisplayToolTip Property

[image]
Intersoft WebDesktop Documentation
DisplayToolTip Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : DisplayToolTip Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property DisplayToolTip As DisplayToolTip
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As DisplayToolTip

instance.DisplayToolTip = value

value = instance.DisplayToolTip
C#
public DisplayToolTip DisplayToolTip {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


DockingArea Property

[image]
Intersoft WebDesktop Documentation
DockingArea Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : DockingArea Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property DockingArea As DockingArea
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As DockingArea

instance.DockingArea = value

value = instance.DockingArea
C#
public DockingArea DockingArea {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


DockingOffset Property

[image]
Intersoft WebDesktop Documentation
DockingOffset Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : DockingOffset Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property DockingOffset As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As Integer

instance.DockingOffset = value

value = instance.DockingOffset
C#
public int DockingOffset {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


DockingRow Property

[image]
Intersoft WebDesktop Documentation
DockingRow Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : DockingRow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property DockingRow As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As Integer

instance.DockingRow = value

value = instance.DockingRow
C#
public int DockingRow {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


Enabled Property

[image]
Intersoft WebDesktop Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : Enabled Property

Glossary Item Box

Enable state of the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property Enabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As Boolean

instance.Enabled = value

value = instance.Enabled
C#
public virtual bool Enabled {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


EnableManagedTheming Property

[image]
Intersoft WebDesktop Documentation
EnableManagedTheming Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : EnableManagedTheming Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property EnableManagedTheming As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As Boolean

instance.EnableManagedTheming = value

value = instance.EnableManagedTheming
C#
public virtual bool EnableManagedTheming {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


EnableTheming Property

[image]
Intersoft WebDesktop Documentation
EnableTheming Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : EnableTheming Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property EnableTheming As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As Boolean

instance.EnableTheming = value

value = instance.EnableTheming
C#
public virtual bool EnableTheming {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


EnableViewState Property

[image]
Intersoft WebDesktop Documentation
EnableViewState Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : EnableViewState Property

Glossary Item Box

Whether the control automatically saves its state for use in round-trips.

Syntax

Visual Basic (Declaration)
Public Overridable Property EnableViewState As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As Boolean

instance.EnableViewState = value

value = instance.EnableViewState
C#
public virtual bool EnableViewState {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


EnableWebResources Property

[image]
Intersoft WebDesktop Documentation
EnableWebResources Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : EnableWebResources Property

Glossary Item Box

Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory).

Syntax

Visual Basic (Declaration)
Public Property EnableWebResources As ISNet.WebUI.WebResourceType
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As ISNet.WebUI.WebResourceType

instance.EnableWebResources = value

value = instance.EnableWebResources
C#
public ISNet.WebUI.WebResourceType EnableWebResources {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


FillDockingRow Property

[image]
Intersoft WebDesktop Documentation
FillDockingRow Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : FillDockingRow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property FillDockingRow As FillDockingRow
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As FillDockingRow

instance.FillDockingRow = value

value = instance.FillDockingRow
C#
public FillDockingRow FillDockingRow {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


GreyImageWhenDisabled Property

[image]
Intersoft WebDesktop Documentation
GreyImageWhenDisabled Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : GreyImageWhenDisabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property GreyImageWhenDisabled As GreyImageWhenDisabled
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As GreyImageWhenDisabled

instance.GreyImageWhenDisabled = value

value = instance.GreyImageWhenDisabled
C#
public GreyImageWhenDisabled GreyImageWhenDisabled {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


HandleStyle Property

[image]
Intersoft WebDesktop Documentation
HandleStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : HandleStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property HandleStyle As BarSectionStyle
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As BarSectionStyle

instance.HandleStyle = value

value = instance.HandleStyle
C#
public BarSectionStyle HandleStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


HandleVisible Property

[image]
Intersoft WebDesktop Documentation
HandleVisible Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : HandleVisible Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property HandleVisible As HandleVisible
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As HandleVisible

instance.HandleVisible = value

value = instance.HandleVisible
C#
public HandleVisible HandleVisible {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


HeaderButtonStyle Property

[image]
Intersoft WebDesktop Documentation
HeaderButtonStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : HeaderButtonStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property HeaderButtonStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As ISNet.WebUI.DynamicStyle

instance.HeaderButtonStyle = value

value = instance.HeaderButtonStyle
C#
public virtual ISNet.WebUI.DynamicStyle HeaderButtonStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


HeaderCaptionStyle Property

[image]
Intersoft WebDesktop Documentation
HeaderCaptionStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : HeaderCaptionStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property HeaderCaptionStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As ISNet.WebUI.WebStyle

instance.HeaderCaptionStyle = value

value = instance.HeaderCaptionStyle
C#
public virtual ISNet.WebUI.WebStyle HeaderCaptionStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


HeaderHeight Property

[image]
Intersoft WebDesktop Documentation
HeaderHeight Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : HeaderHeight Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property HeaderHeight As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As System.Web.UI.WebControls.Unit

instance.HeaderHeight = value

value = instance.HeaderHeight
C#
public System.Web.UI.WebControls.Unit HeaderHeight {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


Height Property

[image]
Intersoft WebDesktop Documentation
Height Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : Height Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Property Height As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As System.Web.UI.WebControls.Unit

instance.Height = value

value = instance.Height
C#
public override System.Web.UI.WebControls.Unit Height {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


ID Property

[image]
Intersoft WebDesktop Documentation
ID Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : ID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ID As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As String

instance.ID = value

value = instance.ID
C#
public virtual string ID {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


ImagesDirectory Property

[image]
Intersoft WebDesktop Documentation
ImagesDirectory Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : ImagesDirectory Property

Glossary Item Box

Gets or sets the location of images used to render the control.

Syntax

Visual Basic (Declaration)
Public Property ImagesDirectory As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As String

instance.ImagesDirectory = value

value = instance.ImagesDirectory
C#
public string ImagesDirectory {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


ImageSize Property

[image]
Intersoft WebDesktop Documentation
ImageSize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : ImageSize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ImageSize As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As System.Drawing.Size

instance.ImageSize = value

value = instance.ImageSize
C#
public System.Drawing.Size ImageSize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


IntegratedTo Property

[image]
Intersoft WebDesktop Documentation
IntegratedTo Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : IntegratedTo Property

Glossary Item Box

Gets or sets the WebMenuBar menu integrated mode.

Syntax

Visual Basic (Declaration)
Public Property IntegratedTo As MenuIntegrationMode
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As MenuIntegrationMode

instance.IntegratedTo = value

value = instance.IntegratedTo
C#
public MenuIntegrationMode IntegratedTo {get; set;}

Remarks

There are 2 integration modes available on WebMenuBar, which are Integration to Desktop Manager and Integration to PlaceHolder Manager.

  • Integration to Desktop Manager.
    This is the most recommended configuration to create a uniform and consistent look&feel for all menu instances throughout entire applications. When integrated to DesktopManager, the Menu will use Application MenuStyles defined in DesktopManager level. To do this, you simply set the IntegratedTo property to DesktopManager. The menu system will automatically apply the styles at runtime, and hence the integration also means compact output since styles and CSS classes for the menu instance are no longer rendered.
  • Integration to PlaceHolder Manager.
    This scenario is the best applied when you want to have all menu instances inside a WebForm to use one single style definition which is different with DesktopManager's Application MenuStyle. The easiest way to understand this integration mode is by examining how Office 2003 application works. So all menu system in Office 2003 applications are using one single style definition which is separate to Windows menu style. Likewise, all menu systems in Visual Studio 2005 use one single style defined at application level, which differs from Windows menu style.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members

Concepts

WebMenu Features


IsFloat Property

[image]
Intersoft WebDesktop Documentation
IsFloat Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : IsFloat Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property IsFloat As IsFloat
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As IsFloat

instance.IsFloat = value

value = instance.IsFloat
C#
public IsFloat IsFloat {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


Menus Property

[image]
Intersoft WebDesktop Documentation
Menus Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : Menus Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Menus As MenuCommandCollection
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As MenuCommandCollection

value = instance.Menus
C#
public MenuCommandCollection Menus {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


MenuStyleSettings Property

[image]
Intersoft WebDesktop Documentation
MenuStyleSettings Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : MenuStyleSettings Property

Glossary Item Box

Gets or sets the style properties of menu styles in the bar control.

Syntax

Visual Basic (Declaration)
Public Property MenuStyleSettings As WebMenuStyles
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As WebMenuStyles

instance.MenuStyleSettings = value

value = instance.MenuStyleSettings
C#
public WebMenuStyles MenuStyleSettings {get; set;}

Remarks

In the previous release, we introduced a nice Fading animation effect to WebMenu system component. As one of the initiative in 2008 release, we have added more animation effects and apply it consistently to applicable components and scenarios.

The improved WebMenu now features Quadratic sliding animation. This type of animation quickly adds elegant image to your Web application as the menu smoothly sliding from the left or bottom direction depend on the menu position. The sliding animation is using quadratic acceleration logic, which is an enhanced acceleration algorithm to achieve elegant and high-performance animation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members

Tasks

How-to: Enable quadratic sliding animation


OptionStyle Property

[image]
Intersoft WebDesktop Documentation
OptionStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : OptionStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property OptionStyle As BarSectionStyle
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As BarSectionStyle

instance.OptionStyle = value

value = instance.OptionStyle
C#
public BarSectionStyle OptionStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


Page Property

[image]
Intersoft WebDesktop Documentation
Page Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : Page Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Page As System.Web.UI.Page
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As System.Web.UI.Page

instance.Page = value

value = instance.Page
C#
public virtual System.Web.UI.Page Page {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


PlaceHolder Property

[image]
Intersoft WebDesktop Documentation
PlaceHolder Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : PlaceHolder Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property PlaceHolder As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As String

instance.PlaceHolder = value

value = instance.PlaceHolder
C#
public virtual string PlaceHolder {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


RenderingMode Property

[image]
Intersoft WebDesktop Documentation
RenderingMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : RenderingMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property RenderingMode As ISNet.WebUI.RenderMode
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As ISNet.WebUI.RenderMode

instance.RenderingMode = value

value = instance.RenderingMode
C#
public virtual ISNet.WebUI.RenderMode RenderingMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


RuntimeLicenseKey Property

[image]
Intersoft WebDesktop Documentation
RuntimeLicenseKey Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : RuntimeLicenseKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property RuntimeLicenseKey As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As String

instance.RuntimeLicenseKey = value

value = instance.RuntimeLicenseKey
C#
public virtual string RuntimeLicenseKey {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


ScriptDirectory Property

[image]
Intersoft WebDesktop Documentation
ScriptDirectory Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : ScriptDirectory Property

Glossary Item Box

Gets or sets the directory where all required scripts for the control are stored.

Syntax

Visual Basic (Declaration)
Public Overrides Property ScriptDirectory As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As String

instance.ScriptDirectory = value

value = instance.ScriptDirectory
C#
public override string ScriptDirectory {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


SeparatorStyle Property

[image]
Intersoft WebDesktop Documentation
SeparatorStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : SeparatorStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property SeparatorStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As ISNet.WebUI.WebStyle

instance.SeparatorStyle = value

value = instance.SeparatorStyle
C#
public virtual ISNet.WebUI.WebStyle SeparatorStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


SharedScriptDirectory Property

[image]
Intersoft WebDesktop Documentation
SharedScriptDirectory Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : SharedScriptDirectory Property

Glossary Item Box

Gets or sets the directory where all shared scripts for Intersoft controls are stored.

Syntax

Visual Basic (Declaration)
Public Overrides Property SharedScriptDirectory As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As String

instance.SharedScriptDirectory = value

value = instance.SharedScriptDirectory
C#
public override string SharedScriptDirectory {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


ShowDelay Property

[image]
Intersoft WebDesktop Documentation
ShowDelay Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : ShowDelay Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ShowDelay As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As Integer

instance.ShowDelay = value

value = instance.ShowDelay
C#
public int ShowDelay {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


ShowFocusBorder Property

[image]
Intersoft WebDesktop Documentation
ShowFocusBorder Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : ShowFocusBorder Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ShowFocusBorder As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As Boolean

instance.ShowFocusBorder = value

value = instance.ShowFocusBorder
C#
public bool ShowFocusBorder {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


SizeMode Property

[image]
Intersoft WebDesktop Documentation
SizeMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : SizeMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property SizeMode As SizeMode
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As SizeMode

instance.SizeMode = value

value = instance.SizeMode
C#
public SizeMode SizeMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


SkinID Property

[image]
Intersoft WebDesktop Documentation
SkinID Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : SkinID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property SkinID As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As String

instance.SkinID = value

value = instance.SkinID
C#
public virtual string SkinID {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


TabIndex Property

[image]
Intersoft WebDesktop Documentation
TabIndex Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : TabIndex Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property TabIndex As Short
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As Short

instance.TabIndex = value

value = instance.TabIndex
C#
public virtual short TabIndex {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


TextAlign Property

[image]
Intersoft WebDesktop Documentation
TextAlign Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : TextAlign Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property TextAlign As BarTextAlign
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As BarTextAlign

instance.TextAlign = value

value = instance.TextAlign
C#
public BarTextAlign TextAlign {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


ToolTip Property

[image]
Intersoft WebDesktop Documentation
ToolTip Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : ToolTip Property

Glossary Item Box

The tooltip displayed when the mouse is over the control.

Syntax

Visual Basic (Declaration)
Public Shadows Property ToolTip As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As String

instance.ToolTip = value

value = instance.ToolTip
C#
public new string ToolTip {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


ValidateRequestMode Property

[image]
Intersoft WebDesktop Documentation
ValidateRequestMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : ValidateRequestMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ValidateRequestMode As System.Web.UI.ValidateRequestMode
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As System.Web.UI.ValidateRequestMode

instance.ValidateRequestMode = value

value = instance.ValidateRequestMode
C#
public virtual System.Web.UI.ValidateRequestMode ValidateRequestMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


ViewStateItems Property

[image]
Intersoft WebDesktop Documentation
ViewStateItems Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : ViewStateItems Property

Glossary Item Box

Gets or sets the items to be stored in view state storage.

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateItems As ISNet.WebUI.ViewStateItem
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As ISNet.WebUI.ViewStateItem

instance.ViewStateItems = value

value = instance.ViewStateItems
C#
public virtual ISNet.WebUI.ViewStateItem ViewStateItems {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


ViewStateMode Property

[image]
Intersoft WebDesktop Documentation
ViewStateMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : ViewStateMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateMode As System.Web.UI.ViewStateMode
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As System.Web.UI.ViewStateMode

instance.ViewStateMode = value

value = instance.ViewStateMode
C#
public virtual System.Web.UI.ViewStateMode ViewStateMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


ViewStateServerConnection Property

[image]
Intersoft WebDesktop Documentation
ViewStateServerConnection Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : ViewStateServerConnection Property

Glossary Item Box

Gets or sets the server connection string for file server-based viewstate storage.

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateServerConnection As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As String

instance.ViewStateServerConnection = value

value = instance.ViewStateServerConnection
C#
public virtual string ViewStateServerConnection {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


ViewStateStorage Property

[image]
Intersoft WebDesktop Documentation
ViewStateStorage Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : ViewStateStorage Property

Glossary Item Box

Gets or sets the location to store the viewstate of this control.

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateStorage As ISNet.WebUI.StateCacheStorage
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As ISNet.WebUI.StateCacheStorage

instance.ViewStateStorage = value

value = instance.ViewStateStorage
C#
public virtual ISNet.WebUI.StateCacheStorage ViewStateStorage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


Visible Property

[image]
Intersoft WebDesktop Documentation
Visible Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : Visible Property

Glossary Item Box

Indicates whether the control is visible and rendered.

Syntax

Visual Basic (Declaration)
Public Overrides Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public override bool Visible {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


Width Property

[image]
Intersoft WebDesktop Documentation
Width Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : Width Property

Glossary Item Box

The width of the control.

Syntax

Visual Basic (Declaration)
Public Overrides Property Width As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As System.Web.UI.WebControls.Unit

instance.Width = value

value = instance.Width
C#
public override System.Web.UI.WebControls.Unit Width {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


XmlCompressionEnabled Property

[image]
Intersoft WebDesktop Documentation
XmlCompressionEnabled Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : XmlCompressionEnabled Property

Glossary Item Box

Specifies whether the Xml used for clientside state storage should be compressed.

Syntax

Visual Basic (Declaration)
Public Overridable Property XmlCompressionEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim value As Boolean

instance.XmlCompressionEnabled = value

value = instance.XmlCompressionEnabled
C#
public virtual bool XmlCompressionEnabled {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


WebMenuBar Class Events

[image]
Intersoft WebDesktop Documentation
WebMenuBar Class Events
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebMenuBar Class

Glossary Item Box

For a list of all members of this type, see WebMenuBar members.

Public Events

 | Name | Description
Public Event | BarLayoutPropertiesChanged | Occurs when bar layout properties is changed.
Public Event | BarPropertiesChanged | Occurs when bar properties is changed.
Public Event | CommandClick | Occurs when command bar is clicked.
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebMenuBar Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Using MenuBar in PlaceHolderManager mode
Creating Standalone MenuBar
Working with MenuItem Types

Concepts

WebMenuBar Overview

concepts

Features
VisualMenuBuilder Overview
Building WebMenuBar Structure


BarLayoutPropertiesChanged Event

[image]
Intersoft WebDesktop Documentation
BarLayoutPropertiesChanged Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : BarLayoutPropertiesChanged Event

Glossary Item Box

Occurs when bar layout properties is changed.

Syntax

Visual Basic (Declaration)
Public Event BarLayoutPropertiesChanged As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim handler As EventHandler

AddHandler instance.BarLayoutPropertiesChanged, handler
C#
public event EventHandler BarLayoutPropertiesChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


BarPropertiesChanged Event

[image]
Intersoft WebDesktop Documentation
BarPropertiesChanged Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : BarPropertiesChanged Event

Glossary Item Box

Occurs when bar properties is changed.

Syntax

Visual Basic (Declaration)
Public Event BarPropertiesChanged As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim handler As EventHandler

AddHandler instance.BarPropertiesChanged, handler
C#
public event EventHandler BarPropertiesChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


CommandClick Event

[image]
Intersoft WebDesktop Documentation
CommandClick Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : CommandClick Event

Glossary Item Box

Occurs when command bar is clicked.

Syntax

Visual Basic (Declaration)
Public Event CommandClick As MenuCommandClickEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim handler As MenuCommandClickEventHandler

AddHandler instance.CommandClick, handler
C#
public event MenuCommandClickEventHandler CommandClick

Event Data

The event handler receives an argument of type MenuCommandClickEventArgs containing data related to this event. The following MenuCommandClickEventArgs properties provide information specific to this event.

Property | Description
ClickedCommand | Gets the clicked command in MenuCommand.
ClickedMenuItem | Gets the clicked menu item in MenuCommand.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


DataBinding Event

[image]
Intersoft WebDesktop Documentation
DataBinding Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : DataBinding Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event DataBinding As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim handler As EventHandler

AddHandler instance.DataBinding, handler
C#
public event EventHandler DataBinding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


Disposed Event

[image]
Intersoft WebDesktop Documentation
Disposed Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim handler As EventHandler

AddHandler instance.Disposed, handler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


Init Event

[image]
Intersoft WebDesktop Documentation
Init Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : Init Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Init As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim handler As EventHandler

AddHandler instance.Init, handler
C#
public event EventHandler Init

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


Load Event

[image]
Intersoft WebDesktop Documentation
Load Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : Load Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Load As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim handler As EventHandler

AddHandler instance.Load, handler
C#
public event EventHandler Load

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


PreInitialize Event

[image]
Intersoft WebDesktop Documentation
PreInitialize Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : PreInitialize Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event PreInitialize As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim handler As EventHandler

AddHandler instance.PreInitialize, handler
C#
public event EventHandler PreInitialize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


PreRender Event

[image]
Intersoft WebDesktop Documentation
PreRender Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : PreRender Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event PreRender As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim handler As EventHandler

AddHandler instance.PreRender, handler
C#
public event EventHandler PreRender

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


Unload Event

[image]
Intersoft WebDesktop Documentation
Unload Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuBar Class : Unload Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Unload As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebMenuBar
Dim handler As EventHandler

AddHandler instance.Unload, handler
C#
public event EventHandler Unload

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuBar Class
WebMenuBar Members


WebMenuImagesSettings Class

[image]
Intersoft WebDesktop Documentation
WebMenuImagesSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebMenuImagesSettings Class

Glossary Item Box

The class that contains images configuration used in WebMenu.

Object Model

WebMenuImagesSettings Class

Syntax

Visual Basic (Declaration)
Public Class WebMenuImagesSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebMenuImagesSettings
C#
public class WebMenuImagesSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebDesktop.WebMenuImagesSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuImagesSettings Members
ISNet.WebUI.WebDesktop Namespace


WebMenuImagesSettings Class Members

[image]
Intersoft WebDesktop Documentation
WebMenuImagesSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebMenuImagesSettings Class

Glossary Item Box

The following tables list the members exposed by WebMenuImagesSettings.

Public Constructors

 | Name | Description
Public Constructor | WebMenuImagesSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | ActiveIconCell |
Public Property | DisabledCenter |
Public Property | DisabledLeft |
Public Property | DisabledRight |
Public Property | OverCenter |
Public Property | OverLeft |
Public Property | OverRight |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebMenuImagesSettings Class
ISNet.WebUI.WebDesktop Namespace


WebMenuImagesSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebMenuImagesSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuImagesSettings Class : WebMenuImagesSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebMenuImagesSettings()
C#
public WebMenuImagesSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuImagesSettings Class
WebMenuImagesSettings Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuImagesSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebMenuImagesSettings
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuImagesSettings Class
WebMenuImagesSettings Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuImagesSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuImagesSettings Class
WebMenuImagesSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuImagesSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuImagesSettings
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuImagesSettings Class
WebMenuImagesSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuImagesSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuImagesSettings
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuImagesSettings Class
WebMenuImagesSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuImagesSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuImagesSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuImagesSettings Class
WebMenuImagesSettings Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuImagesSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebMenuImagesSettings
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuImagesSettings Class
WebMenuImagesSettings Members


WebMenuImagesSettings Class Methods

[image]
Intersoft WebDesktop Documentation
WebMenuImagesSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebMenuImagesSettings Class

Glossary Item Box

For a list of all members of this type, see WebMenuImagesSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebMenuImagesSettings Class
ISNet.WebUI.WebDesktop Namespace


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuImagesSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuImagesSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuImagesSettings Class
WebMenuImagesSettings Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuImagesSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebMenuImagesSettings
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuImagesSettings Class
WebMenuImagesSettings Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuImagesSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebMenuImagesSettings

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuImagesSettings Class
WebMenuImagesSettings Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuImagesSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuImagesSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuImagesSettings Class
WebMenuImagesSettings Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuImagesSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuImagesSettings
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuImagesSettings Class
WebMenuImagesSettings Members


WebMenuImagesSettings Class Properties

[image]
Intersoft WebDesktop Documentation
WebMenuImagesSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebMenuImagesSettings Class

Glossary Item Box

For a list of all members of this type, see WebMenuImagesSettings members.

Public Properties

 | Name | Description
Public Property | ActiveIconCell |
Public Property | DisabledCenter |
Public Property | DisabledLeft |
Public Property | DisabledRight |
Public Property | OverCenter |
Public Property | OverLeft |
Public Property | OverRight |
Top

See Also

Reference

WebMenuImagesSettings Class
ISNet.WebUI.WebDesktop Namespace


WebMenuImagesSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebMenuImagesSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuImagesSettings Class : WebMenuImagesSettings Constructor

Glossary Item Box

Overload List

Overload | Description
WebMenuImagesSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuImagesSettings Class
WebMenuImagesSettings Members


ActiveIconCell Property

[image]
Intersoft WebDesktop Documentation
ActiveIconCell Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuImagesSettings Class : ActiveIconCell Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ActiveIconCell As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuImagesSettings
Dim value As String

instance.ActiveIconCell = value

value = instance.ActiveIconCell
C#
public string ActiveIconCell {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuImagesSettings Class
WebMenuImagesSettings Members


DisabledCenter Property

[image]
Intersoft WebDesktop Documentation
DisabledCenter Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuImagesSettings Class : DisabledCenter Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property DisabledCenter As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuImagesSettings
Dim value As String

instance.DisabledCenter = value

value = instance.DisabledCenter
C#
public string DisabledCenter {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuImagesSettings Class
WebMenuImagesSettings Members


DisabledLeft Property

[image]
Intersoft WebDesktop Documentation
DisabledLeft Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuImagesSettings Class : DisabledLeft Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property DisabledLeft As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuImagesSettings
Dim value As String

instance.DisabledLeft = value

value = instance.DisabledLeft
C#
public string DisabledLeft {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuImagesSettings Class
WebMenuImagesSettings Members


DisabledRight Property

[image]
Intersoft WebDesktop Documentation
DisabledRight Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuImagesSettings Class : DisabledRight Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property DisabledRight As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuImagesSettings
Dim value As String

instance.DisabledRight = value

value = instance.DisabledRight
C#
public string DisabledRight {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuImagesSettings Class
WebMenuImagesSettings Members


OverCenter Property

[image]
Intersoft WebDesktop Documentation
OverCenter Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuImagesSettings Class : OverCenter Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property OverCenter As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuImagesSettings
Dim value As String

instance.OverCenter = value

value = instance.OverCenter
C#
public string OverCenter {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuImagesSettings Class
WebMenuImagesSettings Members


OverLeft Property

[image]
Intersoft WebDesktop Documentation
OverLeft Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuImagesSettings Class : OverLeft Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property OverLeft As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuImagesSettings
Dim value As String

instance.OverLeft = value

value = instance.OverLeft
C#
public string OverLeft {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuImagesSettings Class
WebMenuImagesSettings Members


OverRight Property

[image]
Intersoft WebDesktop Documentation
OverRight Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuImagesSettings Class : OverRight Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property OverRight As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuImagesSettings
Dim value As String

instance.OverRight = value

value = instance.OverRight
C#
public string OverRight {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuImagesSettings Class
WebMenuImagesSettings Members


WebMenuItem Class

[image]
Intersoft WebDesktop Documentation
WebMenuItem Class
Members Example See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebMenuItem Class

Glossary Item Box

Command menu item collection in WebMenuBar and WebContextMenu.

Object Model

WebMenuItem Class

Syntax

Visual Basic (Declaration)
Public Class WebMenuItem
   Inherits ISNet.WebUI.NamedObjectBase
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject, IWebMenu
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItem
C#
public class WebMenuItem : ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject, IWebMenu

Remarks

WebMenu provides five MenuItem types. They are Normal, Radio, CheckBox, Separator, and Custom.

Example

The following codes show you how to enable and disable menu items programmatically. For more details please read the Enabling and Disabling MenuItem on See Also section.
C# Copy Code
protected void Button1_Click(object sender, EventArgs e)
{
    WebMenuBar1.Menus[0].Items.GetNamedItem("mnuSave").Enabled = false;
    WebMenuBar1.Menus[0].Items.GetNamedItem("mnuSaveAll").Enabled = false;
    Label1.Text = "MenuItem Save and SaveAll have been disabled";
}
protected void Button2_Click(object sender, EventArgs e)
{
    WebMenuBar1.Menus[0].Items.GetNamedItem("mnuSave").Enabled = true;
    WebMenuBar1.Menus[0].Items.GetNamedItem("mnuSaveAll").Enabled = true;
    Label1.Text = "MenuItem Save and SaveAll have been enabled";
}

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase
ISNet.WebUI.WebDesktop.WebMenuItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItem Members
ISNet.WebUI.WebDesktop Namespace

Tasks

Working with MenuItem Types

tasks

Enabling and Disabling MenuItem
Add new MenuItem at Client Side


WebMenuItem Class Members

[image]
Intersoft WebDesktop Documentation
WebMenuItem Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebMenuItem Class

Glossary Item Box

The following tables list the members exposed by WebMenuItem.

Public Constructors

 | Name | Description
Public Constructor | WebMenuItem Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | AccessKey | Gets or sets the access character key (mnemonic) for this item. The access key will appear as underline automatically.
Public Property | AutoPostBack | Specifies whether the control should cause postback automatically when clicked. When set to Default, it will use the AutoPostBack value specified in Control level.
Public Property | Checked | Gets or sets whether this menu item is checked. This property is only applicable to menu item which Type is either Radio or CheckBox.
Public Property | Enabled | Specifies whether this menu item is enabled or not.
Public Property | GroupName | Gets or sets the name for radio menu item which should appear in the same group.
Public Property | IconViewDisplayMode | Gets or sets the display mode when the menu is operating in IconView mode.
Public Property | ImageURL | Gets or sets the image URL displayed for this menu item.
Public Property | IsPredefinedItem | Indicates whether this menu item is a predefined item. This flag is used to mark built-in menu items used in other Intersoft's products.
Public Property | Items | Gets the collection containing WebMenuItem objects for this item's sub menu.
Public Property | KeepMenuVisible | Indicates whether the menu which owns this item should be kept visible after clicked.
Public Property | Name | Overridden. Gets or sets the name of WebMenuItem.
Public Property | OnClick | Gets or sets the javascript function to invoke when this menu item is clicked.
Public Property | PredefinedId | The predefined identifier for this item.
Public Property | Shortcut | Gets or sets the shortcut key for this menu item, which will invoke the associated command when pressed.
Public Property | SubMenu | Gets the WebMenu object for the SubMenu of this menu item.
Public Property | Tag | Gets or sets custom information specific to this item.
Public Property | TargetFrame | Gets or sets the target frame where the URL specified in TargetURL should be displyaed.
Public Property | TargetURL | Gets os sets the target URL which will be invoked when this menu is clicked.
Public Property | Text | Gets or sets the text displayed for this menu item.
Public Property | Tooltip | Gets or sets the tooltip that will be displayed when mouse is over this menu item.
Public Property | Type | Gets or sets the type of the MenuItem.
Public Property | UseFontImage | Indicates whether font should be used as replacement for Image. When set to True, the text specified in ImageURL will be rendered using WebDings font.
Public Property | Visible | Gets or sets a value that indicates whether a Command is visibled.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | GetOwnerControl |
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebMenuItem Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Working with MenuItem Types

tasks

Enabling and Disabling MenuItem
Add new MenuItem at Client Side


WebMenuItem Constructor

[image]
Intersoft WebDesktop Documentation
WebMenuItem Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItem Class : WebMenuItem Constructor

Glossary Item Box

Initializes a new instance of the WebMenuItem class.

Overload List

Overload | Description
WebMenuItem Constructor() | Initializes a new instance of the WebMenuItem class with no argument.
WebMenuItem Constructor(String) | Initializes a new instance of the WebMenuItem class with Text parameter.
WebMenuItem Constructor(String,String) | Initializes a new instance of the WebMenuItem class with Text and Name parameters.
WebMenuItem Constructor(String,String,String) | Initializes a new instance of the WebMenuItem class with Text, Name, and ImageURL parameters.
WebMenuItem Constructor(String,String,String,String) | Initializes a new instance of the WebMenuItem class with Text, Name, ImageURL and AccessKey parameters.
WebMenuItem Constructor(String,String,String,String,ShortcutKey) | Initializes a new instance of the WebMenuItem class with Text, Name, ImageURL, AccessKey and ShortcutKey parameters.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItem Class
WebMenuItem Members


WebMenuItem Constructor()

[image]
Intersoft WebDesktop Documentation
WebMenuItem Constructor()
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItem Class > WebMenuItem Constructor : WebMenuItem Constructor()

Glossary Item Box

Initializes a new instance of the WebMenuItem class with no argument.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebMenuItem()
C#
public WebMenuItem()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItem Class
WebMenuItem Members
Overload List


WebMenuItem Constructor(String)

[image]
Intersoft WebDesktop Documentation
WebMenuItem Constructor(String)
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItem Class > WebMenuItem Constructor : WebMenuItem Constructor(String)

text

Glossary Item Box

Initializes a new instance of the WebMenuItem class with Text parameter.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim text As String

Dim instance As New WebMenuItem(text)
C#
public WebMenuItem(
   string text
)

Parameters

text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItem Class
WebMenuItem Members
Overload List


WebMenuItem Constructor(String,String)

[image]
Intersoft WebDesktop Documentation
WebMenuItem Constructor(String,String)
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItem Class > WebMenuItem Constructor : WebMenuItem Constructor(String,String)

text
name

Glossary Item Box

Initializes a new instance of the WebMenuItem class with Text and Name parameters.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal text As String, _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim text As String
Dim name As String

Dim instance As New WebMenuItem(text, name)
C#
public WebMenuItem(
   string text,
   string name
)

Parameters

text
name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItem Class
WebMenuItem Members
Overload List


WebMenuItem Constructor(String,String,String)

[image]
Intersoft WebDesktop Documentation
WebMenuItem Constructor(String,String,String)
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItem Class > WebMenuItem Constructor : WebMenuItem Constructor(String,String,String)

text
name
imageURL

Glossary Item Box

Initializes a new instance of the WebMenuItem class with Text, Name, and ImageURL parameters.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal text As String, _
   ByVal name As String, _
   ByVal imageURL As String _
)
Visual Basic (Usage) Copy Code
Dim text As String
Dim name As String
Dim imageURL As String

Dim instance As New WebMenuItem(text, name, imageURL)
C#
public WebMenuItem(
   string text,
   string name,
   string imageURL
)

Parameters

text
name
imageURL

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItem Class
WebMenuItem Members
Overload List


WebMenuItem Constructor(String,String,String,String)

[image]
Intersoft WebDesktop Documentation
WebMenuItem Constructor(String,String,String,String)
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItem Class > WebMenuItem Constructor : WebMenuItem Constructor(String,String,String,String)

text
name
imageURL
accessKey

Glossary Item Box

Initializes a new instance of the WebMenuItem class with Text, Name, ImageURL and AccessKey parameters.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal text As String, _
   ByVal name As String, _
   ByVal imageURL As String, _
   ByVal accessKey As String _
)
Visual Basic (Usage) Copy Code
Dim text As String
Dim name As String
Dim imageURL As String
Dim accessKey As String

Dim instance As New WebMenuItem(text, name, imageURL, accessKey)
C#
public WebMenuItem(
   string text,
   string name,
   string imageURL,
   string accessKey
)

Parameters

text
name
imageURL
accessKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItem Class
WebMenuItem Members
Overload List


WebMenuItem Constructor(String,String,String,String,ShortcutKey)

[image]
Intersoft WebDesktop Documentation
WebMenuItem Constructor(String,String,String,String,ShortcutKey)
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItem Class > WebMenuItem Constructor : WebMenuItem Constructor(String,String,String,String,ShortcutKey)

text
name
imageURL
accessKey
shortcutKey

Glossary Item Box

Initializes a new instance of the WebMenuItem class with Text, Name, ImageURL, AccessKey and ShortcutKey parameters.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal text As String, _
   ByVal name As String, _
   ByVal imageURL As String, _
   ByVal accessKey As String, _
   ByVal shortcutKey As ISNet.WebUI.ShortcutKey _
)
Visual Basic (Usage) Copy Code
Dim text As String
Dim name As String
Dim imageURL As String
Dim accessKey As String
Dim shortcutKey As ISNet.WebUI.ShortcutKey

Dim instance As New WebMenuItem(text, name, imageURL, accessKey, shortcutKey)
C#
public WebMenuItem(
   string text,
   string name,
   string imageURL,
   string accessKey,
   ISNet.WebUI.ShortcutKey shortcutKey
)

Parameters

text
name
imageURL
accessKey
shortcutKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItem Class
WebMenuItem Members
Overload List


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItem Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItem
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItem Class
WebMenuItem Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItem Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItem Class
WebMenuItem Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItem Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItem
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItem Class
WebMenuItem Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItem Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItem
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItem Class
WebMenuItem Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItem Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItem
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItem Class
WebMenuItem Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItem Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItem
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItem Class
WebMenuItem Members


WebMenuItem Class Methods

[image]
Intersoft WebDesktop Documentation
WebMenuItem Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebMenuItem Class

Glossary Item Box

For a list of all members of this type, see WebMenuItem members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | GetOwnerControl |
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebMenuItem Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Working with MenuItem Types

tasks

Enabling and Disabling MenuItem
Add new MenuItem at Client Side


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItem Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItem
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItem Class
WebMenuItem Members


GetOwnerControl Method

[image]
Intersoft WebDesktop Documentation
GetOwnerControl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItem Class : GetOwnerControl Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetOwnerControl() As ISNet.WebUI.ISNetControl
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItem
Dim value As ISNet.WebUI.ISNetControl

value = instance.GetOwnerControl()
C#
public ISNet.WebUI.ISNetControl GetOwnerControl()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItem Class
WebMenuItem Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItem Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItem
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItem Class
WebMenuItem Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItem Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItem

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItem Class
WebMenuItem Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItem Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItem
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItem Class
WebMenuItem Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItem Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItem
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItem Class
WebMenuItem Members


WebMenuItem Class Properties

[image]
Intersoft WebDesktop Documentation
WebMenuItem Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebMenuItem Class

Glossary Item Box

For a list of all members of this type, see WebMenuItem members.

Public Properties

 | Name | Description
Public Property | AccessKey | Gets or sets the access character key (mnemonic) for this item. The access key will appear as underline automatically.
Public Property | AutoPostBack | Specifies whether the control should cause postback automatically when clicked. When set to Default, it will use the AutoPostBack value specified in Control level.
Public Property | Checked | Gets or sets whether this menu item is checked. This property is only applicable to menu item which Type is either Radio or CheckBox.
Public Property | Enabled | Specifies whether this menu item is enabled or not.
Public Property | GroupName | Gets or sets the name for radio menu item which should appear in the same group.
Public Property | IconViewDisplayMode | Gets or sets the display mode when the menu is operating in IconView mode.
Public Property | ImageURL | Gets or sets the image URL displayed for this menu item.
Public Property | IsPredefinedItem | Indicates whether this menu item is a predefined item. This flag is used to mark built-in menu items used in other Intersoft's products.
Public Property | Items | Gets the collection containing WebMenuItem objects for this item's sub menu.
Public Property | KeepMenuVisible | Indicates whether the menu which owns this item should be kept visible after clicked.
Public Property | Name | Overridden. Gets or sets the name of WebMenuItem.
Public Property | OnClick | Gets or sets the javascript function to invoke when this menu item is clicked.
Public Property | PredefinedId | The predefined identifier for this item.
Public Property | Shortcut | Gets or sets the shortcut key for this menu item, which will invoke the associated command when pressed.
Public Property | SubMenu | Gets the WebMenu object for the SubMenu of this menu item.
Public Property | Tag | Gets or sets custom information specific to this item.
Public Property | TargetFrame | Gets or sets the target frame where the URL specified in TargetURL should be displyaed.
Public Property | TargetURL | Gets os sets the target URL which will be invoked when this menu is clicked.
Public Property | Text | Gets or sets the text displayed for this menu item.
Public Property | Tooltip | Gets or sets the tooltip that will be displayed when mouse is over this menu item.
Public Property | Type | Gets or sets the type of the MenuItem.
Public Property | UseFontImage | Indicates whether font should be used as replacement for Image. When set to True, the text specified in ImageURL will be rendered using WebDings font.
Public Property | Visible | Gets or sets a value that indicates whether a Command is visibled.
Top

See Also

Reference

WebMenuItem Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Working with MenuItem Types

tasks

Enabling and Disabling MenuItem
Add new MenuItem at Client Side


AccessKey Property

[image]
Intersoft WebDesktop Documentation
AccessKey Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItem Class : AccessKey Property

Glossary Item Box

Gets or sets the access character key (mnemonic) for this item. The access key will appear as underline automatically.

Syntax

Visual Basic (Declaration)
Public Property AccessKey As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItem
Dim value As String

instance.AccessKey = value

value = instance.AccessKey
C#
public string AccessKey {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItem Class
WebMenuItem Members


AutoPostBack Property

[image]
Intersoft WebDesktop Documentation
AutoPostBack Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItem Class : AutoPostBack Property

Glossary Item Box

Specifies whether the control should cause postback automatically when clicked. When set to Default, it will use the AutoPostBack value specified in Control level.

Syntax

Visual Basic (Declaration)
Public Property AutoPostBack As AutoPostBackMode
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItem
Dim value As AutoPostBackMode

instance.AutoPostBack = value

value = instance.AutoPostBack
C#
public AutoPostBackMode AutoPostBack {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItem Class
WebMenuItem Members


Checked Property

[image]
Intersoft WebDesktop Documentation
Checked Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItem Class : Checked Property

Glossary Item Box

Gets or sets whether this menu item is checked. This property is only applicable to menu item which Type is either Radio or CheckBox.

Syntax

Visual Basic (Declaration)
Public Property Checked As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItem
Dim value As Boolean

instance.Checked = value

value = instance.Checked
C#
public bool Checked {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItem Class
WebMenuItem Members


Enabled Property

[image]
Intersoft WebDesktop Documentation
Enabled Property
See Also Example Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItem Class : Enabled Property

Glossary Item Box

Specifies whether this menu item is enabled or not.

Syntax

Visual Basic (Declaration)
Public Property Enabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItem
Dim value As Boolean

instance.Enabled = value

value = instance.Enabled
C#
public bool Enabled {get; set;}

Example

The following codes show you how to enable and disable menu items programmatically. For more details please read the Enabling and Disabling MenuItem on See Also section.
C# Copy Code
protected void Button1_Click(object sender, EventArgs e)
{
    WebMenuBar1.Menus[0].Items.GetNamedItem("mnuSave").Enabled = false;
    WebMenuBar1.Menus[0].Items.GetNamedItem("mnuSaveAll").Enabled = false;
    Label1.Text = "MenuItem Save and SaveAll have been disabled";
}
protected void Button2_Click(object sender, EventArgs e)
{
    WebMenuBar1.Menus[0].Items.GetNamedItem("mnuSave").Enabled = true;
    WebMenuBar1.Menus[0].Items.GetNamedItem("mnuSaveAll").Enabled = true;
    Label1.Text = "MenuItem Save and SaveAll have been enabled";
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItem Class
WebMenuItem Members

Tasks

Enabling and Disabling MenuItem


GroupName Property

[image]
Intersoft WebDesktop Documentation
GroupName Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItem Class : GroupName Property

Glossary Item Box

Gets or sets the name for radio menu item which should appear in the same group.

Syntax

Visual Basic (Declaration)
Public Property GroupName As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItem
Dim value As String

instance.GroupName = value

value = instance.GroupName
C#
public string GroupName {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItem Class
WebMenuItem Members


IconViewDisplayMode Property

[image]
Intersoft WebDesktop Documentation
IconViewDisplayMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItem Class : IconViewDisplayMode Property

Glossary Item Box

Gets or sets the display mode when the menu is operating in IconView mode.

Syntax

Visual Basic (Declaration)
Public Property IconViewDisplayMode As IconViewDisplayMode
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItem
Dim value As IconViewDisplayMode

instance.IconViewDisplayMode = value

value = instance.IconViewDisplayMode
C#
public IconViewDisplayMode IconViewDisplayMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItem Class
WebMenuItem Members


ImageURL Property

[image]
Intersoft WebDesktop Documentation
ImageURL Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItem Class : ImageURL Property

Glossary Item Box

Gets or sets the image URL displayed for this menu item.

Syntax

Visual Basic (Declaration)
Public Property ImageURL As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItem
Dim value As String

instance.ImageURL = value

value = instance.ImageURL
C#
public string ImageURL {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItem Class
WebMenuItem Members


IsPredefinedItem Property

[image]
Intersoft WebDesktop Documentation
IsPredefinedItem Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItem Class : IsPredefinedItem Property

Glossary Item Box

Indicates whether this menu item is a predefined item. This flag is used to mark built-in menu items used in other Intersoft's products.

Syntax

Visual Basic (Declaration)
Public Property IsPredefinedItem As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItem
Dim value As Boolean

instance.IsPredefinedItem = value

value = instance.IsPredefinedItem
C#
public bool IsPredefinedItem {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItem Class
WebMenuItem Members


Items Property

[image]
Intersoft WebDesktop Documentation
Items Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItem Class : Items Property

Glossary Item Box

Gets the collection containing WebMenuItem objects for this item's sub menu.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Items As WebMenuItemCollection
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItem
Dim value As WebMenuItemCollection

value = instance.Items
C#
public WebMenuItemCollection Items {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItem Class
WebMenuItem Members


KeepMenuVisible Property

[image]
Intersoft WebDesktop Documentation
KeepMenuVisible Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItem Class : KeepMenuVisible Property

Glossary Item Box

Indicates whether the menu which owns this item should be kept visible after clicked.

Syntax

Visual Basic (Declaration)
Public Property KeepMenuVisible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItem
Dim value As Boolean

instance.KeepMenuVisible = value

value = instance.KeepMenuVisible
C#
public bool KeepMenuVisible {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItem Class
WebMenuItem Members


Name Property

[image]
Intersoft WebDesktop Documentation
Name Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItem Class : Name Property

Glossary Item Box

Gets or sets the name of WebMenuItem.

Syntax

Visual Basic (Declaration)
Public Overrides Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItem
Dim value As String

instance.Name = value

value = instance.Name
C#
public override string Name {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItem Class
WebMenuItem Members


OnClick Property

[image]
Intersoft WebDesktop Documentation
OnClick Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItem Class : OnClick Property

Glossary Item Box

Gets or sets the javascript function to invoke when this menu item is clicked.

Syntax

Visual Basic (Declaration)
Public Property OnClick As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItem
Dim value As String

instance.OnClick = value

value = instance.OnClick
C#
public string OnClick {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItem Class
WebMenuItem Members


PredefinedId Property

[image]
Intersoft WebDesktop Documentation
PredefinedId Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItem Class : PredefinedId Property

Glossary Item Box

The predefined identifier for this item.

Syntax

Visual Basic (Declaration)
Public Property PredefinedId As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItem
Dim value As String

instance.PredefinedId = value

value = instance.PredefinedId
C#
public string PredefinedId {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItem Class
WebMenuItem Members


Shortcut Property

[image]
Intersoft WebDesktop Documentation
Shortcut Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItem Class : Shortcut Property

Glossary Item Box

Gets or sets the shortcut key for this menu item, which will invoke the associated command when pressed.

Syntax

Visual Basic (Declaration)
Public Property Shortcut As ISNet.WebUI.ShortcutKey
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItem
Dim value As ISNet.WebUI.ShortcutKey

instance.Shortcut = value

value = instance.Shortcut
C#
public ISNet.WebUI.ShortcutKey Shortcut {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItem Class
WebMenuItem Members


SubMenu Property

[image]
Intersoft WebDesktop Documentation
SubMenu Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItem Class : SubMenu Property

Glossary Item Box

Gets the WebMenu object for the SubMenu of this menu item.

Syntax

Visual Basic (Declaration)
Public Property SubMenu As WebMenu
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItem
Dim value As WebMenu

instance.SubMenu = value

value = instance.SubMenu
C#
public WebMenu SubMenu {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItem Class
WebMenuItem Members


Tag Property

[image]
Intersoft WebDesktop Documentation
Tag Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItem Class : Tag Property

Glossary Item Box

Gets or sets custom information specific to this item.

Syntax

Visual Basic (Declaration)
Public Property Tag As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItem
Dim value As String

instance.Tag = value

value = instance.Tag
C#
public string Tag {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItem Class
WebMenuItem Members


TargetFrame Property

[image]
Intersoft WebDesktop Documentation
TargetFrame Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItem Class : TargetFrame Property

Glossary Item Box

Gets or sets the target frame where the URL specified in TargetURL should be displyaed.

Syntax

Visual Basic (Declaration)
Public Property TargetFrame As FrameTarget
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItem
Dim value As FrameTarget

instance.TargetFrame = value

value = instance.TargetFrame
C#
public FrameTarget TargetFrame {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItem Class
WebMenuItem Members


TargetURL Property

[image]
Intersoft WebDesktop Documentation
TargetURL Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItem Class : TargetURL Property

Glossary Item Box

Gets os sets the target URL which will be invoked when this menu is clicked.

Syntax

Visual Basic (Declaration)
Public Property TargetURL As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItem
Dim value As String

instance.TargetURL = value

value = instance.TargetURL
C#
public string TargetURL {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItem Class
WebMenuItem Members


Text Property

[image]
Intersoft WebDesktop Documentation
Text Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItem Class : Text Property

Glossary Item Box

Gets or sets the text displayed for this menu item.

Syntax

Visual Basic (Declaration)
Public Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItem
Dim value As String

instance.Text = value

value = instance.Text
C#
public string Text {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItem Class
WebMenuItem Members


Tooltip Property

[image]
Intersoft WebDesktop Documentation
Tooltip Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItem Class : Tooltip Property

Glossary Item Box

Gets or sets the tooltip that will be displayed when mouse is over this menu item.

Syntax

Visual Basic (Declaration)
Public Property Tooltip As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItem
Dim value As String

instance.Tooltip = value

value = instance.Tooltip
C#
public string Tooltip {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItem Class
WebMenuItem Members


Type Property

[image]
Intersoft WebDesktop Documentation
Type Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItem Class : Type Property

Glossary Item Box

Gets or sets the type of the MenuItem.

Syntax

Visual Basic (Declaration)
Public Property Type As MenuItemType
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItem
Dim value As MenuItemType

instance.Type = value

value = instance.Type
C#
public MenuItemType Type {get; set;}

Remarks

WebMenu provides five MenuItem types. They are Normal, Radio, CheckBox, Separator, and Custom.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItem Class
WebMenuItem Members

Tasks

Working with MenuItem Types


UseFontImage Property

[image]
Intersoft WebDesktop Documentation
UseFontImage Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItem Class : UseFontImage Property

Glossary Item Box

Indicates whether font should be used as replacement for Image. When set to True, the text specified in ImageURL will be rendered using WebDings font.

Syntax

Visual Basic (Declaration)
Public Property UseFontImage As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItem
Dim value As Boolean

instance.UseFontImage = value

value = instance.UseFontImage
C#
public bool UseFontImage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItem Class
WebMenuItem Members


Visible Property

[image]
Intersoft WebDesktop Documentation
Visible Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItem Class : Visible Property

Glossary Item Box

Gets or sets a value that indicates whether a Command is visibled.

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItem
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public bool Visible {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItem Class
WebMenuItem Members


WebMenuItemClickedEventArgs Class

[image]
Intersoft WebDesktop Documentation
WebMenuItemClickedEventArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebMenuItemClickedEventArgs Class

Glossary Item Box

Provides data for WebMenuItem clicked related event.

Object Model

WebMenuItemClickedEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class WebMenuItemClickedEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItemClickedEventArgs
C#
public class WebMenuItemClickedEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebDesktop.WebMenuItemClickedEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItemClickedEventArgs Members
ISNet.WebUI.WebDesktop Namespace


WebMenuItemClickedEventArgs Class Members

[image]
Intersoft WebDesktop Documentation
WebMenuItemClickedEventArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebMenuItemClickedEventArgs Class

Glossary Item Box

The following tables list the members exposed by WebMenuItemClickedEventArgs.

Public Properties

 | Name | Description
Public Property | MenuItem | Gets the menu item on WebMenuItem clicked event.
Top

See Also

Reference

WebMenuItemClickedEventArgs Class
ISNet.WebUI.WebDesktop Namespace


WebMenuItemClickedEventArgs Class Properties

[image]
Intersoft WebDesktop Documentation
WebMenuItemClickedEventArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebMenuItemClickedEventArgs Class

Glossary Item Box

For a list of all members of this type, see WebMenuItemClickedEventArgs members.

Public Properties

 | Name | Description
Public Property | MenuItem | Gets the menu item on WebMenuItem clicked event.
Top

See Also

Reference

WebMenuItemClickedEventArgs Class
ISNet.WebUI.WebDesktop Namespace


MenuItem Property

[image]
Intersoft WebDesktop Documentation
MenuItem Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItemClickedEventArgs Class : MenuItem Property

Glossary Item Box

Gets the menu item on WebMenuItem clicked event.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MenuItem As WebMenuItem
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItemClickedEventArgs
Dim value As WebMenuItem

value = instance.MenuItem
C#
public WebMenuItem MenuItem {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItemClickedEventArgs Class
WebMenuItemClickedEventArgs Members


WebMenuItemCollection Class

[image]
Intersoft WebDesktop Documentation
WebMenuItemCollection Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebMenuItemCollection Class

Glossary Item Box

Collection of WebMenuItem.

Object Model

WebMenuItemCollection Class

Syntax

Visual Basic (Declaration)
Public Class WebMenuItemCollection
   Inherits ISNet.WebUI.ISCollectionBase
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItemCollection
C#
public class WebMenuItemCollection : ISNet.WebUI.ISCollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
ISNet.WebUI.ISCollectionBase
ISNet.WebUI.WebDesktop.WebMenuItemCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItemCollection Members
ISNet.WebUI.WebDesktop Namespace


WebMenuItemCollection Class Members

[image]
Intersoft WebDesktop Documentation
WebMenuItemCollection Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebMenuItemCollection Class

Glossary Item Box

The following tables list the members exposed by WebMenuItemCollection.

Public Constructors

 | Name | Description
Public Constructor | WebMenuItemCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden. Returns a Boolean value indicating whether the collection is read-only.
Public Property | Item | Property indexer for the collection.
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebMenuItemCollection Class
ISNet.WebUI.WebDesktop Namespace


WebMenuItemCollection Constructor

[image]
Intersoft WebDesktop Documentation
WebMenuItemCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItemCollection Class : WebMenuItemCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebMenuItemCollection()
C#
public WebMenuItemCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItemCollection Class
WebMenuItemCollection Members


WebMenuItemCollection Class Methods

[image]
Intersoft WebDesktop Documentation
WebMenuItemCollection Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebMenuItemCollection Class

Glossary Item Box

For a list of all members of this type, see WebMenuItemCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebMenuItemCollection Class
ISNet.WebUI.WebDesktop Namespace


Add Method

[image]
Intersoft WebDesktop Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItemCollection Class : Add Method

Glossary Item Box

Overload List

Overload | Description
Add(WebMenuItem) |
Add(String) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItemCollection Class
WebMenuItemCollection Members


Add(WebMenuItem) Method

[image]
Intersoft WebDesktop Documentation
Add(WebMenuItem) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItemCollection Class > Add Method : Add(WebMenuItem) Method

webMenuItem

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function Add( _
   ByVal webMenuItem As WebMenuItem _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItemCollection
Dim webMenuItem As WebMenuItem
Dim value As Integer

value = instance.Add(webMenuItem)
C#
public virtual int Add(
   WebMenuItem webMenuItem
)

Parameters

webMenuItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItemCollection Class
WebMenuItemCollection Members
Overload List


Add(String) Method

[image]
Intersoft WebDesktop Documentation
Add(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItemCollection Class > Add Method : Add(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal name As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItemCollection
Dim name As String
Dim value As Integer

value = instance.Add(name)
C#
public int Add(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItemCollection Class
WebMenuItemCollection Members
Overload List


Clear Method

[image]
Intersoft WebDesktop Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItemCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItemCollection

instance.Clear()
C#
public new void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItemCollection Class
WebMenuItemCollection Members


Contains Method

[image]
Intersoft WebDesktop Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItemCollection Class : Contains Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As ISNet.WebUI.INamedObject _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItemCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As Boolean

value = instance.Contains(value)
C#
public bool Contains(
   ISNet.WebUI.INamedObject value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItemCollection Class
WebMenuItemCollection Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItemCollection Class : CopyFrom Method

passIn

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CopyFrom( _
   ByVal passIn As WebMenuItemCollection _
) As WebMenuItemCollection
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItemCollection
Dim passIn As WebMenuItemCollection
Dim value As WebMenuItemCollection

value = instance.CopyFrom(passIn)
C#
public WebMenuItemCollection CopyFrom(
   WebMenuItemCollection passIn
)

Parameters

passIn

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItemCollection Class
WebMenuItemCollection Members


CopyTo Method

[image]
Intersoft WebDesktop Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItemCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItemCollection
Dim array() As ISNet.WebUI.INamedObject
Dim index As Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   ISNet.WebUI.INamedObject[] array,
   int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItemCollection Class
WebMenuItemCollection Members


Exists Method

[image]
Intersoft WebDesktop Documentation
Exists Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItemCollection Class : Exists Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Exists( _
   ByVal name As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItemCollection
Dim name As String
Dim value As Boolean

value = instance.Exists(name)
C#
public bool Exists(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItemCollection Class
WebMenuItemCollection Members


GetEnumerator Method

[image]
Intersoft WebDesktop Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItemCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Function GetEnumerator() As System.Collections.IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItemCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
public new System.Collections.IEnumerator GetEnumerator()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItemCollection Class
WebMenuItemCollection Members


GetItem Method

[image]
Intersoft WebDesktop Documentation
GetItem Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItemCollection Class : GetItem Method

Glossary Item Box

Overload List

Overload | Description
GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItemCollection Class
WebMenuItemCollection Members


GetItem(Int32) Method

[image]
Intersoft WebDesktop Documentation
GetItem(Int32) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItemCollection Class : GetItem(Int32) Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetItem( _
   ByVal index As Integer _
) As ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItemCollection
Dim index As Integer
Dim value As ISNet.WebUI.INamedObject

value = instance.GetItem(index)
C#
public virtual ISNet.WebUI.INamedObject GetItem(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItemCollection Class
WebMenuItemCollection Members


GetNamedItem Method

[image]
Intersoft WebDesktop Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItemCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNamedItem( _
   ByVal name As String _
) As WebMenuItem
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItemCollection
Dim name As String
Dim value As WebMenuItem

value = instance.GetNamedItem(name)
C#
public WebMenuItem GetNamedItem(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItemCollection Class
WebMenuItemCollection Members


IndexOf Method

[image]
Intersoft WebDesktop Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItemCollection Class : IndexOf Method

Glossary Item Box

Overload List

Overload | Description
IndexOf(String) | (Inherited from ISNet.WebUI.ISCollectionBase)
IndexOf(INamedObject) | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItemCollection Class
WebMenuItemCollection Members


IndexOf(String) Method

[image]
Intersoft WebDesktop Documentation
IndexOf(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItemCollection Class > IndexOf Method : IndexOf(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function IndexOf( _
   ByVal name As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItemCollection
Dim name As String
Dim value As Integer

value = instance.IndexOf(name)
C#
public virtual int IndexOf(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItemCollection Class
WebMenuItemCollection Members
Overload List


IndexOf(INamedObject) Method

[image]
Intersoft WebDesktop Documentation
IndexOf(INamedObject) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItemCollection Class > IndexOf Method : IndexOf(INamedObject) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal value As ISNet.WebUI.INamedObject _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItemCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As Integer

value = instance.IndexOf(value)
C#
public int IndexOf(
   ISNet.WebUI.INamedObject value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItemCollection Class
WebMenuItemCollection Members
Overload List


Insert Method

[image]
Intersoft WebDesktop Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItemCollection Class : Insert Method

index
webMenuItem

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal webMenuItem As WebMenuItem _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItemCollection
Dim index As Integer
Dim webMenuItem As WebMenuItem

instance.Insert(index, webMenuItem)
C#
public void Insert(
   int index,
   WebMenuItem webMenuItem
)

Parameters

index
webMenuItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItemCollection Class
WebMenuItemCollection Members


IntInsert Method

[image]
Intersoft WebDesktop Documentation
IntInsert Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItemCollection Class : IntInsert Method

index
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub IntInsert( _
   ByVal index As Integer, _
   ByVal value As ISNet.WebUI.INamedObject _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItemCollection
Dim index As Integer
Dim value As ISNet.WebUI.INamedObject

instance.IntInsert(index, value)
C#
public void IntInsert(
   int index,
   ISNet.WebUI.INamedObject value
)

Parameters

index
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItemCollection Class
WebMenuItemCollection Members


Remove Method

[image]
Intersoft WebDesktop Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItemCollection Class : Remove Method

webMenuItem

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal webMenuItem As WebMenuItem _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItemCollection
Dim webMenuItem As WebMenuItem

instance.Remove(webMenuItem)
C#
public void Remove(
   WebMenuItem webMenuItem
)

Parameters

webMenuItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItemCollection Class
WebMenuItemCollection Members


setParent Method

[image]
Intersoft WebDesktop Documentation
setParent Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItemCollection Class : setParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub setParent( _
   ByVal parent As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItemCollection
Dim parent As Object

instance.setParent(parent)
C#
public virtual void setParent(
   object parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItemCollection Class
WebMenuItemCollection Members


Capacity Property

[image]
Intersoft WebDesktop Documentation
Capacity Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItemCollection Class : Capacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItemCollection
Dim value As Integer

instance.Capacity = value

value = instance.Capacity
C#
public int Capacity {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItemCollection Class
WebMenuItemCollection Members


Count Property

[image]
Intersoft WebDesktop Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItemCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItemCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItemCollection Class
WebMenuItemCollection Members


WebMenuItemCollection Class Properties

[image]
Intersoft WebDesktop Documentation
WebMenuItemCollection Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebMenuItemCollection Class

Glossary Item Box

For a list of all members of this type, see WebMenuItemCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden. Returns a Boolean value indicating whether the collection is read-only.
Public Property | Item | Property indexer for the collection.
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebMenuItemCollection Class
ISNet.WebUI.WebDesktop Namespace


WebMenuItemCollection Constructor

[image]
Intersoft WebDesktop Documentation
WebMenuItemCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItemCollection Class : WebMenuItemCollection Constructor

Glossary Item Box

Initializes a new instance of the WebMenuItemCollection class.

Overload List

Overload | Description
WebMenuItemCollection Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItemCollection Class
WebMenuItemCollection Members


IsReadOnly Property

[image]
Intersoft WebDesktop Documentation
IsReadOnly Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItemCollection Class : IsReadOnly Property

Glossary Item Box

Returns a Boolean value indicating whether the collection is read-only.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItemCollection
Dim value As Boolean

value = instance.IsReadOnly
C#
public override bool IsReadOnly {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItemCollection Class
WebMenuItemCollection Members


Item Property

[image]
Intersoft WebDesktop Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItemCollection Class : Item Property

index

Glossary Item Box

Property indexer for the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As WebMenuItem
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItemCollection
Dim index As Integer
Dim value As WebMenuItem

value = instance.Item(index)
C#
public WebMenuItem this[
   int index
]; {get;}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItemCollection Class
WebMenuItemCollection Members


Parent Property

[image]
Intersoft WebDesktop Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuItemCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As Object
Visual Basic (Usage) Copy Code
Dim instance As WebMenuItemCollection
Dim value As Object

value = instance.Parent
C#
public object Parent {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItemCollection Class
WebMenuItemCollection Members


WebMenuRoot Class

[image]
Intersoft WebDesktop Documentation
WebMenuRoot Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebMenuRoot Class

Glossary Item Box

Command menu root implementation in WebMenuBar.

Object Model

WebMenuRoot Class

Syntax

Visual Basic (Declaration)
Public Class WebMenuRoot
   Inherits WebMenu
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebMenuRoot
C#
public class WebMenuRoot : WebMenu, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebDesktop.WebMenu
ISNet.WebUI.WebDesktop.WebMenuRoot

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuRoot Members
ISNet.WebUI.WebDesktop Namespace


WebMenuRoot Class Members

[image]
Intersoft WebDesktop Documentation
WebMenuRoot Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebMenuRoot Class

Glossary Item Box

The following tables list the members exposed by WebMenuRoot.

Public Constructors

 | Name | Description
Public Constructor | WebMenuRoot Constructor |
Top

Public Properties

 | Name | Description
Public Property | Direction | Overridden.
Public Property | IconViewMode | Specifies whether this menu should be displayed in IconView mode. (Inherited from ISNet.WebUI.WebDesktop.WebMenu)
Public Property | OffsetAlignment | Overridden.
Public Property | Width | (Inherited from ISNet.WebUI.WebDesktop.WebMenu)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.WebDesktop.WebMenu)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebMenuRoot Class
ISNet.WebUI.WebDesktop Namespace


WebMenuRoot Class Methods

[image]
Intersoft WebDesktop Documentation
WebMenuRoot Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebMenuRoot Class

Glossary Item Box

For a list of all members of this type, see WebMenuRoot members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.WebDesktop.WebMenu)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebMenuRoot Class
ISNet.WebUI.WebDesktop Namespace


WebMenuRoot Constructor

[image]
Intersoft WebDesktop Documentation
WebMenuRoot Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuRoot Class : WebMenuRoot Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebMenuRoot()
C#
public WebMenuRoot()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuRoot Class
WebMenuRoot Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuRoot Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebMenuRoot
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuRoot Class
WebMenuRoot Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuRoot Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuRoot Class
WebMenuRoot Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuRoot Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuRoot
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuRoot Class
WebMenuRoot Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuRoot Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuRoot
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuRoot Class
WebMenuRoot Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuRoot Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuRoot
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuRoot Class
WebMenuRoot Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuRoot Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebMenuRoot
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuRoot Class
WebMenuRoot Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuRoot Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebMenuRoot
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuRoot Class
WebMenuRoot Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuRoot Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebMenuRoot

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuRoot Class
WebMenuRoot Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuRoot Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuRoot
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuRoot Class
WebMenuRoot Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuRoot Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuRoot
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuRoot Class
WebMenuRoot Members


WebMenuRoot Class Properties

[image]
Intersoft WebDesktop Documentation
WebMenuRoot Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebMenuRoot Class

Glossary Item Box

For a list of all members of this type, see WebMenuRoot members.

Public Properties

 | Name | Description
Public Property | Direction | Overridden.
Public Property | IconViewMode | Specifies whether this menu should be displayed in IconView mode. (Inherited from ISNet.WebUI.WebDesktop.WebMenu)
Public Property | OffsetAlignment | Overridden.
Public Property | Width | (Inherited from ISNet.WebUI.WebDesktop.WebMenu)
Top

See Also

Reference

WebMenuRoot Class
ISNet.WebUI.WebDesktop Namespace


WebMenuRoot Constructor

[image]
Intersoft WebDesktop Documentation
WebMenuRoot Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuRoot Class : WebMenuRoot Constructor

Glossary Item Box

Initializes a new instance of the WebMenuRoot class.

Overload List

Overload | Description
WebMenuRoot Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuRoot Class
WebMenuRoot Members


Direction Property

[image]
Intersoft WebDesktop Documentation
Direction Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuRoot Class : Direction Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Property Direction As OrientationMode
Visual Basic (Usage) Copy Code
Dim instance As WebMenuRoot
Dim value As OrientationMode

instance.Direction = value

value = instance.Direction
C#
public override OrientationMode Direction {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuRoot Class
WebMenuRoot Members


OffsetAlignment Property

[image]
Intersoft WebDesktop Documentation
OffsetAlignment Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuRoot Class : OffsetAlignment Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Property OffsetAlignment As ISNet.WebUI.DisplayPosition
Visual Basic (Usage) Copy Code
Dim instance As WebMenuRoot
Dim value As ISNet.WebUI.DisplayPosition

instance.OffsetAlignment = value

value = instance.OffsetAlignment
C#
public override ISNet.WebUI.DisplayPosition OffsetAlignment {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuRoot Class
WebMenuRoot Members


WebMenuStyles Class

[image]
Intersoft WebDesktop Documentation
WebMenuStyles Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebMenuStyles Class

Glossary Item Box

Styles and behaviors that can be applied to WebMenu.

Object Model

WebMenuStyles Class

Syntax

Visual Basic (Declaration)
Public Class WebMenuStyles
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer
Visual Basic (Usage) Copy Code
Dim instance As WebMenuStyles
C#
public class WebMenuStyles : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer

Remarks

WebMenu is designed with rich and highly customizable styles in mind. It can simulate almost any kind of menu appearances, from Windows system menu to latest Outlook 2003 style in every high detail. Following are list of configurable elements:

  • ItemStyle with 3 states: Normal, Over and Active.
    ItemStyle represent the dynamic style for each menu item.
  • CheckedItemStyle with 3 states: Normal, Over and Active.
    This dynamic style is applied to the "icon part" of checked menu item.
  • DisabledItemStyle with 3 states
    This dynamic style is applied for disabled menu item.
  • SeparatorStyle
    The style applied to Separator.
  • FrameStyle
    The style applied to the menu's frame.

There are numerous styles and behaviors that can be easily applied through WebMenuStyles. You can easily draw a background strip similar to Office-style menu by setting HasBackgroundStrip property to True. You can even customize its colors by specifying the BackgroundStripColor and additionally BackgroundStripColor2 to achieve gradient effect.

BackgroundStrip menu appearance is firstly introduced in Office XP application and later improved in Outlook 2003 where gradient colors can be applied to make the icons looks nicer. In WebMenu, you can also configure its gradient and colors in the property configuration and hence allow you to create any kind of menu themes with futuristic look

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebDesktop.WebMenuStyles

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuStyles Members
ISNet.WebUI.WebDesktop Namespace

Concepts

WebMenuStyles

concepts

WebMenuFeatures


WebMenuStyles Class Members

[image]
Intersoft WebDesktop Documentation
WebMenuStyles Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebMenuStyles Class

Glossary Item Box

The following tables list the members exposed by WebMenuStyles.

Public Constructors

 | Name | Description
Public Constructor | WebMenuStyles Constructor |
Top

Public Properties

 | Name | Description
Public Property | BackgroundStripColor | The background color of the strip.
Public Property | BackgroundStripColor2 | The second background color of the strip. When filled, gradient will be applied from background color 1 to background color 2.
Public Property | BackgroundStripImage |
Public Property | BackgroundStripWidth | The width of the background strip.
Public Property | CheckedItemStyle | The interactive style of Menu Item when checked.
Public Property | ContentPadding | The padding width of each Menu Item applied to Content (Text) part.
Public Property | CustomStyle |
Public Property | DisabledItemStyle | The interactive style of Menu Item when disabled.
Public Property | FrameStyle | The style of the Menu's Frame.
Public Property | HasBackgroundStrip | Indicates whether the background strip should be drawn.
Public Property | HighlightDisabledItem |
Public Property | HighlightMode |
Public Property | IconCellWidth |
Public Property | ImagesSettings |
Public Property | ItemPadding |
Public Property | ItemStyle | The interactive style of Menu Item.
Public Property | MenuAnimation | Specifies whether fading animation should be applied when displaying menu.
Public Property | MenuAnimationMode |
Public Property | MenuDropShadow | Specifies whether dropshadow effect should be applied to menu. This property is only applicable for IE browser and when window type is set to Normal.
Public Property | MenuWindowType | Specifies the window type to be used as the menu container.
Public Property | SeparatorStyle | The style of the Separator Menu Item.
Public Property | UseSmartWebResources |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CustomDeserialize |
Public Method | CustomSerialize |
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebMenuStyles Class
ISNet.WebUI.WebDesktop Namespace

Concepts

WebMenuStyles

concepts

WebMenuFeatures


WebMenuStyles Constructor

[image]
Intersoft WebDesktop Documentation
WebMenuStyles Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuStyles Class : WebMenuStyles Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebMenuStyles()
C#
public WebMenuStyles()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuStyles Class
WebMenuStyles Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuStyles Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebMenuStyles
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuStyles Class
WebMenuStyles Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuStyles Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuStyles Class
WebMenuStyles Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuStyles Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuStyles
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuStyles Class
WebMenuStyles Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuStyles Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuStyles
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuStyles Class
WebMenuStyles Members
Overload List


WebMenuStyles Class Methods

[image]
Intersoft WebDesktop Documentation
WebMenuStyles Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebMenuStyles Class

Glossary Item Box

For a list of all members of this type, see WebMenuStyles members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CustomDeserialize |
Public Method | CustomSerialize |
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebMenuStyles Class
ISNet.WebUI.WebDesktop Namespace

Concepts

WebMenuStyles

concepts

WebMenuFeatures


CustomDeserialize Method

[image]
Intersoft WebDesktop Documentation
CustomDeserialize Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuStyles Class : CustomDeserialize Method

mi
currentObj
parentNode
currentNode

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CustomDeserialize( _
   ByVal mi As System.Reflection.MemberInfo, _
   ByVal currentObj As Object, _
   ByVal parentNode As System.Xml.XmlNode, _
   ByVal currentNode As System.Xml.XmlNode _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuStyles
Dim mi As System.Reflection.MemberInfo
Dim currentObj As Object
Dim parentNode As System.Xml.XmlNode
Dim currentNode As System.Xml.XmlNode

instance.CustomDeserialize(mi, currentObj, parentNode, currentNode)
C#
public void CustomDeserialize(
   System.Reflection.MemberInfo mi,
   object currentObj,
   System.Xml.XmlNode parentNode,
   System.Xml.XmlNode currentNode
)

Parameters

mi
currentObj
parentNode
currentNode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuStyles Class
WebMenuStyles Members


CustomSerialize Method

[image]
Intersoft WebDesktop Documentation
CustomSerialize Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuStyles Class : CustomSerialize Method

doc
node

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CustomSerialize( _
   ByVal doc As System.Xml.XmlDocument, _
   ByVal node As System.Xml.XmlNode _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuStyles
Dim doc As System.Xml.XmlDocument
Dim node As System.Xml.XmlNode

instance.CustomSerialize(doc, node)
C#
public void CustomSerialize(
   System.Xml.XmlDocument doc,
   System.Xml.XmlNode node
)

Parameters

doc
node

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuStyles Class
WebMenuStyles Members


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuStyles Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuStyles
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuStyles Class
WebMenuStyles Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuStyles Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebMenuStyles
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuStyles Class
WebMenuStyles Members


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuStyles Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuStyles
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuStyles Class
WebMenuStyles Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuStyles Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebMenuStyles
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuStyles Class
WebMenuStyles Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuStyles Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebMenuStyles

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuStyles Class
WebMenuStyles Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuStyles Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebMenuStyles
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuStyles Class
WebMenuStyles Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuStyles Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuStyles
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuStyles Class
WebMenuStyles Members


WebMenuStyles Class Properties

[image]
Intersoft WebDesktop Documentation
WebMenuStyles Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebMenuStyles Class

Glossary Item Box

For a list of all members of this type, see WebMenuStyles members.

Public Properties

 | Name | Description
Public Property | BackgroundStripColor | The background color of the strip.
Public Property | BackgroundStripColor2 | The second background color of the strip. When filled, gradient will be applied from background color 1 to background color 2.
Public Property | BackgroundStripImage |
Public Property | BackgroundStripWidth | The width of the background strip.
Public Property | CheckedItemStyle | The interactive style of Menu Item when checked.
Public Property | ContentPadding | The padding width of each Menu Item applied to Content (Text) part.
Public Property | CustomStyle |
Public Property | DisabledItemStyle | The interactive style of Menu Item when disabled.
Public Property | FrameStyle | The style of the Menu's Frame.
Public Property | HasBackgroundStrip | Indicates whether the background strip should be drawn.
Public Property | HighlightDisabledItem |
Public Property | HighlightMode |
Public Property | IconCellWidth |
Public Property | ImagesSettings |
Public Property | ItemPadding |
Public Property | ItemStyle | The interactive style of Menu Item.
Public Property | MenuAnimation | Specifies whether fading animation should be applied when displaying menu.
Public Property | MenuAnimationMode |
Public Property | MenuDropShadow | Specifies whether dropshadow effect should be applied to menu. This property is only applicable for IE browser and when window type is set to Normal.
Public Property | MenuWindowType | Specifies the window type to be used as the menu container.
Public Property | SeparatorStyle | The style of the Separator Menu Item.
Public Property | UseSmartWebResources |
Top

See Also

Reference

WebMenuStyles Class
ISNet.WebUI.WebDesktop Namespace

Concepts

WebMenuStyles

concepts

WebMenuFeatures


WebMenuStyles Constructor

[image]
Intersoft WebDesktop Documentation
WebMenuStyles Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuStyles Class : WebMenuStyles Constructor

Glossary Item Box

Initializes a new instance of the WebMenuStyles class.

Overload List

Overload | Description
WebMenuStyles Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuStyles Class
WebMenuStyles Members


BackgroundStripColor Property

[image]
Intersoft WebDesktop Documentation
BackgroundStripColor Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuStyles Class : BackgroundStripColor Property

Glossary Item Box

The background color of the strip.

Syntax

Visual Basic (Declaration)
Public Property BackgroundStripColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebMenuStyles
Dim value As System.Drawing.Color

instance.BackgroundStripColor = value

value = instance.BackgroundStripColor
C#
public System.Drawing.Color BackgroundStripColor {get; set;}

Remarks

BackgroundStrip menu appearance is firstly introduced in Office XP application and later enhanced in Outlook 2003 where gradient colors can be applied to make the icons looks nicer. Using this property you can configure the background strip color to achieve the gradient effect.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuStyles Class
WebMenuStyles Members

Concepts

WebMenu Styles


BackgroundStripColor2 Property

[image]
Intersoft WebDesktop Documentation
BackgroundStripColor2 Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuStyles Class : BackgroundStripColor2 Property

Glossary Item Box

The second background color of the strip. When filled, gradient will be applied from background color 1 to background color 2.

Syntax

Visual Basic (Declaration)
Public Property BackgroundStripColor2 As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebMenuStyles
Dim value As System.Drawing.Color

instance.BackgroundStripColor2 = value

value = instance.BackgroundStripColor2
C#
public System.Drawing.Color BackgroundStripColor2 {get; set;}

Remarks

In addition to the BackGroundStripColor, you can also customize the BackgroundStripColor2 to achieve the gradient color effect of WebMenu.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuStyles Class
WebMenuStyles Members

Concepts

WebMenu Styles


BackgroundStripImage Property

[image]
Intersoft WebDesktop Documentation
BackgroundStripImage Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuStyles Class : BackgroundStripImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property BackgroundStripImage As String
Visual Basic (Usage) Copy Code
Dim instance As WebMenuStyles
Dim value As String

instance.BackgroundStripImage = value

value = instance.BackgroundStripImage
C#
public string BackgroundStripImage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuStyles Class
WebMenuStyles Members


BackgroundStripWidth Property

[image]
Intersoft WebDesktop Documentation
BackgroundStripWidth Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuStyles Class : BackgroundStripWidth Property

Glossary Item Box

The width of the background strip.

Syntax

Visual Basic (Declaration)
Public Property BackgroundStripWidth As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebMenuStyles
Dim value As Integer

instance.BackgroundStripWidth = value

value = instance.BackgroundStripWidth
C#
public int BackgroundStripWidth {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuStyles Class
WebMenuStyles Members


CheckedItemStyle Property

[image]
Intersoft WebDesktop Documentation
CheckedItemStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuStyles Class : CheckedItemStyle Property

Glossary Item Box

The interactive style of Menu Item when checked.

Syntax

Visual Basic (Declaration)
Public Property CheckedItemStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebMenuStyles
Dim value As ISNet.WebUI.DynamicStyle

instance.CheckedItemStyle = value

value = instance.CheckedItemStyle
C#
public ISNet.WebUI.DynamicStyle CheckedItemStyle {get; set;}

Remarks

Using CheckedItemStyle you can customize the style of checked item in three states - Normal, Active, and Over. This dynamic style is applied to the "icon part" of checked menu item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuStyles Class
WebMenuStyles Members

Concepts

WebMenu Styles

concepts

WebMenu Features


ContentPadding Property

[image]
Intersoft WebDesktop Documentation
ContentPadding Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuStyles Class : ContentPadding Property

Glossary Item Box

The padding width of each Menu Item applied to Content (Text) part.

Syntax

Visual Basic (Declaration)
Public Property ContentPadding As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebMenuStyles
Dim value As Integer

instance.ContentPadding = value

value = instance.ContentPadding
C#
public int ContentPadding {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuStyles Class
WebMenuStyles Members

Concepts

WebMenu Styles


CustomStyle Property

[image]
Intersoft WebDesktop Documentation
CustomStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuStyles Class : CustomStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property CustomStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebMenuStyles
Dim value As ISNet.WebUI.WebStyle

instance.CustomStyle = value

value = instance.CustomStyle
C#
public ISNet.WebUI.WebStyle CustomStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuStyles Class
WebMenuStyles Members


DisabledItemStyle Property

[image]
Intersoft WebDesktop Documentation
DisabledItemStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuStyles Class : DisabledItemStyle Property

Glossary Item Box

The interactive style of Menu Item when disabled.

Syntax

Visual Basic (Declaration)
Public Property DisabledItemStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebMenuStyles
Dim value As ISNet.WebUI.DynamicStyle

instance.DisabledItemStyle = value

value = instance.DisabledItemStyle
C#
public ISNet.WebUI.DynamicStyle DisabledItemStyle {get; set;}

Remarks

Using DisabledItemStyle you can customize the style of checked item in three states - Normal, Active, and Over. This dynamic style is applied for disabled menu item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuStyles Class
WebMenuStyles Members

Concepts

WebMenu Styles

concepts

WebMenu Features


FrameStyle Property

[image]
Intersoft WebDesktop Documentation
FrameStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuStyles Class : FrameStyle Property

Glossary Item Box

The style of the Menu's Frame.

Syntax

Visual Basic (Declaration)
Public Property FrameStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebMenuStyles
Dim value As ISNet.WebUI.WebStyle

instance.FrameStyle = value

value = instance.FrameStyle
C#
public ISNet.WebUI.WebStyle FrameStyle {get; set;}

Remarks

This property allows you to customize the style applied to Frame.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuStyles Class
WebMenuStyles Members

Concepts

WebMenu Features

concepts

WebMenu Styles


HasBackgroundStrip Property

[image]
Intersoft WebDesktop Documentation
HasBackgroundStrip Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuStyles Class : HasBackgroundStrip Property

Glossary Item Box

Indicates whether the background strip should be drawn.

Syntax

Visual Basic (Declaration)
Public Property HasBackgroundStrip As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebMenuStyles
Dim value As Boolean

instance.HasBackgroundStrip = value

value = instance.HasBackgroundStrip
C#
public bool HasBackgroundStrip {get; set;}

Remarks

You can easily configure the "BackgroundStrip" visibility in the menu style object. BackgroundStrip menu appearance is firstly introduced in Office XP application and later enhanced in Outlook 2003 where gradient colors can be applied to make the icons looks nicer. To enable the BackGroundStrip simply set HasBackgroundStrip to True. You can customize its colors by specifying the BackgroundStripColor and additionally BackgroundStripColor2 to achieve gradient effect.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuStyles Class
WebMenuStyles Members

Concepts

WebMenu Styles


HighlightDisabledItem Property

[image]
Intersoft WebDesktop Documentation
HighlightDisabledItem Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuStyles Class : HighlightDisabledItem Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property HighlightDisabledItem As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebMenuStyles
Dim value As Boolean

instance.HighlightDisabledItem = value

value = instance.HighlightDisabledItem
C#
public bool HighlightDisabledItem {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuStyles Class
WebMenuStyles Members


HighlightMode Property

[image]
Intersoft WebDesktop Documentation
HighlightMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuStyles Class : HighlightMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property HighlightMode As MenuHighlightMode
Visual Basic (Usage) Copy Code
Dim instance As WebMenuStyles
Dim value As MenuHighlightMode

instance.HighlightMode = value

value = instance.HighlightMode
C#
public MenuHighlightMode HighlightMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuStyles Class
WebMenuStyles Members


IconCellWidth Property

[image]
Intersoft WebDesktop Documentation
IconCellWidth Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuStyles Class : IconCellWidth Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property IconCellWidth As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebMenuStyles
Dim value As Integer

instance.IconCellWidth = value

value = instance.IconCellWidth
C#
public int IconCellWidth {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuStyles Class
WebMenuStyles Members


ImagesSettings Property

[image]
Intersoft WebDesktop Documentation
ImagesSettings Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuStyles Class : ImagesSettings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ImagesSettings As WebMenuImagesSettings
Visual Basic (Usage) Copy Code
Dim instance As WebMenuStyles
Dim value As WebMenuImagesSettings

instance.ImagesSettings = value

value = instance.ImagesSettings
C#
public WebMenuImagesSettings ImagesSettings {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuStyles Class
WebMenuStyles Members


ItemPadding Property

[image]
Intersoft WebDesktop Documentation
ItemPadding Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuStyles Class : ItemPadding Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ItemPadding As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebMenuStyles
Dim value As Integer

instance.ItemPadding = value

value = instance.ItemPadding
C#
public int ItemPadding {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuStyles Class
WebMenuStyles Members


ItemStyle Property

[image]
Intersoft WebDesktop Documentation
ItemStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuStyles Class : ItemStyle Property

Glossary Item Box

The interactive style of Menu Item.

Syntax

Visual Basic (Declaration)
Public Property ItemStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebMenuStyles
Dim value As ISNet.WebUI.DynamicStyle

instance.ItemStyle = value

value = instance.ItemStyle
C#
public ISNet.WebUI.DynamicStyle ItemStyle {get; set;}

Remarks

Using ItemStyle you can customize the style of menu item in three states - Normal, Active, and Over. ItemStyle represent the dynamic style for each menu item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuStyles Class
WebMenuStyles Members

Concepts

WebMenu Features

concepts

WebMenu Styles


MenuAnimation Property

[image]
Intersoft WebDesktop Documentation
MenuAnimation Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuStyles Class : MenuAnimation Property

Glossary Item Box

Specifies whether fading animation should be applied when displaying menu.

Syntax

Visual Basic (Declaration)
Public Property MenuAnimation As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebMenuStyles
Dim value As Boolean

instance.MenuAnimation = value

value = instance.MenuAnimation
C#
public bool MenuAnimation {get; set;}

Remarks

New in latest version of WebMenu, you can add smooth fading animation effect to all components that based on WebMenu. For instance, WebContextMenu, WebToolBar, WebMenuBar and other Intersoft's components that integrates WebMenu Runtime System.

Before you can enable animation, you need to set MenuWindowType to Normal. The default value of MenuWindowType is set to Popup to preserve compatibility with previous version. To enable animation, simply set MenuAnimation in MenuStyleSettings to True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuStyles Class
WebMenuStyles Members

Concepts

Fading Animation


MenuAnimationMode Property

[image]
Intersoft WebDesktop Documentation
MenuAnimationMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuStyles Class : MenuAnimationMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property MenuAnimationMode As MenuAnimationMode
Visual Basic (Usage) Copy Code
Dim instance As WebMenuStyles
Dim value As MenuAnimationMode

instance.MenuAnimationMode = value

value = instance.MenuAnimationMode
C#
public MenuAnimationMode MenuAnimationMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuStyles Class
WebMenuStyles Members


MenuDropShadow Property

[image]
Intersoft WebDesktop Documentation
MenuDropShadow Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuStyles Class : MenuDropShadow Property

Glossary Item Box

Specifies whether dropshadow effect should be applied to menu. This property is only applicable for IE browser and when window type is set to Normal.

Syntax

Visual Basic (Declaration)
Public Property MenuDropShadow As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebMenuStyles
Dim value As Boolean

instance.MenuDropShadow = value

value = instance.MenuDropShadow
C#
public bool MenuDropShadow {get; set;}

Remarks

Several notes regarding this feature

  • Best used with animation effect to create smooth, visually appealing Menu.
  • This feature is not supported in Mozilla browsers since Mozilla has not provide such API.
  • As in animation feature, you also need to set the MenuWindowType to Normal in order to enable dropshadow effect.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuStyles Class
WebMenuStyles Members

Concepts

DropShadow Effect


MenuWindowType Property

[image]
Intersoft WebDesktop Documentation
MenuWindowType Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuStyles Class : MenuWindowType Property

Glossary Item Box

Specifies the window type to be used as the menu container.

Syntax

Visual Basic (Declaration)
Public Property MenuWindowType As PopupWindowType
Visual Basic (Usage) Copy Code
Dim instance As WebMenuStyles
Dim value As PopupWindowType

instance.MenuWindowType = value

value = instance.MenuWindowType
C#
public PopupWindowType MenuWindowType {get; set;}

Remarks

The default value of MenuWindowType is Popup in order to preserve compatibility with previous version. If you would like to enable MenuAnimation you need to set MenuWindowType to Normal.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuStyles Class
WebMenuStyles Members

Concepts

Fading Animation


SeparatorStyle Property

[image]
Intersoft WebDesktop Documentation
SeparatorStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuStyles Class : SeparatorStyle Property

Glossary Item Box

The style of the Separator Menu Item.

Syntax

Visual Basic (Declaration)
Public Property SeparatorStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebMenuStyles
Dim value As ISNet.WebUI.WebStyle

instance.SeparatorStyle = value

value = instance.SeparatorStyle
C#
public ISNet.WebUI.WebStyle SeparatorStyle {get; set;}

Remarks

This property allows you to customize the style applied to Separator.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuStyles Class
WebMenuStyles Members

Concepts

WebMenu Features

concepts

WebMenu Styles


UseSmartWebResources Property

[image]
Intersoft WebDesktop Documentation
UseSmartWebResources Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebMenuStyles Class : UseSmartWebResources Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property UseSmartWebResources As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebMenuStyles
Dim value As Boolean

instance.UseSmartWebResources = value

value = instance.UseSmartWebResources
C#
public bool UseSmartWebResources {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuStyles Class
WebMenuStyles Members


WebNavBar Class

[image]
Intersoft WebDesktop Documentation
WebNavBar Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNavBar Class

Glossary Item Box

Collection of bars in WebNavPane which can be constructed in either design-time or runtime.

Object Model

WebNavBar Class

Syntax

Visual Basic (Declaration)
Public Class WebNavBar
   Inherits ISNet.WebUI.NamedObjectBase
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebNavBar
C#
public class WebNavBar : ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase
ISNet.WebUI.WebDesktop.WebNavBar
ISNet.WebUI.WebDesktop.WebExplorerBar

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBar Members
ISNet.WebUI.WebDesktop Namespace

Tasks

Using BarItem for Content Navigation
Using Template and IFrame Content mode

Concepts

WebNavPane Concepts
WebNavPane Features


WebNavBar Class Members

[image]
Intersoft WebDesktop Documentation
WebNavBar Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNavBar Class

Glossary Item Box

The following tables list the members exposed by WebNavBar.

Public Constructors

 | Name | Description
Public Constructor | WebNavBar Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | ActiveBarItemIndex | Gets or sets the active NavBarItem index.
Public Property | CaptionCustomRules | Gets or sets the custom rules applied to Caption.
Public Property | CaptionDisplayMode | Gets or sets the display mode of the Caption.
Public Property | ContentMode | Gets or sets the content mode of the NavBar.
Public Property | ContentURL | Gets or sets the content URL of the NavBar.
Public Property | Enabled | Indicates whether the NavBar is enable.
Public Property | Image | Gets or sets the image of NavBar.
Public Property | ImageSize | Gets or sets the image size of the NavBar.
Public Property | Items | Gets or sets the collection of NavBarItem.
Public Property | ItemSettings | Contains NavBarItem settings such as ItemStyle, Items PlaceholderStyle, DisplayMode and ImagePosition.
Public Property | Name | Overridden. Gets or sets the name of NavBar.
Public Property | Size | Gets or sets the size of the NavBar (in pixel size).
Public Property | Text | Gets or sets the text of NavBar.
Public Property | ToolTip | Gets or sets the tooltip of NavBar.
Public Property | Visible | Indicates whether the NavBar is visible.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

WebNavBar Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Using BarItem for Content Navigation
Using Template and IFrame Content mode

Concepts

WebNavPane Concepts
WebNavPane Features


WebNavBar Constructor

[image]
Intersoft WebDesktop Documentation
WebNavBar Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBar Class : WebNavBar Constructor

Glossary Item Box

Initializes a new instance of the WebNavBar class.

Overload List

Overload | Description
WebNavBar Constructor() | Initializes a new instance of the WebNavBar class with no argument.
WebNavBar Constructor(String) | Initializes a new instance of the WebNavBar class with Text parameter.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBar Class
WebNavBar Members


WebNavBar Constructor()

[image]
Intersoft WebDesktop Documentation
WebNavBar Constructor()
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBar Class > WebNavBar Constructor : WebNavBar Constructor()

Glossary Item Box

Initializes a new instance of the WebNavBar class with no argument.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebNavBar()
C#
public WebNavBar()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBar Class
WebNavBar Members
Overload List


WebNavBar Constructor(String)

[image]
Intersoft WebDesktop Documentation
WebNavBar Constructor(String)
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBar Class > WebNavBar Constructor : WebNavBar Constructor(String)

text

Glossary Item Box

Initializes a new instance of the WebNavBar class with Text parameter.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim text As String

Dim instance As New WebNavBar(text)
C#
public WebNavBar(
   string text
)

Parameters

text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBar Class
WebNavBar Members
Overload List


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBar Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebNavBar
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBar Class
WebNavBar Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBar Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBar Class
WebNavBar Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBar Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavBar
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBar Class
WebNavBar Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBar Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavBar
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBar Class
WebNavBar Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBar Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavBar
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBar Class
WebNavBar Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBar Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebNavBar
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBar Class
WebNavBar Members


WebNavBar Class Methods

[image]
Intersoft WebDesktop Documentation
WebNavBar Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNavBar Class

Glossary Item Box

For a list of all members of this type, see WebNavBar members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

WebNavBar Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Using BarItem for Content Navigation
Using Template and IFrame Content mode

Concepts

WebNavPane Concepts
WebNavPane Features


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBar Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavBar
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBar Class
WebNavBar Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBar Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNavBar
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBar Class
WebNavBar Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBar Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebNavBar

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBar Class
WebNavBar Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBar Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavBar
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBar Class
WebNavBar Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBar Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavBar
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBar Class
WebNavBar Members


WebNavBar Class Properties

[image]
Intersoft WebDesktop Documentation
WebNavBar Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNavBar Class

Glossary Item Box

For a list of all members of this type, see WebNavBar members.

Public Properties

 | Name | Description
Public Property | ActiveBarItemIndex | Gets or sets the active NavBarItem index.
Public Property | CaptionCustomRules | Gets or sets the custom rules applied to Caption.
Public Property | CaptionDisplayMode | Gets or sets the display mode of the Caption.
Public Property | ContentMode | Gets or sets the content mode of the NavBar.
Public Property | ContentURL | Gets or sets the content URL of the NavBar.
Public Property | Enabled | Indicates whether the NavBar is enable.
Public Property | Image | Gets or sets the image of NavBar.
Public Property | ImageSize | Gets or sets the image size of the NavBar.
Public Property | Items | Gets or sets the collection of NavBarItem.
Public Property | ItemSettings | Contains NavBarItem settings such as ItemStyle, Items PlaceholderStyle, DisplayMode and ImagePosition.
Public Property | Name | Overridden. Gets or sets the name of NavBar.
Public Property | Size | Gets or sets the size of the NavBar (in pixel size).
Public Property | Text | Gets or sets the text of NavBar.
Public Property | ToolTip | Gets or sets the tooltip of NavBar.
Public Property | Visible | Indicates whether the NavBar is visible.
Top

See Also

Reference

WebNavBar Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Using BarItem for Content Navigation
Using Template and IFrame Content mode

Concepts

WebNavPane Concepts
WebNavPane Features


ActiveBarItemIndex Property

[image]
Intersoft WebDesktop Documentation
ActiveBarItemIndex Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBar Class : ActiveBarItemIndex Property

Glossary Item Box

Gets or sets the active NavBarItem index.

Syntax

Visual Basic (Declaration)
Public Overridable Property ActiveBarItemIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebNavBar
Dim value As Integer

instance.ActiveBarItemIndex = value

value = instance.ActiveBarItemIndex
C#
public virtual int ActiveBarItemIndex {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBar Class
WebNavBar Members


CaptionCustomRules Property

[image]
Intersoft WebDesktop Documentation
CaptionCustomRules Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBar Class : CaptionCustomRules Property

Glossary Item Box

Gets or sets the custom rules applied to Caption.

Syntax

Visual Basic (Declaration)
Public Overridable Property CaptionCustomRules As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavBar
Dim value As String

instance.CaptionCustomRules = value

value = instance.CaptionCustomRules
C#
public virtual string CaptionCustomRules {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBar Class
WebNavBar Members


CaptionDisplayMode Property

[image]
Intersoft WebDesktop Documentation
CaptionDisplayMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBar Class : CaptionDisplayMode Property

Glossary Item Box

Gets or sets the display mode of the Caption.

Syntax

Visual Basic (Declaration)
Public Property CaptionDisplayMode As DisplayMode
Visual Basic (Usage) Copy Code
Dim instance As WebNavBar
Dim value As DisplayMode

instance.CaptionDisplayMode = value

value = instance.CaptionDisplayMode
C#
public DisplayMode CaptionDisplayMode {get; set;}

Remarks

By default, the CaptionDisplayMode is set to Text mode when a new instance is dropped to designer surface. You can also have Text&Images, Images, and UseTemplate for CaptionDisplaymode.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBar Class
WebNavBar Members

Concepts

NavPane Features

Tasks

Creating NavPane With Images


ContentMode Property

[image]
Intersoft WebDesktop Documentation
ContentMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBar Class : ContentMode Property

Glossary Item Box

Gets or sets the content mode of the NavBar.

Syntax

Visual Basic (Declaration)
Public Property ContentMode As NavBarContentMode
Visual Basic (Usage) Copy Code
Dim instance As WebNavBar
Dim value As NavBarContentMode

instance.ContentMode = value

value = instance.ContentMode
C#
public NavBarContentMode ContentMode {get; set;}

Remarks

By default, the WebNavBar will operate in UseInlineContent mode when a new instance is dropped to designer surface. UseInlineContent is the most suitable when the contents inside each WebNavBar page are relatively small. UseInlineContent mode utilized .NET Framework's template architecture and therefore all contents are loaded at once in first load (although the contents in inactive bar are set to hidden).

In most cases where you want to develop a more reusable form, you should use UseIFrame as the content mode. When using IFrame mode, you would need to specify the ContentURL which page you want to load for the designated WebNavBar.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBar Class
WebNavBar Members

Concepts

NavPane Features

Tasks

Using Template and IFrame Content mode

concepts

NavPane Concepts


ContentURL Property

[image]
Intersoft WebDesktop Documentation
ContentURL Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBar Class : ContentURL Property

Glossary Item Box

Gets or sets the content URL of the NavBar.

Syntax

Visual Basic (Declaration)
Public Overridable Property ContentURL As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavBar
Dim value As String

instance.ContentURL = value

value = instance.ContentURL
C#
public virtual string ContentURL {get; set;}

Remarks

The ContentURL accepts three formats of URL:

  • .NET specific application relative URL. This format starts with "~" character, for instance, "~/FolderA/Page1.aspx".
  • Absolute URL. This format starts with "/" character, for instance, "/SharedModule/Page1.aspx".
  • Relative URL. This format usually starts with "." character or no special characters (which assume the page can be found in the current folder's context).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBar Class
WebNavBar Members

Concepts

NavPane Features


Enabled Property

[image]
Intersoft WebDesktop Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBar Class : Enabled Property

Glossary Item Box

Indicates whether the NavBar is enable.

Syntax

Visual Basic (Declaration)
Public Property Enabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNavBar
Dim value As Boolean

instance.Enabled = value

value = instance.Enabled
C#
public bool Enabled {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBar Class
WebNavBar Members


Image Property

[image]
Intersoft WebDesktop Documentation
Image Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBar Class : Image Property

Glossary Item Box

Gets or sets the image of NavBar.

Syntax

Visual Basic (Declaration)
Public Overridable Property Image As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavBar
Dim value As String

instance.Image = value

value = instance.Image
C#
public virtual string Image {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBar Class
WebNavBar Members


ImageSize Property

[image]
Intersoft WebDesktop Documentation
ImageSize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBar Class : ImageSize Property

Glossary Item Box

Gets or sets the image size of the NavBar.

Syntax

Visual Basic (Declaration)
Public Property ImageSize As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebNavBar
Dim value As System.Web.UI.WebControls.Unit

instance.ImageSize = value

value = instance.ImageSize
C#
public System.Web.UI.WebControls.Unit ImageSize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBar Class
WebNavBar Members


Items Property

[image]
Intersoft WebDesktop Documentation
Items Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBar Class : Items Property

Glossary Item Box

Gets or sets the collection of NavBarItem.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Items As WebNavBarItemCollection
Visual Basic (Usage) Copy Code
Dim instance As WebNavBar
Dim value As WebNavBarItemCollection

value = instance.Items
C#
public virtual WebNavBarItemCollection Items {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBar Class
WebNavBar Members


ItemSettings Property

[image]
Intersoft WebDesktop Documentation
ItemSettings Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBar Class : ItemSettings Property

Glossary Item Box

Contains NavBarItem settings such as ItemStyle, Items PlaceholderStyle, DisplayMode and ImagePosition.

Syntax

Visual Basic (Declaration)
Public Property ItemSettings As WebNavBarItemSettings
Visual Basic (Usage) Copy Code
Dim instance As WebNavBar
Dim value As WebNavBarItemSettings

instance.ItemSettings = value

value = instance.ItemSettings
C#
public WebNavBarItemSettings ItemSettings {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBar Class
WebNavBar Members


Name Property

[image]
Intersoft WebDesktop Documentation
Name Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBar Class : Name Property

Glossary Item Box

Gets or sets the name of NavBar.

Syntax

Visual Basic (Declaration)
Public Overrides Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavBar
Dim value As String

instance.Name = value

value = instance.Name
C#
public override string Name {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBar Class
WebNavBar Members


Size Property

[image]
Intersoft WebDesktop Documentation
Size Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBar Class : Size Property

Glossary Item Box

Gets or sets the size of the NavBar (in pixel size).

Syntax

Visual Basic (Declaration)
Public Property Size As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebNavBar
Dim value As Integer

instance.Size = value

value = instance.Size
C#
public int Size {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBar Class
WebNavBar Members


Text Property

[image]
Intersoft WebDesktop Documentation
Text Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBar Class : Text Property

Glossary Item Box

Gets or sets the text of NavBar.

Syntax

Visual Basic (Declaration)
Public Overridable Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavBar
Dim value As String

instance.Text = value

value = instance.Text
C#
public virtual string Text {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBar Class
WebNavBar Members


ToolTip Property

[image]
Intersoft WebDesktop Documentation
ToolTip Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBar Class : ToolTip Property

Glossary Item Box

Gets or sets the tooltip of NavBar.

Syntax

Visual Basic (Declaration)
Public Property ToolTip As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavBar
Dim value As String

instance.ToolTip = value

value = instance.ToolTip
C#
public string ToolTip {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBar Class
WebNavBar Members


Visible Property

[image]
Intersoft WebDesktop Documentation
Visible Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBar Class : Visible Property

Glossary Item Box

Indicates whether the NavBar is visible.

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNavBar
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public bool Visible {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBar Class
WebNavBar Members


WebNavBarCollection Class

[image]
Intersoft WebDesktop Documentation
WebNavBarCollection Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNavBarCollection Class

Glossary Item Box

Collection of WebNavBar.

Object Model

WebNavBarCollection Class

Syntax

Visual Basic (Declaration)
Public Class WebNavBarCollection
   Inherits ISNet.WebUI.ISCollectionBase
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarCollection
C#
public class WebNavBarCollection : ISNet.WebUI.ISCollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
ISNet.WebUI.ISCollectionBase
ISNet.WebUI.WebDesktop.WebNavBarCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarCollection Members
ISNet.WebUI.WebDesktop Namespace


WebNavBarCollection Class Members

[image]
Intersoft WebDesktop Documentation
WebNavBarCollection Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNavBarCollection Class

Glossary Item Box

The following tables list the members exposed by WebNavBarCollection.

Public Constructors

 | Name | Description
Public Constructor | WebNavBarCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden. Returns a Boolean value indicating whether the collection is read-only.
Public Property | Item | Property indexer for the collection.
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | GetObjectData |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebNavBarCollection Class
ISNet.WebUI.WebDesktop Namespace


WebNavBarCollection Constructor

[image]
Intersoft WebDesktop Documentation
WebNavBarCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarCollection Class : WebNavBarCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebNavBarCollection()
C#
public WebNavBarCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarCollection Class
WebNavBarCollection Members


WebNavBarCollection Class Methods

[image]
Intersoft WebDesktop Documentation
WebNavBarCollection Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNavBarCollection Class

Glossary Item Box

For a list of all members of this type, see WebNavBarCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | GetObjectData |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebNavBarCollection Class
ISNet.WebUI.WebDesktop Namespace


Add Method

[image]
Intersoft WebDesktop Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarCollection Class : Add Method

Glossary Item Box

Overload List

Overload | Description
Add(WebNavBar) |
Add(String) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarCollection Class
WebNavBarCollection Members


Add(WebNavBar) Method

[image]
Intersoft WebDesktop Documentation
Add(WebNavBar) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarCollection Class > Add Method : Add(WebNavBar) Method

navbar

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function Add( _
   ByVal navbar As WebNavBar _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarCollection
Dim navbar As WebNavBar
Dim value As Integer

value = instance.Add(navbar)
C#
public virtual int Add(
   WebNavBar navbar
)

Parameters

navbar

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarCollection Class
WebNavBarCollection Members
Overload List


Add(String) Method

[image]
Intersoft WebDesktop Documentation
Add(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarCollection Class > Add Method : Add(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal name As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarCollection
Dim name As String
Dim value As Integer

value = instance.Add(name)
C#
public int Add(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarCollection Class
WebNavBarCollection Members
Overload List


Clear Method

[image]
Intersoft WebDesktop Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarCollection

instance.Clear()
C#
public new void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarCollection Class
WebNavBarCollection Members


Contains Method

[image]
Intersoft WebDesktop Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarCollection Class : Contains Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As ISNet.WebUI.INamedObject _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As Boolean

value = instance.Contains(value)
C#
public bool Contains(
   ISNet.WebUI.INamedObject value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarCollection Class
WebNavBarCollection Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarCollection Class : CopyFrom Method

passIn

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CopyFrom( _
   ByVal passIn As WebNavBarCollection _
) As WebNavBarCollection
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarCollection
Dim passIn As WebNavBarCollection
Dim value As WebNavBarCollection

value = instance.CopyFrom(passIn)
C#
public WebNavBarCollection CopyFrom(
   WebNavBarCollection passIn
)

Parameters

passIn

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarCollection Class
WebNavBarCollection Members


CopyTo Method

[image]
Intersoft WebDesktop Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarCollection
Dim array() As ISNet.WebUI.INamedObject
Dim index As Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   ISNet.WebUI.INamedObject[] array,
   int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarCollection Class
WebNavBarCollection Members


Exists Method

[image]
Intersoft WebDesktop Documentation
Exists Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarCollection Class : Exists Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Exists( _
   ByVal name As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarCollection
Dim name As String
Dim value As Boolean

value = instance.Exists(name)
C#
public bool Exists(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarCollection Class
WebNavBarCollection Members


GetEnumerator Method

[image]
Intersoft WebDesktop Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Function GetEnumerator() As System.Collections.IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
public new System.Collections.IEnumerator GetEnumerator()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarCollection Class
WebNavBarCollection Members


GetItem Method

[image]
Intersoft WebDesktop Documentation
GetItem Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarCollection Class : GetItem Method

Glossary Item Box

Overload List

Overload | Description
GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarCollection Class
WebNavBarCollection Members


GetItem(Int32) Method

[image]
Intersoft WebDesktop Documentation
GetItem(Int32) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarCollection Class : GetItem(Int32) Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetItem( _
   ByVal index As Integer _
) As ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarCollection
Dim index As Integer
Dim value As ISNet.WebUI.INamedObject

value = instance.GetItem(index)
C#
public virtual ISNet.WebUI.INamedObject GetItem(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarCollection Class
WebNavBarCollection Members


GetNamedItem Method

[image]
Intersoft WebDesktop Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNamedItem( _
   ByVal name As String _
) As WebNavBar
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarCollection
Dim name As String
Dim value As WebNavBar

value = instance.GetNamedItem(name)
C#
public WebNavBar GetNamedItem(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarCollection Class
WebNavBarCollection Members


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarCollection Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarCollection Class
WebNavBarCollection Members


IndexOf Method

[image]
Intersoft WebDesktop Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarCollection Class : IndexOf Method

Glossary Item Box

Overload List

Overload | Description
IndexOf(String) | (Inherited from ISNet.WebUI.ISCollectionBase)
IndexOf(INamedObject) | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarCollection Class
WebNavBarCollection Members


IndexOf(String) Method

[image]
Intersoft WebDesktop Documentation
IndexOf(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarCollection Class > IndexOf Method : IndexOf(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function IndexOf( _
   ByVal name As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarCollection
Dim name As String
Dim value As Integer

value = instance.IndexOf(name)
C#
public virtual int IndexOf(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarCollection Class
WebNavBarCollection Members
Overload List


IndexOf(INamedObject) Method

[image]
Intersoft WebDesktop Documentation
IndexOf(INamedObject) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarCollection Class > IndexOf Method : IndexOf(INamedObject) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal value As ISNet.WebUI.INamedObject _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As Integer

value = instance.IndexOf(value)
C#
public int IndexOf(
   ISNet.WebUI.INamedObject value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarCollection Class
WebNavBarCollection Members
Overload List


Insert Method

[image]
Intersoft WebDesktop Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarCollection Class : Insert Method

index
navbar

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal navbar As WebNavBar _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarCollection
Dim index As Integer
Dim navbar As WebNavBar

instance.Insert(index, navbar)
C#
public void Insert(
   int index,
   WebNavBar navbar
)

Parameters

index
navbar

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarCollection Class
WebNavBarCollection Members


IntInsert Method

[image]
Intersoft WebDesktop Documentation
IntInsert Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarCollection Class : IntInsert Method

index
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub IntInsert( _
   ByVal index As Integer, _
   ByVal value As ISNet.WebUI.INamedObject _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarCollection
Dim index As Integer
Dim value As ISNet.WebUI.INamedObject

instance.IntInsert(index, value)
C#
public void IntInsert(
   int index,
   ISNet.WebUI.INamedObject value
)

Parameters

index
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarCollection Class
WebNavBarCollection Members


Remove Method

[image]
Intersoft WebDesktop Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarCollection Class : Remove Method

navbar

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal navbar As WebNavBar _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarCollection
Dim navbar As WebNavBar

instance.Remove(navbar)
C#
public void Remove(
   WebNavBar navbar
)

Parameters

navbar

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarCollection Class
WebNavBarCollection Members


setParent Method

[image]
Intersoft WebDesktop Documentation
setParent Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarCollection Class : setParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub setParent( _
   ByVal parent As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarCollection
Dim parent As Object

instance.setParent(parent)
C#
public virtual void setParent(
   object parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarCollection Class
WebNavBarCollection Members


Capacity Property

[image]
Intersoft WebDesktop Documentation
Capacity Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarCollection Class : Capacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarCollection
Dim value As Integer

instance.Capacity = value

value = instance.Capacity
C#
public int Capacity {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarCollection Class
WebNavBarCollection Members


Count Property

[image]
Intersoft WebDesktop Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarCollection Class
WebNavBarCollection Members


WebNavBarCollection Class Properties

[image]
Intersoft WebDesktop Documentation
WebNavBarCollection Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNavBarCollection Class

Glossary Item Box

For a list of all members of this type, see WebNavBarCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden. Returns a Boolean value indicating whether the collection is read-only.
Public Property | Item | Property indexer for the collection.
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebNavBarCollection Class
ISNet.WebUI.WebDesktop Namespace


WebNavBarCollection Constructor

[image]
Intersoft WebDesktop Documentation
WebNavBarCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarCollection Class : WebNavBarCollection Constructor

Glossary Item Box

Initializes a new instance of the WebNavBarItemCollection class.

Overload List

Overload | Description
WebNavBarCollection Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarCollection Class
WebNavBarCollection Members


IsReadOnly Property

[image]
Intersoft WebDesktop Documentation
IsReadOnly Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarCollection Class : IsReadOnly Property

Glossary Item Box

Returns a Boolean value indicating whether the collection is read-only.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarCollection
Dim value As Boolean

value = instance.IsReadOnly
C#
public override bool IsReadOnly {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarCollection Class
WebNavBarCollection Members


Item Property

[image]
Intersoft WebDesktop Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarCollection Class : Item Property

index

Glossary Item Box

Property indexer for the collection.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As WebNavBar
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarCollection
Dim index As Integer
Dim value As WebNavBar

instance.Item(index) = value

value = instance.Item(index)
C#
public WebNavBar this[
   int index
]; {get; set;}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarCollection Class
WebNavBarCollection Members


Parent Property

[image]
Intersoft WebDesktop Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As Object
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarCollection
Dim value As Object

value = instance.Parent
C#
public object Parent {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarCollection Class
WebNavBarCollection Members


WebNavBarItem Class

[image]
Intersoft WebDesktop Documentation
WebNavBarItem Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNavBarItem Class

Glossary Item Box

Items in WebNavBar which mainly used as navigation links. The WebNavBarItem can be easily manipulated and accessed through Items collection provided by each WebNavBar object.

Object Model

WebNavBarItem Class

Syntax

Visual Basic (Declaration)
Public Class WebNavBarItem
   Inherits ISNet.WebUI.NamedObjectBase
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItem
C#
public class WebNavBarItem : ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject

Remarks

The WebNavBar's Items will be used and rendered when the WebNavBar's ContentMode is set to UseItems by default. For extensibility or customized content, you may set the ContentMode to UseInlineContent and put any kind of ASP.NET's server controls. You can also use IFrame ContentMode for better reusability. The ContentMode property can be found in BarSettings object which contains global configurations for Bar.

The WebNavBarItem object provides TargetURL and TargetWindow features for effective navigation purpose.

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase
ISNet.WebUI.WebDesktop.WebNavBarItem
ISNet.WebUI.WebDesktop.WebExplorerBarItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItem Members
ISNet.WebUI.WebDesktop Namespace

Tasks

Using BarItem for Content Navigation

Concepts

NavPane Concepts


WebNavBarItem Class Members

[image]
Intersoft WebDesktop Documentation
WebNavBarItem Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNavBarItem Class

Glossary Item Box

The following tables list the members exposed by WebNavBarItem.

Public Constructors

 | Name | Description
Public Constructor | WebNavBarItem Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | DisplayMode | Gets or sets the display mode of the NavBarItem.
Public Property | Enabled | Indicates whether the NavBarItem is enable.
Public Property | Image | Gets or sets the image of NavBarItem.
Public Property | ImagePosition | Gets or sets the image position of NavBarItem.
Public Property | ImageSize | Gets or sets the image size of the NavBarItem.
Public Property | ItemCustomRules | Gets or sets the custom rules applied to NavBarItem.
Public Property | Name | Overridden. Gets or sets the name of WebNavBarItem.
Public Property | TargetURL | Gets or sets the target url when item is clicked.
Public Property | TargetWindow | Gets or sets the target window for the navigation link. If blank, it will use TargetWindow property specified in BarItemSettings.
Public Property | Text | Gets or sets text of NavBarItem.
Public Property | ToolTip | Gets or sets the tooltip of NavBarItem.
Public Property | Visible | Indicates whether the NavBarItem is visible.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

WebNavBarItem Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Using BarItem for Content Navigation

Concepts

NavPane Concepts


WebNavBarItem Constructor

[image]
Intersoft WebDesktop Documentation
WebNavBarItem Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItem Class : WebNavBarItem Constructor

Glossary Item Box

Initializes a new instance of the WebNavBarItem class.

Overload List

Overload | Description
WebNavBarItem Constructor() | Initializes a new instance of the WebNavBarItem with no argument.
WebNavBarItem Constructor(String) | Initializes a new instance of the WebNavBarItem class using ID.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItem Class
WebNavBarItem Members


WebNavBarItem Constructor()

[image]
Intersoft WebDesktop Documentation
WebNavBarItem Constructor()
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItem Class > WebNavBarItem Constructor : WebNavBarItem Constructor()

Glossary Item Box

Initializes a new instance of the WebNavBarItem with no argument.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebNavBarItem()
C#
public WebNavBarItem()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItem Class
WebNavBarItem Members
Overload List


WebNavBarItem Constructor(String)

[image]
Intersoft WebDesktop Documentation
WebNavBarItem Constructor(String)
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItem Class > WebNavBarItem Constructor : WebNavBarItem Constructor(String)

text

Glossary Item Box

Initializes a new instance of the WebNavBarItem class using ID.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim text As String

Dim instance As New WebNavBarItem(text)
C#
public WebNavBarItem(
   string text
)

Parameters

text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItem Class
WebNavBarItem Members
Overload List


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItem Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItem
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItem Class
WebNavBarItem Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItem Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItem Class
WebNavBarItem Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItem Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItem
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItem Class
WebNavBarItem Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItem Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItem
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItem Class
WebNavBarItem Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItem Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItem
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItem Class
WebNavBarItem Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItem Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItem
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItem Class
WebNavBarItem Members


WebNavBarItem Class Methods

[image]
Intersoft WebDesktop Documentation
WebNavBarItem Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNavBarItem Class

Glossary Item Box

For a list of all members of this type, see WebNavBarItem members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

WebNavBarItem Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Using BarItem for Content Navigation

Concepts

NavPane Concepts


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItem Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItem
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItem Class
WebNavBarItem Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItem Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItem
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItem Class
WebNavBarItem Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItem Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItem

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItem Class
WebNavBarItem Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItem Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItem
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItem Class
WebNavBarItem Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItem Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItem
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItem Class
WebNavBarItem Members


WebNavBarItem Class Properties

[image]
Intersoft WebDesktop Documentation
WebNavBarItem Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNavBarItem Class

Glossary Item Box

For a list of all members of this type, see WebNavBarItem members.

Public Properties

 | Name | Description
Public Property | DisplayMode | Gets or sets the display mode of the NavBarItem.
Public Property | Enabled | Indicates whether the NavBarItem is enable.
Public Property | Image | Gets or sets the image of NavBarItem.
Public Property | ImagePosition | Gets or sets the image position of NavBarItem.
Public Property | ImageSize | Gets or sets the image size of the NavBarItem.
Public Property | ItemCustomRules | Gets or sets the custom rules applied to NavBarItem.
Public Property | Name | Overridden. Gets or sets the name of WebNavBarItem.
Public Property | TargetURL | Gets or sets the target url when item is clicked.
Public Property | TargetWindow | Gets or sets the target window for the navigation link. If blank, it will use TargetWindow property specified in BarItemSettings.
Public Property | Text | Gets or sets text of NavBarItem.
Public Property | ToolTip | Gets or sets the tooltip of NavBarItem.
Public Property | Visible | Indicates whether the NavBarItem is visible.
Top

See Also

Reference

WebNavBarItem Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Using BarItem for Content Navigation

Concepts

NavPane Concepts


DisplayMode Property

[image]
Intersoft WebDesktop Documentation
DisplayMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItem Class : DisplayMode Property

Glossary Item Box

Gets or sets the display mode of the NavBarItem.

Syntax

Visual Basic (Declaration)
Public Property DisplayMode As DisplayMode
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItem
Dim value As DisplayMode

instance.DisplayMode = value

value = instance.DisplayMode
C#
public DisplayMode DisplayMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItem Class
WebNavBarItem Members

Tasks

Creating NavPane With Images


Enabled Property

[image]
Intersoft WebDesktop Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItem Class : Enabled Property

Glossary Item Box

Indicates whether the NavBarItem is enable.

Syntax

Visual Basic (Declaration)
Public Property Enabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItem
Dim value As Boolean

instance.Enabled = value

value = instance.Enabled
C#
public bool Enabled {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItem Class
WebNavBarItem Members


Image Property

[image]
Intersoft WebDesktop Documentation
Image Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItem Class : Image Property

Glossary Item Box

Gets or sets the image of NavBarItem.

Syntax

Visual Basic (Declaration)
Public Property Image As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItem
Dim value As String

instance.Image = value

value = instance.Image
C#
public string Image {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItem Class
WebNavBarItem Members


ImagePosition Property

[image]
Intersoft WebDesktop Documentation
ImagePosition Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItem Class : ImagePosition Property

Glossary Item Box

Gets or sets the image position of NavBarItem.

Syntax

Visual Basic (Declaration)
Public Property ImagePosition As WebNavImagePosition
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItem
Dim value As WebNavImagePosition

instance.ImagePosition = value

value = instance.ImagePosition
C#
public WebNavImagePosition ImagePosition {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItem Class
WebNavBarItem Members


ImageSize Property

[image]
Intersoft WebDesktop Documentation
ImageSize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItem Class : ImageSize Property

Glossary Item Box

Gets or sets the image size of the NavBarItem.

Syntax

Visual Basic (Declaration)
Public Property ImageSize As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItem
Dim value As System.Web.UI.WebControls.Unit

instance.ImageSize = value

value = instance.ImageSize
C#
public System.Web.UI.WebControls.Unit ImageSize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItem Class
WebNavBarItem Members


ItemCustomRules Property

[image]
Intersoft WebDesktop Documentation
ItemCustomRules Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItem Class : ItemCustomRules Property

Glossary Item Box

Gets or sets the custom rules applied to NavBarItem.

Syntax

Visual Basic (Declaration)
Public Property ItemCustomRules As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItem
Dim value As String

instance.ItemCustomRules = value

value = instance.ItemCustomRules
C#
public string ItemCustomRules {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItem Class
WebNavBarItem Members


Name Property

[image]
Intersoft WebDesktop Documentation
Name Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItem Class : Name Property

Glossary Item Box

Gets or sets the name of WebNavBarItem.

Syntax

Visual Basic (Declaration)
Public Overrides Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItem
Dim value As String

instance.Name = value

value = instance.Name
C#
public override string Name {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItem Class
WebNavBarItem Members


TargetURL Property

[image]
Intersoft WebDesktop Documentation
TargetURL Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItem Class : TargetURL Property

Glossary Item Box

Gets or sets the target url when item is clicked.

Syntax

Visual Basic (Declaration)
Public Property TargetURL As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItem
Dim value As String

instance.TargetURL = value

value = instance.TargetURL
C#
public string TargetURL {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItem Class
WebNavBarItem Members

Concepts

NavPane Concepts


TargetWindow Property

[image]
Intersoft WebDesktop Documentation
TargetWindow Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItem Class : TargetWindow Property

Glossary Item Box

Gets or sets the target window for the navigation link. If blank, it will use TargetWindow property specified in BarItemSettings.

Syntax

Visual Basic (Declaration)
Public Property TargetWindow As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItem
Dim value As String

instance.TargetWindow = value

value = instance.TargetWindow
C#
public string TargetWindow {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItem Class
WebNavBarItem Members

Concepts

NavPane Concepts


Text Property

[image]
Intersoft WebDesktop Documentation
Text Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItem Class : Text Property

Glossary Item Box

Gets or sets text of NavBarItem.

Syntax

Visual Basic (Declaration)
Public Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItem
Dim value As String

instance.Text = value

value = instance.Text
C#
public string Text {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItem Class
WebNavBarItem Members


ToolTip Property

[image]
Intersoft WebDesktop Documentation
ToolTip Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItem Class : ToolTip Property

Glossary Item Box

Gets or sets the tooltip of NavBarItem.

Syntax

Visual Basic (Declaration)
Public Property ToolTip As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItem
Dim value As String

instance.ToolTip = value

value = instance.ToolTip
C#
public string ToolTip {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItem Class
WebNavBarItem Members


Visible Property

[image]
Intersoft WebDesktop Documentation
Visible Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItem Class : Visible Property

Glossary Item Box

Indicates whether the NavBarItem is visible.

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItem
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public bool Visible {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItem Class
WebNavBarItem Members


WebNavBarItemCollection Class

[image]
Intersoft WebDesktop Documentation
WebNavBarItemCollection Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNavBarItemCollection Class

Glossary Item Box

Collection of WebNavBarItem.

Object Model

WebNavBarItemCollection Class

Syntax

Visual Basic (Declaration)
Public Class WebNavBarItemCollection
   Inherits ISNet.WebUI.ISCollectionBase
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItemCollection
C#
public class WebNavBarItemCollection : ISNet.WebUI.ISCollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
ISNet.WebUI.ISCollectionBase
ISNet.WebUI.WebDesktop.WebNavBarItemCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItemCollection Members
ISNet.WebUI.WebDesktop Namespace


WebNavBarItemCollection Class Members

[image]
Intersoft WebDesktop Documentation
WebNavBarItemCollection Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNavBarItemCollection Class

Glossary Item Box

The following tables list the members exposed by WebNavBarItemCollection.

Public Constructors

 | Name | Description
Public Constructor | WebNavBarItemCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden. Returns a Boolean value indicating whether the collection is read-only.
Public Property | Item | Property indexer for the collection.
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | GetObjectData |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebNavBarItemCollection Class
ISNet.WebUI.WebDesktop Namespace


WebNavBarItemCollection Constructor

[image]
Intersoft WebDesktop Documentation
WebNavBarItemCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItemCollection Class : WebNavBarItemCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebNavBarItemCollection()
C#
public WebNavBarItemCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItemCollection Class
WebNavBarItemCollection Members


WebNavBarItemCollection Class Methods

[image]
Intersoft WebDesktop Documentation
WebNavBarItemCollection Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNavBarItemCollection Class

Glossary Item Box

For a list of all members of this type, see WebNavBarItemCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | GetObjectData |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebNavBarItemCollection Class
ISNet.WebUI.WebDesktop Namespace


Add Method

[image]
Intersoft WebDesktop Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItemCollection Class : Add Method

Glossary Item Box

Overload List

Overload | Description
Add(WebNavBarItem) |
Add(String) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItemCollection Class
WebNavBarItemCollection Members


Add(WebNavBarItem) Method

[image]
Intersoft WebDesktop Documentation
Add(WebNavBarItem) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItemCollection Class > Add Method : Add(WebNavBarItem) Method

navbaritem

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function Add( _
   ByVal navbaritem As WebNavBarItem _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItemCollection
Dim navbaritem As WebNavBarItem
Dim value As Integer

value = instance.Add(navbaritem)
C#
public virtual int Add(
   WebNavBarItem navbaritem
)

Parameters

navbaritem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItemCollection Class
WebNavBarItemCollection Members
Overload List


Add(String) Method

[image]
Intersoft WebDesktop Documentation
Add(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItemCollection Class > Add Method : Add(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal name As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItemCollection
Dim name As String
Dim value As Integer

value = instance.Add(name)
C#
public int Add(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItemCollection Class
WebNavBarItemCollection Members
Overload List


Clear Method

[image]
Intersoft WebDesktop Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItemCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItemCollection

instance.Clear()
C#
public new void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItemCollection Class
WebNavBarItemCollection Members


Contains Method

[image]
Intersoft WebDesktop Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItemCollection Class : Contains Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As ISNet.WebUI.INamedObject _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItemCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As Boolean

value = instance.Contains(value)
C#
public bool Contains(
   ISNet.WebUI.INamedObject value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItemCollection Class
WebNavBarItemCollection Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItemCollection Class : CopyFrom Method

passIn

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CopyFrom( _
   ByVal passIn As WebNavBarItemCollection _
) As WebNavBarItemCollection
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItemCollection
Dim passIn As WebNavBarItemCollection
Dim value As WebNavBarItemCollection

value = instance.CopyFrom(passIn)
C#
public WebNavBarItemCollection CopyFrom(
   WebNavBarItemCollection passIn
)

Parameters

passIn

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItemCollection Class
WebNavBarItemCollection Members


CopyTo Method

[image]
Intersoft WebDesktop Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItemCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItemCollection
Dim array() As ISNet.WebUI.INamedObject
Dim index As Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   ISNet.WebUI.INamedObject[] array,
   int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItemCollection Class
WebNavBarItemCollection Members


Exists Method

[image]
Intersoft WebDesktop Documentation
Exists Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItemCollection Class : Exists Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Exists( _
   ByVal name As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItemCollection
Dim name As String
Dim value As Boolean

value = instance.Exists(name)
C#
public bool Exists(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItemCollection Class
WebNavBarItemCollection Members


GetEnumerator Method

[image]
Intersoft WebDesktop Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItemCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Function GetEnumerator() As System.Collections.IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItemCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
public new System.Collections.IEnumerator GetEnumerator()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItemCollection Class
WebNavBarItemCollection Members


GetItem Method

[image]
Intersoft WebDesktop Documentation
GetItem Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItemCollection Class : GetItem Method

Glossary Item Box

Overload List

Overload | Description
GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItemCollection Class
WebNavBarItemCollection Members


GetItem(Int32) Method

[image]
Intersoft WebDesktop Documentation
GetItem(Int32) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItemCollection Class : GetItem(Int32) Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetItem( _
   ByVal index As Integer _
) As ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItemCollection
Dim index As Integer
Dim value As ISNet.WebUI.INamedObject

value = instance.GetItem(index)
C#
public virtual ISNet.WebUI.INamedObject GetItem(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItemCollection Class
WebNavBarItemCollection Members


GetNamedItem Method

[image]
Intersoft WebDesktop Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItemCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNamedItem( _
   ByVal name As String _
) As WebNavBarItem
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItemCollection
Dim name As String
Dim value As WebNavBarItem

value = instance.GetNamedItem(name)
C#
public WebNavBarItem GetNamedItem(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItemCollection Class
WebNavBarItemCollection Members


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItemCollection Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItemCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItemCollection Class
WebNavBarItemCollection Members


IndexOf Method

[image]
Intersoft WebDesktop Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItemCollection Class : IndexOf Method

Glossary Item Box

Overload List

Overload | Description
IndexOf(String) | (Inherited from ISNet.WebUI.ISCollectionBase)
IndexOf(INamedObject) | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItemCollection Class
WebNavBarItemCollection Members


IndexOf(String) Method

[image]
Intersoft WebDesktop Documentation
IndexOf(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItemCollection Class > IndexOf Method : IndexOf(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function IndexOf( _
   ByVal name As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItemCollection
Dim name As String
Dim value As Integer

value = instance.IndexOf(name)
C#
public virtual int IndexOf(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItemCollection Class
WebNavBarItemCollection Members
Overload List


IndexOf(INamedObject) Method

[image]
Intersoft WebDesktop Documentation
IndexOf(INamedObject) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItemCollection Class > IndexOf Method : IndexOf(INamedObject) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal value As ISNet.WebUI.INamedObject _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItemCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As Integer

value = instance.IndexOf(value)
C#
public int IndexOf(
   ISNet.WebUI.INamedObject value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItemCollection Class
WebNavBarItemCollection Members
Overload List


Insert Method

[image]
Intersoft WebDesktop Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItemCollection Class : Insert Method

index
navbaritem

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal navbaritem As WebNavBarItem _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItemCollection
Dim index As Integer
Dim navbaritem As WebNavBarItem

instance.Insert(index, navbaritem)
C#
public void Insert(
   int index,
   WebNavBarItem navbaritem
)

Parameters

index
navbaritem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItemCollection Class
WebNavBarItemCollection Members


IntInsert Method

[image]
Intersoft WebDesktop Documentation
IntInsert Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItemCollection Class : IntInsert Method

index
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub IntInsert( _
   ByVal index As Integer, _
   ByVal value As ISNet.WebUI.INamedObject _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItemCollection
Dim index As Integer
Dim value As ISNet.WebUI.INamedObject

instance.IntInsert(index, value)
C#
public void IntInsert(
   int index,
   ISNet.WebUI.INamedObject value
)

Parameters

index
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItemCollection Class
WebNavBarItemCollection Members


Remove Method

[image]
Intersoft WebDesktop Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItemCollection Class : Remove Method

navbaritem

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal navbaritem As WebNavBarItem _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItemCollection
Dim navbaritem As WebNavBarItem

instance.Remove(navbaritem)
C#
public void Remove(
   WebNavBarItem navbaritem
)

Parameters

navbaritem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItemCollection Class
WebNavBarItemCollection Members


setParent Method

[image]
Intersoft WebDesktop Documentation
setParent Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItemCollection Class : setParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub setParent( _
   ByVal parent As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItemCollection
Dim parent As Object

instance.setParent(parent)
C#
public virtual void setParent(
   object parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItemCollection Class
WebNavBarItemCollection Members


Capacity Property

[image]
Intersoft WebDesktop Documentation
Capacity Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItemCollection Class : Capacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItemCollection
Dim value As Integer

instance.Capacity = value

value = instance.Capacity
C#
public int Capacity {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItemCollection Class
WebNavBarItemCollection Members


Count Property

[image]
Intersoft WebDesktop Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItemCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItemCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItemCollection Class
WebNavBarItemCollection Members


WebNavBarItemCollection Class Properties

[image]
Intersoft WebDesktop Documentation
WebNavBarItemCollection Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNavBarItemCollection Class

Glossary Item Box

For a list of all members of this type, see WebNavBarItemCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden. Returns a Boolean value indicating whether the collection is read-only.
Public Property | Item | Property indexer for the collection.
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebNavBarItemCollection Class
ISNet.WebUI.WebDesktop Namespace


WebNavBarItemCollection Constructor

[image]
Intersoft WebDesktop Documentation
WebNavBarItemCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItemCollection Class : WebNavBarItemCollection Constructor

Glossary Item Box

Initializes a new instance of the WebNavBarItemCollection class.

Overload List

Overload | Description
WebNavBarItemCollection Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItemCollection Class
WebNavBarItemCollection Members


IsReadOnly Property

[image]
Intersoft WebDesktop Documentation
IsReadOnly Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItemCollection Class : IsReadOnly Property

Glossary Item Box

Returns a Boolean value indicating whether the collection is read-only.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItemCollection
Dim value As Boolean

value = instance.IsReadOnly
C#
public override bool IsReadOnly {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItemCollection Class
WebNavBarItemCollection Members


Item Property

[image]
Intersoft WebDesktop Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItemCollection Class : Item Property

index

Glossary Item Box

Property indexer for the collection.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As WebNavBarItem
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItemCollection
Dim index As Integer
Dim value As WebNavBarItem

instance.Item(index) = value

value = instance.Item(index)
C#
public WebNavBarItem this[
   int index
]; {get; set;}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItemCollection Class
WebNavBarItemCollection Members


Parent Property

[image]
Intersoft WebDesktop Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItemCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As Object
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItemCollection
Dim value As Object

value = instance.Parent
C#
public object Parent {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItemCollection Class
WebNavBarItemCollection Members


WebNavBarItemSettings Class

[image]
Intersoft WebDesktop Documentation
WebNavBarItemSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNavBarItemSettings Class

Glossary Item Box

A collection of bar item settings to customize the WebNavbarItem.

Object Model

WebNavBarItemSettings Class

Syntax

Visual Basic (Declaration)
Public Class WebNavBarItemSettings
   Inherits WebNavPaneItemSettings
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItemSettings
C#
public class WebNavBarItemSettings : WebNavPaneItemSettings, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Remarks

The configurations for BarItem can be set in global level at BarItemSettings or at invidiual WebNavBarItem object level. Using WebNavBarSettings you can customize the WebNavBar, such as ImagePosition and Alignment.

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebDesktop.WebNavPaneItemSettings
ISNet.WebUI.WebDesktop.WebNavBarItemSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItemSettings Members
ISNet.WebUI.WebDesktop Namespace

Tasks

Using BarItem for Content Navigation

Concepts

Understanding Concepts


WebNavBarItemSettings Class Members

[image]
Intersoft WebDesktop Documentation
WebNavBarItemSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNavBarItemSettings Class

Glossary Item Box

The following tables list the members exposed by WebNavBarItemSettings.

Public Constructors

 | Name | Description
Public Constructor | WebNavBarItemSettings Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Alignment | Overridden. Gets or sets horizontal alignment of NavBarItem.
Public Property | DisplayMode | Overridden. Gets or sets the display mode of the NavBarItem.
Public Property | ImagePosition | Overridden. Gets or sets the image position of NavBarItem.
Public Property | ImageSize | Overridden. Gets or sets the image size of the NavBarItem.
Public Property | ItemsContainerCustomRules | Gets or sets the custom rules applied to Items container.
Public Property | ItemSpacing | (Inherited from ISNet.WebUI.WebDesktop.WebNavPaneItemSettings)
Public Property | TargetWindow | Overridden. Gets or sets the target window when item is clicked.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

WebNavBarItemSettings Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Using BarItem for Content Navigation

Concepts

Understanding Concepts


WebNavBarItemSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebNavBarItemSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItemSettings Class : WebNavBarItemSettings Constructor

Glossary Item Box

Initializes a new instance of the WebNavBarItemSettings class.

Overload List

Overload | Description
WebNavBarItemSettings Constructor() |
WebNavBarItemSettings Constructor(Unit,DisplayMode,WebNavImagePosition) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItemSettings Class
WebNavBarItemSettings Members


WebNavBarItemSettings Constructor()

[image]
Intersoft WebDesktop Documentation
WebNavBarItemSettings Constructor()
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItemSettings Class > WebNavBarItemSettings Constructor : WebNavBarItemSettings Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebNavBarItemSettings()
C#
public WebNavBarItemSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItemSettings Class
WebNavBarItemSettings Members
Overload List


WebNavBarItemSettings Constructor(Unit,DisplayMode,WebNavImagePosition)

[image]
Intersoft WebDesktop Documentation
WebNavBarItemSettings Constructor(Unit,DisplayMode,WebNavImagePosition)
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItemSettings Class > WebNavBarItemSettings Constructor : WebNavBarItemSettings Constructor(Unit,DisplayMode,WebNavImagePosition)

imgSize
dispMode
imgPos

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal imgSize As System.Web.UI.WebControls.Unit, _
   ByVal dispMode As DisplayMode, _
   ByVal imgPos As WebNavImagePosition _
)
Visual Basic (Usage) Copy Code
Dim imgSize As System.Web.UI.WebControls.Unit
Dim dispMode As DisplayMode
Dim imgPos As WebNavImagePosition

Dim instance As New WebNavBarItemSettings(imgSize, dispMode, imgPos)
C#
public WebNavBarItemSettings(
   System.Web.UI.WebControls.Unit imgSize,
   DisplayMode dispMode,
   WebNavImagePosition imgPos
)

Parameters

imgSize
dispMode
imgPos

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItemSettings Class
WebNavBarItemSettings Members
Overload List


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItemSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItemSettings
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItemSettings Class
WebNavBarItemSettings Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItemSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItemSettings Class
WebNavBarItemSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItemSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItemSettings
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItemSettings Class
WebNavBarItemSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItemSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItemSettings
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItemSettings Class
WebNavBarItemSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItemSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItemSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItemSettings Class
WebNavBarItemSettings Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItemSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItemSettings
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItemSettings Class
WebNavBarItemSettings Members


WebNavBarItemSettings Class Methods

[image]
Intersoft WebDesktop Documentation
WebNavBarItemSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNavBarItemSettings Class

Glossary Item Box

For a list of all members of this type, see WebNavBarItemSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

WebNavBarItemSettings Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Using BarItem for Content Navigation

Concepts

Understanding Concepts


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItemSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItemSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItemSettings Class
WebNavBarItemSettings Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItemSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItemSettings
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItemSettings Class
WebNavBarItemSettings Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItemSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItemSettings

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItemSettings Class
WebNavBarItemSettings Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItemSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItemSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItemSettings Class
WebNavBarItemSettings Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItemSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItemSettings
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItemSettings Class
WebNavBarItemSettings Members


WebNavBarItemSettings Class Properties

[image]
Intersoft WebDesktop Documentation
WebNavBarItemSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNavBarItemSettings Class

Glossary Item Box

For a list of all members of this type, see WebNavBarItemSettings members.

Public Properties

 | Name | Description
Public Property | Alignment | Overridden. Gets or sets horizontal alignment of NavBarItem.
Public Property | DisplayMode | Overridden. Gets or sets the display mode of the NavBarItem.
Public Property | ImagePosition | Overridden. Gets or sets the image position of NavBarItem.
Public Property | ImageSize | Overridden. Gets or sets the image size of the NavBarItem.
Public Property | ItemsContainerCustomRules | Gets or sets the custom rules applied to Items container.
Public Property | ItemSpacing | (Inherited from ISNet.WebUI.WebDesktop.WebNavPaneItemSettings)
Public Property | TargetWindow | Overridden. Gets or sets the target window when item is clicked.
Top

See Also

Reference

WebNavBarItemSettings Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Using BarItem for Content Navigation

Concepts

Understanding Concepts


Alignment Property

[image]
Intersoft WebDesktop Documentation
Alignment Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItemSettings Class : Alignment Property

Glossary Item Box

Gets or sets horizontal alignment of NavBarItem.

Syntax

Visual Basic (Declaration)
Public Overrides Property Alignment As TextAlignment
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItemSettings
Dim value As TextAlignment

instance.Alignment = value

value = instance.Alignment
C#
public override TextAlignment Alignment {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItemSettings Class
WebNavBarItemSettings Members


DisplayMode Property

[image]
Intersoft WebDesktop Documentation
DisplayMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItemSettings Class : DisplayMode Property

Glossary Item Box

Gets or sets the display mode of the NavBarItem.

Syntax

Visual Basic (Declaration)
Public Overrides Property DisplayMode As DisplayMode
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItemSettings
Dim value As DisplayMode

instance.DisplayMode = value

value = instance.DisplayMode
C#
public override DisplayMode DisplayMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItemSettings Class
WebNavBarItemSettings Members


ImagePosition Property

[image]
Intersoft WebDesktop Documentation
ImagePosition Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItemSettings Class : ImagePosition Property

Glossary Item Box

Gets or sets the image position of NavBarItem.

Syntax

Visual Basic (Declaration)
Public Overrides Property ImagePosition As WebNavImagePosition
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItemSettings
Dim value As WebNavImagePosition

instance.ImagePosition = value

value = instance.ImagePosition
C#
public override WebNavImagePosition ImagePosition {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItemSettings Class
WebNavBarItemSettings Members


ImageSize Property

[image]
Intersoft WebDesktop Documentation
ImageSize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItemSettings Class : ImageSize Property

Glossary Item Box

Gets or sets the image size of the NavBarItem.

Syntax

Visual Basic (Declaration)
Public Overrides Property ImageSize As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItemSettings
Dim value As System.Web.UI.WebControls.Unit

instance.ImageSize = value

value = instance.ImageSize
C#
public override System.Web.UI.WebControls.Unit ImageSize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItemSettings Class
WebNavBarItemSettings Members


ItemsContainerCustomRules Property

[image]
Intersoft WebDesktop Documentation
ItemsContainerCustomRules Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItemSettings Class : ItemsContainerCustomRules Property

Glossary Item Box

Gets or sets the custom rules applied to Items container.

Syntax

Visual Basic (Declaration)
Public Property ItemsContainerCustomRules As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItemSettings
Dim value As String

instance.ItemsContainerCustomRules = value

value = instance.ItemsContainerCustomRules
C#
public string ItemsContainerCustomRules {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItemSettings Class
WebNavBarItemSettings Members


TargetWindow Property

[image]
Intersoft WebDesktop Documentation
TargetWindow Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarItemSettings Class : TargetWindow Property

Glossary Item Box

Gets or sets the target window when item is clicked.

Syntax

Visual Basic (Declaration)
Public Overrides Property TargetWindow As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarItemSettings
Dim value As String

instance.TargetWindow = value

value = instance.TargetWindow
C#
public override string TargetWindow {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarItemSettings Class
WebNavBarItemSettings Members


WebNavBarSettings Class

[image]
Intersoft WebDesktop Documentation
WebNavBarSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNavBarSettings Class

Glossary Item Box

A collection of bar settings to configure the WebNavbar in global level.

Object Model

WebNavBarSettings Class

Syntax

Visual Basic (Declaration)
Public Class WebNavBarSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarSettings
C#
public class WebNavBarSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Remarks

The configurations for Bar can be set in global level at BarSettings or at individual WebNavBar object level. Using WebNavBarSettings you can customize the WebNavBar, such as CaptionDisplayMode, ImageSize, and Size.

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebDesktop.WebNavBarSettings
ISNet.WebUI.WebDesktop.WebExplorerBarSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarSettings Members
ISNet.WebUI.WebDesktop Namespace

Tasks

Using BarItem for Content Navigation

Concepts

Understanding Concepts


WebNavBarSettings Class Members

[image]
Intersoft WebDesktop Documentation
WebNavBarSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNavBarSettings Class

Glossary Item Box

The following tables list the members exposed by WebNavBarSettings.

Public Constructors

 | Name | Description
Public Constructor | WebNavBarSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | BarStyle | Gets or sets the style of NavBar.
Public Property | CaptionDisplayMode | Gets or sets the display mode of the Caption.
Public Property | CaptionStyle | Gets or sets the style of the Caption.
Public Property | ContentMode | Gets or sets the content mode of the NavBar.
Public Property | Image | Gets or sets the default image of NavBar.
Public Property | ImageSize | Gets or sets the image size of the NavBar.
Public Property | Size | Gets or sets the size of the NavBar.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebNavBarSettings Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Using BarItem for Content Navigation

Concepts

Understanding Concepts


WebNavBarSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebNavBarSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarSettings Class : WebNavBarSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebNavBarSettings()
C#
public WebNavBarSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarSettings Class
WebNavBarSettings Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarSettings
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarSettings Class
WebNavBarSettings Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarSettings Class
WebNavBarSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarSettings
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarSettings Class
WebNavBarSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarSettings
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarSettings Class
WebNavBarSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarSettings Class
WebNavBarSettings Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarSettings
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarSettings Class
WebNavBarSettings Members


WebNavBarSettings Class Methods

[image]
Intersoft WebDesktop Documentation
WebNavBarSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNavBarSettings Class

Glossary Item Box

For a list of all members of this type, see WebNavBarSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebNavBarSettings Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Using BarItem for Content Navigation

Concepts

Understanding Concepts


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarSettings Class
WebNavBarSettings Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarSettings
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarSettings Class
WebNavBarSettings Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarSettings

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarSettings Class
WebNavBarSettings Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarSettings Class
WebNavBarSettings Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarSettings
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarSettings Class
WebNavBarSettings Members


WebNavBarSettings Class Properties

[image]
Intersoft WebDesktop Documentation
WebNavBarSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNavBarSettings Class

Glossary Item Box

For a list of all members of this type, see WebNavBarSettings members.

Public Properties

 | Name | Description
Public Property | BarStyle | Gets or sets the style of NavBar.
Public Property | CaptionDisplayMode | Gets or sets the display mode of the Caption.
Public Property | CaptionStyle | Gets or sets the style of the Caption.
Public Property | ContentMode | Gets or sets the content mode of the NavBar.
Public Property | Image | Gets or sets the default image of NavBar.
Public Property | ImageSize | Gets or sets the image size of the NavBar.
Public Property | Size | Gets or sets the size of the NavBar.
Top

See Also

Reference

WebNavBarSettings Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Using BarItem for Content Navigation

Concepts

Understanding Concepts


WebNavBarSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebNavBarSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarSettings Class : WebNavBarSettings Constructor

Glossary Item Box

Initializes a new instance of the WebNavBarSettings class.

Overload List

Overload | Description
WebNavBarSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarSettings Class
WebNavBarSettings Members


BarStyle Property

[image]
Intersoft WebDesktop Documentation
BarStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarSettings Class : BarStyle Property

Glossary Item Box

Gets or sets the style of NavBar.

Syntax

Visual Basic (Declaration)
Public Overridable Property BarStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarSettings
Dim value As ISNet.WebUI.DynamicStyle

instance.BarStyle = value

value = instance.BarStyle
C#
public virtual ISNet.WebUI.DynamicStyle BarStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarSettings Class
WebNavBarSettings Members


CaptionDisplayMode Property

[image]
Intersoft WebDesktop Documentation
CaptionDisplayMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarSettings Class : CaptionDisplayMode Property

Glossary Item Box

Gets or sets the display mode of the Caption.

Syntax

Visual Basic (Declaration)
Public Property CaptionDisplayMode As DisplayMode
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarSettings
Dim value As DisplayMode

instance.CaptionDisplayMode = value

value = instance.CaptionDisplayMode
C#
public DisplayMode CaptionDisplayMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarSettings Class
WebNavBarSettings Members


CaptionStyle Property

[image]
Intersoft WebDesktop Documentation
CaptionStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarSettings Class : CaptionStyle Property

Glossary Item Box

Gets or sets the style of the Caption.

Syntax

Visual Basic (Declaration)
Public Property CaptionStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarSettings
Dim value As ISNet.WebUI.WebStyle

instance.CaptionStyle = value

value = instance.CaptionStyle
C#
public ISNet.WebUI.WebStyle CaptionStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarSettings Class
WebNavBarSettings Members


ContentMode Property

[image]
Intersoft WebDesktop Documentation
ContentMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarSettings Class : ContentMode Property

Glossary Item Box

Gets or sets the content mode of the NavBar.

Syntax

Visual Basic (Declaration)
Public Property ContentMode As NavBarContentMode
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarSettings
Dim value As NavBarContentMode

instance.ContentMode = value

value = instance.ContentMode
C#
public NavBarContentMode ContentMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarSettings Class
WebNavBarSettings Members


Image Property

[image]
Intersoft WebDesktop Documentation
Image Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarSettings Class : Image Property

Glossary Item Box

Gets or sets the default image of NavBar.

Syntax

Visual Basic (Declaration)
Public Property Image As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarSettings
Dim value As String

instance.Image = value

value = instance.Image
C#
public string Image {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarSettings Class
WebNavBarSettings Members


ImageSize Property

[image]
Intersoft WebDesktop Documentation
ImageSize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarSettings Class : ImageSize Property

Glossary Item Box

Gets or sets the image size of the NavBar.

Syntax

Visual Basic (Declaration)
Public Overridable Property ImageSize As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarSettings
Dim value As System.Web.UI.WebControls.Unit

instance.ImageSize = value

value = instance.ImageSize
C#
public virtual System.Web.UI.WebControls.Unit ImageSize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarSettings Class
WebNavBarSettings Members


Size Property

[image]
Intersoft WebDesktop Documentation
Size Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavBarSettings Class : Size Property

Glossary Item Box

Gets or sets the size of the NavBar.

Syntax

Visual Basic (Declaration)
Public Overridable Property Size As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebNavBarSettings
Dim value As Integer

instance.Size = value

value = instance.Size
C#
public virtual int Size {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavBarSettings Class
WebNavBarSettings Members


WebNavPane Class

[image]
Intersoft WebDesktop Documentation
WebNavPane Class
Members Example See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNavPane Class

Glossary Item Box

WebNavPane is the server control object serving as the root container for WebNavBar objects as well as other available configurations. WebNavPane lets you create advanced navigation user interface with the richness of desktop's navigation.

Object Model

WebNavPane Class

Syntax

Visual Basic (Declaration)
Public Class WebNavPane
   Inherits ISNet.WebUI.ISNetControl
   Implements ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, ISNet.WebUI.ITemplateSync
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
C#
public class WebNavPane : ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, ISNet.WebUI.ITemplateSync

Remarks

WebNavPane consists of main user interface elements, which are Header, Content, BarResizer, Bars, and Footer.

You can use WebNavPane control to quickly create rich and fully-functional Outlook-like navigation user interface in a professional way. WebNavPane is designed with elegant architecture and object model as well as specialized user interface for each element. As a result, you do not need to do any workarounds in order to achieve a modern navigation control which is rich in styles, functions and behaviors.

WebNavPane enhances user experience through resizable Bars. It allows your users resize the bar to determine how many bars should be visible in the navigation control. WebNavPane will automatically manage the available bars and collapse them in the Footer section as users drag the ResizerGrip to the bottom way. WebNavPane also maintain every states of the Bar, such as the currently ActiveBar and properly restore them whether the bar is collapsed or restored.

WebNavPane increases developer's productivity through advanced flexibility and extensibility. It sets a new standard in navigation user interface by providing advanced features for greater flexibility and extensibility. You can choose one of three ContentMode for each Bar's contents, or having all of them to use the global setting specified in BarSettings.

Example

The sample codes below show you how to load NavPane structure programmatically. You need to put the following codes at Page_Load
C# Copy Code
// initialize navPane
ISNet.WebUI.WebDesktop.WebNavPane navPane = (ISNet.WebUI.WebDesktop.WebNavPane)WebPaneManager1.FindControl("WebNavPane1");

// initialize navBar
ISNet.WebUI.WebDesktop.WebNavBar navBar = new ISNet.WebUI.WebDesktop.WebNavBar();

// initialize navBar
ItemISNet.WebUI.WebDesktop.WebNavBarItem navBarItem = new ISNet.WebUI.WebDesktop.WebNavBarItem();

// configure navBarItem's settings
navBarItem.Name = "itmBarItem1";
navBarItem.Text = "Item 1";
navBarItem.Image = "~/Images/Home.gif";
navBarItem.DisplayMode = ISNet.WebUI.WebDesktop.DisplayMode.TextAndImage;

// configure navBar's settings
navBar.Name = "wnbBar1";
navBar.Text = "NavBar 1";
navBar.Image = "~/Images/S_Cust-24.gif";
navBar.CaptionDisplayMode = ISNet.WebUI.WebDesktop.DisplayMode.TextAndImage;

// add navBarItem to navBar Item's Collection
navBar.Items.Add(navBarItem);
// add navBar to navNape Bar's Collection
navPane.Bars.Add(navBar);

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
ISNet.WebUI.ISNetControl
ISNet.WebUI.WebDesktop.WebNavPane
ISNet.WebUI.WebDesktop.WebExplorerPane

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Members
ISNet.WebUI.WebDesktop Namespace

Tasks

Creating Simple NavPane

tasks

Creating NavPane With Images
Loading NavPane Structure Programmatically

Concepts

WebNavPane Overview

concepts

Understanding Concepts
WebNavPane Features


WebNavPane Class Members

[image]
Intersoft WebDesktop Documentation
WebNavPane Class Members
See Also Properties Methods Events Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNavPane Class

Glossary Item Box

The following tables list the members exposed by WebNavPane.

Public Constructors

 | Name | Description
Public Constructor | WebNavPane Constructor |
Top

Public Properties

 | Name | Description
Public Property | AccessKey | Keyboard shortcut used by the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ActiveBarIndex | Gets or sets the active NavBar index.
Public Property | AllowResize | Specify whether the bar can be resized (apply to Outlook2003 type)
Public Property | AutoPostBack | Specifies whether the navbar or navbar_item should perform autopostback automatically when clicked.
Public Property | BackColor | Overridden. Color of the background of the control.
Public Property | BarItemSettings | Contains NavBarItem settings such as ItemStyle, ItemsPlaceholderStyle, DisplayMode and ImagePosition.
Public Property | Bars | Gets or sets the collection of WebNavBar.
Public Property | BarSettings | Contains NavBar settings such as BarStyle, CaptionStyle, ContentMode and ImageSize.
Public Property | BarVisible | Gets or sets the number of visible bar.
Public Property | BorderColor | Overridden. Color of the border around the control.
Public Property | BorderStyle | Overridden. Style of the border around the control.
Public Property | BorderWidth | Overridden. Width of the border around the control.
Public Property | CausesValidation |
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Enabled | Enable state of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableManagedTheming | Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to False, this control will not apply the style defined in Theme Architecture. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | Whether the control automatically saves its state for use in round-trips. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). (Inherited from ISNet.WebUI.ISNetControl)
Public Property | FooterSettings | Gets or sets footer settings. The settings are applicable when WebNavType is set to Outlook2003.
Public Property | FrameStyle | Gets or sets the style applied to Frame.
Public Property | GripImage |
Public Property | GripStyle | Gets or sets the style of the grip.
Public Property | Height | Overridden.
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ImagesDirectory | Gets or sets the location of images used to render the control.
Public Property | NavType | Gets or sets the type of WebNavPane.
Public Property | OnBarClick | Gets or sets the javascript function to invoke when the NavBar is clicked.
Public Property | OnBarItemClick | Gets or sets the javascript function to invoke when the NavBarItem is clicked.
Public Property | OnClientUnload | Gets or sets the javascript function to invoke when the NavPane is unload.
Public Property | OnInitialize | Gets or sets the javascript function to invoke when the NavPane is initialized.
Public Property | OnPaneResize | Gets or sets the javascript function to invoke when the NavPane is resized.
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RenderAsListBox |
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden. Gets or sets the directory where all required scripts for the control are stored.
Public Property | SharedScriptDirectory | Overridden.
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ToolTip | The tooltip displayed when the mouse is over the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ValidationGroup |
Public Property | ViewStateItems | Gets or sets the items to be stored in view state storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | Gets or sets the server connection string for file server-based viewstate storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | Gets or sets the location to store the viewstate of this control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | Indicates whether the control is visible and rendered. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Width | Overridden. The width of the control.
Public Property | XmlCompressionEnabled | Specifies whether the Xml used for clientside state storage should be compressed. (Inherited from ISNet.WebUI.ISNetControl)
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CheckConstrains | Overridden.
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. Overridden.
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadBarsStructureFromXml | Overloaded.
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPostData | Overridden.
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RecreateChildControls |
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveBarsStructureToXml | Overloaded.
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SynchronizeTemplatesFrom |
Top

Public Events

 | Name | Description
Public Event | ActiveBarChanged | Occurs when the active bar in WebNavPane is changed.
Public Event | ActiveBarItemChanged | Occurs when the active bar item in WebNavPane is changed.
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebNavPane Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Creating Simple NavPane

tasks

Creating NavPane With Images
Loading NavPane Structure Programmatically

Concepts

WebNavPane Overview

concepts

Understanding Concepts
WebNavPane Features


WebNavPane Constructor

[image]
Intersoft WebDesktop Documentation
WebNavPane Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : WebNavPane Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebNavPane()
C#
public WebNavPane()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


ApplyStyle Method

[image]
Intersoft WebDesktop Documentation
ApplyStyle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : ApplyStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ApplyStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim s As System.Web.UI.WebControls.Style

instance.ApplyStyle(s)
C#
public void ApplyStyle(
   System.Web.UI.WebControls.Style s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


ApplyStyleSheetSkin Method

[image]
Intersoft WebDesktop Documentation
ApplyStyleSheetSkin Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : ApplyStyleSheetSkin Method

page

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub ApplyStyleSheetSkin( _
   ByVal page As System.Web.UI.Page _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim page As System.Web.UI.Page

instance.ApplyStyleSheetSkin(page)
C#
public virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page page
)

Parameters

page

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


CanUseWebResources Method

[image]
Intersoft WebDesktop Documentation
CanUseWebResources Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : CanUseWebResources Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CanUseWebResources() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As Boolean

value = instance.CanUseWebResources()
C#
public bool CanUseWebResources()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


WebNavPane Class Methods

[image]
Intersoft WebDesktop Documentation
WebNavPane Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNavPane Class

Glossary Item Box

For a list of all members of this type, see WebNavPane members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CheckConstrains | Overridden.
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. Overridden.
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadBarsStructureFromXml | Overloaded.
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPostData | Overridden.
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RecreateChildControls |
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveBarsStructureToXml | Overloaded.
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SynchronizeTemplatesFrom |
Top

See Also

Reference

WebNavPane Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Creating Simple NavPane

tasks

Creating NavPane With Images
Loading NavPane Structure Programmatically

Concepts

WebNavPane Overview

concepts

Understanding Concepts
WebNavPane Features


CheckConstrains Method

[image]
Intersoft WebDesktop Documentation
CheckConstrains Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : CheckConstrains Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub CheckConstrains()
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane

instance.CheckConstrains()
C#
public override void CheckConstrains()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


CopyBaseAttributes Method

[image]
Intersoft WebDesktop Documentation
CopyBaseAttributes Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : CopyBaseAttributes Method

controlSrc

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyBaseAttributes( _
   ByVal controlSrc As System.Web.UI.WebControls.WebControl _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim controlSrc As System.Web.UI.WebControls.WebControl

instance.CopyBaseAttributes(controlSrc)
C#
public void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl controlSrc
)

Parameters

controlSrc

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object,Boolean) |
CopyFrom(Object) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public override void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members
Overload List


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members
Overload List


DataBind Method

[image]
Intersoft WebDesktop Documentation
DataBind Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : DataBind Method

Glossary Item Box

Overload List

Overload | Description
DataBind | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


DataBind() Method

[image]
Intersoft WebDesktop Documentation
DataBind() Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : DataBind() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub DataBind()
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane

instance.DataBind()
C#
public virtual void DataBind()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


Dispose Method

[image]
Intersoft WebDesktop Documentation
Dispose Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : Dispose Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane

instance.Dispose()
C#
public virtual void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


FindControl Method

[image]
Intersoft WebDesktop Documentation
FindControl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : FindControl Method

Glossary Item Box

Overload List

Overload | Description
FindControl | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


FindControl(String) Method

[image]
Intersoft WebDesktop Documentation
FindControl(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : FindControl(String) Method

id

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function FindControl( _
   ByVal id As String _
) As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim id As String
Dim value As System.Web.UI.Control

value = instance.FindControl(id)
C#
public virtual System.Web.UI.Control FindControl(
   string id
)

Parameters

id

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


Focus Method

[image]
Intersoft WebDesktop Documentation
Focus Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : Focus Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Focus()
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane

instance.Focus()
C#
public virtual void Focus()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


ForceDisableXmlCompression Method

[image]
Intersoft WebDesktop Documentation
ForceDisableXmlCompression Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : ForceDisableXmlCompression Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ForceDisableXmlCompression()
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane

instance.ForceDisableXmlCompression()
C#
public void ForceDisableXmlCompression()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


GetCurrentControlLifeCycle Method

[image]
Intersoft WebDesktop Documentation
GetCurrentControlLifeCycle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : GetCurrentControlLifeCycle Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentControlLifeCycle() As ISNet.WebUI.ControlLifeCycle
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As ISNet.WebUI.ControlLifeCycle

value = instance.GetCurrentControlLifeCycle()
C#
public ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


GetCurrentTheme Method

[image]
Intersoft WebDesktop Documentation
GetCurrentTheme Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : GetCurrentTheme Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentTheme() As ISNet.WebUI.ThemeInfo
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As ISNet.WebUI.ThemeInfo

value = instance.GetCurrentTheme()
C#
public ISNet.WebUI.ThemeInfo GetCurrentTheme()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


GetFrameworkDataFolder Method

[image]
Intersoft WebDesktop Documentation
GetFrameworkDataFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : GetFrameworkDataFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkDataFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As String

value = instance.GetFrameworkDataFolder()
C#
public string GetFrameworkDataFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


GetFrameworkFolder Method

[image]
Intersoft WebDesktop Documentation
GetFrameworkFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : GetFrameworkFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As String

value = instance.GetFrameworkFolder()
C#
public string GetFrameworkFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


GetFrameworkVersion Method

[image]
Intersoft WebDesktop Documentation
GetFrameworkVersion Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : GetFrameworkVersion Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkVersion() As Version
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As Version

value = instance.GetFrameworkVersion()
C#
public Version GetFrameworkVersion()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


GetIntersoftFolder Method

[image]
Intersoft WebDesktop Documentation
GetIntersoftFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : GetIntersoftFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetIntersoftFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As String

value = instance.GetIntersoftFolder()
C#
public string GetIntersoftFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


GetLayoutFolder Method

[image]
Intersoft WebDesktop Documentation
GetLayoutFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : GetLayoutFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetLayoutFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As String

value = instance.GetLayoutFolder()
C#
public string GetLayoutFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


GetPostedXMLData Method

[image]
Intersoft WebDesktop Documentation
GetPostedXMLData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : GetPostedXMLData Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPostedXMLData() As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As String

value = instance.GetPostedXMLData()
C#
public string GetPostedXMLData()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


GetProductInfoKey Method

[image]
Intersoft WebDesktop Documentation
GetProductInfoKey Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : GetProductInfoKey Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductInfoKey() As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As String

value = instance.GetProductInfoKey()
C#
public string GetProductInfoKey()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


GetProductSimpleName Method

[image]
Intersoft WebDesktop Documentation
GetProductSimpleName Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : GetProductSimpleName Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductSimpleName() As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As String

value = instance.GetProductSimpleName()
C#
public string GetProductSimpleName()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


GetPropertyValue Method

[image]
Intersoft WebDesktop Documentation
GetPropertyValue Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : GetPropertyValue Method

defValue
propValue
webConfigKey

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPropertyValue( _
   ByVal defValue As String, _
   ByVal propValue As String, _
   ByVal webConfigKey As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim defValue As String
Dim propValue As String
Dim webConfigKey As String
Dim value As String

value = instance.GetPropertyValue(defValue, propValue, webConfigKey)
C#
public string GetPropertyValue(
   string defValue,
   string propValue,
   string webConfigKey
)

Parameters

defValue
propValue
webConfigKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


GetResourceStream Method

[image]
Intersoft WebDesktop Documentation
GetResourceStream Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : GetResourceStream Method

resourceUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetResourceStream( _
   ByVal resourceUrl As String _
) As System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim resourceUrl As String
Dim value As System.IO.Stream

value = instance.GetResourceStream(resourceUrl)
C#
public System.IO.Stream GetResourceStream(
   string resourceUrl
)

Parameters

resourceUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


GetRouteUrl Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : GetRouteUrl Method

Glossary Item Box

Overload List

Overload | Description
GetRouteUrl(Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(RouteValueDictionary) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,RouteValueDictionary) | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


GetRouteUrl(Object) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class > GetRouteUrl Method : GetRouteUrl(Object) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As Object _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim routeParameters As Object
Dim value As String

value = instance.GetRouteUrl(routeParameters)
C#
public string GetRouteUrl(
   object routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members
Overload List


GetRouteUrl(String,Object) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(String,Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class > GetRouteUrl Method : GetRouteUrl(String,Object) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As String, _
   ByVal routeParameters As Object _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim routeName As String
Dim routeParameters As Object
Dim value As String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public string GetRouteUrl(
   string routeName,
   object routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members
Overload List


GetRouteUrl(RouteValueDictionary) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(RouteValueDictionary) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class > GetRouteUrl Method : GetRouteUrl(RouteValueDictionary) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As String

value = instance.GetRouteUrl(routeParameters)
C#
public string GetRouteUrl(
   System.Web.Routing.RouteValueDictionary routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members
Overload List


GetRouteUrl(String,RouteValueDictionary) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(String,RouteValueDictionary) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class > GetRouteUrl Method : GetRouteUrl(String,RouteValueDictionary) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As String, _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim routeName As String
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public string GetRouteUrl(
   string routeName,
   System.Web.Routing.RouteValueDictionary routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members
Overload List


GetUniqueIDRelativeTo Method

[image]
Intersoft WebDesktop Documentation
GetUniqueIDRelativeTo Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : GetUniqueIDRelativeTo Method

control

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetUniqueIDRelativeTo( _
   ByVal control As System.Web.UI.Control _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim control As System.Web.UI.Control
Dim value As String

value = instance.GetUniqueIDRelativeTo(control)
C#
public string GetUniqueIDRelativeTo(
   System.Web.UI.Control control
)

Parameters

control

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


HasControls Method

[image]
Intersoft WebDesktop Documentation
HasControls Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : HasControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function HasControls() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As Boolean

value = instance.HasControls()
C#
public virtual bool HasControls()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


IsAtlasCallback Method

[image]
Intersoft WebDesktop Documentation
IsAtlasCallback Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : IsAtlasCallback Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsAtlasCallback() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As Boolean

value = instance.IsAtlasCallback()
C#
public bool IsAtlasCallback()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


IsBetaRelease Method

[image]
Intersoft WebDesktop Documentation
IsBetaRelease Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : IsBetaRelease Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsBetaRelease() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As Boolean

value = instance.IsBetaRelease()
C#
public bool IsBetaRelease()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


IsChromeBrowser Method

[image]
Intersoft WebDesktop Documentation
IsChromeBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : IsChromeBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsChromeBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As Boolean

value = instance.IsChromeBrowser()
C#
public bool IsChromeBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


IsFlyPostBackControl Method

[image]
Intersoft WebDesktop Documentation
IsFlyPostBackControl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : IsFlyPostBackControl Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackControl() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As Boolean

value = instance.IsFlyPostBackControl()
C#
public virtual bool IsFlyPostBackControl()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


IsFlyPostBackRequest Method

[image]
Intersoft WebDesktop Documentation
IsFlyPostBackRequest Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : IsFlyPostBackRequest Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackRequest() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As Boolean

value = instance.IsFlyPostBackRequest()
C#
public virtual bool IsFlyPostBackRequest()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


IsGeckoBasedBrowser Method

[image]
Intersoft WebDesktop Documentation
IsGeckoBasedBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : IsGeckoBasedBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoBasedBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As Boolean

value = instance.IsGeckoBasedBrowser()
C#
public bool IsGeckoBasedBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


IsGeckoVersion18 Method

[image]
Intersoft WebDesktop Documentation
IsGeckoVersion18 Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : IsGeckoVersion18 Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoVersion18() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As Boolean

value = instance.IsGeckoVersion18()
C#
public bool IsGeckoVersion18()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


IsInDesignMode Method

[image]
Intersoft WebDesktop Documentation
IsInDesignMode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : IsInDesignMode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInDesignMode() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As Boolean

value = instance.IsInDesignMode()
C#
public bool IsInDesignMode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


IsInternetExplorer8Browser Method

[image]
Intersoft WebDesktop Documentation
IsInternetExplorer8Browser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : IsInternetExplorer8Browser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorer8Browser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As Boolean

value = instance.IsInternetExplorer8Browser()
C#
public bool IsInternetExplorer8Browser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


IsInternetExplorerBrowser Method

[image]
Intersoft WebDesktop Documentation
IsInternetExplorerBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : IsInternetExplorerBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorerBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As Boolean

value = instance.IsInternetExplorerBrowser()
C#
public bool IsInternetExplorerBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


IsOperaBrowser Method

[image]
Intersoft WebDesktop Documentation
IsOperaBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : IsOperaBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsOperaBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As Boolean

value = instance.IsOperaBrowser()
C#
public bool IsOperaBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


IsSafariBrowser Method

[image]
Intersoft WebDesktop Documentation
IsSafariBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : IsSafariBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsSafariBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As Boolean

value = instance.IsSafariBrowser()
C#
public bool IsSafariBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


IsW3CStandardBrowser Method

[image]
Intersoft WebDesktop Documentation
IsW3CStandardBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : IsW3CStandardBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsW3CStandardBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As Boolean

value = instance.IsW3CStandardBrowser()
C#
public bool IsW3CStandardBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


LoadBarsStructureFromXml Method

[image]
Intersoft WebDesktop Documentation
LoadBarsStructureFromXml Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : LoadBarsStructureFromXml Method

Glossary Item Box

Overload List

Overload | Description
LoadBarsStructureFromXml(Stream) |
LoadBarsStructureFromXml(String) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


LoadBarsStructureFromXml(Stream) Method

[image]
Intersoft WebDesktop Documentation
LoadBarsStructureFromXml(Stream) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class > LoadBarsStructureFromXml Method : LoadBarsStructureFromXml(Stream) Method

stream

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadBarsStructureFromXml( _
   ByVal stream As System.IO.Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim stream As System.IO.Stream

instance.LoadBarsStructureFromXml(stream)
C#
public void LoadBarsStructureFromXml(
   System.IO.Stream stream
)

Parameters

stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members
Overload List


LoadBarsStructureFromXml(String) Method

[image]
Intersoft WebDesktop Documentation
LoadBarsStructureFromXml(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class > LoadBarsStructureFromXml Method : LoadBarsStructureFromXml(String) Method

fileName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadBarsStructureFromXml( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim fileName As String

instance.LoadBarsStructureFromXml(fileName)
C#
public void LoadBarsStructureFromXml(
   string fileName
)

Parameters

fileName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members
Overload List


LoadLayout Method

[image]
Intersoft WebDesktop Documentation
LoadLayout Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : LoadLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim settings As ISNet.WebUI.LayoutInfo

instance.LoadLayout(settings)
C#
public virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


LoadLayoutFromFile Method

[image]
Intersoft WebDesktop Documentation
LoadLayoutFromFile Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : LoadLayoutFromFile Method

filePath

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromFile( _
   ByVal filePath As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim filePath As String

instance.LoadLayoutFromFile(filePath)
C#
public virtual void LoadLayoutFromFile(
   string filePath
)

Parameters

filePath

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


LoadLayoutFromPredefinedName Method

[image]
Intersoft WebDesktop Documentation
LoadLayoutFromPredefinedName Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : LoadLayoutFromPredefinedName Method

predefinedName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromPredefinedName( _
   ByVal predefinedName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim predefinedName As String

instance.LoadLayoutFromPredefinedName(predefinedName)
C#
public virtual void LoadLayoutFromPredefinedName(
   string predefinedName
)

Parameters

predefinedName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


LoadLayoutFromStream Method

[image]
Intersoft WebDesktop Documentation
LoadLayoutFromStream Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : LoadLayoutFromStream Method

stream

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromStream( _
   ByVal stream As System.IO.Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim stream As System.IO.Stream

instance.LoadLayoutFromStream(stream)
C#
public virtual void LoadLayoutFromStream(
   System.IO.Stream stream
)

Parameters

stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


LoadPostData Method

[image]
Intersoft WebDesktop Documentation
LoadPostData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : LoadPostData Method

postDataKey
postCollection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function LoadPostData( _
   ByVal postDataKey As String, _
   ByVal postCollection As System.Collections.Specialized.NameValueCollection _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim postDataKey As String
Dim postCollection As System.Collections.Specialized.NameValueCollection
Dim value As Boolean

value = instance.LoadPostData(postDataKey, postCollection)
C#
public override bool LoadPostData(
   string postDataKey,
   System.Collections.Specialized.NameValueCollection postCollection
)

Parameters

postDataKey
postCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


MergeStyle Method

[image]
Intersoft WebDesktop Documentation
MergeStyle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : MergeStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub MergeStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim s As System.Web.UI.WebControls.Style

instance.MergeStyle(s)
C#
public void MergeStyle(
   System.Web.UI.WebControls.Style s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


OnInfoChanged Method

[image]
Intersoft WebDesktop Documentation
OnInfoChanged Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : OnInfoChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnInfoChanged( _
   ByVal e As ISNet.WebUI.SynchronizeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim e As ISNet.WebUI.SynchronizeEventArgs

instance.OnInfoChanged(e)
C#
public void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


OnPreInitialize Method

[image]
Intersoft WebDesktop Documentation
OnPreInitialize Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : OnPreInitialize Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnPreInitialize()
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane

instance.OnPreInitialize()
C#
public virtual void OnPreInitialize()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


RaisePostDataChangedEvent Method

[image]
Intersoft WebDesktop Documentation
RaisePostDataChangedEvent Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : RaisePostDataChangedEvent Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RaisePostDataChangedEvent()
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane

instance.RaisePostDataChangedEvent()
C#
public virtual void RaisePostDataChangedEvent()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


ReadWebConfigValue Method

[image]
Intersoft WebDesktop Documentation
ReadWebConfigValue Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : ReadWebConfigValue Method

key

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ReadWebConfigValue( _
   ByVal key As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim key As String
Dim value As String

value = instance.ReadWebConfigValue(key)
C#
public string ReadWebConfigValue(
   string key
)

Parameters

key

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


RecreateChildControls Method

[image]
Intersoft WebDesktop Documentation
RecreateChildControls Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : RecreateChildControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RecreateChildControls()
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane

instance.RecreateChildControls()
C#
public void RecreateChildControls()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


RegisterBoxSizing Method

[image]
Intersoft WebDesktop Documentation
RegisterBoxSizing Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : RegisterBoxSizing Method

Glossary Item Box

Overload List

Overload | Description
RegisterBoxSizing() | (Inherited from ISNet.WebUI.ISNetControl)
RegisterBoxSizing(Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


RegisterBoxSizing() Method

[image]
Intersoft WebDesktop Documentation
RegisterBoxSizing() Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class > RegisterBoxSizing Method : RegisterBoxSizing() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing()
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane

instance.RegisterBoxSizing()
C#
public void RegisterBoxSizing()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members
Overload List


RegisterBoxSizing(Boolean) Method

[image]
Intersoft WebDesktop Documentation
RegisterBoxSizing(Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class > RegisterBoxSizing Method : RegisterBoxSizing(Boolean) Method

forceAll

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing( _
   ByVal forceAll As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim forceAll As Boolean

instance.RegisterBoxSizing(forceAll)
C#
public void RegisterBoxSizing(
   bool forceAll
)

Parameters

forceAll

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members
Overload List


RegisterGlobalStyle Method

[image]
Intersoft WebDesktop Documentation
RegisterGlobalStyle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : RegisterGlobalStyle Method

style

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterGlobalStyle( _
   ByVal style As ISNet.WebUI.WebStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim style As ISNet.WebUI.WebStyle

instance.RegisterGlobalStyle(style)
C#
public void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle style
)

Parameters

style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


RegisterLink Method

[image]
Intersoft WebDesktop Documentation
RegisterLink Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : RegisterLink Method

name
url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterLink( _
   ByVal name As String, _
   ByVal url As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim name As String
Dim url As String

instance.RegisterLink(name, url)
C#
public void RegisterLink(
   string name,
   string url
)

Parameters

name
url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


RegisterOptimizedCssClasses Method

[image]
Intersoft WebDesktop Documentation
RegisterOptimizedCssClasses Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : RegisterOptimizedCssClasses Method

runtimeStyleOnly

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterOptimizedCssClasses( _
   ByVal runtimeStyleOnly As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim runtimeStyleOnly As Boolean

instance.RegisterOptimizedCssClasses(runtimeStyleOnly)
C#
public void RegisterOptimizedCssClasses(
   bool runtimeStyleOnly
)

Parameters

runtimeStyleOnly

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


RegisterPreloadImage Method

[image]
Intersoft WebDesktop Documentation
RegisterPreloadImage Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : RegisterPreloadImage Method

image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterPreloadImage( _
   ByVal image As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim image As String

instance.RegisterPreloadImage(image)
C#
public void RegisterPreloadImage(
   string image
)

Parameters

image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


RegisterSharePointHandler Method

[image]
Intersoft WebDesktop Documentation
RegisterSharePointHandler Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : RegisterSharePointHandler Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RegisterSharePointHandler()
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane

instance.RegisterSharePointHandler()
C#
public virtual void RegisterSharePointHandler()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


RenderBeginTag Method

[image]
Intersoft WebDesktop Documentation
RenderBeginTag Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : RenderBeginTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderBeginTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderBeginTag(writer)
C#
public virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


RenderControl Method

[image]
Intersoft WebDesktop Documentation
RenderControl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : RenderControl Method

Glossary Item Box

Overload List

Overload | Description
RenderControl | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


RenderControl(HtmlTextWriter) Method

[image]
Intersoft WebDesktop Documentation
RenderControl(HtmlTextWriter) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : RenderControl(HtmlTextWriter) Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderControl( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderControl(writer)
C#
public virtual void RenderControl(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


RenderEndTag Method

[image]
Intersoft WebDesktop Documentation
RenderEndTag Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : RenderEndTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderEndTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderEndTag(writer)
C#
public virtual void RenderEndTag(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


ResolveClientUrl Method

[image]
Intersoft WebDesktop Documentation
ResolveClientUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : ResolveClientUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveClientUrl( _
   ByVal relativeUrl As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim relativeUrl As String
Dim value As String

value = instance.ResolveClientUrl(relativeUrl)
C#
public string ResolveClientUrl(
   string relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


ResolveImagePath Method

[image]
Intersoft WebDesktop Documentation
ResolveImagePath Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : ResolveImagePath Method

folder
image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveImagePath( _
   ByVal folder As String, _
   ByVal image As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim folder As String
Dim image As String
Dim value As String

value = instance.ResolveImagePath(folder, image)
C#
public string ResolveImagePath(
   string folder,
   string image
)

Parameters

folder
image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


ResolveRelativeURL Method

[image]
Intersoft WebDesktop Documentation
ResolveRelativeURL Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : ResolveRelativeURL Method

url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ResolveRelativeURL( _
   ByVal url As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim url As String
Dim value As String

value = instance.ResolveRelativeURL(url)
C#
public virtual string ResolveRelativeURL(
   string url
)

Parameters

url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


ResolveResourceUrl Method

[image]
Intersoft WebDesktop Documentation
ResolveResourceUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : ResolveResourceUrl Method

kind
defaultFolder
currentFolder
resourceName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveResourceUrl( _
   ByVal kind As ISNet.WebUI.ResourceKind, _
   ByVal defaultFolder As String, _
   ByVal currentFolder As String, _
   ByVal resourceName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim kind As ISNet.WebUI.ResourceKind
Dim defaultFolder As String
Dim currentFolder As String
Dim resourceName As String
Dim value As String

value = instance.ResolveResourceUrl(kind, defaultFolder, currentFolder, resourceName)
C#
public string ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   string defaultFolder,
   string currentFolder,
   string resourceName
)

Parameters

kind
defaultFolder
currentFolder
resourceName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


ResolveUrl Method

[image]
Intersoft WebDesktop Documentation
ResolveUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : ResolveUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveUrl( _
   ByVal relativeUrl As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim relativeUrl As String
Dim value As String

value = instance.ResolveUrl(relativeUrl)
C#
public string ResolveUrl(
   string relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


SaveBarsStructureToXml Method

[image]
Intersoft WebDesktop Documentation
SaveBarsStructureToXml Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : SaveBarsStructureToXml Method

Glossary Item Box

Overload List

Overload | Description
SaveBarsStructureToXml(String) |
SaveBarsStructureToXml() |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


SaveBarsStructureToXml(String) Method

[image]
Intersoft WebDesktop Documentation
SaveBarsStructureToXml(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class > SaveBarsStructureToXml Method : SaveBarsStructureToXml(String) Method

fileName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub SaveBarsStructureToXml( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim fileName As String

instance.SaveBarsStructureToXml(fileName)
C#
public void SaveBarsStructureToXml(
   string fileName
)

Parameters

fileName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members
Overload List


SaveBarsStructureToXml() Method

[image]
Intersoft WebDesktop Documentation
SaveBarsStructureToXml() Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class > SaveBarsStructureToXml Method : SaveBarsStructureToXml() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function SaveBarsStructureToXml() As System.Xml.XmlDocument
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As System.Xml.XmlDocument

value = instance.SaveBarsStructureToXml()
C#
public System.Xml.XmlDocument SaveBarsStructureToXml()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members
Overload List


SaveLayout Method

[image]
Intersoft WebDesktop Documentation
SaveLayout Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : SaveLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim settings As ISNet.WebUI.LayoutInfo

instance.SaveLayout(settings)
C#
public virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


SaveLayoutToFile Method

[image]
Intersoft WebDesktop Documentation
SaveLayoutToFile Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : SaveLayoutToFile Method

filePath
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToFile( _
   ByVal filePath As String, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim filePath As String
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToFile(filePath, saveOptions)
C#
public virtual void SaveLayoutToFile(
   string filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

filePath
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


SaveLayoutToStream Method

[image]
Intersoft WebDesktop Documentation
SaveLayoutToStream Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : SaveLayoutToStream Method

stream
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToStream( _
   ByVal stream As System.IO.Stream, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim stream As System.IO.Stream
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToStream(stream, saveOptions)
C#
public virtual void SaveLayoutToStream(
   System.IO.Stream stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

stream
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


SetRenderMethodDelegate Method

[image]
Intersoft WebDesktop Documentation
SetRenderMethodDelegate Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : SetRenderMethodDelegate Method

renderMethod

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetRenderMethodDelegate( _
   ByVal renderMethod As System.Web.UI.RenderMethod _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim renderMethod As System.Web.UI.RenderMethod

instance.SetRenderMethodDelegate(renderMethod)
C#
public void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod renderMethod
)

Parameters

renderMethod

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


SetSessionTheme Method

[image]
Intersoft WebDesktop Documentation
SetSessionTheme Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : SetSessionTheme Method

themeInfo

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetSessionTheme( _
   ByVal themeInfo As ISNet.WebUI.ThemeInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim themeInfo As ISNet.WebUI.ThemeInfo

instance.SetSessionTheme(themeInfo)
C#
public void SetSessionTheme(
   ISNet.WebUI.ThemeInfo themeInfo
)

Parameters

themeInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


ShouldReturnJson Method

[image]
Intersoft WebDesktop Documentation
ShouldReturnJson Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : ShouldReturnJson Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ShouldReturnJson() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As Boolean

value = instance.ShouldReturnJson()
C#
public virtual bool ShouldReturnJson()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


SynchronizeTemplatesFrom Method

[image]
Intersoft WebDesktop Documentation
SynchronizeTemplatesFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : SynchronizeTemplatesFrom Method

sourceObj

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SynchronizeTemplatesFrom( _
   ByVal sourceObj As ISNet.WebUI.ISNetControl _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim sourceObj As ISNet.WebUI.ISNetControl

instance.SynchronizeTemplatesFrom(sourceObj)
C#
public virtual void SynchronizeTemplatesFrom(
   ISNet.WebUI.ISNetControl sourceObj
)

Parameters

sourceObj

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


AccessKey Property

[image]
Intersoft WebDesktop Documentation
AccessKey Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : AccessKey Property

Glossary Item Box

Keyboard shortcut used by the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property AccessKey As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As String

instance.AccessKey = value

value = instance.AccessKey
C#
public virtual string AccessKey {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


WebNavPane Class Properties

[image]
Intersoft WebDesktop Documentation
WebNavPane Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNavPane Class

Glossary Item Box

For a list of all members of this type, see WebNavPane members.

Public Properties

 | Name | Description
Public Property | AccessKey | Keyboard shortcut used by the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ActiveBarIndex | Gets or sets the active NavBar index.
Public Property | AllowResize | Specify whether the bar can be resized (apply to Outlook2003 type)
Public Property | AutoPostBack | Specifies whether the navbar or navbar_item should perform autopostback automatically when clicked.
Public Property | BackColor | Overridden. Color of the background of the control.
Public Property | BarItemSettings | Contains NavBarItem settings such as ItemStyle, ItemsPlaceholderStyle, DisplayMode and ImagePosition.
Public Property | Bars | Gets or sets the collection of WebNavBar.
Public Property | BarSettings | Contains NavBar settings such as BarStyle, CaptionStyle, ContentMode and ImageSize.
Public Property | BarVisible | Gets or sets the number of visible bar.
Public Property | BorderColor | Overridden. Color of the border around the control.
Public Property | BorderStyle | Overridden. Style of the border around the control.
Public Property | BorderWidth | Overridden. Width of the border around the control.
Public Property | CausesValidation |
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Enabled | Enable state of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableManagedTheming | Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to False, this control will not apply the style defined in Theme Architecture. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | Whether the control automatically saves its state for use in round-trips. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). (Inherited from ISNet.WebUI.ISNetControl)
Public Property | FooterSettings | Gets or sets footer settings. The settings are applicable when WebNavType is set to Outlook2003.
Public Property | FrameStyle | Gets or sets the style applied to Frame.
Public Property | GripImage |
Public Property | GripStyle | Gets or sets the style of the grip.
Public Property | Height | Overridden.
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ImagesDirectory | Gets or sets the location of images used to render the control.
Public Property | NavType | Gets or sets the type of WebNavPane.
Public Property | OnBarClick | Gets or sets the javascript function to invoke when the NavBar is clicked.
Public Property | OnBarItemClick | Gets or sets the javascript function to invoke when the NavBarItem is clicked.
Public Property | OnClientUnload | Gets or sets the javascript function to invoke when the NavPane is unload.
Public Property | OnInitialize | Gets or sets the javascript function to invoke when the NavPane is initialized.
Public Property | OnPaneResize | Gets or sets the javascript function to invoke when the NavPane is resized.
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RenderAsListBox |
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden. Gets or sets the directory where all required scripts for the control are stored.
Public Property | SharedScriptDirectory | Overridden.
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ToolTip | The tooltip displayed when the mouse is over the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ValidationGroup |
Public Property | ViewStateItems | Gets or sets the items to be stored in view state storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | Gets or sets the server connection string for file server-based viewstate storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | Gets or sets the location to store the viewstate of this control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | Indicates whether the control is visible and rendered. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Width | Overridden. The width of the control.
Public Property | XmlCompressionEnabled | Specifies whether the Xml used for clientside state storage should be compressed. (Inherited from ISNet.WebUI.ISNetControl)
Top

See Also

Reference

WebNavPane Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Creating Simple NavPane

tasks

Creating NavPane With Images
Loading NavPane Structure Programmatically

Concepts

WebNavPane Overview

concepts

Understanding Concepts
WebNavPane Features


WebNavPane Constructor

[image]
Intersoft WebDesktop Documentation
WebNavPane Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : WebNavPane Constructor

Glossary Item Box

Initializes a new instance of the WebNavPane class.

Overload List

Overload | Description
WebNavPane Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


ActiveBarIndex Property

[image]
Intersoft WebDesktop Documentation
ActiveBarIndex Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : ActiveBarIndex Property

Glossary Item Box

Gets or sets the active NavBar index.

Syntax

Visual Basic (Declaration)
Public Overridable Property ActiveBarIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As Integer

instance.ActiveBarIndex = value

value = instance.ActiveBarIndex
C#
public virtual int ActiveBarIndex {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


AllowResize Property

[image]
Intersoft WebDesktop Documentation
AllowResize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : AllowResize Property

Glossary Item Box

Specify whether the bar can be resized (apply to Outlook2003 type)

Syntax

Visual Basic (Declaration)
Public Overridable Property AllowResize As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As Boolean

instance.AllowResize = value

value = instance.AllowResize
C#
public virtual bool AllowResize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


AutoPostBack Property

[image]
Intersoft WebDesktop Documentation
AutoPostBack Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : AutoPostBack Property

Glossary Item Box

Specifies whether the navbar or navbar_item should perform autopostback automatically when clicked.

Syntax

Visual Basic (Declaration)
Public Overridable Property AutoPostBack As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As Boolean

instance.AutoPostBack = value

value = instance.AutoPostBack
C#
public virtual bool AutoPostBack {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


BackColor Property

[image]
Intersoft WebDesktop Documentation
BackColor Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : BackColor Property

Glossary Item Box

Color of the background of the control.

Syntax

Visual Basic (Declaration)
Public Overrides Property BackColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
C#
public override System.Drawing.Color BackColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


BarItemSettings Property

[image]
Intersoft WebDesktop Documentation
BarItemSettings Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : BarItemSettings Property

Glossary Item Box

Contains NavBarItem settings such as ItemStyle, ItemsPlaceholderStyle, DisplayMode and ImagePosition.

Syntax

Visual Basic (Declaration)
Public Overridable Property BarItemSettings As WebNavPaneItemSettings
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As WebNavPaneItemSettings

instance.BarItemSettings = value

value = instance.BarItemSettings
C#
public virtual WebNavPaneItemSettings BarItemSettings {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


Bars Property

[image]
Intersoft WebDesktop Documentation
Bars Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : Bars Property

Glossary Item Box

Gets or sets the collection of WebNavBar.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Bars As WebNavBarCollection
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As WebNavBarCollection

value = instance.Bars
C#
public virtual WebNavBarCollection Bars {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


BarSettings Property

[image]
Intersoft WebDesktop Documentation
BarSettings Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : BarSettings Property

Glossary Item Box

Contains NavBar settings such as BarStyle, CaptionStyle, ContentMode and ImageSize.

Syntax

Visual Basic (Declaration)
Public Overridable Property BarSettings As WebNavBarSettings
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As WebNavBarSettings

instance.BarSettings = value

value = instance.BarSettings
C#
public virtual WebNavBarSettings BarSettings {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members

Concepts

WebNavPane Concepts


BarVisible Property

[image]
Intersoft WebDesktop Documentation
BarVisible Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : BarVisible Property

Glossary Item Box

Gets or sets the number of visible bar.

Syntax

Visual Basic (Declaration)
Public Overridable Property BarVisible As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As Integer

instance.BarVisible = value

value = instance.BarVisible
C#
public virtual int BarVisible {get; set;}

Remarks

By default, all bars are set to be visible (BarVisible = -1).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


BorderColor Property

[image]
Intersoft WebDesktop Documentation
BorderColor Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : BorderColor Property

Glossary Item Box

Color of the border around the control.

Syntax

Visual Basic (Declaration)
Public Overrides Property BorderColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As System.Drawing.Color

instance.BorderColor = value

value = instance.BorderColor
C#
public override System.Drawing.Color BorderColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


BorderStyle Property

[image]
Intersoft WebDesktop Documentation
BorderStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : BorderStyle Property

Glossary Item Box

Style of the border around the control.

Syntax

Visual Basic (Declaration)
Public Overrides Property BorderStyle As System.Web.UI.WebControls.BorderStyle
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As System.Web.UI.WebControls.BorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
C#
public override System.Web.UI.WebControls.BorderStyle BorderStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


BorderWidth Property

[image]
Intersoft WebDesktop Documentation
BorderWidth Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : BorderWidth Property

Glossary Item Box

Width of the border around the control.

Syntax

Visual Basic (Declaration)
Public Overrides Property BorderWidth As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As System.Web.UI.WebControls.Unit

instance.BorderWidth = value

value = instance.BorderWidth
C#
public override System.Web.UI.WebControls.Unit BorderWidth {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


CausesValidation Property

[image]
Intersoft WebDesktop Documentation
CausesValidation Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : CausesValidation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property CausesValidation As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As Boolean

instance.CausesValidation = value

value = instance.CausesValidation
C#
public bool CausesValidation {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


ClientIDMode Property

[image]
Intersoft WebDesktop Documentation
ClientIDMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : ClientIDMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ClientIDMode As System.Web.UI.ClientIDMode
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As System.Web.UI.ClientIDMode

instance.ClientIDMode = value

value = instance.ClientIDMode
C#
public virtual System.Web.UI.ClientIDMode ClientIDMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


ControlDataTransferFormat Property

[image]
Intersoft WebDesktop Documentation
ControlDataTransferFormat Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : ControlDataTransferFormat Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ControlDataTransferFormat As ISNet.WebUI.DataTransferFormat
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As ISNet.WebUI.DataTransferFormat

instance.ControlDataTransferFormat = value

value = instance.ControlDataTransferFormat
C#
public virtual ISNet.WebUI.DataTransferFormat ControlDataTransferFormat {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


Enabled Property

[image]
Intersoft WebDesktop Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : Enabled Property

Glossary Item Box

Enable state of the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property Enabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As Boolean

instance.Enabled = value

value = instance.Enabled
C#
public virtual bool Enabled {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


EnableManagedTheming Property

[image]
Intersoft WebDesktop Documentation
EnableManagedTheming Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : EnableManagedTheming Property

Glossary Item Box

Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to False, this control will not apply the style defined in Theme Architecture.

Syntax

Visual Basic (Declaration)
Public Overridable Property EnableManagedTheming As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As Boolean

instance.EnableManagedTheming = value

value = instance.EnableManagedTheming
C#
public virtual bool EnableManagedTheming {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


EnableTheming Property

[image]
Intersoft WebDesktop Documentation
EnableTheming Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : EnableTheming Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property EnableTheming As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As Boolean

instance.EnableTheming = value

value = instance.EnableTheming
C#
public virtual bool EnableTheming {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


EnableViewState Property

[image]
Intersoft WebDesktop Documentation
EnableViewState Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : EnableViewState Property

Glossary Item Box

Whether the control automatically saves its state for use in round-trips.

Syntax

Visual Basic (Declaration)
Public Overridable Property EnableViewState As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As Boolean

instance.EnableViewState = value

value = instance.EnableViewState
C#
public virtual bool EnableViewState {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


EnableWebResources Property

[image]
Intersoft WebDesktop Documentation
EnableWebResources Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : EnableWebResources Property

Glossary Item Box

Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory).

Syntax

Visual Basic (Declaration)
Public Property EnableWebResources As ISNet.WebUI.WebResourceType
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As ISNet.WebUI.WebResourceType

instance.EnableWebResources = value

value = instance.EnableWebResources
C#
public ISNet.WebUI.WebResourceType EnableWebResources {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


FooterSettings Property

[image]
Intersoft WebDesktop Documentation
FooterSettings Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : FooterSettings Property

Glossary Item Box

Gets or sets footer settings. The settings are applicable when WebNavType is set to Outlook2003.

Syntax

Visual Basic (Declaration)
Public Overridable Property FooterSettings As WebNavPaneFooterSettings
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As WebNavPaneFooterSettings

instance.FooterSettings = value

value = instance.FooterSettings
C#
public virtual WebNavPaneFooterSettings FooterSettings {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


FrameStyle Property

[image]
Intersoft WebDesktop Documentation
FrameStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : FrameStyle Property

Glossary Item Box

Gets or sets the style applied to Frame.

Syntax

Visual Basic (Declaration)
Public Property FrameStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As ISNet.WebUI.WebStyle

instance.FrameStyle = value

value = instance.FrameStyle
C#
public ISNet.WebUI.WebStyle FrameStyle {get; set;}

Remarks

WebNavPane allows you to customize most of the elements' styles by using strongly typed WebStyle and DynamicStyle properties listed in FrameStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


GripImage Property

[image]
Intersoft WebDesktop Documentation
GripImage Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : GripImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property GripImage As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As String

instance.GripImage = value

value = instance.GripImage
C#
public virtual string GripImage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


GripStyle Property

[image]
Intersoft WebDesktop Documentation
GripStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : GripStyle Property

Glossary Item Box

Gets or sets the style of the grip.

Syntax

Visual Basic (Declaration)
Public Overridable Property GripStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As ISNet.WebUI.DynamicStyle

instance.GripStyle = value

value = instance.GripStyle
C#
public virtual ISNet.WebUI.DynamicStyle GripStyle {get; set;}

Remarks

WebNavPane allows you to customize most of the elements' styles by using strongly typed WebStyle and DynamicStyle properties listed in GripStyle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


Height Property

[image]
Intersoft WebDesktop Documentation
Height Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : Height Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Property Height As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As System.Web.UI.WebControls.Unit

instance.Height = value

value = instance.Height
C#
public override System.Web.UI.WebControls.Unit Height {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


ID Property

[image]
Intersoft WebDesktop Documentation
ID Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : ID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ID As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As String

instance.ID = value

value = instance.ID
C#
public virtual string ID {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


ImagesDirectory Property

[image]
Intersoft WebDesktop Documentation
ImagesDirectory Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : ImagesDirectory Property

Glossary Item Box

Gets or sets the location of images used to render the control.

Syntax

Visual Basic (Declaration)
Public Property ImagesDirectory As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As String

instance.ImagesDirectory = value

value = instance.ImagesDirectory
C#
public string ImagesDirectory {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


NavType Property

[image]
Intersoft WebDesktop Documentation
NavType Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : NavType Property

Glossary Item Box

Gets or sets the type of WebNavPane.

Syntax

Visual Basic (Declaration)
Public Overridable Property NavType As WebNavType
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As WebNavType

instance.NavType = value

value = instance.NavType
C#
public virtual WebNavType NavType {get; set;}

Remarks

Currently the NavType in WebNavPane is using Outlook2003 Style, later on NavType is also planned to support WinXP Style and many other today's popular styles.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


OnBarClick Property

[image]
Intersoft WebDesktop Documentation
OnBarClick Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : OnBarClick Property

Glossary Item Box

Gets or sets the javascript function to invoke when the NavBar is clicked.

Syntax

Visual Basic (Declaration)
Public Overridable Property OnBarClick As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As String

instance.OnBarClick = value

value = instance.OnBarClick
C#
public virtual string OnBarClick {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members

Tasks

Handling Client Side Events

Concepts

WebNavPane Features


OnBarItemClick Property

[image]
Intersoft WebDesktop Documentation
OnBarItemClick Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : OnBarItemClick Property

Glossary Item Box

Gets or sets the javascript function to invoke when the NavBarItem is clicked.

Syntax

Visual Basic (Declaration)
Public Overridable Property OnBarItemClick As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As String

instance.OnBarItemClick = value

value = instance.OnBarItemClick
C#
public virtual string OnBarItemClick {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members

Tasks

Handling Client Side Events

Concepts

WebNavPane Features


OnClientUnload Property

[image]
Intersoft WebDesktop Documentation
OnClientUnload Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : OnClientUnload Property

Glossary Item Box

Gets or sets the javascript function to invoke when the NavPane is unload.

Syntax

Visual Basic (Declaration)
Public Overridable Property OnClientUnload As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As String

instance.OnClientUnload = value

value = instance.OnClientUnload
C#
public virtual string OnClientUnload {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members

Tasks

Handling Client Side Events

Concepts

WebNavPane Features


OnInitialize Property

[image]
Intersoft WebDesktop Documentation
OnInitialize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : OnInitialize Property

Glossary Item Box

Gets or sets the javascript function to invoke when the NavPane is initialized.

Syntax

Visual Basic (Declaration)
Public Overridable Property OnInitialize As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As String

instance.OnInitialize = value

value = instance.OnInitialize
C#
public virtual string OnInitialize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members

Tasks

Handling Client Side Events

Concepts

WebNavPane Features


OnPaneResize Property

[image]
Intersoft WebDesktop Documentation
OnPaneResize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : OnPaneResize Property

Glossary Item Box

Gets or sets the javascript function to invoke when the NavPane is resized.

Syntax

Visual Basic (Declaration)
Public Overridable Property OnPaneResize As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As String

instance.OnPaneResize = value

value = instance.OnPaneResize
C#
public virtual string OnPaneResize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members

Tasks

Handling Client Side Events

Concepts

WebNavPane Features


Page Property

[image]
Intersoft WebDesktop Documentation
Page Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : Page Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Page As System.Web.UI.Page
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As System.Web.UI.Page

instance.Page = value

value = instance.Page
C#
public virtual System.Web.UI.Page Page {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


RenderAsListBox Property

[image]
Intersoft WebDesktop Documentation
RenderAsListBox Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : RenderAsListBox Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property RenderAsListBox As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As Boolean

instance.RenderAsListBox = value

value = instance.RenderAsListBox
C#
public bool RenderAsListBox {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


RenderingMode Property

[image]
Intersoft WebDesktop Documentation
RenderingMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : RenderingMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property RenderingMode As ISNet.WebUI.RenderMode
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As ISNet.WebUI.RenderMode

instance.RenderingMode = value

value = instance.RenderingMode
C#
public virtual ISNet.WebUI.RenderMode RenderingMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


RuntimeLicenseKey Property

[image]
Intersoft WebDesktop Documentation
RuntimeLicenseKey Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : RuntimeLicenseKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property RuntimeLicenseKey As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As String

instance.RuntimeLicenseKey = value

value = instance.RuntimeLicenseKey
C#
public virtual string RuntimeLicenseKey {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


ScriptDirectory Property

[image]
Intersoft WebDesktop Documentation
ScriptDirectory Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : ScriptDirectory Property

Glossary Item Box

Gets or sets the directory where all required scripts for the control are stored.

Syntax

Visual Basic (Declaration)
Public Overrides Property ScriptDirectory As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As String

instance.ScriptDirectory = value

value = instance.ScriptDirectory
C#
public override string ScriptDirectory {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


SharedScriptDirectory Property

[image]
Intersoft WebDesktop Documentation
SharedScriptDirectory Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : SharedScriptDirectory Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Property SharedScriptDirectory As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As String

instance.SharedScriptDirectory = value

value = instance.SharedScriptDirectory
C#
public override string SharedScriptDirectory {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


SkinID Property

[image]
Intersoft WebDesktop Documentation
SkinID Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : SkinID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property SkinID As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As String

instance.SkinID = value

value = instance.SkinID
C#
public virtual string SkinID {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


TabIndex Property

[image]
Intersoft WebDesktop Documentation
TabIndex Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : TabIndex Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property TabIndex As Short
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As Short

instance.TabIndex = value

value = instance.TabIndex
C#
public virtual short TabIndex {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


ToolTip Property

[image]
Intersoft WebDesktop Documentation
ToolTip Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : ToolTip Property

Glossary Item Box

The tooltip displayed when the mouse is over the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property ToolTip As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As String

instance.ToolTip = value

value = instance.ToolTip
C#
public virtual string ToolTip {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


ValidateRequestMode Property

[image]
Intersoft WebDesktop Documentation
ValidateRequestMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : ValidateRequestMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ValidateRequestMode As System.Web.UI.ValidateRequestMode
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As System.Web.UI.ValidateRequestMode

instance.ValidateRequestMode = value

value = instance.ValidateRequestMode
C#
public virtual System.Web.UI.ValidateRequestMode ValidateRequestMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


ValidationGroup Property

[image]
Intersoft WebDesktop Documentation
ValidationGroup Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : ValidationGroup Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ValidationGroup As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As String

instance.ValidationGroup = value

value = instance.ValidationGroup
C#
public string ValidationGroup {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


ViewStateItems Property

[image]
Intersoft WebDesktop Documentation
ViewStateItems Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : ViewStateItems Property

Glossary Item Box

Gets or sets the items to be stored in view state storage.

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateItems As ISNet.WebUI.ViewStateItem
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As ISNet.WebUI.ViewStateItem

instance.ViewStateItems = value

value = instance.ViewStateItems
C#
public virtual ISNet.WebUI.ViewStateItem ViewStateItems {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


ViewStateMode Property

[image]
Intersoft WebDesktop Documentation
ViewStateMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : ViewStateMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateMode As System.Web.UI.ViewStateMode
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As System.Web.UI.ViewStateMode

instance.ViewStateMode = value

value = instance.ViewStateMode
C#
public virtual System.Web.UI.ViewStateMode ViewStateMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


ViewStateServerConnection Property

[image]
Intersoft WebDesktop Documentation
ViewStateServerConnection Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : ViewStateServerConnection Property

Glossary Item Box

Gets or sets the server connection string for file server-based viewstate storage.

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateServerConnection As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As String

instance.ViewStateServerConnection = value

value = instance.ViewStateServerConnection
C#
public virtual string ViewStateServerConnection {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


ViewStateStorage Property

[image]
Intersoft WebDesktop Documentation
ViewStateStorage Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : ViewStateStorage Property

Glossary Item Box

Gets or sets the location to store the viewstate of this control.

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateStorage As ISNet.WebUI.StateCacheStorage
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As ISNet.WebUI.StateCacheStorage

instance.ViewStateStorage = value

value = instance.ViewStateStorage
C#
public virtual ISNet.WebUI.StateCacheStorage ViewStateStorage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


Visible Property

[image]
Intersoft WebDesktop Documentation
Visible Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : Visible Property

Glossary Item Box

Indicates whether the control is visible and rendered.

Syntax

Visual Basic (Declaration)
Public Overridable Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public virtual bool Visible {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


Width Property

[image]
Intersoft WebDesktop Documentation
Width Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : Width Property

Glossary Item Box

The width of the control.

Syntax

Visual Basic (Declaration)
Public Overrides Property Width As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As System.Web.UI.WebControls.Unit

instance.Width = value

value = instance.Width
C#
public override System.Web.UI.WebControls.Unit Width {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


XmlCompressionEnabled Property

[image]
Intersoft WebDesktop Documentation
XmlCompressionEnabled Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : XmlCompressionEnabled Property

Glossary Item Box

Specifies whether the Xml used for clientside state storage should be compressed.

Syntax

Visual Basic (Declaration)
Public Overridable Property XmlCompressionEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim value As Boolean

instance.XmlCompressionEnabled = value

value = instance.XmlCompressionEnabled
C#
public virtual bool XmlCompressionEnabled {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


WebNavPane Class Events

[image]
Intersoft WebDesktop Documentation
WebNavPane Class Events
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNavPane Class

Glossary Item Box

For a list of all members of this type, see WebNavPane members.

Public Events

 | Name | Description
Public Event | ActiveBarChanged | Occurs when the active bar in WebNavPane is changed.
Public Event | ActiveBarItemChanged | Occurs when the active bar item in WebNavPane is changed.
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebNavPane Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Creating Simple NavPane

tasks

Creating NavPane With Images
Loading NavPane Structure Programmatically

Concepts

WebNavPane Overview

concepts

Understanding Concepts
WebNavPane Features


ActiveBarChanged Event

[image]
Intersoft WebDesktop Documentation
ActiveBarChanged Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : ActiveBarChanged Event

Glossary Item Box

Occurs when the active bar in WebNavPane is changed.

Syntax

Visual Basic (Declaration)
Public Event ActiveBarChanged As ActiveBarChangedDelegate
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim handler As ActiveBarChangedDelegate

AddHandler instance.ActiveBarChanged, handler
C#
public event ActiveBarChangedDelegate ActiveBarChanged

Event Data

The event handler receives an argument of type ActiveBarChangedEventArgs containing data related to this event. The following ActiveBarChangedEventArgs properties provide information specific to this event.

Property | Description
ActiveBar | Gets or sets the active NavBar.
NewIndex | Gets or sets the new NavBar index.
OldIndex | Gets or sets the old NavBar index.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


ActiveBarItemChanged Event

[image]
Intersoft WebDesktop Documentation
ActiveBarItemChanged Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : ActiveBarItemChanged Event

Glossary Item Box

Occurs when the active bar item in WebNavPane is changed.

Syntax

Visual Basic (Declaration)
Public Event ActiveBarItemChanged As ActiveBarItemChangedDelegate
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim handler As ActiveBarItemChangedDelegate

AddHandler instance.ActiveBarItemChanged, handler
C#
public event ActiveBarItemChangedDelegate ActiveBarItemChanged

Event Data

The event handler receives an argument of type ActiveBarItemChangedEventArgs containing data related to this event. The following ActiveBarItemChangedEventArgs properties provide information specific to this event.

Property | Description
ActiveBar | Gets or sets the active NavBarItem.
ActiveBarItem | Gets or sets the active NavBarItem.
NewIndex | Gets or sets the new NavBarItem index.
OldIndex | Gets or sets the old NavBarItem index.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


DataBinding Event

[image]
Intersoft WebDesktop Documentation
DataBinding Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : DataBinding Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event DataBinding As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim handler As EventHandler

AddHandler instance.DataBinding, handler
C#
public event EventHandler DataBinding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


Disposed Event

[image]
Intersoft WebDesktop Documentation
Disposed Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim handler As EventHandler

AddHandler instance.Disposed, handler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


Init Event

[image]
Intersoft WebDesktop Documentation
Init Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : Init Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Init As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim handler As EventHandler

AddHandler instance.Init, handler
C#
public event EventHandler Init

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


Load Event

[image]
Intersoft WebDesktop Documentation
Load Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : Load Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Load As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim handler As EventHandler

AddHandler instance.Load, handler
C#
public event EventHandler Load

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


PreInitialize Event

[image]
Intersoft WebDesktop Documentation
PreInitialize Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : PreInitialize Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event PreInitialize As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim handler As EventHandler

AddHandler instance.PreInitialize, handler
C#
public event EventHandler PreInitialize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


PreRender Event

[image]
Intersoft WebDesktop Documentation
PreRender Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : PreRender Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event PreRender As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim handler As EventHandler

AddHandler instance.PreRender, handler
C#
public event EventHandler PreRender

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


Unload Event

[image]
Intersoft WebDesktop Documentation
Unload Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPane Class : Unload Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Unload As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebNavPane
Dim handler As EventHandler

AddHandler instance.Unload, handler
C#
public event EventHandler Unload

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPane Class
WebNavPane Members


WebNavPaneFooterSettings Class

[image]
Intersoft WebDesktop Documentation
WebNavPaneFooterSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNavPaneFooterSettings Class

Glossary Item Box

Collection of footer settings in WebNavPane. The settings are applicable when NavType is set to Outlook 2003.

Object Model

WebNavPaneFooterSettings Class

Syntax

Visual Basic (Declaration)
Public Class WebNavPaneFooterSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebNavPaneFooterSettings
C#
public class WebNavPaneFooterSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebDesktop.WebNavPaneFooterSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPaneFooterSettings Members
ISNet.WebUI.WebDesktop Namespace


WebNavPaneFooterSettings Class Members

[image]
Intersoft WebDesktop Documentation
WebNavPaneFooterSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNavPaneFooterSettings Class

Glossary Item Box

The following tables list the members exposed by WebNavPaneFooterSettings.

Public Constructors

 | Name | Description
Public Constructor | WebNavPaneFooterSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | FooterStyle | Footer style (apply only to Outlook2003 type).
Public Property | ImageSize | Gets or sets the image size in the footer bar.
Public Property | Size | Gets or sets the size of the footer bar.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

WebNavPaneFooterSettings Class
ISNet.WebUI.WebDesktop Namespace


WebNavPaneFooterSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebNavPaneFooterSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPaneFooterSettings Class : WebNavPaneFooterSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebNavPaneFooterSettings()
C#
public WebNavPaneFooterSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPaneFooterSettings Class
WebNavPaneFooterSettings Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPaneFooterSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebNavPaneFooterSettings
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPaneFooterSettings Class
WebNavPaneFooterSettings Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPaneFooterSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPaneFooterSettings Class
WebNavPaneFooterSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPaneFooterSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavPaneFooterSettings
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPaneFooterSettings Class
WebNavPaneFooterSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPaneFooterSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavPaneFooterSettings
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPaneFooterSettings Class
WebNavPaneFooterSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPaneFooterSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavPaneFooterSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPaneFooterSettings Class
WebNavPaneFooterSettings Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPaneFooterSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebNavPaneFooterSettings
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPaneFooterSettings Class
WebNavPaneFooterSettings Members


WebNavPaneFooterSettings Class Methods

[image]
Intersoft WebDesktop Documentation
WebNavPaneFooterSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNavPaneFooterSettings Class

Glossary Item Box

For a list of all members of this type, see WebNavPaneFooterSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

WebNavPaneFooterSettings Class
ISNet.WebUI.WebDesktop Namespace


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPaneFooterSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavPaneFooterSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPaneFooterSettings Class
WebNavPaneFooterSettings Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPaneFooterSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNavPaneFooterSettings
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPaneFooterSettings Class
WebNavPaneFooterSettings Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPaneFooterSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebNavPaneFooterSettings

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPaneFooterSettings Class
WebNavPaneFooterSettings Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPaneFooterSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavPaneFooterSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPaneFooterSettings Class
WebNavPaneFooterSettings Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPaneFooterSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavPaneFooterSettings
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPaneFooterSettings Class
WebNavPaneFooterSettings Members


WebNavPaneFooterSettings Class Properties

[image]
Intersoft WebDesktop Documentation
WebNavPaneFooterSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNavPaneFooterSettings Class

Glossary Item Box

For a list of all members of this type, see WebNavPaneFooterSettings members.

Public Properties

 | Name | Description
Public Property | FooterStyle | Footer style (apply only to Outlook2003 type).
Public Property | ImageSize | Gets or sets the image size in the footer bar.
Public Property | Size | Gets or sets the size of the footer bar.
Top

See Also

Reference

WebNavPaneFooterSettings Class
ISNet.WebUI.WebDesktop Namespace


WebNavPaneFooterSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebNavPaneFooterSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPaneFooterSettings Class : WebNavPaneFooterSettings Constructor

Glossary Item Box

Initializes a new instance of the WebNavPaneFooterSettings class.

Overload List

Overload | Description
WebNavPaneFooterSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPaneFooterSettings Class
WebNavPaneFooterSettings Members


FooterStyle Property

[image]
Intersoft WebDesktop Documentation
FooterStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPaneFooterSettings Class : FooterStyle Property

Glossary Item Box

Footer style (apply only to Outlook2003 type).

Syntax

Visual Basic (Declaration)
Public Property FooterStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebNavPaneFooterSettings
Dim value As ISNet.WebUI.WebStyle

instance.FooterStyle = value

value = instance.FooterStyle
C#
public ISNet.WebUI.WebStyle FooterStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPaneFooterSettings Class
WebNavPaneFooterSettings Members


ImageSize Property

[image]
Intersoft WebDesktop Documentation
ImageSize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPaneFooterSettings Class : ImageSize Property

Glossary Item Box

Gets or sets the image size in the footer bar.

Syntax

Visual Basic (Declaration)
Public Overridable Property ImageSize As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebNavPaneFooterSettings
Dim value As System.Web.UI.WebControls.Unit

instance.ImageSize = value

value = instance.ImageSize
C#
public virtual System.Web.UI.WebControls.Unit ImageSize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPaneFooterSettings Class
WebNavPaneFooterSettings Members


Size Property

[image]
Intersoft WebDesktop Documentation
Size Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPaneFooterSettings Class : Size Property

Glossary Item Box

Gets or sets the size of the footer bar.

Syntax

Visual Basic (Declaration)
Public Property Size As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebNavPaneFooterSettings
Dim value As System.Web.UI.WebControls.Unit

instance.Size = value

value = instance.Size
C#
public System.Web.UI.WebControls.Unit Size {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPaneFooterSettings Class
WebNavPaneFooterSettings Members


WebNavPaneItemSettings Class

[image]
Intersoft WebDesktop Documentation
WebNavPaneItemSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNavPaneItemSettings Class

Glossary Item Box

Collection of settings to configure WebNavBarItem.

Object Model

WebNavPaneItemSettings Class

Syntax

Visual Basic (Declaration)
Public Class WebNavPaneItemSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebNavPaneItemSettings
C#
public class WebNavPaneItemSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Remarks

WebNavPaneItemSettings contains NavBarItem settings such as ItemStyle, DisplayMode, and ImagePosition.

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebDesktop.WebNavPaneItemSettings
ISNet.WebUI.WebDesktop.WebNavBarItemSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPaneItemSettings Members
ISNet.WebUI.WebDesktop Namespace

Tasks

Using BarItem for Content Navigation

Concepts

Understanding Concepts


WebNavPaneItemSettings Class Members

[image]
Intersoft WebDesktop Documentation
WebNavPaneItemSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNavPaneItemSettings Class

Glossary Item Box

The following tables list the members exposed by WebNavPaneItemSettings.

Public Constructors

 | Name | Description
Public Constructor | WebNavPaneItemSettings Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Alignment | Gets or sets horizontal alignment of NavBarItem.
Public Property | DisplayMode | Gets or sets the display mode of the NavBarItem.
Public Property | ImagePosition | Gets or sets the image position of NavBarItem.
Public Property | ImageSize | Gets or sets the image size of the NavBarItem.
Public Property | ItemsContainerStyle | Gets or sets the style of NavBarItem's container.
Public Property | ItemSpacing |
Public Property | ItemStyle | Gets or sets the style of NavBarItem.
Public Property | TargetWindow | Gets or sets the target window when item is clicked.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

WebNavPaneItemSettings Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Using BarItem for Content Navigation

Concepts

Understanding Concepts


WebNavPaneItemSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebNavPaneItemSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPaneItemSettings Class : WebNavPaneItemSettings Constructor

Glossary Item Box

Initializes a new instance of the WebNavPaneItemSettings class.

Overload List

Overload | Description
WebNavPaneItemSettings Constructor() |
WebNavPaneItemSettings Constructor(Unit,DisplayMode,WebNavImagePosition) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPaneItemSettings Class
WebNavPaneItemSettings Members


WebNavPaneItemSettings Constructor()

[image]
Intersoft WebDesktop Documentation
WebNavPaneItemSettings Constructor()
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPaneItemSettings Class > WebNavPaneItemSettings Constructor : WebNavPaneItemSettings Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebNavPaneItemSettings()
C#
public WebNavPaneItemSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPaneItemSettings Class
WebNavPaneItemSettings Members
Overload List


WebNavPaneItemSettings Constructor(Unit,DisplayMode,WebNavImagePosition)

[image]
Intersoft WebDesktop Documentation
WebNavPaneItemSettings Constructor(Unit,DisplayMode,WebNavImagePosition)
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPaneItemSettings Class > WebNavPaneItemSettings Constructor : WebNavPaneItemSettings Constructor(Unit,DisplayMode,WebNavImagePosition)

imgSize
dispMode
imgPos

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal imgSize As System.Web.UI.WebControls.Unit, _
   ByVal dispMode As DisplayMode, _
   ByVal imgPos As WebNavImagePosition _
)
Visual Basic (Usage) Copy Code
Dim imgSize As System.Web.UI.WebControls.Unit
Dim dispMode As DisplayMode
Dim imgPos As WebNavImagePosition

Dim instance As New WebNavPaneItemSettings(imgSize, dispMode, imgPos)
C#
public WebNavPaneItemSettings(
   System.Web.UI.WebControls.Unit imgSize,
   DisplayMode dispMode,
   WebNavImagePosition imgPos
)

Parameters

imgSize
dispMode
imgPos

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPaneItemSettings Class
WebNavPaneItemSettings Members
Overload List


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPaneItemSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebNavPaneItemSettings
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPaneItemSettings Class
WebNavPaneItemSettings Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPaneItemSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPaneItemSettings Class
WebNavPaneItemSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPaneItemSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavPaneItemSettings
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPaneItemSettings Class
WebNavPaneItemSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPaneItemSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavPaneItemSettings
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPaneItemSettings Class
WebNavPaneItemSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPaneItemSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavPaneItemSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPaneItemSettings Class
WebNavPaneItemSettings Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPaneItemSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebNavPaneItemSettings
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPaneItemSettings Class
WebNavPaneItemSettings Members


WebNavPaneItemSettings Class Methods

[image]
Intersoft WebDesktop Documentation
WebNavPaneItemSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNavPaneItemSettings Class

Glossary Item Box

For a list of all members of this type, see WebNavPaneItemSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

WebNavPaneItemSettings Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Using BarItem for Content Navigation

Concepts

Understanding Concepts


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPaneItemSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavPaneItemSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPaneItemSettings Class
WebNavPaneItemSettings Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPaneItemSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNavPaneItemSettings
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPaneItemSettings Class
WebNavPaneItemSettings Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPaneItemSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebNavPaneItemSettings

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPaneItemSettings Class
WebNavPaneItemSettings Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPaneItemSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNavPaneItemSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPaneItemSettings Class
WebNavPaneItemSettings Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPaneItemSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavPaneItemSettings
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPaneItemSettings Class
WebNavPaneItemSettings Members


WebNavPaneItemSettings Class Properties

[image]
Intersoft WebDesktop Documentation
WebNavPaneItemSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNavPaneItemSettings Class

Glossary Item Box

For a list of all members of this type, see WebNavPaneItemSettings members.

Public Properties

 | Name | Description
Public Property | Alignment | Gets or sets horizontal alignment of NavBarItem.
Public Property | DisplayMode | Gets or sets the display mode of the NavBarItem.
Public Property | ImagePosition | Gets or sets the image position of NavBarItem.
Public Property | ImageSize | Gets or sets the image size of the NavBarItem.
Public Property | ItemsContainerStyle | Gets or sets the style of NavBarItem's container.
Public Property | ItemSpacing |
Public Property | ItemStyle | Gets or sets the style of NavBarItem.
Public Property | TargetWindow | Gets or sets the target window when item is clicked.
Top

See Also

Reference

WebNavPaneItemSettings Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Using BarItem for Content Navigation

Concepts

Understanding Concepts


Alignment Property

[image]
Intersoft WebDesktop Documentation
Alignment Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPaneItemSettings Class : Alignment Property

Glossary Item Box

Gets or sets horizontal alignment of NavBarItem.

Syntax

Visual Basic (Declaration)
Public Overridable Property Alignment As TextAlignment
Visual Basic (Usage) Copy Code
Dim instance As WebNavPaneItemSettings
Dim value As TextAlignment

instance.Alignment = value

value = instance.Alignment
C#
public virtual TextAlignment Alignment {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPaneItemSettings Class
WebNavPaneItemSettings Members


DisplayMode Property

[image]
Intersoft WebDesktop Documentation
DisplayMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPaneItemSettings Class : DisplayMode Property

Glossary Item Box

Gets or sets the display mode of the NavBarItem.

Syntax

Visual Basic (Declaration)
Public Overridable Property DisplayMode As DisplayMode
Visual Basic (Usage) Copy Code
Dim instance As WebNavPaneItemSettings
Dim value As DisplayMode

instance.DisplayMode = value

value = instance.DisplayMode
C#
public virtual DisplayMode DisplayMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPaneItemSettings Class
WebNavPaneItemSettings Members


ImagePosition Property

[image]
Intersoft WebDesktop Documentation
ImagePosition Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPaneItemSettings Class : ImagePosition Property

Glossary Item Box

Gets or sets the image position of NavBarItem.

Syntax

Visual Basic (Declaration)
Public Overridable Property ImagePosition As WebNavImagePosition
Visual Basic (Usage) Copy Code
Dim instance As WebNavPaneItemSettings
Dim value As WebNavImagePosition

instance.ImagePosition = value

value = instance.ImagePosition
C#
public virtual WebNavImagePosition ImagePosition {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPaneItemSettings Class
WebNavPaneItemSettings Members


ImageSize Property

[image]
Intersoft WebDesktop Documentation
ImageSize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPaneItemSettings Class : ImageSize Property

Glossary Item Box

Gets or sets the image size of the NavBarItem.

Syntax

Visual Basic (Declaration)
Public Overridable Property ImageSize As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebNavPaneItemSettings
Dim value As System.Web.UI.WebControls.Unit

instance.ImageSize = value

value = instance.ImageSize
C#
public virtual System.Web.UI.WebControls.Unit ImageSize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPaneItemSettings Class
WebNavPaneItemSettings Members


ItemsContainerStyle Property

[image]
Intersoft WebDesktop Documentation
ItemsContainerStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPaneItemSettings Class : ItemsContainerStyle Property

Glossary Item Box

Gets or sets the style of NavBarItem's container.

Syntax

Visual Basic (Declaration)
Public Overridable Property ItemsContainerStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebNavPaneItemSettings
Dim value As ISNet.WebUI.WebStyle

instance.ItemsContainerStyle = value

value = instance.ItemsContainerStyle
C#
public virtual ISNet.WebUI.WebStyle ItemsContainerStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPaneItemSettings Class
WebNavPaneItemSettings Members


ItemSpacing Property

[image]
Intersoft WebDesktop Documentation
ItemSpacing Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPaneItemSettings Class : ItemSpacing Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ItemSpacing As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebNavPaneItemSettings
Dim value As Integer

instance.ItemSpacing = value

value = instance.ItemSpacing
C#
public int ItemSpacing {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPaneItemSettings Class
WebNavPaneItemSettings Members


ItemStyle Property

[image]
Intersoft WebDesktop Documentation
ItemStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPaneItemSettings Class : ItemStyle Property

Glossary Item Box

Gets or sets the style of NavBarItem.

Syntax

Visual Basic (Declaration)
Public Overridable Property ItemStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebNavPaneItemSettings
Dim value As ISNet.WebUI.DynamicStyle

instance.ItemStyle = value

value = instance.ItemStyle
C#
public virtual ISNet.WebUI.DynamicStyle ItemStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPaneItemSettings Class
WebNavPaneItemSettings Members


TargetWindow Property

[image]
Intersoft WebDesktop Documentation
TargetWindow Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNavPaneItemSettings Class : TargetWindow Property

Glossary Item Box

Gets or sets the target window when item is clicked.

Syntax

Visual Basic (Declaration)
Public Overridable Property TargetWindow As String
Visual Basic (Usage) Copy Code
Dim instance As WebNavPaneItemSettings
Dim value As String

instance.TargetWindow = value

value = instance.TargetWindow
C#
public virtual string TargetWindow {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNavPaneItemSettings Class
WebNavPaneItemSettings Members


WebNotification Class

[image]
Intersoft WebDesktop Documentation
WebNotification Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNotification Class

Glossary Item Box

WebNotification is a server control designed to retrieve new notifications from server side using object model.

Object Model

WebNotification Class

Syntax

Visual Basic (Declaration)
Public Class WebNotification
   Inherits ISNet.WebUI.ISNetControl
   Implements ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, IWebMenu, IWebMenuControl
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
C#
public class WebNotification : ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, IWebMenu, IWebMenuControl

Remarks

Using WebNotification you can notify new events to your end users in stylish and professional way, such as displaying new emails or alerting server maintenance process. WebNotification allows you to configure numerous visual effect settings such as the animation style, fading speed and more.

WebNotification communicates with a WebService or WebForm page provider through asynchronous call (a.k.a. AJAX) which is based on WebFlyPostBackManager component. WebNotification asynchronously retrieves new Notifications from server side in every certain time interval. The control can retrieves the Notifications from either WebService (asmx) or WebForm (aspx) page. The asynchronous process allows seamless data retrieval and ensures extremely fast communication between client and server since WebNotification returns only the events data in XML format, instead of HTML control rendering result.

WebNotification allows you to quickly create modern notifications with Outlook or Messenger behavior. Since that WebNotification is designed specifically for notifications purpose, WebNotification replicates every single details of behavior available in Outlook or Messenger.

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
ISNet.WebUI.ISNetControl
ISNet.WebUI.WebDesktop.WebNotification

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Members
ISNet.WebUI.WebDesktop Namespace

Tasks

Retrieving notifications from webservice

tasks

Retrieving notifications from webform listener
Integrating into WebDesktopManager
Using action context menu
Passing custom properties

Concepts

WebNotification Overview

concepts

Understanding Concepts
WebNotification Features


WebNotification Class Members

[image]
Intersoft WebDesktop Documentation
WebNotification Class Members
See Also Properties Methods Events Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNotification Class

Glossary Item Box

The following tables list the members exposed by WebNotification.

Public Constructors

 | Name | Description
Public Constructor | WebNotification Constructor |
Top

Public Properties

 | Name | Description
Public Property | AccessKey | Keyboard shortcut used by the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ActionMenu | Gets the WebMenu object which is the action menu for the notification control.
Public Property | AnimationStyle | Specifies the animation style for this notification control.
Public Property | AutoStart | Specifies whether the control should start the notification process immediately after page load.
Public Property | BackColor | Overridden. Color of the background of the control.
Public Property | BorderColor | Overridden. Border of the color around the control.
Public Property | BorderStyle | Overridden. Style of the border around the control.
Public Property | BorderWidth | Overridden. Width of the border around the control.
Public Property | CaptionStyle | The style applied to Caption element of the notification control.
Public Property | CaptionText | Gets or sets the text displayed in the caption area.
Public Property | CaptionTextStyle |
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ClientSideEvents | Provides client side events available in WebNotification control.
Public Property | CommandStyle | The interactive style applied to Command element of the notification control.
Public Property | ContentImage | Gets or set the image displayed in the content area.
Public Property | ContentStyle | The style applied to the content element of the notification control.
Public Property | ContentText | Gets or sets the text displayed in the content area.
Public Property | ContentVAlign | Gets or sets the vertical alignment of the text relatively to control's Height.
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | DisplayLatency | Gets or sets the time span of the display before the notification disappear.
Public Property | DisplayMode | Gets or sets the display mode for this notification control.
Public Property | DisplayPosition | Gets or sets the display position of the notification.
Public Property | Enabled | Enabled state of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableManagedTheming | Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to False, this control will not apply the style defined in Theme Architecture. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableSound | Specifies whether sound is played when notification occurs.
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | Whether the control automatically saves its state for use in round-trips. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). (Inherited from ISNet.WebUI.ISNetControl)
Public Property | FadingSpeed | When AnimationStyle is set to Fading, specify the speed of the Fading animation effect.
Public Property | Font | Overridden. The font used for text within the control.
Public Property | ForeColor | Overridden. Color of the text within the control.
Public Property | FrameStyle | The style applied to the Frame element of the notification control.
Public Property | Height | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ImageCommandVAlign |
Public Property | ImagePosition | Gets or sets the position of the image relative to the text.
Public Property | ImagesDirectory | Gets or sets the default directory for images specified in ImagesSettings.
Public Property | ImageSize | Gets or sets the default size of image used in entire menu hierarchy.
Public Property | ImagesSettings | Provides settings for images used by WebNotification control.
Public Property | ImageVAlign | Gets or sets the vertical alignment of the image.
Public Property | IntegratedTo | Specifies whether this menu control should be operated in Integration mode. When integrated, the menu will automatically inherit all styles defined in the Integration Object (whether it is PlaceHolderManager or DesktopManager).
Public Property | IntegratedToDesktopManager | Specifies whether the notification should be integrated to DesktopManager. When integrated, the notification will be displayed at desktop level instead of the caller's window.
Public Property | Interval | Gets or sets the time interval, in seconds, between notification data requests.
Public Property | Items | The collection of menu items to be displayed in Action Context Menu.
Public Property | MenuStyleSettings | Containts style and appearance definition for the Menu.
Public Property | NotifyWindowClickable | Specifies whether the notification window is clickable when a notification event occured.
Public Property | NotifyWindowName | Gets or sets the window name which will be used when user clicks on the notification window.
Public Property | NotifyWindowURL | Gets or sets the URL to launch when user clicked on notification window.
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RunOnce | Specifies a boolean value to indicate whether the notification should be performed only once or periodically in specified Interval value.
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden. Gets or sets the directory where all required scripts for the control are stored.
Public Property | ServiceType | Gets or sets the service type used by the notification control to request data.
Public Property | ServiceUrl | Gets or sets the service URL that this control will use for client server communication.
Public Property | SharedScriptDirectory | Overridden. Gets or sets the directory where all shared scripts for Intersoft controls are stored.
Public Property | ShowActionDropdown | Specifies whether action dropdown button is displayed.
Public Property | ShowCloseButton | Specifies whether close button is displayed.
Public Property | ShowDelay | Gets or sets the amount of submenu that shows delay in milliseconds.
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SoundFile | Specifies the valid music file to play on notification. Supported types are midi, wav and au.
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ToolTip | The tooltip displayed when the mouse is over the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateItems | Gets or sets the items to be stored in view state storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | Gets or sets the server connection string for file server-based viewstate storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | Gets or sets the location to store the viewstate of this control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | Indicates whether the control is visible and rendered. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Width | The width of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | XmlCompressionEnabled | Specifies whether the Xml used for clientside state storage should be compressed. (Inherited from ISNet.WebUI.ISNetControl)
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CheckConstrains | Overridden.
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPostData | Overridden.
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | Notify | Overloaded.
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RaisePostBackEvent |
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RecreateChildControls |
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterScript | Overridden.
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebNotification Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Retrieving notifications from webservice

tasks

Retrieving notifications from webform listener
Integrating into WebDesktopManager
Using action context menu
Passing custom properties

Concepts

WebNotification Overview

concepts

Understanding Concepts
WebNotification Features


WebNotification Class Events

[image]
Intersoft WebDesktop Documentation
WebNotification Class Events
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNotification Class

Glossary Item Box

For a list of all members of this type, see WebNotification members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebNotification Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Retrieving notifications from webservice

tasks

Retrieving notifications from webform listener
Integrating into WebDesktopManager
Using action context menu
Passing custom properties

Concepts

WebNotification Overview

concepts

Understanding Concepts
WebNotification Features


WebNotification Constructor

[image]
Intersoft WebDesktop Documentation
WebNotification Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : WebNotification Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebNotification()
C#
public WebNotification()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


ApplyStyle Method

[image]
Intersoft WebDesktop Documentation
ApplyStyle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : ApplyStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ApplyStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim s As System.Web.UI.WebControls.Style

instance.ApplyStyle(s)
C#
public void ApplyStyle(
   System.Web.UI.WebControls.Style s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


ApplyStyleSheetSkin Method

[image]
Intersoft WebDesktop Documentation
ApplyStyleSheetSkin Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : ApplyStyleSheetSkin Method

page

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub ApplyStyleSheetSkin( _
   ByVal page As System.Web.UI.Page _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim page As System.Web.UI.Page

instance.ApplyStyleSheetSkin(page)
C#
public virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page page
)

Parameters

page

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


CanUseWebResources Method

[image]
Intersoft WebDesktop Documentation
CanUseWebResources Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : CanUseWebResources Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CanUseWebResources() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As Boolean

value = instance.CanUseWebResources()
C#
public bool CanUseWebResources()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


WebNotification Class Methods

[image]
Intersoft WebDesktop Documentation
WebNotification Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNotification Class

Glossary Item Box

For a list of all members of this type, see WebNotification members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CheckConstrains | Overridden.
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPostData | Overridden.
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | Notify | Overloaded.
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RaisePostBackEvent |
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RecreateChildControls |
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterScript | Overridden.
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Top

See Also

Reference

WebNotification Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Retrieving notifications from webservice

tasks

Retrieving notifications from webform listener
Integrating into WebDesktopManager
Using action context menu
Passing custom properties

Concepts

WebNotification Overview

concepts

Understanding Concepts
WebNotification Features


CheckConstrains Method

[image]
Intersoft WebDesktop Documentation
CheckConstrains Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : CheckConstrains Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub CheckConstrains()
Visual Basic (Usage) Copy Code
Dim instance As WebNotification

instance.CheckConstrains()
C#
public override void CheckConstrains()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


CopyBaseAttributes Method

[image]
Intersoft WebDesktop Documentation
CopyBaseAttributes Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : CopyBaseAttributes Method

controlSrc

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyBaseAttributes( _
   ByVal controlSrc As System.Web.UI.WebControls.WebControl _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim controlSrc As System.Web.UI.WebControls.WebControl

instance.CopyBaseAttributes(controlSrc)
C#
public void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl controlSrc
)

Parameters

controlSrc

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.ISNetControl)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members
Overload List


DataBind Method

[image]
Intersoft WebDesktop Documentation
DataBind Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : DataBind Method

Glossary Item Box

Overload List

Overload | Description
DataBind | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


DataBind() Method

[image]
Intersoft WebDesktop Documentation
DataBind() Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : DataBind() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub DataBind()
Visual Basic (Usage) Copy Code
Dim instance As WebNotification

instance.DataBind()
C#
public virtual void DataBind()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


Dispose Method

[image]
Intersoft WebDesktop Documentation
Dispose Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : Dispose Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As WebNotification

instance.Dispose()
C#
public virtual void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


FindControl Method

[image]
Intersoft WebDesktop Documentation
FindControl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : FindControl Method

Glossary Item Box

Overload List

Overload | Description
FindControl | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


FindControl(String) Method

[image]
Intersoft WebDesktop Documentation
FindControl(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : FindControl(String) Method

id

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function FindControl( _
   ByVal id As String _
) As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim id As String
Dim value As System.Web.UI.Control

value = instance.FindControl(id)
C#
public virtual System.Web.UI.Control FindControl(
   string id
)

Parameters

id

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


Focus Method

[image]
Intersoft WebDesktop Documentation
Focus Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : Focus Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Focus()
Visual Basic (Usage) Copy Code
Dim instance As WebNotification

instance.Focus()
C#
public virtual void Focus()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


ForceDisableXmlCompression Method

[image]
Intersoft WebDesktop Documentation
ForceDisableXmlCompression Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : ForceDisableXmlCompression Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ForceDisableXmlCompression()
Visual Basic (Usage) Copy Code
Dim instance As WebNotification

instance.ForceDisableXmlCompression()
C#
public void ForceDisableXmlCompression()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


GetCurrentControlLifeCycle Method

[image]
Intersoft WebDesktop Documentation
GetCurrentControlLifeCycle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : GetCurrentControlLifeCycle Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentControlLifeCycle() As ISNet.WebUI.ControlLifeCycle
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As ISNet.WebUI.ControlLifeCycle

value = instance.GetCurrentControlLifeCycle()
C#
public ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


GetCurrentTheme Method

[image]
Intersoft WebDesktop Documentation
GetCurrentTheme Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : GetCurrentTheme Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentTheme() As ISNet.WebUI.ThemeInfo
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As ISNet.WebUI.ThemeInfo

value = instance.GetCurrentTheme()
C#
public ISNet.WebUI.ThemeInfo GetCurrentTheme()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


GetFrameworkDataFolder Method

[image]
Intersoft WebDesktop Documentation
GetFrameworkDataFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : GetFrameworkDataFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkDataFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As String

value = instance.GetFrameworkDataFolder()
C#
public string GetFrameworkDataFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


GetFrameworkFolder Method

[image]
Intersoft WebDesktop Documentation
GetFrameworkFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : GetFrameworkFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As String

value = instance.GetFrameworkFolder()
C#
public string GetFrameworkFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


GetFrameworkVersion Method

[image]
Intersoft WebDesktop Documentation
GetFrameworkVersion Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : GetFrameworkVersion Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkVersion() As Version
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As Version

value = instance.GetFrameworkVersion()
C#
public Version GetFrameworkVersion()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


GetIntersoftFolder Method

[image]
Intersoft WebDesktop Documentation
GetIntersoftFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : GetIntersoftFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetIntersoftFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As String

value = instance.GetIntersoftFolder()
C#
public string GetIntersoftFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


GetLayoutFolder Method

[image]
Intersoft WebDesktop Documentation
GetLayoutFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : GetLayoutFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetLayoutFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As String

value = instance.GetLayoutFolder()
C#
public string GetLayoutFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


GetPostedXMLData Method

[image]
Intersoft WebDesktop Documentation
GetPostedXMLData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : GetPostedXMLData Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPostedXMLData() As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As String

value = instance.GetPostedXMLData()
C#
public string GetPostedXMLData()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


GetProductInfoKey Method

[image]
Intersoft WebDesktop Documentation
GetProductInfoKey Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : GetProductInfoKey Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductInfoKey() As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As String

value = instance.GetProductInfoKey()
C#
public string GetProductInfoKey()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


GetProductSimpleName Method

[image]
Intersoft WebDesktop Documentation
GetProductSimpleName Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : GetProductSimpleName Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductSimpleName() As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As String

value = instance.GetProductSimpleName()
C#
public string GetProductSimpleName()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


GetPropertyValue Method

[image]
Intersoft WebDesktop Documentation
GetPropertyValue Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : GetPropertyValue Method

defValue
propValue
webConfigKey

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPropertyValue( _
   ByVal defValue As String, _
   ByVal propValue As String, _
   ByVal webConfigKey As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim defValue As String
Dim propValue As String
Dim webConfigKey As String
Dim value As String

value = instance.GetPropertyValue(defValue, propValue, webConfigKey)
C#
public string GetPropertyValue(
   string defValue,
   string propValue,
   string webConfigKey
)

Parameters

defValue
propValue
webConfigKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


GetResourceStream Method

[image]
Intersoft WebDesktop Documentation
GetResourceStream Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : GetResourceStream Method

resourceUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetResourceStream( _
   ByVal resourceUrl As String _
) As System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim resourceUrl As String
Dim value As System.IO.Stream

value = instance.GetResourceStream(resourceUrl)
C#
public System.IO.Stream GetResourceStream(
   string resourceUrl
)

Parameters

resourceUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


GetRouteUrl Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : GetRouteUrl Method

Glossary Item Box

Overload List

Overload | Description
GetRouteUrl(Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(RouteValueDictionary) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,RouteValueDictionary) | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


GetRouteUrl(Object) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class > GetRouteUrl Method : GetRouteUrl(Object) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As Object _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim routeParameters As Object
Dim value As String

value = instance.GetRouteUrl(routeParameters)
C#
public string GetRouteUrl(
   object routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members
Overload List


GetRouteUrl(String,Object) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(String,Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class > GetRouteUrl Method : GetRouteUrl(String,Object) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As String, _
   ByVal routeParameters As Object _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim routeName As String
Dim routeParameters As Object
Dim value As String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public string GetRouteUrl(
   string routeName,
   object routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members
Overload List


GetRouteUrl(RouteValueDictionary) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(RouteValueDictionary) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class > GetRouteUrl Method : GetRouteUrl(RouteValueDictionary) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As String

value = instance.GetRouteUrl(routeParameters)
C#
public string GetRouteUrl(
   System.Web.Routing.RouteValueDictionary routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members
Overload List


GetRouteUrl(String,RouteValueDictionary) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(String,RouteValueDictionary) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class > GetRouteUrl Method : GetRouteUrl(String,RouteValueDictionary) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As String, _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim routeName As String
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public string GetRouteUrl(
   string routeName,
   System.Web.Routing.RouteValueDictionary routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members
Overload List


GetUniqueIDRelativeTo Method

[image]
Intersoft WebDesktop Documentation
GetUniqueIDRelativeTo Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : GetUniqueIDRelativeTo Method

control

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetUniqueIDRelativeTo( _
   ByVal control As System.Web.UI.Control _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim control As System.Web.UI.Control
Dim value As String

value = instance.GetUniqueIDRelativeTo(control)
C#
public string GetUniqueIDRelativeTo(
   System.Web.UI.Control control
)

Parameters

control

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


HasControls Method

[image]
Intersoft WebDesktop Documentation
HasControls Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : HasControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function HasControls() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As Boolean

value = instance.HasControls()
C#
public virtual bool HasControls()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


IsAtlasCallback Method

[image]
Intersoft WebDesktop Documentation
IsAtlasCallback Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : IsAtlasCallback Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsAtlasCallback() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As Boolean

value = instance.IsAtlasCallback()
C#
public bool IsAtlasCallback()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


IsBetaRelease Method

[image]
Intersoft WebDesktop Documentation
IsBetaRelease Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : IsBetaRelease Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsBetaRelease() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As Boolean

value = instance.IsBetaRelease()
C#
public bool IsBetaRelease()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


IsChromeBrowser Method

[image]
Intersoft WebDesktop Documentation
IsChromeBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : IsChromeBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsChromeBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As Boolean

value = instance.IsChromeBrowser()
C#
public bool IsChromeBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


IsFlyPostBackControl Method

[image]
Intersoft WebDesktop Documentation
IsFlyPostBackControl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : IsFlyPostBackControl Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackControl() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As Boolean

value = instance.IsFlyPostBackControl()
C#
public virtual bool IsFlyPostBackControl()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


IsFlyPostBackRequest Method

[image]
Intersoft WebDesktop Documentation
IsFlyPostBackRequest Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : IsFlyPostBackRequest Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackRequest() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As Boolean

value = instance.IsFlyPostBackRequest()
C#
public virtual bool IsFlyPostBackRequest()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


IsGeckoBasedBrowser Method

[image]
Intersoft WebDesktop Documentation
IsGeckoBasedBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : IsGeckoBasedBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoBasedBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As Boolean

value = instance.IsGeckoBasedBrowser()
C#
public bool IsGeckoBasedBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


IsGeckoVersion18 Method

[image]
Intersoft WebDesktop Documentation
IsGeckoVersion18 Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : IsGeckoVersion18 Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoVersion18() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As Boolean

value = instance.IsGeckoVersion18()
C#
public bool IsGeckoVersion18()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


IsInDesignMode Method

[image]
Intersoft WebDesktop Documentation
IsInDesignMode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : IsInDesignMode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInDesignMode() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As Boolean

value = instance.IsInDesignMode()
C#
public bool IsInDesignMode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


IsInternetExplorer8Browser Method

[image]
Intersoft WebDesktop Documentation
IsInternetExplorer8Browser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : IsInternetExplorer8Browser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorer8Browser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As Boolean

value = instance.IsInternetExplorer8Browser()
C#
public bool IsInternetExplorer8Browser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


IsInternetExplorerBrowser Method

[image]
Intersoft WebDesktop Documentation
IsInternetExplorerBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : IsInternetExplorerBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorerBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As Boolean

value = instance.IsInternetExplorerBrowser()
C#
public bool IsInternetExplorerBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


IsOperaBrowser Method

[image]
Intersoft WebDesktop Documentation
IsOperaBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : IsOperaBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsOperaBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As Boolean

value = instance.IsOperaBrowser()
C#
public bool IsOperaBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


IsSafariBrowser Method

[image]
Intersoft WebDesktop Documentation
IsSafariBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : IsSafariBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsSafariBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As Boolean

value = instance.IsSafariBrowser()
C#
public bool IsSafariBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


IsW3CStandardBrowser Method

[image]
Intersoft WebDesktop Documentation
IsW3CStandardBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : IsW3CStandardBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsW3CStandardBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As Boolean

value = instance.IsW3CStandardBrowser()
C#
public bool IsW3CStandardBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


LoadLayout Method

[image]
Intersoft WebDesktop Documentation
LoadLayout Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : LoadLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim settings As ISNet.WebUI.LayoutInfo

instance.LoadLayout(settings)
C#
public virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


LoadLayoutFromFile Method

[image]
Intersoft WebDesktop Documentation
LoadLayoutFromFile Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : LoadLayoutFromFile Method

filePath

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromFile( _
   ByVal filePath As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim filePath As String

instance.LoadLayoutFromFile(filePath)
C#
public virtual void LoadLayoutFromFile(
   string filePath
)

Parameters

filePath

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


LoadLayoutFromPredefinedName Method

[image]
Intersoft WebDesktop Documentation
LoadLayoutFromPredefinedName Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : LoadLayoutFromPredefinedName Method

predefinedName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromPredefinedName( _
   ByVal predefinedName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim predefinedName As String

instance.LoadLayoutFromPredefinedName(predefinedName)
C#
public virtual void LoadLayoutFromPredefinedName(
   string predefinedName
)

Parameters

predefinedName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


LoadLayoutFromStream Method

[image]
Intersoft WebDesktop Documentation
LoadLayoutFromStream Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : LoadLayoutFromStream Method

stream

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromStream( _
   ByVal stream As System.IO.Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim stream As System.IO.Stream

instance.LoadLayoutFromStream(stream)
C#
public virtual void LoadLayoutFromStream(
   System.IO.Stream stream
)

Parameters

stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


LoadPostData Method

[image]
Intersoft WebDesktop Documentation
LoadPostData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : LoadPostData Method

postDataKey
postCollection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function LoadPostData( _
   ByVal postDataKey As String, _
   ByVal postCollection As System.Collections.Specialized.NameValueCollection _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim postDataKey As String
Dim postCollection As System.Collections.Specialized.NameValueCollection
Dim value As Boolean

value = instance.LoadPostData(postDataKey, postCollection)
C#
public override bool LoadPostData(
   string postDataKey,
   System.Collections.Specialized.NameValueCollection postCollection
)

Parameters

postDataKey
postCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


MergeStyle Method

[image]
Intersoft WebDesktop Documentation
MergeStyle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : MergeStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub MergeStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim s As System.Web.UI.WebControls.Style

instance.MergeStyle(s)
C#
public void MergeStyle(
   System.Web.UI.WebControls.Style s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


Notify Method

[image]
Intersoft WebDesktop Documentation
Notify Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : Notify Method

Glossary Item Box

Overload List

Overload | Description
Notify(String) |
Notify(String,String) |
Notify(String,String,String) |
Notify(WebNotificationEvent) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


Notify(String) Method

[image]
Intersoft WebDesktop Documentation
Notify(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class > Notify Method : Notify(String) Method

contentText

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Notify( _
   ByVal contentText As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim contentText As String

instance.Notify(contentText)
C#
public void Notify(
   string contentText
)

Parameters

contentText

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members
Overload List


Notify(String,String) Method

[image]
Intersoft WebDesktop Documentation
Notify(String,String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class > Notify Method : Notify(String,String) Method

contentText
contentImage

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Notify( _
   ByVal contentText As String, _
   ByVal contentImage As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim contentText As String
Dim contentImage As String

instance.Notify(contentText, contentImage)
C#
public void Notify(
   string contentText,
   string contentImage
)

Parameters

contentText
contentImage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members
Overload List


Notify(String,String,String) Method

[image]
Intersoft WebDesktop Documentation
Notify(String,String,String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class > Notify Method : Notify(String,String,String) Method

contentText
contentImage
captionText

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Notify( _
   ByVal contentText As String, _
   ByVal contentImage As String, _
   ByVal captionText As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim contentText As String
Dim contentImage As String
Dim captionText As String

instance.Notify(contentText, contentImage, captionText)
C#
public void Notify(
   string contentText,
   string contentImage,
   string captionText
)

Parameters

contentText
contentImage
captionText

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members
Overload List


Notify(WebNotificationEvent) Method

[image]
Intersoft WebDesktop Documentation
Notify(WebNotificationEvent) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class > Notify Method : Notify(WebNotificationEvent) Method

notificationEvent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Notify( _
   ByVal notificationEvent As WebNotificationEvent _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim notificationEvent As WebNotificationEvent

instance.Notify(notificationEvent)
C#
public void Notify(
   WebNotificationEvent notificationEvent
)

Parameters

notificationEvent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members
Overload List


OnInfoChanged Method

[image]
Intersoft WebDesktop Documentation
OnInfoChanged Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : OnInfoChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnInfoChanged( _
   ByVal e As ISNet.WebUI.SynchronizeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim e As ISNet.WebUI.SynchronizeEventArgs

instance.OnInfoChanged(e)
C#
public void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


OnPreInitialize Method

[image]
Intersoft WebDesktop Documentation
OnPreInitialize Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : OnPreInitialize Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnPreInitialize()
Visual Basic (Usage) Copy Code
Dim instance As WebNotification

instance.OnPreInitialize()
C#
public virtual void OnPreInitialize()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


RaisePostBackEvent Method

[image]
Intersoft WebDesktop Documentation
RaisePostBackEvent Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : RaisePostBackEvent Method

eventArgument

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RaisePostBackEvent( _
   ByVal eventArgument As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim eventArgument As String

instance.RaisePostBackEvent(eventArgument)
C#
public void RaisePostBackEvent(
   string eventArgument
)

Parameters

eventArgument

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


RaisePostDataChangedEvent Method

[image]
Intersoft WebDesktop Documentation
RaisePostDataChangedEvent Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : RaisePostDataChangedEvent Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RaisePostDataChangedEvent()
Visual Basic (Usage) Copy Code
Dim instance As WebNotification

instance.RaisePostDataChangedEvent()
C#
public virtual void RaisePostDataChangedEvent()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


ReadWebConfigValue Method

[image]
Intersoft WebDesktop Documentation
ReadWebConfigValue Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : ReadWebConfigValue Method

key

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ReadWebConfigValue( _
   ByVal key As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim key As String
Dim value As String

value = instance.ReadWebConfigValue(key)
C#
public string ReadWebConfigValue(
   string key
)

Parameters

key

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


RecreateChildControls Method

[image]
Intersoft WebDesktop Documentation
RecreateChildControls Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : RecreateChildControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RecreateChildControls()
Visual Basic (Usage) Copy Code
Dim instance As WebNotification

instance.RecreateChildControls()
C#
public void RecreateChildControls()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


RegisterBoxSizing Method

[image]
Intersoft WebDesktop Documentation
RegisterBoxSizing Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : RegisterBoxSizing Method

Glossary Item Box

Overload List

Overload | Description
RegisterBoxSizing() | (Inherited from ISNet.WebUI.ISNetControl)
RegisterBoxSizing(Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


RegisterBoxSizing() Method

[image]
Intersoft WebDesktop Documentation
RegisterBoxSizing() Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class > RegisterBoxSizing Method : RegisterBoxSizing() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing()
Visual Basic (Usage) Copy Code
Dim instance As WebNotification

instance.RegisterBoxSizing()
C#
public void RegisterBoxSizing()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members
Overload List


RegisterBoxSizing(Boolean) Method

[image]
Intersoft WebDesktop Documentation
RegisterBoxSizing(Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class > RegisterBoxSizing Method : RegisterBoxSizing(Boolean) Method

forceAll

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing( _
   ByVal forceAll As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim forceAll As Boolean

instance.RegisterBoxSizing(forceAll)
C#
public void RegisterBoxSizing(
   bool forceAll
)

Parameters

forceAll

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members
Overload List


RegisterGlobalStyle Method

[image]
Intersoft WebDesktop Documentation
RegisterGlobalStyle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : RegisterGlobalStyle Method

style

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterGlobalStyle( _
   ByVal style As ISNet.WebUI.WebStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim style As ISNet.WebUI.WebStyle

instance.RegisterGlobalStyle(style)
C#
public void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle style
)

Parameters

style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


RegisterLink Method

[image]
Intersoft WebDesktop Documentation
RegisterLink Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : RegisterLink Method

name
url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterLink( _
   ByVal name As String, _
   ByVal url As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim name As String
Dim url As String

instance.RegisterLink(name, url)
C#
public void RegisterLink(
   string name,
   string url
)

Parameters

name
url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


RegisterOptimizedCssClasses Method

[image]
Intersoft WebDesktop Documentation
RegisterOptimizedCssClasses Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : RegisterOptimizedCssClasses Method

runtimeStyleOnly

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterOptimizedCssClasses( _
   ByVal runtimeStyleOnly As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim runtimeStyleOnly As Boolean

instance.RegisterOptimizedCssClasses(runtimeStyleOnly)
C#
public void RegisterOptimizedCssClasses(
   bool runtimeStyleOnly
)

Parameters

runtimeStyleOnly

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


RegisterPreloadImage Method

[image]
Intersoft WebDesktop Documentation
RegisterPreloadImage Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : RegisterPreloadImage Method

image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterPreloadImage( _
   ByVal image As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim image As String

instance.RegisterPreloadImage(image)
C#
public void RegisterPreloadImage(
   string image
)

Parameters

image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


RegisterScript Method

[image]
Intersoft WebDesktop Documentation
RegisterScript Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : RegisterScript Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub RegisterScript()
Visual Basic (Usage) Copy Code
Dim instance As WebNotification

instance.RegisterScript()
C#
public override void RegisterScript()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


RegisterSharePointHandler Method

[image]
Intersoft WebDesktop Documentation
RegisterSharePointHandler Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : RegisterSharePointHandler Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RegisterSharePointHandler()
Visual Basic (Usage) Copy Code
Dim instance As WebNotification

instance.RegisterSharePointHandler()
C#
public virtual void RegisterSharePointHandler()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


RenderBeginTag Method

[image]
Intersoft WebDesktop Documentation
RenderBeginTag Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : RenderBeginTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderBeginTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderBeginTag(writer)
C#
public virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


RenderControl Method

[image]
Intersoft WebDesktop Documentation
RenderControl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : RenderControl Method

Glossary Item Box

Overload List

Overload | Description
RenderControl | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


RenderControl(HtmlTextWriter) Method

[image]
Intersoft WebDesktop Documentation
RenderControl(HtmlTextWriter) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : RenderControl(HtmlTextWriter) Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderControl( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderControl(writer)
C#
public virtual void RenderControl(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


RenderEndTag Method

[image]
Intersoft WebDesktop Documentation
RenderEndTag Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : RenderEndTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub RenderEndTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderEndTag(writer)
C#
public override void RenderEndTag(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebNotification

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


ResolveClientUrl Method

[image]
Intersoft WebDesktop Documentation
ResolveClientUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : ResolveClientUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveClientUrl( _
   ByVal relativeUrl As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim relativeUrl As String
Dim value As String

value = instance.ResolveClientUrl(relativeUrl)
C#
public string ResolveClientUrl(
   string relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


ResolveImagePath Method

[image]
Intersoft WebDesktop Documentation
ResolveImagePath Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : ResolveImagePath Method

folder
image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveImagePath( _
   ByVal folder As String, _
   ByVal image As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim folder As String
Dim image As String
Dim value As String

value = instance.ResolveImagePath(folder, image)
C#
public string ResolveImagePath(
   string folder,
   string image
)

Parameters

folder
image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


ResolveRelativeURL Method

[image]
Intersoft WebDesktop Documentation
ResolveRelativeURL Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : ResolveRelativeURL Method

url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ResolveRelativeURL( _
   ByVal url As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim url As String
Dim value As String

value = instance.ResolveRelativeURL(url)
C#
public virtual string ResolveRelativeURL(
   string url
)

Parameters

url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


ResolveResourceUrl Method

[image]
Intersoft WebDesktop Documentation
ResolveResourceUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : ResolveResourceUrl Method

kind
defaultFolder
currentFolder
resourceName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveResourceUrl( _
   ByVal kind As ISNet.WebUI.ResourceKind, _
   ByVal defaultFolder As String, _
   ByVal currentFolder As String, _
   ByVal resourceName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim kind As ISNet.WebUI.ResourceKind
Dim defaultFolder As String
Dim currentFolder As String
Dim resourceName As String
Dim value As String

value = instance.ResolveResourceUrl(kind, defaultFolder, currentFolder, resourceName)
C#
public string ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   string defaultFolder,
   string currentFolder,
   string resourceName
)

Parameters

kind
defaultFolder
currentFolder
resourceName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


ResolveUrl Method

[image]
Intersoft WebDesktop Documentation
ResolveUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : ResolveUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveUrl( _
   ByVal relativeUrl As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim relativeUrl As String
Dim value As String

value = instance.ResolveUrl(relativeUrl)
C#
public string ResolveUrl(
   string relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


SaveLayout Method

[image]
Intersoft WebDesktop Documentation
SaveLayout Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : SaveLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim settings As ISNet.WebUI.LayoutInfo

instance.SaveLayout(settings)
C#
public virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


SaveLayoutToFile Method

[image]
Intersoft WebDesktop Documentation
SaveLayoutToFile Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : SaveLayoutToFile Method

filePath
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToFile( _
   ByVal filePath As String, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim filePath As String
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToFile(filePath, saveOptions)
C#
public virtual void SaveLayoutToFile(
   string filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

filePath
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


SaveLayoutToStream Method

[image]
Intersoft WebDesktop Documentation
SaveLayoutToStream Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : SaveLayoutToStream Method

stream
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToStream( _
   ByVal stream As System.IO.Stream, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim stream As System.IO.Stream
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToStream(stream, saveOptions)
C#
public virtual void SaveLayoutToStream(
   System.IO.Stream stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

stream
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


SetRenderMethodDelegate Method

[image]
Intersoft WebDesktop Documentation
SetRenderMethodDelegate Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : SetRenderMethodDelegate Method

renderMethod

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetRenderMethodDelegate( _
   ByVal renderMethod As System.Web.UI.RenderMethod _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim renderMethod As System.Web.UI.RenderMethod

instance.SetRenderMethodDelegate(renderMethod)
C#
public void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod renderMethod
)

Parameters

renderMethod

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


SetSessionTheme Method

[image]
Intersoft WebDesktop Documentation
SetSessionTheme Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : SetSessionTheme Method

themeInfo

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetSessionTheme( _
   ByVal themeInfo As ISNet.WebUI.ThemeInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim themeInfo As ISNet.WebUI.ThemeInfo

instance.SetSessionTheme(themeInfo)
C#
public void SetSessionTheme(
   ISNet.WebUI.ThemeInfo themeInfo
)

Parameters

themeInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


ShouldReturnJson Method

[image]
Intersoft WebDesktop Documentation
ShouldReturnJson Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : ShouldReturnJson Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ShouldReturnJson() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As Boolean

value = instance.ShouldReturnJson()
C#
public virtual bool ShouldReturnJson()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


AccessKey Property

[image]
Intersoft WebDesktop Documentation
AccessKey Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : AccessKey Property

Glossary Item Box

Keyboard shortcut used by the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property AccessKey As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As String

instance.AccessKey = value

value = instance.AccessKey
C#
public virtual string AccessKey {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


WebNotification Class Properties

[image]
Intersoft WebDesktop Documentation
WebNotification Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNotification Class

Glossary Item Box

For a list of all members of this type, see WebNotification members.

Public Properties

 | Name | Description
Public Property | AccessKey | Keyboard shortcut used by the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ActionMenu | Gets the WebMenu object which is the action menu for the notification control.
Public Property | AnimationStyle | Specifies the animation style for this notification control.
Public Property | AutoStart | Specifies whether the control should start the notification process immediately after page load.
Public Property | BackColor | Overridden. Color of the background of the control.
Public Property | BorderColor | Overridden. Border of the color around the control.
Public Property | BorderStyle | Overridden. Style of the border around the control.
Public Property | BorderWidth | Overridden. Width of the border around the control.
Public Property | CaptionStyle | The style applied to Caption element of the notification control.
Public Property | CaptionText | Gets or sets the text displayed in the caption area.
Public Property | CaptionTextStyle |
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ClientSideEvents | Provides client side events available in WebNotification control.
Public Property | CommandStyle | The interactive style applied to Command element of the notification control.
Public Property | ContentImage | Gets or set the image displayed in the content area.
Public Property | ContentStyle | The style applied to the content element of the notification control.
Public Property | ContentText | Gets or sets the text displayed in the content area.
Public Property | ContentVAlign | Gets or sets the vertical alignment of the text relatively to control's Height.
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | DisplayLatency | Gets or sets the time span of the display before the notification disappear.
Public Property | DisplayMode | Gets or sets the display mode for this notification control.
Public Property | DisplayPosition | Gets or sets the display position of the notification.
Public Property | Enabled | Enabled state of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableManagedTheming | Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to False, this control will not apply the style defined in Theme Architecture. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableSound | Specifies whether sound is played when notification occurs.
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | Whether the control automatically saves its state for use in round-trips. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). (Inherited from ISNet.WebUI.ISNetControl)
Public Property | FadingSpeed | When AnimationStyle is set to Fading, specify the speed of the Fading animation effect.
Public Property | Font | Overridden. The font used for text within the control.
Public Property | ForeColor | Overridden. Color of the text within the control.
Public Property | FrameStyle | The style applied to the Frame element of the notification control.
Public Property | Height | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ImageCommandVAlign |
Public Property | ImagePosition | Gets or sets the position of the image relative to the text.
Public Property | ImagesDirectory | Gets or sets the default directory for images specified in ImagesSettings.
Public Property | ImageSize | Gets or sets the default size of image used in entire menu hierarchy.
Public Property | ImagesSettings | Provides settings for images used by WebNotification control.
Public Property | ImageVAlign | Gets or sets the vertical alignment of the image.
Public Property | IntegratedTo | Specifies whether this menu control should be operated in Integration mode. When integrated, the menu will automatically inherit all styles defined in the Integration Object (whether it is PlaceHolderManager or DesktopManager).
Public Property | IntegratedToDesktopManager | Specifies whether the notification should be integrated to DesktopManager. When integrated, the notification will be displayed at desktop level instead of the caller's window.
Public Property | Interval | Gets or sets the time interval, in seconds, between notification data requests.
Public Property | Items | The collection of menu items to be displayed in Action Context Menu.
Public Property | MenuStyleSettings | Containts style and appearance definition for the Menu.
Public Property | NotifyWindowClickable | Specifies whether the notification window is clickable when a notification event occured.
Public Property | NotifyWindowName | Gets or sets the window name which will be used when user clicks on the notification window.
Public Property | NotifyWindowURL | Gets or sets the URL to launch when user clicked on notification window.
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RunOnce | Specifies a boolean value to indicate whether the notification should be performed only once or periodically in specified Interval value.
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden. Gets or sets the directory where all required scripts for the control are stored.
Public Property | ServiceType | Gets or sets the service type used by the notification control to request data.
Public Property | ServiceUrl | Gets or sets the service URL that this control will use for client server communication.
Public Property | SharedScriptDirectory | Overridden. Gets or sets the directory where all shared scripts for Intersoft controls are stored.
Public Property | ShowActionDropdown | Specifies whether action dropdown button is displayed.
Public Property | ShowCloseButton | Specifies whether close button is displayed.
Public Property | ShowDelay | Gets or sets the amount of submenu that shows delay in milliseconds.
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SoundFile | Specifies the valid music file to play on notification. Supported types are midi, wav and au.
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ToolTip | The tooltip displayed when the mouse is over the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateItems | Gets or sets the items to be stored in view state storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | Gets or sets the server connection string for file server-based viewstate storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | Gets or sets the location to store the viewstate of this control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | Indicates whether the control is visible and rendered. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Width | The width of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | XmlCompressionEnabled | Specifies whether the Xml used for clientside state storage should be compressed. (Inherited from ISNet.WebUI.ISNetControl)
Top

See Also

Reference

WebNotification Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Retrieving notifications from webservice

tasks

Retrieving notifications from webform listener
Integrating into WebDesktopManager
Using action context menu
Passing custom properties

Concepts

WebNotification Overview

concepts

Understanding Concepts
WebNotification Features


WebNotification Constructor

[image]
Intersoft WebDesktop Documentation
WebNotification Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : WebNotification Constructor

Glossary Item Box

Initializes a new instance of the WebNotification class.

Overload List

Overload | Description
WebNotification Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


ActionMenu Property

[image]
Intersoft WebDesktop Documentation
ActionMenu Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : ActionMenu Property

Glossary Item Box

Gets the WebMenu object which is the action menu for the notification control.

Syntax

Visual Basic (Declaration)
Public Property ActionMenu As WebMenu
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As WebMenu

instance.ActionMenu = value

value = instance.ActionMenu
C#
public WebMenu ActionMenu {get; set;}

Remarks

You can customize the menu direction and alignment of WebNotification using the ActionMenu property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members

Concepts

WebNotification Features


AnimationStyle Property

[image]
Intersoft WebDesktop Documentation
AnimationStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : AnimationStyle Property

Glossary Item Box

Specifies the animation style for this notification control.

Syntax

Visual Basic (Declaration)
Public Property AnimationStyle As NotificationAnimationStyle
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As NotificationAnimationStyle

instance.AnimationStyle = value

value = instance.AnimationStyle
C#
public NotificationAnimationStyle AnimationStyle {get; set;}

Remarks

Using AnimationStyle you can determine the animation style for visual effects, either Fading or Sliding.

When set to Fading, the WebNotification window will be displayed (fading from transparent to opaque). The animation speed can be set in FadingSpeed property. The Fading mode resembles the Outlook 2003® animation's style and behavior.

The Sliding mode resembles the MSN Messenger® animation's style and behavior where notification window will be slided from bottom to top.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members

Concepts

WebNotification Features


AutoStart Property

[image]
Intersoft WebDesktop Documentation
AutoStart Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : AutoStart Property

Glossary Item Box

Specifies whether the control should start the notification process immediately after page load.

Syntax

Visual Basic (Declaration)
Public Property AutoStart As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As Boolean

instance.AutoStart = value

value = instance.AutoStart
C#
public bool AutoStart {get; set;}

Remarks

You need to set this property to False if you want to prevent the control from starting the timer automatically.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


BackColor Property

[image]
Intersoft WebDesktop Documentation
BackColor Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : BackColor Property

Glossary Item Box

Color of the background of the control.

Syntax

Visual Basic (Declaration)
Public Overrides Property BackColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
C#
public override System.Drawing.Color BackColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


BorderColor Property

[image]
Intersoft WebDesktop Documentation
BorderColor Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : BorderColor Property

Glossary Item Box

Border of the color around the control.

Syntax

Visual Basic (Declaration)
Public Overrides Property BorderColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As System.Drawing.Color

instance.BorderColor = value

value = instance.BorderColor
C#
public override System.Drawing.Color BorderColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


BorderStyle Property

[image]
Intersoft WebDesktop Documentation
BorderStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : BorderStyle Property

Glossary Item Box

Style of the border around the control.

Syntax

Visual Basic (Declaration)
Public Overrides Property BorderStyle As System.Web.UI.WebControls.BorderStyle
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As System.Web.UI.WebControls.BorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
C#
public override System.Web.UI.WebControls.BorderStyle BorderStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


BorderWidth Property

[image]
Intersoft WebDesktop Documentation
BorderWidth Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : BorderWidth Property

Glossary Item Box

Width of the border around the control.

Syntax

Visual Basic (Declaration)
Public Overrides Property BorderWidth As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As System.Web.UI.WebControls.Unit

instance.BorderWidth = value

value = instance.BorderWidth
C#
public override System.Web.UI.WebControls.Unit BorderWidth {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


CaptionStyle Property

[image]
Intersoft WebDesktop Documentation
CaptionStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : CaptionStyle Property

Glossary Item Box

The style applied to Caption element of the notification control.

Syntax

Visual Basic (Declaration)
Public Property CaptionStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As ISNet.WebUI.WebStyle

instance.CaptionStyle = value

value = instance.CaptionStyle
C#
public ISNet.WebUI.WebStyle CaptionStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


CaptionText Property

[image]
Intersoft WebDesktop Documentation
CaptionText Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : CaptionText Property

Glossary Item Box

Gets or sets the text displayed in the caption area.

Syntax

Visual Basic (Declaration)
Public Property CaptionText As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As String

instance.CaptionText = value

value = instance.CaptionText
C#
public string CaptionText {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


CaptionTextStyle Property

[image]
Intersoft WebDesktop Documentation
CaptionTextStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : CaptionTextStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property CaptionTextStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As ISNet.WebUI.WebStyle

instance.CaptionTextStyle = value

value = instance.CaptionTextStyle
C#
public ISNet.WebUI.WebStyle CaptionTextStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


ClientIDMode Property

[image]
Intersoft WebDesktop Documentation
ClientIDMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : ClientIDMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ClientIDMode As System.Web.UI.ClientIDMode
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As System.Web.UI.ClientIDMode

instance.ClientIDMode = value

value = instance.ClientIDMode
C#
public virtual System.Web.UI.ClientIDMode ClientIDMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


ClientSideEvents Property

[image]
Intersoft WebDesktop Documentation
ClientSideEvents Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : ClientSideEvents Property

Glossary Item Box

Provides client side events available in WebNotification control.

Syntax

Visual Basic (Declaration)
Public Property ClientSideEvents As WebNotificationClientSideEvents
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As WebNotificationClientSideEvents

instance.ClientSideEvents = value

value = instance.ClientSideEvents
C#
public WebNotificationClientSideEvents ClientSideEvents {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


CommandStyle Property

[image]
Intersoft WebDesktop Documentation
CommandStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : CommandStyle Property

Glossary Item Box

The interactive style applied to Command element of the notification control.

Syntax

Visual Basic (Declaration)
Public Property CommandStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As ISNet.WebUI.DynamicStyle

instance.CommandStyle = value

value = instance.CommandStyle
C#
public ISNet.WebUI.DynamicStyle CommandStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


ContentImage Property

[image]
Intersoft WebDesktop Documentation
ContentImage Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : ContentImage Property

Glossary Item Box

Gets or set the image displayed in the content area.

Syntax

Visual Basic (Declaration)
Public Property ContentImage As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As String

instance.ContentImage = value

value = instance.ContentImage
C#
public string ContentImage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


ContentStyle Property

[image]
Intersoft WebDesktop Documentation
ContentStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : ContentStyle Property

Glossary Item Box

The style applied to the content element of the notification control.

Syntax

Visual Basic (Declaration)
Public Property ContentStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As ISNet.WebUI.WebStyle

instance.ContentStyle = value

value = instance.ContentStyle
C#
public ISNet.WebUI.WebStyle ContentStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


ContentText Property

[image]
Intersoft WebDesktop Documentation
ContentText Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : ContentText Property

Glossary Item Box

Gets or sets the text displayed in the content area.

Syntax

Visual Basic (Declaration)
Public Property ContentText As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As String

instance.ContentText = value

value = instance.ContentText
C#
public string ContentText {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


ContentVAlign Property

[image]
Intersoft WebDesktop Documentation
ContentVAlign Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : ContentVAlign Property

Glossary Item Box

Gets or sets the vertical alignment of the text relatively to control's Height.

Syntax

Visual Basic (Declaration)
Public Property ContentVAlign As ISNet.WebUI.VerticalAlign
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As ISNet.WebUI.VerticalAlign

instance.ContentVAlign = value

value = instance.ContentVAlign
C#
public ISNet.WebUI.VerticalAlign ContentVAlign {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


ControlDataTransferFormat Property

[image]
Intersoft WebDesktop Documentation
ControlDataTransferFormat Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : ControlDataTransferFormat Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ControlDataTransferFormat As ISNet.WebUI.DataTransferFormat
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As ISNet.WebUI.DataTransferFormat

instance.ControlDataTransferFormat = value

value = instance.ControlDataTransferFormat
C#
public virtual ISNet.WebUI.DataTransferFormat ControlDataTransferFormat {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


DisplayLatency Property

[image]
Intersoft WebDesktop Documentation
DisplayLatency Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : DisplayLatency Property

Glossary Item Box

Gets or sets the time span of the display before the notification disappear.

Syntax

Visual Basic (Declaration)
Public Property DisplayLatency As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As Integer

instance.DisplayLatency = value

value = instance.DisplayLatency
C#
public int DisplayLatency {get; set;}

Remarks

This property allows you to control how long a notification window should stay visible to the user. The default value of this property is 5 seconds.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


DisplayMode Property

[image]
Intersoft WebDesktop Documentation
DisplayMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : DisplayMode Property

Glossary Item Box

Gets or sets the display mode for this notification control.

Syntax

Visual Basic (Declaration)
Public Property DisplayMode As DisplayMode
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As DisplayMode

instance.DisplayMode = value

value = instance.DisplayMode
C#
public DisplayMode DisplayMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


DisplayPosition Property

[image]
Intersoft WebDesktop Documentation
DisplayPosition Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : DisplayPosition Property

Glossary Item Box

Gets or sets the display position of the notification.

Syntax

Visual Basic (Declaration)
Public Property DisplayPosition As ISNet.WebUI.DisplayPosition
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As ISNet.WebUI.DisplayPosition

instance.DisplayPosition = value

value = instance.DisplayPosition
C#
public ISNet.WebUI.DisplayPosition DisplayPosition {get; set;}

Remarks

The default value of DisplayPosition property is RightBottom. You may want to change the display to other position, such as RightTop, LeftTop, LeftBottom, etc.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


Enabled Property

[image]
Intersoft WebDesktop Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : Enabled Property

Glossary Item Box

Enabled state of the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property Enabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As Boolean

instance.Enabled = value

value = instance.Enabled
C#
public virtual bool Enabled {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


EnableManagedTheming Property

[image]
Intersoft WebDesktop Documentation
EnableManagedTheming Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : EnableManagedTheming Property

Glossary Item Box

Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to False, this control will not apply the style defined in Theme Architecture.

Syntax

Visual Basic (Declaration)
Public Overridable Property EnableManagedTheming As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As Boolean

instance.EnableManagedTheming = value

value = instance.EnableManagedTheming
C#
public virtual bool EnableManagedTheming {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


EnableSound Property

[image]
Intersoft WebDesktop Documentation
EnableSound Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : EnableSound Property

Glossary Item Box

Specifies whether sound is played when notification occurs.

Syntax

Visual Basic (Declaration)
Public Property EnableSound As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As Boolean

instance.EnableSound = value

value = instance.EnableSound
C#
public bool EnableSound {get; set;}

Remarks

After you have set this property to True, you need to set the SoundFile property to a valid sound file URL. Supported sound types are midi, wav and au.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members

Concepts

WebNotification Features


EnableTheming Property

[image]
Intersoft WebDesktop Documentation
EnableTheming Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : EnableTheming Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property EnableTheming As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As Boolean

instance.EnableTheming = value

value = instance.EnableTheming
C#
public virtual bool EnableTheming {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


EnableViewState Property

[image]
Intersoft WebDesktop Documentation
EnableViewState Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : EnableViewState Property

Glossary Item Box

Whether the control automatically saves its state for use in round-trips.

Syntax

Visual Basic (Declaration)
Public Overridable Property EnableViewState As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As Boolean

instance.EnableViewState = value

value = instance.EnableViewState
C#
public virtual bool EnableViewState {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


EnableWebResources Property

[image]
Intersoft WebDesktop Documentation
EnableWebResources Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : EnableWebResources Property

Glossary Item Box

Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory).

Syntax

Visual Basic (Declaration)
Public Property EnableWebResources As ISNet.WebUI.WebResourceType
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As ISNet.WebUI.WebResourceType

instance.EnableWebResources = value

value = instance.EnableWebResources
C#
public ISNet.WebUI.WebResourceType EnableWebResources {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


FadingSpeed Property

[image]
Intersoft WebDesktop Documentation
FadingSpeed Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : FadingSpeed Property

Glossary Item Box

When AnimationStyle is set to Fading, specify the speed of the Fading animation effect.

Syntax

Visual Basic (Declaration)
Public Property FadingSpeed As AnimationSpeed
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As AnimationSpeed

instance.FadingSpeed = value

value = instance.FadingSpeed
C#
public AnimationSpeed FadingSpeed {get; set;}

Remarks

The default value of this property is Slow. However, you can configure it to Medium or Fast.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members

Concepts

WebNotification Features


Font Property

[image]
Intersoft WebDesktop Documentation
Font Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : Font Property

Glossary Item Box

The font used for text within the control.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Font As System.Web.UI.WebControls.FontInfo
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As System.Web.UI.WebControls.FontInfo

value = instance.Font
C#
public override System.Web.UI.WebControls.FontInfo Font {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


ForeColor Property

[image]
Intersoft WebDesktop Documentation
ForeColor Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : ForeColor Property

Glossary Item Box

Color of the text within the control.

Syntax

Visual Basic (Declaration)
Public Overrides Property ForeColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
C#
public override System.Drawing.Color ForeColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


FrameStyle Property

[image]
Intersoft WebDesktop Documentation
FrameStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : FrameStyle Property

Glossary Item Box

The style applied to the Frame element of the notification control.

Syntax

Visual Basic (Declaration)
Public Property FrameStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As ISNet.WebUI.WebStyle

instance.FrameStyle = value

value = instance.FrameStyle
C#
public ISNet.WebUI.WebStyle FrameStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


Height Property

[image]
Intersoft WebDesktop Documentation
Height Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : Height Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Height As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As System.Web.UI.WebControls.Unit

instance.Height = value

value = instance.Height
C#
public virtual System.Web.UI.WebControls.Unit Height {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


ID Property

[image]
Intersoft WebDesktop Documentation
ID Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : ID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ID As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As String

instance.ID = value

value = instance.ID
C#
public virtual string ID {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


ImageCommandVAlign Property

[image]
Intersoft WebDesktop Documentation
ImageCommandVAlign Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : ImageCommandVAlign Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ImageCommandVAlign As ISNet.WebUI.VerticalAlign
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As ISNet.WebUI.VerticalAlign

instance.ImageCommandVAlign = value

value = instance.ImageCommandVAlign
C#
public ISNet.WebUI.VerticalAlign ImageCommandVAlign {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


ImagePosition Property

[image]
Intersoft WebDesktop Documentation
ImagePosition Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : ImagePosition Property

Glossary Item Box

Gets or sets the position of the image relative to the text.

Syntax

Visual Basic (Declaration)
Public Property ImagePosition As ImagePosition
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As ImagePosition

instance.ImagePosition = value

value = instance.ImagePosition
C#
public ImagePosition ImagePosition {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


ImagesDirectory Property

[image]
Intersoft WebDesktop Documentation
ImagesDirectory Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : ImagesDirectory Property

Glossary Item Box

Gets or sets the default directory for images specified in ImagesSettings.

Syntax

Visual Basic (Declaration)
Public Property ImagesDirectory As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As String

instance.ImagesDirectory = value

value = instance.ImagesDirectory
C#
public string ImagesDirectory {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


ImageSize Property

[image]
Intersoft WebDesktop Documentation
ImageSize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : ImageSize Property

Glossary Item Box

Gets or sets the default size of image used in entire menu hierarchy.

Syntax

Visual Basic (Declaration)
Public Property ImageSize As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As System.Drawing.Size

instance.ImageSize = value

value = instance.ImageSize
C#
public System.Drawing.Size ImageSize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


ImagesSettings Property

[image]
Intersoft WebDesktop Documentation
ImagesSettings Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : ImagesSettings Property

Glossary Item Box

Provides settings for images used by WebNotification control.

Syntax

Visual Basic (Declaration)
Public Property ImagesSettings As WebNotificationImagesSettings
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As WebNotificationImagesSettings

instance.ImagesSettings = value

value = instance.ImagesSettings
C#
public WebNotificationImagesSettings ImagesSettings {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


ImageVAlign Property

[image]
Intersoft WebDesktop Documentation
ImageVAlign Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : ImageVAlign Property

Glossary Item Box

Gets or sets the vertical alignment of the image.

Syntax

Visual Basic (Declaration)
Public Property ImageVAlign As ISNet.WebUI.VerticalAlign
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As ISNet.WebUI.VerticalAlign

instance.ImageVAlign = value

value = instance.ImageVAlign
C#
public ISNet.WebUI.VerticalAlign ImageVAlign {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


IntegratedTo Property

[image]
Intersoft WebDesktop Documentation
IntegratedTo Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : IntegratedTo Property

Glossary Item Box

Specifies whether this menu control should be operated in Integration mode. When integrated, the menu will automatically inherit all styles defined in the Integration Object (whether it is PlaceHolderManager or DesktopManager).

Syntax

Visual Basic (Declaration)
Public Property IntegratedTo As MenuIntegrationMode
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As MenuIntegrationMode

instance.IntegratedTo = value

value = instance.IntegratedTo
C#
public MenuIntegrationMode IntegratedTo {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


IntegratedToDesktopManager Property

[image]
Intersoft WebDesktop Documentation
IntegratedToDesktopManager Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : IntegratedToDesktopManager Property

Glossary Item Box

Specifies whether the notification should be integrated to DesktopManager. When integrated, the notification will be displayed at desktop level instead of the caller's window.

Syntax

Visual Basic (Declaration)
Public Property IntegratedToDesktopManager As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As Boolean

instance.IntegratedToDesktopManager = value

value = instance.IntegratedToDesktopManager
C#
public bool IntegratedToDesktopManager {get; set;}

Remarks

By setting this property to True, you can set the WebNotification control to be integrated into the WebDesktopManager instance which hosts the WebForm. When integrated, the notification popup window will be displayed at desktop level instead of current Window. This feature enables end users to conveniently access to the notification popup regardless of the active Window.

When WebNotification is integrated to WebDesktopManager, the notification popup window will be displayed at desktop level instead of current Window. This feature enables end users to conveniently access the notification popup regardless of the active Window.

The display position of the notification popup window is set to RightBottom by default (as in most modern applications). You may want to change the display to other position by changing the DisplayPosition property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members

Tasks

Integrating into WebDesktopManager

Concepts

WebNotification Features


Interval Property

[image]
Intersoft WebDesktop Documentation
Interval Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : Interval Property

Glossary Item Box

Gets or sets the time interval, in seconds, between notification data requests.

Syntax

Visual Basic (Declaration)
Public Property Interval As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As Integer

instance.Interval = value

value = instance.Interval
C#
public int Interval {get; set;}

Remarks

Using this property you can specify how often the control should check for new notifications. The default value of this property is 5 seconds.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


Items Property

[image]
Intersoft WebDesktop Documentation
Items Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : Items Property

Glossary Item Box

The collection of menu items to be displayed in Action Context Menu.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Items As WebMenuItemCollection
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As WebMenuItemCollection

value = instance.Items
C#
public WebMenuItemCollection Items {get;}

Remarks

Using this property you can use Action context menu in WebNotification which provides a way for end users to access a list of available actions and perform an action against notification event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members

Tasks

Using action context menu

Concepts

WebNotification Features


MenuStyleSettings Property

[image]
Intersoft WebDesktop Documentation
MenuStyleSettings Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : MenuStyleSettings Property

Glossary Item Box

Containts style and appearance definition for the Menu.

Syntax

Visual Basic (Declaration)
Public Property MenuStyleSettings As WebMenuStyles
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As WebMenuStyles

instance.MenuStyleSettings = value

value = instance.MenuStyleSettings
C#
public WebMenuStyles MenuStyleSettings {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


NotifyWindowClickable Property

[image]
Intersoft WebDesktop Documentation
NotifyWindowClickable Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : NotifyWindowClickable Property

Glossary Item Box

Specifies whether the notification window is clickable when a notification event occured.

Syntax

Visual Basic (Declaration)
Public Property NotifyWindowClickable As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As Boolean

instance.NotifyWindowClickable = value

value = instance.NotifyWindowClickable
C#
public bool NotifyWindowClickable {get; set;}

Remarks

You can enable the clickable window by simply setting this property to True, which allows you to set the popup window as clickable when the notification popup window appears. Using this feature you can redirect the users to other page when the control's window is displayed due to a notifiy event. For instance, you may want to launch the Mail Inbox home page when users clicked on the new email notification event.

You would also need to set the corresponding URL in the NotifyWindowURL property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members

Concepts

WebNotification Features


NotifyWindowName Property

[image]
Intersoft WebDesktop Documentation
NotifyWindowName Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : NotifyWindowName Property

Glossary Item Box

Gets or sets the window name which will be used when user clicks on the notification window.

Syntax

Visual Basic (Declaration)
Public Property NotifyWindowName As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As String

instance.NotifyWindowName = value

value = instance.NotifyWindowName
C#
public string NotifyWindowName {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


NotifyWindowURL Property

[image]
Intersoft WebDesktop Documentation
NotifyWindowURL Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : NotifyWindowURL Property

Glossary Item Box

Gets or sets the URL to launch when user clicked on notification window.

Syntax

Visual Basic (Declaration)
Public Property NotifyWindowURL As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As String

instance.NotifyWindowURL = value

value = instance.NotifyWindowURL
C#
public string NotifyWindowURL {get; set;}

Remarks

After you have enabled clickable window by setting NotifyWindowClickable to True, you need to set the corresponding URL in the NotifyWindowURL property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members

Concepts

WebNotification Features


Page Property

[image]
Intersoft WebDesktop Documentation
Page Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : Page Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Page As System.Web.UI.Page
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As System.Web.UI.Page

instance.Page = value

value = instance.Page
C#
public virtual System.Web.UI.Page Page {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


RenderingMode Property

[image]
Intersoft WebDesktop Documentation
RenderingMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : RenderingMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property RenderingMode As ISNet.WebUI.RenderMode
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As ISNet.WebUI.RenderMode

instance.RenderingMode = value

value = instance.RenderingMode
C#
public virtual ISNet.WebUI.RenderMode RenderingMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


RunOnce Property

[image]
Intersoft WebDesktop Documentation
RunOnce Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : RunOnce Property

Glossary Item Box

Specifies a boolean value to indicate whether the notification should be performed only once or periodically in specified Interval value.

Syntax

Visual Basic (Declaration)
Public Property RunOnce As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As Boolean

instance.RunOnce = value

value = instance.RunOnce
C#
public bool RunOnce {get; set;}

Remarks

You need to set this property to True if you want the control to run only once instead of periodically.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


RuntimeLicenseKey Property

[image]
Intersoft WebDesktop Documentation
RuntimeLicenseKey Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : RuntimeLicenseKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property RuntimeLicenseKey As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As String

instance.RuntimeLicenseKey = value

value = instance.RuntimeLicenseKey
C#
public virtual string RuntimeLicenseKey {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


ScriptDirectory Property

[image]
Intersoft WebDesktop Documentation
ScriptDirectory Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : ScriptDirectory Property

Glossary Item Box

Gets or sets the directory where all required scripts for the control are stored.

Syntax

Visual Basic (Declaration)
Public Overrides Property ScriptDirectory As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As String

instance.ScriptDirectory = value

value = instance.ScriptDirectory
C#
public override string ScriptDirectory {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


ServiceType Property

[image]
Intersoft WebDesktop Documentation
ServiceType Property
See Also Example Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : ServiceType Property

Glossary Item Box

Gets or sets the service type used by the notification control to request data.

Syntax

Visual Basic (Declaration)
Public Property ServiceType As ServiceType
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As ServiceType

instance.ServiceType = value

value = instance.ServiceType
C#
public ServiceType ServiceType {get; set;}

Remarks

WebNotification provides two types ServiceType. They are WebForm ServiceType and WebService ServiceType.

  • WebForm ServiceType.
    This is the default value for ServiceType property. WebForm mode is recommended when the data provider is private and does not need to be exposed. With this mode, you need to set the WebForm (aspx) page which the control will invoke. You can set the ServiceUrl to either the current caller page or another WebForm page in the application.
  • WebService ServiceType.
    This type allows you to retrieve Notifications data from a web service (asmx) page. When set to this mode, you set the ServiceUrl to the web service page containing the method required by WebNotification control. The WebService mode is the recommended data provider setting when the methods need to be exposed for other usage. Note that both WebForm and WebService have similar method signature and returned object type. This allows you to easily switch between WebForm and WebService as necessary in certain phase of development.

Example

The following example shows you the WebNotification that use WebService engine as its ServiceType is set to WebService (default). The WebNotification control will look for 'GetNotifications' method in the specified webservice page (WebNotificationService3.asmx in this example). For better understanding please refer to 'WebFormType.aspx' in WebDesktopSamples.
C# Copy Code
[WebMethod]
public WebNotificationEventCollection GetNotifications(WebNotificationEventArgs e)
{
         WebNotificationEventCollection collection = new WebNotificationEventCollection();
         WebNotificationEvent evnt = new WebNotificationEvent();

         evnt.CaptionText = "Samples";
         evnt.ContentText = "Hello world from WebNotification!\nCurrent time is:" + DateTime.Now.ToLongTimeString();

         collection.Notifications = new WebNotificationEvent[] { evnt };
         return collection;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members

Concepts

WebNotification Features

Tasks

Retrieving notifications from webservice

tasks

Retrieving simple types using WebForm service


ServiceUrl Property

[image]
Intersoft WebDesktop Documentation
ServiceUrl Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : ServiceUrl Property

Glossary Item Box

Gets or sets the service URL that this control will use for client server communication.

Syntax

Visual Basic (Declaration)
Public Property ServiceUrl As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As String

instance.ServiceUrl = value

value = instance.ServiceUrl
C#
public string ServiceUrl {get; set;}

Remarks

When the ServiceType is set to WebForm, you can set the ServiceUrl to either the current caller page or another WebForm page in the application. The best practice for WebForm ServiceType is by assigning the ServiceUrl to another WebForm page which is created to serve the notifications purpose. With this flexibility, you are no longer restricted to call the self current page which exposes performance issues and ineffective codes design.

When the ServiceType is set to WebService, you can set the ServiceUrl to the web service page containing the method required by WebNotification control. For more information please refer to WebNotification Features.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members

Tasks

Retrieving notifications from webservice

tasks

Retrieving notifications from webform listener

Concepts

WebNotification Features


SharedScriptDirectory Property

[image]
Intersoft WebDesktop Documentation
SharedScriptDirectory Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : SharedScriptDirectory Property

Glossary Item Box

Gets or sets the directory where all shared scripts for Intersoft controls are stored.

Syntax

Visual Basic (Declaration)
Public Overrides Property SharedScriptDirectory As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As String

instance.SharedScriptDirectory = value

value = instance.SharedScriptDirectory
C#
public override string SharedScriptDirectory {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


ShowActionDropdown Property

[image]
Intersoft WebDesktop Documentation
ShowActionDropdown Property
See Also Example Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : ShowActionDropdown Property

Glossary Item Box

Specifies whether action dropdown button is displayed.

Syntax

Visual Basic (Declaration)
Public Property ShowActionDropdown As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As Boolean

instance.ShowActionDropdown = value

value = instance.ShowActionDropdown
C#
public bool ShowActionDropdown {get; set;}

Remarks

Using this property you can enable action context menu on WebNotification. Action context menu provides a way for end users to access a list of available actions and perform an action against notification event. The Action context menu takes advantage of Hybrid Menu architecture and Visual Menu Builder for design consistency and enhanced integrated development experience.

To enable action context menu, simply set the ShowActionDropdown to true then defines the menu items. You can also manipulate the action menu items programmatically at client side, such as during OnActionClick client side event.

Example

The following example shows you how to use action context menu in WebNotification. You need to create a WebService page in the same directory. (For instance, name it NotificationService.asmx, then it will automatically create NotificationService.cs in the App_code folder).The codes below is used GetNotifications method in WebService. To learn more please refer to Using Action Context Menu in See Also section.
C# Copy Code
[WebMethod]
public WebNotificationEventCollection GetNotifications(WebNotificationEventArgs e)
{
        WebNotificationEventCollection collection = new WebNotificationEventCollection();
        WebNotificationEvent evnt = new WebNotificationEvent();

        evnt.CaptionText = "Samples";
        evnt.ContentText = "Hello world from WebNotification!\nCurrent time is:" + DateTime.Now.ToLongTimeString();

        collection.Notifications = new WebNotificationEvent[] { evnt };
        return collection;
}
In addition to the codes above, you also need to add client side script for OnClick event to use action context menu in WebNotification.
JScript Copy Code
<script language="javascript" type="text/javascript">
        function doClick(mi)
        {
                alert("Clicked : " + mi.Name);
        }
</script>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members

Tasks

Using action context menu

Concepts

WebNotification Features

concepts

Hybrid Menu System
Visual Menu Builder


ShowCloseButton Property

[image]
Intersoft WebDesktop Documentation
ShowCloseButton Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : ShowCloseButton Property

Glossary Item Box

Specifies whether close button is displayed.

Syntax

Visual Basic (Declaration)
Public Property ShowCloseButton As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As Boolean

instance.ShowCloseButton = value

value = instance.ShowCloseButton
C#
public bool ShowCloseButton {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


ShowDelay Property

[image]
Intersoft WebDesktop Documentation
ShowDelay Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : ShowDelay Property

Glossary Item Box

Gets or sets the amount of submenu that shows delay in milliseconds.

Syntax

Visual Basic (Declaration)
Public Property ShowDelay As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As Integer

instance.ShowDelay = value

value = instance.ShowDelay
C#
public int ShowDelay {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


SkinID Property

[image]
Intersoft WebDesktop Documentation
SkinID Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : SkinID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property SkinID As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As String

instance.SkinID = value

value = instance.SkinID
C#
public virtual string SkinID {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


SoundFile Property

[image]
Intersoft WebDesktop Documentation
SoundFile Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : SoundFile Property

Glossary Item Box

Specifies the valid music file to play on notification. Supported types are midi, wav and au.

Syntax

Visual Basic (Declaration)
Public Property SoundFile As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As String

instance.SoundFile = value

value = instance.SoundFile
C#
public string SoundFile {get; set;}

Remarks

The sound effect feature works in Internet Explorer browsers without any extra efforts. However, this feature requires Sound System plug-in for Mozilla-based browsers to work properly.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members

Concepts

WebNotification Features


TabIndex Property

[image]
Intersoft WebDesktop Documentation
TabIndex Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : TabIndex Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property TabIndex As Short
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As Short

instance.TabIndex = value

value = instance.TabIndex
C#
public virtual short TabIndex {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


ToolTip Property

[image]
Intersoft WebDesktop Documentation
ToolTip Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : ToolTip Property

Glossary Item Box

The tooltip displayed when the mouse is over the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property ToolTip As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As String

instance.ToolTip = value

value = instance.ToolTip
C#
public virtual string ToolTip {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


ValidateRequestMode Property

[image]
Intersoft WebDesktop Documentation
ValidateRequestMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : ValidateRequestMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ValidateRequestMode As System.Web.UI.ValidateRequestMode
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As System.Web.UI.ValidateRequestMode

instance.ValidateRequestMode = value

value = instance.ValidateRequestMode
C#
public virtual System.Web.UI.ValidateRequestMode ValidateRequestMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


ViewStateItems Property

[image]
Intersoft WebDesktop Documentation
ViewStateItems Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : ViewStateItems Property

Glossary Item Box

Gets or sets the items to be stored in view state storage.

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateItems As ISNet.WebUI.ViewStateItem
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As ISNet.WebUI.ViewStateItem

instance.ViewStateItems = value

value = instance.ViewStateItems
C#
public virtual ISNet.WebUI.ViewStateItem ViewStateItems {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


ViewStateMode Property

[image]
Intersoft WebDesktop Documentation
ViewStateMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : ViewStateMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateMode As System.Web.UI.ViewStateMode
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As System.Web.UI.ViewStateMode

instance.ViewStateMode = value

value = instance.ViewStateMode
C#
public virtual System.Web.UI.ViewStateMode ViewStateMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


ViewStateServerConnection Property

[image]
Intersoft WebDesktop Documentation
ViewStateServerConnection Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : ViewStateServerConnection Property

Glossary Item Box

Gets or sets the server connection string for file server-based viewstate storage.

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateServerConnection As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As String

instance.ViewStateServerConnection = value

value = instance.ViewStateServerConnection
C#
public virtual string ViewStateServerConnection {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


ViewStateStorage Property

[image]
Intersoft WebDesktop Documentation
ViewStateStorage Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : ViewStateStorage Property

Glossary Item Box

Gets or sets the location to store the viewstate of this control.

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateStorage As ISNet.WebUI.StateCacheStorage
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As ISNet.WebUI.StateCacheStorage

instance.ViewStateStorage = value

value = instance.ViewStateStorage
C#
public virtual ISNet.WebUI.StateCacheStorage ViewStateStorage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


Visible Property

[image]
Intersoft WebDesktop Documentation
Visible Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : Visible Property

Glossary Item Box

Indicates whether the control is visible and rendered.

Syntax

Visual Basic (Declaration)
Public Overridable Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public virtual bool Visible {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


Width Property

[image]
Intersoft WebDesktop Documentation
Width Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : Width Property

Glossary Item Box

The width of the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property Width As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As System.Web.UI.WebControls.Unit

instance.Width = value

value = instance.Width
C#
public virtual System.Web.UI.WebControls.Unit Width {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


XmlCompressionEnabled Property

[image]
Intersoft WebDesktop Documentation
XmlCompressionEnabled Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : XmlCompressionEnabled Property

Glossary Item Box

Specifies whether the Xml used for clientside state storage should be compressed.

Syntax

Visual Basic (Declaration)
Public Overridable Property XmlCompressionEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim value As Boolean

instance.XmlCompressionEnabled = value

value = instance.XmlCompressionEnabled
C#
public virtual bool XmlCompressionEnabled {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


DataBinding Event

[image]
Intersoft WebDesktop Documentation
DataBinding Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : DataBinding Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event DataBinding As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim handler As EventHandler

AddHandler instance.DataBinding, handler
C#
public event EventHandler DataBinding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


Disposed Event

[image]
Intersoft WebDesktop Documentation
Disposed Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim handler As EventHandler

AddHandler instance.Disposed, handler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


Init Event

[image]
Intersoft WebDesktop Documentation
Init Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : Init Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Init As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim handler As EventHandler

AddHandler instance.Init, handler
C#
public event EventHandler Init

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


Load Event

[image]
Intersoft WebDesktop Documentation
Load Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : Load Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Load As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim handler As EventHandler

AddHandler instance.Load, handler
C#
public event EventHandler Load

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


PreInitialize Event

[image]
Intersoft WebDesktop Documentation
PreInitialize Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : PreInitialize Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event PreInitialize As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim handler As EventHandler

AddHandler instance.PreInitialize, handler
C#
public event EventHandler PreInitialize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


PreRender Event

[image]
Intersoft WebDesktop Documentation
PreRender Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : PreRender Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event PreRender As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim handler As EventHandler

AddHandler instance.PreRender, handler
C#
public event EventHandler PreRender

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


Unload Event

[image]
Intersoft WebDesktop Documentation
Unload Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotification Class : Unload Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Unload As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebNotification
Dim handler As EventHandler

AddHandler instance.Unload, handler
C#
public event EventHandler Unload

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotification Class
WebNotification Members


WebNotificationClientSideEvents Class

[image]
Intersoft WebDesktop Documentation
WebNotificationClientSideEvents Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNotificationClientSideEvents Class

Glossary Item Box

Javascript functions which invoked from client side in WebNotification.

Object Model

WebNotificationClientSideEvents Class

Syntax

Visual Basic (Declaration)
Public Class WebNotificationClientSideEvents
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebNotificationClientSideEvents
C#
public class WebNotificationClientSideEvents : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebDesktop.WebNotificationClientSideEvents

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationClientSideEvents Members
ISNet.WebUI.WebDesktop Namespace


WebNotificationClientSideEvents Class Members

[image]
Intersoft WebDesktop Documentation
WebNotificationClientSideEvents Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNotificationClientSideEvents Class

Glossary Item Box

The following tables list the members exposed by WebNotificationClientSideEvents.

Public Constructors

 | Name | Description
Public Constructor | WebNotificationClientSideEvents Constructor |
Top

Public Properties

 | Name | Description
Public Property | OnActionClick | The javascript function that will be invoked when user clicks on the Action dropdown button.
Public Property | OnBeforeRequest | The javascript function that will be invoked before the control performs request.
Public Property | OnClick | The javascript function that will be invoked when user clicks on the notification window.
Public Property | OnClose | The javascript function that will be invoked when user closes the notification window.
Public Property | OnError | The javascript function that will be invoked when error is received during response.
Public Property | OnInitialize | The javascript function that will be invoked during control initialization.
Public Property | OnNotify | The javascript function that will be invoked when the control returns at least one notification.
Public Property | OnResponse | The javascript function that will be invoked after the control receives response from server.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebNotificationClientSideEvents Class
ISNet.WebUI.WebDesktop Namespace


WebNotificationClientSideEvents Constructor

[image]
Intersoft WebDesktop Documentation
WebNotificationClientSideEvents Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationClientSideEvents Class : WebNotificationClientSideEvents Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebNotificationClientSideEvents()
C#
public WebNotificationClientSideEvents()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationClientSideEvents Class
WebNotificationClientSideEvents Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationClientSideEvents Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebNotificationClientSideEvents
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationClientSideEvents Class
WebNotificationClientSideEvents Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationClientSideEvents Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationClientSideEvents Class
WebNotificationClientSideEvents Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationClientSideEvents Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNotificationClientSideEvents
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationClientSideEvents Class
WebNotificationClientSideEvents Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationClientSideEvents Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNotificationClientSideEvents
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationClientSideEvents Class
WebNotificationClientSideEvents Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationClientSideEvents Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNotificationClientSideEvents
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationClientSideEvents Class
WebNotificationClientSideEvents Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationClientSideEvents Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebNotificationClientSideEvents
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationClientSideEvents Class
WebNotificationClientSideEvents Members


WebNotificationClientSideEvents Class Methods

[image]
Intersoft WebDesktop Documentation
WebNotificationClientSideEvents Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNotificationClientSideEvents Class

Glossary Item Box

For a list of all members of this type, see WebNotificationClientSideEvents members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebNotificationClientSideEvents Class
ISNet.WebUI.WebDesktop Namespace


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationClientSideEvents Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNotificationClientSideEvents
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationClientSideEvents Class
WebNotificationClientSideEvents Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationClientSideEvents Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNotificationClientSideEvents
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationClientSideEvents Class
WebNotificationClientSideEvents Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationClientSideEvents Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebNotificationClientSideEvents

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationClientSideEvents Class
WebNotificationClientSideEvents Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationClientSideEvents Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNotificationClientSideEvents
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationClientSideEvents Class
WebNotificationClientSideEvents Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationClientSideEvents Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotificationClientSideEvents
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationClientSideEvents Class
WebNotificationClientSideEvents Members


WebNotificationClientSideEvents Class Properties

[image]
Intersoft WebDesktop Documentation
WebNotificationClientSideEvents Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNotificationClientSideEvents Class

Glossary Item Box

For a list of all members of this type, see WebNotificationClientSideEvents members.

Public Properties

 | Name | Description
Public Property | OnActionClick | The javascript function that will be invoked when user clicks on the Action dropdown button.
Public Property | OnBeforeRequest | The javascript function that will be invoked before the control performs request.
Public Property | OnClick | The javascript function that will be invoked when user clicks on the notification window.
Public Property | OnClose | The javascript function that will be invoked when user closes the notification window.
Public Property | OnError | The javascript function that will be invoked when error is received during response.
Public Property | OnInitialize | The javascript function that will be invoked during control initialization.
Public Property | OnNotify | The javascript function that will be invoked when the control returns at least one notification.
Public Property | OnResponse | The javascript function that will be invoked after the control receives response from server.
Top

See Also

Reference

WebNotificationClientSideEvents Class
ISNet.WebUI.WebDesktop Namespace


WebNotificationClientSideEvents Constructor

[image]
Intersoft WebDesktop Documentation
WebNotificationClientSideEvents Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationClientSideEvents Class : WebNotificationClientSideEvents Constructor

Glossary Item Box

Initializes a new instance of the WebNotificationClientSideEvent class.

Overload List

Overload | Description
WebNotificationClientSideEvents Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationClientSideEvents Class
WebNotificationClientSideEvents Members


OnActionClick Property

[image]
Intersoft WebDesktop Documentation
OnActionClick Property
See Also Example Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationClientSideEvents Class : OnActionClick Property

Glossary Item Box

The javascript function that will be invoked when user clicks on the Action dropdown button.

Syntax

Visual Basic (Declaration)
Public Property OnActionClick As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotificationClientSideEvents
Dim value As String

instance.OnActionClick = value

value = instance.OnActionClick
C#
public string OnActionClick {get; set;}

Remarks

You can use this property to manipulate the action menu items programmatically at client side.

Example

The following javascript codes is used when you want to create action context menu in WebNotification. The codes is invoked to display the popup window when user click on menu item. To learn more please refer to Using Action Context Menu in See Also section.
JScript Copy Code
<script language="javascript" type="text/javascript">
        function doClick(mi)
        {
                alert("Clicked : " + mi.Name);
        }
</script>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationClientSideEvents Class
WebNotificationClientSideEvents Members

Tasks

Using action context menu

Concepts

WebNotification Features


OnBeforeRequest Property

[image]
Intersoft WebDesktop Documentation
OnBeforeRequest Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationClientSideEvents Class : OnBeforeRequest Property

Glossary Item Box

The javascript function that will be invoked before the control performs request.

Syntax

Visual Basic (Declaration)
Public Property OnBeforeRequest As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotificationClientSideEvents
Dim value As String

instance.OnBeforeRequest = value

value = instance.OnBeforeRequest
C#
public string OnBeforeRequest {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationClientSideEvents Class
WebNotificationClientSideEvents Members


OnClick Property

[image]
Intersoft WebDesktop Documentation
OnClick Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationClientSideEvents Class : OnClick Property

Glossary Item Box

The javascript function that will be invoked when user clicks on the notification window.

Syntax

Visual Basic (Declaration)
Public Property OnClick As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotificationClientSideEvents
Dim value As String

instance.OnClick = value

value = instance.OnClick
C#
public string OnClick {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationClientSideEvents Class
WebNotificationClientSideEvents Members


OnClose Property

[image]
Intersoft WebDesktop Documentation
OnClose Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationClientSideEvents Class : OnClose Property

Glossary Item Box

The javascript function that will be invoked when user closes the notification window.

Syntax

Visual Basic (Declaration)
Public Property OnClose As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotificationClientSideEvents
Dim value As String

instance.OnClose = value

value = instance.OnClose
C#
public string OnClose {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationClientSideEvents Class
WebNotificationClientSideEvents Members


OnError Property

[image]
Intersoft WebDesktop Documentation
OnError Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationClientSideEvents Class : OnError Property

Glossary Item Box

The javascript function that will be invoked when error is received during response.

Syntax

Visual Basic (Declaration)
Public Property OnError As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotificationClientSideEvents
Dim value As String

instance.OnError = value

value = instance.OnError
C#
public string OnError {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationClientSideEvents Class
WebNotificationClientSideEvents Members


OnInitialize Property

[image]
Intersoft WebDesktop Documentation
OnInitialize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationClientSideEvents Class : OnInitialize Property

Glossary Item Box

The javascript function that will be invoked during control initialization.

Syntax

Visual Basic (Declaration)
Public Property OnInitialize As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotificationClientSideEvents
Dim value As String

instance.OnInitialize = value

value = instance.OnInitialize
C#
public string OnInitialize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationClientSideEvents Class
WebNotificationClientSideEvents Members


OnNotify Property

[image]
Intersoft WebDesktop Documentation
OnNotify Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationClientSideEvents Class : OnNotify Property

Glossary Item Box

The javascript function that will be invoked when the control returns at least one notification.

Syntax

Visual Basic (Declaration)
Public Property OnNotify As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotificationClientSideEvents
Dim value As String

instance.OnNotify = value

value = instance.OnNotify
C#
public string OnNotify {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationClientSideEvents Class
WebNotificationClientSideEvents Members

Tasks

Passing custom properties


OnResponse Property

[image]
Intersoft WebDesktop Documentation
OnResponse Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationClientSideEvents Class : OnResponse Property

Glossary Item Box

The javascript function that will be invoked after the control receives response from server.

Syntax

Visual Basic (Declaration)
Public Property OnResponse As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotificationClientSideEvents
Dim value As String

instance.OnResponse = value

value = instance.OnResponse
C#
public string OnResponse {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationClientSideEvents Class
WebNotificationClientSideEvents Members


WebNotificationEvent Class

[image]
Intersoft WebDesktop Documentation
WebNotificationEvent Class
Members Example See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNotificationEvent Class

Glossary Item Box

Contains the information required by WebNotification control to receive new notification events, which passed from the server side.

Object Model

WebNotificationEvent Class

Syntax

Visual Basic (Declaration)
Public Class WebNotificationEvent
Visual Basic (Usage) Copy Code
Dim instance As WebNotificationEvent
C#
public class WebNotificationEvent

Remarks

The WebNotificationEvent object is the central notification data that contains information about an event. The object contains information such as the CaptionText, NotifyURL and so on which provided by the developers. The information provided in the object will be automatically retrieved by the WebNotification control in the client side for the end user notification display process.

WebNotification control begins its life cycle by requesting data from WebService. The GetNotifications function then execute the contained codes and add new WebNotificationEvent object to the collection when data existed. Finally, the collection is returned from the function. The collection object will then serialized back to the client as XML data and processed internally by the WebNotification control.

When the collection contains one or more WebNotificationEvent objects, the notification popup window will be displayed in the client's screen. The text, image and the caption text of the notification will be based on the data provided in the WebNotificationEvent object which passed from the server side. To learn more on this topic please refer to Understanding WebNotification Concepts.

Example

The following example shows you how to create WebService using the GetNotifications method. You should put the codes in asmx file (for example, WebServiceNotify.asmx). To learn more please look at WebDesktop 20 Tutorial (RetrievingNotificationsFromWebService.aspx).
C# Copy Code
[WebMethod ]
public WebNotificationEventCollection GetNotifications( WebNotificationEventArgs e)
{
         WebNotificationEventCollection collection = new WebNotificationEventCollection ();
         WebNotificationEvent evnt = new WebNotificationEvent ();

         evnt.CaptionText = "Samples";
         evnt.ContentText = "Hello world from WebNotification!\nCurrent time is:" + DateTime.Now.ToLongTimeString();

         collection.Notifications = new WebNotificationEvent[] { evnt };
         return collection;
}

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebDesktop.WebNotificationEvent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationEvent Members
ISNet.WebUI.WebDesktop Namespace

Tasks

Retrieving notifications from webservice

tasks

Retrieving notifications from webform listener
Using action context menu

Concepts

Understanding Concepts


WebNotificationEvent Class Members

[image]
Intersoft WebDesktop Documentation
WebNotificationEvent Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNotificationEvent Class

Glossary Item Box

The following tables list the members exposed by WebNotificationEvent.

Public Constructors

 | Name | Description
Public Constructor | WebNotificationEvent Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | CaptionText | Gets or sets the text displayed in the caption area.
Public Property | ContentImage | Gets or sets the image displayed in the content area.
Public Property | ContentText | Gets or sets the text displayed in the content area.
Public Property | NotifyURL | Gets or sets the URL to launch.
Public Property | Properties | Gets or sets the notification event.
Public Property | TemplateText | Gets or sets a reference to the template that contains text.
Top

See Also

Reference

WebNotificationEvent Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Retrieving notifications from webservice

tasks

Retrieving notifications from webform listener
Using action context menu

Concepts

Understanding Concepts


WebNotificationEvent Constructor

[image]
Intersoft WebDesktop Documentation
WebNotificationEvent Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationEvent Class : WebNotificationEvent Constructor

Glossary Item Box

Initializes a new instance of the WebNotificationEvent class.

Overload List

Overload | Description
WebNotificationEvent Constructor() |
WebNotificationEvent Constructor(String) |
WebNotificationEvent Constructor(String,String) |
WebNotificationEvent Constructor(String,String,String) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationEvent Class
WebNotificationEvent Members


WebNotificationEvent Constructor()

[image]
Intersoft WebDesktop Documentation
WebNotificationEvent Constructor()
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationEvent Class > WebNotificationEvent Constructor : WebNotificationEvent Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebNotificationEvent()
C#
public WebNotificationEvent()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationEvent Class
WebNotificationEvent Members
Overload List


WebNotificationEvent Constructor(String)

[image]
Intersoft WebDesktop Documentation
WebNotificationEvent Constructor(String)
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationEvent Class > WebNotificationEvent Constructor : WebNotificationEvent Constructor(String)

contentText

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal contentText As String _
)
Visual Basic (Usage) Copy Code
Dim contentText As String

Dim instance As New WebNotificationEvent(contentText)
C#
public WebNotificationEvent(
   string contentText
)

Parameters

contentText

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationEvent Class
WebNotificationEvent Members
Overload List


WebNotificationEvent Constructor(String,String)

[image]
Intersoft WebDesktop Documentation
WebNotificationEvent Constructor(String,String)
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationEvent Class > WebNotificationEvent Constructor : WebNotificationEvent Constructor(String,String)

contentText
contentImage

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal contentText As String, _
   ByVal contentImage As String _
)
Visual Basic (Usage) Copy Code
Dim contentText As String
Dim contentImage As String

Dim instance As New WebNotificationEvent(contentText, contentImage)
C#
public WebNotificationEvent(
   string contentText,
   string contentImage
)

Parameters

contentText
contentImage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationEvent Class
WebNotificationEvent Members
Overload List


WebNotificationEvent Constructor(String,String,String)

[image]
Intersoft WebDesktop Documentation
WebNotificationEvent Constructor(String,String,String)
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationEvent Class > WebNotificationEvent Constructor : WebNotificationEvent Constructor(String,String,String)

contentText
contentImage
captionText

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal contentText As String, _
   ByVal contentImage As String, _
   ByVal captionText As String _
)
Visual Basic (Usage) Copy Code
Dim contentText As String
Dim contentImage As String
Dim captionText As String

Dim instance As New WebNotificationEvent(contentText, contentImage, captionText)
C#
public WebNotificationEvent(
   string contentText,
   string contentImage,
   string captionText
)

Parameters

contentText
contentImage
captionText

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationEvent Class
WebNotificationEvent Members
Overload List


WebNotificationEvent Class Properties

[image]
Intersoft WebDesktop Documentation
WebNotificationEvent Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNotificationEvent Class

Glossary Item Box

For a list of all members of this type, see WebNotificationEvent members.

Public Properties

 | Name | Description
Public Property | CaptionText | Gets or sets the text displayed in the caption area.
Public Property | ContentImage | Gets or sets the image displayed in the content area.
Public Property | ContentText | Gets or sets the text displayed in the content area.
Public Property | NotifyURL | Gets or sets the URL to launch.
Public Property | Properties | Gets or sets the notification event.
Public Property | TemplateText | Gets or sets a reference to the template that contains text.
Top

See Also

Reference

WebNotificationEvent Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Retrieving notifications from webservice

tasks

Retrieving notifications from webform listener
Using action context menu

Concepts

Understanding Concepts


CaptionText Property

[image]
Intersoft WebDesktop Documentation
CaptionText Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationEvent Class : CaptionText Property

Glossary Item Box

Gets or sets the text displayed in the caption area.

Syntax

Visual Basic (Declaration)
Public Property CaptionText As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotificationEvent
Dim value As String

instance.CaptionText = value

value = instance.CaptionText
C#
public string CaptionText {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationEvent Class
WebNotificationEvent Members


ContentImage Property

[image]
Intersoft WebDesktop Documentation
ContentImage Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationEvent Class : ContentImage Property

Glossary Item Box

Gets or sets the image displayed in the content area.

Syntax

Visual Basic (Declaration)
Public Property ContentImage As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotificationEvent
Dim value As String

instance.ContentImage = value

value = instance.ContentImage
C#
public string ContentImage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationEvent Class
WebNotificationEvent Members


ContentText Property

[image]
Intersoft WebDesktop Documentation
ContentText Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationEvent Class : ContentText Property

Glossary Item Box

Gets or sets the text displayed in the content area.

Syntax

Visual Basic (Declaration)
Public Property ContentText As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotificationEvent
Dim value As String

instance.ContentText = value

value = instance.ContentText
C#
public string ContentText {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationEvent Class
WebNotificationEvent Members


NotifyURL Property

[image]
Intersoft WebDesktop Documentation
NotifyURL Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationEvent Class : NotifyURL Property

Glossary Item Box

Gets or sets the URL to launch.

Syntax

Visual Basic (Declaration)
Public Property NotifyURL As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotificationEvent
Dim value As String

instance.NotifyURL = value

value = instance.NotifyURL
C#
public string NotifyURL {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationEvent Class
WebNotificationEvent Members


Properties Property

[image]
Intersoft WebDesktop Documentation
Properties Property
See Also Example Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationEvent Class : Properties Property

Glossary Item Box

Gets or sets the notification event.

Syntax

Visual Basic (Declaration)
Public Property Properties As NotificationProperties
Visual Basic (Usage) Copy Code
Dim instance As WebNotificationEvent
Dim value As NotificationProperties

instance.Properties = value

value = instance.Properties
C#
public NotificationProperties Properties {get; set;}

Remarks

WebNotification has the ability to pass custom properties along with the notification event to the client side. For instance, you may want to send the RowID along with the notification event so you can get the ID in the client side and perform further extensibility. In WebNotification, you can send custom property easily in collection-object friendly approach. WebNotification used Dictionary based type and is able to be serialized perfectly into XML Format.

The following codes snippet demonstrates how you can pass the EmailID value along with the notification event.

WebNotificationEvent evnt = new WebNotificationEvent();

evnt.CaptionText =

"Samples: Outlook 2003";
evnt.Properties["EmailID"] = emailObj.ID;

Example

The following example shows you to pass custom properties to be used in WebNotification. You need to create a WebService page in the same directory. (For instance, name it NotificationService.asmx, then it will automatically create NotificationService.cs in the App_code folder).The codes below is used GetNotifications method in WebService. To learn more please refer to 'Passing Custom Properties' in See Also section.
C# Copy Code
[WebMethod]
public WebNotificationEventCollection GetNotifications(WebNotificationEventArgs e)
{
        WebNotificationEventCollection collection = new WebNotificationEventCollection();
        WebNotificationEvent evnt = new WebNotificationEvent();

        evnt.CaptionText = "Samples";
        evnt.ContentText = "Hello world from WebNotification!\nCurrent time is:" + DateTime.Now.ToLongTimeString();
        evnt.Properties["CustomerId"] = "ALFKI";

        collection.Notifications = new WebNotificationEvent[] { evnt };
        return collection;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationEvent Class
WebNotificationEvent Members

Tasks

Passing custom properties

Concepts

WebNotification Features


TemplateText Property

[image]
Intersoft WebDesktop Documentation
TemplateText Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationEvent Class : TemplateText Property

Glossary Item Box

Gets or sets a reference to the template that contains text.

Syntax

Visual Basic (Declaration)
Public Property TemplateText As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotificationEvent
Dim value As String

instance.TemplateText = value

value = instance.TemplateText
C#
public string TemplateText {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationEvent Class
WebNotificationEvent Members


WebNotificationEventArgs Class

[image]
Intersoft WebDesktop Documentation
WebNotificationEventArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNotificationEventArgs Class

Glossary Item Box

Object that constructed internally at the client side of WebNotification and passed into the function as parameter value.

Object Model

WebNotificationEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class WebNotificationEventArgs
Visual Basic (Usage) Copy Code
Dim instance As WebNotificationEventArgs
C#
public class WebNotificationEventArgs

Remarks

The WebNotificationEventArgs object is constructed internally at client side and passed into the function as parameter value. It is used to provide the current context of the WebNotification caller, such as the RawUrl of the WebForm page which invokes the service, or the Id of the WebNotification which in charge calling the service.

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebDesktop.WebNotificationEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationEventArgs Members
ISNet.WebUI.WebDesktop Namespace

Concepts

Understanding Concepts


WebNotificationEventArgs Class Members

[image]
Intersoft WebDesktop Documentation
WebNotificationEventArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNotificationEventArgs Class

Glossary Item Box

The following tables list the members exposed by WebNotificationEventArgs.

Public Constructors

 | Name | Description
Public Constructor | WebNotificationEventArgs Constructor | Initializes a new instance of the WebNotificationEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | CustomData | Gets or sets custom data of notification event.
Public Property | Id | Gets or sets Id of notification event.
Public Property | RawUrl | Gets or sets raw url used by notification event.
Top

See Also

Reference

WebNotificationEventArgs Class
ISNet.WebUI.WebDesktop Namespace

Concepts

Understanding Concepts


WebNotificationEventArgs Constructor

[image]
Intersoft WebDesktop Documentation
WebNotificationEventArgs Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationEventArgs Class : WebNotificationEventArgs Constructor

Glossary Item Box

Initializes a new instance of the WebNotificationEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebNotificationEventArgs()
C#
public WebNotificationEventArgs()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationEventArgs Class
WebNotificationEventArgs Members


WebNotificationEventArgs Class Properties

[image]
Intersoft WebDesktop Documentation
WebNotificationEventArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNotificationEventArgs Class

Glossary Item Box

For a list of all members of this type, see WebNotificationEventArgs members.

Public Properties

 | Name | Description
Public Property | CustomData | Gets or sets custom data of notification event.
Public Property | Id | Gets or sets Id of notification event.
Public Property | RawUrl | Gets or sets raw url used by notification event.
Top

See Also

Reference

WebNotificationEventArgs Class
ISNet.WebUI.WebDesktop Namespace

Concepts

Understanding Concepts


CustomData Property

[image]
Intersoft WebDesktop Documentation
CustomData Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationEventArgs Class : CustomData Property

Glossary Item Box

Gets or sets custom data of notification event.

Syntax

Visual Basic (Declaration)
Public Property CustomData As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotificationEventArgs
Dim value As String

instance.CustomData = value

value = instance.CustomData
C#
public string CustomData {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationEventArgs Class
WebNotificationEventArgs Members


Id Property

[image]
Intersoft WebDesktop Documentation
Id Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationEventArgs Class : Id Property

Glossary Item Box

Gets or sets Id of notification event.

Syntax

Visual Basic (Declaration)
Public Property Id As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotificationEventArgs
Dim value As String

instance.Id = value

value = instance.Id
C#
public string Id {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationEventArgs Class
WebNotificationEventArgs Members


RawUrl Property

[image]
Intersoft WebDesktop Documentation
RawUrl Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationEventArgs Class : RawUrl Property

Glossary Item Box

Gets or sets raw url used by notification event.

Syntax

Visual Basic (Declaration)
Public Property RawUrl As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotificationEventArgs
Dim value As String

instance.RawUrl = value

value = instance.RawUrl
C#
public string RawUrl {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationEventArgs Class
WebNotificationEventArgs Members


WebNotificationEventCollection Class

[image]
Intersoft WebDesktop Documentation
WebNotificationEventCollection Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNotificationEventCollection Class

Glossary Item Box

Collection of WebNotificationEvent.

Object Model

WebNotificationEventCollection Class

Syntax

Visual Basic (Declaration)
Public Class WebNotificationEventCollection
Visual Basic (Usage) Copy Code
Dim instance As WebNotificationEventCollection
C#
public class WebNotificationEventCollection

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebDesktop.WebNotificationEventCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationEventCollection Members
ISNet.WebUI.WebDesktop Namespace


WebNotificationEventCollection Class Members

[image]
Intersoft WebDesktop Documentation
WebNotificationEventCollection Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNotificationEventCollection Class

Glossary Item Box

The following tables list the members exposed by WebNotificationEventCollection.

Public Constructors

 | Name | Description
Public Constructor | WebNotificationEventCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | HasData | Indicates whether WebNotification has data which will be sent to client side.
Public Property | Notifications | Contains the collection WebNotificationEvent.
Top

See Also

Reference

WebNotificationEventCollection Class
ISNet.WebUI.WebDesktop Namespace


WebNotificationEventCollection Constructor

[image]
Intersoft WebDesktop Documentation
WebNotificationEventCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationEventCollection Class : WebNotificationEventCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebNotificationEventCollection()
C#
public WebNotificationEventCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationEventCollection Class
WebNotificationEventCollection Members


WebNotificationEventCollection Class Properties

[image]
Intersoft WebDesktop Documentation
WebNotificationEventCollection Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNotificationEventCollection Class

Glossary Item Box

For a list of all members of this type, see WebNotificationEventCollection members.

Public Properties

 | Name | Description
Public Property | HasData | Indicates whether WebNotification has data which will be sent to client side.
Public Property | Notifications | Contains the collection WebNotificationEvent.
Top

See Also

Reference

WebNotificationEventCollection Class
ISNet.WebUI.WebDesktop Namespace


HasData Property

[image]
Intersoft WebDesktop Documentation
HasData Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationEventCollection Class : HasData Property

Glossary Item Box

Indicates whether WebNotification has data which will be sent to client side.

Syntax

Visual Basic (Declaration)
Public Property HasData As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNotificationEventCollection
Dim value As Boolean

instance.HasData = value

value = instance.HasData
C#
public bool HasData {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationEventCollection Class
WebNotificationEventCollection Members


Notifications Property

[image]
Intersoft WebDesktop Documentation
Notifications Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationEventCollection Class : Notifications Property

Glossary Item Box

Contains the collection WebNotificationEvent.

Syntax

Visual Basic (Declaration)
Public Property Notifications As WebNotificationEvent()
Visual Basic (Usage) Copy Code
Dim instance As WebNotificationEventCollection
Dim value() As WebNotificationEvent

instance.Notifications = value

value = instance.Notifications
C#
public WebNotificationEvent[] Notifications {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationEventCollection Class
WebNotificationEventCollection Members


WebNotificationImagesSettings Class

[image]
Intersoft WebDesktop Documentation
WebNotificationImagesSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNotificationImagesSettings Class

Glossary Item Box

Collection of settings for images used by WebNotification control.

Object Model

WebNotificationImagesSettings Class

Syntax

Visual Basic (Declaration)
Public Class WebNotificationImagesSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebNotificationImagesSettings
C#
public class WebNotificationImagesSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebDesktop.WebNotificationImagesSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationImagesSettings Members
ISNet.WebUI.WebDesktop Namespace


WebNotificationImagesSettings Class Members

[image]
Intersoft WebDesktop Documentation
WebNotificationImagesSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNotificationImagesSettings Class

Glossary Item Box

The following tables list the members exposed by WebNotificationImagesSettings.

Public Constructors

 | Name | Description
Public Constructor | WebNotificationImagesSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | ActionActive | Gets or sets the image to represent Action dropdown button in active mode.
Public Property | ActionNormal | Gets or sets the image to represent Action dropdown button in normal mode.
Public Property | ActionOver | Gets or sets the image to represent Action dropdown button in over mode.
Public Property | CloseActive | Gets or sets the image to represent Close button in active mode.
Public Property | CloseNormal | Gets or sets the image to represent Close button in normal mode.
Public Property | CloseOver | Gets or sets the image to represent Close button in over mode.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebNotificationImagesSettings Class
ISNet.WebUI.WebDesktop Namespace


WebNotificationImagesSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebNotificationImagesSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationImagesSettings Class : WebNotificationImagesSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebNotificationImagesSettings()
C#
public WebNotificationImagesSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationImagesSettings Class
WebNotificationImagesSettings Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationImagesSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebNotificationImagesSettings
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationImagesSettings Class
WebNotificationImagesSettings Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationImagesSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationImagesSettings Class
WebNotificationImagesSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationImagesSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNotificationImagesSettings
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationImagesSettings Class
WebNotificationImagesSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationImagesSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNotificationImagesSettings
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationImagesSettings Class
WebNotificationImagesSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationImagesSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNotificationImagesSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationImagesSettings Class
WebNotificationImagesSettings Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationImagesSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebNotificationImagesSettings
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationImagesSettings Class
WebNotificationImagesSettings Members


WebNotificationImagesSettings Class Methods

[image]
Intersoft WebDesktop Documentation
WebNotificationImagesSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNotificationImagesSettings Class

Glossary Item Box

For a list of all members of this type, see WebNotificationImagesSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebNotificationImagesSettings Class
ISNet.WebUI.WebDesktop Namespace


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationImagesSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNotificationImagesSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationImagesSettings Class
WebNotificationImagesSettings Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationImagesSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebNotificationImagesSettings
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationImagesSettings Class
WebNotificationImagesSettings Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationImagesSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebNotificationImagesSettings

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationImagesSettings Class
WebNotificationImagesSettings Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationImagesSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebNotificationImagesSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationImagesSettings Class
WebNotificationImagesSettings Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationImagesSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotificationImagesSettings
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationImagesSettings Class
WebNotificationImagesSettings Members


WebNotificationImagesSettings Class Properties

[image]
Intersoft WebDesktop Documentation
WebNotificationImagesSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNotificationImagesSettings Class

Glossary Item Box

For a list of all members of this type, see WebNotificationImagesSettings members.

Public Properties

 | Name | Description
Public Property | ActionActive | Gets or sets the image to represent Action dropdown button in active mode.
Public Property | ActionNormal | Gets or sets the image to represent Action dropdown button in normal mode.
Public Property | ActionOver | Gets or sets the image to represent Action dropdown button in over mode.
Public Property | CloseActive | Gets or sets the image to represent Close button in active mode.
Public Property | CloseNormal | Gets or sets the image to represent Close button in normal mode.
Public Property | CloseOver | Gets or sets the image to represent Close button in over mode.
Top

See Also

Reference

WebNotificationImagesSettings Class
ISNet.WebUI.WebDesktop Namespace


WebNotificationImagesSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebNotificationImagesSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationImagesSettings Class : WebNotificationImagesSettings Constructor

Glossary Item Box

Initializes a new instance of the WebNotificationImagesSettings class.

Overload List

Overload | Description
WebNotificationImagesSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationImagesSettings Class
WebNotificationImagesSettings Members


ActionActive Property

[image]
Intersoft WebDesktop Documentation
ActionActive Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationImagesSettings Class : ActionActive Property

Glossary Item Box

Gets or sets the image to represent Action dropdown button in active mode.

Syntax

Visual Basic (Declaration)
Public Property ActionActive As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotificationImagesSettings
Dim value As String

instance.ActionActive = value

value = instance.ActionActive
C#
public string ActionActive {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationImagesSettings Class
WebNotificationImagesSettings Members


ActionNormal Property

[image]
Intersoft WebDesktop Documentation
ActionNormal Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationImagesSettings Class : ActionNormal Property

Glossary Item Box

Gets or sets the image to represent Action dropdown button in normal mode.

Syntax

Visual Basic (Declaration)
Public Property ActionNormal As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotificationImagesSettings
Dim value As String

instance.ActionNormal = value

value = instance.ActionNormal
C#
public string ActionNormal {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationImagesSettings Class
WebNotificationImagesSettings Members


ActionOver Property

[image]
Intersoft WebDesktop Documentation
ActionOver Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationImagesSettings Class : ActionOver Property

Glossary Item Box

Gets or sets the image to represent Action dropdown button in over mode.

Syntax

Visual Basic (Declaration)
Public Property ActionOver As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotificationImagesSettings
Dim value As String

instance.ActionOver = value

value = instance.ActionOver
C#
public string ActionOver {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationImagesSettings Class
WebNotificationImagesSettings Members


CloseActive Property

[image]
Intersoft WebDesktop Documentation
CloseActive Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationImagesSettings Class : CloseActive Property

Glossary Item Box

Gets or sets the image to represent Close button in active mode.

Syntax

Visual Basic (Declaration)
Public Property CloseActive As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotificationImagesSettings
Dim value As String

instance.CloseActive = value

value = instance.CloseActive
C#
public string CloseActive {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationImagesSettings Class
WebNotificationImagesSettings Members


CloseNormal Property

[image]
Intersoft WebDesktop Documentation
CloseNormal Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationImagesSettings Class : CloseNormal Property

Glossary Item Box

Gets or sets the image to represent Close button in normal mode.

Syntax

Visual Basic (Declaration)
Public Property CloseNormal As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotificationImagesSettings
Dim value As String

instance.CloseNormal = value

value = instance.CloseNormal
C#
public string CloseNormal {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationImagesSettings Class
WebNotificationImagesSettings Members


CloseOver Property

[image]
Intersoft WebDesktop Documentation
CloseOver Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebNotificationImagesSettings Class : CloseOver Property

Glossary Item Box

Gets or sets the image to represent Close button in over mode.

Syntax

Visual Basic (Declaration)
Public Property CloseOver As String
Visual Basic (Usage) Copy Code
Dim instance As WebNotificationImagesSettings
Dim value As String

instance.CloseOver = value

value = instance.CloseOver
C#
public string CloseOver {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebNotificationImagesSettings Class
WebNotificationImagesSettings Members


WebPane Class

[image]
Intersoft WebDesktop Documentation
WebPane Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebPane Class

Glossary Item Box

The lowest level object of WebPaneManager which represent a Pane. It can contain server side or html controls when used in UseInlineContent mode.

Object Model

WebPane Class

Syntax

Visual Basic (Declaration)
Public Class WebPane
   Inherits WebPaneBase
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebPane
C#
public class WebPane : WebPaneBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject

Remarks

A WebPane object supports unlimited nested level of another WebPane or WebGroupPane objects. For better understanding on WebPane concepts please read Understanding Concepts.

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase
ISNet.WebUI.WebDesktop.WebPaneBase
ISNet.WebUI.WebDesktop.WebPane

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPane Members
ISNet.WebUI.WebDesktop Namespace

Tasks

Creating Simple Layout
Configuring Collapsible Pane
Disabling Resizing for specific Pane

tasks

Configuring Styles and Appearance

Concepts

Understanding Concepts

concepts

Add Pane
Convert to Pane
Delete Pane


WebPane Class Members

[image]
Intersoft WebDesktop Documentation
WebPane Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebPane Class

Glossary Item Box

The following tables list the members exposed by WebPane.

Public Constructors

 | Name | Description
Public Constructor | WebPane Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | AccessKey | Keyboard shortcut used by the control. (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | AllowCollapse | Indicates whether users are allowed to collase panes through splitter. (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | AllowResize | Determines whether panes are resizable. (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | CaptionDisplayMode | Gets or sets the mode of the caption display. (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | ContentMode | Gets or sets the content mode of this Pane.
Public Property | ContentPadding |
Public Property | ContentScrollable |
Public Property | ContentURL | Gets or sets the URL for the IFrame content. This property is applicable when ContentMode is set to UseIFrame.
Public Property | DiscardContainerStyle | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | HeaderAppearance | Gets or sets the default predefined style applied to Header part. (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | HeaderCustomStyle | Gets or sets the style applied to the Header part of the Pane when the HeaderAppearance is set to Custom. (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | HeaderVisible |
Public Property | Height | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | HeightValue | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | Image | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | ImageAlignment | Gets or sets the alignment of the image. The image alignment is relative to the caption text. (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | InfoText | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | InfoTextAlignment | Gets or sets the alignment of the InfoText relative to its placeholder. (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | InfoTextPosition | Gets or sets the position of the InfoText part. (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | InProgressText |
Public Property | IsEnabled | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | Name | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | Text | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | TextAlignment | Gets or sets the alignment of the text. (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | ToolTip | The tooltip displayed when the mouse is over the control. (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | UseRelativePositioning | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | Visible | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | Width | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | WidthValue | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | RecalculateActualDimension | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebPane Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Creating Simple Layout
Configuring Collapsible Pane
Disabling Resizing for specific Pane

tasks

Configuring Styles and Appearance

Concepts

Understanding Concepts

concepts

Add Pane
Convert to Pane
Delete Pane


WebPane Constructor

[image]
Intersoft WebDesktop Documentation
WebPane Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPane Class : WebPane Constructor

Glossary Item Box

Initializes a new instance of the WebPane class.

Overload List

Overload | Description
WebPane Constructor() | Initializes a new instance of the WebPane class with no argument.
WebPane Constructor(String) | Initializes a new instance of the WebPane class with Text parameter.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPane Class
WebPane Members


WebPane Constructor()

[image]
Intersoft WebDesktop Documentation
WebPane Constructor()
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPane Class > WebPane Constructor : WebPane Constructor()

Glossary Item Box

Initializes a new instance of the WebPane class with no argument.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebPane()
C#
public WebPane()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPane Class
WebPane Members
Overload List


WebPane Constructor(String)

[image]
Intersoft WebDesktop Documentation
WebPane Constructor(String)
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPane Class > WebPane Constructor : WebPane Constructor(String)

text

Glossary Item Box

Initializes a new instance of the WebPane class with Text parameter.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim text As String

Dim instance As New WebPane(text)
C#
public WebPane(
   string text
)

Parameters

text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPane Class
WebPane Members
Overload List


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPane Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebPane
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPane Class
WebPane Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPane Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPane Class
WebPane Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPane Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPane
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPane Class
WebPane Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPane Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPane
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPane Class
WebPane Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPane Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPane
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPane Class
WebPane Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPane Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebPane
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPane Class
WebPane Members


WebPane Class Methods

[image]
Intersoft WebDesktop Documentation
WebPane Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebPane Class

Glossary Item Box

For a list of all members of this type, see WebPane members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | RecalculateActualDimension | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebPane Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Creating Simple Layout
Configuring Collapsible Pane
Disabling Resizing for specific Pane

tasks

Configuring Styles and Appearance

Concepts

Understanding Concepts

concepts

Add Pane
Convert to Pane
Delete Pane


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPane Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPane
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPane Class
WebPane Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPane Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebPane
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPane Class
WebPane Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPane Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebPane

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPane Class
WebPane Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPane Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPane
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPane Class
WebPane Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPane Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebPane
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPane Class
WebPane Members


WebPane Class Properties

[image]
Intersoft WebDesktop Documentation
WebPane Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebPane Class

Glossary Item Box

For a list of all members of this type, see WebPane members.

Public Properties

 | Name | Description
Public Property | AccessKey | Keyboard shortcut used by the control. (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | AllowCollapse | Indicates whether users are allowed to collase panes through splitter. (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | AllowResize | Determines whether panes are resizable. (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | CaptionDisplayMode | Gets or sets the mode of the caption display. (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | ContentMode | Gets or sets the content mode of this Pane.
Public Property | ContentPadding |
Public Property | ContentScrollable |
Public Property | ContentURL | Gets or sets the URL for the IFrame content. This property is applicable when ContentMode is set to UseIFrame.
Public Property | DiscardContainerStyle | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | HeaderAppearance | Gets or sets the default predefined style applied to Header part. (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | HeaderCustomStyle | Gets or sets the style applied to the Header part of the Pane when the HeaderAppearance is set to Custom. (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | HeaderVisible |
Public Property | Height | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | HeightValue | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | Image | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | ImageAlignment | Gets or sets the alignment of the image. The image alignment is relative to the caption text. (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | InfoText | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | InfoTextAlignment | Gets or sets the alignment of the InfoText relative to its placeholder. (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | InfoTextPosition | Gets or sets the position of the InfoText part. (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | InProgressText |
Public Property | IsEnabled | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | Name | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | Text | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | TextAlignment | Gets or sets the alignment of the text. (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | ToolTip | The tooltip displayed when the mouse is over the control. (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | UseRelativePositioning | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | Visible | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | Width | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Public Property | WidthValue | (Inherited from ISNet.WebUI.WebDesktop.WebPaneBase)
Top

See Also

Reference

WebPane Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Creating Simple Layout
Configuring Collapsible Pane
Disabling Resizing for specific Pane

tasks

Configuring Styles and Appearance

Concepts

Understanding Concepts

concepts

Add Pane
Convert to Pane
Delete Pane


ContentMode Property

[image]
Intersoft WebDesktop Documentation
ContentMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPane Class : ContentMode Property

Glossary Item Box

Gets or sets the content mode of this Pane.

Syntax

Visual Basic (Declaration)
Public Property ContentMode As ContentMode
Visual Basic (Usage) Copy Code
Dim instance As WebPane
Dim value As ContentMode

instance.ContentMode = value

value = instance.ContentMode
C#
public ContentMode ContentMode {get; set;}

Remarks

By default, the WebPaneManager will operate in UseInlineContent mode when a new instance is dropped to designer surface. UseInlineContent is the most suitable when the contents inside each tab page are relatively small. You can also determine the "content load" by inspecting the performance during page load as well as the size of the output. UseInlineContent mode utilized .NET Framework's Templating archictecture and therefore all contents are loaded at once in first load (although the inactive pages are set to hidden).

In most cases where you want to develop a more reusable form, you should use UseIFrame for the content mode. When using IFrame mode, you would need to specify the ContentURL which page you want to load for the designated Tab item.

You can configure different ContentMode for each WebPane. To apply all WebPane to use a specific ContentMode, configure the ContentMode in WebPane control level and leave WebPane's ContentMode to Default.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPane Class
WebPane Members

Concepts

WebPane Features

Tasks

Using IFrame as ContentMode


ContentPadding Property

[image]
Intersoft WebDesktop Documentation
ContentPadding Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPane Class : ContentPadding Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ContentPadding As ISNet.WebUI.Padding
Visual Basic (Usage) Copy Code
Dim instance As WebPane
Dim value As ISNet.WebUI.Padding

instance.ContentPadding = value

value = instance.ContentPadding
C#
public ISNet.WebUI.Padding ContentPadding {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPane Class
WebPane Members


ContentScrollable Property

[image]
Intersoft WebDesktop Documentation
ContentScrollable Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPane Class : ContentScrollable Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ContentScrollable As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebPane
Dim value As Boolean

instance.ContentScrollable = value

value = instance.ContentScrollable
C#
public bool ContentScrollable {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPane Class
WebPane Members


ContentURL Property

[image]
Intersoft WebDesktop Documentation
ContentURL Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPane Class : ContentURL Property

Glossary Item Box

Gets or sets the URL for the IFrame content. This property is applicable when ContentMode is set to UseIFrame.

Syntax

Visual Basic (Declaration)
Public Property ContentURL As String
Visual Basic (Usage) Copy Code
Dim instance As WebPane
Dim value As String

instance.ContentURL = value

value = instance.ContentURL
C#
public string ContentURL {get; set;}

Remarks

When you use IFrame mode in ContentMode, you would need to specify the ContentURL which page you want to load for the designated Tab item.

The ContentURL accepts three formats of URL:

  • .NET specific application relative URL. This format starts with "~" character, for instance, "~/FolderA/Page1.aspx".
  • Absolute URL. This format starts with "/" character, for instance, "/SharedModule/Page1.aspx".
  • Relative URL. This format usually starts with "." character or no special characters (which assume the page can be found in the current folder's context).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPane Class
WebPane Members


HeaderVisible Property

[image]
Intersoft WebDesktop Documentation
HeaderVisible Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPane Class : HeaderVisible Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property HeaderVisible As Visibility
Visual Basic (Usage) Copy Code
Dim instance As WebPane
Dim value As Visibility

instance.HeaderVisible = value

value = instance.HeaderVisible
C#
public Visibility HeaderVisible {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPane Class
WebPane Members


InProgressText Property

[image]
Intersoft WebDesktop Documentation
InProgressText Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPane Class : InProgressText Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property InProgressText As String
Visual Basic (Usage) Copy Code
Dim instance As WebPane
Dim value As String

instance.InProgressText = value

value = instance.InProgressText
C#
public string InProgressText {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPane Class
WebPane Members


WebPaneBase Class

[image]
Intersoft WebDesktop Documentation
WebPaneBase Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebPaneBase Class

Glossary Item Box

List of settings to customize WebPane object.

Object Model

WebPaneBase Class

Syntax

Visual Basic (Declaration)
Public Class WebPaneBase
   Inherits ISNet.WebUI.NamedObjectBase
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebPaneBase
C#
public class WebPaneBase : ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase
ISNet.WebUI.WebDesktop.WebPaneBase
ISNet.WebUI.WebDesktop.WebGroupPane
ISNet.WebUI.WebDesktop.WebPane

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneBase Members
ISNet.WebUI.WebDesktop Namespace


WebPaneBase Class Members

[image]
Intersoft WebDesktop Documentation
WebPaneBase Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebPaneBase Class

Glossary Item Box

The following tables list the members exposed by WebPaneBase.

Public Constructors

 | Name | Description
Public Constructor | WebPaneBase Constructor |
Top

Public Properties

 | Name | Description
Public Property | AccessKey | Keyboard shortcut used by the control.
Public Property | AllowCollapse | Indicates whether users are allowed to collase panes through splitter.
Public Property | AllowResize | Determines whether panes are resizable.
Public Property | CaptionDisplayMode | Gets or sets the mode of the caption display.
Public Property | DiscardContainerStyle |
Public Property | HeaderAppearance | Gets or sets the default predefined style applied to Header part.
Public Property | HeaderCustomStyle | Gets or sets the style applied to the Header part of the Pane when the HeaderAppearance is set to Custom.
Public Property | Height |
Public Property | HeightValue |
Public Property | Image |
Public Property | ImageAlignment | Gets or sets the alignment of the image. The image alignment is relative to the caption text.
Public Property | InfoText |
Public Property | InfoTextAlignment | Gets or sets the alignment of the InfoText relative to its placeholder.
Public Property | InfoTextPosition | Gets or sets the position of the InfoText part.
Public Property | IsEnabled |
Public Property | Name | Overridden.
Public Property | Text |
Public Property | TextAlignment | Gets or sets the alignment of the text.
Public Property | ToolTip | The tooltip displayed when the mouse is over the control.
Public Property | UseRelativePositioning |
Public Property | Visible |
Public Property | Width |
Public Property | WidthValue |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | RecalculateActualDimension |
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebPaneBase Class
ISNet.WebUI.WebDesktop Namespace


WebPaneBase Constructor

[image]
Intersoft WebDesktop Documentation
WebPaneBase Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneBase Class : WebPaneBase Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebPaneBase()
C#
public WebPaneBase()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneBase Class
WebPaneBase Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneBase Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebPaneBase
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneBase Class
WebPaneBase Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneBase Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneBase Class
WebPaneBase Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneBase Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneBase
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneBase Class
WebPaneBase Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneBase Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneBase
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneBase Class
WebPaneBase Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneBase Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneBase
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneBase Class
WebPaneBase Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneBase Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebPaneBase
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneBase Class
WebPaneBase Members


WebPaneBase Class Methods

[image]
Intersoft WebDesktop Documentation
WebPaneBase Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebPaneBase Class

Glossary Item Box

For a list of all members of this type, see WebPaneBase members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | RecalculateActualDimension |
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebPaneBase Class
ISNet.WebUI.WebDesktop Namespace


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneBase Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneBase
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneBase Class
WebPaneBase Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneBase Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebPaneBase
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneBase Class
WebPaneBase Members


RecalculateActualDimension Method

[image]
Intersoft WebDesktop Documentation
RecalculateActualDimension Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneBase Class : RecalculateActualDimension Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RecalculateActualDimension()
Visual Basic (Usage) Copy Code
Dim instance As WebPaneBase

instance.RecalculateActualDimension()
C#
public void RecalculateActualDimension()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneBase Class
WebPaneBase Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneBase Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebPaneBase

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneBase Class
WebPaneBase Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneBase Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneBase
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneBase Class
WebPaneBase Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneBase Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneBase
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneBase Class
WebPaneBase Members


WebPaneBase Class Properties

[image]
Intersoft WebDesktop Documentation
WebPaneBase Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebPaneBase Class

Glossary Item Box

For a list of all members of this type, see WebPaneBase members.

Public Properties

 | Name | Description
Public Property | AccessKey | Keyboard shortcut used by the control.
Public Property | AllowCollapse | Indicates whether users are allowed to collase panes through splitter.
Public Property | AllowResize | Determines whether panes are resizable.
Public Property | CaptionDisplayMode | Gets or sets the mode of the caption display.
Public Property | DiscardContainerStyle |
Public Property | HeaderAppearance | Gets or sets the default predefined style applied to Header part.
Public Property | HeaderCustomStyle | Gets or sets the style applied to the Header part of the Pane when the HeaderAppearance is set to Custom.
Public Property | Height |
Public Property | HeightValue |
Public Property | Image |
Public Property | ImageAlignment | Gets or sets the alignment of the image. The image alignment is relative to the caption text.
Public Property | InfoText |
Public Property | InfoTextAlignment | Gets or sets the alignment of the InfoText relative to its placeholder.
Public Property | InfoTextPosition | Gets or sets the position of the InfoText part.
Public Property | IsEnabled |
Public Property | Name | Overridden.
Public Property | Text |
Public Property | TextAlignment | Gets or sets the alignment of the text.
Public Property | ToolTip | The tooltip displayed when the mouse is over the control.
Public Property | UseRelativePositioning |
Public Property | Visible |
Public Property | Width |
Public Property | WidthValue |
Top

See Also

Reference

WebPaneBase Class
ISNet.WebUI.WebDesktop Namespace


WebPaneBase Constructor

[image]
Intersoft WebDesktop Documentation
WebPaneBase Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneBase Class : WebPaneBase Constructor

Glossary Item Box

Initializes a new instance of the WebPane class.

Overload List

Overload | Description
WebPaneBase Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneBase Class
WebPaneBase Members


AccessKey Property

[image]
Intersoft WebDesktop Documentation
AccessKey Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneBase Class : AccessKey Property

Glossary Item Box

Keyboard shortcut used by the control.

Syntax

Visual Basic (Declaration)
Public Property AccessKey As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneBase
Dim value As String

instance.AccessKey = value

value = instance.AccessKey
C#
public string AccessKey {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneBase Class
WebPaneBase Members


AllowCollapse Property

[image]
Intersoft WebDesktop Documentation
AllowCollapse Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneBase Class : AllowCollapse Property

Glossary Item Box

Indicates whether users are allowed to collase panes through splitter.

Syntax

Visual Basic (Declaration)
Public Property AllowCollapse As AllowCollapse
Visual Basic (Usage) Copy Code
Dim instance As WebPaneBase
Dim value As AllowCollapse

instance.AllowCollapse = value

value = instance.AllowCollapse
C#
public AllowCollapse AllowCollapse {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneBase Class
WebPaneBase Members


AllowResize Property

[image]
Intersoft WebDesktop Documentation
AllowResize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneBase Class : AllowResize Property

Glossary Item Box

Determines whether panes are resizable.

Syntax

Visual Basic (Declaration)
Public Property AllowResize As AllowResize
Visual Basic (Usage) Copy Code
Dim instance As WebPaneBase
Dim value As AllowResize

instance.AllowResize = value

value = instance.AllowResize
C#
public AllowResize AllowResize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneBase Class
WebPaneBase Members


CaptionDisplayMode Property

[image]
Intersoft WebDesktop Documentation
CaptionDisplayMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneBase Class : CaptionDisplayMode Property

Glossary Item Box

Gets or sets the mode of the caption display.

Syntax

Visual Basic (Declaration)
Public Property CaptionDisplayMode As DisplayMode
Visual Basic (Usage) Copy Code
Dim instance As WebPaneBase
Dim value As DisplayMode

instance.CaptionDisplayMode = value

value = instance.CaptionDisplayMode
C#
public DisplayMode CaptionDisplayMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneBase Class
WebPaneBase Members


DiscardContainerStyle Property

[image]
Intersoft WebDesktop Documentation
DiscardContainerStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneBase Class : DiscardContainerStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property DiscardContainerStyle As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebPaneBase
Dim value As Boolean

instance.DiscardContainerStyle = value

value = instance.DiscardContainerStyle
C#
public bool DiscardContainerStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneBase Class
WebPaneBase Members


HeaderAppearance Property

[image]
Intersoft WebDesktop Documentation
HeaderAppearance Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneBase Class : HeaderAppearance Property

Glossary Item Box

Gets or sets the default predefined style applied to Header part.

Syntax

Visual Basic (Declaration)
Public Property HeaderAppearance As HeaderAppearanceMode
Visual Basic (Usage) Copy Code
Dim instance As WebPaneBase
Dim value As HeaderAppearanceMode

instance.HeaderAppearance = value

value = instance.HeaderAppearance
C#
public HeaderAppearanceMode HeaderAppearance {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneBase Class
WebPaneBase Members


HeaderCustomStyle Property

[image]
Intersoft WebDesktop Documentation
HeaderCustomStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneBase Class : HeaderCustomStyle Property

Glossary Item Box

Gets or sets the style applied to the Header part of the Pane when the HeaderAppearance is set to Custom.

Syntax

Visual Basic (Declaration)
Public Property HeaderCustomStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebPaneBase
Dim value As ISNet.WebUI.WebStyle

instance.HeaderCustomStyle = value

value = instance.HeaderCustomStyle
C#
public ISNet.WebUI.WebStyle HeaderCustomStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneBase Class
WebPaneBase Members


Height Property

[image]
Intersoft WebDesktop Documentation
Height Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneBase Class : Height Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Height As DimensionMode
Visual Basic (Usage) Copy Code
Dim instance As WebPaneBase
Dim value As DimensionMode

instance.Height = value

value = instance.Height
C#
public DimensionMode Height {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneBase Class
WebPaneBase Members


HeightValue Property

[image]
Intersoft WebDesktop Documentation
HeightValue Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneBase Class : HeightValue Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property HeightValue As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebPaneBase
Dim value As System.Web.UI.WebControls.Unit

instance.HeightValue = value

value = instance.HeightValue
C#
public System.Web.UI.WebControls.Unit HeightValue {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneBase Class
WebPaneBase Members


Image Property

[image]
Intersoft WebDesktop Documentation
Image Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneBase Class : Image Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Image As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneBase
Dim value As String

instance.Image = value

value = instance.Image
C#
public string Image {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneBase Class
WebPaneBase Members


ImageAlignment Property

[image]
Intersoft WebDesktop Documentation
ImageAlignment Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneBase Class : ImageAlignment Property

Glossary Item Box

Gets or sets the alignment of the image. The image alignment is relative to the caption text.

Syntax

Visual Basic (Declaration)
Public Property ImageAlignment As DisplayAlignment
Visual Basic (Usage) Copy Code
Dim instance As WebPaneBase
Dim value As DisplayAlignment

instance.ImageAlignment = value

value = instance.ImageAlignment
C#
public DisplayAlignment ImageAlignment {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneBase Class
WebPaneBase Members


InfoText Property

[image]
Intersoft WebDesktop Documentation
InfoText Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneBase Class : InfoText Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property InfoText As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneBase
Dim value As String

instance.InfoText = value

value = instance.InfoText
C#
public string InfoText {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneBase Class
WebPaneBase Members


InfoTextAlignment Property

[image]
Intersoft WebDesktop Documentation
InfoTextAlignment Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneBase Class : InfoTextAlignment Property

Glossary Item Box

Gets or sets the alignment of the InfoText relative to its placeholder.

Syntax

Visual Basic (Declaration)
Public Property InfoTextAlignment As TextAlignment
Visual Basic (Usage) Copy Code
Dim instance As WebPaneBase
Dim value As TextAlignment

instance.InfoTextAlignment = value

value = instance.InfoTextAlignment
C#
public TextAlignment InfoTextAlignment {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneBase Class
WebPaneBase Members


InfoTextPosition Property

[image]
Intersoft WebDesktop Documentation
InfoTextPosition Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneBase Class : InfoTextPosition Property

Glossary Item Box

Gets or sets the position of the InfoText part.

Syntax

Visual Basic (Declaration)
Public Property InfoTextPosition As InfoTextPosition
Visual Basic (Usage) Copy Code
Dim instance As WebPaneBase
Dim value As InfoTextPosition

instance.InfoTextPosition = value

value = instance.InfoTextPosition
C#
public InfoTextPosition InfoTextPosition {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneBase Class
WebPaneBase Members


IsEnabled Property

[image]
Intersoft WebDesktop Documentation
IsEnabled Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneBase Class : IsEnabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property IsEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebPaneBase
Dim value As Boolean

instance.IsEnabled = value

value = instance.IsEnabled
C#
public bool IsEnabled {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneBase Class
WebPaneBase Members


Name Property

[image]
Intersoft WebDesktop Documentation
Name Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneBase Class : Name Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneBase
Dim value As String

instance.Name = value

value = instance.Name
C#
public override string Name {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneBase Class
WebPaneBase Members


Text Property

[image]
Intersoft WebDesktop Documentation
Text Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneBase Class : Text Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneBase
Dim value As String

instance.Text = value

value = instance.Text
C#
public string Text {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneBase Class
WebPaneBase Members


TextAlignment Property

[image]
Intersoft WebDesktop Documentation
TextAlignment Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneBase Class : TextAlignment Property

Glossary Item Box

Gets or sets the alignment of the text.

Syntax

Visual Basic (Declaration)
Public Property TextAlignment As TextAlignment
Visual Basic (Usage) Copy Code
Dim instance As WebPaneBase
Dim value As TextAlignment

instance.TextAlignment = value

value = instance.TextAlignment
C#
public TextAlignment TextAlignment {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneBase Class
WebPaneBase Members


ToolTip Property

[image]
Intersoft WebDesktop Documentation
ToolTip Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneBase Class : ToolTip Property

Glossary Item Box

The tooltip displayed when the mouse is over the control.

Syntax

Visual Basic (Declaration)
Public Property ToolTip As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneBase
Dim value As String

instance.ToolTip = value

value = instance.ToolTip
C#
public string ToolTip {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneBase Class
WebPaneBase Members


UseRelativePositioning Property

[image]
Intersoft WebDesktop Documentation
UseRelativePositioning Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneBase Class : UseRelativePositioning Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property UseRelativePositioning As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebPaneBase
Dim value As Boolean

instance.UseRelativePositioning = value

value = instance.UseRelativePositioning
C#
public bool UseRelativePositioning {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneBase Class
WebPaneBase Members


Visible Property

[image]
Intersoft WebDesktop Documentation
Visible Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneBase Class : Visible Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebPaneBase
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public bool Visible {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneBase Class
WebPaneBase Members


Width Property

[image]
Intersoft WebDesktop Documentation
Width Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneBase Class : Width Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Width As DimensionMode
Visual Basic (Usage) Copy Code
Dim instance As WebPaneBase
Dim value As DimensionMode

instance.Width = value

value = instance.Width
C#
public DimensionMode Width {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneBase Class
WebPaneBase Members


WidthValue Property

[image]
Intersoft WebDesktop Documentation
WidthValue Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneBase Class : WidthValue Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property WidthValue As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebPaneBase
Dim value As System.Web.UI.WebControls.Unit

instance.WidthValue = value

value = instance.WidthValue
C#
public System.Web.UI.WebControls.Unit WidthValue {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneBase Class
WebPaneBase Members


WebPaneClientSideEvents Class

[image]
Intersoft WebDesktop Documentation
WebPaneClientSideEvents Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebPaneClientSideEvents Class

Glossary Item Box

Javascript functions which invoked from client side in WebPane.

Object Model

WebPaneClientSideEvents Class

Syntax

Visual Basic (Declaration)
Public Class WebPaneClientSideEvents
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebPaneClientSideEvents
C#
public class WebPaneClientSideEvents : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebDesktop.WebPaneClientSideEvents

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneClientSideEvents Members
ISNet.WebUI.WebDesktop Namespace


WebPaneClientSideEvents Class Members

[image]
Intersoft WebDesktop Documentation
WebPaneClientSideEvents Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebPaneClientSideEvents Class

Glossary Item Box

The following tables list the members exposed by WebPaneClientSideEvents.

Public Constructors

 | Name | Description
Public Constructor | WebPaneClientSideEvents Constructor |
Top

Public Properties

 | Name | Description
Public Property | OnAfterCollapse | Gets or sets the javascript function to invoke after the Pane is collapsed.
Public Property | OnAfterResize | Gets or sets the javascript function to invoke after the Pane is resized through splitter.
Public Property | OnAfterRestore | Gets or sets the javascript function to invoke after the Pane is restored.
Public Property | OnBeforeCollapse | Gets or sets the javascript function to invoke before the Pane is collapsed.
Public Property | OnBeforeResize | Gets or sets the javascript function to invoke when the Pane is about to be resized through splitter.
Public Property | OnBeforeRestore | Gets or sets the javascript function to invoke before the Pane is restored.
Public Property | OnInitialize | Gets or sets the javascript function to invoke when the control is being initialized.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebPaneClientSideEvents Class
ISNet.WebUI.WebDesktop Namespace


WebPaneClientSideEvents Constructor

[image]
Intersoft WebDesktop Documentation
WebPaneClientSideEvents Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneClientSideEvents Class : WebPaneClientSideEvents Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebPaneClientSideEvents()
C#
public WebPaneClientSideEvents()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneClientSideEvents Class
WebPaneClientSideEvents Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneClientSideEvents Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebPaneClientSideEvents
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneClientSideEvents Class
WebPaneClientSideEvents Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneClientSideEvents Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneClientSideEvents Class
WebPaneClientSideEvents Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneClientSideEvents Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneClientSideEvents
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneClientSideEvents Class
WebPaneClientSideEvents Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneClientSideEvents Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneClientSideEvents
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneClientSideEvents Class
WebPaneClientSideEvents Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneClientSideEvents Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneClientSideEvents
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneClientSideEvents Class
WebPaneClientSideEvents Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneClientSideEvents Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebPaneClientSideEvents
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneClientSideEvents Class
WebPaneClientSideEvents Members


WebPaneClientSideEvents Class Methods

[image]
Intersoft WebDesktop Documentation
WebPaneClientSideEvents Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebPaneClientSideEvents Class

Glossary Item Box

For a list of all members of this type, see WebPaneClientSideEvents members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebPaneClientSideEvents Class
ISNet.WebUI.WebDesktop Namespace


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneClientSideEvents Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneClientSideEvents
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneClientSideEvents Class
WebPaneClientSideEvents Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneClientSideEvents Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebPaneClientSideEvents
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneClientSideEvents Class
WebPaneClientSideEvents Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneClientSideEvents Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebPaneClientSideEvents

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneClientSideEvents Class
WebPaneClientSideEvents Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneClientSideEvents Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneClientSideEvents
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneClientSideEvents Class
WebPaneClientSideEvents Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneClientSideEvents Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneClientSideEvents
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneClientSideEvents Class
WebPaneClientSideEvents Members


WebPaneClientSideEvents Class Properties

[image]
Intersoft WebDesktop Documentation
WebPaneClientSideEvents Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebPaneClientSideEvents Class

Glossary Item Box

For a list of all members of this type, see WebPaneClientSideEvents members.

Public Properties

 | Name | Description
Public Property | OnAfterCollapse | Gets or sets the javascript function to invoke after the Pane is collapsed.
Public Property | OnAfterResize | Gets or sets the javascript function to invoke after the Pane is resized through splitter.
Public Property | OnAfterRestore | Gets or sets the javascript function to invoke after the Pane is restored.
Public Property | OnBeforeCollapse | Gets or sets the javascript function to invoke before the Pane is collapsed.
Public Property | OnBeforeResize | Gets or sets the javascript function to invoke when the Pane is about to be resized through splitter.
Public Property | OnBeforeRestore | Gets or sets the javascript function to invoke before the Pane is restored.
Public Property | OnInitialize | Gets or sets the javascript function to invoke when the control is being initialized.
Top

See Also

Reference

WebPaneClientSideEvents Class
ISNet.WebUI.WebDesktop Namespace


WebPaneClientSideEvents Constructor

[image]
Intersoft WebDesktop Documentation
WebPaneClientSideEvents Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneClientSideEvents Class : WebPaneClientSideEvents Constructor

Glossary Item Box

Initializes a new instance of the WebPaneClientSideEvents class.

Overload List

Overload | Description
WebPaneClientSideEvents Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneClientSideEvents Class
WebPaneClientSideEvents Members


OnAfterCollapse Property

[image]
Intersoft WebDesktop Documentation
OnAfterCollapse Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneClientSideEvents Class : OnAfterCollapse Property

Glossary Item Box

Gets or sets the javascript function to invoke after the Pane is collapsed.

Syntax

Visual Basic (Declaration)
Public Property OnAfterCollapse As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneClientSideEvents
Dim value As String

instance.OnAfterCollapse = value

value = instance.OnAfterCollapse
C#
public string OnAfterCollapse {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneClientSideEvents Class
WebPaneClientSideEvents Members


OnAfterResize Property

[image]
Intersoft WebDesktop Documentation
OnAfterResize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneClientSideEvents Class : OnAfterResize Property

Glossary Item Box

Gets or sets the javascript function to invoke after the Pane is resized through splitter.

Syntax

Visual Basic (Declaration)
Public Property OnAfterResize As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneClientSideEvents
Dim value As String

instance.OnAfterResize = value

value = instance.OnAfterResize
C#
public string OnAfterResize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneClientSideEvents Class
WebPaneClientSideEvents Members


OnAfterRestore Property

[image]
Intersoft WebDesktop Documentation
OnAfterRestore Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneClientSideEvents Class : OnAfterRestore Property

Glossary Item Box

Gets or sets the javascript function to invoke after the Pane is restored.

Syntax

Visual Basic (Declaration)
Public Property OnAfterRestore As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneClientSideEvents
Dim value As String

instance.OnAfterRestore = value

value = instance.OnAfterRestore
C#
public string OnAfterRestore {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneClientSideEvents Class
WebPaneClientSideEvents Members


OnBeforeCollapse Property

[image]
Intersoft WebDesktop Documentation
OnBeforeCollapse Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneClientSideEvents Class : OnBeforeCollapse Property

Glossary Item Box

Gets or sets the javascript function to invoke before the Pane is collapsed.

Syntax

Visual Basic (Declaration)
Public Property OnBeforeCollapse As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneClientSideEvents
Dim value As String

instance.OnBeforeCollapse = value

value = instance.OnBeforeCollapse
C#
public string OnBeforeCollapse {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneClientSideEvents Class
WebPaneClientSideEvents Members


OnBeforeResize Property

[image]
Intersoft WebDesktop Documentation
OnBeforeResize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneClientSideEvents Class : OnBeforeResize Property

Glossary Item Box

Gets or sets the javascript function to invoke when the Pane is about to be resized through splitter.

Syntax

Visual Basic (Declaration)
Public Property OnBeforeResize As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneClientSideEvents
Dim value As String

instance.OnBeforeResize = value

value = instance.OnBeforeResize
C#
public string OnBeforeResize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneClientSideEvents Class
WebPaneClientSideEvents Members


OnBeforeRestore Property

[image]
Intersoft WebDesktop Documentation
OnBeforeRestore Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneClientSideEvents Class : OnBeforeRestore Property

Glossary Item Box

Gets or sets the javascript function to invoke before the Pane is restored.

Syntax

Visual Basic (Declaration)
Public Property OnBeforeRestore As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneClientSideEvents
Dim value As String

instance.OnBeforeRestore = value

value = instance.OnBeforeRestore
C#
public string OnBeforeRestore {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneClientSideEvents Class
WebPaneClientSideEvents Members


OnInitialize Property

[image]
Intersoft WebDesktop Documentation
OnInitialize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneClientSideEvents Class : OnInitialize Property

Glossary Item Box

Gets or sets the javascript function to invoke when the control is being initialized.

Syntax

Visual Basic (Declaration)
Public Property OnInitialize As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneClientSideEvents
Dim value As String

instance.OnInitialize = value

value = instance.OnInitialize
C#
public string OnInitialize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneClientSideEvents Class
WebPaneClientSideEvents Members


WebPaneCollection Class

[image]
Intersoft WebDesktop Documentation
WebPaneCollection Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebPaneCollection Class

Glossary Item Box

Collection of WebPane.

Object Model

WebPaneCollection Class

Syntax

Visual Basic (Declaration)
Public Class WebPaneCollection
   Inherits ISNet.WebUI.ISCollectionBase
Visual Basic (Usage) Copy Code
Dim instance As WebPaneCollection
C#
public class WebPaneCollection : ISNet.WebUI.ISCollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
ISNet.WebUI.ISCollectionBase
ISNet.WebUI.WebDesktop.WebPaneCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneCollection Members
ISNet.WebUI.WebDesktop Namespace


WebPaneCollection Class Members

[image]
Intersoft WebDesktop Documentation
WebPaneCollection Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebPaneCollection Class

Glossary Item Box

The following tables list the members exposed by WebPaneCollection.

Public Constructors

 | Name | Description
Public Constructor | WebPaneCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden.
Public Property | Item |
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Move |
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebPaneCollection Class
ISNet.WebUI.WebDesktop Namespace


WebPaneCollection Constructor

[image]
Intersoft WebDesktop Documentation
WebPaneCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneCollection Class : WebPaneCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebPaneCollection()
C#
public WebPaneCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneCollection Class
WebPaneCollection Members


WebPaneCollection Class Methods

[image]
Intersoft WebDesktop Documentation
WebPaneCollection Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebPaneCollection Class

Glossary Item Box

For a list of all members of this type, see WebPaneCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Move |
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebPaneCollection Class
ISNet.WebUI.WebDesktop Namespace


Add Method

[image]
Intersoft WebDesktop Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneCollection Class : Add Method

Glossary Item Box

Overload List

Overload | Description
Add(WebPaneBase) |
Add(String) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneCollection Class
WebPaneCollection Members


Add(WebPaneBase) Method

[image]
Intersoft WebDesktop Documentation
Add(WebPaneBase) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneCollection Class > Add Method : Add(WebPaneBase) Method

webPane

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function Add( _
   ByVal webPane As WebPaneBase _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebPaneCollection
Dim webPane As WebPaneBase
Dim value As Integer

value = instance.Add(webPane)
C#
public virtual int Add(
   WebPaneBase webPane
)

Parameters

webPane

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneCollection Class
WebPaneCollection Members
Overload List


Add(String) Method

[image]
Intersoft WebDesktop Documentation
Add(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneCollection Class > Add Method : Add(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal name As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebPaneCollection
Dim name As String
Dim value As Integer

value = instance.Add(name)
C#
public int Add(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneCollection Class
WebPaneCollection Members
Overload List


Clear Method

[image]
Intersoft WebDesktop Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As WebPaneCollection

instance.Clear()
C#
public new void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneCollection Class
WebPaneCollection Members


Contains Method

[image]
Intersoft WebDesktop Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneCollection Class : Contains Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As ISNet.WebUI.INamedObject _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebPaneCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As Boolean

value = instance.Contains(value)
C#
public bool Contains(
   ISNet.WebUI.INamedObject value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneCollection Class
WebPaneCollection Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneCollection Class : CopyFrom Method

passIn

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CopyFrom( _
   ByVal passIn As WebPaneCollection _
) As WebPaneCollection
Visual Basic (Usage) Copy Code
Dim instance As WebPaneCollection
Dim passIn As WebPaneCollection
Dim value As WebPaneCollection

value = instance.CopyFrom(passIn)
C#
public WebPaneCollection CopyFrom(
   WebPaneCollection passIn
)

Parameters

passIn

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneCollection Class
WebPaneCollection Members


CopyTo Method

[image]
Intersoft WebDesktop Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneCollection
Dim array() As ISNet.WebUI.INamedObject
Dim index As Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   ISNet.WebUI.INamedObject[] array,
   int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneCollection Class
WebPaneCollection Members


Exists Method

[image]
Intersoft WebDesktop Documentation
Exists Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneCollection Class : Exists Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Exists( _
   ByVal name As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebPaneCollection
Dim name As String
Dim value As Boolean

value = instance.Exists(name)
C#
public bool Exists(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneCollection Class
WebPaneCollection Members


GetEnumerator Method

[image]
Intersoft WebDesktop Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Function GetEnumerator() As System.Collections.IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As WebPaneCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
public new System.Collections.IEnumerator GetEnumerator()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneCollection Class
WebPaneCollection Members


GetItem Method

[image]
Intersoft WebDesktop Documentation
GetItem Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneCollection Class : GetItem Method

Glossary Item Box

Overload List

Overload | Description
GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneCollection Class
WebPaneCollection Members


GetItem(Int32) Method

[image]
Intersoft WebDesktop Documentation
GetItem(Int32) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneCollection Class : GetItem(Int32) Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetItem( _
   ByVal index As Integer _
) As ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebPaneCollection
Dim index As Integer
Dim value As ISNet.WebUI.INamedObject

value = instance.GetItem(index)
C#
public virtual ISNet.WebUI.INamedObject GetItem(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneCollection Class
WebPaneCollection Members


GetNamedItem Method

[image]
Intersoft WebDesktop Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNamedItem( _
   ByVal name As String _
) As WebPaneBase
Visual Basic (Usage) Copy Code
Dim instance As WebPaneCollection
Dim name As String
Dim value As WebPaneBase

value = instance.GetNamedItem(name)
C#
public WebPaneBase GetNamedItem(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneCollection Class
WebPaneCollection Members


IndexOf Method

[image]
Intersoft WebDesktop Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneCollection Class : IndexOf Method

Glossary Item Box

Overload List

Overload | Description
IndexOf(String) | (Inherited from ISNet.WebUI.ISCollectionBase)
IndexOf(INamedObject) | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneCollection Class
WebPaneCollection Members


IndexOf(String) Method

[image]
Intersoft WebDesktop Documentation
IndexOf(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneCollection Class > IndexOf Method : IndexOf(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function IndexOf( _
   ByVal name As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebPaneCollection
Dim name As String
Dim value As Integer

value = instance.IndexOf(name)
C#
public virtual int IndexOf(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneCollection Class
WebPaneCollection Members
Overload List


IndexOf(INamedObject) Method

[image]
Intersoft WebDesktop Documentation
IndexOf(INamedObject) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneCollection Class > IndexOf Method : IndexOf(INamedObject) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal value As ISNet.WebUI.INamedObject _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebPaneCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As Integer

value = instance.IndexOf(value)
C#
public int IndexOf(
   ISNet.WebUI.INamedObject value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneCollection Class
WebPaneCollection Members
Overload List


Insert Method

[image]
Intersoft WebDesktop Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneCollection Class : Insert Method

index
webPane

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal webPane As WebPaneBase _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneCollection
Dim index As Integer
Dim webPane As WebPaneBase

instance.Insert(index, webPane)
C#
public void Insert(
   int index,
   WebPaneBase webPane
)

Parameters

index
webPane

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneCollection Class
WebPaneCollection Members


IntInsert Method

[image]
Intersoft WebDesktop Documentation
IntInsert Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneCollection Class : IntInsert Method

index
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub IntInsert( _
   ByVal index As Integer, _
   ByVal value As ISNet.WebUI.INamedObject _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneCollection
Dim index As Integer
Dim value As ISNet.WebUI.INamedObject

instance.IntInsert(index, value)
C#
public void IntInsert(
   int index,
   ISNet.WebUI.INamedObject value
)

Parameters

index
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneCollection Class
WebPaneCollection Members


Move Method

[image]
Intersoft WebDesktop Documentation
Move Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneCollection Class : Move Method

index
webPane

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Move( _
   ByVal index As Integer, _
   ByVal webPane As WebPaneBase _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneCollection
Dim index As Integer
Dim webPane As WebPaneBase

instance.Move(index, webPane)
C#
public void Move(
   int index,
   WebPaneBase webPane
)

Parameters

index
webPane

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneCollection Class
WebPaneCollection Members


Remove Method

[image]
Intersoft WebDesktop Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneCollection Class : Remove Method

webPane

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal webPane As WebPaneBase _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneCollection
Dim webPane As WebPaneBase

instance.Remove(webPane)
C#
public void Remove(
   WebPaneBase webPane
)

Parameters

webPane

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneCollection Class
WebPaneCollection Members


setParent Method

[image]
Intersoft WebDesktop Documentation
setParent Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneCollection Class : setParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub setParent( _
   ByVal parent As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneCollection
Dim parent As Object

instance.setParent(parent)
C#
public virtual void setParent(
   object parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneCollection Class
WebPaneCollection Members


Capacity Property

[image]
Intersoft WebDesktop Documentation
Capacity Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneCollection Class : Capacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebPaneCollection
Dim value As Integer

instance.Capacity = value

value = instance.Capacity
C#
public int Capacity {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneCollection Class
WebPaneCollection Members


Count Property

[image]
Intersoft WebDesktop Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebPaneCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneCollection Class
WebPaneCollection Members


WebPaneCollection Class Properties

[image]
Intersoft WebDesktop Documentation
WebPaneCollection Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebPaneCollection Class

Glossary Item Box

For a list of all members of this type, see WebPaneCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden.
Public Property | Item |
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebPaneCollection Class
ISNet.WebUI.WebDesktop Namespace


WebPaneCollection Constructor

[image]
Intersoft WebDesktop Documentation
WebPaneCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneCollection Class : WebPaneCollection Constructor

Glossary Item Box

Initializes a new instance of the WebPaneCollection class.

Overload List

Overload | Description
WebPaneCollection Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneCollection Class
WebPaneCollection Members


IsReadOnly Property

[image]
Intersoft WebDesktop Documentation
IsReadOnly Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneCollection Class : IsReadOnly Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebPaneCollection
Dim value As Boolean

value = instance.IsReadOnly
C#
public override bool IsReadOnly {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneCollection Class
WebPaneCollection Members


Item Property

[image]
Intersoft WebDesktop Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneCollection Class : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As WebPaneBase
Visual Basic (Usage) Copy Code
Dim instance As WebPaneCollection
Dim index As Integer
Dim value As WebPaneBase

value = instance.Item(index)
C#
public WebPaneBase this[
   int index
]; {get;}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneCollection Class
WebPaneCollection Members


Parent Property

[image]
Intersoft WebDesktop Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As Object
Visual Basic (Usage) Copy Code
Dim instance As WebPaneCollection
Dim value As Object

value = instance.Parent
C#
public object Parent {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneCollection Class
WebPaneCollection Members


WebPaneImagesSettings Class

[image]
Intersoft WebDesktop Documentation
WebPaneImagesSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebPaneImagesSettings Class

Glossary Item Box

Collection of images settings for WebPaneManager.

Object Model

WebPaneImagesSettings Class

Syntax

Visual Basic (Declaration)
Public Class WebPaneImagesSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebPaneImagesSettings
C#
public class WebPaneImagesSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Remarks

Using WebPaneImagesSettings you can configure whether to display the splitter grip on WebPane by configuring the SplitterGripBottom, SplitterGripLeft, SplitterGripRight, and SplitterGripTop.

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebDesktop.WebPaneImagesSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneImagesSettings Members
ISNet.WebUI.WebDesktop Namespace


WebPaneImagesSettings Class Members

[image]
Intersoft WebDesktop Documentation
WebPaneImagesSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebPaneImagesSettings Class

Glossary Item Box

The following tables list the members exposed by WebPaneImagesSettings.

Public Constructors

 | Name | Description
Public Constructor | WebPaneImagesSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | InProgress | The image displayed when the IFrame is being loaded.
Public Property | SplitterGripBottom | The splitter's grip image indicating the splitter is collapsible to bottom direction.
Public Property | SplitterGripLeft | The splitter's grip image indicating the splitter is collapsible to left direction.
Public Property | SplitterGripRight | The splitter's grip image indicating the splitter is collapsible to right direction.
Public Property | SplitterGripTop | The splitter's grip image indicating the splitter is collapsible to top direction.
Public Property | SplitterHorizontalIndicator |
Public Property | SplitterVerticalIndicator |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebPaneImagesSettings Class
ISNet.WebUI.WebDesktop Namespace


WebPaneImagesSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebPaneImagesSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneImagesSettings Class : WebPaneImagesSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebPaneImagesSettings()
C#
public WebPaneImagesSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneImagesSettings Class
WebPaneImagesSettings Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneImagesSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebPaneImagesSettings
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneImagesSettings Class
WebPaneImagesSettings Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneImagesSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneImagesSettings Class
WebPaneImagesSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneImagesSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneImagesSettings
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneImagesSettings Class
WebPaneImagesSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneImagesSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneImagesSettings
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneImagesSettings Class
WebPaneImagesSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneImagesSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneImagesSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneImagesSettings Class
WebPaneImagesSettings Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneImagesSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebPaneImagesSettings
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneImagesSettings Class
WebPaneImagesSettings Members


WebPaneImagesSettings Class Methods

[image]
Intersoft WebDesktop Documentation
WebPaneImagesSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebPaneImagesSettings Class

Glossary Item Box

For a list of all members of this type, see WebPaneImagesSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebPaneImagesSettings Class
ISNet.WebUI.WebDesktop Namespace


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneImagesSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneImagesSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneImagesSettings Class
WebPaneImagesSettings Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneImagesSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebPaneImagesSettings
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneImagesSettings Class
WebPaneImagesSettings Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneImagesSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebPaneImagesSettings

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneImagesSettings Class
WebPaneImagesSettings Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneImagesSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneImagesSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneImagesSettings Class
WebPaneImagesSettings Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneImagesSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneImagesSettings
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneImagesSettings Class
WebPaneImagesSettings Members


WebPaneImagesSettings Class Properties

[image]
Intersoft WebDesktop Documentation
WebPaneImagesSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebPaneImagesSettings Class

Glossary Item Box

For a list of all members of this type, see WebPaneImagesSettings members.

Public Properties

 | Name | Description
Public Property | InProgress | The image displayed when the IFrame is being loaded.
Public Property | SplitterGripBottom | The splitter's grip image indicating the splitter is collapsible to bottom direction.
Public Property | SplitterGripLeft | The splitter's grip image indicating the splitter is collapsible to left direction.
Public Property | SplitterGripRight | The splitter's grip image indicating the splitter is collapsible to right direction.
Public Property | SplitterGripTop | The splitter's grip image indicating the splitter is collapsible to top direction.
Public Property | SplitterHorizontalIndicator |
Public Property | SplitterVerticalIndicator |
Top

See Also

Reference

WebPaneImagesSettings Class
ISNet.WebUI.WebDesktop Namespace


WebPaneImagesSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebPaneImagesSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneImagesSettings Class : WebPaneImagesSettings Constructor

Glossary Item Box

Initializes a new instance of the WebPaneImagesSettings class.

Overload List

Overload | Description
WebPaneImagesSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneImagesSettings Class
WebPaneImagesSettings Members


InProgress Property

[image]
Intersoft WebDesktop Documentation
InProgress Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneImagesSettings Class : InProgress Property

Glossary Item Box

The image displayed when the IFrame is being loaded.

Syntax

Visual Basic (Declaration)
Public Property InProgress As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneImagesSettings
Dim value As String

instance.InProgress = value

value = instance.InProgress
C#
public string InProgress {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneImagesSettings Class
WebPaneImagesSettings Members


SplitterGripBottom Property

[image]
Intersoft WebDesktop Documentation
SplitterGripBottom Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneImagesSettings Class : SplitterGripBottom Property

Glossary Item Box

The splitter's grip image indicating the splitter is collapsible to bottom direction.

Syntax

Visual Basic (Declaration)
Public Property SplitterGripBottom As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneImagesSettings
Dim value As String

instance.SplitterGripBottom = value

value = instance.SplitterGripBottom
C#
public string SplitterGripBottom {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneImagesSettings Class
WebPaneImagesSettings Members


SplitterGripLeft Property

[image]
Intersoft WebDesktop Documentation
SplitterGripLeft Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneImagesSettings Class : SplitterGripLeft Property

Glossary Item Box

The splitter's grip image indicating the splitter is collapsible to left direction.

Syntax

Visual Basic (Declaration)
Public Property SplitterGripLeft As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneImagesSettings
Dim value As String

instance.SplitterGripLeft = value

value = instance.SplitterGripLeft
C#
public string SplitterGripLeft {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneImagesSettings Class
WebPaneImagesSettings Members


SplitterGripRight Property

[image]
Intersoft WebDesktop Documentation
SplitterGripRight Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneImagesSettings Class : SplitterGripRight Property

Glossary Item Box

The splitter's grip image indicating the splitter is collapsible to right direction.

Syntax

Visual Basic (Declaration)
Public Property SplitterGripRight As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneImagesSettings
Dim value As String

instance.SplitterGripRight = value

value = instance.SplitterGripRight
C#
public string SplitterGripRight {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneImagesSettings Class
WebPaneImagesSettings Members


SplitterGripTop Property

[image]
Intersoft WebDesktop Documentation
SplitterGripTop Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneImagesSettings Class : SplitterGripTop Property

Glossary Item Box

The splitter's grip image indicating the splitter is collapsible to top direction.

Syntax

Visual Basic (Declaration)
Public Property SplitterGripTop As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneImagesSettings
Dim value As String

instance.SplitterGripTop = value

value = instance.SplitterGripTop
C#
public string SplitterGripTop {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneImagesSettings Class
WebPaneImagesSettings Members


SplitterHorizontalIndicator Property

[image]
Intersoft WebDesktop Documentation
SplitterHorizontalIndicator Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneImagesSettings Class : SplitterHorizontalIndicator Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property SplitterHorizontalIndicator As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneImagesSettings
Dim value As String

instance.SplitterHorizontalIndicator = value

value = instance.SplitterHorizontalIndicator
C#
public string SplitterHorizontalIndicator {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneImagesSettings Class
WebPaneImagesSettings Members


SplitterVerticalIndicator Property

[image]
Intersoft WebDesktop Documentation
SplitterVerticalIndicator Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneImagesSettings Class : SplitterVerticalIndicator Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property SplitterVerticalIndicator As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneImagesSettings
Dim value As String

instance.SplitterVerticalIndicator = value

value = instance.SplitterVerticalIndicator
C#
public string SplitterVerticalIndicator {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneImagesSettings Class
WebPaneImagesSettings Members


WebPaneManager Class

[image]
Intersoft WebDesktop Documentation
WebPaneManager Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebPaneManager Class

Glossary Item Box

WebPaneManager is a component that allows you to easily manage the Pane structure. Using WebPaneManager you can quickly create simple layout to complex Office-style layout.

Object Model

WebPaneManager Class

Syntax

Visual Basic (Declaration)
Public Class WebPaneManager
   Inherits ISNet.WebUI.ISNetControl
   Implements ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, ISNet.WebUI.ITemplateSync
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
C#
public class WebPaneManager : ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, ISNet.WebUI.ITemplateSync

Remarks

You can use WebPaneManager to create simple layout to complex Office-style layout which contains Header Element and fully customizable appearances. Use the provided Visual PaneManager Designer to create common Layout from Predefined Template with one click away.

WebPaneManager's TrueFill architecture allows you to build consistent Layout with Panes that are resizable and responding properly to window resize. Instead of creating separate pages by using Frame approach, you can now create a single page with resizable Panes which you can configure easily in strong object model approach.

The Automatic Resizing feature that works in conjunction with TrueFill architecture can manages the dimension of all available Panes to take best dimension of available spaces. Combined with AllowCollapse feature, you can let your users to maximize the utilization of screen real estate by collapsing a Pane into a specific direction at runtime.

The following are time-saving and innovative features of WebPaneManager

  • Rich Design Time experience
    WebPaneManager makes it possible for you to design and develop your rapid web application the same way and manner as in WinForm IDE. WebPaneManager implements ClickAndEdit™ and ClickAndSelect™ technologies to deliver this time-saving and elegant architecture to life.
  • TrueFill™ Layout
    TrueFill introduces you to a new way of creating complex Layout in less effort by automating common layout tasks as well as automatically adjusting incorrect dimension values to produce consistent and extensible layout.
  • Nested Layout Grouping in strong object model
    WebPaneManager is built with strong object model and clear separation between Group and Pane to enable nested Layout Grouping to be shown in consistent fashion.
  • AllowCollapse and AllowResize
    Using AllowCollapse and AllowResize users can resize the dimension of Pane at runtime and collapse a Pane into specified direction.
  • Automatic Resizing
    When configured to use percentage Width and Height (default is 100%), WebPaneManager with its TrueFill™ architecture will be able to resize its size along as the available Panes automatically responding to the current Window's size.

To learn more and see the illustrations of WebPaneManager's features please refer to WebPaneManager Features.

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
ISNet.WebUI.ISNetControl
ISNet.WebUI.WebDesktop.WebPaneManager

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Members
ISNet.WebUI.WebDesktop Namespace

Tasks

Creating Simple Layout
Creating Layout from Predefined Template
Creating Outlook 2003 Style Layout

tasks

Configuring Collapsible Pane

Concepts

WebPaneManager Overview
WebPaneFeatures
Understanding Concepts
Working with ClickAndEdit and Designers
Splitter Integration


WebPaneManager Class Members

[image]
Intersoft WebDesktop Documentation
WebPaneManager Class Members
See Also Properties Methods Events Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebPaneManager Class

Glossary Item Box

The following tables list the members exposed by WebPaneManager.

Public Constructors

 | Name | Description
Public Constructor | WebPaneManager Constructor |
Top

Public Properties

 | Name | Description
Public Property | AccessKey | Keyboard shortcut used by the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | BackColor | Overridden. Color of the background of the control.
Public Property | BorderColor | Overridden. Color of the border around the control.
Public Property | BorderStyle | Overridden. Style of the border around the control.
Public Property | BorderWidth | Overridden. Width of the border around the control.
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ClientSideEvents | Contains client side events for WebPaneManager.
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Enabled | Enabled state of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableManagedTheming | Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to False, this control will not apply the style defined in Theme Architecture. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | Whether the control automatically saves its state for use in round-trips. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Font | Overridden. The font used for text within the control.
Public Property | ForeColor | Overridden. Color of the text within the control.
Public Property | FrameStyle | Gets or sets the Frame style of the WebPaneManager.
Public Property | Height | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ImagesDirectory | Gets or sets the location of images used to render the WebPaneManager control.
Public Property | ImagesSettings | Contains images settings for WebPaneManager.
Public Property | Padding |
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | PaneSettings | Contains default settings for the WebPaneManager.
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden. Gets or sets the directory where all required scripts for the control are stored.
Public Property | SharedScriptDirectory | Overridden.
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SplitterSettings | Contains default settings for the Splitter.
Public Property | SplitterStyle |
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | TextSettings | Contains text settings used by the control.
Public Property | ToolTip | The tooltip displayed when the mouse is over the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateItems | Gets or sets the items to be stored in view state storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | Gets or sets the server connection string for file server-based viewstate storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | Gets or sets the location to store the viewstate of this control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | Indicates whether the control is visible and rendered. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Width | The width of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | XmlCompressionEnabled | Specifies whether the Xml used for clientside state storage should be compressed. (Inherited from ISNet.WebUI.ISNetControl)
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CheckConstrains | Overridden.
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. Overridden.
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetAllPanes |
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPanesStructureFromXml | Overloaded.
Public Method | LoadPostData | Overridden.
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RaisePostBackEvent |
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RecreateChildControls |
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SavePanesStructureToXml | Overloaded.
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SynchronizeTemplatesFrom |
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebPaneManager Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Creating Simple Layout
Creating Layout from Predefined Template
Creating Outlook 2003 Style Layout

tasks

Configuring Collapsible Pane

Concepts

WebPaneManager Overview
WebPaneFeatures
Understanding Concepts
Working with ClickAndEdit and Designers
Splitter Integration


WebPaneManager Class Events

[image]
Intersoft WebDesktop Documentation
WebPaneManager Class Events
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebPaneManager Class

Glossary Item Box

For a list of all members of this type, see WebPaneManager members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebPaneManager Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Creating Simple Layout
Creating Layout from Predefined Template
Creating Outlook 2003 Style Layout

tasks

Configuring Collapsible Pane

Concepts

WebPaneManager Overview
WebPaneFeatures
Understanding Concepts
Working with ClickAndEdit and Designers
Splitter Integration


WebPaneManager Constructor

[image]
Intersoft WebDesktop Documentation
WebPaneManager Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : WebPaneManager Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebPaneManager()
C#
public WebPaneManager()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


ApplyStyle Method

[image]
Intersoft WebDesktop Documentation
ApplyStyle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : ApplyStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ApplyStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim s As System.Web.UI.WebControls.Style

instance.ApplyStyle(s)
C#
public void ApplyStyle(
   System.Web.UI.WebControls.Style s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


ApplyStyleSheetSkin Method

[image]
Intersoft WebDesktop Documentation
ApplyStyleSheetSkin Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : ApplyStyleSheetSkin Method

page

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub ApplyStyleSheetSkin( _
   ByVal page As System.Web.UI.Page _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim page As System.Web.UI.Page

instance.ApplyStyleSheetSkin(page)
C#
public virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page page
)

Parameters

page

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


CanUseWebResources Method

[image]
Intersoft WebDesktop Documentation
CanUseWebResources Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : CanUseWebResources Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CanUseWebResources() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As Boolean

value = instance.CanUseWebResources()
C#
public bool CanUseWebResources()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


WebPaneManager Class Methods

[image]
Intersoft WebDesktop Documentation
WebPaneManager Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebPaneManager Class

Glossary Item Box

For a list of all members of this type, see WebPaneManager members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CheckConstrains | Overridden.
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. Overridden.
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetAllPanes |
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPanesStructureFromXml | Overloaded.
Public Method | LoadPostData | Overridden.
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RaisePostBackEvent |
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RecreateChildControls |
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SavePanesStructureToXml | Overloaded.
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SynchronizeTemplatesFrom |
Top

See Also

Reference

WebPaneManager Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Creating Simple Layout
Creating Layout from Predefined Template
Creating Outlook 2003 Style Layout

tasks

Configuring Collapsible Pane

Concepts

WebPaneManager Overview
WebPaneFeatures
Understanding Concepts
Working with ClickAndEdit and Designers
Splitter Integration


CheckConstrains Method

[image]
Intersoft WebDesktop Documentation
CheckConstrains Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : CheckConstrains Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub CheckConstrains()
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager

instance.CheckConstrains()
C#
public override void CheckConstrains()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


CopyBaseAttributes Method

[image]
Intersoft WebDesktop Documentation
CopyBaseAttributes Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : CopyBaseAttributes Method

controlSrc

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyBaseAttributes( _
   ByVal controlSrc As System.Web.UI.WebControls.WebControl _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim controlSrc As System.Web.UI.WebControls.WebControl

instance.CopyBaseAttributes(controlSrc)
C#
public void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl controlSrc
)

Parameters

controlSrc

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object,Boolean) |
CopyFrom(Object) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public override void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members
Overload List


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members
Overload List


DataBind Method

[image]
Intersoft WebDesktop Documentation
DataBind Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : DataBind Method

Glossary Item Box

Overload List

Overload | Description
DataBind | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


DataBind() Method

[image]
Intersoft WebDesktop Documentation
DataBind() Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : DataBind() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub DataBind()
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager

instance.DataBind()
C#
public virtual void DataBind()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


Dispose Method

[image]
Intersoft WebDesktop Documentation
Dispose Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : Dispose Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager

instance.Dispose()
C#
public virtual void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


FindControl Method

[image]
Intersoft WebDesktop Documentation
FindControl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : FindControl Method

Glossary Item Box

Overload List

Overload | Description
FindControl | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


FindControl(String) Method

[image]
Intersoft WebDesktop Documentation
FindControl(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : FindControl(String) Method

id

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function FindControl( _
   ByVal id As String _
) As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim id As String
Dim value As System.Web.UI.Control

value = instance.FindControl(id)
C#
public virtual System.Web.UI.Control FindControl(
   string id
)

Parameters

id

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


Focus Method

[image]
Intersoft WebDesktop Documentation
Focus Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : Focus Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Focus()
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager

instance.Focus()
C#
public virtual void Focus()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


ForceDisableXmlCompression Method

[image]
Intersoft WebDesktop Documentation
ForceDisableXmlCompression Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : ForceDisableXmlCompression Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ForceDisableXmlCompression()
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager

instance.ForceDisableXmlCompression()
C#
public void ForceDisableXmlCompression()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


GetAllPanes Method

[image]
Intersoft WebDesktop Documentation
GetAllPanes Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : GetAllPanes Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetAllPanes() As WebPaneCollection
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As WebPaneCollection

value = instance.GetAllPanes()
C#
public WebPaneCollection GetAllPanes()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


GetCurrentControlLifeCycle Method

[image]
Intersoft WebDesktop Documentation
GetCurrentControlLifeCycle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : GetCurrentControlLifeCycle Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentControlLifeCycle() As ISNet.WebUI.ControlLifeCycle
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As ISNet.WebUI.ControlLifeCycle

value = instance.GetCurrentControlLifeCycle()
C#
public ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


GetCurrentTheme Method

[image]
Intersoft WebDesktop Documentation
GetCurrentTheme Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : GetCurrentTheme Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentTheme() As ISNet.WebUI.ThemeInfo
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As ISNet.WebUI.ThemeInfo

value = instance.GetCurrentTheme()
C#
public ISNet.WebUI.ThemeInfo GetCurrentTheme()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


GetFrameworkDataFolder Method

[image]
Intersoft WebDesktop Documentation
GetFrameworkDataFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : GetFrameworkDataFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkDataFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As String

value = instance.GetFrameworkDataFolder()
C#
public string GetFrameworkDataFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


GetFrameworkFolder Method

[image]
Intersoft WebDesktop Documentation
GetFrameworkFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : GetFrameworkFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As String

value = instance.GetFrameworkFolder()
C#
public string GetFrameworkFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


GetFrameworkVersion Method

[image]
Intersoft WebDesktop Documentation
GetFrameworkVersion Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : GetFrameworkVersion Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkVersion() As Version
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As Version

value = instance.GetFrameworkVersion()
C#
public Version GetFrameworkVersion()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


GetIntersoftFolder Method

[image]
Intersoft WebDesktop Documentation
GetIntersoftFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : GetIntersoftFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetIntersoftFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As String

value = instance.GetIntersoftFolder()
C#
public string GetIntersoftFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


GetLayoutFolder Method

[image]
Intersoft WebDesktop Documentation
GetLayoutFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : GetLayoutFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetLayoutFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As String

value = instance.GetLayoutFolder()
C#
public string GetLayoutFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


GetPostedXMLData Method

[image]
Intersoft WebDesktop Documentation
GetPostedXMLData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : GetPostedXMLData Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPostedXMLData() As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As String

value = instance.GetPostedXMLData()
C#
public string GetPostedXMLData()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


GetProductInfoKey Method

[image]
Intersoft WebDesktop Documentation
GetProductInfoKey Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : GetProductInfoKey Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductInfoKey() As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As String

value = instance.GetProductInfoKey()
C#
public string GetProductInfoKey()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


GetProductSimpleName Method

[image]
Intersoft WebDesktop Documentation
GetProductSimpleName Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : GetProductSimpleName Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductSimpleName() As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As String

value = instance.GetProductSimpleName()
C#
public string GetProductSimpleName()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


GetPropertyValue Method

[image]
Intersoft WebDesktop Documentation
GetPropertyValue Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : GetPropertyValue Method

defValue
propValue
webConfigKey

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPropertyValue( _
   ByVal defValue As String, _
   ByVal propValue As String, _
   ByVal webConfigKey As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim defValue As String
Dim propValue As String
Dim webConfigKey As String
Dim value As String

value = instance.GetPropertyValue(defValue, propValue, webConfigKey)
C#
public string GetPropertyValue(
   string defValue,
   string propValue,
   string webConfigKey
)

Parameters

defValue
propValue
webConfigKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


GetResourceStream Method

[image]
Intersoft WebDesktop Documentation
GetResourceStream Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : GetResourceStream Method

resourceUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetResourceStream( _
   ByVal resourceUrl As String _
) As System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim resourceUrl As String
Dim value As System.IO.Stream

value = instance.GetResourceStream(resourceUrl)
C#
public System.IO.Stream GetResourceStream(
   string resourceUrl
)

Parameters

resourceUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


GetRouteUrl Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : GetRouteUrl Method

Glossary Item Box

Overload List

Overload | Description
GetRouteUrl(Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(RouteValueDictionary) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,RouteValueDictionary) | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


GetRouteUrl(Object) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class > GetRouteUrl Method : GetRouteUrl(Object) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As Object _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim routeParameters As Object
Dim value As String

value = instance.GetRouteUrl(routeParameters)
C#
public string GetRouteUrl(
   object routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members
Overload List


GetRouteUrl(String,Object) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(String,Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class > GetRouteUrl Method : GetRouteUrl(String,Object) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As String, _
   ByVal routeParameters As Object _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim routeName As String
Dim routeParameters As Object
Dim value As String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public string GetRouteUrl(
   string routeName,
   object routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members
Overload List


GetRouteUrl(RouteValueDictionary) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(RouteValueDictionary) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class > GetRouteUrl Method : GetRouteUrl(RouteValueDictionary) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As String

value = instance.GetRouteUrl(routeParameters)
C#
public string GetRouteUrl(
   System.Web.Routing.RouteValueDictionary routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members
Overload List


GetRouteUrl(String,RouteValueDictionary) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(String,RouteValueDictionary) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class > GetRouteUrl Method : GetRouteUrl(String,RouteValueDictionary) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As String, _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim routeName As String
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public string GetRouteUrl(
   string routeName,
   System.Web.Routing.RouteValueDictionary routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members
Overload List


GetUniqueIDRelativeTo Method

[image]
Intersoft WebDesktop Documentation
GetUniqueIDRelativeTo Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : GetUniqueIDRelativeTo Method

control

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetUniqueIDRelativeTo( _
   ByVal control As System.Web.UI.Control _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim control As System.Web.UI.Control
Dim value As String

value = instance.GetUniqueIDRelativeTo(control)
C#
public string GetUniqueIDRelativeTo(
   System.Web.UI.Control control
)

Parameters

control

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


HasControls Method

[image]
Intersoft WebDesktop Documentation
HasControls Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : HasControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function HasControls() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As Boolean

value = instance.HasControls()
C#
public virtual bool HasControls()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


IsAtlasCallback Method

[image]
Intersoft WebDesktop Documentation
IsAtlasCallback Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : IsAtlasCallback Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsAtlasCallback() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As Boolean

value = instance.IsAtlasCallback()
C#
public bool IsAtlasCallback()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


IsBetaRelease Method

[image]
Intersoft WebDesktop Documentation
IsBetaRelease Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : IsBetaRelease Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsBetaRelease() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As Boolean

value = instance.IsBetaRelease()
C#
public bool IsBetaRelease()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


IsChromeBrowser Method

[image]
Intersoft WebDesktop Documentation
IsChromeBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : IsChromeBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsChromeBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As Boolean

value = instance.IsChromeBrowser()
C#
public bool IsChromeBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


IsFlyPostBackControl Method

[image]
Intersoft WebDesktop Documentation
IsFlyPostBackControl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : IsFlyPostBackControl Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackControl() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As Boolean

value = instance.IsFlyPostBackControl()
C#
public virtual bool IsFlyPostBackControl()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


IsFlyPostBackRequest Method

[image]
Intersoft WebDesktop Documentation
IsFlyPostBackRequest Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : IsFlyPostBackRequest Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackRequest() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As Boolean

value = instance.IsFlyPostBackRequest()
C#
public virtual bool IsFlyPostBackRequest()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


IsGeckoBasedBrowser Method

[image]
Intersoft WebDesktop Documentation
IsGeckoBasedBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : IsGeckoBasedBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoBasedBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As Boolean

value = instance.IsGeckoBasedBrowser()
C#
public bool IsGeckoBasedBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


IsGeckoVersion18 Method

[image]
Intersoft WebDesktop Documentation
IsGeckoVersion18 Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : IsGeckoVersion18 Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoVersion18() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As Boolean

value = instance.IsGeckoVersion18()
C#
public bool IsGeckoVersion18()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


IsInDesignMode Method

[image]
Intersoft WebDesktop Documentation
IsInDesignMode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : IsInDesignMode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInDesignMode() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As Boolean

value = instance.IsInDesignMode()
C#
public bool IsInDesignMode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


IsInternetExplorer8Browser Method

[image]
Intersoft WebDesktop Documentation
IsInternetExplorer8Browser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : IsInternetExplorer8Browser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorer8Browser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As Boolean

value = instance.IsInternetExplorer8Browser()
C#
public bool IsInternetExplorer8Browser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


IsInternetExplorerBrowser Method

[image]
Intersoft WebDesktop Documentation
IsInternetExplorerBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : IsInternetExplorerBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorerBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As Boolean

value = instance.IsInternetExplorerBrowser()
C#
public bool IsInternetExplorerBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


IsOperaBrowser Method

[image]
Intersoft WebDesktop Documentation
IsOperaBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : IsOperaBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsOperaBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As Boolean

value = instance.IsOperaBrowser()
C#
public bool IsOperaBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


IsSafariBrowser Method

[image]
Intersoft WebDesktop Documentation
IsSafariBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : IsSafariBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsSafariBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As Boolean

value = instance.IsSafariBrowser()
C#
public bool IsSafariBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


IsW3CStandardBrowser Method

[image]
Intersoft WebDesktop Documentation
IsW3CStandardBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : IsW3CStandardBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsW3CStandardBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As Boolean

value = instance.IsW3CStandardBrowser()
C#
public bool IsW3CStandardBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


LoadLayout Method

[image]
Intersoft WebDesktop Documentation
LoadLayout Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : LoadLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim settings As ISNet.WebUI.LayoutInfo

instance.LoadLayout(settings)
C#
public virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


LoadLayoutFromFile Method

[image]
Intersoft WebDesktop Documentation
LoadLayoutFromFile Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : LoadLayoutFromFile Method

filePath

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromFile( _
   ByVal filePath As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim filePath As String

instance.LoadLayoutFromFile(filePath)
C#
public virtual void LoadLayoutFromFile(
   string filePath
)

Parameters

filePath

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


LoadLayoutFromPredefinedName Method

[image]
Intersoft WebDesktop Documentation
LoadLayoutFromPredefinedName Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : LoadLayoutFromPredefinedName Method

predefinedName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromPredefinedName( _
   ByVal predefinedName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim predefinedName As String

instance.LoadLayoutFromPredefinedName(predefinedName)
C#
public virtual void LoadLayoutFromPredefinedName(
   string predefinedName
)

Parameters

predefinedName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


LoadLayoutFromStream Method

[image]
Intersoft WebDesktop Documentation
LoadLayoutFromStream Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : LoadLayoutFromStream Method

stream

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromStream( _
   ByVal stream As System.IO.Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim stream As System.IO.Stream

instance.LoadLayoutFromStream(stream)
C#
public virtual void LoadLayoutFromStream(
   System.IO.Stream stream
)

Parameters

stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


LoadPanesStructureFromXml Method

[image]
Intersoft WebDesktop Documentation
LoadPanesStructureFromXml Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : LoadPanesStructureFromXml Method

Glossary Item Box

Overload List

Overload | Description
LoadPanesStructureFromXml(Stream) |
LoadPanesStructureFromXml(String) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


LoadPanesStructureFromXml(Stream) Method

[image]
Intersoft WebDesktop Documentation
LoadPanesStructureFromXml(Stream) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class > LoadPanesStructureFromXml Method : LoadPanesStructureFromXml(Stream) Method

stream

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadPanesStructureFromXml( _
   ByVal stream As System.IO.Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim stream As System.IO.Stream

instance.LoadPanesStructureFromXml(stream)
C#
public void LoadPanesStructureFromXml(
   System.IO.Stream stream
)

Parameters

stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members
Overload List


LoadPanesStructureFromXml(String) Method

[image]
Intersoft WebDesktop Documentation
LoadPanesStructureFromXml(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class > LoadPanesStructureFromXml Method : LoadPanesStructureFromXml(String) Method

fileName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadPanesStructureFromXml( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim fileName As String

instance.LoadPanesStructureFromXml(fileName)
C#
public void LoadPanesStructureFromXml(
   string fileName
)

Parameters

fileName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members
Overload List


LoadPostData Method

[image]
Intersoft WebDesktop Documentation
LoadPostData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : LoadPostData Method

postDataKey
postCollection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function LoadPostData( _
   ByVal postDataKey As String, _
   ByVal postCollection As System.Collections.Specialized.NameValueCollection _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim postDataKey As String
Dim postCollection As System.Collections.Specialized.NameValueCollection
Dim value As Boolean

value = instance.LoadPostData(postDataKey, postCollection)
C#
public override bool LoadPostData(
   string postDataKey,
   System.Collections.Specialized.NameValueCollection postCollection
)

Parameters

postDataKey
postCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


MergeStyle Method

[image]
Intersoft WebDesktop Documentation
MergeStyle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : MergeStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub MergeStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim s As System.Web.UI.WebControls.Style

instance.MergeStyle(s)
C#
public void MergeStyle(
   System.Web.UI.WebControls.Style s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


OnInfoChanged Method

[image]
Intersoft WebDesktop Documentation
OnInfoChanged Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : OnInfoChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnInfoChanged( _
   ByVal e As ISNet.WebUI.SynchronizeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim e As ISNet.WebUI.SynchronizeEventArgs

instance.OnInfoChanged(e)
C#
public void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


OnPreInitialize Method

[image]
Intersoft WebDesktop Documentation
OnPreInitialize Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : OnPreInitialize Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnPreInitialize()
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager

instance.OnPreInitialize()
C#
public virtual void OnPreInitialize()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


RaisePostBackEvent Method

[image]
Intersoft WebDesktop Documentation
RaisePostBackEvent Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : RaisePostBackEvent Method

eventArgument

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RaisePostBackEvent( _
   ByVal eventArgument As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim eventArgument As String

instance.RaisePostBackEvent(eventArgument)
C#
public void RaisePostBackEvent(
   string eventArgument
)

Parameters

eventArgument

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


RaisePostDataChangedEvent Method

[image]
Intersoft WebDesktop Documentation
RaisePostDataChangedEvent Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : RaisePostDataChangedEvent Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RaisePostDataChangedEvent()
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager

instance.RaisePostDataChangedEvent()
C#
public virtual void RaisePostDataChangedEvent()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


ReadWebConfigValue Method

[image]
Intersoft WebDesktop Documentation
ReadWebConfigValue Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : ReadWebConfigValue Method

key

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ReadWebConfigValue( _
   ByVal key As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim key As String
Dim value As String

value = instance.ReadWebConfigValue(key)
C#
public string ReadWebConfigValue(
   string key
)

Parameters

key

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


RecreateChildControls Method

[image]
Intersoft WebDesktop Documentation
RecreateChildControls Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : RecreateChildControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RecreateChildControls()
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager

instance.RecreateChildControls()
C#
public void RecreateChildControls()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


RegisterBoxSizing Method

[image]
Intersoft WebDesktop Documentation
RegisterBoxSizing Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : RegisterBoxSizing Method

Glossary Item Box

Overload List

Overload | Description
RegisterBoxSizing() | (Inherited from ISNet.WebUI.ISNetControl)
RegisterBoxSizing(Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


RegisterBoxSizing() Method

[image]
Intersoft WebDesktop Documentation
RegisterBoxSizing() Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class > RegisterBoxSizing Method : RegisterBoxSizing() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing()
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager

instance.RegisterBoxSizing()
C#
public void RegisterBoxSizing()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members
Overload List


RegisterBoxSizing(Boolean) Method

[image]
Intersoft WebDesktop Documentation
RegisterBoxSizing(Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class > RegisterBoxSizing Method : RegisterBoxSizing(Boolean) Method

forceAll

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing( _
   ByVal forceAll As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim forceAll As Boolean

instance.RegisterBoxSizing(forceAll)
C#
public void RegisterBoxSizing(
   bool forceAll
)

Parameters

forceAll

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members
Overload List


RegisterGlobalStyle Method

[image]
Intersoft WebDesktop Documentation
RegisterGlobalStyle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : RegisterGlobalStyle Method

style

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterGlobalStyle( _
   ByVal style As ISNet.WebUI.WebStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim style As ISNet.WebUI.WebStyle

instance.RegisterGlobalStyle(style)
C#
public void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle style
)

Parameters

style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


RegisterLink Method

[image]
Intersoft WebDesktop Documentation
RegisterLink Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : RegisterLink Method

name
url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterLink( _
   ByVal name As String, _
   ByVal url As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim name As String
Dim url As String

instance.RegisterLink(name, url)
C#
public void RegisterLink(
   string name,
   string url
)

Parameters

name
url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


RegisterOptimizedCssClasses Method

[image]
Intersoft WebDesktop Documentation
RegisterOptimizedCssClasses Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : RegisterOptimizedCssClasses Method

runtimeStyleOnly

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterOptimizedCssClasses( _
   ByVal runtimeStyleOnly As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim runtimeStyleOnly As Boolean

instance.RegisterOptimizedCssClasses(runtimeStyleOnly)
C#
public void RegisterOptimizedCssClasses(
   bool runtimeStyleOnly
)

Parameters

runtimeStyleOnly

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


RegisterPreloadImage Method

[image]
Intersoft WebDesktop Documentation
RegisterPreloadImage Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : RegisterPreloadImage Method

image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterPreloadImage( _
   ByVal image As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim image As String

instance.RegisterPreloadImage(image)
C#
public void RegisterPreloadImage(
   string image
)

Parameters

image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


RegisterSharePointHandler Method

[image]
Intersoft WebDesktop Documentation
RegisterSharePointHandler Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : RegisterSharePointHandler Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RegisterSharePointHandler()
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager

instance.RegisterSharePointHandler()
C#
public virtual void RegisterSharePointHandler()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


RenderBeginTag Method

[image]
Intersoft WebDesktop Documentation
RenderBeginTag Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : RenderBeginTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderBeginTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderBeginTag(writer)
C#
public virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


RenderControl Method

[image]
Intersoft WebDesktop Documentation
RenderControl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : RenderControl Method

Glossary Item Box

Overload List

Overload | Description
RenderControl | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


RenderControl(HtmlTextWriter) Method

[image]
Intersoft WebDesktop Documentation
RenderControl(HtmlTextWriter) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : RenderControl(HtmlTextWriter) Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderControl( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderControl(writer)
C#
public virtual void RenderControl(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


RenderEndTag Method

[image]
Intersoft WebDesktop Documentation
RenderEndTag Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : RenderEndTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub RenderEndTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderEndTag(writer)
C#
public override void RenderEndTag(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


ResolveClientUrl Method

[image]
Intersoft WebDesktop Documentation
ResolveClientUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : ResolveClientUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveClientUrl( _
   ByVal relativeUrl As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim relativeUrl As String
Dim value As String

value = instance.ResolveClientUrl(relativeUrl)
C#
public string ResolveClientUrl(
   string relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


ResolveImagePath Method

[image]
Intersoft WebDesktop Documentation
ResolveImagePath Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : ResolveImagePath Method

folder
image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveImagePath( _
   ByVal folder As String, _
   ByVal image As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim folder As String
Dim image As String
Dim value As String

value = instance.ResolveImagePath(folder, image)
C#
public string ResolveImagePath(
   string folder,
   string image
)

Parameters

folder
image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


ResolveRelativeURL Method

[image]
Intersoft WebDesktop Documentation
ResolveRelativeURL Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : ResolveRelativeURL Method

url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ResolveRelativeURL( _
   ByVal url As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim url As String
Dim value As String

value = instance.ResolveRelativeURL(url)
C#
public virtual string ResolveRelativeURL(
   string url
)

Parameters

url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


ResolveResourceUrl Method

[image]
Intersoft WebDesktop Documentation
ResolveResourceUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : ResolveResourceUrl Method

kind
defaultFolder
currentFolder
resourceName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveResourceUrl( _
   ByVal kind As ISNet.WebUI.ResourceKind, _
   ByVal defaultFolder As String, _
   ByVal currentFolder As String, _
   ByVal resourceName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim kind As ISNet.WebUI.ResourceKind
Dim defaultFolder As String
Dim currentFolder As String
Dim resourceName As String
Dim value As String

value = instance.ResolveResourceUrl(kind, defaultFolder, currentFolder, resourceName)
C#
public string ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   string defaultFolder,
   string currentFolder,
   string resourceName
)

Parameters

kind
defaultFolder
currentFolder
resourceName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


ResolveUrl Method

[image]
Intersoft WebDesktop Documentation
ResolveUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : ResolveUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveUrl( _
   ByVal relativeUrl As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim relativeUrl As String
Dim value As String

value = instance.ResolveUrl(relativeUrl)
C#
public string ResolveUrl(
   string relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


SaveLayout Method

[image]
Intersoft WebDesktop Documentation
SaveLayout Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : SaveLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim settings As ISNet.WebUI.LayoutInfo

instance.SaveLayout(settings)
C#
public virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


SaveLayoutToFile Method

[image]
Intersoft WebDesktop Documentation
SaveLayoutToFile Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : SaveLayoutToFile Method

filePath
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToFile( _
   ByVal filePath As String, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim filePath As String
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToFile(filePath, saveOptions)
C#
public virtual void SaveLayoutToFile(
   string filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

filePath
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


SaveLayoutToStream Method

[image]
Intersoft WebDesktop Documentation
SaveLayoutToStream Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : SaveLayoutToStream Method

stream
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToStream( _
   ByVal stream As System.IO.Stream, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim stream As System.IO.Stream
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToStream(stream, saveOptions)
C#
public virtual void SaveLayoutToStream(
   System.IO.Stream stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

stream
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


SavePanesStructureToXml Method

[image]
Intersoft WebDesktop Documentation
SavePanesStructureToXml Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : SavePanesStructureToXml Method

Glossary Item Box

Overload List

Overload | Description
SavePanesStructureToXml(String) |
SavePanesStructureToXml() |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


SavePanesStructureToXml(String) Method

[image]
Intersoft WebDesktop Documentation
SavePanesStructureToXml(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class > SavePanesStructureToXml Method : SavePanesStructureToXml(String) Method

fileName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub SavePanesStructureToXml( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim fileName As String

instance.SavePanesStructureToXml(fileName)
C#
public void SavePanesStructureToXml(
   string fileName
)

Parameters

fileName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members
Overload List


SavePanesStructureToXml() Method

[image]
Intersoft WebDesktop Documentation
SavePanesStructureToXml() Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class > SavePanesStructureToXml Method : SavePanesStructureToXml() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function SavePanesStructureToXml() As System.Xml.XmlDocument
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As System.Xml.XmlDocument

value = instance.SavePanesStructureToXml()
C#
public System.Xml.XmlDocument SavePanesStructureToXml()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members
Overload List


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


SetRenderMethodDelegate Method

[image]
Intersoft WebDesktop Documentation
SetRenderMethodDelegate Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : SetRenderMethodDelegate Method

renderMethod

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetRenderMethodDelegate( _
   ByVal renderMethod As System.Web.UI.RenderMethod _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim renderMethod As System.Web.UI.RenderMethod

instance.SetRenderMethodDelegate(renderMethod)
C#
public void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod renderMethod
)

Parameters

renderMethod

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


SetSessionTheme Method

[image]
Intersoft WebDesktop Documentation
SetSessionTheme Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : SetSessionTheme Method

themeInfo

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetSessionTheme( _
   ByVal themeInfo As ISNet.WebUI.ThemeInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim themeInfo As ISNet.WebUI.ThemeInfo

instance.SetSessionTheme(themeInfo)
C#
public void SetSessionTheme(
   ISNet.WebUI.ThemeInfo themeInfo
)

Parameters

themeInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


ShouldReturnJson Method

[image]
Intersoft WebDesktop Documentation
ShouldReturnJson Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : ShouldReturnJson Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ShouldReturnJson() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As Boolean

value = instance.ShouldReturnJson()
C#
public virtual bool ShouldReturnJson()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


SynchronizeTemplatesFrom Method

[image]
Intersoft WebDesktop Documentation
SynchronizeTemplatesFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : SynchronizeTemplatesFrom Method

sourceObj

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SynchronizeTemplatesFrom( _
   ByVal sourceObj As ISNet.WebUI.ISNetControl _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim sourceObj As ISNet.WebUI.ISNetControl

instance.SynchronizeTemplatesFrom(sourceObj)
C#
public void SynchronizeTemplatesFrom(
   ISNet.WebUI.ISNetControl sourceObj
)

Parameters

sourceObj

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


AccessKey Property

[image]
Intersoft WebDesktop Documentation
AccessKey Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : AccessKey Property

Glossary Item Box

Keyboard shortcut used by the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property AccessKey As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As String

instance.AccessKey = value

value = instance.AccessKey
C#
public virtual string AccessKey {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


WebPaneManager Class Properties

[image]
Intersoft WebDesktop Documentation
WebPaneManager Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebPaneManager Class

Glossary Item Box

For a list of all members of this type, see WebPaneManager members.

Public Properties

 | Name | Description
Public Property | AccessKey | Keyboard shortcut used by the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | BackColor | Overridden. Color of the background of the control.
Public Property | BorderColor | Overridden. Color of the border around the control.
Public Property | BorderStyle | Overridden. Style of the border around the control.
Public Property | BorderWidth | Overridden. Width of the border around the control.
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ClientSideEvents | Contains client side events for WebPaneManager.
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Enabled | Enabled state of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableManagedTheming | Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to False, this control will not apply the style defined in Theme Architecture. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | Whether the control automatically saves its state for use in round-trips. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Font | Overridden. The font used for text within the control.
Public Property | ForeColor | Overridden. Color of the text within the control.
Public Property | FrameStyle | Gets or sets the Frame style of the WebPaneManager.
Public Property | Height | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ImagesDirectory | Gets or sets the location of images used to render the WebPaneManager control.
Public Property | ImagesSettings | Contains images settings for WebPaneManager.
Public Property | Padding |
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | PaneSettings | Contains default settings for the WebPaneManager.
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden. Gets or sets the directory where all required scripts for the control are stored.
Public Property | SharedScriptDirectory | Overridden.
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SplitterSettings | Contains default settings for the Splitter.
Public Property | SplitterStyle |
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | TextSettings | Contains text settings used by the control.
Public Property | ToolTip | The tooltip displayed when the mouse is over the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateItems | Gets or sets the items to be stored in view state storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | Gets or sets the server connection string for file server-based viewstate storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | Gets or sets the location to store the viewstate of this control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | Indicates whether the control is visible and rendered. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Width | The width of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | XmlCompressionEnabled | Specifies whether the Xml used for clientside state storage should be compressed. (Inherited from ISNet.WebUI.ISNetControl)
Top

See Also

Reference

WebPaneManager Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Creating Simple Layout
Creating Layout from Predefined Template
Creating Outlook 2003 Style Layout

tasks

Configuring Collapsible Pane

Concepts

WebPaneManager Overview
WebPaneFeatures
Understanding Concepts
Working with ClickAndEdit and Designers
Splitter Integration


WebPaneManager Constructor

[image]
Intersoft WebDesktop Documentation
WebPaneManager Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : WebPaneManager Constructor

Glossary Item Box

Initializes a new instance of the WebPaneManager class.

Overload List

Overload | Description
WebPaneManager Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


BackColor Property

[image]
Intersoft WebDesktop Documentation
BackColor Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : BackColor Property

Glossary Item Box

Color of the background of the control.

Syntax

Visual Basic (Declaration)
Public Overrides Property BackColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
C#
public override System.Drawing.Color BackColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


BorderColor Property

[image]
Intersoft WebDesktop Documentation
BorderColor Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : BorderColor Property

Glossary Item Box

Color of the border around the control.

Syntax

Visual Basic (Declaration)
Public Overrides Property BorderColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As System.Drawing.Color

instance.BorderColor = value

value = instance.BorderColor
C#
public override System.Drawing.Color BorderColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


BorderStyle Property

[image]
Intersoft WebDesktop Documentation
BorderStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : BorderStyle Property

Glossary Item Box

Style of the border around the control.

Syntax

Visual Basic (Declaration)
Public Overrides Property BorderStyle As System.Web.UI.WebControls.BorderStyle
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As System.Web.UI.WebControls.BorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
C#
public override System.Web.UI.WebControls.BorderStyle BorderStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


BorderWidth Property

[image]
Intersoft WebDesktop Documentation
BorderWidth Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : BorderWidth Property

Glossary Item Box

Width of the border around the control.

Syntax

Visual Basic (Declaration)
Public Overrides Property BorderWidth As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As System.Web.UI.WebControls.Unit

instance.BorderWidth = value

value = instance.BorderWidth
C#
public override System.Web.UI.WebControls.Unit BorderWidth {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


ClientIDMode Property

[image]
Intersoft WebDesktop Documentation
ClientIDMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : ClientIDMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ClientIDMode As System.Web.UI.ClientIDMode
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As System.Web.UI.ClientIDMode

instance.ClientIDMode = value

value = instance.ClientIDMode
C#
public virtual System.Web.UI.ClientIDMode ClientIDMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


ClientSideEvents Property

[image]
Intersoft WebDesktop Documentation
ClientSideEvents Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : ClientSideEvents Property

Glossary Item Box

Contains client side events for WebPaneManager.

Syntax

Visual Basic (Declaration)
Public Property ClientSideEvents As WebPaneClientSideEvents
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As WebPaneClientSideEvents

instance.ClientSideEvents = value

value = instance.ClientSideEvents
C#
public WebPaneClientSideEvents ClientSideEvents {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


ControlDataTransferFormat Property

[image]
Intersoft WebDesktop Documentation
ControlDataTransferFormat Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : ControlDataTransferFormat Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ControlDataTransferFormat As ISNet.WebUI.DataTransferFormat
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As ISNet.WebUI.DataTransferFormat

instance.ControlDataTransferFormat = value

value = instance.ControlDataTransferFormat
C#
public virtual ISNet.WebUI.DataTransferFormat ControlDataTransferFormat {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


Enabled Property

[image]
Intersoft WebDesktop Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : Enabled Property

Glossary Item Box

Enabled state of the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property Enabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As Boolean

instance.Enabled = value

value = instance.Enabled
C#
public virtual bool Enabled {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


EnableManagedTheming Property

[image]
Intersoft WebDesktop Documentation
EnableManagedTheming Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : EnableManagedTheming Property

Glossary Item Box

Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to False, this control will not apply the style defined in Theme Architecture.

Syntax

Visual Basic (Declaration)
Public Overridable Property EnableManagedTheming As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As Boolean

instance.EnableManagedTheming = value

value = instance.EnableManagedTheming
C#
public virtual bool EnableManagedTheming {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


EnableTheming Property

[image]
Intersoft WebDesktop Documentation
EnableTheming Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : EnableTheming Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property EnableTheming As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As Boolean

instance.EnableTheming = value

value = instance.EnableTheming
C#
public virtual bool EnableTheming {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


EnableViewState Property

[image]
Intersoft WebDesktop Documentation
EnableViewState Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : EnableViewState Property

Glossary Item Box

Whether the control automatically saves its state for use in round-trips.

Syntax

Visual Basic (Declaration)
Public Overridable Property EnableViewState As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As Boolean

instance.EnableViewState = value

value = instance.EnableViewState
C#
public virtual bool EnableViewState {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


EnableWebResources Property

[image]
Intersoft WebDesktop Documentation
EnableWebResources Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : EnableWebResources Property

Glossary Item Box

Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory).

Syntax

Visual Basic (Declaration)
Public Property EnableWebResources As ISNet.WebUI.WebResourceType
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As ISNet.WebUI.WebResourceType

instance.EnableWebResources = value

value = instance.EnableWebResources
C#
public ISNet.WebUI.WebResourceType EnableWebResources {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


Font Property

[image]
Intersoft WebDesktop Documentation
Font Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : Font Property

Glossary Item Box

The font used for text within the control.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Font As System.Web.UI.WebControls.FontInfo
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As System.Web.UI.WebControls.FontInfo

value = instance.Font
C#
public override System.Web.UI.WebControls.FontInfo Font {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


ForeColor Property

[image]
Intersoft WebDesktop Documentation
ForeColor Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : ForeColor Property

Glossary Item Box

Color of the text within the control.

Syntax

Visual Basic (Declaration)
Public Overrides Property ForeColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
C#
public override System.Drawing.Color ForeColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


FrameStyle Property

[image]
Intersoft WebDesktop Documentation
FrameStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : FrameStyle Property

Glossary Item Box

Gets or sets the Frame style of the WebPaneManager.

Syntax

Visual Basic (Declaration)
Public Property FrameStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As ISNet.WebUI.WebStyle

instance.FrameStyle = value

value = instance.FrameStyle
C#
public ISNet.WebUI.WebStyle FrameStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


Height Property

[image]
Intersoft WebDesktop Documentation
Height Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : Height Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Height As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As System.Web.UI.WebControls.Unit

instance.Height = value

value = instance.Height
C#
public virtual System.Web.UI.WebControls.Unit Height {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


ID Property

[image]
Intersoft WebDesktop Documentation
ID Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : ID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ID As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As String

instance.ID = value

value = instance.ID
C#
public virtual string ID {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


ImagesDirectory Property

[image]
Intersoft WebDesktop Documentation
ImagesDirectory Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : ImagesDirectory Property

Glossary Item Box

Gets or sets the location of images used to render the WebPaneManager control.

Syntax

Visual Basic (Declaration)
Public Property ImagesDirectory As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As String

instance.ImagesDirectory = value

value = instance.ImagesDirectory
C#
public string ImagesDirectory {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


ImagesSettings Property

[image]
Intersoft WebDesktop Documentation
ImagesSettings Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : ImagesSettings Property

Glossary Item Box

Contains images settings for WebPaneManager.

Syntax

Visual Basic (Declaration)
Public Property ImagesSettings As WebPaneImagesSettings
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As WebPaneImagesSettings

instance.ImagesSettings = value

value = instance.ImagesSettings
C#
public WebPaneImagesSettings ImagesSettings {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


Padding Property

[image]
Intersoft WebDesktop Documentation
Padding Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : Padding Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Padding As ISNet.WebUI.Padding
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As ISNet.WebUI.Padding

value = instance.Padding
C#
public ISNet.WebUI.Padding Padding {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


Page Property

[image]
Intersoft WebDesktop Documentation
Page Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : Page Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Page As System.Web.UI.Page
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As System.Web.UI.Page

instance.Page = value

value = instance.Page
C#
public virtual System.Web.UI.Page Page {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


PaneSettings Property

[image]
Intersoft WebDesktop Documentation
PaneSettings Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : PaneSettings Property

Glossary Item Box

Contains default settings for the WebPaneManager.

Syntax

Visual Basic (Declaration)
Public Property PaneSettings As WebPaneSettings
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As WebPaneSettings

instance.PaneSettings = value

value = instance.PaneSettings
C#
public WebPaneSettings PaneSettings {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


RenderingMode Property

[image]
Intersoft WebDesktop Documentation
RenderingMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : RenderingMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property RenderingMode As ISNet.WebUI.RenderMode
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As ISNet.WebUI.RenderMode

instance.RenderingMode = value

value = instance.RenderingMode
C#
public virtual ISNet.WebUI.RenderMode RenderingMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


RuntimeLicenseKey Property

[image]
Intersoft WebDesktop Documentation
RuntimeLicenseKey Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : RuntimeLicenseKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property RuntimeLicenseKey As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As String

instance.RuntimeLicenseKey = value

value = instance.RuntimeLicenseKey
C#
public virtual string RuntimeLicenseKey {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


ScriptDirectory Property

[image]
Intersoft WebDesktop Documentation
ScriptDirectory Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : ScriptDirectory Property

Glossary Item Box

Gets or sets the directory where all required scripts for the control are stored.

Syntax

Visual Basic (Declaration)
Public Overrides Property ScriptDirectory As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As String

instance.ScriptDirectory = value

value = instance.ScriptDirectory
C#
public override string ScriptDirectory {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


SharedScriptDirectory Property

[image]
Intersoft WebDesktop Documentation
SharedScriptDirectory Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : SharedScriptDirectory Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Property SharedScriptDirectory As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As String

instance.SharedScriptDirectory = value

value = instance.SharedScriptDirectory
C#
public override string SharedScriptDirectory {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


SkinID Property

[image]
Intersoft WebDesktop Documentation
SkinID Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : SkinID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property SkinID As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As String

instance.SkinID = value

value = instance.SkinID
C#
public virtual string SkinID {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


SplitterSettings Property

[image]
Intersoft WebDesktop Documentation
SplitterSettings Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : SplitterSettings Property

Glossary Item Box

Contains default settings for the Splitter.

Syntax

Visual Basic (Declaration)
Public Property SplitterSettings As WebPaneSplitterSettings
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As WebPaneSplitterSettings

instance.SplitterSettings = value

value = instance.SplitterSettings
C#
public WebPaneSplitterSettings SplitterSettings {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


SplitterStyle Property

[image]
Intersoft WebDesktop Documentation
SplitterStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : SplitterStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property SplitterStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As ISNet.WebUI.DynamicStyle

instance.SplitterStyle = value

value = instance.SplitterStyle
C#
public ISNet.WebUI.DynamicStyle SplitterStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


TabIndex Property

[image]
Intersoft WebDesktop Documentation
TabIndex Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : TabIndex Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property TabIndex As Short
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As Short

instance.TabIndex = value

value = instance.TabIndex
C#
public virtual short TabIndex {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


TextSettings Property

[image]
Intersoft WebDesktop Documentation
TextSettings Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : TextSettings Property

Glossary Item Box

Contains text settings used by the control.

Syntax

Visual Basic (Declaration)
Public Property TextSettings As WebPaneTextSettings
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As WebPaneTextSettings

instance.TextSettings = value

value = instance.TextSettings
C#
public WebPaneTextSettings TextSettings {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


ToolTip Property

[image]
Intersoft WebDesktop Documentation
ToolTip Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : ToolTip Property

Glossary Item Box

The tooltip displayed when the mouse is over the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property ToolTip As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As String

instance.ToolTip = value

value = instance.ToolTip
C#
public virtual string ToolTip {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


ValidateRequestMode Property

[image]
Intersoft WebDesktop Documentation
ValidateRequestMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : ValidateRequestMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ValidateRequestMode As System.Web.UI.ValidateRequestMode
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As System.Web.UI.ValidateRequestMode

instance.ValidateRequestMode = value

value = instance.ValidateRequestMode
C#
public virtual System.Web.UI.ValidateRequestMode ValidateRequestMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


ViewStateItems Property

[image]
Intersoft WebDesktop Documentation
ViewStateItems Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : ViewStateItems Property

Glossary Item Box

Gets or sets the items to be stored in view state storage.

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateItems As ISNet.WebUI.ViewStateItem
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As ISNet.WebUI.ViewStateItem

instance.ViewStateItems = value

value = instance.ViewStateItems
C#
public virtual ISNet.WebUI.ViewStateItem ViewStateItems {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


ViewStateMode Property

[image]
Intersoft WebDesktop Documentation
ViewStateMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : ViewStateMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateMode As System.Web.UI.ViewStateMode
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As System.Web.UI.ViewStateMode

instance.ViewStateMode = value

value = instance.ViewStateMode
C#
public virtual System.Web.UI.ViewStateMode ViewStateMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


ViewStateServerConnection Property

[image]
Intersoft WebDesktop Documentation
ViewStateServerConnection Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : ViewStateServerConnection Property

Glossary Item Box

Gets or sets the server connection string for file server-based viewstate storage.

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateServerConnection As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As String

instance.ViewStateServerConnection = value

value = instance.ViewStateServerConnection
C#
public virtual string ViewStateServerConnection {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


ViewStateStorage Property

[image]
Intersoft WebDesktop Documentation
ViewStateStorage Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : ViewStateStorage Property

Glossary Item Box

Gets or sets the location to store the viewstate of this control.

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateStorage As ISNet.WebUI.StateCacheStorage
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As ISNet.WebUI.StateCacheStorage

instance.ViewStateStorage = value

value = instance.ViewStateStorage
C#
public virtual ISNet.WebUI.StateCacheStorage ViewStateStorage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


Visible Property

[image]
Intersoft WebDesktop Documentation
Visible Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : Visible Property

Glossary Item Box

Indicates whether the control is visible and rendered.

Syntax

Visual Basic (Declaration)
Public Overridable Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public virtual bool Visible {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


Width Property

[image]
Intersoft WebDesktop Documentation
Width Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : Width Property

Glossary Item Box

The width of the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property Width As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As System.Web.UI.WebControls.Unit

instance.Width = value

value = instance.Width
C#
public virtual System.Web.UI.WebControls.Unit Width {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


XmlCompressionEnabled Property

[image]
Intersoft WebDesktop Documentation
XmlCompressionEnabled Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : XmlCompressionEnabled Property

Glossary Item Box

Specifies whether the Xml used for clientside state storage should be compressed.

Syntax

Visual Basic (Declaration)
Public Overridable Property XmlCompressionEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim value As Boolean

instance.XmlCompressionEnabled = value

value = instance.XmlCompressionEnabled
C#
public virtual bool XmlCompressionEnabled {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


DataBinding Event

[image]
Intersoft WebDesktop Documentation
DataBinding Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : DataBinding Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event DataBinding As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim handler As EventHandler

AddHandler instance.DataBinding, handler
C#
public event EventHandler DataBinding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


Disposed Event

[image]
Intersoft WebDesktop Documentation
Disposed Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim handler As EventHandler

AddHandler instance.Disposed, handler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


Init Event

[image]
Intersoft WebDesktop Documentation
Init Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : Init Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Init As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim handler As EventHandler

AddHandler instance.Init, handler
C#
public event EventHandler Init

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


Load Event

[image]
Intersoft WebDesktop Documentation
Load Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : Load Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Load As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim handler As EventHandler

AddHandler instance.Load, handler
C#
public event EventHandler Load

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


PreInitialize Event

[image]
Intersoft WebDesktop Documentation
PreInitialize Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : PreInitialize Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event PreInitialize As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim handler As EventHandler

AddHandler instance.PreInitialize, handler
C#
public event EventHandler PreInitialize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


PreRender Event

[image]
Intersoft WebDesktop Documentation
PreRender Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : PreRender Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event PreRender As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim handler As EventHandler

AddHandler instance.PreRender, handler
C#
public event EventHandler PreRender

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


Unload Event

[image]
Intersoft WebDesktop Documentation
Unload Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneManager Class : Unload Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Unload As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebPaneManager
Dim handler As EventHandler

AddHandler instance.Unload, handler
C#
public event EventHandler Unload

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneManager Class
WebPaneManager Members


WebPaneSettings Class

[image]
Intersoft WebDesktop Documentation
WebPaneSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebPaneSettings Class

Glossary Item Box

A collection of default settings for WebPaneManager.

Object Model

WebPaneSettings Class

Syntax

Visual Basic (Declaration)
Public Class WebPaneSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebPaneSettings
C#
public class WebPaneSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Remarks

WebPaneSettings has ability to inherit properties set at parent level. You can set the WebPaneSettings property of WebPaneManager which will automatically inherit all Panes' settings contained in WebPaneManager.

The AllowResize and AllowCollapse features in WebPaneSettings allow you to integrate WebPane and WebSplitter. The two features provide sophisticated resizing and collapsing functionalities.

The default value of AllowResize in Global level is True. When users set this feature to True, they can resize the Pane conveniently in runtime. This feature can be configured in Global level and Individual Pane level.

The default value of AllowCollapse in Global level is False. The best recommendation for enabling this feature is by configuring the AllowCollapse in Individual Pane level so that you can have more control over which direction should the Pane collapsed to.

For better understanding of WebPaneManager and WebSplitter integration please read Splitter Integration.

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebDesktop.WebPaneSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneSettings Members
ISNet.WebUI.WebDesktop Namespace

Concepts

WebPane Features

concepts

Splitter Integration


WebPaneSettings Class Members

[image]
Intersoft WebDesktop Documentation
WebPaneSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebPaneSettings Class

Glossary Item Box

The following tables list the members exposed by WebPaneSettings.

Public Constructors

 | Name | Description
Public Constructor | WebPaneSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | AllowCollapse | Indicates whether users are allowed to collapsed Panes through splitter.
Public Property | AllowResize | Determines whether panes are resizable.
Public Property | CaptionDisplayMode | Gets or sets the mode of the caption display.
Public Property | ContainerStyle | Gets or sets the style applied to the Content part of the Pane.
Public Property | ContentMode | Gets or sets the content mode of the WebPaneManager control.
Public Property | GroupPaneHeaderVisible | Determines whether the GroupPane's Header part should be rendered.
Public Property | HeaderAppearance | Gets or sets the default predefined style applied to Header part.
Public Property | HeaderCustomStyle | Gets or sets the style applied to the Header part of the Pane when the HeaderAppearance is set to Custom.
Public Property | HeaderMainStyle | Gets or sets the style applied to the Header part of the Pane when the HeaderAppearance is set to Main.
Public Property | HeaderSubStyle | Gets or sets the style applied to the Header part of the Pane when the HeaderAppearance is set to Sub.
Public Property | HeaderVisible | Determines whether the header part should be rendered.
Public Property | IFrameAllowTransparency | Specifies whether the IFRAME should allow transparency. This property is applicable when ContentMode is set to UseIFrame.
Public Property | IFrameShowLoader | Specifies whether to show loader text when the active IFrame is in loading progress. This property only applicables when ContentMode is set to UseIFrame.
Public Property | ImageAlignment | Gets or sets the alignment of the image. The image alignment is relative to the caption text.
Public Property | InfoTextAlignment | Gets or sets the alignment of the InfoText relative to its placeholder.
Public Property | InfoTextPosition | Gets or sets the position of the InfoText part.
Public Property | InfoTextStyle | Gets or sets the style applied to the InfoText part (inside the Header) of the Pane.
Public Property | PaneSpacing | Specifies the spacing between each Pane in pixel.
Public Property | ScrollBarStyle | Gets or sets the scrollbar style for WebPane.
Public Property | TextAlignment | Gets or sets the alignment of the text.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebPaneSettings Class
ISNet.WebUI.WebDesktop Namespace

Concepts

WebPane Features

concepts

Splitter Integration


WebPaneSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebPaneSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneSettings Class : WebPaneSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebPaneSettings()
C#
public WebPaneSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneSettings Class
WebPaneSettings Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebPaneSettings
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneSettings Class
WebPaneSettings Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneSettings Class
WebPaneSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneSettings
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneSettings Class
WebPaneSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneSettings
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneSettings Class
WebPaneSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneSettings Class
WebPaneSettings Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebPaneSettings
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneSettings Class
WebPaneSettings Members


WebPaneSettings Class Methods

[image]
Intersoft WebDesktop Documentation
WebPaneSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebPaneSettings Class

Glossary Item Box

For a list of all members of this type, see WebPaneSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebPaneSettings Class
ISNet.WebUI.WebDesktop Namespace

Concepts

WebPane Features

concepts

Splitter Integration


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneSettings Class
WebPaneSettings Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebPaneSettings
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneSettings Class
WebPaneSettings Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebPaneSettings

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneSettings Class
WebPaneSettings Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneSettings Class
WebPaneSettings Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneSettings
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneSettings Class
WebPaneSettings Members


WebPaneSettings Class Properties

[image]
Intersoft WebDesktop Documentation
WebPaneSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebPaneSettings Class

Glossary Item Box

For a list of all members of this type, see WebPaneSettings members.

Public Properties

 | Name | Description
Public Property | AllowCollapse | Indicates whether users are allowed to collapsed Panes through splitter.
Public Property | AllowResize | Determines whether panes are resizable.
Public Property | CaptionDisplayMode | Gets or sets the mode of the caption display.
Public Property | ContainerStyle | Gets or sets the style applied to the Content part of the Pane.
Public Property | ContentMode | Gets or sets the content mode of the WebPaneManager control.
Public Property | GroupPaneHeaderVisible | Determines whether the GroupPane's Header part should be rendered.
Public Property | HeaderAppearance | Gets or sets the default predefined style applied to Header part.
Public Property | HeaderCustomStyle | Gets or sets the style applied to the Header part of the Pane when the HeaderAppearance is set to Custom.
Public Property | HeaderMainStyle | Gets or sets the style applied to the Header part of the Pane when the HeaderAppearance is set to Main.
Public Property | HeaderSubStyle | Gets or sets the style applied to the Header part of the Pane when the HeaderAppearance is set to Sub.
Public Property | HeaderVisible | Determines whether the header part should be rendered.
Public Property | IFrameAllowTransparency | Specifies whether the IFRAME should allow transparency. This property is applicable when ContentMode is set to UseIFrame.
Public Property | IFrameShowLoader | Specifies whether to show loader text when the active IFrame is in loading progress. This property only applicables when ContentMode is set to UseIFrame.
Public Property | ImageAlignment | Gets or sets the alignment of the image. The image alignment is relative to the caption text.
Public Property | InfoTextAlignment | Gets or sets the alignment of the InfoText relative to its placeholder.
Public Property | InfoTextPosition | Gets or sets the position of the InfoText part.
Public Property | InfoTextStyle | Gets or sets the style applied to the InfoText part (inside the Header) of the Pane.
Public Property | PaneSpacing | Specifies the spacing between each Pane in pixel.
Public Property | ScrollBarStyle | Gets or sets the scrollbar style for WebPane.
Public Property | TextAlignment | Gets or sets the alignment of the text.
Top

See Also

Reference

WebPaneSettings Class
ISNet.WebUI.WebDesktop Namespace

Concepts

WebPane Features

concepts

Splitter Integration


WebPaneSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebPaneSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneSettings Class : WebPaneSettings Constructor

Glossary Item Box

Initializes a new instance of the WebPaneSettings class.

Overload List

Overload | Description
WebPaneSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneSettings Class
WebPaneSettings Members


AllowCollapse Property

[image]
Intersoft WebDesktop Documentation
AllowCollapse Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneSettings Class : AllowCollapse Property

Glossary Item Box

Indicates whether users are allowed to collapsed Panes through splitter.

Syntax

Visual Basic (Declaration)
Public Property AllowCollapse As AllowCollapse
Visual Basic (Usage) Copy Code
Dim instance As WebPaneSettings
Dim value As AllowCollapse

instance.AllowCollapse = value

value = instance.AllowCollapse
C#
public AllowCollapse AllowCollapse {get; set;}

Remarks

AllowCollapse allows users to collapse a Pane into specified direction. With this property you can easily let your users to maximize the layout to use available screen real estate which dramatically enhance the user experience resulting in greater productivity.

To learn more please read Splitter Integration.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneSettings Class
WebPaneSettings Members

Tasks

Configuring Collapsible Pane

Concepts

WebPane Features

concepts

Splitter Integration


AllowResize Property

[image]
Intersoft WebDesktop Documentation
AllowResize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneSettings Class : AllowResize Property

Glossary Item Box

Determines whether panes are resizable.

Syntax

Visual Basic (Declaration)
Public Property AllowResize As AllowResize
Visual Basic (Usage) Copy Code
Dim instance As WebPaneSettings
Dim value As AllowResize

instance.AllowResize = value

value = instance.AllowResize
C#
public AllowResize AllowResize {get; set;}

Remarks

AllowResize allows users to resize the dimension of Pane at runtime. The resizing works in conjunction with TrueFill architecture which intelligently determines the target size and convert the value back to the original unit type. When a Pane is resized, it will resize the other pair of the Pane and extend its dimension properly. The resizing however, will not affect other Panes or other Group's dimension.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneSettings Class
WebPaneSettings Members

Tasks

Disabling Resizing for specific Pane

Concepts

WebPane Features


CaptionDisplayMode Property

[image]
Intersoft WebDesktop Documentation
CaptionDisplayMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneSettings Class : CaptionDisplayMode Property

Glossary Item Box

Gets or sets the mode of the caption display.

Syntax

Visual Basic (Declaration)
Public Property CaptionDisplayMode As DisplayMode
Visual Basic (Usage) Copy Code
Dim instance As WebPaneSettings
Dim value As DisplayMode

instance.CaptionDisplayMode = value

value = instance.CaptionDisplayMode
C#
public DisplayMode CaptionDisplayMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneSettings Class
WebPaneSettings Members


ContainerStyle Property

[image]
Intersoft WebDesktop Documentation
ContainerStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneSettings Class : ContainerStyle Property

Glossary Item Box

Gets or sets the style applied to the Content part of the Pane.

Syntax

Visual Basic (Declaration)
Public Property ContainerStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebPaneSettings
Dim value As ISNet.WebUI.WebStyle

instance.ContainerStyle = value

value = instance.ContainerStyle
C#
public ISNet.WebUI.WebStyle ContainerStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneSettings Class
WebPaneSettings Members


ContentMode Property

[image]
Intersoft WebDesktop Documentation
ContentMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneSettings Class : ContentMode Property

Glossary Item Box

Gets or sets the content mode of the WebPaneManager control.

Syntax

Visual Basic (Declaration)
Public Property ContentMode As ContentMode
Visual Basic (Usage) Copy Code
Dim instance As WebPaneSettings
Dim value As ContentMode

instance.ContentMode = value

value = instance.ContentMode
C#
public ContentMode ContentMode {get; set;}

Remarks

By default, the WebPaneManager will operate in UseInlineContent mode when a new instance is dropped to designer surface. UseInlineContent is the most suitable when the contents inside each tab page are relatively small. You can also determine the "content load" by inspecting the performance during page load as well as the size of the output. UseInlineContent mode utilized .NET Framework's Templating archictecture and therefore all contents are loaded at once in first load (although the inactive pages are set to hidden).

In most cases where you want to develop a more reusable form, you should use UseIFrame for the content mode. When using IFrame mode, you would need to specify the ContentURL which page you want to load for the designated Tab item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneSettings Class
WebPaneSettings Members

Concepts

WebPane Features

Tasks

Using IFrame as ContentMode


GroupPaneHeaderVisible Property

[image]
Intersoft WebDesktop Documentation
GroupPaneHeaderVisible Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneSettings Class : GroupPaneHeaderVisible Property

Glossary Item Box

Determines whether the GroupPane's Header part should be rendered.

Syntax

Visual Basic (Declaration)
Public Property GroupPaneHeaderVisible As Visibility
Visual Basic (Usage) Copy Code
Dim instance As WebPaneSettings
Dim value As Visibility

instance.GroupPaneHeaderVisible = value

value = instance.GroupPaneHeaderVisible
C#
public Visibility GroupPaneHeaderVisible {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneSettings Class
WebPaneSettings Members


HeaderAppearance Property

[image]
Intersoft WebDesktop Documentation
HeaderAppearance Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneSettings Class : HeaderAppearance Property

Glossary Item Box

Gets or sets the default predefined style applied to Header part.

Syntax

Visual Basic (Declaration)
Public Property HeaderAppearance As HeaderAppearanceMode
Visual Basic (Usage) Copy Code
Dim instance As WebPaneSettings
Dim value As HeaderAppearanceMode

instance.HeaderAppearance = value

value = instance.HeaderAppearance
C#
public HeaderAppearanceMode HeaderAppearance {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneSettings Class
WebPaneSettings Members

Concepts

WebPane Features


HeaderCustomStyle Property

[image]
Intersoft WebDesktop Documentation
HeaderCustomStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneSettings Class : HeaderCustomStyle Property

Glossary Item Box

Gets or sets the style applied to the Header part of the Pane when the HeaderAppearance is set to Custom.

Syntax

Visual Basic (Declaration)
Public Property HeaderCustomStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebPaneSettings
Dim value As ISNet.WebUI.WebStyle

instance.HeaderCustomStyle = value

value = instance.HeaderCustomStyle
C#
public ISNet.WebUI.WebStyle HeaderCustomStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneSettings Class
WebPaneSettings Members


HeaderMainStyle Property

[image]
Intersoft WebDesktop Documentation
HeaderMainStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneSettings Class : HeaderMainStyle Property

Glossary Item Box

Gets or sets the style applied to the Header part of the Pane when the HeaderAppearance is set to Main.

Syntax

Visual Basic (Declaration)
Public Property HeaderMainStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebPaneSettings
Dim value As ISNet.WebUI.WebStyle

instance.HeaderMainStyle = value

value = instance.HeaderMainStyle
C#
public ISNet.WebUI.WebStyle HeaderMainStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneSettings Class
WebPaneSettings Members

Concepts

WebPane Features


HeaderSubStyle Property

[image]
Intersoft WebDesktop Documentation
HeaderSubStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneSettings Class : HeaderSubStyle Property

Glossary Item Box

Gets or sets the style applied to the Header part of the Pane when the HeaderAppearance is set to Sub.

Syntax

Visual Basic (Declaration)
Public Property HeaderSubStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebPaneSettings
Dim value As ISNet.WebUI.WebStyle

instance.HeaderSubStyle = value

value = instance.HeaderSubStyle
C#
public ISNet.WebUI.WebStyle HeaderSubStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneSettings Class
WebPaneSettings Members

Concepts

WebPane Features


HeaderVisible Property

[image]
Intersoft WebDesktop Documentation
HeaderVisible Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneSettings Class : HeaderVisible Property

Glossary Item Box

Determines whether the header part should be rendered.

Syntax

Visual Basic (Declaration)
Public Property HeaderVisible As Visibility
Visual Basic (Usage) Copy Code
Dim instance As WebPaneSettings
Dim value As Visibility

instance.HeaderVisible = value

value = instance.HeaderVisible
C#
public Visibility HeaderVisible {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneSettings Class
WebPaneSettings Members


IFrameAllowTransparency Property

[image]
Intersoft WebDesktop Documentation
IFrameAllowTransparency Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneSettings Class : IFrameAllowTransparency Property

Glossary Item Box

Specifies whether the IFRAME should allow transparency. This property is applicable when ContentMode is set to UseIFrame.

Syntax

Visual Basic (Declaration)
Public Property IFrameAllowTransparency As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebPaneSettings
Dim value As Boolean

instance.IFrameAllowTransparency = value

value = instance.IFrameAllowTransparency
C#
public bool IFrameAllowTransparency {get; set;}

Remarks

The default value of this property is True. When set to True, the IFrame will show the background color specified in ContainerStyle instead of the background color in the page specified in ContentURL. This feature will produce better consistency of the user interface and appearance, without having to configure background color of each webform.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneSettings Class
WebPaneSettings Members

Concepts

WebPane Features


IFrameShowLoader Property

[image]
Intersoft WebDesktop Documentation
IFrameShowLoader Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneSettings Class : IFrameShowLoader Property

Glossary Item Box

Specifies whether to show loader text when the active IFrame is in loading progress. This property only applicables when ContentMode is set to UseIFrame.

Syntax

Visual Basic (Declaration)
Public Property IFrameShowLoader As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebPaneSettings
Dim value As Boolean

instance.IFrameShowLoader = value

value = instance.IFrameShowLoader
C#
public bool IFrameShowLoader {get; set;}

Remarks

The default value of this property is True. When set to True, the WebPaneManager will display an animated image and text indicating that the Page is currently in loading progress. This feature is helpful when loading a relatively large page and still keep informing the user of the loading progress.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneSettings Class
WebPaneSettings Members

Concepts

WebPane Features


ImageAlignment Property

[image]
Intersoft WebDesktop Documentation
ImageAlignment Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneSettings Class : ImageAlignment Property

Glossary Item Box

Gets or sets the alignment of the image. The image alignment is relative to the caption text.

Syntax

Visual Basic (Declaration)
Public Property ImageAlignment As DisplayAlignment
Visual Basic (Usage) Copy Code
Dim instance As WebPaneSettings
Dim value As DisplayAlignment

instance.ImageAlignment = value

value = instance.ImageAlignment
C#
public DisplayAlignment ImageAlignment {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneSettings Class
WebPaneSettings Members


InfoTextAlignment Property

[image]
Intersoft WebDesktop Documentation
InfoTextAlignment Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneSettings Class : InfoTextAlignment Property

Glossary Item Box

Gets or sets the alignment of the InfoText relative to its placeholder.

Syntax

Visual Basic (Declaration)
Public Property InfoTextAlignment As TextAlignment
Visual Basic (Usage) Copy Code
Dim instance As WebPaneSettings
Dim value As TextAlignment

instance.InfoTextAlignment = value

value = instance.InfoTextAlignment
C#
public TextAlignment InfoTextAlignment {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneSettings Class
WebPaneSettings Members


InfoTextPosition Property

[image]
Intersoft WebDesktop Documentation
InfoTextPosition Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneSettings Class : InfoTextPosition Property

Glossary Item Box

Gets or sets the position of the InfoText part.

Syntax

Visual Basic (Declaration)
Public Property InfoTextPosition As InfoTextPosition
Visual Basic (Usage) Copy Code
Dim instance As WebPaneSettings
Dim value As InfoTextPosition

instance.InfoTextPosition = value

value = instance.InfoTextPosition
C#
public InfoTextPosition InfoTextPosition {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneSettings Class
WebPaneSettings Members


InfoTextStyle Property

[image]
Intersoft WebDesktop Documentation
InfoTextStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneSettings Class : InfoTextStyle Property

Glossary Item Box

Gets or sets the style applied to the InfoText part (inside the Header) of the Pane.

Syntax

Visual Basic (Declaration)
Public Property InfoTextStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebPaneSettings
Dim value As ISNet.WebUI.WebStyle

instance.InfoTextStyle = value

value = instance.InfoTextStyle
C#
public ISNet.WebUI.WebStyle InfoTextStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneSettings Class
WebPaneSettings Members


PaneSpacing Property

[image]
Intersoft WebDesktop Documentation
PaneSpacing Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneSettings Class : PaneSpacing Property

Glossary Item Box

Specifies the spacing between each Pane in pixel.

Syntax

Visual Basic (Declaration)
Public Property PaneSpacing As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebPaneSettings
Dim value As Integer

instance.PaneSpacing = value

value = instance.PaneSpacing
C#
public int PaneSpacing {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneSettings Class
WebPaneSettings Members


ScrollBarStyle Property

[image]
Intersoft WebDesktop Documentation
ScrollBarStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneSettings Class : ScrollBarStyle Property

Glossary Item Box

Gets or sets the scrollbar style for WebPane.

Syntax

Visual Basic (Declaration)
Public Property ScrollBarStyle As WebScrollBarStyle
Visual Basic (Usage) Copy Code
Dim instance As WebPaneSettings
Dim value As WebScrollBarStyle

instance.ScrollBarStyle = value

value = instance.ScrollBarStyle
C#
public WebScrollBarStyle ScrollBarStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneSettings Class
WebPaneSettings Members


TextAlignment Property

[image]
Intersoft WebDesktop Documentation
TextAlignment Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneSettings Class : TextAlignment Property

Glossary Item Box

Gets or sets the alignment of the text.

Syntax

Visual Basic (Declaration)
Public Property TextAlignment As TextAlignment
Visual Basic (Usage) Copy Code
Dim instance As WebPaneSettings
Dim value As TextAlignment

instance.TextAlignment = value

value = instance.TextAlignment
C#
public TextAlignment TextAlignment {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneSettings Class
WebPaneSettings Members


WebPaneSplitterSettings Class

[image]
Intersoft WebDesktop Documentation
WebPaneSplitterSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebPaneSplitterSettings Class

Glossary Item Box

A collection of default settings for the integration of WebPaneManager and WebSplitter.

Object Model

WebPaneSplitterSettings Class

Syntax

Visual Basic (Declaration)
Public Class WebPaneSplitterSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebPaneSplitterSettings
C#
public class WebPaneSplitterSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Remarks

The two most useful features in WebPaneManager - AllowCollapse and AllowResize - allow users to integrate WebPaneManager and WebSplitter. AllowCollapse adds the capability for users to collapse a Pane into specified direction. On the other hand, AllowResize allows users to resize the dimension of Pane at runtime. For further information you can read Splitter Integration.

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebDesktop.WebPaneSplitterSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneSplitterSettings Members
ISNet.WebUI.WebDesktop Namespace

Concepts

WebPaneManager Features

concepts

Splitter Integration


WebPaneSplitterSettings Class Members

[image]
Intersoft WebDesktop Documentation
WebPaneSplitterSettings Class Members
See Also Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebPaneSplitterSettings Class

Glossary Item Box

The following tables list the members exposed by WebPaneSplitterSettings.

Public Constructors

 | Name | Description
Public Constructor | WebPaneSplitterSettings Constructor |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebPaneSplitterSettings Class
ISNet.WebUI.WebDesktop Namespace

Concepts

WebPaneManager Features

concepts

Splitter Integration


WebPaneSplitterSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebPaneSplitterSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneSplitterSettings Class : WebPaneSplitterSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebPaneSplitterSettings()
C#
public WebPaneSplitterSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneSplitterSettings Class
WebPaneSplitterSettings Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneSplitterSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebPaneSplitterSettings
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneSplitterSettings Class
WebPaneSplitterSettings Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneSplitterSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneSplitterSettings Class
WebPaneSplitterSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneSplitterSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneSplitterSettings
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneSplitterSettings Class
WebPaneSplitterSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneSplitterSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneSplitterSettings
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneSplitterSettings Class
WebPaneSplitterSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneSplitterSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneSplitterSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneSplitterSettings Class
WebPaneSplitterSettings Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneSplitterSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebPaneSplitterSettings
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneSplitterSettings Class
WebPaneSplitterSettings Members


WebPaneSplitterSettings Class Methods

[image]
Intersoft WebDesktop Documentation
WebPaneSplitterSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebPaneSplitterSettings Class

Glossary Item Box

For a list of all members of this type, see WebPaneSplitterSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebPaneSplitterSettings Class
ISNet.WebUI.WebDesktop Namespace

Concepts

WebPaneManager Features

concepts

Splitter Integration


WebPaneSplitterSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebPaneSplitterSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneSplitterSettings Class : WebPaneSplitterSettings Constructor

Glossary Item Box

Initializes a new instance of the WebPaneSplitterSettings class.

Overload List

Overload | Description
WebPaneSplitterSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneSplitterSettings Class
WebPaneSplitterSettings Members


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneSplitterSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneSplitterSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneSplitterSettings Class
WebPaneSplitterSettings Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneSplitterSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebPaneSplitterSettings
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneSplitterSettings Class
WebPaneSplitterSettings Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneSplitterSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebPaneSplitterSettings

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneSplitterSettings Class
WebPaneSplitterSettings Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneSplitterSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneSplitterSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneSplitterSettings Class
WebPaneSplitterSettings Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneSplitterSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneSplitterSettings
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneSplitterSettings Class
WebPaneSplitterSettings Members


WebPaneTextSettings Class

[image]
Intersoft WebDesktop Documentation
WebPaneTextSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebPaneTextSettings Class

Glossary Item Box

Contains text settings used by the control.

Object Model

WebPaneTextSettings Class

Syntax

Visual Basic (Declaration)
Public Class WebPaneTextSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebPaneTextSettings
C#
public class WebPaneTextSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Example

Using WebPaneTextSettings you can customize the text displayed when an IFrame is in loading progress.

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebDesktop.WebPaneTextSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneTextSettings Members
ISNet.WebUI.WebDesktop Namespace


WebPaneTextSettings Class Members

[image]
Intersoft WebDesktop Documentation
WebPaneTextSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebPaneTextSettings Class

Glossary Item Box

The following tables list the members exposed by WebPaneTextSettings.

Public Constructors

 | Name | Description
Public Constructor | WebPaneTextSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | InProgressText | Gets or sets the text which will be displayed when an IFrame is in loading progress.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebPaneTextSettings Class
ISNet.WebUI.WebDesktop Namespace


WebPaneTextSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebPaneTextSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneTextSettings Class : WebPaneTextSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebPaneTextSettings()
C#
public WebPaneTextSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneTextSettings Class
WebPaneTextSettings Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneTextSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebPaneTextSettings
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneTextSettings Class
WebPaneTextSettings Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneTextSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneTextSettings Class
WebPaneTextSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneTextSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneTextSettings
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneTextSettings Class
WebPaneTextSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneTextSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneTextSettings
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneTextSettings Class
WebPaneTextSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneTextSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneTextSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneTextSettings Class
WebPaneTextSettings Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneTextSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebPaneTextSettings
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneTextSettings Class
WebPaneTextSettings Members


WebPaneTextSettings Class Methods

[image]
Intersoft WebDesktop Documentation
WebPaneTextSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebPaneTextSettings Class

Glossary Item Box

For a list of all members of this type, see WebPaneTextSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebPaneTextSettings Class
ISNet.WebUI.WebDesktop Namespace


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneTextSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneTextSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneTextSettings Class
WebPaneTextSettings Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneTextSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebPaneTextSettings
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneTextSettings Class
WebPaneTextSettings Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneTextSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebPaneTextSettings

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneTextSettings Class
WebPaneTextSettings Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneTextSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebPaneTextSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneTextSettings Class
WebPaneTextSettings Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneTextSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneTextSettings
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneTextSettings Class
WebPaneTextSettings Members


WebPaneTextSettings Class Properties

[image]
Intersoft WebDesktop Documentation
WebPaneTextSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebPaneTextSettings Class

Glossary Item Box

For a list of all members of this type, see WebPaneTextSettings members.

Public Properties

 | Name | Description
Public Property | InProgressText | Gets or sets the text which will be displayed when an IFrame is in loading progress.
Top

See Also

Reference

WebPaneTextSettings Class
ISNet.WebUI.WebDesktop Namespace


WebPaneTextSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebPaneTextSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneTextSettings Class : WebPaneTextSettings Constructor

Glossary Item Box

Initializes a new instance of the WebPaneTextSettings class.

Overload List

Overload | Description
WebPaneTextSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneTextSettings Class
WebPaneTextSettings Members


InProgressText Property

[image]
Intersoft WebDesktop Documentation
InProgressText Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebPaneTextSettings Class : InProgressText Property

Glossary Item Box

Gets or sets the text which will be displayed when an IFrame is in loading progress.

Syntax

Visual Basic (Declaration)
Public Property InProgressText As String
Visual Basic (Usage) Copy Code
Dim instance As WebPaneTextSettings
Dim value As String

instance.InProgressText = value

value = instance.InProgressText
C#
public string InProgressText {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebPaneTextSettings Class
WebPaneTextSettings Members


WebScrollBarStyle Class

[image]
Intersoft WebDesktop Documentation
WebScrollBarStyle Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebScrollBarStyle Class

Glossary Item Box

The style you can apply to WebScrollBar.

Object Model

WebScrollBarStyle Class

Syntax

Visual Basic (Declaration)
Public Class WebScrollBarStyle
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebScrollBarStyle
C#
public class WebScrollBarStyle : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebDesktop.WebScrollBarStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScrollBarStyle Members
ISNet.WebUI.WebDesktop Namespace


WebScrollBarStyle Class Members

[image]
Intersoft WebDesktop Documentation
WebScrollBarStyle Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebScrollBarStyle Class

Glossary Item Box

The following tables list the members exposed by WebScrollBarStyle.

Public Constructors

 | Name | Description
Public Constructor | WebScrollBarStyle Constructor |
Top

Public Properties

 | Name | Description
Public Property | ArrowColor | The arrow color of the scroll bar.
Public Property | BaseColor | The base color of the scroll bar.
Public Property | CssClass | The CSS class name of the scrollbar style.
Public Property | DarkShadowColor | The dark shadow color of the scroll bar.
Public Property | FaceColor | The face color of the scroll bar.
Public Property | HighlightColor | The highlight color of the scroll bar.
Public Property | LightColor | The light color of the scroll bar.
Public Property | ShadowColor | The shadow color of the scroll bar.
Public Property | TrackColor | The track color of the scroll bar.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebScrollBarStyle Class
ISNet.WebUI.WebDesktop Namespace


WebScrollBarStyle Constructor

[image]
Intersoft WebDesktop Documentation
WebScrollBarStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebScrollBarStyle Class : WebScrollBarStyle Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebScrollBarStyle()
C#
public WebScrollBarStyle()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScrollBarStyle Class
WebScrollBarStyle Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebScrollBarStyle Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebScrollBarStyle
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScrollBarStyle Class
WebScrollBarStyle Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebScrollBarStyle Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScrollBarStyle Class
WebScrollBarStyle Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebScrollBarStyle Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebScrollBarStyle
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScrollBarStyle Class
WebScrollBarStyle Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebScrollBarStyle Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebScrollBarStyle
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScrollBarStyle Class
WebScrollBarStyle Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebScrollBarStyle Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebScrollBarStyle
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScrollBarStyle Class
WebScrollBarStyle Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebScrollBarStyle Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebScrollBarStyle
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScrollBarStyle Class
WebScrollBarStyle Members


WebScrollBarStyle Class Methods

[image]
Intersoft WebDesktop Documentation
WebScrollBarStyle Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebScrollBarStyle Class

Glossary Item Box

For a list of all members of this type, see WebScrollBarStyle members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebScrollBarStyle Class
ISNet.WebUI.WebDesktop Namespace


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebScrollBarStyle Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebScrollBarStyle
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScrollBarStyle Class
WebScrollBarStyle Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebScrollBarStyle Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebScrollBarStyle
Dim value As Boolean

value = instance.IsEmpty()
C#
public override bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScrollBarStyle Class
WebScrollBarStyle Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebScrollBarStyle Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebScrollBarStyle

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScrollBarStyle Class
WebScrollBarStyle Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebScrollBarStyle Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebScrollBarStyle
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScrollBarStyle Class
WebScrollBarStyle Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebScrollBarStyle Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebScrollBarStyle
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScrollBarStyle Class
WebScrollBarStyle Members


WebScrollBarStyle Class Properties

[image]
Intersoft WebDesktop Documentation
WebScrollBarStyle Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebScrollBarStyle Class

Glossary Item Box

For a list of all members of this type, see WebScrollBarStyle members.

Public Properties

 | Name | Description
Public Property | ArrowColor | The arrow color of the scroll bar.
Public Property | BaseColor | The base color of the scroll bar.
Public Property | CssClass | The CSS class name of the scrollbar style.
Public Property | DarkShadowColor | The dark shadow color of the scroll bar.
Public Property | FaceColor | The face color of the scroll bar.
Public Property | HighlightColor | The highlight color of the scroll bar.
Public Property | LightColor | The light color of the scroll bar.
Public Property | ShadowColor | The shadow color of the scroll bar.
Public Property | TrackColor | The track color of the scroll bar.
Top

See Also

Reference

WebScrollBarStyle Class
ISNet.WebUI.WebDesktop Namespace


WebScrollBarStyle Constructor

[image]
Intersoft WebDesktop Documentation
WebScrollBarStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebScrollBarStyle Class : WebScrollBarStyle Constructor

Glossary Item Box

Initializes a new instance of the WebScrollBarStyle class.

Overload List

Overload | Description
WebScrollBarStyle Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScrollBarStyle Class
WebScrollBarStyle Members


ArrowColor Property

[image]
Intersoft WebDesktop Documentation
ArrowColor Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebScrollBarStyle Class : ArrowColor Property

Glossary Item Box

The arrow color of the scroll bar.

Syntax

Visual Basic (Declaration)
Public Property ArrowColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebScrollBarStyle
Dim value As System.Drawing.Color

instance.ArrowColor = value

value = instance.ArrowColor
C#
public System.Drawing.Color ArrowColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScrollBarStyle Class
WebScrollBarStyle Members


BaseColor Property

[image]
Intersoft WebDesktop Documentation
BaseColor Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebScrollBarStyle Class : BaseColor Property

Glossary Item Box

The base color of the scroll bar.

Syntax

Visual Basic (Declaration)
Public Property BaseColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebScrollBarStyle
Dim value As System.Drawing.Color

instance.BaseColor = value

value = instance.BaseColor
C#
public System.Drawing.Color BaseColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScrollBarStyle Class
WebScrollBarStyle Members


CssClass Property

[image]
Intersoft WebDesktop Documentation
CssClass Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebScrollBarStyle Class : CssClass Property

Glossary Item Box

The CSS class name of the scrollbar style.

Syntax

Visual Basic (Declaration)
Public Property CssClass As String
Visual Basic (Usage) Copy Code
Dim instance As WebScrollBarStyle
Dim value As String

instance.CssClass = value

value = instance.CssClass
C#
public string CssClass {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScrollBarStyle Class
WebScrollBarStyle Members


DarkShadowColor Property

[image]
Intersoft WebDesktop Documentation
DarkShadowColor Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebScrollBarStyle Class : DarkShadowColor Property

Glossary Item Box

The dark shadow color of the scroll bar.

Syntax

Visual Basic (Declaration)
Public Property DarkShadowColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebScrollBarStyle
Dim value As System.Drawing.Color

instance.DarkShadowColor = value

value = instance.DarkShadowColor
C#
public System.Drawing.Color DarkShadowColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScrollBarStyle Class
WebScrollBarStyle Members


FaceColor Property

[image]
Intersoft WebDesktop Documentation
FaceColor Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebScrollBarStyle Class : FaceColor Property

Glossary Item Box

The face color of the scroll bar.

Syntax

Visual Basic (Declaration)
Public Property FaceColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebScrollBarStyle
Dim value As System.Drawing.Color

instance.FaceColor = value

value = instance.FaceColor
C#
public System.Drawing.Color FaceColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScrollBarStyle Class
WebScrollBarStyle Members


HighlightColor Property

[image]
Intersoft WebDesktop Documentation
HighlightColor Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebScrollBarStyle Class : HighlightColor Property

Glossary Item Box

The highlight color of the scroll bar.

Syntax

Visual Basic (Declaration)
Public Property HighlightColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebScrollBarStyle
Dim value As System.Drawing.Color

instance.HighlightColor = value

value = instance.HighlightColor
C#
public System.Drawing.Color HighlightColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScrollBarStyle Class
WebScrollBarStyle Members


LightColor Property

[image]
Intersoft WebDesktop Documentation
LightColor Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebScrollBarStyle Class : LightColor Property

Glossary Item Box

The light color of the scroll bar.

Syntax

Visual Basic (Declaration)
Public Property LightColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebScrollBarStyle
Dim value As System.Drawing.Color

instance.LightColor = value

value = instance.LightColor
C#
public System.Drawing.Color LightColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScrollBarStyle Class
WebScrollBarStyle Members


ShadowColor Property

[image]
Intersoft WebDesktop Documentation
ShadowColor Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebScrollBarStyle Class : ShadowColor Property

Glossary Item Box

The shadow color of the scroll bar.

Syntax

Visual Basic (Declaration)
Public Property ShadowColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebScrollBarStyle
Dim value As System.Drawing.Color

instance.ShadowColor = value

value = instance.ShadowColor
C#
public System.Drawing.Color ShadowColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScrollBarStyle Class
WebScrollBarStyle Members


TrackColor Property

[image]
Intersoft WebDesktop Documentation
TrackColor Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebScrollBarStyle Class : TrackColor Property

Glossary Item Box

The track color of the scroll bar.

Syntax

Visual Basic (Declaration)
Public Property TrackColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebScrollBarStyle
Dim value As System.Drawing.Color

instance.TrackColor = value

value = instance.TrackColor
C#
public System.Drawing.Color TrackColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScrollBarStyle Class
WebScrollBarStyle Members


WebSplitter Class

[image]
Intersoft WebDesktop Documentation
WebSplitter Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebSplitter Class

Glossary Item Box

The control which integrated with WebPaneManager and used to split or resize the pane in WebDesktop.

Object Model

WebSplitter Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class WebSplitter
   Inherits ISNet.WebUI.ISNetControl
   Implements ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
C#
public sealed class WebSplitter : ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings

Remarks

WebSplitter control has a tight integration to WebPaneManager to bring a new standard in Web Layouting. It is often used on table with contents have varying lengths of data to present, which needs more dynamic navigation to resize the panes.

WebSplitter control is built to add more dynamically feature to HTML table-element. You do not need to change the existing layout, simply add one additional cell between the two cells you want to split, then drag and drop the WebSplitter control inside that cell. That makes the WebSplitter control is easily to apply and configure.

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
ISNet.WebUI.ISNetControl
ISNet.WebUI.WebDesktop.WebSplitter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Members
ISNet.WebUI.WebDesktop Namespace

Tasks

Using WebSplitter to split basic two cells
Using AllowCollapse feature

tasks

Using WebSplitter to split two rows
Configuring WebSplitter Interactive Styles

Concepts

WebSplitter Features


WebSplitter Class Members

[image]
Intersoft WebDesktop Documentation
WebSplitter Class Members
See Also Properties Methods Events Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebSplitter Class

Glossary Item Box

The following tables list the members exposed by WebSplitter.

Public Constructors

 | Name | Description
Public Constructor | WebSplitter Constructor | Initializes a new instance of the WebSplitterclass.
Top

Public Properties

 | Name | Description
Public Property | AccessKey | Keyboard shortcut used by the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | AllowCollapse | Gets or sets the property whether the WebSplitter able to collapse.
Public Property | AllowResize | Gets or sets the property whether the WebSplitter is able to resize.
Public Property | BackColor | Color of the background of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | BorderColor | Color of the border around the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | BorderStyle | Style of the border around the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | BorderWidth | Width of the border around the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | CollapseDirection | Gets or sets the direction of collapse, either to Panel1 or Panel2.
Public Property | ContainerType | Gets or sets the container type of WebSplitter.
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | CssClass | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Enabled | Enabled state of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableManagedTheming | Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to False, this control will not apply the style defined in Theme Architecture. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | Whether the control automatically saves its state for use in round-trips. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Font | The font used for text within the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ForeColor | Color of the text within the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | GripImageCollapse | Gets or sets the image of the grip to collapse. The image shown when the Panel is not collapse yet.
Public Property | GripImageRestore | Gets or sets the image of the grip to restore. The image shown when the Panel is already collapsed.
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ImagesDirectory | Gets or sets the image directory used by ImagesSettings.
Public Property | OnAfterCollapse | Gets or sets the javascript function to invoke after the Pane is collapsed.
Public Property | OnAfterResize | Gets or sets the javascript function to invoke after the Pane is resized.
Public Property | OnAfterRestore | Gets or sets the javascript function to invoke after the Pane is restored.
Public Property | OnBeforeCollapse | Gets or sets the javascript function to invoke before the Pane is collapsed.
Public Property | OnBeforeResize | Gets or sets the javascript function to invoke before the Pane is resized.
Public Property | OnBeforeRestore | Gets or sets the javascript function to invoke before the Pane is restored.
Public Property | Orientation | Gets or sets the WebSplitter orientation.
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Panel1Min | Gets or sets the minimum size of Panel I. (in pixel size)
Public Property | Panel1Scrollable | Gets or sets whether Panel I is scrollable.
Public Property | Panel2Min | Gets or sets the minimum size of Panel II. (in pixel size)
Public Property | Panel2Scrollable | Gets or sets whether Panel II is scrollable.
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden. Gets or sets the directory where all required scripts for the control are stored.
Public Property | SharedScriptDirectory | Overridden. Gets or sets the directory where all shared scripts for Intersoft controls are stored.
Public Property | Size | Get or sets WebSplitter size.
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SplitterStyle | The Style of WebSplitter.
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ToolTip | The tooltip displayed when the mouse is over the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateItems | Gets or sets the items to be stored in view state storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | Gets or sets the server connection string for file server-based viewstate storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | Gets or sets the location to store the viewstate of this control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | Indicates whether the control is visible and rendered. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | XmlCompressionEnabled | Specifies whether the Xml used for clientside state storage should be compressed. (Inherited from ISNet.WebUI.ISNetControl)
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPostData | Overridden.
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | GripClick | Occurs when WebSplitter's grip is clicked.
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebSplitter Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Using WebSplitter to split basic two cells
Using AllowCollapse feature

tasks

Using WebSplitter to split two rows
Configuring WebSplitter Interactive Styles

Concepts

WebSplitter Features


WebSplitter Constructor

[image]
Intersoft WebDesktop Documentation
WebSplitter Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : WebSplitter Constructor

Glossary Item Box

Initializes a new instance of the WebSplitterclass.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSplitter()
C#
public WebSplitter()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


ApplyStyle Method

[image]
Intersoft WebDesktop Documentation
ApplyStyle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : ApplyStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ApplyStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim s As System.Web.UI.WebControls.Style

instance.ApplyStyle(s)
C#
public void ApplyStyle(
   System.Web.UI.WebControls.Style s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


ApplyStyleSheetSkin Method

[image]
Intersoft WebDesktop Documentation
ApplyStyleSheetSkin Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : ApplyStyleSheetSkin Method

page

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ApplyStyleSheetSkin( _
   ByVal page As System.Web.UI.Page _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim page As System.Web.UI.Page

instance.ApplyStyleSheetSkin(page)
C#
public void ApplyStyleSheetSkin(
   System.Web.UI.Page page
)

Parameters

page

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


CanUseWebResources Method

[image]
Intersoft WebDesktop Documentation
CanUseWebResources Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : CanUseWebResources Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CanUseWebResources() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As Boolean

value = instance.CanUseWebResources()
C#
public bool CanUseWebResources()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As Object

value = instance.Clone()
C#
public object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


CopyBaseAttributes Method

[image]
Intersoft WebDesktop Documentation
CopyBaseAttributes Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : CopyBaseAttributes Method

controlSrc

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyBaseAttributes( _
   ByVal controlSrc As System.Web.UI.WebControls.WebControl _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim controlSrc As System.Web.UI.WebControls.WebControl

instance.CopyBaseAttributes(controlSrc)
C#
public void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl controlSrc
)

Parameters

controlSrc

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.ISNetControl)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members
Overload List


DataBind Method

[image]
Intersoft WebDesktop Documentation
DataBind Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : DataBind Method

Glossary Item Box

Overload List

Overload | Description
DataBind | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


DataBind() Method

[image]
Intersoft WebDesktop Documentation
DataBind() Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : DataBind() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DataBind()
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter

instance.DataBind()
C#
public void DataBind()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


Dispose Method

[image]
Intersoft WebDesktop Documentation
Dispose Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : Dispose Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter

instance.Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


FindControl Method

[image]
Intersoft WebDesktop Documentation
FindControl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : FindControl Method

Glossary Item Box

Overload List

Overload | Description
FindControl | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


FindControl(String) Method

[image]
Intersoft WebDesktop Documentation
FindControl(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : FindControl(String) Method

id

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function FindControl( _
   ByVal id As String _
) As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim id As String
Dim value As System.Web.UI.Control

value = instance.FindControl(id)
C#
public System.Web.UI.Control FindControl(
   string id
)

Parameters

id

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


Focus Method

[image]
Intersoft WebDesktop Documentation
Focus Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : Focus Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Focus()
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter

instance.Focus()
C#
public void Focus()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


ForceDisableXmlCompression Method

[image]
Intersoft WebDesktop Documentation
ForceDisableXmlCompression Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : ForceDisableXmlCompression Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ForceDisableXmlCompression()
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter

instance.ForceDisableXmlCompression()
C#
public void ForceDisableXmlCompression()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


GetCurrentControlLifeCycle Method

[image]
Intersoft WebDesktop Documentation
GetCurrentControlLifeCycle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : GetCurrentControlLifeCycle Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentControlLifeCycle() As ISNet.WebUI.ControlLifeCycle
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As ISNet.WebUI.ControlLifeCycle

value = instance.GetCurrentControlLifeCycle()
C#
public ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


GetCurrentTheme Method

[image]
Intersoft WebDesktop Documentation
GetCurrentTheme Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : GetCurrentTheme Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentTheme() As ISNet.WebUI.ThemeInfo
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As ISNet.WebUI.ThemeInfo

value = instance.GetCurrentTheme()
C#
public ISNet.WebUI.ThemeInfo GetCurrentTheme()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


GetFrameworkDataFolder Method

[image]
Intersoft WebDesktop Documentation
GetFrameworkDataFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : GetFrameworkDataFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkDataFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As String

value = instance.GetFrameworkDataFolder()
C#
public string GetFrameworkDataFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


GetFrameworkFolder Method

[image]
Intersoft WebDesktop Documentation
GetFrameworkFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : GetFrameworkFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As String

value = instance.GetFrameworkFolder()
C#
public string GetFrameworkFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


GetFrameworkVersion Method

[image]
Intersoft WebDesktop Documentation
GetFrameworkVersion Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : GetFrameworkVersion Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkVersion() As Version
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As Version

value = instance.GetFrameworkVersion()
C#
public Version GetFrameworkVersion()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


GetIntersoftFolder Method

[image]
Intersoft WebDesktop Documentation
GetIntersoftFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : GetIntersoftFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetIntersoftFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As String

value = instance.GetIntersoftFolder()
C#
public string GetIntersoftFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


GetLayoutFolder Method

[image]
Intersoft WebDesktop Documentation
GetLayoutFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : GetLayoutFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetLayoutFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As String

value = instance.GetLayoutFolder()
C#
public string GetLayoutFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


GetPostedXMLData Method

[image]
Intersoft WebDesktop Documentation
GetPostedXMLData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : GetPostedXMLData Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPostedXMLData() As String
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As String

value = instance.GetPostedXMLData()
C#
public string GetPostedXMLData()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


GetProductInfoKey Method

[image]
Intersoft WebDesktop Documentation
GetProductInfoKey Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : GetProductInfoKey Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductInfoKey() As String
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As String

value = instance.GetProductInfoKey()
C#
public string GetProductInfoKey()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


GetProductSimpleName Method

[image]
Intersoft WebDesktop Documentation
GetProductSimpleName Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : GetProductSimpleName Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductSimpleName() As String
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As String

value = instance.GetProductSimpleName()
C#
public string GetProductSimpleName()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


GetPropertyValue Method

[image]
Intersoft WebDesktop Documentation
GetPropertyValue Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : GetPropertyValue Method

defValue
propValue
webConfigKey

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPropertyValue( _
   ByVal defValue As String, _
   ByVal propValue As String, _
   ByVal webConfigKey As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim defValue As String
Dim propValue As String
Dim webConfigKey As String
Dim value As String

value = instance.GetPropertyValue(defValue, propValue, webConfigKey)
C#
public string GetPropertyValue(
   string defValue,
   string propValue,
   string webConfigKey
)

Parameters

defValue
propValue
webConfigKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


GetResourceStream Method

[image]
Intersoft WebDesktop Documentation
GetResourceStream Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : GetResourceStream Method

resourceUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetResourceStream( _
   ByVal resourceUrl As String _
) As System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim resourceUrl As String
Dim value As System.IO.Stream

value = instance.GetResourceStream(resourceUrl)
C#
public System.IO.Stream GetResourceStream(
   string resourceUrl
)

Parameters

resourceUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


GetRouteUrl Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : GetRouteUrl Method

Glossary Item Box

Overload List

Overload | Description
GetRouteUrl(Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(RouteValueDictionary) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,RouteValueDictionary) | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


GetRouteUrl(Object) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class > GetRouteUrl Method : GetRouteUrl(Object) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As Object _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim routeParameters As Object
Dim value As String

value = instance.GetRouteUrl(routeParameters)
C#
public string GetRouteUrl(
   object routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members
Overload List


GetRouteUrl(String,Object) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(String,Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class > GetRouteUrl Method : GetRouteUrl(String,Object) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As String, _
   ByVal routeParameters As Object _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim routeName As String
Dim routeParameters As Object
Dim value As String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public string GetRouteUrl(
   string routeName,
   object routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members
Overload List


GetRouteUrl(RouteValueDictionary) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(RouteValueDictionary) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class > GetRouteUrl Method : GetRouteUrl(RouteValueDictionary) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As String

value = instance.GetRouteUrl(routeParameters)
C#
public string GetRouteUrl(
   System.Web.Routing.RouteValueDictionary routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members
Overload List


GetRouteUrl(String,RouteValueDictionary) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(String,RouteValueDictionary) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class > GetRouteUrl Method : GetRouteUrl(String,RouteValueDictionary) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As String, _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim routeName As String
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public string GetRouteUrl(
   string routeName,
   System.Web.Routing.RouteValueDictionary routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members
Overload List


GetUniqueIDRelativeTo Method

[image]
Intersoft WebDesktop Documentation
GetUniqueIDRelativeTo Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : GetUniqueIDRelativeTo Method

control

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetUniqueIDRelativeTo( _
   ByVal control As System.Web.UI.Control _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim control As System.Web.UI.Control
Dim value As String

value = instance.GetUniqueIDRelativeTo(control)
C#
public string GetUniqueIDRelativeTo(
   System.Web.UI.Control control
)

Parameters

control

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


HasControls Method

[image]
Intersoft WebDesktop Documentation
HasControls Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : HasControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function HasControls() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As Boolean

value = instance.HasControls()
C#
public bool HasControls()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


IsAtlasCallback Method

[image]
Intersoft WebDesktop Documentation
IsAtlasCallback Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : IsAtlasCallback Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsAtlasCallback() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As Boolean

value = instance.IsAtlasCallback()
C#
public bool IsAtlasCallback()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


IsBetaRelease Method

[image]
Intersoft WebDesktop Documentation
IsBetaRelease Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : IsBetaRelease Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsBetaRelease() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As Boolean

value = instance.IsBetaRelease()
C#
public bool IsBetaRelease()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


IsChromeBrowser Method

[image]
Intersoft WebDesktop Documentation
IsChromeBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : IsChromeBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsChromeBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As Boolean

value = instance.IsChromeBrowser()
C#
public bool IsChromeBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As Boolean

value = instance.IsEmpty()
C#
public bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


IsFlyPostBackControl Method

[image]
Intersoft WebDesktop Documentation
IsFlyPostBackControl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : IsFlyPostBackControl Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsFlyPostBackControl() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As Boolean

value = instance.IsFlyPostBackControl()
C#
public bool IsFlyPostBackControl()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


IsFlyPostBackRequest Method

[image]
Intersoft WebDesktop Documentation
IsFlyPostBackRequest Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : IsFlyPostBackRequest Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsFlyPostBackRequest() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As Boolean

value = instance.IsFlyPostBackRequest()
C#
public bool IsFlyPostBackRequest()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


IsGeckoBasedBrowser Method

[image]
Intersoft WebDesktop Documentation
IsGeckoBasedBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : IsGeckoBasedBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoBasedBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As Boolean

value = instance.IsGeckoBasedBrowser()
C#
public bool IsGeckoBasedBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


IsGeckoVersion18 Method

[image]
Intersoft WebDesktop Documentation
IsGeckoVersion18 Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : IsGeckoVersion18 Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoVersion18() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As Boolean

value = instance.IsGeckoVersion18()
C#
public bool IsGeckoVersion18()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


IsInDesignMode Method

[image]
Intersoft WebDesktop Documentation
IsInDesignMode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : IsInDesignMode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInDesignMode() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As Boolean

value = instance.IsInDesignMode()
C#
public bool IsInDesignMode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


IsInternetExplorer8Browser Method

[image]
Intersoft WebDesktop Documentation
IsInternetExplorer8Browser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : IsInternetExplorer8Browser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorer8Browser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As Boolean

value = instance.IsInternetExplorer8Browser()
C#
public bool IsInternetExplorer8Browser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


IsInternetExplorerBrowser Method

[image]
Intersoft WebDesktop Documentation
IsInternetExplorerBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : IsInternetExplorerBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorerBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As Boolean

value = instance.IsInternetExplorerBrowser()
C#
public bool IsInternetExplorerBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


IsOperaBrowser Method

[image]
Intersoft WebDesktop Documentation
IsOperaBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : IsOperaBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsOperaBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As Boolean

value = instance.IsOperaBrowser()
C#
public bool IsOperaBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


IsSafariBrowser Method

[image]
Intersoft WebDesktop Documentation
IsSafariBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : IsSafariBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsSafariBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As Boolean

value = instance.IsSafariBrowser()
C#
public bool IsSafariBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


IsW3CStandardBrowser Method

[image]
Intersoft WebDesktop Documentation
IsW3CStandardBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : IsW3CStandardBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsW3CStandardBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As Boolean

value = instance.IsW3CStandardBrowser()
C#
public bool IsW3CStandardBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


LoadLayout Method

[image]
Intersoft WebDesktop Documentation
LoadLayout Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : LoadLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub LoadLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim settings As ISNet.WebUI.LayoutInfo

instance.LoadLayout(settings)
C#
public void LoadLayout(
   ISNet.WebUI.LayoutInfo settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


LoadLayoutFromFile Method

[image]
Intersoft WebDesktop Documentation
LoadLayoutFromFile Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : LoadLayoutFromFile Method

filePath

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub LoadLayoutFromFile( _
   ByVal filePath As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim filePath As String

instance.LoadLayoutFromFile(filePath)
C#
public void LoadLayoutFromFile(
   string filePath
)

Parameters

filePath

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


LoadLayoutFromPredefinedName Method

[image]
Intersoft WebDesktop Documentation
LoadLayoutFromPredefinedName Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : LoadLayoutFromPredefinedName Method

predefinedName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub LoadLayoutFromPredefinedName( _
   ByVal predefinedName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim predefinedName As String

instance.LoadLayoutFromPredefinedName(predefinedName)
C#
public void LoadLayoutFromPredefinedName(
   string predefinedName
)

Parameters

predefinedName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


LoadLayoutFromStream Method

[image]
Intersoft WebDesktop Documentation
LoadLayoutFromStream Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : LoadLayoutFromStream Method

stream

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub LoadLayoutFromStream( _
   ByVal stream As System.IO.Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim stream As System.IO.Stream

instance.LoadLayoutFromStream(stream)
C#
public void LoadLayoutFromStream(
   System.IO.Stream stream
)

Parameters

stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


WebSplitter Class Methods

[image]
Intersoft WebDesktop Documentation
WebSplitter Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebSplitter Class

Glossary Item Box

For a list of all members of this type, see WebSplitter members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPostData | Overridden.
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Top

See Also

Reference

WebSplitter Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Using WebSplitter to split basic two cells
Using AllowCollapse feature

tasks

Using WebSplitter to split two rows
Configuring WebSplitter Interactive Styles

Concepts

WebSplitter Features


LoadPostData Method

[image]
Intersoft WebDesktop Documentation
LoadPostData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : LoadPostData Method

postDataKey
postCollection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function LoadPostData( _
   ByVal postDataKey As String, _
   ByVal postCollection As System.Collections.Specialized.NameValueCollection _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim postDataKey As String
Dim postCollection As System.Collections.Specialized.NameValueCollection
Dim value As Boolean

value = instance.LoadPostData(postDataKey, postCollection)
C#
public override bool LoadPostData(
   string postDataKey,
   System.Collections.Specialized.NameValueCollection postCollection
)

Parameters

postDataKey
postCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


MergeStyle Method

[image]
Intersoft WebDesktop Documentation
MergeStyle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : MergeStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub MergeStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim s As System.Web.UI.WebControls.Style

instance.MergeStyle(s)
C#
public void MergeStyle(
   System.Web.UI.WebControls.Style s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


OnInfoChanged Method

[image]
Intersoft WebDesktop Documentation
OnInfoChanged Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : OnInfoChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnInfoChanged( _
   ByVal e As ISNet.WebUI.SynchronizeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim e As ISNet.WebUI.SynchronizeEventArgs

instance.OnInfoChanged(e)
C#
public void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


OnPreInitialize Method

[image]
Intersoft WebDesktop Documentation
OnPreInitialize Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : OnPreInitialize Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnPreInitialize()
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter

instance.OnPreInitialize()
C#
public void OnPreInitialize()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


RaisePostDataChangedEvent Method

[image]
Intersoft WebDesktop Documentation
RaisePostDataChangedEvent Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : RaisePostDataChangedEvent Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RaisePostDataChangedEvent()
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter

instance.RaisePostDataChangedEvent()
C#
public void RaisePostDataChangedEvent()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


ReadWebConfigValue Method

[image]
Intersoft WebDesktop Documentation
ReadWebConfigValue Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : ReadWebConfigValue Method

key

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ReadWebConfigValue( _
   ByVal key As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim key As String
Dim value As String

value = instance.ReadWebConfigValue(key)
C#
public string ReadWebConfigValue(
   string key
)

Parameters

key

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


RegisterBoxSizing Method

[image]
Intersoft WebDesktop Documentation
RegisterBoxSizing Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : RegisterBoxSizing Method

Glossary Item Box

Overload List

Overload | Description
RegisterBoxSizing() | (Inherited from ISNet.WebUI.ISNetControl)
RegisterBoxSizing(Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


RegisterBoxSizing() Method

[image]
Intersoft WebDesktop Documentation
RegisterBoxSizing() Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class > RegisterBoxSizing Method : RegisterBoxSizing() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing()
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter

instance.RegisterBoxSizing()
C#
public void RegisterBoxSizing()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members
Overload List


RegisterBoxSizing(Boolean) Method

[image]
Intersoft WebDesktop Documentation
RegisterBoxSizing(Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class > RegisterBoxSizing Method : RegisterBoxSizing(Boolean) Method

forceAll

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing( _
   ByVal forceAll As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim forceAll As Boolean

instance.RegisterBoxSizing(forceAll)
C#
public void RegisterBoxSizing(
   bool forceAll
)

Parameters

forceAll

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members
Overload List


RegisterGlobalStyle Method

[image]
Intersoft WebDesktop Documentation
RegisterGlobalStyle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : RegisterGlobalStyle Method

style

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterGlobalStyle( _
   ByVal style As ISNet.WebUI.WebStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim style As ISNet.WebUI.WebStyle

instance.RegisterGlobalStyle(style)
C#
public void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle style
)

Parameters

style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


RegisterLink Method

[image]
Intersoft WebDesktop Documentation
RegisterLink Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : RegisterLink Method

name
url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterLink( _
   ByVal name As String, _
   ByVal url As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim name As String
Dim url As String

instance.RegisterLink(name, url)
C#
public void RegisterLink(
   string name,
   string url
)

Parameters

name
url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


RegisterOptimizedCssClasses Method

[image]
Intersoft WebDesktop Documentation
RegisterOptimizedCssClasses Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : RegisterOptimizedCssClasses Method

runtimeStyleOnly

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterOptimizedCssClasses( _
   ByVal runtimeStyleOnly As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim runtimeStyleOnly As Boolean

instance.RegisterOptimizedCssClasses(runtimeStyleOnly)
C#
public void RegisterOptimizedCssClasses(
   bool runtimeStyleOnly
)

Parameters

runtimeStyleOnly

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


RegisterPreloadImage Method

[image]
Intersoft WebDesktop Documentation
RegisterPreloadImage Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : RegisterPreloadImage Method

image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterPreloadImage( _
   ByVal image As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim image As String

instance.RegisterPreloadImage(image)
C#
public void RegisterPreloadImage(
   string image
)

Parameters

image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


RegisterSharePointHandler Method

[image]
Intersoft WebDesktop Documentation
RegisterSharePointHandler Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : RegisterSharePointHandler Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterSharePointHandler()
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter

instance.RegisterSharePointHandler()
C#
public void RegisterSharePointHandler()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


RenderBeginTag Method

[image]
Intersoft WebDesktop Documentation
RenderBeginTag Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : RenderBeginTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RenderBeginTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderBeginTag(writer)
C#
public void RenderBeginTag(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


RenderControl Method

[image]
Intersoft WebDesktop Documentation
RenderControl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : RenderControl Method

Glossary Item Box

Overload List

Overload | Description
RenderControl | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


RenderControl(HtmlTextWriter) Method

[image]
Intersoft WebDesktop Documentation
RenderControl(HtmlTextWriter) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : RenderControl(HtmlTextWriter) Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RenderControl( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderControl(writer)
C#
public void RenderControl(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


RenderEndTag Method

[image]
Intersoft WebDesktop Documentation
RenderEndTag Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : RenderEndTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub RenderEndTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderEndTag(writer)
C#
public override void RenderEndTag(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter

instance.Reset()
C#
public void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


ResolveClientUrl Method

[image]
Intersoft WebDesktop Documentation
ResolveClientUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : ResolveClientUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveClientUrl( _
   ByVal relativeUrl As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim relativeUrl As String
Dim value As String

value = instance.ResolveClientUrl(relativeUrl)
C#
public string ResolveClientUrl(
   string relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


ResolveImagePath Method

[image]
Intersoft WebDesktop Documentation
ResolveImagePath Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : ResolveImagePath Method

folder
image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveImagePath( _
   ByVal folder As String, _
   ByVal image As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim folder As String
Dim image As String
Dim value As String

value = instance.ResolveImagePath(folder, image)
C#
public string ResolveImagePath(
   string folder,
   string image
)

Parameters

folder
image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


ResolveRelativeURL Method

[image]
Intersoft WebDesktop Documentation
ResolveRelativeURL Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : ResolveRelativeURL Method

url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveRelativeURL( _
   ByVal url As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim url As String
Dim value As String

value = instance.ResolveRelativeURL(url)
C#
public string ResolveRelativeURL(
   string url
)

Parameters

url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


ResolveResourceUrl Method

[image]
Intersoft WebDesktop Documentation
ResolveResourceUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : ResolveResourceUrl Method

kind
defaultFolder
currentFolder
resourceName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveResourceUrl( _
   ByVal kind As ISNet.WebUI.ResourceKind, _
   ByVal defaultFolder As String, _
   ByVal currentFolder As String, _
   ByVal resourceName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim kind As ISNet.WebUI.ResourceKind
Dim defaultFolder As String
Dim currentFolder As String
Dim resourceName As String
Dim value As String

value = instance.ResolveResourceUrl(kind, defaultFolder, currentFolder, resourceName)
C#
public string ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   string defaultFolder,
   string currentFolder,
   string resourceName
)

Parameters

kind
defaultFolder
currentFolder
resourceName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


ResolveUrl Method

[image]
Intersoft WebDesktop Documentation
ResolveUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : ResolveUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveUrl( _
   ByVal relativeUrl As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim relativeUrl As String
Dim value As String

value = instance.ResolveUrl(relativeUrl)
C#
public string ResolveUrl(
   string relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


SaveLayout Method

[image]
Intersoft WebDesktop Documentation
SaveLayout Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : SaveLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SaveLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim settings As ISNet.WebUI.LayoutInfo

instance.SaveLayout(settings)
C#
public void SaveLayout(
   ISNet.WebUI.LayoutInfo settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


SaveLayoutToFile Method

[image]
Intersoft WebDesktop Documentation
SaveLayoutToFile Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : SaveLayoutToFile Method

filePath
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SaveLayoutToFile( _
   ByVal filePath As String, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim filePath As String
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToFile(filePath, saveOptions)
C#
public void SaveLayoutToFile(
   string filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

filePath
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


SaveLayoutToStream Method

[image]
Intersoft WebDesktop Documentation
SaveLayoutToStream Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : SaveLayoutToStream Method

stream
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SaveLayoutToStream( _
   ByVal stream As System.IO.Stream, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim stream As System.IO.Stream
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToStream(stream, saveOptions)
C#
public void SaveLayoutToStream(
   System.IO.Stream stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

stream
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


SetRenderMethodDelegate Method

[image]
Intersoft WebDesktop Documentation
SetRenderMethodDelegate Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : SetRenderMethodDelegate Method

renderMethod

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetRenderMethodDelegate( _
   ByVal renderMethod As System.Web.UI.RenderMethod _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim renderMethod As System.Web.UI.RenderMethod

instance.SetRenderMethodDelegate(renderMethod)
C#
public void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod renderMethod
)

Parameters

renderMethod

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


SetSessionTheme Method

[image]
Intersoft WebDesktop Documentation
SetSessionTheme Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : SetSessionTheme Method

themeInfo

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetSessionTheme( _
   ByVal themeInfo As ISNet.WebUI.ThemeInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim themeInfo As ISNet.WebUI.ThemeInfo

instance.SetSessionTheme(themeInfo)
C#
public void SetSessionTheme(
   ISNet.WebUI.ThemeInfo themeInfo
)

Parameters

themeInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


ShouldReturnJson Method

[image]
Intersoft WebDesktop Documentation
ShouldReturnJson Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : ShouldReturnJson Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ShouldReturnJson() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As Boolean

value = instance.ShouldReturnJson()
C#
public bool ShouldReturnJson()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


AccessKey Property

[image]
Intersoft WebDesktop Documentation
AccessKey Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : AccessKey Property

Glossary Item Box

Keyboard shortcut used by the control.

Syntax

Visual Basic (Declaration)
Public Property AccessKey As String
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As String

instance.AccessKey = value

value = instance.AccessKey
C#
public string AccessKey {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


WebSplitter Class Properties

[image]
Intersoft WebDesktop Documentation
WebSplitter Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebSplitter Class

Glossary Item Box

For a list of all members of this type, see WebSplitter members.

Public Properties

 | Name | Description
Public Property | AccessKey | Keyboard shortcut used by the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | AllowCollapse | Gets or sets the property whether the WebSplitter able to collapse.
Public Property | AllowResize | Gets or sets the property whether the WebSplitter is able to resize.
Public Property | BackColor | Color of the background of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | BorderColor | Color of the border around the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | BorderStyle | Style of the border around the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | BorderWidth | Width of the border around the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | CollapseDirection | Gets or sets the direction of collapse, either to Panel1 or Panel2.
Public Property | ContainerType | Gets or sets the container type of WebSplitter.
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | CssClass | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Enabled | Enabled state of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableManagedTheming | Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to False, this control will not apply the style defined in Theme Architecture. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | Whether the control automatically saves its state for use in round-trips. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Font | The font used for text within the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ForeColor | Color of the text within the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | GripImageCollapse | Gets or sets the image of the grip to collapse. The image shown when the Panel is not collapse yet.
Public Property | GripImageRestore | Gets or sets the image of the grip to restore. The image shown when the Panel is already collapsed.
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ImagesDirectory | Gets or sets the image directory used by ImagesSettings.
Public Property | OnAfterCollapse | Gets or sets the javascript function to invoke after the Pane is collapsed.
Public Property | OnAfterResize | Gets or sets the javascript function to invoke after the Pane is resized.
Public Property | OnAfterRestore | Gets or sets the javascript function to invoke after the Pane is restored.
Public Property | OnBeforeCollapse | Gets or sets the javascript function to invoke before the Pane is collapsed.
Public Property | OnBeforeResize | Gets or sets the javascript function to invoke before the Pane is resized.
Public Property | OnBeforeRestore | Gets or sets the javascript function to invoke before the Pane is restored.
Public Property | Orientation | Gets or sets the WebSplitter orientation.
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Panel1Min | Gets or sets the minimum size of Panel I. (in pixel size)
Public Property | Panel1Scrollable | Gets or sets whether Panel I is scrollable.
Public Property | Panel2Min | Gets or sets the minimum size of Panel II. (in pixel size)
Public Property | Panel2Scrollable | Gets or sets whether Panel II is scrollable.
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden. Gets or sets the directory where all required scripts for the control are stored.
Public Property | SharedScriptDirectory | Overridden. Gets or sets the directory where all shared scripts for Intersoft controls are stored.
Public Property | Size | Get or sets WebSplitter size.
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SplitterStyle | The Style of WebSplitter.
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ToolTip | The tooltip displayed when the mouse is over the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateItems | Gets or sets the items to be stored in view state storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | Gets or sets the server connection string for file server-based viewstate storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | Gets or sets the location to store the viewstate of this control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | Indicates whether the control is visible and rendered. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | XmlCompressionEnabled | Specifies whether the Xml used for clientside state storage should be compressed. (Inherited from ISNet.WebUI.ISNetControl)
Top

See Also

Reference

WebSplitter Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Using WebSplitter to split basic two cells
Using AllowCollapse feature

tasks

Using WebSplitter to split two rows
Configuring WebSplitter Interactive Styles

Concepts

WebSplitter Features


AllowCollapse Property

[image]
Intersoft WebDesktop Documentation
AllowCollapse Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : AllowCollapse Property

Glossary Item Box

Gets or sets the property whether the WebSplitter able to collapse.

Syntax

Visual Basic (Declaration)
Public Property AllowCollapse As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As Boolean

instance.AllowCollapse = value

value = instance.AllowCollapse
C#
public bool AllowCollapse {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members

Tasks

Using AllowCollapse feature

Concept

WebSplitter Features


AllowResize Property

[image]
Intersoft WebDesktop Documentation
AllowResize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : AllowResize Property

Glossary Item Box

Gets or sets the property whether the WebSplitter is able to resize.

Syntax

Visual Basic (Declaration)
Public Property AllowResize As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As Boolean

instance.AllowResize = value

value = instance.AllowResize
C#
public bool AllowResize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


BackColor Property

[image]
Intersoft WebDesktop Documentation
BackColor Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : BackColor Property

Glossary Item Box

Color of the background of the control.

Syntax

Visual Basic (Declaration)
Public Property BackColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
C#
public System.Drawing.Color BackColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


BorderColor Property

[image]
Intersoft WebDesktop Documentation
BorderColor Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : BorderColor Property

Glossary Item Box

Color of the border around the control.

Syntax

Visual Basic (Declaration)
Public Property BorderColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As System.Drawing.Color

instance.BorderColor = value

value = instance.BorderColor
C#
public System.Drawing.Color BorderColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


BorderStyle Property

[image]
Intersoft WebDesktop Documentation
BorderStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : BorderStyle Property

Glossary Item Box

Style of the border around the control.

Syntax

Visual Basic (Declaration)
Public Property BorderStyle As System.Web.UI.WebControls.BorderStyle
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As System.Web.UI.WebControls.BorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
C#
public System.Web.UI.WebControls.BorderStyle BorderStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


BorderWidth Property

[image]
Intersoft WebDesktop Documentation
BorderWidth Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : BorderWidth Property

Glossary Item Box

Width of the border around the control.

Syntax

Visual Basic (Declaration)
Public Property BorderWidth As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As System.Web.UI.WebControls.Unit

instance.BorderWidth = value

value = instance.BorderWidth
C#
public System.Web.UI.WebControls.Unit BorderWidth {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


ClientIDMode Property

[image]
Intersoft WebDesktop Documentation
ClientIDMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : ClientIDMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ClientIDMode As System.Web.UI.ClientIDMode
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As System.Web.UI.ClientIDMode

instance.ClientIDMode = value

value = instance.ClientIDMode
C#
public System.Web.UI.ClientIDMode ClientIDMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


CollapseDirection Property

[image]
Intersoft WebDesktop Documentation
CollapseDirection Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : CollapseDirection Property

Glossary Item Box

Gets or sets the direction of collapse, either to Panel1 or Panel2.

Syntax

Visual Basic (Declaration)
Public Property CollapseDirection As CollapseDirection
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As CollapseDirection

instance.CollapseDirection = value

value = instance.CollapseDirection
C#
public CollapseDirection CollapseDirection {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members

Tasks

Using AllowCollapse feature


ContainerType Property

[image]
Intersoft WebDesktop Documentation
ContainerType Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : ContainerType Property

Glossary Item Box

Gets or sets the container type of WebSplitter.

Syntax

Visual Basic (Declaration)
Public Property ContainerType As ContainerType
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As ContainerType

instance.ContainerType = value

value = instance.ContainerType
C#
public ContainerType ContainerType {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


ControlDataTransferFormat Property

[image]
Intersoft WebDesktop Documentation
ControlDataTransferFormat Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : ControlDataTransferFormat Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ControlDataTransferFormat As ISNet.WebUI.DataTransferFormat
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As ISNet.WebUI.DataTransferFormat

instance.ControlDataTransferFormat = value

value = instance.ControlDataTransferFormat
C#
public ISNet.WebUI.DataTransferFormat ControlDataTransferFormat {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


CssClass Property

[image]
Intersoft WebDesktop Documentation
CssClass Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : CssClass Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property CssClass As String
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As String

instance.CssClass = value

value = instance.CssClass
C#
public string CssClass {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


Enabled Property

[image]
Intersoft WebDesktop Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : Enabled Property

Glossary Item Box

Enabled state of the control.

Syntax

Visual Basic (Declaration)
Public Property Enabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As Boolean

instance.Enabled = value

value = instance.Enabled
C#
public bool Enabled {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


EnableManagedTheming Property

[image]
Intersoft WebDesktop Documentation
EnableManagedTheming Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : EnableManagedTheming Property

Glossary Item Box

Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to False, this control will not apply the style defined in Theme Architecture.

Syntax

Visual Basic (Declaration)
Public Property EnableManagedTheming As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As Boolean

instance.EnableManagedTheming = value

value = instance.EnableManagedTheming
C#
public bool EnableManagedTheming {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


EnableTheming Property

[image]
Intersoft WebDesktop Documentation
EnableTheming Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : EnableTheming Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property EnableTheming As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As Boolean

instance.EnableTheming = value

value = instance.EnableTheming
C#
public bool EnableTheming {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


EnableViewState Property

[image]
Intersoft WebDesktop Documentation
EnableViewState Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : EnableViewState Property

Glossary Item Box

Whether the control automatically saves its state for use in round-trips.

Syntax

Visual Basic (Declaration)
Public Property EnableViewState As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As Boolean

instance.EnableViewState = value

value = instance.EnableViewState
C#
public bool EnableViewState {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


EnableWebResources Property

[image]
Intersoft WebDesktop Documentation
EnableWebResources Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : EnableWebResources Property

Glossary Item Box

Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory).

Syntax

Visual Basic (Declaration)
Public Property EnableWebResources As ISNet.WebUI.WebResourceType
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As ISNet.WebUI.WebResourceType

instance.EnableWebResources = value

value = instance.EnableWebResources
C#
public ISNet.WebUI.WebResourceType EnableWebResources {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


Font Property

[image]
Intersoft WebDesktop Documentation
Font Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : Font Property

Glossary Item Box

The font used for text within the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Font As System.Web.UI.WebControls.FontInfo
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As System.Web.UI.WebControls.FontInfo

value = instance.Font
C#
public System.Web.UI.WebControls.FontInfo Font {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


ForeColor Property

[image]
Intersoft WebDesktop Documentation
ForeColor Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : ForeColor Property

Glossary Item Box

Color of the text within the control.

Syntax

Visual Basic (Declaration)
Public Property ForeColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
C#
public System.Drawing.Color ForeColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


GripImageCollapse Property

[image]
Intersoft WebDesktop Documentation
GripImageCollapse Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : GripImageCollapse Property

Glossary Item Box

Gets or sets the image of the grip to collapse. The image shown when the Panel is not collapse yet.

Syntax

Visual Basic (Declaration)
Public Property GripImageCollapse As String
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As String

instance.GripImageCollapse = value

value = instance.GripImageCollapse
C#
public string GripImageCollapse {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members

Tasks

Using AllowCollapse feature


GripImageRestore Property

[image]
Intersoft WebDesktop Documentation
GripImageRestore Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : GripImageRestore Property

Glossary Item Box

Gets or sets the image of the grip to restore. The image shown when the Panel is already collapsed.

Syntax

Visual Basic (Declaration)
Public Property GripImageRestore As String
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As String

instance.GripImageRestore = value

value = instance.GripImageRestore
C#
public string GripImageRestore {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members

Tasks

Using AllowCollapse feature


ID Property

[image]
Intersoft WebDesktop Documentation
ID Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : ID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ID As String
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As String

instance.ID = value

value = instance.ID
C#
public string ID {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


ImagesDirectory Property

[image]
Intersoft WebDesktop Documentation
ImagesDirectory Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : ImagesDirectory Property

Glossary Item Box

Gets or sets the image directory used by ImagesSettings.

Syntax

Visual Basic (Declaration)
Public Property ImagesDirectory As String
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As String

instance.ImagesDirectory = value

value = instance.ImagesDirectory
C#
public string ImagesDirectory {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


OnAfterCollapse Property

[image]
Intersoft WebDesktop Documentation
OnAfterCollapse Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : OnAfterCollapse Property

Glossary Item Box

Gets or sets the javascript function to invoke after the Pane is collapsed.

Syntax

Visual Basic (Declaration)
Public Property OnAfterCollapse As String
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As String

instance.OnAfterCollapse = value

value = instance.OnAfterCollapse
C#
public string OnAfterCollapse {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


OnAfterResize Property

[image]
Intersoft WebDesktop Documentation
OnAfterResize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : OnAfterResize Property

Glossary Item Box

Gets or sets the javascript function to invoke after the Pane is resized.

Syntax

Visual Basic (Declaration)
Public Property OnAfterResize As String
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As String

instance.OnAfterResize = value

value = instance.OnAfterResize
C#
public string OnAfterResize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


OnAfterRestore Property

[image]
Intersoft WebDesktop Documentation
OnAfterRestore Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : OnAfterRestore Property

Glossary Item Box

Gets or sets the javascript function to invoke after the Pane is restored.

Syntax

Visual Basic (Declaration)
Public Property OnAfterRestore As String
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As String

instance.OnAfterRestore = value

value = instance.OnAfterRestore
C#
public string OnAfterRestore {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


OnBeforeCollapse Property

[image]
Intersoft WebDesktop Documentation
OnBeforeCollapse Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : OnBeforeCollapse Property

Glossary Item Box

Gets or sets the javascript function to invoke before the Pane is collapsed.

Syntax

Visual Basic (Declaration)
Public Property OnBeforeCollapse As String
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As String

instance.OnBeforeCollapse = value

value = instance.OnBeforeCollapse
C#
public string OnBeforeCollapse {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


OnBeforeResize Property

[image]
Intersoft WebDesktop Documentation
OnBeforeResize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : OnBeforeResize Property

Glossary Item Box

Gets or sets the javascript function to invoke before the Pane is resized.

Syntax

Visual Basic (Declaration)
Public Property OnBeforeResize As String
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As String

instance.OnBeforeResize = value

value = instance.OnBeforeResize
C#
public string OnBeforeResize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


OnBeforeRestore Property

[image]
Intersoft WebDesktop Documentation
OnBeforeRestore Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : OnBeforeRestore Property

Glossary Item Box

Gets or sets the javascript function to invoke before the Pane is restored.

Syntax

Visual Basic (Declaration)
Public Property OnBeforeRestore As String
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As String

instance.OnBeforeRestore = value

value = instance.OnBeforeRestore
C#
public string OnBeforeRestore {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


Orientation Property

[image]
Intersoft WebDesktop Documentation
Orientation Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : Orientation Property

Glossary Item Box

Gets or sets the WebSplitter orientation.

Syntax

Visual Basic (Declaration)
Public Property Orientation As Orientation
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As Orientation

instance.Orientation = value

value = instance.Orientation
C#
public Orientation Orientation {get; set;}

Remarks

Using this property you can determine the orientation of the splitter - Vertical or Horizontal. The default value of this property is Vertical. However, you can change the value to Horizontal if you want to use WebSplitter to split rows.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members

Tasks

Using WebSplitter to split two rows

Concepts

WebSplitter Features


Page Property

[image]
Intersoft WebDesktop Documentation
Page Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : Page Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Page As System.Web.UI.Page
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As System.Web.UI.Page

instance.Page = value

value = instance.Page
C#
public System.Web.UI.Page Page {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


Panel1Min Property

[image]
Intersoft WebDesktop Documentation
Panel1Min Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : Panel1Min Property

Glossary Item Box

Gets or sets the minimum size of Panel I. (in pixel size)

Syntax

Visual Basic (Declaration)
Public Property Panel1Min As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As Integer

instance.Panel1Min = value

value = instance.Panel1Min
C#
public int Panel1Min {get; set;}

Remarks

This property also determines the size of the panel I being collapsed (if the CollapseDirection is set to "panel1"). The default value is 1 pixel.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


Panel1Scrollable Property

[image]
Intersoft WebDesktop Documentation
Panel1Scrollable Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : Panel1Scrollable Property

Glossary Item Box

Gets or sets whether Panel I is scrollable.

Syntax

Visual Basic (Declaration)
Public Property Panel1Scrollable As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As Boolean

instance.Panel1Scrollable = value

value = instance.Panel1Scrollable
C#
public bool Panel1Scrollable {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


Panel2Min Property

[image]
Intersoft WebDesktop Documentation
Panel2Min Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : Panel2Min Property

Glossary Item Box

Gets or sets the minimum size of Panel II. (in pixel size)

Syntax

Visual Basic (Declaration)
Public Property Panel2Min As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As Integer

instance.Panel2Min = value

value = instance.Panel2Min
C#
public int Panel2Min {get; set;}

Remarks

This property also determines the size of the panel II being collapsed (if the CollapseDirection is set to "panel2"). The default value is 1 pixel.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


Panel2Scrollable Property

[image]
Intersoft WebDesktop Documentation
Panel2Scrollable Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : Panel2Scrollable Property

Glossary Item Box

Gets or sets whether Panel II is scrollable.

Syntax

Visual Basic (Declaration)
Public Property Panel2Scrollable As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As Boolean

instance.Panel2Scrollable = value

value = instance.Panel2Scrollable
C#
public bool Panel2Scrollable {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


RenderingMode Property

[image]
Intersoft WebDesktop Documentation
RenderingMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : RenderingMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property RenderingMode As ISNet.WebUI.RenderMode
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As ISNet.WebUI.RenderMode

instance.RenderingMode = value

value = instance.RenderingMode
C#
public ISNet.WebUI.RenderMode RenderingMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


RuntimeLicenseKey Property

[image]
Intersoft WebDesktop Documentation
RuntimeLicenseKey Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : RuntimeLicenseKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property RuntimeLicenseKey As String
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As String

instance.RuntimeLicenseKey = value

value = instance.RuntimeLicenseKey
C#
public string RuntimeLicenseKey {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


ScriptDirectory Property

[image]
Intersoft WebDesktop Documentation
ScriptDirectory Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : ScriptDirectory Property

Glossary Item Box

Gets or sets the directory where all required scripts for the control are stored.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Property ScriptDirectory As String
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As String

instance.ScriptDirectory = value

value = instance.ScriptDirectory
C#
public override string ScriptDirectory {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


SharedScriptDirectory Property

[image]
Intersoft WebDesktop Documentation
SharedScriptDirectory Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : SharedScriptDirectory Property

Glossary Item Box

Gets or sets the directory where all shared scripts for Intersoft controls are stored.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Property SharedScriptDirectory As String
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As String

instance.SharedScriptDirectory = value

value = instance.SharedScriptDirectory
C#
public override string SharedScriptDirectory {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


Size Property

[image]
Intersoft WebDesktop Documentation
Size Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : Size Property

Glossary Item Box

Get or sets WebSplitter size.

Syntax

Visual Basic (Declaration)
Public Property Size As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As Integer

instance.Size = value

value = instance.Size
C#
public int Size {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


SkinID Property

[image]
Intersoft WebDesktop Documentation
SkinID Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : SkinID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property SkinID As String
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As String

instance.SkinID = value

value = instance.SkinID
C#
public string SkinID {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


SplitterStyle Property

[image]
Intersoft WebDesktop Documentation
SplitterStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : SplitterStyle Property

Glossary Item Box

The Style of WebSplitter.

Syntax

Visual Basic (Declaration)
Public Property SplitterStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As ISNet.WebUI.DynamicStyle

instance.SplitterStyle = value

value = instance.SplitterStyle
C#
public ISNet.WebUI.DynamicStyle SplitterStyle {get; set;}

Remarks

SplitterStyle is a DynamicStyle property. DynamicStyle is built around the WebStyle object, and consists of 3 states of interactivity: Normal, Over and Active.

  • Normal : The default style of the WebSplitter.
  • Over : The style of the WebSplitter being hovered.
  • Active : The style when the WebSplitter is in the state of being dragged.

There are some properties that can be configured in DynamicStyle. Following is a brief descriptions of commonly used properties.

  • BackColor : set the color of the WebSplitter.
  • BackColor2 : set the alternate color of the WebSplitter for gradient color, relates to GradientType property.
  • Cursor : the type of mouse pointer when the WebSplitter being hovered.
  • Overflow, OverflowX and OverflowY should be set to hidden for consistent layout especially not in IE browser.

    • Requirements

    Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

    See Also

    Reference

    WebSplitter Class
    WebSplitter Members

    Tasks

    Configuring WebSplitter Interactive Styles

    Concepts

    WebSplitter Features


TabIndex Property

[image]
Intersoft WebDesktop Documentation
TabIndex Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : TabIndex Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property TabIndex As Short
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As Short

instance.TabIndex = value

value = instance.TabIndex
C#
public short TabIndex {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


ToolTip Property

[image]
Intersoft WebDesktop Documentation
ToolTip Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : ToolTip Property

Glossary Item Box

The tooltip displayed when the mouse is over the control.

Syntax

Visual Basic (Declaration)
Public Property ToolTip As String
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As String

instance.ToolTip = value

value = instance.ToolTip
C#
public string ToolTip {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


ValidateRequestMode Property

[image]
Intersoft WebDesktop Documentation
ValidateRequestMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : ValidateRequestMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ValidateRequestMode As System.Web.UI.ValidateRequestMode
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As System.Web.UI.ValidateRequestMode

instance.ValidateRequestMode = value

value = instance.ValidateRequestMode
C#
public System.Web.UI.ValidateRequestMode ValidateRequestMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


ViewStateItems Property

[image]
Intersoft WebDesktop Documentation
ViewStateItems Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : ViewStateItems Property

Glossary Item Box

Gets or sets the items to be stored in view state storage.

Syntax

Visual Basic (Declaration)
Public Property ViewStateItems As ISNet.WebUI.ViewStateItem
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As ISNet.WebUI.ViewStateItem

instance.ViewStateItems = value

value = instance.ViewStateItems
C#
public ISNet.WebUI.ViewStateItem ViewStateItems {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


ViewStateMode Property

[image]
Intersoft WebDesktop Documentation
ViewStateMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : ViewStateMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ViewStateMode As System.Web.UI.ViewStateMode
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As System.Web.UI.ViewStateMode

instance.ViewStateMode = value

value = instance.ViewStateMode
C#
public System.Web.UI.ViewStateMode ViewStateMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


ViewStateServerConnection Property

[image]
Intersoft WebDesktop Documentation
ViewStateServerConnection Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : ViewStateServerConnection Property

Glossary Item Box

Gets or sets the server connection string for file server-based viewstate storage.

Syntax

Visual Basic (Declaration)
Public Property ViewStateServerConnection As String
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As String

instance.ViewStateServerConnection = value

value = instance.ViewStateServerConnection
C#
public string ViewStateServerConnection {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


ViewStateStorage Property

[image]
Intersoft WebDesktop Documentation
ViewStateStorage Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : ViewStateStorage Property

Glossary Item Box

Gets or sets the location to store the viewstate of this control.

Syntax

Visual Basic (Declaration)
Public Property ViewStateStorage As ISNet.WebUI.StateCacheStorage
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As ISNet.WebUI.StateCacheStorage

instance.ViewStateStorage = value

value = instance.ViewStateStorage
C#
public ISNet.WebUI.StateCacheStorage ViewStateStorage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


Visible Property

[image]
Intersoft WebDesktop Documentation
Visible Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : Visible Property

Glossary Item Box

Indicates whether the control is visible and rendered.

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public bool Visible {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


XmlCompressionEnabled Property

[image]
Intersoft WebDesktop Documentation
XmlCompressionEnabled Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : XmlCompressionEnabled Property

Glossary Item Box

Specifies whether the Xml used for clientside state storage should be compressed.

Syntax

Visual Basic (Declaration)
Public Property XmlCompressionEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim value As Boolean

instance.XmlCompressionEnabled = value

value = instance.XmlCompressionEnabled
C#
public bool XmlCompressionEnabled {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


DataBinding Event

[image]
Intersoft WebDesktop Documentation
DataBinding Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : DataBinding Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event DataBinding As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim handler As EventHandler

AddHandler instance.DataBinding, handler
C#
public event EventHandler DataBinding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


Disposed Event

[image]
Intersoft WebDesktop Documentation
Disposed Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim handler As EventHandler

AddHandler instance.Disposed, handler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


WebSplitter Class Events

[image]
Intersoft WebDesktop Documentation
WebSplitter Class Events
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebSplitter Class

Glossary Item Box

For a list of all members of this type, see WebSplitter members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | GripClick | Occurs when WebSplitter's grip is clicked.
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebSplitter Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Using WebSplitter to split basic two cells
Using AllowCollapse feature

tasks

Using WebSplitter to split two rows
Configuring WebSplitter Interactive Styles

Concepts

WebSplitter Features


GripClick Event

[image]
Intersoft WebDesktop Documentation
GripClick Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : GripClick Event

Glossary Item Box

Occurs when WebSplitter's grip is clicked.

Syntax

Visual Basic (Declaration)
Public Event GripClick As WebSplitter.GripClickedDelegate
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim handler As WebSplitter.GripClickedDelegate

AddHandler instance.GripClick, handler
C#
public event WebSplitter.GripClickedDelegate GripClick

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


Init Event

[image]
Intersoft WebDesktop Documentation
Init Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : Init Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Init As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim handler As EventHandler

AddHandler instance.Init, handler
C#
public event EventHandler Init

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


Load Event

[image]
Intersoft WebDesktop Documentation
Load Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : Load Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Load As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim handler As EventHandler

AddHandler instance.Load, handler
C#
public event EventHandler Load

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


PreInitialize Event

[image]
Intersoft WebDesktop Documentation
PreInitialize Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : PreInitialize Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event PreInitialize As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim handler As EventHandler

AddHandler instance.PreInitialize, handler
C#
public event EventHandler PreInitialize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


PreRender Event

[image]
Intersoft WebDesktop Documentation
PreRender Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : PreRender Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event PreRender As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim handler As EventHandler

AddHandler instance.PreRender, handler
C#
public event EventHandler PreRender

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


Unload Event

[image]
Intersoft WebDesktop Documentation
Unload Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebSplitter Class : Unload Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Unload As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSplitter
Dim handler As EventHandler

AddHandler instance.Unload, handler
C#
public event EventHandler Unload

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter Class
WebSplitter Members


WebTab Class

[image]
Intersoft WebDesktop Documentation
WebTab Class
Members Example See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebTab Class

Glossary Item Box

WebTab is a component which implements the appearances and rich behaviors of Tab in Dekstop application. The WebTab object represents the main operational area which contains a collection of tab items.

Object Model

WebTab Class

Syntax

Visual Basic (Declaration)
Public Class WebTab
   Inherits ISNet.WebUI.ISNetControl
   Implements ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, ISNet.WebUI.ITemplateSync
Visual Basic (Usage) Copy Code
Dim instance As WebTab
C#
public class WebTab : ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, ISNet.WebUI.ITemplateSync

Remarks

WebTab object is created by default to have a value of height 300px and width 500px which you can easily resize either by setting it in the property, or resizing it directly through the designer. You can specify the size of WebTab in pixels or in percentage measurement.

A WebTab object consists of a tab items collection. Each of this tab items has its own property that can be set individually, or set globally using the default property inherited from the WebTab object.

You can use WebTab control to build well-organized user interface in the form of "Tab" navigations and easily achieve modern visual styles with the ease of couple properties changes. WebTab features TrueShape rendering which lets you design a rich Windows XP-like Tab control without requiring any images.

WebTab also offers numerous innovative features, such as automatic scrolling and AllowClose. The scrolling feature lets you define as many tabs as you like without compromising the layout functions. The AllowClose feature gives a richer experience for your users by letting them close any unused tabs.

WebTab includes strong client side object model and API which lets developers to easily interact with the control programmatically. This capability enables you to extend the functions of the tab according to your application-specific scenarios.

To learn more on WebTab please refer to WebTab Overview and WebTab Features.

Example

The following example shows you how to load and save structure of WebTab programmatically. You need to create two WebTabs and two Buttons and insert the codes below OnClick Server Side Event. For more information please refer to Saving and Loading Structure Programmatically in See Also section
C# Copy Code
protected void Page_Load(object sender, EventArgs e)
{
    body.Style.Add("overflow", "hidden");
}
protected void Button1_Click(object sender, EventArgs e)
{
    WebTab2.LoadTabsStructureFromXml(Server.MapPath("Style1.xml"));
}
protected void Button2_Click(object sender, EventArgs e)
{
    WebTab1.SaveTabsStructureToXml(Server.MapPath("Style1.xml"));
}

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
ISNet.WebUI.ISNetControl
ISNet.WebUI.WebDesktop.WebTab

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Members
ISNet.WebUI.WebDesktop Namespace

Tasks

Creating Simple Tab
Creating Overlapped Edges Tab

tasks

Configuring Scrolling Tab mode
Configuring Closable Tab mode
Changing Tab Position
Saving and Loading Structure Programmatically

Concepts

WebTab Overview

concepts

WebTab Features
Understanding Tab Concepts
Enabling TrueShape rendering
Working with Complex Images


WebTab Class Members

[image]
Intersoft WebDesktop Documentation
WebTab Class Members
See Also Properties Methods Events Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebTab Class

Glossary Item Box

The following tables list the members exposed by WebTab.

Public Constructors

 | Name | Description
Public Constructor | WebTab Constructor |
Top

Public Properties

 | Name | Description
Public Property | AccessKey | Keyboard shortcut used by the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ActiveTabIndex | Gets or sets the active tab index.
Public Property | Alignment | Gets or sets the alignment of the Tab.
Public Property | AllowClose | Gets or sets a value indicating whether users are allowed to close the Tabs.
Public Property | AllowScrolling | Gets or sets a value indicating whether the Tab control should display ScrollButtons when the number of Tab exceeds the controls' width.
Public Property | AllowTextWrapping | Gets or sets whether the Text of TabItem shoudl be wrapped when the width is not sufficient. (Applicable when SizeMode is set to Fixed).
Public Property | AlwaysVisibleSeparator |
Public Property | AutoPostback | Specifies whether the Tab control should perform postback automatically when active tab is changed.
Public Property | BackColor | Overridden. Color of the background of the control.
Public Property | BorderColor | Overridden. Color of the border around the control.
Public Property | BorderStyle | Overridden. Style of the border around the control.
Public Property | BorderWidth | Overridden. Width of the border around the control.
Public Property | CaptionDisplayMode | Gets or sets the default display mode of Tab Item.
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ClientSideEvents | Contains client side events for the Tab control.
Public Property | CloseIndicatorPosition |
Public Property | ComplexImagesSettings | Contains settings of complex images for the Tab control. The settings are applicable when RenderMode is set to UseComplexImages.
Public Property | ContainerDropShadow | Specifies whether drop shadow effect should be applied to container part the Tab control. (only applicable to IE browser).
Public Property | ContainerStyle | Gets or sets the style applied to Container part of the Tab control.
Public Property | ContentMode | Gets or sets the content mode of the Tab control.
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | DefaultTabItemHeight | Gets or sets the default TabItem height in Unit.
Public Property | DefaultTabItemWidth | Gets or sets the default TabItem's width (applicable when SizeMode is set to Fixed).
Public Property | DefaultTabSeparatorWidth | Gets or sets the default tab separator's width in Unit.
Public Property | DisabledStyle | Gets or sets the style for disabled Tab.
Public Property | Enabled | Enable state of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableKeyboardNavigation | Specifies whether users can navigate the Tab using keyboard.
Public Property | EnableManagedTheming | Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to False, this control will not apply the style defined in Theme Architecture. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | Whether the control automatically saves its state for use in round-trips. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Font | Overridden. The font used for text within the control.
Public Property | ForeColor | Overridden. Color of the text within the control.
Public Property | FrameStyle | Gets or sets the style applied to Frame.
Public Property | Height | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | IFrameAllowTransparency | Specifies whether the IFRAME should allow transparency. This property is applicable when ContentMode is set to UseIFrame.
Public Property | IFrameAutoLoadContent | Specifies whether the IFrame content will be loaded automatically on first page load. This property is applicable when ContentMode is set to UseIFrame.
Public Property | IFrameShowLoader | Specifies whether to show loader text when the active IFrame is in loading progress. This property only applicables when ContentMode is set to UseIFrame.
Public Property | ImageAlignment | Gets or sets the default image alignment of Tab Item (applicable when DisplayMode is set to TextAndImage).
Public Property | ImagesDirectory | Gets or sets the location of images used to render the Tab control.
Public Property | ImagesSettings | Contains images settings such as Images Folder and images to render the Tab control.
Public Property | NormalTabOffset | Specifies the offset of Normal Tab in Pixel. The offset will cause the normal tabs to be rendered below Active Tab.
Public Property | Orientation | Gets or sets the Orientation of the Tab control. Reserver for future version.
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Position | Gets or sets the Position of the Tab control. (Top or Bottom is applicable when Orientation is Horizontal, Left or Right is applicable for Vertical)
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RenderMode | Gets or sets the rendering mode of Tab control.
Public Property | RoundCornerSettings | Gets or sets the round corner settings. The settings are applicable when RenderMode is set to UseRoundCorner.
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden. Gets or sets the directory where all required scripts for the control are stored.
Public Property | SharedScriptDirectory | Overridden. Gets or sets the directory where all shared scripts for Intersoft controls are stored.
Public Property | ShowFocusBorder | Gets or sets whether to show border around the Active Tab. This property is recommended for Accessibility and Section 508 Compliant.
Public Property | SizeMode | Gets or sets the sizing mode of the Tab control.
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | The tab order of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | TabItemImageStyle | Gets or sets the style applied to TabItem's Image (DisplayMode is set to TextAndImage or Image)
Public Property | TabItemStyle | Gets or sets the interactive style applied to Tab Item.
Public Property | TabPages | Gets or sets the collection containing Tab Items.
Public Property | TabSeparator | Specifies whether Separator should be rendered between Tab Items.
Public Property | TabSeparatorStyle | Gets or sets the style applied to Tab Separator.
Public Property | TextDirection | Gets or sets the direction of the text in each TabItem.
Public Property | TextSettings | Contains text settings used by the Tab control.
Public Property | ToolTip | The tooltip displayed when the mouse is over the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | TrimSeparatorsWhenActive | Specifies whether the separators near the Active Tab should be removed.
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateItems | Gets or sets the items to be stored in view state storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | Gets or sets the server connection string for file server-based viewstate storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | Gets or sets the location to store the viewstate of this control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | Indicates whether the control is visible and rendered. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Width | The width of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | XmlCompressionEnabled | Specifies whether the Xml used for clientside state storage should be compressed. (Inherited from ISNet.WebUI.ISNetControl)
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CheckConstrains | Overridden.
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. Overridden.
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPostData | Overridden.
Public Method | LoadTabsStructureFromXml | Overloaded. Loads Tabs structure from a XML file and restore it to TabPages of current WebTab.
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnTabChanged |
Public Method | RaisePostBackEvent |
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RecreateChildControls |
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveTabsStructureToXml | Overloaded. Saves WebTabCollection collection to a XML file.
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetTabPages |
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SynchronizeTemplatesFrom |
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | TabChanged | Occurs when the tab is changed.
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebTab Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Creating Simple Tab
Creating Overlapped Edges Tab

tasks

Configuring Scrolling Tab mode
Configuring Closable Tab mode
Changing Tab Position
Saving and Loading Structure Programmatically

Concepts

WebTab Overview

concepts

WebTab Features
Understanding Tab Concepts
Enabling TrueShape rendering
Working with Complex Images


WebTab Constructor

[image]
Intersoft WebDesktop Documentation
WebTab Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : WebTab Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTab()
C#
public WebTab()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


ApplyStyle Method

[image]
Intersoft WebDesktop Documentation
ApplyStyle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : ApplyStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ApplyStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim s As System.Web.UI.WebControls.Style

instance.ApplyStyle(s)
C#
public void ApplyStyle(
   System.Web.UI.WebControls.Style s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


ApplyStyleSheetSkin Method

[image]
Intersoft WebDesktop Documentation
ApplyStyleSheetSkin Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : ApplyStyleSheetSkin Method

page

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub ApplyStyleSheetSkin( _
   ByVal page As System.Web.UI.Page _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim page As System.Web.UI.Page

instance.ApplyStyleSheetSkin(page)
C#
public virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page page
)

Parameters

page

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


CanUseWebResources Method

[image]
Intersoft WebDesktop Documentation
CanUseWebResources Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : CanUseWebResources Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CanUseWebResources() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As Boolean

value = instance.CanUseWebResources()
C#
public bool CanUseWebResources()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


WebTab Class Methods

[image]
Intersoft WebDesktop Documentation
WebTab Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebTab Class

Glossary Item Box

For a list of all members of this type, see WebTab members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CheckConstrains | Overridden.
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. Overridden.
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPostData | Overridden.
Public Method | LoadTabsStructureFromXml | Overloaded. Loads Tabs structure from a XML file and restore it to TabPages of current WebTab.
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnTabChanged |
Public Method | RaisePostBackEvent |
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RecreateChildControls |
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveTabsStructureToXml | Overloaded. Saves WebTabCollection collection to a XML file.
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetTabPages |
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SynchronizeTemplatesFrom |
Top

See Also

Reference

WebTab Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Creating Simple Tab
Creating Overlapped Edges Tab

tasks

Configuring Scrolling Tab mode
Configuring Closable Tab mode
Changing Tab Position
Saving and Loading Structure Programmatically

Concepts

WebTab Overview

concepts

WebTab Features
Understanding Tab Concepts
Enabling TrueShape rendering
Working with Complex Images


CheckConstrains Method

[image]
Intersoft WebDesktop Documentation
CheckConstrains Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : CheckConstrains Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub CheckConstrains()
Visual Basic (Usage) Copy Code
Dim instance As WebTab

instance.CheckConstrains()
C#
public override void CheckConstrains()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


CopyBaseAttributes Method

[image]
Intersoft WebDesktop Documentation
CopyBaseAttributes Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : CopyBaseAttributes Method

controlSrc

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyBaseAttributes( _
   ByVal controlSrc As System.Web.UI.WebControls.WebControl _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim controlSrc As System.Web.UI.WebControls.WebControl

instance.CopyBaseAttributes(controlSrc)
C#
public void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl controlSrc
)

Parameters

controlSrc

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object,Boolean) |
CopyFrom(Object) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public override void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members
Overload List


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members
Overload List


DataBind Method

[image]
Intersoft WebDesktop Documentation
DataBind Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : DataBind Method

Glossary Item Box

Overload List

Overload | Description
DataBind | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


DataBind() Method

[image]
Intersoft WebDesktop Documentation
DataBind() Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : DataBind() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub DataBind()
Visual Basic (Usage) Copy Code
Dim instance As WebTab

instance.DataBind()
C#
public virtual void DataBind()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


Dispose Method

[image]
Intersoft WebDesktop Documentation
Dispose Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : Dispose Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As WebTab

instance.Dispose()
C#
public virtual void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


FindControl Method

[image]
Intersoft WebDesktop Documentation
FindControl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : FindControl Method

Glossary Item Box

Overload List

Overload | Description
FindControl | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


FindControl(String) Method

[image]
Intersoft WebDesktop Documentation
FindControl(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : FindControl(String) Method

id

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function FindControl( _
   ByVal id As String _
) As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim id As String
Dim value As System.Web.UI.Control

value = instance.FindControl(id)
C#
public virtual System.Web.UI.Control FindControl(
   string id
)

Parameters

id

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


Focus Method

[image]
Intersoft WebDesktop Documentation
Focus Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : Focus Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Focus()
Visual Basic (Usage) Copy Code
Dim instance As WebTab

instance.Focus()
C#
public virtual void Focus()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


ForceDisableXmlCompression Method

[image]
Intersoft WebDesktop Documentation
ForceDisableXmlCompression Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : ForceDisableXmlCompression Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ForceDisableXmlCompression()
Visual Basic (Usage) Copy Code
Dim instance As WebTab

instance.ForceDisableXmlCompression()
C#
public void ForceDisableXmlCompression()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


GetCurrentControlLifeCycle Method

[image]
Intersoft WebDesktop Documentation
GetCurrentControlLifeCycle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : GetCurrentControlLifeCycle Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentControlLifeCycle() As ISNet.WebUI.ControlLifeCycle
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As ISNet.WebUI.ControlLifeCycle

value = instance.GetCurrentControlLifeCycle()
C#
public ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


GetCurrentTheme Method

[image]
Intersoft WebDesktop Documentation
GetCurrentTheme Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : GetCurrentTheme Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentTheme() As ISNet.WebUI.ThemeInfo
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As ISNet.WebUI.ThemeInfo

value = instance.GetCurrentTheme()
C#
public ISNet.WebUI.ThemeInfo GetCurrentTheme()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


GetFrameworkDataFolder Method

[image]
Intersoft WebDesktop Documentation
GetFrameworkDataFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : GetFrameworkDataFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkDataFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As String

value = instance.GetFrameworkDataFolder()
C#
public string GetFrameworkDataFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


GetFrameworkFolder Method

[image]
Intersoft WebDesktop Documentation
GetFrameworkFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : GetFrameworkFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As String

value = instance.GetFrameworkFolder()
C#
public string GetFrameworkFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


GetFrameworkVersion Method

[image]
Intersoft WebDesktop Documentation
GetFrameworkVersion Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : GetFrameworkVersion Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkVersion() As Version
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As Version

value = instance.GetFrameworkVersion()
C#
public Version GetFrameworkVersion()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


GetIntersoftFolder Method

[image]
Intersoft WebDesktop Documentation
GetIntersoftFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : GetIntersoftFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetIntersoftFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As String

value = instance.GetIntersoftFolder()
C#
public string GetIntersoftFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


GetLayoutFolder Method

[image]
Intersoft WebDesktop Documentation
GetLayoutFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : GetLayoutFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetLayoutFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As String

value = instance.GetLayoutFolder()
C#
public string GetLayoutFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


GetPostedXMLData Method

[image]
Intersoft WebDesktop Documentation
GetPostedXMLData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : GetPostedXMLData Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPostedXMLData() As String
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As String

value = instance.GetPostedXMLData()
C#
public string GetPostedXMLData()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


GetProductInfoKey Method

[image]
Intersoft WebDesktop Documentation
GetProductInfoKey Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : GetProductInfoKey Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductInfoKey() As String
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As String

value = instance.GetProductInfoKey()
C#
public string GetProductInfoKey()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


GetProductSimpleName Method

[image]
Intersoft WebDesktop Documentation
GetProductSimpleName Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : GetProductSimpleName Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductSimpleName() As String
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As String

value = instance.GetProductSimpleName()
C#
public string GetProductSimpleName()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


GetPropertyValue Method

[image]
Intersoft WebDesktop Documentation
GetPropertyValue Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : GetPropertyValue Method

defValue
propValue
webConfigKey

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPropertyValue( _
   ByVal defValue As String, _
   ByVal propValue As String, _
   ByVal webConfigKey As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim defValue As String
Dim propValue As String
Dim webConfigKey As String
Dim value As String

value = instance.GetPropertyValue(defValue, propValue, webConfigKey)
C#
public string GetPropertyValue(
   string defValue,
   string propValue,
   string webConfigKey
)

Parameters

defValue
propValue
webConfigKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


GetResourceStream Method

[image]
Intersoft WebDesktop Documentation
GetResourceStream Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : GetResourceStream Method

resourceUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetResourceStream( _
   ByVal resourceUrl As String _
) As System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim resourceUrl As String
Dim value As System.IO.Stream

value = instance.GetResourceStream(resourceUrl)
C#
public System.IO.Stream GetResourceStream(
   string resourceUrl
)

Parameters

resourceUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


GetRouteUrl Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : GetRouteUrl Method

Glossary Item Box

Overload List

Overload | Description
GetRouteUrl(Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(RouteValueDictionary) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,RouteValueDictionary) | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


GetRouteUrl(Object) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class > GetRouteUrl Method : GetRouteUrl(Object) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As Object _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim routeParameters As Object
Dim value As String

value = instance.GetRouteUrl(routeParameters)
C#
public string GetRouteUrl(
   object routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members
Overload List


GetRouteUrl(String,Object) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(String,Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class > GetRouteUrl Method : GetRouteUrl(String,Object) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As String, _
   ByVal routeParameters As Object _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim routeName As String
Dim routeParameters As Object
Dim value As String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public string GetRouteUrl(
   string routeName,
   object routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members
Overload List


GetRouteUrl(RouteValueDictionary) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(RouteValueDictionary) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class > GetRouteUrl Method : GetRouteUrl(RouteValueDictionary) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As String

value = instance.GetRouteUrl(routeParameters)
C#
public string GetRouteUrl(
   System.Web.Routing.RouteValueDictionary routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members
Overload List


GetRouteUrl(String,RouteValueDictionary) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(String,RouteValueDictionary) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class > GetRouteUrl Method : GetRouteUrl(String,RouteValueDictionary) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As String, _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim routeName As String
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public string GetRouteUrl(
   string routeName,
   System.Web.Routing.RouteValueDictionary routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members
Overload List


GetUniqueIDRelativeTo Method

[image]
Intersoft WebDesktop Documentation
GetUniqueIDRelativeTo Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : GetUniqueIDRelativeTo Method

control

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetUniqueIDRelativeTo( _
   ByVal control As System.Web.UI.Control _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim control As System.Web.UI.Control
Dim value As String

value = instance.GetUniqueIDRelativeTo(control)
C#
public string GetUniqueIDRelativeTo(
   System.Web.UI.Control control
)

Parameters

control

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


HasControls Method

[image]
Intersoft WebDesktop Documentation
HasControls Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : HasControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function HasControls() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As Boolean

value = instance.HasControls()
C#
public virtual bool HasControls()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


IsAtlasCallback Method

[image]
Intersoft WebDesktop Documentation
IsAtlasCallback Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : IsAtlasCallback Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsAtlasCallback() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As Boolean

value = instance.IsAtlasCallback()
C#
public bool IsAtlasCallback()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


IsBetaRelease Method

[image]
Intersoft WebDesktop Documentation
IsBetaRelease Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : IsBetaRelease Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsBetaRelease() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As Boolean

value = instance.IsBetaRelease()
C#
public bool IsBetaRelease()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


IsChromeBrowser Method

[image]
Intersoft WebDesktop Documentation
IsChromeBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : IsChromeBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsChromeBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As Boolean

value = instance.IsChromeBrowser()
C#
public bool IsChromeBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


IsFlyPostBackControl Method

[image]
Intersoft WebDesktop Documentation
IsFlyPostBackControl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : IsFlyPostBackControl Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackControl() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As Boolean

value = instance.IsFlyPostBackControl()
C#
public virtual bool IsFlyPostBackControl()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


IsFlyPostBackRequest Method

[image]
Intersoft WebDesktop Documentation
IsFlyPostBackRequest Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : IsFlyPostBackRequest Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackRequest() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As Boolean

value = instance.IsFlyPostBackRequest()
C#
public virtual bool IsFlyPostBackRequest()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


IsGeckoBasedBrowser Method

[image]
Intersoft WebDesktop Documentation
IsGeckoBasedBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : IsGeckoBasedBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoBasedBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As Boolean

value = instance.IsGeckoBasedBrowser()
C#
public bool IsGeckoBasedBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


IsGeckoVersion18 Method

[image]
Intersoft WebDesktop Documentation
IsGeckoVersion18 Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : IsGeckoVersion18 Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoVersion18() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As Boolean

value = instance.IsGeckoVersion18()
C#
public bool IsGeckoVersion18()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


IsInDesignMode Method

[image]
Intersoft WebDesktop Documentation
IsInDesignMode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : IsInDesignMode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInDesignMode() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As Boolean

value = instance.IsInDesignMode()
C#
public bool IsInDesignMode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


IsInternetExplorer8Browser Method

[image]
Intersoft WebDesktop Documentation
IsInternetExplorer8Browser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : IsInternetExplorer8Browser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorer8Browser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As Boolean

value = instance.IsInternetExplorer8Browser()
C#
public bool IsInternetExplorer8Browser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


IsInternetExplorerBrowser Method

[image]
Intersoft WebDesktop Documentation
IsInternetExplorerBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : IsInternetExplorerBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorerBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As Boolean

value = instance.IsInternetExplorerBrowser()
C#
public bool IsInternetExplorerBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


IsOperaBrowser Method

[image]
Intersoft WebDesktop Documentation
IsOperaBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : IsOperaBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsOperaBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As Boolean

value = instance.IsOperaBrowser()
C#
public bool IsOperaBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


IsSafariBrowser Method

[image]
Intersoft WebDesktop Documentation
IsSafariBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : IsSafariBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsSafariBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As Boolean

value = instance.IsSafariBrowser()
C#
public bool IsSafariBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


IsW3CStandardBrowser Method

[image]
Intersoft WebDesktop Documentation
IsW3CStandardBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : IsW3CStandardBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsW3CStandardBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As Boolean

value = instance.IsW3CStandardBrowser()
C#
public bool IsW3CStandardBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


LoadLayout Method

[image]
Intersoft WebDesktop Documentation
LoadLayout Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : LoadLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim settings As ISNet.WebUI.LayoutInfo

instance.LoadLayout(settings)
C#
public virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


LoadLayoutFromFile Method

[image]
Intersoft WebDesktop Documentation
LoadLayoutFromFile Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : LoadLayoutFromFile Method

filePath

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromFile( _
   ByVal filePath As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim filePath As String

instance.LoadLayoutFromFile(filePath)
C#
public virtual void LoadLayoutFromFile(
   string filePath
)

Parameters

filePath

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


LoadLayoutFromPredefinedName Method

[image]
Intersoft WebDesktop Documentation
LoadLayoutFromPredefinedName Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : LoadLayoutFromPredefinedName Method

predefinedName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromPredefinedName( _
   ByVal predefinedName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim predefinedName As String

instance.LoadLayoutFromPredefinedName(predefinedName)
C#
public virtual void LoadLayoutFromPredefinedName(
   string predefinedName
)

Parameters

predefinedName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


LoadLayoutFromStream Method

[image]
Intersoft WebDesktop Documentation
LoadLayoutFromStream Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : LoadLayoutFromStream Method

stream

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromStream( _
   ByVal stream As System.IO.Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim stream As System.IO.Stream

instance.LoadLayoutFromStream(stream)
C#
public virtual void LoadLayoutFromStream(
   System.IO.Stream stream
)

Parameters

stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


LoadPostData Method

[image]
Intersoft WebDesktop Documentation
LoadPostData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : LoadPostData Method

postDataKey
postCollection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function LoadPostData( _
   ByVal postDataKey As String, _
   ByVal postCollection As System.Collections.Specialized.NameValueCollection _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim postDataKey As String
Dim postCollection As System.Collections.Specialized.NameValueCollection
Dim value As Boolean

value = instance.LoadPostData(postDataKey, postCollection)
C#
public override bool LoadPostData(
   string postDataKey,
   System.Collections.Specialized.NameValueCollection postCollection
)

Parameters

postDataKey
postCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


LoadTabsStructureFromXml Method

[image]
Intersoft WebDesktop Documentation
LoadTabsStructureFromXml Method
See Also Example Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : LoadTabsStructureFromXml Method

Glossary Item Box

Loads Tabs structure from a XML file and restore it to TabPages of current WebTab. Loads Tabs structure from a XML file and restore it to TabPages of current WebTab.

Overload List

Overload | Description
LoadTabsStructureFromXml(Stream) | Loads Tabs structure from a XML file and restore it to TabPages of current WebTab.
LoadTabsStructureFromXml(String) | Loads Tabs structure from a XML file and restore it to TabPages of current WebTab.

Example

The following example shows you how to load structure of WebTab programmatically. You need to insert the codes below OnClick Server Side Event. For more information please refer to Saving and Loading Structure Programmatically in See Also section
C# Copy Code
protected void Button1_Click(object sender, EventArgs e)
{
    WebTab2.LoadTabsStructureFromXml("Style1.xml");
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members

Tasks

Saving and Loading Structure Programmatically


LoadTabsStructureFromXml(Stream) Method

[image]
Intersoft WebDesktop Documentation
LoadTabsStructureFromXml(Stream) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class > LoadTabsStructureFromXml Method : LoadTabsStructureFromXml(Stream) Method

stream

Glossary Item Box

Loads Tabs structure from a XML file and restore it to TabPages of current WebTab.

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadTabsStructureFromXml( _
   ByVal stream As System.IO.Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim stream As System.IO.Stream

instance.LoadTabsStructureFromXml(stream)
C#
public void LoadTabsStructureFromXml(
   System.IO.Stream stream
)

Parameters

stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members
Overload List


LoadTabsStructureFromXml(String) Method

[image]
Intersoft WebDesktop Documentation
LoadTabsStructureFromXml(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class > LoadTabsStructureFromXml Method : LoadTabsStructureFromXml(String) Method

fileName

Glossary Item Box

Loads Tabs structure from a XML file and restore it to TabPages of current WebTab.

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadTabsStructureFromXml( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim fileName As String

instance.LoadTabsStructureFromXml(fileName)
C#
public void LoadTabsStructureFromXml(
   string fileName
)

Parameters

fileName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members
Overload List


MergeStyle Method

[image]
Intersoft WebDesktop Documentation
MergeStyle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : MergeStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub MergeStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim s As System.Web.UI.WebControls.Style

instance.MergeStyle(s)
C#
public void MergeStyle(
   System.Web.UI.WebControls.Style s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


OnInfoChanged Method

[image]
Intersoft WebDesktop Documentation
OnInfoChanged Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : OnInfoChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnInfoChanged( _
   ByVal e As ISNet.WebUI.SynchronizeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim e As ISNet.WebUI.SynchronizeEventArgs

instance.OnInfoChanged(e)
C#
public void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


OnPreInitialize Method

[image]
Intersoft WebDesktop Documentation
OnPreInitialize Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : OnPreInitialize Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnPreInitialize()
Visual Basic (Usage) Copy Code
Dim instance As WebTab

instance.OnPreInitialize()
C#
public virtual void OnPreInitialize()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


OnTabChanged Method

[image]
Intersoft WebDesktop Documentation
OnTabChanged Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : OnTabChanged Method

fromTab
toTab

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function OnTabChanged( _
   ByVal fromTab As WebTabItem, _
   ByVal toTab As WebTabItem _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim fromTab As WebTabItem
Dim toTab As WebTabItem
Dim value As Boolean

value = instance.OnTabChanged(fromTab, toTab)
C#
public virtual bool OnTabChanged(
   WebTabItem fromTab,
   WebTabItem toTab
)

Parameters

fromTab
toTab

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


RaisePostBackEvent Method

[image]
Intersoft WebDesktop Documentation
RaisePostBackEvent Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : RaisePostBackEvent Method

eventArgument

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RaisePostBackEvent( _
   ByVal eventArgument As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim eventArgument As String

instance.RaisePostBackEvent(eventArgument)
C#
public void RaisePostBackEvent(
   string eventArgument
)

Parameters

eventArgument

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


RaisePostDataChangedEvent Method

[image]
Intersoft WebDesktop Documentation
RaisePostDataChangedEvent Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : RaisePostDataChangedEvent Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RaisePostDataChangedEvent()
Visual Basic (Usage) Copy Code
Dim instance As WebTab

instance.RaisePostDataChangedEvent()
C#
public virtual void RaisePostDataChangedEvent()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


ReadWebConfigValue Method

[image]
Intersoft WebDesktop Documentation
ReadWebConfigValue Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : ReadWebConfigValue Method

key

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ReadWebConfigValue( _
   ByVal key As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim key As String
Dim value As String

value = instance.ReadWebConfigValue(key)
C#
public string ReadWebConfigValue(
   string key
)

Parameters

key

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


RecreateChildControls Method

[image]
Intersoft WebDesktop Documentation
RecreateChildControls Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : RecreateChildControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RecreateChildControls()
Visual Basic (Usage) Copy Code
Dim instance As WebTab

instance.RecreateChildControls()
C#
public void RecreateChildControls()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


RegisterBoxSizing Method

[image]
Intersoft WebDesktop Documentation
RegisterBoxSizing Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : RegisterBoxSizing Method

Glossary Item Box

Overload List

Overload | Description
RegisterBoxSizing() | (Inherited from ISNet.WebUI.ISNetControl)
RegisterBoxSizing(Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


RegisterBoxSizing() Method

[image]
Intersoft WebDesktop Documentation
RegisterBoxSizing() Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class > RegisterBoxSizing Method : RegisterBoxSizing() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing()
Visual Basic (Usage) Copy Code
Dim instance As WebTab

instance.RegisterBoxSizing()
C#
public void RegisterBoxSizing()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members
Overload List


RegisterBoxSizing(Boolean) Method

[image]
Intersoft WebDesktop Documentation
RegisterBoxSizing(Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class > RegisterBoxSizing Method : RegisterBoxSizing(Boolean) Method

forceAll

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing( _
   ByVal forceAll As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim forceAll As Boolean

instance.RegisterBoxSizing(forceAll)
C#
public void RegisterBoxSizing(
   bool forceAll
)

Parameters

forceAll

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members
Overload List


RegisterGlobalStyle Method

[image]
Intersoft WebDesktop Documentation
RegisterGlobalStyle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : RegisterGlobalStyle Method

style

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterGlobalStyle( _
   ByVal style As ISNet.WebUI.WebStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim style As ISNet.WebUI.WebStyle

instance.RegisterGlobalStyle(style)
C#
public void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle style
)

Parameters

style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


RegisterLink Method

[image]
Intersoft WebDesktop Documentation
RegisterLink Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : RegisterLink Method

name
url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterLink( _
   ByVal name As String, _
   ByVal url As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim name As String
Dim url As String

instance.RegisterLink(name, url)
C#
public void RegisterLink(
   string name,
   string url
)

Parameters

name
url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


RegisterOptimizedCssClasses Method

[image]
Intersoft WebDesktop Documentation
RegisterOptimizedCssClasses Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : RegisterOptimizedCssClasses Method

runtimeStyleOnly

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterOptimizedCssClasses( _
   ByVal runtimeStyleOnly As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim runtimeStyleOnly As Boolean

instance.RegisterOptimizedCssClasses(runtimeStyleOnly)
C#
public void RegisterOptimizedCssClasses(
   bool runtimeStyleOnly
)

Parameters

runtimeStyleOnly

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


RegisterPreloadImage Method

[image]
Intersoft WebDesktop Documentation
RegisterPreloadImage Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : RegisterPreloadImage Method

image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterPreloadImage( _
   ByVal image As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim image As String

instance.RegisterPreloadImage(image)
C#
public void RegisterPreloadImage(
   string image
)

Parameters

image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


RegisterSharePointHandler Method

[image]
Intersoft WebDesktop Documentation
RegisterSharePointHandler Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : RegisterSharePointHandler Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RegisterSharePointHandler()
Visual Basic (Usage) Copy Code
Dim instance As WebTab

instance.RegisterSharePointHandler()
C#
public virtual void RegisterSharePointHandler()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


RenderBeginTag Method

[image]
Intersoft WebDesktop Documentation
RenderBeginTag Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : RenderBeginTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderBeginTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderBeginTag(writer)
C#
public virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


RenderControl Method

[image]
Intersoft WebDesktop Documentation
RenderControl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : RenderControl Method

Glossary Item Box

Overload List

Overload | Description
RenderControl | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


RenderControl(HtmlTextWriter) Method

[image]
Intersoft WebDesktop Documentation
RenderControl(HtmlTextWriter) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : RenderControl(HtmlTextWriter) Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderControl( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderControl(writer)
C#
public virtual void RenderControl(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


RenderEndTag Method

[image]
Intersoft WebDesktop Documentation
RenderEndTag Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : RenderEndTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub RenderEndTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderEndTag(writer)
C#
public override void RenderEndTag(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebTab

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


ResolveClientUrl Method

[image]
Intersoft WebDesktop Documentation
ResolveClientUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : ResolveClientUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveClientUrl( _
   ByVal relativeUrl As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim relativeUrl As String
Dim value As String

value = instance.ResolveClientUrl(relativeUrl)
C#
public string ResolveClientUrl(
   string relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


ResolveImagePath Method

[image]
Intersoft WebDesktop Documentation
ResolveImagePath Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : ResolveImagePath Method

folder
image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveImagePath( _
   ByVal folder As String, _
   ByVal image As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim folder As String
Dim image As String
Dim value As String

value = instance.ResolveImagePath(folder, image)
C#
public string ResolveImagePath(
   string folder,
   string image
)

Parameters

folder
image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


ResolveRelativeURL Method

[image]
Intersoft WebDesktop Documentation
ResolveRelativeURL Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : ResolveRelativeURL Method

url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ResolveRelativeURL( _
   ByVal url As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim url As String
Dim value As String

value = instance.ResolveRelativeURL(url)
C#
public virtual string ResolveRelativeURL(
   string url
)

Parameters

url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


ResolveResourceUrl Method

[image]
Intersoft WebDesktop Documentation
ResolveResourceUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : ResolveResourceUrl Method

kind
defaultFolder
currentFolder
resourceName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveResourceUrl( _
   ByVal kind As ISNet.WebUI.ResourceKind, _
   ByVal defaultFolder As String, _
   ByVal currentFolder As String, _
   ByVal resourceName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim kind As ISNet.WebUI.ResourceKind
Dim defaultFolder As String
Dim currentFolder As String
Dim resourceName As String
Dim value As String

value = instance.ResolveResourceUrl(kind, defaultFolder, currentFolder, resourceName)
C#
public string ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   string defaultFolder,
   string currentFolder,
   string resourceName
)

Parameters

kind
defaultFolder
currentFolder
resourceName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


ResolveUrl Method

[image]
Intersoft WebDesktop Documentation
ResolveUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : ResolveUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveUrl( _
   ByVal relativeUrl As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim relativeUrl As String
Dim value As String

value = instance.ResolveUrl(relativeUrl)
C#
public string ResolveUrl(
   string relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


SaveLayout Method

[image]
Intersoft WebDesktop Documentation
SaveLayout Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : SaveLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim settings As ISNet.WebUI.LayoutInfo

instance.SaveLayout(settings)
C#
public virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


SaveLayoutToFile Method

[image]
Intersoft WebDesktop Documentation
SaveLayoutToFile Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : SaveLayoutToFile Method

filePath
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToFile( _
   ByVal filePath As String, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim filePath As String
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToFile(filePath, saveOptions)
C#
public virtual void SaveLayoutToFile(
   string filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

filePath
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


SaveLayoutToStream Method

[image]
Intersoft WebDesktop Documentation
SaveLayoutToStream Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : SaveLayoutToStream Method

stream
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToStream( _
   ByVal stream As System.IO.Stream, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim stream As System.IO.Stream
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToStream(stream, saveOptions)
C#
public virtual void SaveLayoutToStream(
   System.IO.Stream stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

stream
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


SaveTabsStructureToXml Method

[image]
Intersoft WebDesktop Documentation
SaveTabsStructureToXml Method
See Also Example Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : SaveTabsStructureToXml Method

Glossary Item Box

Saves WebTabCollection collection to a XML file. Saves WebTabCollection collection to a XML file.

Overload List

Overload | Description
SaveTabsStructureToXml(String) | Saves WebTabCollection collection to a XML file.
SaveTabsStructureToXml() | Saves WebTabCollection collection to a XmlDocument instance.

Example

The following example shows you how to save structure of WebTab programmatically. You need to insert the codes below OnClick Server Side Event. For more information please refer to Saving and Loading Structure Programmatically in See Also section
C# Copy Code
protected void Button1_Click(object sender, EventArgs e)
{
    WebTab1.SaveTabsStructureFromXml("Style1.xml");
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members

Tasks

Saving and Loading Structure Programmatically


SaveTabsStructureToXml(String) Method

[image]
Intersoft WebDesktop Documentation
SaveTabsStructureToXml(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class > SaveTabsStructureToXml Method : SaveTabsStructureToXml(String) Method

fileName

Glossary Item Box

Saves WebTabCollection collection to a XML file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SaveTabsStructureToXml( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim fileName As String

instance.SaveTabsStructureToXml(fileName)
C#
public void SaveTabsStructureToXml(
   string fileName
)

Parameters

fileName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members
Overload List


SaveTabsStructureToXml() Method

[image]
Intersoft WebDesktop Documentation
SaveTabsStructureToXml() Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class > SaveTabsStructureToXml Method : SaveTabsStructureToXml() Method

Glossary Item Box

Saves WebTabCollection collection to a XmlDocument instance.

Syntax

Visual Basic (Declaration)
Public Overloads Function SaveTabsStructureToXml() As System.Xml.XmlDocument
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As System.Xml.XmlDocument

value = instance.SaveTabsStructureToXml()
C#
public System.Xml.XmlDocument SaveTabsStructureToXml()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members
Overload List


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


SetRenderMethodDelegate Method

[image]
Intersoft WebDesktop Documentation
SetRenderMethodDelegate Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : SetRenderMethodDelegate Method

renderMethod

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetRenderMethodDelegate( _
   ByVal renderMethod As System.Web.UI.RenderMethod _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim renderMethod As System.Web.UI.RenderMethod

instance.SetRenderMethodDelegate(renderMethod)
C#
public void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod renderMethod
)

Parameters

renderMethod

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


SetSessionTheme Method

[image]
Intersoft WebDesktop Documentation
SetSessionTheme Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : SetSessionTheme Method

themeInfo

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetSessionTheme( _
   ByVal themeInfo As ISNet.WebUI.ThemeInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim themeInfo As ISNet.WebUI.ThemeInfo

instance.SetSessionTheme(themeInfo)
C#
public void SetSessionTheme(
   ISNet.WebUI.ThemeInfo themeInfo
)

Parameters

themeInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


SetTabPages Method

[image]
Intersoft WebDesktop Documentation
SetTabPages Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : SetTabPages Method

collection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetTabPages( _
   ByVal collection As WebTabCollection _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim collection As WebTabCollection

instance.SetTabPages(collection)
C#
public void SetTabPages(
   WebTabCollection collection
)

Parameters

collection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


ShouldReturnJson Method

[image]
Intersoft WebDesktop Documentation
ShouldReturnJson Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : ShouldReturnJson Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ShouldReturnJson() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As Boolean

value = instance.ShouldReturnJson()
C#
public virtual bool ShouldReturnJson()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


SynchronizeTemplatesFrom Method

[image]
Intersoft WebDesktop Documentation
SynchronizeTemplatesFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : SynchronizeTemplatesFrom Method

sourceObj

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SynchronizeTemplatesFrom( _
   ByVal sourceObj As ISNet.WebUI.ISNetControl _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim sourceObj As ISNet.WebUI.ISNetControl

instance.SynchronizeTemplatesFrom(sourceObj)
C#
public void SynchronizeTemplatesFrom(
   ISNet.WebUI.ISNetControl sourceObj
)

Parameters

sourceObj

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


AccessKey Property

[image]
Intersoft WebDesktop Documentation
AccessKey Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : AccessKey Property

Glossary Item Box

Keyboard shortcut used by the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property AccessKey As String
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As String

instance.AccessKey = value

value = instance.AccessKey
C#
public virtual string AccessKey {get; set;}

Remarks

The AccessKey term is similar to Mnemonic key used in WinForm development. For instance, you have the tab header's Text set to "General" and would like user to be able to access the General page by pressing Alt+G, you can then set the AccessKey to "g" (note that AccessKey is case-insensitive). In runtime mode, you will see an underline beneath G character automatically.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members

Concepts

WebTab Features


WebTab Class Properties

[image]
Intersoft WebDesktop Documentation
WebTab Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebTab Class

Glossary Item Box

For a list of all members of this type, see WebTab members.

Public Properties

 | Name | Description
Public Property | AccessKey | Keyboard shortcut used by the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ActiveTabIndex | Gets or sets the active tab index.
Public Property | Alignment | Gets or sets the alignment of the Tab.
Public Property | AllowClose | Gets or sets a value indicating whether users are allowed to close the Tabs.
Public Property | AllowScrolling | Gets or sets a value indicating whether the Tab control should display ScrollButtons when the number of Tab exceeds the controls' width.
Public Property | AllowTextWrapping | Gets or sets whether the Text of TabItem shoudl be wrapped when the width is not sufficient. (Applicable when SizeMode is set to Fixed).
Public Property | AlwaysVisibleSeparator |
Public Property | AutoPostback | Specifies whether the Tab control should perform postback automatically when active tab is changed.
Public Property | BackColor | Overridden. Color of the background of the control.
Public Property | BorderColor | Overridden. Color of the border around the control.
Public Property | BorderStyle | Overridden. Style of the border around the control.
Public Property | BorderWidth | Overridden. Width of the border around the control.
Public Property | CaptionDisplayMode | Gets or sets the default display mode of Tab Item.
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ClientSideEvents | Contains client side events for the Tab control.
Public Property | CloseIndicatorPosition |
Public Property | ComplexImagesSettings | Contains settings of complex images for the Tab control. The settings are applicable when RenderMode is set to UseComplexImages.
Public Property | ContainerDropShadow | Specifies whether drop shadow effect should be applied to container part the Tab control. (only applicable to IE browser).
Public Property | ContainerStyle | Gets or sets the style applied to Container part of the Tab control.
Public Property | ContentMode | Gets or sets the content mode of the Tab control.
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | DefaultTabItemHeight | Gets or sets the default TabItem height in Unit.
Public Property | DefaultTabItemWidth | Gets or sets the default TabItem's width (applicable when SizeMode is set to Fixed).
Public Property | DefaultTabSeparatorWidth | Gets or sets the default tab separator's width in Unit.
Public Property | DisabledStyle | Gets or sets the style for disabled Tab.
Public Property | Enabled | Enable state of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableKeyboardNavigation | Specifies whether users can navigate the Tab using keyboard.
Public Property | EnableManagedTheming | Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to False, this control will not apply the style defined in Theme Architecture. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | Whether the control automatically saves its state for use in round-trips. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Font | Overridden. The font used for text within the control.
Public Property | ForeColor | Overridden. Color of the text within the control.
Public Property | FrameStyle | Gets or sets the style applied to Frame.
Public Property | Height | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | IFrameAllowTransparency | Specifies whether the IFRAME should allow transparency. This property is applicable when ContentMode is set to UseIFrame.
Public Property | IFrameAutoLoadContent | Specifies whether the IFrame content will be loaded automatically on first page load. This property is applicable when ContentMode is set to UseIFrame.
Public Property | IFrameShowLoader | Specifies whether to show loader text when the active IFrame is in loading progress. This property only applicables when ContentMode is set to UseIFrame.
Public Property | ImageAlignment | Gets or sets the default image alignment of Tab Item (applicable when DisplayMode is set to TextAndImage).
Public Property | ImagesDirectory | Gets or sets the location of images used to render the Tab control.
Public Property | ImagesSettings | Contains images settings such as Images Folder and images to render the Tab control.
Public Property | NormalTabOffset | Specifies the offset of Normal Tab in Pixel. The offset will cause the normal tabs to be rendered below Active Tab.
Public Property | Orientation | Gets or sets the Orientation of the Tab control. Reserver for future version.
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Position | Gets or sets the Position of the Tab control. (Top or Bottom is applicable when Orientation is Horizontal, Left or Right is applicable for Vertical)
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RenderMode | Gets or sets the rendering mode of Tab control.
Public Property | RoundCornerSettings | Gets or sets the round corner settings. The settings are applicable when RenderMode is set to UseRoundCorner.
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden. Gets or sets the directory where all required scripts for the control are stored.
Public Property | SharedScriptDirectory | Overridden. Gets or sets the directory where all shared scripts for Intersoft controls are stored.
Public Property | ShowFocusBorder | Gets or sets whether to show border around the Active Tab. This property is recommended for Accessibility and Section 508 Compliant.
Public Property | SizeMode | Gets or sets the sizing mode of the Tab control.
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | The tab order of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | TabItemImageStyle | Gets or sets the style applied to TabItem's Image (DisplayMode is set to TextAndImage or Image)
Public Property | TabItemStyle | Gets or sets the interactive style applied to Tab Item.
Public Property | TabPages | Gets or sets the collection containing Tab Items.
Public Property | TabSeparator | Specifies whether Separator should be rendered between Tab Items.
Public Property | TabSeparatorStyle | Gets or sets the style applied to Tab Separator.
Public Property | TextDirection | Gets or sets the direction of the text in each TabItem.
Public Property | TextSettings | Contains text settings used by the Tab control.
Public Property | ToolTip | The tooltip displayed when the mouse is over the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | TrimSeparatorsWhenActive | Specifies whether the separators near the Active Tab should be removed.
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateItems | Gets or sets the items to be stored in view state storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | Gets or sets the server connection string for file server-based viewstate storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | Gets or sets the location to store the viewstate of this control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | Indicates whether the control is visible and rendered. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Width | The width of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | XmlCompressionEnabled | Specifies whether the Xml used for clientside state storage should be compressed. (Inherited from ISNet.WebUI.ISNetControl)
Top

See Also

Reference

WebTab Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Creating Simple Tab
Creating Overlapped Edges Tab

tasks

Configuring Scrolling Tab mode
Configuring Closable Tab mode
Changing Tab Position
Saving and Loading Structure Programmatically

Concepts

WebTab Overview

concepts

WebTab Features
Understanding Tab Concepts
Enabling TrueShape rendering
Working with Complex Images


WebTab Constructor

[image]
Intersoft WebDesktop Documentation
WebTab Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : WebTab Constructor

Glossary Item Box

Initializes a new instance of the WebTab class.

Overload List

Overload | Description
WebTab Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


ActiveTabIndex Property

[image]
Intersoft WebDesktop Documentation
ActiveTabIndex Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : ActiveTabIndex Property

Glossary Item Box

Gets or sets the active tab index.

Syntax

Visual Basic (Declaration)
Public Property ActiveTabIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As Integer

instance.ActiveTabIndex = value

value = instance.ActiveTabIndex
C#
public int ActiveTabIndex {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


Alignment Property

[image]
Intersoft WebDesktop Documentation
Alignment Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : Alignment Property

Glossary Item Box

Gets or sets the alignment of the Tab.

Syntax

Visual Basic (Declaration)
Public Property Alignment As DisplayAlignment
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As DisplayAlignment

instance.Alignment = value

value = instance.Alignment
C#
public DisplayAlignment Alignment {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


AllowClose Property

[image]
Intersoft WebDesktop Documentation
AllowClose Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : AllowClose Property

Glossary Item Box

Gets or sets a value indicating whether users are allowed to close the Tabs.

Syntax

Visual Basic (Declaration)
Public Property AllowClose As CloseMode
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As CloseMode

instance.AllowClose = value

value = instance.AllowClose
C#
public CloseMode AllowClose {get; set;}

Remarks

By setting this property to True, you can allow your users to to close a Tab item by clicking on a Close button at right end of the Tab control.

When enabled, a Close control will appear at the right end of the Tab control, after the Scroll arrows if AllowScrolling is enabled. When clicked, it will close the currently Active Tab and activate the nearest tab at the right or left side depend on the which is available.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members

Tasks

Configuring Closable Tab mode

Concepts

Understanding Tab Concepts

concepts

WebTab Features


AllowScrolling Property

[image]
Intersoft WebDesktop Documentation
AllowScrolling Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : AllowScrolling Property

Glossary Item Box

Gets or sets a value indicating whether the Tab control should display ScrollButtons when the number of Tab exceeds the controls' width.

Syntax

Visual Basic (Declaration)
Public Property AllowScrolling As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As Boolean

instance.AllowScrolling = value

value = instance.AllowScrolling
C#
public bool AllowScrolling {get; set;}

Remarks

WebTab allows you to create a lot of tab items which might exceed the boundary of the Tab control itself. You can achieve the scenario by simply setting the AllowScrolling property to True. When you set this property to True, a Left and Right arrow will appear at the right end of the Tab control.

The AllowScrolling feature worked in conjunction with Automatic Resizing, that is the arrows will appear as "disabled" when there are no items exceeding the Tab width boundary. However, when later user resized the browser window which cause the Tab control to be smaller than available items, the WebTab will automatically enable the Scroll arrows. Furthermore, any active tab which set from either codes or invoked by keyboard keys will be scrolled into view automatically.

You can customize the Text and Image for the Scroll Arrows in TextSettings and ImagesSettings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members

Tasks

Configuring Scrolling Tab mode

Concepts

Understanding Tab Concepts
WebTab Features


AllowTextWrapping Property

[image]
Intersoft WebDesktop Documentation
AllowTextWrapping Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : AllowTextWrapping Property

Glossary Item Box

Gets or sets whether the Text of TabItem shoudl be wrapped when the width is not sufficient. (Applicable when SizeMode is set to Fixed).

Syntax

Visual Basic (Declaration)
Public Property AllowTextWrapping As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As Boolean

instance.AllowTextWrapping = value

value = instance.AllowTextWrapping
C#
public bool AllowTextWrapping {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


AlwaysVisibleSeparator Property

[image]
Intersoft WebDesktop Documentation
AlwaysVisibleSeparator Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : AlwaysVisibleSeparator Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property AlwaysVisibleSeparator As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As Boolean

instance.AlwaysVisibleSeparator = value

value = instance.AlwaysVisibleSeparator
C#
public bool AlwaysVisibleSeparator {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


AutoPostback Property

[image]
Intersoft WebDesktop Documentation
AutoPostback Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : AutoPostback Property

Glossary Item Box

Specifies whether the Tab control should perform postback automatically when active tab is changed.

Syntax

Visual Basic (Declaration)
Public Property AutoPostback As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As Boolean

instance.AutoPostback = value

value = instance.AutoPostback
C#
public bool AutoPostback {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


BackColor Property

[image]
Intersoft WebDesktop Documentation
BackColor Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : BackColor Property

Glossary Item Box

Color of the background of the control.

Syntax

Visual Basic (Declaration)
Public Overrides Property BackColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
C#
public override System.Drawing.Color BackColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


BorderColor Property

[image]
Intersoft WebDesktop Documentation
BorderColor Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : BorderColor Property

Glossary Item Box

Color of the border around the control.

Syntax

Visual Basic (Declaration)
Public Overrides Property BorderColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As System.Drawing.Color

instance.BorderColor = value

value = instance.BorderColor
C#
public override System.Drawing.Color BorderColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


BorderStyle Property

[image]
Intersoft WebDesktop Documentation
BorderStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : BorderStyle Property

Glossary Item Box

Style of the border around the control.

Syntax

Visual Basic (Declaration)
Public Overrides Property BorderStyle As System.Web.UI.WebControls.BorderStyle
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As System.Web.UI.WebControls.BorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
C#
public override System.Web.UI.WebControls.BorderStyle BorderStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


BorderWidth Property

[image]
Intersoft WebDesktop Documentation
BorderWidth Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : BorderWidth Property

Glossary Item Box

Width of the border around the control.

Syntax

Visual Basic (Declaration)
Public Overrides Property BorderWidth As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As System.Web.UI.WebControls.Unit

instance.BorderWidth = value

value = instance.BorderWidth
C#
public override System.Web.UI.WebControls.Unit BorderWidth {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


CaptionDisplayMode Property

[image]
Intersoft WebDesktop Documentation
CaptionDisplayMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : CaptionDisplayMode Property

Glossary Item Box

Gets or sets the default display mode of Tab Item.

Syntax

Visual Basic (Declaration)
Public Property CaptionDisplayMode As DisplayMode
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As DisplayMode

instance.CaptionDisplayMode = value

value = instance.CaptionDisplayMode
C#
public DisplayMode CaptionDisplayMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


ClientIDMode Property

[image]
Intersoft WebDesktop Documentation
ClientIDMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : ClientIDMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ClientIDMode As System.Web.UI.ClientIDMode
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As System.Web.UI.ClientIDMode

instance.ClientIDMode = value

value = instance.ClientIDMode
C#
public virtual System.Web.UI.ClientIDMode ClientIDMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


ClientSideEvents Property

[image]
Intersoft WebDesktop Documentation
ClientSideEvents Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : ClientSideEvents Property

Glossary Item Box

Contains client side events for the Tab control.

Syntax

Visual Basic (Declaration)
Public Property ClientSideEvents As WebTabClientEvents
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As WebTabClientEvents

instance.ClientSideEvents = value

value = instance.ClientSideEvents
C#
public WebTabClientEvents ClientSideEvents {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


CloseIndicatorPosition Property

[image]
Intersoft WebDesktop Documentation
CloseIndicatorPosition Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : CloseIndicatorPosition Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property CloseIndicatorPosition As CloseIndicatorPosition
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As CloseIndicatorPosition

instance.CloseIndicatorPosition = value

value = instance.CloseIndicatorPosition
C#
public CloseIndicatorPosition CloseIndicatorPosition {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


ComplexImagesSettings Property

[image]
Intersoft WebDesktop Documentation
ComplexImagesSettings Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : ComplexImagesSettings Property

Glossary Item Box

Contains settings of complex images for the Tab control. The settings are applicable when RenderMode is set to UseComplexImages.

Syntax

Visual Basic (Declaration)
Public Property ComplexImagesSettings As WebTabComplexImagesSettings
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As WebTabComplexImagesSettings

instance.ComplexImagesSettings = value

value = instance.ComplexImagesSettings
C#
public WebTabComplexImagesSettings ComplexImagesSettings {get; set;}

Remarks

The properties inside ComplexImagesSettings will be applicable only when RenderMode is set to UseComplexImages. Using ComplexImagesSettings you can configure your WebTab to use overlapped edges. Simply set the AllowOverlappingEdges under ComplexImagesSettings to True (The default value is False), then set the overlapped edges' image of the WebTab. By default, The image folder path is set to the /CommonLibrary/Images/WebDesktop/.

Furthermore, you can set the ComplexImageSettings to RenderDividerForActiveTab (The default value is True) or UseSpecialRightSeparator (The default value is False)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members

Tasks

Creating Overlapped Edges Tab

Concepts

WebTab Features


ContainerDropShadow Property

[image]
Intersoft WebDesktop Documentation
ContainerDropShadow Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : ContainerDropShadow Property

Glossary Item Box

Specifies whether drop shadow effect should be applied to container part the Tab control. (only applicable to IE browser).

Syntax

Visual Basic (Declaration)
Public Property ContainerDropShadow As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As Boolean

instance.ContainerDropShadow = value

value = instance.ContainerDropShadow
C#
public bool ContainerDropShadow {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


ContainerStyle Property

[image]
Intersoft WebDesktop Documentation
ContainerStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : ContainerStyle Property

Glossary Item Box

Gets or sets the style applied to Container part of the Tab control.

Syntax

Visual Basic (Declaration)
Public Property ContainerStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As ISNet.WebUI.WebStyle

instance.ContainerStyle = value

value = instance.ContainerStyle
C#
public ISNet.WebUI.WebStyle ContainerStyle {get; set;}

Remarks

WebTab allows you to customize most of the elements' styles by using strongly typed WebStyle and DynamicStyle properties listed in ContainerStyle, such as BackColor, BorderStyle, ForeColor, etc.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members

Concepts

WebTab Features


ContentMode Property

[image]
Intersoft WebDesktop Documentation
ContentMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : ContentMode Property

Glossary Item Box

Gets or sets the content mode of the Tab control.

Syntax

Visual Basic (Declaration)
Public Property ContentMode As ContentMode
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As ContentMode

instance.ContentMode = value

value = instance.ContentMode
C#
public ContentMode ContentMode {get; set;}

Remarks

By default, the WebTab will operate in UseInlineContent mode when a new instance is dropped to designer surface. UseInlineContent is the most suitable when the contents inside each tab page are relatively small. You can also determine the "content load" by inspecting the performance during page load as well as the size of the output.

In most cases where you want to develop a more reusable form, you should use UseIFrame for the content mode. When using IFrame mode, you would need to specify the ContentURL which page you want to load for the designated Tab item.

You can configure different ContentMode for each TabItem. To apply all TabItem to use a specific ContentMode, configure the ContentMode in WebTab control level and leave TabItem's ContentMode to Default.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members

Concepts

WebTab Features


ControlDataTransferFormat Property

[image]
Intersoft WebDesktop Documentation
ControlDataTransferFormat Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : ControlDataTransferFormat Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ControlDataTransferFormat As ISNet.WebUI.DataTransferFormat
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As ISNet.WebUI.DataTransferFormat

instance.ControlDataTransferFormat = value

value = instance.ControlDataTransferFormat
C#
public virtual ISNet.WebUI.DataTransferFormat ControlDataTransferFormat {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


DefaultTabItemHeight Property

[image]
Intersoft WebDesktop Documentation
DefaultTabItemHeight Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : DefaultTabItemHeight Property

Glossary Item Box

Gets or sets the default TabItem height in Unit.

Syntax

Visual Basic (Declaration)
Public Property DefaultTabItemHeight As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As System.Web.UI.WebControls.Unit

instance.DefaultTabItemHeight = value

value = instance.DefaultTabItemHeight
C#
public System.Web.UI.WebControls.Unit DefaultTabItemHeight {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


DefaultTabItemWidth Property

[image]
Intersoft WebDesktop Documentation
DefaultTabItemWidth Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : DefaultTabItemWidth Property

Glossary Item Box

Gets or sets the default TabItem's width (applicable when SizeMode is set to Fixed).

Syntax

Visual Basic (Declaration)
Public Property DefaultTabItemWidth As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As System.Web.UI.WebControls.Unit

instance.DefaultTabItemWidth = value

value = instance.DefaultTabItemWidth
C#
public System.Web.UI.WebControls.Unit DefaultTabItemWidth {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


DefaultTabSeparatorWidth Property

[image]
Intersoft WebDesktop Documentation
DefaultTabSeparatorWidth Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : DefaultTabSeparatorWidth Property

Glossary Item Box

Gets or sets the default tab separator's width in Unit.

Syntax

Visual Basic (Declaration)
Public Property DefaultTabSeparatorWidth As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As System.Web.UI.WebControls.Unit

instance.DefaultTabSeparatorWidth = value

value = instance.DefaultTabSeparatorWidth
C#
public System.Web.UI.WebControls.Unit DefaultTabSeparatorWidth {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


DisabledStyle Property

[image]
Intersoft WebDesktop Documentation
DisabledStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : DisabledStyle Property

Glossary Item Box

Gets or sets the style for disabled Tab.

Syntax

Visual Basic (Declaration)
Public Property DisabledStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As ISNet.WebUI.WebStyle

instance.DisabledStyle = value

value = instance.DisabledStyle
C#
public ISNet.WebUI.WebStyle DisabledStyle {get; set;}

Remarks

WebTab allows you to customize most of the elements' styles by using strongly typed WebStyle and DynamicStyle properties listed in DisabledStyle, such as BackColor, BorderStyle, ForeColor, etc.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members

Concepts

WebTab Features


Enabled Property

[image]
Intersoft WebDesktop Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : Enabled Property

Glossary Item Box

Enable state of the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property Enabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As Boolean

instance.Enabled = value

value = instance.Enabled
C#
public virtual bool Enabled {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


EnableKeyboardNavigation Property

[image]
Intersoft WebDesktop Documentation
EnableKeyboardNavigation Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : EnableKeyboardNavigation Property

Glossary Item Box

Specifies whether users can navigate the Tab using keyboard.

Syntax

Visual Basic (Declaration)
Public Property EnableKeyboardNavigation As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As Boolean

instance.EnableKeyboardNavigation = value

value = instance.EnableKeyboardNavigation
C#
public bool EnableKeyboardNavigation {get; set;}

Remarks

Using this property you can easily enable keyboard navigation, simply by setting EnableKeyboardNavigation to True.

When enabled, you can navigate the active tab in runtime by using following keys:

  • Ctrl+Alt+Left Arrow. Navigate active tab to the left visible and enabled tab.
  • Ctrl+Alt+Right Arrow. Navigate active tab to the right visible and enabled tab.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members

Concepts

WebTab Features


EnableManagedTheming Property

[image]
Intersoft WebDesktop Documentation
EnableManagedTheming Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : EnableManagedTheming Property

Glossary Item Box

Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to False, this control will not apply the style defined in Theme Architecture.

Syntax

Visual Basic (Declaration)
Public Overridable Property EnableManagedTheming As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As Boolean

instance.EnableManagedTheming = value

value = instance.EnableManagedTheming
C#
public virtual bool EnableManagedTheming {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


EnableTheming Property

[image]
Intersoft WebDesktop Documentation
EnableTheming Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : EnableTheming Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property EnableTheming As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As Boolean

instance.EnableTheming = value

value = instance.EnableTheming
C#
public virtual bool EnableTheming {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


EnableViewState Property

[image]
Intersoft WebDesktop Documentation
EnableViewState Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : EnableViewState Property

Glossary Item Box

Whether the control automatically saves its state for use in round-trips.

Syntax

Visual Basic (Declaration)
Public Overridable Property EnableViewState As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As Boolean

instance.EnableViewState = value

value = instance.EnableViewState
C#
public virtual bool EnableViewState {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


EnableWebResources Property

[image]
Intersoft WebDesktop Documentation
EnableWebResources Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : EnableWebResources Property

Glossary Item Box

Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory).

Syntax

Visual Basic (Declaration)
Public Property EnableWebResources As ISNet.WebUI.WebResourceType
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As ISNet.WebUI.WebResourceType

instance.EnableWebResources = value

value = instance.EnableWebResources
C#
public ISNet.WebUI.WebResourceType EnableWebResources {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


Font Property

[image]
Intersoft WebDesktop Documentation
Font Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : Font Property

Glossary Item Box

The font used for text within the control.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Font As System.Web.UI.WebControls.FontInfo
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As System.Web.UI.WebControls.FontInfo

value = instance.Font
C#
public override System.Web.UI.WebControls.FontInfo Font {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


ForeColor Property

[image]
Intersoft WebDesktop Documentation
ForeColor Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : ForeColor Property

Glossary Item Box

Color of the text within the control.

Syntax

Visual Basic (Declaration)
Public Overrides Property ForeColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
C#
public override System.Drawing.Color ForeColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


FrameStyle Property

[image]
Intersoft WebDesktop Documentation
FrameStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : FrameStyle Property

Glossary Item Box

Gets or sets the style applied to Frame.

Syntax

Visual Basic (Declaration)
Public Property FrameStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As ISNet.WebUI.WebStyle

instance.FrameStyle = value

value = instance.FrameStyle
C#
public ISNet.WebUI.WebStyle FrameStyle {get; set;}

Remarks

WebTab allows you to customize most of the elements' styles by using strongly typed WebStyle and DynamicStyle properties listed in FrameStyle, such as BackColor, BorderStyle, ForeColor, etc.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members

Concepts

WebTab Features


Height Property

[image]
Intersoft WebDesktop Documentation
Height Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : Height Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Height As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As System.Web.UI.WebControls.Unit

instance.Height = value

value = instance.Height
C#
public virtual System.Web.UI.WebControls.Unit Height {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


ID Property

[image]
Intersoft WebDesktop Documentation
ID Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : ID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ID As String
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As String

instance.ID = value

value = instance.ID
C#
public virtual string ID {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


IFrameAllowTransparency Property

[image]
Intersoft WebDesktop Documentation
IFrameAllowTransparency Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : IFrameAllowTransparency Property

Glossary Item Box

Specifies whether the IFRAME should allow transparency. This property is applicable when ContentMode is set to UseIFrame.

Syntax

Visual Basic (Declaration)
Public Property IFrameAllowTransparency As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As Boolean

instance.IFrameAllowTransparency = value

value = instance.IFrameAllowTransparency
C#
public bool IFrameAllowTransparency {get; set;}

Remarks

The default value of this property is True. When set to True, the IFrame will show the background color specified in ContainerStyle instead of the background color in the page specifid in ContentURL. This feature will provide better consistency of the user interface and appearance, without having to configure background color of each webform.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members

Concepts

WebTab Features


IFrameAutoLoadContent Property

[image]
Intersoft WebDesktop Documentation
IFrameAutoLoadContent Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : IFrameAutoLoadContent Property

Glossary Item Box

Specifies whether the IFrame content will be loaded automatically on first page load. This property is applicable when ContentMode is set to UseIFrame.

Syntax

Visual Basic (Declaration)
Public Property IFrameAutoLoadContent As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As Boolean

instance.IFrameAutoLoadContent = value

value = instance.IFrameAutoLoadContent
C#
public bool IFrameAutoLoadContent {get; set;}

Remarks

The default value of this property False. When set to False, the IFrame's URL will be populated on demand only when the TabHeader is clicked (activated). When set to True, WebTab will automatically load all the pages specified in each tab's ContentURL at first load. This is not recommended when you have numerous tab items as they will degrade the performance at first load.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members

Concepts

WebTab Features


IFrameShowLoader Property

[image]
Intersoft WebDesktop Documentation
IFrameShowLoader Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : IFrameShowLoader Property

Glossary Item Box

Specifies whether to show loader text when the active IFrame is in loading progress. This property only applicables when ContentMode is set to UseIFrame.

Syntax

Visual Basic (Declaration)
Public Property IFrameShowLoader As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As Boolean

instance.IFrameShowLoader = value

value = instance.IFrameShowLoader
C#
public bool IFrameShowLoader {get; set;}

Remarks

The default value of this property is True. When set to True, the WebTab will display an animated image and text indicating that the Page is currently in loading progress. This feature is helpful when loading a relatively large page and still keep informing the user of the loading progress.

You can customize the in progress image and text in ImagesSettings and TextSettings respectively.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members

Concepts

WebTab Features


ImageAlignment Property

[image]
Intersoft WebDesktop Documentation
ImageAlignment Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : ImageAlignment Property

Glossary Item Box

Gets or sets the default image alignment of Tab Item (applicable when DisplayMode is set to TextAndImage).

Syntax

Visual Basic (Declaration)
Public Property ImageAlignment As DisplayAlignment
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As DisplayAlignment

instance.ImageAlignment = value

value = instance.ImageAlignment
C#
public DisplayAlignment ImageAlignment {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


ImagesDirectory Property

[image]
Intersoft WebDesktop Documentation
ImagesDirectory Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : ImagesDirectory Property

Glossary Item Box

Gets or sets the location of images used to render the Tab control.

Syntax

Visual Basic (Declaration)
Public Property ImagesDirectory As String
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As String

instance.ImagesDirectory = value

value = instance.ImagesDirectory
C#
public string ImagesDirectory {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


ImagesSettings Property

[image]
Intersoft WebDesktop Documentation
ImagesSettings Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : ImagesSettings Property

Glossary Item Box

Contains images settings such as Images Folder and images to render the Tab control.

Syntax

Visual Basic (Declaration)
Public Property ImagesSettings As WebTabImageSettings
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As WebTabImageSettings

instance.ImagesSettings = value

value = instance.ImagesSettings
C#
public WebTabImageSettings ImagesSettings {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


NormalTabOffset Property

[image]
Intersoft WebDesktop Documentation
NormalTabOffset Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : NormalTabOffset Property

Glossary Item Box

Specifies the offset of Normal Tab in Pixel. The offset will cause the normal tabs to be rendered below Active Tab.

Syntax

Visual Basic (Declaration)
Public Property NormalTabOffset As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As Integer

instance.NormalTabOffset = value

value = instance.NormalTabOffset
C#
public int NormalTabOffset {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


Orientation Property

[image]
Intersoft WebDesktop Documentation
Orientation Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : Orientation Property

Glossary Item Box

Gets or sets the Orientation of the Tab control. Reserver for future version.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Orientation As OrientationMode
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As OrientationMode

value = instance.Orientation
C#
public OrientationMode Orientation {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


Page Property

[image]
Intersoft WebDesktop Documentation
Page Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : Page Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Page As System.Web.UI.Page
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As System.Web.UI.Page

instance.Page = value

value = instance.Page
C#
public virtual System.Web.UI.Page Page {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


Position Property

[image]
Intersoft WebDesktop Documentation
Position Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : Position Property

Glossary Item Box

Gets or sets the Position of the Tab control. (Top or Bottom is applicable when Orientation is Horizontal, Left or Right is applicable for Vertical)

Syntax

Visual Basic (Declaration)
Public Property Position As DisplayAlignment
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As DisplayAlignment

instance.Position = value

value = instance.Position
C#
public DisplayAlignment Position {get; set;}

Remarks

You can choose to put the tab at the top position or in bottom position. By default, the property is set to Top.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members

Tasks

Changing Tab Position


RenderingMode Property

[image]
Intersoft WebDesktop Documentation
RenderingMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : RenderingMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property RenderingMode As ISNet.WebUI.RenderMode
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As ISNet.WebUI.RenderMode

instance.RenderingMode = value

value = instance.RenderingMode
C#
public virtual ISNet.WebUI.RenderMode RenderingMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


RenderMode Property

[image]
Intersoft WebDesktop Documentation
RenderMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : RenderMode Property

Glossary Item Box

Gets or sets the rendering mode of Tab control.

Syntax

Visual Basic (Declaration)
Public Property RenderMode As RenderMode
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As RenderMode

instance.RenderMode = value

value = instance.RenderMode
C#
public RenderMode RenderMode {get; set;}

Remarks

The following are the values of RenderMode.

  • Simple
    This is the default RenderMode where WebTab will render basic and simple rectangle edge for the tab header. You can use this mode for best performance and compact output.
  • RoundCorner
    Thanks to TrueShape architecture which enables WebTab to render round corner without using images. With this mode, the tab header's edge will be rendered in round corner fashion allowing you to simulate XP-like Tab control. You can even configure the round corner colors and other advanced settings in RoundCornerSettings property enabling you to design a XP-like Tab control in any color schemes easily.
  • ComplexImages
    The ComplexImages rendering mode lets you create a more sophisticated style and appearance of a Tab control. You can specify the images on every part of the element's edges in ImagesSettings. Each element's part requires two set of images which is the Inactive and Active state of the tab header, and another set for the junction/intersection part.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members

Concepts

WebTab Features

Tasks

Creating Overlapped Edges Tab


RoundCornerSettings Property

[image]
Intersoft WebDesktop Documentation
RoundCornerSettings Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : RoundCornerSettings Property

Glossary Item Box

Gets or sets the round corner settings. The settings are applicable when RenderMode is set to UseRoundCorner.

Syntax

Visual Basic (Declaration)
Public Property RoundCornerSettings As WebTabRoundCornerSettings
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As WebTabRoundCornerSettings

instance.RoundCornerSettings = value

value = instance.RoundCornerSettings
C#
public WebTabRoundCornerSettings RoundCornerSettings {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


RuntimeLicenseKey Property

[image]
Intersoft WebDesktop Documentation
RuntimeLicenseKey Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : RuntimeLicenseKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property RuntimeLicenseKey As String
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As String

instance.RuntimeLicenseKey = value

value = instance.RuntimeLicenseKey
C#
public virtual string RuntimeLicenseKey {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


ScriptDirectory Property

[image]
Intersoft WebDesktop Documentation
ScriptDirectory Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : ScriptDirectory Property

Glossary Item Box

Gets or sets the directory where all required scripts for the control are stored.

Syntax

Visual Basic (Declaration)
Public Overrides Property ScriptDirectory As String
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As String

instance.ScriptDirectory = value

value = instance.ScriptDirectory
C#
public override string ScriptDirectory {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


SharedScriptDirectory Property

[image]
Intersoft WebDesktop Documentation
SharedScriptDirectory Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : SharedScriptDirectory Property

Glossary Item Box

Gets or sets the directory where all shared scripts for Intersoft controls are stored.

Syntax

Visual Basic (Declaration)
Public Overrides Property SharedScriptDirectory As String
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As String

instance.SharedScriptDirectory = value

value = instance.SharedScriptDirectory
C#
public override string SharedScriptDirectory {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


ShowFocusBorder Property

[image]
Intersoft WebDesktop Documentation
ShowFocusBorder Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : ShowFocusBorder Property

Glossary Item Box

Gets or sets whether to show border around the Active Tab. This property is recommended for Accessibility and Section 508 Compliant.

Syntax

Visual Basic (Declaration)
Public Property ShowFocusBorder As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As Boolean

instance.ShowFocusBorder = value

value = instance.ShowFocusBorder
C#
public bool ShowFocusBorder {get; set;}

Remarks

WebTab gives you an accessibility of enabling the focus border from the keyboard. To enable the focus border simply set ShowFocusBorder from the property window to True.

By enabling this property, users can press Tab key to navigate between TabHeader. When the designated TabHeader has the Focus Border, users can hit Space or Enter in order to activate the Page for that Tab.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members

Concepts

WebTab Features

Tasks

Enabling Focus border for Accessibility


SizeMode Property

[image]
Intersoft WebDesktop Documentation
SizeMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : SizeMode Property

Glossary Item Box

Gets or sets the sizing mode of the Tab control.

Syntax

Visual Basic (Declaration)
Public Property SizeMode As SizeMode
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As SizeMode

instance.SizeMode = value

value = instance.SizeMode
C#
public SizeMode SizeMode {get; set;}

Remarks

Using this property you can make a selection in arranging the layout of the WebTab to use either Default, Automatic, Fixed, or Justify.

  • Automatic.
    This is the default value for the SizeMode. The automatic sizing mode is the most recommended configuration which allowing you to enter any length of characters in the tab header's text. The TabHeader will shrink and expand automatically depend on the size of the text.
  • Fixed
    This sizing mode is suitable when you want all tab headers to have same width. When using this mode, if the size of the text exceeds the width of the tab header, the text will be wrapped automatically. To prevent text wrapping, set AllowTextWrapping to False. When AllowTextWrapping is set to False, the overflowed text will be truncated and shown as ellipsis.
  • Justify
    The Justified sizing mode will automatically adjust tab header's width of all headers to fit the width of the tab control. This mode is suitable when you have fixed width of tab control with a lot of tab items and in the case where empty gaps are not preferred.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members

Tasks

Configuring Justify Sizing mode

Concepts

WebTab Features


SkinID Property

[image]
Intersoft WebDesktop Documentation
SkinID Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : SkinID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property SkinID As String
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As String

instance.SkinID = value

value = instance.SkinID
C#
public virtual string SkinID {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


TabIndex Property

[image]
Intersoft WebDesktop Documentation
TabIndex Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : TabIndex Property

Glossary Item Box

The tab order of the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property TabIndex As Short
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As Short

instance.TabIndex = value

value = instance.TabIndex
C#
public virtual short TabIndex {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


TabItemImageStyle Property

[image]
Intersoft WebDesktop Documentation
TabItemImageStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : TabItemImageStyle Property

Glossary Item Box

Gets or sets the style applied to TabItem's Image (DisplayMode is set to TextAndImage or Image)

Syntax

Visual Basic (Declaration)
Public Property TabItemImageStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As ISNet.WebUI.DynamicStyle

instance.TabItemImageStyle = value

value = instance.TabItemImageStyle
C#
public ISNet.WebUI.DynamicStyle TabItemImageStyle {get; set;}

Remarks

WebTab allows you to customize most of the elements' styles by using strongly typed WebStyle and DynamicStyle properties listed in TabImageStyle (DynamicStyle including Normal, Over and Active styles).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members

Concepts

WebTab Features


TabItemStyle Property

[image]
Intersoft WebDesktop Documentation
TabItemStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : TabItemStyle Property

Glossary Item Box

Gets or sets the interactive style applied to Tab Item.

Syntax

Visual Basic (Declaration)
Public Property TabItemStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As ISNet.WebUI.DynamicStyle

instance.TabItemStyle = value

value = instance.TabItemStyle
C#
public ISNet.WebUI.DynamicStyle TabItemStyle {get; set;}

Remarks

WebTab allows you to customize most of the elements' styles by using strongly typed WebStyle and DynamicStyle properties listed in TabItemStyle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members

Concepts

WebTab Features


TabPages Property

[image]
Intersoft WebDesktop Documentation
TabPages Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : TabPages Property

Glossary Item Box

Gets or sets the collection containing Tab Items.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TabPages As WebTabCollection
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As WebTabCollection

value = instance.TabPages
C#
public WebTabCollection TabPages {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


TabSeparator Property

[image]
Intersoft WebDesktop Documentation
TabSeparator Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : TabSeparator Property

Glossary Item Box

Specifies whether Separator should be rendered between Tab Items.

Syntax

Visual Basic (Declaration)
Public Property TabSeparator As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As Boolean

instance.TabSeparator = value

value = instance.TabSeparator
C#
public bool TabSeparator {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


TabSeparatorStyle Property

[image]
Intersoft WebDesktop Documentation
TabSeparatorStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : TabSeparatorStyle Property

Glossary Item Box

Gets or sets the style applied to Tab Separator.

Syntax

Visual Basic (Declaration)
Public Property TabSeparatorStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As ISNet.WebUI.WebStyle

instance.TabSeparatorStyle = value

value = instance.TabSeparatorStyle
C#
public ISNet.WebUI.WebStyle TabSeparatorStyle {get; set;}

Remarks

WebTab allows you to customize most of the elements' styles by using strongly typed WebStyle and DynamicStyle properties listed in TabSeparatorStyle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members

Concepts

WebTab Features


TextDirection Property

[image]
Intersoft WebDesktop Documentation
TextDirection Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : TextDirection Property

Glossary Item Box

Gets or sets the direction of the text in each TabItem.

Syntax

Visual Basic (Declaration)
Public Property TextDirection As TextDirection
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As TextDirection

instance.TextDirection = value

value = instance.TextDirection
C#
public TextDirection TextDirection {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


TextSettings Property

[image]
Intersoft WebDesktop Documentation
TextSettings Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : TextSettings Property

Glossary Item Box

Contains text settings used by the Tab control.

Syntax

Visual Basic (Declaration)
Public Property TextSettings As WebTabTextSettings
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As WebTabTextSettings

instance.TextSettings = value

value = instance.TextSettings
C#
public WebTabTextSettings TextSettings {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


ToolTip Property

[image]
Intersoft WebDesktop Documentation
ToolTip Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : ToolTip Property

Glossary Item Box

The tooltip displayed when the mouse is over the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property ToolTip As String
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As String

instance.ToolTip = value

value = instance.ToolTip
C#
public virtual string ToolTip {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


TrimSeparatorsWhenActive Property

[image]
Intersoft WebDesktop Documentation
TrimSeparatorsWhenActive Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : TrimSeparatorsWhenActive Property

Glossary Item Box

Specifies whether the separators near the Active Tab should be removed.

Syntax

Visual Basic (Declaration)
Public Property TrimSeparatorsWhenActive As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As Boolean

instance.TrimSeparatorsWhenActive = value

value = instance.TrimSeparatorsWhenActive
C#
public bool TrimSeparatorsWhenActive {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


ValidateRequestMode Property

[image]
Intersoft WebDesktop Documentation
ValidateRequestMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : ValidateRequestMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ValidateRequestMode As System.Web.UI.ValidateRequestMode
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As System.Web.UI.ValidateRequestMode

instance.ValidateRequestMode = value

value = instance.ValidateRequestMode
C#
public virtual System.Web.UI.ValidateRequestMode ValidateRequestMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


ViewStateItems Property

[image]
Intersoft WebDesktop Documentation
ViewStateItems Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : ViewStateItems Property

Glossary Item Box

Gets or sets the items to be stored in view state storage.

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateItems As ISNet.WebUI.ViewStateItem
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As ISNet.WebUI.ViewStateItem

instance.ViewStateItems = value

value = instance.ViewStateItems
C#
public virtual ISNet.WebUI.ViewStateItem ViewStateItems {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


ViewStateMode Property

[image]
Intersoft WebDesktop Documentation
ViewStateMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : ViewStateMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateMode As System.Web.UI.ViewStateMode
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As System.Web.UI.ViewStateMode

instance.ViewStateMode = value

value = instance.ViewStateMode
C#
public virtual System.Web.UI.ViewStateMode ViewStateMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


ViewStateServerConnection Property

[image]
Intersoft WebDesktop Documentation
ViewStateServerConnection Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : ViewStateServerConnection Property

Glossary Item Box

Gets or sets the server connection string for file server-based viewstate storage.

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateServerConnection As String
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As String

instance.ViewStateServerConnection = value

value = instance.ViewStateServerConnection
C#
public virtual string ViewStateServerConnection {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


ViewStateStorage Property

[image]
Intersoft WebDesktop Documentation
ViewStateStorage Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : ViewStateStorage Property

Glossary Item Box

Gets or sets the location to store the viewstate of this control.

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateStorage As ISNet.WebUI.StateCacheStorage
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As ISNet.WebUI.StateCacheStorage

instance.ViewStateStorage = value

value = instance.ViewStateStorage
C#
public virtual ISNet.WebUI.StateCacheStorage ViewStateStorage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


Visible Property

[image]
Intersoft WebDesktop Documentation
Visible Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : Visible Property

Glossary Item Box

Indicates whether the control is visible and rendered.

Syntax

Visual Basic (Declaration)
Public Overridable Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public virtual bool Visible {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


Width Property

[image]
Intersoft WebDesktop Documentation
Width Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : Width Property

Glossary Item Box

The width of the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property Width As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As System.Web.UI.WebControls.Unit

instance.Width = value

value = instance.Width
C#
public virtual System.Web.UI.WebControls.Unit Width {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


XmlCompressionEnabled Property

[image]
Intersoft WebDesktop Documentation
XmlCompressionEnabled Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : XmlCompressionEnabled Property

Glossary Item Box

Specifies whether the Xml used for clientside state storage should be compressed.

Syntax

Visual Basic (Declaration)
Public Overridable Property XmlCompressionEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim value As Boolean

instance.XmlCompressionEnabled = value

value = instance.XmlCompressionEnabled
C#
public virtual bool XmlCompressionEnabled {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


DataBinding Event

[image]
Intersoft WebDesktop Documentation
DataBinding Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : DataBinding Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event DataBinding As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim handler As EventHandler

AddHandler instance.DataBinding, handler
C#
public event EventHandler DataBinding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


Disposed Event

[image]
Intersoft WebDesktop Documentation
Disposed Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim handler As EventHandler

AddHandler instance.Disposed, handler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


Init Event

[image]
Intersoft WebDesktop Documentation
Init Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : Init Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Init As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim handler As EventHandler

AddHandler instance.Init, handler
C#
public event EventHandler Init

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


Load Event

[image]
Intersoft WebDesktop Documentation
Load Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : Load Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Load As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim handler As EventHandler

AddHandler instance.Load, handler
C#
public event EventHandler Load

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


PreInitialize Event

[image]
Intersoft WebDesktop Documentation
PreInitialize Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : PreInitialize Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event PreInitialize As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim handler As EventHandler

AddHandler instance.PreInitialize, handler
C#
public event EventHandler PreInitialize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


PreRender Event

[image]
Intersoft WebDesktop Documentation
PreRender Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : PreRender Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event PreRender As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim handler As EventHandler

AddHandler instance.PreRender, handler
C#
public event EventHandler PreRender

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


WebTab Class Events

[image]
Intersoft WebDesktop Documentation
WebTab Class Events
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebTab Class

Glossary Item Box

For a list of all members of this type, see WebTab members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | TabChanged | Occurs when the tab is changed.
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebTab Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Creating Simple Tab
Creating Overlapped Edges Tab

tasks

Configuring Scrolling Tab mode
Configuring Closable Tab mode
Changing Tab Position
Saving and Loading Structure Programmatically

Concepts

WebTab Overview

concepts

WebTab Features
Understanding Tab Concepts
Enabling TrueShape rendering
Working with Complex Images


TabChanged Event

[image]
Intersoft WebDesktop Documentation
TabChanged Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : TabChanged Event

Glossary Item Box

Occurs when the tab is changed.

Syntax

Visual Basic (Declaration)
Public Event TabChanged As WebTabChangedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim handler As WebTabChangedEventHandler

AddHandler instance.TabChanged, handler
C#
public event WebTabChangedEventHandler TabChanged

Event Data

The event handler receives an argument of type WebTabChangedEventArgs containing data related to this event. The following WebTabChangedEventArgs properties provide information specific to this event.

Property | Description
FromTab | Gets the tab that was clicked previously (from-tab) on WebTab changed event.
ToTab | Gets the tab that will be clicked (to-tab) on WebTab changed event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


Unload Event

[image]
Intersoft WebDesktop Documentation
Unload Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTab Class : Unload Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Unload As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebTab
Dim handler As EventHandler

AddHandler instance.Unload, handler
C#
public event EventHandler Unload

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTab Class
WebTab Members


WebTabChangedEventArgs Class

[image]
Intersoft WebDesktop Documentation
WebTabChangedEventArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebTabChangedEventArgs Class

Glossary Item Box

Provides data for WebTab changed related event.

Object Model

WebTabChangedEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class WebTabChangedEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As WebTabChangedEventArgs
C#
public class WebTabChangedEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebDesktop.WebTabChangedEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabChangedEventArgs Members
ISNet.WebUI.WebDesktop Namespace


WebTabChangedEventArgs Class Members

[image]
Intersoft WebDesktop Documentation
WebTabChangedEventArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebTabChangedEventArgs Class

Glossary Item Box

The following tables list the members exposed by WebTabChangedEventArgs.

Public Properties

 | Name | Description
Public Property | FromTab | Gets the tab that was clicked previously (from-tab) on WebTab changed event.
Public Property | ToTab | Gets the tab that will be clicked (to-tab) on WebTab changed event.
Top

See Also

Reference

WebTabChangedEventArgs Class
ISNet.WebUI.WebDesktop Namespace


WebTabChangedEventArgs Class Properties

[image]
Intersoft WebDesktop Documentation
WebTabChangedEventArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebTabChangedEventArgs Class

Glossary Item Box

For a list of all members of this type, see WebTabChangedEventArgs members.

Public Properties

 | Name | Description
Public Property | FromTab | Gets the tab that was clicked previously (from-tab) on WebTab changed event.
Public Property | ToTab | Gets the tab that will be clicked (to-tab) on WebTab changed event.
Top

See Also

Reference

WebTabChangedEventArgs Class
ISNet.WebUI.WebDesktop Namespace


FromTab Property

[image]
Intersoft WebDesktop Documentation
FromTab Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabChangedEventArgs Class : FromTab Property

Glossary Item Box

Gets the tab that was clicked previously (from-tab) on WebTab changed event.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FromTab As WebTabItem
Visual Basic (Usage) Copy Code
Dim instance As WebTabChangedEventArgs
Dim value As WebTabItem

value = instance.FromTab
C#
public WebTabItem FromTab {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabChangedEventArgs Class
WebTabChangedEventArgs Members


ToTab Property

[image]
Intersoft WebDesktop Documentation
ToTab Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabChangedEventArgs Class : ToTab Property

Glossary Item Box

Gets the tab that will be clicked (to-tab) on WebTab changed event.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ToTab As WebTabItem
Visual Basic (Usage) Copy Code
Dim instance As WebTabChangedEventArgs
Dim value As WebTabItem

value = instance.ToTab
C#
public WebTabItem ToTab {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabChangedEventArgs Class
WebTabChangedEventArgs Members


WebTabClientEvents Class

[image]
Intersoft WebDesktop Documentation
WebTabClientEvents Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebTabClientEvents Class

Glossary Item Box

Client side events of WebTab that you can use to create interactions and extensible web applications.

Object Model

WebTabClientEvents Class

Syntax

Visual Basic (Declaration)
Public Class WebTabClientEvents
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebTabClientEvents
C#
public class WebTabClientEvents : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Remarks

You can have many scenarios of WebTab to be used with client side events. For instance, the OnBeforeClosed event is appropriate if you want to put your codes to validate some actions before the Tab is really closed.

The other common scenario would be populating some information when a Tab is activated. For instance, you might want to call a FlyPostBack action through FlyPostBackManager to fill the fields on demand when the Tab is activated. In this case, you can handle OnAfterTabChanged client side event.

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebDesktop.WebTabClientEvents

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabClientEvents Members
ISNet.WebUI.WebDesktop Namespace

Tasks

Adding new TabItem at Client Side

tasks

Changing TabItem Caption at Client Side
Displaying confirmation box before TabItem is closed.


WebTabClientEvents Class Members

[image]
Intersoft WebDesktop Documentation
WebTabClientEvents Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebTabClientEvents Class

Glossary Item Box

The following tables list the members exposed by WebTabClientEvents.

Public Constructors

 | Name | Description
Public Constructor | WebTabClientEvents Constructor |
Top

Public Properties

 | Name | Description
Public Property | OnAfterClosed | Gets or sets the client event handler that will be invoked when a tab has been closed.
Public Property | OnAfterTabChanged | Gets or sets the client event handler that will be invoked when a tab has been changed to Active.
Public Property | OnBeforeClosed | Gets or sets the client event handler that will be invoked when a tab is about to be closed.
Public Property | OnBeforeTabChanged | Gets or sets the client event handler that will be invoked when the active tab is about to change.
Public Property | OnCreated | Gets or sets the client event handler that will be invoked when a tab is created programmatically in client side (via Client Side API).
Public Property | OnInitialize | Gets or sets the client event handler that will be invoked when the tab control is about to be intialized.
Public Property | OnScroll | Gets or sets the client event handler that will be invoked when the tab control is scrolled.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebTabClientEvents Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Adding new TabItem at Client Side

tasks

Changing TabItem Caption at Client Side
Displaying confirmation box before TabItem is closed.


WebTabClientEvents Constructor

[image]
Intersoft WebDesktop Documentation
WebTabClientEvents Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabClientEvents Class : WebTabClientEvents Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTabClientEvents()
C#
public WebTabClientEvents()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabClientEvents Class
WebTabClientEvents Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabClientEvents Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebTabClientEvents
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabClientEvents Class
WebTabClientEvents Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabClientEvents Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabClientEvents Class
WebTabClientEvents Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabClientEvents Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTabClientEvents
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabClientEvents Class
WebTabClientEvents Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabClientEvents Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTabClientEvents
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabClientEvents Class
WebTabClientEvents Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabClientEvents Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTabClientEvents
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabClientEvents Class
WebTabClientEvents Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabClientEvents Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTabClientEvents
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabClientEvents Class
WebTabClientEvents Members


WebTabClientEvents Class Methods

[image]
Intersoft WebDesktop Documentation
WebTabClientEvents Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebTabClientEvents Class

Glossary Item Box

For a list of all members of this type, see WebTabClientEvents members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebTabClientEvents Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Adding new TabItem at Client Side

tasks

Changing TabItem Caption at Client Side
Displaying confirmation box before TabItem is closed.


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabClientEvents Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTabClientEvents
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabClientEvents Class
WebTabClientEvents Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabClientEvents Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTabClientEvents
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabClientEvents Class
WebTabClientEvents Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabClientEvents Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebTabClientEvents

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabClientEvents Class
WebTabClientEvents Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabClientEvents Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTabClientEvents
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabClientEvents Class
WebTabClientEvents Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabClientEvents Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebTabClientEvents
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabClientEvents Class
WebTabClientEvents Members


WebTabClientEvents Class Properties

[image]
Intersoft WebDesktop Documentation
WebTabClientEvents Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebTabClientEvents Class

Glossary Item Box

For a list of all members of this type, see WebTabClientEvents members.

Public Properties

 | Name | Description
Public Property | OnAfterClosed | Gets or sets the client event handler that will be invoked when a tab has been closed.
Public Property | OnAfterTabChanged | Gets or sets the client event handler that will be invoked when a tab has been changed to Active.
Public Property | OnBeforeClosed | Gets or sets the client event handler that will be invoked when a tab is about to be closed.
Public Property | OnBeforeTabChanged | Gets or sets the client event handler that will be invoked when the active tab is about to change.
Public Property | OnCreated | Gets or sets the client event handler that will be invoked when a tab is created programmatically in client side (via Client Side API).
Public Property | OnInitialize | Gets or sets the client event handler that will be invoked when the tab control is about to be intialized.
Public Property | OnScroll | Gets or sets the client event handler that will be invoked when the tab control is scrolled.
Top

See Also

Reference

WebTabClientEvents Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Adding new TabItem at Client Side

tasks

Changing TabItem Caption at Client Side
Displaying confirmation box before TabItem is closed.


WebTabClientEvents Constructor

[image]
Intersoft WebDesktop Documentation
WebTabClientEvents Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabClientEvents Class : WebTabClientEvents Constructor

Glossary Item Box

Initializes a new instance of the WebTabClientEvents class.

Overload List

Overload | Description
WebTabClientEvents Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabClientEvents Class
WebTabClientEvents Members


OnAfterClosed Property

[image]
Intersoft WebDesktop Documentation
OnAfterClosed Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabClientEvents Class : OnAfterClosed Property

Glossary Item Box

Gets or sets the client event handler that will be invoked when a tab has been closed.

Syntax

Visual Basic (Declaration)
Public Property OnAfterClosed As String
Visual Basic (Usage) Copy Code
Dim instance As WebTabClientEvents
Dim value As String

instance.OnAfterClosed = value

value = instance.OnAfterClosed
C#
public string OnAfterClosed {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabClientEvents Class
WebTabClientEvents Members


OnAfterTabChanged Property

[image]
Intersoft WebDesktop Documentation
OnAfterTabChanged Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabClientEvents Class : OnAfterTabChanged Property

Glossary Item Box

Gets or sets the client event handler that will be invoked when a tab has been changed to Active.

Syntax

Visual Basic (Declaration)
Public Property OnAfterTabChanged As String
Visual Basic (Usage) Copy Code
Dim instance As WebTabClientEvents
Dim value As String

instance.OnAfterTabChanged = value

value = instance.OnAfterTabChanged
C#
public string OnAfterTabChanged {get; set;}

Remarks

You can use OnAfterTabChanged event to populate some information when a Tab is activated. For example, you might want to call a FlyPostBack action through FlyPostBackManager to fill the fields on demand when the Tab is activated.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabClientEvents Class
WebTabClientEvents Members

Concepts

WebTab Features


OnBeforeClosed Property

[image]
Intersoft WebDesktop Documentation
OnBeforeClosed Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabClientEvents Class : OnBeforeClosed Property

Glossary Item Box

Gets or sets the client event handler that will be invoked when a tab is about to be closed.

Syntax

Visual Basic (Declaration)
Public Property OnBeforeClosed As String
Visual Basic (Usage) Copy Code
Dim instance As WebTabClientEvents
Dim value As String

instance.OnBeforeClosed = value

value = instance.OnBeforeClosed
C#
public string OnBeforeClosed {get; set;}

Remarks

This event is suitable if you want to put your codes to validate some actions before the Tab is really closed. For instance, you want to customize WebTabItem to display a confirmation box, which is made using WebDialogBox, before TabItem is closed. To learn more on this event you can refer to the tutorial Displaying confirmation box before TabItem is closed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabClientEvents Class
WebTabClientEvents Members

Tasks

Displaying confirmation box before TabItem is closed.

Concepts

WebTab Features


OnBeforeTabChanged Property

[image]
Intersoft WebDesktop Documentation
OnBeforeTabChanged Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabClientEvents Class : OnBeforeTabChanged Property

Glossary Item Box

Gets or sets the client event handler that will be invoked when the active tab is about to change.

Syntax

Visual Basic (Declaration)
Public Property OnBeforeTabChanged As String
Visual Basic (Usage) Copy Code
Dim instance As WebTabClientEvents
Dim value As String

instance.OnBeforeTabChanged = value

value = instance.OnBeforeTabChanged
C#
public string OnBeforeTabChanged {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabClientEvents Class
WebTabClientEvents Members


OnCreated Property

[image]
Intersoft WebDesktop Documentation
OnCreated Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabClientEvents Class : OnCreated Property

Glossary Item Box

Gets or sets the client event handler that will be invoked when a tab is created programmatically in client side (via Client Side API).

Syntax

Visual Basic (Declaration)
Public Property OnCreated As String
Visual Basic (Usage) Copy Code
Dim instance As WebTabClientEvents
Dim value As String

instance.OnCreated = value

value = instance.OnCreated
C#
public string OnCreated {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabClientEvents Class
WebTabClientEvents Members


OnInitialize Property

[image]
Intersoft WebDesktop Documentation
OnInitialize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabClientEvents Class : OnInitialize Property

Glossary Item Box

Gets or sets the client event handler that will be invoked when the tab control is about to be intialized.

Syntax

Visual Basic (Declaration)
Public Property OnInitialize As String
Visual Basic (Usage) Copy Code
Dim instance As WebTabClientEvents
Dim value As String

instance.OnInitialize = value

value = instance.OnInitialize
C#
public string OnInitialize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabClientEvents Class
WebTabClientEvents Members


OnScroll Property

[image]
Intersoft WebDesktop Documentation
OnScroll Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabClientEvents Class : OnScroll Property

Glossary Item Box

Gets or sets the client event handler that will be invoked when the tab control is scrolled.

Syntax

Visual Basic (Declaration)
Public Property OnScroll As String
Visual Basic (Usage) Copy Code
Dim instance As WebTabClientEvents
Dim value As String

instance.OnScroll = value

value = instance.OnScroll
C#
public string OnScroll {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabClientEvents Class
WebTabClientEvents Members


WebTabCollection Class

[image]
Intersoft WebDesktop Documentation
WebTabCollection Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebTabCollection Class

Glossary Item Box

Collection of WebTab.

Object Model

WebTabCollection Class

Syntax

Visual Basic (Declaration)
Public Class WebTabCollection
   Inherits ISNet.WebUI.ISCollectionBase
Visual Basic (Usage) Copy Code
Dim instance As WebTabCollection
C#
public class WebTabCollection : ISNet.WebUI.ISCollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
ISNet.WebUI.ISCollectionBase
ISNet.WebUI.WebDesktop.WebTabCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabCollection Members
ISNet.WebUI.WebDesktop Namespace


WebTabCollection Class Members

[image]
Intersoft WebDesktop Documentation
WebTabCollection Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebTabCollection Class

Glossary Item Box

The following tables list the members exposed by WebTabCollection.

Public Constructors

 | Name | Description
Public Constructor | WebTabCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden. Returns a Boolean value indicating whether the collection is read-only.
Public Property | Item | Property indexer for the collection.
Public Property | Parent |
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebTabCollection Class
ISNet.WebUI.WebDesktop Namespace


WebTabCollection Constructor

[image]
Intersoft WebDesktop Documentation
WebTabCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabCollection Class : WebTabCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTabCollection()
C#
public WebTabCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabCollection Class
WebTabCollection Members


WebTabCollection Class Methods

[image]
Intersoft WebDesktop Documentation
WebTabCollection Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebTabCollection Class

Glossary Item Box

For a list of all members of this type, see WebTabCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebTabCollection Class
ISNet.WebUI.WebDesktop Namespace


Add Method

[image]
Intersoft WebDesktop Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabCollection Class : Add Method

Glossary Item Box

Overload List

Overload | Description
Add(WebTabItem) |
Add(String) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabCollection Class
WebTabCollection Members


Add(WebTabItem) Method

[image]
Intersoft WebDesktop Documentation
Add(WebTabItem) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabCollection Class > Add Method : Add(WebTabItem) Method

webTabItem

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function Add( _
   ByVal webTabItem As WebTabItem _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTabCollection
Dim webTabItem As WebTabItem
Dim value As Integer

value = instance.Add(webTabItem)
C#
public virtual int Add(
   WebTabItem webTabItem
)

Parameters

webTabItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabCollection Class
WebTabCollection Members
Overload List


Add(String) Method

[image]
Intersoft WebDesktop Documentation
Add(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabCollection Class > Add Method : Add(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal name As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTabCollection
Dim name As String
Dim value As Integer

value = instance.Add(name)
C#
public int Add(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabCollection Class
WebTabCollection Members
Overload List


Clear Method

[image]
Intersoft WebDesktop Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As WebTabCollection

instance.Clear()
C#
public new void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabCollection Class
WebTabCollection Members


Contains Method

[image]
Intersoft WebDesktop Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabCollection Class : Contains Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As ISNet.WebUI.INamedObject _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTabCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As Boolean

value = instance.Contains(value)
C#
public bool Contains(
   ISNet.WebUI.INamedObject value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabCollection Class
WebTabCollection Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabCollection Class : CopyFrom Method

passIn

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CopyFrom( _
   ByVal passIn As WebTabCollection _
) As WebTabCollection
Visual Basic (Usage) Copy Code
Dim instance As WebTabCollection
Dim passIn As WebTabCollection
Dim value As WebTabCollection

value = instance.CopyFrom(passIn)
C#
public WebTabCollection CopyFrom(
   WebTabCollection passIn
)

Parameters

passIn

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabCollection Class
WebTabCollection Members


CopyTo Method

[image]
Intersoft WebDesktop Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTabCollection
Dim array() As ISNet.WebUI.INamedObject
Dim index As Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   ISNet.WebUI.INamedObject[] array,
   int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabCollection Class
WebTabCollection Members


Exists Method

[image]
Intersoft WebDesktop Documentation
Exists Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabCollection Class : Exists Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Exists( _
   ByVal name As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTabCollection
Dim name As String
Dim value As Boolean

value = instance.Exists(name)
C#
public bool Exists(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabCollection Class
WebTabCollection Members


GetEnumerator Method

[image]
Intersoft WebDesktop Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Function GetEnumerator() As System.Collections.IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As WebTabCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
public new System.Collections.IEnumerator GetEnumerator()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabCollection Class
WebTabCollection Members


GetItem Method

[image]
Intersoft WebDesktop Documentation
GetItem Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabCollection Class : GetItem Method

Glossary Item Box

Overload List

Overload | Description
GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabCollection Class
WebTabCollection Members


GetItem(Int32) Method

[image]
Intersoft WebDesktop Documentation
GetItem(Int32) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabCollection Class : GetItem(Int32) Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetItem( _
   ByVal index As Integer _
) As ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebTabCollection
Dim index As Integer
Dim value As ISNet.WebUI.INamedObject

value = instance.GetItem(index)
C#
public virtual ISNet.WebUI.INamedObject GetItem(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabCollection Class
WebTabCollection Members


GetNamedItem Method

[image]
Intersoft WebDesktop Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNamedItem( _
   ByVal name As String _
) As WebTabItem
Visual Basic (Usage) Copy Code
Dim instance As WebTabCollection
Dim name As String
Dim value As WebTabItem

value = instance.GetNamedItem(name)
C#
public WebTabItem GetNamedItem(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabCollection Class
WebTabCollection Members


IndexOf Method

[image]
Intersoft WebDesktop Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabCollection Class : IndexOf Method

Glossary Item Box

Overload List

Overload | Description
IndexOf(String) | (Inherited from ISNet.WebUI.ISCollectionBase)
IndexOf(INamedObject) | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabCollection Class
WebTabCollection Members


IndexOf(String) Method

[image]
Intersoft WebDesktop Documentation
IndexOf(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabCollection Class > IndexOf Method : IndexOf(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function IndexOf( _
   ByVal name As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTabCollection
Dim name As String
Dim value As Integer

value = instance.IndexOf(name)
C#
public virtual int IndexOf(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabCollection Class
WebTabCollection Members
Overload List


IndexOf(INamedObject) Method

[image]
Intersoft WebDesktop Documentation
IndexOf(INamedObject) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabCollection Class > IndexOf Method : IndexOf(INamedObject) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal value As ISNet.WebUI.INamedObject _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTabCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As Integer

value = instance.IndexOf(value)
C#
public int IndexOf(
   ISNet.WebUI.INamedObject value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabCollection Class
WebTabCollection Members
Overload List


Insert Method

[image]
Intersoft WebDesktop Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabCollection Class : Insert Method

index
webTabItem

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal webTabItem As WebTabItem _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTabCollection
Dim index As Integer
Dim webTabItem As WebTabItem

instance.Insert(index, webTabItem)
C#
public void Insert(
   int index,
   WebTabItem webTabItem
)

Parameters

index
webTabItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabCollection Class
WebTabCollection Members


IntInsert Method

[image]
Intersoft WebDesktop Documentation
IntInsert Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabCollection Class : IntInsert Method

index
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub IntInsert( _
   ByVal index As Integer, _
   ByVal value As ISNet.WebUI.INamedObject _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTabCollection
Dim index As Integer
Dim value As ISNet.WebUI.INamedObject

instance.IntInsert(index, value)
C#
public void IntInsert(
   int index,
   ISNet.WebUI.INamedObject value
)

Parameters

index
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabCollection Class
WebTabCollection Members


Remove Method

[image]
Intersoft WebDesktop Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabCollection Class : Remove Method

webTabItem

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal webTabItem As WebTabItem _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTabCollection
Dim webTabItem As WebTabItem

instance.Remove(webTabItem)
C#
public void Remove(
   WebTabItem webTabItem
)

Parameters

webTabItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabCollection Class
WebTabCollection Members


setParent Method

[image]
Intersoft WebDesktop Documentation
setParent Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabCollection Class : setParent Method

Glossary Item Box

Overload List

Overload | Description
setParent | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabCollection Class
WebTabCollection Members


setParent(Object) Method

[image]
Intersoft WebDesktop Documentation
setParent(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabCollection Class : setParent(Object) Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub setParent( _
   ByVal parent As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTabCollection
Dim parent As Object

instance.setParent(parent)
C#
public virtual void setParent(
   object parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabCollection Class
WebTabCollection Members


Capacity Property

[image]
Intersoft WebDesktop Documentation
Capacity Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabCollection Class : Capacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTabCollection
Dim value As Integer

instance.Capacity = value

value = instance.Capacity
C#
public int Capacity {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabCollection Class
WebTabCollection Members


Count Property

[image]
Intersoft WebDesktop Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTabCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabCollection Class
WebTabCollection Members


WebTabCollection Class Properties

[image]
Intersoft WebDesktop Documentation
WebTabCollection Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebTabCollection Class

Glossary Item Box

For a list of all members of this type, see WebTabCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden. Returns a Boolean value indicating whether the collection is read-only.
Public Property | Item | Property indexer for the collection.
Public Property | Parent |
Top

See Also

Reference

WebTabCollection Class
ISNet.WebUI.WebDesktop Namespace


WebTabCollection Constructor

[image]
Intersoft WebDesktop Documentation
WebTabCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabCollection Class : WebTabCollection Constructor

Glossary Item Box

Initializes a new instance of the WebTabCollection class.

Overload List

Overload | Description
WebTabCollection Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabCollection Class
WebTabCollection Members


IsReadOnly Property

[image]
Intersoft WebDesktop Documentation
IsReadOnly Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabCollection Class : IsReadOnly Property

Glossary Item Box

Returns a Boolean value indicating whether the collection is read-only.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTabCollection
Dim value As Boolean

value = instance.IsReadOnly
C#
public override bool IsReadOnly {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabCollection Class
WebTabCollection Members


Item Property

[image]
Intersoft WebDesktop Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabCollection Class : Item Property

index

Glossary Item Box

Property indexer for the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As WebTabItem
Visual Basic (Usage) Copy Code
Dim instance As WebTabCollection
Dim index As Integer
Dim value As WebTabItem

value = instance.Item(index)
C#
public WebTabItem this[
   int index
]; {get;}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabCollection Class
WebTabCollection Members


Parent Property

[image]
Intersoft WebDesktop Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabCollection Class : Parent Property

Glossary Item Box

Returns the WebTab control.

Syntax

Visual Basic (Declaration)
Public Shadows ReadOnly Property Parent As WebTab
Visual Basic (Usage) Copy Code
Dim instance As WebTabCollection
Dim value As WebTab

value = instance.Parent
C#
public new WebTab Parent {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabCollection Class
WebTabCollection Members


WebTabComplexImagesSettings Class

[image]
Intersoft WebDesktop Documentation
WebTabComplexImagesSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebTabComplexImagesSettings Class

Glossary Item Box

The ComplexImages RenderMode option of WebTab which you can customize your WebTab appearance using images to be more stylish and complex.

Object Model

WebTabComplexImagesSettings Class

Syntax

Visual Basic (Declaration)
Public Class WebTabComplexImagesSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebTabComplexImagesSettings
C#
public class WebTabComplexImagesSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Remarks

Customizing the appearance and behavior of your WebTab control by using “ComplexImages” RenderMode enable three new unique advanced features which include the capability of having a True Tab behavior which allows the inactive tabs’ edges to be overlapped by the active-tab item, setting the visibility of the active tab’s divider, and using the special right separator.

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebDesktop.WebTabComplexImagesSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabComplexImagesSettings Members
ISNet.WebUI.WebDesktop Namespace

Concepts

Working with Complex Images

concepts

WebTab Features


WebTabComplexImagesSettings Class Members

[image]
Intersoft WebDesktop Documentation
WebTabComplexImagesSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebTabComplexImagesSettings Class

Glossary Item Box

The following tables list the members exposed by WebTabComplexImagesSettings.

Public Constructors

 | Name | Description
Public Constructor | WebTabComplexImagesSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | AllowOverlappingEdges | Indicates whether the Active Tab will overlap the edges of tabs around it.
Public Property | RenderDividerForActiveTab | Indicates whether the divider between header and content should be rendered in Active Tab. The divider is usually rendered in most cases.
Public Property | UseSpecialRightSeparator | Indicates whether the Tab control should render the tabs' separator on the right side of Active Tab using special images. This property can be used to achieve look&feel similar to Visual Studio 2005 tabs.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebTabComplexImagesSettings Class
ISNet.WebUI.WebDesktop Namespace

Concepts

Working with Complex Images

concepts

WebTab Features


WebTabComplexImagesSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebTabComplexImagesSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabComplexImagesSettings Class : WebTabComplexImagesSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTabComplexImagesSettings()
C#
public WebTabComplexImagesSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabComplexImagesSettings Class
WebTabComplexImagesSettings Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabComplexImagesSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebTabComplexImagesSettings
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabComplexImagesSettings Class
WebTabComplexImagesSettings Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabComplexImagesSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabComplexImagesSettings Class
WebTabComplexImagesSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabComplexImagesSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTabComplexImagesSettings
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabComplexImagesSettings Class
WebTabComplexImagesSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabComplexImagesSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTabComplexImagesSettings
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabComplexImagesSettings Class
WebTabComplexImagesSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabComplexImagesSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTabComplexImagesSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabComplexImagesSettings Class
WebTabComplexImagesSettings Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabComplexImagesSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTabComplexImagesSettings
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabComplexImagesSettings Class
WebTabComplexImagesSettings Members


WebTabComplexImagesSettings Class Methods

[image]
Intersoft WebDesktop Documentation
WebTabComplexImagesSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebTabComplexImagesSettings Class

Glossary Item Box

For a list of all members of this type, see WebTabComplexImagesSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebTabComplexImagesSettings Class
ISNet.WebUI.WebDesktop Namespace

Concepts

Working with Complex Images

concepts

WebTab Features


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabComplexImagesSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTabComplexImagesSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabComplexImagesSettings Class
WebTabComplexImagesSettings Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabComplexImagesSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTabComplexImagesSettings
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabComplexImagesSettings Class
WebTabComplexImagesSettings Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabComplexImagesSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebTabComplexImagesSettings

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabComplexImagesSettings Class
WebTabComplexImagesSettings Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabComplexImagesSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTabComplexImagesSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabComplexImagesSettings Class
WebTabComplexImagesSettings Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabComplexImagesSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebTabComplexImagesSettings
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabComplexImagesSettings Class
WebTabComplexImagesSettings Members


WebTabComplexImagesSettings Class Properties

[image]
Intersoft WebDesktop Documentation
WebTabComplexImagesSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebTabComplexImagesSettings Class

Glossary Item Box

For a list of all members of this type, see WebTabComplexImagesSettings members.

Public Properties

 | Name | Description
Public Property | AllowOverlappingEdges | Indicates whether the Active Tab will overlap the edges of tabs around it.
Public Property | RenderDividerForActiveTab | Indicates whether the divider between header and content should be rendered in Active Tab. The divider is usually rendered in most cases.
Public Property | UseSpecialRightSeparator | Indicates whether the Tab control should render the tabs' separator on the right side of Active Tab using special images. This property can be used to achieve look&feel similar to Visual Studio 2005 tabs.
Top

See Also

Reference

WebTabComplexImagesSettings Class
ISNet.WebUI.WebDesktop Namespace

Concepts

Working with Complex Images

concepts

WebTab Features


WebTabComplexImagesSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebTabComplexImagesSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabComplexImagesSettings Class : WebTabComplexImagesSettings Constructor

Glossary Item Box

Initializes a new instance of the WebTabComplexImagesSettings class.

Overload List

Overload | Description
WebTabComplexImagesSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabComplexImagesSettings Class
WebTabComplexImagesSettings Members


AllowOverlappingEdges Property

[image]
Intersoft WebDesktop Documentation
AllowOverlappingEdges Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabComplexImagesSettings Class : AllowOverlappingEdges Property

Glossary Item Box

Indicates whether the Active Tab will overlap the edges of tabs around it.

Syntax

Visual Basic (Declaration)
Public Property AllowOverlappingEdges As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTabComplexImagesSettings
Dim value As Boolean

instance.AllowOverlappingEdges = value

value = instance.AllowOverlappingEdges
C#
public bool AllowOverlappingEdges {get; set;}

Remarks

The properties inside ComplexImagesSettings will be applicable only when RenderMode is set to UseComplexImages. Using ComplexImagesSettings you can configure your WebTab to use overlapped edges. Simply set the AllowOverlappingEdges under ComplexImagesSettings to True, then set the overlapped edges' image of the WebTab. By default, The image folder path is set to the /CommonLibrary/Images/WebDesktop/.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabComplexImagesSettings Class
WebTabComplexImagesSettings Members

Tasks

Creating Overlapped Edges Tab

Concepts

WebTab Features


RenderDividerForActiveTab Property

[image]
Intersoft WebDesktop Documentation
RenderDividerForActiveTab Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabComplexImagesSettings Class : RenderDividerForActiveTab Property

Glossary Item Box

Indicates whether the divider between header and content should be rendered in Active Tab. The divider is usually rendered in most cases.

Syntax

Visual Basic (Declaration)
Public Property RenderDividerForActiveTab As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTabComplexImagesSettings
Dim value As Boolean

instance.RenderDividerForActiveTab = value

value = instance.RenderDividerForActiveTab
C#
public bool RenderDividerForActiveTab {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabComplexImagesSettings Class
WebTabComplexImagesSettings Members


UseSpecialRightSeparator Property

[image]
Intersoft WebDesktop Documentation
UseSpecialRightSeparator Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabComplexImagesSettings Class : UseSpecialRightSeparator Property

Glossary Item Box

Indicates whether the Tab control should render the tabs' separator on the right side of Active Tab using special images. This property can be used to achieve look&feel similar to Visual Studio 2005 tabs.

Syntax

Visual Basic (Declaration)
Public Property UseSpecialRightSeparator As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTabComplexImagesSettings
Dim value As Boolean

instance.UseSpecialRightSeparator = value

value = instance.UseSpecialRightSeparator
C#
public bool UseSpecialRightSeparator {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabComplexImagesSettings Class
WebTabComplexImagesSettings Members


WebTabImageSettings Class

[image]
Intersoft WebDesktop Documentation
WebTabImageSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebTabImageSettings Class

Glossary Item Box

The image settings that applied to the WebTab.

Object Model

WebTabImageSettings Class

Syntax

Visual Basic (Declaration)
Public Class WebTabImageSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebTabImageSettings
C#
public class WebTabImageSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebDesktop.WebTabImageSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabImageSettings Members
ISNet.WebUI.WebDesktop Namespace


WebTabImageSettings Class Members

[image]
Intersoft WebDesktop Documentation
WebTabImageSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebTabImageSettings Class

Glossary Item Box

The following tables list the members exposed by WebTabImageSettings.

Public Constructors

 | Name | Description
Public Constructor | WebTabImageSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | ActiveCenter | Gets or sets the center background image for Active Tab.
Public Property | ActiveLeft | Gets or sets the left background image for Active Tab.
Public Property | ActiveLeftSeparator | Gets or sets the background image for left separator (overlapping edge) of Active Tab.
Public Property | ActiveRight | Gets or sets the right background image for Active Tab.
Public Property | ActiveRightSeparator | Gets or sets the background image for right separator (overlapping edge) of Active Tab.
Public Property | CloseButton | Gets or sets the image of Close button.
Public Property | InProgress | Gets or sets the image used to indicate that n IFrame is in loading progress.
Public Property | NormalCenter | Gets or sets the center background image for Normal Tab.
Public Property | NormalLeft | Gets or sets the left background image for Normal Tab.
Public Property | NormalRight | Gets or sets the right background image for Normal Tab.
Public Property | NormalSeparator | Gets or sets the separator background image for Normal Tab.
Public Property | OverCenter | Gets or sets the center background image for hovered Tab.
Public Property | OverLeft | Gets or sets the left background image for hovered Tab.
Public Property | OverRight | Gets or sets the right background image for hovered Tab.
Public Property | ScrollLeftButton | Gets or sets the image of SCrollLeft button (applicable when AllowScrolling is set to True).
Public Property | ScrollRightButton | Gets or sets the image of SCrollRight button (applicable when AllowScrolling is set to True).
Public Property | SpecialRightSeparator | Gets or sets the special separator (overlap edges) background image of Tabs in the right side of Active Tab. This property is only applicable when UseSpecialRigthSeparator is set to True.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebTabImageSettings Class
ISNet.WebUI.WebDesktop Namespace


WebTabImageSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebTabImageSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabImageSettings Class : WebTabImageSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTabImageSettings()
C#
public WebTabImageSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabImageSettings Class
WebTabImageSettings Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabImageSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebTabImageSettings
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabImageSettings Class
WebTabImageSettings Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabImageSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabImageSettings Class
WebTabImageSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabImageSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTabImageSettings
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabImageSettings Class
WebTabImageSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabImageSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTabImageSettings
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabImageSettings Class
WebTabImageSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabImageSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTabImageSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabImageSettings Class
WebTabImageSettings Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabImageSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTabImageSettings
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabImageSettings Class
WebTabImageSettings Members


WebTabImageSettings Class Methods

[image]
Intersoft WebDesktop Documentation
WebTabImageSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebTabImageSettings Class

Glossary Item Box

For a list of all members of this type, see WebTabImageSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebTabImageSettings Class
ISNet.WebUI.WebDesktop Namespace


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabImageSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTabImageSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabImageSettings Class
WebTabImageSettings Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabImageSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTabImageSettings
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabImageSettings Class
WebTabImageSettings Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabImageSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebTabImageSettings

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabImageSettings Class
WebTabImageSettings Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabImageSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTabImageSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabImageSettings Class
WebTabImageSettings Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabImageSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebTabImageSettings
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabImageSettings Class
WebTabImageSettings Members


WebTabImageSettings Class Properties

[image]
Intersoft WebDesktop Documentation
WebTabImageSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebTabImageSettings Class

Glossary Item Box

For a list of all members of this type, see WebTabImageSettings members.

Public Properties

 | Name | Description
Public Property | ActiveCenter | Gets or sets the center background image for Active Tab.
Public Property | ActiveLeft | Gets or sets the left background image for Active Tab.
Public Property | ActiveLeftSeparator | Gets or sets the background image for left separator (overlapping edge) of Active Tab.
Public Property | ActiveRight | Gets or sets the right background image for Active Tab.
Public Property | ActiveRightSeparator | Gets or sets the background image for right separator (overlapping edge) of Active Tab.
Public Property | CloseButton | Gets or sets the image of Close button.
Public Property | InProgress | Gets or sets the image used to indicate that n IFrame is in loading progress.
Public Property | NormalCenter | Gets or sets the center background image for Normal Tab.
Public Property | NormalLeft | Gets or sets the left background image for Normal Tab.
Public Property | NormalRight | Gets or sets the right background image for Normal Tab.
Public Property | NormalSeparator | Gets or sets the separator background image for Normal Tab.
Public Property | OverCenter | Gets or sets the center background image for hovered Tab.
Public Property | OverLeft | Gets or sets the left background image for hovered Tab.
Public Property | OverRight | Gets or sets the right background image for hovered Tab.
Public Property | ScrollLeftButton | Gets or sets the image of SCrollLeft button (applicable when AllowScrolling is set to True).
Public Property | ScrollRightButton | Gets or sets the image of SCrollRight button (applicable when AllowScrolling is set to True).
Public Property | SpecialRightSeparator | Gets or sets the special separator (overlap edges) background image of Tabs in the right side of Active Tab. This property is only applicable when UseSpecialRigthSeparator is set to True.
Top

See Also

Reference

WebTabImageSettings Class
ISNet.WebUI.WebDesktop Namespace


WebTabImageSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebTabImageSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabImageSettings Class : WebTabImageSettings Constructor

Glossary Item Box

Initializes a new instance of the WebTabImageSetings class.

Overload List

Overload | Description
WebTabImageSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabImageSettings Class
WebTabImageSettings Members


ActiveCenter Property

[image]
Intersoft WebDesktop Documentation
ActiveCenter Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabImageSettings Class : ActiveCenter Property

Glossary Item Box

Gets or sets the center background image for Active Tab.

Syntax

Visual Basic (Declaration)
Public Property ActiveCenter As String
Visual Basic (Usage) Copy Code
Dim instance As WebTabImageSettings
Dim value As String

instance.ActiveCenter = value

value = instance.ActiveCenter
C#
public string ActiveCenter {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabImageSettings Class
WebTabImageSettings Members


ActiveLeft Property

[image]
Intersoft WebDesktop Documentation
ActiveLeft Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabImageSettings Class : ActiveLeft Property

Glossary Item Box

Gets or sets the left background image for Active Tab.

Syntax

Visual Basic (Declaration)
Public Property ActiveLeft As String
Visual Basic (Usage) Copy Code
Dim instance As WebTabImageSettings
Dim value As String

instance.ActiveLeft = value

value = instance.ActiveLeft
C#
public string ActiveLeft {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabImageSettings Class
WebTabImageSettings Members


ActiveLeftSeparator Property

[image]
Intersoft WebDesktop Documentation
ActiveLeftSeparator Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabImageSettings Class : ActiveLeftSeparator Property

Glossary Item Box

Gets or sets the background image for left separator (overlapping edge) of Active Tab.

Syntax

Visual Basic (Declaration)
Public Property ActiveLeftSeparator As String
Visual Basic (Usage) Copy Code
Dim instance As WebTabImageSettings
Dim value As String

instance.ActiveLeftSeparator = value

value = instance.ActiveLeftSeparator
C#
public string ActiveLeftSeparator {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabImageSettings Class
WebTabImageSettings Members


ActiveRight Property

[image]
Intersoft WebDesktop Documentation
ActiveRight Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabImageSettings Class : ActiveRight Property

Glossary Item Box

Gets or sets the right background image for Active Tab.

Syntax

Visual Basic (Declaration)
Public Property ActiveRight As String
Visual Basic (Usage) Copy Code
Dim instance As WebTabImageSettings
Dim value As String

instance.ActiveRight = value

value = instance.ActiveRight
C#
public string ActiveRight {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabImageSettings Class
WebTabImageSettings Members


ActiveRightSeparator Property

[image]
Intersoft WebDesktop Documentation
ActiveRightSeparator Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabImageSettings Class : ActiveRightSeparator Property

Glossary Item Box

Gets or sets the background image for right separator (overlapping edge) of Active Tab.

Syntax

Visual Basic (Declaration)
Public Property ActiveRightSeparator As String
Visual Basic (Usage) Copy Code
Dim instance As WebTabImageSettings
Dim value As String

instance.ActiveRightSeparator = value

value = instance.ActiveRightSeparator
C#
public string ActiveRightSeparator {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabImageSettings Class
WebTabImageSettings Members


CloseButton Property

[image]
Intersoft WebDesktop Documentation
CloseButton Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabImageSettings Class : CloseButton Property

Glossary Item Box

Gets or sets the image of Close button.

Syntax

Visual Basic (Declaration)
Public Property CloseButton As String
Visual Basic (Usage) Copy Code
Dim instance As WebTabImageSettings
Dim value As String

instance.CloseButton = value

value = instance.CloseButton
C#
public string CloseButton {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabImageSettings Class
WebTabImageSettings Members


InProgress Property

[image]
Intersoft WebDesktop Documentation
InProgress Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabImageSettings Class : InProgress Property

Glossary Item Box

Gets or sets the image used to indicate that n IFrame is in loading progress.

Syntax

Visual Basic (Declaration)
Public Property InProgress As String
Visual Basic (Usage) Copy Code
Dim instance As WebTabImageSettings
Dim value As String

instance.InProgress = value

value = instance.InProgress
C#
public string InProgress {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabImageSettings Class
WebTabImageSettings Members


NormalCenter Property

[image]
Intersoft WebDesktop Documentation
NormalCenter Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabImageSettings Class : NormalCenter Property

Glossary Item Box

Gets or sets the center background image for Normal Tab.

Syntax

Visual Basic (Declaration)
Public Property NormalCenter As String
Visual Basic (Usage) Copy Code
Dim instance As WebTabImageSettings
Dim value As String

instance.NormalCenter = value

value = instance.NormalCenter
C#
public string NormalCenter {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabImageSettings Class
WebTabImageSettings Members


NormalLeft Property

[image]
Intersoft WebDesktop Documentation
NormalLeft Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabImageSettings Class : NormalLeft Property

Glossary Item Box

Gets or sets the left background image for Normal Tab.

Syntax

Visual Basic (Declaration)
Public Property NormalLeft As String
Visual Basic (Usage) Copy Code
Dim instance As WebTabImageSettings
Dim value As String

instance.NormalLeft = value

value = instance.NormalLeft
C#
public string NormalLeft {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabImageSettings Class
WebTabImageSettings Members


NormalRight Property

[image]
Intersoft WebDesktop Documentation
NormalRight Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabImageSettings Class : NormalRight Property

Glossary Item Box

Gets or sets the right background image for Normal Tab.

Syntax

Visual Basic (Declaration)
Public Property NormalRight As String
Visual Basic (Usage) Copy Code
Dim instance As WebTabImageSettings
Dim value As String

instance.NormalRight = value

value = instance.NormalRight
C#
public string NormalRight {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabImageSettings Class
WebTabImageSettings Members


NormalSeparator Property

[image]
Intersoft WebDesktop Documentation
NormalSeparator Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabImageSettings Class : NormalSeparator Property

Glossary Item Box

Gets or sets the separator background image for Normal Tab.

Syntax

Visual Basic (Declaration)
Public Property NormalSeparator As String
Visual Basic (Usage) Copy Code
Dim instance As WebTabImageSettings
Dim value As String

instance.NormalSeparator = value

value = instance.NormalSeparator
C#
public string NormalSeparator {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabImageSettings Class
WebTabImageSettings Members


OverCenter Property

[image]
Intersoft WebDesktop Documentation
OverCenter Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabImageSettings Class : OverCenter Property

Glossary Item Box

Gets or sets the center background image for hovered Tab.

Syntax

Visual Basic (Declaration)
Public Property OverCenter As String
Visual Basic (Usage) Copy Code
Dim instance As WebTabImageSettings
Dim value As String

instance.OverCenter = value

value = instance.OverCenter
C#
public string OverCenter {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabImageSettings Class
WebTabImageSettings Members


OverLeft Property

[image]
Intersoft WebDesktop Documentation
OverLeft Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabImageSettings Class : OverLeft Property

Glossary Item Box

Gets or sets the left background image for hovered Tab.

Syntax

Visual Basic (Declaration)
Public Property OverLeft As String
Visual Basic (Usage) Copy Code
Dim instance As WebTabImageSettings
Dim value As String

instance.OverLeft = value

value = instance.OverLeft
C#
public string OverLeft {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabImageSettings Class
WebTabImageSettings Members


OverRight Property

[image]
Intersoft WebDesktop Documentation
OverRight Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabImageSettings Class : OverRight Property

Glossary Item Box

Gets or sets the right background image for hovered Tab.

Syntax

Visual Basic (Declaration)
Public Property OverRight As String
Visual Basic (Usage) Copy Code
Dim instance As WebTabImageSettings
Dim value As String

instance.OverRight = value

value = instance.OverRight
C#
public string OverRight {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabImageSettings Class
WebTabImageSettings Members


ScrollLeftButton Property

[image]
Intersoft WebDesktop Documentation
ScrollLeftButton Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabImageSettings Class : ScrollLeftButton Property

Glossary Item Box

Gets or sets the image of SCrollLeft button (applicable when AllowScrolling is set to True).

Syntax

Visual Basic (Declaration)
Public Property ScrollLeftButton As String
Visual Basic (Usage) Copy Code
Dim instance As WebTabImageSettings
Dim value As String

instance.ScrollLeftButton = value

value = instance.ScrollLeftButton
C#
public string ScrollLeftButton {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabImageSettings Class
WebTabImageSettings Members


ScrollRightButton Property

[image]
Intersoft WebDesktop Documentation
ScrollRightButton Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabImageSettings Class : ScrollRightButton Property

Glossary Item Box

Gets or sets the image of SCrollRight button (applicable when AllowScrolling is set to True).

Syntax

Visual Basic (Declaration)
Public Property ScrollRightButton As String
Visual Basic (Usage) Copy Code
Dim instance As WebTabImageSettings
Dim value As String

instance.ScrollRightButton = value

value = instance.ScrollRightButton
C#
public string ScrollRightButton {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabImageSettings Class
WebTabImageSettings Members


SpecialRightSeparator Property

[image]
Intersoft WebDesktop Documentation
SpecialRightSeparator Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabImageSettings Class : SpecialRightSeparator Property

Glossary Item Box

Gets or sets the special separator (overlap edges) background image of Tabs in the right side of Active Tab. This property is only applicable when UseSpecialRigthSeparator is set to True.

Syntax

Visual Basic (Declaration)
Public Property SpecialRightSeparator As String
Visual Basic (Usage) Copy Code
Dim instance As WebTabImageSettings
Dim value As String

instance.SpecialRightSeparator = value

value = instance.SpecialRightSeparator
C#
public string SpecialRightSeparator {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabImageSettings Class
WebTabImageSettings Members


WebTabItem Class

[image]
Intersoft WebDesktop Documentation
WebTabItem Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebTabItem Class

Glossary Item Box

Tab item or collection of tab items on WebTab.

Object Model

WebTabItem Class

Syntax

Visual Basic (Declaration)
Public Class WebTabItem
   Inherits ISNet.WebUI.NamedObjectBase
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebTabItem
C#
public class WebTabItem : ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase
ISNet.WebUI.WebDesktop.WebTabItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabItem Members
ISNet.WebUI.WebDesktop Namespace


WebTabItem Class Members

[image]
Intersoft WebDesktop Documentation
WebTabItem Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebTabItem Class

Glossary Item Box

The following tables list the members exposed by WebTabItem.

Public Constructors

 | Name | Description
Public Constructor | WebTabItem Constructor |
Top

Public Properties

 | Name | Description
Public Property | AccessKey | Keyboard shortcut used by the control.
Public Property | AllowClose | Gets or sets a value indicating whether users are allowed to close this Tab.
Public Property | CaptionDisplayMode | Gets or sets the default display mode of Tab Item.
Public Property | ContentMode | Gets or sets the content mode of this Tab page.
Public Property | ContentURL | Gets or sets the URL for the IFrame content. This property is applicable when ContentMode is set to UseIFrame.
Public Property | Image | Gets or sets the URL of the image for this Tab Item.
Public Property | ImageAlignment | Gets or sets the default image alignment of Tab Item (applicable when DisplayMode is set to TextAndImage).
Public Property | InProgressText | ets or sets the text which will be displayed when the Active IFrame is in loading progress. This property only applicables when IFrameShowLoader is set to True and ContentMode is set to UseIFrame.
Public Property | IsEnabled | Specifies whether this Tab Item is enabled.
Public Property | IsSeparator | Specifies whether this Tab Item is a separator.
Public Property | Name | Overridden.
Public Property | Style | Gets or sets the interactive style individually for this Tab Item.
Public Property | Text | Gets or sets the text for this Tab Item.
Public Property | ToolTip | Gets or sets the tooltip text for this Tab.
Public Property | Width | Gets or sets the width in Unit for this Tab Item (applicable when SizeMode is set to Fixed).
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsActiveTab |
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SetActive |
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebTabItem Class
ISNet.WebUI.WebDesktop Namespace


WebTabItem Constructor

[image]
Intersoft WebDesktop Documentation
WebTabItem Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabItem Class : WebTabItem Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTabItem()
C#
public WebTabItem()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabItem Class
WebTabItem Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabItem Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebTabItem
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabItem Class
WebTabItem Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabItem Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabItem Class
WebTabItem Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabItem Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTabItem
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabItem Class
WebTabItem Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabItem Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTabItem
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabItem Class
WebTabItem Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabItem Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTabItem
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabItem Class
WebTabItem Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabItem Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTabItem
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabItem Class
WebTabItem Members


WebTabItem Class Methods

[image]
Intersoft WebDesktop Documentation
WebTabItem Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebTabItem Class

Glossary Item Box

For a list of all members of this type, see WebTabItem members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsActiveTab |
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SetActive |
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebTabItem Class
ISNet.WebUI.WebDesktop Namespace


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabItem Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTabItem
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabItem Class
WebTabItem Members


IsActiveTab Method

[image]
Intersoft WebDesktop Documentation
IsActiveTab Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabItem Class : IsActiveTab Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsActiveTab() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTabItem
Dim value As Boolean

value = instance.IsActiveTab()
C#
public bool IsActiveTab()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabItem Class
WebTabItem Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabItem Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTabItem
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabItem Class
WebTabItem Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabItem Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebTabItem

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabItem Class
WebTabItem Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabItem Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTabItem
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabItem Class
WebTabItem Members


SetActive Method

[image]
Intersoft WebDesktop Documentation
SetActive Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabItem Class : SetActive Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetActive()
Visual Basic (Usage) Copy Code
Dim instance As WebTabItem

instance.SetActive()
C#
public void SetActive()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabItem Class
WebTabItem Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabItem Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebTabItem
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabItem Class
WebTabItem Members


WebTabItem Class Properties

[image]
Intersoft WebDesktop Documentation
WebTabItem Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebTabItem Class

Glossary Item Box

For a list of all members of this type, see WebTabItem members.

Public Properties

 | Name | Description
Public Property | AccessKey | Keyboard shortcut used by the control.
Public Property | AllowClose | Gets or sets a value indicating whether users are allowed to close this Tab.
Public Property | CaptionDisplayMode | Gets or sets the default display mode of Tab Item.
Public Property | ContentMode | Gets or sets the content mode of this Tab page.
Public Property | ContentURL | Gets or sets the URL for the IFrame content. This property is applicable when ContentMode is set to UseIFrame.
Public Property | Image | Gets or sets the URL of the image for this Tab Item.
Public Property | ImageAlignment | Gets or sets the default image alignment of Tab Item (applicable when DisplayMode is set to TextAndImage).
Public Property | InProgressText | ets or sets the text which will be displayed when the Active IFrame is in loading progress. This property only applicables when IFrameShowLoader is set to True and ContentMode is set to UseIFrame.
Public Property | IsEnabled | Specifies whether this Tab Item is enabled.
Public Property | IsSeparator | Specifies whether this Tab Item is a separator.
Public Property | Name | Overridden.
Public Property | Style | Gets or sets the interactive style individually for this Tab Item.
Public Property | Text | Gets or sets the text for this Tab Item.
Public Property | ToolTip | Gets or sets the tooltip text for this Tab.
Public Property | Width | Gets or sets the width in Unit for this Tab Item (applicable when SizeMode is set to Fixed).
Top

See Also

Reference

WebTabItem Class
ISNet.WebUI.WebDesktop Namespace


WebTabItem Constructor

[image]
Intersoft WebDesktop Documentation
WebTabItem Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabItem Class : WebTabItem Constructor

Glossary Item Box

Initializes a new instance of the WebTabItem class.

Overload List

Overload | Description
WebTabItem Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabItem Class
WebTabItem Members


AccessKey Property

[image]
Intersoft WebDesktop Documentation
AccessKey Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabItem Class : AccessKey Property

Glossary Item Box

Keyboard shortcut used by the control.

Syntax

Visual Basic (Declaration)
Public Property AccessKey As String
Visual Basic (Usage) Copy Code
Dim instance As WebTabItem
Dim value As String

instance.AccessKey = value

value = instance.AccessKey
C#
public string AccessKey {get; set;}

Remarks

The AccessKey term is similar to Mnemonic key used in WinForm development. For instance, you have the tab header's Text set to "General" and would like user to be able to access the General page by pressing Alt+G, you can then set the AccessKey to "g" (note that AccessKey is case-insensitive). In runtime mode, you will see an underline beneath G character automatically.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabItem Class
WebTabItem Members

Concepts

WebTab Features


AllowClose Property

[image]
Intersoft WebDesktop Documentation
AllowClose Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabItem Class : AllowClose Property

Glossary Item Box

Gets or sets a value indicating whether users are allowed to close this Tab.

Syntax

Visual Basic (Declaration)
Public Property AllowClose As CloseMode
Visual Basic (Usage) Copy Code
Dim instance As WebTabItem
Dim value As CloseMode

instance.AllowClose = value

value = instance.AllowClose
C#
public CloseMode AllowClose {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabItem Class
WebTabItem Members


CaptionDisplayMode Property

[image]
Intersoft WebDesktop Documentation
CaptionDisplayMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabItem Class : CaptionDisplayMode Property

Glossary Item Box

Gets or sets the default display mode of Tab Item.

Syntax

Visual Basic (Declaration)
Public Property CaptionDisplayMode As DisplayMode
Visual Basic (Usage) Copy Code
Dim instance As WebTabItem
Dim value As DisplayMode

instance.CaptionDisplayMode = value

value = instance.CaptionDisplayMode
C#
public DisplayMode CaptionDisplayMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabItem Class
WebTabItem Members


ContentMode Property

[image]
Intersoft WebDesktop Documentation
ContentMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabItem Class : ContentMode Property

Glossary Item Box

Gets or sets the content mode of this Tab page.

Syntax

Visual Basic (Declaration)
Public Property ContentMode As ContentMode
Visual Basic (Usage) Copy Code
Dim instance As WebTabItem
Dim value As ContentMode

instance.ContentMode = value

value = instance.ContentMode
C#
public ContentMode ContentMode {get; set;}

Remarks

By default, the WebTab will operate in UseInlineContent mode when a new instance is dropped to designer surface. UseInlineContent is the most suitable when the contents inside each tab page are relatively small. You can also determine the "content load" by inspecting the performance during page load as well as the size of the output.

In most cases where you want to develop a more reusable form, you should use UseIFrame for the content mode. When using IFrame mode, you would need to specify the ContentURL which page you want to load for the designated Tab item.

You can configure different ContentMode for each TabItem. To apply all TabItem to use a specific ContentMode, configure the ContentMode in WebTab control level and leave TabItem's ContentMode to Default.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabItem Class
WebTabItem Members

Concepts

WebTab Features


ContentURL Property

[image]
Intersoft WebDesktop Documentation
ContentURL Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabItem Class : ContentURL Property

Glossary Item Box

Gets or sets the URL for the IFrame content. This property is applicable when ContentMode is set to UseIFrame.

Syntax

Visual Basic (Declaration)
Public Property ContentURL As String
Visual Basic (Usage) Copy Code
Dim instance As WebTabItem
Dim value As String

instance.ContentURL = value

value = instance.ContentURL
C#
public string ContentURL {get; set;}

Remarks

When you use IFrame mode in ContentMode, you would need to specify the ContentURL which page you want to load for the designated Tab item.

The ContentURL accepts three formats of URL:

  • .NET specific application relative URL. This format starts with "~" character, for instance, "~/FolderA/Page1.aspx".
  • Absolute URL. This format starts with "/" character, for instance, "/SharedModule/Page1.aspx".
  • Relative URL. This format usually starts with "." character or no special characters (which assume the page can be found in the current folder's context).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabItem Class
WebTabItem Members

Concepts

WebTab Features


Image Property

[image]
Intersoft WebDesktop Documentation
Image Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabItem Class : Image Property

Glossary Item Box

Gets or sets the URL of the image for this Tab Item.

Syntax

Visual Basic (Declaration)
Public Property Image As String
Visual Basic (Usage) Copy Code
Dim instance As WebTabItem
Dim value As String

instance.Image = value

value = instance.Image
C#
public string Image {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabItem Class
WebTabItem Members


ImageAlignment Property

[image]
Intersoft WebDesktop Documentation
ImageAlignment Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabItem Class : ImageAlignment Property

Glossary Item Box

Gets or sets the default image alignment of Tab Item (applicable when DisplayMode is set to TextAndImage).

Syntax

Visual Basic (Declaration)
Public Property ImageAlignment As DisplayAlignment
Visual Basic (Usage) Copy Code
Dim instance As WebTabItem
Dim value As DisplayAlignment

instance.ImageAlignment = value

value = instance.ImageAlignment
C#
public DisplayAlignment ImageAlignment {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabItem Class
WebTabItem Members


InProgressText Property

[image]
Intersoft WebDesktop Documentation
InProgressText Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabItem Class : InProgressText Property

Glossary Item Box

ets or sets the text which will be displayed when the Active IFrame is in loading progress. This property only applicables when IFrameShowLoader is set to True and ContentMode is set to UseIFrame.

Syntax

Visual Basic (Declaration)
Public Property InProgressText As String
Visual Basic (Usage) Copy Code
Dim instance As WebTabItem
Dim value As String

instance.InProgressText = value

value = instance.InProgressText
C#
public string InProgressText {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabItem Class
WebTabItem Members


IsEnabled Property

[image]
Intersoft WebDesktop Documentation
IsEnabled Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabItem Class : IsEnabled Property

Glossary Item Box

Specifies whether this Tab Item is enabled.

Syntax

Visual Basic (Declaration)
Public Property IsEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTabItem
Dim value As Boolean

instance.IsEnabled = value

value = instance.IsEnabled
C#
public bool IsEnabled {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabItem Class
WebTabItem Members


IsSeparator Property

[image]
Intersoft WebDesktop Documentation
IsSeparator Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabItem Class : IsSeparator Property

Glossary Item Box

Specifies whether this Tab Item is a separator.

Syntax

Visual Basic (Declaration)
Public Property IsSeparator As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTabItem
Dim value As Boolean

instance.IsSeparator = value

value = instance.IsSeparator
C#
public bool IsSeparator {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabItem Class
WebTabItem Members


Name Property

[image]
Intersoft WebDesktop Documentation
Name Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabItem Class : Name Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As WebTabItem
Dim value As String

instance.Name = value

value = instance.Name
C#
public override string Name {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabItem Class
WebTabItem Members


Style Property

[image]
Intersoft WebDesktop Documentation
Style Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabItem Class : Style Property

Glossary Item Box

Gets or sets the interactive style individually for this Tab Item.

Syntax

Visual Basic (Declaration)
Public Property Style As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebTabItem
Dim value As ISNet.WebUI.DynamicStyle

instance.Style = value

value = instance.Style
C#
public ISNet.WebUI.DynamicStyle Style {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabItem Class
WebTabItem Members


Text Property

[image]
Intersoft WebDesktop Documentation
Text Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabItem Class : Text Property

Glossary Item Box

Gets or sets the text for this Tab Item.

Syntax

Visual Basic (Declaration)
Public Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As WebTabItem
Dim value As String

instance.Text = value

value = instance.Text
C#
public string Text {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabItem Class
WebTabItem Members


ToolTip Property

[image]
Intersoft WebDesktop Documentation
ToolTip Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabItem Class : ToolTip Property

Glossary Item Box

Gets or sets the tooltip text for this Tab.

Syntax

Visual Basic (Declaration)
Public Property ToolTip As String
Visual Basic (Usage) Copy Code
Dim instance As WebTabItem
Dim value As String

instance.ToolTip = value

value = instance.ToolTip
C#
public string ToolTip {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabItem Class
WebTabItem Members


Width Property

[image]
Intersoft WebDesktop Documentation
Width Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabItem Class : Width Property

Glossary Item Box

Gets or sets the width in Unit for this Tab Item (applicable when SizeMode is set to Fixed).

Syntax

Visual Basic (Declaration)
Public Property Width As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebTabItem
Dim value As System.Web.UI.WebControls.Unit

instance.Width = value

value = instance.Width
C#
public System.Web.UI.WebControls.Unit Width {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabItem Class
WebTabItem Members


WebTabRoundCornerSettings Class

[image]
Intersoft WebDesktop Documentation
WebTabRoundCornerSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebTabRoundCornerSettings Class

Glossary Item Box

A collection of settings that related with WebTab's round corner. Using the RoundCornerSettings you can design a XP-like Tab control in any color schemes.

Object Model

WebTabRoundCornerSettings Class

Syntax

Visual Basic (Declaration)
Public Class WebTabRoundCornerSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebTabRoundCornerSettings
C#
public class WebTabRoundCornerSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Remarks

WebTabRoundCornerSettings provides you with configuration for the round corner colors and other settings related with RoundCorner. Using this configuration you can design a XP-like Tab control in any color schemes.

RoundCornerSettings facilitates you to configure 2 colors for RoundCorner tab header, which represent FillerBorderColor and TopBorderColor of the active tab item.

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebDesktop.WebTabRoundCornerSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabRoundCornerSettings Members
ISNet.WebUI.WebDesktop Namespace

Concepts

Enabling TrueShape rendering


WebTabRoundCornerSettings Class Members

[image]
Intersoft WebDesktop Documentation
WebTabRoundCornerSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebTabRoundCornerSettings Class

Glossary Item Box

The following tables list the members exposed by WebTabRoundCornerSettings.

Public Constructors

 | Name | Description
Public Constructor | WebTabRoundCornerSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | ApplyHover | Indicates whether the roundcorner active colors should be applied in mouse over event.
Public Property | FillerBorderColor | Gets or sets the Color for filler (the area between top border and bottom edge of round corner).
Public Property | TopBorderColor | Gets or sets the Color for the top most border.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebTabRoundCornerSettings Class
ISNet.WebUI.WebDesktop Namespace

Concepts

Enabling TrueShape rendering


WebTabRoundCornerSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebTabRoundCornerSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabRoundCornerSettings Class : WebTabRoundCornerSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTabRoundCornerSettings()
C#
public WebTabRoundCornerSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabRoundCornerSettings Class
WebTabRoundCornerSettings Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabRoundCornerSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebTabRoundCornerSettings
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabRoundCornerSettings Class
WebTabRoundCornerSettings Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabRoundCornerSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabRoundCornerSettings Class
WebTabRoundCornerSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabRoundCornerSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTabRoundCornerSettings
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabRoundCornerSettings Class
WebTabRoundCornerSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabRoundCornerSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTabRoundCornerSettings
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabRoundCornerSettings Class
WebTabRoundCornerSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabRoundCornerSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTabRoundCornerSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabRoundCornerSettings Class
WebTabRoundCornerSettings Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabRoundCornerSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTabRoundCornerSettings
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabRoundCornerSettings Class
WebTabRoundCornerSettings Members


WebTabRoundCornerSettings Class Methods

[image]
Intersoft WebDesktop Documentation
WebTabRoundCornerSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebTabRoundCornerSettings Class

Glossary Item Box

For a list of all members of this type, see WebTabRoundCornerSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebTabRoundCornerSettings Class
ISNet.WebUI.WebDesktop Namespace

Concepts

Enabling TrueShape rendering


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabRoundCornerSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTabRoundCornerSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabRoundCornerSettings Class
WebTabRoundCornerSettings Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabRoundCornerSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTabRoundCornerSettings
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabRoundCornerSettings Class
WebTabRoundCornerSettings Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabRoundCornerSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebTabRoundCornerSettings

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabRoundCornerSettings Class
WebTabRoundCornerSettings Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabRoundCornerSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTabRoundCornerSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabRoundCornerSettings Class
WebTabRoundCornerSettings Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabRoundCornerSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebTabRoundCornerSettings
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabRoundCornerSettings Class
WebTabRoundCornerSettings Members


WebTabRoundCornerSettings Class Properties

[image]
Intersoft WebDesktop Documentation
WebTabRoundCornerSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebTabRoundCornerSettings Class

Glossary Item Box

For a list of all members of this type, see WebTabRoundCornerSettings members.

Public Properties

 | Name | Description
Public Property | ApplyHover | Indicates whether the roundcorner active colors should be applied in mouse over event.
Public Property | FillerBorderColor | Gets or sets the Color for filler (the area between top border and bottom edge of round corner).
Public Property | TopBorderColor | Gets or sets the Color for the top most border.
Top

See Also

Reference

WebTabRoundCornerSettings Class
ISNet.WebUI.WebDesktop Namespace

Concepts

Enabling TrueShape rendering


WebTabRoundCornerSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebTabRoundCornerSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabRoundCornerSettings Class : WebTabRoundCornerSettings Constructor

Glossary Item Box

Initializes a new instance of the WebTabRoundCornerSettings class.

Overload List

Overload | Description
WebTabRoundCornerSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabRoundCornerSettings Class
WebTabRoundCornerSettings Members


ApplyHover Property

[image]
Intersoft WebDesktop Documentation
ApplyHover Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabRoundCornerSettings Class : ApplyHover Property

Glossary Item Box

Indicates whether the roundcorner active colors should be applied in mouse over event.

Syntax

Visual Basic (Declaration)
Public Property ApplyHover As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTabRoundCornerSettings
Dim value As Boolean

instance.ApplyHover = value

value = instance.ApplyHover
C#
public bool ApplyHover {get; set;}

Remarks

In RoundCornerSettings, you can customize your WebTab to apply active colors in mouse over event for your inactive WebTabItems. To use this feature, you will need to set the ApplyHover property to True (by default, this property is set to False).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabRoundCornerSettings Class
WebTabRoundCornerSettings Members

Concepts

Enabling TrueShape rendering


FillerBorderColor Property

[image]
Intersoft WebDesktop Documentation
FillerBorderColor Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabRoundCornerSettings Class : FillerBorderColor Property

Glossary Item Box

Gets or sets the Color for filler (the area between top border and bottom edge of round corner).

Syntax

Visual Basic (Declaration)
Public Property FillerBorderColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebTabRoundCornerSettings
Dim value As System.Drawing.Color

instance.FillerBorderColor = value

value = instance.FillerBorderColor
C#
public System.Drawing.Color FillerBorderColor {get; set;}

Remarks

The color specified in this property will become the filler color of the WebTab header's border.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabRoundCornerSettings Class
WebTabRoundCornerSettings Members

Concepts

Enabling TrueShape rendering


TopBorderColor Property

[image]
Intersoft WebDesktop Documentation
TopBorderColor Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabRoundCornerSettings Class : TopBorderColor Property

Glossary Item Box

Gets or sets the Color for the top most border.

Syntax

Visual Basic (Declaration)
Public Property TopBorderColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebTabRoundCornerSettings
Dim value As System.Drawing.Color

instance.TopBorderColor = value

value = instance.TopBorderColor
C#
public System.Drawing.Color TopBorderColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabRoundCornerSettings Class
WebTabRoundCornerSettings Members

Concepts

Enabling TrueShape rendering


WebTabStyle Class

[image]
Intersoft WebDesktop Documentation
WebTabStyle Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebTabStyle Class

Glossary Item Box

The style you can apply to WebTab.

Object Model

WebTabStyle Class

Syntax

Visual Basic (Declaration)
Public Class WebTabStyle
   Inherits ISNet.WebUI.WebStyle
   Implements ISNet.ICopyable, ISNet.IEmpty, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlLayoutSerialize
Visual Basic (Usage) Copy Code
Dim instance As WebTabStyle
C#
public class WebTabStyle : ISNet.WebUI.WebStyle, ISNet.ICopyable, ISNet.IEmpty, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlLayoutSerialize

Remarks

You can customize the style applied to your WebTab. Other than the Style that you make by your own, WebTab Designer will provide a few different predefined style. To learn more regarding this issue, you can read the tutorial Creating Visual Studio 2005 Style Tab.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Web.UI.WebControls.Style
ISNet.WebUI.WebStyle
ISNet.WebUI.WebDesktop.WebTabStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Members
ISNet.WebUI.WebDesktop Namespace

Tasks

Creating Visual Studio 2005 Style Tab


WebTabStyle Class Members

[image]
Intersoft WebDesktop Documentation
WebTabStyle Class Members
See Also Fields Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebTabStyle Class

Glossary Item Box

The following tables list the members exposed by WebTabStyle.

Public Constructors

 | Name | Description
Public Constructor | WebTabStyle Constructor | Initializes a new instance of the WebTabStyle class.
Top

Public Fields

 | Name | Description
Public Field | dynamicStyle | (Inherited from ISNet.WebUI.WebStyle)
Public Field | layoutKey | (Inherited from ISNet.WebUI.WebStyle)
Public Field | styleState | (Inherited from ISNet.WebUI.WebStyle)
Top

Public Properties

 | Name | Description
Public Property | BackColor | Background color of the controls applied with this style. (Inherited from ISNet.WebUI.WebStyle)
Public Property | BackColor2 | End background color of the controls applied with this style. When specified, gradient back color will be rendered from BackColor to BackColor2. (Inherited from ISNet.WebUI.WebStyle)
Public Property | BackgroundImage | Determines the file name of an image to be displayed in the background of the object associated with the style. (Inherited from ISNet.WebUI.WebStyle)
Public Property | BaseStyle | Returns or sets the base style that this style will inherit from. This property is only useful when the style is contained DynamicStyle object. (Inherited from ISNet.WebUI.WebStyle)
Public Property | BorderColor | Border color of the controls applied with this style. (Inherited from ISNet.WebUI.WebStyle)
Public Property | BorderSettings | Customize the border's appearance in more details. (Inherited from ISNet.WebUI.WebStyle)
Public Property | BorderStyle | Style of the border of controls applied with this style. (Inherited from ISNet.WebUI.WebStyle)
Public Property | BorderWidth | Thickness of the border around the controls applied with this style. (Inherited from ISNet.WebUI.WebStyle)
Public Property | CssClass | CSS class name applied to the user of this style. (Inherited from ISNet.WebUI.WebStyle)
Public Property | Cursor | Type of cursor displayed for the object associated with the style when the mouse pointer is over it. (Inherited from ISNet.WebUI.WebStyle)
Public Property | CustomRules | Determines additional CSS rules to apply the object associated with this style. (Inherited from ISNet.WebUI.WebStyle)
Public Property | Font | The font used for text in controls applied with this style. (Inherited from ISNet.WebUI.WebStyle)
Public Property | ForeColor | Foreground color of the controls applied with this style. (Inherited from ISNet.WebUI.WebStyle)
Public Property | GradientType | Specifies the gradient type for back color when BackColor2 is specified. (Inherited from ISNet.WebUI.WebStyle)
Public Property | Height | The height of the controls applied with this style. (Inherited from ISNet.WebUI.WebStyle)
Public Property | HorizontalAlign | Specifies the horizontal alignment of the text associated with the style. (Inherited from ISNet.WebUI.WebStyle)
Public Property | Margin | Determines the amount of space for the style associated object's margin. (Inherited from ISNet.WebUI.WebStyle)
Public Property | Overflow | Determines whether scrollbar is showed. (Inherited from ISNet.WebUI.WebStyle)
Public Property | OverflowX | Determines whether horizontal scrollbar should be shown. (Inherited from ISNet.WebUI.WebStyle)
Public Property | OverflowY | Determines whether vertical scrollbar should be shown. (Inherited from ISNet.WebUI.WebStyle)
Public Property | Padding | Determines the amount of space to insert between the style associated object and its margin. (Inherited from ISNet.WebUI.WebStyle)
Public Property | VerticalAlign | Specifies the vertical alignment of the text associated with the style. (Inherited from ISNet.WebUI.WebStyle)
Public Property | Width | The width of the controls applied with this style. (Inherited from ISNet.WebUI.WebStyle)
Top

Public Methods

 | Name | Description
Public Method | AddAttributesToRender | Overloaded. (Inherited from System.Web.UI.WebControls.Style)
Public Method | Clone | (Inherited from ISNet.WebUI.WebStyle)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebStyle)
Public Method | CopyFromNative | (Inherited from ISNet.WebUI.WebStyle)
Public Method | CopyMerge | (Inherited from ISNet.WebUI.WebStyle)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebStyle)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetMergedCssStyleName | (Inherited from ISNet.WebUI.WebStyle)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.WebStyle)
Public Method | GetStyleAttributes | (Inherited from System.Web.UI.WebControls.Style)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebStyle)
Public Method | IsFontEmpty | (Inherited from ISNet.WebUI.WebStyle)
Public Method | IsStyleEmpty | (Inherited from ISNet.WebUI.WebStyle)
Public Method | MergeWith | (Inherited from System.Web.UI.WebControls.Style)
Public Method | Reset | (Inherited from ISNet.WebUI.WebStyle)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebStyle)
Public Method | SetDirty | (Inherited from System.Web.UI.WebControls.Style)
Public Method | ToString | (Inherited from ISNet.WebUI.WebStyle)
Top

See Also

Reference

WebTabStyle Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Creating Visual Studio 2005 Style Tab


WebTabStyle Class Fields

[image]
Intersoft WebDesktop Documentation
WebTabStyle Class Fields
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebTabStyle Class

Glossary Item Box

For a list of all members of this type, see WebTabStyle members.

Public Fields

 | Name | Description
Public Field | dynamicStyle | (Inherited from ISNet.WebUI.WebStyle)
Public Field | layoutKey | (Inherited from ISNet.WebUI.WebStyle)
Public Field | styleState | (Inherited from ISNet.WebUI.WebStyle)
Top

See Also

Reference

WebTabStyle Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Creating Visual Studio 2005 Style Tab


WebTabStyle Class Methods

[image]
Intersoft WebDesktop Documentation
WebTabStyle Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebTabStyle Class

Glossary Item Box

For a list of all members of this type, see WebTabStyle members.

Public Methods

 | Name | Description
Public Method | AddAttributesToRender | Overloaded. (Inherited from System.Web.UI.WebControls.Style)
Public Method | Clone | (Inherited from ISNet.WebUI.WebStyle)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebStyle)
Public Method | CopyFromNative | (Inherited from ISNet.WebUI.WebStyle)
Public Method | CopyMerge | (Inherited from ISNet.WebUI.WebStyle)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebStyle)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetMergedCssStyleName | (Inherited from ISNet.WebUI.WebStyle)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.WebStyle)
Public Method | GetStyleAttributes | (Inherited from System.Web.UI.WebControls.Style)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebStyle)
Public Method | IsFontEmpty | (Inherited from ISNet.WebUI.WebStyle)
Public Method | IsStyleEmpty | (Inherited from ISNet.WebUI.WebStyle)
Public Method | MergeWith | (Inherited from System.Web.UI.WebControls.Style)
Public Method | Reset | (Inherited from ISNet.WebUI.WebStyle)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebStyle)
Public Method | SetDirty | (Inherited from System.Web.UI.WebControls.Style)
Public Method | ToString | (Inherited from ISNet.WebUI.WebStyle)
Top

See Also

Reference

WebTabStyle Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Creating Visual Studio 2005 Style Tab


WebTabStyle Class Properties

[image]
Intersoft WebDesktop Documentation
WebTabStyle Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebTabStyle Class

Glossary Item Box

For a list of all members of this type, see WebTabStyle members.

Public Properties

 | Name | Description
Public Property | BackColor | Background color of the controls applied with this style. (Inherited from ISNet.WebUI.WebStyle)
Public Property | BackColor2 | End background color of the controls applied with this style. When specified, gradient back color will be rendered from BackColor to BackColor2. (Inherited from ISNet.WebUI.WebStyle)
Public Property | BackgroundImage | Determines the file name of an image to be displayed in the background of the object associated with the style. (Inherited from ISNet.WebUI.WebStyle)
Public Property | BaseStyle | Returns or sets the base style that this style will inherit from. This property is only useful when the style is contained DynamicStyle object. (Inherited from ISNet.WebUI.WebStyle)
Public Property | BorderColor | Border color of the controls applied with this style. (Inherited from ISNet.WebUI.WebStyle)
Public Property | BorderSettings | Customize the border's appearance in more details. (Inherited from ISNet.WebUI.WebStyle)
Public Property | BorderStyle | Style of the border of controls applied with this style. (Inherited from ISNet.WebUI.WebStyle)
Public Property | BorderWidth | Thickness of the border around the controls applied with this style. (Inherited from ISNet.WebUI.WebStyle)
Public Property | CssClass | CSS class name applied to the user of this style. (Inherited from ISNet.WebUI.WebStyle)
Public Property | Cursor | Type of cursor displayed for the object associated with the style when the mouse pointer is over it. (Inherited from ISNet.WebUI.WebStyle)
Public Property | CustomRules | Determines additional CSS rules to apply the object associated with this style. (Inherited from ISNet.WebUI.WebStyle)
Public Property | Font | The font used for text in controls applied with this style. (Inherited from ISNet.WebUI.WebStyle)
Public Property | ForeColor | Foreground color of the controls applied with this style. (Inherited from ISNet.WebUI.WebStyle)
Public Property | GradientType | Specifies the gradient type for back color when BackColor2 is specified. (Inherited from ISNet.WebUI.WebStyle)
Public Property | Height | The height of the controls applied with this style. (Inherited from ISNet.WebUI.WebStyle)
Public Property | HorizontalAlign | Specifies the horizontal alignment of the text associated with the style. (Inherited from ISNet.WebUI.WebStyle)
Public Property | Margin | Determines the amount of space for the style associated object's margin. (Inherited from ISNet.WebUI.WebStyle)
Public Property | Overflow | Determines whether scrollbar is showed. (Inherited from ISNet.WebUI.WebStyle)
Public Property | OverflowX | Determines whether horizontal scrollbar should be shown. (Inherited from ISNet.WebUI.WebStyle)
Public Property | OverflowY | Determines whether vertical scrollbar should be shown. (Inherited from ISNet.WebUI.WebStyle)
Public Property | Padding | Determines the amount of space to insert between the style associated object and its margin. (Inherited from ISNet.WebUI.WebStyle)
Public Property | VerticalAlign | Specifies the vertical alignment of the text associated with the style. (Inherited from ISNet.WebUI.WebStyle)
Public Property | Width | The width of the controls applied with this style. (Inherited from ISNet.WebUI.WebStyle)
Top

See Also

Reference

WebTabStyle Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Creating Visual Studio 2005 Style Tab


WebTabStyle Constructor

[image]
Intersoft WebDesktop Documentation
WebTabStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class : WebTabStyle Constructor

Glossary Item Box

Initializes a new instance of the WebTabStyle class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTabStyle()
C#
public WebTabStyle()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members


AddAttributesToRender Method

[image]
Intersoft WebDesktop Documentation
AddAttributesToRender Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class : AddAttributesToRender Method

Glossary Item Box

Overload List

Overload | Description
AddAttributesToRender(HtmlTextWriter) | (Inherited from System.Web.UI.WebControls.Style)
AddAttributesToRender(HtmlTextWriter,WebControl) | (Inherited from System.Web.UI.WebControls.Style)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members


AddAttributesToRender(HtmlTextWriter) Method

[image]
Intersoft WebDesktop Documentation
AddAttributesToRender(HtmlTextWriter) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class > AddAttributesToRender Method : AddAttributesToRender(HtmlTextWriter) Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddAttributesToRender( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTabStyle
Dim writer As System.Web.UI.HtmlTextWriter

instance.AddAttributesToRender(writer)
C#
public void AddAttributesToRender(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members
Overload List


AddAttributesToRender(HtmlTextWriter,WebControl) Method

[image]
Intersoft WebDesktop Documentation
AddAttributesToRender(HtmlTextWriter,WebControl) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class > AddAttributesToRender Method : AddAttributesToRender(HtmlTextWriter,WebControl) Method

writer
owner

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub AddAttributesToRender( _
   ByVal writer As System.Web.UI.HtmlTextWriter, _
   ByVal owner As System.Web.UI.WebControls.WebControl _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTabStyle
Dim writer As System.Web.UI.HtmlTextWriter
Dim owner As System.Web.UI.WebControls.WebControl

instance.AddAttributesToRender(writer, owner)
C#
public virtual void AddAttributesToRender(
   System.Web.UI.HtmlTextWriter writer,
   System.Web.UI.WebControls.WebControl owner
)

Parameters

writer
owner

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members
Overload List


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebTabStyle
Dim value As Object

value = instance.Clone()
C#
public object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Style) | (Inherited from ISNet.WebUI.WebStyle)
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebStyle)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebStyle)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members


CopyFrom(Style) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Style) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class > CopyFrom Method : CopyFrom(Style) Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTabStyle
Dim s As System.Web.UI.WebControls.Style

instance.CopyFrom(s)
C#
public virtual void CopyFrom(
   System.Web.UI.WebControls.Style s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members
Overload List


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTabStyle
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTabStyle
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members
Overload List


CopyFromNative Method

[image]
Intersoft WebDesktop Documentation
CopyFromNative Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class : CopyFromNative Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub CopyFromNative( _
   ByVal s As ISNet.WebUI.WebStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTabStyle
Dim s As ISNet.WebUI.WebStyle

instance.CopyFromNative(s)
C#
public virtual void CopyFromNative(
   ISNet.WebUI.WebStyle s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members


CopyMerge Method

[image]
Intersoft WebDesktop Documentation
CopyMerge Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class : CopyMerge Method

style

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyMerge( _
   ByVal style As ISNet.WebUI.WebStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTabStyle
Dim style As ISNet.WebUI.WebStyle

instance.CopyMerge(style)
C#
public void CopyMerge(
   ISNet.WebUI.WebStyle style
)

Parameters

style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members


CreateObjRef Method

[image]
Intersoft WebDesktop Documentation
CreateObjRef Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class : CreateObjRef Method

requestedType

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function CreateObjRef( _
   ByVal requestedType As Type _
) As System.Runtime.Remoting.ObjRef
Visual Basic (Usage) Copy Code
Dim instance As WebTabStyle
Dim requestedType As Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
C#
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   Type requestedType
)

Parameters

requestedType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTabStyle
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members


Dispose Method

[image]
Intersoft WebDesktop Documentation
Dispose Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class : Dispose Method

Glossary Item Box

Overload List

Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members


Dispose() Method

[image]
Intersoft WebDesktop Documentation
Dispose() Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class : Dispose() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As WebTabStyle

instance.Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members


GetLifetimeService Method

[image]
Intersoft WebDesktop Documentation
GetLifetimeService Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class : GetLifetimeService Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebTabStyle
Dim value As Object

value = instance.GetLifetimeService()
C#
public object GetLifetimeService()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members


GetMergedCssStyleName Method

[image]
Intersoft WebDesktop Documentation
GetMergedCssStyleName Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class : GetMergedCssStyleName Method

finalKey

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetMergedCssStyleName( _
   ByVal finalKey As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebTabStyle
Dim finalKey As String
Dim value As String

value = instance.GetMergedCssStyleName(finalKey)
C#
public string GetMergedCssStyleName(
   string finalKey
)

Parameters

finalKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTabStyle
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members


GetStyleAttributes Method

[image]
Intersoft WebDesktop Documentation
GetStyleAttributes Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class : GetStyleAttributes Method

urlResolver

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetStyleAttributes( _
   ByVal urlResolver As System.Web.UI.IUrlResolutionService _
) As System.Web.UI.CssStyleCollection
Visual Basic (Usage) Copy Code
Dim instance As WebTabStyle
Dim urlResolver As System.Web.UI.IUrlResolutionService
Dim value As System.Web.UI.CssStyleCollection

value = instance.GetStyleAttributes(urlResolver)
C#
public System.Web.UI.CssStyleCollection GetStyleAttributes(
   System.Web.UI.IUrlResolutionService urlResolver
)

Parameters

urlResolver

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members


InitializeLifetimeService Method

[image]
Intersoft WebDesktop Documentation
InitializeLifetimeService Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class : InitializeLifetimeService Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function InitializeLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebTabStyle
Dim value As Object

value = instance.InitializeLifetimeService()
C#
public virtual object InitializeLifetimeService()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTabStyle
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members


IsFontEmpty Method

[image]
Intersoft WebDesktop Documentation
IsFontEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class : IsFontEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFontEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTabStyle
Dim value As Boolean

value = instance.IsFontEmpty()
C#
public virtual bool IsFontEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members


IsStyleEmpty Method

[image]
Intersoft WebDesktop Documentation
IsStyleEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class : IsStyleEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsStyleEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTabStyle
Dim value As Boolean

value = instance.IsStyleEmpty()
C#
public virtual bool IsStyleEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members


MergeWith Method

[image]
Intersoft WebDesktop Documentation
MergeWith Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class : MergeWith Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub MergeWith( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTabStyle
Dim s As System.Web.UI.WebControls.Style

instance.MergeWith(s)
C#
public virtual void MergeWith(
   System.Web.UI.WebControls.Style s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class : Reset Method

Glossary Item Box

Overload List

Overload | Description
Reset | (Inherited from ISNet.WebUI.WebStyle)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members


Reset() Method

[image]
Intersoft WebDesktop Documentation
Reset() Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class : Reset() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebTabStyle

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTabStyle
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members


SetDirty Method

[image]
Intersoft WebDesktop Documentation
SetDirty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class : SetDirty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetDirty()
Visual Basic (Usage) Copy Code
Dim instance As WebTabStyle

instance.SetDirty()
C#
public void SetDirty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebTabStyle
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members


BackColor Property

[image]
Intersoft WebDesktop Documentation
BackColor Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class : BackColor Property

Glossary Item Box

Background color of the controls applied with this style.

Syntax

Visual Basic (Declaration)
Public Overridable Property BackColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebTabStyle
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
C#
public virtual System.Drawing.Color BackColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members


BackColor2 Property

[image]
Intersoft WebDesktop Documentation
BackColor2 Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class : BackColor2 Property

Glossary Item Box

End background color of the controls applied with this style. When specified, gradient back color will be rendered from BackColor to BackColor2.

Syntax

Visual Basic (Declaration)
Public Overridable Property BackColor2 As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebTabStyle
Dim value As System.Drawing.Color

instance.BackColor2 = value

value = instance.BackColor2
C#
public virtual System.Drawing.Color BackColor2 {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members


BackgroundImage Property

[image]
Intersoft WebDesktop Documentation
BackgroundImage Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class : BackgroundImage Property

Glossary Item Box

Determines the file name of an image to be displayed in the background of the object associated with the style.

Syntax

Visual Basic (Declaration)
Public Overridable Property BackgroundImage As String
Visual Basic (Usage) Copy Code
Dim instance As WebTabStyle
Dim value As String

instance.BackgroundImage = value

value = instance.BackgroundImage
C#
public virtual string BackgroundImage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members


BaseStyle Property

[image]
Intersoft WebDesktop Documentation
BaseStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class : BaseStyle Property

Glossary Item Box

Returns or sets the base style that this style will inherit from. This property is only useful when the style is contained DynamicStyle object.

Syntax

Visual Basic (Declaration)
Public Overridable Property BaseStyle As ISNet.WebUI.BaseStyleType
Visual Basic (Usage) Copy Code
Dim instance As WebTabStyle
Dim value As ISNet.WebUI.BaseStyleType

instance.BaseStyle = value

value = instance.BaseStyle
C#
public virtual ISNet.WebUI.BaseStyleType BaseStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members


BorderColor Property

[image]
Intersoft WebDesktop Documentation
BorderColor Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class : BorderColor Property

Glossary Item Box

Border color of the controls applied with this style.

Syntax

Visual Basic (Declaration)
Public Overridable Property BorderColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebTabStyle
Dim value As System.Drawing.Color

instance.BorderColor = value

value = instance.BorderColor
C#
public virtual System.Drawing.Color BorderColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members


BorderSettings Property

[image]
Intersoft WebDesktop Documentation
BorderSettings Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class : BorderSettings Property

Glossary Item Box

Customize the border's appearance in more details.

Syntax

Visual Basic (Declaration)
Public Overridable Property BorderSettings As ISNet.WebUI.BorderSettings
Visual Basic (Usage) Copy Code
Dim instance As WebTabStyle
Dim value As ISNet.WebUI.BorderSettings

instance.BorderSettings = value

value = instance.BorderSettings
C#
public virtual ISNet.WebUI.BorderSettings BorderSettings {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members


BorderStyle Property

[image]
Intersoft WebDesktop Documentation
BorderStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class : BorderStyle Property

Glossary Item Box

Style of the border of controls applied with this style.

Syntax

Visual Basic (Declaration)
Public Overridable Property BorderStyle As System.Web.UI.WebControls.BorderStyle
Visual Basic (Usage) Copy Code
Dim instance As WebTabStyle
Dim value As System.Web.UI.WebControls.BorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
C#
public virtual System.Web.UI.WebControls.BorderStyle BorderStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members


BorderWidth Property

[image]
Intersoft WebDesktop Documentation
BorderWidth Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class : BorderWidth Property

Glossary Item Box

Thickness of the border around the controls applied with this style.

Syntax

Visual Basic (Declaration)
Public Overridable Property BorderWidth As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebTabStyle
Dim value As System.Web.UI.WebControls.Unit

instance.BorderWidth = value

value = instance.BorderWidth
C#
public virtual System.Web.UI.WebControls.Unit BorderWidth {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members


CssClass Property

[image]
Intersoft WebDesktop Documentation
CssClass Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class : CssClass Property

Glossary Item Box

CSS class name applied to the user of this style.

Syntax

Visual Basic (Declaration)
Public Overridable Property CssClass As String
Visual Basic (Usage) Copy Code
Dim instance As WebTabStyle
Dim value As String

instance.CssClass = value

value = instance.CssClass
C#
public virtual string CssClass {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members


Cursor Property

[image]
Intersoft WebDesktop Documentation
Cursor Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class : Cursor Property

Glossary Item Box

Type of cursor displayed for the object associated with the style when the mouse pointer is over it.

Syntax

Visual Basic (Declaration)
Public Overridable Property Cursor As ISNet.WebUI.Cursors
Visual Basic (Usage) Copy Code
Dim instance As WebTabStyle
Dim value As ISNet.WebUI.Cursors

instance.Cursor = value

value = instance.Cursor
C#
public virtual ISNet.WebUI.Cursors Cursor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members


CustomRules Property

[image]
Intersoft WebDesktop Documentation
CustomRules Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class : CustomRules Property

Glossary Item Box

Determines additional CSS rules to apply the object associated with this style.

Syntax

Visual Basic (Declaration)
Public Overridable Property CustomRules As String
Visual Basic (Usage) Copy Code
Dim instance As WebTabStyle
Dim value As String

instance.CustomRules = value

value = instance.CustomRules
C#
public virtual string CustomRules {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members


Font Property

[image]
Intersoft WebDesktop Documentation
Font Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class : Font Property

Glossary Item Box

The font used for text in controls applied with this style.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Font As System.Web.UI.WebControls.FontInfo
Visual Basic (Usage) Copy Code
Dim instance As WebTabStyle
Dim value As System.Web.UI.WebControls.FontInfo

value = instance.Font
C#
public virtual System.Web.UI.WebControls.FontInfo Font {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members


ForeColor Property

[image]
Intersoft WebDesktop Documentation
ForeColor Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class : ForeColor Property

Glossary Item Box

Foreground color of the controls applied with this style.

Syntax

Visual Basic (Declaration)
Public Overridable Property ForeColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebTabStyle
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
C#
public virtual System.Drawing.Color ForeColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members


GradientType Property

[image]
Intersoft WebDesktop Documentation
GradientType Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class : GradientType Property

Glossary Item Box

Specifies the gradient type for back color when BackColor2 is specified.

Syntax

Visual Basic (Declaration)
Public Property GradientType As ISNet.WebUI.GradientType
Visual Basic (Usage) Copy Code
Dim instance As WebTabStyle
Dim value As ISNet.WebUI.GradientType

instance.GradientType = value

value = instance.GradientType
C#
public ISNet.WebUI.GradientType GradientType {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members


Height Property

[image]
Intersoft WebDesktop Documentation
Height Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class : Height Property

Glossary Item Box

The height of the controls applied with this style.

Syntax

Visual Basic (Declaration)
Public Overridable Property Height As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebTabStyle
Dim value As System.Web.UI.WebControls.Unit

instance.Height = value

value = instance.Height
C#
public virtual System.Web.UI.WebControls.Unit Height {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members


HorizontalAlign Property

[image]
Intersoft WebDesktop Documentation
HorizontalAlign Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class : HorizontalAlign Property

Glossary Item Box

Specifies the horizontal alignment of the text associated with the style.

Syntax

Visual Basic (Declaration)
Public Overridable Property HorizontalAlign As ISNet.WebUI.HorizontalAlign
Visual Basic (Usage) Copy Code
Dim instance As WebTabStyle
Dim value As ISNet.WebUI.HorizontalAlign

instance.HorizontalAlign = value

value = instance.HorizontalAlign
C#
public virtual ISNet.WebUI.HorizontalAlign HorizontalAlign {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members


Margin Property

[image]
Intersoft WebDesktop Documentation
Margin Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class : Margin Property

Glossary Item Box

Determines the amount of space for the style associated object's margin.

Syntax

Visual Basic (Declaration)
Public Overridable Property Margin As ISNet.WebUI.Margin
Visual Basic (Usage) Copy Code
Dim instance As WebTabStyle
Dim value As ISNet.WebUI.Margin

instance.Margin = value

value = instance.Margin
C#
public virtual ISNet.WebUI.Margin Margin {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members


Overflow Property

[image]
Intersoft WebDesktop Documentation
Overflow Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class : Overflow Property

Glossary Item Box

Determines whether scrollbar is showed.

Syntax

Visual Basic (Declaration)
Public Overridable Property Overflow As ISNet.WebUI.Overflow
Visual Basic (Usage) Copy Code
Dim instance As WebTabStyle
Dim value As ISNet.WebUI.Overflow

instance.Overflow = value

value = instance.Overflow
C#
public virtual ISNet.WebUI.Overflow Overflow {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members


OverflowX Property

[image]
Intersoft WebDesktop Documentation
OverflowX Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class : OverflowX Property

Glossary Item Box

Determines whether horizontal scrollbar should be shown.

Syntax

Visual Basic (Declaration)
Public Overridable Property OverflowX As ISNet.WebUI.Overflow
Visual Basic (Usage) Copy Code
Dim instance As WebTabStyle
Dim value As ISNet.WebUI.Overflow

instance.OverflowX = value

value = instance.OverflowX
C#
public virtual ISNet.WebUI.Overflow OverflowX {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members


OverflowY Property

[image]
Intersoft WebDesktop Documentation
OverflowY Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class : OverflowY Property

Glossary Item Box

Determines whether vertical scrollbar should be shown.

Syntax

Visual Basic (Declaration)
Public Overridable Property OverflowY As ISNet.WebUI.Overflow
Visual Basic (Usage) Copy Code
Dim instance As WebTabStyle
Dim value As ISNet.WebUI.Overflow

instance.OverflowY = value

value = instance.OverflowY
C#
public virtual ISNet.WebUI.Overflow OverflowY {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members


Padding Property

[image]
Intersoft WebDesktop Documentation
Padding Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class : Padding Property

Glossary Item Box

Determines the amount of space to insert between the style associated object and its margin.

Syntax

Visual Basic (Declaration)
Public Overridable Property Padding As ISNet.WebUI.Padding
Visual Basic (Usage) Copy Code
Dim instance As WebTabStyle
Dim value As ISNet.WebUI.Padding

instance.Padding = value

value = instance.Padding
C#
public virtual ISNet.WebUI.Padding Padding {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members


VerticalAlign Property

[image]
Intersoft WebDesktop Documentation
VerticalAlign Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class : VerticalAlign Property

Glossary Item Box

Specifies the vertical alignment of the text associated with the style.

Syntax

Visual Basic (Declaration)
Public Overridable Property VerticalAlign As ISNet.WebUI.VerticalAlign
Visual Basic (Usage) Copy Code
Dim instance As WebTabStyle
Dim value As ISNet.WebUI.VerticalAlign

instance.VerticalAlign = value

value = instance.VerticalAlign
C#
public virtual ISNet.WebUI.VerticalAlign VerticalAlign {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members


Width Property

[image]
Intersoft WebDesktop Documentation
Width Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class : Width Property

Glossary Item Box

The width of the controls applied with this style.

Syntax

Visual Basic (Declaration)
Public Overridable Property Width As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebTabStyle
Dim value As System.Web.UI.WebControls.Unit

instance.Width = value

value = instance.Width
C#
public virtual System.Web.UI.WebControls.Unit Width {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members


dynamicStyle Field

[image]
Intersoft WebDesktop Documentation
dynamicStyle Field
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class : dynamicStyle Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public dynamicStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebTabStyle
Dim value As ISNet.WebUI.DynamicStyle

value = instance.dynamicStyle

instance.dynamicStyle = value
C#
public ISNet.WebUI.DynamicStyle dynamicStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members


layoutKey Field

[image]
Intersoft WebDesktop Documentation
layoutKey Field
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class : layoutKey Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public layoutKey As String
Visual Basic (Usage) Copy Code
Dim instance As WebTabStyle
Dim value As String

value = instance.layoutKey

instance.layoutKey = value
C#
public string layoutKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members


styleState Field

[image]
Intersoft WebDesktop Documentation
styleState Field
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabStyle Class : styleState Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public styleState As String
Visual Basic (Usage) Copy Code
Dim instance As WebTabStyle
Dim value As String

value = instance.styleState

instance.styleState = value
C#
public string styleState

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabStyle Class
WebTabStyle Members


WebTabTextSettings Class

[image]
Intersoft WebDesktop Documentation
WebTabTextSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebTabTextSettings Class

Glossary Item Box

Collection of text settings used by the Tab control.

Object Model

WebTabTextSettings Class

Syntax

Visual Basic (Declaration)
Public Class WebTabTextSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebTabTextSettings
C#
public class WebTabTextSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebDesktop.WebTabTextSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabTextSettings Members
ISNet.WebUI.WebDesktop Namespace


WebTabTextSettings Class Members

[image]
Intersoft WebDesktop Documentation
WebTabTextSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebTabTextSettings Class

Glossary Item Box

The following tables list the members exposed by WebTabTextSettings.

Public Constructors

 | Name | Description
Public Constructor | WebTabTextSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | CloseButtonTooltipText |
Public Property | InProgressText |
Public Property | ScrollLeftButtonTooltipText |
Public Property | ScrollRightButtonTooltipText |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebTabTextSettings Class
ISNet.WebUI.WebDesktop Namespace


WebTabTextSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebTabTextSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabTextSettings Class : WebTabTextSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTabTextSettings()
C#
public WebTabTextSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabTextSettings Class
WebTabTextSettings Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabTextSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebTabTextSettings
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabTextSettings Class
WebTabTextSettings Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabTextSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabTextSettings Class
WebTabTextSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabTextSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTabTextSettings
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabTextSettings Class
WebTabTextSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabTextSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTabTextSettings
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabTextSettings Class
WebTabTextSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabTextSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTabTextSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabTextSettings Class
WebTabTextSettings Members


GetHashCode Method

[image]
Intersoft WebDesktop Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabTextSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTabTextSettings
Dim value As Integer

value = instance.GetHashCode()
C#
public virtual int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabTextSettings Class
WebTabTextSettings Members


WebTabTextSettings Class Methods

[image]
Intersoft WebDesktop Documentation
WebTabTextSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebTabTextSettings Class

Glossary Item Box

For a list of all members of this type, see WebTabTextSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebTabTextSettings Class
ISNet.WebUI.WebDesktop Namespace


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabTextSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTabTextSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabTextSettings Class
WebTabTextSettings Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabTextSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTabTextSettings
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabTextSettings Class
WebTabTextSettings Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabTextSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebTabTextSettings

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabTextSettings Class
WebTabTextSettings Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabTextSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTabTextSettings
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabTextSettings Class
WebTabTextSettings Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabTextSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebTabTextSettings
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabTextSettings Class
WebTabTextSettings Members


WebTabTextSettings Class Properties

[image]
Intersoft WebDesktop Documentation
WebTabTextSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebTabTextSettings Class

Glossary Item Box

For a list of all members of this type, see WebTabTextSettings members.

Public Properties

 | Name | Description
Public Property | CloseButtonTooltipText |
Public Property | InProgressText |
Public Property | ScrollLeftButtonTooltipText |
Public Property | ScrollRightButtonTooltipText |
Top

See Also

Reference

WebTabTextSettings Class
ISNet.WebUI.WebDesktop Namespace


WebTabTextSettings Constructor

[image]
Intersoft WebDesktop Documentation
WebTabTextSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabTextSettings Class : WebTabTextSettings Constructor

Glossary Item Box

Initializes a new instance of the WebTabTextSetings class.

Overload List

Overload | Description
WebTabTextSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabTextSettings Class
WebTabTextSettings Members


CloseButtonTooltipText Property

[image]
Intersoft WebDesktop Documentation
CloseButtonTooltipText Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabTextSettings Class : CloseButtonTooltipText Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property CloseButtonTooltipText As String
Visual Basic (Usage) Copy Code
Dim instance As WebTabTextSettings
Dim value As String

instance.CloseButtonTooltipText = value

value = instance.CloseButtonTooltipText
C#
public string CloseButtonTooltipText {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabTextSettings Class
WebTabTextSettings Members


InProgressText Property

[image]
Intersoft WebDesktop Documentation
InProgressText Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabTextSettings Class : InProgressText Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property InProgressText As String
Visual Basic (Usage) Copy Code
Dim instance As WebTabTextSettings
Dim value As String

instance.InProgressText = value

value = instance.InProgressText
C#
public string InProgressText {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabTextSettings Class
WebTabTextSettings Members


ScrollLeftButtonTooltipText Property

[image]
Intersoft WebDesktop Documentation
ScrollLeftButtonTooltipText Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabTextSettings Class : ScrollLeftButtonTooltipText Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ScrollLeftButtonTooltipText As String
Visual Basic (Usage) Copy Code
Dim instance As WebTabTextSettings
Dim value As String

instance.ScrollLeftButtonTooltipText = value

value = instance.ScrollLeftButtonTooltipText
C#
public string ScrollLeftButtonTooltipText {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabTextSettings Class
WebTabTextSettings Members


ScrollRightButtonTooltipText Property

[image]
Intersoft WebDesktop Documentation
ScrollRightButtonTooltipText Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebTabTextSettings Class : ScrollRightButtonTooltipText Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ScrollRightButtonTooltipText As String
Visual Basic (Usage) Copy Code
Dim instance As WebTabTextSettings
Dim value As String

instance.ScrollRightButtonTooltipText = value

value = instance.ScrollRightButtonTooltipText
C#
public string ScrollRightButtonTooltipText {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabTextSettings Class
WebTabTextSettings Members


WebToolBar Class

[image]
Intersoft WebDesktop Documentation
WebToolBar Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebToolBar Class

Glossary Item Box

Intersoft WebToolBar.NET WebControl for ASP.NET which offers most functionalities a ToolBar control should have, and integrated with a powerful designer which will ease the process of design time.

Object Model

WebToolBar Class

Syntax

Visual Basic (Declaration)
Public Class WebToolBar
   Inherits ISNet.WebUI.ISNetControl
   Implements ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, ISNet.WebUI.ITemplateSync, IBar, ICommand, IWebMenuControl
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
C#
public class WebToolBar : ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, ISNet.WebUI.ITemplateSync, IBar, ICommand, IWebMenuControl

Remarks

You can use WebToolBar control to quickly build a professional desktop application-style's ToolBar. WebToolBar is designed with an elegant architecture and object model as well as specialized user interface for each element. That means, you no longer require any workarounds to create a look like ToolBar object which is not only rich in styles, but also in every functions and behaviors.

When combined with PlaceHolder manager, you can easily deploy dockable ToolBars which commonly found in desktop-based applications. Supported by PlaceHolderManager architecture, you can dock the ToolBar quickly with just a property change, no extensive coding required.

WebToolBar is also supported with an interactive designer which eases you during design and development time process. No more unvisualized designer or hard coding is needed.

Some important features of WebToolBar include:

  • TrueShape™
    TrueShape is an innovative rendering technology which enables round corner shape to be rendered without the needs to use images.
  • TrueDock™
    TrueDock is the only correct implementation today which allowing end users to dock a ToolBar into four edges of designated content area.
  • Docking and Floating
    WebToolBar can be configured as docking and floating.
  • ToolBar Merging
    WebToolBar introduces Merging feature which allows you to Merge ToolBar from your parent page with child page.

To learn more on the toolbar's features please refer to the WebToolBar Features.

WebToolBar provides some Designers to help you configuring the WebToolBar as easy as possible. Those designers are WebToolBar Designer, WebToolBar Quick Designer, and Visual Menu Builder.

  • WebToolBar Designer.

    WebToolBar Designer is the common designer that Intersoft Component has, and also the complete designer which used to handle all property management of WebToolBar. In addition, the structure of WebToolBar can also be managed using StructureManager.

  • WebToolBar Quick Designer.
    WebToolBar Quick Designer is a more specific Designer, it focus on properties that related to WebToolBar Features. In general WebToolBar Quick Designer is divided into three Main tabs, they are Bar, Docking, and Command.

  • Visual Menu Builder
    Visual Menu Builder is another Designer that integrated to WebToolBar, it is used to help you managing WebToolBar CommandTypes of type DropDown Buttons and Split Buttons.

For more information regarding WebToolBar Designer please refer to Working with ToolBar Designer.

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
ISNet.WebUI.ISNetControl
ISNet.WebUI.WebDesktop.WebToolBar

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Members
ISNet.WebUI.WebDesktop Namespace

Tasks

Creating Dockable Toolbar
Creating Standalone Toolbar
Changing Toolbar docking at design time
Configuring Floating Mode
Configuring ToolCommand Toolbar Merging

Concepts

WebToolBar Overview
WebToolBar Features
Understanding ToolBar Architecture
Working with ToolBar Designer
Rich Design-time Experience


WebToolBar Class Members

[image]
Intersoft WebDesktop Documentation
WebToolBar Class Members
See Also Properties Methods Events Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebToolBar Class

Glossary Item Box

The following tables list the members exposed by WebToolBar.

Public Constructors

 | Name | Description
Public Constructor | WebToolBar Constructor |
Top

Public Properties

 | Name | Description
Public Property | AccessKey | Keyboard shortcut used by the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | AddRemoveOptionMenuViewMode | Gets or sets the add remove option menu view mode.
Public Property | AllowCustomize | Gets or sets a value that indicates whether a WebToolBar control is customizable.
Public Property | AllowDockBottom | Gets or sets a value that indicates whether a WebToolBar control can be dock to bottom area of PlaceHolderManager.
Public Property | AllowDockLeft | Gets or sets a value that indicates whether a WebToolBar control can be dock to left area of PlaceHolderManager.
Public Property | AllowDockRight | Gets or sets a value that indicates whether a WebToolBar control can be dock to right area of PlaceHolderManager.
Public Property | AllowDockTop | Gets or sets a value that indicates whether a WebToolBar control can be dock to top area of PlaceHolderManager.
Public Property | AllowExpandCollapse | Gets or sets a value that indicates whether a WebToolBar control is expandable and collapsible.
Public Property | AllowFloat | Gets or sets a value that indicates whether a WebToolBar control is floatable.
Public Property | AllowMove | Gets or sets a value that indicates whether a WebToolBar control is moveable.
Public Property | AutoPostBack | Gets or sets a value that indicates whether a Command is autopostback.
Public Property | BarStyle | Gets or sets the Bar style.
Public Property | BodyStyle | Gets or sets the style properties of body bar section in the bar control.
Public Property | Caption | Specifies the bar caption.
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | CommandClientSideEvents | Specifies the client side (Javascript) tool command events.
Public Property | CommandDisabledStyle | Gets or sets the style properties of disable command style.
Public Property | CommandMargin | Gets or sets the margin for commands.
Public Property | Commands | Gets the collection of tool commands in this WebToolBar.
Public Property | CommandSize | Specifies the ToolCommand size.
Public Property | CommandStyle | Gets or sets the style properties of command in the bar control.
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Display | Gets or sets a value that indicates whether a WebToolBar control is displayed as UI on the page.
Public Property | DisplayAccessKeyOnToolTip | Gets or sets a value that indicates whether access key is displayed on tooltip.
Public Property | DisplayMode | Specifies the ToolCommand display mode.
Public Property | DisplayToolTip | Gets or sets a value that indicates whether tooltip is displayed.
Public Property | DockingArea | Gets or sets the WebToolBar docking area.
Public Property | DockingOffset | Specifies the WebToolBar docking offset.
Public Property | DockingRow | Specifies the WebToolBar docking row.
Public Property | Enabled | Enabled state of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableManagedTheming | Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to False, this control will not apply the style defined in Theme Architecture. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | Whether the control automatically saves its state for use in round-trips. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | FillDockingRow | Gets or sets a value that indicates whether a WebToolBar control dimension fills the row region of PlaceHolderManager docking row.
Public Property | GreyImageWhenDisabled | Gets or sets a value indicates whether a grey image is applied when command is disabled.
Public Property | HandleStyle | Gets or sets the style properties of handle bar section in the bar control.
Public Property | HandleVisible | Gets or sets a value that indicates whether a WebToolBar handle section is visible.
Public Property | HeaderButtonStyle | Gets or sets the style properties of the header bar close button in the bar control.
Public Property | HeaderCaptionStyle | Gets or sets the style properties of the header bar caption in the bar control.
Public Property | HeaderHeight | Gets or sets the height of the WebToolBar control header.
Public Property | Height | Overridden. Gets or sets the height of the WebToolBar control.
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ImagesDirectory | Gets or sets the location of images used to render the control.
Public Property | ImageSize | Specifies the ToolCommand image size.
Public Property | IntegratedTo | Gets or sets the WebToolBar menu integrated mode.
Public Property | IsFloat | Gets or sets a value that indicates whether a WebToolBar control is floated on the page.
Public Property | LazyLoadContextMenu | Gets or sets a value that indicates whether DropdownButton context menu or SplitButton context menu is loaded lazily (on first button clicked).
Public Property | MenuStyleSettings | Gets or sets the style properties of menu styles in the bar control.
Public Property | MergeCommandID | Specifies the Merge Command ID.
Public Property | MergeToolBar | Gets or sets a value that indicates whether a WebToolBar control is a merge WebToolBar.
Public Property | MergeToolBarParentID | Gets or sets the merged WebToolBar parent ID.
Public Property | MergeToolBarParentWindowName | Gets or sets the merged WebToolBar parent window name.
Public Property | Opacity |
Public Property | OptionStyle | Gets or sets the style properties of option bar section in the bar control.
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | PlaceHolder | Specifies the bar placeholder manager.
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden. Gets or sets the directory where all required scripts for the control are stored.
Public Property | SeparatorStyle | Gets or sets the style properties of separator command in the bar control.
Public Property | SharedScriptDirectory | Overridden.
Public Property | ShowDelay | Gets or sets the amount of submenu that shows delay in milliseconds.
Public Property | ShowFocusBorder | Gets or sets a boolean value indicating whether to show border around the Active Command when tabbed via keyboard. This property is recommended for Accessbility and Section 508 Compliant.
Public Property | SizeMode | Gets or sets the tool command sizing mode.
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | TextAlign | Specifies the ToolCommand text align type.
Public Property | ToggleGroups | Gets the collection of toggle group commands in this WebToolBar.
Public Property | ToolTip | The tooltip displayed when the mouse is over the control.
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateItems | Gets or sets the items to be stored in view state storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | Gets or sets the server connection string for file server-based viewstate storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | Gets or sets the location to store the viewstate of this control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | Overridden. Indicates whether the control is visible and rendered.
Public Property | Width | Overridden. The width of the control.
Public Property | XmlCompressionEnabled | Specifies whether the Xml used for clientside state storage should be compressed. (Inherited from ISNet.WebUI.ISNetControl)
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CheckConstrains | Overridden.
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. Overridden.
Public Method | CustomDeserialize | This method is not intended to be called directly. It is used internally for control developers.
Public Method | CustomSerialize | This method is not intended to be called directly. It is used internally for control developers.
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetOrientation |
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | GetXMLData | Overridden.
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadCommandsStructureFromXml | Overloaded.
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPostData | Overridden.
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RaisePostBackEvent |
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RecreateChildControls |
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterScript | Overridden.
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResetUsageData |
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveCommandsStructureToXml | Overloaded.
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetPlaceHolder |
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SynchronizeBarProperties |
Public Method | SynchronizeTemplatesFrom |
Top

Public Events

 | Name | Description
Public Event | BarLayoutPropertiesChanged | Occurs when bar layout properties is changed.
Public Event | BarPropertiesChanged | Occurs when bar properties is changed.
Public Event | CommandClick | Occurs when command bar is clicked.
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebToolBar Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Creating Dockable Toolbar
Creating Standalone Toolbar
Changing Toolbar docking at design time
Configuring Floating Mode
Configuring ToolCommand Toolbar Merging

Concepts

WebToolBar Overview
WebToolBar Features
Understanding ToolBar Architecture
Working with ToolBar Designer
Rich Design-time Experience


WebToolBar Constructor

[image]
Intersoft WebDesktop Documentation
WebToolBar Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : WebToolBar Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebToolBar()
C#
public WebToolBar()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


ApplyStyle Method

[image]
Intersoft WebDesktop Documentation
ApplyStyle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : ApplyStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ApplyStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim s As System.Web.UI.WebControls.Style

instance.ApplyStyle(s)
C#
public void ApplyStyle(
   System.Web.UI.WebControls.Style s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


ApplyStyleSheetSkin Method

[image]
Intersoft WebDesktop Documentation
ApplyStyleSheetSkin Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : ApplyStyleSheetSkin Method

page

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub ApplyStyleSheetSkin( _
   ByVal page As System.Web.UI.Page _
)
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim page As System.Web.UI.Page

instance.ApplyStyleSheetSkin(page)
C#
public virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page page
)

Parameters

page

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


CanUseWebResources Method

[image]
Intersoft WebDesktop Documentation
CanUseWebResources Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : CanUseWebResources Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CanUseWebResources() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As Boolean

value = instance.CanUseWebResources()
C#
public bool CanUseWebResources()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


WebToolBar Class Methods

[image]
Intersoft WebDesktop Documentation
WebToolBar Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebToolBar Class

Glossary Item Box

For a list of all members of this type, see WebToolBar members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CheckConstrains | Overridden.
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. Overridden.
Public Method | CustomDeserialize | This method is not intended to be called directly. It is used internally for control developers.
Public Method | CustomSerialize | This method is not intended to be called directly. It is used internally for control developers.
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetOrientation |
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | GetXMLData | Overridden.
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadCommandsStructureFromXml | Overloaded.
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPostData | Overridden.
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RaisePostBackEvent |
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RecreateChildControls |
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterScript | Overridden.
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResetUsageData |
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveCommandsStructureToXml | Overloaded.
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetPlaceHolder |
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SynchronizeBarProperties |
Public Method | SynchronizeTemplatesFrom |
Top

See Also

Reference

WebToolBar Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Creating Dockable Toolbar
Creating Standalone Toolbar
Changing Toolbar docking at design time
Configuring Floating Mode
Configuring ToolCommand Toolbar Merging

Concepts

WebToolBar Overview
WebToolBar Features
Understanding ToolBar Architecture
Working with ToolBar Designer
Rich Design-time Experience


CheckConstrains Method

[image]
Intersoft WebDesktop Documentation
CheckConstrains Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : CheckConstrains Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub CheckConstrains()
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar

instance.CheckConstrains()
C#
public override void CheckConstrains()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


CopyBaseAttributes Method

[image]
Intersoft WebDesktop Documentation
CopyBaseAttributes Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : CopyBaseAttributes Method

controlSrc

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyBaseAttributes( _
   ByVal controlSrc As System.Web.UI.WebControls.WebControl _
)
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim controlSrc As System.Web.UI.WebControls.WebControl

instance.CopyBaseAttributes(controlSrc)
C#
public void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl controlSrc
)

Parameters

controlSrc

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object,Boolean) |
CopyFrom(Object) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public override void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members
Overload List


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members
Overload List


CustomDeserialize Method

[image]
Intersoft WebDesktop Documentation
CustomDeserialize Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : CustomDeserialize Method

mi
currentObj
parentNode
currentNode

Glossary Item Box

This method is not intended to be called directly. It is used internally for control developers.

Syntax

Visual Basic (Declaration)
Public Sub CustomDeserialize( _
   ByVal mi As System.Reflection.MemberInfo, _
   ByVal currentObj As Object, _
   ByVal parentNode As System.Xml.XmlNode, _
   ByVal currentNode As System.Xml.XmlNode _
)
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim mi As System.Reflection.MemberInfo
Dim currentObj As Object
Dim parentNode As System.Xml.XmlNode
Dim currentNode As System.Xml.XmlNode

instance.CustomDeserialize(mi, currentObj, parentNode, currentNode)
C#
public void CustomDeserialize(
   System.Reflection.MemberInfo mi,
   object currentObj,
   System.Xml.XmlNode parentNode,
   System.Xml.XmlNode currentNode
)

Parameters

mi
currentObj
parentNode
currentNode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


CustomSerialize Method

[image]
Intersoft WebDesktop Documentation
CustomSerialize Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : CustomSerialize Method

doc
node

Glossary Item Box

This method is not intended to be called directly. It is used internally for control developers.

Syntax

Visual Basic (Declaration)
Public Sub CustomSerialize( _
   ByVal doc As System.Xml.XmlDocument, _
   ByVal node As System.Xml.XmlNode _
)
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim doc As System.Xml.XmlDocument
Dim node As System.Xml.XmlNode

instance.CustomSerialize(doc, node)
C#
public void CustomSerialize(
   System.Xml.XmlDocument doc,
   System.Xml.XmlNode node
)

Parameters

doc
node

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


DataBind Method

[image]
Intersoft WebDesktop Documentation
DataBind Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : DataBind Method

Glossary Item Box

Overload List

Overload | Description
DataBind | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


DataBind() Method

[image]
Intersoft WebDesktop Documentation
DataBind() Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : DataBind() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub DataBind()
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar

instance.DataBind()
C#
public virtual void DataBind()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


Dispose Method

[image]
Intersoft WebDesktop Documentation
Dispose Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : Dispose Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar

instance.Dispose()
C#
public virtual void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


FindControl Method

[image]
Intersoft WebDesktop Documentation
FindControl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : FindControl Method

Glossary Item Box

Overload List

Overload | Description
FindControl | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


FindControl(String) Method

[image]
Intersoft WebDesktop Documentation
FindControl(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : FindControl(String) Method

id

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function FindControl( _
   ByVal id As String _
) As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim id As String
Dim value As System.Web.UI.Control

value = instance.FindControl(id)
C#
public virtual System.Web.UI.Control FindControl(
   string id
)

Parameters

id

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


Focus Method

[image]
Intersoft WebDesktop Documentation
Focus Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : Focus Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Focus()
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar

instance.Focus()
C#
public virtual void Focus()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


ForceDisableXmlCompression Method

[image]
Intersoft WebDesktop Documentation
ForceDisableXmlCompression Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : ForceDisableXmlCompression Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ForceDisableXmlCompression()
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar

instance.ForceDisableXmlCompression()
C#
public void ForceDisableXmlCompression()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


GetCurrentControlLifeCycle Method

[image]
Intersoft WebDesktop Documentation
GetCurrentControlLifeCycle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : GetCurrentControlLifeCycle Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentControlLifeCycle() As ISNet.WebUI.ControlLifeCycle
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As ISNet.WebUI.ControlLifeCycle

value = instance.GetCurrentControlLifeCycle()
C#
public ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


GetCurrentTheme Method

[image]
Intersoft WebDesktop Documentation
GetCurrentTheme Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : GetCurrentTheme Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentTheme() As ISNet.WebUI.ThemeInfo
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As ISNet.WebUI.ThemeInfo

value = instance.GetCurrentTheme()
C#
public ISNet.WebUI.ThemeInfo GetCurrentTheme()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


GetFrameworkDataFolder Method

[image]
Intersoft WebDesktop Documentation
GetFrameworkDataFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : GetFrameworkDataFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkDataFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As String

value = instance.GetFrameworkDataFolder()
C#
public string GetFrameworkDataFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


GetFrameworkFolder Method

[image]
Intersoft WebDesktop Documentation
GetFrameworkFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : GetFrameworkFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As String

value = instance.GetFrameworkFolder()
C#
public string GetFrameworkFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


GetFrameworkVersion Method

[image]
Intersoft WebDesktop Documentation
GetFrameworkVersion Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : GetFrameworkVersion Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkVersion() As Version
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As Version

value = instance.GetFrameworkVersion()
C#
public Version GetFrameworkVersion()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


GetIntersoftFolder Method

[image]
Intersoft WebDesktop Documentation
GetIntersoftFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : GetIntersoftFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetIntersoftFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As String

value = instance.GetIntersoftFolder()
C#
public string GetIntersoftFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


GetLayoutFolder Method

[image]
Intersoft WebDesktop Documentation
GetLayoutFolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : GetLayoutFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetLayoutFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As String

value = instance.GetLayoutFolder()
C#
public string GetLayoutFolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


GetOrientation Method

[image]
Intersoft WebDesktop Documentation
GetOrientation Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : GetOrientation Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetOrientation() As OrientationMode
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As OrientationMode

value = instance.GetOrientation()
C#
public virtual OrientationMode GetOrientation()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


GetPostedXMLData Method

[image]
Intersoft WebDesktop Documentation
GetPostedXMLData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : GetPostedXMLData Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPostedXMLData() As String
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As String

value = instance.GetPostedXMLData()
C#
public string GetPostedXMLData()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


GetProductInfoKey Method

[image]
Intersoft WebDesktop Documentation
GetProductInfoKey Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : GetProductInfoKey Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductInfoKey() As String
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As String

value = instance.GetProductInfoKey()
C#
public string GetProductInfoKey()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


GetProductSimpleName Method

[image]
Intersoft WebDesktop Documentation
GetProductSimpleName Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : GetProductSimpleName Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductSimpleName() As String
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As String

value = instance.GetProductSimpleName()
C#
public string GetProductSimpleName()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


GetPropertyValue Method

[image]
Intersoft WebDesktop Documentation
GetPropertyValue Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : GetPropertyValue Method

defValue
propValue
webConfigKey

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPropertyValue( _
   ByVal defValue As String, _
   ByVal propValue As String, _
   ByVal webConfigKey As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim defValue As String
Dim propValue As String
Dim webConfigKey As String
Dim value As String

value = instance.GetPropertyValue(defValue, propValue, webConfigKey)
C#
public string GetPropertyValue(
   string defValue,
   string propValue,
   string webConfigKey
)

Parameters

defValue
propValue
webConfigKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


GetResourceStream Method

[image]
Intersoft WebDesktop Documentation
GetResourceStream Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : GetResourceStream Method

resourceUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetResourceStream( _
   ByVal resourceUrl As String _
) As System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim resourceUrl As String
Dim value As System.IO.Stream

value = instance.GetResourceStream(resourceUrl)
C#
public System.IO.Stream GetResourceStream(
   string resourceUrl
)

Parameters

resourceUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


GetRouteUrl Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : GetRouteUrl Method

Glossary Item Box

Overload List

Overload | Description
GetRouteUrl(Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(RouteValueDictionary) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,RouteValueDictionary) | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


GetRouteUrl(Object) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class > GetRouteUrl Method : GetRouteUrl(Object) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As Object _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim routeParameters As Object
Dim value As String

value = instance.GetRouteUrl(routeParameters)
C#
public string GetRouteUrl(
   object routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members
Overload List


GetRouteUrl(String,Object) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(String,Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class > GetRouteUrl Method : GetRouteUrl(String,Object) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As String, _
   ByVal routeParameters As Object _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim routeName As String
Dim routeParameters As Object
Dim value As String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public string GetRouteUrl(
   string routeName,
   object routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members
Overload List


GetRouteUrl(RouteValueDictionary) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(RouteValueDictionary) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class > GetRouteUrl Method : GetRouteUrl(RouteValueDictionary) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As String

value = instance.GetRouteUrl(routeParameters)
C#
public string GetRouteUrl(
   System.Web.Routing.RouteValueDictionary routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members
Overload List


GetRouteUrl(String,RouteValueDictionary) Method

[image]
Intersoft WebDesktop Documentation
GetRouteUrl(String,RouteValueDictionary) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class > GetRouteUrl Method : GetRouteUrl(String,RouteValueDictionary) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As String, _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim routeName As String
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public string GetRouteUrl(
   string routeName,
   System.Web.Routing.RouteValueDictionary routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members
Overload List


GetUniqueIDRelativeTo Method

[image]
Intersoft WebDesktop Documentation
GetUniqueIDRelativeTo Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : GetUniqueIDRelativeTo Method

control

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetUniqueIDRelativeTo( _
   ByVal control As System.Web.UI.Control _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim control As System.Web.UI.Control
Dim value As String

value = instance.GetUniqueIDRelativeTo(control)
C#
public string GetUniqueIDRelativeTo(
   System.Web.UI.Control control
)

Parameters

control

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


GetXMLData Method

[image]
Intersoft WebDesktop Documentation
GetXMLData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : GetXMLData Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function GetXMLData() As String
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As String

value = instance.GetXMLData()
C#
public override string GetXMLData()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


HasControls Method

[image]
Intersoft WebDesktop Documentation
HasControls Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : HasControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function HasControls() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As Boolean

value = instance.HasControls()
C#
public virtual bool HasControls()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


IsAtlasCallback Method

[image]
Intersoft WebDesktop Documentation
IsAtlasCallback Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : IsAtlasCallback Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsAtlasCallback() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As Boolean

value = instance.IsAtlasCallback()
C#
public bool IsAtlasCallback()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


IsBetaRelease Method

[image]
Intersoft WebDesktop Documentation
IsBetaRelease Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : IsBetaRelease Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsBetaRelease() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As Boolean

value = instance.IsBetaRelease()
C#
public bool IsBetaRelease()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


IsChromeBrowser Method

[image]
Intersoft WebDesktop Documentation
IsChromeBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : IsChromeBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsChromeBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As Boolean

value = instance.IsChromeBrowser()
C#
public bool IsChromeBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


IsFlyPostBackControl Method

[image]
Intersoft WebDesktop Documentation
IsFlyPostBackControl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : IsFlyPostBackControl Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackControl() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As Boolean

value = instance.IsFlyPostBackControl()
C#
public virtual bool IsFlyPostBackControl()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


IsFlyPostBackRequest Method

[image]
Intersoft WebDesktop Documentation
IsFlyPostBackRequest Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : IsFlyPostBackRequest Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackRequest() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As Boolean

value = instance.IsFlyPostBackRequest()
C#
public virtual bool IsFlyPostBackRequest()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


IsGeckoBasedBrowser Method

[image]
Intersoft WebDesktop Documentation
IsGeckoBasedBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : IsGeckoBasedBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoBasedBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As Boolean

value = instance.IsGeckoBasedBrowser()
C#
public bool IsGeckoBasedBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


IsGeckoVersion18 Method

[image]
Intersoft WebDesktop Documentation
IsGeckoVersion18 Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : IsGeckoVersion18 Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoVersion18() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As Boolean

value = instance.IsGeckoVersion18()
C#
public bool IsGeckoVersion18()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


IsInDesignMode Method

[image]
Intersoft WebDesktop Documentation
IsInDesignMode Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : IsInDesignMode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInDesignMode() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As Boolean

value = instance.IsInDesignMode()
C#
public bool IsInDesignMode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


IsInternetExplorer8Browser Method

[image]
Intersoft WebDesktop Documentation
IsInternetExplorer8Browser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : IsInternetExplorer8Browser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorer8Browser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As Boolean

value = instance.IsInternetExplorer8Browser()
C#
public bool IsInternetExplorer8Browser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


IsInternetExplorerBrowser Method

[image]
Intersoft WebDesktop Documentation
IsInternetExplorerBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : IsInternetExplorerBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorerBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As Boolean

value = instance.IsInternetExplorerBrowser()
C#
public bool IsInternetExplorerBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


IsOperaBrowser Method

[image]
Intersoft WebDesktop Documentation
IsOperaBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : IsOperaBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsOperaBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As Boolean

value = instance.IsOperaBrowser()
C#
public bool IsOperaBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


IsSafariBrowser Method

[image]
Intersoft WebDesktop Documentation
IsSafariBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : IsSafariBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsSafariBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As Boolean

value = instance.IsSafariBrowser()
C#
public bool IsSafariBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


IsW3CStandardBrowser Method

[image]
Intersoft WebDesktop Documentation
IsW3CStandardBrowser Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : IsW3CStandardBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsW3CStandardBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As Boolean

value = instance.IsW3CStandardBrowser()
C#
public bool IsW3CStandardBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


LoadCommandsStructureFromXml Method

[image]
Intersoft WebDesktop Documentation
LoadCommandsStructureFromXml Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : LoadCommandsStructureFromXml Method

Glossary Item Box

Overload List

Overload | Description
LoadCommandsStructureFromXml(String) |
LoadCommandsStructureFromXml(XmlDocument) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


LoadCommandsStructureFromXml(String) Method

[image]
Intersoft WebDesktop Documentation
LoadCommandsStructureFromXml(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class > LoadCommandsStructureFromXml Method : LoadCommandsStructureFromXml(String) Method

fileName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadCommandsStructureFromXml( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim fileName As String

instance.LoadCommandsStructureFromXml(fileName)
C#
public void LoadCommandsStructureFromXml(
   string fileName
)

Parameters

fileName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members
Overload List


LoadCommandsStructureFromXml(XmlDocument) Method

[image]
Intersoft WebDesktop Documentation
LoadCommandsStructureFromXml(XmlDocument) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class > LoadCommandsStructureFromXml Method : LoadCommandsStructureFromXml(XmlDocument) Method

doc

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadCommandsStructureFromXml( _
   ByVal doc As System.Xml.XmlDocument _
)
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim doc As System.Xml.XmlDocument

instance.LoadCommandsStructureFromXml(doc)
C#
public void LoadCommandsStructureFromXml(
   System.Xml.XmlDocument doc
)

Parameters

doc

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members
Overload List


LoadLayout Method

[image]
Intersoft WebDesktop Documentation
LoadLayout Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : LoadLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim settings As ISNet.WebUI.LayoutInfo

instance.LoadLayout(settings)
C#
public virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


LoadLayoutFromFile Method

[image]
Intersoft WebDesktop Documentation
LoadLayoutFromFile Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : LoadLayoutFromFile Method

filePath

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromFile( _
   ByVal filePath As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim filePath As String

instance.LoadLayoutFromFile(filePath)
C#
public virtual void LoadLayoutFromFile(
   string filePath
)

Parameters

filePath

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


LoadLayoutFromPredefinedName Method

[image]
Intersoft WebDesktop Documentation
LoadLayoutFromPredefinedName Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : LoadLayoutFromPredefinedName Method

predefinedName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromPredefinedName( _
   ByVal predefinedName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim predefinedName As String

instance.LoadLayoutFromPredefinedName(predefinedName)
C#
public virtual void LoadLayoutFromPredefinedName(
   string predefinedName
)

Parameters

predefinedName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


LoadLayoutFromStream Method

[image]
Intersoft WebDesktop Documentation
LoadLayoutFromStream Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : LoadLayoutFromStream Method

stream

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromStream( _
   ByVal stream As System.IO.Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim stream As System.IO.Stream

instance.LoadLayoutFromStream(stream)
C#
public virtual void LoadLayoutFromStream(
   System.IO.Stream stream
)

Parameters

stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


LoadPostData Method

[image]
Intersoft WebDesktop Documentation
LoadPostData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : LoadPostData Method

postDataKey
postCollection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function LoadPostData( _
   ByVal postDataKey As String, _
   ByVal postCollection As System.Collections.Specialized.NameValueCollection _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim postDataKey As String
Dim postCollection As System.Collections.Specialized.NameValueCollection
Dim value As Boolean

value = instance.LoadPostData(postDataKey, postCollection)
C#
public override bool LoadPostData(
   string postDataKey,
   System.Collections.Specialized.NameValueCollection postCollection
)

Parameters

postDataKey
postCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


MergeStyle Method

[image]
Intersoft WebDesktop Documentation
MergeStyle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : MergeStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub MergeStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim s As System.Web.UI.WebControls.Style

instance.MergeStyle(s)
C#
public void MergeStyle(
   System.Web.UI.WebControls.Style s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


OnInfoChanged Method

[image]
Intersoft WebDesktop Documentation
OnInfoChanged Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : OnInfoChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnInfoChanged( _
   ByVal e As ISNet.WebUI.SynchronizeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim e As ISNet.WebUI.SynchronizeEventArgs

instance.OnInfoChanged(e)
C#
public void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


OnPreInitialize Method

[image]
Intersoft WebDesktop Documentation
OnPreInitialize Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : OnPreInitialize Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnPreInitialize()
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar

instance.OnPreInitialize()
C#
public virtual void OnPreInitialize()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


RaisePostBackEvent Method

[image]
Intersoft WebDesktop Documentation
RaisePostBackEvent Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : RaisePostBackEvent Method

eventArgument

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RaisePostBackEvent( _
   ByVal eventArgument As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim eventArgument As String

instance.RaisePostBackEvent(eventArgument)
C#
public void RaisePostBackEvent(
   string eventArgument
)

Parameters

eventArgument

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


RaisePostDataChangedEvent Method

[image]
Intersoft WebDesktop Documentation
RaisePostDataChangedEvent Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : RaisePostDataChangedEvent Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RaisePostDataChangedEvent()
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar

instance.RaisePostDataChangedEvent()
C#
public virtual void RaisePostDataChangedEvent()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


ReadWebConfigValue Method

[image]
Intersoft WebDesktop Documentation
ReadWebConfigValue Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : ReadWebConfigValue Method

key

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ReadWebConfigValue( _
   ByVal key As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim key As String
Dim value As String

value = instance.ReadWebConfigValue(key)
C#
public string ReadWebConfigValue(
   string key
)

Parameters

key

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


RecreateChildControls Method

[image]
Intersoft WebDesktop Documentation
RecreateChildControls Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : RecreateChildControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RecreateChildControls()
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar

instance.RecreateChildControls()
C#
public void RecreateChildControls()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


RegisterBoxSizing Method

[image]
Intersoft WebDesktop Documentation
RegisterBoxSizing Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : RegisterBoxSizing Method

Glossary Item Box

Overload List

Overload | Description
RegisterBoxSizing() | (Inherited from ISNet.WebUI.ISNetControl)
RegisterBoxSizing(Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


RegisterBoxSizing() Method

[image]
Intersoft WebDesktop Documentation
RegisterBoxSizing() Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class > RegisterBoxSizing Method : RegisterBoxSizing() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing()
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar

instance.RegisterBoxSizing()
C#
public void RegisterBoxSizing()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members
Overload List


RegisterBoxSizing(Boolean) Method

[image]
Intersoft WebDesktop Documentation
RegisterBoxSizing(Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class > RegisterBoxSizing Method : RegisterBoxSizing(Boolean) Method

forceAll

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing( _
   ByVal forceAll As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim forceAll As Boolean

instance.RegisterBoxSizing(forceAll)
C#
public void RegisterBoxSizing(
   bool forceAll
)

Parameters

forceAll

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members
Overload List


RegisterGlobalStyle Method

[image]
Intersoft WebDesktop Documentation
RegisterGlobalStyle Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : RegisterGlobalStyle Method

style

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterGlobalStyle( _
   ByVal style As ISNet.WebUI.WebStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim style As ISNet.WebUI.WebStyle

instance.RegisterGlobalStyle(style)
C#
public void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle style
)

Parameters

style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


RegisterLink Method

[image]
Intersoft WebDesktop Documentation
RegisterLink Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : RegisterLink Method

name
url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterLink( _
   ByVal name As String, _
   ByVal url As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim name As String
Dim url As String

instance.RegisterLink(name, url)
C#
public void RegisterLink(
   string name,
   string url
)

Parameters

name
url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


RegisterOptimizedCssClasses Method

[image]
Intersoft WebDesktop Documentation
RegisterOptimizedCssClasses Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : RegisterOptimizedCssClasses Method

runtimeStyleOnly

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterOptimizedCssClasses( _
   ByVal runtimeStyleOnly As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim runtimeStyleOnly As Boolean

instance.RegisterOptimizedCssClasses(runtimeStyleOnly)
C#
public void RegisterOptimizedCssClasses(
   bool runtimeStyleOnly
)

Parameters

runtimeStyleOnly

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


RegisterPreloadImage Method

[image]
Intersoft WebDesktop Documentation
RegisterPreloadImage Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : RegisterPreloadImage Method

image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterPreloadImage( _
   ByVal image As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim image As String

instance.RegisterPreloadImage(image)
C#
public void RegisterPreloadImage(
   string image
)

Parameters

image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


RegisterScript Method

[image]
Intersoft WebDesktop Documentation
RegisterScript Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : RegisterScript Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub RegisterScript()
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar

instance.RegisterScript()
C#
public override void RegisterScript()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


RegisterSharePointHandler Method

[image]
Intersoft WebDesktop Documentation
RegisterSharePointHandler Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : RegisterSharePointHandler Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RegisterSharePointHandler()
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar

instance.RegisterSharePointHandler()
C#
public virtual void RegisterSharePointHandler()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


RenderBeginTag Method

[image]
Intersoft WebDesktop Documentation
RenderBeginTag Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : RenderBeginTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderBeginTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderBeginTag(writer)
C#
public virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


RenderControl Method

[image]
Intersoft WebDesktop Documentation
RenderControl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : RenderControl Method

Glossary Item Box

Overload List

Overload | Description
RenderControl | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


RenderControl(HtmlTextWriter) Method

[image]
Intersoft WebDesktop Documentation
RenderControl(HtmlTextWriter) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : RenderControl(HtmlTextWriter) Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderControl( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderControl(writer)
C#
public virtual void RenderControl(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


RenderEndTag Method

[image]
Intersoft WebDesktop Documentation
RenderEndTag Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : RenderEndTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub RenderEndTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderEndTag(writer)
C#
public override void RenderEndTag(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


ResetUsageData Method

[image]
Intersoft WebDesktop Documentation
ResetUsageData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : ResetUsageData Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ResetUsageData()
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar

instance.ResetUsageData()
C#
public void ResetUsageData()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


ResolveClientUrl Method

[image]
Intersoft WebDesktop Documentation
ResolveClientUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : ResolveClientUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveClientUrl( _
   ByVal relativeUrl As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim relativeUrl As String
Dim value As String

value = instance.ResolveClientUrl(relativeUrl)
C#
public string ResolveClientUrl(
   string relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


ResolveImagePath Method

[image]
Intersoft WebDesktop Documentation
ResolveImagePath Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : ResolveImagePath Method

folder
image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveImagePath( _
   ByVal folder As String, _
   ByVal image As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim folder As String
Dim image As String
Dim value As String

value = instance.ResolveImagePath(folder, image)
C#
public string ResolveImagePath(
   string folder,
   string image
)

Parameters

folder
image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


ResolveRelativeURL Method

[image]
Intersoft WebDesktop Documentation
ResolveRelativeURL Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : ResolveRelativeURL Method

url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ResolveRelativeURL( _
   ByVal url As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim url As String
Dim value As String

value = instance.ResolveRelativeURL(url)
C#
public virtual string ResolveRelativeURL(
   string url
)

Parameters

url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


ResolveResourceUrl Method

[image]
Intersoft WebDesktop Documentation
ResolveResourceUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : ResolveResourceUrl Method

kind
defaultFolder
currentFolder
resourceName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveResourceUrl( _
   ByVal kind As ISNet.WebUI.ResourceKind, _
   ByVal defaultFolder As String, _
   ByVal currentFolder As String, _
   ByVal resourceName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim kind As ISNet.WebUI.ResourceKind
Dim defaultFolder As String
Dim currentFolder As String
Dim resourceName As String
Dim value As String

value = instance.ResolveResourceUrl(kind, defaultFolder, currentFolder, resourceName)
C#
public string ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   string defaultFolder,
   string currentFolder,
   string resourceName
)

Parameters

kind
defaultFolder
currentFolder
resourceName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


ResolveUrl Method

[image]
Intersoft WebDesktop Documentation
ResolveUrl Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : ResolveUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveUrl( _
   ByVal relativeUrl As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim relativeUrl As String
Dim value As String

value = instance.ResolveUrl(relativeUrl)
C#
public string ResolveUrl(
   string relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


SaveCommandsStructureToXml Method

[image]
Intersoft WebDesktop Documentation
SaveCommandsStructureToXml Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : SaveCommandsStructureToXml Method

Glossary Item Box

Overload List

Overload | Description
SaveCommandsStructureToXml(String) |
SaveCommandsStructureToXml() |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


SaveCommandsStructureToXml(String) Method

[image]
Intersoft WebDesktop Documentation
SaveCommandsStructureToXml(String) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class > SaveCommandsStructureToXml Method : SaveCommandsStructureToXml(String) Method

fileName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub SaveCommandsStructureToXml( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim fileName As String

instance.SaveCommandsStructureToXml(fileName)
C#
public void SaveCommandsStructureToXml(
   string fileName
)

Parameters

fileName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members
Overload List


SaveCommandsStructureToXml() Method

[image]
Intersoft WebDesktop Documentation
SaveCommandsStructureToXml() Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class > SaveCommandsStructureToXml Method : SaveCommandsStructureToXml() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function SaveCommandsStructureToXml() As System.Xml.XmlDocument
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As System.Xml.XmlDocument

value = instance.SaveCommandsStructureToXml()
C#
public System.Xml.XmlDocument SaveCommandsStructureToXml()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members
Overload List


SaveLayout Method

[image]
Intersoft WebDesktop Documentation
SaveLayout Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : SaveLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim settings As ISNet.WebUI.LayoutInfo

instance.SaveLayout(settings)
C#
public virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


SaveLayoutToFile Method

[image]
Intersoft WebDesktop Documentation
SaveLayoutToFile Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : SaveLayoutToFile Method

filePath
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToFile( _
   ByVal filePath As String, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim filePath As String
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToFile(filePath, saveOptions)
C#
public virtual void SaveLayoutToFile(
   string filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

filePath
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


SaveLayoutToStream Method

[image]
Intersoft WebDesktop Documentation
SaveLayoutToStream Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : SaveLayoutToStream Method

stream
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToStream( _
   ByVal stream As System.IO.Stream, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim stream As System.IO.Stream
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToStream(stream, saveOptions)
C#
public virtual void SaveLayoutToStream(
   System.IO.Stream stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

stream
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


SetPlaceHolder Method

[image]
Intersoft WebDesktop Documentation
SetPlaceHolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : SetPlaceHolder Method

plHolder

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetPlaceHolder( _
   ByVal plHolder As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim plHolder As String

instance.SetPlaceHolder(plHolder)
C#
public void SetPlaceHolder(
   string plHolder
)

Parameters

plHolder

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


SetRenderMethodDelegate Method

[image]
Intersoft WebDesktop Documentation
SetRenderMethodDelegate Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : SetRenderMethodDelegate Method

renderMethod

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetRenderMethodDelegate( _
   ByVal renderMethod As System.Web.UI.RenderMethod _
)
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim renderMethod As System.Web.UI.RenderMethod

instance.SetRenderMethodDelegate(renderMethod)
C#
public void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod renderMethod
)

Parameters

renderMethod

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


SetSessionTheme Method

[image]
Intersoft WebDesktop Documentation
SetSessionTheme Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : SetSessionTheme Method

themeInfo

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetSessionTheme( _
   ByVal themeInfo As ISNet.WebUI.ThemeInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim themeInfo As ISNet.WebUI.ThemeInfo

instance.SetSessionTheme(themeInfo)
C#
public void SetSessionTheme(
   ISNet.WebUI.ThemeInfo themeInfo
)

Parameters

themeInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


ShouldReturnJson Method

[image]
Intersoft WebDesktop Documentation
ShouldReturnJson Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : ShouldReturnJson Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ShouldReturnJson() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As Boolean

value = instance.ShouldReturnJson()
C#
public virtual bool ShouldReturnJson()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


SynchronizeBarProperties Method

[image]
Intersoft WebDesktop Documentation
SynchronizeBarProperties Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : SynchronizeBarProperties Method

bar

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SynchronizeBarProperties( _
   ByVal bar As IBar _
)
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim bar As IBar

instance.SynchronizeBarProperties(bar)
C#
public void SynchronizeBarProperties(
   IBar bar
)

Parameters

bar

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


SynchronizeTemplatesFrom Method

[image]
Intersoft WebDesktop Documentation
SynchronizeTemplatesFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : SynchronizeTemplatesFrom Method

sourceObj

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SynchronizeTemplatesFrom( _
   ByVal sourceObj As ISNet.WebUI.ISNetControl _
)
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim sourceObj As ISNet.WebUI.ISNetControl

instance.SynchronizeTemplatesFrom(sourceObj)
C#
public void SynchronizeTemplatesFrom(
   ISNet.WebUI.ISNetControl sourceObj
)

Parameters

sourceObj

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


AccessKey Property

[image]
Intersoft WebDesktop Documentation
AccessKey Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : AccessKey Property

Glossary Item Box

Keyboard shortcut used by the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property AccessKey As String
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As String

instance.AccessKey = value

value = instance.AccessKey
C#
public virtual string AccessKey {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


WebToolBar Class Properties

[image]
Intersoft WebDesktop Documentation
WebToolBar Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebToolBar Class

Glossary Item Box

For a list of all members of this type, see WebToolBar members.

Public Properties

 | Name | Description
Public Property | AccessKey | Keyboard shortcut used by the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | AddRemoveOptionMenuViewMode | Gets or sets the add remove option menu view mode.
Public Property | AllowCustomize | Gets or sets a value that indicates whether a WebToolBar control is customizable.
Public Property | AllowDockBottom | Gets or sets a value that indicates whether a WebToolBar control can be dock to bottom area of PlaceHolderManager.
Public Property | AllowDockLeft | Gets or sets a value that indicates whether a WebToolBar control can be dock to left area of PlaceHolderManager.
Public Property | AllowDockRight | Gets or sets a value that indicates whether a WebToolBar control can be dock to right area of PlaceHolderManager.
Public Property | AllowDockTop | Gets or sets a value that indicates whether a WebToolBar control can be dock to top area of PlaceHolderManager.
Public Property | AllowExpandCollapse | Gets or sets a value that indicates whether a WebToolBar control is expandable and collapsible.
Public Property | AllowFloat | Gets or sets a value that indicates whether a WebToolBar control is floatable.
Public Property | AllowMove | Gets or sets a value that indicates whether a WebToolBar control is moveable.
Public Property | AutoPostBack | Gets or sets a value that indicates whether a Command is autopostback.
Public Property | BarStyle | Gets or sets the Bar style.
Public Property | BodyStyle | Gets or sets the style properties of body bar section in the bar control.
Public Property | Caption | Specifies the bar caption.
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | CommandClientSideEvents | Specifies the client side (Javascript) tool command events.
Public Property | CommandDisabledStyle | Gets or sets the style properties of disable command style.
Public Property | CommandMargin | Gets or sets the margin for commands.
Public Property | Commands | Gets the collection of tool commands in this WebToolBar.
Public Property | CommandSize | Specifies the ToolCommand size.
Public Property | CommandStyle | Gets or sets the style properties of command in the bar control.
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Display | Gets or sets a value that indicates whether a WebToolBar control is displayed as UI on the page.
Public Property | DisplayAccessKeyOnToolTip | Gets or sets a value that indicates whether access key is displayed on tooltip.
Public Property | DisplayMode | Specifies the ToolCommand display mode.
Public Property | DisplayToolTip | Gets or sets a value that indicates whether tooltip is displayed.
Public Property | DockingArea | Gets or sets the WebToolBar docking area.
Public Property | DockingOffset | Specifies the WebToolBar docking offset.
Public Property | DockingRow | Specifies the WebToolBar docking row.
Public Property | Enabled | Enabled state of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableManagedTheming | Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to False, this control will not apply the style defined in Theme Architecture. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | Whether the control automatically saves its state for use in round-trips. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | FillDockingRow | Gets or sets a value that indicates whether a WebToolBar control dimension fills the row region of PlaceHolderManager docking row.
Public Property | GreyImageWhenDisabled | Gets or sets a value indicates whether a grey image is applied when command is disabled.
Public Property | HandleStyle | Gets or sets the style properties of handle bar section in the bar control.
Public Property | HandleVisible | Gets or sets a value that indicates whether a WebToolBar handle section is visible.
Public Property | HeaderButtonStyle | Gets or sets the style properties of the header bar close button in the bar control.
Public Property | HeaderCaptionStyle | Gets or sets the style properties of the header bar caption in the bar control.
Public Property | HeaderHeight | Gets or sets the height of the WebToolBar control header.
Public Property | Height | Overridden. Gets or sets the height of the WebToolBar control.
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ImagesDirectory | Gets or sets the location of images used to render the control.
Public Property | ImageSize | Specifies the ToolCommand image size.
Public Property | IntegratedTo | Gets or sets the WebToolBar menu integrated mode.
Public Property | IsFloat | Gets or sets a value that indicates whether a WebToolBar control is floated on the page.
Public Property | LazyLoadContextMenu | Gets or sets a value that indicates whether DropdownButton context menu or SplitButton context menu is loaded lazily (on first button clicked).
Public Property | MenuStyleSettings | Gets or sets the style properties of menu styles in the bar control.
Public Property | MergeCommandID | Specifies the Merge Command ID.
Public Property | MergeToolBar | Gets or sets a value that indicates whether a WebToolBar control is a merge WebToolBar.
Public Property | MergeToolBarParentID | Gets or sets the merged WebToolBar parent ID.
Public Property | MergeToolBarParentWindowName | Gets or sets the merged WebToolBar parent window name.
Public Property | Opacity |
Public Property | OptionStyle | Gets or sets the style properties of option bar section in the bar control.
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | PlaceHolder | Specifies the bar placeholder manager.
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden. Gets or sets the directory where all required scripts for the control are stored.
Public Property | SeparatorStyle | Gets or sets the style properties of separator command in the bar control.
Public Property | SharedScriptDirectory | Overridden.
Public Property | ShowDelay | Gets or sets the amount of submenu that shows delay in milliseconds.
Public Property | ShowFocusBorder | Gets or sets a boolean value indicating whether to show border around the Active Command when tabbed via keyboard. This property is recommended for Accessbility and Section 508 Compliant.
Public Property | SizeMode | Gets or sets the tool command sizing mode.
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | TextAlign | Specifies the ToolCommand text align type.
Public Property | ToggleGroups | Gets the collection of toggle group commands in this WebToolBar.
Public Property | ToolTip | The tooltip displayed when the mouse is over the control.
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateItems | Gets or sets the items to be stored in view state storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | Gets or sets the server connection string for file server-based viewstate storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | Gets or sets the location to store the viewstate of this control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | Overridden. Indicates whether the control is visible and rendered.
Public Property | Width | Overridden. The width of the control.
Public Property | XmlCompressionEnabled | Specifies whether the Xml used for clientside state storage should be compressed. (Inherited from ISNet.WebUI.ISNetControl)
Top

See Also

Reference

WebToolBar Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Creating Dockable Toolbar
Creating Standalone Toolbar
Changing Toolbar docking at design time
Configuring Floating Mode
Configuring ToolCommand Toolbar Merging

Concepts

WebToolBar Overview
WebToolBar Features
Understanding ToolBar Architecture
Working with ToolBar Designer
Rich Design-time Experience


WebToolBar Constructor

[image]
Intersoft WebDesktop Documentation
WebToolBar Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : WebToolBar Constructor

Glossary Item Box

Initializes a new instance of the WebToolBar class.

Overload List

Overload | Description
WebToolBar Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


AddRemoveOptionMenuViewMode Property

[image]
Intersoft WebDesktop Documentation
AddRemoveOptionMenuViewMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : AddRemoveOptionMenuViewMode Property

Glossary Item Box

Gets or sets the add remove option menu view mode.

Syntax

Visual Basic (Declaration)
Public Property AddRemoveOptionMenuViewMode As AddRemoveOptionMenuViewMode
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As AddRemoveOptionMenuViewMode

instance.AddRemoveOptionMenuViewMode = value

value = instance.AddRemoveOptionMenuViewMode
C#
public AddRemoveOptionMenuViewMode AddRemoveOptionMenuViewMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


AllowCustomize Property

[image]
Intersoft WebDesktop Documentation
AllowCustomize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : AllowCustomize Property

Glossary Item Box

Gets or sets a value that indicates whether a WebToolBar control is customizable.

Syntax

Visual Basic (Declaration)
Public Property AllowCustomize As AllowCustomize
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As AllowCustomize

instance.AllowCustomize = value

value = instance.AllowCustomize
C#
public AllowCustomize AllowCustomize {get; set;}

Remarks

Using this property you can implement a Customization DialogBox. Customization DialogBox is a feature which allows the user to configure the WebToolBar(s) settings at run-time. One of the benefits having this feature is the customized WebToolBar, where the users can modify it to their own requirement, which later on the structure can be saved to xml.

To enable WebToolBar's Customization, you need to set this property to True. For more information regarding WebToolBar's Customization please refer to Using Customization Dialog Box.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members

Concepts

Using Customization Dialog Box


AllowDockBottom Property

[image]
Intersoft WebDesktop Documentation
AllowDockBottom Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : AllowDockBottom Property

Glossary Item Box

Gets or sets a value that indicates whether a WebToolBar control can be dock to bottom area of PlaceHolderManager.

Syntax

Visual Basic (Declaration)
Public Property AllowDockBottom As AllowDock
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As AllowDock

instance.AllowDockBottom = value

value = instance.AllowDockBottom
C#
public AllowDock AllowDockBottom {get; set;}

Remarks

Using the docking mode, you can freely customize the docking position of WebToolBar in the PlaceHolderManager, such as left, right, top and bottom.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members

Concepts

WebToolBar Features


AllowDockLeft Property

[image]
Intersoft WebDesktop Documentation
AllowDockLeft Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : AllowDockLeft Property

Glossary Item Box

Gets or sets a value that indicates whether a WebToolBar control can be dock to left area of PlaceHolderManager.

Syntax

Visual Basic (Declaration)
Public Property AllowDockLeft As AllowDock
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As AllowDock

instance.AllowDockLeft = value

value = instance.AllowDockLeft
C#
public AllowDock AllowDockLeft {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members

Concepts

WebToolBar Features


AllowDockRight Property

[image]
Intersoft WebDesktop Documentation
AllowDockRight Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : AllowDockRight Property

Glossary Item Box

Gets or sets a value that indicates whether a WebToolBar control can be dock to right area of PlaceHolderManager.

Syntax

Visual Basic (Declaration)
Public Property AllowDockRight As AllowDock
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As AllowDock

instance.AllowDockRight = value

value = instance.AllowDockRight
C#
public AllowDock AllowDockRight {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members

Concepts

WebToolBar Features


AllowDockTop Property

[image]
Intersoft WebDesktop Documentation
AllowDockTop Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : AllowDockTop Property

Glossary Item Box

Gets or sets a value that indicates whether a WebToolBar control can be dock to top area of PlaceHolderManager.

Syntax

Visual Basic (Declaration)
Public Property AllowDockTop As AllowDock
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As AllowDock

instance.AllowDockTop = value

value = instance.AllowDockTop
C#
public AllowDock AllowDockTop {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members

Concepts

WebToolBar Features


AllowExpandCollapse Property

[image]
Intersoft WebDesktop Documentation
AllowExpandCollapse Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : AllowExpandCollapse Property

Glossary Item Box

Gets or sets a value that indicates whether a WebToolBar control is expandable and collapsible.

Syntax

Visual Basic (Declaration)
Public Property AllowExpandCollapse As AllowExpandCollapse
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As AllowExpandCollapse

instance.AllowExpandCollapse = value

value = instance.AllowExpandCollapse
C#
public AllowExpandCollapse AllowExpandCollapse {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


AllowFloat Property

[image]
Intersoft WebDesktop Documentation
AllowFloat Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : AllowFloat Property

Glossary Item Box

Gets or sets a value that indicates whether a WebToolBar control is floatable.

Syntax

Visual Basic (Declaration)
Public Property AllowFloat As AllowFloat
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As AllowFloat

instance.AllowFloat = value

value = instance.AllowFloat
C#
public AllowFloat AllowFloat {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


AllowMove Property

[image]
Intersoft WebDesktop Documentation
AllowMove Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : AllowMove Property

Glossary Item Box

Gets or sets a value that indicates whether a WebToolBar control is moveable.

Syntax

Visual Basic (Declaration)
Public Property AllowMove As AllowMove
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As AllowMove

instance.AllowMove = value

value = instance.AllowMove
C#
public AllowMove AllowMove {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


AutoPostBack Property

[image]
Intersoft WebDesktop Documentation
AutoPostBack Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : AutoPostBack Property

Glossary Item Box

Gets or sets a value that indicates whether a Command is autopostback.

Syntax

Visual Basic (Declaration)
Public Overridable Property AutoPostBack As AutoPostBackMode
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As AutoPostBackMode

instance.AutoPostBack = value

value = instance.AutoPostBack
C#
public virtual AutoPostBackMode AutoPostBack {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


BarStyle Property

[image]
Intersoft WebDesktop Documentation
BarStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : BarStyle Property

Glossary Item Box

Gets or sets the Bar style.

Syntax

Visual Basic (Declaration)
Public Property BarStyle As BarStyle
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As BarStyle

instance.BarStyle = value

value = instance.BarStyle
C#
public BarStyle BarStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


BodyStyle Property

[image]
Intersoft WebDesktop Documentation
BodyStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : BodyStyle Property

Glossary Item Box

Gets or sets the style properties of body bar section in the bar control.

Syntax

Visual Basic (Declaration)
Public Property BodyStyle As BarSectionStyle
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As BarSectionStyle

instance.BodyStyle = value

value = instance.BodyStyle
C#
public BarSectionStyle BodyStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


Caption Property

[image]
Intersoft WebDesktop Documentation
Caption Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : Caption Property

Glossary Item Box

Specifies the bar caption.

Syntax

Visual Basic (Declaration)
Public Overridable Property Caption As String
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As String

instance.Caption = value

value = instance.Caption
C#
public virtual string Caption {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


ClientIDMode Property

[image]
Intersoft WebDesktop Documentation
ClientIDMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : ClientIDMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ClientIDMode As System.Web.UI.ClientIDMode
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As System.Web.UI.ClientIDMode

instance.ClientIDMode = value

value = instance.ClientIDMode
C#
public virtual System.Web.UI.ClientIDMode ClientIDMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


CommandClientSideEvents Property

[image]
Intersoft WebDesktop Documentation
CommandClientSideEvents Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : CommandClientSideEvents Property

Glossary Item Box

Specifies the client side (Javascript) tool command events.

Syntax

Visual Basic (Declaration)
Public Property CommandClientSideEvents As ISNet.WebUI.BaseMouseElementClientSideEvents
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As ISNet.WebUI.BaseMouseElementClientSideEvents

instance.CommandClientSideEvents = value

value = instance.CommandClientSideEvents
C#
public ISNet.WebUI.BaseMouseElementClientSideEvents CommandClientSideEvents {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


CommandDisabledStyle Property

[image]
Intersoft WebDesktop Documentation
CommandDisabledStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : CommandDisabledStyle Property

Glossary Item Box

Gets or sets the style properties of disable command style.

Syntax

Visual Basic (Declaration)
Public Overridable Property CommandDisabledStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As ISNet.WebUI.WebStyle

instance.CommandDisabledStyle = value

value = instance.CommandDisabledStyle
C#
public virtual ISNet.WebUI.WebStyle CommandDisabledStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


CommandMargin Property

[image]
Intersoft WebDesktop Documentation
CommandMargin Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : CommandMargin Property

Glossary Item Box

Gets or sets the margin for commands.

Syntax

Visual Basic (Declaration)
Public Property CommandMargin As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As System.Web.UI.WebControls.Unit

instance.CommandMargin = value

value = instance.CommandMargin
C#
public System.Web.UI.WebControls.Unit CommandMargin {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


Commands Property

[image]
Intersoft WebDesktop Documentation
Commands Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : Commands Property

Glossary Item Box

Gets the collection of tool commands in this WebToolBar.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Commands As ToolCommandCollection
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As ToolCommandCollection

value = instance.Commands
C#
public ToolCommandCollection Commands {get;}

Remarks

WebToolBar has several command types for its Items. These ToolCommand's Types consist of Button, Toggle Button, DropDown Button, Split Button, Separator, Custom, and Container.

  • Button
    Button Type is the most common type in any ToolBar. It simply represent a button behavior in toolBar.
  • ToggleButton
    ToggleButton is a button that has select and unselect state. This type of button can be either used in a group of toggle buttons (linked with Toggle's GroupName) or act in SingleMode.
    Usually a SingleMode ToggleButton is used for as a flag to set active/inactive of certain state. On the other hand a GroupMode ToggleButton is used as a selection from several states that included in the Toggle Group.
  • DropDownButton
    DropDown Button consist of sub items (Collection of WebMenuItem) where each of sub items then can have it owns action.
  • SplitButton
    Similar with DropDown Button, it consist sub items (Collection of WebMenuItem), however unlike DropDown Button, the SplitButton's parent command can also have it own action.
  • Custom
    Using the ITemplate to design the custom command type for WebToolBar ensure the flexibility to use any control(s) to represent a command type in WebToolBar.
  • Container
    One of key features of WebToolBar is ability to merge two or more WebToolBars inside a given WebTolBar, this can be achieved using Container Type where it will act as the container for the merged WebToolbar.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members

Tasks

Using ToolCommand Types
Using Images for Toolbar Appearance

Concepts

WebToolBar Features

concepts

Understanding ToolBar Architecture

tasks

Configuring ToolCommand Toolbar Merging
Configuring ToolBar Merging
Changing Toolbar Styles


CommandSize Property

[image]
Intersoft WebDesktop Documentation
CommandSize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : CommandSize Property

Glossary Item Box

Specifies the ToolCommand size.

Syntax

Visual Basic (Declaration)
Public Property CommandSize As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As System.Web.UI.WebControls.Unit

instance.CommandSize = value

value = instance.CommandSize
C#
public System.Web.UI.WebControls.Unit CommandSize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


CommandStyle Property

[image]
Intersoft WebDesktop Documentation
CommandStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : CommandStyle Property

Glossary Item Box

Gets or sets the style properties of command in the bar control.

Syntax

Visual Basic (Declaration)
Public Overridable Property CommandStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As ISNet.WebUI.DynamicStyle

instance.CommandStyle = value

value = instance.CommandStyle
C#
public virtual ISNet.WebUI.DynamicStyle CommandStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members

Tasks

Changing Toolbar Styles

Concepts

Working with ToolBar Designer


ControlDataTransferFormat Property

[image]
Intersoft WebDesktop Documentation
ControlDataTransferFormat Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : ControlDataTransferFormat Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ControlDataTransferFormat As ISNet.WebUI.DataTransferFormat
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As ISNet.WebUI.DataTransferFormat

instance.ControlDataTransferFormat = value

value = instance.ControlDataTransferFormat
C#
public virtual ISNet.WebUI.DataTransferFormat ControlDataTransferFormat {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


Display Property

[image]
Intersoft WebDesktop Documentation
Display Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : Display Property

Glossary Item Box

Gets or sets a value that indicates whether a WebToolBar control is displayed as UI on the page.

Syntax

Visual Basic (Declaration)
Public Property Display As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As Boolean

instance.Display = value

value = instance.Display
C#
public bool Display {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


DisplayAccessKeyOnToolTip Property

[image]
Intersoft WebDesktop Documentation
DisplayAccessKeyOnToolTip Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : DisplayAccessKeyOnToolTip Property

Glossary Item Box

Gets or sets a value that indicates whether access key is displayed on tooltip.

Syntax

Visual Basic (Declaration)
Public Property DisplayAccessKeyOnToolTip As DisplayAccessKeyOnToolTip
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As DisplayAccessKeyOnToolTip

instance.DisplayAccessKeyOnToolTip = value

value = instance.DisplayAccessKeyOnToolTip
C#
public DisplayAccessKeyOnToolTip DisplayAccessKeyOnToolTip {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


DisplayMode Property

[image]
Intersoft WebDesktop Documentation
DisplayMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : DisplayMode Property

Glossary Item Box

Specifies the ToolCommand display mode.

Syntax

Visual Basic (Declaration)
Public Property DisplayMode As CommandDisplayMode
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As CommandDisplayMode

instance.DisplayMode = value

value = instance.DisplayMode
C#
public CommandDisplayMode DisplayMode {get; set;}

Remarks

Using this property you can customize the display mode of ToolBar, such as Text, Image, and TextAndImage.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members

Tasks

Changing Toolbar Styles
Using Images for Toolbar Appearance

Concepts

WebToolBar Features


DisplayToolTip Property

[image]
Intersoft WebDesktop Documentation
DisplayToolTip Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : DisplayToolTip Property

Glossary Item Box

Gets or sets a value that indicates whether tooltip is displayed.

Syntax

Visual Basic (Declaration)
Public Property DisplayToolTip As DisplayToolTip
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As DisplayToolTip

instance.DisplayToolTip = value

value = instance.DisplayToolTip
C#
public DisplayToolTip DisplayToolTip {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


DockingArea Property

[image]
Intersoft WebDesktop Documentation
DockingArea Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : DockingArea Property

Glossary Item Box

Gets or sets the WebToolBar docking area.

Syntax

Visual Basic (Declaration)
Public Property DockingArea As DockingArea
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As DockingArea

instance.DockingArea = value

value = instance.DockingArea
C#
public DockingArea DockingArea {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members

Tasks

Creating Dockable Toolbar

Concepts

WebToolBar Features


DockingOffset Property

[image]
Intersoft WebDesktop Documentation
DockingOffset Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : DockingOffset Property

Glossary Item Box

Specifies the WebToolBar docking offset.

Syntax

Visual Basic (Declaration)
Public Property DockingOffset As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As Integer

instance.DockingOffset = value

value = instance.DockingOffset
C#
public int DockingOffset {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


DockingRow Property

[image]
Intersoft WebDesktop Documentation
DockingRow Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : DockingRow Property

Glossary Item Box

Specifies the WebToolBar docking row.

Syntax

Visual Basic (Declaration)
Public Property DockingRow As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As Integer

instance.DockingRow = value

value = instance.DockingRow
C#
public int DockingRow {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


Enabled Property

[image]
Intersoft WebDesktop Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : Enabled Property

Glossary Item Box

Enabled state of the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property Enabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As Boolean

instance.Enabled = value

value = instance.Enabled
C#
public virtual bool Enabled {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


EnableManagedTheming Property

[image]
Intersoft WebDesktop Documentation
EnableManagedTheming Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : EnableManagedTheming Property

Glossary Item Box

Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to False, this control will not apply the style defined in Theme Architecture.

Syntax

Visual Basic (Declaration)
Public Overridable Property EnableManagedTheming As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As Boolean

instance.EnableManagedTheming = value

value = instance.EnableManagedTheming
C#
public virtual bool EnableManagedTheming {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


EnableTheming Property

[image]
Intersoft WebDesktop Documentation
EnableTheming Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : EnableTheming Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property EnableTheming As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As Boolean

instance.EnableTheming = value

value = instance.EnableTheming
C#
public virtual bool EnableTheming {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


EnableViewState Property

[image]
Intersoft WebDesktop Documentation
EnableViewState Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : EnableViewState Property

Glossary Item Box

Whether the control automatically saves its state for use in round-trips.

Syntax

Visual Basic (Declaration)
Public Overridable Property EnableViewState As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As Boolean

instance.EnableViewState = value

value = instance.EnableViewState
C#
public virtual bool EnableViewState {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


EnableWebResources Property

[image]
Intersoft WebDesktop Documentation
EnableWebResources Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : EnableWebResources Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property EnableWebResources As ISNet.WebUI.WebResourceType
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As ISNet.WebUI.WebResourceType

instance.EnableWebResources = value

value = instance.EnableWebResources
C#
public ISNet.WebUI.WebResourceType EnableWebResources {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


FillDockingRow Property

[image]
Intersoft WebDesktop Documentation
FillDockingRow Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : FillDockingRow Property

Glossary Item Box

Gets or sets a value that indicates whether a WebToolBar control dimension fills the row region of PlaceHolderManager docking row.

Syntax

Visual Basic (Declaration)
Public Property FillDockingRow As FillDockingRow
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As FillDockingRow

instance.FillDockingRow = value

value = instance.FillDockingRow
C#
public FillDockingRow FillDockingRow {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


GreyImageWhenDisabled Property

[image]
Intersoft WebDesktop Documentation
GreyImageWhenDisabled Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : GreyImageWhenDisabled Property

Glossary Item Box

Gets or sets a value indicates whether a grey image is applied when command is disabled.

Syntax

Visual Basic (Declaration)
Public Property GreyImageWhenDisabled As GreyImageWhenDisabled
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As GreyImageWhenDisabled

instance.GreyImageWhenDisabled = value

value = instance.GreyImageWhenDisabled
C#
public GreyImageWhenDisabled GreyImageWhenDisabled {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


HandleStyle Property

[image]
Intersoft WebDesktop Documentation
HandleStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : HandleStyle Property

Glossary Item Box

Gets or sets the style properties of handle bar section in the bar control.

Syntax

Visual Basic (Declaration)
Public Property HandleStyle As BarSectionStyle
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As BarSectionStyle

instance.HandleStyle = value

value = instance.HandleStyle
C#
public BarSectionStyle HandleStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


HandleVisible Property

[image]
Intersoft WebDesktop Documentation
HandleVisible Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : HandleVisible Property

Glossary Item Box

Gets or sets a value that indicates whether a WebToolBar handle section is visible.

Syntax

Visual Basic (Declaration)
Public Property HandleVisible As HandleVisible
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As HandleVisible

instance.HandleVisible = value

value = instance.HandleVisible
C#
public HandleVisible HandleVisible {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


HeaderButtonStyle Property

[image]
Intersoft WebDesktop Documentation
HeaderButtonStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : HeaderButtonStyle Property

Glossary Item Box

Gets or sets the style properties of the header bar close button in the bar control.

Syntax

Visual Basic (Declaration)
Public Overridable Property HeaderButtonStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As ISNet.WebUI.DynamicStyle

instance.HeaderButtonStyle = value

value = instance.HeaderButtonStyle
C#
public virtual ISNet.WebUI.DynamicStyle HeaderButtonStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


HeaderCaptionStyle Property

[image]
Intersoft WebDesktop Documentation
HeaderCaptionStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : HeaderCaptionStyle Property

Glossary Item Box

Gets or sets the style properties of the header bar caption in the bar control.

Syntax

Visual Basic (Declaration)
Public Overridable Property HeaderCaptionStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As ISNet.WebUI.WebStyle

instance.HeaderCaptionStyle = value

value = instance.HeaderCaptionStyle
C#
public virtual ISNet.WebUI.WebStyle HeaderCaptionStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


HeaderHeight Property

[image]
Intersoft WebDesktop Documentation
HeaderHeight Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : HeaderHeight Property

Glossary Item Box

Gets or sets the height of the WebToolBar control header.

Syntax

Visual Basic (Declaration)
Public Property HeaderHeight As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As System.Web.UI.WebControls.Unit

instance.HeaderHeight = value

value = instance.HeaderHeight
C#
public System.Web.UI.WebControls.Unit HeaderHeight {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


Height Property

[image]
Intersoft WebDesktop Documentation
Height Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : Height Property

Glossary Item Box

Gets or sets the height of the WebToolBar control.

Syntax

Visual Basic (Declaration)
Public Overrides Property Height As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As System.Web.UI.WebControls.Unit

instance.Height = value

value = instance.Height
C#
public override System.Web.UI.WebControls.Unit Height {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


ID Property

[image]
Intersoft WebDesktop Documentation
ID Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : ID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ID As String
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As String

instance.ID = value

value = instance.ID
C#
public virtual string ID {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


ImagesDirectory Property

[image]
Intersoft WebDesktop Documentation
ImagesDirectory Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : ImagesDirectory Property

Glossary Item Box

Gets or sets the location of images used to render the control.

Syntax

Visual Basic (Declaration)
Public Property ImagesDirectory As String
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As String

instance.ImagesDirectory = value

value = instance.ImagesDirectory
C#
public string ImagesDirectory {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


ImageSize Property

[image]
Intersoft WebDesktop Documentation
ImageSize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : ImageSize Property

Glossary Item Box

Specifies the ToolCommand image size.

Syntax

Visual Basic (Declaration)
Public Property ImageSize As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As System.Drawing.Size

instance.ImageSize = value

value = instance.ImageSize
C#
public System.Drawing.Size ImageSize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


IntegratedTo Property

[image]
Intersoft WebDesktop Documentation
IntegratedTo Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : IntegratedTo Property

Glossary Item Box

Gets or sets the WebToolBar menu integrated mode.

Syntax

Visual Basic (Declaration)
Public Property IntegratedTo As MenuIntegrationMode
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As MenuIntegrationMode

instance.IntegratedTo = value

value = instance.IntegratedTo
C#
public MenuIntegrationMode IntegratedTo {get; set;}

Remarks

By default, when you drop a new Bar from ToolBox to the designer surface, the Bar will automatically looking for the default PlaceHolderManager instance, set its PlaceHolder property to the PlaceHolderManager's ID and finally set its IntegratedTo property to PlaceHolderManager. For more information on how the PlaceHolderManager works in design time, see Interactive PlaceHolderManager Designer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members

Concepts

Interactive PlaceHolderManager Designer

concepts

PlaceHolderManager Concept


IsFloat Property

[image]
Intersoft WebDesktop Documentation
IsFloat Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : IsFloat Property

Glossary Item Box

Gets or sets a value that indicates whether a WebToolBar control is floated on the page.

Syntax

Visual Basic (Declaration)
Public Property IsFloat As IsFloat
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As IsFloat

instance.IsFloat = value

value = instance.IsFloat
C#
public IsFloat IsFloat {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members

Tasks

Configuring Floating Mode


LazyLoadContextMenu Property

[image]
Intersoft WebDesktop Documentation
LazyLoadContextMenu Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : LazyLoadContextMenu Property

Glossary Item Box

Gets or sets a value that indicates whether DropdownButton context menu or SplitButton context menu is loaded lazily (on first button clicked).

Syntax

Visual Basic (Declaration)
Public Property LazyLoadContextMenu As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As Boolean

instance.LazyLoadContextMenu = value

value = instance.LazyLoadContextMenu
C#
public bool LazyLoadContextMenu {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


MenuStyleSettings Property

[image]
Intersoft WebDesktop Documentation
MenuStyleSettings Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : MenuStyleSettings Property

Glossary Item Box

Gets or sets the style properties of menu styles in the bar control.

Syntax

Visual Basic (Declaration)
Public Property MenuStyleSettings As WebMenuStyles
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As WebMenuStyles

instance.MenuStyleSettings = value

value = instance.MenuStyleSettings
C#
public WebMenuStyles MenuStyleSettings {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


MergeCommandID Property

[image]
Intersoft WebDesktop Documentation
MergeCommandID Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : MergeCommandID Property

Glossary Item Box

Specifies the Merge Command ID.

Syntax

Visual Basic (Declaration)
Public Overridable Property MergeCommandID As String
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As String

instance.MergeCommandID = value

value = instance.MergeCommandID
C#
public virtual string MergeCommandID {get; set;}

Remarks

WebToolBar introduces Merging feature which allows you to Merge ToolBar from your parent page with child page. There are 2 types of Merging, which are ToolBar Merging and ToolCommand Merging. ToolBar Merging is used to combine Parent ToolBar with Child ToolBar from different pages. Hence, it will merge the whole ToolBars.

ToolCommand Merging is slightly different compared to ToolBar Merging. It does not merge the whole ToolBar, but it does merge the ToolCommand instead. Hence, the Child's ToolCommand will be merged to Parent's ToolCommand using the container.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members

Tasks

Configuring ToolCommand Toolbar Merging

Concepts

WebToolBar Features


MergeToolBar Property

[image]
Intersoft WebDesktop Documentation
MergeToolBar Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : MergeToolBar Property

Glossary Item Box

Gets or sets a value that indicates whether a WebToolBar control is a merge WebToolBar.

Syntax

Visual Basic (Declaration)
Public Property MergeToolBar As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As Boolean

instance.MergeToolBar = value

value = instance.MergeToolBar
C#
public bool MergeToolBar {get; set;}

Remarks

WebToolBar introduces Merging feature which allows you to Merge ToolBar from your parent page with child page. There are 2 types of Merging, which are ToolBar Merging and ToolCommand Merging.

ToolBar Merging is used to combine Parent ToolBar with Child ToolBar from different pages. Hence, it will merge the whole ToolBars. To enable ToolBar Merging simply set MergeToolBar to True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members

Tasks

Configuring ToolBar Merging

Concepts

WebToolBar Features


MergeToolBarParentID Property

[image]
Intersoft WebDesktop Documentation
MergeToolBarParentID Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : MergeToolBarParentID Property

Glossary Item Box

Gets or sets the merged WebToolBar parent ID.

Syntax

Visual Basic (Declaration)
Public Property MergeToolBarParentID As String
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As String

instance.MergeToolBarParentID = value

value = instance.MergeToolBarParentID
C#
public string MergeToolBarParentID {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


MergeToolBarParentWindowName Property

[image]
Intersoft WebDesktop Documentation
MergeToolBarParentWindowName Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : MergeToolBarParentWindowName Property

Glossary Item Box

Gets or sets the merged WebToolBar parent window name.

Syntax

Visual Basic (Declaration)
Public Property MergeToolBarParentWindowName As String
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As String

instance.MergeToolBarParentWindowName = value

value = instance.MergeToolBarParentWindowName
C#
public string MergeToolBarParentWindowName {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


Opacity Property

[image]
Intersoft WebDesktop Documentation
Opacity Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : Opacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Opacity As Single
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As Single

instance.Opacity = value

value = instance.Opacity
C#
public float Opacity {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


OptionStyle Property

[image]
Intersoft WebDesktop Documentation
OptionStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : OptionStyle Property

Glossary Item Box

Gets or sets the style properties of option bar section in the bar control.

Syntax

Visual Basic (Declaration)
Public Property OptionStyle As BarSectionStyle
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As BarSectionStyle

instance.OptionStyle = value

value = instance.OptionStyle
C#
public BarSectionStyle OptionStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


Page Property

[image]
Intersoft WebDesktop Documentation
Page Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : Page Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Page As System.Web.UI.Page
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As System.Web.UI.Page

instance.Page = value

value = instance.Page
C#
public virtual System.Web.UI.Page Page {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


PlaceHolder Property

[image]
Intersoft WebDesktop Documentation
PlaceHolder Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : PlaceHolder Property

Glossary Item Box

Specifies the bar placeholder manager.

Syntax

Visual Basic (Declaration)
Public Overridable Property PlaceHolder As String
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As String

instance.PlaceHolder = value

value = instance.PlaceHolder
C#
public virtual string PlaceHolder {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


RenderingMode Property

[image]
Intersoft WebDesktop Documentation
RenderingMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : RenderingMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property RenderingMode As ISNet.WebUI.RenderMode
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As ISNet.WebUI.RenderMode

instance.RenderingMode = value

value = instance.RenderingMode
C#
public virtual ISNet.WebUI.RenderMode RenderingMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


RuntimeLicenseKey Property

[image]
Intersoft WebDesktop Documentation
RuntimeLicenseKey Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : RuntimeLicenseKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property RuntimeLicenseKey As String
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As String

instance.RuntimeLicenseKey = value

value = instance.RuntimeLicenseKey
C#
public virtual string RuntimeLicenseKey {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


ScriptDirectory Property

[image]
Intersoft WebDesktop Documentation
ScriptDirectory Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : ScriptDirectory Property

Glossary Item Box

Gets or sets the directory where all required scripts for the control are stored.

Syntax

Visual Basic (Declaration)
Public Overrides Property ScriptDirectory As String
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As String

instance.ScriptDirectory = value

value = instance.ScriptDirectory
C#
public override string ScriptDirectory {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


SeparatorStyle Property

[image]
Intersoft WebDesktop Documentation
SeparatorStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : SeparatorStyle Property

Glossary Item Box

Gets or sets the style properties of separator command in the bar control.

Syntax

Visual Basic (Declaration)
Public Overridable Property SeparatorStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As ISNet.WebUI.WebStyle

instance.SeparatorStyle = value

value = instance.SeparatorStyle
C#
public virtual ISNet.WebUI.WebStyle SeparatorStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


SharedScriptDirectory Property

[image]
Intersoft WebDesktop Documentation
SharedScriptDirectory Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : SharedScriptDirectory Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Property SharedScriptDirectory As String
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As String

instance.SharedScriptDirectory = value

value = instance.SharedScriptDirectory
C#
public override string SharedScriptDirectory {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


ShowDelay Property

[image]
Intersoft WebDesktop Documentation
ShowDelay Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : ShowDelay Property

Glossary Item Box

Gets or sets the amount of submenu that shows delay in milliseconds.

Syntax

Visual Basic (Declaration)
Public Property ShowDelay As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As Integer

instance.ShowDelay = value

value = instance.ShowDelay
C#
public int ShowDelay {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


ShowFocusBorder Property

[image]
Intersoft WebDesktop Documentation
ShowFocusBorder Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : ShowFocusBorder Property

Glossary Item Box

Gets or sets a boolean value indicating whether to show border around the Active Command when tabbed via keyboard. This property is recommended for Accessbility and Section 508 Compliant.

Syntax

Visual Basic (Declaration)
Public Property ShowFocusBorder As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As Boolean

instance.ShowFocusBorder = value

value = instance.ShowFocusBorder
C#
public bool ShowFocusBorder {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


SizeMode Property

[image]
Intersoft WebDesktop Documentation
SizeMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : SizeMode Property

Glossary Item Box

Gets or sets the tool command sizing mode.

Syntax

Visual Basic (Declaration)
Public Property SizeMode As SizeMode
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As SizeMode

instance.SizeMode = value

value = instance.SizeMode
C#
public SizeMode SizeMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


SkinID Property

[image]
Intersoft WebDesktop Documentation
SkinID Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : SkinID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property SkinID As String
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As String

instance.SkinID = value

value = instance.SkinID
C#
public virtual string SkinID {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


TabIndex Property

[image]
Intersoft WebDesktop Documentation
TabIndex Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : TabIndex Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property TabIndex As Short
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As Short

instance.TabIndex = value

value = instance.TabIndex
C#
public virtual short TabIndex {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


TextAlign Property

[image]
Intersoft WebDesktop Documentation
TextAlign Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : TextAlign Property

Glossary Item Box

Specifies the ToolCommand text align type.

Syntax

Visual Basic (Declaration)
Public Property TextAlign As BarTextAlign
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As BarTextAlign

instance.TextAlign = value

value = instance.TextAlign
C#
public BarTextAlign TextAlign {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


ToggleGroups Property

[image]
Intersoft WebDesktop Documentation
ToggleGroups Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : ToggleGroups Property

Glossary Item Box

Gets the collection of toggle group commands in this WebToolBar.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ToggleGroups As ToggleGroupCollection
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As ToggleGroupCollection

value = instance.ToggleGroups
C#
public ToggleGroupCollection ToggleGroups {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


ToolTip Property

[image]
Intersoft WebDesktop Documentation
ToolTip Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : ToolTip Property

Glossary Item Box

The tooltip displayed when the mouse is over the control.

Syntax

Visual Basic (Declaration)
Public Shadows Property ToolTip As String
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As String

instance.ToolTip = value

value = instance.ToolTip
C#
public new string ToolTip {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


ValidateRequestMode Property

[image]
Intersoft WebDesktop Documentation
ValidateRequestMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : ValidateRequestMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ValidateRequestMode As System.Web.UI.ValidateRequestMode
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As System.Web.UI.ValidateRequestMode

instance.ValidateRequestMode = value

value = instance.ValidateRequestMode
C#
public virtual System.Web.UI.ValidateRequestMode ValidateRequestMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


ViewStateItems Property

[image]
Intersoft WebDesktop Documentation
ViewStateItems Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : ViewStateItems Property

Glossary Item Box

Gets or sets the items to be stored in view state storage.

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateItems As ISNet.WebUI.ViewStateItem
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As ISNet.WebUI.ViewStateItem

instance.ViewStateItems = value

value = instance.ViewStateItems
C#
public virtual ISNet.WebUI.ViewStateItem ViewStateItems {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


ViewStateMode Property

[image]
Intersoft WebDesktop Documentation
ViewStateMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : ViewStateMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateMode As System.Web.UI.ViewStateMode
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As System.Web.UI.ViewStateMode

instance.ViewStateMode = value

value = instance.ViewStateMode
C#
public virtual System.Web.UI.ViewStateMode ViewStateMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


ViewStateServerConnection Property

[image]
Intersoft WebDesktop Documentation
ViewStateServerConnection Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : ViewStateServerConnection Property

Glossary Item Box

Gets or sets the server connection string for file server-based viewstate storage.

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateServerConnection As String
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As String

instance.ViewStateServerConnection = value

value = instance.ViewStateServerConnection
C#
public virtual string ViewStateServerConnection {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


ViewStateStorage Property

[image]
Intersoft WebDesktop Documentation
ViewStateStorage Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : ViewStateStorage Property

Glossary Item Box

Gets or sets the location to store the viewstate of this control.

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateStorage As ISNet.WebUI.StateCacheStorage
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As ISNet.WebUI.StateCacheStorage

instance.ViewStateStorage = value

value = instance.ViewStateStorage
C#
public virtual ISNet.WebUI.StateCacheStorage ViewStateStorage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


Visible Property

[image]
Intersoft WebDesktop Documentation
Visible Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : Visible Property

Glossary Item Box

Indicates whether the control is visible and rendered.

Syntax

Visual Basic (Declaration)
Public Overrides Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public override bool Visible {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


Width Property

[image]
Intersoft WebDesktop Documentation
Width Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : Width Property

Glossary Item Box

The width of the control.

Syntax

Visual Basic (Declaration)
Public Overrides Property Width As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As System.Web.UI.WebControls.Unit

instance.Width = value

value = instance.Width
C#
public override System.Web.UI.WebControls.Unit Width {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


XmlCompressionEnabled Property

[image]
Intersoft WebDesktop Documentation
XmlCompressionEnabled Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : XmlCompressionEnabled Property

Glossary Item Box

Specifies whether the Xml used for clientside state storage should be compressed.

Syntax

Visual Basic (Declaration)
Public Overridable Property XmlCompressionEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim value As Boolean

instance.XmlCompressionEnabled = value

value = instance.XmlCompressionEnabled
C#
public virtual bool XmlCompressionEnabled {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


WebToolBar Class Events

[image]
Intersoft WebDesktop Documentation
WebToolBar Class Events
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebToolBar Class

Glossary Item Box

For a list of all members of this type, see WebToolBar members.

Public Events

 | Name | Description
Public Event | BarLayoutPropertiesChanged | Occurs when bar layout properties is changed.
Public Event | BarPropertiesChanged | Occurs when bar properties is changed.
Public Event | CommandClick | Occurs when command bar is clicked.
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebToolBar Class
ISNet.WebUI.WebDesktop Namespace

Tasks

Creating Dockable Toolbar
Creating Standalone Toolbar
Changing Toolbar docking at design time
Configuring Floating Mode
Configuring ToolCommand Toolbar Merging

Concepts

WebToolBar Overview
WebToolBar Features
Understanding ToolBar Architecture
Working with ToolBar Designer
Rich Design-time Experience


BarLayoutPropertiesChanged Event

[image]
Intersoft WebDesktop Documentation
BarLayoutPropertiesChanged Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : BarLayoutPropertiesChanged Event

Glossary Item Box

Occurs when bar layout properties is changed.

Syntax

Visual Basic (Declaration)
Public Event BarLayoutPropertiesChanged As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim handler As EventHandler

AddHandler instance.BarLayoutPropertiesChanged, handler
C#
public event EventHandler BarLayoutPropertiesChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


BarPropertiesChanged Event

[image]
Intersoft WebDesktop Documentation
BarPropertiesChanged Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : BarPropertiesChanged Event

Glossary Item Box

Occurs when bar properties is changed.

Syntax

Visual Basic (Declaration)
Public Event BarPropertiesChanged As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim handler As EventHandler

AddHandler instance.BarPropertiesChanged, handler
C#
public event EventHandler BarPropertiesChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


CommandClick Event

[image]
Intersoft WebDesktop Documentation
CommandClick Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : CommandClick Event

Glossary Item Box

Occurs when command bar is clicked.

Syntax

Visual Basic (Declaration)
Public Event CommandClick As ToolCommandClickEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim handler As ToolCommandClickEventHandler

AddHandler instance.CommandClick, handler
C#
public event ToolCommandClickEventHandler CommandClick

Event Data

The event handler receives an argument of type ToolCommandClickEventArgs containing data related to this event. The following ToolCommandClickEventArgs properties provide information specific to this event.

Property | Description
ClickedCommand | Gets the clicked command in ToolCommand.
ClickedMenuItem | Gets the clicked menu item in ToolCommand.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


DataBinding Event

[image]
Intersoft WebDesktop Documentation
DataBinding Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : DataBinding Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event DataBinding As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim handler As EventHandler

AddHandler instance.DataBinding, handler
C#
public event EventHandler DataBinding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


Disposed Event

[image]
Intersoft WebDesktop Documentation
Disposed Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim handler As EventHandler

AddHandler instance.Disposed, handler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


Init Event

[image]
Intersoft WebDesktop Documentation
Init Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : Init Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Init As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim handler As EventHandler

AddHandler instance.Init, handler
C#
public event EventHandler Init

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


Load Event

[image]
Intersoft WebDesktop Documentation
Load Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : Load Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Load As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim handler As EventHandler

AddHandler instance.Load, handler
C#
public event EventHandler Load

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


PreInitialize Event

[image]
Intersoft WebDesktop Documentation
PreInitialize Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : PreInitialize Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event PreInitialize As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim handler As EventHandler

AddHandler instance.PreInitialize, handler
C#
public event EventHandler PreInitialize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


PreRender Event

[image]
Intersoft WebDesktop Documentation
PreRender Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : PreRender Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event PreRender As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim handler As EventHandler

AddHandler instance.PreRender, handler
C#
public event EventHandler PreRender

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


Unload Event

[image]
Intersoft WebDesktop Documentation
Unload Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebToolBar Class : Unload Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Unload As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebToolBar
Dim handler As EventHandler

AddHandler instance.Unload, handler
C#
public event EventHandler Unload

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebToolBar Class
WebToolBar Members


WebWindowBorderStyle Class

[image]
Intersoft WebDesktop Documentation
WebWindowBorderStyle Class
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebWindowBorderStyle Class

Glossary Item Box

Style of the border around the WebDesktopWindow.

Object Model

WebWindowBorderStyle Class

Syntax

Visual Basic (Declaration)
Public Class WebWindowBorderStyle
   Inherits ISNet.WebUI.WebStyle
   Implements ISNet.ICopyable, ISNet.IEmpty, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlLayoutSerialize
Visual Basic (Usage) Copy Code
Dim instance As WebWindowBorderStyle
C#
public class WebWindowBorderStyle : ISNet.WebUI.WebStyle, ISNet.ICopyable, ISNet.IEmpty, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlLayoutSerialize

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Web.UI.WebControls.Style
ISNet.WebUI.WebStyle
ISNet.WebUI.WebDesktop.WebWindowBorderStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebWindowBorderStyle Members
ISNet.WebUI.WebDesktop Namespace


WebWindowBorderStyle Class Members

[image]
Intersoft WebDesktop Documentation
WebWindowBorderStyle Class Members
See Also Fields Properties Methods Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebWindowBorderStyle Class

Glossary Item Box

The following tables list the members exposed by WebWindowBorderStyle.

Public Constructors

 | Name | Description
Public Constructor | WebWindowBorderStyle Constructor |
Top

Public Fields

 | Name | Description
Public Field | dynamicStyle | (Inherited from ISNet.WebUI.WebStyle)
Public Field | layoutKey | (Inherited from ISNet.WebUI.WebStyle)
Public Field | styleState | (Inherited from ISNet.WebUI.WebStyle)
Top

Public Properties

 | Name | Description
Public Property | BorderColor | Border color of the controls aplied with this style. (Inherited from ISNet.WebUI.WebStyle)
Public Property | BorderSettings | Customize the border's appearance in more details. (Inherited from ISNet.WebUI.WebStyle)
Public Property | BorderStyle | Style of the border of controls applied with this style. (Inherited from ISNet.WebUI.WebStyle)
Public Property | BorderWidth | Thickness of the border around the controls applied with this style. (Inherited from ISNet.WebUI.WebStyle)
Public Property | CssClass | CSS class name applied to the user of this style. (Inherited from ISNet.WebUI.WebStyle)
Public Property | CustomRules | Determines additional CSS rules to apply the object associated with this style. (Inherited from ISNet.WebUI.WebStyle)
Public Property | GradientType | Specifies the gradient type for back color when BackColor2 is specified. (Inherited from ISNet.WebUI.WebStyle)
Top

Public Methods

 | Name | Description
Public Method | AddAttributesToRender | Overloaded. (Inherited from System.Web.UI.WebControls.Style)
Public Method | Clone | (Inherited from ISNet.WebUI.WebStyle)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebStyle)
Public Method | CopyFromNative | (Inherited from ISNet.WebUI.WebStyle)
Public Method | CopyMerge | (Inherited from ISNet.WebUI.WebStyle)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebStyle)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetMergedCssStyleName | (Inherited from ISNet.WebUI.WebStyle)
Public Method | GetObjectData | Overridden.
Public Method | GetStyleAttributes | (Inherited from System.Web.UI.WebControls.Style)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebStyle)
Public Method | IsFontEmpty | (Inherited from ISNet.WebUI.WebStyle)
Public Method | IsStyleEmpty | (Inherited from ISNet.WebUI.WebStyle)
Public Method | MergeWith | (Inherited from System.Web.UI.WebControls.Style)
Public Method | Reset | (Inherited from ISNet.WebUI.WebStyle)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebStyle)
Public Method | SetDirty | (Inherited from System.Web.UI.WebControls.Style)
Public Method | ToString | (Inherited from ISNet.WebUI.WebStyle)
Top

See Also

Reference

WebWindowBorderStyle Class
ISNet.WebUI.WebDesktop Namespace


WebWindowBorderStyle Class Fields

[image]
Intersoft WebDesktop Documentation
WebWindowBorderStyle Class Fields
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebWindowBorderStyle Class

Glossary Item Box

For a list of all members of this type, see WebWindowBorderStyle members.

Public Fields

 | Name | Description
Public Field | dynamicStyle | (Inherited from ISNet.WebUI.WebStyle)
Public Field | layoutKey | (Inherited from ISNet.WebUI.WebStyle)
Public Field | styleState | (Inherited from ISNet.WebUI.WebStyle)
Top

See Also

Reference

WebWindowBorderStyle Class
ISNet.WebUI.WebDesktop Namespace


WebWindowBorderStyle Constructor

[image]
Intersoft WebDesktop Documentation
WebWindowBorderStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebWindowBorderStyle Class : WebWindowBorderStyle Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebWindowBorderStyle()
C#
public WebWindowBorderStyle()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebWindowBorderStyle Class
WebWindowBorderStyle Members


AddAttributesToRender Method

[image]
Intersoft WebDesktop Documentation
AddAttributesToRender Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebWindowBorderStyle Class : AddAttributesToRender Method

Glossary Item Box

Overload List

Overload | Description
AddAttributesToRender(HtmlTextWriter) | (Inherited from System.Web.UI.WebControls.Style)
AddAttributesToRender(HtmlTextWriter,WebControl) | (Inherited from System.Web.UI.WebControls.Style)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebWindowBorderStyle Class
WebWindowBorderStyle Members


AddAttributesToRender(HtmlTextWriter) Method

[image]
Intersoft WebDesktop Documentation
AddAttributesToRender(HtmlTextWriter) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebWindowBorderStyle Class > AddAttributesToRender Method : AddAttributesToRender(HtmlTextWriter) Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddAttributesToRender( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebWindowBorderStyle
Dim writer As System.Web.UI.HtmlTextWriter

instance.AddAttributesToRender(writer)
C#
public void AddAttributesToRender(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebWindowBorderStyle Class
WebWindowBorderStyle Members
Overload List


AddAttributesToRender(HtmlTextWriter,WebControl) Method

[image]
Intersoft WebDesktop Documentation
AddAttributesToRender(HtmlTextWriter,WebControl) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebWindowBorderStyle Class > AddAttributesToRender Method : AddAttributesToRender(HtmlTextWriter,WebControl) Method

writer
owner

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub AddAttributesToRender( _
   ByVal writer As System.Web.UI.HtmlTextWriter, _
   ByVal owner As System.Web.UI.WebControls.WebControl _
)
Visual Basic (Usage) Copy Code
Dim instance As WebWindowBorderStyle
Dim writer As System.Web.UI.HtmlTextWriter
Dim owner As System.Web.UI.WebControls.WebControl

instance.AddAttributesToRender(writer, owner)
C#
public virtual void AddAttributesToRender(
   System.Web.UI.HtmlTextWriter writer,
   System.Web.UI.WebControls.WebControl owner
)

Parameters

writer
owner

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebWindowBorderStyle Class
WebWindowBorderStyle Members
Overload List


Clone Method

[image]
Intersoft WebDesktop Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebWindowBorderStyle Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebWindowBorderStyle
Dim value As Object

value = instance.Clone()
C#
public object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebWindowBorderStyle Class
WebWindowBorderStyle Members


CopyFrom Method

[image]
Intersoft WebDesktop Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebWindowBorderStyle Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Style) | (Inherited from ISNet.WebUI.WebStyle)
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebStyle)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebStyle)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebWindowBorderStyle Class
WebWindowBorderStyle Members


CopyFrom(Style) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Style) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebWindowBorderStyle Class > CopyFrom Method : CopyFrom(Style) Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebWindowBorderStyle
Dim s As System.Web.UI.WebControls.Style

instance.CopyFrom(s)
C#
public virtual void CopyFrom(
   System.Web.UI.WebControls.Style s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebWindowBorderStyle Class
WebWindowBorderStyle Members
Overload List


CopyFrom(Object) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebWindowBorderStyle Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebWindowBorderStyle
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebWindowBorderStyle Class
WebWindowBorderStyle Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebDesktop Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebWindowBorderStyle Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebWindowBorderStyle
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebWindowBorderStyle Class
WebWindowBorderStyle Members
Overload List


CopyFromNative Method

[image]
Intersoft WebDesktop Documentation
CopyFromNative Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebWindowBorderStyle Class : CopyFromNative Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub CopyFromNative( _
   ByVal s As ISNet.WebUI.WebStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As WebWindowBorderStyle
Dim s As ISNet.WebUI.WebStyle

instance.CopyFromNative(s)
C#
public virtual void CopyFromNative(
   ISNet.WebUI.WebStyle s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebWindowBorderStyle Class
WebWindowBorderStyle Members


CopyMerge Method

[image]
Intersoft WebDesktop Documentation
CopyMerge Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebWindowBorderStyle Class : CopyMerge Method

style

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyMerge( _
   ByVal style As ISNet.WebUI.WebStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As WebWindowBorderStyle
Dim style As ISNet.WebUI.WebStyle

instance.CopyMerge(style)
C#
public void CopyMerge(
   ISNet.WebUI.WebStyle style
)

Parameters

style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebWindowBorderStyle Class
WebWindowBorderStyle Members


CreateObjRef Method

[image]
Intersoft WebDesktop Documentation
CreateObjRef Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebWindowBorderStyle Class : CreateObjRef Method

requestedType

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function CreateObjRef( _
   ByVal requestedType As Type _
) As System.Runtime.Remoting.ObjRef
Visual Basic (Usage) Copy Code
Dim instance As WebWindowBorderStyle
Dim requestedType As Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
C#
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   Type requestedType
)

Parameters

requestedType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebWindowBorderStyle Class
WebWindowBorderStyle Members


DeSerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebWindowBorderStyle Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebWindowBorderStyle
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebWindowBorderStyle Class
WebWindowBorderStyle Members


Dispose Method

[image]
Intersoft WebDesktop Documentation
Dispose Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebWindowBorderStyle Class : Dispose Method

Glossary Item Box

Overload List

Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebWindowBorderStyle Class
WebWindowBorderStyle Members


Dispose() Method

[image]
Intersoft WebDesktop Documentation
Dispose() Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebWindowBorderStyle Class : Dispose() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As WebWindowBorderStyle

instance.Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebWindowBorderStyle Class
WebWindowBorderStyle Members


GetLifetimeService Method

[image]
Intersoft WebDesktop Documentation
GetLifetimeService Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebWindowBorderStyle Class : GetLifetimeService Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebWindowBorderStyle
Dim value As Object

value = instance.GetLifetimeService()
C#
public object GetLifetimeService()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebWindowBorderStyle Class
WebWindowBorderStyle Members


GetMergedCssStyleName Method

[image]
Intersoft WebDesktop Documentation
GetMergedCssStyleName Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebWindowBorderStyle Class : GetMergedCssStyleName Method

finalKey

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetMergedCssStyleName( _
   ByVal finalKey As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebWindowBorderStyle
Dim finalKey As String
Dim value As String

value = instance.GetMergedCssStyleName(finalKey)
C#
public string GetMergedCssStyleName(
   string finalKey
)

Parameters

finalKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebWindowBorderStyle Class
WebWindowBorderStyle Members


WebWindowBorderStyle Class Methods

[image]
Intersoft WebDesktop Documentation
WebWindowBorderStyle Class Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebWindowBorderStyle Class

Glossary Item Box

For a list of all members of this type, see WebWindowBorderStyle members.

Public Methods

 | Name | Description
Public Method | AddAttributesToRender | Overloaded. (Inherited from System.Web.UI.WebControls.Style)
Public Method | Clone | (Inherited from ISNet.WebUI.WebStyle)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebStyle)
Public Method | CopyFromNative | (Inherited from ISNet.WebUI.WebStyle)
Public Method | CopyMerge | (Inherited from ISNet.WebUI.WebStyle)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebStyle)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetMergedCssStyleName | (Inherited from ISNet.WebUI.WebStyle)
Public Method | GetObjectData | Overridden.
Public Method | GetStyleAttributes | (Inherited from System.Web.UI.WebControls.Style)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebStyle)
Public Method | IsFontEmpty | (Inherited from ISNet.WebUI.WebStyle)
Public Method | IsStyleEmpty | (Inherited from ISNet.WebUI.WebStyle)
Public Method | MergeWith | (Inherited from System.Web.UI.WebControls.Style)
Public Method | Reset | (Inherited from ISNet.WebUI.WebStyle)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebStyle)
Public Method | SetDirty | (Inherited from System.Web.UI.WebControls.Style)
Public Method | ToString | (Inherited from ISNet.WebUI.WebStyle)
Top

See Also

Reference

WebWindowBorderStyle Class
ISNet.WebUI.WebDesktop Namespace


WebWindowBorderStyle Class Properties

[image]
Intersoft WebDesktop Documentation
WebWindowBorderStyle Class Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebWindowBorderStyle Class

Glossary Item Box

For a list of all members of this type, see WebWindowBorderStyle members.

Public Properties

 | Name | Description
Public Property | BorderColor | Border color of the controls aplied with this style. (Inherited from ISNet.WebUI.WebStyle)
Public Property | BorderSettings | Customize the border's appearance in more details. (Inherited from ISNet.WebUI.WebStyle)
Public Property | BorderStyle | Style of the border of controls applied with this style. (Inherited from ISNet.WebUI.WebStyle)
Public Property | BorderWidth | Thickness of the border around the controls applied with this style. (Inherited from ISNet.WebUI.WebStyle)
Public Property | CssClass | CSS class name applied to the user of this style. (Inherited from ISNet.WebUI.WebStyle)
Public Property | CustomRules | Determines additional CSS rules to apply the object associated with this style. (Inherited from ISNet.WebUI.WebStyle)
Public Property | GradientType | Specifies the gradient type for back color when BackColor2 is specified. (Inherited from ISNet.WebUI.WebStyle)
Top

See Also

Reference

WebWindowBorderStyle Class
ISNet.WebUI.WebDesktop Namespace


WebWindowBorderStyle Constructor

[image]
Intersoft WebDesktop Documentation
WebWindowBorderStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebWindowBorderStyle Class : WebWindowBorderStyle Constructor

Glossary Item Box

Initializes a new instance of the WebWindowBorderStyle class.

Overload List

Overload | Description
WebWindowBorderStyle Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebWindowBorderStyle Class
WebWindowBorderStyle Members


GetObjectData Method

[image]
Intersoft WebDesktop Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebWindowBorderStyle Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebWindowBorderStyle
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebWindowBorderStyle Class
WebWindowBorderStyle Members


GetStyleAttributes Method

[image]
Intersoft WebDesktop Documentation
GetStyleAttributes Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebWindowBorderStyle Class : GetStyleAttributes Method

urlResolver

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetStyleAttributes( _
   ByVal urlResolver As System.Web.UI.IUrlResolutionService _
) As System.Web.UI.CssStyleCollection
Visual Basic (Usage) Copy Code
Dim instance As WebWindowBorderStyle
Dim urlResolver As System.Web.UI.IUrlResolutionService
Dim value As System.Web.UI.CssStyleCollection

value = instance.GetStyleAttributes(urlResolver)
C#
public System.Web.UI.CssStyleCollection GetStyleAttributes(
   System.Web.UI.IUrlResolutionService urlResolver
)

Parameters

urlResolver

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebWindowBorderStyle Class
WebWindowBorderStyle Members


InitializeLifetimeService Method

[image]
Intersoft WebDesktop Documentation
InitializeLifetimeService Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebWindowBorderStyle Class : InitializeLifetimeService Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function InitializeLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebWindowBorderStyle
Dim value As Object

value = instance.InitializeLifetimeService()
C#
public virtual object InitializeLifetimeService()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebWindowBorderStyle Class
WebWindowBorderStyle Members


IsEmpty Method

[image]
Intersoft WebDesktop Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebWindowBorderStyle Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebWindowBorderStyle
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebWindowBorderStyle Class
WebWindowBorderStyle Members


IsFontEmpty Method

[image]
Intersoft WebDesktop Documentation
IsFontEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebWindowBorderStyle Class : IsFontEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFontEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebWindowBorderStyle
Dim value As Boolean

value = instance.IsFontEmpty()
C#
public virtual bool IsFontEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebWindowBorderStyle Class
WebWindowBorderStyle Members


IsStyleEmpty Method

[image]
Intersoft WebDesktop Documentation
IsStyleEmpty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebWindowBorderStyle Class : IsStyleEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsStyleEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebWindowBorderStyle
Dim value As Boolean

value = instance.IsStyleEmpty()
C#
public virtual bool IsStyleEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebWindowBorderStyle Class
WebWindowBorderStyle Members


MergeWith Method

[image]
Intersoft WebDesktop Documentation
MergeWith Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebWindowBorderStyle Class : MergeWith Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub MergeWith( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebWindowBorderStyle
Dim s As System.Web.UI.WebControls.Style

instance.MergeWith(s)
C#
public virtual void MergeWith(
   System.Web.UI.WebControls.Style s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebWindowBorderStyle Class
WebWindowBorderStyle Members


Reset Method

[image]
Intersoft WebDesktop Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebWindowBorderStyle Class : Reset Method

Glossary Item Box

Overload List

Overload | Description
Reset | (Inherited from ISNet.WebUI.WebStyle)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebWindowBorderStyle Class
WebWindowBorderStyle Members


Reset() Method

[image]
Intersoft WebDesktop Documentation
Reset() Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebWindowBorderStyle Class : Reset() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebWindowBorderStyle

instance.Reset()
C#
public virtual void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebWindowBorderStyle Class
WebWindowBorderStyle Members


SerializeObjectData Method

[image]
Intersoft WebDesktop Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebWindowBorderStyle Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebWindowBorderStyle
Dim type As Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebWindowBorderStyle Class
WebWindowBorderStyle Members


SetDirty Method

[image]
Intersoft WebDesktop Documentation
SetDirty Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebWindowBorderStyle Class : SetDirty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetDirty()
Visual Basic (Usage) Copy Code
Dim instance As WebWindowBorderStyle

instance.SetDirty()
C#
public void SetDirty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebWindowBorderStyle Class
WebWindowBorderStyle Members


ToString Method

[image]
Intersoft WebDesktop Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebWindowBorderStyle Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebWindowBorderStyle
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebWindowBorderStyle Class
WebWindowBorderStyle Members


BorderColor Property

[image]
Intersoft WebDesktop Documentation
BorderColor Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebWindowBorderStyle Class : BorderColor Property

Glossary Item Box

Border color of the controls aplied with this style.

Syntax

Visual Basic (Declaration)
Public Overridable Property BorderColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebWindowBorderStyle
Dim value As System.Drawing.Color

instance.BorderColor = value

value = instance.BorderColor
C#
public virtual System.Drawing.Color BorderColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebWindowBorderStyle Class
WebWindowBorderStyle Members


BorderSettings Property

[image]
Intersoft WebDesktop Documentation
BorderSettings Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebWindowBorderStyle Class : BorderSettings Property

Glossary Item Box

Customize the border's appearance in more details.

Syntax

Visual Basic (Declaration)
Public Overridable Property BorderSettings As ISNet.WebUI.BorderSettings
Visual Basic (Usage) Copy Code
Dim instance As WebWindowBorderStyle
Dim value As ISNet.WebUI.BorderSettings

instance.BorderSettings = value

value = instance.BorderSettings
C#
public virtual ISNet.WebUI.BorderSettings BorderSettings {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebWindowBorderStyle Class
WebWindowBorderStyle Members


BorderStyle Property

[image]
Intersoft WebDesktop Documentation
BorderStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebWindowBorderStyle Class : BorderStyle Property

Glossary Item Box

Style of the border of controls applied with this style.

Syntax

Visual Basic (Declaration)
Public Overridable Property BorderStyle As System.Web.UI.WebControls.BorderStyle
Visual Basic (Usage) Copy Code
Dim instance As WebWindowBorderStyle
Dim value As System.Web.UI.WebControls.BorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
C#
public virtual System.Web.UI.WebControls.BorderStyle BorderStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebWindowBorderStyle Class
WebWindowBorderStyle Members


BorderWidth Property

[image]
Intersoft WebDesktop Documentation
BorderWidth Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebWindowBorderStyle Class : BorderWidth Property

Glossary Item Box

Thickness of the border around the controls applied with this style.

Syntax

Visual Basic (Declaration)
Public Overridable Property BorderWidth As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebWindowBorderStyle
Dim value As System.Web.UI.WebControls.Unit

instance.BorderWidth = value

value = instance.BorderWidth
C#
public virtual System.Web.UI.WebControls.Unit BorderWidth {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebWindowBorderStyle Class
WebWindowBorderStyle Members


CssClass Property

[image]
Intersoft WebDesktop Documentation
CssClass Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebWindowBorderStyle Class : CssClass Property

Glossary Item Box

CSS class name applied to the user of this style.

Syntax

Visual Basic (Declaration)
Public Overridable Property CssClass As String
Visual Basic (Usage) Copy Code
Dim instance As WebWindowBorderStyle
Dim value As String

instance.CssClass = value

value = instance.CssClass
C#
public virtual string CssClass {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebWindowBorderStyle Class
WebWindowBorderStyle Members


CustomRules Property

[image]
Intersoft WebDesktop Documentation
CustomRules Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebWindowBorderStyle Class : CustomRules Property

Glossary Item Box

Determines additional CSS rules to apply the object associated with this style.

Syntax

Visual Basic (Declaration)
Public Overridable Property CustomRules As String
Visual Basic (Usage) Copy Code
Dim instance As WebWindowBorderStyle
Dim value As String

instance.CustomRules = value

value = instance.CustomRules
C#
public virtual string CustomRules {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebWindowBorderStyle Class
WebWindowBorderStyle Members


GradientType Property

[image]
Intersoft WebDesktop Documentation
GradientType Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebWindowBorderStyle Class : GradientType Property

Glossary Item Box

Specifies the gradient type for back color when BackColor2 is specified.

Syntax

Visual Basic (Declaration)
Public Property GradientType As ISNet.WebUI.GradientType
Visual Basic (Usage) Copy Code
Dim instance As WebWindowBorderStyle
Dim value As ISNet.WebUI.GradientType

instance.GradientType = value

value = instance.GradientType
C#
public ISNet.WebUI.GradientType GradientType {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebWindowBorderStyle Class
WebWindowBorderStyle Members


dynamicStyle Field

[image]
Intersoft WebDesktop Documentation
dynamicStyle Field
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebWindowBorderStyle Class : dynamicStyle Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public dynamicStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebWindowBorderStyle
Dim value As ISNet.WebUI.DynamicStyle

value = instance.dynamicStyle

instance.dynamicStyle = value
C#
public ISNet.WebUI.DynamicStyle dynamicStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebWindowBorderStyle Class
WebWindowBorderStyle Members


layoutKey Field

[image]
Intersoft WebDesktop Documentation
layoutKey Field
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebWindowBorderStyle Class : layoutKey Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public layoutKey As String
Visual Basic (Usage) Copy Code
Dim instance As WebWindowBorderStyle
Dim value As String

value = instance.layoutKey

instance.layoutKey = value
C#
public string layoutKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebWindowBorderStyle Class
WebWindowBorderStyle Members


styleState Field

[image]
Intersoft WebDesktop Documentation
styleState Field
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > WebWindowBorderStyle Class : styleState Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public styleState As String
Visual Basic (Usage) Copy Code
Dim instance As WebWindowBorderStyle
Dim value As String

value = instance.styleState

instance.styleState = value
C#
public string styleState

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebWindowBorderStyle Class
WebWindowBorderStyle Members


AddRemoveOptionMenuViewMode Enumeration

[image]
Intersoft WebDesktop Documentation
AddRemoveOptionMenuViewMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : AddRemoveOptionMenuViewMode Enumeration

Glossary Item Box

Gets or sets the add remove option menu view mode.

Syntax

Visual Basic (Declaration)
Public Enum AddRemoveOptionMenuViewMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As AddRemoveOptionMenuViewMode
C#
public enum AddRemoveOptionMenuViewMode : System.Enum

Members

Member | Description
Default |
IconView | Sets the add remove option menu view mode to IconView. The menu item will be rendered as small icon display only.
NormalView | Sets the add remove option menu view mode to NormalView. The menu item will be rendered as small icon along with text.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.AddRemoveOptionMenuViewMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


Alignment Enumeration

[image]
Intersoft WebDesktop Documentation
Alignment Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : Alignment Enumeration

Glossary Item Box

Value representing the horizontal alignment of an element.

Syntax

Visual Basic (Declaration)
Public Enum Alignment
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As Alignment
C#
public enum Alignment : System.Enum

Members

Member | Description
Center | The text will be aligned to center.
Left | The text will be aligned to left.
Right | The text will be aligned to right.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.Alignment

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


AllowCollapse Enumeration

[image]
Intersoft WebDesktop Documentation
AllowCollapse Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : AllowCollapse Enumeration

Glossary Item Box

Value indicating whether users are allowed to collapse Panes through splitter.

Syntax

Visual Basic (Declaration)
Public Enum AllowCollapse
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As AllowCollapse
C#
public enum AllowCollapse : System.Enum

Members

Member | Description
Default |
No | Users can not collapse the element.
Yes | Users can collapse the element.

Remarks

AllowCollapse allows users to collapse a Pane into specified direction. With this property you can easily let your users to maximize the layout to use available screen real estate which dramatically enhance the user experience resulting in greater productivity.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.AllowCollapse

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


AllowCustomize Enumeration

[image]
Intersoft WebDesktop Documentation
AllowCustomize Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : AllowCustomize Enumeration

Glossary Item Box

Value indicating whether a control is customizable

Syntax

Visual Basic (Declaration)
Public Enum AllowCustomize
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As AllowCustomize
C#
public enum AllowCustomize : System.Enum

Members

Member | Description
Default |
No | Users can not customize the control.
Yes | Users can customize the control.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.AllowCustomize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


AllowDock Enumeration

[image]
Intersoft WebDesktop Documentation
AllowDock Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : AllowDock Enumeration

Glossary Item Box

Value indicating whether a control is dockable.

Syntax

Visual Basic (Declaration)
Public Enum AllowDock
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As AllowDock
C#
public enum AllowDock : System.Enum

Members

Member | Description
Default |
No | Users can not dock the control.
Yes | Users can dock the control.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.AllowDock

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


AllowExpandCollapse Enumeration

[image]
Intersoft WebDesktop Documentation
AllowExpandCollapse Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : AllowExpandCollapse Enumeration

Glossary Item Box

Value indicating whether a bar control is expandable and collapsible.

Syntax

Visual Basic (Declaration)
Public Enum AllowExpandCollapse
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As AllowExpandCollapse
C#
public enum AllowExpandCollapse : System.Enum

Members

Member | Description
Default |
No | Users can not expand and collapse bar control.
Yes | Users can expand and collapse bar control.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.AllowExpandCollapse

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


AllowFloat Enumeration

[image]
Intersoft WebDesktop Documentation
AllowFloat Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : AllowFloat Enumeration

Glossary Item Box

Value indicating whether a bar control is floatable.

Syntax

Visual Basic (Declaration)
Public Enum AllowFloat
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As AllowFloat
C#
public enum AllowFloat : System.Enum

Members

Member | Description
Default |
No | Users can not float the bar control.
Yes | Users can float the bar control.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.AllowFloat

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


AllowMaximize Enumeration

[image]
Intersoft WebDesktop Documentation
AllowMaximize Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : AllowMaximize Enumeration

Glossary Item Box

Value indicating whether user is allowed to maximize Window.

Syntax

Visual Basic (Declaration)
Public Enum AllowMaximize
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As AllowMaximize
C#
public enum AllowMaximize : System.Enum

Members

Member | Description
Default |
No | Users can not maximize Window.
Yes | Users can maximize Window.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.AllowMaximize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


AllowMinimize Enumeration

[image]
Intersoft WebDesktop Documentation
AllowMinimize Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : AllowMinimize Enumeration

Glossary Item Box

Value indicating whether user is allowed to minimize Window.

Syntax

Visual Basic (Declaration)
Public Enum AllowMinimize
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As AllowMinimize
C#
public enum AllowMinimize : System.Enum

Members

Member | Description
Default |
No | Users can not minimize Window.
Yes | Users can minimize Window.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.AllowMinimize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


AllowMove Enumeration

[image]
Intersoft WebDesktop Documentation
AllowMove Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : AllowMove Enumeration

Glossary Item Box

Value indicating whether a bar control is moveable.

Syntax

Visual Basic (Declaration)
Public Enum AllowMove
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As AllowMove
C#
public enum AllowMove : System.Enum

Members

Member | Description
Default |
No | Users can not move the bar control.
Yes | Users can move the bar control.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.AllowMove

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


AllowResize Enumeration

[image]
Intersoft WebDesktop Documentation
AllowResize Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : AllowResize Enumeration

Glossary Item Box

Value indicating whether panes are resizable.

Syntax

Visual Basic (Declaration)
Public Enum AllowResize
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As AllowResize
C#
public enum AllowResize : System.Enum

Members

Member | Description
Default |
No | Indicates that a container element such as Pane or Window is not allowed to be resized by users.
Yes | Indicates that a container element such as Pane or Window is allowed to be resized by users.

Remarks

AllowResize allows users to resize the dimension of Pane at runtime. The resizing works in conjunction with TrueFill architecture which intelligently determines the target size and convert the value back to the original unit type. When a Pane is resized, it will resize the other pair of the Pane and extend its dimension properly. The resizing however, will not affect other Panes or other Group's dimension.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.AllowResize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


AnimationSpeed Enumeration

[image]
Intersoft WebDesktop Documentation
AnimationSpeed Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : AnimationSpeed Enumeration

Glossary Item Box

Value representing the speed of animation.

Syntax

Visual Basic (Declaration)
Public Enum AnimationSpeed
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As AnimationSpeed
C#
public enum AnimationSpeed : System.Enum

Members

Member | Description
Fast | The animation speed is fast.
Medium | The animation speed is medium.
Slow | The animation speed is slow.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.AnimationSpeed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


AutoPostBackMode Enumeration

[image]
Intersoft WebDesktop Documentation
AutoPostBackMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : AutoPostBackMode Enumeration

Glossary Item Box

Value indicating whether a command is autopostback.

Syntax

Visual Basic (Declaration)
Public Enum AutoPostBackMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As AutoPostBackMode
C#
public enum AutoPostBackMode : System.Enum

Members

Member | Description
Default |
No | The command is not in autopostback mode.
Yes | The command is in autopostback mode.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.AutoPostBackMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


BarStyle Enumeration

[image]
Intersoft WebDesktop Documentation
BarStyle Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : BarStyle Enumeration

Glossary Item Box

Value representing the style of Bar in WebMenuBar and WebToolBar.

Syntax

Visual Basic (Declaration)
Public Enum BarStyle
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As BarStyle
C#
public enum BarStyle : System.Enum

Members

Member | Description
ComplexImages | The bar will use ComplexImages style.
Default | The bar will use default style.
IE | The bar will use IE style.
Metro |
Office2000 | The bar will use Office2000 style.
Office2003 | The bar will use Office2003 style.
OfficeXP | The bar will use OfficeXP style.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.BarStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


BarTextAlign Enumeration

[image]
Intersoft WebDesktop Documentation
BarTextAlign Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : BarTextAlign Enumeration

Glossary Item Box

Value representing bar commands text align type.

Syntax

Visual Basic (Declaration)
Public Enum BarTextAlign
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As BarTextAlign
C#
public enum BarTextAlign : System.Enum

Members

Member | Description
Above | The text alignment type in bar is above.
Default |
Left | The text alignment type in bar is left.
Right | The text alignment type in bar is right.
Underneath | The text alignment type in bar is underneath.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.BarTextAlign

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


BorderType Enumeration

[image]
Intersoft WebDesktop Documentation
BorderType Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : BorderType Enumeration

Glossary Item Box

Value representing the type of the border applied to Window.

Syntax

Visual Basic (Declaration)
Public Enum BorderType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As BorderType
C#
public enum BorderType : System.Enum

Members

Member | Description
ComplexImages | Use complex images to draw the caption's border appearance.
Simple | Single line border style.

Remarks

You can set the BorderType to ComplexImages in order to enable higher level of customization. The term "ComplexImages" indicates that the rendering will use many images to draw up an element. For example, there should be 3 separate images in order to draw left part of caption, the body of the caption and right part of caption.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.BorderType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


ButtonAlignment Enumeration

[image]
Intersoft WebDesktop Documentation
ButtonAlignment Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : ButtonAlignment Enumeration

Glossary Item Box

Value representing buttons alignment type in the dialog box.

Syntax

Visual Basic (Declaration)
Public Enum ButtonAlignment
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ButtonAlignment
C#
public enum ButtonAlignment : System.Enum

Members

Member | Description
Center | The button will be aligned to the center.
Default |
Left | The button will be aligned to the left.
Right | The button will be aligned to the right.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.ButtonAlignment

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


ButtonDisplayMode Enumeration

[image]
Intersoft WebDesktop Documentation
ButtonDisplayMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : ButtonDisplayMode Enumeration

Glossary Item Box

Value representing caption display mode for the button.

Syntax

Visual Basic (Declaration)
Public Enum ButtonDisplayMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ButtonDisplayMode
C#
public enum ButtonDisplayMode : System.Enum

Members

Member | Description
Default |
Image | The button display mode is Image.
Text | The button display mode is Text.
TextAndImage | The button display mode is Text and Image.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.ButtonDisplayMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


CloseBehavior Enumeration

[image]
Intersoft WebDesktop Documentation
CloseBehavior Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : CloseBehavior Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum CloseBehavior
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As CloseBehavior
C#
public enum CloseBehavior : System.Enum

Members

Member | Description
ClickOutsideCallOut |
Latency |
MouseOut |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.CloseBehavior

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


CloseIndicatorPosition Enumeration

[image]
Intersoft WebDesktop Documentation
CloseIndicatorPosition Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : CloseIndicatorPosition Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum CloseIndicatorPosition
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As CloseIndicatorPosition
C#
public enum CloseIndicatorPosition : System.Enum

Members

Member | Description
EdgeOfContainer |
EdgeOfTabHeader |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.CloseIndicatorPosition

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


CloseMode Enumeration

[image]
Intersoft WebDesktop Documentation
CloseMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : CloseMode Enumeration

Glossary Item Box

Value indicating whether users are allowed to close the Tab.

Syntax

Visual Basic (Declaration)
Public Enum CloseMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As CloseMode
C#
public enum CloseMode : System.Enum

Members

Member | Description
Default | Use Default AllowClose value specified in parent.
No | Disallow the Tab to be closed by user.
Yes | Allow the Tab to be closed by user.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.CloseMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


CollapseDirection Enumeration

[image]
Intersoft WebDesktop Documentation
CollapseDirection Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : CollapseDirection Enumeration

Glossary Item Box

Value indicating the direction of panel's collapse.

Syntax

Visual Basic (Declaration)
Public Enum CollapseDirection
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As CollapseDirection
C#
public enum CollapseDirection : System.Enum

Members

Member | Description
Panel1 | The panel will collapse to Panel1.
Panel2 | The panel will collapse to Panel2.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.CollapseDirection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


CommandDisplayMode Enumeration

[image]
Intersoft WebDesktop Documentation
CommandDisplayMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : CommandDisplayMode Enumeration

Glossary Item Box

Value representing the MenuCommand display mode.

Syntax

Visual Basic (Declaration)
Public Enum CommandDisplayMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As CommandDisplayMode
C#
public enum CommandDisplayMode : System.Enum

Members

Member | Description
Default |
Image | The display mode on MenuCommand is Image.
Text | The display mode on MenuCommand is Text.
TextAndImage | The display mode on MenuCommand is Text and Image.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.CommandDisplayMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


CommandType Enumeration

[image]
Intersoft WebDesktop Documentation
CommandType Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : CommandType Enumeration

Glossary Item Box

Value representing the command type.

Syntax

Visual Basic (Declaration)
Public Enum CommandType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As CommandType
C#
public enum CommandType : System.Enum

Members

Member | Description
Button | The command type is Button.
Container | The command type will act as the container for the merged WebToolbar.
Custom | The custom command type for WebToolBar.
DropDownButton | The command type is DropDownButton.
Normal | The normal command type.
Separator | The command type is Separator.
SplitButton | The command type is SplitButton.
ToggleButton | The command type is ToggleButton.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.CommandType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace

Tasks

Using ToolCommand Types

tasks

Using Templated Command

Concepts

WebToolBar Features

concepts

Understanding ToolBar Architecture


ContainerType Enumeration

[image]
Intersoft WebDesktop Documentation
ContainerType Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : ContainerType Enumeration

Glossary Item Box

Value representing the container type of WebSplitter.

Syntax

Visual Basic (Declaration)
Public Enum ContainerType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ContainerType
C#
public enum ContainerType : System.Enum

Members

Member | Description
Custom | The container type of WebSplitter is Custom.
Table | The container type of WebSplitter is Table.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.ContainerType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


ContentMode Enumeration

[image]
Intersoft WebDesktop Documentation
ContentMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : ContentMode Enumeration

Glossary Item Box

Value representing the content mode used by a container.

Syntax

Visual Basic (Declaration)
Public Enum ContentMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ContentMode
C#
public enum ContentMode : System.Enum

Members

Member | Description
Default | The default content mode.
UseIFrame | The content is specified in another page which displayed in an IFrame.
UseInlineContent | The content is specified in Template.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.ContentMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


ControlBox Enumeration

[image]
Intersoft WebDesktop Documentation
ControlBox Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : ControlBox Enumeration

Glossary Item Box

Value indicating whether the control box for the Window is visible.

Syntax

Visual Basic (Declaration)
Public Enum ControlBox
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ControlBox
C#
public enum ControlBox : System.Enum

Members

Member | Description
Default |
No | The control box for the Window is not rendered.
Yes | The control box for the Window is rendered in caption bar.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.ControlBox

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


ControlBoxPosition Enumeration

[image]
Intersoft WebDesktop Documentation
ControlBoxPosition Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : ControlBoxPosition Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum ControlBoxPosition
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ControlBoxPosition
C#
public enum ControlBoxPosition : System.Enum

Members

Member | Description
Center |
Left |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.ControlBoxPosition

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


ControlType Enumeration

[image]
Intersoft WebDesktop Documentation
ControlType Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : ControlType Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum ControlType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ControlType
C#
public enum ControlType : System.Enum

Members

Member | Description
NotSet |
WebDesktopManager |
WebExplorerPane |
WebGrid |
WebNavPane |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.ControlType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


CrossIFrameMode Enumeration

[image]
Intersoft WebDesktop Documentation
CrossIFrameMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : CrossIFrameMode Enumeration

Glossary Item Box

Specifies the behavior when drag operation is performed across an IFrame element in a Web page.

Syntax

Visual Basic (Declaration)
Public Enum CrossIFrameMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As CrossIFrameMode
C#
public enum CrossIFrameMode : System.Enum

Members

Member | Description
ChildIFrameOnly | Users are allowed to perform drag action on child IFrame only.
Default |
NotAllowed | Users are not allowed to perform drag action on cross IFrame.
SiblingAndChildIFrame | Users are allowed to perform drag action on sibling and child IFrame.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.CrossIFrameMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


DialogBoxButtonType Enumeration

[image]
Intersoft WebDesktop Documentation
DialogBoxButtonType Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : DialogBoxButtonType Enumeration

Glossary Item Box

Value representing the type of button which will automatically perform built-in behavior accordingly.

Syntax

Visual Basic (Declaration)
Public Enum DialogBoxButtonType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As DialogBoxButtonType
C#
public enum DialogBoxButtonType : System.Enum

Members

Member | Description
Abort | The type of button is Abort.
Cancel | The type of button is Cancel.
Custom | The type of button is Custom.
Ignore | The type of button is Ignore.
No | The type of button is No.
NotSet | The button is not set.
OK | The type of button is Ok.
Retry | The type of button is Retry.
Yes | The type of button is Yes.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.DialogBoxButtonType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


DialogBoxImageType Enumeration

[image]
Intersoft WebDesktop Documentation
DialogBoxImageType Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : DialogBoxImageType Enumeration

Glossary Item Box

Value representing the type of WebDialogBox image.

Syntax

Visual Basic (Declaration)
Public Enum DialogBoxImageType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As DialogBoxImageType
C#
public enum DialogBoxImageType : System.Enum

Members

Member | Description
Custom | The type of image shown on WebDialogBox is custom.
Error | The type of image shown on WebDialogBox is error.
Information | The type of image shown on WebDialogBox is information.
None | None of the image is shown on WebDialogBox.
NotSet | The image on WebDialogBox is not set.
Question | The type of image shown on WebDialogBox is information.
Warning | The type of image shown on WebDialogBox is warning.

Remarks

This feature simulates the behavior of Windows Form's MessageBox where the Icon of the box can be specified. The predefined DialogBoxImage lets developers easily create any type of DialogBox with default Image assigned to it. The valid enumerations for DialogBoxImage are Information, Error, Warning, Question, None and Custom.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.DialogBoxImageType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


DialogBoxPosition Enumeration

[image]
Intersoft WebDesktop Documentation
DialogBoxPosition Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : DialogBoxPosition Enumeration

Glossary Item Box

Value representing the position of WebDialogBox.

Syntax

Visual Basic (Declaration)
Public Enum DialogBoxPosition
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As DialogBoxPosition
C#
public enum DialogBoxPosition : System.Enum

Members

Member | Description
CenterDesktop | The DialogBox will be displayd at the center screen of the entire desktop manager size.
CenterParent | The DialogBox will be automatically displayed at the center of parent's window.
Custom | The DialogBox will appear to the exact location specified in Location property

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.DialogBoxPosition

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


DimensionMode Enumeration

[image]
Intersoft WebDesktop Documentation
DimensionMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : DimensionMode Enumeration

Glossary Item Box

Value indicating the dimension/sizing mode.

Syntax

Visual Basic (Declaration)
Public Enum DimensionMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As DimensionMode
C#
public enum DimensionMode : System.Enum

Members

Member | Description
Custom | Element size will be taken from specified WidthValue or HeightValue.
Fill | Element size (height/width) will be calculated automatically to fill available spaces.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.DimensionMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


DisplayAccessKeyOnToolTip Enumeration

[image]
Intersoft WebDesktop Documentation
DisplayAccessKeyOnToolTip Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : DisplayAccessKeyOnToolTip Enumeration

Glossary Item Box

Value indicating whether access key is displayed on command tooltip.

Syntax

Visual Basic (Declaration)
Public Enum DisplayAccessKeyOnToolTip
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As DisplayAccessKeyOnToolTip
C#
public enum DisplayAccessKeyOnToolTip : System.Enum

Members

Member | Description
Default |
No | Access key will not be displayed on command tooltip.
Yes | Access key will be displayed on command tooltip.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.DisplayAccessKeyOnToolTip

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


DisplayAlignment Enumeration

[image]
Intersoft WebDesktop Documentation
DisplayAlignment Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : DisplayAlignment Enumeration

Glossary Item Box

Value representing element's display alignment.

Syntax

Visual Basic (Declaration)
Public Enum DisplayAlignment
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As DisplayAlignment
C#
public enum DisplayAlignment : System.Enum

Members

Member | Description
Bottom | Element will be displayed at bottom.
Default |
Left | Element will be displayed at left.
Right | Element will be displayed at right.
Top | Element will be displayed at top.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.DisplayAlignment

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


DisplayMode Enumeration

[image]
Intersoft WebDesktop Documentation
DisplayMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : DisplayMode Enumeration

Glossary Item Box

Value representing caption or footer display mode.

Syntax

Visual Basic (Declaration)
Public Enum DisplayMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As DisplayMode
C#
public enum DisplayMode : System.Enum

Members

Member | Description
Default |
Image | Only Image will be rendered.
Text | Only Text will be rendered.
TextAndImage | Text and Image will be rendered.
UseTemplate | The container should render the content specified in the Template, ignoring built-in rendering mechanism.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.DisplayMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


DisplayToolTip Enumeration

[image]
Intersoft WebDesktop Documentation
DisplayToolTip Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : DisplayToolTip Enumeration

Glossary Item Box

Value indicating whether command tooltip is displayed.

Syntax

Visual Basic (Declaration)
Public Enum DisplayToolTip
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As DisplayToolTip
C#
public enum DisplayToolTip : System.Enum

Members

Member | Description
Default |
No | Command tooltip will not be displayed.
Yes | Command tooltip will be displayed.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.DisplayToolTip

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


DockingArea Enumeration

[image]
Intersoft WebDesktop Documentation
DockingArea Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : DockingArea Enumeration

Glossary Item Box

Value representing the docking area for WebToolBar and WebMenuBar.

Syntax

Visual Basic (Declaration)
Public Enum DockingArea
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As DockingArea
C#
public enum DockingArea : System.Enum

Members

Member | Description
Bottom | The docking on toolbar is set to bottom area.
Left | The docking on toolbar is set to left area.
NotSet | The docking on toolbar is not set.
Right | The docking on toolbar is set to right area.
Top | The docking on toolbar is set to top area.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.DockingArea

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


DragDataTypes Enumeration

[image]
Intersoft WebDesktop Documentation
DragDataTypes Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : DragDataTypes Enumeration

Glossary Item Box

Specifies which data types are acceptable for a drag control to perform a drop operation.

Syntax

Visual Basic (Declaration)
Public Enum DragDataTypes
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As DragDataTypes
C#
public enum DragDataTypes : System.Enum

Members

Member | Description
All | All data types are acceptable for a drag control to perform a drop operation.
Array | Array data types are acceptable for a drag control to perform a drop operation.
Boolean | Boolean data types are acceptable for a drag control to perform a drop operation.
Custom | Custom data types are acceptable for a drag control to perform a drop operation.
DateTime | DateTime data types are acceptable for a drag control to perform a drop operation.
Default |
Number | Number data types are acceptable for a drag control to perform a drop operation.
Object | Object data types are acceptable for a drag control to perform a drop operation.
String | String data types are acceptable for a drag control to perform a drop operation.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.DragDataTypes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


DragDropEffects Enumeration

[image]
Intersoft WebDesktop Documentation
DragDropEffects Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : DragDropEffects Enumeration

Glossary Item Box

Specifies the effect when drag-drop is performed.

Syntax

Visual Basic (Declaration)
Public Enum DragDropEffects
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As DragDropEffects
C#
public enum DragDropEffects : System.Enum

Members

Member | Description
All |
Copy | The Copy effect is applied when drag-drop is performed.
Link | The Link effect is applied when drag-drop is performed.
Move | The Move effect is applied when drag-drop is performed.
None | No effect is applied when drag-drop is performed.
NotAllowed | The NotAllowed effect is applied when drag-drop is performed.
Remove | The Remove effect is applied when drag-drop is performed.
Scroll | The Scroll effect is applied when drag-drop is performed.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.DragDropEffects

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


DragVisualHint Enumeration

[image]
Intersoft WebDesktop Documentation
DragVisualHint Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : DragVisualHint Enumeration

Glossary Item Box

Specifies the visual effect which is displayed during drag operation.

Syntax

Visual Basic (Declaration)
Public Enum DragVisualHint
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As DragVisualHint
C#
public enum DragVisualHint : System.Enum

Members

Member | Description
Default |
MakeTransparent | Sets the visual effect of the object to transparent when dragged.
SimpleIndicator | Sets the visual effect of the object to show a simple indicator when dragged.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.DragVisualHint

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


FillDockingRow Enumeration

[image]
Intersoft WebDesktop Documentation
FillDockingRow Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : FillDockingRow Enumeration

Glossary Item Box

Value indicating whether a Bar control dimension fills the row region of PlaceHolderManager docking row.

Syntax

Visual Basic (Declaration)
Public Enum FillDockingRow
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As FillDockingRow
C#
public enum FillDockingRow : System.Enum

Members

Member | Description
Default |
No | Bar control dimension does not fill the row region of PlaceHolderManager docking row.
Yes | Bar control dimension fills the row region of PlaceHolderManager docking row.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.FillDockingRow

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


FrameTarget Enumeration

[image]
Intersoft WebDesktop Documentation
FrameTarget Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : FrameTarget Enumeration

Glossary Item Box

Value representing the target frame where the URL specified in TargetURL should be displayed.

Syntax

Visual Basic (Declaration)
Public Enum FrameTarget
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As FrameTarget
C#
public enum FrameTarget : System.Enum

Members

Member | Description
Blank | No frame is targeted.
Parent | The frame is targeted to parent.
Search | The frame is targeted to search.
Self | The frame is targeted to self.
Top | The frame is targeted to top.
UseBase | The frame is targeted using base.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.FrameTarget

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


GreyImageWhenDisabled Enumeration

[image]
Intersoft WebDesktop Documentation
GreyImageWhenDisabled Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : GreyImageWhenDisabled Enumeration

Glossary Item Box

Value indicating whether a grey image is applied when command is disabled.

Syntax

Visual Basic (Declaration)
Public Enum GreyImageWhenDisabled
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As GreyImageWhenDisabled
C#
public enum GreyImageWhenDisabled : System.Enum

Members

Member | Description
Default |
No | grey image is not applied when command is disabled.
Yes | Grey image is applied when command is disabled.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.GreyImageWhenDisabled

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


GroupPaneType Enumeration

[image]
Intersoft WebDesktop Documentation
GroupPaneType Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : GroupPaneType Enumeration

Glossary Item Box

Value representing the group type of the GroupPane.

Syntax

Visual Basic (Declaration)
Public Enum GroupPaneType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As GroupPaneType
C#
public enum GroupPaneType : System.Enum

Members

Member | Description
HorizontalTile | Panes inside the group will be tiled horizontally.
VerticalTile | Panes inside the group will be tiled vertically.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.GroupPaneType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


HandleVisible Enumeration

[image]
Intersoft WebDesktop Documentation
HandleVisible Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : HandleVisible Enumeration

Glossary Item Box

Value indicating whether a bar handle is visible.

Syntax

Visual Basic (Declaration)
Public Enum HandleVisible
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As HandleVisible
C#
public enum HandleVisible : System.Enum

Members

Member | Description
Default |
No | The bar handle section is not visible.
Yes | The bar handle section is visible.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.HandleVisible

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


HeaderAppearanceMode Enumeration

[image]
Intersoft WebDesktop Documentation
HeaderAppearanceMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : HeaderAppearanceMode Enumeration

Glossary Item Box

Value representing predefined style applied to the WebPane's header part.

Syntax

Visual Basic (Declaration)
Public Enum HeaderAppearanceMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As HeaderAppearanceMode
C#
public enum HeaderAppearanceMode : System.Enum

Members

Member | Description
Default |
UseCustomStyle | HeaderCustomStyle will be used to render Pane's Header.
UseMainStyle | HeaderMainStyle will be used to render Pane's Header.
UseSubStyle | HeaderSubStyle will be used to render Pane's Header.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.HeaderAppearanceMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


IconViewDisplayMode Enumeration

[image]
Intersoft WebDesktop Documentation
IconViewDisplayMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : IconViewDisplayMode Enumeration

Glossary Item Box

Value representing the display mode when the menu is operating in IconView mode.

Syntax

Visual Basic (Declaration)
Public Enum IconViewDisplayMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As IconViewDisplayMode
C#
public enum IconViewDisplayMode : System.Enum

Members

Member | Description
Image | The display mode is Image.
Text | The display mode is Text.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.IconViewDisplayMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


ImagePosition Enumeration

[image]
Intersoft WebDesktop Documentation
ImagePosition Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : ImagePosition Enumeration

Glossary Item Box

Value representing the position of the image relative to the text.

Syntax

Visual Basic (Declaration)
Public Enum ImagePosition
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ImagePosition
C#
public enum ImagePosition : System.Enum

Members

Member | Description
Default |
Left | The position of the image to the text is left.
Right | The position of the image to the text is right.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.ImagePosition

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


InfoTextPosition Enumeration

[image]
Intersoft WebDesktop Documentation
InfoTextPosition Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : InfoTextPosition Enumeration

Glossary Item Box

Value representing the position of the InfoText part.

Syntax

Visual Basic (Declaration)
Public Enum InfoTextPosition
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As InfoTextPosition
C#
public enum InfoTextPosition : System.Enum

Members

Member | Description
BelowCaption | Infotext should be placed below the caption.
BesideCaption | Infotext should be placed beside caption, by default is the right side.
Default |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.InfoTextPosition

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


InteractivityMode Enumeration

[image]
Intersoft WebDesktop Documentation
InteractivityMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : InteractivityMode Enumeration

Glossary Item Box

Specifies the interactivity type when a window is moved or resized in WebDesktopManager.

Syntax

Visual Basic (Declaration)
Public Enum InteractivityMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As InteractivityMode
C#
public enum InteractivityMode : System.Enum

Members

Member | Description
Physical | Users will interact with the physical window when resizing or moving the window.
Shadow | Users will interact with the shadow of the physical window when resizing or moving the window.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.InteractivityMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


IsFloat Enumeration

[image]
Intersoft WebDesktop Documentation
IsFloat Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : IsFloat Enumeration

Glossary Item Box

Value indicating whether Bar control is floated on the page.

Syntax

Visual Basic (Declaration)
Public Enum IsFloat
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As IsFloat
C#
public enum IsFloat : System.Enum

Members

Member | Description
Default |
No | The bar control is not floated on the page.
Yes | The bar control is floated on the page.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.IsFloat

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


LayoutMode Enumeration

[image]
Intersoft WebDesktop Documentation
LayoutMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : LayoutMode Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum LayoutMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As LayoutMode
C#
public enum LayoutMode : System.Enum

Members

Member | Description
ComplexImages |
Simple |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.LayoutMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


LoaderMode Enumeration

[image]
Intersoft WebDesktop Documentation
LoaderMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : LoaderMode Enumeration

Glossary Item Box

Value representing WebDesktopManager's loader mode.

Syntax

Visual Basic (Declaration)
Public Enum LoaderMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As LoaderMode
C#
public enum LoaderMode : System.Enum

Members

Member | Description
UseBuiltIn | The built-in loader provided by WebDesktopManager control.
UseCustom | Use custom loader specified in LoaderTemplate of WebDesktopManager control.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.LoaderMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


MenuAnimationMode Enumeration

[image]
Intersoft WebDesktop Documentation
MenuAnimationMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : MenuAnimationMode Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum MenuAnimationMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As MenuAnimationMode
C#
public enum MenuAnimationMode : System.Enum

Members

Member | Description
Fading |
Sliding |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.MenuAnimationMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


MenuAnimationType Enumeration

[image]
Intersoft WebDesktop Documentation
MenuAnimationType Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : MenuAnimationType Enumeration

Glossary Item Box

Value representing animation type for showing popup menu.

Syntax

Visual Basic (Declaration)
Public Enum MenuAnimationType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As MenuAnimationType
C#
public enum MenuAnimationType : System.Enum

Members

Member | Description
Default |
Slide | The animation type while showing popup menu is Slide.
Unfold | The animation type while showing popup menu is Unfold.

Remarks

Test

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.MenuAnimationType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


MenuHighlightMode Enumeration

[image]
Intersoft WebDesktop Documentation
MenuHighlightMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : MenuHighlightMode Enumeration

Glossary Item Box

Contains the options used to highlight the menu item.

Syntax

Visual Basic (Declaration)
Public Enum MenuHighlightMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As MenuHighlightMode
C#
public enum MenuHighlightMode : System.Enum

Members

Member | Description
UseComplexImages | Uses the specified complex images.
UseWebStyle | Uses the default WebStyle.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.MenuHighlightMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


MenuIntegrationMode Enumeration

[image]
Intersoft WebDesktop Documentation
MenuIntegrationMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : MenuIntegrationMode Enumeration

Glossary Item Box

Value representing menu integration mode in WebToolBar, WebMenuBar or PlaceHolderManager.

Syntax

Visual Basic (Declaration)
Public Enum MenuIntegrationMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As MenuIntegrationMode
C#
public enum MenuIntegrationMode : System.Enum

Members

Member | Description
DesktopManager | Menu will integrate to DesktopManager.
None |
PlaceHolderManager | Menu will integrate to PlaceHolderManager.

Remarks

There are 2 integration modes available on WebMenuBar, which are Integration to Desktop Manager and Integration to PlaceHolder Manager.

  • Integration to Desktop Manager.
    This is the most recommended configuration to create a uniform and consistent look&feel for all menu instances throughout entire applications. When integrated to DesktopManager, the Menu will use Application MenuStyles defined in DesktopManager level. To do this, you simply set the IntegratedTo property to DesktopManager. The menu system will automatically apply the styles at runtime, and hence the integration also means compact output since styles and CSS classes for the menu instance are no longer rendered.
  • Integration to PlaceHolder Manager.
    This scenario is the best applied when you want to have all menu instances inside a WebForm to use one single style definition which is different with DesktopManager's Application MenuStyle. The easiest way to understand this integration mode is by examining how Office 2003 application works. So all menu system in Office 2003 applications are using one single style definition which is separate to Windows menu style. Likewise, all menu systems in Visual Studio 2005 use one single style defined at application level, which differs from Windows menu style.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.MenuIntegrationMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace

Concepts

WebMenu Features
WebToolBar Features
PlaceHolderManager Concept


MenuItemType Enumeration

[image]
Intersoft WebDesktop Documentation
MenuItemType Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : MenuItemType Enumeration

Glossary Item Box

Value representing the type of the MenuItem.

Syntax

Visual Basic (Declaration)
Public Enum MenuItemType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As MenuItemType
C#
public enum MenuItemType : System.Enum

Members

Member | Description
CheckBox | The type of menu item is CheckBox.
Custom | Menu item type can be customized.
Normal |
Radio | The type of menu item is Radio.
Separator | The type of menu item is Separator.
Template | The type of menu item is Template.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.MenuItemType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


NavBarContentMode Enumeration

[image]
Intersoft WebDesktop Documentation
NavBarContentMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : NavBarContentMode Enumeration

Glossary Item Box

Value representing content mode of the NavBar.

Syntax

Visual Basic (Declaration)
Public Enum NavBarContentMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As NavBarContentMode
C#
public enum NavBarContentMode : System.Enum

Members

Member | Description
Default |
UseIFrame | The content mode of WebNavBar is UseIFrame mode.
UseInlineContent | The content mode of WebNavBar is UseInlineContent mode.
UseItems | The content mode of WebNavBar is UseItems mode.

Remarks

By default, the WebNavBar will operate in UseInlineContent mode when a new instance is dropped to designer surface. UseInlineContent is the most suitable when the contents inside each WebNavBar page are relatively small. UseInlineContent mode utilized .NET Framework's template architecture and therefore all contents are loaded at once in first load (although the contents in inactive bar are set to hidden).

In most cases where you want to develop a more reusable form, you should use UseIFrame as the content mode. When using IFrame mode, you would need to specify the ContentURL which page you want to load for the designated WebNavBar.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.NavBarContentMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace

Tasks

Using Template and IFrame Content mode

Concepts

NavPane Features

concepts

Understanding NavPane Concepts


NotificationAnimationStyle Enumeration

[image]
Intersoft WebDesktop Documentation
NotificationAnimationStyle Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : NotificationAnimationStyle Enumeration

Glossary Item Box

Value representing the animation style for this notification control.

Syntax

Visual Basic (Declaration)
Public Enum NotificationAnimationStyle
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As NotificationAnimationStyle
C#
public enum NotificationAnimationStyle : System.Enum

Members

Member | Description
Fading | The animation style of notification control is fading.
None | No animation style is set on notification control.
Sliding | The animation style of notification control is sliding.

Remarks

When set to Fading, the WebNotification window will be displayed (fading from transparent to opaque). The animation speed can be set in FadingSpeed property. The Fading mode resembles the Outlook 2003® animation's style and behavior.

The Sliding mode resembles the MSN Messenger® animation's style and behavior where notification window will be slided from bottom to top.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.NotificationAnimationStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace

Concepts

WebNotification Features


Orientation Enumeration

[image]
Intersoft WebDesktop Documentation
Orientation Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : Orientation Enumeration

Glossary Item Box

Value representing the orientation of WebSplitter.

Syntax

Visual Basic (Declaration)
Public Enum Orientation
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As Orientation
C#
public enum Orientation : System.Enum

Members

Member | Description
Horizontal | The orientation of splitter is horizontal.
Vertical | The orientation of splitter is vertical (the default value).

Remarks

The default value of Orientation property is Vertical. However, you can change the value to Horizontal if you want to use WebSplitter to split rows.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.Orientation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace

Tasks

Using WebSplitter to split basic two cells

Concepts

WebSplitter Features


OrientationMode Enumeration

[image]
Intersoft WebDesktop Documentation
OrientationMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : OrientationMode Enumeration

Glossary Item Box

Value representing window type to be used as the menu container.

Syntax

Visual Basic (Declaration)
Public Enum OrientationMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As OrientationMode
C#
public enum OrientationMode : System.Enum

Members

Member | Description
Horizontal | Element should be rendered in left to right direction.
Vertical | Element should be rendered in straightup (top to bottom) direction.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.OrientationMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


PlaceHolderIntegrationMode Enumeration

[image]
Intersoft WebDesktop Documentation
PlaceHolderIntegrationMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : PlaceHolderIntegrationMode Enumeration

Glossary Item Box

Value representing PlaceHolder integration mode.

Syntax

Visual Basic (Declaration)
Public Enum PlaceHolderIntegrationMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As PlaceHolderIntegrationMode
C#
public enum PlaceHolderIntegrationMode : System.Enum

Members

Member | Description
DesktopManager | The integration mode on PlaceHolder is DesktopManager.
None | No integration mode on PlaceHolder.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.PlaceHolderIntegrationMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


PointingPosition Enumeration

[image]
Intersoft WebDesktop Documentation
PointingPosition Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : PointingPosition Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum PointingPosition
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As PointingPosition
C#
public enum PointingPosition : System.Enum

Members

Member | Description
AutoDetect |
PointingBottomLeft |
PointingBottomRight |
PointingTopLeft |
PointingTopRight |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.PointingPosition

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


PopupWindowType Enumeration

[image]
Intersoft WebDesktop Documentation
PopupWindowType Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : PopupWindowType Enumeration

Glossary Item Box

Value representing the window type to be used as the menu container.

Syntax

Visual Basic (Declaration)
Public Enum PopupWindowType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As PopupWindowType
C#
public enum PopupWindowType : System.Enum

Members

Member | Description
Normal | The popup should use normal html object.
Popup | The popup should use IE special popup object.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.PopupWindowType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


PostbackMode Enumeration

[image]
Intersoft WebDesktop Documentation
PostbackMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : PostbackMode Enumeration

Glossary Item Box

Value indicating postback mode when the button is clicked and AutoPostback is enabled.

Syntax

Visual Basic (Declaration)
Public Enum PostbackMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As PostbackMode
C#
public enum PostbackMode : System.Enum

Members

Member | Description
FlyPostBack | The postback mode is FlyPostBack when the button is clicked and AutoPostback is enabled.
FullPostBack | The postback mode is FullPostBack when the button is clicked and AutoPostback is enabled.

Remarks

WebButton is taking advantage of FlyPostBack and ClientAction architecture enabling the Button to execute server side codes in Button's OnClick event without full page refresh. Instead of FlyPostBack, WebButton also supports traditional page postback by setting it to FullPostBack value.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.PostbackMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace

Concepts

WebButton Features


PreferredHorizontalPosition Enumeration

[image]
Intersoft WebDesktop Documentation
PreferredHorizontalPosition Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : PreferredHorizontalPosition Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum PreferredHorizontalPosition
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As PreferredHorizontalPosition
C#
public enum PreferredHorizontalPosition : System.Enum

Members

Member | Description
Left |
Right |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.PreferredHorizontalPosition

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


PreferredVerticalPosition Enumeration

[image]
Intersoft WebDesktop Documentation
PreferredVerticalPosition Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : PreferredVerticalPosition Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum PreferredVerticalPosition
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As PreferredVerticalPosition
C#
public enum PreferredVerticalPosition : System.Enum

Members

Member | Description
Bottom |
Top |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.PreferredVerticalPosition

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


RenderMode Enumeration

[image]
Intersoft WebDesktop Documentation
RenderMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : RenderMode Enumeration

Glossary Item Box

Value representing the type of rendering mode that you can use to create professional Tab control in your web application.

Syntax

Visual Basic (Declaration)
Public Enum RenderMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As RenderMode
C#
public enum RenderMode : System.Enum

Members

Member | Description
ComplexImages | Renders Tab control using complex images using specified settings and images.
RoundCorner | Renders Tab control using artificial round corner similar to Windows XP style. No images are required.
Simple | Renders Tab control using simple layout applying standard borders and styles.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.RenderMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace

Concepts

WebTab Features


ServiceType Enumeration

[image]
Intersoft WebDesktop Documentation
ServiceType Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : ServiceType Enumeration

Glossary Item Box

Value representing the service type used by the notification control to request data.

Syntax

Visual Basic (Declaration)
Public Enum ServiceType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ServiceType
C#
public enum ServiceType : System.Enum

Members

Member | Description
WebForm | WebNotification will use WebForm Service Type.
WebService | WebNotification will use WebService Service Type.

Remarks

WebNotification provides two types ServiceType. They are WebForm ServiceType and WebService ServiceType.

  • WebForm ServiceType.
    This is the default value for ServiceType property. WebForm mode is recommended when the data provider is private and does not need to be exposed. With this mode, you need to set the WebForm (aspx) page which the control will invoke. You can set the ServiceUrl to either the current caller page or another WebForm page in the application.
  • WebService ServiceType.
    This type allows you to retrieve Notifications data from a web service (asmx) page. When set to this mode, you set the ServiceUrl to the web service page containing the method required by WebNotification control. The WebService mode is the recommended data provider setting when the methods need to be exposed for other usage. Note that both WebForm and WebService have similar method signature and returned object type. This allows you to easily switch between WebForm and WebService as necessary in certain phase of development.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.ServiceType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


ShortcutDisplayMode Enumeration

[image]
Intersoft WebDesktop Documentation
ShortcutDisplayMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : ShortcutDisplayMode Enumeration

Glossary Item Box

Value representing display mode of the shortcut icons.

Syntax

Visual Basic (Declaration)
Public Enum ShortcutDisplayMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ShortcutDisplayMode
C#
public enum ShortcutDisplayMode : System.Enum

Members

Member | Description
Image | The display mode of shortcut icon is Image.
TextAndImage | The display mode of shortcut icon is Text and Image.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.ShortcutDisplayMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


ShowBehavior Enumeration

[image]
Intersoft WebDesktop Documentation
ShowBehavior Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : ShowBehavior Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum ShowBehavior
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ShowBehavior
C#
public enum ShowBehavior : System.Enum

Members

Member | Description
Default |
NoFading |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.ShowBehavior

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


SizeMode Enumeration

[image]
Intersoft WebDesktop Documentation
SizeMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : SizeMode Enumeration

Glossary Item Box

Value representing the tool command sizing mode.

Syntax

Visual Basic (Declaration)
Public Enum SizeMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As SizeMode
C#
public enum SizeMode : System.Enum

Members

Member | Description
Automatic | Width and Height are automatically calculated based on length of the text.
Default |
Fixed | Width and Height should be fixed using the value specified in Width and Height property.
Justify | Width/Height are automatically justified to take all available spaces in the control area.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.SizeMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


SpecificDragObjectEffects Enumeration

[image]
Intersoft WebDesktop Documentation
SpecificDragObjectEffects Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : SpecificDragObjectEffects Enumeration

Glossary Item Box

Specifies the single effect applied to drag control.

Syntax

Visual Basic (Declaration)
Public Enum SpecificDragObjectEffects
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As SpecificDragObjectEffects
C#
public enum SpecificDragObjectEffects : System.Enum

Members

Member | Description
All |
Copy | The Copy effect is applied on the specified object when drag-drop is performed.
Default |
Link | The Link effect is applied on the specified object when drag-drop is performed.
Move | The Move effect is applied on the specified object when drag-drop is performed.
None | No effect is applied when drag-drop is performed.
NotAllowed | The NotAllowed effect is applied on the specified object when drag-drop is performed.
Remove | The Remove effect is applied on the specified object when drag-drop is performed.
Scroll | The Scroll effect is applied on the specified object when drag-drop is performed.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.SpecificDragObjectEffects

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


TextAlignment Enumeration

[image]
Intersoft WebDesktop Documentation
TextAlignment Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : TextAlignment Enumeration

Glossary Item Box

Value representing the type of command text alignment.

Syntax

Visual Basic (Declaration)
Public Enum TextAlignment
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As TextAlignment
C#
public enum TextAlignment : System.Enum

Members

Member | Description
Center | Text will be aligned to center.
Default |
Left | Text will be aligned to left.
Right | Text will be aligned to right.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.TextAlignment

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


TextDirection Enumeration

[image]
Intersoft WebDesktop Documentation
TextDirection Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : TextDirection Enumeration

Glossary Item Box

Value representing the direction of the text in each TabItem.

Syntax

Visual Basic (Declaration)
Public Enum TextDirection
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As TextDirection
C#
public enum TextDirection : System.Enum

Members

Member | Description
Default |
Horizontal | Text is displayed from either left to right or right to left.
Vertical | Text is displayed from top to bottom.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.TextDirection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


Theme Enumeration

[image]
Intersoft WebDesktop Documentation
Theme Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : Theme Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum Theme
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As Theme
C#
public enum Theme : System.Enum

Members

Member | Description
Buddy |
Vista |
XP |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.Theme

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


ToggleGroupType Enumeration

[image]
Intersoft WebDesktop Documentation
ToggleGroupType Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : ToggleGroupType Enumeration

Glossary Item Box

Value representing ToggleGroup type.

Syntax

Visual Basic (Declaration)
Public Enum ToggleGroupType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ToggleGroupType
C#
public enum ToggleGroupType : System.Enum

Members

Member | Description
SelectNone | The ToggleGroup will select none of the object on WebToolBar.
SelectOne | The ToggleGroup will select one object on WebToolBar.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.ToggleGroupType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


UIUpdateMode Enumeration

[image]
Intersoft WebDesktop Documentation
UIUpdateMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : UIUpdateMode Enumeration

Glossary Item Box

Value representing the update behavior of automatic callback feature.

Syntax

Visual Basic (Declaration)
Public Enum UIUpdateMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As UIUpdateMode
C#
public enum UIUpdateMode : System.Enum

Members

Member | Description
AllControls | All controls converted to use FlyPostBack.
Custom | Only specific individual controls converted to use FlyPostBack.

Remarks

When the EnableUIMode property in WebFlyPostBackManager is set to True, you can decide whether all ASP.NET standard controls should be converted to use FlyPostBack or only specific individual controls by configuring the UpdateMode property. The default value is AllControls.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.UIUpdateMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


Visibility Enumeration

[image]
Intersoft WebDesktop Documentation
Visibility Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : Visibility Enumeration

Glossary Item Box

Value indicating whether the element should be visible or not.

Syntax

Visual Basic (Declaration)
Public Enum Visibility
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As Visibility
C#
public enum Visibility : System.Enum

Members

Member | Description
Default |
No | Element is not visible.
Yes | Element should be rendered and visible.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.Visibility

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


VisualTransitionEffect Enumeration

[image]
Intersoft WebDesktop Documentation
VisualTransitionEffect Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : VisualTransitionEffect Enumeration

Glossary Item Box

Value representing visual transition effect used when the desktop has been loaded successfully.

Syntax

Visual Basic (Declaration)
Public Enum VisualTransitionEffect
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As VisualTransitionEffect
C#
public enum VisualTransitionEffect : System.Enum

Members

Member | Description
Fade | The visual transition effect is fading.
GradientWipe | The visual transition effect type is GradientWipe.
Iris | The visual transition effect type is Iris.
None | No visual transition effect is set.
Pixelate | The visual transition effect type is Pixelate.
SlideAndHide | The visual transition effect type is SlideAndHide.
SlideAndPush | The visual transition effect type is SlideAndPush.
SlideAndSwap | The visual transition effect type is SlideAndSwap.
Wheel | The visual transition effect type is Wheel.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.VisualTransitionEffect

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


WebCallOutContentMode Enumeration

[image]
Intersoft WebDesktop Documentation
WebCallOutContentMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebCallOutContentMode Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum WebCallOutContentMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebCallOutContentMode
C#
public enum WebCallOutContentMode : System.Enum

Members

Member | Description
UseTemplate |
UseText |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.WebCallOutContentMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


WebNavImagePosition Enumeration

[image]
Intersoft WebDesktop Documentation
WebNavImagePosition Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNavImagePosition Enumeration

Glossary Item Box

Value representing the image position of NavBarItem.

Syntax

Visual Basic (Declaration)
Public Enum WebNavImagePosition
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebNavImagePosition
C#
public enum WebNavImagePosition : System.Enum

Members

Member | Description
AboveText | The image position in WebNavBarItem is above text.
BesideText | The image position in WebNavBarItem is beside text.
Default |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.WebNavImagePosition

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


WebNavType Enumeration

[image]
Intersoft WebDesktop Documentation
WebNavType Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebNavType Enumeration

Glossary Item Box

Value representing the type of WebNavPane.

Syntax

Visual Basic (Declaration)
Public Enum WebNavType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebNavType
C#
public enum WebNavType : System.Enum

Members

Member | Description
Outlook2003 | The type applied to WebNavPane is Outlook 2003.
WinXP | The type applied to WebNavPane is WinXP.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.WebNavType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


WindowAnimationStyle Enumeration

[image]
Intersoft WebDesktop Documentation
WindowAnimationStyle Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WindowAnimationStyle Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum WindowAnimationStyle
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WindowAnimationStyle
C#
public enum WindowAnimationStyle : System.Enum

Members

Member | Description
ShrinkExpand |
VistaStyleZoom |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.WindowAnimationStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


WindowArrangementMode Enumeration

[image]
Intersoft WebDesktop Documentation
WindowArrangementMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WindowArrangementMode Enumeration

Glossary Item Box

Value representing the arrangement mode for all windows.

Syntax

Visual Basic (Declaration)
Public Enum WindowArrangementMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WindowArrangementMode
C#
public enum WindowArrangementMode : System.Enum

Members

Member | Description
Cascaded | Windows are arranged in cascading tile.
TiledHorizontally | Windows are tiled horizontally.
TiledVertically | Windows are tiled vertically.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.WindowArrangementMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


WindowCaptionDisplayMode Enumeration

[image]
Intersoft WebDesktop Documentation
WindowCaptionDisplayMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WindowCaptionDisplayMode Enumeration

Glossary Item Box

Value representing display mode for the Caption.

Syntax

Visual Basic (Declaration)
Public Enum WindowCaptionDisplayMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WindowCaptionDisplayMode
C#
public enum WindowCaptionDisplayMode : System.Enum

Members

Member | Description
Default |
Text | The caption display mode uses text.
UseTemplate | The caption display mode uses template.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.WindowCaptionDisplayMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


WindowOptionsPosition Enumeration

[image]
Intersoft WebDesktop Documentation
WindowOptionsPosition Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WindowOptionsPosition Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum WindowOptionsPosition
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WindowOptionsPosition
C#
public enum WindowOptionsPosition : System.Enum

Members

Member | Description
Left |
Right |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.WindowOptionsPosition

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


WindowState Enumeration

[image]
Intersoft WebDesktop Documentation
WindowState Enumeration
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WindowState Enumeration

Glossary Item Box

Value representing the initial state for Window.

Syntax

Visual Basic (Declaration)
Public Enum WindowState
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WindowState
C#
public enum WindowState : System.Enum

Members

Member | Description
Maximized | The initial state of Window is maximized.
Minimized | The initial state of Window is minimized.
Normal | The initial state of Window is normal.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebDesktop.WindowState

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebDesktop Namespace


IBar Interface

[image]
Intersoft WebDesktop Documentation
IBar Interface
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : IBar Interface

Glossary Item Box

IBar interface. This Interface is used to support intersoft products development only, not to be used by developers.

Syntax

Visual Basic (Declaration)
Public Interface IBar
   Inherits ICommand
Visual Basic (Usage) Copy Code
Dim instance As IBar
C#
public interface IBar : ICommand

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Members
ISNet.WebUI.WebDesktop Namespace


IBar Interface Members

[image]
Intersoft WebDesktop Documentation
IBar Interface Members
See Also Properties Methods Events Send Feedback
ISNet.WebUI.WebDesktop Namespace : IBar Interface

Glossary Item Box

The following tables list the members exposed by IBar.

Public Properties

 | Name | Description
Property | AddRemoveOptionMenuViewMode | Gets or sets the add remove option menu view mode.
Property | AllowCustomize | Gets or sets a value that indicates whether bar controls in PlaceHolderManager is customizeable.
Property | AllowDockBottom | Gets or sets a value that indicates whether a bar control can be docked to bottom area of PlaceHolderManager.
Property | AllowDockLeft | Gets or sets a value that indicates whether a bar control can be docked to left area of PlaceHolderManager.
Property | AllowDockRight | Gets or sets a value that indicates whether a bar control can be docked to right area of PlaceHolderManager.
Property | AllowDockTop | Gets or sets a value that indicates whether a bar control can be docked to top area of PlaceHolderManager.
Property | AllowExpandCollapse | Gets or sets a value that indicates whether Bar controls in PlaceHolderManager is expandable and collapseable.
Property | AllowFloat | Gets or sets a value that indicates whether Bar controls in PlaceHolderManager is floatable.
Property | AllowMove | Gets or sets a value that indicates whether Bar controls in PlaceHolderManager is moveable.
Property | BarStyle | Gets or sets the Bar style.
Property | BodyStyle | Gets or sets the body style.
Property | Caption | Specifies the Bar caption
Property | CommandClientSideEvents | Specifies the client side (JavaScript) tool command events.
Property | CommandDisabledStyle | Gets or sets the style properties of disabled command style.
Property | CommandFontStyle | Gets or sets the font style of the tool command.
Property | CommandStyle | Gets or sets the style properties of command in the bar control.
Property | DefaultFillDockingRow | Gets or sets the default fill of DockingRow.
Property | DesignHeight |
Property | DesignWidth |
Property | DockingArea | Gets or sets the bar docking area.
Property | DockingOffset | Specifies the bar docking offset.
Property | DockingRow | Specifies the bar docking row.
Property | FillDockingRow | Gets or sets a value that indicates whether a bar control dimension in PlaceHolderManager fills the row region of PlaceHolderManager docking row.
Property | GreyImageWhenDisabled | Gets or sets a value that indicates whether a grey image is applied when command is disabled.
Property | HandleStyle | Gets or sets the style properties of handle bar section in the bar control.
Property | HandleVisible | Gets or sets a value that indicates whether a Bar handle section in PlaceHolderManager is visible.
Property | HeaderButtonStyle | Gets or sets the style properties of the header bar close button in the bar control.
Property | HeaderCaptionStyle | Gets or sets the style properties of the header bar caption in the bar control.
Property | HeaderHeight | Gets or sets the height of the bar control header.
Property | Height |
Property | ID |
Property | IntegratedTo | Gets or sets the bar menu integrated mode.
Property | IsFloat | Gets or sets a value that indicates whether a bar control is floated on the page.
Property | IsRemoveInDesign |
Property | IsRuntimeBar |
Property | IsSynchronize |
Property | MaxDockingRows | Gets or sets maximum docking rows for docking area.
Property | NewDockingArea |
Property | NewDockingRow |
Property | OptionStyle | Gets or sets the style properties of option bar section in the bar control.
Property | PHMDesigner |
Property | PlaceHolder | Specifies the bar placeholder manager.
Property | RaiseBarLayoutPropertiesChangedEvent |
Property | RaiseBarPropertiesChangedEvent |
Property | SeparatorStyle | Gets or sets the style properties of separator command in the bar control.
Property | SizeMode | Gets or sets the tool command sizing mode.
Property | ToggleGroups | Gets the collection of toggle group commands in WebToolbar.
Property | Width |
Top

Public Methods

 | Name | Description
Method | GetOrientation |
Method | ResetUsageData |
Method | SetDockingArea |
Method | SetDockingRow |
Method | SetPlaceHolder |
Method | SynchronizeBarProperties |
Top

Public Events

 | Name | Description
Event | BarLayoutPropertiesChanged |
Event | BarPropertiesChanged |
Top

See Also

Reference

IBar Interface
ISNet.WebUI.WebDesktop Namespace


IBar Interface Methods

[image]
Intersoft WebDesktop Documentation
IBar Interface Methods
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : IBar Interface

Glossary Item Box

For a list of all members of this type, see IBar members.

Public Methods

 | Name | Description
Method | GetOrientation |
Method | ResetUsageData |
Method | SetDockingArea |
Method | SetDockingRow |
Method | SetPlaceHolder |
Method | SynchronizeBarProperties |
Top

See Also

Reference

IBar Interface
ISNet.WebUI.WebDesktop Namespace


SetDockingArea Method

[image]
Intersoft WebDesktop Documentation
SetDockingArea Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : SetDockingArea Method

dockingArea

Glossary Item Box

Syntax

Visual Basic (Declaration)
Sub SetDockingArea( _
   ByVal dockingArea As DockingArea _
)
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim dockingArea As DockingArea

instance.SetDockingArea(dockingArea)
C#
void SetDockingArea(
   DockingArea dockingArea
)

Parameters

dockingArea

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


SetDockingRow Method

[image]
Intersoft WebDesktop Documentation
SetDockingRow Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : SetDockingRow Method

dockingRow

Glossary Item Box

Syntax

Visual Basic (Declaration)
Sub SetDockingRow( _
   ByVal dockingRow As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim dockingRow As Integer

instance.SetDockingRow(dockingRow)
C#
void SetDockingRow(
   int dockingRow
)

Parameters

dockingRow

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


SetPlaceHolder Method

[image]
Intersoft WebDesktop Documentation
SetPlaceHolder Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : SetPlaceHolder Method

plHolder

Glossary Item Box

Syntax

Visual Basic (Declaration)
Sub SetPlaceHolder( _
   ByVal plHolder As String _
)
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim plHolder As String

instance.SetPlaceHolder(plHolder)
C#
void SetPlaceHolder(
   string plHolder
)

Parameters

plHolder

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


SynchronizeBarProperties Method

[image]
Intersoft WebDesktop Documentation
SynchronizeBarProperties Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : SynchronizeBarProperties Method

bar

Glossary Item Box

Syntax

Visual Basic (Declaration)
Sub SynchronizeBarProperties( _
   ByVal bar As IBar _
)
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim bar As IBar

instance.SynchronizeBarProperties(bar)
C#
void SynchronizeBarProperties(
   IBar bar
)

Parameters

bar

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


IBar Interface Properties

[image]
Intersoft WebDesktop Documentation
IBar Interface Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : IBar Interface

Glossary Item Box

For a list of all members of this type, see IBar members.

Public Properties

 | Name | Description
Property | AddRemoveOptionMenuViewMode | Gets or sets the add remove option menu view mode.
Property | AllowCustomize | Gets or sets a value that indicates whether bar controls in PlaceHolderManager is customizeable.
Property | AllowDockBottom | Gets or sets a value that indicates whether a bar control can be docked to bottom area of PlaceHolderManager.
Property | AllowDockLeft | Gets or sets a value that indicates whether a bar control can be docked to left area of PlaceHolderManager.
Property | AllowDockRight | Gets or sets a value that indicates whether a bar control can be docked to right area of PlaceHolderManager.
Property | AllowDockTop | Gets or sets a value that indicates whether a bar control can be docked to top area of PlaceHolderManager.
Property | AllowExpandCollapse | Gets or sets a value that indicates whether Bar controls in PlaceHolderManager is expandable and collapseable.
Property | AllowFloat | Gets or sets a value that indicates whether Bar controls in PlaceHolderManager is floatable.
Property | AllowMove | Gets or sets a value that indicates whether Bar controls in PlaceHolderManager is moveable.
Property | BarStyle | Gets or sets the Bar style.
Property | BodyStyle | Gets or sets the body style.
Property | Caption | Specifies the Bar caption
Property | CommandClientSideEvents | Specifies the client side (JavaScript) tool command events.
Property | CommandDisabledStyle | Gets or sets the style properties of disabled command style.
Property | CommandFontStyle | Gets or sets the font style of the tool command.
Property | CommandStyle | Gets or sets the style properties of command in the bar control.
Property | DefaultFillDockingRow | Gets or sets the default fill of DockingRow.
Property | DesignHeight |
Property | DesignWidth |
Property | DockingArea | Gets or sets the bar docking area.
Property | DockingOffset | Specifies the bar docking offset.
Property | DockingRow | Specifies the bar docking row.
Property | FillDockingRow | Gets or sets a value that indicates whether a bar control dimension in PlaceHolderManager fills the row region of PlaceHolderManager docking row.
Property | GreyImageWhenDisabled | Gets or sets a value that indicates whether a grey image is applied when command is disabled.
Property | HandleStyle | Gets or sets the style properties of handle bar section in the bar control.
Property | HandleVisible | Gets or sets a value that indicates whether a Bar handle section in PlaceHolderManager is visible.
Property | HeaderButtonStyle | Gets or sets the style properties of the header bar close button in the bar control.
Property | HeaderCaptionStyle | Gets or sets the style properties of the header bar caption in the bar control.
Property | HeaderHeight | Gets or sets the height of the bar control header.
Property | Height |
Property | ID |
Property | IntegratedTo | Gets or sets the bar menu integrated mode.
Property | IsFloat | Gets or sets a value that indicates whether a bar control is floated on the page.
Property | IsRemoveInDesign |
Property | IsRuntimeBar |
Property | IsSynchronize |
Property | MaxDockingRows | Gets or sets maximum docking rows for docking area.
Property | NewDockingArea |
Property | NewDockingRow |
Property | OptionStyle | Gets or sets the style properties of option bar section in the bar control.
Property | PHMDesigner |
Property | PlaceHolder | Specifies the bar placeholder manager.
Property | RaiseBarLayoutPropertiesChangedEvent |
Property | RaiseBarPropertiesChangedEvent |
Property | SeparatorStyle | Gets or sets the style properties of separator command in the bar control.
Property | SizeMode | Gets or sets the tool command sizing mode.
Property | ToggleGroups | Gets the collection of toggle group commands in WebToolbar.
Property | Width |
Top

See Also

Reference

IBar Interface
ISNet.WebUI.WebDesktop Namespace


GetOrientation Method

[image]
Intersoft WebDesktop Documentation
GetOrientation Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : GetOrientation Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function GetOrientation() As OrientationMode
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim value As OrientationMode

value = instance.GetOrientation()
C#
OrientationMode GetOrientation()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


ResetUsageData Method

[image]
Intersoft WebDesktop Documentation
ResetUsageData Method
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : ResetUsageData Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Sub ResetUsageData()
Visual Basic (Usage) Copy Code
Dim instance As IBar

instance.ResetUsageData()
C#
void ResetUsageData()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


AddRemoveOptionMenuViewMode Property

[image]
Intersoft WebDesktop Documentation
AddRemoveOptionMenuViewMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : AddRemoveOptionMenuViewMode Property

Glossary Item Box

Gets or sets the add remove option menu view mode.

Syntax

Visual Basic (Declaration)
Property AddRemoveOptionMenuViewMode As AddRemoveOptionMenuViewMode
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim value As AddRemoveOptionMenuViewMode

instance.AddRemoveOptionMenuViewMode = value

value = instance.AddRemoveOptionMenuViewMode
C#
AddRemoveOptionMenuViewMode AddRemoveOptionMenuViewMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


AllowCustomize Property

[image]
Intersoft WebDesktop Documentation
AllowCustomize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : AllowCustomize Property

Glossary Item Box

Gets or sets a value that indicates whether bar controls in PlaceHolderManager is customizeable.

Syntax

Visual Basic (Declaration)
Property AllowCustomize As AllowCustomize
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim value As AllowCustomize

instance.AllowCustomize = value

value = instance.AllowCustomize
C#
AllowCustomize AllowCustomize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


AllowDockBottom Property

[image]
Intersoft WebDesktop Documentation
AllowDockBottom Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : AllowDockBottom Property

Glossary Item Box

Gets or sets a value that indicates whether a bar control can be docked to bottom area of PlaceHolderManager.

Syntax

Visual Basic (Declaration)
Property AllowDockBottom As AllowDock
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim value As AllowDock

instance.AllowDockBottom = value

value = instance.AllowDockBottom
C#
AllowDock AllowDockBottom {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


AllowDockLeft Property

[image]
Intersoft WebDesktop Documentation
AllowDockLeft Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : AllowDockLeft Property

Glossary Item Box

Gets or sets a value that indicates whether a bar control can be docked to left area of PlaceHolderManager.

Syntax

Visual Basic (Declaration)
Property AllowDockLeft As AllowDock
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim value As AllowDock

instance.AllowDockLeft = value

value = instance.AllowDockLeft
C#
AllowDock AllowDockLeft {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


AllowDockRight Property

[image]
Intersoft WebDesktop Documentation
AllowDockRight Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : AllowDockRight Property

Glossary Item Box

Gets or sets a value that indicates whether a bar control can be docked to right area of PlaceHolderManager.

Syntax

Visual Basic (Declaration)
Property AllowDockRight As AllowDock
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim value As AllowDock

instance.AllowDockRight = value

value = instance.AllowDockRight
C#
AllowDock AllowDockRight {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


AllowDockTop Property

[image]
Intersoft WebDesktop Documentation
AllowDockTop Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : AllowDockTop Property

Glossary Item Box

Gets or sets a value that indicates whether a bar control can be docked to top area of PlaceHolderManager.

Syntax

Visual Basic (Declaration)
Property AllowDockTop As AllowDock
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim value As AllowDock

instance.AllowDockTop = value

value = instance.AllowDockTop
C#
AllowDock AllowDockTop {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


AllowExpandCollapse Property

[image]
Intersoft WebDesktop Documentation
AllowExpandCollapse Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : AllowExpandCollapse Property

Glossary Item Box

Gets or sets a value that indicates whether Bar controls in PlaceHolderManager is expandable and collapseable.

Syntax

Visual Basic (Declaration)
Property AllowExpandCollapse As AllowExpandCollapse
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim value As AllowExpandCollapse

instance.AllowExpandCollapse = value

value = instance.AllowExpandCollapse
C#
AllowExpandCollapse AllowExpandCollapse {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


AllowFloat Property

[image]
Intersoft WebDesktop Documentation
AllowFloat Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : AllowFloat Property

Glossary Item Box

Gets or sets a value that indicates whether Bar controls in PlaceHolderManager is floatable.

Syntax

Visual Basic (Declaration)
Property AllowFloat As AllowFloat
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim value As AllowFloat

instance.AllowFloat = value

value = instance.AllowFloat
C#
AllowFloat AllowFloat {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


AllowMove Property

[image]
Intersoft WebDesktop Documentation
AllowMove Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : AllowMove Property

Glossary Item Box

Gets or sets a value that indicates whether Bar controls in PlaceHolderManager is moveable.

Syntax

Visual Basic (Declaration)
Property AllowMove As AllowMove
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim value As AllowMove

instance.AllowMove = value

value = instance.AllowMove
C#
AllowMove AllowMove {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


BarStyle Property

[image]
Intersoft WebDesktop Documentation
BarStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : BarStyle Property

Glossary Item Box

Gets or sets the Bar style.

Syntax

Visual Basic (Declaration)
Property BarStyle As BarStyle
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim value As BarStyle

instance.BarStyle = value

value = instance.BarStyle
C#
BarStyle BarStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


BodyStyle Property

[image]
Intersoft WebDesktop Documentation
BodyStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : BodyStyle Property

Glossary Item Box

Gets or sets the body style.

Syntax

Visual Basic (Declaration)
Property BodyStyle As BarSectionStyle
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim value As BarSectionStyle

instance.BodyStyle = value

value = instance.BodyStyle
C#
BarSectionStyle BodyStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


Caption Property

[image]
Intersoft WebDesktop Documentation
Caption Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : Caption Property

Glossary Item Box

Specifies the Bar caption

Syntax

Visual Basic (Declaration)
Property Caption As String
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim value As String

instance.Caption = value

value = instance.Caption
C#
string Caption {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


CommandClientSideEvents Property

[image]
Intersoft WebDesktop Documentation
CommandClientSideEvents Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : CommandClientSideEvents Property

Glossary Item Box

Specifies the client side (JavaScript) tool command events.

Syntax

Visual Basic (Declaration)
Property CommandClientSideEvents As ISNet.WebUI.BaseMouseElementClientSideEvents
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim value As ISNet.WebUI.BaseMouseElementClientSideEvents

instance.CommandClientSideEvents = value

value = instance.CommandClientSideEvents
C#
ISNet.WebUI.BaseMouseElementClientSideEvents CommandClientSideEvents {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


CommandDisabledStyle Property

[image]
Intersoft WebDesktop Documentation
CommandDisabledStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : CommandDisabledStyle Property

Glossary Item Box

Gets or sets the style properties of disabled command style.

Syntax

Visual Basic (Declaration)
Property CommandDisabledStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim value As ISNet.WebUI.WebStyle

instance.CommandDisabledStyle = value

value = instance.CommandDisabledStyle
C#
ISNet.WebUI.WebStyle CommandDisabledStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


CommandFontStyle Property

[image]
Intersoft WebDesktop Documentation
CommandFontStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : CommandFontStyle Property

Glossary Item Box

Gets or sets the font style of the tool command.

Syntax

Visual Basic (Declaration)
ReadOnly Property CommandFontStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim value As ISNet.WebUI.DynamicStyle

value = instance.CommandFontStyle
C#
ISNet.WebUI.DynamicStyle CommandFontStyle {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


CommandStyle Property

[image]
Intersoft WebDesktop Documentation
CommandStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : CommandStyle Property

Glossary Item Box

Gets or sets the style properties of command in the bar control.

Syntax

Visual Basic (Declaration)
Property CommandStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim value As ISNet.WebUI.DynamicStyle

instance.CommandStyle = value

value = instance.CommandStyle
C#
ISNet.WebUI.DynamicStyle CommandStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


DefaultFillDockingRow Property

[image]
Intersoft WebDesktop Documentation
DefaultFillDockingRow Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : DefaultFillDockingRow Property

Glossary Item Box

Gets or sets the default fill of DockingRow.

Syntax

Visual Basic (Declaration)
ReadOnly Property DefaultFillDockingRow As FillDockingRow
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim value As FillDockingRow

value = instance.DefaultFillDockingRow
C#
FillDockingRow DefaultFillDockingRow {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


DesignHeight Property

[image]
Intersoft WebDesktop Documentation
DesignHeight Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : DesignHeight Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property DesignHeight As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim value As System.Web.UI.WebControls.Unit

instance.DesignHeight = value

value = instance.DesignHeight
C#
System.Web.UI.WebControls.Unit DesignHeight {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


DesignWidth Property

[image]
Intersoft WebDesktop Documentation
DesignWidth Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : DesignWidth Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property DesignWidth As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim value As System.Web.UI.WebControls.Unit

instance.DesignWidth = value

value = instance.DesignWidth
C#
System.Web.UI.WebControls.Unit DesignWidth {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


DockingArea Property

[image]
Intersoft WebDesktop Documentation
DockingArea Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : DockingArea Property

Glossary Item Box

Gets or sets the bar docking area.

Syntax

Visual Basic (Declaration)
Property DockingArea As DockingArea
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim value As DockingArea

instance.DockingArea = value

value = instance.DockingArea
C#
DockingArea DockingArea {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


DockingOffset Property

[image]
Intersoft WebDesktop Documentation
DockingOffset Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : DockingOffset Property

Glossary Item Box

Specifies the bar docking offset.

Syntax

Visual Basic (Declaration)
Property DockingOffset As Integer
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim value As Integer

instance.DockingOffset = value

value = instance.DockingOffset
C#
int DockingOffset {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


DockingRow Property

[image]
Intersoft WebDesktop Documentation
DockingRow Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : DockingRow Property

Glossary Item Box

Specifies the bar docking row.

Syntax

Visual Basic (Declaration)
Property DockingRow As Integer
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim value As Integer

instance.DockingRow = value

value = instance.DockingRow
C#
int DockingRow {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


FillDockingRow Property

[image]
Intersoft WebDesktop Documentation
FillDockingRow Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : FillDockingRow Property

Glossary Item Box

Gets or sets a value that indicates whether a bar control dimension in PlaceHolderManager fills the row region of PlaceHolderManager docking row.

Syntax

Visual Basic (Declaration)
Property FillDockingRow As FillDockingRow
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim value As FillDockingRow

instance.FillDockingRow = value

value = instance.FillDockingRow
C#
FillDockingRow FillDockingRow {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


GreyImageWhenDisabled Property

[image]
Intersoft WebDesktop Documentation
GreyImageWhenDisabled Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : GreyImageWhenDisabled Property

Glossary Item Box

Gets or sets a value that indicates whether a grey image is applied when command is disabled.

Syntax

Visual Basic (Declaration)
Property GreyImageWhenDisabled As GreyImageWhenDisabled
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim value As GreyImageWhenDisabled

instance.GreyImageWhenDisabled = value

value = instance.GreyImageWhenDisabled
C#
GreyImageWhenDisabled GreyImageWhenDisabled {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


HandleStyle Property

[image]
Intersoft WebDesktop Documentation
HandleStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : HandleStyle Property

Glossary Item Box

Gets or sets the style properties of handle bar section in the bar control.

Syntax

Visual Basic (Declaration)
Property HandleStyle As BarSectionStyle
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim value As BarSectionStyle

instance.HandleStyle = value

value = instance.HandleStyle
C#
BarSectionStyle HandleStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


HandleVisible Property

[image]
Intersoft WebDesktop Documentation
HandleVisible Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : HandleVisible Property

Glossary Item Box

Gets or sets a value that indicates whether a Bar handle section in PlaceHolderManager is visible.

Syntax

Visual Basic (Declaration)
Property HandleVisible As HandleVisible
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim value As HandleVisible

instance.HandleVisible = value

value = instance.HandleVisible
C#
HandleVisible HandleVisible {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


HeaderButtonStyle Property

[image]
Intersoft WebDesktop Documentation
HeaderButtonStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : HeaderButtonStyle Property

Glossary Item Box

Gets or sets the style properties of the header bar close button in the bar control.

Syntax

Visual Basic (Declaration)
Property HeaderButtonStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim value As ISNet.WebUI.DynamicStyle

instance.HeaderButtonStyle = value

value = instance.HeaderButtonStyle
C#
ISNet.WebUI.DynamicStyle HeaderButtonStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


HeaderCaptionStyle Property

[image]
Intersoft WebDesktop Documentation
HeaderCaptionStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : HeaderCaptionStyle Property

Glossary Item Box

Gets or sets the style properties of the header bar caption in the bar control.

Syntax

Visual Basic (Declaration)
Property HeaderCaptionStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim value As ISNet.WebUI.WebStyle

instance.HeaderCaptionStyle = value

value = instance.HeaderCaptionStyle
C#
ISNet.WebUI.WebStyle HeaderCaptionStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


HeaderHeight Property

[image]
Intersoft WebDesktop Documentation
HeaderHeight Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : HeaderHeight Property

Glossary Item Box

Gets or sets the height of the bar control header.

Syntax

Visual Basic (Declaration)
Property HeaderHeight As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim value As System.Web.UI.WebControls.Unit

instance.HeaderHeight = value

value = instance.HeaderHeight
C#
System.Web.UI.WebControls.Unit HeaderHeight {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


Height Property

[image]
Intersoft WebDesktop Documentation
Height Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : Height Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Height As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim value As System.Web.UI.WebControls.Unit

instance.Height = value

value = instance.Height
C#
System.Web.UI.WebControls.Unit Height {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


ID Property

[image]
Intersoft WebDesktop Documentation
ID Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : ID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property ID As String
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim value As String

instance.ID = value

value = instance.ID
C#
string ID {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


IntegratedTo Property

[image]
Intersoft WebDesktop Documentation
IntegratedTo Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : IntegratedTo Property

Glossary Item Box

Gets or sets the bar menu integrated mode.

Syntax

Visual Basic (Declaration)
Property IntegratedTo As MenuIntegrationMode
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim value As MenuIntegrationMode

instance.IntegratedTo = value

value = instance.IntegratedTo
C#
MenuIntegrationMode IntegratedTo {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


IsFloat Property

[image]
Intersoft WebDesktop Documentation
IsFloat Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : IsFloat Property

Glossary Item Box

Gets or sets a value that indicates whether a bar control is floated on the page.

Syntax

Visual Basic (Declaration)
Property IsFloat As IsFloat
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim value As IsFloat

instance.IsFloat = value

value = instance.IsFloat
C#
IsFloat IsFloat {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


IsRemoveInDesign Property

[image]
Intersoft WebDesktop Documentation
IsRemoveInDesign Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : IsRemoveInDesign Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property IsRemoveInDesign As Boolean
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim value As Boolean

instance.IsRemoveInDesign = value

value = instance.IsRemoveInDesign
C#
bool IsRemoveInDesign {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


IsRuntimeBar Property

[image]
Intersoft WebDesktop Documentation
IsRuntimeBar Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : IsRuntimeBar Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property IsRuntimeBar As Boolean
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim value As Boolean

instance.IsRuntimeBar = value

value = instance.IsRuntimeBar
C#
bool IsRuntimeBar {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


IsSynchronize Property

[image]
Intersoft WebDesktop Documentation
IsSynchronize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : IsSynchronize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property IsSynchronize As Boolean
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim value As Boolean

instance.IsSynchronize = value

value = instance.IsSynchronize
C#
bool IsSynchronize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


MaxDockingRows Property

[image]
Intersoft WebDesktop Documentation
MaxDockingRows Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : MaxDockingRows Property

Glossary Item Box

Gets or sets maximum docking rows for docking area.

Syntax

Visual Basic (Declaration)
Property MaxDockingRows As Integer
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim value As Integer

instance.MaxDockingRows = value

value = instance.MaxDockingRows
C#
int MaxDockingRows {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


NewDockingArea Property

[image]
Intersoft WebDesktop Documentation
NewDockingArea Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : NewDockingArea Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property NewDockingArea As DockingArea
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim value As DockingArea

instance.NewDockingArea = value

value = instance.NewDockingArea
C#
DockingArea NewDockingArea {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


NewDockingRow Property

[image]
Intersoft WebDesktop Documentation
NewDockingRow Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : NewDockingRow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property NewDockingRow As Integer
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim value As Integer

instance.NewDockingRow = value

value = instance.NewDockingRow
C#
int NewDockingRow {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


OptionStyle Property

[image]
Intersoft WebDesktop Documentation
OptionStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : OptionStyle Property

Glossary Item Box

Gets or sets the style properties of option bar section in the bar control.

Syntax

Visual Basic (Declaration)
Property OptionStyle As BarSectionStyle
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim value As BarSectionStyle

instance.OptionStyle = value

value = instance.OptionStyle
C#
BarSectionStyle OptionStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


PHMDesigner Property

[image]
Intersoft WebDesktop Documentation
PHMDesigner Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : PHMDesigner Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property PHMDesigner As PlaceHolderManagerDesigner
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim value As PlaceHolderManagerDesigner

value = instance.PHMDesigner
C#
PlaceHolderManagerDesigner PHMDesigner {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


PlaceHolder Property

[image]
Intersoft WebDesktop Documentation
PlaceHolder Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : PlaceHolder Property

Glossary Item Box

Specifies the bar placeholder manager.

Syntax

Visual Basic (Declaration)
Property PlaceHolder As String
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim value As String

instance.PlaceHolder = value

value = instance.PlaceHolder
C#
string PlaceHolder {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


RaiseBarLayoutPropertiesChangedEvent Property

[image]
Intersoft WebDesktop Documentation
RaiseBarLayoutPropertiesChangedEvent Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : RaiseBarLayoutPropertiesChangedEvent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property RaiseBarLayoutPropertiesChangedEvent As Boolean
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim value As Boolean

instance.RaiseBarLayoutPropertiesChangedEvent = value

value = instance.RaiseBarLayoutPropertiesChangedEvent
C#
bool RaiseBarLayoutPropertiesChangedEvent {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


RaiseBarPropertiesChangedEvent Property

[image]
Intersoft WebDesktop Documentation
RaiseBarPropertiesChangedEvent Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : RaiseBarPropertiesChangedEvent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property RaiseBarPropertiesChangedEvent As Boolean
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim value As Boolean

instance.RaiseBarPropertiesChangedEvent = value

value = instance.RaiseBarPropertiesChangedEvent
C#
bool RaiseBarPropertiesChangedEvent {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


SeparatorStyle Property

[image]
Intersoft WebDesktop Documentation
SeparatorStyle Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : SeparatorStyle Property

Glossary Item Box

Gets or sets the style properties of separator command in the bar control.

Syntax

Visual Basic (Declaration)
Property SeparatorStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim value As ISNet.WebUI.WebStyle

instance.SeparatorStyle = value

value = instance.SeparatorStyle
C#
ISNet.WebUI.WebStyle SeparatorStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


SizeMode Property

[image]
Intersoft WebDesktop Documentation
SizeMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : SizeMode Property

Glossary Item Box

Gets or sets the tool command sizing mode.

Syntax

Visual Basic (Declaration)
Property SizeMode As SizeMode
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim value As SizeMode

instance.SizeMode = value

value = instance.SizeMode
C#
SizeMode SizeMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


ToggleGroups Property

[image]
Intersoft WebDesktop Documentation
ToggleGroups Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : ToggleGroups Property

Glossary Item Box

Gets the collection of toggle group commands in WebToolbar.

Syntax

Visual Basic (Declaration)
ReadOnly Property ToggleGroups As ToggleGroupCollection
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim value As ToggleGroupCollection

value = instance.ToggleGroups
C#
ToggleGroupCollection ToggleGroups {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


Width Property

[image]
Intersoft WebDesktop Documentation
Width Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : Width Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Width As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim value As System.Web.UI.WebControls.Unit

instance.Width = value

value = instance.Width
C#
System.Web.UI.WebControls.Unit Width {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


BarLayoutPropertiesChanged Event

[image]
Intersoft WebDesktop Documentation
BarLayoutPropertiesChanged Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : BarLayoutPropertiesChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Event BarLayoutPropertiesChanged As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim handler As EventHandler

AddHandler instance.BarLayoutPropertiesChanged, handler
C#
event EventHandler BarLayoutPropertiesChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


BarPropertiesChanged Event

[image]
Intersoft WebDesktop Documentation
BarPropertiesChanged Event
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IBar Interface : BarPropertiesChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Event BarPropertiesChanged As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As IBar
Dim handler As EventHandler

AddHandler instance.BarPropertiesChanged, handler
C#
event EventHandler BarPropertiesChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBar Interface
IBar Members


IBar Interface Events

[image]
Intersoft WebDesktop Documentation
IBar Interface Events
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : IBar Interface

Glossary Item Box

For a list of all members of this type, see IBar members.

Public Events

 | Name | Description
Event | BarLayoutPropertiesChanged |
Event | BarPropertiesChanged |
Top

See Also

Reference

IBar Interface
ISNet.WebUI.WebDesktop Namespace


ICommand Interface

[image]
Intersoft WebDesktop Documentation
ICommand Interface
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : ICommand Interface

Glossary Item Box

ICommand interface. This Interface is used to support intersoft products development only, not to be used by developers.

Syntax

Visual Basic (Declaration)
Public Interface ICommand
Visual Basic (Usage) Copy Code
Dim instance As ICommand
C#
public interface ICommand

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICommand Members
ISNet.WebUI.WebDesktop Namespace


ICommand Interface Members

[image]
Intersoft WebDesktop Documentation
ICommand Interface Members
See Also Properties Send Feedback
ISNet.WebUI.WebDesktop Namespace : ICommand Interface

Glossary Item Box

The following tables list the members exposed by ICommand.

Public Properties

 | Name | Description
Property | AccessKey | Sets or retrieves the keyboard shortcut key for setting focus to the Command.
Property | AutoPostBack | Gets or sets a value that indicates whether a Command is autopostback.
Property | CommandSize | Specifies the Command size.
Property | ContainerObj |
Property | DisplayAccessKeyOnToolTip | Gets or sets a value that indicates whether access key is displayed on command tooltip.
Property | DisplayMode | Specifies the Command display mode.
Property | DisplayToolTip | Gets or sets a value that indicates whether command tooltip is displayed.
Property | ImageSize | Specifies the Command image size.
Property | MergeCommandID | Specifies the Merge Command ID.
Property | TextAlign | Specifies the Command text align type.
Property | ToolTip | Specifies command tooltip.
Top

See Also

Reference

ICommand Interface
ISNet.WebUI.WebDesktop Namespace


ICommand Interface Properties

[image]
Intersoft WebDesktop Documentation
ICommand Interface Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : ICommand Interface

Glossary Item Box

For a list of all members of this type, see ICommand members.

Public Properties

 | Name | Description
Property | AccessKey | Sets or retrieves the keyboard shortcut key for setting focus to the Command.
Property | AutoPostBack | Gets or sets a value that indicates whether a Command is autopostback.
Property | CommandSize | Specifies the Command size.
Property | ContainerObj |
Property | DisplayAccessKeyOnToolTip | Gets or sets a value that indicates whether access key is displayed on command tooltip.
Property | DisplayMode | Specifies the Command display mode.
Property | DisplayToolTip | Gets or sets a value that indicates whether command tooltip is displayed.
Property | ImageSize | Specifies the Command image size.
Property | MergeCommandID | Specifies the Merge Command ID.
Property | TextAlign | Specifies the Command text align type.
Property | ToolTip | Specifies command tooltip.
Top

See Also

Reference

ICommand Interface
ISNet.WebUI.WebDesktop Namespace


AccessKey Property

[image]
Intersoft WebDesktop Documentation
AccessKey Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ICommand Interface : AccessKey Property

Glossary Item Box

Sets or retrieves the keyboard shortcut key for setting focus to the Command.

Syntax

Visual Basic (Declaration)
Property AccessKey As String
Visual Basic (Usage) Copy Code
Dim instance As ICommand
Dim value As String

instance.AccessKey = value

value = instance.AccessKey
C#
string AccessKey {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICommand Interface
ICommand Members


AutoPostBack Property

[image]
Intersoft WebDesktop Documentation
AutoPostBack Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ICommand Interface : AutoPostBack Property

Glossary Item Box

Gets or sets a value that indicates whether a Command is autopostback.

Syntax

Visual Basic (Declaration)
Property AutoPostBack As AutoPostBackMode
Visual Basic (Usage) Copy Code
Dim instance As ICommand
Dim value As AutoPostBackMode

instance.AutoPostBack = value

value = instance.AutoPostBack
C#
AutoPostBackMode AutoPostBack {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICommand Interface
ICommand Members


CommandSize Property

[image]
Intersoft WebDesktop Documentation
CommandSize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ICommand Interface : CommandSize Property

Glossary Item Box

Specifies the Command size.

Syntax

Visual Basic (Declaration)
Property CommandSize As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As ICommand
Dim value As System.Web.UI.WebControls.Unit

instance.CommandSize = value

value = instance.CommandSize
C#
System.Web.UI.WebControls.Unit CommandSize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICommand Interface
ICommand Members


ContainerObj Property

[image]
Intersoft WebDesktop Documentation
ContainerObj Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ICommand Interface : ContainerObj Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property ContainerObj As Object
Visual Basic (Usage) Copy Code
Dim instance As ICommand
Dim value As Object

instance.ContainerObj = value

value = instance.ContainerObj
C#
object ContainerObj {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICommand Interface
ICommand Members


DisplayAccessKeyOnToolTip Property

[image]
Intersoft WebDesktop Documentation
DisplayAccessKeyOnToolTip Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ICommand Interface : DisplayAccessKeyOnToolTip Property

Glossary Item Box

Gets or sets a value that indicates whether access key is displayed on command tooltip.

Syntax

Visual Basic (Declaration)
Property DisplayAccessKeyOnToolTip As DisplayAccessKeyOnToolTip
Visual Basic (Usage) Copy Code
Dim instance As ICommand
Dim value As DisplayAccessKeyOnToolTip

instance.DisplayAccessKeyOnToolTip = value

value = instance.DisplayAccessKeyOnToolTip
C#
DisplayAccessKeyOnToolTip DisplayAccessKeyOnToolTip {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICommand Interface
ICommand Members


DisplayMode Property

[image]
Intersoft WebDesktop Documentation
DisplayMode Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ICommand Interface : DisplayMode Property

Glossary Item Box

Specifies the Command display mode.

Syntax

Visual Basic (Declaration)
Property DisplayMode As CommandDisplayMode
Visual Basic (Usage) Copy Code
Dim instance As ICommand
Dim value As CommandDisplayMode

instance.DisplayMode = value

value = instance.DisplayMode
C#
CommandDisplayMode DisplayMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICommand Interface
ICommand Members


DisplayToolTip Property

[image]
Intersoft WebDesktop Documentation
DisplayToolTip Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ICommand Interface : DisplayToolTip Property

Glossary Item Box

Gets or sets a value that indicates whether command tooltip is displayed.

Syntax

Visual Basic (Declaration)
Property DisplayToolTip As DisplayToolTip
Visual Basic (Usage) Copy Code
Dim instance As ICommand
Dim value As DisplayToolTip

instance.DisplayToolTip = value

value = instance.DisplayToolTip
C#
DisplayToolTip DisplayToolTip {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICommand Interface
ICommand Members


ImageSize Property

[image]
Intersoft WebDesktop Documentation
ImageSize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ICommand Interface : ImageSize Property

Glossary Item Box

Specifies the Command image size.

Syntax

Visual Basic (Declaration)
Property ImageSize As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As ICommand
Dim value As System.Drawing.Size

instance.ImageSize = value

value = instance.ImageSize
C#
System.Drawing.Size ImageSize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICommand Interface
ICommand Members


MergeCommandID Property

[image]
Intersoft WebDesktop Documentation
MergeCommandID Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ICommand Interface : MergeCommandID Property

Glossary Item Box

Specifies the Merge Command ID.

Syntax

Visual Basic (Declaration)
Property MergeCommandID As String
Visual Basic (Usage) Copy Code
Dim instance As ICommand
Dim value As String

instance.MergeCommandID = value

value = instance.MergeCommandID
C#
string MergeCommandID {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICommand Interface
ICommand Members


TextAlign Property

[image]
Intersoft WebDesktop Documentation
TextAlign Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ICommand Interface : TextAlign Property

Glossary Item Box

Specifies the Command text align type.

Syntax

Visual Basic (Declaration)
Property TextAlign As BarTextAlign
Visual Basic (Usage) Copy Code
Dim instance As ICommand
Dim value As BarTextAlign

instance.TextAlign = value

value = instance.TextAlign
C#
BarTextAlign TextAlign {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICommand Interface
ICommand Members


ToolTip Property

[image]
Intersoft WebDesktop Documentation
ToolTip Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > ICommand Interface : ToolTip Property

Glossary Item Box

Specifies command tooltip.

Syntax

Visual Basic (Declaration)
Property ToolTip As String
Visual Basic (Usage) Copy Code
Dim instance As ICommand
Dim value As String

instance.ToolTip = value

value = instance.ToolTip
C#
string ToolTip {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICommand Interface
ICommand Members


IDock Interface

[image]
Intersoft WebDesktop Documentation
IDock Interface
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : IDock Interface

Glossary Item Box

IDock interface. This Interface is used to support intersoft products development only, not to be used by developers.

Syntax

Visual Basic (Declaration)
Public Interface IDock
Visual Basic (Usage) Copy Code
Dim instance As IDock
C#
public interface IDock

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDock Members
ISNet.WebUI.WebDesktop Namespace


IDock Interface Members

[image]
Intersoft WebDesktop Documentation
IDock Interface Members
See Also Properties Send Feedback
ISNet.WebUI.WebDesktop Namespace : IDock Interface

Glossary Item Box

The following tables list the members exposed by IDock.

Public Properties

 | Name | Description
Property | AllowDockBottom | Gets or sets a value that indicates whether a bar control can be docked to bottom area of PlaceHolderManager.
Property | AllowDockLeft | Gets or sets a value that indicates whether a bar control can be docked to left area of PlaceHolderManager.
Property | AllowDockRight | Gets or sets a value that indicates whether a bar control can be docked to right area of PlaceHolderManager.
Property | AllowDockTop | Gets or sets a value that indicates whether a bar control can be docked to top area of PlaceHolderManager.
Property | Dockable | Specifies whether the bar is dockable.
Property | DockingArea | Gets or sets the bar docking area.
Property | DockingOffset | Specifies the bar docking offset.
Property | DockingRow | Specifies the bar docking row.
Property | FillDockingRow | Gets or sets a value that indicates whether a bar control dimension fills the row region of PlaceHolderManager docking row.
Property | Floatable | Gets or sets a value that indicates whether a bar control is floatable.
Top

See Also

Reference

IDock Interface
ISNet.WebUI.WebDesktop Namespace


IDock Interface Properties

[image]
Intersoft WebDesktop Documentation
IDock Interface Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : IDock Interface

Glossary Item Box

For a list of all members of this type, see IDock members.

Public Properties

 | Name | Description
Property | AllowDockBottom | Gets or sets a value that indicates whether a bar control can be docked to bottom area of PlaceHolderManager.
Property | AllowDockLeft | Gets or sets a value that indicates whether a bar control can be docked to left area of PlaceHolderManager.
Property | AllowDockRight | Gets or sets a value that indicates whether a bar control can be docked to right area of PlaceHolderManager.
Property | AllowDockTop | Gets or sets a value that indicates whether a bar control can be docked to top area of PlaceHolderManager.
Property | Dockable | Specifies whether the bar is dockable.
Property | DockingArea | Gets or sets the bar docking area.
Property | DockingOffset | Specifies the bar docking offset.
Property | DockingRow | Specifies the bar docking row.
Property | FillDockingRow | Gets or sets a value that indicates whether a bar control dimension fills the row region of PlaceHolderManager docking row.
Property | Floatable | Gets or sets a value that indicates whether a bar control is floatable.
Top

See Also

Reference

IDock Interface
ISNet.WebUI.WebDesktop Namespace


AllowDockBottom Property

[image]
Intersoft WebDesktop Documentation
AllowDockBottom Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IDock Interface : AllowDockBottom Property

Glossary Item Box

Gets or sets a value that indicates whether a bar control can be docked to bottom area of PlaceHolderManager.

Syntax

Visual Basic (Declaration)
Property AllowDockBottom As Boolean
Visual Basic (Usage) Copy Code
Dim instance As IDock
Dim value As Boolean

instance.AllowDockBottom = value

value = instance.AllowDockBottom
C#
bool AllowDockBottom {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDock Interface
IDock Members


AllowDockLeft Property

[image]
Intersoft WebDesktop Documentation
AllowDockLeft Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IDock Interface : AllowDockLeft Property

Glossary Item Box

Gets or sets a value that indicates whether a bar control can be docked to left area of PlaceHolderManager.

Syntax

Visual Basic (Declaration)
Property AllowDockLeft As Boolean
Visual Basic (Usage) Copy Code
Dim instance As IDock
Dim value As Boolean

instance.AllowDockLeft = value

value = instance.AllowDockLeft
C#
bool AllowDockLeft {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDock Interface
IDock Members


AllowDockRight Property

[image]
Intersoft WebDesktop Documentation
AllowDockRight Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IDock Interface : AllowDockRight Property

Glossary Item Box

Gets or sets a value that indicates whether a bar control can be docked to right area of PlaceHolderManager.

Syntax

Visual Basic (Declaration)
Property AllowDockRight As Boolean
Visual Basic (Usage) Copy Code
Dim instance As IDock
Dim value As Boolean

instance.AllowDockRight = value

value = instance.AllowDockRight
C#
bool AllowDockRight {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDock Interface
IDock Members


AllowDockTop Property

[image]
Intersoft WebDesktop Documentation
AllowDockTop Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IDock Interface : AllowDockTop Property

Glossary Item Box

Gets or sets a value that indicates whether a bar control can be docked to top area of PlaceHolderManager.

Syntax

Visual Basic (Declaration)
Property AllowDockTop As Boolean
Visual Basic (Usage) Copy Code
Dim instance As IDock
Dim value As Boolean

instance.AllowDockTop = value

value = instance.AllowDockTop
C#
bool AllowDockTop {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDock Interface
IDock Members


Dockable Property

[image]
Intersoft WebDesktop Documentation
Dockable Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IDock Interface : Dockable Property

Glossary Item Box

Specifies whether the bar is dockable.

Syntax

Visual Basic (Declaration)
Property Dockable As Boolean
Visual Basic (Usage) Copy Code
Dim instance As IDock
Dim value As Boolean

instance.Dockable = value

value = instance.Dockable
C#
bool Dockable {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDock Interface
IDock Members


DockingArea Property

[image]
Intersoft WebDesktop Documentation
DockingArea Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IDock Interface : DockingArea Property

Glossary Item Box

Gets or sets the bar docking area.

Syntax

Visual Basic (Declaration)
Property DockingArea As DockingArea
Visual Basic (Usage) Copy Code
Dim instance As IDock
Dim value As DockingArea

instance.DockingArea = value

value = instance.DockingArea
C#
DockingArea DockingArea {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDock Interface
IDock Members


DockingOffset Property

[image]
Intersoft WebDesktop Documentation
DockingOffset Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IDock Interface : DockingOffset Property

Glossary Item Box

Specifies the bar docking offset.

Syntax

Visual Basic (Declaration)
Property DockingOffset As Integer
Visual Basic (Usage) Copy Code
Dim instance As IDock
Dim value As Integer

instance.DockingOffset = value

value = instance.DockingOffset
C#
int DockingOffset {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDock Interface
IDock Members


DockingRow Property

[image]
Intersoft WebDesktop Documentation
DockingRow Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IDock Interface : DockingRow Property

Glossary Item Box

Specifies the bar docking row.

Syntax

Visual Basic (Declaration)
Property DockingRow As Integer
Visual Basic (Usage) Copy Code
Dim instance As IDock
Dim value As Integer

instance.DockingRow = value

value = instance.DockingRow
C#
int DockingRow {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDock Interface
IDock Members


FillDockingRow Property

[image]
Intersoft WebDesktop Documentation
FillDockingRow Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IDock Interface : FillDockingRow Property

Glossary Item Box

Gets or sets a value that indicates whether a bar control dimension fills the row region of PlaceHolderManager docking row.

Syntax

Visual Basic (Declaration)
Property FillDockingRow As Boolean
Visual Basic (Usage) Copy Code
Dim instance As IDock
Dim value As Boolean

instance.FillDockingRow = value

value = instance.FillDockingRow
C#
bool FillDockingRow {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDock Interface
IDock Members


Floatable Property

[image]
Intersoft WebDesktop Documentation
Floatable Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IDock Interface : Floatable Property

Glossary Item Box

Gets or sets a value that indicates whether a bar control is floatable.

Syntax

Visual Basic (Declaration)
Property Floatable As Boolean
Visual Basic (Usage) Copy Code
Dim instance As IDock
Dim value As Boolean

instance.Floatable = value

value = instance.Floatable
C#
bool Floatable {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDock Interface
IDock Members


IWebMenu Interface

[image]
Intersoft WebDesktop Documentation
IWebMenu Interface
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : IWebMenu Interface

Glossary Item Box

IWebMenu interface. This interface is used to support Intersoft products development only, not to be used by developers.

Syntax

Visual Basic (Declaration)
Public Interface IWebMenu
Visual Basic (Usage) Copy Code
Dim instance As IWebMenu
C#
public interface IWebMenu

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IWebMenu Members
ISNet.WebUI.WebDesktop Namespace


IWebMenu Interface Members

[image]
Intersoft WebDesktop Documentation
IWebMenu Interface Members
See Also Properties Send Feedback
ISNet.WebUI.WebDesktop Namespace : IWebMenu Interface

Glossary Item Box

The following tables list the members exposed by IWebMenu.

Public Properties

 | Name | Description
Property | Items | Gets the collection containing WebMenuItem objects of this menu.
Top

See Also

Reference

IWebMenu Interface
ISNet.WebUI.WebDesktop Namespace


IWebMenu Interface Properties

[image]
Intersoft WebDesktop Documentation
IWebMenu Interface Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : IWebMenu Interface

Glossary Item Box

For a list of all members of this type, see IWebMenu members.

Public Properties

 | Name | Description
Property | Items | Gets the collection containing WebMenuItem objects of this menu.
Top

See Also

Reference

IWebMenu Interface
ISNet.WebUI.WebDesktop Namespace


Items Property

[image]
Intersoft WebDesktop Documentation
Items Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IWebMenu Interface : Items Property

Glossary Item Box

Gets the collection containing WebMenuItem objects of this menu.

Syntax

Visual Basic (Declaration)
ReadOnly Property Items As WebMenuItemCollection
Visual Basic (Usage) Copy Code
Dim instance As IWebMenu
Dim value As WebMenuItemCollection

value = instance.Items
C#
WebMenuItemCollection Items {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IWebMenu Interface
IWebMenu Members


IWebMenuControl Interface

[image]
Intersoft WebDesktop Documentation
IWebMenuControl Interface
Members See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : IWebMenuControl Interface

Glossary Item Box

IWebMenuControl interface. This Interface is used to support intersoft products development only, not to be used by developers.

Syntax

Visual Basic (Declaration)
Public Interface IWebMenuControl
Visual Basic (Usage) Copy Code
Dim instance As IWebMenuControl
C#
public interface IWebMenuControl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IWebMenuControl Members
ISNet.WebUI.WebDesktop Namespace


IWebMenuControl Interface Members

[image]
Intersoft WebDesktop Documentation
IWebMenuControl Interface Members
See Also Properties Send Feedback
ISNet.WebUI.WebDesktop Namespace : IWebMenuControl Interface

Glossary Item Box

The following tables list the members exposed by IWebMenuControl.

Public Properties

 | Name | Description
Property | ImageSize | Specifies the MenuCommand image size.
Property | IntegratedTo | Gets or sets the WebMenuBar menu integrated mode.
Property | MenuStyleSettings | Gets or sets the style properties of menu styles in the bar control.
Property | ShowDelay | Gets or sets the amount of submenu show delay in miliseconds.
Top

See Also

Reference

IWebMenuControl Interface
ISNet.WebUI.WebDesktop Namespace


IWebMenuControl Interface Properties

[image]
Intersoft WebDesktop Documentation
IWebMenuControl Interface Properties
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : IWebMenuControl Interface

Glossary Item Box

For a list of all members of this type, see IWebMenuControl members.

Public Properties

 | Name | Description
Property | ImageSize | Specifies the MenuCommand image size.
Property | IntegratedTo | Gets or sets the WebMenuBar menu integrated mode.
Property | MenuStyleSettings | Gets or sets the style properties of menu styles in the bar control.
Property | ShowDelay | Gets or sets the amount of submenu show delay in miliseconds.
Top

See Also

Reference

IWebMenuControl Interface
ISNet.WebUI.WebDesktop Namespace


ImageSize Property

[image]
Intersoft WebDesktop Documentation
ImageSize Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IWebMenuControl Interface : ImageSize Property

Glossary Item Box

Specifies the MenuCommand image size.

Syntax

Visual Basic (Declaration)
Property ImageSize As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As IWebMenuControl
Dim value As System.Drawing.Size

instance.ImageSize = value

value = instance.ImageSize
C#
System.Drawing.Size ImageSize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IWebMenuControl Interface
IWebMenuControl Members


IntegratedTo Property

[image]
Intersoft WebDesktop Documentation
IntegratedTo Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IWebMenuControl Interface : IntegratedTo Property

Glossary Item Box

Gets or sets the WebMenuBar menu integrated mode.

Syntax

Visual Basic (Declaration)
Property IntegratedTo As MenuIntegrationMode
Visual Basic (Usage) Copy Code
Dim instance As IWebMenuControl
Dim value As MenuIntegrationMode

instance.IntegratedTo = value

value = instance.IntegratedTo
C#
MenuIntegrationMode IntegratedTo {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IWebMenuControl Interface
IWebMenuControl Members


MenuStyleSettings Property

[image]
Intersoft WebDesktop Documentation
MenuStyleSettings Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IWebMenuControl Interface : MenuStyleSettings Property

Glossary Item Box

Gets or sets the style properties of menu styles in the bar control.

Syntax

Visual Basic (Declaration)
Property MenuStyleSettings As WebMenuStyles
Visual Basic (Usage) Copy Code
Dim instance As IWebMenuControl
Dim value As WebMenuStyles

instance.MenuStyleSettings = value

value = instance.MenuStyleSettings
C#
WebMenuStyles MenuStyleSettings {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IWebMenuControl Interface
IWebMenuControl Members


ShowDelay Property

[image]
Intersoft WebDesktop Documentation
ShowDelay Property
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace > IWebMenuControl Interface : ShowDelay Property

Glossary Item Box

Gets or sets the amount of submenu show delay in miliseconds.

Syntax

Visual Basic (Declaration)
Property ShowDelay As Integer
Visual Basic (Usage) Copy Code
Dim instance As IWebMenuControl
Dim value As Integer

instance.ShowDelay = value

value = instance.ShowDelay
C#
int ShowDelay {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IWebMenuControl Interface
IWebMenuControl Members


ActiveBarChangedDelegate Delegate

[image]
Intersoft WebDesktop Documentation
ActiveBarChangedDelegate Delegate
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : ActiveBarChangedDelegate Delegate

sender
e

Glossary Item Box

Delegate that handle ActiveBarChanged event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub ActiveBarChangedDelegate( _
   ByVal sender As Object, _
   ByVal e As ActiveBarChangedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New ActiveBarChangedDelegate(AddressOf HandlerMethod)
C#
public delegate void ActiveBarChangedDelegate(
   object sender,
   ActiveBarChangedEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActiveBarChangedDelegate Members
ISNet.WebUI.WebDesktop Namespace


ActiveBarItemChangedDelegate Delegate

[image]
Intersoft WebDesktop Documentation
ActiveBarItemChangedDelegate Delegate
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : ActiveBarItemChangedDelegate Delegate

sender
e

Glossary Item Box

Delegate that handle ActiveBarItemChanged event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub ActiveBarItemChangedDelegate( _
   ByVal sender As Object, _
   ByVal e As ActiveBarItemChangedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New ActiveBarItemChangedDelegate(AddressOf HandlerMethod)
C#
public delegate void ActiveBarItemChangedDelegate(
   object sender,
   ActiveBarItemChangedEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActiveBarItemChangedDelegate Members
ISNet.WebUI.WebDesktop Namespace


IBarEventHandler Delegate

[image]
Intersoft WebDesktop Documentation
IBarEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : IBarEventHandler Delegate

sender
e

Glossary Item Box

Delegate that handle IBar event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub IBarEventHandler( _
   ByVal sender As Object, _
   ByVal e As IBarEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New IBarEventHandler(AddressOf HandlerMethod)
C#
public delegate void IBarEventHandler(
   object sender,
   IBarEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarEventHandler Members
ISNet.WebUI.WebDesktop Namespace


MenuCommandClickEventHandler Delegate

[image]
Intersoft WebDesktop Documentation
MenuCommandClickEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : MenuCommandClickEventHandler Delegate

sender
e

Glossary Item Box

Delegate that handle CommandClick event in WebMenuBar.

Syntax

Visual Basic (Declaration)
Public Delegate Sub MenuCommandClickEventHandler( _
   ByVal sender As Object, _
   ByVal e As MenuCommandClickEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New MenuCommandClickEventHandler(AddressOf HandlerMethod)
C#
public delegate void MenuCommandClickEventHandler(
   object sender,
   MenuCommandClickEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuCommandClickEventHandler Members
ISNet.WebUI.WebDesktop Namespace


ToolCommandClickEventHandler Delegate

[image]
Intersoft WebDesktop Documentation
ToolCommandClickEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : ToolCommandClickEventHandler Delegate

sender
e

Glossary Item Box

Delegate that handle CommandClick event in WebToolBar.

Syntax

Visual Basic (Declaration)
Public Delegate Sub ToolCommandClickEventHandler( _
   ByVal sender As Object, _
   ByVal e As ToolCommandClickEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New ToolCommandClickEventHandler(AddressOf HandlerMethod)
C#
public delegate void ToolCommandClickEventHandler(
   object sender,
   ToolCommandClickEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolCommandClickEventHandler Members
ISNet.WebUI.WebDesktop Namespace


WebButtonClickedEventHandler Delegate

[image]
Intersoft WebDesktop Documentation
WebButtonClickedEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebButtonClickedEventHandler Delegate

sender
e

Glossary Item Box

Delegate that handle Clicked event in WebButton.

Syntax

Visual Basic (Declaration)
Public Delegate Sub WebButtonClickedEventHandler( _
   ByVal sender As Object, _
   ByVal e As WebButtonClickedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New WebButtonClickedEventHandler(AddressOf HandlerMethod)
C#
public delegate void WebButtonClickedEventHandler(
   object sender,
   WebButtonClickedEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebButtonClickedEventHandler Members
ISNet.WebUI.WebDesktop Namespace


WebCallOutOnShowEventHandler Delegate

[image]
Intersoft WebDesktop Documentation
WebCallOutOnShowEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebCallOutOnShowEventHandler Delegate

sender
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub WebCallOutOnShowEventHandler( _
   ByVal sender As Object, _
   ByVal e As WebCallOutEventDataArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New WebCallOutOnShowEventHandler(AddressOf HandlerMethod)
C#
public delegate void WebCallOutOnShowEventHandler(
   object sender,
   WebCallOutEventDataArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCallOutOnShowEventHandler Members
ISNet.WebUI.WebDesktop Namespace


WebMenuItemClickedEventHandler Delegate

[image]
Intersoft WebDesktop Documentation
WebMenuItemClickedEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebMenuItemClickedEventHandler Delegate

sender
e

Glossary Item Box

Delegate that handle Clicked event in WebMenuItem.

Syntax

Visual Basic (Declaration)
Public Delegate Sub WebMenuItemClickedEventHandler( _
   ByVal sender As Object, _
   ByVal e As WebMenuItemClickedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New WebMenuItemClickedEventHandler(AddressOf HandlerMethod)
C#
public delegate void WebMenuItemClickedEventHandler(
   object sender,
   WebMenuItemClickedEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebMenuItemClickedEventHandler Members
ISNet.WebUI.WebDesktop Namespace


WebSplitter.GripClickedDelegate Delegate

[image]
Intersoft WebDesktop Documentation
WebSplitter.GripClickedDelegate Delegate
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebSplitter.GripClickedDelegate Delegate

id
gripType

Glossary Item Box

Delegate that handle GripClick event in WebSplitter.

Syntax

Visual Basic (Declaration)
Public Delegate Sub WebSplitter.GripClickedDelegate( _
   ByVal id As String, _
   ByVal gripType As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As New WebSplitter.GripClickedDelegate(AddressOf HandlerMethod)
C#
public delegate void WebSplitter.GripClickedDelegate(
   string id,
   int gripType
)

Parameters

id
gripType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSplitter.GripClickedDelegate Members
ISNet.WebUI.WebDesktop Namespace


WebTabChangedEventHandler Delegate

[image]
Intersoft WebDesktop Documentation
WebTabChangedEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebDesktop Namespace : WebTabChangedEventHandler Delegate

sender
e

Glossary Item Box

Delegate that handle TabChanged event in WebTab.

Syntax

Visual Basic (Declaration)
Public Delegate Sub WebTabChangedEventHandler( _
   ByVal sender As Object, _
   ByVal e As WebTabChangedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New WebTabChangedEventHandler(AddressOf HandlerMethod)
C#
public delegate void WebTabChangedEventHandler(
   object sender,
   WebTabChangedEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTabChangedEventHandler Members
ISNet.WebUI.WebDesktop Namespace


Client-side References

Client-side References
Send Feedback
Intersoft WebDesktop > Client-side References

Glossary Item Box

This section is designated to help user working with client-side references in WebDesktop.

In This Section

ISDragableObject

ISDropableObject

ISDragEventArgs

WebButton

WebCallOut

WebContextMenu

WebContextMenuClientSideEvents

WebDesktopClientSideEvents

WebDesktopManager

WebDesktopShortcut

WebDesktopTaskBarSettings

WebDesktopTextSettings

WebDesktopWindow

WebDesktopWindowSettings

WebDialogBox

WebDialogBoxButton

WebDialogBoxClientSideEvents

WebDragControl

WebDropControl

WebDragDropExtender

WebDragDropExtenderClientSideEvents

WebExplorerPane

WebExplorerBar

WebExplorerBarItem

WebFlyPostBackManager

WebFlyPostBackManagerSettings

WebFlyPostBackManagerClientSideEvents

WebMenu

WebMenuBar

WebMenuCheckBoxItem

WebMenuItem

WebMenuRadioItem

WebMenuSeparatorItem

WebNavBar

WebNavPane

WebNavBarItem

WebNavBarItemSettings

WebNavBarSettings

WebNavPaneFooterSettings

WebNotification

WebNotificationEventCollection

WebNotificationEvent

WebNotificationEventArgs

WebNotificationImageSettings

WebNotificationClientSideEvents

WebPaneBase

WebPane

WebPaneClientSideEvents

WebPaneManager

WebPaneSettings

WebPaneTextSettings

WebSplitter

WebTab

WebTabClientSideEvents

WebTabItem

WebTabRoundCornerSettings

WebTabTextSettings

PlaceHolderManager

WebToolBar

ToolCommand

MenuCommand

PlaceHolderManager Global Functions

WebToolBar Global Functions

WebMenuBar Global Functions

WebFlyPostBackManager Global Functions


ISDragableObject

ISDragableObject
Send Feedback
Intersoft WebDesktop > Client-side References > ISDragableObject

Glossary Item Box

ISDragableObject Properties

IsDragged | Description Determines whether the current drag element is being dragged. ValueType boolean Default Value
Enabled | Description Specifies whether the drag element is enabled. ValueType boolean Default Value
Owner | Description Gets the associated WebDragControl instance for the drag element. ValueType Object Default Value
ShadowElement | Description Gets the HTML element of the drag element's shadow which is displayed during dragging. ValueType String Default Value


ISDropableObject

ISDropableObject
Send Feedback
Intersoft WebDesktop > Client-side References > ISDropableObject

Glossary Item Box

ISDropableObject Properties

Enabled | Description Specifies whether the drop element is enabled. ValueType boolean Default Value
IsSubObject | Description Determines whether the current drop object is a sub object. Sub object concept is usually used in Intersoft Control Integration or other complex objects where the control has more than one drop elements. ValueType boolean Default Value
SubObjectContext | Description Gets the CustomSubDropInterfaceBase instance associated to the current drop context. SubObjectContext is used only in complex control integration such as Intersoft Control Integration. SubObjectContext contains information about the sub-object in the context of drag-drop operation, such as during DragOver or DragDrop. ValueType String Default Value
Owner | Description Gets the associated WebDropControl instance for the drop element. ValueType Object Default Value


ISDragEventArgs

ISDragEventArgs
Send Feedback
Intersoft WebDesktop > Client-side References > ISDragEventArgs

Glossary Item Box

ISDragEventArgs Properties

DragObject | Description Represents ISDragableObject instance, which is the object being dragged by the user. ValueType object Default Value
AllowedEffects | Description The allowed effects specified in DragSettings.AllowedEffects of the WebDragDropExtender control. ValueType String Default Value
Data | Description The data associated with a drag control. The native-string type data can be assigned directly in the DragData property of a DragControl object. ValueType Object Default Value
Effect | Description The default effect associated with a drag control. The effect can be set on the Effect property of a drag control or drag settings (for global appliance). ValueType String Default Value
EffectText | Description The effect text (tool tip) that will be displayed when the drag control is over a valid drop target. ValueType String Default Value
KeyState | Description The key state in the current context of drag operation. Key state can be combination of Ctrl, Alt, and Shift. ValueType String Default Value
X | Description The X point of mouse cursor relative to the document. ValueType String Default Value
Y | Description The Y point of mouse cursor relative to the document. ValueType String Default Value
CursorX | Description The X point of mouse cursor relative to the target element. ValueType String Default Value
CursorY | Description The Y point of mouse cursor relative to the target element. ValueType String Default Value
IsInTargetFrame | Description Determines whether the drag operation is currently targeting an element inside IFRAME. ValueType boolean Default Value

ISDragEventArgs Methods
GetDataPresent Description
Determines whether the Data associated in the drag control is matching with the specified type and class name.

Parameters
type ( String )
The type of data associated in the drag control.

className ( String )
The class name associated in the drag control.

Remarks

Return Value
object


WebButton

WebButton
Send Feedback
Intersoft WebDesktop > Client-side References > WebButton

Glossary Item Box

WebButton Properties

Text | Description Gets or sets the text caption displayed in the Button control ValueType String Default Value
Type | Description Gets or sets the type of Button control ValueType String Default Value
Parameter | Description Gets the parameter of the Button control ValueType String Default Value
IntegratedToDesktopManager | Description Gets or sets the status of whether the Button control is integrated to Desktop Manager or not ValueType boolean Default Value False
AutoPostback | Description Specifies whether Postback will be automatically invoked when the button is clicked ValueType boolean Default Value False
OnClientClick | Description Specifies the client-side function to be invoked when a client performs a click event ValueType String Default Value
OnClientResponse | Description Specifies the client-side function to be invoked when a response from client is returned, irregardless of a successful response or error response ValueType String Default Value
PostBackMode | Description Gets or sets whether the postback should be performed by using OnTheFly or FullPagePostback mode when the Button control is clicked. ValueType PostbackMode Default Value OnTheFly
DisableOnClicked | Description Gets or sets whether this button control will be disabled on click event ValueType boolean Default Value False
ClientID | Description Gets the server control identifier generated by ASP.NET ValueType String Default Value The server control identifier generated by ASP.NET
ID | Description Gets or sets the programmatic identifier assigned to the Button control ValueType String Default Value The programmatic identifier assigned to the control
FlyPostBackSettings | Description Configures the settings used by the control when performing OnTheFly postback. ValueType FlyPostBackSettings object Default Value
DesktopManager | Description Gets or sets the DesktopManager instance associated with this Button control ValueType DesktopManager object Default Value

WebButton Methods
GetElement Description
Gets the HTML element from current button

Parameters

Remarks

Return Value
object ( HTML element)

Samples

Disable Description
Disable the button control

Parameters

Return Value
void

Enable Description
Enable the button control

Parameters

Return Value
void

Click Description
Invoke the Click event from this WebButton

Parameters

Return Value
void


WebCallOut

WebCallOut
Send Feedback
Intersoft WebDesktop > Client-side References > WebCallOut

Glossary Item Box

WebCallOut Methods
GetElement

Description
Gets the HTML element associated to the WebCallOut.

Parameters

Remarks

Return Value
object (HTML element)

Samples

GetContentElement Description
Gets the HTML element associated to the WebCallOut's content.

Parameters

Remarks

Return Value
object (HTML element)

Samples

SetTitle Description
Sets WebCallOut's Title.

Parameters
Title ( String )
Name of the title.

Remarks

Return Value
object (HTML element)

Samples

SetText Description
Sets WebCallOut's Text.

Parameters
Title ( String )
Name of the WebCallOut's text.

Remarks

Return Value
object (HTML element)

Samples

SetPosition Description
Set WebCallOut's position.

Parameters
X ( Pixel )
The X coordinate where the WebCallOut will be shown.

Y ( Pixel )
The Y coordinate where the WebCallOut will be shown.

Remarks

Return Value

Samples

SetTitleIcon Description
Sets WebCallOut's TitleIcon.

Parameters
Filename ( the image's name )
Name of the image's filename.

Remarks

Return Value

Samples

Show Description
Shows the WebCallOut control.

Parameters

Remarks

Return Value
void

Samples

Hide Description
Hides the WebCallOut control.

Parameters

Remarks

Return Value
void

Samples

SetHeight Description
Sets WebCallOut's height.

Parameters
Height ( Pixel )
Height of WebCallOut in pixel.
Remarks

Return Value

Samples

SetWidth Description
Sets WebCallOut's width.

Parameters
Width ( Pixel )
Width of WebCallOut in pixel.
Remarks

Return Value

Samples

SetCursorTopLeft Description
Sets cursor/pointing position to top left.

Parameters
CallOut ( WebCallOutObject )

Remarks

Return Value

Samples

SetCursorTopRight Description
Expands the WebExplorerBar instance.

Parameters
CallOut ( WebCallOutObject )

Remarks

Return Value

Samples

SetCursorBottomLeft Description
Sets cursor/pointing position to bottom left.

Parameters
CallOut ( WebCallOutObject )

Remarks

Return Value

Samples

SetCursorBottomRight Description
Sets cursor/pointing position to bottom right.

Parameters
CallOut ( WebCallOutObject )

Remarks

Return Value

Samples

ShowAutoDetect

Description
Shows WebCallOut AutoDetect feature without specifying the TargetControlID initially.

Parameters
targetControlId ( String )
WebCallOut's target control ID

ImplementDisplayLatency ( Boolean )
True / False

Remarks

Return Value

Samples


WebContextMenu

WebContextMenu
Send Feedback
Intersoft WebDesktop > Client-side References > WebContextMenu

Glossary Item Box

WebContextMenu Properties

RootMenu | Description Gets or sets the root menu of this WebContextMenu instance. ValueType String Default Value
Items | Description Gets or sets the items collection this WebContextMenu instance. ValueType Collection ( ISArray) Default Value
ControlId | Description Gets or sets the control id of WebContextMenu instance. ValueType String Default Value
ClientSideEvents | Description Gets the ClientSideEvents of this WebContextMenu instance. ValueType WebContextMenuClientSideEvents Default Value

WebContextMenu Methods
ClearAll Description
Client side (Java Script) function that will clear all the WebContextMenuItem.

Parameters

Remarks

Return Value

Samples

Show Description
Client side (Java Script) function that will show this WebContextMenu instance.

Parameters
x ( int )
the x coordinate where the WebContextMenu will be shown.

y ( int )
the y coordinate where the WebContextMenu will be shown.

Remarks

Return Value

Samples

SetOffsetElement Description
Client side (Java Script) function to set the element which will be used as the offset when showing the WebContextMenu

Parameters
o ( HTML element )
The HTML Element which will be used as the offset

Remarks

Return Value

Samples

HideAll Description
Client side (Java Script) function that will hide this WebContextMenu instance

Parameters

Remarks

Return Value

Samples

RefreshStructure Description
Client side (Java Script) function that will refresh the structure of this WebContextMenu instance

Parameters

Remarks

Return Value

Samples


WebContextMenuClientSideEvents

WebContextMenuClientSideEvents
Send Feedback
Intersoft WebDesktop > Client-side References > WebContextMenuClientSideEvents

Glossary Item Box

WebContextMenuClientSideEvents Properties

OnInitialize | Description Specifies the client side (JavaScript) function that will be invoked when the WebContextMenu object is in initialization process. ValueType String Default Value
OnShowMenu | Description Specifies the client side (JavaScript) function that will be invoked when the WebContextMenu shows the menu. ValueType String Default Value
OnMenuItemClick | Description Specifies the client side (JavaScript) function that will be invoked when the WebContextMenu Item is clicked. ValueType String Default Value


WebDesktopClientSideEvents

WebDesktopClientSideEvents
Send Feedback
Intersoft WebDesktop > Client-side References > WebDesktopClientSideEvents

Glossary Item Box

WebDesktopClientSideEvents Properties

OnInitialize | Description Specifies the client side (JavaScript) function that will be invoked when the webdesktop is in initialization process. ValueType String Default Value
OnShortcutCreated | Description Specifies the client side (JavaScript) function that will be invoked when the webdesktop's shortcut is created ValueType String Default Value
OnShortcutSelected | Description Specifies the client side (JavaScript) function that will be invoked when the webdesktop's shortcut is selected ValueType String Default Value
OnShortcutBeforeLaunched | Description Specifies the client side (JavaScript) function that will be invoked before the webdesktop's shortcut is launched ValueType String Default Value
OnShortcutAfterLaunched | Description Specifies the client side (JavaScript) function that will be invoked after the webdesktop's shortcut is launched ValueType String Default Value
OnWindowCreating | Description Specifies the client side (JavaScript) function that will be invoked when creating window ValueType String Default Value
OnWindowCreated | Description Specifies the client side (JavaScript) function that will be invoked after the window is created ValueType String Default Value
OnWindowMinimized | Description Specifies the client side (JavaScript) function that will be invoked when the window is minimized ValueType String Default Value
OnWindowMaximized | Description Specifies the client side (JavaScript) function that will be invoked when the window is maximized ValueType String Default Value
OnWindowRestored | Description Specifies the client side (JavaScript) function that will be invoked when the window is restored ValueType String Default Value
OnWindowBeforeClosed | Description Specifies the client side (JavaScript) function that will be invoked before the window is closed ValueType String Default Value
OnWindowAfterClosed | Description Specifies the client side (JavaScript) function that will be invoked after the window is closed ValueType String Default Value
OnWindowResized | Description Specifies the client side (JavaScript) function that will be invoked when the window is resized ValueType String Default Value
OnWindowMoved | Description Specifies the client side (JavaScript) function that will be invoked when the window is moved ValueType String Default Value
OnContextMenu | Description Specifies the client side (JavaScript) function that will be invoked when the context menu is called ValueType String Default Value
OnWindowBeforeActivated | Description Specifies the client side (JavaScript) function that will be invoked before the window is activated ValueType String Default Value
OnWindowAfterActivated | Description Specifies the client side (JavaScript) function that will be invoked after the window is activated ValueType String Default Value


WebDesktopManager

WebDesktopManager
Send Feedback
Intersoft WebDesktop > Client-side References > WebDesktopManager

Glossary Item Box

WebDesktopManager Properties

Windows | Description Gets the collection of Windows available in this DesktopManager instance ValueType Collection (ISArray) Default Value
ShortcutIcons | Description Gets the collection of shortcut icons available in this WebDesktop Manager ValueType Collection (ISArray) Default Value
WindowArrangement | Description Gets or sets window arrangement in this WebDesktop Manager ValueType String Default Value
TaskBarVisible | Description Gets or sets the value to indicate whether taskbar is visible in WebDesktop ValueType boolean Default Value
TaskBarSettings | Description Gets or sets the taskbar settings in WebDesktop Manager ValueType TaskBarSettings Default Value
ImagesSettings | Description Gets or sets the images settings in WebDesktop Manager ValueType ImageSettings Default Value
WindowSettings | Description Gets or sets the window settings ValueType WindowSettings Default Value
ShortcutIconsVisible | Description Gets or sets the value to indicate whether shortcut icons are visible in WebDesktop ValueType boolean Default Value
EnableAnimation | Description Gets or sets the value to indicate whether animation should be enabled in WebDesktop ValueType boolean Default Value
EnableKeyboardNavigation | Description Gets or sets the value to indicate whether keyboard navigation should be enabled in WebDesktop ValueType boolean Default Value
ClientSideEvents | Description Gets the object containing list of client side events. ValueType Default Value
ImagesDirectory | Description Gets or sets the images directory used in WebDesktop ValueType String Default Value
TextSettings | Description Gets or sets the text settings used in WebDesktop ValueType TextSettings Default Value
ShortcutSettings | Description Gets or sets shortcut settings ValueType ShortcutSettings Default Value
ActiveWindowIndex | Description Gets or sets the index of currently active window ValueType int Default Value
EnableContextMenu | Description Gets or sets the value to indicate whether context menu should be enabled when user right click on valid objects in DesktopManager ValueType boolean Default Value
ClientID | Description Gets the server control identifier generated by ASP.NET ValueType String Default Value
ID | Description Gets or sets the programmatic identifier assigned to the WebManager ValueType String Default Value
ActiveShortcutIndex | Description Gets or sets the index of currently active shortcut ValueType int Default Value
CreatedAtRuntime | Description Gets or sets the value to indicate whether the WebDesktopManager is created at runtime ValueType boolean Default Value

WebDesktopManager Methods
GetIFrameWindow Description
Get the IFrameWindow of the WebDesktopManager object by given name

Parameters
name ( String )
The name of IFrameWindow that you want to get.

Remarks

Return Value

object (window)

Samples

CreateWindow

Description
Creates a new WebDesktopWindow instance with default configurations

Parameters

Remarks

Return Value

object (WebDesktopWindow)

Samples

GetDocument

Description
Gets the WebDesktop document

Parameters

Remarks

Return Value

object

Samples

GetContentWindow

Description
Gets the WebDesktop content window

Parameters

Remarks

Return Value

object (WebDesktopWindow)

Samples

GetTaskBarElement

Description
Gets the HTML taskbar element of WebDesktop

Parameters

Remarks

Return Value

object (HTML element)

Samples

GetTaskBarWindowGroupElement

Description
Gets the HTML taskbar element of the WebDesktop's WindowGroup

Parameters

Remarks

Return Value

object (HTML element)

Samples

GetTaskBarLeftTemplateElement

Description
Gets the HTML taskbar element of WebDesktop's left template

Parameters

Remarks

Return Value

object (HTML element)

Samples

GetTaskBarRightTemplateElement

Description
Gets the HTML taskbar element of WebDesktop's right template

Parameters

Remarks

Return Value

object (HTML element)

Samples

GetDesktopElement

Description
Gets the HTML desktop element

Parameters

Remarks

Return Value

object (HTML element)

Samples

GetDesktopSize

Description
Gets the desktop size

Parameters

Remarks

Return Value

unit size

Samples

CascadeWindows Decription
Performs cascade windows tiling to all open Windows

Parameters
skipCustomLocation ( String )
Skip the windows if the location is custom

Remarks

Return Value

Samples

TileWindowsHorizontally Description
Tiling all open windows horizontally

Parameters
skipCustomLocation ( String )
Skip the windows if the location is custom

Remarks

Return Value

Samples

TileWindowsVertically Description
Tiling all open windows vertically

Parameters
skipCustomLocation ( String )
Skip the windows if the location is custom

Remarks

Return Value

Samples

GetActiveWindow

Description
Gets the active WebDesktopWindow instance

Parameters

Remarks

Return Value

object (WebDesktopWindow)

Samples

GetActiveShortcut

Description
Gets the WebDesktop active shortcut

Parameters

Remarks

Return Value

object (WebDesktopShortcut)

Samples

GetWindow Description
Gets WebDesktopWindow instance by given name

Parameters
name ( String )
Name of the window

Remarks

Return Value

object (WebDesktopWindow)
Samples

ResolveImagePath Description
Resolves the image path

Parameters
img ( )
path of the image

Remarks

Return Value

Samples

RearrangeShortCutIcons

Description
Rearrange WebDesktop's ShortCut Icons

Parameters

Remarks

Return Value

Samples

ShowShortcutIcons

Description
Show WebDesktop's ShortCut Icons

Parameters

Remarks

Return Value

Samples

HideShortcutIcons

Description
Hide WebDesktop's ShortCut Icons

Parameters

Remarks

Return Value

Samples

ShowDesktop

Description
Minimize all Window and show the Desktop

Parameters

Remarks

Return Value

Samples

SaveDesktopStateToXml

Description
Save Desktop State to XML object

Parameters

Remarks

Return Value

xml object

Samples

GetNotificationControl

Description

Parameters

Remarks

Return Value

Samples


WebDesktopShortcut

WebDesktopShortcut
Send Feedback
Intersoft WebDesktop > Client-side References > WebDesktopShortcut

Glossary Item Box

WebDesktopShortcut Properties

Name | Description Gets the name of the WebDesktopShortcut control. ValueType String Default Value
Index | Description Gets or sets the index of the WebDesktopShortcut object. ValueType String Default Value
DesktopManager | Description Gets or sets the DesktopManager instance associated with WebDesktopShortcut control. ValueType DesktopManager Default Value
Text | Description Gets or sets the text caption displayed in the WebDesktopShortcut control. ValueType String Default Value
TargetURL | Description Gets or sets the target URL of WebDesktopShortcut. ValueType String Default Value
WindowName | Description Gets or sets the WebDesktopWindow's name associated with the WebDesktopShortcut. ValueType String Default Value
Visible | Description Gets the value that indicates whether the control is visible. ValueType Boolean Default Value True
Enabled | Description Gets the value that indicates whether the WebDesktopShortcut control is enabled. ValueType Boolean Default Value True
Location | Description Gets or sets the location of WebDesktopShortcut. ValueType OffsetLocation Default Value
Collection | Description Gets the Collection that contains the WebDesktopShortcut. ValueType Array Default Value
ToolTip | Description Gets or sets the tool tip text that will be displayed on mouse over action. ValueType String Default Value
TargetControlBoxImage | Description Gets or sets the image that will be displayed as the control box image of WebDesktopShortcut. ValueType String Default Value

WebDesktopShortcut Methods
GetElement Description
Returns the outer part of Frame element of WebDesktopShortcut.

Parameters

Remarks

Return Value
object (HTML element)

GetTextElement Description
Returns the text element of WebDesktopShortcut.

Parameters

Remarks

Return Value
object (HTML element)

Rearrange Description
Rearranges the collection of WebDesktopShortcut.

Parameters

Remarks

Return Value
void

Select Description
Selects the WebDesktopShortcut.

Parameters

Remarks

Return Value
void

Open Description
Opens the WebDesktopWindows associated with the WebDesktopShortcut.

Parameters

Remarks

Return Value
void

SetText Description
Sets the text property of WebDesktopShortcut.

Parameters

Remarks

Return Value
void

Delete Description
Deletes the WebDesktopShortcut.

Parameters

Remarks

Return Value
void

Show Description
Show the WebDesktopShortcut.

Parameters

Remarks

Return Value
void

Hide Description
Hide the WebDesktopShortcut.

Parameters

Remarks

Return Value
void


WebDesktopShortcutSetings

WebDesktopShortcutSetings
Send Feedback
Intersoft WebDesktop > Client-side References > WebDesktopShortcutSetings

Glossary Item Box

WebDesktopShortcutSettings Properties

AllowAutoArrange | Description Specifies whether the WebDesktopShortcut will be automatically arranged when moved. ValueType Boolean Default Value true
Movable | Description Specifies whether the WebDesktopShortcut is able to be moved. ValueType Boolean Default Value true


WebDesktopTaskBarSettings

WebDesktopTaskBarSettings
Send Feedback
Intersoft WebDesktop > Client-side References > WebDesktopTaskBarSettings

Glossary Item Box

WebDesktopTaskBarSettings Properties

Position | Description Gets or sets the position of the taskbar. ValueType OffsetLocation Default Value
Movable | Description Specifies whether the taskbar is able to be moved. ValueType Boolean Default Value
Resizable | Description Specifies whether the taskbar is able to be resized. ValueType Boolean Default Value
ShowWindows | Description Specifies whether the opened windows should be displayed in the Taskbar. ValueType Boolean Default Value
WindowButtonWidth | Description Gets or sets the width of the button inside the Taskbar. ValueType Integer Default Value


WebDesktopTextSettings

WebDesktopTextSettings
Send Feedback
Intersoft WebDesktop > Client-side References > WebDesktopTextSettings

Glossary Item Box

WebDesktopTextSettings Properties

InProgressText | Description Specifies the text configuration that will be displayed for all inprogress processing behaviors. ValueType String Default Value
MaximizeText | Description Specifies the text configuration that will be displayed for all maximizing behaviors. ValueType String Default Value
MinimizeText | Description Specifies the text configuration that will be displayed for all minimizing behaviors. ValueType String Default Value
RestoreText | Description Specifies the text configuration that will be displayed for all restoring behaviors. ValueType String Default Value
CloseText | Description Specifies the text configuration that will be displayed for all closing behaviors. ValueType String Default Value


WebDesktopWindow

WebDesktopWindow
Send Feedback
Intersoft WebDesktop > Client-side References > WebDesktopWindow

Glossary Item Box

WebDesktopWindow Properties

AllowMinimize | Description Gets or sets whether minimizing WebDesktopWindow control is allowed. ValueType String Default Value "Default"
AllowMaximize | Description Gets or sets whether maximizing WebDesktopWindow control is allowed. ValueType String Default Value "Default"
AllowResize | Description Gets or sets whether resizing WebDesktopWindow control is allowed. ValueType String Default Value "Default"
AllowClose | Description Gets or sets whether closing WebDesktopWindow control is allowed. ValueType String Default Value "Default"
ControlBox | Description Gets or sets the value indicating whether a control box is displayed in the caption bar of the WebDesktopWindow. ValueType Boolean Default Value
Text | Description Gets or sets the text caption displayed in the WebDesktopWindow control. ValueType String Default Value
TextAlignment | Description Gets or sets the text alignment displayed in the WebDesktopWindow control. ValueType String Default Value
CaptionDisplayMode | Description Gets or sets the display mode of the caption of WebDesktopWindow. ValueType String Default Value
ContentMode | Description Gets or sets whether the content of this Window is using native HTML content or IFrame. ValueType String Default Value
ClientVisible | Description Indicates whether the WebDesktopWindow is visible in the client side at initialization. ValueType Boolean Default Value
Size | Description The size of the WebDesktopWindow control. ValueType UnitSize Default Value
MaximumSize | Description The Maximum size of the WebDesktopWindow control. ValueType UnitSize Default Value
MinimumSize | Description The Minimum size of the WebDesktopWindow control. ValueType UnitSize Default Value
Location | Description Gets or sets the location of WebDesktopWindow control. ValueType String Default Value
Name | Description Gets the name of the WebDesktopWindow control. ValueType String Default Value
InProgressText | Description Gets or sets the text of the InProgressText. ValueType String Default Value
ShowInTaskBar | Description Indicates whether to show the WebDesktopWindow in task bar. ValueType Boolean Default Value
ControlBoxImage | Description Gets or sets the image displayed in the WebDesktopWindow control. ValueType String Default Value
ShortcutImage | Description Gets or sets the image that will be used in WebDesktopShortcut that links to this window. ValueType String Default Value
Index | Description Gets or sets the index of the WebDialogBoxButton object. ValueType String Default Value
DesktopManager | Description Gets or sets the DesktopManager instance associated with WebDialogBoxButton control. ValueType DesktopManager Default Value
ContentURL | Description Gets or sets the URL string of a page that will be displayed inside the container (Window, Pane, Tab). ValueType String Default Value
Collection | Description Gets the Collection that contains the WebDesktopWindow. ValueType Array Default Value
IsClosed | Description Indicates whether or not the WebDesktopWindow is closed. ValueType Boolean Default Value
Initialized | Description Indicates whether or not the WebDesktopWindow has been initialized. ValueType Boolean Default Value
IFrameContentLoaded | Description Indicates whether or not the IFrame content has been loaded. ValueType Boolean Default Value
WindowState | Description Gets or sets the WebDesktopWindow's state ValueType Boolean Default Value
CreatedAtRuntime | Description Indicates whether or not the WebDesktopWindow is created at runtime. ValueType Boolean Default Value
DialogBoxShown | Description Determines whether the dialog box should be shown. ValueType Boolean Default Value
CurrentDialogBox | Description Gets the currently active dialog box owned by the WebDesktopWindow. ValueType WebDialogBox Default Value

WebDesktopWindow Methods
GetWindowDivElement Description
Gets the HTML Div element of this WebDesktopWindow

Parameters

Remarks

Return Value
object (HTML Element)

Samples

GetCaptionBarCellElement Description
Gets the HTML caption bar cell element of WebDesktopWindow

Parameters

Remarks

Return Value
object (HTML Element)

Samples

GetControlBoxElement Description
Gets the HTML ControlBox element of WebDesktopWindow

Parameters

Remarks

Return Value
object (HTML Element)

Samples

GetCaptionBarTableElement Description
Gets the HTML Caption Bar Table element of WebDesktopWindow

Parameters

Remarks

Return Value
object (HTML Element)

Samples

GetInProgressText Description
Gets the progress text of this WebDesktopWindow

Parameters

Remarks

Return Value
String

Samples
GetContentDivElement Description
Gets the HTML Content Div Element of this WebDesktopWindow

Parameters

Remarks

Return Value
object (HTML Element)

Samples

GetDesktopManager Description
Gets the DesktopManager object where this WebDesktopWindow is created

Parameters

Remarks

Return Value
object (DesktopManager)

Samples

GetWindowOptionsCellElement Description
Gets the HTML Window Options Element of this WebDesktopWindow

Parameters

Remarks

Return Value
object (HTML Element)

Samples

GetControlBoxCellElement Description
Gets the HTML Control Box Cell Element of this WebDesktopWindow

Parameters

Remarks

Return Value
object (HTML Element)

Samples

GetMaximizeButtonElement Description
Gets the HTML Maximize Button Element of this WebDesktopWindow

Parameters

Remarks

Return Value
object (HTML Element)

Samples
GetCloseButtonElement Description
Gets the HTML Close Button Element of this WebDesktopWindow

Parameters

Remarks

Return Value
object (HTML Element)

Samples

GetMinimizeButtonElement Description
Gets the HTML Minimize ButtonElement of this WebDesktopWindow

Parameters

Remarks

Return Value
object (HTML Element)

Samples
IsActiveWindow Description
Check whether this WebDesktopWindow is the active window

Parameters

Remarks

Return Value
boolean

Samples
GetTaskBarButtonElement Description
Gets the HTML TaskBar Button Element of this WebDesktopWindow

Parameters

Remarks

Return Value
object (HTML Element)

Samples

GetWindowIFrameElement Description
Gets the HTML Window IFrame element of WebDesktop

Parameters

Remarks

Return Value
object (HTML Element)

Samples
MoveTo Description
Move this WebDesktopWindow to specific location that has been specified from the parameters

Parameters
x ( int )
the x coordinate of where this window will be moved
y ( int )
the y coordinate of where this window will be moved

Remarks

Return Value

Samples
MoveToCenterDesktop Description
Move the position of this WebDesktopWindow to the center of the desktop

Parameters

Remarks

Return Value

Samples

ResizeTo Description
Resize this WebDesktopWindow to specific width and height from the parameters

Parameters
width ( unit )
The width of the Window wants to be resized to
height ( unit )
The height of the Window wants to be resized to

Remarks

Return Value

Samples

Minimize Description
Minimize WebDesktopWindow

Parameters
raiseEvent ( boolean )
An inidicator of whether this minimize action will rise an event
runAnimation ( boolean )
An inidicator of whether this minimize action will run any animation

Remarks

Return Value

Samples

Maximize Description
Maximize this WebDesktopWindow

Parameters
raiseEvent ( boolean )
An inidicator of whether this maximize action will rise an event
runAnimation ( boolean )
An inidicator of whether this maximize action will run any animation

Remarks

Return Value

Samples

Restore Description
Restore this WebDesktopWindow

Parameters
raiseEvent ( boolean )
An inidicator of whether this restore action will rise an event

runAnimation ( boolean )
An inidicator of whether this restore action will run any animation

Remarks

Return Value

Samples

Close Description
Close this WebDesktopWindow

Parameters
raiseEvent ( boolean )
An inidicator of whether this close action will rise an event

Remarks

Return Value

Samples

Activate Description
Activate this WebDesktopWindow

Parameters

Remarks

Return Value

Samples

Show Description
Show this WebDesktopWindow

Parameters
shortcutDiv ( HTML element )
The HTML element of the shortcut

Remarks

Return Value

Samples

Hide Description
Hide this WebDesktopWindow

Parameters

Remarks

Return Value

Samples

BringToFront Description
Bring this WebDesktopWindow to the front of other windows

Parameters

Remarks

Return Value

Samples
SendToBack Description
Send this WebDesktopWindow to the back of other windows

Parameters

Remarks

Return Value

Samples

SetCaption Description
Sets the caption of this WebDesktopWindow

Parameters
text ( String )
The text that will be set as the caption of this WebDesktopWindow

Remarks

Return Value

Samples

SetControlBoxImage Description
Sets the control box image of this WebDesktopWindow

Parameters
imgURL ( String )
The image url that will be set as the ControlBoxImage

Remarks

Return Value

Samples

SetContentURL Description
Sets the content URL of this WebDesktopWindow

Parameters
url ( String )
The content url that will be set as the content url

Remarks

Return Value

Samples

LoadContent Description
Load the content of the Window

Parameters

Remarks

Return Value

Samples
SaveLocationAndSize Description
Save the location and size of this window

Parameters

Remarks

Return Value

Samples

IsTargetSizeValid Description
Check whether the Target size passed from the parameter is a valid size

Parameters
width ( unit )
the width of the target size
height ( unit )
the height of the target size

Remarks

Return Value

Samples

GetPreferredSize Description
Gets the preferred size of this Window

Parameters
width ( unit )
The width of the preferred size
height ( unit )
The height of the preferred size

Remarks

Return Value

Samples

GetNextWindow Description
Gets the next window from the parent WebDesktopManager

Parameters

Remarks

Return Value

Samples

GetPreviousWindow Description
Gets the previous window from the parent WebDesktopManager

Parameters

Remarks

Return Value

Samples

SetInlineContent Description
Sets the inline content from this WebDesktopWindow

Parameters
strHTML ( HTML element )
The String HTML to be set as the Inline Content for this WebDesktopWindow instance

Remarks

Return Value

Samples

SetBusy

Description
Sets the WebDesktopWindow to be busy

Parameters

Remarks

Return Value

Samples

SetIdle Description
Sets the WebDesktopWindow to be Idle

Parameters

Remarks

Return Value

Samples


WebDesktopWindowSettings

WebDesktopWindowSettings
Send Feedback
Intersoft WebDesktop > Client-side References > WebDesktopWindowSettings

Glossary Item Box

WebDesktopWindowSettings Properties

AllowMinimize | Description Specifies whether the WebDesktopWindow object is able to be minimized. ValueType Boolean Default Value
AllowMaximize | Description Specifies whether the WebDesktopWindow object is able to be maximized. ValueType Boolean Default Value
AllowResize | Description Specifies whether the WebDesktopWindow object is able to be resized. ValueType Boolean Default Value
AllowClose | Description Specifies whether the WebDesktopWindow object is able to be closed. ValueType Boolean Default Value
ControlBox | Description Gets or sets the value indicating whether a control box is displayed in the caption bar of the WebDesktopWindow. ValueType Boolean Default Value
CaptionDisplayMode | Description Gets or sets the display mode of the caption of WebDesktopWindow. ValueType String Default Value
ContentMode | Description Gets or sets whether the content of the WebDesktopWindow is using native HTML content or IFrame. ValueType String Default Value
Size | Description Gets or sets the size of WebDesktopWindow. ValueType UnitSize Default Value
MaximumSize | Description Gets or sets the maximum size of WebDesktopWindow. ValueType UnitSize Default Value
MinimumSize | Description Gets or sets the minimum size of WebDesktopWindow. ValueType UnitSize Default Value
BorderType | Description Gets or sets the border type of WebDesktopWindow. ValueType Default Value


WebDialogBox

WebDialogBox
Send Feedback
Intersoft WebDesktop > Client-side References > WebDialogBox

Glossary Item Box

WebDialogBox Properties

CommandButtons | Description Creates command buttons in the dialog box. ValueType Object Default Value
WindowSettings | Description Get or sets the global settings of Window. ValueType Object Default Value
Text | Description Gets or sets the text caption displayed in the WebDialogBox control. ValueType String Default Value
Location | Description Gets or sets the location of WebDialogBox control. ValueType OffsetLocation Default Value
ControlBoxImage | Description Gets or sets the image displayed in the WebDialogBox caption. ValueType String Default Value
ContentURL | Description Gets or sets the URL string of a page that will be displayed inside the container (Window, Pane, Tab). ValueType String Default Value
IntegratedToDesktopManager | Description Gets or sets the status of whether the WebDialogBox control is integrated to Desktop Manager or not. ValueType Boolean Default Value
ClientSideEvents | Description Represents ClientEvents object that hold list of client events. ValueType Object (WebDialogBoxClientSideEvents) Default Value
InProgressText | Description Gets or sets the text displayed when the IFrame is in loading progress. ValueType String Default Value
StartPosition | Description Gets or sets the initial startup position of WebDialogBox. ValueType OffsetLocation Default Value
ClientID | Description Gets the server control identifier generated by ASP.NET. ValueType String Default Value
ID | Description Gets or sets the programmatic identifier assigned to the WebDialogBox control. ValueType Default Value
Window | Description Returns the WebDesktopWindow object associated with the WebDialogBox ValueType WebDesktopWindow Default Value
ParentWindow | Description Gets the parent Window of the WebDialogBox object. ValueType WebDesktopWindow Default Value

WebDialogBox Methods
CreateWebDialogBox

Description
Create the WebDialogBox control.

Parameters

id (string)
Name of the control's id

Remarks

Return Value

object

Samples

ShowDialog Description
Show the WebDialogBox which by default is not shown.

Parameters

Remarks

Return Value

Samples

CloseDialog

Description
Close the WebDialogBox

Parameters

Remarks

Return Value

Samples
GetContentElement

Description
Gets the WebDialogBox's Content Element

Parameters

Remarks

Return Value

object (HTML Element)

Samples
GetContentWindow

Description
Gets the WebDesktop content window

Parameters

Remarks

Return Value

object (WebDesktopWindow)

Samples

FindControl

Description
Gets the Control inside WebDialogBox's TemplateContent

Parameters

id (string)
Name of the Control to be found

Remarks

Return Value

object

Samples

SetContentURL Description
Sets the content URL of this WebDialogBox

Parameters
url ( String )
The url that will be set as the content url.

Remarks

Return Value

Samples


WebDialogBoxButton

WebDialogBoxButton
Send Feedback
Intersoft WebDesktop > Client-side References > WebDialogBoxButton

Glossary Item Box

WebDialogBoxButton Properties

Text | Description Gets or sets the text caption displayed in the WebDialogBoxButton control. ValueType String Default Value
Enabled | Description Gets the value that indicates whether the WebDialogBoxButton control is enabled. ValueType Boolean Default Value True
Name | Description Gets the name of the WebDialogBoxButton control. ValueType String Default Value
Type | Description Gets or sets the type of WebDialogBoxButton control. ValueType String Default Value
Parameter | Description Gets the parameter of the WebDialogBoxButton control. ValueType String Default Value
DesktopManager | Description Gets or sets the DesktopManager instance associated with WebDialogBoxButton control. ValueType Default Value DesktopManager
Index | Description Gets or sets the index of the WebDialogBoxButton object. ValueType String Default Value


WebDialogBoxClientSideEvents

WebDialogBoxClientSideEvents
Send Feedback
Intersoft WebDesktop > Client-side References > WebDialogBoxClientSideEvents

Glossary Item Box

WebDialogBoxClientSideEvents Properties

OnCreated | Description Specifies the client-side function to be invoked when WebDialogBox is created. ValueType String Default Value
OnClosed | Description Specifies the client-side function to be invoked when a WebDialogBox is closed. ValueType String Default Value
OnButtonClicked | Description Specifies the client-side function to be invoked when a WebDialogBoxButton is clicked. ValueType String Default Value


WebDragControl

WebDragControl
Send Feedback
Intersoft WebDesktop > Client-side References > WebDragControl

Glossary Item Box

WebDragControl Properties

AdvancedProperties | Description Specifies the ControlID to be integrated with other Intersoft control. ValueType String Default Value
AllowCrossIFrame | Description Specifies the behavior when the drag operation is crossing IFrame element in a Web page. ValueType String Default Value
AllowedEffects | Description Specifies the allowed effect of a drag operation. ValueType String Default Value
ControlID | Description Gets or sets the control id of WebDragDropExtender instance. ValueType String Default Value
DragData | Description Specifies the string-type data to be passed. ValueType String Default Value
DragVisualHint | Description Specifies the visual effect that is displayed during drag operation. ValueType String Default Value
Effect | Description Gets or sets the effect that applies to a valid drop object during a drag drop operation. ValueType String Default Value
EffectText | Description Gets or sets the default text to be displayed when a drag control is hovered on a valid drop control. ValueType String Default Value
Enabled | Description Enables state of the control. ValueType boolean Default Value True


WebDropControl

WebDropControl
Send Feedback
Intersoft WebDesktop > Client-side References > WebDropControl

Glossary Item Box

WebDropControl Properties

AdvancedProperties | Description Specifies the ControlID to be integrated with other Intersoft control. ValueType String Default Value
AcceptDataType | Description Specifies the data type that accepted by the drop control. ValueType String Default Value
AcceptDragSourceControls | Description Gets or sets the controls that can be accepted by this drop control. Use ; character as separator when you want to include more than one control identifiter. ValueType String Default Value
AutoPostBackOnDragDrop | Description Determines whether postback should be automatically invoked upon successful drag drop operation. ValueType boolean Default Value False
ControlID | Description Gets or sets the control id of WebDragDropExtender instance. ValueType String Default Value
EnableCaching | Description Specifies whether caching is automatically handled by the control. ValueType boolean Default Value True
Enabled | Description Enables state of the control. ValueType boolean Default Value True

WebDropControl Methods
GetElement Description
Gets the HTML element associated to this drop control.

Parameters

Remarks

Return Value
object ( HTML element )


WebDragDropExtender

WebDragDropExtender
Send Feedback
Intersoft WebDesktop > Client-side References > WebDragDropExtender

Glossary Item Box

WebDragDropExtender Properties

DragControls | Description The collection of WebDragControl in ISArray format. ValueType Collection ( ISArray ) Default Value
DropControls | Description The collection of WebDropControl in ISArray format. ValueType Collection ( ISArray ) Default Value
DragSettings | Description Contains global settings related to drag behavior. ValueType String Default Value
DropSettings | Description Contains global settings related to drop behavior. ValueType boolean Default Value False
ClientSideEvents | Description Contains drag and drop client side events. ValueType String Default Value

WebDragDropExtender Methods
ReInitializeDragControls Description
Performs re-initialization of drag controls in the WebDragDropExtender control.

Parameters

Remarks
You will need to call this method whenever the drag control is refreshed/updated using AJAX callback. For instance, this method needs to be called in OnResponse client side event of WebGrid so the drag behaviors are initialized back to the WebGrid after its refresh (partial updates). For example of this usage, see Outlook Style Drag and Drop sample in WebUI Studio.NET 2007 R2 Integrated Samples.

Return Value
void
ReInitializeDropControls Description
Performs re-initialization of drop controls in the WebDragDropExtender control.

Parameters

Remarks
You will need to call this method when the drop control is refreshed/updated using AJAX callback. For instance, if the WebExplorerPane items are removed or added using AJAX, the changes won't take effect until this method is called.

Return Value
void
ClearDropControlCache Description
Clear the cache of the drop controls.

Parameters

Remarks
The drop controls are cached in many ways internally by WebDragDropExtender to provide a high performance drag-drop solution. However, when the drop control's properties are modified, for instances, its location or sizes, you need to call this method to invalidate the cache.

Return Value
void


WebDragDropExtenderClientSideEvents

WebDragDropExtenderClientSideEvents
Send Feedback
Intersoft WebDesktop > Client-side References > WebDragDropExtenderClientSideEvents

Glossary Item Box

WebDragDropExtenderClientSideEvents Properties

OnDragDrop | Description Gets or sets the javascript function to invoke when a valid drag source is dropped to a valid drop target. Parameters controlId The Id of WebDragDropExtender control. dragEventArgs The event arguments of the drag object. dropObject The object that is being dropped. ValueType String Default Value
OnDragEnd | Description Gets or sets the javascript function to invoke when the drag operation has ended. Parameters controlId The Id of WebDragDropExtender control. dragObject The object that is being dragged. ValueType String Default Value
OnDragEnter | Description Gets or sets the javascript function to invoke when a valid drag source is entering a valid drop target for the first time. Parameters controlId The Id of WebDragDropExtender control. dragEventArgs The event arguments of the drag object. dropObject The object that is being dropped. ValueType String Default Value
OnDragLeave | Description Gets or sets the javascript function to invoke when a valid drag source is leaving a drop target without releasing the mouse button. Parameters controlId The Id of WebDragDropExtender control. dropObject The object that is being dropped. ValueType String Default Value
OnDragOver | Description Gets or sets the javascript function to invoke when a valid drag source is over a valid drop target. Parameters controlId The Id of WebDragDropExtender control. dragEventArgs The event arguments of the drag object. dropObject The object that is being dropped. ValueType String Default Value
OnDragStart | Description Gets or sets the javascript function to invoke when the drag operation has started. Parameters controlId The Id of WebDragDropExtender control. dragObject The object that is being dragged. ValueType String Default Value
OnInitilize | Description Gets or sets the javascript function to invoke when the control is being initialized. Parameters controlId The Id of WebDragDropExtender control. ValueType String Default Value
OnShadowCreate | Description Gets or sets the javascript function to invoke when the control needs to create shadow visual effect for dragging operation. Parameters controlId The Id of WebDragDropExtender control. dragObject The object that is being dragged. ValueType String Default Value


WebExplorerPane

WebExplorerPane
Send Feedback
Intersoft WebDesktop > Client-side References > WebExplorerPane

Glossary Item Box

WebExplorerPane Properties

Id | Description Gets or sets the programmatic identifier assigned to the WebExplorerPane control. ValueType String Default Value
Panes | Description Gets the collection of WebExplorerBar items in this WebExplorerPane. ValueType Collection (ISArray) Default Value
PaneItemSettings | Description Gets or sets the WebExplorerBar item settings in this WebExplorerPane object ValueType WebNavBarItemSettings Default Value
PaneSettings | Description Contains default settings for the WebExplorerPane. ValueType WebExplorerBarSettings Default Value
ClientSideEvents | Description Contains client side events for WebExplorerPane. ValueType WebExplorerClientSideEvents Default Value
RenderMode | Description Gets or sets the rendering mode of WebExplorerPane control (Simple, RoundCorner and ComplexImages). ValueType String Default Value
SpecialBarIndex | Description Gets or sets the active WebExplorerPane index. ValueType Int Default Value 0
EnableAnimation | Description Sets the control to enable/activate animated Expand and Collapse of WebExplorerPane. ValueType Boolean Default Value
WebExplorerPane Methods

ResolveImagePath Description
Resolves the image path.

Parameters
img ( String )
Path of the image.

Remarks

Return Value

Samples


WebExplorerBar

WebExplorerBar
Send Feedback
Intersoft WebDesktop > Client-side References > WebExplorerBar

Glossary Item Box

WebExplorerBar Properties

Name | Description Gets or sets the name of this WebExplorerBar instance. ValueType String Default Value
Index | Description Gets or sets the index of this WebExplorerBar instance. ValueType Int Default Value
Size | Description Gets or sets the size of this WebExplorerBar instance. ValueType unit size Default Value
Text | Description Gets or sets the text of this WebExplorerBar instance. ValueType String Default Value
Image | Description Gets or sets the image of this WebExplorerBar instance. ValueType String Default Value
ImageSize | Description Gets or sets the image size of this WebExplorerBar instance. ValueType unit size Default Value
ToolTip | Description Gets or sets the tooltip of this WebExplorerBar instance. ValueType String Default Value
Visible | Description Gets or sets the value to indicate whether this WebExplorerBar instance is visible. ValueType Boolean Default Value
Enabled | Description Gets or sets the value to indicate whether this WebExplorerBar instance is enabled. ValueType Boolean Default Value
Collapse | Description Gets or sets the value to indicate whether this WebExplorerBar instance is collapsed ValueType Boolean Default Value
CaptionDisplayMode | Description Gets or sets the caption display mode of this WebExplorerBar instance. ValueType CaptionDisplayMode Default Value
PaneItems | Description Gets or sets the items in this WebExplorerBar instance. ValueType Collection (ISArray) Default Value
ContentMode | Description Gets or sets the content mode of this WebExplorerBar instance. ValueType ContentMode Default Value
ContentURL | Description Gets or sets the content URL of this WebExplorerBar instance when using IFrame as ContentMode. ValueType String Default Value
IFrameContentLoaded | Description Gets IFrameContentLoaded status of this WebExplorerBar instance. ValueType Boolean Default Value
ItemSettings | Description Gets or sets the ItemSettings of this WebExplorerBar instance. ValueType ItemSettings Default Value
ImagesSettings | Description Gets or sets the images settings in WebExplorerBar. ValueType ImageSettings Default Value

WebExplorerBar Methods

GetItemsContainerElement Description
Gets the HTML Items Container element of the WebExplorerBar instance.

Parameters

Remarks

Return Value
object (HTML element)

Samples

GetIFrameElement Description
Gets the HTML IFrame element of the WebExplorerBar instance.

Parameters

Remarks

Return Value
object (HTML element)

Samples

GetHeaderElement Description
Gets the HTML header element of the WebExplorerBar instance.

Parameters

Remarks

Return Value
object (HTML element)

Samples

GetContentElement Description
Gets the HTML content element of the WebExplorerBar instance.

Parameters

Remarks

Return Value
object (HTML element)

Samples

GetElement Description
Gets the HTML element of the WebExplorerBar instance.

Parameters

Remarks

Return Value
object (HTML element)

Samples

IsActive Description
Gets the value indicating whether the WebExplorerBar instance is currently active.

Parameters

Remarks

Return Value
Boolean

Samples

SetImage Description
Sets the image of the WebExplorerBar instance.

Parameters
img ( String )
Path of the image.

Remarks

Return Value

Samples

SetDisable Description
Disabled the WebExplorerBar instance.

Parameters

Remarks

Return Value

Samples

SetEnable Description
Enabled the WebNavBar instance.

Parameters

Remarks

Return Value

Samples

SetActive Description
Activated the WebExplorerBar instance.

Parameters

Remarks

Return Value

Samples

Click Description
Trigger the click event of the WebExplorerBar instance.

Parameters

Remarks

Return Value

Samples

DoExpand Description
Expand the WebExplorerBar instance.

Parameters

Remarks

Return Value

Samples

DoCollapse Description
Collapse the WebExplorerBar instance.

Parameters

Remarks

Return Value

Samples

HideAllItems Description
Hides all items WebExplorerBarItem.

Parameters

Remarks

Return Value

Samples

ShowAllItems Description
Shows all items of WebExplorerBarItem.

Parameters

Remarks

Return Value

Samples

ShowItems Description
Shows items of WebExplorerBarItem specified in the parameters.

Parameters
arrItemName ( Collection (ISArray) )
Adds the items defined.
isReflectAll ( Boolean )
Shows only the defined items according to arrItemName parameters.
False

Remarks

Return Value

Samples

HideItems Description
Hide items of WebExplorerBarItem specified in the parameters.

Parameters
arrItemName ( Collection (ISArray) )
Hides the items defined.
isReflectAll ( Boolean )
Hides only the defined items according to arrItemName parameters.
False

Remarks

Return Value

Samples

ChangeInlineContent Description
Modifiy WebExplorerBar's content when ContentMode sets to UseInlineContent.

Parameters
newContent ( String )
Sets the content of WebExplorerBar.

Remarks

Return Value

Samples
AnimateHeight Description
Invokes height animation of WebExplorerPane.

Parameters

Remarks

Return Value

Samples


WebExplorerBarItem

WebExplorerBarItem
Send Feedback
Intersoft WebDesktop > Client-side References > WebExplorerBarItem

Glossary Item Box

WebExplorerBarItem Properties

Name | Description Gets or sets the name of this WebExplorerBarItem instance. ValueType String Default Value
Index | Description Gets or sets the index of this WebExplorerBarItem instance. ValueType Int Default Value
Text | Description Gets or sets the text of this WebExplorerBarItem instance. ValueType String Default Value
Image | Description Gets or sets the image of this WebExplorerBarItem instance. ValueType String Default Value
ImageSize | Description Gets or sets the image size of this WebExplorerBarItem instance. ValueType unit size Default Value
ToolTip | Description Gets or sets the tooltip of this WebExplorerBarItem instance. ValueType String Default Value
Enabled | Description Gets or sets the value to indicate whether this WebExplorerBarItem instance is enabled. ValueType Boolean Default Value True
DisplayMode | Description Gets or sets the display mode of this WebExplorerBarItem instance. ValueType DisplayMode Default Value
ImagePosition | Description Gets or sets the image position of this WebExplorerBarItem instance. ValueType ImagePosition Default Value
Visible | Description Gets or sets the value to indicate whether this WebExplorerBarItem instance is visible. ValueType Boolean Default Value
TargetURL | Description Gets or sets the target URL of this WebExplorerBarItem instance. ValueType String Default Value
TargetWindow | Description Gets or sets the target window of this WebExplorerBarItem instance. ValueType String Default Value

WebExplorerBarItem Methods
GetElement Description
Gets the HTML element of this WebExplorerBarItem instance.

Parameters

Remarks

Return Value
Object (HTML Element)

Samples

Click Description
Trigger the click event of this WebExplorerBarItem instance.

Parameters

Remarks

Return Value

Samples


WebFlyPostBackManager

WebFlyPostBackManager
Send Feedback
Intersoft WebDesktop > Client-side References > WebFlyPostBackManager

Glossary Item Box

WebFlyPostBackManager Properties

ClassName | Description Gets the class name of WebFlyPostBackManager's type name. ValueType String Default Value WebFlyPostBackManager
Asynchronous | Description Gets or sets the value to indicate whether OnTheFlyPostBack is done asynchronously. ValueType Boolean Default Value
AutoLoadMetaData | Description Gets or sets the value to indicate whether or not the metadata is automatically loaded on page load. ValueType Boolean Default Value
AutoEventWireup | Description Gets or sets the value to indicate whether or not functions are directly wired up to related server side events. ValueType Boolean Default Value
ClientSideEvents | Description Gets the ClientSideEvents object. ValueType Object Default Value
Metadata | Description Gets the MetaData object in XML form. ValueType Object Default Value
TimeoutInterval | Description Gets or sets the value to indicate a timeout interval for a specified request (in seconds). ValueType Int Default Value

WebFlyPostBackManager Methods
Invoke Description
Invokes the specified method.

Parameters
methodName ( String )
Indicates the requested method name.
params ( params )
Indicates the parameters value for the specified method name.

Remarks

Return Value

Samples

GetStatus Description
Returns the request status of the invoked method.

Parameters
methodName ( String )
Indicates the requested method name.

Remarks

Return Value
String

Samples

Abort Description
Aborts the method that is requested.

Parameters
methodName ( String )
Indicates the requested method name.

Remarks

Return Value

Samples

IsMethodExist Description
Determines whether or not a method exists in metadata.

Parameters

Remarks

Return Value
Boolean

Samples

InvokeCustomAction Description

Parameters
actionName ( )
xmlData ( )

Remarks

Return Value

Samples

IsBusy Description
Determines whether or not the method status is Invoking or Response.

Parameters
methodName ( String )
Indicates the requested method name.

Remarks

Return Value
Boolean

Samples


WebFlyPostBackManagerSettings

WebFlyPostBackManagerSettings
Send Feedback
Intersoft WebDesktop > Client-side References > WebFlyPostBackManagerSettings

Glossary Item Box

WebFlyPostBackManagerSettings Properties

PostHiddenFields | Description Gets or sets whether hidden fields should be posted to server during OnTheFlyPostBack. ValueType String Default Value
PostInputControls | Description Gets or sets whether HTML INPUT controls as well as SELECT and TEXTAREA should be posted to server during OnTheFlyPostBack. ValueType String Default Value
PostControlState | Description Gets or sets a value indicating whether this control's state should be posted during OnTheFlyPostBack. ValueType String Default Value


WebFlyPostBackManagerClientSideEvents

WebFlyPostBackManagerClientSideEvents
Send Feedback
Intersoft WebDesktop > Client-side References > WebFlyPostBackManagerClientSideEvents

Glossary Item Box

WebFlyPostBackManagerClientSideEvents Properties

OnError | Description Specifies the client-side function name that will be invoked when error occured during FlyPostBackManager request. ValueType String Default Value
OnResponse | Description Specifies the client-side function name that will be invoked when FlyPostBackManager request gets a response. ValueType String Default Value
OnResponseSuccess | Description Specifies the client side function name that will be invoked when FlyPostBackManager response completely succeeded. ValueType String Default Value
OnTimeout | Description Specifies the client side function name that will be invoked when FlyPostBackManager request gets a timeout. ValueType String Default Value


WebMenu

WebMenu
Send Feedback
Intersoft WebDesktop > Client-side References > WebMenu

Glossary Item Box

WebMenu Properties

Name | Description Gets or sets the name of this WebMenu instance. ValueType String Default Value
Items | Description Gets or sets the items collection in this WebMenu instance. ValueType Collection ( ISArray) Default Value
ParentMenu | Description Gets the WebContextMenu object which is the parent of this WebMenu instance. ValueType WebContextMenu Default Value
ParentMenuItem | Description Gets the WebContextMenuItem object which is the parent of this WebMenu instance. ValueType WebContextMenuItem Default Value
MenuControl | Description Gets or sets the menu control of this WebMenu instance. ValueType Default Value
DisplayMode | Description Gets or sets the display mode of this WebMenu instance. ValueType Default Value
IconViewMode | Description Gets or sets the icon view mode of this WebMenu instance. ValueType Default Value
ActiveItemIndex | Description Gets or sets the active item index for this WebMenu instance. ValueType Default Value
ActiveItem | Description Gets or sets the active item of this WebMenu instance. ValueType Default Value
Direction | Description Gets or sets the direction of this WebMenu instance. ValueType Default Value
OffsetAlignment | Description Gets or sets the offset alignment of this WebMenu instance. ValueType Default Value
Width | Description Gets or sets the width of this WebMenu instance. ValueType Default Value
Initialized | Description Gets or sets the value to indicate whether the WebMenu object is already initialized. ValueType Default Value
OffsetElement | Description Gets or sets the element which will be used as the offset for this WebMenu. ValueType Default Value
ScrollEnabled | Description Gets or sets the value to indicate whether the WebMenu object is scroll enabled. ValueType Default Value

WebMenu Methods
IsOpen Description
Determines whether WebMenu is opened.

Parameters

Remarks

Return Value
Boolean

Samples

IsRootMenu Description
Determines the RootMenu of MenuBar.

Parameters

Remarks

Return Value
Boolean

Samples

GetId Description
Gets the id of WebMenu.

Parameters

Remarks

Return Value

Samples

GetDocument Description
Returns the html element of the document used by the webmenu instance.

Parameters

Remarks

Return Value

Samples

GetElement Description
Gets the HTML element from current MenuBar instance.

Parameters

Remarks

Return Value
object (HTML element)

Samples

GetMenuBodyElement Description
Gets the WebMenu's Menu body element.

Parameters

Remarks

Return Value
object (HTML element)

Samples

GetScrollElement Description
Gets the WebMenu's Scroll Element.

Parameters
part ( )
The part of the scroll element.

Remarks

Return Value
object (HTML element)

Samples

GetSelectedItemByGroup Description
Gets the WebMenu's selected item according to its group.

Parameters
groupName ( )
Gets or sets the name for Menu Bar item which should appear in the same group.
String

Remarks

Return Value

Samples

Destroy Description
Destroys a menu bar after it has been removed.

Parameters

Remarks

Return Value

Samples

Show Description
Shows the WebMenu.

Parameters
x ( int )
the x coordinate where the WebMenu will be shown.
y ( int )
the y coordinate where the WebMenu will be shown.

Remarks

Return Value

Samples

Hide Description
Hides the WebMenu.

Parameters

Remarks

Return Value

Samples

Invalidate Description
Refresh the user interface.

Parameters

Remarks

Return Value

Samples


WebMenuBar

WebMenuBar
Send Feedback
Intersoft WebDesktop > Client-side References > WebMenuBar

Glossary Item Box

WebMenuBar Properties

ClassName | Description Gets the object class name. ValueType String Default Value WebMenuBar
RequiredFrameworkVersion | Description ValueType Default Value
AccessKey | Description ValueType Default Value
Caption | Description Specifies the bar caption. ValueType String Default Value null
Menus | Description Gets the collection of menu commands in this webmenubar. ValueType ISArray object Default Value array
Display | Description Gets a value that indicates whether a WebMenuBar control is displayed as UI on the page. ValueType Boolean Default Value True
Visible | Description ValueType Default Value
CommandClientSideEvents | Description Specifies the client side (JavaScript) menu command events. ValueType CommandClientEvents object Default Value null
Enabled | Description Gets or sets a value indicating enable state of control. ValueType Boolean Default Value True
ActiveMenu | Description Gets the activated/selected menu. ValueType WebMenuItem object Default Value null
Index | Description ValueType Default Value
SizeMode | Description Gets the tool command sizing mode. ValueType String Default Value Automatic
AllowMove | Description Gets or sets a value that indicates whether a WebMenuBar control is moveable. ValueType String Default Value Default
HandleVisible | Description Gets or sets a value that indicates whether a WebMenuBar handle section is visible. ValueType String Default Value Default
AllowCustomize | Description Gets a value that indicates whether a WebMenuBar control is customizeable. ValueType String Default Value Default
AllowDockBottom | Description Gets or sets a value that indicates whether a WebMenuBar control can be dock to bottom area of PlaceHolderManager. ValueType String Default Value Default
AllowDockLeft | Description Gets or sets a value that indicates whether a WebMenuBar control can be dock to left area of PlaceHolderManager. ValueType String Default Value Default
AllowDockRight | Description Gets or sets a value that indicates whether a WebMenuBar control can be dock to right area of PlaceHolderManager. ValueType String Default Value Default
AllowDockTop | Description Gets or sets a value that indicates whether a WebMenuBar control can be dock to top area of PlaceHolderManager. ValueType String Default Value Default
AllowExpandCollapse | Description Gets or sets a value that indicates whether a WebMenuBar control is expandable and collapseable. ValueType String Default Value Default
AllowFloat | Description Gets or sets a value that indicates whether a WebMenuBar control is floatable. ValueType String Default Value Default
DockingArea | Description Gets the WebMenuBar docking area. ValueType String Default Value NotSet
DockingOffset | Description Gets the WebMenuBar docking offset. ValueType Number Default Value 0
DockingRow | Description Gets the WebMenuBar docking row. ValueType Number Default Value 0
FillDockingRow | Description Gets a value that indicates whether a WebMenuBar control dimension fills the row region of PlaceHolderManager docking row. ValueType String Default Value Yes
HandleStyle | Description Gets or sets the style properties of handle bar section in the bar control. ValueType BarSectionStyle object Default Value null
BodyStyle | Description Gets or sets the style properties of body bar section in the bar control. ValueType BarSectionStyle object Default Value null
OptionStyle | Description Gets or sets the style properties of option bar section in the bar control. ValueType BarSectionStyle object Default Value null
CommandStyle | Description Gets or sets the style properties of command in the bar control. ValueType DynamicStyle object Default Value object
CommandFontStyle | Description ValueType Default Value
SeparatorStyle | Description Gets or sets the style properties of separator command in the bar control. ValueType String Default Value Empty string
ImageSize | Description Gets or sets image size. ValueType UnitSize object Default Value UnitSize (16px,16px)
ShowDelay | Description ValueType Default Value
MenuStyleSettings | Description Gets or sets the style properties of menu styles in the bar control. ValueType WebMenuStyles object Default Value object
AutoPostBack | Description Gets or sets a value that indicates whether a Command is autopostback. ValueType String Default Value No
CommandSize | Description Specifies the MenuCommand size. ValueType String Default Value 50px
DisplayToolTip | Description Gets or sets a value that indicates whether tooltip is displayed. ValueType Boolean Default Value True
ToolTip | Description Specifies the WebMenuBar tooltip. ValueType String Default Value Empty string
TextAlign | Description Specifies the MenuCommand text align type. ValueType String Default Value Default
DisplayMode | Description Specifies the MenuCommand display mode. ValueType String Default Value Default

WebMenuBar Methods
UnregisterAccessKeys Description
Unregisters access keys from menu items.

Parameters

Remarks

Return Value

Samples

RegisterAccessKeys Description
Registers access keys for menu items.

Parameters

Remarks

Return Value
void

Samples

GetOrientation Description
Gets WebMenuBar orientation

Parameters

Remarks

Return Value
String. Horizontal or Vertical

Samples

SelectMenu Description
Sets active and highlight a menu item.

Parameters
menu ( )

Remarks

Return Value
void

Samples

SelectPrevMenu Description
Sets active and highlight previous menu item.

Parameters

Remarks

Return Value
void

Samples

SelectNextMenu Description
Sets active and highlight next menu item.

Parameters

Remarks

Return Value
void

Samples

OnMenuKeyDown Description
Raises the menu keydown event of active menu item.

Parameters
keyCode ( Number )
event keyCode
null
activeMenu ( WebMenuItem object )
Menu that the event will be raised.
null

Remarks

Return Value
void

Samples

SetCaption Description
Sets WebMenuBar caption

Parameters
caption ( String )
WebMenuBar caption parameter
null

Remarks

Return Value
void

Samples

SetDisplayToolTip Description
Sets WebMenuBar DisplayToolTip

Parameters
val ( String )
no default

Remarks

Return Value
void

Samples

SetAllowMove Description
Sets WebMenuBar AllowMove

Parameters
val ( String )
no default

Remarks

Return Value
void

Samples

SetToolTip Description
Sets WebMenuBar ToolTip

Parameters
tooltips ( String )
no default

Remarks

Return Value
void

Samples

SetDisplay Description
Sets WebMenuBar Display

Parameters
val ( Boolean )
no default

Remarks

Return Value
void

Samples

SetIsFloat Description
Sets WebMenuBar floating dock behavior.

Parameters
val ( String )
No default (required)

Remarks

Return Value
void

Samples

ShowMenu Description
Show WebMenuBar menu

Parameters
cmd ( MenuCommand object )
no default
updateContainerDimension ( Boolean )
Update container (WebMenuBar) dimension when Command is showed.
False

Remarks

Return Value
void

Samples

HideMenu Description
Hide WebMenuBar menu

Parameters
cmd ( MenuCommand object )
no default
updateContainerDimension ( Boolean )
Update container (WebMenuBar) dimension when Command is hidden.
False

Remarks

Return Value
void

Samples

AddMenu Description
Add Command to existing MenuCommandCollection

Parameters
cmd ( MenuCommand object )
no default
idx ( Number )
Last collection index

Remarks

Return Value
void

Samples

RemoveMenu Description
Remove Command from MenuCommandCollection

Parameters
cmd ( MenuCommand object )
no default

Remarks

Return Value
void

Samples

EnableMenu Description
Enabling group of Menus

Parameters
c ( MenuCommand or Array of MenuCommands )
no default

Remarks

Return Value
void

Samples

DisableMenu Description
Disabling group of Menus

Parameters
c ( MenuCommand or Array of MenuCommands )
no default

Remarks

Return Value
void

Samples

UpdateUI Description
Apply immediately all UI changes.

Parameters
updateContainerDimension ( Boolean )
Update container (WebMenuBar) dimension.
False

Remarks

Return Value
void

Samples

ResetUsageData Description
Reset MenuCommands setting to original setting.

Parameters

Remarks

Return Value
void

Samples

HideAll Description
Hides all the WebMenuBar.

Parameters

Remarks

Return Value
void

Samples


WebMenuCheckBoxItem

WebMenuCheckBoxItem
Send Feedback
Intersoft WebDesktop > Client-side References > WebMenuCheckBoxItem

Glossary Item Box

WebMenuCheckBoxItem Properties

Type | Description Gets or sets the type of WebMenuCheckBoxItem control. ValueType WebMenuCheckBoxItem Default Value
Checked | Description Determines whether the current WebMenuCheckBoxItem is checked. ValueType Boolean Default Value


WebMenuItem

WebMenuItem
Send Feedback
Intersoft WebDesktop > Client-side References > WebMenuItem

Glossary Item Box

WebMenuItem Properties

Name | Description Gets the name of the WebMenuItem control. ValueType String Default Value
Index | Description Gets or sets the index of the WebMenuUItem object. ValueType String Default Value
Collection | Description Gets the Collection that contains the WebMenuItem. ValueType Array Default Value
ParentMenu | Description Gets the ParentMenu of WebMenuItem. ValueType WebMenuItem Default Value
SubMenu | Description Gets the SubMenu of this WebMenuItem. ValueType WebMenuItem Default Value
OwnerMenu | Description Gets the OwnerMenu of this WebMenuItem. ValueType WebMenuItem Default Value
Items | Description Gets the Items collection of WebMenuItem. ValueType WebMenuItem Default Value
Type | Description Gets or sets the type of WebMenuItem control. ValueType WebMenuItem Default Value
Text | Description Gets or sets the text caption displayed in the WebMenuItem control ValueType String Default Value
ImageURL | Description Gets or sets the images URL link in WebMenuItem ValueType String Default Value
OnClick | Description Specifies the client-side function to be invoked when a client performs a click event ValueType String Default Value
KeepMenuVisible | Description Indicates whether the menu which own this item should be kept visible after clicked. ValueType Boolean Default Value False
Enabled | Description Gets the value that indicates whether the WebMenuItem control is enabled. ValueType Boolean Default Value True
AccessKey | Description Sets or retrieves the keyboard shortcut key for setting focus to the Command. ValueType String Default Value
Shortcut | Description Gets or sets the shortcut key for the menu item, which will invoke the associated command when pressed. ValueType WebMenuItem Default Value
Tooltip | Description Gets or sets the tool tip text that will be displayed on mouse over action. ValueType String Default Value
Visible | Description Gets the value that indicates whether the control is visible. ValueType Boolean Default Value True
TargetURL | Description Gets or sets the target URL of WebMenuItem. ValueType String Default Value
TargetFrame | Description Gets or sets the target frame where the URL specified in TargetURL should be displayed. ValueType WebMenuItem Default Value
GroupName | Description Gets or sets the name for radio menu item which should appear in the same group. ValueType String Default Value
IconViewDisplayMode | Description Gets or sets the display mode when the menu is operating in IconView mode. ValueType WebMenuItem Default Value
IconViewMode | Description Specifies whether this menu should be displayed in IconViewMode. ValueType Boolean Default Value False
UseFontImage | Description Indicates whether font should be used as replacement for Image. When set to True, the text specified in ImageURL will be rendered using WebDings font. ValueType Boolean Default Value False
AutoPostBack | Description Specifies whether Postback will be automatically invoked when the MenuItem is clicked ValueType Boolean Default Value False
Selected | Description Determines whether the current menu item is selected. ValueType Boolean Default Value
Checked | Description Gets or sets whether this menu item is checked. This property only applicable to menu item which Type is either Radio or CheckBox. ValueType Boolean Default Value False
PredefinedId | Description The predefined identifier for this item. ValueType String Default Value
IsPredefinedItem | Description Indicates whether this menu item is a predefined item. This flag is used to mark built-in menu items used in other Intersoft's product. ValueType Boolean Default Value False
CustomElement | Description Specify the custom element for the menu item which Type is Custom. ValueType String Default Value

WebMenuItem Methods
IsUsingImageIconViewMode Description
Determines whether WebMenuItem is using ImageIconViewMode

Parameters

Remarks

Return Value
Boolean

Samples

ScrollIntoView Description
To scroll the menu item into view, when scrolling is enabled.

Parameters

Remarks

Return Value

Samples

GetElement Description
Gets the HTML element from current WebMenuItem instance.

Parameters

Remarks

Return Value
object (HTML element)

Samples

HasSubMenu Description
Determines whether WebMenuItem has SubMenu collection.

Parameters

Remarks

Return Value
Boolean

Samples

Click Description
Performs click action on WebMenuItem.

Parameters

Remarks

Return Value

Samples

GetPreviousSelectableItem Description
Gets the previous Selectable Item.

Parameters

Remarks

Return Value

Samples

GetNextSelectableItem Description
Gets the next Selectable Item.

Parameters

Remarks

Return Value

Samples

SetChecked Description
Sets a menu item which Type is Radio or CheckBox to Checked state.

Parameters
isChecked
It will set the item as checked. if it is false, then it will be unchecked.

fromCode ( )
It needs to be set to true when called from API call.

Remarks

Return Value

Samples

Enable Description
Enables the WebMenuItem control

Parameters

Remarks

Return Value

Samples

Disable Description
Disables the WebMenuItem control

Parameters

Remarks

Return Value

Samples

Show Description
Client side (Java Script) function that will show this WebMenuItem instance.

Parameters

Remarks

Return Value

Samples

Hide Description
Client side (Java Script) function that will hide this WebMenuItem instance.

Parameters

Remarks

Return Value

Samples

SetText Description
Sets the text property of WebMenuItem.

Parameters
text (String)
Text of the WebMenuItem
String

Remarks

Return Value

Samples

SetImage Description
Sets WebMenuItem's Image URL.

Parameters
imageURL (url(String))
Address of the image URL

Remarks

Return Value

Samples

Destroy Description
Destroys a menu item after it has been removed.

Parameters

Remarks

Return Value

Samples

Delete Description
Deletes the WebMenuItem control.

Parameters

Remarks

Return Value

Samples

Unselect Description
Deselect the WebMenuItem.

Parameters

Remarks

Return Value

Samples

IsSelected Description
Determines whether the WebMenuItem is selected.

Parameters

Remarks

Return Value
Boolean

Samples

Select Description
Selects the WebMenuItem.

Parameters
unselectPreviousItem ( )
Deselect the previous MenuItem.

Remarks

Return Value

Samples

IsSubMenuOpen Description
Determines whether SubMenu of WebMenuItem is opened.

Parameters

Remarks

Return Value
Boolean

Samples


WebMenuRadioItem

WebMenuRadioItem
Send Feedback
Intersoft WebDesktop > Client-side References > WebMenuRadioItem

Glossary Item Box

WebMenuRadioItem Properties

GroupName | Description Gets or sets the name for radio menu item which should appear in the same group. ValueType WebMenuRadioItem Default Value
Checked | Description Determines whether the current WebMenuRadioItem is checked. ValueType Boolean Default Value


WebMenuSeparatorItem

WebMenuSeparatorItem
Send Feedback
Intersoft WebDesktop > Client-side References > WebMenuSeparatorItem

Glossary Item Box

WebMenuSeparatorItem Properties
Type Description
Gets or sets the type of WebMenu control.

ValueType
String

Default Value


WebNavBar

WebNavBar
Send Feedback
Intersoft WebDesktop > Client-side References > WebNavBar

Glossary Item Box

WebNavBar Properties

Name | Description Gets or sets the name of this WebNavBar instance ValueType String Default Value
Index | Description Gets or sets the index of this WebNavBar instance ValueType int Default Value
Size | Description Gets or sets the size of this WebNavBar instance ValueType unit size Default Value
Text | Description Gets or sets the text of this WebNavBar instance ValueType String Default Value
Image | Description Gets or sets the image of this WebNavBar instance ValueType String Default Value
ImageSize | Description Gets or sets the image size of this WebNavBar instance ValueType unit size Default Value
ToolTip | Description Gets or sets the tooltip of this WebNavBar instance ValueType String Default Value
Visible | Description Gets or sets the value to indicate whether this WebNavBar instance is visible ValueType boolean Default Value
Enabled | Description Gets or sets the value to indicate whether this WebNavBar instance is enabled ValueType boolean Default Value
Collapse | Description Gets or sets the value to indicate whether this WebNavBar instance is collapsed ValueType boolean Default Value
CaptionDisplayMode | Description Gets or sets the caption display mode of this WebNavBar instance ValueType CaptionDisplayMode Default Value
CaptionStyle | Description Gets or sets the caption style of this WebNavBar instance ValueType WebStyle Default Value
Items | Description Gets or sets the items in this WebNavBar instance ValueType Collection (ISArray) Default Value
ActiveBarItemIndex | Description Gets or sets the active WebNavBarItem index of this WebNavBar instance ValueType int Default Value
ContentMode | Description Gets or sets the content mode of this WebNavBar instance ValueType ContentMode Default Value
ContentURL | Description Gets or sets the content URL of this WebNavBar instance when using IFrame as ContentMode ValueType String Default Value
IFrameContentLoaded | Description Gets IFrameContentLoaded status of this WebNavBar instance ValueType boolean Default Value
ItemSettings | Description Gets or sets the ItemSettings of this WebNavBar instance ValueType ItemSettings Default Value
CaptionText | Description Gets or sets the CaptionText of this WebNavBar instance ValueType String Default Value

WebNavBar Methods
GetActiveBarItem Description
Gets the active WebNavBar Item

Parameters

Remarks

Return Value
object ( WebNavBarItem)

Samples

GetItemsContainerElement Description
Gets the HTML Items Container element of this WebNavBar instance

Parameters

Remarks

Return Value
object (HTML element)

Samples

GetIFrameElement Description
Gets the HTML IFrame element of this WebNavBar instance

Parameters

Remarks

Return Value
object (HTML element)

Samples

GetImageElement Description
Gets the HTML Image element of this WebNavBar instance

Parameters

Remarks

Return Value
object (HTML element)

Samples

GetTextElement Description
Gets the HTML Text element of this WebNavBar instance

Parameters

Remarks

Return Value
object (HTML element)

Samples

GetElement Description
Gets the HTML element of this WebNavBar instance

Parameters

Remarks

Return Value
object (HTML element)

Samples

GetFooterElement Description
Gets the HTML footer element of this WebNavBar instance

Parameters

Remarks

Return Value
object (HTML element)

Samples

IsActive Description
Gets the value indicating whether this WebNavBar instance is currently active

Parameters

Remarks

Return Value
boolean

Samples

SetCaption Description
Sets the caption of this WebNavBar instance

Parameters
caption ( String )
Caption to be set for this WebnavBar instance

Remarks

Return Value

Samples

SetImage Description
Sets the image of this WebNavBar instance

Parameters
img ( String )
path of the image

Remarks

Return Value

Samples

SetDisable Description
Disabled this WebNavBar instance

Parameters

Remarks

Return Value

Samples

SetEnable Description
Enabled this WebNavBar instance

Parameters

Remarks

Return Value

Samples

SetActive Description
Activated this WebNavBar instance

Parameters

Remarks

Return Value

Samples

Click Description
Trigger the click event of this WebNavBar instance

Parameters

Remarks

Return Value

Samples


WebNavPane

WebNavPane
Send Feedback
Intersoft WebDesktop > Client-side References > WebNavPane

Glossary Item Box

WebNavPane Properties

Id | Description The ID of the control ValueType String Default Value
NavType | Description Gets or sets the NavType of this WebNavPane instance ValueType NavType Default Value
BarItems | Description Gets the collection of WebNavBar items in this WebNavPane ValueType Collection (ISArray) Default Value
ActiveBarIndex | Description Gets or sets the active WebNavBar index inside this WebNavPane object ValueType int Default Value
AllowResize | Description Gets or sets the value to indicate whether the WebNavPane object is allowed to be resized ValueType boolean Default Value
BarItemSettings | Description Gets or sets the WebNavBar item settings in this WebNavPane object ValueType BarItemSettings Default Value
BarSettings | Description Gets or sets the WebNavBar settings in this WebNavPane object ValueType BarSettings Default Value
FooterSettings | Description Gets or sets the footer settings in WebNavPane object ValueType FooterSettings Default Value
BarVisible | Description Gets or sets the value to indicate whether the WebNavBar is visible in WebNavPane Object ValueType boolean Default Value
ImagesDirectory | Description Gets or sets the images directory in this WebNavPane object ValueType String Default Value
OnBarClick | Description Specifies the client side (Java Script) function that will be invoked when the bar is clicked ValueType String Default Value
OnBarItemClick | Description Specifies the client side (Java Script) function that will be invoked when the bar item is clicked ValueType String Default Value
OnPaneResize | Description Specifies the client side (Java Script) function that will be invoked when the pane is resized ValueType String Default Value
OnInitialize | Description Specifies the client side (JavaScript) function that will be invoked when the WebNavPane object is in initialization process. ValueType String Default Value
OnClientUnload | Description Specifies the client side (JavaScript) function that will be invoked when client object is in unload process. ValueType String Default Value

WebNavPane Methods
ResolveImagePath Description
Resolves the image path

Parameters
img ( String )
path of the image

Remarks

Return Value

Samples

GetCaptionElement Description
Gets the HTML Caption element of WebNavPane object

Parameters

Remarks

Return Value
object (HTML element)

Samples

GetGripElement Description
Gets the HTML Grip element of WebNavPane object

Parameters

Remarks

Return Value
object (HTML element)

Samples

GetFooterElement Description
Gets the HTML Footer element of WebNavPane object

Parameters

Remarks

Return Value
object (HTML element)

Samples

GetActiveBar Description
Gets the active WebNavBar instance inside this WebNavPane

Parameters

Remarks

Return Value
object (WebNavBar)

Samples

SetActiveBar Description
Sets the active WebNavBar instance inside this WebNavPane

Parameters
idx ( int )
The index of the active WebNavBar instance

Remarks

Return Value

Samples


WebNavBarItem

WebNavBarItem
Send Feedback
Intersoft WebDesktop > Client-side References > WebNavBarItem

Glossary Item Box

WebNavBarItem Properties

Name | Description Gets or sets the name of this WebNavBarItem instance ValueType String Default Value
Index | Description Gets or sets the index of this WebNavBarItem instance ValueType int Default Value
Text | Description Gets or sets the text of this WebNavBarItem instance ValueType String Default Value
Image | Description Gets or sets the image of this WebNavBarItem instance ValueType String Default Value
ImageSize | Description Gets or sets the image size of this WebNavBarItem instance ValueType unit Default Value
ToolTip | Description Gets or sets the tooltip of this WebNavBarItem instance ValueType String Default Value
Enabled | Description Gets or sets the value to indicate whether this WebNavBarItem instance is enabled ValueType boolean Default Value true
DisplayMode | Description Gets or sets the display mode of this WebNavBarItem instance ValueType DisplayMode Default Value
ImagePosition | Description Gets or sets the image position of this WebNavBarItem instance ValueType ImagePosition Default Value
Visible | Description Gets or sets the value to indicate whether this WebNavBarItem instance is visible ValueType boolean Default Value true
TargetURL | Description Gets or sets the target URL of this WebNavBarItem instance ValueType String Default Value
TargetWindow | Description Gets or sets the target window of this WebNavBarItem instance ValueType String Default Value

WebNavBarItem Methods
GetElement Description
Gets the HTML element of this WebNavBarItem instance

Parameters

Remarks

Return Value
Object (HTML Element)

Samples

IsActive Description
Gets the value indicating whether this WebNavBarItem instance is currently active

Parameters

Remarks

Return Value
boolean

Samples

Click Description
Trigger the click event of this WebNavBarItem instance

Parameters

Remarks

Return Value

Samples


WebNavBarItemSettings

WebNavBarItemSettings
Send Feedback
Intersoft WebDesktop > Client-side References > WebNavBarItemSettings

Glossary Item Box

WebNavBarItemSettings Properties

DisplayMode | Description Gets or sets the display mode of this WebNavBarItemSettings ValueType DisplayMode Default Value
ImagePosition | Description Gets or sets the image position of this WebNavBarItemSettings ValueType ImagePosition Default Value
ImageSize | Description Gets or sets the image size of this WebNavBarItemSettings ValueType unit Default Value
TargetWindow | Description Gets or sets the target window of this WebNavBarItemSettings ValueType String Default Value


WebNavBarSettings

WebNavBarSettings
Send Feedback
Intersoft WebDesktop > Client-side References > WebNavBarSettings

Glossary Item Box

WebNavBarSettings Properties

CaptionDisplayMode | Description Gets or sets the caption display mode of this WebNavBarSettings ValueType DisplayMode Default Value
ContentMode | Description Gets or sets the content mode of this WebNavBarSettings ValueType ContentMode Default Value
ImageSize | Description Gets or sets the image size of this WebNavBarSettings ValueType unit Default Value
Size | Description Gets or sets the size of this WebNavBarSettings ValueType unit Default Value
Image | Description Gets or sets the image of this WebNavBarSettings ValueType String Default Value


WebNavPaneFooterSettings

WebNavPaneFooterSettings
Send Feedback
Intersoft WebDesktop > Client-side References > WebNavPaneFooterSettings

Glossary Item Box

WebNavPaneFooterSettings Properties
ImageSize Description
Gets or sets the image size in this WebNavPaneFooter

ValueType
unit

Default Value


WebNotification

WebNotification
Send Feedback
Intersoft WebDesktop > Client-side References > WebNotification

Glossary Item Box

WebNotification Properties

Interval | Description Gets or sets the WebNotification's interval ValueType Int Default Value
DisplayLatency | Description Gets or sets the WebNotificaton's display latency ValueType Int Default Value
IntegratedToDesktopManager | Description Gets or sets the WebNotification integrated mode ValueType MenuIntegrationMode Default Value
ServiceType | Description Gets or sets the WebNotification's service type ValueType String Default Value
ServiceUrl | Description Gets or sets the WebNotification's service url ValueType String Default Value
DisplayMode | Description Gets or sets the WebNotification's display mode ValueType DisplayMode Default Value
ContentText | Description Gets or sets the WebNotification's content text ValueType String Default Value
ContentImage | Description Gets or sets the WebNotification's content image ValueType Image Default Value
CaptionText | Description Gets or sets the WebNotification's caption text ValueType String Default Value
ShowActionDropdown | Description Gets or sets a value indicating whether WebNotification should show drop down action ValueType Boolean Default Value
ShowCloseButton | Description Gets or sets a value indicating whether close button should be shown in this WebNotification instance ValueType Boolean Default Value
EnableSound | Description Gets or sets a value indicating whether sound should be enabled for this WebNotification instance ValueType Boolean Default Value
SoundFile | Description Gets or sets the sound file of this WebNotification instance ValueType String Default Value
AnimationStyle | Description Gets or sets the animation style of this WebNotification instance ValueType String Default Value
ImagePosition | Description Gets or sets the image's position in this WebNotification instance ValueType String Default Value
ImageVAlign | Description Gets or sets the image's vertical alignment of this WebNotification instance ValueType String Default Value
ImagesSettings | Description Gets the ImagesSettigns of this WebNotification instance ValueType ImagesSettings Default Value
ClientSideEvents | Description Gets the ClientSideEvents of this WebNotification instance ValueType WebNotificationClientSideEvents Default Value
MenuStyleSettings | Description Gets the MenuStyleSettings of this WebNotification instance ValueType MenuStyleSettings Default Value
Menu | Description Gets the Menu of this WebNotification instance ValueType WebMenu Default Value
Items | Description Gets or sets the items collection in this WebNotification instance ValueType Collection (ISArray) Default Value
Enabled | Description Gets or sets a value indicating whether this WebNofitication instance should be enabled ValueType Boolean Default Value
ClientID | Description Gets the server control identifier generated by ASP.NET ValueType String Default Value
ID | Description Gets or sets the programmatic identifier assigned to the WebNotification control instance ValueType String Default Value
NotifyWindowClickable | Description Gets or sets a value indicating whether this WebNotification will notify if the window is clickable ValueType Boolean Default Value
NotifyWindowURL | Description Gets or sets a value indicating whether this WebNofitication instance will notify the window url ValueType Boolean Default Value
NotifyWindowName | Description Gets or sets a value indicating whether this WebNofitication instance will notify the window's name ValueType Boolean Default Value
AutoStart | Description Gets or sets a value indicating whether this WebNofitication is automatically start ValueType Boolean Default Value
RunOnce | Description Gets or sets a value indicating whether this WebNofitication instance will run only once ValueType Boolean Default Value

WebNotification Methods
Show Description
Shows the specified WebNotification control.

Parameters

Remarks

Return Value

Samples

Hide Description
Hides the specified WebNotification control.

Parameters

Remarks

Return Value

Samples

Enable Description
Enables the state of WebNotification control.

Parameters

Remarks

Return Value

Samples

Disable Description
Disables the state of WebNotification control.

Parameters

Remarks

Return Value

Samples

GetCaptionElement Description
Gets the caption element of WebNotification control.

Parameters

Remarks

Return Value
Object (HTML CellElement)

Samples

SetCaptionText Description
Sets the caption of WebNotification control.

Parameters
text ( String )
Indicates the caption text that will be applied.

Remarks

Return Value

Samples

GetOptionElement Description
Gets the ActionDropDown element of WebNotification control.

Parameters

Remarks

Return Value
Object (HTML SpanElement)

Samples

GetCloseElement Description
Gets the Close element of WebNotification control

Parameters

Remarks

Return Value
Object (HTML SpanElement)

Samples

GetCaptionBarElement Description
Gets the Caption Bar element of WebNotification control.

Parameters

Remarks

Return Value
Object (HTML TableElement)

Samples

GetContentElement Description
Gets the content element of WebNotification control.

Parameters

Remarks

Return Value
Object (HTML DivElement)

Samples

GetContentTextElement Description
Gets the context text of WebNotification control.

Parameters

Remarks

Return Value
Object (HTML DivElement)

Samples

GetContentImageElement Description
Gets the content image of WebNotification control.

Parameters

Remarks

Return Value
Object (HTML ImageElement)

Samples

GetContentTemplateElement Description
Gets the content template element of WebNotification control.

Parameters

Remarks

Return Value
Object (HTML DivElement)

Samples

GetCurrentNotification Description
Gets the current WebNotificationEvent object.

Parameters

Remarks

Return Value
Object (WebNotificationEvent)

Samples

GetAllNotifications Description
Gets all the WebNotificationEvent objects in the WebNotification control.

Parameters

Remarks

Return Value
Object (WebNotificationEventCollection)

Samples

GetLastNotification Description
Gets the last WebNotificationEvent object.

Parameters

Remarks

Return Value
Object (WebNotificationEvent)

Samples

GetMissedNotifications Description
Gets missed WebNotificationEvent objects.

Parameters

Remarks

Return Value
Object (WebNotificationEventCollection)

Samples

GetActionMenu Description
Gets the ActionMenu object of the WebNotification control.

Parameters

Remarks

Return Value
WebMenu object

Samples

Notify Description
Notifies the specified WebNotificationEvent object.

Parameters
notification ( WebNotificationEvent )
Indicates the WebNotificationEvent that will be notified.

Remarks

Return Value

Samples

GetSoundElement Description
Gets the sound element of WebNotification control.

Parameters

Remarks

Return Value
Object (HTML BgSoundElement)

Samples


WebNotificationEventCollection

WebNotificationEventCollection
Send Feedback
Intersoft WebDesktop > Client-side References > WebNotificationEventCollection

Glossary Item Box

WebNotificationEventCollection Properties

Notifications | Description Specifies collection of WebNotifications in current session ValueType Object Default Value
HasData | Description Specifies whether the WebNotification has data or not ValueType Boolean Default Value


WebNotificationEvent

WebNotificationEvent
Send Feedback
Intersoft WebDesktop > Client-side References > WebNotificationEvent

Glossary Item Box

WebNotificationEvent Properties

ContentImage | Description Gets or sets the image content of the notification ValueType String Default Value
ContentText | Description Gets or sets the text content of the notification ValueType String Default Value
Properties | Description Specifies the custom properties to be passed from method to client ValueType Object Default Value
Shown | Description Gets or sets the WebNotification visibility ValueType Boolean Default Value
Clicked | Description Specifies whether the WebNotification is clicked or not ValueType Boolean Default Value
CaptionText | Description Gets or sets the caption text of the WebNotification ValueType String Default Value
NotifyURL | Description Gets or sets the URL for the WebNotification ValueType String Default Value


WebNotificationEventArgs

WebNotificationEventArgs
Send Feedback
Intersoft WebDesktop > Client-side References > WebNotificationEventArgs

Glossary Item Box

WebNotificationEventArgs Properties

Id | Description The ID of the control ValueType String Default Value
RawUrl | Description Specifies the service which is called by the WebNotification ValueType String Default Value
CustomData | Description Specifies the custom data of the WebNotification ValueType String Default Value


WebNotificationImagesSettings

WebNotificationImagesSettings
Send Feedback
Intersoft WebDesktop > Client-side References > WebNotificationImagesSettings

Glossary Item Box

WebNotificationImagesSettings Properties

CloseNormal | Description Gets or sets the image to represent Close button in normal mode ValueType Default Value
CloseOver | Description Gets or sets the image to represent Close button in over mode ValueType Default Value
CloseActive | Description Gets or sets the image to represent Close button in active mode ValueType Default Value
ActionNormal | Description Gets or sets the image to represent Action button in normal mode ValueType Default Value
ActionOver | Description Gets or sets the image to represent Action button in over mode ValueType Default Value
ActionActive | Description Gets or sets the image to represent Action button in active mode ValueType Default Value


WebNotificationClientSideEvents

WebNotificationClientSideEvents
Send Feedback
Intersoft WebDesktop > Client-side References > WebNotificationClientSideEvents

Glossary Item Box

WebNotificationClientSideEvents Properties

OnBeforeRequest | Description The javascript function that will be invoked before the control perform request. ValueType String Default Value
OnNotify | Description The javascript function that will be invoked when the control returns at least one notification. ValueType String Default Value
OnInitialize | Description The javascript function that will be invoked during control utilization. ValueType String Default Value
OnResponse | Description The javascript function that will be invoked after the control receives response from server. ValueType String Default Value
OnError | Description The javascript function that will be invoked when error is received during response. ValueType String Default Value
OnClick | Description The javascript function that will be invoked when user clicks on the notification window. ValueType String Default Value
OnClose | Description The javascript function that will be invoked when user closes the notification window. ValueType String Default Value
OnActionClick | Description The javascript function that will be invoked when user clicks on the Action dropdown button. ValueType String Default Value


WebPaneBase

WebPaneBase
Send Feedback
Intersoft WebDesktop > Client-side References > WebPaneBase

Glossary Item Box

WebPaneBase Properties

Name | Description Gets or sets the name for this Pane Item. ValueType String Default Value
IsEnabled | Description Specifies whether this Pane Item is enabled. ValueType Boolean Default Value True
Text | Description Gets or sets the text for this Pane Item. ValueType String Default Value
ToolTip | Description Gets or sets the tooltip text for this Pane. ValueType String Default Value
Width | Description Gets or sets the dimension mode for this Pane's width. ValueType DimensionMode Default Value Fill
Height | Description Gets or sets the dimension mode for this Pane's height. ValueType DimensionMode Default Value Fill
WidthValue | Description Gets or sets the value of Width in Unit. This property is applicable when Width is set to Custom. ValueType Unit Default Value
HeightValue | Description Gets or sets the value of the Height in Unit. This property is applicable when Height mode is set to Custom. ValueType Unit Default Value
PaneManager | Description Gets the PaneManager from WebPaneBase Control. ValueType WebPaneManager Default Value
ParentGroupPane | Description Gets the ParentGroupPane of this Pane Item. ValueType WebGroupPane Default Value
AllowResize | Description Determines whether this Pane can be resized by users. ValueType AllowResize Default Value
TextAlignment | Description Gets or sets the alignment of the text. ValueType TextAlignment Default Value Default
Index | Description Gets the index of this Pane Item in the collection ValueType Integer Default Value
ActualWidth | Description Gets the actual width of this Pane Item. ValueType Unit Default Value
ActualHeight | Description Gets the actual height of this Pane Item. ValueType Unit Default Value
AllowCollapse | Description Gets whether users are allowed to collapse this Pane through splitter. ValueType AllowCollapse Default Value Default
Collection | Description Gets the collection which owns this Pane Item. ValueType ISCollectionBase Default Value
IFrameContentLoaded | Description Determines whether the IFrame Content has been loaded. ValueType Boolean Default Value
IsRootPane | Description Determines whether this Pane is root Pane. ValueType Boolean Default Value

WebPaneBase Methods
GetPaneManager Description
Get WebPaneManager object

Parameters

Remarks

Return Value

object (WebPaneManager)

Samples

GetElement

Description
Get WebPane Element

Parameters

Remarks

Return Value

object (HTML Element)

Samples

GetHeaderCellElement

Description
Gets WebPane Header Cell Element (if isInfoText is true, it get the InfoText Cell Element, if isInfoText is false, it get the WebPane Title Cell Element)

Parameters
isInfoText (boolean)

Remarks

Return Value

object (HTML Element)

Samples
SetText

Description
Set the title of WebPane

Parameters

text (String)
WebPane's Title

Remarks

Return Value

Samples
SetInfoText

Description
Set the InfoText of WebPane

Parameters

text (string)
WebPane's InfoText

Remarks

Return Value

Samples

SetImage

Description
Set the Image for WebPane Header

Parameters

imageURL (string)
URL of the Image

Remarks

Return Value

Samples

SetVisible

Description
Set the Visibility of WebPane

Parameters

isVisible (boolean)
WebPane visibility

Remarks

Return Value

Samples

SetContentVisible

Description
Set the Visibility of WebPane's content area

Parameters

isVisible (boolean)
Visibility of WebPane's content area

Remarks

Return Value

Samples

Collapse

Description
Collapse the WebPane

Parameters

Remarks

Return Value

Samples

Expand

Description
Expand the WebPane

Parameters

Remarks

Return Value

Samples

IsCollapsed

Description
Get WebPane status whether its Collapsed or Not

Parameters

Remarks

Return Value

boolean

Samples


WebPane

WebPane
Send Feedback
Intersoft WebDesktop > Client-side References > WebPane

Glossary Item Box

WebPane Properties

ContentMode | Description Gets or sets the content mode of this Pane. ValueType ContentMode Default Value Default
ContentURL | Description Gets or sets the URL for the IFrame content. This property is applicable when ContentMode is set to UseIFrame. ValueType String Default Value
InProgressText | Description Gets or sets the text which will be displayed when the Active IFrame is in loading progress. This property only applicable when IFrameShowLoader is set to True and ContentMode is set to UseIFrame. ValueType String Default Value

WebPane Methods

GetContentDivElement

Description
Get the Content's DivElement of WebPane

Parameters

Remarks

Return Value
object (HTML Element)
Samples
GetContentElement

Description
Get the Content's Element of WebPane

Parameters

Remarks

Return Value
object (HTML Element)
Samples
GetPanelFrameElement

Description
Get PanelFrame's Element of WebPane

Parameters

Remarks

Return Value

object (HTML Element)

Samples

GetInProgressText

Description
Get WebPane's InProgress Text

Parameters

Remarks

Return Value

String

Samples

SetContentURL Description
Set WebPane Content URL

Parameters
url (String)
Address of the URL

Remarks

Return Value

Samples


WebPaneClientSideEvents

WebPaneClientSideEvents
Send Feedback
Intersoft WebDesktop > Client-side References > WebPaneClientSideEvents

Glossary Item Box

WebPaneClientSideEvents Properties

OnInitialize | Description Gets or sets the javascript function to invoke when the control is being initialized. ValueType String Default Value
OnBeforeResize | Description Gets or sets the javascript function to invoke when the Pane is about to be resized through splitter. ValueType String Default Value
OnAfterResize | Description Gets or sets the javascript function to invoke after the Pane is resized through splitter. ValueType String Default Value


WebPaneManager

WebPaneManager
Send Feedback
Intersoft WebDesktop > Client-side References > WebPaneManager

Glossary Item Box

WebPaneManager Properties

SplitterSettings | Description Contains default settings for the Splitter. ValueType WebPaneSplitterSettings Default Value
ClientSideEvents | Description Contains client side events for WebPaneManager. ValueType WebPaneClientSideEvents Default Value
ImagesSettings | Description Contains images settings for WebPaneManager. ValueType WebPaneImagesSettings Default Value
RootGroupPane | Description Gets or sets the RootGroupPane used by the WebPaneManager. ValueType WebGroupPane Default Value
PaneSettings | Description Contains default settings for the WebPaneManager. ValueType WebPaneSetting Default Value
ImagesDirectory | Description Gets or sets the location of Images used to render the WebPaneManager control. ValueType String Default Value /CommonLibrary/Images/WebDesktop/
TextSettings | Description Contains text settings used by the control. ValueType WebPaneTextSettings Default Value
ClientID | Description Gets the server control identifier generated by ASP.NET. ValueType String Default Value
ID | Description The ID name of the control ValueType String Default Value

WebPaneManager Methods
GetPaneByName Description
returns the pane of specified name

Parameters
name ( )

Remarks

Return Value
WebPaneBase

Samples

GetAllPanes Description
returns all Panes objects available in the PaneManager regardless of the hierarchy structure.

Parameters

Remarks

Return Value
WebPaneCollection

Samples


WebPaneSettings

WebPaneSettings
Send Feedback
Intersoft WebDesktop > Client-side References > WebPaneSettings

Glossary Item Box

WebPaneSettings Properties

AllowResize | Description Determines whether panes are resizable. ValueType AllowResize Default Value Yes
CaptionDisplayMode | Description Gets or sets the mode of the caption display. ValueType DisplayMode Default Value Text
HeaderVisible | Description Gets or sets whether the header part should be rendered. ValueType Visibility Default Value Yes
HeaderAppearance | Description Gets or sets the default predefined style applied to Header part. ValueType HeaderAppearanceMode Default Value UseMainStyle
ImageAlignment | Description Gets or sets the alignment of the image. The image alignment is relative to the caption text. ValueType DisplayAlignment Default Value Left
TextAlignment | Description Gets or sets the alignment of the text. ValueType TextAlignment Default Value Left
InfoTextAlignment | Description Gets or sets the alignment of the InfoText relative its placeholder. ValueType TextAlignment Default Value Right
InfoTextPosition | Description Gets or sets the position of the InfoText part. ValueType InfoTextPosition Default Value BesideCaption
ContentMode | Description Gets or sets the content mode of the WebPaneManager control. ValueType ContentMode Default Value UseInlineContent
IFrameAllowTransparency | Description Specifies whether the IFRAME should allow transparency. This property is applicable when ContentMode is set to UseIFrame. ValueType Boolean Default Value True
IFrameShowLoader | Description Specifies whether to show loader text when the active IFrame is in loading progress. This property only applicable when ContentMode is set to UseIFrame. ValueType Boolean Default Value True
PaneSpacing | Description Specifies the spacing between each Pane in pixel. ValueType Integer Default Value 4
ScrollBarStyle | Description Gets or sets the scrollbar style for WebPane. ValueType WebScrollBarStyle Default Value
AllowCollapse | Description Indicates whether users are allowed to collapsed Panes through splitter. ValueType AllowCollapse Default Value No


WebPaneTextSettings

WebPaneTextSettings
Send Feedback
Intersoft WebDesktop > Client-side References > WebPaneTextSettings

Glossary Item Box

WebPaneTextSettings Properties
InProgressText Description
Gets or sets the text which will be displayed when an IFrame is in loading progress.

ValueType
String

Default Value


WebSplitter

WebSplitter
Send Feedback
Intersoft WebDesktop > Client-side References > WebSplitter

Glossary Item Box

WebSplitter Properties

Id | Description Gets or sets the Id of the WebSplitter. ValueType String Default Value
Size | Description Gets or sets the Size of the WebSplitter (in pixel). ValueType Integer Default Value 4
Shadow | Description Gets or sets the behavior of WebSplitter's resizing method. true indicating shadow movement, false indicating realtime movement. currently only support shadow movement. ValueType Boolean Default Value True
AllowCollapse | Description Gets or sets whether the WebSplitter is able to collapse or not. ValueType Boolean Default Value True
AllowResize | Description Gets or sets whether the WebSplitter is able to resize or not. ValueType Boolean Default Value True
Panel1Min | Description Gets or sets the minimum size of panel1 to collapse or resize (in pixel). valid value is greater or equal to 1. ValueType Integer Default Value 1
Panel2Min | Description Gets or sets the minimum size of panel2 to collapse or resize (in pixel). valid value is greater or equal to 1. ValueType Integer Default Value 1
Panel1Scrollable | Description Gets or sets whether the panel1 of the WebSplitter is scrollable or not. ValueType Boolean Default Value False
Panel2Scrollable | Description Gets or sets whether the panel2 of the WebSplitter is scrollable or not. ValueType Boolean Default Value False
PlaceholderId | Description Gets or sets the Id of the WebSplitter's placeholder. it supposed to be a td element id. ValueType String Default Value
Orientation | Description Gets or sets the Orientation of the WebSplitter, either "Horizontal" or "Vertical". ValueType String Default Value
CollapseDirection | Description Gets or sets the direction of the grip to collapse, either "Panel1" or "Panel2". ValueType String Default Value
GripImageCollapse | Description Gets or sets the Image path icon to collapse. ValueType String Default Value
GripImageRestore | Description Gets or sets the Image path icon to restore. ValueType String Default Value
Integrated | Description Gets or sets whether the WebSplitter control is integrated into PaneManager object. ValueType Boolean Default Value False
PaneManager | Description Gets or sets the PaneManager instance associated with this WebSplitter control. Used when integrating into PaneManager, in order to have a consistent style. ValueType Object Default Value


WebTab

WebTab
Send Feedback
Intersoft WebDesktop > Client-side References > WebTab

Glossary Item Box

WebTab Properties

ActiveTabIndex | Description Gets or sets the active WebTab index. ValueType Integer Default Value 0
TabPages | Description Gets the collection of WebTab pages in this WebTab control. ValueType WebTab[] Default Value
ActiveTab | Description Gets or sets the active WebTab object. ValueType WebTab object Default Value
ClientID | Description Gets the server control identifier generated by ASP.NET. ValueType String Default Value The server control identifier generated by ASP.NET
ID | Description Gets or sets the programmatic identifier assigned to the WebTab control. ValueType String Default Value The programmatic identifier assigned to the control
RenderMode | Description Gets or sets the active WebExplorerPane index. ValueType String Default Value

WebTab Methods
GetContainerBorderWidth

Description
Gets the container's border width

Parameters

Remarks

Return Value

unit (Container's border's width)

Samples

GetHeaderTableElement

Description
Gets the HTML table element of WebTab's header part

Parameters

Remarks

Return Value

object ( HTML element)

Samples

GetTabContentDivElement

Description
Gets the HTML content div element of WebTab

Parameters

Remarks

Return Value

object ( HTML element)

Samples

GetTabItemNormalStyle

Description
Gets the tab item's normal style

Parameters

Remarks

Return Value

Samples

GetIFrameWindow Description
Get the IFrameWindow of the WebTab object

Parameters
name ( String )
The name of IFrameWindow that you want to get.

Remarks

Return Value

object ( Window)

Samples
GetScrollCellElement

Description
Gets the HTML ScrollCell element of the WebTab

Parameters

Remarks

Return Value

object ( HTML element)

Samples
GetScrollLeftButtonElement

Description
Gets the HTML ScrollLeftButton element of the WebTab

Parameters

Remarks

Return Value

object ( HTML element)

Samples
GetScrollRightButtonElement

Description
Gets the HTML ScrollRighttButton element of the WebTab

Parameters

Remarks

Return Value

object ( HTML element)

Samples
GetCloseButtonElement

Description
Gets the HTML CloseButton element of the WebTab

Parameters

Remarks

Return Value

object ( HTML element)

Samples
GetActiveTab

Description
Gets the active WebTab object

Parameters

Remarks

Return Value

WebTab object

Samples
AddNewTabItem Description
Add a new tab item which has properties based on the parameters

Parameters
name ( String )
The name of the new TabItem
captionText ( String )
The caption text of the new TabItem
imagePath ( String )
The imagePath of the new TabItem
contentURL ( String )
The contentURL of the new TabItem
setActive ( boolean )
The active status of the new TabItem

Remarks

Return Value

Samples


WebTabClientSideEvents

WebTabClientSideEvents
Send Feedback
Intersoft WebDesktop > Client-side References > WebTabClientSideEvents

Glossary Item Box

WebTabClientSideEvents Properties

OnBeforeTabChanged | Description Specifies the client-side function to be invoked before client changed the tab ValueType String Default Value
OnAfterTabChanged | Description Specifies the client-side function to be invoked after client changed the tab ValueType String Default Value
OnInitialize | Description Specified the client side function to be invoked when the WebTab is in initialization process ValueType String Default Value
OnBeforeClosed | Description Specified the client side function to be invoked before the WebTab is closed ValueType String Default Value
OnAfterClosed | Description Specified the client side function to be invoked after the WebTab is closed ValueType String Default Value
OnCreated | Description Specified the client side function to be invoked when the WebTab is created ValueType String Default Value
OnScroll | Description Specified the client side function to be invoked when the WebTab is scrolled ValueType String Default Value


WebTabItem

WebTabItem
Send Feedback
Intersoft WebDesktop > Client-side References > WebTabItem

Glossary Item Box

WebTabItem Properties

Name | Description Gets or sets the name of the WebTabItem ValueType String Default Value
CaptionDisplayMode | Description Gets or sets the CaptionDisplayMode for WebTabItem ValueType DisplayMode Default Value
ImageAlignment | Description The alignment of image in this WebTabItem ValueType String Default Value
IsEnabled | Description Gets or sets a value indicating whether the WebTabItem can respond to user interaction ValueType boolean Default Value true
IsSeparator | Description Gets or sets a value indicating whether the WebTabItem is a separator ValueType boolean Default Value true
Text | Description Gets or sets the text to display on the WebTabItem ValueType String Default Value
Image | Description Gets or sets the image inside WebTabItem ValueType object ( Image ) Default Value
Index | Description Gets the index of the WebTabItem ValueType integer Default Value
ToolTip | Description Gets or sets the tooltip for the WebTabItem ValueType String Default Value
ContentMode | Description Gets or sets the ContentMode of WebTabItem ValueType Default Value
ContentURL | Description Gets or sets the ContentURL of the WebTabItem ValueType String Default Value
AllowClose | Description When this property is set to true, there will be a close button at the right most of the Tab ValueType boolean Default Value true
InProgressText | Description Specifies the text that will be displayed when the specific WebTabItem is in progress processing request ValueType String Default Value
Collection | Description Gets the collection of WebTabItem ValueType WebTabItem[] Default Value
IFrameLoaded | Description Gets or sets a value indicating whether content of the IFrame has been successfully loaded into WebTabItem ValueType boolean Default Value false
IsClosed | Description Gets or sets the status of the WebTabItem ValueType boolean Default Value false

WebTabItem Methods
Enable Description
Enable the WebTab control

Parameters

Remarks

Return Value

void

Samples

Disable Description
Disable the WebTab control

Parameters

Remarks

Return Value

void

Samples

Close Description
Close the WebTab control

Parameters

Remarks

Return Value

void

Samples

GetElement Description
Gets the HTML element from current WebTab object

Parameters

Remarks

Return Value

object ( HTML element)

Samples

GetInnerTableElement Description
Gets the HTML Inner Table element of the WebTab

Parameters

Remarks

Return Value

object ( HTML element)

Samples

GetLeftImageElement Description
Gets the HTML Left Image element of the WebTab

Parameters

Remarks

Return Value

object ( HTML element)

Samples

GetCenterImageCellElement Description
Gets the HTML Center Image element of the WebTab

Parameters

Remarks

Return Value

object ( HTML element)

Samples

GetRightImageElement Description
Gets the HTML Right Image element of the WebTab

Parameters

Remarks

Return Value

object ( HTML element)

Samples

GetDivElement

Description
Gets the HTML Div element of the WebTab

Parameters

Remarks

Return Value

object ( HTML element)

Samples

IsActiveTab Description
Gets the value indicating whether this TabItem is the active tab

Parameters

Remarks

Return Value

boolean

Samples
SetActive Description
Sets this TabItem to become the active tab item

Parameters

Remarks

Return Value

Samples
SetCaption Description
Sets the caption text of this WebTabItem

Parameters
text ( String )
The text to be set as the caption for this WebTabItem

Remarks

Return Value

Samples
SetImage Description
Sets the image of this WebTabItem's header

Parameters
imageURL( String )
The image url to be set as the image of this WebTabItem

Remarks

Return Value

Samples
SetContentURL Description
Sets the content's URL of this WebTabItem

Parameters
url( String )
The content URL to be set as the content of this WebTabItem

Remarks

The ContentMode of the WebTabItem must be set to UseIFrame in order for this method to take affect.

Return Value

Samples
IsFirstItem

Description
Gets the value indicating whether this TabItem is the first tab item

Parameters

Remarks

Return Value

boolean

Samples
IsLastItem

Description
Gets the value indicating whether this TabItem is the last tab item

Parameters

Remarks

Return Value

boolean

Samples
GetTabPageElement

Description
Gets the HTML element of this TabPage

Parameters

Remarks

Return Value

object ( HTML element)

Samples

GetTabPageIFrameElement

Description
Gets the HTML element of this TabPage's IFrame

Parameters

Remarks

Return Value

object ( HTML element)

Samples

LoadContent

Description
Load the content of this WebTabItem

Parameters

Remarks

Return Value

Samples

GetInProgressText

Description
Gets the InProgressText of this TabItem

Parameters

Remarks

Return Value

String

Samples

ScrollIntoView

Description

Scroll this WebTabItem into visible view. This method is useful when the WebTab is using AllowScrolling feature.

Parameters

Remarks

Return Value

Samples


WebTabRoundCornerSettings

WebTabRoundCornerSettings
Send Feedback
Intersoft WebDesktop > Client-side References > WebTabRoundCornerSettings

Glossary Item Box

WebTabRoundCornerSettings Properties

TopBorderColor | Description Gets or sets the top border color of WebTab ValueType Color Default Value
FillerBorderColor | Description Gets or sets the filler border color of WebTab ValueType Color Default Value
ApplyHover | Description Gets or sets a value indicating whether the Over style will be applied ValueType boolean Default Value true


WebTabTextSettings

WebTabTextSettings
Send Feedback
Intersoft WebDesktop > Client-side References > WebTabTextSettings

Glossary Item Box

WebTabTextSettings Properties

InProgressText | Description Specifies the text that will be displayed when the specific WebTab object is in progress processing request ValueType String Default Value
ScrollLeftButtonTooltipText | Description Gets or sets the tooltip text of ScrollLeftButton for this WebTab object ValueType String Default Value
ScrollRightButtonTooltipText | Description Gets or sets the tooltip text of ScrollRighttButton for this WebTab object ValueType String Default Value
CloseButtonTooltipText | Description Gets or sets the tooltip text of CloseButton for this WebTab object ValueType String Default Value


PlaceHolderManager

PlaceHolderManager
Send Feedback
Intersoft WebDesktop > Client-side References > PlaceHolderManager

Glossary Item Box

PlaceHolderManager Properties

ClassName | Description Gets the object class name. ValueType String Default Value PlaceHolderManager
IsDefaultPagePlaceHolder | Description Gets a value whether a placeholder is a default placeholder for a page. ValueType Boolean Default Value False
PlaceHolderContainer | Description Gets container ID for placeholder manager. ValueType String Default Value Empty String
EnableMergeBar | Description Gets or sets a value that indicates whether merged Bar allow to be added to PlaceHolderManager. ValueType Boolean Default Value False
Bars | Description Gets the collection of Bar controls in this PlaceHolderManager. ValueType ISArray object Default Value array
WebToolBarStyleSettings | Description Gets or sets the style properties of WebToolBar control managed by PlaceHolderManager. ValueType WebToolBarStyleSettings object Default Value object
WebMenuBarStyleSettings | Description Gets or sets the style properties of WebMenuBar control managed by PlaceHolderManager. ValueType WebMenuBarStyleSettings object Default Value object
SizeMode | Description Gets the command sizing mode. ValueType String Default Value Automatic
AllowMove | Description Gets or sets a value that indicates whether Bar controls in PlaceHolderManager is moveable. ValueType String Default Value Yes
HandleVisible | Description Gets a value that indicates whether a Bar handle section in PlaceHolderManager is visible. ValueType String Default Value Yes
AllowCustomize | Description Gets or sets a value that indicates whether Bar controls in PlaceHolderManager is customizeable. ValueType String Default Value Yes
AllowDockBottom | Description Gets or sets a value that indicates whether Bar controls in PlaceHolderManager can be dock to bottom area of PlaceHolderManager. ValueType String Default Value Yes
AllowDockLeft | Description Gets or sets a value that indicates whether Bar controls in PlaceHolderManager can be dock to left area of PlaceHolderManager. ValueType String Default Value Yes
AllowDockRight | Description Gets or sets a value that indicates whether Bar controls in PlaceHolderManager can be dock to right area of PlaceHolderManager. ValueType String Default Value Yes
AllowDockTop | Description Gets or sets a value that indicates whether Bar controls in PlaceHolderManager can be dock to top area of PlaceHolderManager. ValueType String Default Value Yes
AllowExpandCollapse | Description Gets or sets a value that indicates whether Bar controls in PlaceHolderManager is expandable and collapseable. ValueType String Default Value Yes
AllowFloat | Description Gets or sets a value that indicates whether Bar controls in PlaceHolderManager is floatable. ValueType String Default Value Yes
DockingArea | Description Gets Bars docking area. ValueType String Default Value Top
DockingOffset | Description Gets a Bar docking offset. ValueType Number Default Value 0
FillDockingRow | Description Gets a value that indicates whether Bar controls dimension in PlaceHolderManager fills the row region of PlaceHolderManager docking row. ValueType String Default Value Yes
MaxDockingRows | Description Gets maximum docking rows for docking area. ValueType Number Default Value 2
DisplayToolTip | Description Gets or sets a value that indicates whether a Bar tooltip control in PlaceHolderManager is displayed. ValueType String Default Value Yes
TextAlign | Description Gets Bar commands text align type. ValueType String Default Value Right
DisplayMode | Description Gets Bar commands display mode. ValueType String Default Value Text
CommandSize | Description Gets Bar commands size. ValueType String Default Value 50px
IntegratedTo | Description Gets or sets the PlaceHolderManager menu integrated mode. ValueType String Default Value None
MenuStyleSettings | Description Gets or sets the style properties of menu styles in the bar control. ValueType WebMenuStyles object Default Value object

PlaceHolderManager Methods
SetDisplayToolTip Description
Sets Bars DisplayToolTip property

Parameters
val ( String )
DisplayToolTip value
no default (required)

Remarks

Return Value

void

Samples
GetCustomizeWindow

Description
Gets customize window object

Parameters

Remarks

Return Value

CustomizeWindowBAR object

Samples
ShowCustomizeWindow

Description
Show customize window

Parameters

Remarks

Return Value

void

Samples
RegisterBar Description
Register runtime bar object into PlaceHolderManager

Parameters
bar ( Bar object (WebToolBar object or WebMenuBar object) )
no default (required)

Remarks

Return Value

void

Samples
UnRegisterBar Description
Unregister runtime bar object from PlaceHolderManager

Parameters
bar ( Bar object (WebToolBar object or WebMenuBar object) )
no default (required)

Remarks

Return Value

void

Samples
ResetUsageData

Description
Reset all bars usage data

Parameters

Remarks

Return Value

void

Samples
AdjustDimension

Description
Adjust PlaceHolderManager layout dimension

Parameters

Remarks

Return Value

void

Samples


WebToolBar

WebToolBar
Send Feedback
Intersoft WebDesktop > Client-side References > WebToolBar

Glossary Item Box

WebToolBar Properties

ClassName | Description Gets the object class name. ValueType String Default Value WebToolBar
Caption | Description Specifies the bar caption. ValueType String Default Value null
Commands | Description Gets the collection of tool commands in this webtoolbar. ValueType ISArray object Default Value array
Display | Description Gets a value that indicates whether a WebToolBar control is displayed as UI on the page. ValueType Boolean Default Value True
MergeToolBar | Description Gets a value that indicates whether a WebToolBar control is a merge webtoolbar. ValueType Boolean Default Value False
CommandClientSideEvents | Description Specifies the client side (JavaScript) tool command events. ValueType CommandClientEvents object Default Value null
SizeMode | Description Gets the tool command sizing mode. ValueType String Default Value Automatic
AllowMove | Description Gets or sets a value that indicates whether a WebToolBar control is moveable. ValueType String Default Value Default
AllowCustomize | Description Gets a value that indicates whether a WebToolBar control is customizeable. ValueType String Default Value Default
AllowDockBottom | Description Gets or sets a value that indicates whether a WebToolBar control can be dock to bottom area of PlaceHolderManager. ValueType String Default Value Default
AllowDockLeft | Description Gets or sets a value that indicates whether a WebToolBar control can be dock to left area of PlaceHolderManager. ValueType String Default Value Default
AllowDockRight | Description Gets or sets a value that indicates whether a WebToolBar control can be dock to right area of PlaceHolderManager. ValueType String Default Value Default
AllowDockTop | Description Gets or sets a value that indicates whether a WebToolBar control can be dock to top area of PlaceHolderManager. ValueType String Default Value Default
AllowExpandCollapse | Description Gets or sets a value that indicates whether a WebToolBar control is expandable and collapseable. ValueType String Default Value Default
AllowFloat | Description Gets or sets a value that indicates whether a WebToolBar control is floatable. ValueType String Default Value Default
DockingArea | Description Gets the WebToolBar docking area. ValueType String Default Value NotSet
DockingOffset | Description Gets the WebToolBar docking offset. ValueType Number Default Value 0
DockingRow | Description Gets the WebToolBar docking row. ValueType Number Default Value 0
FillDockingRow | Description Gets a value that indicates whether a WebToolBar control dimension fills the row region of PlaceHolderManager docking row. ValueType String Default Value Yes
ToggleGroups | Description Gets the collection of toggle group commands in this webtoolbar. ValueType ISArray object Default Value array
HandleStyle | Description Gets or sets the style properties of handle bar section in the bar control. ValueType BarSectionStyle object Default Value object
BodyStyle | Description Gets or sets the style properties of body bar section in the bar control. ValueType BarSectionStyle object Default Value object
OptionStyle | Description Gets or sets the style properties of option bar section in the bar control. ValueType BarSectionStyle object Default Value object
CommandStyle | Description Gets or sets the style properties of command in the bar control. ValueType DynamicStyle object Default Value object
SeparatorStyle | Description Gets or sets the style properties of separator command in the bar control. ValueType String Default Value Empty string
ShowDelay | Description Gets or sets the amount of submenu show delay in miliseconds. ValueType Number Default Value 500
MenuStyleSettings | Description Gets or sets the style properties of menu styles in the bar control. ValueType WebMenuStyles object Default Value object
CommandSize | Description Specifies the ToolCommand size. ValueType String Default Value 50px
ToolTip | Description Specifies the WebToolBar tooltip. ValueType String Default Value Empty string
TextAlign | Description Specifies the ToolCommand text align type. ValueType String Default Value Default
DisplayMode | Description Specifies the ToolCommand display mode. ValueType String Default Value Default

WebToolBar Methods
UnregisterAccessKeys Description
Unregisters access keys from command items.

Parameters

Remarks

Return Value
void

Samples

RegisterAccessKeys Description
Registers access keys for command items.

Parameters

Remarks

Return Value
void

Samples

GetOrientation Description
Gets WebToolBar orientation

Parameters

Remarks

Return Value
String. Horizontal or Vertical

Samples

SetCaption Description
Sets WebToolBar caption

Parameters
caption ( String )
WebToolBar caption paramater
null

Remarks

Return Value
void

Samples

SetDisplayToolTip Description
Sets WebToolBar DisplayToolTip

Parameters
val ( String )
no default

Remarks

Return Value
void

Samples

SetAllowMove Description
Sets WebToolBar AllowMove

Parameters
val ( String )
no default

Remarks

Return Value
void

Samples

SetToolTip Description
Sets WebToolBar ToolTip

Parameters
tooltips ( String )
no default

Remarks

Return Value
void

Samples

SetDisplay Description
Sets WebToolBar Display

Parameters
val ( Boolean )
no default

Remarks

Return Value
void

Samples

SetIsFloat Description
Sets WebToolBar floating dock behavior.

Parameters
val ( String )
No default (required)

Remarks

Return Value

Samples

ShowCommand Description
Show WebToolBar command

Parameters
cmd ( ToolCommand object )
no default
updateContainerDimension ( Boolean )
Update container (WebToolBar) dimension when Command is showed.
False

Remarks

Return Value
void

Samples

HideCommand Description
Hide WebToolBar command

Parameters
cmd ( ToolCommand object )
no default
updateContainerDimension ( Boolean )
Update container (WebToolBar) dimension when Command is hided.
False

Remarks

Return Value
void

Samples

AddCommand Description
Add Command to existing ToolCommandCollection

Parameters
cmd ( ToolCommand object )
no default
idx ( Number )
Last collection index

Remarks

Return Value
void

Samples

RemoveCommand Description
Remove Command from ToolCommandCollection

Parameters
cmd ( ToolCommand object )
no default

Remarks

Return Value
void

Samples

EnableCommand Description
Enabling group of Commands

Parameters
c ( ToolCommand or Array of ToolCommands )
no default

Remarks

Return Value
void

Samples

DisableCommand Description
Disabling group of Commands

Parameters
c ( ToolCommand or Array of ToolCommands )
no default

Remarks

Return Value
void

Samples

UpdateUI Description
Apply immediately all UI changes.

Parameters
updateContainerDimension ( Boolean )
Update container (WebToolBar) dimension.
False

Remarks

Return Value
void

Samples

ResetUsageData Description
Reset ToolCommands setting to original setting.

Parameters

Remarks

Return Value
void

Samples


ToolCommand

ToolCommand
Send Feedback
Intersoft WebDesktop > Client-side References > ToolCommand

Glossary Item Box

ToolCommand Properties

ClassName | Description Gets the object class name. ValueType String Default Value ToolCommand
AutoPostBack | Description Gets or sets a value that indicates whether a Command is autopostback. ValueType String Default Value No
DisplayToolTip | Description Gets a value that indicates whether command tooltip is displayed. ValueType String Default Value Default
ToolTip | Description Specifies command tooltip. ValueType String Default Value Empty String
TextAlign | Description Gets the Command text align type. ValueType String Default Value Default
DisplayMode | Description Gets the Command display mode. ValueType String Default Value Default
Pushed | Description Gets a value that indicates whether a Command is pushed. ValueType Boolean Default Value False
AutoCheck | Description ValueType Default Value
Checked | Description ValueType Default Value
IsEnabled | Description Gets a value that indicates whether a Command is enabled. ValueType String Default Value Default
Visible | Description Gets a value that indicates whether a Command is visibled. ValueType String Default Value Default
Image | Description Specifies command image file name. ValueType String Default Value null
Text | Description Specifies command text. ValueType String Default Value null
Category | Description Specifies command category. ValueType String Default Value null
Type | Description Gets command type. ValueType String Default Value Button
Name | Description Gets or sets command name ValueType String Default Value no default
Index | Description Gets command index. ValueType Number Default Value -1
ImageSize | Description Specifies the Command image size. ValueType UnitSize object Default Value 16,16
AccessKey | Description Gets the keyboard shortcut key for setting focus to the Command. ValueType string Default Value
MergeCommandID | Description Specifies the Merge Command ID. ValueType String Default Value null
Menu | Description Gets or sets command menu implementation. ValueType WebMenu object Default Value null
Items | Description Gets command menu item collection. ValueType WebMenuItemCollection object Default Value null
SelectedMenuItem | Description Gets selected menu item. ValueType WebMenu object. Default Value null

ToolCommand Methods
SetDisplayToolTip Description
Sets Command display tooltip

Parameters
val ( Boolean )
no default (required)

Remarks

Return Value
void

Samples

Clone Description
Clone Command

Parameters
newBar ( WebToolBar object )
no default (required)

Remarks
Clone command with its structure , add it to new WebToolBar.

Return Value
ToolCommand object

Samples

SetVisible Description
Sets Command visibility.

Parameters
val ( String )
visible value (Default, Yes, No)
no default (required)
batchUIUpdate ( Boolean )
False

Remarks

Return Value
void

Samples

UpdateUI Description
Apply immediately command UI changes.

Parameters
updateContainerDimension ( Boolean )
Update container (WebToolBar) dimension.
False

Remarks

Return Value
void

Samples

Reset Description
Reset ToolCommand setting to original setting.

Parameters

Remarks

Return Value

Samples

SetIsEnabled Description
Sets Command enability.

Parameters
v ( Boolean )
no default

Remarks

Return Value
void

Samples

OnClick Description
Emulate onclick event programmatically.

Parameters

Remarks

Return Value
void

Samples


MenuCommand

MenuCommand
Send Feedback
Intersoft WebDesktop > Client-side References > MenuCommand

Glossary Item Box

MenuCommand Properties

ClassName | Description Gets the object class name. ValueType String Default Value MenuCommand
AutoPostBack | Description Gets or sets a value that indicates whether a Command is autopostback. ValueType String Default Value No
DisplayToolTip | Description Gets a value that indicates whether command tooltip is displayed. ValueType String Default Value Default
ToolTip | Description Specifies command tooltip. ValueType String Default Value Empty String
TextAlign | Description Gets the Command text align type. ValueType String Default Value Default
DisplayMode | Description Gets the Command display mode. ValueType String Default Value Default
IsEnabled | Description Gets a value that indicates whether a Command is enabled. ValueType String Default Value Default
Visible | Description Gets a value that indicates whether a Command is visibled. ValueType String Default Value Default
Image | Description Specifies command image file name. ValueType String Default Value null
Text | Description Specifies command text. ValueType String Default Value null
Type | Description Gets command type. ValueType String Default Value Normal
Name | Description Gets or sets command name ValueType String Default Value no default
Index | Description Gets command index. ValueType Number Default Value -1
ImageSize | Description Specifies the Command image size. ValueType UnitSize object Default Value 16,16
AccessKey | Description Gets the keyboard shortcut key for setting focus to the Command. ValueType string Default Value
Menu | Description Gets or sets command menu implementation. ValueType WebMenu object Default Value null
Items | Description Gets command menu item collection. ValueType WebMenuItemCollection object Default Value null
SelectedMenuItem | Description Gets selected menu item. ValueType WebMenu object. Default Value null

MenuCommand Methods
SetDisplayToolTip Description
Sets Command display tooltip

Parameters
val ( Boolean )
no default (required)

Remarks

Return Value
void

Samples

Clone Description
Clone Command

Parameters
newBar ( WebMenuBar object )
no default (required)

Remarks
Clone command with its structure , add it to new WebMenuBar.

Return Value
MenuCommand object

Samples

SetVisible Description
Sets Command visibility.

Parameters
val ( String )
visible value (Default, Yes, No)
no default (required)
batchUIUpdate ( Boolean )
False

Remarks

Return Value
void

Samples

UpdateUI Description
Apply immediately command UI changes.

Parameters
updateContainerDimension ( Boolean )
Update container (WebMenuBar) dimension.
False

Remarks

Return Value
void

Samples

Reset Description
Reset MenuCommand setting to original setting.

Parameters

Remarks

Return Value

Samples

SetIsEnabled Description
Sets Command to be enabled.
Parameters
v ( Boolean )
no default

Remarks

Return Value
void

Samples

OnClick Description
Emulate onclick event programmatically.

Parameters

Remarks

Return Value
void

Samples

OnPostBackClick Description
Emulate onpostbackclick event programmatically.

Parameters

Remarks

Return Value
void

Samples

Select Description
Sets active and highlight this menu item.

Parameters

Remarks

Return Value
void

Samples

GetPreviousNormalMenu Description
Gets previous menu item.

Parameters

Remarks

Return Value
void

Samples

GetNextNormalMenu Description
Gets next menu item.

Parameters

Remarks

Return Value
void

Samples


PlaceHolderManager Global Functions
Send Feedback
Intersoft WebDesktop > Client-side References > PlaceHolderManager Global Functions

Glossary Item Box

PlaceHolderManager Global Functions
InitPlaceHolderManager Description
Creates PlaceHolderManager object with its default settings from server side, attach PlaceHolder behaviors, and initialize it.

Parameters
id ( String )
PlaceHolderManager client side control ID (same as server side ID)

Return Value

Object (PlaceHolderManager)

Samples

WebToolBarStyleSettings Description
Creates WebToolBarStyleSettings object.

Return Value
Object (WebToolBarStyleSettings)

Samples

WebMenuBarStyleSettings Description
Creates WebMenuBarStyleSettings object.

Return Value
Object (WebMenuBarStyleSettings)

Samples


WebToolBar Global Functions
Send Feedback
Intersoft WebDesktop > Client-side References > WebToolBar Global Functions

Glossary Item Box

WebToolBar Global Functions
InitWebToolBar Description
Creates WebToolBar object with its default settings from server side, attach WebToolBar behaviors, and initialize it.

Parameters
id ( String )
WebToolBar client side control ID (same as server side ID)
phmId ( String )
PlaceHolderManager ID parameter. It is used internally for Merged WebToolBar.

Return Value
object (WebToolBar)

Samples

CommandClientSideEvents Description
Creates CommandClientEvents object with default settings, no behaviors attach and no initialized.

Return Value
object (CommandClientEvents)

Samples


PlaceHolderManager

PlaceHolderManager
Send Feedback

Glossary Item Box


PlaceHolderManager Properties

PlaceHolderManager Properties
Send Feedback

Glossary Item Box

PlaceHolderManager Properties

ClassName | Description Gets the object class name. ValueType String Default Value PlaceHolderManager
IsDefaultPagePlaceHolder | Description Gets a value whether a placeholder is a default placeholder for a page. ValueType Boolean Default Value False
PlaceHolderContainer | Description Gets container ID for placeholder manager. ValueType String Default Value Empty String
EnableMergeBar | Description Gets or sets a value that indicates whether merged Bar allow to be added to PlaceHolderManager. ValueType Boolean Default Value False
Bars | Description Gets the collection of Bar controls in this PlaceHolderManager. ValueType ISArray object Default Value array
WebToolBarStyleSettings | Description Gets or sets the style properties of WebToolBar control managed by PlaceHolderManager. ValueType WebToolBarStyleSettings object Default Value object
WebMenuBarStyleSettings | Description Gets or sets the style properties of WebMenuBar control managed by PlaceHolderManager. ValueType WebMenuBarStyleSettings object Default Value object
SizeMode | Description Gets the command sizing mode. ValueType String Default Value Automatic
AllowMove | Description Gets or sets a value that indicates whether Bar controls in PlaceHolderManager is moveable. ValueType String Default Value Yes
HandleVisible | Description Gets a value that indicates whether a Bar handle section in PlaceHolderManager is visible. ValueType String Default Value Yes
AllowCustomize | Description Gets or sets a value that indicates whether Bar controls in PlaceHolderManager is customizeable. ValueType String Default Value Yes
AllowDockBottom | Description Gets or sets a value that indicates whether Bar controls in PlaceHolderManager can be dock to bottom area of PlaceHolderManager. ValueType String Default Value Yes
AllowDockLeft | Description Gets or sets a value that indicates whether Bar controls in PlaceHolderManager can be dock to left area of PlaceHolderManager. ValueType String Default Value Yes
AllowDockRight | Description Gets or sets a value that indicates whether Bar controls in PlaceHolderManager can be dock to right area of PlaceHolderManager. ValueType String Default Value Yes
AllowDockTop | Description Gets or sets a value that indicates whether Bar controls in PlaceHolderManager can be dock to top area of PlaceHolderManager. ValueType String Default Value Yes
AllowExpandCollapse | Description Gets or sets a value that indicates whether Bar controls in PlaceHolderManager is expandable and collapseable. ValueType String Default Value Yes
AllowFloat | Description Gets or sets a value that indicates whether Bar controls in PlaceHolderManager is floatable. ValueType String Default Value Yes
DockingArea | Description Gets Bars docking area. ValueType String Default Value Top
DockingOffset | Description Gets a Bar docking offset. ValueType Number Default Value 0
FillDockingRow | Description Gets a value that indicates whether Bar controls dimension in PlaceHolderManager fills the row region of PlaceHolderManager docking row. ValueType String Default Value Yes
MaxDockingRows | Description Gets maximum docking rows for docking area. ValueType Number Default Value 2
DisplayToolTip | Description Gets or sets a value that indicates whether a Bar tooltip control in PlaceHolderManager is displayed. ValueType String Default Value Yes
TextAlign | Description Gets Bar commands text align type. ValueType String Default Value Right
DisplayMode | Description Gets Bar commands display mode. ValueType String Default Value Text
CommandSize | Description Gets Bar commands size. ValueType String Default Value 50px
IntegratedTo | Description Gets or sets the PlaceHolderManager menu integrated mode. ValueType String Default Value None
MenuStyleSettings | Description Gets or sets the style properties of menu styles in the bar control. ValueType WebMenuStyles object Default Value object


PlaceHolderManager Methods

PlaceHolderManager Methods
Send Feedback

Glossary Item Box

PlaceHolderManager Methods

SetDisplayToolTip Description
Sets Bars DisplayToolTip property

Parameters
val ( String )
DisplayToolTip value
no default (required)

Remarks

Return Value

void

Samples
GetCustomizeWindow

Description
Gets customize window object

Parameters

Remarks

Return Value

CustomizeWindowBAR object

Samples
ShowCustomizeWindow

Description
Show customize window

Parameters

Remarks

Return Value

void

Samples
RegisterBar Description
Register runtime bar object into PlaceHolderManager

Parameters
bar ( Bar object (WebToolBar object or WebMenuBar object) )
no default (required)

Remarks

Return Value

void

Samples
UnRegisterBar Description
Unregister runtime bar object from PlaceHolderManager

Parameters
bar ( Bar object (WebToolBar object or WebMenuBar object) )
no default (required)

Remarks

Return Value

void

Samples
ResetUsageData

Description
Reset all bars usage data

Parameters

Remarks

Return Value

void

Samples
AdjustDimension

Description
Adjust PlaceHolderManager layout dimension

Parameters

Remarks

Return Value

void

Samples


WebToolBar Properties

WebToolBar Properties
Send Feedback

Glossary Item Box

WebToolBar Properties

ClassName | Description Gets the object class name. ValueType String Default Value WebToolBar
Caption | Description Specifies the bar caption. ValueType String Default Value null
Commands | Description Gets the collection of tool commands in this webtoolbar. ValueType ISArray object Default Value array
Display | Description Gets a value that indicates whether a WebToolBar control is displayed as UI on the page. ValueType Boolean Default Value True
MergeToolBar | Description Gets a value that indicates whether a WebToolBar control is a merge webtoolbar. ValueType Boolean Default Value False
CommandClientSideEvents | Description Specifies the client side (JavaScript) tool command events. ValueType CommandClientEvents object Default Value null
SizeMode | Description Gets the tool command sizing mode. ValueType String Default Value Automatic
AllowMove | Description Gets or sets a value that indicates whether a WebToolBar control is moveable. ValueType String Default Value Default
AllowCustomize | Description Gets a value that indicates whether a WebToolBar control is customizeable. ValueType String Default Value Default
AllowDockBottom | Description Gets or sets a value that indicates whether a WebToolBar control can be dock to bottom area of PlaceHolderManager. ValueType String Default Value Default
AllowDockLeft | Description Gets or sets a value that indicates whether a WebToolBar control can be dock to left area of PlaceHolderManager. ValueType String Default Value Default
AllowDockRight | Description Gets or sets a value that indicates whether a WebToolBar control can be dock to right area of PlaceHolderManager. ValueType String Default Value Default
AllowDockTop | Description Gets or sets a value that indicates whether a WebToolBar control can be dock to top area of PlaceHolderManager. ValueType String Default Value Default
AllowExpandCollapse | Description Gets or sets a value that indicates whether a WebToolBar control is expandable and collapseable. ValueType String Default Value Default
AllowFloat | Description Gets or sets a value that indicates whether a WebToolBar control is floatable. ValueType String Default Value Default
DockingArea | Description Gets the WebToolBar docking area. ValueType String Default Value NotSet
DockingOffset | Description Gets the WebToolBar docking offset. ValueType Number Default Value 0
DockingRow | Description Gets the WebToolBar docking row. ValueType Number Default Value 0
FillDockingRow | Description Gets a value that indicates whether a WebToolBar control dimension fills the row region of PlaceHolderManager docking row. ValueType String Default Value Yes
ToggleGroups | Description Gets the collection of toggle group commands in this webtoolbar. ValueType ISArray object Default Value array
HandleStyle | Description Gets or sets the style properties of handle bar section in the bar control. ValueType BarSectionStyle object Default Value object
BodyStyle | Description Gets or sets the style properties of body bar section in the bar control. ValueType BarSectionStyle object Default Value object
OptionStyle | Description Gets or sets the style properties of option bar section in the bar control. ValueType BarSectionStyle object Default Value object
CommandStyle | Description Gets or sets the style properties of command in the bar control. ValueType DynamicStyle object Default Value object
SeparatorStyle | Description Gets or sets the style properties of separator command in the bar control. ValueType String Default Value Empty string
ShowDelay | Description Gets or sets the amount of submenu show delay in miliseconds. ValueType Number Default Value 500
MenuStyleSettings | Description Gets or sets the style properties of menu styles in the bar control. ValueType WebMenuStyles object Default Value object
CommandSize | Description Specifies the ToolCommand size. ValueType String Default Value 50px
ToolTip | Description Specifies the WebToolBar tooltip. ValueType String Default Value Empty string
TextAlign | Description Specifies the ToolCommand text align type. ValueType String Default Value Default
DisplayMode | Description Specifies the ToolCommand display mode. ValueType String Default Value Default


WebToolBar Methods

WebToolBar Methods
Send Feedback

Glossary Item Box

WebToolBar Methods

UnregisterAccessKeys Description
Unregisters access keys from command items.

Parameters

Remarks

Return Value
void

Samples

RegisterAccessKeys Description
Registers access keys for command items.

Parameters

Remarks

Return Value
void

Samples

GetOrientation Description
Gets WebToolBar orientation

Parameters

Remarks

Return Value
String. Horizontal or Vertical

Samples

SetCaption Description
Sets WebToolBar caption

Parameters
caption ( String )
WebToolBar caption paramater
null

Remarks

Return Value
void

Samples

SetDisplayToolTip Description
Sets WebToolBar DisplayToolTip

Parameters
val ( String )
no default

Remarks

Return Value
void

Samples

SetAllowMove Description
Sets WebToolBar AllowMove

Parameters
val ( String )
no default

Remarks

Return Value
void

Samples

SetToolTip Description
Sets WebToolBar ToolTip

Parameters
tooltips ( String )
no default

Remarks

Return Value
void

Samples

SetDisplay Description
Sets WebToolBar Display

Parameters
val ( Boolean )
no default

Remarks

Return Value
void

Samples

SetIsFloat Description
Sets WebToolBar floating dock behavior.

Parameters
val ( String )
No default (required)

Remarks

Return Value

Samples

ShowCommand Description
Show WebToolBar command

Parameters
cmd ( ToolCommand object )
no default
updateContainerDimension ( Boolean )
Update container (WebToolBar) dimension when Command is showed.
False

Remarks

Return Value
void

Samples

HideCommand Description
Hide WebToolBar command

Parameters
cmd ( ToolCommand object )
no default
updateContainerDimension ( Boolean )
Update container (WebToolBar) dimension when Command is hided.
False

Remarks

Return Value
void

Samples

AddCommand Description
Add Command to existing ToolCommandCollection

Parameters
cmd ( ToolCommand object )
no default
idx ( Number )
Last collection index

Remarks

Return Value
void

Samples

RemoveCommand Description
Remove Command from ToolCommandCollection

Parameters
cmd ( ToolCommand object )
no default

Remarks

Return Value
void

Samples

EnableCommand Description
Enabling group of Commands

Parameters
c ( ToolCommand or Array of ToolCommands )
no default

Remarks

Return Value
void

Samples

DisableCommand Description
Disabling group of Commands

Parameters
c ( ToolCommand or Array of ToolCommands )
no default

Remarks

Return Value
void

Samples

UpdateUI Description
Apply immediately all UI changes.

Parameters
updateContainerDimension ( Boolean )
Update container (WebToolBar) dimension.
False

Remarks

Return Value
void

Samples

ResetUsageData Description
Reset ToolCommands setting to original setting.

Parameters

Remarks

Return Value
void

Samples


ToolCommand

ToolCommand
Send Feedback

Glossary Item Box


ToolCommand Properties

ToolCommand Properties
Send Feedback

Glossary Item Box

ToolCommand Properties

ClassName | Description Gets the object class name. ValueType String Default Value ToolCommand
AutoPostBack | Description Gets or sets a value that indicates whether a Command is autopostback. ValueType String Default Value No
DisplayToolTip | Description Gets a value that indicates whether command tooltip is displayed. ValueType String Default Value Default
ToolTip | Description Specifies command tooltip. ValueType String Default Value Empty String
TextAlign | Description Gets the Command text align type. ValueType String Default Value Default
DisplayMode | Description Gets the Command display mode. ValueType String Default Value Default
Pushed | Description Gets a value that indicates whether a Command is pushed. ValueType Boolean Default Value False
AutoCheck | Description ValueType Default Value
Checked | Description ValueType Default Value
IsEnabled | Description Gets a value that indicates whether a Command is enabled. ValueType String Default Value Default
Visible | Description Gets a value that indicates whether a Command is visibled. ValueType String Default Value Default
Image | Description Specifies command image file name. ValueType String Default Value null
Text | Description Specifies command text. ValueType String Default Value null
Category | Description Specifies command category. ValueType String Default Value null
Type | Description Gets command type. ValueType String Default Value Button
Name | Description Gets or sets command name ValueType String Default Value no default
Index | Description Gets command index. ValueType Number Default Value -1
ImageSize | Description Specifies the Command image size. ValueType UnitSize object Default Value 16,16
AccessKey | Description Gets the keyboard shortcut key for setting focus to the Command. ValueType string Default Value
MergeCommandID | Description Specifies the Merge Command ID. ValueType String Default Value null
Menu | Description Gets or sets command menu implementation. ValueType WebMenu object Default Value null
Items | Description Gets command menu item collection. ValueType WebMenuItemCollection object Default Value null
SelectedMenuItem | Description Gets selected menu item. ValueType WebMenu object. Default Value null


ToolCommand Methods

ToolCommand Methods
Send Feedback

Glossary Item Box

ToolCommand Methods

SetDisplayToolTip Description
Sets Command display tooltip

Parameters
val ( Boolean )
no default (required)

Remarks

Return Value
void

Samples

Clone Description
Clone Command

Parameters
newBar ( WebToolBar object )
no default (required)

Remarks
Clone command with its structure , add it to new WebToolBar.

Return Value
ToolCommand object

Samples

SetVisible Description
Sets Command visibility.

Parameters
val ( String )
visible value (Default, Yes, No)
no default (required)
batchUIUpdate ( Boolean )
False

Remarks

Return Value
void

Samples

UpdateUI Description
Apply immediately command UI changes.

Parameters
updateContainerDimension ( Boolean )
Update container (WebToolBar) dimension.
False

Remarks

Return Value
void

Samples

Reset Description
Reset ToolCommand setting to original setting.

Parameters

Remarks

Return Value

Samples

SetIsEnabled Description
Sets Command enability.

Parameters
v ( Boolean )
no default

Remarks

Return Value
void

Samples

OnClick Description
Emulate onclick event programmatically.

Parameters

Remarks

Return Value
void

Samples


WebMenuBar Global Functions
Send Feedback
Intersoft WebDesktop > Client-side References > WebMenuBar Global Functions

Glossary Item Box

WebMenuBar Global Functions
InitWebMenuBar Description
Creates WebMenuBar object with its default settings from server side, attach WebMenuBar behaviors, and initialize it.

Parameters
id ( String )
WebMenuBar client side control ID (same as server side ID)

Return Value
object (WebMenuBar)

Samples

CommandClientSideEvents Description
Creates CommandClientEvents object with default settings, no behaviors attach and no initialized.

Return Value
object (CommandClientEvents)

Samples


WebMenuBar Properties

WebMenuBar Properties
Send Feedback

Glossary Item Box

WebMenuBar Properties

ClassName | Description Gets the object class name. ValueType String Default Value WebMenuBar
RequiredFrameworkVersion | Description ValueType Default Value
AccessKey | Description ValueType Default Value
Caption | Description Specifies the bar caption. ValueType String Default Value null
Menus | Description Gets the collection of menu commands in this webmenubar. ValueType ISArray object Default Value array
Display | Description Gets a value that indicates whether a WebMenuBar control is displayed as UI on the page. ValueType Boolean Default Value True
Visible | Description ValueType Default Value
CommandClientSideEvents | Description Specifies the client side (JavaScript) menu command events. ValueType CommandClientEvents object Default Value null
Enabled | Description Gets or sets a value indicating enable state of control. ValueType Boolean Default Value True
ActiveMenu | Description Gets the activated/selected menu. ValueType WebMenuItem object Default Value null
Index | Description ValueType Default Value
SizeMode | Description Gets the tool command sizing mode. ValueType String Default Value Automatic
AllowMove | Description Gets or sets a value that indicates whether a WebMenuBar control is moveable. ValueType String Default Value Default
HandleVisible | Description Gets or sets a value that indicates whether a WebMenuBar handle section is visible. ValueType String Default Value Default
AllowCustomize | Description Gets a value that indicates whether a WebMenuBar control is customizeable. ValueType String Default Value Default
AllowDockBottom | Description Gets or sets a value that indicates whether a WebMenuBar control can be dock to bottom area of PlaceHolderManager. ValueType String Default Value Default
AllowDockLeft | Description Gets or sets a value that indicates whether a WebMenuBar control can be dock to left area of PlaceHolderManager. ValueType String Default Value Default
AllowDockRight | Description Gets or sets a value that indicates whether a WebMenuBar control can be dock to right area of PlaceHolderManager. ValueType String Default Value Default
AllowDockTop | Description Gets or sets a value that indicates whether a WebMenuBar control can be dock to top area of PlaceHolderManager. ValueType String Default Value Default
AllowExpandCollapse | Description Gets or sets a value that indicates whether a WebMenuBar control is expandable and collapseable. ValueType String Default Value Default
AllowFloat | Description Gets or sets a value that indicates whether a WebMenuBar control is floatable. ValueType String Default Value Default
DockingArea | Description Gets the WebMenuBar docking area. ValueType String Default Value NotSet
DockingOffset | Description Gets the WebMenuBar docking offset. ValueType Number Default Value 0
DockingRow | Description Gets the WebMenuBar docking row. ValueType Number Default Value 0
FillDockingRow | Description Gets a value that indicates whether a WebMenuBar control dimension fills the row region of PlaceHolderManager docking row. ValueType String Default Value Yes
HandleStyle | Description Gets or sets the style properties of handle bar section in the bar control. ValueType BarSectionStyle object Default Value null
BodyStyle | Description Gets or sets the style properties of body bar section in the bar control. ValueType BarSectionStyle object Default Value null
OptionStyle | Description Gets or sets the style properties of option bar section in the bar control. ValueType BarSectionStyle object Default Value null
CommandStyle | Description Gets or sets the style properties of command in the bar control. ValueType DynamicStyle object Default Value object
CommandFontStyle | Description ValueType Default Value
SeparatorStyle | Description Gets or sets the style properties of separator command in the bar control. ValueType String Default Value Empty string
ImageSize | Description Gets or sets image size. ValueType UnitSize object Default Value UnitSize (16px,16px)
ShowDelay | Description ValueType Default Value
MenuStyleSettings | Description Gets or sets the style properties of menu styles in the bar control. ValueType WebMenuStyles object Default Value object
AutoPostBack | Description Gets or sets a value that indicates whether a Command is autopostback. ValueType String Default Value No
CommandSize | Description Specifies the MenuCommand size. ValueType String Default Value 50px
DisplayToolTip | Description Gets or sets a value that indicates whether tooltip is displayed. ValueType Boolean Default Value True
ToolTip | Description Specifies the WebMenuBar tooltip. ValueType String Default Value Empty string
TextAlign | Description Specifies the MenuCommand text align type. ValueType String Default Value Default
DisplayMode | Description Specifies the MenuCommand display mode. ValueType String Default Value Default


WebMenuBar Methods

WebMenuBar Methods
Send Feedback

Glossary Item Box

WebMenuBar Methods

UnregisterAccessKeys Description
Unregisters access keys from menu items.

Parameters

Remarks

Return Value

Samples

RegisterAccessKeys Description
Registers access keys for menu items.

Parameters

Remarks

Return Value
void

Samples

GetOrientation Description
Gets WebMenuBar orientation

Parameters

Remarks

Return Value
String. Horizontal or Vertical

Samples

SelectMenu Description
Sets active and highlight a menu item.

Parameters
menu ( )

Remarks

Return Value
void

Samples

SelectPrevMenu Description
Sets active and highlight previous menu item.

Parameters

Remarks

Return Value
void

Samples

SelectNextMenu Description
Sets active and highlight next menu item.

Parameters

Remarks

Return Value
void

Samples

OnMenuKeyDown Description
Raises the menu keydown event of active menu item.

Parameters
keyCode ( Number )
event keyCode
null
activeMenu ( WebMenuItem object )
Menu that the event will be raised.
null

Remarks

Return Value
void

Samples

SetCaption Description
Sets WebMenuBar caption

Parameters
caption ( String )
WebMenuBar caption parameter
null

Remarks

Return Value
void

Samples

SetDisplayToolTip Description
Sets WebMenuBar DisplayToolTip

Parameters
val ( String )
no default

Remarks

Return Value
void

Samples

SetAllowMove Description
Sets WebMenuBar AllowMove

Parameters
val ( String )
no default

Remarks

Return Value
void

Samples

SetToolTip Description
Sets WebMenuBar ToolTip

Parameters
tooltips ( String )
no default

Remarks

Return Value
void

Samples

SetDisplay Description
Sets WebMenuBar Display

Parameters
val ( Boolean )
no default

Remarks

Return Value
void

Samples

SetIsFloat Description
Sets WebMenuBar floating dock behavior.

Parameters
val ( String )
No default (required)

Remarks

Return Value
void

Samples

ShowMenu Description
Show WebMenuBar menu

Parameters
cmd ( MenuCommand object )
no default
updateContainerDimension ( Boolean )
Update container (WebMenuBar) dimension when Command is showed.
False

Remarks

Return Value
void

Samples

HideMenu Description
Hide WebMenuBar menu

Parameters
cmd ( MenuCommand object )
no default
updateContainerDimension ( Boolean )
Update container (WebMenuBar) dimension when Command is hidden.
False

Remarks

Return Value
void

Samples

AddMenu Description
Add Command to existing MenuCommandCollection

Parameters
cmd ( MenuCommand object )
no default
idx ( Number )
Last collection index

Remarks

Return Value
void

Samples

RemoveMenu Description
Remove Command from MenuCommandCollection

Parameters
cmd ( MenuCommand object )
no default

Remarks

Return Value
void

Samples

EnableMenu Description
Enabling group of Menus

Parameters
c ( MenuCommand or Array of MenuCommands )
no default

Remarks

Return Value
void

Samples

DisableMenu Description
Disabling group of Menus

Parameters
c ( MenuCommand or Array of MenuCommands )
no default

Remarks

Return Value
void

Samples

UpdateUI Description
Apply immediately all UI changes.

Parameters
updateContainerDimension ( Boolean )
Update container (WebMenuBar) dimension.
False

Remarks

Return Value
void

Samples

ResetUsageData Description
Reset MenuCommands setting to original setting.

Parameters

Remarks

Return Value
void

Samples

HideAll Description
Hides all the WebMenuBar.

Parameters

Remarks

Return Value
void

Samples


MenuCommand Properties

MenuCommand Properties
Send Feedback

Glossary Item Box

MenuCommand Properties

ClassName | Description Gets the object class name. ValueType String Default Value MenuCommand
AutoPostBack | Description Gets or sets a value that indicates whether a Command is autopostback. ValueType String Default Value No
DisplayToolTip | Description Gets a value that indicates whether command tooltip is displayed. ValueType String Default Value Default
ToolTip | Description Specifies command tooltip. ValueType String Default Value Empty String
TextAlign | Description Gets the Command text align type. ValueType String Default Value Default
DisplayMode | Description Gets the Command display mode. ValueType String Default Value Default
IsEnabled | Description Gets a value that indicates whether a Command is enabled. ValueType String Default Value Default
Visible | Description Gets a value that indicates whether a Command is visibled. ValueType String Default Value Default
Image | Description Specifies command image file name. ValueType String Default Value null
Text | Description Specifies command text. ValueType String Default Value null
Type | Description Gets command type. ValueType String Default Value Normal
Name | Description Gets or sets command name ValueType String Default Value no default
Index | Description Gets command index. ValueType Number Default Value -1
ImageSize | Description Specifies the Command image size. ValueType UnitSize object Default Value 16,16
AccessKey | Description Gets the keyboard shortcut key for setting focus to the Command. ValueType string Default Value
Menu | Description Gets or sets command menu implementation. ValueType WebMenu object Default Value null
Items | Description Gets command menu item collection. ValueType WebMenuItemCollection object Default Value null
SelectedMenuItem | Description Gets selected menu item. ValueType WebMenu object. Default Value null


MenuCommand Methods

MenuCommand Methods
Send Feedback

Glossary Item Box

MenuCommand Methods

SetDisplayToolTip Description
Sets Command display tooltip

Parameters
val ( Boolean )
no default (required)

Remarks

Return Value
void

Samples

Clone Description
Clone Command

Parameters
newBar ( WebMenuBar object )
no default (required)

Remarks
Clone command with its structure , add it to new WebMenuBar.

Return Value
MenuCommand object

Samples

SetVisible Description
Sets Command visibility.

Parameters
val ( String )
visible value (Default, Yes, No)
no default (required)
batchUIUpdate ( Boolean )
False

Remarks

Return Value
void

Samples

UpdateUI Description
Apply immediately command UI changes.

Parameters
updateContainerDimension ( Boolean )
Update container (WebMenuBar) dimension.
False

Remarks

Return Value
void

Samples

Reset Description
Reset MenuCommand setting to original setting.

Parameters

Remarks

Return Value

Samples

SetIsEnabled Description
Sets Command to be enabled.
Parameters
v ( Boolean )
no default

Remarks

Return Value
void

Samples

OnClick Description
Emulate onclick event programmatically.

Parameters

Remarks

Return Value
void

Samples

OnPostBackClick Description
Emulate onpostbackclick event programmatically.

Parameters

Remarks

Return Value
void

Samples

Select Description
Sets active and highlight this menu item.

Parameters

Remarks

Return Value
void

Samples

GetPreviousNormalMenu Description
Gets previous menu item.

Parameters

Remarks

Return Value
void

Samples

GetNextNormalMenu Description
Gets next menu item.

Parameters

Remarks

Return Value
void

Samples


WebFlyPostBackManager Global Functions
Send Feedback
Intersoft WebDesktop > Client-side References > WebFlyPostBackManager Global Functions

Glossary Item Box

WebFlyPostBackManager Global Functions
InitWebFlyPostBackManager Description
Creates WebFlyPostBackManager object

Parameters
id ( String )
The identifier of WebFlyPostBackManager control.

Return Value

Samples


WebFlyPostBackManager

WebFlyPostBackManager
Send Feedback

Glossary Item Box


WebFlyPostBackManager Properties

WebFlyPostBackManager Properties
Send Feedback

Glossary Item Box

WebFlyPostBackManager Properties

ClassName | Description Gets the class name of WebFlyPostBackManager's type name. ValueType String Default Value WebFlyPostBackManager
Asynchronous | Description Gets or sets the value to indicate whether OnTheFlyPostBack is done asynchronously. ValueType Boolean Default Value
AutoLoadMetaData | Description Gets or sets the value to indicate whether or not the metadata is automatically loaded on page load. ValueType Boolean Default Value
AutoEventWireup | Description Gets or sets the value to indicate whether or not functions are directly wired up to related server side events. ValueType Boolean Default Value
ClientSideEvents | Description Gets the ClientSideEvents object. ValueType Object Default Value
Metadata | Description Gets the MetaData object in XML form. ValueType Object Default Value
TimeoutInterval | Description Gets or sets the value to indicate a timeout interval for a specified request (in seconds). ValueType Int Default Value


WebFlyPostBackManager Methods

WebFlyPostBackManager Methods
Send Feedback

Glossary Item Box

WebFlyPostBackManager Methods

Invoke Description
Invokes the specified method.

Parameters
methodName ( String )
Indicates the requested method name.
params ( params )
Indicates the parameters value for the specified method name.

Remarks

Return Value

Samples

GetStatus Description
Returns the request status of the invoked method.

Parameters
methodName ( String )
Indicates the requested method name.

Remarks

Return Value
String

Samples

Abort Description
Aborts the method that is requested.

Parameters
methodName ( String )
Indicates the requested method name.

Remarks

Return Value

Samples

IsMethodExist Description
Determines whether or not a method exists in metadata.

Parameters

Remarks

Return Value
Boolean

Samples

InvokeCustomAction Description

Parameters
actionName ( )
xmlData ( )

Remarks

Return Value

Samples

IsBusy Description
Determines whether or not the method status is Invoking or Response.

Parameters
methodName ( String )
Indicates the requested method name.

Remarks

Return Value
Boolean

Samples


WebFlyPostBackManagerSettings

WebFlyPostBackManagerSettings
Send Feedback

Glossary Item Box


WebFlyPostBackManagerSettings Properties

WebFlyPostBackManagerSettings Properties
Send Feedback

Glossary Item Box

WebFlyPostBackManagerSettings Properties

PostHiddenFields | Description Gets or sets whether hidden fields should be posted to server during OnTheFlyPostBack. ValueType String Default Value
PostInputControls | Description Gets or sets whether HTML INPUT controls as well as SELECT and TEXTAREA should be posted to server during OnTheFlyPostBack. ValueType String Default Value
PostControlState | Description Gets or sets a value indicating whether this control's state should be posted during OnTheFlyPostBack. ValueType String Default Value


WebFlyPostBackManagerSettings Methods

WebFlyPostBackManagerSettings Methods
Send Feedback

Glossary Item Box


WebFlyPostBackManagerClientSideEvents

WebFlyPostBackManagerClientSideEvents
Send Feedback

Glossary Item Box


WebFlyPostBackManagerClientSideEvents Properties

WebFlyPostBackManagerClientSideEvents Properties
Send Feedback

Glossary Item Box

WebFlyPostBackManagerClientSideEvents Properties

OnError | Description Specifies the client-side function name that will be invoked when error occured during FlyPostBackManager request. ValueType String Default Value
OnResponse | Description Specifies the client-side function name that will be invoked when FlyPostBackManager request gets a response. ValueType String Default Value
OnResponseSuccess | Description Specifies the client side function name that will be invoked when FlyPostBackManager response completely succeeded. ValueType String Default Value
OnTimeout | Description Specifies the client side function name that will be invoked when FlyPostBackManager request gets a timeout. ValueType String Default Value


WebFlyPostBackManagerClientSideEvents Methods

WebFlyPostBackManagerClientSideEvents Methods
Send Feedback

Glossary Item Box


WebNotification Properties

WebNotification Properties
Send Feedback

Glossary Item Box

WebNotification Properties

Interval | Description Gets or sets the WebNotification's interval ValueType Int Default Value
DisplayLatency | Description Gets or sets the WebNotificaton's display latency ValueType Int Default Value
IntegratedToDesktopManager | Description Gets or sets the WebNotification integrated mode ValueType MenuIntegrationMode Default Value
ServiceType | Description Gets or sets the WebNotification's service type ValueType String Default Value
ServiceUrl | Description Gets or sets the WebNotification's service url ValueType String Default Value
DisplayMode | Description Gets or sets the WebNotification's display mode ValueType DisplayMode Default Value
ContentText | Description Gets or sets the WebNotification's content text ValueType String Default Value
ContentImage | Description Gets or sets the WebNotification's content image ValueType Image Default Value
CaptionText | Description Gets or sets the WebNotification's caption text ValueType String Default Value
ShowActionDropdown | Description Gets or sets a value indicating whether WebNotification should show drop down action ValueType Boolean Default Value
ShowCloseButton | Description Gets or sets a value indicating whether close button should be shown in this WebNotification instance ValueType Boolean Default Value
EnableSound | Description Gets or sets a value indicating whether sound should be enabled for this WebNotification instance ValueType Boolean Default Value
SoundFile | Description Gets or sets the sound file of this WebNotification instance ValueType String Default Value
AnimationStyle | Description Gets or sets the animation style of this WebNotification instance ValueType String Default Value
ImagePosition | Description Gets or sets the image's position in this WebNotification instance ValueType String Default Value
ImageVAlign | Description Gets or sets the image's vertical alignment of this WebNotification instance ValueType String Default Value
ImagesSettings | Description Gets the ImagesSettigns of this WebNotification instance ValueType ImagesSettings Default Value
ClientSideEvents | Description Gets the ClientSideEvents of this WebNotification instance ValueType WebNotificationClientSideEvents Default Value
MenuStyleSettings | Description Gets the MenuStyleSettings of this WebNotification instance ValueType MenuStyleSettings Default Value
Menu | Description Gets the Menu of this WebNotification instance ValueType WebMenu Default Value
Items | Description Gets or sets the items collection in this WebNotification instance ValueType Collection (ISArray) Default Value
Enabled | Description Gets or sets a value indicating whether this WebNofitication instance should be enabled ValueType Boolean Default Value
ClientID | Description Gets the server control identifier generated by ASP.NET ValueType String Default Value
ID | Description Gets or sets the programmatic identifier assigned to the WebNotification control instance ValueType String Default Value
NotifyWindowClickable | Description Gets or sets a value indicating whether this WebNotification will notify if the window is clickable ValueType Boolean Default Value
NotifyWindowURL | Description Gets or sets a value indicating whether this WebNofitication instance will notify the window url ValueType Boolean Default Value
NotifyWindowName | Description Gets or sets a value indicating whether this WebNofitication instance will notify the window's name ValueType Boolean Default Value
AutoStart | Description Gets or sets a value indicating whether this WebNofitication is automatically start ValueType Boolean Default Value
RunOnce | Description Gets or sets a value indicating whether this WebNofitication instance will run only once ValueType Boolean Default Value


WebNotification Methods

WebNotification Methods
Send Feedback

Glossary Item Box

WebNotification Methods

Show | Description Shows the specified WebNotification control. Parameters Remarks Return Value Samples
Hide | Description Hides the specified WebNotification control. Parameters Remarks Return Value Samples
Enable | Description Enables the state of WebNotification control. Parameters Remarks Return Value Samples
Disable | Description Disables the state of WebNotification control. Parameters Remarks Return Value Samples
GetCaptionElement | Description Gets the caption element of WebNotification control. Parameters Remarks Return Value Object (HTML CellElement) Samples
SetCaptionText | Description Sets the caption of WebNotification control. Parameters text ( String ) Indicates the caption text that will be applied. Remarks Return Value Samples
GetOptionElement | Description Gets the ActionDropDown element of WebNotification control. Parameters Remarks Return Value Object (HTML SpanElement) Samples
GetCloseElement | Description Gets the Close element of WebNotification control Parameters Remarks Return Value Object (HTML SpanElement) Samples
GetCaptionBarElement | Description Gets the Caption Bar element of WebNotification control. Parameters Remarks Return Value Object (HTML TableElement) Samples
GetContentElement | Description Gets the content element of WebNotification control. Parameters Remarks Return Value Object (HTML DivElement) Samples
GetContentTextElement | Description Gets the context text of WebNotification control. Parameters Remarks Return Value Object (HTML DivElement) Samples
GetContentImageElement | Description Gets the content image of WebNotification control. Parameters Remarks Return Value Object (HTML ImageElement) Samples
GetContentTemplateElement | Description Gets the content template element of WebNotification control. Parameters Remarks Return Value Object (HTML DivElement) Samples
GetCurrentNotification | Description Gets the current WebNotificationEvent object. Parameters Remarks Return Value Object (WebNotificationEvent) Samples
GetAllNotifications | Description Gets all the WebNotificationEvent objects in the WebNotification control. Parameters Remarks Return Value Object (WebNotificationEventCollection) Samples
GetLastNotification | Description Gets the last WebNotificationEvent object. Parameters Remarks Return Value Object (WebNotificationEvent) Samples
GetMissedNotifications | Description Gets missed WebNotificationEvent objects. Parameters Remarks Return Value Object (WebNotificationEventCollection) Samples
GetActionMenu | Description Gets the ActionMenu object of the WebNotification control. Parameters Remarks Return Value WebMenu object Samples
Notify | Description Notifies the specified WebNotificationEvent object. Parameters notification ( WebNotificationEvent ) Indicates the WebNotificationEvent that will be notified. Remarks Return Value Samples
GetSoundElement | Description Gets the sound element of WebNotification control. Parameters Remarks Return Value Object (HTML BgSoundElement) Samples


WebNotificationEventCollection Properties

WebNotificationEventCollection Properties
Send Feedback

Glossary Item Box

WebNotificationEventCollection Properties

Notifications | Description Specifies collection of WebNotifications in current session ValueType Object Default Value
HasData | Description Specifies whether the WebNotification has data or not ValueType Boolean Default Value


WebNotificationEventCollection Methods

WebNotificationEventCollection Methods
Send Feedback

Glossary Item Box


WebNotificationEvent Properties

WebNotificationEvent Properties
Send Feedback

Glossary Item Box

WebNotificationEvent Properties

ContentImage | Description Gets or sets the image content of the notification ValueType String Default Value
ContentText | Description Gets or sets the text content of the notification ValueType String Default Value
Properties | Description Specifies the custom properties to be passed from method to client ValueType Object Default Value
Shown | Description Gets or sets the WebNotification visibility ValueType Boolean Default Value
Clicked | Description Specifies whether the WebNotification is clicked or not ValueType Boolean Default Value
CaptionText | Description Gets or sets the caption text of the WebNotification ValueType String Default Value
NotifyURL | Description Gets or sets the URL for the WebNotification ValueType String Default Value


WebNotificationEvent Methods

WebNotificationEvent Methods
Send Feedback

Glossary Item Box


WebNotificationEventArgs Properties

WebNotificationEventArgs Properties
Send Feedback

Glossary Item Box

WebNotificationEventArgs Properties

Id | Description The ID of the control ValueType String Default Value
RawUrl | Description Specifies the service which is called by the WebNotification ValueType String Default Value
CustomData | Description Specifies the custom data of the WebNotification ValueType String Default Value


WebNotificationEventArgs Methods

WebNotificationEventArgs Methods
Send Feedback

Glossary Item Box


Property Properties

Property Properties
Send Feedback

Glossary Item Box

Property Properties

Key | Description The name of the property ValueType String Default Value
Value | Description The value of the named property ValueType String Default Value


WebNotificationClientSideEvents Properties

WebNotificationClientSideEvents Properties
Send Feedback

Glossary Item Box

WebNotificationClientSideEvents Properties

OnBeforeRequest | Description The javascript function that will be invoked before the control perform request. ValueType String Default Value
OnNotify | Description The javascript function that will be invoked when the control returns at least one notification. ValueType String Default Value
OnInitialize | Description The javascript function that will be invoked during control utilization. ValueType String Default Value
OnResponse | Description The javascript function that will be invoked after the control receives response from server. ValueType String Default Value
OnError | Description The javascript function that will be invoked when error is received during response. ValueType String Default Value
OnClick | Description The javascript function that will be invoked when user clicks on the notification window. ValueType String Default Value
OnClose | Description The javascript function that will be invoked when user closes the notification window. ValueType String Default Value
OnActionClick | Description The javascript function that will be invoked when user clicks on the Action dropdown button. ValueType String Default Value


WebNotificationClientSideEvents Methods

WebNotificationClientSideEvents Methods
Send Feedback

Glossary Item Box


WebNotificationImagesSettings Properties

WebNotificationImagesSettings Properties
Send Feedback

Glossary Item Box

WebNotificationImagesSettings Properties

CloseNormal | Description Gets or sets the image to represent Close button in normal mode ValueType Default Value
CloseOver | Description Gets or sets the image to represent Close button in over mode ValueType Default Value
CloseActive | Description Gets or sets the image to represent Close button in active mode ValueType Default Value
ActionNormal | Description Gets or sets the image to represent Action button in normal mode ValueType Default Value
ActionOver | Description Gets or sets the image to represent Action button in over mode ValueType Default Value
ActionActive | Description Gets or sets the image to represent Action button in active mode ValueType Default Value


Troubleshooting

Troubleshooting
Send Feedback
Intersoft WebDesktop > Troubleshooting

Glossary Item Box

This section contains troubleshooting in WebDesktop.NET.

In This Section

Frequently Asked Questions

Known Mozilla Issues


Frequently Asked Questions

Frequently Asked Questions
Send Feedback
Intersoft WebDesktop > Troubleshooting > Frequently Asked Questions

Glossary Item Box

Following is the compilation of most frequently asked questions applicable to WebDesktop.NET V1.0 or higher:

Q: Is there any way to close a window from server side code ? I have a login window and I need to close the login window on successful login
A: I don't think there is a way to close the window from server side because the WebDesktopManager instance is hosted on the different page as the content page. But you can easily do this by calling a client side script to close the Window after your successful login, such as by using RegisterClientScriptBlock or RegisterStartupScript methods.
Q: If I set up the WebDesktopWindow's size to have height of 100px and width of 300px, the window shows up with correct size according to the parameters, but the TitleBar does not extend all the way to the end of the window's width. There is enough place at the right of the TitleBar for the ScrollBar, but since my content is smaller than the window, no scrollbar appears. Hence, now I have a window which its width is slightly longer than the width of the window's TitleBar.
A: If your Window is using IFrame content mode, then the scrollbar should appear automatically. If you are using InlineContent as the content mode, the scrollbar should also appear automatically (by default). If it doesn't appear, you can check the ContainerStyle under WindowSettings, and ensure that the Overflow, OverflowX and OverflowY have been set to Auto.
Q: I have a desktop with a right and left TaskBar templates, and one window on the desktop. When I remove the window, the TaskBar no longer displays the templates.
A: Your TaskBar templates (left and right) require a DIV with specific width in order for the TaskBar to render properly.

E.g.

<TaskBarLeftTemplate>

<div style='width:250px'>

Your left template

</div>

</TaskBarLeftTemplate>

Q: How can I have an .aspx page running in the IFrame that has save/cancel buttons that will close the dialog?
A: To close a Window from client side, first, we have to get the Window object which host the IFrame's page by using ISGetCurrentWindow(). That method will return a WebDesktopWindow object. Next, in WebDesktopWindow APIs in the client side reference, there is a Close method, and you can use it like the following example.

E.g.

var wnd = ISGetCurrentWindow();
wnd.Close();

You can then easily call that function in your server side or AJAX call through RegisterClientScriptBlock method (avoid body onload).

Q: How to open a new window from another window?

I have a window that is an IFrame. I would like to open another window from the .aspx page in the IFrame window.

A: Basically you can use the same way as in Create new Window at client side tutorial. You will need to use ISGetDesktopManager() function to return the desktop manager instance at your children .aspx page.

E.g.

var dm = ISGetDesktopManager(); // return the WebDesktopManager instance
var newWindow = dm.CreateWindow(); // return the WebDesktopWindow instance
//initialize newWindow properties...
//add to the Window collection
//show the Window

The tutorial for this specific scenario will be included in the final version's tutorials.

Q: I try to run WebDesktopSamples/Default.aspx, in Internet Explorer it runs well, in FireFox 1.0.3 it displays fine, but no windows are displayed and I can't click on the shortcuts. In Opera 8.0, nothing is displayed (blank screen).
A: Mozilla 1.0.3 build has a regression bug, you will need to use Mozilla 1.0.4 or above.

WebDesktop supports all kind of Gecko-based browsers, but not Opera at the moment. We will support Opera when it has equal API as in IE and Gecko.

Q: On App_Customer.aspx I get error message like this:

Server Error in '/WebDesktopSamples' Application.

Compilation Error

Description: An error occurred during the compilation of a resource required to service this request. Please review the following specific error details and modify your source code appropriately.

Compiler Error Message: CS0117: 'ISNet.WebUI.WebGrid.WebGridTable' does not contain a definition for 'ReindexColumnsPosition'

A: You would require all latest product builds (December build) in order to run all samples.
Q: When I ran the sample application provided in the installation The windows have no style. Hence its all transparent and content of different windows overlap each other. The WebDesktop's Layout Manager doesn't work. Many problems everywhere.
A: You will need to update your application to use the latest WebUI.NET Framework. It requires version 3.0.5000.16

To ensure that you're running latest versions, try to go to the bin folder of the WebDesktopSamples, bring up the property window for ISNet.WebUI. If it turns out to be the problem ( you are not using the latest WebUI.NET Framework), you will need to update it first, then restart Visual Studio 2005 after copying the new DLL into the bin folder.

It is important that you uninstalled the old WebDesktopSamples property since if you are not uninstalled it properly the new files might not be replaced by the new file and it will caused you to use the old file instead the new one. Make sure when you uninstall the WebDesktop, all the files and folders under WebDesktop.NET installation files are removed, then install it again.

Q: I've noticed the response time for Maximizing/ Minimizing windows in IE is rather slow. While in Mozilla FireFox is much faster.
A: If you used too much gradient, then yes, it will be a bit slower when Minimize/Maximize specially when you enabled Animation. To optimize the performance, you can do either use gradient effectively or disable Window's Animation.


Known Mozilla Issues

Known Mozilla Issues
Send Feedback
Intersoft WebDesktop > Troubleshooting > Known Mozilla Issues

Glossary Item Box

This topic lists the known issues when using specific components in Mozilla browsers:

  • WebPaneManager

    When WebPaneManager is used in a WebForm that hosted in DesktopManager and when the Window is resized, the dimension of Pane which set to "Fill" is sometimes flicking and resizing improperly.

This issue has been certified as Mozilla bug and has not been resolved at the time of this writing.
For more information about this bug, please visit BugZilla

  • AccessKey and ShortcutKey

    Due to limitations in Mozilla browsers, some advanced accessibilities features are not working properly in Mozilla although some workaround have been implemented. The features can work properly when it is not conflicting with Mozilla-system keys.

    However, Mozilla planned to implement enhancements in accessibility areas in Mozilla 2.0. For more information, see Accessible DHTML (point 4)


Product Supports

Product Supports
Send Feedback
Intersoft WebDesktop > Product Supports

Glossary Item Box

This section contains product support in WebDesktop.NET.

In This Section

Bug Reports

Support Options


Bug Reports

Bug Reports
Send Feedback
Intersoft WebDesktop > Product Support > Bug Reports

Glossary Item Box

You can submit bugs using one of the following methods:

  • Email
    Please submit any bugs or product issues to webdesktopsupport@intersoftpt.com
  • Product Feedback
    Please login to Developer Network 2.0 and launch Community Center application. You can submit bugs in the Product Feedback tab, which is the third tab in the Community Center.
The preferred way to submit bugs, enhancements or feature requests is through Product Feedback. With Product Feedback, your submission will result in reward points. Moreover, you will be able to track and get notified when the bugs are resolved. Your submission will also be beneficial to other registered customers.

When submitting the bug report, make sure you have following information to avoid multiple communication roundtrip:

  • Product Edition (if applicable)
  • Full Product Version. Eg: 2.0.2007
  • Browsers (with Full Version, including Service Packs or HotFixes if any)
  • Operating System (with Full Version, including Service Packs or HotFixes if any)
  • Development Environment Products
  • Development Environment Versions
  • Affected Machines: Development, Production Server or Both
  • Monitors: Single or Dual

You also might need to provide issue-specific information such as:

  • Current result/behavior
  • Expected result/behavior
  • Steps to reproduce
  • Working/Compliable Samples


Support Options

Support Options
Send Feedback
Intersoft WebDesktop > Product Support > Support Options

Glossary Item Box

WebDesktop.NET 2.0 is developed and fully supported by Intersoft Solutions Corp. The company provides several methods for registered customers to obtain technical supports.

Things to consider before you contact us

In order to save everyone some time, we would like you to do a few things before you contact us:
  • Have you tried the Help's Index and Search function?
  • Have you looked at Tutorials, Concepts and Common Tasks in Products Documentation?
  • Have you searched the Knowledge Base?
  • Have you searched at the Forum, Workspace and Product Feedback in our Developer Network 2.0 site?
  • Are you using the latest assembly?

Online Support

All of WebDesktop.NET users have free access to our online support at www.intersoftpt.com which includes latest product updates, bug fixes, FAQ, hundreds of Knowledge Base Articles.

Standard Email Support

You can also send email to webdesktopsupport@intersoftpt.com for product trouble shooting or bugs. Please provide information on the product version, operating system name and version as well as your development environment and its version. Your email will be answered shortly by our technical support team.

The turnaround time for standard email support is 72 hours (at the latest).

Developer Network Support

The company provides rich web-based forums for registered customers. The forum will not be regularly monitored by our support team, but the main purpose is for our registered customers to exchange their ideas, knowledge and solutions regarding the product.

To access the Developer Network, please go to Intersoft website and click on Developer Network.

Login details are required to access Developer Network. Please refer to your original order receipt sent from Intersoft Accounts. If you do not get the automated order receipt, please contact accounts@intersoftpt.com

Priority Support Options

The NEW Priority Support option allows registered customers to obtain technical support via direct e-mail or telephone support from our Senior Support Engineer.

This option is designated for advanced customers who require faster response time. The inquiries types are mostly intermediate to advance involving application-specific scenarios, minor feature requests, quick patches and more.

For more information about the Priority Support pricing and online purchase, please visit Intersoft Solutions web site at http://www.intersoftpt.com

Phone Support

Phone Support is currently available only for registered customers who have purchased Priority Support. You can reach Technical Support through following numbers:

    +62 21 25556680
      +62 21 25556681
        Please have your UserID ready when calling.
        For pre-sales phone support, you may contact our Authorized Distributor at no costs.


Licensing

Licensing
Send Feedback
Intersoft WebDesktop > Licensing

Glossary Item Box

This section contains licensing in WebDesktop.NET.

In This Section

License Agreement

Copyright Info


License Agreement

License Agreement
Send Feedback
Intersoft WebDesktop > Licensing > License Agreement

Glossary Item Box

Software License Agreement for Intersoft Solutions Corp.

VERY IMPORTANT -- By installing the WebDesktop.NET Version 3.0 software (herein the 'SOFTWARE') developed by Intersoft Solutions Corp (hereinafter the 'VENDOR'), you are accepting the following License Agreement.

I. LICENSE AGREEMENT. This is a legal agreement between you (either an individual or a single entity) and VENDOR. By installing the SOFTWARE you are agreeing to be bound by the terms of this agreement. If you do not agree to the terms of this agreement, please kindly click the [CANCEL] icon to exit now. The installation process will be immediately terminated.

II. OWNERSHIP; GRANT OF LICENSE. This is a license agreement and NOT an agreement for sale. The VENDOR hereby grants to you, and you accept, a non-exclusive, non-transferable license to use, copy and modify the SOFTWARE only as authorized below.

III. PERMITTED USES. This LICENSE grants you the following rights:

A. The SOFTWARE is licensed per individual developer. You may make copies on more than one computer, as long as the use of the SOFTWARE is by the same developer. If you have purchased a "multi-pack" license, you may use a copy of the SOFTWARE identified in the multi-pack on the number of computers associated with the multi-pack (e.g. a five user multi-pack allows you to use the SOFTWARE on up to five computers concurrently or by five different developers, the ten user multi-pack on up to ten computers concurrently or by ten different developers). The SOFTWARE is in "use" on a computer when it is loaded into temporary memory (i.e. RAM) or installed into permanent memory (e.g. hard disk, CD-ROM, or other storage devise) of that computer. However, installation on a network server for the sole purpose of internal distribution to one or more other computer(s) shall not constitute "use" for which a separate license is required, provided you have a separate license for each computer to which the SOFTWARE is distributed.

B. Solely with respect to electronic documents included with the SOFTWARE, you may make a copy (either in hardcopy or electronic form) for each developer for which the Software has been licensed as described in Section III.A, above; provided, that such copies shall be used only by such developer for internal purposes and are not to be republished or distributed to any other third party.

C. Runtime and redistributable files. You may deploy your web applications using the SOFTWARE to any number of production server or clients with no additional charges. The SOFTWARE runtime files shouldn't be modified in any ways prior to deploying and all copyright notices should be retain.

IV. PROHIBITED USES. You may not, without the prior written permission of the VENDOR:

A. Disassemble, decompile or "unlock", decode or otherwise reverse translate or engineer, or attempt in any manner to reconstruct or discover any source code or underlying algorithms of SOFTWARE provided in object code form only.

B. Use, copy, modify, or merge copies of the SOFTWARE and any accompanying documents except as permitted in this LICENSE.

C. Transfer, rent, lease, or sublicense the SOFTWARE.

D. Separate the software programs comprising the SOFTWARE for use by more than one user at a time.

V. COPYRIGHT. All title and copyrights in and to the SOFTWARE (including but not limited to any images, photographs, animation, video, audio, music, text and "applets" incorporated into the SOFTWARE) and the accompanying printed materials are owned by the VENDOR or its suppliers. The SOFTWARE is protected by Indonesian copyright laws and international treaty provisions. All rights are reserved worldwide. You must treat the SOFTWARE like any other copyrighted material, except that you may, in addition to the copies permitted in this LICENSE, make one copy of the SOFTWARE solely for backup or archival purposes. No part of the accompanying printed materials may be reproduced, transmitted, transcribed, stored in any retrieval system, or translated into any language by any means without the express prior written permission of the VENDOR.

VI. TERMINATION

A. This LICENSE and your right to use the SOFTWARE will terminate immediately without notice from the VENDOR if you fail to comply with the terms and conditions of this LICENSE. Upon termination, you agree to destroy the SOFTWARE, including all accompanying documents and copies. This is in addition to and not in lieu of any criminal, civil or other remedies available to the VENDOR.

B. The VENDOR has the right to perform temporary or permanent TERMINATION to this LICENSE upon the detection of license violation described in Section III A. The SOFTWARE has implemented Installation Tracker which is used to increment the number of installations during the installation of SOFTWARE. Related to Section III A, the LICENSE will be temporarily or permanently terminated upon the detection of unauthorized transfer or distribution of the LICENSE to either private or public web site, or to ANY medium.

C. ANY VIOLATION TO THE COPYRIGHT, OR TO THIS LICENSE AGREEMENT, MAY RESULT IN SEVERE CIVIL AND CRIMINAL PENALTIES, AND WILL BE PROSECUTED TO THE MAXIMUM EXTENT POSSIBLE UNDER THE LAW.

VII. LIMITED WARRANTY.

A. The VENDOR warrants that the SOFTWARE will perform substantially in accordance with the accompanying printed materials or officially "online" documented materials for a period of thirty (30) days from the date of receipt. The VENDOR does not warranty that the SOFTWARE will be error-free.

B. Your exclusive remedy under the performance warranty set forth in Section X.A, shall be, at VENDOR's option, either (a) return of the purchase price paid, or (b) repair or replacement of the defective SOFTWARE. SOFTWARE purchased other than directly from the VENDOR shall be returned to the place it was purchased. This limited warranty is void if failure of the SOFTWARE has resulted from accident, abuse, or misapplication. Any replacement SOFTWARE will be warranted for the remainder of the original thirty (30) day period.


Copyright Info

Copyright Info
Send Feedback
Intersoft WebDesktop > Licensing > Copyright Info

Glossary Item Box

Information in this document, including URL and other Internet Web site references, is subject to change without notice. Complying with all applicable copyright laws is the responsibility of the user. Without limiting the rights under copyright, no part of this document may be reproduced, stored in or introduced into a retrieval system, or transmitted in any form or by any means (electronic, mechanical, photocopying, recording, or otherwise), or for any purpose, without the express written permission of Intersoft Solutions Corp.

Intersoft Solutions, Intersoft Solutions Logo, A Better Web Experience, WebUI.NET Framework, WebUI.NET Framework Logo, WebUI Studio.NET Family, WebCombo.NET, WebGrid.NET Enterprise, WebInput.NET, WebUIControls.NET, ISDataSource.NET, WebDesktop.NET, WebTreeView.NET are either trademarks or registered trademarks of Intersoft Solutions Corporation.

Copyright © 2000-2007 Intersoft Solutions Corp. All rights reserved.

ActiveX, Internet Explorer, Microsoft, Visual Basic, Visual Basic .NET, Visual C# .NET, Visual C++ .NET, Visual Studio, Visual Studio .NET, Windows, Windows 95, Windows 98, Windows 2000, Windows Millennium Edition, Windows .NET server family, Windows NT, Windows XP and Windows Vista are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.

The names of actual companies and products mentioned herein may be the trademarks or registered trademarks of their respective owners.